HidSharp Namespace

HidSharp Namespace HIDSharp
HidSharp wraps HID APIs for Windows, MacOS, and Linux. Use HidDeviceLoader to enumerate HidDevice objects, and then open the HidDevice to get a HidStream.
Classes
 | Class | Description
Public class | HidDevice | Represents a USB HID class device.
Public class | HidDeviceLoader | Detects USB HID class devices connected to the system.
Public class | HidStream | Communicates with a USB HID class device.

Online Copyright 2010-2013 James F. Bellinger (http://www.zer7.com/software/hidsharp)

Send Feedback on this topic to jfb@zer7.com.


HidDevice Class

HidDevice Class HIDSharp
Represents a USB HID class device.
Inheritance Hierarchy
Online System Object
HidSharp HidDevice

Namespace: HidSharp
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class HidDevice
public abstract class HidDevice
Public MustInherit Class HidDevice
Public MustInherit Class HidDevice
public ref class HidDevice abstract
public ref class HidDevice abstract
[<AbstractClassAttribute>]
type HidDevice =  class end
[<AbstractClassAttribute>]
type HidDevice =  class end
See Also
HidDevice Members
HidSharp Namespace


HidDevice Members

HidDevice Members HIDSharp

The HidDevice type exposes the following members.
Methods
 | Name | Description
Public method | GetReportDescriptor | Returns the raw report descriptor of the USB device. Currently this is only supported on Linux.
Public method | Open | Makes a connection to the USB HID class device, or throws an exception if the connection cannot be made.
Public method | ToString | Returns a Online String that represents the current Online Object. (Overrides Online Object ToString .)
Public method | TryOpen | Tries to make a connection to the USB HID class device.
Back to Top
Properties
 | Name | Description
Public property | DevicePath | The operating system's name for the device. If you have multiple devices with the same Vendor ID, Product ID, Serial Number. etc., this may be useful for differentiating them.
Public property | Manufacturer | The manufacturer name.
Public property | MaxFeatureReportLength | The maximum feature report length, including the Report ID byte. If the device does not use Report IDs, use 0 for the first byte.
Public property | MaxInputReportLength | The maximum input report length, including the Report ID byte. If the device does not use Report IDs, the first byte will always be 0.
Public property | MaxOutputReportLength | The maximum output report length, including the Report ID byte. If the device does not use Report IDs, use 0 for the first byte.
Public property | ProductID | The USB product ID. These are listed at: http://usb-ids.gowdy.us
Public property | ProductName | The product name.
Public property | ProductVersion | The product version. This is a 16-bit number encoding the major and minor versions in the upper and lower 8 bits, respectively.
Public property | SerialNumber | The device serial number.
Public property | VendorID | The USB vendor ID. These are listed at: http://usb-ids.gowdy.us
Back to Top
See Also
HidDevice Class
HidSharp Namespace


HidDevice Methods

HidDevice Methods HIDSharp
The HidDevice type exposes the following members.
Methods
 | Name | Description
Public method | GetReportDescriptor | Returns the raw report descriptor of the USB device. Currently this is only supported on Linux.
Public method | Open | Makes a connection to the USB HID class device, or throws an exception if the connection cannot be made.
Public method | ToString | Returns a Online String that represents the current Online Object. (Overrides Online Object ToString .)
Public method | TryOpen | Tries to make a connection to the USB HID class device.
Back to Top
See Also
HidDevice Class
HidSharp Namespace


GetReportDescriptor Method

HidDevice GetReportDescriptor Method HIDSharp
Returns the raw report descriptor of the USB device. Currently this is only supported on Linux.

Namespace: HidSharp
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual byte[] GetReportDescriptor()
public virtual byte[] GetReportDescriptor()
Public Overridable Function GetReportDescriptor As Byte()
Public Overridable Function GetReportDescriptor As Byte()
public:
virtual array<unsigned char>^ GetReportDescriptor()
public:
virtual array<unsigned char>^ GetReportDescriptor()
abstract GetReportDescriptor : unit -> byte[]
override GetReportDescriptor : unit -> byte[]
abstract GetReportDescriptor : unit -> byte[]
override GetReportDescriptor : unit -> byte[]

Return Value

The report descriptor.
See Also
HidDevice Class
HidDevice Members
HidSharp Namespace


Open Method

HidDevice Open Method HIDSharp
Makes a connection to the USB HID class device, or throws an exception if the connection cannot be made.

Namespace: HidSharp
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract HidStream Open()
public abstract HidStream Open()
Public MustOverride Function Open As HidStream
Public MustOverride Function Open As HidStream
public:
virtual HidStream^ Open() abstract
public:
virtual HidStream^ Open() abstract
abstract Open : unit -> HidStream
abstract Open : unit -> HidStream

Return Value

The stream to use to communicate with the device.
See Also
HidDevice Class
HidDevice Members
HidSharp Namespace


ToString Method

HidDevice ToString Method HIDSharp
Returns a Online String that represents the current Online Object.

Namespace: HidSharp
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

A Online String that represents the current Online Object.
See Also
HidDevice Class
HidDevice Members
HidSharp Namespace


TryOpen Method

HidDevice TryOpen Method HIDSharp
Tries to make a connection to the USB HID class device.

Namespace: HidSharp
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool TryOpen(
    out HidStream stream
)
public bool TryOpen(
    out HidStream stream
)
Public Function TryOpen ( _
    <OutAttribute> ByRef stream As HidStream _
) As Boolean
Public Function TryOpen ( _
    <OutAttribute> ByRef stream As HidStream _
) As Boolean
public:
bool TryOpen(
    [OutAttribute] HidStream^% stream
)
public:
bool TryOpen(
    [OutAttribute] HidStream^% stream
)
member TryOpen :
        stream : HidStream byref -> bool
member TryOpen :
        stream : HidStream byref -> bool

Parameters

stream
Type: HidSharp HidStream
The stream to use to communicate with the device.

Return Value

True if the connetion was successful.
See Also
HidDevice Class
HidDevice Members
HidSharp Namespace


HidDevice Properties

HidDevice Properties HIDSharp
The HidDevice type exposes the following members.
Properties
 | Name | Description
Public property | DevicePath | The operating system's name for the device. If you have multiple devices with the same Vendor ID, Product ID, Serial Number. etc., this may be useful for differentiating them.
Public property | Manufacturer | The manufacturer name.
Public property | MaxFeatureReportLength | The maximum feature report length, including the Report ID byte. If the device does not use Report IDs, use 0 for the first byte.
Public property | MaxInputReportLength | The maximum input report length, including the Report ID byte. If the device does not use Report IDs, the first byte will always be 0.
Public property | MaxOutputReportLength | The maximum output report length, including the Report ID byte. If the device does not use Report IDs, use 0 for the first byte.
Public property | ProductID | The USB product ID. These are listed at: http://usb-ids.gowdy.us
Public property | ProductName | The product name.
Public property | ProductVersion | The product version. This is a 16-bit number encoding the major and minor versions in the upper and lower 8 bits, respectively.
Public property | SerialNumber | The device serial number.
Public property | VendorID | The USB vendor ID. These are listed at: http://usb-ids.gowdy.us
Back to Top
See Also
HidDevice Class
HidSharp Namespace


DevicePath Property

HidDevice DevicePath Property HIDSharp
The operating system's name for the device. If you have multiple devices with the same Vendor ID, Product ID, Serial Number. etc., this may be useful for differentiating them.

Namespace: HidSharp
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract string DevicePath { get; }
public abstract string DevicePath { get; }
Public MustOverride ReadOnly Property DevicePath As String
    Get
Public MustOverride ReadOnly Property DevicePath As String
    Get
public:
virtual property String^ DevicePath {
    String^ get () abstract;
}
public:
virtual property String^ DevicePath {
    String^ get () abstract;
}
abstract DevicePath : string with get
abstract DevicePath : string with get
See Also
HidDevice Class
HidDevice Members
HidSharp Namespace


Manufacturer Property

HidDevice Manufacturer Property HIDSharp
The manufacturer name.

Namespace: HidSharp
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract string Manufacturer { get; }
public abstract string Manufacturer { get; }
Public MustOverride ReadOnly Property Manufacturer As String
    Get
Public MustOverride ReadOnly Property Manufacturer As String
    Get
public:
virtual property String^ Manufacturer {
    String^ get () abstract;
}
public:
virtual property String^ Manufacturer {
    String^ get () abstract;
}
abstract Manufacturer : string with get
abstract Manufacturer : string with get
See Also
HidDevice Class
HidDevice Members
HidSharp Namespace


MaxFeatureReportLength Property

HidDevice MaxFeatureReportLength Property HIDSharp
The maximum feature report length, including the Report ID byte. If the device does not use Report IDs, use 0 for the first byte.

Namespace: HidSharp
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract int MaxFeatureReportLength { get; }
public abstract int MaxFeatureReportLength { get; }
Public MustOverride ReadOnly Property MaxFeatureReportLength As Integer
    Get
Public MustOverride ReadOnly Property MaxFeatureReportLength As Integer
    Get
public:
virtual property int MaxFeatureReportLength {
    int get () abstract;
}
public:
virtual property int MaxFeatureReportLength {
    int get () abstract;
}
abstract MaxFeatureReportLength : int with get
abstract MaxFeatureReportLength : int with get
See Also
HidDevice Class
HidDevice Members
HidSharp Namespace


MaxInputReportLength Property

HidDevice MaxInputReportLength Property HIDSharp
The maximum input report length, including the Report ID byte. If the device does not use Report IDs, the first byte will always be 0.

Namespace: HidSharp
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract int MaxInputReportLength { get; }
public abstract int MaxInputReportLength { get; }
Public MustOverride ReadOnly Property MaxInputReportLength As Integer
    Get
Public MustOverride ReadOnly Property MaxInputReportLength As Integer
    Get
public:
virtual property int MaxInputReportLength {
    int get () abstract;
}
public:
virtual property int MaxInputReportLength {
    int get () abstract;
}
abstract MaxInputReportLength : int with get
abstract MaxInputReportLength : int with get
See Also
HidDevice Class
HidDevice Members
HidSharp Namespace


MaxOutputReportLength Property

HidDevice MaxOutputReportLength Property HIDSharp
The maximum output report length, including the Report ID byte. If the device does not use Report IDs, use 0 for the first byte.

Namespace: HidSharp
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract int MaxOutputReportLength { get; }
public abstract int MaxOutputReportLength { get; }
Public MustOverride ReadOnly Property MaxOutputReportLength As Integer
    Get
Public MustOverride ReadOnly Property MaxOutputReportLength As Integer
    Get
public:
virtual property int MaxOutputReportLength {
    int get () abstract;
}
public:
virtual property int MaxOutputReportLength {
    int get () abstract;
}
abstract MaxOutputReportLength : int with get
abstract MaxOutputReportLength : int with get
See Also
HidDevice Class
HidDevice Members
HidSharp Namespace


ProductID Property

HidDevice ProductID Property HIDSharp
The USB product ID. These are listed at: http://usb-ids.gowdy.us

Namespace: HidSharp
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract int ProductID { get; }
public abstract int ProductID { get; }
Public MustOverride ReadOnly Property ProductID As Integer
    Get
Public MustOverride ReadOnly Property ProductID As Integer
    Get
public:
virtual property int ProductID {
    int get () abstract;
}
public:
virtual property int ProductID {
    int get () abstract;
}
abstract ProductID : int with get
abstract ProductID : int with get
See Also
HidDevice Class
HidDevice Members
HidSharp Namespace


ProductName Property

HidDevice ProductName Property HIDSharp
The product name.

Namespace: HidSharp
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract string ProductName { get; }
public abstract string ProductName { get; }
Public MustOverride ReadOnly Property ProductName As String
    Get
Public MustOverride ReadOnly Property ProductName As String
    Get
public:
virtual property String^ ProductName {
    String^ get () abstract;
}
public:
virtual property String^ ProductName {
    String^ get () abstract;
}
abstract ProductName : string with get
abstract ProductName : string with get
See Also
HidDevice Class
HidDevice Members
HidSharp Namespace


ProductVersion Property

HidDevice ProductVersion Property HIDSharp
The product version. This is a 16-bit number encoding the major and minor versions in the upper and lower 8 bits, respectively.

Namespace: HidSharp
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract int ProductVersion { get; }
public abstract int ProductVersion { get; }
Public MustOverride ReadOnly Property ProductVersion As Integer
    Get
Public MustOverride ReadOnly Property ProductVersion As Integer
    Get
public:
virtual property int ProductVersion {
    int get () abstract;
}
public:
virtual property int ProductVersion {
    int get () abstract;
}
abstract ProductVersion : int with get
abstract ProductVersion : int with get
See Also
HidDevice Class
HidDevice Members
HidSharp Namespace


SerialNumber Property

HidDevice SerialNumber Property HIDSharp
The device serial number.

Namespace: HidSharp
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract string SerialNumber { get; }
public abstract string SerialNumber { get; }
Public MustOverride ReadOnly Property SerialNumber As String
    Get
Public MustOverride ReadOnly Property SerialNumber As String
    Get
public:
virtual property String^ SerialNumber {
    String^ get () abstract;
}
public:
virtual property String^ SerialNumber {
    String^ get () abstract;
}
abstract SerialNumber : string with get
abstract SerialNumber : string with get
See Also
HidDevice Class
HidDevice Members
HidSharp Namespace


VendorID Property

HidDevice VendorID Property HIDSharp
The USB vendor ID. These are listed at: http://usb-ids.gowdy.us

Namespace: HidSharp
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract int VendorID { get; }
public abstract int VendorID { get; }
Public MustOverride ReadOnly Property VendorID As Integer
    Get
Public MustOverride ReadOnly Property VendorID As Integer
    Get
public:
virtual property int VendorID {
    int get () abstract;
}
public:
virtual property int VendorID {
    int get () abstract;
}
abstract VendorID : int with get
abstract VendorID : int with get
See Also
HidDevice Class
HidDevice Members
HidSharp Namespace


HidDeviceLoader Class

HidDeviceLoader Class HIDSharp
Detects USB HID class devices connected to the system.
Inheritance Hierarchy
Online System Object
HidSharp HidDeviceLoader

Namespace: HidSharp
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class HidDeviceLoader
public class HidDeviceLoader
Public Class HidDeviceLoader
Public Class HidDeviceLoader
public ref class HidDeviceLoader
public ref class HidDeviceLoader
type HidDeviceLoader =  class end
type HidDeviceLoader =  class end
See Also
HidDeviceLoader Members
HidSharp Namespace


HidDeviceLoader Members

HidDeviceLoader Members HIDSharp

The HidDeviceLoader type exposes the following members.
Constructors
 | Name | Description
Public method | HidDeviceLoader | Initializes a new instance of the HidDeviceLoader class.
Back to Top
Methods
 | Name | Description
Public method | GetDeviceOrDefault | Gets the first connected USB device that matches specified criteria.
Public method | GetDevices | Gets a list of connected USB devices.
Public method | GetDevices(Nullable Int32 , Nullable Int32 , Nullable Int32 , String) | Gets a list of connected USB devices, filtered by some criteria.
Public method | GetDevicesVB | Gets a list of connected USB devices. This overload is meant for Visual Basic 6 and COM clients.
Back to Top
See Also
HidDeviceLoader Class
HidSharp Namespace


HidDeviceLoader Constructor

HidDeviceLoader Constructor HIDSharp
Initializes a new instance of the HidDeviceLoader class.

Namespace: HidSharp
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public HidDeviceLoader()
public HidDeviceLoader()
Public Sub New
Public Sub New
public:
HidDeviceLoader()
public:
HidDeviceLoader()
new : unit -> HidDeviceLoader
new : unit -> HidDeviceLoader
See Also
HidDeviceLoader Class
HidDeviceLoader Members
HidSharp Namespace


HidDeviceLoader Methods

HidDeviceLoader Methods HIDSharp
The HidDeviceLoader type exposes the following members.
Methods
 | Name | Description
Public method | GetDeviceOrDefault | Gets the first connected USB device that matches specified criteria.
Public method | GetDevices | Gets a list of connected USB devices.
Public method | GetDevices(Nullable Int32 , Nullable Int32 , Nullable Int32 , String) | Gets a list of connected USB devices, filtered by some criteria.
Public method | GetDevicesVB | Gets a list of connected USB devices. This overload is meant for Visual Basic 6 and COM clients.
Back to Top
See Also
HidDeviceLoader Class
HidSharp Namespace


GetDeviceOrDefault Method

HidDeviceLoader GetDeviceOrDefault Method HIDSharp
Gets the first connected USB device that matches specified criteria.

Namespace: HidSharp
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public HidDevice GetDeviceOrDefault(
    Nullable<int> vendorID = null,
    Nullable<int> productID = null,
    Nullable<int> productVersion = null,
    string serialNumber = null
)
public HidDevice GetDeviceOrDefault(
    Nullable<int> vendorID = null,
    Nullable<int> productID = null,
    Nullable<int> productVersion = null,
    string serialNumber = null
)
Public Function GetDeviceOrDefault ( _
    Optional vendorID As Nullable(Of Integer) = Nothing, _
    Optional productID As Nullable(Of Integer) = Nothing, _
    Optional productVersion As Nullable(Of Integer) = Nothing, _
    Optional serialNumber As String = Nothing _
) As HidDevice
Public Function GetDeviceOrDefault ( _
    Optional vendorID As Nullable(Of Integer) = Nothing, _
    Optional productID As Nullable(Of Integer) = Nothing, _
    Optional productVersion As Nullable(Of Integer) = Nothing, _
    Optional serialNumber As String = Nothing _
) As HidDevice
public:
HidDevice^ GetDeviceOrDefault(
    Nullable<int> vendorID = nullptr,
    Nullable<int> productID = nullptr,
    Nullable<int> productVersion = nullptr,
    String^ serialNumber = nullptr
)
public:
HidDevice^ GetDeviceOrDefault(
    Nullable<int> vendorID = nullptr,
    Nullable<int> productID = nullptr,
    Nullable<int> productVersion = nullptr,
    String^ serialNumber = nullptr
)
member GetDeviceOrDefault :
        ?vendorID : Nullable<int> *
        ?productID : Nullable<int> *
        ?productVersion : Nullable<int> *
        ?serialNumber : string
(* Defaults:
        let _vendorID = defaultArg vendorID null
        let _productID = defaultArg productID null
        let _productVersion = defaultArg productVersion null
        let _serialNumber = defaultArg serialNumber null
*)
-> HidDevice
member GetDeviceOrDefault :
        ?vendorID : Nullable<int> *
        ?productID : Nullable<int> *
        ?productVersion : Nullable<int> *
        ?serialNumber : string
(* Defaults:
        let _vendorID = defaultArg vendorID null
        let _productID = defaultArg productID null
        let _productVersion = defaultArg productVersion null
        let _serialNumber = defaultArg serialNumber null
*)
-> HidDevice

Parameters

vendorID (Optional)
Type: Online System Nullable Online Int32
The vendor ID, or null to not filter by vendor ID.
productID (Optional)
Type: Online System Nullable Online Int32
The product ID, or null to not filter by product ID.
productVersion (Optional)
Type: Online System Nullable Online Int32
The product version, or null to not filter by product version.
serialNumber (Optional)
Type: Online System String
The serial number, or null to not filter by serial number.

Return Value

The device, or null if none was found.
See Also
HidDeviceLoader Class
HidDeviceLoader Members
HidSharp Namespace


GetDevices Method

HidDeviceLoader GetDevices Method HIDSharp
Overload List
 | Name | Description
Public method | GetDevices | Gets a list of connected USB devices.
Public method | GetDevices(Nullable Int32 , Nullable Int32 , Nullable Int32 , String) | Gets a list of connected USB devices, filtered by some criteria.
Back to Top
See Also
HidDeviceLoader Class
HidDeviceLoader Members
HidSharp Namespace


GetDevices Method

HidDeviceLoader GetDevices Method HIDSharp
Gets a list of connected USB devices.

Namespace: HidSharp
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<HidDevice> GetDevices()
public IEnumerable<HidDevice> GetDevices()
Public Function GetDevices As IEnumerable(Of HidDevice)
Public Function GetDevices As IEnumerable(Of HidDevice)
public:
IEnumerable<HidDevice^>^ GetDevices()
public:
IEnumerable<HidDevice^>^ GetDevices()
member GetDevices : unit -> IEnumerable<HidDevice>
member GetDevices : unit -> IEnumerable<HidDevice>

Return Value

The device list.
See Also
HidDeviceLoader Class
HidDeviceLoader Members
GetDevices Overload
HidSharp Namespace


GetDevices Method (Nullable(Int32), Nullable(Int32), Nullable(Int32), String)

HidDeviceLoader GetDevices Method (Nullable Int32 , Nullable Int32 , Nullable Int32 , String) HIDSharp
Gets a list of connected USB devices, filtered by some criteria.

Namespace: HidSharp
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<HidDevice> GetDevices(
    Nullable<int> vendorID = null,
    Nullable<int> productID = null,
    Nullable<int> productVersion = null,
    string serialNumber = null
)
public IEnumerable<HidDevice> GetDevices(
    Nullable<int> vendorID = null,
    Nullable<int> productID = null,
    Nullable<int> productVersion = null,
    string serialNumber = null
)
Public Function GetDevices ( _
    Optional vendorID As Nullable(Of Integer) = Nothing, _
    Optional productID As Nullable(Of Integer) = Nothing, _
    Optional productVersion As Nullable(Of Integer) = Nothing, _
    Optional serialNumber As String = Nothing _
) As IEnumerable(Of HidDevice)
Public Function GetDevices ( _
    Optional vendorID As Nullable(Of Integer) = Nothing, _
    Optional productID As Nullable(Of Integer) = Nothing, _
    Optional productVersion As Nullable(Of Integer) = Nothing, _
    Optional serialNumber As String = Nothing _
) As IEnumerable(Of HidDevice)
public:
IEnumerable<HidDevice^>^ GetDevices(
    Nullable<int> vendorID = nullptr,
    Nullable<int> productID = nullptr,
    Nullable<int> productVersion = nullptr,
    String^ serialNumber = nullptr
)
public:
IEnumerable<HidDevice^>^ GetDevices(
    Nullable<int> vendorID = nullptr,
    Nullable<int> productID = nullptr,
    Nullable<int> productVersion = nullptr,
    String^ serialNumber = nullptr
)
member GetDevices :
        ?vendorID : Nullable<int> *
        ?productID : Nullable<int> *
        ?productVersion : Nullable<int> *
        ?serialNumber : string
(* Defaults:
        let _vendorID = defaultArg vendorID null
        let _productID = defaultArg productID null
        let _productVersion = defaultArg productVersion null
        let _serialNumber = defaultArg serialNumber null
*)
-> IEnumerable<HidDevice>
member GetDevices :
        ?vendorID : Nullable<int> *
        ?productID : Nullable<int> *
        ?productVersion : Nullable<int> *
        ?serialNumber : string
(* Defaults:
        let _vendorID = defaultArg vendorID null
        let _productID = defaultArg productID null
        let _productVersion = defaultArg productVersion null
        let _serialNumber = defaultArg serialNumber null
*)
-> IEnumerable<HidDevice>

Parameters

vendorID (Optional)
Type: Online System Nullable Online Int32
The vendor ID, or null to not filter by vendor ID.
productID (Optional)
Type: Online System Nullable Online Int32
The product ID, or null to not filter by product ID.
productVersion (Optional)
Type: Online System Nullable Online Int32
The product version, or null to not filter by product version.
serialNumber (Optional)
Type: Online System String
The serial number, or null to not filter by serial number.

Return Value

The filtered device list.
See Also
HidDeviceLoader Class
HidDeviceLoader Members
GetDevices Overload
HidSharp Namespace


GetDevicesVB Method

HidDeviceLoader GetDevicesVB Method HIDSharp
Gets a list of connected USB devices. This overload is meant for Visual Basic 6 and COM clients.

Namespace: HidSharp
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable GetDevicesVB()
public IEnumerable GetDevicesVB()
Public Function GetDevicesVB As IEnumerable
Public Function GetDevicesVB As IEnumerable
public:
IEnumerable^ GetDevicesVB()
public:
IEnumerable^ GetDevicesVB()
member GetDevicesVB : unit -> IEnumerable
member GetDevicesVB : unit -> IEnumerable

Return Value

The device list.
See Also
HidDeviceLoader Class
HidDeviceLoader Members
HidSharp Namespace


HidStream Class

HidStream Class HIDSharp
Communicates with a USB HID class device.
Inheritance Hierarchy
Online System Object
Online System MarshalByRefObject
Online System.IO Stream
HidSharp HidStream

Namespace: HidSharp
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract class HidStream : Stream
public abstract class HidStream : Stream
Public MustInherit Class HidStream _
    Inherits Stream
Public MustInherit Class HidStream _
    Inherits Stream
public ref class HidStream abstract : public Stream
public ref class HidStream abstract : public Stream
[<AbstractClassAttribute>]
type HidStream =
    class
        inherit Stream
    end
[<AbstractClassAttribute>]
type HidStream =
    class
        inherit Stream
    end
See Also
HidStream Members
HidSharp Namespace


HidStream Members

HidStream Members HIDSharp

The HidStream type exposes the following members.
Methods
 | Name | Description
Public method | BeginRead | (Overrides Online Stream BeginRead( Byte , Int32, Int32, AsyncCallback, Object).)
Public method | BeginWrite | (Overrides Online Stream BeginWrite( Byte , Int32, Int32, AsyncCallback, Object).)
Public method | EndRead | Waits for the pending asynchronous read to complete. (Overrides Online Stream EndRead(IAsyncResult).)
Public method | EndWrite | Ends an asynchronous write operation. (Overrides Online Stream EndWrite(IAsyncResult).)
Public method | GetFeature( Byte ) | Sends a Get Feature setup request.
Public method | GetFeature( Byte , Int32, Int32) | Sends a Get Feature setup request.
Public method | Read | Reads HID Input Reports.
Public method | Read( Byte ) | Reads HID Input Reports.
Public method | SetFeature( Byte ) | Sends a Set Feature setup request.
Public method | SetFeature( Byte , Int32, Int32) | Sends a Set Feature setup request.
Public method | Write | Writes an HID Output Report to the device.
Back to Top
Properties
 | Name | Description
Public property | Device | Gets the HidDevice associated with this stream.
Public property | ReadTimeout | The maximum amount of time, in milliseconds, to wait for to receive a HID report. The default is 3000 milliseconds. To disable the timeout, set this to Online Infinite. (Overrides Online Stream ReadTimeout.)
Public property | WriteTimeout | The maximum amount of time, in milliseconds, to wait for the device to acknowledge a HID report. The default is 3000 milliseconds. To disable the timeout, set this to Online Infinite. (Overrides Online Stream WriteTimeout.)
Back to Top
See Also
HidStream Class
HidSharp Namespace


HidStream Methods

HidStream Methods HIDSharp
The HidStream type exposes the following members.
Methods
 | Name | Description
Public method | BeginRead | (Overrides Online Stream BeginRead( Byte , Int32, Int32, AsyncCallback, Object).)
Public method | BeginWrite | (Overrides Online Stream BeginWrite( Byte , Int32, Int32, AsyncCallback, Object).)
Public method | EndRead | Waits for the pending asynchronous read to complete. (Overrides Online Stream EndRead(IAsyncResult).)
Public method | EndWrite | Ends an asynchronous write operation. (Overrides Online Stream EndWrite(IAsyncResult).)
Public method | GetFeature( Byte ) | Sends a Get Feature setup request.
Public method | GetFeature( Byte , Int32, Int32) | Sends a Get Feature setup request.
Public method | Read | Reads HID Input Reports.
Public method | Read( Byte ) | Reads HID Input Reports.
Public method | SetFeature( Byte ) | Sends a Set Feature setup request.
Public method | SetFeature( Byte , Int32, Int32) | Sends a Set Feature setup request.
Public method | Write | Writes an HID Output Report to the device.
Back to Top
See Also
HidStream Class
HidSharp Namespace


BeginRead Method

HidStream BeginRead Method HIDSharp

Namespace: HidSharp
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override IAsyncResult BeginRead(
    byte[] buffer,
    int offset,
    int count,
    AsyncCallback callback,
    Object state
)
public override IAsyncResult BeginRead(
    byte[] buffer,
    int offset,
    int count,
    AsyncCallback callback,
    Object state
)
Public Overrides Function BeginRead ( _
    buffer As Byte(), _
    offset As Integer, _
    count As Integer, _
    callback As AsyncCallback, _
    state As Object _
) As IAsyncResult
Public Overrides Function BeginRead ( _
    buffer As Byte(), _
    offset As Integer, _
    count As Integer, _
    callback As AsyncCallback, _
    state As Object _
) As IAsyncResult
public:
virtual IAsyncResult^ BeginRead(
    array<unsigned char>^ buffer,
    int offset,
    int count,
    AsyncCallback^ callback,
    Object^ state
) override
public:
virtual IAsyncResult^ BeginRead(
    array<unsigned char>^ buffer,
    int offset,
    int count,
    AsyncCallback^ callback,
    Object^ state
) override
abstract BeginRead :
        buffer : byte[] *
        offset : int *
        count : int *
        callback : AsyncCallback *
        state : Object -> IAsyncResult
override BeginRead :
        buffer : byte[] *
        offset : int *
        count : int *
        callback : AsyncCallback *
        state : Object -> IAsyncResult
abstract BeginRead :
        buffer : byte[] *
        offset : int *
        count : int *
        callback : AsyncCallback *
        state : Object -> IAsyncResult
override BeginRead :
        buffer : byte[] *
        offset : int *
        count : int *
        callback : AsyncCallback *
        state : Object -> IAsyncResult

Parameters

buffer
Type: Online System Byte
offset
Type: Online System Int32
count
Type: Online System Int32
callback
Type: Online System AsyncCallback
state
Type: Online System Object
See Also
HidStream Class
HidStream Members
HidSharp Namespace


BeginWrite Method

HidStream BeginWrite Method HIDSharp

Namespace: HidSharp
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override IAsyncResult BeginWrite(
    byte[] buffer,
    int offset,
    int count,
    AsyncCallback callback,
    Object state
)
public override IAsyncResult BeginWrite(
    byte[] buffer,
    int offset,
    int count,
    AsyncCallback callback,
    Object state
)
Public Overrides Function BeginWrite ( _
    buffer As Byte(), _
    offset As Integer, _
    count As Integer, _
    callback As AsyncCallback, _
    state As Object _
) As IAsyncResult
Public Overrides Function BeginWrite ( _
    buffer As Byte(), _
    offset As Integer, _
    count As Integer, _
    callback As AsyncCallback, _
    state As Object _
) As IAsyncResult
public:
virtual IAsyncResult^ BeginWrite(
    array<unsigned char>^ buffer,
    int offset,
    int count,
    AsyncCallback^ callback,
    Object^ state
) override
public:
virtual IAsyncResult^ BeginWrite(
    array<unsigned char>^ buffer,
    int offset,
    int count,
    AsyncCallback^ callback,
    Object^ state
) override
abstract BeginWrite :
        buffer : byte[] *
        offset : int *
        count : int *
        callback : AsyncCallback *
        state : Object -> IAsyncResult
override BeginWrite :
        buffer : byte[] *
        offset : int *
        count : int *
        callback : AsyncCallback *
        state : Object -> IAsyncResult
abstract BeginWrite :
        buffer : byte[] *
        offset : int *
        count : int *
        callback : AsyncCallback *
        state : Object -> IAsyncResult
override BeginWrite :
        buffer : byte[] *
        offset : int *
        count : int *
        callback : AsyncCallback *
        state : Object -> IAsyncResult

Parameters

buffer
Type: Online System Byte
offset
Type: Online System Int32
count
Type: Online System Int32
callback
Type: Online System AsyncCallback
state
Type: Online System Object
See Also
HidStream Class
HidStream Members
HidSharp Namespace


EndRead Method

HidStream EndRead Method HIDSharp
Waits for the pending asynchronous read to complete.

Namespace: HidSharp
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int EndRead(
    IAsyncResult asyncResult
)
public override int EndRead(
    IAsyncResult asyncResult
)
Public Overrides Function EndRead ( _
    asyncResult As IAsyncResult _
) As Integer
Public Overrides Function EndRead ( _
    asyncResult As IAsyncResult _
) As Integer
public:
virtual int EndRead(
    IAsyncResult^ asyncResult
) override
public:
virtual int EndRead(
    IAsyncResult^ asyncResult
) override
abstract EndRead :
        asyncResult : IAsyncResult -> int
override EndRead :
        asyncResult : IAsyncResult -> int
abstract EndRead :
        asyncResult : IAsyncResult -> int
override EndRead :
        asyncResult : IAsyncResult -> int

Parameters

asyncResult
Type: Online System IAsyncResult
The reference to the pending asynchronous request to finish.

Return Value

The number of bytes read from the stream, between zero (0) and the number of bytes you requested. Streams return zero (0) only at the end of the stream, otherwise, they should block until at least one byte is available.
Exceptions
Exception | Condition
Online System ArgumentNullException | asyncResult is null.
Online System ArgumentException | asyncResult did not originate from a Online BeginRead( Byte , Int32, Int32, AsyncCallback, Object) method on the current stream.
Online System.IO IOException | The stream is closed or an internal error has occurred.
See Also
HidStream Class
HidStream Members
HidSharp Namespace


EndWrite Method

HidStream EndWrite Method HIDSharp
Ends an asynchronous write operation.

Namespace: HidSharp
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override void EndWrite(
    IAsyncResult asyncResult
)
public override void EndWrite(
    IAsyncResult asyncResult
)
Public Overrides Sub EndWrite ( _
    asyncResult As IAsyncResult _
)
Public Overrides Sub EndWrite ( _
    asyncResult As IAsyncResult _
)
public:
virtual void EndWrite(
    IAsyncResult^ asyncResult
) override
public:
virtual void EndWrite(
    IAsyncResult^ asyncResult
) override
abstract EndWrite :
        asyncResult : IAsyncResult -> unit
override EndWrite :
        asyncResult : IAsyncResult -> unit
abstract EndWrite :
        asyncResult : IAsyncResult -> unit
override EndWrite :
        asyncResult : IAsyncResult -> unit

Parameters

asyncResult
Type: Online System IAsyncResult
A reference to the outstanding asynchronous I/O request.
Exceptions
Exception | Condition
Online System ArgumentNullException | asyncResult is null.
Online System ArgumentException | asyncResult did not originate from a Online BeginWrite( Byte , Int32, Int32, AsyncCallback, Object) method on the current stream.
Online System.IO IOException | The stream is closed or an internal error has occurred.
See Also
HidStream Class
HidStream Members
HidSharp Namespace


GetFeature Method

HidStream GetFeature Method HIDSharp
Overload List
 | Name | Description
Public method | GetFeature( Byte ) | Sends a Get Feature setup request.
Public method | GetFeature( Byte , Int32, Int32) | Sends a Get Feature setup request.
Back to Top
See Also
HidStream Class
HidStream Members
HidSharp Namespace


GetFeature Method (Byte[])

HidStream GetFeature Method ( Byte ) HIDSharp
Sends a Get Feature setup request.

Namespace: HidSharp
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void GetFeature(
    byte[] buffer
)
public void GetFeature(
    byte[] buffer
)
Public Sub GetFeature ( _
    buffer As Byte() _
)
Public Sub GetFeature ( _
    buffer As Byte() _
)
public:
void GetFeature(
    array<unsigned char>^ buffer
)
public:
void GetFeature(
    array<unsigned char>^ buffer
)
member GetFeature :
        buffer : byte[] -> unit
member GetFeature :
        buffer : byte[] -> unit

Parameters

buffer
Type: Online System Byte
The buffer to fill. Place the Report ID in the first byte.
See Also
HidStream Class
HidStream Members
GetFeature Overload
HidSharp Namespace


GetFeature Method (Byte[], Int32, Int32)

HidStream GetFeature Method ( Byte , Int32, Int32) HIDSharp
Sends a Get Feature setup request.

Namespace: HidSharp
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void GetFeature(
    byte[] buffer,
    int offset,
    int count
)
public abstract void GetFeature(
    byte[] buffer,
    int offset,
    int count
)
Public MustOverride Sub GetFeature ( _
    buffer As Byte(), _
    offset As Integer, _
    count As Integer _
)
Public MustOverride Sub GetFeature ( _
    buffer As Byte(), _
    offset As Integer, _
    count As Integer _
)
public:
virtual void GetFeature(
    array<unsigned char>^ buffer,
    int offset,
    int count
) abstract
public:
virtual void GetFeature(
    array<unsigned char>^ buffer,
    int offset,
    int count
) abstract
abstract GetFeature :
        buffer : byte[] *
        offset : int *
        count : int -> unit
abstract GetFeature :
        buffer : byte[] *
        offset : int *
        count : int -> unit

Parameters

buffer
Type: Online System Byte
The buffer to fill. Place the Report ID in the byte at index offset.
offset
Type: Online System Int32
The index in the buffer to begin filling with data.
count
Type: Online System Int32
The number of bytes in the feature request.
See Also
HidStream Class
HidStream Members
GetFeature Overload
HidSharp Namespace


Read Method

HidStream Read Method HIDSharp
Overload List
 | Name | Description
Public method | Read | Reads HID Input Reports.
Public method | Read( Byte ) | Reads HID Input Reports.
Back to Top
See Also
HidStream Class
HidStream Members
HidSharp Namespace


Read Method

HidStream Read Method HIDSharp
Reads HID Input Reports.

Namespace: HidSharp
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public byte[] Read()
public byte[] Read()
Public Function Read As Byte()
Public Function Read As Byte()
public:
array<unsigned char>^ Read()
public:
array<unsigned char>^ Read()
member Read : unit -> byte[]
member Read : unit -> byte[]

Return Value

The data read.
See Also
HidStream Class
HidStream Members
Read Overload
HidSharp Namespace


Read Method (Byte[])

HidStream Read Method ( Byte ) HIDSharp
Reads HID Input Reports.

Namespace: HidSharp
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Read(
    byte[] buffer
)
public int Read(
    byte[] buffer
)
Public Function Read ( _
    buffer As Byte() _
) As Integer
Public Function Read ( _
    buffer As Byte() _
) As Integer
public:
int Read(
    array<unsigned char>^ buffer
)
public:
int Read(
    array<unsigned char>^ buffer
)
member Read :
        buffer : byte[] -> int
member Read :
        buffer : byte[] -> int

Parameters

buffer
Type: Online System Byte
The buffer to place the reports into.

Return Value

The number of bytes read.
See Also
HidStream Class
HidStream Members
Read Overload
HidSharp Namespace


SetFeature Method

HidStream SetFeature Method HIDSharp
Overload List
 | Name | Description
Public method | SetFeature( Byte ) | Sends a Set Feature setup request.
Public method | SetFeature( Byte , Int32, Int32) | Sends a Set Feature setup request.
Back to Top
See Also
HidStream Class
HidStream Members
HidSharp Namespace


SetFeature Method (Byte[])

HidStream SetFeature Method ( Byte ) HIDSharp
Sends a Set Feature setup request.

Namespace: HidSharp
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void SetFeature(
    byte[] buffer
)
public void SetFeature(
    byte[] buffer
)
Public Sub SetFeature ( _
    buffer As Byte() _
)
Public Sub SetFeature ( _
    buffer As Byte() _
)
public:
void SetFeature(
    array<unsigned char>^ buffer
)
public:
void SetFeature(
    array<unsigned char>^ buffer
)
member SetFeature :
        buffer : byte[] -> unit
member SetFeature :
        buffer : byte[] -> unit

Parameters

buffer
Type: Online System Byte
The buffer of data to send. Place the Report ID in the first byte.
See Also
HidStream Class
HidStream Members
SetFeature Overload
HidSharp Namespace


SetFeature Method (Byte[], Int32, Int32)

HidStream SetFeature Method ( Byte , Int32, Int32) HIDSharp
Sends a Set Feature setup request.

Namespace: HidSharp
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract void SetFeature(
    byte[] buffer,
    int offset,
    int count
)
public abstract void SetFeature(
    byte[] buffer,
    int offset,
    int count
)
Public MustOverride Sub SetFeature ( _
    buffer As Byte(), _
    offset As Integer, _
    count As Integer _
)
Public MustOverride Sub SetFeature ( _
    buffer As Byte(), _
    offset As Integer, _
    count As Integer _
)
public:
virtual void SetFeature(
    array<unsigned char>^ buffer,
    int offset,
    int count
) abstract
public:
virtual void SetFeature(
    array<unsigned char>^ buffer,
    int offset,
    int count
) abstract
abstract SetFeature :
        buffer : byte[] *
        offset : int *
        count : int -> unit
abstract SetFeature :
        buffer : byte[] *
        offset : int *
        count : int -> unit

Parameters

buffer
Type: Online System Byte
The buffer of data to send. Place the Report ID in the byte at index offset.
offset
Type: Online System Int32
The index in the buffer to start the write from.
count
Type: Online System Int32
The number of bytes in the feature request.
See Also
HidStream Class
HidStream Members
SetFeature Overload
HidSharp Namespace


Write Method

HidStream Write Method HIDSharp
Writes an HID Output Report to the device.

Namespace: HidSharp
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Write(
    byte[] buffer
)
public void Write(
    byte[] buffer
)
Public Sub Write ( _
    buffer As Byte() _
)
Public Sub Write ( _
    buffer As Byte() _
)
public:
void Write(
    array<unsigned char>^ buffer
)
public:
void Write(
    array<unsigned char>^ buffer
)
member Write :
        buffer : byte[] -> unit
member Write :
        buffer : byte[] -> unit

Parameters

buffer
Type: Online System Byte
The buffer containing the report. Place the Report ID in the first byte.
See Also
HidStream Class
HidStream Members
HidSharp Namespace


HidStream Properties

HidStream Properties HIDSharp
The HidStream type exposes the following members.
Properties
 | Name | Description
Public property | Device | Gets the HidDevice associated with this stream.
Public property | ReadTimeout | The maximum amount of time, in milliseconds, to wait for to receive a HID report. The default is 3000 milliseconds. To disable the timeout, set this to Online Infinite. (Overrides Online Stream ReadTimeout.)
Public property | WriteTimeout | The maximum amount of time, in milliseconds, to wait for the device to acknowledge a HID report. The default is 3000 milliseconds. To disable the timeout, set this to Online Infinite. (Overrides Online Stream WriteTimeout.)
Back to Top
See Also
HidStream Class
HidSharp Namespace


Device Property

HidStream Device Property HIDSharp
Gets the HidDevice associated with this stream.

Namespace: HidSharp
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public abstract HidDevice Device { get; }
public abstract HidDevice Device { get; }
Public MustOverride ReadOnly Property Device As HidDevice
    Get
Public MustOverride ReadOnly Property Device As HidDevice
    Get
public:
virtual property HidDevice^ Device {
    HidDevice^ get () abstract;
}
public:
virtual property HidDevice^ Device {
    HidDevice^ get () abstract;
}
abstract Device : HidDevice with get
abstract Device : HidDevice with get
See Also
HidStream Class
HidStream Members
HidSharp Namespace


ReadTimeout Property

HidStream ReadTimeout Property HIDSharp
The maximum amount of time, in milliseconds, to wait for to receive a HID report. The default is 3000 milliseconds. To disable the timeout, set this to Online Infinite.

Namespace: HidSharp
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override sealed int ReadTimeout { get; set; }
public override sealed int ReadTimeout { get; set; }
Public Overrides NotOverridable Property ReadTimeout As Integer
    Get
    Set
Public Overrides NotOverridable Property ReadTimeout As Integer
    Get
    Set
public:
virtual property int ReadTimeout {
    int get () override sealed;
    void set (int value) override sealed;
}
public:
virtual property int ReadTimeout {
    int get () override sealed;
    void set (int value) override sealed;
}
abstract ReadTimeout : int with get, set
override ReadTimeout : int with get, set
abstract ReadTimeout : int with get, set
override ReadTimeout : int with get, set
See Also
HidStream Class
HidStream Members
HidSharp Namespace


WriteTimeout Property

HidStream WriteTimeout Property HIDSharp
The maximum amount of time, in milliseconds, to wait for the device to acknowledge a HID report. The default is 3000 milliseconds. To disable the timeout, set this to Online Infinite.

Namespace: HidSharp
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override sealed int WriteTimeout { get; set; }
public override sealed int WriteTimeout { get; set; }
Public Overrides NotOverridable Property WriteTimeout As Integer
    Get
    Set
Public Overrides NotOverridable Property WriteTimeout As Integer
    Get
    Set
public:
virtual property int WriteTimeout {
    int get () override sealed;
    void set (int value) override sealed;
}
public:
virtual property int WriteTimeout {
    int get () override sealed;
    void set (int value) override sealed;
}
abstract WriteTimeout : int with get, set
override WriteTimeout : int with get, set
abstract WriteTimeout : int with get, set
override WriteTimeout : int with get, set
See Also
HidStream Class
HidStream Members
HidSharp Namespace


HidSharp.ReportDescriptors Namespace

HidSharp.ReportDescriptors Namespace HIDSharp
HID report descriptors can be edited or parsed using these classes.
Classes
 | Class | Description
Public class | EncodedItem |
Enumerations
 | Enumeration | Description
Public enumeration | CollectionType |
Public enumeration | DataMainItemFlags |
Public enumeration | GlobalItemTag |
Public enumeration | ItemType | Describes the manner in which an item affects the descriptor.
Public enumeration | LocalItemTag |
Public enumeration | MainItemTag |


CollectionType Enumeration

CollectionType Enumeration HIDSharp

Namespace: HidSharp.ReportDescriptors
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum CollectionType
public enum CollectionType
Public Enumeration CollectionType
Public Enumeration CollectionType
public enum class CollectionType
public enum class CollectionType
type CollectionType
type CollectionType
Members
Member name | Value | Description
Physical | 0 |
Application | 1 |
Logical | 2 |
Report | 3 |
NamedArray | 4 |
UsageSwitch | 5 |
UsageModifier | 6 |
See Also
HidSharp.ReportDescriptors Namespace


DataMainItemFlags Enumeration

DataMainItemFlags Enumeration HIDSharp

Namespace: HidSharp.ReportDescriptors
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[FlagsAttribute]
public enum DataMainItemFlags
[FlagsAttribute]
public enum DataMainItemFlags
<FlagsAttribute> _
Public Enumeration DataMainItemFlags
<FlagsAttribute> _
Public Enumeration DataMainItemFlags
[FlagsAttribute]
public enum class DataMainItemFlags
[FlagsAttribute]
public enum class DataMainItemFlags
[<FlagsAttribute>]
type DataMainItemFlags
[<FlagsAttribute>]
type DataMainItemFlags
Members
Member name | Value | Description
None | 0 | No flags are set.
Constant | 1 | Constant values cannot be changed.
Variable | 2 | Each variable field corresponds to a particular value. The alternative is an array, where each field specifies an index. For example, with eight buttons, a variable field would have eight bits. An array would have an index of which button is pressed.
Relative | 4 | Mouse motion is in relative coordinates. Most sensors -- joysticks, accelerometers, etc. -- output absolute coordinates.
Wrap | 8 | The value wraps around in a continuous manner.
Nonlinear | 16 |
NoPreferred | 32 |
NullState | 64 |
Volatile | 128 |
BufferedBytes | 256 |
See Also
HidSharp.ReportDescriptors Namespace


EncodedItem Class

EncodedItem Class HIDSharp
Inheritance Hierarchy
Online System Object
HidSharp.ReportDescriptors EncodedItem

Namespace: HidSharp.ReportDescriptors
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class EncodedItem
public class EncodedItem
Public Class EncodedItem
Public Class EncodedItem
public ref class EncodedItem
public ref class EncodedItem
type EncodedItem =  class end
type EncodedItem =  class end
See Also
EncodedItem Members
HidSharp.ReportDescriptors Namespace


EncodedItem Members

EncodedItem Members HIDSharp

The EncodedItem type exposes the following members.
Constructors
 | Name | Description
Public method | EncodedItem | Initializes a new instance of the EncodedItem class
Back to Top
Methods
 | Name | Description
Public method | Clear |
Public method | DataAt |
Public method | Decode |
 | DecodeHIDDT |
 | DecodeRaw |
Public method | Encode |
 | EncodeRaw |
Back to Top
Properties
 | Name | Description
Public property | Data |
Public property | DataSize |
Public property | DataValue |
Public property | DataValueMayBeNegative |
Public property | DataValueSigned |
Public property | EncodedSize |
Public property | IsLongTag |
Public property | IsShortTag |
Public property | Tag |
Public property | TagForGlobal |
Public property | TagForLocal |
Public property | TagForMain |
Public property | Type |
Back to Top
See Also
EncodedItem Class
HidSharp.ReportDescriptors Namespace


EncodedItem Constructor

EncodedItem Constructor HIDSharp
Initializes a new instance of the EncodedItem class

Namespace: HidSharp.ReportDescriptors
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public EncodedItem()
public EncodedItem()
Public Sub New
Public Sub New
public:
EncodedItem()
public:
EncodedItem()
new : unit -> EncodedItem
new : unit -> EncodedItem
See Also
EncodedItem Class
EncodedItem Members
HidSharp.ReportDescriptors Namespace


EncodedItem Methods

EncodedItem Methods HIDSharp
The EncodedItem type exposes the following members.
Methods
 | Name | Description
Public method | Clear |
Public method | DataAt |
Public method | Decode |
 | DecodeHIDDT |
 | DecodeRaw |
Public method | Encode |
 | EncodeRaw |
Back to Top
See Also
EncodedItem Class
HidSharp.ReportDescriptors Namespace


Clear Method

EncodedItem Clear Method HIDSharp

Namespace: HidSharp.ReportDescriptors
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Clear()
public void Clear()
Public Sub Clear
Public Sub Clear
public:
void Clear()
public:
void Clear()
member Clear : unit -> unit
member Clear : unit -> unit
See Also
EncodedItem Class
EncodedItem Members
HidSharp.ReportDescriptors Namespace


DataAt Method

EncodedItem DataAt Method HIDSharp

Namespace: HidSharp.ReportDescriptors
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public byte DataAt(
    int index
)
public byte DataAt(
    int index
)
Public Function DataAt ( _
    index As Integer _
) As Byte
Public Function DataAt ( _
    index As Integer _
) As Byte
public:
unsigned char DataAt(
    int index
)
public:
unsigned char DataAt(
    int index
)
member DataAt :
        index : int -> byte
member DataAt :
        index : int -> byte

Parameters

index
Type: Online System Int32
See Also
EncodedItem Class
EncodedItem Members
HidSharp.ReportDescriptors Namespace


Decode Method

EncodedItem Decode Method HIDSharp

Namespace: HidSharp.ReportDescriptors
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Decode(
    IList<byte> buffer,
    int offset,
    int count
)
public int Decode(
    IList<byte> buffer,
    int offset,
    int count
)
Public Function Decode ( _
    buffer As IList(Of Byte), _
    offset As Integer, _
    count As Integer _
) As Integer
Public Function Decode ( _
    buffer As IList(Of Byte), _
    offset As Integer, _
    count As Integer _
) As Integer
public:
int Decode(
    IList<unsigned char>^ buffer,
    int offset,
    int count
)
public:
int Decode(
    IList<unsigned char>^ buffer,
    int offset,
    int count
)
member Decode :
        buffer : IList<byte> *
        offset : int *
        count : int -> int
member Decode :
        buffer : IList<byte> *
        offset : int *
        count : int -> int

Parameters

buffer
Type: Online System.Collections.Generic IList Online Byte
offset
Type: Online System Int32
count
Type: Online System Int32
See Also
EncodedItem Class
EncodedItem Members
HidSharp.ReportDescriptors Namespace


DecodeHIDDT Method

EncodedItem DecodeHIDDT Method HIDSharp

Namespace: HidSharp.ReportDescriptors
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IEnumerable<EncodedItem> DecodeHIDDT(
    IList<byte> buffer,
    int offset,
    int count
)
public static IEnumerable<EncodedItem> DecodeHIDDT(
    IList<byte> buffer,
    int offset,
    int count
)
Public Shared Function DecodeHIDDT ( _
    buffer As IList(Of Byte), _
    offset As Integer, _
    count As Integer _
) As IEnumerable(Of EncodedItem)
Public Shared Function DecodeHIDDT ( _
    buffer As IList(Of Byte), _
    offset As Integer, _
    count As Integer _
) As IEnumerable(Of EncodedItem)
public:
static IEnumerable<EncodedItem^>^ DecodeHIDDT(
    IList<unsigned char>^ buffer,
    int offset,
    int count
)
public:
static IEnumerable<EncodedItem^>^ DecodeHIDDT(
    IList<unsigned char>^ buffer,
    int offset,
    int count
)
static member DecodeHIDDT :
        buffer : IList<byte> *
        offset : int *
        count : int -> IEnumerable<EncodedItem>
static member DecodeHIDDT :
        buffer : IList<byte> *
        offset : int *
        count : int -> IEnumerable<EncodedItem>

Parameters

buffer
Type: Online System.Collections.Generic IList Online Byte
offset
Type: Online System Int32
count
Type: Online System Int32
See Also
EncodedItem Class
EncodedItem Members
HidSharp.ReportDescriptors Namespace


DecodeRaw Method

EncodedItem DecodeRaw Method HIDSharp

Namespace: HidSharp.ReportDescriptors
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IEnumerable<EncodedItem> DecodeRaw(
    IList<byte> buffer,
    int offset,
    int count
)
public static IEnumerable<EncodedItem> DecodeRaw(
    IList<byte> buffer,
    int offset,
    int count
)
Public Shared Function DecodeRaw ( _
    buffer As IList(Of Byte), _
    offset As Integer, _
    count As Integer _
) As IEnumerable(Of EncodedItem)
Public Shared Function DecodeRaw ( _
    buffer As IList(Of Byte), _
    offset As Integer, _
    count As Integer _
) As IEnumerable(Of EncodedItem)
public:
static IEnumerable<EncodedItem^>^ DecodeRaw(
    IList<unsigned char>^ buffer,
    int offset,
    int count
)
public:
static IEnumerable<EncodedItem^>^ DecodeRaw(
    IList<unsigned char>^ buffer,
    int offset,
    int count
)
static member DecodeRaw :
        buffer : IList<byte> *
        offset : int *
        count : int -> IEnumerable<EncodedItem>
static member DecodeRaw :
        buffer : IList<byte> *
        offset : int *
        count : int -> IEnumerable<EncodedItem>

Parameters

buffer
Type: Online System.Collections.Generic IList Online Byte
offset
Type: Online System Int32
count
Type: Online System Int32
See Also
EncodedItem Class
EncodedItem Members
HidSharp.ReportDescriptors Namespace


Encode Method

EncodedItem Encode Method HIDSharp

Namespace: HidSharp.ReportDescriptors
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Encode(
    IList<byte> buffer
)
public void Encode(
    IList<byte> buffer
)
Public Sub Encode ( _
    buffer As IList(Of Byte) _
)
Public Sub Encode ( _
    buffer As IList(Of Byte) _
)
public:
void Encode(
    IList<unsigned char>^ buffer
)
public:
void Encode(
    IList<unsigned char>^ buffer
)
member Encode :
        buffer : IList<byte> -> unit
member Encode :
        buffer : IList<byte> -> unit

Parameters

buffer
Type: Online System.Collections.Generic IList Online Byte
See Also
EncodedItem Class
EncodedItem Members
HidSharp.ReportDescriptors Namespace


EncodeRaw Method

EncodedItem EncodeRaw Method HIDSharp

Namespace: HidSharp.ReportDescriptors
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void EncodeRaw(
    IList<byte> buffer,
    IEnumerable<EncodedItem> items
)
public static void EncodeRaw(
    IList<byte> buffer,
    IEnumerable<EncodedItem> items
)
Public Shared Sub EncodeRaw ( _
    buffer As IList(Of Byte), _
    items As IEnumerable(Of EncodedItem) _
)
Public Shared Sub EncodeRaw ( _
    buffer As IList(Of Byte), _
    items As IEnumerable(Of EncodedItem) _
)
public:
static void EncodeRaw(
    IList<unsigned char>^ buffer,
    IEnumerable<EncodedItem^>^ items
)
public:
static void EncodeRaw(
    IList<unsigned char>^ buffer,
    IEnumerable<EncodedItem^>^ items
)
static member EncodeRaw :
        buffer : IList<byte> *
        items : IEnumerable<EncodedItem> -> unit
static member EncodeRaw :
        buffer : IList<byte> *
        items : IEnumerable<EncodedItem> -> unit

Parameters

buffer
Type: Online System.Collections.Generic IList Online Byte
items
Type: Online System.Collections.Generic IEnumerable EncodedItem
See Also
EncodedItem Class
EncodedItem Members
HidSharp.ReportDescriptors Namespace


EncodedItem Properties

EncodedItem Properties HIDSharp
The EncodedItem type exposes the following members.
Properties
 | Name | Description
Public property | Data |
Public property | DataSize |
Public property | DataValue |
Public property | DataValueMayBeNegative |
Public property | DataValueSigned |
Public property | EncodedSize |
Public property | IsLongTag |
Public property | IsShortTag |
Public property | Tag |
Public property | TagForGlobal |
Public property | TagForLocal |
Public property | TagForMain |
Public property | Type |
Back to Top
See Also
EncodedItem Class
HidSharp.ReportDescriptors Namespace


Data Property

EncodedItem Data Property HIDSharp

Namespace: HidSharp.ReportDescriptors
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IList<byte> Data { get; private set; }
public IList<byte> Data { get; private set; }
Public Property Data As IList(Of Byte)
    Get
    Private Set
Public Property Data As IList(Of Byte)
    Get
    Private Set
public:
property IList<unsigned char>^ Data {
    IList<unsigned char>^ get ();
    private: void set (IList<unsigned char>^ value);
}
public:
property IList<unsigned char>^ Data {
    IList<unsigned char>^ get ();
    private: void set (IList<unsigned char>^ value);
}
member Data : IList<byte> with get, private set
member Data : IList<byte> with get, private set
See Also
EncodedItem Class
EncodedItem Members
HidSharp.ReportDescriptors Namespace


DataSize Property

EncodedItem DataSize Property HIDSharp

Namespace: HidSharp.ReportDescriptors
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public byte DataSize { get; }
public byte DataSize { get; }
Public ReadOnly Property DataSize As Byte
    Get
Public ReadOnly Property DataSize As Byte
    Get
public:
property unsigned char DataSize {
    unsigned char get ();
}
public:
property unsigned char DataSize {
    unsigned char get ();
}
member DataSize : byte with get
member DataSize : byte with get
See Also
EncodedItem Class
EncodedItem Members
HidSharp.ReportDescriptors Namespace


DataValue Property

EncodedItem DataValue Property HIDSharp

Namespace: HidSharp.ReportDescriptors
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public uint DataValue { get; set; }
public uint DataValue { get; set; }
Public Property DataValue As UInteger
    Get
    Set
Public Property DataValue As UInteger
    Get
    Set
public:
property unsigned int DataValue {
    unsigned int get ();
    void set (unsigned int value);
}
public:
property unsigned int DataValue {
    unsigned int get ();
    void set (unsigned int value);
}
member DataValue : uint32 with get, set
member DataValue : uint32 with get, set
See Also
EncodedItem Class
EncodedItem Members
HidSharp.ReportDescriptors Namespace


DataValueMayBeNegative Property

EncodedItem DataValueMayBeNegative Property HIDSharp

Namespace: HidSharp.ReportDescriptors
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool DataValueMayBeNegative { get; }
public bool DataValueMayBeNegative { get; }
Public ReadOnly Property DataValueMayBeNegative As Boolean
    Get
Public ReadOnly Property DataValueMayBeNegative As Boolean
    Get
public:
property bool DataValueMayBeNegative {
    bool get ();
}
public:
property bool DataValueMayBeNegative {
    bool get ();
}
member DataValueMayBeNegative : bool with get
member DataValueMayBeNegative : bool with get
See Also
EncodedItem Class
EncodedItem Members
HidSharp.ReportDescriptors Namespace


DataValueSigned Property

EncodedItem DataValueSigned Property HIDSharp

Namespace: HidSharp.ReportDescriptors
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int DataValueSigned { get; set; }
public int DataValueSigned { get; set; }
Public Property DataValueSigned As Integer
    Get
    Set
Public Property DataValueSigned As Integer
    Get
    Set
public:
property int DataValueSigned {
    int get ();
    void set (int value);
}
public:
property int DataValueSigned {
    int get ();
    void set (int value);
}
member DataValueSigned : int with get, set
member DataValueSigned : int with get, set
See Also
EncodedItem Class
EncodedItem Members
HidSharp.ReportDescriptors Namespace


EncodedSize Property

EncodedItem EncodedSize Property HIDSharp

Namespace: HidSharp.ReportDescriptors
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int EncodedSize { get; }
public int EncodedSize { get; }
Public ReadOnly Property EncodedSize As Integer
    Get
Public ReadOnly Property EncodedSize As Integer
    Get
public:
property int EncodedSize {
    int get ();
}
public:
property int EncodedSize {
    int get ();
}
member EncodedSize : int with get
member EncodedSize : int with get
See Also
EncodedItem Class
EncodedItem Members
HidSharp.ReportDescriptors Namespace


IsLongTag Property

EncodedItem IsLongTag Property HIDSharp

Namespace: HidSharp.ReportDescriptors
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsLongTag { get; }
public bool IsLongTag { get; }
Public ReadOnly Property IsLongTag As Boolean
    Get
Public ReadOnly Property IsLongTag As Boolean
    Get
public:
property bool IsLongTag {
    bool get ();
}
public:
property bool IsLongTag {
    bool get ();
}
member IsLongTag : bool with get
member IsLongTag : bool with get
See Also
EncodedItem Class
EncodedItem Members
HidSharp.ReportDescriptors Namespace


IsShortTag Property

EncodedItem IsShortTag Property HIDSharp

Namespace: HidSharp.ReportDescriptors
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsShortTag { get; }
public bool IsShortTag { get; }
Public ReadOnly Property IsShortTag As Boolean
    Get
Public ReadOnly Property IsShortTag As Boolean
    Get
public:
property bool IsShortTag {
    bool get ();
}
public:
property bool IsShortTag {
    bool get ();
}
member IsShortTag : bool with get
member IsShortTag : bool with get
See Also
EncodedItem Class
EncodedItem Members
HidSharp.ReportDescriptors Namespace


Tag Property

EncodedItem Tag Property HIDSharp

Namespace: HidSharp.ReportDescriptors
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public byte Tag { get; set; }
public byte Tag { get; set; }
Public Property Tag As Byte
    Get
    Set
Public Property Tag As Byte
    Get
    Set
public:
property unsigned char Tag {
    unsigned char get ();
    void set (unsigned char value);
}
public:
property unsigned char Tag {
    unsigned char get ();
    void set (unsigned char value);
}
member Tag : byte with get, set
member Tag : byte with get, set
See Also
EncodedItem Class
EncodedItem Members
HidSharp.ReportDescriptors Namespace


TagForGlobal Property

EncodedItem TagForGlobal Property HIDSharp

Namespace: HidSharp.ReportDescriptors
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public GlobalItemTag TagForGlobal { get; }
public GlobalItemTag TagForGlobal { get; }
Public ReadOnly Property TagForGlobal As GlobalItemTag
    Get
Public ReadOnly Property TagForGlobal As GlobalItemTag
    Get
public:
property GlobalItemTag TagForGlobal {
    GlobalItemTag get ();
}
public:
property GlobalItemTag TagForGlobal {
    GlobalItemTag get ();
}
member TagForGlobal : GlobalItemTag with get
member TagForGlobal : GlobalItemTag with get
See Also
EncodedItem Class
EncodedItem Members
HidSharp.ReportDescriptors Namespace


TagForLocal Property

EncodedItem TagForLocal Property HIDSharp

Namespace: HidSharp.ReportDescriptors
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LocalItemTag TagForLocal { get; }
public LocalItemTag TagForLocal { get; }
Public ReadOnly Property TagForLocal As LocalItemTag
    Get
Public ReadOnly Property TagForLocal As LocalItemTag
    Get
public:
property LocalItemTag TagForLocal {
    LocalItemTag get ();
}
public:
property LocalItemTag TagForLocal {
    LocalItemTag get ();
}
member TagForLocal : LocalItemTag with get
member TagForLocal : LocalItemTag with get
See Also
EncodedItem Class
EncodedItem Members
HidSharp.ReportDescriptors Namespace


TagForMain Property

EncodedItem TagForMain Property HIDSharp

Namespace: HidSharp.ReportDescriptors
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MainItemTag TagForMain { get; }
public MainItemTag TagForMain { get; }
Public ReadOnly Property TagForMain As MainItemTag
    Get
Public ReadOnly Property TagForMain As MainItemTag
    Get
public:
property MainItemTag TagForMain {
    MainItemTag get ();
}
public:
property MainItemTag TagForMain {
    MainItemTag get ();
}
member TagForMain : MainItemTag with get
member TagForMain : MainItemTag with get
See Also
EncodedItem Class
EncodedItem Members
HidSharp.ReportDescriptors Namespace


Type Property

EncodedItem Type Property HIDSharp

Namespace: HidSharp.ReportDescriptors
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ItemType Type { get; set; }
public ItemType Type { get; set; }
Public Property Type As ItemType
    Get
    Set
Public Property Type As ItemType
    Get
    Set
public:
property ItemType Type {
    ItemType get ();
    void set (ItemType value);
}
public:
property ItemType Type {
    ItemType get ();
    void set (ItemType value);
}
member Type : ItemType with get, set
member Type : ItemType with get, set
See Also
EncodedItem Class
EncodedItem Members
HidSharp.ReportDescriptors Namespace


GlobalItemTag Enumeration

GlobalItemTag Enumeration HIDSharp

Namespace: HidSharp.ReportDescriptors
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum GlobalItemTag
public enum GlobalItemTag
Public Enumeration GlobalItemTag
Public Enumeration GlobalItemTag
public enum class GlobalItemTag
public enum class GlobalItemTag
type GlobalItemTag
type GlobalItemTag
Members
Member name | Value | Description
UsagePage | 0 |
LogicalMinimum | 1 |
LogicalMaximum | 2 |
PhysicalMinimum | 3 |
PhysicalMaximum | 4 |
UnitExponent | 5 |
Unit | 6 |
ReportSize | 7 |
ReportID | 8 |
ReportCount | 9 |
Push | 10 |
Pop | 11 |
See Also
HidSharp.ReportDescriptors Namespace


ItemType Enumeration

ItemType Enumeration HIDSharp
Describes the manner in which an item affects the descriptor.

Namespace: HidSharp.ReportDescriptors
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum ItemType
public enum ItemType
Public Enumeration ItemType
Public Enumeration ItemType
public enum class ItemType
public enum class ItemType
type ItemType
type ItemType
Members
Member name | Value | Description
Main | 0 | Main items determine the report being described. For example, a main item switches between Input and Output reports.
Global | 1 | Global items affect all reports later in the descriptor.
Local | 2 | Local items only affect the current report.
Reserved | 3 | Long items use this type.
See Also
HidSharp.ReportDescriptors Namespace


LocalItemTag Enumeration

LocalItemTag Enumeration HIDSharp

Namespace: HidSharp.ReportDescriptors
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum LocalItemTag
public enum LocalItemTag
Public Enumeration LocalItemTag
Public Enumeration LocalItemTag
public enum class LocalItemTag
public enum class LocalItemTag
type LocalItemTag
type LocalItemTag
Members
Member name | Value | Description
Usage | 0 |
UsageMinimum | 1 |
UsageMaximum | 2 |
DesignatorIndex | 3 |
DesignatorMinimum | 4 |
DesignatorMaximum | 5 |
StringIndex | 7 |
StringMinimum | 8 |
StringMaximum | 9 |
Delimiter | 10 |
See Also
HidSharp.ReportDescriptors Namespace


MainItemTag Enumeration

MainItemTag Enumeration HIDSharp

Namespace: HidSharp.ReportDescriptors
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum MainItemTag
public enum MainItemTag
Public Enumeration MainItemTag
Public Enumeration MainItemTag
public enum class MainItemTag
public enum class MainItemTag
type MainItemTag
type MainItemTag
Members
Member name | Value | Description
Input | 8 |
Output | 9 |
Collection | 10 |
Feature | 11 |
EndCollection | 12 |
See Also
HidSharp.ReportDescriptors Namespace


HidSharp.ReportDescriptors.Parser Namespace

HidSharp.ReportDescriptors.Parser Namespace HIDSharp
Raw HID report descriptors can be parsed to get information about report lengths, layout, etc.
Classes
 | Class | Description
Public class | IndexBase |
Public class | IndexList |
Public class | IndexRange |
Public class | LocalIndexes |
Public class | Report | Reads and writes HID reports.
Public class | ReportCollection |
Public class | ReportDescriptorParser | Parses HID report descriptors.
Public class | ReportMainItem |
Public class | ReportSegment |
Delegates
 | Delegate | Description
Public delegate | ReportScanCallback |
Enumerations
 | Enumeration | Description
Public enumeration | ReportType |


IndexBase Class

IndexBase Class HIDSharp
Inheritance Hierarchy
Online System Object
HidSharp.ReportDescriptors.Parser IndexBase
HidSharp.ReportDescriptors.Parser IndexList
HidSharp.ReportDescriptors.Parser IndexRange

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class IndexBase
public class IndexBase
Public Class IndexBase
Public Class IndexBase
public ref class IndexBase
public ref class IndexBase
type IndexBase =  class end
type IndexBase =  class end
See Also
IndexBase Members
HidSharp.ReportDescriptors.Parser Namespace


IndexBase Members

IndexBase Members HIDSharp

The IndexBase type exposes the following members.
Constructors
 | Name | Description
Public method | IndexBase | Initializes a new instance of the IndexBase class
Back to Top
Methods
 | Name | Description
Public method | ContainsValue |
Public method | IndexFromValue |
Public method | ValuesFromIndex |
Back to Top
Fields
Name | Description
Unset |
Back to Top
Properties
 | Name | Description
Public property | Count |
Back to Top
See Also
IndexBase Class


IndexBase Constructor

IndexBase Constructor HIDSharp
Initializes a new instance of the IndexBase class

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IndexBase()
public IndexBase()
Public Sub New
Public Sub New
public:
IndexBase()
public:
IndexBase()
new : unit -> IndexBase
new : unit -> IndexBase
See Also
IndexBase Class
IndexBase Members


IndexBase Fields

IndexBase Fields HIDSharp
The IndexBase type exposes the following members.
Fields
Name | Description
Unset |
Back to Top
See Also
IndexBase Class


Unset Field

IndexBase Unset Field HIDSharp

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly IndexBase Unset
public static readonly IndexBase Unset
Public Shared ReadOnly Unset As IndexBase
Public Shared ReadOnly Unset As IndexBase
public:
static initonly IndexBase^ Unset
public:
static initonly IndexBase^ Unset
static val Unset: IndexBase
static val Unset: IndexBase
See Also
IndexBase Class
IndexBase Members


IndexBase Methods

IndexBase Methods HIDSharp
The IndexBase type exposes the following members.
Methods
 | Name | Description
Public method | ContainsValue |
Public method | IndexFromValue |
Public method | ValuesFromIndex |
Back to Top
See Also
IndexBase Class


ContainsValue Method

IndexBase ContainsValue Method HIDSharp

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ContainsValue(
    uint value
)
public bool ContainsValue(
    uint value
)
Public Function ContainsValue ( _
    value As UInteger _
) As Boolean
Public Function ContainsValue ( _
    value As UInteger _
) As Boolean
public:
bool ContainsValue(
    unsigned int value
)
public:
bool ContainsValue(
    unsigned int value
)
member ContainsValue :
        value : uint32 -> bool
member ContainsValue :
        value : uint32 -> bool

Parameters

value
Type: Online System UInt32
See Also
IndexBase Class
IndexBase Members


IndexFromValue Method

IndexBase IndexFromValue Method HIDSharp

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual bool IndexFromValue(
    uint value,
    out int index
)
public virtual bool IndexFromValue(
    uint value,
    out int index
)
Public Overridable Function IndexFromValue ( _
    value As UInteger, _
    <OutAttribute> ByRef index As Integer _
) As Boolean
Public Overridable Function IndexFromValue ( _
    value As UInteger, _
    <OutAttribute> ByRef index As Integer _
) As Boolean
public:
virtual bool IndexFromValue(
    unsigned int value,
    [OutAttribute] int% index
)
public:
virtual bool IndexFromValue(
    unsigned int value,
    [OutAttribute] int% index
)
abstract IndexFromValue :
        value : uint32 *
        index : int byref -> bool
override IndexFromValue :
        value : uint32 *
        index : int byref -> bool
abstract IndexFromValue :
        value : uint32 *
        index : int byref -> bool
override IndexFromValue :
        value : uint32 *
        index : int byref -> bool

Parameters

value
Type: Online System UInt32
index
Type: Online System Int32
See Also
IndexBase Class
IndexBase Members


ValuesFromIndex Method

IndexBase ValuesFromIndex Method HIDSharp

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual IEnumerable<uint> ValuesFromIndex(
    int index
)
public virtual IEnumerable<uint> ValuesFromIndex(
    int index
)
Public Overridable Function ValuesFromIndex ( _
    index As Integer _
) As IEnumerable(Of UInteger)
Public Overridable Function ValuesFromIndex ( _
    index As Integer _
) As IEnumerable(Of UInteger)
public:
virtual IEnumerable<unsigned int>^ ValuesFromIndex(
    int index
)
public:
virtual IEnumerable<unsigned int>^ ValuesFromIndex(
    int index
)
abstract ValuesFromIndex :
        index : int -> IEnumerable<uint32>
override ValuesFromIndex :
        index : int -> IEnumerable<uint32>
abstract ValuesFromIndex :
        index : int -> IEnumerable<uint32>
override ValuesFromIndex :
        index : int -> IEnumerable<uint32>

Parameters

index
Type: Online System Int32
See Also
IndexBase Class
IndexBase Members


IndexBase Properties

IndexBase Properties HIDSharp
The IndexBase type exposes the following members.
Properties
 | Name | Description
Public property | Count |
Back to Top
See Also
IndexBase Class


Count Property

IndexBase Count Property HIDSharp

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual int Count { get; }
public virtual int Count { get; }
Public Overridable ReadOnly Property Count As Integer
    Get
Public Overridable ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get ();
}
public:
virtual property int Count {
    int get ();
}
abstract Count : int with get
override Count : int with get
abstract Count : int with get
override Count : int with get
See Also
IndexBase Class
IndexBase Members


IndexList Class

IndexList Class HIDSharp
Inheritance Hierarchy
Online System Object
HidSharp.ReportDescriptors.Parser IndexBase
HidSharp.ReportDescriptors.Parser IndexList

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class IndexList : IndexBase
public class IndexList : IndexBase
Public Class IndexList _
    Inherits IndexBase
Public Class IndexList _
    Inherits IndexBase
public ref class IndexList : public IndexBase
public ref class IndexList : public IndexBase
type IndexList =
    class
        inherit IndexBase
    end
type IndexList =
    class
        inherit IndexBase
    end
See Also
IndexList Members


IndexList Members

IndexList Members HIDSharp

The IndexList type exposes the following members.
Constructors
 | Name | Description
Public method | IndexList | Initializes a new instance of the IndexList class
Back to Top
Methods
 | Name | Description
Public method | ContainsValue | (Inherited from IndexBase.)
Public method | IndexFromValue | (Overrides IndexBase IndexFromValue(UInt32, Int32 ).)
Public method | ValuesFromIndex | (Overrides IndexBase ValuesFromIndex(Int32).)
Back to Top
Properties
 | Name | Description
Public property | Count | (Overrides IndexBase Count.)
Public property | Indices |
Back to Top
See Also
IndexList Class


IndexList Constructor

IndexList Constructor HIDSharp
Initializes a new instance of the IndexList class

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IndexList()
public IndexList()
Public Sub New
Public Sub New
public:
IndexList()
public:
IndexList()
new : unit -> IndexList
new : unit -> IndexList
See Also
IndexList Class
IndexList Members


IndexList Methods

IndexList Methods HIDSharp
The IndexList type exposes the following members.
Methods
 | Name | Description
Public method | ContainsValue | (Inherited from IndexBase.)
Public method | IndexFromValue | (Overrides IndexBase IndexFromValue(UInt32, Int32 ).)
Public method | ValuesFromIndex | (Overrides IndexBase ValuesFromIndex(Int32).)
Back to Top
See Also
IndexList Class


IndexFromValue Method

IndexList IndexFromValue Method HIDSharp

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool IndexFromValue(
    uint value,
    out int index
)
public override bool IndexFromValue(
    uint value,
    out int index
)
Public Overrides Function IndexFromValue ( _
    value As UInteger, _
    <OutAttribute> ByRef index As Integer _
) As Boolean
Public Overrides Function IndexFromValue ( _
    value As UInteger, _
    <OutAttribute> ByRef index As Integer _
) As Boolean
public:
virtual bool IndexFromValue(
    unsigned int value,
    [OutAttribute] int% index
) override
public:
virtual bool IndexFromValue(
    unsigned int value,
    [OutAttribute] int% index
) override
abstract IndexFromValue :
        value : uint32 *
        index : int byref -> bool
override IndexFromValue :
        value : uint32 *
        index : int byref -> bool
abstract IndexFromValue :
        value : uint32 *
        index : int byref -> bool
override IndexFromValue :
        value : uint32 *
        index : int byref -> bool

Parameters

value
Type: Online System UInt32
index
Type: Online System Int32
See Also
IndexList Class
IndexList Members


ValuesFromIndex Method

IndexList ValuesFromIndex Method HIDSharp

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override IEnumerable<uint> ValuesFromIndex(
    int index
)
public override IEnumerable<uint> ValuesFromIndex(
    int index
)
Public Overrides Function ValuesFromIndex ( _
    index As Integer _
) As IEnumerable(Of UInteger)
Public Overrides Function ValuesFromIndex ( _
    index As Integer _
) As IEnumerable(Of UInteger)
public:
virtual IEnumerable<unsigned int>^ ValuesFromIndex(
    int index
) override
public:
virtual IEnumerable<unsigned int>^ ValuesFromIndex(
    int index
) override
abstract ValuesFromIndex :
        index : int -> IEnumerable<uint32>
override ValuesFromIndex :
        index : int -> IEnumerable<uint32>
abstract ValuesFromIndex :
        index : int -> IEnumerable<uint32>
override ValuesFromIndex :
        index : int -> IEnumerable<uint32>

Parameters

index
Type: Online System Int32
See Also
IndexList Class
IndexList Members


IndexList Properties

IndexList Properties HIDSharp
The IndexList type exposes the following members.
Properties
 | Name | Description
Public property | Count | (Overrides IndexBase Count.)
Public property | Indices |
Back to Top
See Also
IndexList Class


Count Property

IndexList Count Property HIDSharp

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int Count { get; }
public override int Count { get; }
Public Overrides ReadOnly Property Count As Integer
    Get
Public Overrides ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get () override;
}
public:
virtual property int Count {
    int get () override;
}
abstract Count : int with get
override Count : int with get
abstract Count : int with get
override Count : int with get
See Also
IndexList Class
IndexList Members


Indices Property

IndexList Indices Property HIDSharp

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IList<IList<uint>> Indices { get; private set; }
public IList<IList<uint>> Indices { get; private set; }
Public Property Indices As IList(Of IList(Of UInteger))
    Get
    Private Set
Public Property Indices As IList(Of IList(Of UInteger))
    Get
    Private Set
public:
property IList<IList<unsigned int>^>^ Indices {
    IList<IList<unsigned int>^>^ get ();
    private: void set (IList<IList<unsigned int>^>^ value);
}
public:
property IList<IList<unsigned int>^>^ Indices {
    IList<IList<unsigned int>^>^ get ();
    private: void set (IList<IList<unsigned int>^>^ value);
}
member Indices : IList<IList<uint32>> with get, private set
member Indices : IList<IList<uint32>> with get, private set
See Also
IndexList Class
IndexList Members


IndexRange Class

IndexRange Class HIDSharp
Inheritance Hierarchy
Online System Object
HidSharp.ReportDescriptors.Parser IndexBase
HidSharp.ReportDescriptors.Parser IndexRange

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class IndexRange : IndexBase
public class IndexRange : IndexBase
Public Class IndexRange _
    Inherits IndexBase
Public Class IndexRange _
    Inherits IndexBase
public ref class IndexRange : public IndexBase
public ref class IndexRange : public IndexBase
type IndexRange =
    class
        inherit IndexBase
    end
type IndexRange =
    class
        inherit IndexBase
    end
See Also
IndexRange Members


IndexRange Members

IndexRange Members HIDSharp

The IndexRange type exposes the following members.
Constructors
 | Name | Description
Public method | IndexRange | Initializes a new instance of the IndexRange class
Public method | IndexRange(UInt32, UInt32) | Initializes a new instance of the IndexRange class
Back to Top
Methods
 | Name | Description
Public method | ContainsValue | (Inherited from IndexBase.)
Public method | IndexFromValue | (Overrides IndexBase IndexFromValue(UInt32, Int32 ).)
Public method | ValuesFromIndex | (Overrides IndexBase ValuesFromIndex(Int32).)
Back to Top
Properties
 | Name | Description
Public property | Count | (Overrides IndexBase Count.)
Public property | Maximum |
Public property | Minimum |
Back to Top
See Also
IndexRange Class


IndexRange Constructor

IndexRange Constructor HIDSharp
Overload List
 | Name | Description
Public method | IndexRange | Initializes a new instance of the IndexRange class
Public method | IndexRange(UInt32, UInt32) | Initializes a new instance of the IndexRange class
Back to Top
See Also
IndexRange Class
IndexRange Members


IndexRange Constructor

IndexRange Constructor HIDSharp
Initializes a new instance of the IndexRange class

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IndexRange()
public IndexRange()
Public Sub New
Public Sub New
public:
IndexRange()
public:
IndexRange()
new : unit -> IndexRange
new : unit -> IndexRange
See Also
IndexRange Class
IndexRange Members
IndexRange Overload


IndexRange Constructor (UInt32, UInt32)

IndexRange Constructor (UInt32, UInt32) HIDSharp
Initializes a new instance of the IndexRange class

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IndexRange(
    uint minimum,
    uint maximum
)
public IndexRange(
    uint minimum,
    uint maximum
)
Public Sub New ( _
    minimum As UInteger, _
    maximum As UInteger _
)
Public Sub New ( _
    minimum As UInteger, _
    maximum As UInteger _
)
public:
IndexRange(
    unsigned int minimum,
    unsigned int maximum
)
public:
IndexRange(
    unsigned int minimum,
    unsigned int maximum
)
new :
        minimum : uint32 *
        maximum : uint32 -> IndexRange
new :
        minimum : uint32 *
        maximum : uint32 -> IndexRange

Parameters

minimum
Type: Online System UInt32
maximum
Type: Online System UInt32
See Also
IndexRange Class
IndexRange Members
IndexRange Overload


IndexRange Methods

IndexRange Methods HIDSharp
The IndexRange type exposes the following members.
Methods
 | Name | Description
Public method | ContainsValue | (Inherited from IndexBase.)
Public method | IndexFromValue | (Overrides IndexBase IndexFromValue(UInt32, Int32 ).)
Public method | ValuesFromIndex | (Overrides IndexBase ValuesFromIndex(Int32).)
Back to Top
See Also
IndexRange Class


IndexFromValue Method

IndexRange IndexFromValue Method HIDSharp

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool IndexFromValue(
    uint value,
    out int index
)
public override bool IndexFromValue(
    uint value,
    out int index
)
Public Overrides Function IndexFromValue ( _
    value As UInteger, _
    <OutAttribute> ByRef index As Integer _
) As Boolean
Public Overrides Function IndexFromValue ( _
    value As UInteger, _
    <OutAttribute> ByRef index As Integer _
) As Boolean
public:
virtual bool IndexFromValue(
    unsigned int value,
    [OutAttribute] int% index
) override
public:
virtual bool IndexFromValue(
    unsigned int value,
    [OutAttribute] int% index
) override
abstract IndexFromValue :
        value : uint32 *
        index : int byref -> bool
override IndexFromValue :
        value : uint32 *
        index : int byref -> bool
abstract IndexFromValue :
        value : uint32 *
        index : int byref -> bool
override IndexFromValue :
        value : uint32 *
        index : int byref -> bool

Parameters

value
Type: Online System UInt32
index
Type: Online System Int32
See Also
IndexRange Class
IndexRange Members


ValuesFromIndex Method

IndexRange ValuesFromIndex Method HIDSharp

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override IEnumerable<uint> ValuesFromIndex(
    int index
)
public override IEnumerable<uint> ValuesFromIndex(
    int index
)
Public Overrides Function ValuesFromIndex ( _
    index As Integer _
) As IEnumerable(Of UInteger)
Public Overrides Function ValuesFromIndex ( _
    index As Integer _
) As IEnumerable(Of UInteger)
public:
virtual IEnumerable<unsigned int>^ ValuesFromIndex(
    int index
) override
public:
virtual IEnumerable<unsigned int>^ ValuesFromIndex(
    int index
) override
abstract ValuesFromIndex :
        index : int -> IEnumerable<uint32>
override ValuesFromIndex :
        index : int -> IEnumerable<uint32>
abstract ValuesFromIndex :
        index : int -> IEnumerable<uint32>
override ValuesFromIndex :
        index : int -> IEnumerable<uint32>

Parameters

index
Type: Online System Int32
See Also
IndexRange Class
IndexRange Members


IndexRange Properties

IndexRange Properties HIDSharp
The IndexRange type exposes the following members.
Properties
 | Name | Description
Public property | Count | (Overrides IndexBase Count.)
Public property | Maximum |
Public property | Minimum |
Back to Top
See Also
IndexRange Class


Count Property

IndexRange Count Property HIDSharp

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int Count { get; }
public override int Count { get; }
Public Overrides ReadOnly Property Count As Integer
    Get
Public Overrides ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get () override;
}
public:
virtual property int Count {
    int get () override;
}
abstract Count : int with get
override Count : int with get
abstract Count : int with get
override Count : int with get
See Also
IndexRange Class
IndexRange Members


Maximum Property

IndexRange Maximum Property HIDSharp

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public uint Maximum { get; set; }
public uint Maximum { get; set; }
Public Property Maximum As UInteger
    Get
    Set
Public Property Maximum As UInteger
    Get
    Set
public:
property unsigned int Maximum {
    unsigned int get ();
    void set (unsigned int value);
}
public:
property unsigned int Maximum {
    unsigned int get ();
    void set (unsigned int value);
}
member Maximum : uint32 with get, set
member Maximum : uint32 with get, set
See Also
IndexRange Class
IndexRange Members


Minimum Property

IndexRange Minimum Property HIDSharp

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public uint Minimum { get; set; }
public uint Minimum { get; set; }
Public Property Minimum As UInteger
    Get
    Set
Public Property Minimum As UInteger
    Get
    Set
public:
property unsigned int Minimum {
    unsigned int get ();
    void set (unsigned int value);
}
public:
property unsigned int Minimum {
    unsigned int get ();
    void set (unsigned int value);
}
member Minimum : uint32 with get, set
member Minimum : uint32 with get, set
See Also
IndexRange Class
IndexRange Members


LocalIndexes Class

LocalIndexes Class HIDSharp
Inheritance Hierarchy
Online System Object
HidSharp.ReportDescriptors.Parser LocalIndexes

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class LocalIndexes
public class LocalIndexes
Public Class LocalIndexes
Public Class LocalIndexes
public ref class LocalIndexes
public ref class LocalIndexes
type LocalIndexes =  class end
type LocalIndexes =  class end
See Also
LocalIndexes Members


LocalIndexes Members

LocalIndexes Members HIDSharp

The LocalIndexes type exposes the following members.
Constructors
 | Name | Description
Public method | LocalIndexes | Initializes a new instance of the LocalIndexes class
Back to Top
Methods
 | Name | Description
Public method | Clear |
Back to Top
Properties
 | Name | Description
Public property | Designator |
Public property | String |
Public property | Usage |
Back to Top
See Also
LocalIndexes Class


LocalIndexes Constructor

LocalIndexes Constructor HIDSharp
Initializes a new instance of the LocalIndexes class

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LocalIndexes()
public LocalIndexes()
Public Sub New
Public Sub New
public:
LocalIndexes()
public:
LocalIndexes()
new : unit -> LocalIndexes
new : unit -> LocalIndexes
See Also
LocalIndexes Class
LocalIndexes Members


LocalIndexes Methods

LocalIndexes Methods HIDSharp
The LocalIndexes type exposes the following members.
Methods
 | Name | Description
Public method | Clear |
Back to Top
See Also
LocalIndexes Class


Clear Method

LocalIndexes Clear Method HIDSharp

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Clear()
public void Clear()
Public Sub Clear
Public Sub Clear
public:
void Clear()
public:
void Clear()
member Clear : unit -> unit
member Clear : unit -> unit
See Also
LocalIndexes Class
LocalIndexes Members


LocalIndexes Properties

LocalIndexes Properties HIDSharp
The LocalIndexes type exposes the following members.
Properties
 | Name | Description
Public property | Designator |
Public property | String |
Public property | Usage |
Back to Top
See Also
LocalIndexes Class


Designator Property

LocalIndexes Designator Property HIDSharp

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IndexBase Designator { get; set; }
public IndexBase Designator { get; set; }
Public Property Designator As IndexBase
    Get
    Set
Public Property Designator As IndexBase
    Get
    Set
public:
property IndexBase^ Designator {
    IndexBase^ get ();
    void set (IndexBase^ value);
}
public:
property IndexBase^ Designator {
    IndexBase^ get ();
    void set (IndexBase^ value);
}
member Designator : IndexBase with get, set
member Designator : IndexBase with get, set
See Also
LocalIndexes Class
LocalIndexes Members


String Property

LocalIndexes String Property HIDSharp

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IndexBase String { get; set; }
public IndexBase String { get; set; }
Public Property String As IndexBase
    Get
    Set
Public Property String As IndexBase
    Get
    Set
public:
property IndexBase^ String {
    IndexBase^ get ();
    void set (IndexBase^ value);
}
public:
property IndexBase^ String {
    IndexBase^ get ();
    void set (IndexBase^ value);
}
member String : IndexBase with get, set
member String : IndexBase with get, set
See Also
LocalIndexes Class
LocalIndexes Members


Usage Property

LocalIndexes Usage Property HIDSharp

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IndexBase Usage { get; set; }
public IndexBase Usage { get; set; }
Public Property Usage As IndexBase
    Get
    Set
Public Property Usage As IndexBase
    Get
    Set
public:
property IndexBase^ Usage {
    IndexBase^ get ();
    void set (IndexBase^ value);
}
public:
property IndexBase^ Usage {
    IndexBase^ get ();
    void set (IndexBase^ value);
}
member Usage : IndexBase with get, set
member Usage : IndexBase with get, set
See Also
LocalIndexes Class
LocalIndexes Members


Report Class

Report Class HIDSharp
Reads and writes HID reports.
Inheritance Hierarchy
Online System Object
HidSharp.ReportDescriptors.Parser Report

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class Report
public class Report
Public Class Report
Public Class Report
public ref class Report
public ref class Report
type Report =  class end
type Report =  class end
See Also
Report Members


Report Members

Report Members HIDSharp

The Report type exposes the following members.
Constructors
 | Name | Description
Public method | Report | Initializes a new instance of the Report class.
Back to Top
Methods
 | Name | Description
Public method | Clear | Resets the instance to its initial state.
Public method | Scan | Reads a HID report, calling back a provided function for each segment.
Public method | Write | Writes a HID report, calling back a provided function for each segment.
Back to Top
Properties
 | Name | Description
Public property | ID | The Report ID.
Public property | Length | The length of this particular report. The Report ID is not included in this length.
Public property | Segments |
Public property | Type |
Back to Top
See Also
Report Class


Report Constructor

Report Constructor HIDSharp
Initializes a new instance of the Report class.

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Report()
public Report()
Public Sub New
Public Sub New
public:
Report()
public:
Report()
new : unit -> Report
new : unit -> Report
See Also
Report Class
Report Members


Report Methods

Report Methods HIDSharp
The Report type exposes the following members.
Methods
 | Name | Description
Public method | Clear | Resets the instance to its initial state.
Public method | Scan | Reads a HID report, calling back a provided function for each segment.
Public method | Write | Writes a HID report, calling back a provided function for each segment.
Back to Top
See Also
Report Class


Clear Method

Report Clear Method HIDSharp
Resets the instance to its initial state.

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Clear()
public void Clear()
Public Sub Clear
Public Sub Clear
public:
void Clear()
public:
void Clear()
member Clear : unit -> unit
member Clear : unit -> unit
See Also
Report Class
Report Members


Scan Method

Report Scan Method HIDSharp
Reads a HID report, calling back a provided function for each segment.

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Scan(
    byte[] buffer,
    int offset,
    ReportScanCallback callback
)
public void Scan(
    byte[] buffer,
    int offset,
    ReportScanCallback callback
)
Public Sub Scan ( _
    buffer As Byte(), _
    offset As Integer, _
    callback As ReportScanCallback _
)
Public Sub Scan ( _
    buffer As Byte(), _
    offset As Integer, _
    callback As ReportScanCallback _
)
public:
void Scan(
    array<unsigned char>^ buffer,
    int offset,
    ReportScanCallback^ callback
)
public:
void Scan(
    array<unsigned char>^ buffer,
    int offset,
    ReportScanCallback^ callback
)
member Scan :
        buffer : byte[] *
        offset : int *
        callback : ReportScanCallback -> unit
member Scan :
        buffer : byte[] *
        offset : int *
        callback : ReportScanCallback -> unit

Parameters

buffer
Type: Online System Byte
The buffer containing the report.
offset
Type: Online System Int32
The offset to begin reading the report at.
callback
Type: HidSharp.ReportDescriptors.Parser ReportScanCallback
This callback will be called for each report segment. Use this to read every value you need.
See Also
Report Class
Report Members


Write Method

Report Write Method HIDSharp
Writes a HID report, calling back a provided function for each segment.

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public byte[] Write(
    ReportScanCallback callback
)
public byte[] Write(
    ReportScanCallback callback
)
Public Function Write ( _
    callback As ReportScanCallback _
) As Byte()
Public Function Write ( _
    callback As ReportScanCallback _
) As Byte()
public:
array<unsigned char>^ Write(
    ReportScanCallback^ callback
)
public:
array<unsigned char>^ Write(
    ReportScanCallback^ callback
)
member Write :
        callback : ReportScanCallback -> byte[]
member Write :
        callback : ReportScanCallback -> byte[]

Parameters

callback
Type: HidSharp.ReportDescriptors.Parser ReportScanCallback
This callback will be called for each report segment. Write to each segment to write a complete HID report.
See Also
Report Class
Report Members


Report Properties

Report Properties HIDSharp
The Report type exposes the following members.
Properties
 | Name | Description
Public property | ID | The Report ID.
Public property | Length | The length of this particular report. The Report ID is not included in this length.
Public property | Segments |
Public property | Type |
Back to Top
See Also
Report Class


ID Property

Report ID Property HIDSharp
The Report ID.

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public byte ID { get; set; }
public byte ID { get; set; }
Public Property ID As Byte
    Get
    Set
Public Property ID As Byte
    Get
    Set
public:
property unsigned char ID {
    unsigned char get ();
    void set (unsigned char value);
}
public:
property unsigned char ID {
    unsigned char get ();
    void set (unsigned char value);
}
member ID : byte with get, set
member ID : byte with get, set
See Also
Report Class
Report Members


Length Property

Report Length Property HIDSharp
The length of this particular report. The Report ID is not included in this length.

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Length { get; }
public int Length { get; }
Public ReadOnly Property Length As Integer
    Get
Public ReadOnly Property Length As Integer
    Get
public:
property int Length {
    int get ();
}
public:
property int Length {
    int get ();
}
member Length : int with get
member Length : int with get
See Also
Report Class
Report Members


Segments Property

Report Segments Property HIDSharp

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<ReportSegment> Segments { get; }
public IEnumerable<ReportSegment> Segments { get; }
Public ReadOnly Property Segments As IEnumerable(Of ReportSegment)
    Get
Public ReadOnly Property Segments As IEnumerable(Of ReportSegment)
    Get
public:
property IEnumerable<ReportSegment^>^ Segments {
    IEnumerable<ReportSegment^>^ get ();
}
public:
property IEnumerable<ReportSegment^>^ Segments {
    IEnumerable<ReportSegment^>^ get ();
}
member Segments : IEnumerable<ReportSegment> with get
member Segments : IEnumerable<ReportSegment> with get
See Also
Report Class
Report Members


Type Property

Report Type Property HIDSharp

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ReportType Type { get; set; }
public ReportType Type { get; set; }
Public Property Type As ReportType
    Get
    Set
Public Property Type As ReportType
    Get
    Set
public:
property ReportType Type {
    ReportType get ();
    void set (ReportType value);
}
public:
property ReportType Type {
    ReportType get ();
    void set (ReportType value);
}
member Type : ReportType with get, set
member Type : ReportType with get, set
See Also
Report Class
Report Members


ReportCollection Class

ReportCollection Class HIDSharp
Inheritance Hierarchy
Online System Object
HidSharp.ReportDescriptors.Parser ReportMainItem
HidSharp.ReportDescriptors.Parser ReportCollection

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ReportCollection : ReportMainItem
public class ReportCollection : ReportMainItem
Public Class ReportCollection _
    Inherits ReportMainItem
Public Class ReportCollection _
    Inherits ReportMainItem
public ref class ReportCollection : public ReportMainItem
public ref class ReportCollection : public ReportMainItem
type ReportCollection =
    class
        inherit ReportMainItem
    end
type ReportCollection =
    class
        inherit ReportMainItem
    end
See Also
ReportCollection Members


ReportCollection Members

ReportCollection Members HIDSharp

The ReportCollection type exposes the following members.
Constructors
 | Name | Description
Public method | ReportCollection | Initializes a new instance of the ReportCollection class
Back to Top
Methods
 | Name | Description
Public method | Clear |
Back to Top
Properties
 | Name | Description
Public property | Children |
Public property | Collections |
Public property | Indexes | (Inherited from ReportMainItem.)
Public property | Parent | (Inherited from ReportMainItem.)
Public property | Segments |
Public property | Type |
Back to Top
See Also
ReportCollection Class


ReportCollection Constructor

ReportCollection Constructor HIDSharp
Initializes a new instance of the ReportCollection class

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ReportCollection()
public ReportCollection()
Public Sub New
Public Sub New
public:
ReportCollection()
public:
ReportCollection()
new : unit -> ReportCollection
new : unit -> ReportCollection
See Also
ReportCollection Class
ReportCollection Members


ReportCollection Methods

ReportCollection Methods HIDSharp
The ReportCollection type exposes the following members.
Methods
 | Name | Description
Public method | Clear |
Back to Top
See Also
ReportCollection Class


Clear Method

ReportCollection Clear Method HIDSharp

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Clear()
public void Clear()
Public Sub Clear
Public Sub Clear
public:
void Clear()
public:
void Clear()
member Clear : unit -> unit
member Clear : unit -> unit
See Also
ReportCollection Class
ReportCollection Members


ReportCollection Properties

ReportCollection Properties HIDSharp
The ReportCollection type exposes the following members.
Properties
 | Name | Description
Public property | Children |
Public property | Collections |
Public property | Indexes | (Inherited from ReportMainItem.)
Public property | Parent | (Inherited from ReportMainItem.)
Public property | Segments |
Public property | Type |
Back to Top
See Also
ReportCollection Class


Children Property

ReportCollection Children Property HIDSharp

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<ReportMainItem> Children { get; }
public IEnumerable<ReportMainItem> Children { get; }
Public ReadOnly Property Children As IEnumerable(Of ReportMainItem)
    Get
Public ReadOnly Property Children As IEnumerable(Of ReportMainItem)
    Get
public:
property IEnumerable<ReportMainItem^>^ Children {
    IEnumerable<ReportMainItem^>^ get ();
}
public:
property IEnumerable<ReportMainItem^>^ Children {
    IEnumerable<ReportMainItem^>^ get ();
}
member Children : IEnumerable<ReportMainItem> with get
member Children : IEnumerable<ReportMainItem> with get
See Also
ReportCollection Class
ReportCollection Members


Collections Property

ReportCollection Collections Property HIDSharp

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<ReportCollection> Collections { get; }
public IEnumerable<ReportCollection> Collections { get; }
Public ReadOnly Property Collections As IEnumerable(Of ReportCollection)
    Get
Public ReadOnly Property Collections As IEnumerable(Of ReportCollection)
    Get
public:
property IEnumerable<ReportCollection^>^ Collections {
    IEnumerable<ReportCollection^>^ get ();
}
public:
property IEnumerable<ReportCollection^>^ Collections {
    IEnumerable<ReportCollection^>^ get ();
}
member Collections : IEnumerable<ReportCollection> with get
member Collections : IEnumerable<ReportCollection> with get
See Also
ReportCollection Class
ReportCollection Members


Segments Property

ReportCollection Segments Property HIDSharp

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<ReportSegment> Segments { get; }
public IEnumerable<ReportSegment> Segments { get; }
Public ReadOnly Property Segments As IEnumerable(Of ReportSegment)
    Get
Public ReadOnly Property Segments As IEnumerable(Of ReportSegment)
    Get
public:
property IEnumerable<ReportSegment^>^ Segments {
    IEnumerable<ReportSegment^>^ get ();
}
public:
property IEnumerable<ReportSegment^>^ Segments {
    IEnumerable<ReportSegment^>^ get ();
}
member Segments : IEnumerable<ReportSegment> with get
member Segments : IEnumerable<ReportSegment> with get
See Also
ReportCollection Class
ReportCollection Members


Type Property

ReportCollection Type Property HIDSharp

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CollectionType Type { get; set; }
public CollectionType Type { get; set; }
Public Property Type As CollectionType
    Get
    Set
Public Property Type As CollectionType
    Get
    Set
public:
property CollectionType Type {
    CollectionType get ();
    void set (CollectionType value);
}
public:
property CollectionType Type {
    CollectionType get ();
    void set (CollectionType value);
}
member Type : CollectionType with get, set
member Type : CollectionType with get, set
See Also
ReportCollection Class
ReportCollection Members


ReportDescriptorParser Class

ReportDescriptorParser Class HIDSharp
Parses HID report descriptors.
Inheritance Hierarchy
Online System Object
HidSharp.ReportDescriptors.Parser ReportDescriptorParser

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ReportDescriptorParser
public class ReportDescriptorParser
Public Class ReportDescriptorParser
Public Class ReportDescriptorParser
public ref class ReportDescriptorParser
public ref class ReportDescriptorParser
type ReportDescriptorParser =  class end
type ReportDescriptorParser =  class end
See Also
ReportDescriptorParser Members


ReportDescriptorParser Members

ReportDescriptorParser Members HIDSharp

The ReportDescriptorParser type exposes the following members.
Constructors
 | Name | Description
Public method | ReportDescriptorParser | Initializes a new instance of the ReportDescriptorParser class.
Back to Top
Methods
 | Name | Description
Public method | Clear | Resets the parser to its initial state.
Public method | GetGlobalItem |
Public method | GetGlobalItemValue |
Public method | GetReport |
Public method | IsGlobalItemSet |
Public method | Parse( Byte ) | Parses a raw HID report descriptor.
Public method | Parse(EncodedItem) | Parses a single EncodedItem. Call this repeatedly for every item to completely decode a report descriptor.
Public method | Parse(IEnumerable EncodedItem ) | Parses all of the EncodedItem elements in a report descriptor.
Public method | Parse( Byte , Int32, Int32) | Parses a raw HID report descriptor.
Public method | TryGetReport |
Back to Top
Properties
 | Name | Description
Public property | CurrentCollection |
Public property | FeatureReportMaxLength | The maximum feature report length. The Report ID is not included in this length.
Public property | FeatureReports |
Public property | GlobalItemState |
Public property | GlobalItemStateStack |
Public property | InputReportMaxLength | The maximum input report length. The Report ID is not included in this length.
Public property | InputReports |
Public property | InputUsages |
Public property | LocalItemState |
Public property | OutputReportMaxLength | The maximum output report length. The Report ID is not included in this length.
Public property | OutputReports |
Public property | Reports |
Public property | ReportsUseID | True if the device sends Report IDs.
Public property | RootCollection |
Back to Top
See Also
ReportDescriptorParser Class


ReportDescriptorParser Constructor

ReportDescriptorParser Constructor HIDSharp
Initializes a new instance of the ReportDescriptorParser class.

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ReportDescriptorParser()
public ReportDescriptorParser()
Public Sub New
Public Sub New
public:
ReportDescriptorParser()
public:
ReportDescriptorParser()
new : unit -> ReportDescriptorParser
new : unit -> ReportDescriptorParser
See Also
ReportDescriptorParser Class
ReportDescriptorParser Members


ReportDescriptorParser Methods

ReportDescriptorParser Methods HIDSharp
The ReportDescriptorParser type exposes the following members.
Methods
 | Name | Description
Public method | Clear | Resets the parser to its initial state.
Public method | GetGlobalItem |
Public method | GetGlobalItemValue |
Public method | GetReport |
Public method | IsGlobalItemSet |
Public method | Parse( Byte ) | Parses a raw HID report descriptor.
Public method | Parse(EncodedItem) | Parses a single EncodedItem. Call this repeatedly for every item to completely decode a report descriptor.
Public method | Parse(IEnumerable EncodedItem ) | Parses all of the EncodedItem elements in a report descriptor.
Public method | Parse( Byte , Int32, Int32) | Parses a raw HID report descriptor.
Public method | TryGetReport |
Back to Top
See Also
ReportDescriptorParser Class


Clear Method

ReportDescriptorParser Clear Method HIDSharp
Resets the parser to its initial state.

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Clear()
public void Clear()
Public Sub Clear
Public Sub Clear
public:
void Clear()
public:
void Clear()
member Clear : unit -> unit
member Clear : unit -> unit
See Also
ReportDescriptorParser Class
ReportDescriptorParser Members


GetGlobalItem Method

ReportDescriptorParser GetGlobalItem Method HIDSharp

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public EncodedItem GetGlobalItem(
    GlobalItemTag tag
)
public EncodedItem GetGlobalItem(
    GlobalItemTag tag
)
Public Function GetGlobalItem ( _
    tag As GlobalItemTag _
) As EncodedItem
Public Function GetGlobalItem ( _
    tag As GlobalItemTag _
) As EncodedItem
public:
EncodedItem^ GetGlobalItem(
    GlobalItemTag tag
)
public:
EncodedItem^ GetGlobalItem(
    GlobalItemTag tag
)
member GetGlobalItem :
        tag : GlobalItemTag -> EncodedItem
member GetGlobalItem :
        tag : GlobalItemTag -> EncodedItem

Parameters

tag
Type: HidSharp.ReportDescriptors GlobalItemTag
See Also
ReportDescriptorParser Class
ReportDescriptorParser Members


GetGlobalItemValue Method

ReportDescriptorParser GetGlobalItemValue Method HIDSharp

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public uint GetGlobalItemValue(
    GlobalItemTag tag
)
public uint GetGlobalItemValue(
    GlobalItemTag tag
)
Public Function GetGlobalItemValue ( _
    tag As GlobalItemTag _
) As UInteger
Public Function GetGlobalItemValue ( _
    tag As GlobalItemTag _
) As UInteger
public:
unsigned int GetGlobalItemValue(
    GlobalItemTag tag
)
public:
unsigned int GetGlobalItemValue(
    GlobalItemTag tag
)
member GetGlobalItemValue :
        tag : GlobalItemTag -> uint32
member GetGlobalItemValue :
        tag : GlobalItemTag -> uint32

Parameters

tag
Type: HidSharp.ReportDescriptors GlobalItemTag
See Also
ReportDescriptorParser Class
ReportDescriptorParser Members


GetReport Method

ReportDescriptorParser GetReport Method HIDSharp

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Report GetReport(
    ReportType type,
    byte id
)
public Report GetReport(
    ReportType type,
    byte id
)
Public Function GetReport ( _
    type As ReportType, _
    id As Byte _
) As Report
Public Function GetReport ( _
    type As ReportType, _
    id As Byte _
) As Report
public:
Report^ GetReport(
    ReportType type,
    unsigned char id
)
public:
Report^ GetReport(
    ReportType type,
    unsigned char id
)
member GetReport :
        type : ReportType *
        id : byte -> Report
member GetReport :
        type : ReportType *
        id : byte -> Report

Parameters

type
Type: HidSharp.ReportDescriptors.Parser ReportType
id
Type: Online System Byte
See Also
ReportDescriptorParser Class
ReportDescriptorParser Members


IsGlobalItemSet Method

ReportDescriptorParser IsGlobalItemSet Method HIDSharp

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsGlobalItemSet(
    GlobalItemTag tag
)
public bool IsGlobalItemSet(
    GlobalItemTag tag
)
Public Function IsGlobalItemSet ( _
    tag As GlobalItemTag _
) As Boolean
Public Function IsGlobalItemSet ( _
    tag As GlobalItemTag _
) As Boolean
public:
bool IsGlobalItemSet(
    GlobalItemTag tag
)
public:
bool IsGlobalItemSet(
    GlobalItemTag tag
)
member IsGlobalItemSet :
        tag : GlobalItemTag -> bool
member IsGlobalItemSet :
        tag : GlobalItemTag -> bool

Parameters

tag
Type: HidSharp.ReportDescriptors GlobalItemTag
See Also
ReportDescriptorParser Class
ReportDescriptorParser Members


Parse Method

ReportDescriptorParser Parse Method HIDSharp
Overload List
 | Name | Description
Public method | Parse( Byte ) | Parses a raw HID report descriptor.
Public method | Parse(EncodedItem) | Parses a single EncodedItem. Call this repeatedly for every item to completely decode a report descriptor.
Public method | Parse(IEnumerable EncodedItem ) | Parses all of the EncodedItem elements in a report descriptor.
Public method | Parse( Byte , Int32, Int32) | Parses a raw HID report descriptor.
Back to Top
See Also
ReportDescriptorParser Class
ReportDescriptorParser Members


Parse Method (Byte[])

ReportDescriptorParser Parse Method ( Byte ) HIDSharp
Parses a raw HID report descriptor.

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Parse(
    byte[] buffer
)
public void Parse(
    byte[] buffer
)
Public Sub Parse ( _
    buffer As Byte() _
)
Public Sub Parse ( _
    buffer As Byte() _
)
public:
void Parse(
    array<unsigned char>^ buffer
)
public:
void Parse(
    array<unsigned char>^ buffer
)
member Parse :
        buffer : byte[] -> unit
member Parse :
        buffer : byte[] -> unit

Parameters

buffer
Type: Online System Byte
The buffer containing the report descriptor.
See Also
ReportDescriptorParser Class
ReportDescriptorParser Members
Parse Overload


Parse Method (EncodedItem)

ReportDescriptorParser Parse Method (EncodedItem) HIDSharp
Parses a single EncodedItem. Call this repeatedly for every item to completely decode a report descriptor.

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Parse(
    EncodedItem item
)
public void Parse(
    EncodedItem item
)
Public Sub Parse ( _
    item As EncodedItem _
)
Public Sub Parse ( _
    item As EncodedItem _
)
public:
void Parse(
    EncodedItem^ item
)
public:
void Parse(
    EncodedItem^ item
)
member Parse :
        item : EncodedItem -> unit
member Parse :
        item : EncodedItem -> unit

Parameters

item
Type: HidSharp.ReportDescriptors EncodedItem
The item to parse.
See Also
ReportDescriptorParser Class
ReportDescriptorParser Members
Parse Overload


Parse Method (IEnumerable(EncodedItem))

ReportDescriptorParser Parse Method (IEnumerable EncodedItem ) HIDSharp
Parses all of the EncodedItem elements in a report descriptor.

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Parse(
    IEnumerable<EncodedItem> items
)
public void Parse(
    IEnumerable<EncodedItem> items
)
Public Sub Parse ( _
    items As IEnumerable(Of EncodedItem) _
)
Public Sub Parse ( _
    items As IEnumerable(Of EncodedItem) _
)
public:
void Parse(
    IEnumerable<EncodedItem^>^ items
)
public:
void Parse(
    IEnumerable<EncodedItem^>^ items
)
member Parse :
        items : IEnumerable<EncodedItem> -> unit
member Parse :
        items : IEnumerable<EncodedItem> -> unit

Parameters

items
Type: Online System.Collections.Generic IEnumerable EncodedItem
The items to parse.
See Also
ReportDescriptorParser Class
ReportDescriptorParser Members
Parse Overload


Parse Method (Byte[], Int32, Int32)

ReportDescriptorParser Parse Method ( Byte , Int32, Int32) HIDSharp
Parses a raw HID report descriptor.

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Parse(
    byte[] buffer,
    int offset,
    int count
)
public void Parse(
    byte[] buffer,
    int offset,
    int count
)
Public Sub Parse ( _
    buffer As Byte(), _
    offset As Integer, _
    count As Integer _
)
Public Sub Parse ( _
    buffer As Byte(), _
    offset As Integer, _
    count As Integer _
)
public:
void Parse(
    array<unsigned char>^ buffer,
    int offset,
    int count
)
public:
void Parse(
    array<unsigned char>^ buffer,
    int offset,
    int count
)
member Parse :
        buffer : byte[] *
        offset : int *
        count : int -> unit
member Parse :
        buffer : byte[] *
        offset : int *
        count : int -> unit

Parameters

buffer
Type: Online System Byte
The buffer containing the report descriptor.
offset
Type: Online System Int32
The offset into the buffer to begin parsing from.
count
Type: Online System Int32
The number of bytes to parse.
See Also
ReportDescriptorParser Class
ReportDescriptorParser Members
Parse Overload


TryGetReport Method

ReportDescriptorParser TryGetReport Method HIDSharp

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool TryGetReport(
    ReportType type,
    byte id,
    out Report report
)
public bool TryGetReport(
    ReportType type,
    byte id,
    out Report report
)
Public Function TryGetReport ( _
    type As ReportType, _
    id As Byte, _
    <OutAttribute> ByRef report As Report _
) As Boolean
Public Function TryGetReport ( _
    type As ReportType, _
    id As Byte, _
    <OutAttribute> ByRef report As Report _
) As Boolean
public:
bool TryGetReport(
    ReportType type,
    unsigned char id,
    [OutAttribute] Report^% report
)
public:
bool TryGetReport(
    ReportType type,
    unsigned char id,
    [OutAttribute] Report^% report
)
member TryGetReport :
        type : ReportType *
        id : byte *
        report : Report byref -> bool
member TryGetReport :
        type : ReportType *
        id : byte *
        report : Report byref -> bool

Parameters

type
Type: HidSharp.ReportDescriptors.Parser ReportType
id
Type: Online System Byte
report
Type: HidSharp.ReportDescriptors.Parser Report
See Also
ReportDescriptorParser Class
ReportDescriptorParser Members


ReportDescriptorParser Properties

ReportDescriptorParser Properties HIDSharp
The ReportDescriptorParser type exposes the following members.
Properties
 | Name | Description
Public property | CurrentCollection |
Public property | FeatureReportMaxLength | The maximum feature report length. The Report ID is not included in this length.
Public property | FeatureReports |
Public property | GlobalItemState |
Public property | GlobalItemStateStack |
Public property | InputReportMaxLength | The maximum input report length. The Report ID is not included in this length.
Public property | InputReports |
Public property | InputUsages |
Public property | LocalItemState |
Public property | OutputReportMaxLength | The maximum output report length. The Report ID is not included in this length.
Public property | OutputReports |
Public property | Reports |
Public property | ReportsUseID | True if the device sends Report IDs.
Public property | RootCollection |
Back to Top
See Also
ReportDescriptorParser Class


CurrentCollection Property

ReportDescriptorParser CurrentCollection Property HIDSharp

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ReportCollection CurrentCollection { get; set; }
public ReportCollection CurrentCollection { get; set; }
Public Property CurrentCollection As ReportCollection
    Get
    Set
Public Property CurrentCollection As ReportCollection
    Get
    Set
public:
property ReportCollection^ CurrentCollection {
    ReportCollection^ get ();
    void set (ReportCollection^ value);
}
public:
property ReportCollection^ CurrentCollection {
    ReportCollection^ get ();
    void set (ReportCollection^ value);
}
member CurrentCollection : ReportCollection with get, set
member CurrentCollection : ReportCollection with get, set
See Also
ReportDescriptorParser Class
ReportDescriptorParser Members


FeatureReportMaxLength Property

ReportDescriptorParser FeatureReportMaxLength Property HIDSharp
The maximum feature report length. The Report ID is not included in this length.

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int FeatureReportMaxLength { get; }
public int FeatureReportMaxLength { get; }
Public ReadOnly Property FeatureReportMaxLength As Integer
    Get
Public ReadOnly Property FeatureReportMaxLength As Integer
    Get
public:
property int FeatureReportMaxLength {
    int get ();
}
public:
property int FeatureReportMaxLength {
    int get ();
}
member FeatureReportMaxLength : int with get
member FeatureReportMaxLength : int with get
See Also
ReportDescriptorParser Class
ReportDescriptorParser Members


FeatureReports Property

ReportDescriptorParser FeatureReports Property HIDSharp

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<Report> FeatureReports { get; }
public IEnumerable<Report> FeatureReports { get; }
Public ReadOnly Property FeatureReports As IEnumerable(Of Report)
    Get
Public ReadOnly Property FeatureReports As IEnumerable(Of Report)
    Get
public:
property IEnumerable<Report^>^ FeatureReports {
    IEnumerable<Report^>^ get ();
}
public:
property IEnumerable<Report^>^ FeatureReports {
    IEnumerable<Report^>^ get ();
}
member FeatureReports : IEnumerable<Report> with get
member FeatureReports : IEnumerable<Report> with get
See Also
ReportDescriptorParser Class
ReportDescriptorParser Members


GlobalItemState Property

ReportDescriptorParser GlobalItemState Property HIDSharp

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IDictionary<GlobalItemTag, EncodedItem> GlobalItemState { get; }
public IDictionary<GlobalItemTag, EncodedItem> GlobalItemState { get; }
Public ReadOnly Property GlobalItemState As IDictionary(Of GlobalItemTag, EncodedItem)
    Get
Public ReadOnly Property GlobalItemState As IDictionary(Of GlobalItemTag, EncodedItem)
    Get
public:
property IDictionary<GlobalItemTag, EncodedItem^>^ GlobalItemState {
    IDictionary<GlobalItemTag, EncodedItem^>^ get ();
}
public:
property IDictionary<GlobalItemTag, EncodedItem^>^ GlobalItemState {
    IDictionary<GlobalItemTag, EncodedItem^>^ get ();
}
member GlobalItemState : IDictionary<GlobalItemTag, EncodedItem> with get
member GlobalItemState : IDictionary<GlobalItemTag, EncodedItem> with get
See Also
ReportDescriptorParser Class
ReportDescriptorParser Members


GlobalItemStateStack Property

ReportDescriptorParser GlobalItemStateStack Property HIDSharp

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IList<IDictionary<GlobalItemTag, EncodedItem>> GlobalItemStateStack { get; private set; }
public IList<IDictionary<GlobalItemTag, EncodedItem>> GlobalItemStateStack { get; private set; }
Public Property GlobalItemStateStack As IList(Of IDictionary(Of GlobalItemTag, EncodedItem))
    Get
    Private Set
Public Property GlobalItemStateStack As IList(Of IDictionary(Of GlobalItemTag, EncodedItem))
    Get
    Private Set
public:
property IList<IDictionary<GlobalItemTag, EncodedItem^>^>^ GlobalItemStateStack {
    IList<IDictionary<GlobalItemTag, EncodedItem^>^>^ get ();
    private: void set (IList<IDictionary<GlobalItemTag, EncodedItem^>^>^ value);
}
public:
property IList<IDictionary<GlobalItemTag, EncodedItem^>^>^ GlobalItemStateStack {
    IList<IDictionary<GlobalItemTag, EncodedItem^>^>^ get ();
    private: void set (IList<IDictionary<GlobalItemTag, EncodedItem^>^>^ value);
}
member GlobalItemStateStack : IList<IDictionary<GlobalItemTag, EncodedItem>> with get, private set
member GlobalItemStateStack : IList<IDictionary<GlobalItemTag, EncodedItem>> with get, private set
See Also
ReportDescriptorParser Class
ReportDescriptorParser Members


InputReportMaxLength Property

ReportDescriptorParser InputReportMaxLength Property HIDSharp
The maximum input report length. The Report ID is not included in this length.

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int InputReportMaxLength { get; }
public int InputReportMaxLength { get; }
Public ReadOnly Property InputReportMaxLength As Integer
    Get
Public ReadOnly Property InputReportMaxLength As Integer
    Get
public:
property int InputReportMaxLength {
    int get ();
}
public:
property int InputReportMaxLength {
    int get ();
}
member InputReportMaxLength : int with get
member InputReportMaxLength : int with get
See Also
ReportDescriptorParser Class
ReportDescriptorParser Members


InputReports Property

ReportDescriptorParser InputReports Property HIDSharp

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<Report> InputReports { get; }
public IEnumerable<Report> InputReports { get; }
Public ReadOnly Property InputReports As IEnumerable(Of Report)
    Get
Public ReadOnly Property InputReports As IEnumerable(Of Report)
    Get
public:
property IEnumerable<Report^>^ InputReports {
    IEnumerable<Report^>^ get ();
}
public:
property IEnumerable<Report^>^ InputReports {
    IEnumerable<Report^>^ get ();
}
member InputReports : IEnumerable<Report> with get
member InputReports : IEnumerable<Report> with get
See Also
ReportDescriptorParser Class
ReportDescriptorParser Members


InputUsages Property

ReportDescriptorParser InputUsages Property HIDSharp

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<IEnumerable<uint>> InputUsages { get; }
public IEnumerable<IEnumerable<uint>> InputUsages { get; }
Public ReadOnly Property InputUsages As IEnumerable(Of IEnumerable(Of UInteger))
    Get
Public ReadOnly Property InputUsages As IEnumerable(Of IEnumerable(Of UInteger))
    Get
public:
property IEnumerable<IEnumerable<unsigned int>^>^ InputUsages {
    IEnumerable<IEnumerable<unsigned int>^>^ get ();
}
public:
property IEnumerable<IEnumerable<unsigned int>^>^ InputUsages {
    IEnumerable<IEnumerable<unsigned int>^>^ get ();
}
member InputUsages : IEnumerable<IEnumerable<uint32>> with get
member InputUsages : IEnumerable<IEnumerable<uint32>> with get
See Also
ReportDescriptorParser Class
ReportDescriptorParser Members


LocalItemState Property

ReportDescriptorParser LocalItemState Property HIDSharp

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IList<KeyValuePair<LocalItemTag, uint>> LocalItemState { get; private set; }
public IList<KeyValuePair<LocalItemTag, uint>> LocalItemState { get; private set; }
Public Property LocalItemState As IList(Of KeyValuePair(Of LocalItemTag, UInteger))
    Get
    Private Set
Public Property LocalItemState As IList(Of KeyValuePair(Of LocalItemTag, UInteger))
    Get
    Private Set
public:
property IList<KeyValuePair<LocalItemTag, unsigned int>>^ LocalItemState {
    IList<KeyValuePair<LocalItemTag, unsigned int>>^ get ();
    private: void set (IList<KeyValuePair<LocalItemTag, unsigned int>>^ value);
}
public:
property IList<KeyValuePair<LocalItemTag, unsigned int>>^ LocalItemState {
    IList<KeyValuePair<LocalItemTag, unsigned int>>^ get ();
    private: void set (IList<KeyValuePair<LocalItemTag, unsigned int>>^ value);
}
member LocalItemState : IList<KeyValuePair<LocalItemTag, uint32>> with get, private set
member LocalItemState : IList<KeyValuePair<LocalItemTag, uint32>> with get, private set
See Also
ReportDescriptorParser Class
ReportDescriptorParser Members


OutputReportMaxLength Property

ReportDescriptorParser OutputReportMaxLength Property HIDSharp
The maximum output report length. The Report ID is not included in this length.

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int OutputReportMaxLength { get; }
public int OutputReportMaxLength { get; }
Public ReadOnly Property OutputReportMaxLength As Integer
    Get
Public ReadOnly Property OutputReportMaxLength As Integer
    Get
public:
property int OutputReportMaxLength {
    int get ();
}
public:
property int OutputReportMaxLength {
    int get ();
}
member OutputReportMaxLength : int with get
member OutputReportMaxLength : int with get
See Also
ReportDescriptorParser Class
ReportDescriptorParser Members


OutputReports Property

ReportDescriptorParser OutputReports Property HIDSharp

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerable<Report> OutputReports { get; }
public IEnumerable<Report> OutputReports { get; }
Public ReadOnly Property OutputReports As IEnumerable(Of Report)
    Get
Public ReadOnly Property OutputReports As IEnumerable(Of Report)
    Get
public:
property IEnumerable<Report^>^ OutputReports {
    IEnumerable<Report^>^ get ();
}
public:
property IEnumerable<Report^>^ OutputReports {
    IEnumerable<Report^>^ get ();
}
member OutputReports : IEnumerable<Report> with get
member OutputReports : IEnumerable<Report> with get
See Also
ReportDescriptorParser Class
ReportDescriptorParser Members


Reports Property

ReportDescriptorParser Reports Property HIDSharp

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IList<Report> Reports { get; private set; }
public IList<Report> Reports { get; private set; }
Public Property Reports As IList(Of Report)
    Get
    Private Set
Public Property Reports As IList(Of Report)
    Get
    Private Set
public:
property IList<Report^>^ Reports {
    IList<Report^>^ get ();
    private: void set (IList<Report^>^ value);
}
public:
property IList<Report^>^ Reports {
    IList<Report^>^ get ();
    private: void set (IList<Report^>^ value);
}
member Reports : IList<Report> with get, private set
member Reports : IList<Report> with get, private set
See Also
ReportDescriptorParser Class
ReportDescriptorParser Members


ReportsUseID Property

ReportDescriptorParser ReportsUseID Property HIDSharp
True if the device sends Report IDs.

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ReportsUseID { get; set; }
public bool ReportsUseID { get; set; }
Public Property ReportsUseID As Boolean
    Get
    Set
Public Property ReportsUseID As Boolean
    Get
    Set
public:
property bool ReportsUseID {
    bool get ();
    void set (bool value);
}
public:
property bool ReportsUseID {
    bool get ();
    void set (bool value);
}
member ReportsUseID : bool with get, set
member ReportsUseID : bool with get, set
See Also
ReportDescriptorParser Class
ReportDescriptorParser Members


RootCollection Property

ReportDescriptorParser RootCollection Property HIDSharp

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ReportCollection RootCollection { get; private set; }
public ReportCollection RootCollection { get; private set; }
Public Property RootCollection As ReportCollection
    Get
    Private Set
Public Property RootCollection As ReportCollection
    Get
    Private Set
public:
property ReportCollection^ RootCollection {
    ReportCollection^ get ();
    private: void set (ReportCollection^ value);
}
public:
property ReportCollection^ RootCollection {
    ReportCollection^ get ();
    private: void set (ReportCollection^ value);
}
member RootCollection : ReportCollection with get, private set
member RootCollection : ReportCollection with get, private set
See Also
ReportDescriptorParser Class
ReportDescriptorParser Members


ReportMainItem Class

ReportMainItem Class HIDSharp
Inheritance Hierarchy
Online System Object
HidSharp.ReportDescriptors.Parser ReportMainItem
HidSharp.ReportDescriptors.Parser ReportCollection
HidSharp.ReportDescriptors.Parser ReportSegment

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ReportMainItem
public class ReportMainItem
Public Class ReportMainItem
Public Class ReportMainItem
public ref class ReportMainItem
public ref class ReportMainItem
type ReportMainItem =  class end
type ReportMainItem =  class end
See Also
ReportMainItem Members


ReportMainItem Members

ReportMainItem Members HIDSharp

The ReportMainItem type exposes the following members.
Constructors
 | Name | Description
Public method | ReportMainItem | Initializes a new instance of the ReportMainItem class
Back to Top
Properties
 | Name | Description
Public property | Indexes |
Public property | Parent |
Back to Top
See Also
ReportMainItem Class


ReportMainItem Constructor

ReportMainItem Constructor HIDSharp
Initializes a new instance of the ReportMainItem class

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ReportMainItem()
public ReportMainItem()
Public Sub New
Public Sub New
public:
ReportMainItem()
public:
ReportMainItem()
new : unit -> ReportMainItem
new : unit -> ReportMainItem
See Also
ReportMainItem Class
ReportMainItem Members


ReportMainItem Properties

ReportMainItem Properties HIDSharp
The ReportMainItem type exposes the following members.
Properties
 | Name | Description
Public property | Indexes |
Public property | Parent |
Back to Top
See Also
ReportMainItem Class


Indexes Property

ReportMainItem Indexes Property HIDSharp

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LocalIndexes Indexes { get; private set; }
public LocalIndexes Indexes { get; private set; }
Public Property Indexes As LocalIndexes
    Get
    Private Set
Public Property Indexes As LocalIndexes
    Get
    Private Set
public:
property LocalIndexes^ Indexes {
    LocalIndexes^ get ();
    private: void set (LocalIndexes^ value);
}
public:
property LocalIndexes^ Indexes {
    LocalIndexes^ get ();
    private: void set (LocalIndexes^ value);
}
member Indexes : LocalIndexes with get, private set
member Indexes : LocalIndexes with get, private set
See Also
ReportMainItem Class
ReportMainItem Members


Parent Property

ReportMainItem Parent Property HIDSharp

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ReportCollection Parent { get; set; }
public ReportCollection Parent { get; set; }
Public Property Parent As ReportCollection
    Get
    Set
Public Property Parent As ReportCollection
    Get
    Set
public:
property ReportCollection^ Parent {
    ReportCollection^ get ();
    void set (ReportCollection^ value);
}
public:
property ReportCollection^ Parent {
    ReportCollection^ get ();
    void set (ReportCollection^ value);
}
member Parent : ReportCollection with get, set
member Parent : ReportCollection with get, set
See Also
ReportMainItem Class
ReportMainItem Members


ReportScanCallback Delegate

ReportScanCallback Delegate HIDSharp

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public delegate void ReportScanCallback(
    byte[] buffer,
    int bitOffset,
    ReportSegment segment
)
public delegate void ReportScanCallback(
    byte[] buffer,
    int bitOffset,
    ReportSegment segment
)
Public Delegate Sub ReportScanCallback ( _
    buffer As Byte(), _
    bitOffset As Integer, _
    segment As ReportSegment _
)
Public Delegate Sub ReportScanCallback ( _
    buffer As Byte(), _
    bitOffset As Integer, _
    segment As ReportSegment _
)
public delegate void ReportScanCallback(
    array<unsigned char>^ buffer,
    int bitOffset,
    ReportSegment^ segment
)
public delegate void ReportScanCallback(
    array<unsigned char>^ buffer,
    int bitOffset,
    ReportSegment^ segment
)
type ReportScanCallback =
    delegate of
        buffer : byte[] *
        bitOffset : int *
        segment : ReportSegment -> unit
type ReportScanCallback =
    delegate of
        buffer : byte[] *
        bitOffset : int *
        segment : ReportSegment -> unit

Parameters

buffer
Type: Online System Byte
bitOffset
Type: Online System Int32
segment
Type: HidSharp.ReportDescriptors.Parser ReportSegment
See Also


ReportSegment Class

ReportSegment Class HIDSharp
Inheritance Hierarchy
Online System Object
HidSharp.ReportDescriptors.Parser ReportMainItem
HidSharp.ReportDescriptors.Parser ReportSegment

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ReportSegment : ReportMainItem
public class ReportSegment : ReportMainItem
Public Class ReportSegment _
    Inherits ReportMainItem
Public Class ReportSegment _
    Inherits ReportMainItem
public ref class ReportSegment : public ReportMainItem
public ref class ReportSegment : public ReportMainItem
type ReportSegment =
    class
        inherit ReportMainItem
    end
type ReportSegment =
    class
        inherit ReportMainItem
    end
See Also
ReportSegment Members


ReportSegment Members

ReportSegment Members HIDSharp

The ReportSegment type exposes the following members.
Constructors
 | Name | Description
Public method | ReportSegment | Initializes a new instance of the ReportSegment class
Back to Top
Methods
 | Name | Description
Public method | ConvertArbitraryRangeToValue |
Public method | ConvertPhysicalQuantityToValue |
Public method | ConvertValueToArbitraryRange |
Public method | ConvertValueToPhysicalQuantity |
Public method | DecodeSigned |
Public method | EncodeSigned |
Public method | IsValueOutOfRange |
Public method | Read |
Public method | ReadRaw |
Public method | Write |
Public method | WriteRaw |
Back to Top
Properties
 | Name | Description
Public property | BitCount |
Public property | ElementCount |
Public property | ElementSize |
Public property | Flags |
Public property | Indexes | (Inherited from ReportMainItem.)
Public property | LogicalIsSigned |
Public property | LogicalMaximum |
Public property | LogicalMinimum |
Public property | LogicalRange |
Public property | Parent | (Inherited from ReportMainItem.)
Public property | PhysicalMaximum |
Public property | PhysicalMinimum |
Public property | PhysicalRange |
Public property | Report |
Public property | Resolution |
Public property | Unit |
Public property | UnitExponent |
Back to Top
See Also
ReportSegment Class


ReportSegment Constructor

ReportSegment Constructor HIDSharp
Initializes a new instance of the ReportSegment class

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ReportSegment()
public ReportSegment()
Public Sub New
Public Sub New
public:
ReportSegment()
public:
ReportSegment()
new : unit -> ReportSegment
new : unit -> ReportSegment
See Also
ReportSegment Class
ReportSegment Members


ReportSegment Methods

ReportSegment Methods HIDSharp
The ReportSegment type exposes the following members.
Methods
 | Name | Description
Public method | ConvertArbitraryRangeToValue |
Public method | ConvertPhysicalQuantityToValue |
Public method | ConvertValueToArbitraryRange |
Public method | ConvertValueToPhysicalQuantity |
Public method | DecodeSigned |
Public method | EncodeSigned |
Public method | IsValueOutOfRange |
Public method | Read |
Public method | ReadRaw |
Public method | Write |
Public method | WriteRaw |
Back to Top
See Also
ReportSegment Class


ConvertArbitraryRangeToValue Method

ReportSegment ConvertArbitraryRangeToValue Method HIDSharp

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int ConvertArbitraryRangeToValue(
    double quantity,
    double minimum,
    double maximum
)
public int ConvertArbitraryRangeToValue(
    double quantity,
    double minimum,
    double maximum
)
Public Function ConvertArbitraryRangeToValue ( _
    quantity As Double, _
    minimum As Double, _
    maximum As Double _
) As Integer
Public Function ConvertArbitraryRangeToValue ( _
    quantity As Double, _
    minimum As Double, _
    maximum As Double _
) As Integer
public:
int ConvertArbitraryRangeToValue(
    double quantity,
    double minimum,
    double maximum
)
public:
int ConvertArbitraryRangeToValue(
    double quantity,
    double minimum,
    double maximum
)
member ConvertArbitraryRangeToValue :
        quantity : float *
        minimum : float *
        maximum : float -> int
member ConvertArbitraryRangeToValue :
        quantity : float *
        minimum : float *
        maximum : float -> int

Parameters

quantity
Type: Online System Double
minimum
Type: Online System Double
maximum
Type: Online System Double
See Also
ReportSegment Class
ReportSegment Members


ConvertPhysicalQuantityToValue Method

ReportSegment ConvertPhysicalQuantityToValue Method HIDSharp

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int ConvertPhysicalQuantityToValue(
    double quantity
)
public int ConvertPhysicalQuantityToValue(
    double quantity
)
Public Function ConvertPhysicalQuantityToValue ( _
    quantity As Double _
) As Integer
Public Function ConvertPhysicalQuantityToValue ( _
    quantity As Double _
) As Integer
public:
int ConvertPhysicalQuantityToValue(
    double quantity
)
public:
int ConvertPhysicalQuantityToValue(
    double quantity
)
member ConvertPhysicalQuantityToValue :
        quantity : float -> int
member ConvertPhysicalQuantityToValue :
        quantity : float -> int

Parameters

quantity
Type: Online System Double
See Also
ReportSegment Class
ReportSegment Members


ConvertValueToArbitraryRange Method

ReportSegment ConvertValueToArbitraryRange Method HIDSharp

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double ConvertValueToArbitraryRange(
    int value,
    double minimum,
    double maximum
)
public double ConvertValueToArbitraryRange(
    int value,
    double minimum,
    double maximum
)
Public Function ConvertValueToArbitraryRange ( _
    value As Integer, _
    minimum As Double, _
    maximum As Double _
) As Double
Public Function ConvertValueToArbitraryRange ( _
    value As Integer, _
    minimum As Double, _
    maximum As Double _
) As Double
public:
double ConvertValueToArbitraryRange(
    int value,
    double minimum,
    double maximum
)
public:
double ConvertValueToArbitraryRange(
    int value,
    double minimum,
    double maximum
)
member ConvertValueToArbitraryRange :
        value : int *
        minimum : float *
        maximum : float -> float
member ConvertValueToArbitraryRange :
        value : int *
        minimum : float *
        maximum : float -> float

Parameters

value
Type: Online System Int32
minimum
Type: Online System Double
maximum
Type: Online System Double
See Also
ReportSegment Class
ReportSegment Members


ConvertValueToPhysicalQuantity Method

ReportSegment ConvertValueToPhysicalQuantity Method HIDSharp

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double ConvertValueToPhysicalQuantity(
    int value
)
public double ConvertValueToPhysicalQuantity(
    int value
)
Public Function ConvertValueToPhysicalQuantity ( _
    value As Integer _
) As Double
Public Function ConvertValueToPhysicalQuantity ( _
    value As Integer _
) As Double
public:
double ConvertValueToPhysicalQuantity(
    int value
)
public:
double ConvertValueToPhysicalQuantity(
    int value
)
member ConvertValueToPhysicalQuantity :
        value : int -> float
member ConvertValueToPhysicalQuantity :
        value : int -> float

Parameters

value
Type: Online System Int32
See Also
ReportSegment Class
ReportSegment Members


DecodeSigned Method

ReportSegment DecodeSigned Method HIDSharp

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int DecodeSigned(
    uint value
)
public int DecodeSigned(
    uint value
)
Public Function DecodeSigned ( _
    value As UInteger _
) As Integer
Public Function DecodeSigned ( _
    value As UInteger _
) As Integer
public:
int DecodeSigned(
    unsigned int value
)
public:
int DecodeSigned(
    unsigned int value
)
member DecodeSigned :
        value : uint32 -> int
member DecodeSigned :
        value : uint32 -> int

Parameters

value
Type: Online System UInt32
See Also
ReportSegment Class
ReportSegment Members


EncodeSigned Method

ReportSegment EncodeSigned Method HIDSharp

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public uint EncodeSigned(
    int value
)
public uint EncodeSigned(
    int value
)
Public Function EncodeSigned ( _
    value As Integer _
) As UInteger
Public Function EncodeSigned ( _
    value As Integer _
) As UInteger
public:
unsigned int EncodeSigned(
    int value
)
public:
unsigned int EncodeSigned(
    int value
)
member EncodeSigned :
        value : int -> uint32
member EncodeSigned :
        value : int -> uint32

Parameters

value
Type: Online System Int32
See Also
ReportSegment Class
ReportSegment Members


IsValueOutOfRange Method

ReportSegment IsValueOutOfRange Method HIDSharp

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsValueOutOfRange(
    int value
)
public bool IsValueOutOfRange(
    int value
)
Public Function IsValueOutOfRange ( _
    value As Integer _
) As Boolean
Public Function IsValueOutOfRange ( _
    value As Integer _
) As Boolean
public:
bool IsValueOutOfRange(
    int value
)
public:
bool IsValueOutOfRange(
    int value
)
member IsValueOutOfRange :
        value : int -> bool
member IsValueOutOfRange :
        value : int -> bool

Parameters

value
Type: Online System Int32
See Also
ReportSegment Class
ReportSegment Members


Read Method

ReportSegment Read Method HIDSharp

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Read(
    byte[] buffer,
    int bitOffset,
    int element
)
public int Read(
    byte[] buffer,
    int bitOffset,
    int element
)
Public Function Read ( _
    buffer As Byte(), _
    bitOffset As Integer, _
    element As Integer _
) As Integer
Public Function Read ( _
    buffer As Byte(), _
    bitOffset As Integer, _
    element As Integer _
) As Integer
public:
int Read(
    array<unsigned char>^ buffer,
    int bitOffset,
    int element
)
public:
int Read(
    array<unsigned char>^ buffer,
    int bitOffset,
    int element
)
member Read :
        buffer : byte[] *
        bitOffset : int *
        element : int -> int
member Read :
        buffer : byte[] *
        bitOffset : int *
        element : int -> int

Parameters

buffer
Type: Online System Byte
bitOffset
Type: Online System Int32
element
Type: Online System Int32
See Also
ReportSegment Class
ReportSegment Members


ReadRaw Method

ReportSegment ReadRaw Method HIDSharp

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public uint ReadRaw(
    byte[] buffer,
    int bitOffset,
    int element
)
public uint ReadRaw(
    byte[] buffer,
    int bitOffset,
    int element
)
Public Function ReadRaw ( _
    buffer As Byte(), _
    bitOffset As Integer, _
    element As Integer _
) As UInteger
Public Function ReadRaw ( _
    buffer As Byte(), _
    bitOffset As Integer, _
    element As Integer _
) As UInteger
public:
unsigned int ReadRaw(
    array<unsigned char>^ buffer,
    int bitOffset,
    int element
)
public:
unsigned int ReadRaw(
    array<unsigned char>^ buffer,
    int bitOffset,
    int element
)
member ReadRaw :
        buffer : byte[] *
        bitOffset : int *
        element : int -> uint32
member ReadRaw :
        buffer : byte[] *
        bitOffset : int *
        element : int -> uint32

Parameters

buffer
Type: Online System Byte
bitOffset
Type: Online System Int32
element
Type: Online System Int32
See Also
ReportSegment Class
ReportSegment Members


Write Method

ReportSegment Write Method HIDSharp

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Write(
    byte[] buffer,
    int bitOffset,
    int element,
    int value
)
public void Write(
    byte[] buffer,
    int bitOffset,
    int element,
    int value
)
Public Sub Write ( _
    buffer As Byte(), _
    bitOffset As Integer, _
    element As Integer, _
    value As Integer _
)
Public Sub Write ( _
    buffer As Byte(), _
    bitOffset As Integer, _
    element As Integer, _
    value As Integer _
)
public:
void Write(
    array<unsigned char>^ buffer,
    int bitOffset,
    int element,
    int value
)
public:
void Write(
    array<unsigned char>^ buffer,
    int bitOffset,
    int element,
    int value
)
member Write :
        buffer : byte[] *
        bitOffset : int *
        element : int *
        value : int -> unit
member Write :
        buffer : byte[] *
        bitOffset : int *
        element : int *
        value : int -> unit

Parameters

buffer
Type: Online System Byte
bitOffset
Type: Online System Int32
element
Type: Online System Int32
value
Type: Online System Int32
See Also
ReportSegment Class
ReportSegment Members


WriteRaw Method

ReportSegment WriteRaw Method HIDSharp

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void WriteRaw(
    byte[] buffer,
    int bitOffset,
    int element,
    uint value
)
public void WriteRaw(
    byte[] buffer,
    int bitOffset,
    int element,
    uint value
)
Public Sub WriteRaw ( _
    buffer As Byte(), _
    bitOffset As Integer, _
    element As Integer, _
    value As UInteger _
)
Public Sub WriteRaw ( _
    buffer As Byte(), _
    bitOffset As Integer, _
    element As Integer, _
    value As UInteger _
)
public:
void WriteRaw(
    array<unsigned char>^ buffer,
    int bitOffset,
    int element,
    unsigned int value
)
public:
void WriteRaw(
    array<unsigned char>^ buffer,
    int bitOffset,
    int element,
    unsigned int value
)
member WriteRaw :
        buffer : byte[] *
        bitOffset : int *
        element : int *
        value : uint32 -> unit
member WriteRaw :
        buffer : byte[] *
        bitOffset : int *
        element : int *
        value : uint32 -> unit

Parameters

buffer
Type: Online System Byte
bitOffset
Type: Online System Int32
element
Type: Online System Int32
value
Type: Online System UInt32
See Also
ReportSegment Class
ReportSegment Members


ReportSegment Properties

ReportSegment Properties HIDSharp
The ReportSegment type exposes the following members.
Properties
 | Name | Description
Public property | BitCount |
Public property | ElementCount |
Public property | ElementSize |
Public property | Flags |
Public property | Indexes | (Inherited from ReportMainItem.)
Public property | LogicalIsSigned |
Public property | LogicalMaximum |
Public property | LogicalMinimum |
Public property | LogicalRange |
Public property | Parent | (Inherited from ReportMainItem.)
Public property | PhysicalMaximum |
Public property | PhysicalMinimum |
Public property | PhysicalRange |
Public property | Report |
Public property | Resolution |
Public property | Unit |
Public property | UnitExponent |
Back to Top
See Also
ReportSegment Class


BitCount Property

ReportSegment BitCount Property HIDSharp

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int BitCount { get; }
public int BitCount { get; }
Public ReadOnly Property BitCount As Integer
    Get
Public ReadOnly Property BitCount As Integer
    Get
public:
property int BitCount {
    int get ();
}
public:
property int BitCount {
    int get ();
}
member BitCount : int with get
member BitCount : int with get
See Also
ReportSegment Class
ReportSegment Members


ElementCount Property

ReportSegment ElementCount Property HIDSharp

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int ElementCount { get; set; }
public int ElementCount { get; set; }
Public Property ElementCount As Integer
    Get
    Set
Public Property ElementCount As Integer
    Get
    Set
public:
property int ElementCount {
    int get ();
    void set (int value);
}
public:
property int ElementCount {
    int get ();
    void set (int value);
}
member ElementCount : int with get, set
member ElementCount : int with get, set
See Also
ReportSegment Class
ReportSegment Members


ElementSize Property

ReportSegment ElementSize Property HIDSharp

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int ElementSize { get; set; }
public int ElementSize { get; set; }
Public Property ElementSize As Integer
    Get
    Set
Public Property ElementSize As Integer
    Get
    Set
public:
property int ElementSize {
    int get ();
    void set (int value);
}
public:
property int ElementSize {
    int get ();
    void set (int value);
}
member ElementSize : int with get, set
member ElementSize : int with get, set
See Also
ReportSegment Class
ReportSegment Members


Flags Property

ReportSegment Flags Property HIDSharp

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DataMainItemFlags Flags { get; set; }
public DataMainItemFlags Flags { get; set; }
Public Property Flags As DataMainItemFlags
    Get
    Set
Public Property Flags As DataMainItemFlags
    Get
    Set
public:
property DataMainItemFlags Flags {
    DataMainItemFlags get ();
    void set (DataMainItemFlags value);
}
public:
property DataMainItemFlags Flags {
    DataMainItemFlags get ();
    void set (DataMainItemFlags value);
}
member Flags : DataMainItemFlags with get, set
member Flags : DataMainItemFlags with get, set
See Also
ReportSegment Class
ReportSegment Members


LogicalIsSigned Property

ReportSegment LogicalIsSigned Property HIDSharp

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool LogicalIsSigned { get; set; }
public bool LogicalIsSigned { get; set; }
Public Property LogicalIsSigned As Boolean
    Get
    Set
Public Property LogicalIsSigned As Boolean
    Get
    Set
public:
property bool LogicalIsSigned {
    bool get ();
    void set (bool value);
}
public:
property bool LogicalIsSigned {
    bool get ();
    void set (bool value);
}
member LogicalIsSigned : bool with get, set
member LogicalIsSigned : bool with get, set
See Also
ReportSegment Class
ReportSegment Members


LogicalMaximum Property

ReportSegment LogicalMaximum Property HIDSharp

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int LogicalMaximum { get; set; }
public int LogicalMaximum { get; set; }
Public Property LogicalMaximum As Integer
    Get
    Set
Public Property LogicalMaximum As Integer
    Get
    Set
public:
property int LogicalMaximum {
    int get ();
    void set (int value);
}
public:
property int LogicalMaximum {
    int get ();
    void set (int value);
}
member LogicalMaximum : int with get, set
member LogicalMaximum : int with get, set
See Also
ReportSegment Class
ReportSegment Members


LogicalMinimum Property

ReportSegment LogicalMinimum Property HIDSharp

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int LogicalMinimum { get; set; }
public int LogicalMinimum { get; set; }
Public Property LogicalMinimum As Integer
    Get
    Set
Public Property LogicalMinimum As Integer
    Get
    Set
public:
property int LogicalMinimum {
    int get ();
    void set (int value);
}
public:
property int LogicalMinimum {
    int get ();
    void set (int value);
}
member LogicalMinimum : int with get, set
member LogicalMinimum : int with get, set
See Also
ReportSegment Class
ReportSegment Members


LogicalRange Property

ReportSegment LogicalRange Property HIDSharp

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int LogicalRange { get; }
public int LogicalRange { get; }
Public ReadOnly Property LogicalRange As Integer
    Get
Public ReadOnly Property LogicalRange As Integer
    Get
public:
property int LogicalRange {
    int get ();
}
public:
property int LogicalRange {
    int get ();
}
member LogicalRange : int with get
member LogicalRange : int with get
See Also
ReportSegment Class
ReportSegment Members


PhysicalMaximum Property

ReportSegment PhysicalMaximum Property HIDSharp

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int PhysicalMaximum { get; set; }
public int PhysicalMaximum { get; set; }
Public Property PhysicalMaximum As Integer
    Get
    Set
Public Property PhysicalMaximum As Integer
    Get
    Set
public:
property int PhysicalMaximum {
    int get ();
    void set (int value);
}
public:
property int PhysicalMaximum {
    int get ();
    void set (int value);
}
member PhysicalMaximum : int with get, set
member PhysicalMaximum : int with get, set
See Also
ReportSegment Class
ReportSegment Members


PhysicalMinimum Property

ReportSegment PhysicalMinimum Property HIDSharp

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int PhysicalMinimum { get; set; }
public int PhysicalMinimum { get; set; }
Public Property PhysicalMinimum As Integer
    Get
    Set
Public Property PhysicalMinimum As Integer
    Get
    Set
public:
property int PhysicalMinimum {
    int get ();
    void set (int value);
}
public:
property int PhysicalMinimum {
    int get ();
    void set (int value);
}
member PhysicalMinimum : int with get, set
member PhysicalMinimum : int with get, set
See Also
ReportSegment Class
ReportSegment Members


PhysicalRange Property

ReportSegment PhysicalRange Property HIDSharp

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int PhysicalRange { get; }
public int PhysicalRange { get; }
Public ReadOnly Property PhysicalRange As Integer
    Get
Public ReadOnly Property PhysicalRange As Integer
    Get
public:
property int PhysicalRange {
    int get ();
}
public:
property int PhysicalRange {
    int get ();
}
member PhysicalRange : int with get
member PhysicalRange : int with get
See Also
ReportSegment Class
ReportSegment Members


Report Property

ReportSegment Report Property HIDSharp

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Report Report { get; set; }
public Report Report { get; set; }
Public Property Report As Report
    Get
    Set
Public Property Report As Report
    Get
    Set
public:
property Report^ Report {
    Report^ get ();
    void set (Report^ value);
}
public:
property Report^ Report {
    Report^ get ();
    void set (Report^ value);
}
member Report : Report with get, set
member Report : Report with get, set
See Also
ReportSegment Class
ReportSegment Members


Resolution Property

ReportSegment Resolution Property HIDSharp

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double Resolution { get; }
public double Resolution { get; }
Public ReadOnly Property Resolution As Double
    Get
Public ReadOnly Property Resolution As Double
    Get
public:
property double Resolution {
    double get ();
}
public:
property double Resolution {
    double get ();
}
member Resolution : float with get
member Resolution : float with get
See Also
ReportSegment Class
ReportSegment Members


Unit Property

ReportSegment Unit Property HIDSharp

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Unit Unit { get; set; }
public Unit Unit { get; set; }
Public Property Unit As Unit
    Get
    Set
Public Property Unit As Unit
    Get
    Set
public:
property Unit^ Unit {
    Unit^ get ();
    void set (Unit^ value);
}
public:
property Unit^ Unit {
    Unit^ get ();
    void set (Unit^ value);
}
member Unit : Unit with get, set
member Unit : Unit with get, set
See Also
ReportSegment Class
ReportSegment Members


UnitExponent Property

ReportSegment UnitExponent Property HIDSharp

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int UnitExponent { get; set; }
public int UnitExponent { get; set; }
Public Property UnitExponent As Integer
    Get
    Set
Public Property UnitExponent As Integer
    Get
    Set
public:
property int UnitExponent {
    int get ();
    void set (int value);
}
public:
property int UnitExponent {
    int get ();
    void set (int value);
}
member UnitExponent : int with get, set
member UnitExponent : int with get, set
See Also
ReportSegment Class
ReportSegment Members


ReportType Enumeration

ReportType Enumeration HIDSharp

Namespace: HidSharp.ReportDescriptors.Parser
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum ReportType
public enum ReportType
Public Enumeration ReportType
Public Enumeration ReportType
public enum class ReportType
public enum class ReportType
type ReportType
type ReportType
Members
Member name | Value | Description
Input | 0 |
Output | 1 |
Feature | 2 |
See Also


HidSharp.ReportDescriptors.Units Namespace

HidSharp.ReportDescriptors.Units Namespace HIDSharp
The HID specification allows one to define units for report values.
Classes
 | Class | Description
Public class | Unit | Describes the units of a report value.
Enumerations
 | Enumeration | Description
Public enumeration | CurrentUnit | Defines the possible units of current.
Public enumeration | LengthUnit | Defines the possible units of length.
Public enumeration | LuminousIntensityUnit | Defines the possible units of luminous intensity.
Public enumeration | MassUnit | Defines the possible units of mass.
Public enumeration | TemperatureUnit | Defines the possible units of temperature.
Public enumeration | TimeUnit | Defines the possible units of time.
Public enumeration | UnitSystem | Defines the possible unit systems.


CurrentUnit Enumeration

CurrentUnit Enumeration HIDSharp
Defines the possible units of current.

Namespace: HidSharp.ReportDescriptors.Units
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum CurrentUnit
public enum CurrentUnit
Public Enumeration CurrentUnit
Public Enumeration CurrentUnit
public enum class CurrentUnit
public enum class CurrentUnit
type CurrentUnit
type CurrentUnit
Members
Member name | Value | Description
None | 0 | The unit system has no unit of current.
Ampere | 1 | The unit of current is the Ampere.
See Also
HidSharp.ReportDescriptors.Units Namespace


LengthUnit Enumeration

LengthUnit Enumeration HIDSharp
Defines the possible units of length.

Namespace: HidSharp.ReportDescriptors.Units
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum LengthUnit
public enum LengthUnit
Public Enumeration LengthUnit
Public Enumeration LengthUnit
public enum class LengthUnit
public enum class LengthUnit
type LengthUnit
type LengthUnit
Members
Member name | Value | Description
None | 0 | The unit system has no unit of length.
Centimeter | 1 | The unit of length is the centimeter (occurs in the SI Linear unit system).
Radians | 2 | The unit of length is the radian (occurs in the SI Rotation unit system).
Inch | 3 | The unit of length is the inch (occurs in the English Linear unit system).
Degrees | 4 | The unit of length is the degree (occurs in the English Rotation unit system).
See Also
HidSharp.ReportDescriptors.Units Namespace


LuminousIntensityUnit Enumeration

LuminousIntensityUnit Enumeration HIDSharp
Defines the possible units of luminous intensity.

Namespace: HidSharp.ReportDescriptors.Units
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum LuminousIntensityUnit
public enum LuminousIntensityUnit
Public Enumeration LuminousIntensityUnit
Public Enumeration LuminousIntensityUnit
public enum class LuminousIntensityUnit
public enum class LuminousIntensityUnit
type LuminousIntensityUnit
type LuminousIntensityUnit
Members
Member name | Value | Description
None | 0 | The unit system has no unit of luminous intensity.
Candela | 1 | The unit of luminous intensity is the candela.
See Also
HidSharp.ReportDescriptors.Units Namespace


MassUnit Enumeration

MassUnit Enumeration HIDSharp
Defines the possible units of mass.

Namespace: HidSharp.ReportDescriptors.Units
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum MassUnit
public enum MassUnit
Public Enumeration MassUnit
Public Enumeration MassUnit
public enum class MassUnit
public enum class MassUnit
type MassUnit
type MassUnit
Members
Member name | Value | Description
None | 0 | The unit system has no unit of mass.
Gram | 1 | The unit of mass is the gram (occurs in the SI Linear and Rotation unit systems).
Slug | 2 | The unit of mass is the slug (occurs in the English Linear and Rotation unit systems).
See Also
HidSharp.ReportDescriptors.Units Namespace


TemperatureUnit Enumeration

TemperatureUnit Enumeration HIDSharp
Defines the possible units of temperature.

Namespace: HidSharp.ReportDescriptors.Units
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum TemperatureUnit
public enum TemperatureUnit
Public Enumeration TemperatureUnit
Public Enumeration TemperatureUnit
public enum class TemperatureUnit
public enum class TemperatureUnit
type TemperatureUnit
type TemperatureUnit
Members
Member name | Value | Description
None | 0 | The unit system has no unit of temperature.
Kelvin | 1 | The unit of temperature is Kelvin (occurs in SI Linear and Rotation unit systems).
Fahrenheit | 2 | The unit of temperature is Fahrenheit (occurs in English Linear and Rotation unit systems).
See Also
HidSharp.ReportDescriptors.Units Namespace


TimeUnit Enumeration

TimeUnit Enumeration HIDSharp
Defines the possible units of time.

Namespace: HidSharp.ReportDescriptors.Units
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum TimeUnit
public enum TimeUnit
Public Enumeration TimeUnit
Public Enumeration TimeUnit
public enum class TimeUnit
public enum class TimeUnit
type TimeUnit
type TimeUnit
Members
Member name | Value | Description
None | 0 | The unit system has no unit of time.
Seconds | 1 | The unit of time is seconds.
See Also
HidSharp.ReportDescriptors.Units Namespace


Unit Class

Unit Class HIDSharp
Describes the units of a report value.
Inheritance Hierarchy
Online System Object
HidSharp.ReportDescriptors.Units Unit

Namespace: HidSharp.ReportDescriptors.Units
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class Unit
public class Unit
Public Class Unit
Public Class Unit
public ref class Unit
public ref class Unit
type Unit =  class end
type Unit =  class end
See Also
Unit Members
HidSharp.ReportDescriptors.Units Namespace


Unit Members

Unit Members HIDSharp

The Unit type exposes the following members.
Constructors
 | Name | Description
Public method | Unit | Initializes a new instance of the Unit class.
Back to Top
Methods
Name | Description
DecodeExponent | Decodes an encoded HID unit exponent.
EncodeExponent | Encodes an exponent in HID unit form.
Back to Top
Properties
 | Name | Description
Public property | CurrentExponent | Gets or sets the exponent of the report value's units of current.
Public property | CurrentUnit | Gets the units of current corresponding to System.
Public property | LengthExponent | Gets or sets the exponent of the report value's units of length.
Public property | LengthUnit | Gets the units of length corresponding to System.
Public property | LuminousIntensityExponent | Gets or sets the exponent of the report value's units of luminous intensity.
Public property | LuminousIntensityUnit | Gets the units of luminous intensity corresponding to System.
Public property | MassExponent | Gets or sets the exponent of the report value's units of mass.
Public property | MassUnit | Gets the units of mass corresponding to System.
Public property | System | Gets or sets the unit system.
Public property | TemperatureExponent | Gets or sets the exponent of the report value's units of temperature.
Public property | TemperatureUnit | Gets the units of temperature corresponding to System.
Public property | TimeExponent | Gets or sets the exponent of the report value's units of time.
Public property | TimeUnit | Gets the units of time corresponding to System.
Public property | Value | Gets or sets the raw HID value describing the units.
Back to Top
See Also
Unit Class
HidSharp.ReportDescriptors.Units Namespace


Unit Constructor

Unit Constructor HIDSharp
Initializes a new instance of the Unit class.

Namespace: HidSharp.ReportDescriptors.Units
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Unit(
    uint value
)
public Unit(
    uint value
)
Public Sub New ( _
    value As UInteger _
)
Public Sub New ( _
    value As UInteger _
)
public:
Unit(
    unsigned int value
)
public:
Unit(
    unsigned int value
)
new :
        value : uint32 -> Unit
new :
        value : uint32 -> Unit

Parameters

value
Type: Online System UInt32
The raw HID value describing the units.
See Also
Unit Class
Unit Members
HidSharp.ReportDescriptors.Units Namespace


Unit Methods

Unit Methods HIDSharp
The Unit type exposes the following members.
Methods
Name | Description
DecodeExponent | Decodes an encoded HID unit exponent.
EncodeExponent | Encodes an exponent in HID unit form.
Back to Top
See Also
Unit Class
HidSharp.ReportDescriptors.Units Namespace


DecodeExponent Method

Unit DecodeExponent Method HIDSharp
Decodes an encoded HID unit exponent.

Namespace: HidSharp.ReportDescriptors.Units
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int DecodeExponent(
    uint value
)
public static int DecodeExponent(
    uint value
)
Public Shared Function DecodeExponent ( _
    value As UInteger _
) As Integer
Public Shared Function DecodeExponent ( _
    value As UInteger _
) As Integer
public:
static int DecodeExponent(
    unsigned int value
)
public:
static int DecodeExponent(
    unsigned int value
)
static member DecodeExponent :
        value : uint32 -> int
static member DecodeExponent :
        value : uint32 -> int

Parameters

value
Type: Online System UInt32
The encoded exponent.

Return Value

The exponent.
See Also
Unit Class
Unit Members
HidSharp.ReportDescriptors.Units Namespace


EncodeExponent Method

Unit EncodeExponent Method HIDSharp
Encodes an exponent in HID unit form.

Namespace: HidSharp.ReportDescriptors.Units
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static uint EncodeExponent(
    int value
)
public static uint EncodeExponent(
    int value
)
Public Shared Function EncodeExponent ( _
    value As Integer _
) As UInteger
Public Shared Function EncodeExponent ( _
    value As Integer _
) As UInteger
public:
static unsigned int EncodeExponent(
    int value
)
public:
static unsigned int EncodeExponent(
    int value
)
static member EncodeExponent :
        value : int -> uint32
static member EncodeExponent :
        value : int -> uint32

Parameters

value
Type: Online System Int32
The exponent.

Return Value

The encoded exponent.
See Also
Unit Class
Unit Members
HidSharp.ReportDescriptors.Units Namespace


Unit Properties

Unit Properties HIDSharp
The Unit type exposes the following members.
Properties
 | Name | Description
Public property | CurrentExponent | Gets or sets the exponent of the report value's units of current.
Public property | CurrentUnit | Gets the units of current corresponding to System.
Public property | LengthExponent | Gets or sets the exponent of the report value's units of length.
Public property | LengthUnit | Gets the units of length corresponding to System.
Public property | LuminousIntensityExponent | Gets or sets the exponent of the report value's units of luminous intensity.
Public property | LuminousIntensityUnit | Gets the units of luminous intensity corresponding to System.
Public property | MassExponent | Gets or sets the exponent of the report value's units of mass.
Public property | MassUnit | Gets the units of mass corresponding to System.
Public property | System | Gets or sets the unit system.
Public property | TemperatureExponent | Gets or sets the exponent of the report value's units of temperature.
Public property | TemperatureUnit | Gets the units of temperature corresponding to System.
Public property | TimeExponent | Gets or sets the exponent of the report value's units of time.
Public property | TimeUnit | Gets the units of time corresponding to System.
Public property | Value | Gets or sets the raw HID value describing the units.
Back to Top
See Also
Unit Class
HidSharp.ReportDescriptors.Units Namespace


CurrentExponent Property

Unit CurrentExponent Property HIDSharp
Gets or sets the exponent of the report value's units of current.

Namespace: HidSharp.ReportDescriptors.Units
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int CurrentExponent { get; set; }
public int CurrentExponent { get; set; }
Public Property CurrentExponent As Integer
    Get
    Set
Public Property CurrentExponent As Integer
    Get
    Set
public:
property int CurrentExponent {
    int get ();
    void set (int value);
}
public:
property int CurrentExponent {
    int get ();
    void set (int value);
}
member CurrentExponent : int with get, set
member CurrentExponent : int with get, set
See Also
Unit Class
Unit Members
HidSharp.ReportDescriptors.Units Namespace


CurrentUnit Property

Unit CurrentUnit Property HIDSharp
Gets the units of current corresponding to System.

Namespace: HidSharp.ReportDescriptors.Units
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CurrentUnit CurrentUnit { get; }
public CurrentUnit CurrentUnit { get; }
Public ReadOnly Property CurrentUnit As CurrentUnit
    Get
Public ReadOnly Property CurrentUnit As CurrentUnit
    Get
public:
property CurrentUnit CurrentUnit {
    CurrentUnit get ();
}
public:
property CurrentUnit CurrentUnit {
    CurrentUnit get ();
}
member CurrentUnit : CurrentUnit with get
member CurrentUnit : CurrentUnit with get
See Also
Unit Class
Unit Members
HidSharp.ReportDescriptors.Units Namespace


LengthExponent Property

Unit LengthExponent Property HIDSharp
Gets or sets the exponent of the report value's units of length.

Namespace: HidSharp.ReportDescriptors.Units
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int LengthExponent { get; set; }
public int LengthExponent { get; set; }
Public Property LengthExponent As Integer
    Get
    Set
Public Property LengthExponent As Integer
    Get
    Set
public:
property int LengthExponent {
    int get ();
    void set (int value);
}
public:
property int LengthExponent {
    int get ();
    void set (int value);
}
member LengthExponent : int with get, set
member LengthExponent : int with get, set
See Also
Unit Class
Unit Members
HidSharp.ReportDescriptors.Units Namespace


LengthUnit Property

Unit LengthUnit Property HIDSharp
Gets the units of length corresponding to System.

Namespace: HidSharp.ReportDescriptors.Units
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LengthUnit LengthUnit { get; }
public LengthUnit LengthUnit { get; }
Public ReadOnly Property LengthUnit As LengthUnit
    Get
Public ReadOnly Property LengthUnit As LengthUnit
    Get
public:
property LengthUnit LengthUnit {
    LengthUnit get ();
}
public:
property LengthUnit LengthUnit {
    LengthUnit get ();
}
member LengthUnit : LengthUnit with get
member LengthUnit : LengthUnit with get
See Also
Unit Class
Unit Members
HidSharp.ReportDescriptors.Units Namespace


LuminousIntensityExponent Property

Unit LuminousIntensityExponent Property HIDSharp
Gets or sets the exponent of the report value's units of luminous intensity.

Namespace: HidSharp.ReportDescriptors.Units
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int LuminousIntensityExponent { get; set; }
public int LuminousIntensityExponent { get; set; }
Public Property LuminousIntensityExponent As Integer
    Get
    Set
Public Property LuminousIntensityExponent As Integer
    Get
    Set
public:
property int LuminousIntensityExponent {
    int get ();
    void set (int value);
}
public:
property int LuminousIntensityExponent {
    int get ();
    void set (int value);
}
member LuminousIntensityExponent : int with get, set
member LuminousIntensityExponent : int with get, set
See Also
Unit Class
Unit Members
HidSharp.ReportDescriptors.Units Namespace


LuminousIntensityUnit Property

Unit LuminousIntensityUnit Property HIDSharp
Gets the units of luminous intensity corresponding to System.

Namespace: HidSharp.ReportDescriptors.Units
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LuminousIntensityUnit LuminousIntensityUnit { get; }
public LuminousIntensityUnit LuminousIntensityUnit { get; }
Public ReadOnly Property LuminousIntensityUnit As LuminousIntensityUnit
    Get
Public ReadOnly Property LuminousIntensityUnit As LuminousIntensityUnit
    Get
public:
property LuminousIntensityUnit LuminousIntensityUnit {
    LuminousIntensityUnit get ();
}
public:
property LuminousIntensityUnit LuminousIntensityUnit {
    LuminousIntensityUnit get ();
}
member LuminousIntensityUnit : LuminousIntensityUnit with get
member LuminousIntensityUnit : LuminousIntensityUnit with get
See Also
Unit Class
Unit Members
HidSharp.ReportDescriptors.Units Namespace


MassExponent Property

Unit MassExponent Property HIDSharp
Gets or sets the exponent of the report value's units of mass.

Namespace: HidSharp.ReportDescriptors.Units
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int MassExponent { get; set; }
public int MassExponent { get; set; }
Public Property MassExponent As Integer
    Get
    Set
Public Property MassExponent As Integer
    Get
    Set
public:
property int MassExponent {
    int get ();
    void set (int value);
}
public:
property int MassExponent {
    int get ();
    void set (int value);
}
member MassExponent : int with get, set
member MassExponent : int with get, set
See Also
Unit Class
Unit Members
HidSharp.ReportDescriptors.Units Namespace


MassUnit Property

Unit MassUnit Property HIDSharp
Gets the units of mass corresponding to System.

Namespace: HidSharp.ReportDescriptors.Units
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MassUnit MassUnit { get; }
public MassUnit MassUnit { get; }
Public ReadOnly Property MassUnit As MassUnit
    Get
Public ReadOnly Property MassUnit As MassUnit
    Get
public:
property MassUnit MassUnit {
    MassUnit get ();
}
public:
property MassUnit MassUnit {
    MassUnit get ();
}
member MassUnit : MassUnit with get
member MassUnit : MassUnit with get
See Also
Unit Class
Unit Members
HidSharp.ReportDescriptors.Units Namespace


System Property

Unit System Property HIDSharp
Gets or sets the unit system.

Namespace: HidSharp.ReportDescriptors.Units
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public UnitSystem System { get; set; }
public UnitSystem System { get; set; }
Public Property System As UnitSystem
    Get
    Set
Public Property System As UnitSystem
    Get
    Set
public:
property UnitSystem System {
    UnitSystem get ();
    void set (UnitSystem value);
}
public:
property UnitSystem System {
    UnitSystem get ();
    void set (UnitSystem value);
}
member System : UnitSystem with get, set
member System : UnitSystem with get, set
See Also
Unit Class
Unit Members
HidSharp.ReportDescriptors.Units Namespace


TemperatureExponent Property

Unit TemperatureExponent Property HIDSharp
Gets or sets the exponent of the report value's units of temperature.

Namespace: HidSharp.ReportDescriptors.Units
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int TemperatureExponent { get; set; }
public int TemperatureExponent { get; set; }
Public Property TemperatureExponent As Integer
    Get
    Set
Public Property TemperatureExponent As Integer
    Get
    Set
public:
property int TemperatureExponent {
    int get ();
    void set (int value);
}
public:
property int TemperatureExponent {
    int get ();
    void set (int value);
}
member TemperatureExponent : int with get, set
member TemperatureExponent : int with get, set
See Also
Unit Class
Unit Members
HidSharp.ReportDescriptors.Units Namespace


TemperatureUnit Property

Unit TemperatureUnit Property HIDSharp
Gets the units of temperature corresponding to System.

Namespace: HidSharp.ReportDescriptors.Units
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TemperatureUnit TemperatureUnit { get; }
public TemperatureUnit TemperatureUnit { get; }
Public ReadOnly Property TemperatureUnit As TemperatureUnit
    Get
Public ReadOnly Property TemperatureUnit As TemperatureUnit
    Get
public:
property TemperatureUnit TemperatureUnit {
    TemperatureUnit get ();
}
public:
property TemperatureUnit TemperatureUnit {
    TemperatureUnit get ();
}
member TemperatureUnit : TemperatureUnit with get
member TemperatureUnit : TemperatureUnit with get
See Also
Unit Class
Unit Members
HidSharp.ReportDescriptors.Units Namespace


TimeExponent Property

Unit TimeExponent Property HIDSharp
Gets or sets the exponent of the report value's units of time.

Namespace: HidSharp.ReportDescriptors.Units
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int TimeExponent { get; set; }
public int TimeExponent { get; set; }
Public Property TimeExponent As Integer
    Get
    Set
Public Property TimeExponent As Integer
    Get
    Set
public:
property int TimeExponent {
    int get ();
    void set (int value);
}
public:
property int TimeExponent {
    int get ();
    void set (int value);
}
member TimeExponent : int with get, set
member TimeExponent : int with get, set
See Also
Unit Class
Unit Members
HidSharp.ReportDescriptors.Units Namespace


TimeUnit Property

Unit TimeUnit Property HIDSharp
Gets the units of time corresponding to System.

Namespace: HidSharp.ReportDescriptors.Units
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TimeUnit TimeUnit { get; }
public TimeUnit TimeUnit { get; }
Public ReadOnly Property TimeUnit As TimeUnit
    Get
Public ReadOnly Property TimeUnit As TimeUnit
    Get
public:
property TimeUnit TimeUnit {
    TimeUnit get ();
}
public:
property TimeUnit TimeUnit {
    TimeUnit get ();
}
member TimeUnit : TimeUnit with get
member TimeUnit : TimeUnit with get
See Also
Unit Class
Unit Members
HidSharp.ReportDescriptors.Units Namespace


Value Property

Unit Value Property HIDSharp
Gets or sets the raw HID value describing the units.

Namespace: HidSharp.ReportDescriptors.Units
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public uint Value { get; set; }
public uint Value { get; set; }
Public Property Value As UInteger
    Get
    Set
Public Property Value As UInteger
    Get
    Set
public:
property unsigned int Value {
    unsigned int get ();
    void set (unsigned int value);
}
public:
property unsigned int Value {
    unsigned int get ();
    void set (unsigned int value);
}
member Value : uint32 with get, set
member Value : uint32 with get, set
See Also
Unit Class
Unit Members
HidSharp.ReportDescriptors.Units Namespace


UnitSystem Enumeration

UnitSystem Enumeration HIDSharp
Defines the possible unit systems.

Namespace: HidSharp.ReportDescriptors.Units
Assembly: HidSharp (in HidSharp.dll) Version: 1.5.0.0 (1.5.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum UnitSystem
public enum UnitSystem
Public Enumeration UnitSystem
Public Enumeration UnitSystem
public enum class UnitSystem
public enum class UnitSystem
type UnitSystem
type UnitSystem
Members
Member name | Value | Description
None | 0 | No units are used.
SILinear | 1 | The SI Linear unit system uses centimeters for length, grams for mass, seconds for time, Kelvin for temperature, Amperes for current, and candelas for luminous intensity.
SIRotation | 2 | The SI Rotation unit system uses radians for length, grams for mass, seconds for time, Kelvin for temperature, Amperes for current, and candelas for luminous intensity.
EnglishLinear | 3 | The English Linear unit system uses inches for length, slugs for mass, seconds for time, Fahrenheit for temperature, Amperes for current, and candelas for luminous intensity.
EnglishRotation | 4 | The English Rotation unit system uses degrees for length, slugs for mass, seconds for time, Fahrenheit for temperature, Amperes for current, and candelas for luminous intensity.
See Also
HidSharp.ReportDescriptors.Units Namespace