Bento4 MP4 SDK: Bento4 SDK

  • Main Page
  • Related Pages
  • Classes
  • Files

Bento4 SDK

1.2

Introduction

Bento4/AP4 is a C++ class library designed to read and write ISO-MP4 files. This format is defined in ISO/IEC 14496-12, 14496-14 and 14496-15. The format is a derivative of the Apple Quicktime file format. Because of that, Bento4 can be used to read and write a number of Quicktime files as well, even though some Quicktime specific features are not supported. In addition, Bento4 supports a number of extensions as defined in various other specifications. This includes some support for ISMA Encrytion and Decryption as defined in the ISMA E&A specification (http://www.isma.tv), OMA 2.0 PDCF Encryption and Decryption as defined in the OMA 2.0 PDCF specification (http://www.openmobilealliance.org) and iTunes compatible metadata. The SDK includes a number of command line tools, built using the class library, that serve as general purpose tools as well as examples of how to use the API.

The SDK is designed to be cross-platform. The code is very portable; it can be compiled with any sufficiently modern C++ compiler. The code does not rely on any external library; all the code necessary to compile the SDK and its tools is included in the standard distribution. The standard distribution contains makefiles for unix-like operating systems, including Linux, project files for Microsoft Visual Studio, and an XCode project for MacOS X. There is also support for building the library with the SCons build system.

Building the SDK

Building the SDK will produce a C++ class library and some command line tools. For the makefile-based configurations, 'make sdk' will produce an SDK directory layout with a bin/ lib/ and include/ subdirectories containing respectively the binaries, library and header files.

Windows

Open the solution file Build/Targets/Build/Targets/x86-microsoft-win32-vs2005 Building the solution will build the class library and command line tools. The script Build/Targets/Build/Targets/x86-microsoft-win32-vs2005/make-sdk.sh will create the SDK directory structure as described above.

Linux

Go to Build/Targets/x86-unknown-linux or Build/Targets/<target-name> for any linux-based target, and use the 'make' command to build the library and tools, or 'make sdk' to build the SDK directory structure.

Cygwin

Go to Build/Targets/x86-unknown-cygwin and follow the same instructions as for the Linux platform.

MacOS

Use the XCode project file located under Build/Targets/ppc-apple-macosx

Using SCons

There is experimental support for building the SDK using the python-based SCons tool (http://www.scons.org). The top level configuration is located at the root of the SDK, and will output all the object files and binaries to a sub-directory under Build/SCons/Targets/<target-name>/<config-name>.

Other Platforms

Other plaftorms can be built by adapting the makefiles for the generic gcc-based configurations.

Structure of an MP4 file

An MP4 file consists of a tree of atoms (also known as boxes). The atoms contain the information about the different media tracks for the file, as well as other information, such as metadata. The Bento4 class library parses files an constructs an in-memory representation of the atoms, and provides an API that is an abstraction layer for the way the information is actually encoded in those atoms.

Reading Files

The class AP4_File represents all the information about an MP4 file. Internally, a tree of AP4_Atom objects plus other helper objects holds the actual information. To create an instance of the class, the caller must pass a reference to an AP4_ByteStream object that represents the file data storage. The SDK includes two subclasses of the abstract AP4_ByteStream class: AP4_FileByteStream for reading/writing disk-based files and AP4_MemoryByteStream for working with in-memory file images. Once you have created an AP4_File object, you can get to the media data by accessing the AP4_Track objects of its AP4_Movie (see AP4_File::GetMovie). The AP4_Track exposes the necessary methods for you to get the AP4_SampleDescription (typically to initialize your decoder) and to get the AP4_Sample objects from the track. These AP4_Sample objects give you the meta information you need (such as timestamps) as well as the sample data that they point to. You can also explore the entire tree of atoms by calling AP4_File::Inspect, passing an instance of AP4_AtomInspector. AP4_AtomInspector is an abstract base class for a visitor of the tree of AP4_Atom objects. The SDK includes an concrete subclass, AP4_PrintInspector, can be used to print out a text representation of the atoms as they are visited. See the Mp4Dump command line application for an example.

Writing Files

To create a new MP4 file, you first create an AP4_SyntheticSampleTable sample table for each track in your file. You specify the sample description for the media samples in each track by calling AP4_SyntheticSampleTable::AddSampleDescription with the description for the samples of that track. Samples can then be added to the sample table with the AP4_SyntheticSampleTable::AddSample method. Once all the samples of all the tracks have been added to the sample tables, you can create an AP4_Movie, and an AP4_Track from each sample table, add the track to the movie, and finally create an AP4_File from the movie object. Finally, the AP4_File object can be serialized to a byte stream (such as an AP4_FileByteStream) using the AP4_FileWriter class. See the Aac2Mp4 application for an example.

Tracks

The AP4_Movie object of an AP4_File has a list of AP4_Track objects. Each AP4_Track represents a media track in the file. From this object, you can obtain the type, duration, etc.. of the tracks. This object also provides access to the media samples in the track. Tracks are made up of media samples, stored in an 'mdat' atom (media data) and a sample table that provides all the information about the individual samples, such as size, timestamps, sample description, etc... Media samples are represented by AP4_Sample objects. You can obtain a track's samples by calling the AP4_Track::GetSample method. You can also directly read the payload of a media sample by calling the AP4_Track::ReadSample method if you want to bypass the intermediate step of going through an AP4_Sample object. The information about the samples in a track is represented by subclasses of the AP4_SampleDescription class. The sample descriptions contain information about media-specific parameters, such as video resolution, audio sampling rates and others. See the Mp4Info and Mp42Aac command line applications as examples.

Advanced Topics

Custom Atoms

The SDK has built-in support for most of the standard atom types as defined in the spec. But an application may want to extend the library to support non-standard atom type, such as custom atoms whose definition is proprietary. The base class for all atoms is AP4_Atom. Instances of subclasses of this class are created by the AP4_AtomFactory object. The factory knows about all the AP4_Atom subclasses included in the SDK, and maintains a list of AP4_AtomFactory::TypeHandler type handlers. When the factory encounters an atom that is not one of the built-in atom type, it calls all the registered type handlers, in turn, until one of them accept to handle the type and create the corresponding atom. The custom atoms must be implemented as subclasses of AP4_Atom and override at least the AP4_Atom::WriteFields method. The custom atoms should also override AP4_Atom::InspectFields if they want to provide meaningful information when inspected.

Transformations

The SDK provides support for transforming MP4 files. Transformations are useful to perform tasks such as editing (removing or adding atoms) and encryption or decryption. When the atom tree for the file changes, the entire file needs to change, because in most cases, the size of the 'moov' atom will change, and thus change the offset of the media samples in the 'mdat' atom. To facilitate this operation, the class AP4_Processor provides the base functionality for managing all the updates to the sample tables. Subclasses of the AP4_Processor class can override certain methods to carry out specific changes to the structure of the atom tree and/or the media samples. AP4_Processor defines an abstract base class, AP4_Processor::TrackHandler that defines the interface that specific track modification classes must implement. A subclass of AP4_Processor may create such an AP4_Processor::TrackHandler subclass instance when is AP4_Processor::CreateTrackHandler is called for one of the tracks in the file. See the sample applications Mp4Edit, Mp4Encrpt and Mp4Decrypt as examples.

Encryption and Decryption

The SDK has support for encrypting and decrypting tracks as specified by the ISMA Encryption and Authentication specification as well as OMA 2.0 and 2.1 DCF and PDCF. The supporting classes found in Ap4IsmaCryp.h and AP4_OmaDcf.h provide a subclass of AP4_Processor for encrypting or decrypting entire files. The class AP4_IsmaCipher and AP4_OmaDcfSampleDecrypter implement the generic AP4_SampleDecrypter interface that provides support for decrypting individual samples. The parameters necessary to instantiate an AP4_IsmaCipher or an AP4_OmaDcfSampleDecrypter can be retrieved from an encrypted track by accessing the track's sample descriptions, which are instances of the AP4_ProtectedSampleDescription class. A more general factory method, AP4_SampleDecrypter::Create can be called, passing an instance of AP4_ProtectedSampleDescription and the cipher key, and the correct concrete class will automatically be instanciated based on the type of encryption that was used for the track.

Packets

For files that contain hint tracks, the SDK provides support for generating RTP packets that can be used to stream the media using the RTP and RTSP protocols. See the application Mp4RtpHintInfo for an example of how to generate the create RTP packets from a file and generate the SDP information for the RTSP protocol.

Generated on Thu May 13 16:36:31 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Deprecated List

  • Files

Deprecated List

Member AP4_FileByteStream::AP4_FileByteStream (const char *name, Mode mode)
Generated on Thu May 13 16:36:41 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Class List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

Class List

Here are the classes, structs, unions and interfaces with brief descriptions:
AP4_3GppLocalizedStringAtom |
AP4_8bdlAtom |
AP4_AesBlockCipher |
AP4_Array< T > |
AP4_Atom | Abstract base class for all atom types
AP4_AtomFactory |
AP4_AtomFinder |
AP4_AtomInspector | Class used in a visitor pattern to walk all the atoms in a tree of AP4_Atom objects
AP4_AtomListInspector |
AP4_AtomListWriter |
AP4_AtomMetaDataValue |
AP4_AtomParent | Base class for containers of atoms
AP4_AtomSampleTable |
AP4_AtomSizeAdder |
AP4_AudioSampleDescription |
AP4_AudioSampleEntry |
AP4_Avc1SampleEntry |
AP4_AvccAtom |
AP4_AvcSampleDescription |
AP4_BinaryMetaDataValue |
AP4_BitWriter |
AP4_BlockCipher |
AP4_BlockCipherFactory |
AP4_BufferedInputStream |
AP4_ByteStream |
AP4_CbcStreamCipher |
AP4_Co64Atom |
AP4_Command |
AP4_CommandFactory |
AP4_ContainerAtom |
AP4_CtrStreamCipher |
AP4_CttsAtom |
AP4_CttsTableEntry |
AP4_DataAtom |
AP4_DataBuffer |
AP4_DcfdAtom |
AP4_DcfStringAtom |
AP4_DecoderConfigDescriptor |
AP4_DecoderSpecificInfoDescriptor |
AP4_DecryptingStream |
AP4_DefaultAtomFactory |
AP4_DefaultBlockCipherFactory |
AP4_Descriptor |
AP4_DescriptorFactory |
AP4_DescriptorFinder |
AP4_DescriptorListInspector |
AP4_DescriptorListWriter |
AP4_DescriptorUpdateCommand | This class is used for ObjectDescriptorUpdateCommand and IPMP_DescriptorUpdateCommand
AP4_DrefAtom |
AP4_DrmiSampleEntry |
AP4_DrmsSampleEntry |
AP4_ElstAtom |
AP4_ElstEntry |
AP4_EncaSampleEntry |
AP4_EncryptingStream |
AP4_EncvSampleEntry |
AP4_EsDescriptor |
AP4_EsdsAtom |
AP4_EsIdIncDescriptor |
AP4_EsIdRefDescriptor |
AP4_Exception |
AP4_Expandable |
AP4_File | The AP4_File object is the top level object for MP4 Files
AP4_FileByteStream |
AP4_FileCopier |
AP4_FileWriter |
AP4_FragmentSampleTable |
AP4_FrmaAtom |
AP4_FtypAtom |
AP4_GenericAudioSampleDescription |
AP4_GenericVideoSampleDescription |
AP4_GrpiAtom |
AP4_HdlrAtom |
AP4_HintTrackReader |
AP4_Hmac |
AP4_HmhdAtom |
AP4_IkmsAtom |
AP4_ImmediateRtpConstructor |
AP4_InitialObjectDescriptor |
AP4_IntegerMetaDataValue |
AP4_IodsAtom |
AP4_IpmpDescriptor |
AP4_IpmpDescriptorPointer |
AP4_IproAtom |
AP4_IsfmAtom |
AP4_IsltAtom |
AP4_IsmaCipher |
AP4_IsmaEncryptingProcessor |
AP4_IsmaTrackDecrypter |
AP4_LinearReader |
AP4_List< T > |
AP4_MarlinIpmpDecryptingProcessor |
AP4_MarlinIpmpEncryptingProcessor |
AP4_MarlinIpmpParser |
AP4_MarlinIpmpTrackDecrypter |
AP4_MarlinIpmpTrackEncrypter |
AP4_MdhdAtom |
AP4_MehdAtom |
AP4_MemoryByteStream |
AP4_MetaData |
AP4_MetaDataAtomTypeHandler |
AP4_MetaDataStringAtom |
AP4_MetaDataTag |
AP4_MfhdAtom |
AP4_MfroAtom |
AP4_MoovAtom |
AP4_Movie |
AP4_MovieFragment |
AP4_Mp4aSampleEntry |
AP4_Mp4sSampleEntry |
AP4_Mp4vSampleEntry |
AP4_Mpeg2TsWriter | This class is a simple implementation of a converter that can convert MP4 audio and video access units into an MPEG2 transport stream
AP4_MpegAudioSampleDescription |
AP4_MpegAudioSampleEntry |
AP4_MpegSampleDescription |
AP4_MpegSystemSampleDescription |
AP4_MpegSystemSampleEntry |
AP4_MpegVideoSampleDescription |
AP4_MpegVideoSampleEntry |
AP4_MvhdAtom |
AP4_NmhdAtom |
AP4_NoopRtpConstructor |
AP4_NullTerminatedStringAtom | Generic Class usd for all atoms that contain a single null-terminated string
AP4_ObjectDescriptor |
AP4_OdafAtom |
AP4_OddaAtom |
AP4_OdheAtom |
AP4_OhdrAtom |
AP4_OmaDcfAtomDecrypter |
AP4_OmaDcfCbcSampleDecrypter |
AP4_OmaDcfCbcSampleEncrypter |
AP4_OmaDcfCtrSampleDecrypter |
AP4_OmaDcfCtrSampleEncrypter |
AP4_OmaDcfDecryptingProcessor | Use for DCF only, not PDCF
AP4_OmaDcfEncryptingProcessor |
AP4_OmaDcfSampleDecrypter |
AP4_OmaDcfSampleEncrypter |
AP4_OmaDcfTrackDecrypter |
AP4_OmaDrmInfo |
AP4_PiffAvcCbcSampleDecrypter |
AP4_PiffAvcCbcSampleEncrypter |
AP4_PiffAvcCtrSampleDecrypter |
AP4_PiffAvcCtrSampleEncrypter |
AP4_PiffCbcSampleDecrypter |
AP4_PiffCbcSampleEncrypter |
AP4_PiffCtrSampleDecrypter |
AP4_PiffCtrSampleEncrypter |
AP4_PiffEncryptingProcessor |
AP4_PiffNullSampleDecrypter |
AP4_PiffSampleDecrypter |
AP4_PiffSampleEncrypter |
AP4_PiffSampleEncryptionAtom |
AP4_PiffTrackEncryptionAtom |
AP4_PrintInspector |
AP4_Processor |
AP4_ProtectedSampleDescription |
AP4_ProtectionKeyMap |
AP4_ProtectionSchemeInfo |
AP4_Referenceable |
AP4_RtpAtom |
AP4_RtpConstructor |
AP4_RtpConstructorFactory |
AP4_RtpHintSampleEntry |
AP4_RtpPacket |
AP4_RtpSampleData |
AP4_Sample |
AP4_SampleDecrypter |
AP4_SampleDescription |
AP4_SampleDescRtpConstructor |
AP4_SampleEntry |
AP4_SampleRtpConstructor |
AP4_SampleSource |
AP4_SampleTable |
AP4_SchmAtom |
AP4_SdpAtom |
AP4_SLConfigDescriptor |
AP4_SmhdAtom |
AP4_StandardDecryptingProcessor |
AP4_StcoAtom |
AP4_StreamCipher |
AP4_String |
AP4_StringMetaDataValue |
AP4_StscAtom |
AP4_StscTableEntry |
AP4_StsdAtom |
AP4_StssAtom |
AP4_StszAtom |
AP4_SttsAtom |
AP4_SttsTableEntry |
AP4_SubStream |
AP4_SyntheticSampleTable |
AP4_TfhdAtom |
AP4_TfraAtom |
AP4_TimsAtom |
AP4_TkhdAtom |
AP4_Track |
AP4_TrackPropertyMap |
AP4_TrackSampleSource |
AP4_TrakAtom |
AP4_TrefTypeAtom |
AP4_TrexAtom |
AP4_TrunAtom |
AP4_UI64 |
AP4_UnknownAtom | Class that represents atoms for which there is no specific support
AP4_UnknownCommand |
AP4_UnknownDescriptor |
AP4_UnknownExpandable |
AP4_UnknownSampleDescription |
AP4_UnknownSampleEntry |
AP4_UnknownUuidAtom | Unknown uuid atoms
AP4_UrlAtom |
AP4_UuidAtom | Base class for uuid atoms
AP4_VideoSampleDescription |
AP4_VisualSampleEntry |
AP4_VmhdAtom |
AP4_PiffEncryptingProcessor::Encrypter |
AP4_TrunAtom::Entry |
AP4_MetaData::Entry |
AP4_TfraAtom::Entry |
AP4_Processor::ExternalTrackData |
AP4_List< T >::Item::Finder |
AP4_Processor::FragmentHandler | Abstract class that defines the interface implemented by concrete fragment handlers
AP4_List< T >::Item |
AP4_MetaData::Key |
AP4_MetaData::KeyInfo |
AP4_List< T >::Item::Operator |
AP4_Processor::ProgressListener | Abstract class that defines the interface implemented by progress listeners
AP4_Mpeg2TsWriter::SampleStream |
AP4_MarlinIpmpParser::SinfEntry |
AP4_Mpeg2TsWriter::Stream |
AP4_Processor::TrackHandler | Abstract class that defines the interface implemented by concrete track handlers
AP4_AtomFactory::TypeHandler |
AP4_MetaDataAtomTypeHandler::TypeList |
AP4_MetaData::Value |
Generated on Thu May 13 16:36:41 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_3GppLocalizedStringAtom Class Reference

  • Class Hierarchy
  • Class Members

AP4_3GppLocalizedStringAtom Class Reference

#include <Ap4MetaData.h>

Inheritance diagram for AP4_3GppLocalizedStringAtom:
AP4_Atom

List of all members.

Public Member Functions

AP4_3GppLocalizedStringAtom (Type type, const char *language, const char *value)
AP4_3GppLocalizedStringAtom (Type type, AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags, AP4_ByteStream &stream)
virtual AP4_Result | InspectFields (AP4_AtomInspector &inspector)
virtual AP4_Result | WriteFields (AP4_ByteStream &stream)
const char * | GetLanguage () const
const AP4_String & | GetValue () const

Static Public Member Functions

static
AP4_3GppLocalizedStringAtom * 		Create (Type type, AP4_UI32 size, AP4_ByteStream &stream)

Detailed Description

Definition at line 334 of file Ap4MetaData.h.

Constructor & Destructor Documentation

AP4_3GppLocalizedStringAtom::AP4_3GppLocalizedStringAtom | ( | Type | type,
 |  | const char * | language,
 |  | const char * | value
 | ) |  |
AP4_3GppLocalizedStringAtom::AP4_3GppLocalizedStringAtom | ( | Type | type,
 |  | AP4_UI32 | size,
 |  | AP4_UI32 | version,
 |  | AP4_UI32 | flags,
 |  | AP4_ByteStream & | stream
 | ) |  |

Member Function Documentation

static AP4_3GppLocalizedStringAtom* AP4_3GppLocalizedStringAtom::Create | ( | Type | type,
 |  | AP4_UI32 | size,
 |  | AP4_ByteStream & | stream |
 | ) |  |  | [static]
const char* AP4_3GppLocalizedStringAtom::GetLanguage ( ) const [inline]

Definition at line 355 of file Ap4MetaData.h.

const AP4_String& AP4_3GppLocalizedStringAtom::GetValue ( ) const [inline]

Definition at line 356 of file Ap4MetaData.h.

virtual AP4_Result AP4_3GppLocalizedStringAtom::InspectFields ( AP4_AtomInspector & inspector ) [virtual]

Reimplemented from AP4_Atom.

virtual AP4_Result AP4_3GppLocalizedStringAtom::WriteFields ( AP4_ByteStream & stream ) [virtual]

Implements AP4_Atom.

The documentation for this class was generated from the following file:
  • Ap4MetaData.h
Generated on Thu May 13 16:36:43 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_3GppLocalizedStringAtom Member List

This is the complete list of members for AP4_3GppLocalizedStringAtom, including all inherited members.
AP4_3GppLocalizedStringAtom(Type type, const char *language, const char *value) | AP4_3GppLocalizedStringAtom |
AP4_3GppLocalizedStringAtom(Type type, AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags, AP4_ByteStream &stream) | AP4_3GppLocalizedStringAtom |
AP4_Atom(Type type, AP4_UI32 size=AP4_ATOM_HEADER_SIZE) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64=false) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
Clone() | AP4_Atom | [virtual]
Create(Type type, AP4_UI32 size, AP4_ByteStream &stream) | AP4_3GppLocalizedStringAtom | [static]
Detach() | AP4_Atom | [virtual]
GetFlags() const | AP4_Atom | [inline]
GetHeaderSize() const | AP4_Atom | [virtual]
GetLanguage() const | AP4_3GppLocalizedStringAtom | [inline]
GetParent() | AP4_Atom | [inline, virtual]
GetSize() const | AP4_Atom | [inline]
GetSize32() const | AP4_Atom | [inline]
GetSize64() const | AP4_Atom | [inline]
GetType() const | AP4_Atom | [inline]
GetValue() const | AP4_3GppLocalizedStringAtom | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
InspectFields(AP4_AtomInspector &inspector) | AP4_3GppLocalizedStringAtom | [virtual]
InspectHeader(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
m_Flags | AP4_Atom | [protected]
m_IsFull | AP4_Atom | [protected]
m_Parent | AP4_Atom | [protected]
m_Size32 | AP4_Atom | [protected]
m_Size64 | AP4_Atom | [protected]
m_Type | AP4_Atom | [protected]
m_Version | AP4_Atom | [protected]
ReadFullHeader(AP4_ByteStream &stream, AP4_UI32 &version, AP4_UI32 &flags) | AP4_Atom | [static]
SetFlags(AP4_UI32 flags) | AP4_Atom | [inline]
SetParent(AP4_AtomParent *parent) | AP4_Atom | [inline, virtual]
SetSize(AP4_UI64 size, bool force_64=false) | AP4_Atom |
SetSize32(AP4_UI32 size) | AP4_Atom | [inline]
SetSize64(AP4_UI64 size) | AP4_Atom | [inline]
SetType(Type type) | AP4_Atom | [inline]
Type typedef | AP4_Atom |
TypeFromString(const char *four_cc) | AP4_Atom | [static]
Write(AP4_ByteStream &stream) | AP4_Atom | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_3GppLocalizedStringAtom | [virtual]
WriteHeader(AP4_ByteStream &stream) | AP4_Atom | [virtual]
~AP4_Atom() | AP4_Atom | [inline, virtual]
Generated on Thu May 13 16:36:43 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_8bdlAtom Class Reference

AP4_8bdlAtom Class Reference

#include <Ap48bdlAtom.h>

Inheritance diagram for AP4_8bdlAtom:
AP4_Atom

List of all members.

Public Member Functions

AP4_8bdlAtom (AP4_UI32 encoding, AP4_UI32 encoding_version, const AP4_Byte *data, AP4_Size data_size)
virtual AP4_Result | InspectFields (AP4_AtomInspector &inspector)
virtual AP4_Result | WriteFields (AP4_ByteStream &stream)
AP4_UI32 GetEncoding ()
AP4_UI32 GetEncodingVersion ()
const AP4_DataBuffer & | GetBundleData ()

Static Public Member Functions

static AP4_8bdlAtom * | Create (AP4_Size size, AP4_ByteStream &stream)

Detailed Description

Definition at line 47 of file Ap48bdlAtom.h.

Constructor & Destructor Documentation

AP4_8bdlAtom::AP4_8bdlAtom | ( | AP4_UI32 | encoding,
 |  | AP4_UI32 | encoding_version,
 |  | const AP4_Byte * | data,
 |  | AP4_Size | data_size
 | ) |  |

Member Function Documentation

static AP4_8bdlAtom* AP4_8bdlAtom::Create | ( | AP4_Size | size,
 |  | AP4_ByteStream & | stream |
 | ) |  |  | [static]
const AP4_DataBuffer& AP4_8bdlAtom::GetBundleData ( ) [inline]

Definition at line 68 of file Ap48bdlAtom.h.

AP4_UI32 AP4_8bdlAtom::GetEncoding ( ) [inline]

Definition at line 66 of file Ap48bdlAtom.h.

AP4_UI32 AP4_8bdlAtom::GetEncodingVersion ( ) [inline]

Definition at line 67 of file Ap48bdlAtom.h.

virtual AP4_Result AP4_8bdlAtom::InspectFields ( AP4_AtomInspector & inspector ) [virtual]

Reimplemented from AP4_Atom.

virtual AP4_Result AP4_8bdlAtom::WriteFields ( AP4_ByteStream & stream ) [virtual]

Implements AP4_Atom.

The documentation for this class was generated from the following file:
  • Ap48bdlAtom.h
Generated on Thu May 13 16:36:43 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_8bdlAtom Member List

This is the complete list of members for AP4_8bdlAtom, including all inherited members.
AP4_8bdlAtom(AP4_UI32 encoding, AP4_UI32 encoding_version, const AP4_Byte *data, AP4_Size data_size) | AP4_8bdlAtom |
AP4_Atom(Type type, AP4_UI32 size=AP4_ATOM_HEADER_SIZE) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64=false) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
Clone() | AP4_Atom | [virtual]
Create(AP4_Size size, AP4_ByteStream &stream) | AP4_8bdlAtom | [static]
Detach() | AP4_Atom | [virtual]
GetBundleData() | AP4_8bdlAtom | [inline]
GetEncoding() | AP4_8bdlAtom | [inline]
GetEncodingVersion() | AP4_8bdlAtom | [inline]
GetFlags() const | AP4_Atom | [inline]
GetHeaderSize() const | AP4_Atom | [virtual]
GetParent() | AP4_Atom | [inline, virtual]
GetSize() const | AP4_Atom | [inline]
GetSize32() const | AP4_Atom | [inline]
GetSize64() const | AP4_Atom | [inline]
GetType() const | AP4_Atom | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
InspectFields(AP4_AtomInspector &inspector) | AP4_8bdlAtom | [virtual]
InspectHeader(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
m_Flags | AP4_Atom | [protected]
m_IsFull | AP4_Atom | [protected]
m_Parent | AP4_Atom | [protected]
m_Size32 | AP4_Atom | [protected]
m_Size64 | AP4_Atom | [protected]
m_Type | AP4_Atom | [protected]
m_Version | AP4_Atom | [protected]
ReadFullHeader(AP4_ByteStream &stream, AP4_UI32 &version, AP4_UI32 &flags) | AP4_Atom | [static]
SetFlags(AP4_UI32 flags) | AP4_Atom | [inline]
SetParent(AP4_AtomParent *parent) | AP4_Atom | [inline, virtual]
SetSize(AP4_UI64 size, bool force_64=false) | AP4_Atom |
SetSize32(AP4_UI32 size) | AP4_Atom | [inline]
SetSize64(AP4_UI64 size) | AP4_Atom | [inline]
SetType(Type type) | AP4_Atom | [inline]
Type typedef | AP4_Atom |
TypeFromString(const char *four_cc) | AP4_Atom | [static]
Write(AP4_ByteStream &stream) | AP4_Atom | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_8bdlAtom | [virtual]
WriteHeader(AP4_ByteStream &stream) | AP4_Atom | [virtual]
~AP4_Atom() | AP4_Atom | [inline, virtual]
Generated on Thu May 13 16:36:43 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_AesBlockCipher Class Reference

AP4_AesBlockCipher Class Reference

#include <Ap4AesBlockCipher.h>

Inheritance diagram for AP4_AesBlockCipher:
AP4_BlockCipher

List of all members.

Public Member Functions

AP4_AesBlockCipher (const AP4_UI08 *key, AP4_BlockCipher::CipherDirection direction)
~AP4_AesBlockCipher ()
virtual AP4_Result ProcessBlock (const AP4_UI08 *input, AP4_UI08 *output)

Detailed Description

Definition at line 60 of file Ap4AesBlockCipher.h.

Constructor & Destructor Documentation

AP4_AesBlockCipher::AP4_AesBlockCipher | ( | const AP4_UI08 * | key,
 |  | AP4_BlockCipher::CipherDirection | direction
 | ) |  |
AP4_AesBlockCipher::~AP4_AesBlockCipher ( )

Member Function Documentation

virtual AP4_Result AP4_AesBlockCipher::ProcessBlock | ( | const AP4_UI08 * | input,
 |  | AP4_UI08 * | output |
 | ) |  |  | [virtual]

Implements AP4_BlockCipher.

The documentation for this class was generated from the following file:
  • Ap4AesBlockCipher.h
Generated on Thu May 13 16:36:43 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_AesBlockCipher Member List

This is the complete list of members for AP4_AesBlockCipher, including all inherited members.
AES_128 enum value | AP4_BlockCipher |
AP4_AesBlockCipher(const AP4_UI08 *key, AP4_BlockCipher::CipherDirection direction) | AP4_AesBlockCipher |
CipherDirection enum name | AP4_BlockCipher |
CipherType enum name | AP4_BlockCipher |
DECRYPT enum value | AP4_BlockCipher |
ENCRYPT enum value | AP4_BlockCipher |
ProcessBlock(const AP4_UI08 *input, AP4_UI08 *output) | AP4_AesBlockCipher | [virtual]
~AP4_AesBlockCipher() | AP4_AesBlockCipher |
~AP4_BlockCipher() | AP4_BlockCipher | [inline, virtual]
Generated on Thu May 13 16:36:43 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_Array< T > Class Template Reference

AP4_Array< T > Class Template Reference

#include <Ap4Array.h>

List of all members.

Public Member Functions

AP4_Array ()
AP4_Array (const T *items, AP4_Size count)
virtual | ~AP4_Array ()
AP4_Cardinal | ItemCount () const
AP4_Result | Append (const T &item)
AP4_Result RemoveLast ()
T & | operator[] (unsigned long idx)
const T & | operator[] (unsigned long idx) const
AP4_Result Clear ()
AP4_Result | EnsureCapacity (AP4_Cardinal count)
AP4_Result | SetItemCount (AP4_Cardinal item_count)

Protected Attributes

AP4_Cardinal m_AllocatedCount
AP4_Cardinal m_ItemCount
T * | m_Items

Detailed Description

template<typename T>
class AP4_Array< T >

Definition at line 55 of file Ap4Array.h.

Constructor & Destructor Documentation

template<typename T>
AP4_Array< T >::AP4_Array ( ) [inline]

Definition at line 59 of file Ap4Array.h.

template<typename T>
AP4_Array< T >::AP4_Array | ( | const T * | items,
 |  | AP4_Size | count |
 | ) |  |  | [inline]

Definition at line 82 of file Ap4Array.h.

References AP4_Array< T >::m_Items.

template<typename T >
AP4_Array< T >::~AP4_Array ( ) [inline, virtual]

Definition at line 96 of file Ap4Array.h.

References AP4_Array< T >::Clear(), and AP4_Array< T >::m_Items.

Member Function Documentation

template<typename T>
AP4_Result AP4_Array< T >::Append ( const T & item ) [inline]

Definition at line 199 of file Ap4Array.h.

References AP4_ARRAY_INITIAL_COUNT, AP4_SUCCESS, AP4_Array< T >::EnsureCapacity(), AP4_Array< T >::m_AllocatedCount, AP4_Array< T >::m_ItemCount, and AP4_Array< T >::m_Items.

template<typename T >
AP4_Result AP4_Array< T >::Clear ( ) [inline]

Definition at line 107 of file Ap4Array.h.

References AP4_SUCCESS, AP4_Array< T >::m_ItemCount, and AP4_Array< T >::m_Items.

Referenced by AP4_Array< T >::~AP4_Array().

template<typename T >
AP4_Result AP4_Array< T >::EnsureCapacity ( AP4_Cardinal count ) [inline]

Definition at line 124 of file Ap4Array.h.

References AP4_ERROR_OUT_OF_MEMORY, AP4_SUCCESS, AP4_Array< T >::m_AllocatedCount, AP4_Array< T >::m_ItemCount, and AP4_Array< T >::m_Items.

Referenced by AP4_Array< T >::Append(), and AP4_Array< T >::SetItemCount().

template<typename T>
AP4_Cardinal AP4_Array< T >::ItemCount ( ) const [inline]

Definition at line 62 of file Ap4Array.h.

template<typename T>
const T& AP4_Array< T >::operator[] ( unsigned long idx ) const [inline]

Definition at line 66 of file Ap4Array.h.

template<typename T>
T& AP4_Array< T >::operator[] ( unsigned long idx ) [inline]

Definition at line 65 of file Ap4Array.h.

template<typename T >
AP4_Result AP4_Array< T >::RemoveLast ( ) [inline]

Definition at line 184 of file Ap4Array.h.

References AP4_ERROR_OUT_OF_RANGE, AP4_SUCCESS, AP4_Array< T >::m_ItemCount, and AP4_Array< T >::m_Items.

template<typename T >
AP4_Result AP4_Array< T >::SetItemCount ( AP4_Cardinal item_count ) [inline]

Definition at line 152 of file Ap4Array.h.

References AP4_FAILED, AP4_SUCCESS, AP4_Array< T >::EnsureCapacity(), AP4_Array< T >::m_ItemCount, and AP4_Array< T >::m_Items.

Member Data Documentation

template<typename T>
AP4_Cardinal AP4_Array< T >::m_AllocatedCount [protected]

Definition at line 73 of file Ap4Array.h.

Referenced by AP4_Array< T >::Append(), and AP4_Array< T >::EnsureCapacity().

template<typename T>
AP4_Cardinal AP4_Array< T >::m_ItemCount [protected]

Definition at line 74 of file Ap4Array.h.

Referenced by AP4_Array< T >::Append(), AP4_Array< T >::Clear(), AP4_Array< T >::EnsureCapacity(), AP4_Array< KeyInfo >::ItemCount(), AP4_Array< T >::RemoveLast(), and AP4_Array< T >::SetItemCount().

template<typename T>
T* AP4_Array< T >::m_Items [protected]

Definition at line 75 of file Ap4Array.h.

Referenced by AP4_Array< T >::AP4_Array(), AP4_Array< T >::Append(), AP4_Array< T >::Clear(), AP4_Array< T >::EnsureCapacity(), AP4_Array< KeyInfo >::operator[](), AP4_Array< T >::RemoveLast(), AP4_Array< T >::SetItemCount(), and AP4_Array< T >::~AP4_Array().

The documentation for this class was generated from the following file:
  • Ap4Array.h
Generated on Thu May 13 16:36:44 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_Array< T > Member List

This is the complete list of members for AP4_Array< T >, including all inherited members.
AP4_Array() | AP4_Array< T > | [inline]
AP4_Array(const T *items, AP4_Size count) | AP4_Array< T > | [inline]
Append(const T &item) | AP4_Array< T > | [inline]
Clear() | AP4_Array< T > | [inline]
EnsureCapacity(AP4_Cardinal count) | AP4_Array< T > | [inline]
ItemCount() const | AP4_Array< T > | [inline]
m_AllocatedCount | AP4_Array< T > | [protected]
m_ItemCount | AP4_Array< T > | [protected]
m_Items | AP4_Array< T > | [protected]
operator[](unsigned long idx) | AP4_Array< T > | [inline]
operator[](unsigned long idx) const | AP4_Array< T > | [inline]
RemoveLast() | AP4_Array< T > | [inline]
SetItemCount(AP4_Cardinal item_count) | AP4_Array< T > | [inline]
~AP4_Array() | AP4_Array< T > | [inline, virtual]
Generated on Thu May 13 16:36:44 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_Atom Class Reference

AP4_Atom Class Reference

Abstract base class for all atom types. More...

#include <Ap4Atom.h>

Inheritance diagram for AP4_Atom:
AP4_3GppLocalizedStringAtom AP4_8bdlAtom AP4_AvccAtom AP4_Co64Atom AP4_ContainerAtom AP4_CttsAtom AP4_DataAtom AP4_DcfdAtom AP4_DcfStringAtom AP4_ElstAtom AP4_EsdsAtom AP4_FrmaAtom AP4_FtypAtom AP4_GrpiAtom AP4_HdlrAtom AP4_HmhdAtom AP4_IkmsAtom AP4_IodsAtom AP4_IsfmAtom AP4_IsltAtom AP4_MdhdAtom AP4_MehdAtom AP4_MetaDataStringAtom AP4_MfhdAtom AP4_MfroAtom AP4_MvhdAtom AP4_NmhdAtom AP4_NullTerminatedStringAtom AP4_OdafAtom AP4_OddaAtom AP4_RtpAtom AP4_SchmAtom AP4_SdpAtom AP4_SmhdAtom AP4_StcoAtom AP4_StscAtom AP4_StssAtom AP4_StszAtom AP4_SttsAtom AP4_TfhdAtom AP4_TfraAtom AP4_TimsAtom AP4_TkhdAtom AP4_TrefTypeAtom AP4_TrexAtom AP4_TrunAtom AP4_UnknownAtom AP4_UrlAtom AP4_UuidAtom AP4_VmhdAtom

List of all members.

Public Types

typedef AP4_UI32 | Type

Public Member Functions

AP4_Atom (Type type, AP4_UI32 size=AP4_ATOM_HEADER_SIZE)
Create a simple atom with a specified type and 32-bit size.
AP4_Atom (Type type, AP4_UI64 size, bool force_64=false)
Create a simple atom with a specified type and 64-bit size.
AP4_Atom (Type type, AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags)
Create a full atom with a specified type, 32-bit size, version and flags.
AP4_Atom (Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags)
Create a full atom with a specified type, 64-bit size, version and flags.
virtual | ~AP4_Atom ()
AP4_UI32 | GetFlags () const
void | SetFlags (AP4_UI32 flags)
Type | GetType () const
void | SetType (Type type)
virtual AP4_Size | GetHeaderSize () const
AP4_UI64 | GetSize () const
void | SetSize (AP4_UI64 size, bool force_64=false)
AP4_UI32 | GetSize32 () const
void | SetSize32 (AP4_UI32 size)
AP4_UI64 | GetSize64 () const
void | SetSize64 (AP4_UI64 size)
virtual AP4_Result | Write (AP4_ByteStream &stream)
virtual AP4_Result | WriteHeader (AP4_ByteStream &stream)
virtual AP4_Result | WriteFields (AP4_ByteStream &stream)=0
virtual AP4_Result | Inspect (AP4_AtomInspector &inspector)
virtual AP4_Result | InspectHeader (AP4_AtomInspector &inspector)
virtual AP4_Result | InspectFields (AP4_AtomInspector &)
virtual AP4_Result | SetParent (AP4_AtomParent *parent)
virtual AP4_AtomParent * | GetParent ()
virtual AP4_Result | Detach ()
virtual AP4_Atom * | Clone ()
Create a clone of the object.

Static Public Member Functions

static Type | TypeFromString (const char *four_cc)
static AP4_Result | ReadFullHeader (AP4_ByteStream &stream, AP4_UI32 &version, AP4_UI32 &flags)

Protected Attributes

Type m_Type
AP4_UI32 m_Size32
AP4_UI64 m_Size64
bool | m_IsFull
AP4_UI32 m_Version
AP4_UI32 m_Flags
AP4_AtomParent * m_Parent

Detailed Description

Abstract base class for all atom types.

Definition at line 152 of file Ap4Atom.h.

Member Typedef Documentation

typedef AP4_UI32 AP4_Atom::Type

Definition at line 157 of file Ap4Atom.h.

Constructor & Destructor Documentation

AP4_Atom::AP4_Atom | ( | Type | type,
 |  | AP4_UI32 | size = AP4_ATOM_HEADER_SIZE |
 | ) |  |  | [explicit]

Create a simple atom with a specified type and 32-bit size.

AP4_Atom::AP4_Atom | ( | Type | type,
 |  | AP4_UI64 | size,
 |  | bool | force_64 = false |
 | ) |  |  | [explicit]

Create a simple atom with a specified type and 64-bit size.

AP4_Atom::AP4_Atom | ( | Type | type,
 |  | AP4_UI32 | size,
 |  | AP4_UI32 | version,
 |  | AP4_UI32 | flags |
 | ) |  |  | [explicit]

Create a full atom with a specified type, 32-bit size, version and flags.

AP4_Atom::AP4_Atom | ( | Type | type,
 |  | AP4_UI64 | size,
 |  | bool | force_64,
 |  | AP4_UI32 | version,
 |  | AP4_UI32 | flags |
 | ) |  |  | [explicit]

Create a full atom with a specified type, 64-bit size, version and flags.

virtual AP4_Atom::~AP4_Atom ( ) [inline, virtual]

Definition at line 194 of file Ap4Atom.h.

Member Function Documentation

virtual AP4_Atom* AP4_Atom::Clone ( ) [virtual]

Create a clone of the object.

This method returns a clone of the atom, or NULL if the atom cannot be cloned. Override this if your want to make an atom cloneable in a more efficient way than the default implementation.

Reimplemented in AP4_UnknownAtom, AP4_ContainerAtom, AP4_GrpiAtom, AP4_IkmsAtom, AP4_IsfmAtom, and AP4_OhdrAtom.

virtual AP4_Result AP4_Atom::Detach ( ) [virtual]
AP4_UI32 AP4_Atom::GetFlags ( ) const [inline]

Definition at line 197 of file Ap4Atom.h.

References m_Flags.

virtual AP4_Size AP4_Atom::GetHeaderSize ( ) const [virtual]

Reimplemented in AP4_UuidAtom.

virtual AP4_AtomParent* AP4_Atom::GetParent ( ) [inline, virtual]

Definition at line 222 of file Ap4Atom.h.

References m_Parent.

AP4_UI64 AP4_Atom::GetSize ( ) const [inline]

Definition at line 202 of file Ap4Atom.h.

References m_Size32, and m_Size64.

AP4_UI32 AP4_Atom::GetSize32 ( ) const [inline]

Definition at line 204 of file Ap4Atom.h.

References m_Size32.

AP4_UI64 AP4_Atom::GetSize64 ( ) const [inline]

Definition at line 206 of file Ap4Atom.h.

References m_Size64.

Type AP4_Atom::GetType ( ) const [inline]

Definition at line 199 of file Ap4Atom.h.

References m_Type.

Referenced by AP4_AtomFinder::Test().

virtual AP4_Result AP4_Atom::Inspect ( AP4_AtomInspector & inspector ) [virtual]

Reimplemented in AP4_SampleEntry.

Referenced by AP4_AtomListInspector::Action().

virtual AP4_Result AP4_Atom::InspectFields ( AP4_AtomInspector & ) [inline, virtual]

Reimplemented in AP4_8bdlAtom, AP4_NullTerminatedStringAtom, AP4_AvccAtom, AP4_Co64Atom, AP4_ContainerAtom, AP4_CttsAtom, AP4_ElstAtom, AP4_EsdsAtom, AP4_FrmaAtom, AP4_FtypAtom, AP4_GrpiAtom, AP4_HdlrAtom, AP4_HmhdAtom, AP4_IkmsAtom, AP4_IodsAtom, AP4_IproAtom, AP4_IsfmAtom, AP4_IsltAtom, AP4_MdhdAtom, AP4_MehdAtom, AP4_MfhdAtom, AP4_MfroAtom, AP4_MvhdAtom, AP4_OdafAtom, AP4_OddaAtom, AP4_OdheAtom, AP4_OhdrAtom, AP4_PiffTrackEncryptionAtom, AP4_PiffSampleEncryptionAtom, AP4_RtpAtom, AP4_SampleEntry, AP4_AudioSampleEntry, AP4_VisualSampleEntry, AP4_RtpHintSampleEntry, AP4_SchmAtom, AP4_SdpAtom, AP4_SmhdAtom, AP4_StcoAtom, AP4_StscAtom, AP4_StsdAtom, AP4_StssAtom, AP4_StszAtom, AP4_SttsAtom, AP4_TfhdAtom, AP4_TfraAtom, AP4_TimsAtom, AP4_TkhdAtom, AP4_TrefTypeAtom, AP4_TrexAtom, AP4_TrunAtom, AP4_UrlAtom, AP4_VmhdAtom, AP4_3GppLocalizedStringAtom, AP4_DcfStringAtom, AP4_DcfdAtom, AP4_MetaDataStringAtom, and AP4_DataAtom.

Definition at line 213 of file Ap4Atom.h.

References AP4_SUCCESS.

virtual AP4_Result AP4_Atom::InspectHeader ( AP4_AtomInspector & inspector ) [virtual]

Reimplemented in AP4_UuidAtom.

static AP4_Result AP4_Atom::ReadFullHeader | ( | AP4_ByteStream & | stream,
 |  | AP4_UI32 & | version,
 |  | AP4_UI32 & | flags |
 | ) |  |  | [static]
void AP4_Atom::SetFlags ( AP4_UI32 flags ) [inline]

Definition at line 198 of file Ap4Atom.h.

References m_Flags.

virtual AP4_Result AP4_Atom::SetParent ( AP4_AtomParent * parent ) [inline, virtual]

Definition at line 218 of file Ap4Atom.h.

References AP4_SUCCESS, and m_Parent.

void AP4_Atom::SetSize | ( | AP4_UI64 | size,
 |  | bool | force_64 = false
 | ) |  |
void AP4_Atom::SetSize32 ( AP4_UI32 size ) [inline]

Definition at line 205 of file Ap4Atom.h.

References m_Size32.

void AP4_Atom::SetSize64 ( AP4_UI64 size ) [inline]

Definition at line 207 of file Ap4Atom.h.

References m_Size64.

void AP4_Atom::SetType ( Type type ) [inline]

Definition at line 200 of file Ap4Atom.h.

References m_Type.

static Type AP4_Atom::TypeFromString ( const char * four_cc ) [static]
virtual AP4_Result AP4_Atom::Write ( AP4_ByteStream & stream ) [virtual]

Reimplemented in AP4_SampleEntry.

virtual AP4_Result AP4_Atom::WriteFields ( AP4_ByteStream & stream ) [pure virtual]

Implemented in AP4_8bdlAtom, AP4_UnknownAtom, AP4_NullTerminatedStringAtom, AP4_AvccAtom, AP4_Co64Atom, AP4_ContainerAtom, AP4_CttsAtom, AP4_DrefAtom, AP4_ElstAtom, AP4_EsdsAtom, AP4_FrmaAtom, AP4_FtypAtom, AP4_GrpiAtom, AP4_HdlrAtom, AP4_HmhdAtom, AP4_IkmsAtom, AP4_IodsAtom, AP4_IproAtom, AP4_IsfmAtom, AP4_IsltAtom, AP4_MdhdAtom, AP4_MehdAtom, AP4_MfhdAtom, AP4_MfroAtom, AP4_MvhdAtom, AP4_NmhdAtom, AP4_OdafAtom, AP4_OddaAtom, AP4_OdheAtom, AP4_OhdrAtom, AP4_PiffTrackEncryptionAtom, AP4_PiffSampleEncryptionAtom, AP4_RtpAtom, AP4_SampleEntry, AP4_UnknownSampleEntry, AP4_AudioSampleEntry, AP4_VisualSampleEntry, AP4_RtpHintSampleEntry, AP4_SchmAtom, AP4_SdpAtom, AP4_SmhdAtom, AP4_StcoAtom, AP4_StscAtom, AP4_StsdAtom, AP4_StssAtom, AP4_StszAtom, AP4_SttsAtom, AP4_TfhdAtom, AP4_TfraAtom, AP4_TimsAtom, AP4_TkhdAtom, AP4_TrefTypeAtom, AP4_TrexAtom, AP4_TrunAtom, AP4_UrlAtom, AP4_UnknownUuidAtom, AP4_VmhdAtom, AP4_3GppLocalizedStringAtom, AP4_DcfStringAtom, AP4_DcfdAtom, AP4_MetaDataStringAtom, and AP4_DataAtom.

virtual AP4_Result AP4_Atom::WriteHeader ( AP4_ByteStream & stream ) [virtual]

Reimplemented in AP4_UuidAtom.

Member Data Documentation

AP4_UI32 AP4_Atom::m_Flags [protected]

Definition at line 242 of file Ap4Atom.h.

Referenced by GetFlags(), and SetFlags().

bool AP4_Atom::m_IsFull [protected]

Definition at line 240 of file Ap4Atom.h.

AP4_AtomParent* AP4_Atom::m_Parent [protected]

Definition at line 243 of file Ap4Atom.h.

Referenced by GetParent(), and SetParent().

AP4_UI32 AP4_Atom::m_Size32 [protected]

Definition at line 237 of file Ap4Atom.h.

Referenced by GetSize(), GetSize32(), and SetSize32().

AP4_UI64 AP4_Atom::m_Size64 [protected]

Definition at line 238 of file Ap4Atom.h.

Referenced by GetSize(), GetSize64(), and SetSize64().

Type AP4_Atom::m_Type [protected]

Definition at line 236 of file Ap4Atom.h.

Referenced by GetType(), and SetType().

AP4_UI32 AP4_Atom::m_Version [protected]

Definition at line 241 of file Ap4Atom.h.

The documentation for this class was generated from the following file:
  • Ap4Atom.h
Generated on Thu May 13 16:36:44 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_Atom Member List

This is the complete list of members for AP4_Atom, including all inherited members.
AP4_Atom(Type type, AP4_UI32 size=AP4_ATOM_HEADER_SIZE) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64=false) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
Clone() | AP4_Atom | [virtual]
Detach() | AP4_Atom | [virtual]
GetFlags() const | AP4_Atom | [inline]
GetHeaderSize() const | AP4_Atom | [virtual]
GetParent() | AP4_Atom | [inline, virtual]
GetSize() const | AP4_Atom | [inline]
GetSize32() const | AP4_Atom | [inline]
GetSize64() const | AP4_Atom | [inline]
GetType() const | AP4_Atom | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
InspectFields(AP4_AtomInspector &) | AP4_Atom | [inline, virtual]
InspectHeader(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
m_Flags | AP4_Atom | [protected]
m_IsFull | AP4_Atom | [protected]
m_Parent | AP4_Atom | [protected]
m_Size32 | AP4_Atom | [protected]
m_Size64 | AP4_Atom | [protected]
m_Type | AP4_Atom | [protected]
m_Version | AP4_Atom | [protected]
ReadFullHeader(AP4_ByteStream &stream, AP4_UI32 &version, AP4_UI32 &flags) | AP4_Atom | [static]
SetFlags(AP4_UI32 flags) | AP4_Atom | [inline]
SetParent(AP4_AtomParent *parent) | AP4_Atom | [inline, virtual]
SetSize(AP4_UI64 size, bool force_64=false) | AP4_Atom |
SetSize32(AP4_UI32 size) | AP4_Atom | [inline]
SetSize64(AP4_UI64 size) | AP4_Atom | [inline]
SetType(Type type) | AP4_Atom | [inline]
Type typedef | AP4_Atom |
TypeFromString(const char *four_cc) | AP4_Atom | [static]
Write(AP4_ByteStream &stream) | AP4_Atom | [virtual]
WriteFields(AP4_ByteStream &stream)=0 | AP4_Atom | [pure virtual]
WriteHeader(AP4_ByteStream &stream) | AP4_Atom | [virtual]
~AP4_Atom() | AP4_Atom | [inline, virtual]
Generated on Thu May 13 16:36:44 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_AtomFactory Class Reference

AP4_AtomFactory Class Reference

#include <Ap4AtomFactory.h>

Inheritance diagram for AP4_AtomFactory:
AP4_DefaultAtomFactory

List of all members.

Classes

class | TypeHandler

Public Member Functions

AP4_AtomFactory ()
virtual | ~AP4_AtomFactory ()
AP4_Result | AddTypeHandler (TypeHandler *handler)
AP4_Result | RemoveTypeHandler (TypeHandler *handler)
AP4_Result | CreateAtomFromStream (AP4_ByteStream &stream, AP4_LargeSize &bytes_available, AP4_Atom *&atom)
virtual AP4_Result | CreateAtomFromStream (AP4_ByteStream &stream, AP4_UI32 type, AP4_UI32 size_32, AP4_UI64 size_64, AP4_Atom *&atom)
AP4_Result | CreateAtomFromStream (AP4_ByteStream &stream, AP4_Atom *&atom)
AP4_Result | CreateAtomsFromStream (AP4_ByteStream &stream, AP4_AtomParent &atoms)
AP4_Result | CreateAtomsFromStream (AP4_ByteStream &stream, AP4_LargeSize bytes_available, AP4_AtomParent &atoms)
void | PushContext (AP4_Atom::Type context)
void | PopContext ()
AP4_Atom::Type | GetContext (AP4_Ordinal depth=0)

Detailed Description

Definition at line 47 of file Ap4AtomFactory.h.

Constructor & Destructor Documentation

AP4_AtomFactory::AP4_AtomFactory ( ) [inline]

Definition at line 61 of file Ap4AtomFactory.h.

virtual AP4_AtomFactory::~AP4_AtomFactory ( ) [virtual]

Member Function Documentation

AP4_Result AP4_AtomFactory::AddTypeHandler ( TypeHandler * handler )
AP4_Result AP4_AtomFactory::CreateAtomFromStream | ( | AP4_ByteStream & | stream,
 |  | AP4_Atom *& | atom
 | ) |  |
virtual AP4_Result AP4_AtomFactory::CreateAtomFromStream | ( | AP4_ByteStream & | stream,
 |  | AP4_UI32 | type,
 |  | AP4_UI32 | size_32,
 |  | AP4_UI64 | size_64,
 |  | AP4_Atom *& | atom |
 | ) |  |  | [virtual]
AP4_Result AP4_AtomFactory::CreateAtomFromStream | ( | AP4_ByteStream & | stream,
 |  | AP4_LargeSize & | bytes_available,
 |  | AP4_Atom *& | atom
 | ) |  |
AP4_Result AP4_AtomFactory::CreateAtomsFromStream | ( | AP4_ByteStream & | stream,
 |  | AP4_LargeSize | bytes_available,
 |  | AP4_AtomParent & | atoms
 | ) |  |
AP4_Result AP4_AtomFactory::CreateAtomsFromStream | ( | AP4_ByteStream & | stream,
 |  | AP4_AtomParent & | atoms
 | ) |  |
AP4_Atom::Type AP4_AtomFactory::GetContext ( AP4_Ordinal depth = 0 )
void AP4_AtomFactory::PopContext ( )
void AP4_AtomFactory::PushContext ( AP4_Atom::Type context )
AP4_Result AP4_AtomFactory::RemoveTypeHandler ( TypeHandler * handler )
The documentation for this class was generated from the following file:
  • Ap4AtomFactory.h
Generated on Thu May 13 16:36:45 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_AtomFactory Member List

This is the complete list of members for AP4_AtomFactory, including all inherited members.
AddTypeHandler(TypeHandler *handler) | AP4_AtomFactory |
AP4_AtomFactory() | AP4_AtomFactory | [inline]
CreateAtomFromStream(AP4_ByteStream &stream, AP4_LargeSize &bytes_available, AP4_Atom *&atom) | AP4_AtomFactory |
CreateAtomFromStream(AP4_ByteStream &stream, AP4_UI32 type, AP4_UI32 size_32, AP4_UI64 size_64, AP4_Atom *&atom) | AP4_AtomFactory | [virtual]
CreateAtomFromStream(AP4_ByteStream &stream, AP4_Atom *&atom) | AP4_AtomFactory |
CreateAtomsFromStream(AP4_ByteStream &stream, AP4_AtomParent &atoms) | AP4_AtomFactory |
CreateAtomsFromStream(AP4_ByteStream &stream, AP4_LargeSize bytes_available, AP4_AtomParent &atoms) | AP4_AtomFactory |
GetContext(AP4_Ordinal depth=0) | AP4_AtomFactory |
PopContext() | AP4_AtomFactory |
PushContext(AP4_Atom::Type context) | AP4_AtomFactory |
RemoveTypeHandler(TypeHandler *handler) | AP4_AtomFactory |
~AP4_AtomFactory() | AP4_AtomFactory | [virtual]
Generated on Thu May 13 16:36:45 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_AtomFinder Class Reference

AP4_AtomFinder Class Reference

#include <Ap4Atom.h>

Inheritance diagram for AP4_AtomFinder:
AP4_List< T >::Item::Finder

List of all members.

Public Member Functions

AP4_AtomFinder (AP4_Atom::Type type, AP4_Ordinal index=0)
AP4_Result Test (AP4_Atom *atom) const

Detailed Description

Definition at line 468 of file Ap4Atom.h.

Constructor & Destructor Documentation

AP4_AtomFinder::AP4_AtomFinder | ( | AP4_Atom::Type | type,
 |  | AP4_Ordinal | index = 0 |
 | ) |  |  | [inline]

Definition at line 471 of file Ap4Atom.h.

Member Function Documentation

AP4_Result AP4_AtomFinder::Test ( AP4_Atom * atom ) const [inline]

Definition at line 473 of file Ap4Atom.h.

References AP4_FAILURE, AP4_SUCCESS, and AP4_Atom::GetType().

The documentation for this class was generated from the following file:
  • Ap4Atom.h
Generated on Thu May 13 16:36:47 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_AtomFinder Member List

This is the complete list of members for AP4_AtomFinder, including all inherited members.
AP4_AtomFinder(AP4_Atom::Type type, AP4_Ordinal index=0) | AP4_AtomFinder | [inline]
Test(AP4_Atom *atom) const | AP4_AtomFinder | [inline]
AP4_List::Item::Finder::Test(T *data) const =0 | AP4_List< T >::Item::Finder | [pure virtual]
~Finder() | AP4_List< T >::Item::Finder | [inline, virtual]
Generated on Thu May 13 16:36:47 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_AtomInspector Class Reference

AP4_AtomInspector Class Reference

Class used in a visitor pattern to walk all the atoms in a tree of AP4_Atom objects. More...

#include <Ap4Atom.h>

Inheritance diagram for AP4_AtomInspector:
AP4_PrintInspector

List of all members.

Public Types

enum FormatHint {
HINT_NONE = 0,
HINT_HEX = 1,
HINT_BOOLEAN = 2
}

Public Member Functions

AP4_AtomInspector ()
virtual | ~AP4_AtomInspector ()
void | SetVerbosity (AP4_Ordinal verbosity)
AP4_Ordinal GetVerbosity ()
virtual void | StartElement (const char *, const char *)
virtual void | EndElement ()
virtual void | AddField (const char *, AP4_UI64, FormatHint hint=HINT_NONE)
virtual void | AddFieldF (const char *, float, FormatHint hint=HINT_NONE)
virtual void | AddField (const char *, const char *, FormatHint hint=HINT_NONE)
virtual void | AddField (const char *, const unsigned char *, AP4_Size, FormatHint hint=HINT_NONE)

Protected Attributes

AP4_Ordinal m_Verbosity

Detailed Description

Class used in a visitor pattern to walk all the atoms in a tree of AP4_Atom objects.

Definition at line 77 of file Ap4Atom.h.

Member Enumeration Documentation

enum AP4_AtomInspector::FormatHint
Enumerator:
HINT_NONE
HINT_HEX
HINT_BOOLEAN

Definition at line 80 of file Ap4Atom.h.

Constructor & Destructor Documentation

AP4_AtomInspector::AP4_AtomInspector ( ) [inline]

Definition at line 87 of file Ap4Atom.h.

virtual AP4_AtomInspector::~AP4_AtomInspector ( ) [inline, virtual]

Definition at line 88 of file Ap4Atom.h.

Member Function Documentation

virtual void AP4_AtomInspector::AddField | ( | const char * | ,
 |  | const unsigned char * | ,
 |  | AP4_Size | ,
 |  | FormatHint | hint = HINT_NONE |
 | ) |  |  | [inline, virtual]

Reimplemented in AP4_PrintInspector.

Definition at line 113 of file Ap4Atom.h.

virtual void AP4_AtomInspector::AddField | ( | const char * | ,
 |  | const char * | ,
 |  | FormatHint | hint = HINT_NONE |
 | ) |  |  | [inline, virtual]

Reimplemented in AP4_PrintInspector.

Definition at line 108 of file Ap4Atom.h.

virtual void AP4_AtomInspector::AddField | ( | const char * | ,
 |  | AP4_UI64 | ,
 |  | FormatHint | hint = HINT_NONE |
 | ) |  |  | [inline, virtual]

Reimplemented in AP4_PrintInspector.

Definition at line 98 of file Ap4Atom.h.

virtual void AP4_AtomInspector::AddFieldF | ( | const char * | ,
 |  | float | ,
 |  | FormatHint | hint = HINT_NONE |
 | ) |  |  | [inline, virtual]

Reimplemented in AP4_PrintInspector.

Definition at line 103 of file Ap4Atom.h.

virtual void AP4_AtomInspector::EndElement ( ) [inline, virtual]

Reimplemented in AP4_PrintInspector.

Definition at line 97 of file Ap4Atom.h.

AP4_Ordinal AP4_AtomInspector::GetVerbosity ( ) [inline]

Definition at line 92 of file Ap4Atom.h.

References m_Verbosity.

void AP4_AtomInspector::SetVerbosity ( AP4_Ordinal verbosity ) [inline]

Definition at line 91 of file Ap4Atom.h.

References m_Verbosity.

virtual void AP4_AtomInspector::StartElement | ( | const char * | ,
 |  | const char * |  |
 | ) |  |  | [inline, virtual]

Reimplemented in AP4_PrintInspector.

Definition at line 95 of file Ap4Atom.h.

Member Data Documentation

AP4_Ordinal AP4_AtomInspector::m_Verbosity [protected]

Definition at line 121 of file Ap4Atom.h.

Referenced by GetVerbosity(), and SetVerbosity().

The documentation for this class was generated from the following file:
  • Ap4Atom.h
Generated on Thu May 13 16:36:48 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_AtomInspector Member List

This is the complete list of members for AP4_AtomInspector, including all inherited members.
AddField(const char *, AP4_UI64, FormatHint hint=HINT_NONE) | AP4_AtomInspector | [inline, virtual]
AddField(const char *, const char *, FormatHint hint=HINT_NONE) | AP4_AtomInspector | [inline, virtual]
AddField(const char *, const unsigned char *, AP4_Size, FormatHint hint=HINT_NONE) | AP4_AtomInspector | [inline, virtual]
AddFieldF(const char *, float, FormatHint hint=HINT_NONE) | AP4_AtomInspector | [inline, virtual]
AP4_AtomInspector() | AP4_AtomInspector | [inline]
EndElement() | AP4_AtomInspector | [inline, virtual]
FormatHint enum name | AP4_AtomInspector |
GetVerbosity() | AP4_AtomInspector | [inline]
HINT_BOOLEAN enum value | AP4_AtomInspector |
HINT_HEX enum value | AP4_AtomInspector |
HINT_NONE enum value | AP4_AtomInspector |
m_Verbosity | AP4_AtomInspector | [protected]
SetVerbosity(AP4_Ordinal verbosity) | AP4_AtomInspector | [inline]
StartElement(const char *, const char *) | AP4_AtomInspector | [inline, virtual]
~AP4_AtomInspector() | AP4_AtomInspector | [inline, virtual]
Generated on Thu May 13 16:36:48 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_AtomListInspector Class Reference

AP4_AtomListInspector Class Reference

#include <Ap4Atom.h>

Inheritance diagram for AP4_AtomListInspector:
AP4_List< T >::Item::Operator

List of all members.

Public Member Functions

AP4_AtomListInspector (AP4_AtomInspector &inspector)
AP4_Result Action (AP4_Atom *atom) const

Detailed Description

Definition at line 437 of file Ap4Atom.h.

Constructor & Destructor Documentation

AP4_AtomListInspector::AP4_AtomListInspector ( AP4_AtomInspector & inspector ) [inline]

Definition at line 440 of file Ap4Atom.h.

Member Function Documentation

AP4_Result AP4_AtomListInspector::Action ( AP4_Atom * atom ) const [inline]

Definition at line 442 of file Ap4Atom.h.

References AP4_SUCCESS, and AP4_Atom::Inspect().

The documentation for this class was generated from the following file:
  • Ap4Atom.h
Generated on Thu May 13 16:36:48 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_AtomListInspector Member List

This is the complete list of members for AP4_AtomListInspector, including all inherited members.
Action(AP4_Atom *atom) const | AP4_AtomListInspector | [inline]
AP4_List::Item::Operator::Action(T *data) const =0 | AP4_List< T >::Item::Operator | [pure virtual]
AP4_AtomListInspector(AP4_AtomInspector &inspector) | AP4_AtomListInspector | [inline]
~Operator() | AP4_List< T >::Item::Operator | [inline, virtual]
Generated on Thu May 13 16:36:48 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_AtomListWriter Class Reference

AP4_AtomListWriter Class Reference

#include <Ap4Atom.h>

Inheritance diagram for AP4_AtomListWriter:
AP4_List< T >::Item::Operator

List of all members.

Public Member Functions

AP4_AtomListWriter (AP4_ByteStream &stream)
AP4_Result Action (AP4_Atom *atom) const

Detailed Description

Definition at line 454 of file Ap4Atom.h.

Constructor & Destructor Documentation

AP4_AtomListWriter::AP4_AtomListWriter ( AP4_ByteStream & stream ) [inline]

Definition at line 457 of file Ap4Atom.h.

Member Function Documentation

AP4_Result AP4_AtomListWriter::Action ( AP4_Atom * atom ) const
The documentation for this class was generated from the following file:
  • Ap4Atom.h
Generated on Thu May 13 16:36:49 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_AtomListWriter Member List

This is the complete list of members for AP4_AtomListWriter, including all inherited members.
Action(AP4_Atom *atom) const | AP4_AtomListWriter |
AP4_List::Item::Operator::Action(T *data) const =0 | AP4_List< T >::Item::Operator | [pure virtual]
AP4_AtomListWriter(AP4_ByteStream &stream) | AP4_AtomListWriter | [inline]
~Operator() | AP4_List< T >::Item::Operator | [inline, virtual]
Generated on Thu May 13 16:36:49 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_AtomMetaDataValue Class Reference

AP4_AtomMetaDataValue Class Reference

#include <Ap4MetaData.h>

Inheritance diagram for AP4_AtomMetaDataValue:
AP4_MetaData::Value

List of all members.

Public Member Functions

AP4_AtomMetaDataValue (AP4_DataAtom *data_atom, AP4_UI32 parent_type)
virtual AP4_String | ToString () const
virtual AP4_Result | ToBytes (AP4_DataBuffer &bytes) const
virtual long | ToInteger () const

Detailed Description

Definition at line 560 of file Ap4MetaData.h.

Constructor & Destructor Documentation

AP4_AtomMetaDataValue::AP4_AtomMetaDataValue | ( | AP4_DataAtom * | data_atom,
 |  | AP4_UI32 | parent_type
 | ) |  |

Member Function Documentation

virtual AP4_Result AP4_AtomMetaDataValue::ToBytes ( AP4_DataBuffer & bytes ) const [virtual]

Implements AP4_MetaData::Value.

virtual long AP4_AtomMetaDataValue::ToInteger ( ) const [virtual]

Implements AP4_MetaData::Value.

virtual AP4_String AP4_AtomMetaDataValue::ToString ( ) const [virtual]

Implements AP4_MetaData::Value.

The documentation for this class was generated from the following file:
  • Ap4MetaData.h
Generated on Thu May 13 16:36:49 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_AtomMetaDataValue Member List

This is the complete list of members for AP4_AtomMetaDataValue, including all inherited members.
AP4_AtomMetaDataValue(AP4_DataAtom *data_atom, AP4_UI32 parent_type) | AP4_AtomMetaDataValue |
GetLanguage() const | AP4_MetaData::Value | [inline]
GetMeaning() const | AP4_MetaData::Value | [inline]
GetType() const | AP4_MetaData::Value | [inline]
GetTypeCategory() const | AP4_MetaData::Value |
m_Language | AP4_MetaData::Value | [protected]
m_Meaning | AP4_MetaData::Value | [protected]
m_Type | AP4_MetaData::Value | [protected]
MapTypeToCategory(Type type) | AP4_MetaData::Value | [protected, static]
Meaning enum name | AP4_MetaData::Value |
MEANING_BINARY_ENCODED_CHARS enum value | AP4_MetaData::Value |
MEANING_BOOLEAN enum value | AP4_MetaData::Value |
MEANING_FILE_KIND enum value | AP4_MetaData::Value |
MEANING_ID3_GENRE enum value | AP4_MetaData::Value |
MEANING_UNKNOWN enum value | AP4_MetaData::Value |
SetLanguage(const char *language) | AP4_MetaData::Value | [inline]
ToBytes(AP4_DataBuffer &bytes) const | AP4_AtomMetaDataValue | [virtual]
ToInteger() const | AP4_AtomMetaDataValue | [virtual]
ToString() const | AP4_AtomMetaDataValue | [virtual]
Type enum name | AP4_MetaData::Value |
TYPE_BINARY enum value | AP4_MetaData::Value |
TYPE_CATEGORY_BINARY enum value | AP4_MetaData::Value |
TYPE_CATEGORY_FLOAT enum value | AP4_MetaData::Value |
TYPE_CATEGORY_INTEGER enum value | AP4_MetaData::Value |
TYPE_CATEGORY_STRING enum value | AP4_MetaData::Value |
TYPE_FLOAT_32_BE enum value | AP4_MetaData::Value |
TYPE_FLOAT_64_BE enum value | AP4_MetaData::Value |
TYPE_GIF enum value | AP4_MetaData::Value |
TYPE_INT_08_BE enum value | AP4_MetaData::Value |
TYPE_INT_16_BE enum value | AP4_MetaData::Value |
TYPE_INT_32_BE enum value | AP4_MetaData::Value |
TYPE_JPEG enum value | AP4_MetaData::Value |
TYPE_STRING_PASCAL enum value | AP4_MetaData::Value |
TYPE_STRING_UTF_16 enum value | AP4_MetaData::Value |
TYPE_STRING_UTF_8 enum value | AP4_MetaData::Value |
TypeCategory enum name | AP4_MetaData::Value |
Value(Type type, Meaning meaning=MEANING_UNKNOWN, const char *language=NULL) | AP4_MetaData::Value | [inline, protected]
~Value() | AP4_MetaData::Value | [inline, virtual]
Generated on Thu May 13 16:36:49 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_AtomParent Class Reference

AP4_AtomParent Class Reference

Base class for containers of atoms. More...

#include <Ap4Atom.h>

Inheritance diagram for AP4_AtomParent:
AP4_ContainerAtom AP4_File AP4_DrefAtom AP4_IproAtom AP4_MoovAtom AP4_OdheAtom AP4_OhdrAtom AP4_SampleEntry AP4_StsdAtom AP4_TrakAtom

List of all members.

Public Member Functions

virtual | ~AP4_AtomParent ()
AP4_List< AP4_Atom > & GetChildren ()
virtual AP4_Result | AddChild (AP4_Atom *child, int position=-1)
virtual AP4_Result | RemoveChild (AP4_Atom *child)
virtual AP4_Result | DeleteChild (AP4_Atom::Type type, AP4_Ordinal index=0)
virtual AP4_Atom * | GetChild (AP4_Atom::Type type, AP4_Ordinal index=0) const
virtual AP4_Atom * | GetChild (const AP4_UI08 *uuid, AP4_Ordinal index=0) const
virtual AP4_Atom * | FindChild (const char *path, bool auto_create=false, bool auto_create_full=false)
virtual void | OnChildChanged (AP4_Atom *)
virtual void | OnChildAdded (AP4_Atom *)
virtual void | OnChildRemoved (AP4_Atom *)

Protected Attributes

AP4_List< AP4_Atom > m_Children

Detailed Description

Base class for containers of atoms.

This class also implements the logic for finding descendents by name.

Definition at line 253 of file Ap4Atom.h.

Constructor & Destructor Documentation

virtual AP4_AtomParent::~AP4_AtomParent ( ) [virtual]

Member Function Documentation

virtual AP4_Result AP4_AtomParent::AddChild | ( | AP4_Atom * | child,
 |  | int | position = -1 |
 | ) |  |  | [virtual]
virtual AP4_Result AP4_AtomParent::DeleteChild | ( | AP4_Atom::Type | type,
 |  | AP4_Ordinal | index = 0 |
 | ) |  |  | [virtual]
virtual AP4_Atom* AP4_AtomParent::FindChild | ( | const char * | path,
 |  | bool | auto_create = false,
 |  | bool | auto_create_full = false |
 | ) |  |  | [virtual]
virtual AP4_Atom* AP4_AtomParent::GetChild | ( | const AP4_UI08 * | uuid,
 |  | AP4_Ordinal | index = 0 |
 | ) |  |  | const [virtual]
virtual AP4_Atom* AP4_AtomParent::GetChild | ( | AP4_Atom::Type | type,
 |  | AP4_Ordinal | index = 0 |
 | ) |  |  | const [virtual]
AP4_List<AP4_Atom>& AP4_AtomParent::GetChildren ( ) [inline]

Reimplemented in AP4_ContainerAtom.

Definition at line 259 of file Ap4Atom.h.

References m_Children.

virtual void AP4_AtomParent::OnChildAdded ( AP4_Atom * ) [inline, virtual]

Reimplemented in AP4_ContainerAtom, and AP4_MoovAtom.

Definition at line 271 of file Ap4Atom.h.

virtual void AP4_AtomParent::OnChildChanged ( AP4_Atom * ) [inline, virtual]

Reimplemented in AP4_ContainerAtom, AP4_OdheAtom, AP4_SampleEntry, and AP4_StsdAtom.

Definition at line 270 of file Ap4Atom.h.

virtual void AP4_AtomParent::OnChildRemoved ( AP4_Atom * ) [inline, virtual]

Reimplemented in AP4_ContainerAtom, and AP4_MoovAtom.

Definition at line 272 of file Ap4Atom.h.

virtual AP4_Result AP4_AtomParent::RemoveChild ( AP4_Atom * child ) [virtual]

Member Data Documentation

AP4_List<AP4_Atom> AP4_AtomParent::m_Children [protected]

Definition at line 276 of file Ap4Atom.h.

Referenced by AP4_ContainerAtom::GetChildren(), GetChildren(), and AP4_File::GetTopLevelAtoms().

The documentation for this class was generated from the following file:
  • Ap4Atom.h
Generated on Thu May 13 16:36:49 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_AtomParent Member List

This is the complete list of members for AP4_AtomParent, including all inherited members.
AddChild(AP4_Atom *child, int position=-1) | AP4_AtomParent | [virtual]
DeleteChild(AP4_Atom::Type type, AP4_Ordinal index=0) | AP4_AtomParent | [virtual]
FindChild(const char *path, bool auto_create=false, bool auto_create_full=false) | AP4_AtomParent | [virtual]
GetChild(AP4_Atom::Type type, AP4_Ordinal index=0) const | AP4_AtomParent | [virtual]
GetChild(const AP4_UI08 *uuid, AP4_Ordinal index=0) const | AP4_AtomParent | [virtual]
GetChildren() | AP4_AtomParent | [inline]
m_Children | AP4_AtomParent | [protected]
OnChildAdded(AP4_Atom *) | AP4_AtomParent | [inline, virtual]
OnChildChanged(AP4_Atom *) | AP4_AtomParent | [inline, virtual]
OnChildRemoved(AP4_Atom *) | AP4_AtomParent | [inline, virtual]
RemoveChild(AP4_Atom *child) | AP4_AtomParent | [virtual]
~AP4_AtomParent() | AP4_AtomParent | [virtual]
Generated on Thu May 13 16:36:49 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_AtomSampleTable Class Reference

AP4_AtomSampleTable Class Reference

#include <Ap4AtomSampleTable.h>

Inheritance diagram for AP4_AtomSampleTable:
AP4_SampleTable

List of all members.

Public Member Functions

AP4_AtomSampleTable (AP4_ContainerAtom *stbl_atom, AP4_ByteStream &sample_stream)
virtual | ~AP4_AtomSampleTable ()
virtual AP4_Result | GetSample (AP4_Ordinal sample_index, AP4_Sample &sample)
virtual AP4_Cardinal | GetSampleCount ()
virtual AP4_SampleDescription * | GetSampleDescription (AP4_Ordinal sd_index)
virtual AP4_Cardinal | GetSampleDescriptionCount ()
virtual AP4_Result | GetSampleChunkPosition (AP4_Ordinal sample_index, AP4_Ordinal &chunk_index, AP4_Ordinal &position_in_chunk)
virtual AP4_Result | GetSampleIndexForTimeStamp (AP4_UI64 ts, AP4_Ordinal &sample_index)
virtual AP4_Ordinal | GetNearestSyncSampleIndex (AP4_Ordinal index, bool before=true)
virtual AP4_Result | GetChunkForSample (AP4_Ordinal sample_index, AP4_Ordinal &chunk_index, AP4_Ordinal &position_in_chunk, AP4_Ordinal &sample_description_index)
virtual AP4_Result | GetChunkOffset (AP4_Ordinal chunk_index, AP4_Position &offset)
virtual AP4_Result | SetChunkOffset (AP4_Ordinal chunk_index, AP4_Position offset)
virtual AP4_Result | SetSampleSize (AP4_Ordinal sample_index, AP4_Size size)

Detailed Description

Definition at line 55 of file Ap4AtomSampleTable.h.

Constructor & Destructor Documentation

AP4_AtomSampleTable::AP4_AtomSampleTable | ( | AP4_ContainerAtom * | stbl_atom,
 |  | AP4_ByteStream & | sample_stream
 | ) |  |
virtual AP4_AtomSampleTable::~AP4_AtomSampleTable ( ) [virtual]

Member Function Documentation

virtual AP4_Result AP4_AtomSampleTable::GetChunkForSample | ( | AP4_Ordinal | sample_index,
 |  | AP4_Ordinal & | chunk_index,
 |  | AP4_Ordinal & | position_in_chunk,
 |  | AP4_Ordinal & | sample_description_index |
 | ) |  |  | [virtual]
virtual AP4_Result AP4_AtomSampleTable::GetChunkOffset | ( | AP4_Ordinal | chunk_index,
 |  | AP4_Position & | offset |
 | ) |  |  | [virtual]
virtual AP4_Ordinal AP4_AtomSampleTable::GetNearestSyncSampleIndex | ( | AP4_Ordinal | index,
 |  | bool | before = true |
 | ) |  |  | [virtual]

Implements AP4_SampleTable.

virtual AP4_Result AP4_AtomSampleTable::GetSample | ( | AP4_Ordinal | sample_index,
 |  | AP4_Sample & | sample |
 | ) |  |  | [virtual]

Implements AP4_SampleTable.

virtual AP4_Result AP4_AtomSampleTable::GetSampleChunkPosition | ( | AP4_Ordinal | sample_index,
 |  | AP4_Ordinal & | chunk_index,
 |  | AP4_Ordinal & | position_in_chunk |
 | ) |  |  | [virtual]

Implements AP4_SampleTable.

virtual AP4_Cardinal AP4_AtomSampleTable::GetSampleCount ( ) [virtual]

Implements AP4_SampleTable.

virtual AP4_SampleDescription* AP4_AtomSampleTable::GetSampleDescription ( AP4_Ordinal sd_index ) [virtual]

Implements AP4_SampleTable.

virtual AP4_Cardinal AP4_AtomSampleTable::GetSampleDescriptionCount ( ) [virtual]

Implements AP4_SampleTable.

virtual AP4_Result AP4_AtomSampleTable::GetSampleIndexForTimeStamp | ( | AP4_UI64 | ts,
 |  | AP4_Ordinal & | sample_index |
 | ) |  |  | [virtual]

Implements AP4_SampleTable.

virtual AP4_Result AP4_AtomSampleTable::SetChunkOffset | ( | AP4_Ordinal | chunk_index,
 |  | AP4_Position | offset |
 | ) |  |  | [virtual]
virtual AP4_Result AP4_AtomSampleTable::SetSampleSize | ( | AP4_Ordinal | sample_index,
 |  | AP4_Size | size |
 | ) |  |  | [virtual]
The documentation for this class was generated from the following file:
  • Ap4AtomSampleTable.h
Generated on Thu May 13 16:36:49 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_AtomSampleTable Member List

This is the complete list of members for AP4_AtomSampleTable, including all inherited members.
AP4_AtomSampleTable(AP4_ContainerAtom *stbl_atom, AP4_ByteStream &sample_stream) | AP4_AtomSampleTable |
GenerateStblAtom(AP4_ContainerAtom *&stbl) | AP4_SampleTable | [virtual]
GetChunkForSample(AP4_Ordinal sample_index, AP4_Ordinal &chunk_index, AP4_Ordinal &position_in_chunk, AP4_Ordinal &sample_description_index) | AP4_AtomSampleTable | [virtual]
GetChunkOffset(AP4_Ordinal chunk_index, AP4_Position &offset) | AP4_AtomSampleTable | [virtual]
GetNearestSyncSampleIndex(AP4_Ordinal index, bool before=true) | AP4_AtomSampleTable | [virtual]
GetSample(AP4_Ordinal sample_index, AP4_Sample &sample) | AP4_AtomSampleTable | [virtual]
GetSampleChunkPosition(AP4_Ordinal sample_index, AP4_Ordinal &chunk_index, AP4_Ordinal &position_in_chunk) | AP4_AtomSampleTable | [virtual]
GetSampleCount() | AP4_AtomSampleTable | [virtual]
GetSampleDescription(AP4_Ordinal sd_index) | AP4_AtomSampleTable | [virtual]
GetSampleDescriptionCount() | AP4_AtomSampleTable | [virtual]
GetSampleIndexForTimeStamp(AP4_UI64 ts, AP4_Ordinal &sample_index) | AP4_AtomSampleTable | [virtual]
SetChunkOffset(AP4_Ordinal chunk_index, AP4_Position offset) | AP4_AtomSampleTable | [virtual]
SetSampleSize(AP4_Ordinal sample_index, AP4_Size size) | AP4_AtomSampleTable | [virtual]
~AP4_AtomSampleTable() | AP4_AtomSampleTable | [virtual]
~AP4_SampleTable() | AP4_SampleTable | [inline, virtual]
Generated on Thu May 13 16:36:49 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_AtomSizeAdder Class Reference

AP4_AtomSizeAdder Class Reference

#include <Ap4Atom.h>

Inheritance diagram for AP4_AtomSizeAdder:
AP4_List< T >::Item::Operator

List of all members.

Public Member Functions

AP4_AtomSizeAdder (AP4_UI64 &size)

Detailed Description

Definition at line 492 of file Ap4Atom.h.

Constructor & Destructor Documentation

AP4_AtomSizeAdder::AP4_AtomSizeAdder ( AP4_UI64 & size ) [inline]

Definition at line 494 of file Ap4Atom.h.

The documentation for this class was generated from the following file:
  • Ap4Atom.h
Generated on Thu May 13 16:36:50 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_AtomSizeAdder Member List

This is the complete list of members for AP4_AtomSizeAdder, including all inherited members.
AP4_List::Item::Operator::Action(T *data) const =0 | AP4_List< T >::Item::Operator | [pure virtual]
AP4_AtomSizeAdder(AP4_UI64 &size) | AP4_AtomSizeAdder | [inline]
~Operator() | AP4_List< T >::Item::Operator | [inline, virtual]
Generated on Thu May 13 16:36:50 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_AudioSampleDescription Class Reference

AP4_AudioSampleDescription Class Reference

#include <Ap4SampleDescription.h>

Inheritance diagram for AP4_AudioSampleDescription:
AP4_GenericAudioSampleDescription AP4_MpegAudioSampleDescription

List of all members.

Public Member Functions

AP4_AudioSampleDescription (unsigned int sample_rate, unsigned int sample_size, unsigned int channel_count)
AP4_UI32 GetSampleRate ()
AP4_UI16 GetSampleSize ()
AP4_UI16 GetChannelCount ()

Protected Attributes

AP4_UI32 m_SampleRate
AP4_UI16 m_SampleSize
AP4_UI16 m_ChannelCount

Detailed Description

Definition at line 148 of file Ap4SampleDescription.h.

Constructor & Destructor Documentation

AP4_AudioSampleDescription::AP4_AudioSampleDescription | ( | unsigned int | sample_rate,
 |  | unsigned int | sample_size,
 |  | unsigned int | channel_count |
 | ) |  |  | [inline]

Definition at line 154 of file Ap4SampleDescription.h.

Member Function Documentation

AP4_UI16 AP4_AudioSampleDescription::GetChannelCount ( ) [inline]

Definition at line 164 of file Ap4SampleDescription.h.

References m_ChannelCount.

AP4_UI32 AP4_AudioSampleDescription::GetSampleRate ( ) [inline]

Definition at line 162 of file Ap4SampleDescription.h.

References m_SampleRate.

AP4_UI16 AP4_AudioSampleDescription::GetSampleSize ( ) [inline]

Definition at line 163 of file Ap4SampleDescription.h.

References m_SampleSize.

Member Data Documentation

AP4_UI16 AP4_AudioSampleDescription::m_ChannelCount [protected]

Definition at line 170 of file Ap4SampleDescription.h.

Referenced by GetChannelCount().

AP4_UI32 AP4_AudioSampleDescription::m_SampleRate [protected]

Definition at line 168 of file Ap4SampleDescription.h.

Referenced by GetSampleRate().

AP4_UI16 AP4_AudioSampleDescription::m_SampleSize [protected]

Definition at line 169 of file Ap4SampleDescription.h.

Referenced by GetSampleSize().

The documentation for this class was generated from the following file:
  • Ap4SampleDescription.h
Generated on Thu May 13 16:36:50 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_AudioSampleDescription Member List

This is the complete list of members for AP4_AudioSampleDescription, including all inherited members.
AP4_AudioSampleDescription(unsigned int sample_rate, unsigned int sample_size, unsigned int channel_count) | AP4_AudioSampleDescription | [inline]
GetChannelCount() | AP4_AudioSampleDescription | [inline]
GetSampleRate() | AP4_AudioSampleDescription | [inline]
GetSampleSize() | AP4_AudioSampleDescription | [inline]
m_ChannelCount | AP4_AudioSampleDescription | [protected]
m_SampleRate | AP4_AudioSampleDescription | [protected]
m_SampleSize | AP4_AudioSampleDescription | [protected]
Generated on Thu May 13 16:36:50 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_AudioSampleEntry Class Reference

AP4_AudioSampleEntry Class Reference

#include <Ap4SampleEntry.h>

Inheritance diagram for AP4_AudioSampleEntry:
AP4_SampleEntry AP4_ContainerAtom AP4_Atom AP4_AtomParent AP4_EncaSampleEntry AP4_MpegAudioSampleEntry AP4_DrmsSampleEntry AP4_Mp4aSampleEntry

List of all members.

Public Member Functions

AP4_AudioSampleEntry (AP4_Atom::Type format, AP4_UI32 sample_rate, AP4_UI16 sample_size, AP4_UI16 channel_count)
AP4_AudioSampleEntry (AP4_Atom::Type format, AP4_Size size, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory)
AP4_UI32 GetSampleRate ()
AP4_UI16 GetSampleSize ()
AP4_UI16 GetChannelCount ()
AP4_SampleDescription * ToSampleDescription ()

Protected Member Functions

virtual AP4_Size | GetFieldsSize ()
virtual AP4_Result | ReadFields (AP4_ByteStream &stream)
virtual AP4_Result | WriteFields (AP4_ByteStream &stream)
virtual AP4_Result | InspectFields (AP4_AtomInspector &inspector)

Protected Attributes

AP4_UI16 m_QtVersion
AP4_UI16 m_QtRevision
AP4_UI32 m_QtVendor
AP4_UI16 m_ChannelCount
AP4_UI16 m_SampleSize
AP4_UI16 m_QtCompressionId
AP4_UI16 m_QtPacketSize
AP4_UI32 m_SampleRate
AP4_UI32 m_QtV1SamplesPerPacket
AP4_UI32 m_QtV1BytesPerPacket
AP4_UI32 m_QtV1BytesPerFrame
AP4_UI32 m_QtV1BytesPerSample
AP4_UI32 m_QtV2StructSize
double | m_QtV2SampleRate64
AP4_UI32 m_QtV2ChannelCount
AP4_UI32 m_QtV2Reserved
AP4_UI32 m_QtV2BitsPerChannel
AP4_UI32 m_QtV2FormatSpecificFlags
AP4_UI32 m_QtV2BytesPerAudioPacket
AP4_UI32 m_QtV2LPCMFramesPerAudioPacket
AP4_DataBuffer m_QtV2Extension

Detailed Description

Definition at line 116 of file Ap4SampleEntry.h.

Constructor & Destructor Documentation

AP4_AudioSampleEntry::AP4_AudioSampleEntry | ( | AP4_Atom::Type | format,
 |  | AP4_UI32 | sample_rate,
 |  | AP4_UI16 | sample_size,
 |  | AP4_UI16 | channel_count
 | ) |  |
AP4_AudioSampleEntry::AP4_AudioSampleEntry | ( | AP4_Atom::Type | format,
 |  | AP4_Size | size,
 |  | AP4_ByteStream & | stream,
 |  | AP4_AtomFactory & | atom_factory
 | ) |  |

Member Function Documentation

AP4_UI16 AP4_AudioSampleEntry::GetChannelCount ( )
virtual AP4_Size AP4_AudioSampleEntry::GetFieldsSize ( ) [protected, virtual]

Reimplemented from AP4_SampleEntry.

AP4_UI32 AP4_AudioSampleEntry::GetSampleRate ( )
AP4_UI16 AP4_AudioSampleEntry::GetSampleSize ( ) [inline]

Definition at line 131 of file Ap4SampleEntry.h.

References m_SampleSize.

virtual AP4_Result AP4_AudioSampleEntry::InspectFields ( AP4_AtomInspector & inspector ) [protected, virtual]

Reimplemented from AP4_SampleEntry.

virtual AP4_Result AP4_AudioSampleEntry::ReadFields ( AP4_ByteStream & stream ) [protected, virtual]

Reimplemented from AP4_SampleEntry.

AP4_SampleDescription* AP4_AudioSampleEntry::ToSampleDescription ( ) [virtual]

Reimplemented from AP4_SampleEntry.

Reimplemented in AP4_EncaSampleEntry, and AP4_MpegAudioSampleEntry.

virtual AP4_Result AP4_AudioSampleEntry::WriteFields ( AP4_ByteStream & stream ) [protected, virtual]

Reimplemented from AP4_SampleEntry.

Member Data Documentation

AP4_UI16 AP4_AudioSampleEntry::m_ChannelCount [protected]

Definition at line 148 of file Ap4SampleEntry.h.

AP4_UI16 AP4_AudioSampleEntry::m_QtCompressionId [protected]

Definition at line 150 of file Ap4SampleEntry.h.

AP4_UI16 AP4_AudioSampleEntry::m_QtPacketSize [protected]

Definition at line 151 of file Ap4SampleEntry.h.

AP4_UI16 AP4_AudioSampleEntry::m_QtRevision [protected]

Definition at line 146 of file Ap4SampleEntry.h.

AP4_UI32 AP4_AudioSampleEntry::m_QtV1BytesPerFrame [protected]

Definition at line 156 of file Ap4SampleEntry.h.

AP4_UI32 AP4_AudioSampleEntry::m_QtV1BytesPerPacket [protected]

Definition at line 155 of file Ap4SampleEntry.h.

AP4_UI32 AP4_AudioSampleEntry::m_QtV1BytesPerSample [protected]

Definition at line 157 of file Ap4SampleEntry.h.

AP4_UI32 AP4_AudioSampleEntry::m_QtV1SamplesPerPacket [protected]

Definition at line 154 of file Ap4SampleEntry.h.

AP4_UI32 AP4_AudioSampleEntry::m_QtV2BitsPerChannel [protected]

Definition at line 163 of file Ap4SampleEntry.h.

AP4_UI32 AP4_AudioSampleEntry::m_QtV2BytesPerAudioPacket [protected]

Definition at line 165 of file Ap4SampleEntry.h.

AP4_UI32 AP4_AudioSampleEntry::m_QtV2ChannelCount [protected]

Definition at line 161 of file Ap4SampleEntry.h.

AP4_DataBuffer AP4_AudioSampleEntry::m_QtV2Extension [protected]

Definition at line 167 of file Ap4SampleEntry.h.

AP4_UI32 AP4_AudioSampleEntry::m_QtV2FormatSpecificFlags [protected]

Definition at line 164 of file Ap4SampleEntry.h.

AP4_UI32 AP4_AudioSampleEntry::m_QtV2LPCMFramesPerAudioPacket [protected]

Definition at line 166 of file Ap4SampleEntry.h.

AP4_UI32 AP4_AudioSampleEntry::m_QtV2Reserved [protected]

Definition at line 162 of file Ap4SampleEntry.h.

double AP4_AudioSampleEntry::m_QtV2SampleRate64 [protected]

Definition at line 160 of file Ap4SampleEntry.h.

AP4_UI32 AP4_AudioSampleEntry::m_QtV2StructSize [protected]

Definition at line 159 of file Ap4SampleEntry.h.

AP4_UI32 AP4_AudioSampleEntry::m_QtVendor [protected]

Definition at line 147 of file Ap4SampleEntry.h.

AP4_UI16 AP4_AudioSampleEntry::m_QtVersion [protected]

Definition at line 145 of file Ap4SampleEntry.h.

AP4_UI32 AP4_AudioSampleEntry::m_SampleRate [protected]

Definition at line 152 of file Ap4SampleEntry.h.

AP4_UI16 AP4_AudioSampleEntry::m_SampleSize [protected]

Definition at line 149 of file Ap4SampleEntry.h.

Referenced by GetSampleSize().

The documentation for this class was generated from the following file:
  • Ap4SampleEntry.h
Generated on Thu May 13 16:36:51 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_AudioSampleEntry Member List

This is the complete list of members for AP4_AudioSampleEntry, including all inherited members.
AddChild(AP4_Atom *child, int position=-1) | AP4_AtomParent | [virtual]
AP4_Atom(Type type, AP4_UI32 size=AP4_ATOM_HEADER_SIZE) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64=false) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_AudioSampleEntry(AP4_Atom::Type format, AP4_UI32 sample_rate, AP4_UI16 sample_size, AP4_UI16 channel_count) | AP4_AudioSampleEntry |
AP4_AudioSampleEntry(AP4_Atom::Type format, AP4_Size size, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_AudioSampleEntry |
AP4_ContainerAtom(Type type) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI32 version, AP4_UI32 flags) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_ContainerAtom | [protected]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_ContainerAtom | [protected]
AP4_SampleEntry(AP4_Atom::Type format, AP4_UI16 data_ref_index=1) | AP4_SampleEntry |
AP4_SampleEntry(AP4_Atom::Type format, AP4_Size size, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_SampleEntry |
AP4_SampleEntry(AP4_Atom::Type format, AP4_Size size) | AP4_SampleEntry | [protected]
Clone() | AP4_ContainerAtom | [virtual]
Create(Type type, AP4_UI64 size, bool is_full, bool force_64, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_ContainerAtom | [static]
DeleteChild(AP4_Atom::Type type, AP4_Ordinal index=0) | AP4_AtomParent | [virtual]
Detach() | AP4_Atom | [virtual]
FindChild(const char *path, bool auto_create=false, bool auto_create_full=false) | AP4_AtomParent | [virtual]
GetChannelCount() | AP4_AudioSampleEntry |
GetChild(AP4_Atom::Type type, AP4_Ordinal index=0) const | AP4_AtomParent | [virtual]
GetChild(const AP4_UI08 *uuid, AP4_Ordinal index=0) const | AP4_AtomParent | [virtual]
GetChildren() | AP4_ContainerAtom | [inline]
GetDataReferenceIndex() | AP4_SampleEntry | [inline]
GetFieldsSize() | AP4_AudioSampleEntry | [protected, virtual]
GetFlags() const | AP4_Atom | [inline]
GetHeaderSize() const | AP4_Atom | [virtual]
GetParent() | AP4_Atom | [inline, virtual]
GetSampleRate() | AP4_AudioSampleEntry |
GetSampleSize() | AP4_AudioSampleEntry | [inline]
GetSize() const | AP4_Atom | [inline]
GetSize32() const | AP4_Atom | [inline]
GetSize64() const | AP4_Atom | [inline]
GetType() const | AP4_Atom | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_SampleEntry | [virtual]
InspectChildren(AP4_AtomInspector &inspector) | AP4_ContainerAtom | [virtual]
InspectFields(AP4_AtomInspector &inspector) | AP4_AudioSampleEntry | [protected, virtual]
InspectHeader(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
m_ChannelCount | AP4_AudioSampleEntry | [protected]
m_Children | AP4_AtomParent | [protected]
m_DataReferenceIndex | AP4_SampleEntry | [protected]
m_Flags | AP4_Atom | [protected]
m_IsFull | AP4_Atom | [protected]
m_Parent | AP4_Atom | [protected]
m_QtCompressionId | AP4_AudioSampleEntry | [protected]
m_QtPacketSize | AP4_AudioSampleEntry | [protected]
m_QtRevision | AP4_AudioSampleEntry | [protected]
m_QtV1BytesPerFrame | AP4_AudioSampleEntry | [protected]
m_QtV1BytesPerPacket | AP4_AudioSampleEntry | [protected]
m_QtV1BytesPerSample | AP4_AudioSampleEntry | [protected]
m_QtV1SamplesPerPacket | AP4_AudioSampleEntry | [protected]
m_QtV2BitsPerChannel | AP4_AudioSampleEntry | [protected]
m_QtV2BytesPerAudioPacket | AP4_AudioSampleEntry | [protected]
m_QtV2ChannelCount | AP4_AudioSampleEntry | [protected]
m_QtV2Extension | AP4_AudioSampleEntry | [protected]
m_QtV2FormatSpecificFlags | AP4_AudioSampleEntry | [protected]
m_QtV2LPCMFramesPerAudioPacket | AP4_AudioSampleEntry | [protected]
m_QtV2Reserved | AP4_AudioSampleEntry | [protected]
m_QtV2SampleRate64 | AP4_AudioSampleEntry | [protected]
m_QtV2StructSize | AP4_AudioSampleEntry | [protected]
m_QtVendor | AP4_AudioSampleEntry | [protected]
m_QtVersion | AP4_AudioSampleEntry | [protected]
m_Reserved1 | AP4_SampleEntry | [protected]
m_SampleRate | AP4_AudioSampleEntry | [protected]
m_SampleSize | AP4_AudioSampleEntry | [protected]
m_Size32 | AP4_Atom | [protected]
m_Size64 | AP4_Atom | [protected]
m_Type | AP4_Atom | [protected]
m_Version | AP4_Atom | [protected]
OnChildAdded(AP4_Atom *child) | AP4_ContainerAtom | [virtual]
OnChildChanged(AP4_Atom *child) | AP4_SampleEntry | [virtual]
OnChildRemoved(AP4_Atom *child) | AP4_ContainerAtom | [virtual]
Read(AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_SampleEntry | [protected, virtual]
ReadChildren(AP4_AtomFactory &atom_factory, AP4_ByteStream &stream, AP4_UI64 size) | AP4_ContainerAtom | [protected]
ReadFields(AP4_ByteStream &stream) | AP4_AudioSampleEntry | [protected, virtual]
ReadFullHeader(AP4_ByteStream &stream, AP4_UI32 &version, AP4_UI32 &flags) | AP4_Atom | [static]
RemoveChild(AP4_Atom *child) | AP4_AtomParent | [virtual]
SetFlags(AP4_UI32 flags) | AP4_Atom | [inline]
SetParent(AP4_AtomParent *parent) | AP4_Atom | [inline, virtual]
SetSize(AP4_UI64 size, bool force_64=false) | AP4_Atom |
SetSize32(AP4_UI32 size) | AP4_Atom | [inline]
SetSize64(AP4_UI64 size) | AP4_Atom | [inline]
SetType(Type type) | AP4_Atom | [inline]
ToSampleDescription() | AP4_AudioSampleEntry | [virtual]
Type typedef | AP4_Atom |
TypeFromString(const char *four_cc) | AP4_Atom | [static]
Write(AP4_ByteStream &stream) | AP4_SampleEntry | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_AudioSampleEntry | [protected, virtual]
WriteHeader(AP4_ByteStream &stream) | AP4_Atom | [virtual]
~AP4_Atom() | AP4_Atom | [inline, virtual]
~AP4_AtomParent() | AP4_AtomParent | [virtual]
~AP4_SampleEntry() | AP4_SampleEntry | [inline, virtual]
Generated on Thu May 13 16:36:51 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_Avc1SampleEntry Class Reference

AP4_Avc1SampleEntry Class Reference

#include <Ap4SampleEntry.h>

Inheritance diagram for AP4_Avc1SampleEntry:
AP4_VisualSampleEntry AP4_SampleEntry AP4_ContainerAtom AP4_Atom AP4_AtomParent

List of all members.

Public Member Functions

AP4_Avc1SampleEntry (AP4_Size size, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory)
AP4_Avc1SampleEntry (AP4_UI16 width, AP4_UI16 height, AP4_UI16 depth, const char *compressor_name, const AP4_AvccAtom &avcc)
virtual AP4_SampleDescription * ToSampleDescription ()

Detailed Description

Definition at line 333 of file Ap4SampleEntry.h.

Constructor & Destructor Documentation

AP4_Avc1SampleEntry::AP4_Avc1SampleEntry | ( | AP4_Size | size,
 |  | AP4_ByteStream & | stream,
 |  | AP4_AtomFactory & | atom_factory
 | ) |  |
AP4_Avc1SampleEntry::AP4_Avc1SampleEntry | ( | AP4_UI16 | width,
 |  | AP4_UI16 | height,
 |  | AP4_UI16 | depth,
 |  | const char * | compressor_name,
 |  | const AP4_AvccAtom & | avcc
 | ) |  |

Member Function Documentation

virtual AP4_SampleDescription* AP4_Avc1SampleEntry::ToSampleDescription ( ) [virtual]

Reimplemented from AP4_VisualSampleEntry.

The documentation for this class was generated from the following file:
  • Ap4SampleEntry.h
Generated on Thu May 13 16:36:51 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_Avc1SampleEntry Member List

This is the complete list of members for AP4_Avc1SampleEntry, including all inherited members.
AddChild(AP4_Atom *child, int position=-1) | AP4_AtomParent | [virtual]
AP4_Atom(Type type, AP4_UI32 size=AP4_ATOM_HEADER_SIZE) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64=false) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_Avc1SampleEntry(AP4_Size size, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_Avc1SampleEntry |
AP4_Avc1SampleEntry(AP4_UI16 width, AP4_UI16 height, AP4_UI16 depth, const char *compressor_name, const AP4_AvccAtom &avcc) | AP4_Avc1SampleEntry |
AP4_ContainerAtom(Type type) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI32 version, AP4_UI32 flags) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_ContainerAtom | [protected]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_ContainerAtom | [protected]
AP4_SampleEntry(AP4_Atom::Type format, AP4_UI16 data_ref_index=1) | AP4_SampleEntry |
AP4_SampleEntry(AP4_Atom::Type format, AP4_Size size, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_SampleEntry |
AP4_SampleEntry(AP4_Atom::Type format, AP4_Size size) | AP4_SampleEntry | [protected]
AP4_VisualSampleEntry(AP4_Atom::Type format, AP4_UI16 width, AP4_UI16 height, AP4_UI16 depth, const char *compressor_name) | AP4_VisualSampleEntry |
AP4_VisualSampleEntry(AP4_Atom::Type format, AP4_Size size, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_VisualSampleEntry |
Clone() | AP4_ContainerAtom | [virtual]
Create(Type type, AP4_UI64 size, bool is_full, bool force_64, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_ContainerAtom | [static]
DeleteChild(AP4_Atom::Type type, AP4_Ordinal index=0) | AP4_AtomParent | [virtual]
Detach() | AP4_Atom | [virtual]
FindChild(const char *path, bool auto_create=false, bool auto_create_full=false) | AP4_AtomParent | [virtual]
GetChild(AP4_Atom::Type type, AP4_Ordinal index=0) const | AP4_AtomParent | [virtual]
GetChild(const AP4_UI08 *uuid, AP4_Ordinal index=0) const | AP4_AtomParent | [virtual]
GetChildren() | AP4_ContainerAtom | [inline]
GetCompressorName() | AP4_VisualSampleEntry | [inline]
GetDataReferenceIndex() | AP4_SampleEntry | [inline]
GetDepth() | AP4_VisualSampleEntry | [inline]
GetFieldsSize() | AP4_VisualSampleEntry | [protected, virtual]
GetFlags() const | AP4_Atom | [inline]
GetHeaderSize() const | AP4_Atom | [virtual]
GetHeight() | AP4_VisualSampleEntry | [inline]
GetHorizResolution() | AP4_VisualSampleEntry | [inline]
GetParent() | AP4_Atom | [inline, virtual]
GetSize() const | AP4_Atom | [inline]
GetSize32() const | AP4_Atom | [inline]
GetSize64() const | AP4_Atom | [inline]
GetType() const | AP4_Atom | [inline]
GetVertResolution() | AP4_VisualSampleEntry | [inline]
GetWidth() | AP4_VisualSampleEntry | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_SampleEntry | [virtual]
InspectChildren(AP4_AtomInspector &inspector) | AP4_ContainerAtom | [virtual]
InspectFields(AP4_AtomInspector &inspector) | AP4_VisualSampleEntry | [protected, virtual]
InspectHeader(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
m_Children | AP4_AtomParent | [protected]
m_CompressorName | AP4_VisualSampleEntry | [protected]
m_DataReferenceIndex | AP4_SampleEntry | [protected]
m_Depth | AP4_VisualSampleEntry | [protected]
m_Flags | AP4_Atom | [protected]
m_FrameCount | AP4_VisualSampleEntry | [protected]
m_Height | AP4_VisualSampleEntry | [protected]
m_HorizResolution | AP4_VisualSampleEntry | [protected]
m_IsFull | AP4_Atom | [protected]
m_Parent | AP4_Atom | [protected]
m_Predefined1 | AP4_VisualSampleEntry | [protected]
m_Predefined2 | AP4_VisualSampleEntry | [protected]
m_Predefined3 | AP4_VisualSampleEntry | [protected]
m_Reserved1 | AP4_SampleEntry | [protected]
m_Reserved2 | AP4_VisualSampleEntry | [protected]
m_Reserved3 | AP4_VisualSampleEntry | [protected]
m_Size32 | AP4_Atom | [protected]
m_Size64 | AP4_Atom | [protected]
m_Type | AP4_Atom | [protected]
m_Version | AP4_Atom | [protected]
m_VertResolution | AP4_VisualSampleEntry | [protected]
m_Width | AP4_VisualSampleEntry | [protected]
OnChildAdded(AP4_Atom *child) | AP4_ContainerAtom | [virtual]
OnChildChanged(AP4_Atom *child) | AP4_SampleEntry | [virtual]
OnChildRemoved(AP4_Atom *child) | AP4_ContainerAtom | [virtual]
Read(AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_SampleEntry | [protected, virtual]
ReadChildren(AP4_AtomFactory &atom_factory, AP4_ByteStream &stream, AP4_UI64 size) | AP4_ContainerAtom | [protected]
ReadFields(AP4_ByteStream &stream) | AP4_VisualSampleEntry | [protected, virtual]
ReadFullHeader(AP4_ByteStream &stream, AP4_UI32 &version, AP4_UI32 &flags) | AP4_Atom | [static]
RemoveChild(AP4_Atom *child) | AP4_AtomParent | [virtual]
SetFlags(AP4_UI32 flags) | AP4_Atom | [inline]
SetParent(AP4_AtomParent *parent) | AP4_Atom | [inline, virtual]
SetSize(AP4_UI64 size, bool force_64=false) | AP4_Atom |
SetSize32(AP4_UI32 size) | AP4_Atom | [inline]
SetSize64(AP4_UI64 size) | AP4_Atom | [inline]
SetType(Type type) | AP4_Atom | [inline]
ToSampleDescription() | AP4_Avc1SampleEntry | [virtual]
Type typedef | AP4_Atom |
TypeFromString(const char *four_cc) | AP4_Atom | [static]
Write(AP4_ByteStream &stream) | AP4_SampleEntry | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_VisualSampleEntry | [protected, virtual]
WriteHeader(AP4_ByteStream &stream) | AP4_Atom | [virtual]
~AP4_Atom() | AP4_Atom | [inline, virtual]
~AP4_AtomParent() | AP4_AtomParent | [virtual]
~AP4_SampleEntry() | AP4_SampleEntry | [inline, virtual]
Generated on Thu May 13 16:36:51 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_AvccAtom Class Reference

AP4_AvccAtom Class Reference

#include <Ap4AvccAtom.h>

Inheritance diagram for AP4_AvccAtom:
AP4_Atom

List of all members.

Public Member Functions

AP4_AvccAtom ()
AP4_AvccAtom (AP4_UI08 profile, AP4_UI08 level, AP4_UI08 profile_compatibility, AP4_UI08 length_size, const AP4_Array< AP4_DataBuffer > &sequence_parameters, const AP4_Array< AP4_DataBuffer > &picture_parameters)
AP4_AvccAtom (const AP4_AvccAtom &other)
virtual AP4_Result | InspectFields (AP4_AtomInspector &inspector)
virtual AP4_Result | WriteFields (AP4_ByteStream &stream)
AP4_UI08 | GetConfigurationVersion () const
AP4_UI08 | GetProfile () const
AP4_UI08 | GetLevel () const
AP4_UI08 | GetProfileCompatibility () const
AP4_UI08 | GetNaluLengthSize () const
AP4_Array< AP4_DataBuffer > & GetSequenceParameters ()
AP4_Array< AP4_DataBuffer > & GetPictureParameters ()
const AP4_DataBuffer & | GetRawBytes () const

Static Public Member Functions

static AP4_AvccAtom * | Create (AP4_Size size, AP4_ByteStream &stream)
static const char * | GetProfileName (AP4_UI08 profile)

Detailed Description

Definition at line 53 of file Ap4AvccAtom.h.

Constructor & Destructor Documentation

AP4_AvccAtom::AP4_AvccAtom ( )
AP4_AvccAtom::AP4_AvccAtom | ( | AP4_UI08 | profile,
 |  | AP4_UI08 | level,
 |  | AP4_UI08 | profile_compatibility,
 |  | AP4_UI08 | length_size,
 |  | const AP4_Array< AP4_DataBuffer > & | sequence_parameters,
 |  | const AP4_Array< AP4_DataBuffer > & | picture_parameters
 | ) |  |
AP4_AvccAtom::AP4_AvccAtom ( const AP4_AvccAtom & other )

Member Function Documentation

static AP4_AvccAtom* AP4_AvccAtom::Create | ( | AP4_Size | size,
 |  | AP4_ByteStream & | stream |
 | ) |  |  | [static]
AP4_UI08 AP4_AvccAtom::GetConfigurationVersion ( ) const [inline]

Definition at line 77 of file Ap4AvccAtom.h.

Referenced by AP4_AvcSampleDescription::GetConfigurationVersion().

AP4_UI08 AP4_AvccAtom::GetLevel ( ) const [inline]

Definition at line 79 of file Ap4AvccAtom.h.

Referenced by AP4_AvcSampleDescription::GetLevel().

AP4_UI08 AP4_AvccAtom::GetNaluLengthSize ( ) const [inline]

Definition at line 81 of file Ap4AvccAtom.h.

Referenced by AP4_AvcSampleDescription::GetNaluLengthSize().

AP4_Array<AP4_DataBuffer>& AP4_AvccAtom::GetPictureParameters ( ) [inline]

Definition at line 83 of file Ap4AvccAtom.h.

Referenced by AP4_AvcSampleDescription::GetPictureParameters().

AP4_UI08 AP4_AvccAtom::GetProfile ( ) const [inline]

Definition at line 78 of file Ap4AvccAtom.h.

Referenced by AP4_AvcSampleDescription::GetProfile().

AP4_UI08 AP4_AvccAtom::GetProfileCompatibility ( ) const [inline]

Definition at line 80 of file Ap4AvccAtom.h.

Referenced by AP4_AvcSampleDescription::GetProfileCompatibility().

static const char* AP4_AvccAtom::GetProfileName ( AP4_UI08 profile ) [static]
const AP4_DataBuffer& AP4_AvccAtom::GetRawBytes ( ) const [inline]

Definition at line 84 of file Ap4AvccAtom.h.

Referenced by AP4_AvcSampleDescription::GetRawBytes().

AP4_Array<AP4_DataBuffer>& AP4_AvccAtom::GetSequenceParameters ( ) [inline]

Definition at line 82 of file Ap4AvccAtom.h.

Referenced by AP4_AvcSampleDescription::GetSequenceParameters().

virtual AP4_Result AP4_AvccAtom::InspectFields ( AP4_AtomInspector & inspector ) [virtual]

Reimplemented from AP4_Atom.

virtual AP4_Result AP4_AvccAtom::WriteFields ( AP4_ByteStream & stream ) [virtual]

Implements AP4_Atom.

The documentation for this class was generated from the following file:
  • Ap4AvccAtom.h
Generated on Thu May 13 16:36:51 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_AvccAtom Member List

This is the complete list of members for AP4_AvccAtom, including all inherited members.
AP4_Atom(Type type, AP4_UI32 size=AP4_ATOM_HEADER_SIZE) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64=false) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_AvccAtom() | AP4_AvccAtom |
AP4_AvccAtom(AP4_UI08 profile, AP4_UI08 level, AP4_UI08 profile_compatibility, AP4_UI08 length_size, const AP4_Array< AP4_DataBuffer > &sequence_parameters, const AP4_Array< AP4_DataBuffer > &picture_parameters) | AP4_AvccAtom |
AP4_AvccAtom(const AP4_AvccAtom &other) | AP4_AvccAtom |
Clone() | AP4_Atom | [virtual]
Create(AP4_Size size, AP4_ByteStream &stream) | AP4_AvccAtom | [static]
Detach() | AP4_Atom | [virtual]
GetConfigurationVersion() const | AP4_AvccAtom | [inline]
GetFlags() const | AP4_Atom | [inline]
GetHeaderSize() const | AP4_Atom | [virtual]
GetLevel() const | AP4_AvccAtom | [inline]
GetNaluLengthSize() const | AP4_AvccAtom | [inline]
GetParent() | AP4_Atom | [inline, virtual]
GetPictureParameters() | AP4_AvccAtom | [inline]
GetProfile() const | AP4_AvccAtom | [inline]
GetProfileCompatibility() const | AP4_AvccAtom | [inline]
GetProfileName(AP4_UI08 profile) | AP4_AvccAtom | [static]
GetRawBytes() const | AP4_AvccAtom | [inline]
GetSequenceParameters() | AP4_AvccAtom | [inline]
GetSize() const | AP4_Atom | [inline]
GetSize32() const | AP4_Atom | [inline]
GetSize64() const | AP4_Atom | [inline]
GetType() const | AP4_Atom | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
InspectFields(AP4_AtomInspector &inspector) | AP4_AvccAtom | [virtual]
InspectHeader(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
m_Flags | AP4_Atom | [protected]
m_IsFull | AP4_Atom | [protected]
m_Parent | AP4_Atom | [protected]
m_Size32 | AP4_Atom | [protected]
m_Size64 | AP4_Atom | [protected]
m_Type | AP4_Atom | [protected]
m_Version | AP4_Atom | [protected]
ReadFullHeader(AP4_ByteStream &stream, AP4_UI32 &version, AP4_UI32 &flags) | AP4_Atom | [static]
SetFlags(AP4_UI32 flags) | AP4_Atom | [inline]
SetParent(AP4_AtomParent *parent) | AP4_Atom | [inline, virtual]
SetSize(AP4_UI64 size, bool force_64=false) | AP4_Atom |
SetSize32(AP4_UI32 size) | AP4_Atom | [inline]
SetSize64(AP4_UI64 size) | AP4_Atom | [inline]
SetType(Type type) | AP4_Atom | [inline]
Type typedef | AP4_Atom |
TypeFromString(const char *four_cc) | AP4_Atom | [static]
Write(AP4_ByteStream &stream) | AP4_Atom | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_AvccAtom | [virtual]
WriteHeader(AP4_ByteStream &stream) | AP4_Atom | [virtual]
~AP4_Atom() | AP4_Atom | [inline, virtual]
Generated on Thu May 13 16:36:51 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_AvcSampleDescription Class Reference

AP4_AvcSampleDescription Class Reference

#include <Ap4SampleDescription.h>

Inheritance diagram for AP4_AvcSampleDescription:
AP4_SampleDescription AP4_VideoSampleDescription

List of all members.

Public Member Functions

AP4_AvcSampleDescription (AP4_UI16 width, AP4_UI16 height, AP4_UI16 depth, const char *compressor_name, const AP4_AvccAtom *avcc)
AP4_AvcSampleDescription (AP4_UI16 width, AP4_UI16 height, AP4_UI16 depth, const char *compressor_name, AP4_AtomParent *details)
AP4_AvcSampleDescription (AP4_UI16 width, AP4_UI16 height, AP4_UI16 depth, const char *compressor_name, AP4_UI08 profile, AP4_UI08 level, AP4_UI08 profile_compatibility, AP4_UI08 nalu_length_size, const AP4_Array< AP4_DataBuffer > &sequence_parameters, const AP4_Array< AP4_DataBuffer > &picture_parameters)
AP4_UI08 | GetConfigurationVersion () const
AP4_UI08 | GetProfile () const
AP4_UI08 | GetLevel () const
AP4_UI08 | GetProfileCompatibility () const
AP4_UI08 | GetNaluLengthSize () const
AP4_Array< AP4_DataBuffer > & GetSequenceParameters ()
AP4_Array< AP4_DataBuffer > & GetPictureParameters ()
const AP4_DataBuffer & | GetRawBytes () const
virtual AP4_Atom * | ToAtom () const

Static Public Member Functions

static const char * | GetProfileName (AP4_UI08 profile)

Detailed Description

Definition at line 247 of file Ap4SampleDescription.h.

Constructor & Destructor Documentation

AP4_AvcSampleDescription::AP4_AvcSampleDescription | ( | AP4_UI16 | width,
 |  | AP4_UI16 | height,
 |  | AP4_UI16 | depth,
 |  | const char * | compressor_name,
 |  | const AP4_AvccAtom * | avcc
 | ) |  |
AP4_AvcSampleDescription::AP4_AvcSampleDescription | ( | AP4_UI16 | width,
 |  | AP4_UI16 | height,
 |  | AP4_UI16 | depth,
 |  | const char * | compressor_name,
 |  | AP4_AtomParent * | details
 | ) |  |
AP4_AvcSampleDescription::AP4_AvcSampleDescription | ( | AP4_UI16 | width,
 |  | AP4_UI16 | height,
 |  | AP4_UI16 | depth,
 |  | const char * | compressor_name,
 |  | AP4_UI08 | profile,
 |  | AP4_UI08 | level,
 |  | AP4_UI08 | profile_compatibility,
 |  | AP4_UI08 | nalu_length_size,
 |  | const AP4_Array< AP4_DataBuffer > & | sequence_parameters,
 |  | const AP4_Array< AP4_DataBuffer > & | picture_parameters
 | ) |  |

Member Function Documentation

AP4_UI08 AP4_AvcSampleDescription::GetConfigurationVersion ( ) const [inline]

Definition at line 278 of file Ap4SampleDescription.h.

References AP4_AvccAtom::GetConfigurationVersion().

AP4_UI08 AP4_AvcSampleDescription::GetLevel ( ) const [inline]

Definition at line 280 of file Ap4SampleDescription.h.

References AP4_AvccAtom::GetLevel().

AP4_UI08 AP4_AvcSampleDescription::GetNaluLengthSize ( ) const [inline]

Definition at line 282 of file Ap4SampleDescription.h.

References AP4_AvccAtom::GetNaluLengthSize().

AP4_Array<AP4_DataBuffer>& AP4_AvcSampleDescription::GetPictureParameters ( ) [inline]

Definition at line 284 of file Ap4SampleDescription.h.

References AP4_AvccAtom::GetPictureParameters().

AP4_UI08 AP4_AvcSampleDescription::GetProfile ( ) const [inline]

Definition at line 279 of file Ap4SampleDescription.h.

References AP4_AvccAtom::GetProfile().

AP4_UI08 AP4_AvcSampleDescription::GetProfileCompatibility ( ) const [inline]

Definition at line 281 of file Ap4SampleDescription.h.

References AP4_AvccAtom::GetProfileCompatibility().

static const char* AP4_AvcSampleDescription::GetProfileName ( AP4_UI08 profile ) [inline, static]

Definition at line 291 of file Ap4SampleDescription.h.

const AP4_DataBuffer& AP4_AvcSampleDescription::GetRawBytes ( ) const [inline]

Definition at line 285 of file Ap4SampleDescription.h.

References AP4_AvccAtom::GetRawBytes().

AP4_Array<AP4_DataBuffer>& AP4_AvcSampleDescription::GetSequenceParameters ( ) [inline]

Definition at line 283 of file Ap4SampleDescription.h.

References AP4_AvccAtom::GetSequenceParameters().

virtual AP4_Atom* AP4_AvcSampleDescription::ToAtom ( ) const [virtual]

Reimplemented from AP4_SampleDescription.

The documentation for this class was generated from the following file:
  • Ap4SampleDescription.h
Generated on Thu May 13 16:36:51 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_AvcSampleDescription Member List

This is the complete list of members for AP4_AvcSampleDescription, including all inherited members.
AP4_AvcSampleDescription(AP4_UI16 width, AP4_UI16 height, AP4_UI16 depth, const char *compressor_name, const AP4_AvccAtom *avcc) | AP4_AvcSampleDescription |
AP4_AvcSampleDescription(AP4_UI16 width, AP4_UI16 height, AP4_UI16 depth, const char *compressor_name, AP4_AtomParent *details) | AP4_AvcSampleDescription |
AP4_AvcSampleDescription(AP4_UI16 width, AP4_UI16 height, AP4_UI16 depth, const char *compressor_name, AP4_UI08 profile, AP4_UI08 level, AP4_UI08 profile_compatibility, AP4_UI08 nalu_length_size, const AP4_Array< AP4_DataBuffer > &sequence_parameters, const AP4_Array< AP4_DataBuffer > &picture_parameters) | AP4_AvcSampleDescription |
AP4_SampleDescription(Type type, AP4_UI32 format, AP4_AtomParent *details) | AP4_SampleDescription |
AP4_VideoSampleDescription(AP4_UI16 width, AP4_UI16 height, AP4_UI16 depth, const char *compressor_name) | AP4_VideoSampleDescription | [inline]
Clone(AP4_Result *result=NULL) | AP4_SampleDescription | [virtual]
GetCompressorName() | AP4_VideoSampleDescription | [inline]
GetConfigurationVersion() const | AP4_AvcSampleDescription | [inline]
GetDepth() | AP4_VideoSampleDescription | [inline]
GetDetails() | AP4_SampleDescription | [inline]
GetFormat() const | AP4_SampleDescription | [inline]
GetHeight() | AP4_VideoSampleDescription | [inline]
GetLevel() const | AP4_AvcSampleDescription | [inline]
GetNaluLengthSize() const | AP4_AvcSampleDescription | [inline]
GetPictureParameters() | AP4_AvcSampleDescription | [inline]
GetProfile() const | AP4_AvcSampleDescription | [inline]
GetProfileCompatibility() const | AP4_AvcSampleDescription | [inline]
GetProfileName(AP4_UI08 profile) | AP4_AvcSampleDescription | [inline, static]
GetRawBytes() const | AP4_AvcSampleDescription | [inline]
GetSequenceParameters() | AP4_AvcSampleDescription | [inline]
GetType() const | AP4_SampleDescription | [inline]
GetWidth() | AP4_VideoSampleDescription | [inline]
m_CompressorName | AP4_VideoSampleDescription | [protected]
m_Depth | AP4_VideoSampleDescription | [protected]
m_Details | AP4_SampleDescription | [protected]
m_Format | AP4_SampleDescription | [protected]
m_Height | AP4_VideoSampleDescription | [protected]
m_Type | AP4_SampleDescription | [protected]
m_Width | AP4_VideoSampleDescription | [protected]
ToAtom() const | AP4_AvcSampleDescription | [virtual]
Type enum name | AP4_SampleDescription |
TYPE_AVC enum value | AP4_SampleDescription |
TYPE_MPEG enum value | AP4_SampleDescription |
TYPE_PROTECTED enum value | AP4_SampleDescription |
TYPE_UNKNOWN enum value | AP4_SampleDescription |
~AP4_SampleDescription() | AP4_SampleDescription | [inline, virtual]
Generated on Thu May 13 16:36:51 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_BinaryMetaDataValue Class Reference

AP4_BinaryMetaDataValue Class Reference

#include <Ap4MetaData.h>

Inheritance diagram for AP4_BinaryMetaDataValue:
AP4_MetaData::Value

List of all members.

Public Member Functions

AP4_BinaryMetaDataValue (Type type, const AP4_UI08 *data, AP4_Size size)
virtual AP4_String | ToString () const
virtual AP4_Result | ToBytes (AP4_DataBuffer &bytes) const
virtual long | ToInteger () const

Detailed Description

Definition at line 541 of file Ap4MetaData.h.

Constructor & Destructor Documentation

AP4_BinaryMetaDataValue::AP4_BinaryMetaDataValue | ( | Type | type,
 |  | const AP4_UI08 * | data,
 |  | AP4_Size | size |
 | ) |  |  | [inline]

Definition at line 544 of file Ap4MetaData.h.

Member Function Documentation

virtual AP4_Result AP4_BinaryMetaDataValue::ToBytes ( AP4_DataBuffer & bytes ) const [virtual]

Implements AP4_MetaData::Value.

virtual long AP4_BinaryMetaDataValue::ToInteger ( ) const [virtual]

Implements AP4_MetaData::Value.

virtual AP4_String AP4_BinaryMetaDataValue::ToString ( ) const [virtual]

Implements AP4_MetaData::Value.

The documentation for this class was generated from the following file:
  • Ap4MetaData.h
Generated on Thu May 13 16:36:51 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_BinaryMetaDataValue Member List

This is the complete list of members for AP4_BinaryMetaDataValue, including all inherited members.
AP4_BinaryMetaDataValue(Type type, const AP4_UI08 *data, AP4_Size size) | AP4_BinaryMetaDataValue | [inline]
GetLanguage() const | AP4_MetaData::Value | [inline]
GetMeaning() const | AP4_MetaData::Value | [inline]
GetType() const | AP4_MetaData::Value | [inline]
GetTypeCategory() const | AP4_MetaData::Value |
m_Language | AP4_MetaData::Value | [protected]
m_Meaning | AP4_MetaData::Value | [protected]
m_Type | AP4_MetaData::Value | [protected]
MapTypeToCategory(Type type) | AP4_MetaData::Value | [protected, static]
Meaning enum name | AP4_MetaData::Value |
MEANING_BINARY_ENCODED_CHARS enum value | AP4_MetaData::Value |
MEANING_BOOLEAN enum value | AP4_MetaData::Value |
MEANING_FILE_KIND enum value | AP4_MetaData::Value |
MEANING_ID3_GENRE enum value | AP4_MetaData::Value |
MEANING_UNKNOWN enum value | AP4_MetaData::Value |
SetLanguage(const char *language) | AP4_MetaData::Value | [inline]
ToBytes(AP4_DataBuffer &bytes) const | AP4_BinaryMetaDataValue | [virtual]
ToInteger() const | AP4_BinaryMetaDataValue | [virtual]
ToString() const | AP4_BinaryMetaDataValue | [virtual]
Type enum name | AP4_MetaData::Value |
TYPE_BINARY enum value | AP4_MetaData::Value |
TYPE_CATEGORY_BINARY enum value | AP4_MetaData::Value |
TYPE_CATEGORY_FLOAT enum value | AP4_MetaData::Value |
TYPE_CATEGORY_INTEGER enum value | AP4_MetaData::Value |
TYPE_CATEGORY_STRING enum value | AP4_MetaData::Value |
TYPE_FLOAT_32_BE enum value | AP4_MetaData::Value |
TYPE_FLOAT_64_BE enum value | AP4_MetaData::Value |
TYPE_GIF enum value | AP4_MetaData::Value |
TYPE_INT_08_BE enum value | AP4_MetaData::Value |
TYPE_INT_16_BE enum value | AP4_MetaData::Value |
TYPE_INT_32_BE enum value | AP4_MetaData::Value |
TYPE_JPEG enum value | AP4_MetaData::Value |
TYPE_STRING_PASCAL enum value | AP4_MetaData::Value |
TYPE_STRING_UTF_16 enum value | AP4_MetaData::Value |
TYPE_STRING_UTF_8 enum value | AP4_MetaData::Value |
TypeCategory enum name | AP4_MetaData::Value |
Value(Type type, Meaning meaning=MEANING_UNKNOWN, const char *language=NULL) | AP4_MetaData::Value | [inline, protected]
~Value() | AP4_MetaData::Value | [inline, virtual]
Generated on Thu May 13 16:36:51 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_BitWriter Class Reference

AP4_BitWriter Class Reference

#include <Ap4Utils.h>

List of all members.

Public Member Functions

AP4_BitWriter (AP4_Size size)
~AP4_BitWriter ()
void | Write (AP4_UI32 bits, unsigned int bit_count)
unsigned int | GetBitCount ()
const unsigned char * | GetData ()

Detailed Description

Definition at line 187 of file Ap4Utils.h.

Constructor & Destructor Documentation

AP4_BitWriter::AP4_BitWriter ( AP4_Size size ) [inline]

Definition at line 190 of file Ap4Utils.h.

AP4_BitWriter::~AP4_BitWriter ( ) [inline]

Definition at line 198 of file Ap4Utils.h.

Member Function Documentation

unsigned int AP4_BitWriter::GetBitCount ( ) [inline]

Definition at line 202 of file Ap4Utils.h.

const unsigned char* AP4_BitWriter::GetData ( ) [inline]

Definition at line 203 of file Ap4Utils.h.

void AP4_BitWriter::Write | ( | AP4_UI32 | bits,
 |  | unsigned int | bit_count
 | ) |  |
The documentation for this class was generated from the following file:
  • Ap4Utils.h
Generated on Thu May 13 16:36:52 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_BitWriter Member List

This is the complete list of members for AP4_BitWriter, including all inherited members.
AP4_BitWriter(AP4_Size size) | AP4_BitWriter | [inline]
GetBitCount() | AP4_BitWriter | [inline]
GetData() | AP4_BitWriter | [inline]
Write(AP4_UI32 bits, unsigned int bit_count) | AP4_BitWriter |
~AP4_BitWriter() | AP4_BitWriter | [inline]
Generated on Thu May 13 16:36:52 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_BlockCipher Class Reference

AP4_BlockCipher Class Reference

#include <Ap4Protection.h>

Inheritance diagram for AP4_BlockCipher:
AP4_AesBlockCipher

List of all members.

Public Types

enum CipherDirection {
ENCRYPT,
DECRYPT
}
enum | CipherType { AES_128 }

Public Member Functions

virtual | ~AP4_BlockCipher ()
virtual AP4_Result | ProcessBlock (const AP4_UI08 *block_in, AP4_UI08 *block_out)=0

Detailed Description

Definition at line 259 of file Ap4Protection.h.

Member Enumeration Documentation

enum AP4_BlockCipher::CipherDirection
Enumerator:
ENCRYPT
DECRYPT

Definition at line 263 of file Ap4Protection.h.

enum AP4_BlockCipher::CipherType
Enumerator:
AES_128

Definition at line 268 of file Ap4Protection.h.

Constructor & Destructor Documentation

virtual AP4_BlockCipher::~AP4_BlockCipher ( ) [inline, virtual]

Definition at line 273 of file Ap4Protection.h.

Member Function Documentation

virtual AP4_Result AP4_BlockCipher::ProcessBlock | ( | const AP4_UI08 * | block_in,
 |  | AP4_UI08 * | block_out |
 | ) |  |  | [pure virtual]

Implemented in AP4_AesBlockCipher.

The documentation for this class was generated from the following file:
  • Ap4Protection.h
Generated on Thu May 13 16:36:52 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_BlockCipher Member List

This is the complete list of members for AP4_BlockCipher, including all inherited members.
AES_128 enum value | AP4_BlockCipher |
CipherDirection enum name | AP4_BlockCipher |
CipherType enum name | AP4_BlockCipher |
DECRYPT enum value | AP4_BlockCipher |
ENCRYPT enum value | AP4_BlockCipher |
ProcessBlock(const AP4_UI08 *block_in, AP4_UI08 *block_out)=0 | AP4_BlockCipher | [pure virtual]
~AP4_BlockCipher() | AP4_BlockCipher | [inline, virtual]
Generated on Thu May 13 16:36:52 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_BlockCipherFactory Class Reference

AP4_BlockCipherFactory Class Reference

#include <Ap4Protection.h>

Inheritance diagram for AP4_BlockCipherFactory:
AP4_DefaultBlockCipherFactory

List of all members.

Public Member Functions

virtual | ~AP4_BlockCipherFactory ()
virtual AP4_Result | Create (AP4_BlockCipher::CipherType type, AP4_BlockCipher::CipherDirection direction, const AP4_UI08 *key, AP4_Size key_size, AP4_BlockCipher *&cipher)=0

Detailed Description

Definition at line 282 of file Ap4Protection.h.

Constructor & Destructor Documentation

virtual AP4_BlockCipherFactory::~AP4_BlockCipherFactory ( ) [inline, virtual]

Definition at line 286 of file Ap4Protection.h.

Member Function Documentation

virtual AP4_Result AP4_BlockCipherFactory::Create | ( | AP4_BlockCipher::CipherType | type,
 |  | AP4_BlockCipher::CipherDirection | direction,
 |  | const AP4_UI08 * | key,
 |  | AP4_Size | key_size,
 |  | AP4_BlockCipher *& | cipher |
 | ) |  |  | [pure virtual]

Implemented in AP4_DefaultBlockCipherFactory.

The documentation for this class was generated from the following file:
  • Ap4Protection.h
Generated on Thu May 13 16:36:52 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_BlockCipherFactory Member List

This is the complete list of members for AP4_BlockCipherFactory, including all inherited members.
Create(AP4_BlockCipher::CipherType type, AP4_BlockCipher::CipherDirection direction, const AP4_UI08 *key, AP4_Size key_size, AP4_BlockCipher *&cipher)=0 | AP4_BlockCipherFactory | [pure virtual]
~AP4_BlockCipherFactory() | AP4_BlockCipherFactory | [inline, virtual]
Generated on Thu May 13 16:36:52 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_BufferedInputStream Class Reference

AP4_BufferedInputStream Class Reference

#include <Ap4ByteStream.h>

Inheritance diagram for AP4_BufferedInputStream:
AP4_ByteStream AP4_Referenceable

List of all members.

Public Member Functions

AP4_BufferedInputStream (AP4_ByteStream &source, AP4_Size buffer_size=4096, AP4_Size seek_as_read_threshold=1024 *128)
AP4_Result | ReadPartial (void *buffer, AP4_Size bytes_to_read, AP4_Size &bytes_read)
AP4_Result | WritePartial (const void *buffer, AP4_Size bytes_to_write, AP4_Size &bytes_written)
AP4_Result | Seek (AP4_Position position)
AP4_Result | Tell (AP4_Position &position)
AP4_Result | GetSize (AP4_LargeSize &size)
void | AddReference ()
void | Release ()

Protected Member Functions

~AP4_BufferedInputStream ()
AP4_Result Refill ()

Detailed Description

Definition at line 167 of file Ap4ByteStream.h.

Constructor & Destructor Documentation

AP4_BufferedInputStream::AP4_BufferedInputStream | ( | AP4_ByteStream & | source,
 |  | AP4_Size | buffer_size = 4096,
 |  | AP4_Size | seek_as_read_threshold = 1024 *128
 | ) |  |
AP4_BufferedInputStream::~AP4_BufferedInputStream ( ) [inline, protected]

Definition at line 190 of file Ap4ByteStream.h.

References AP4_Referenceable::Release().

Member Function Documentation

void AP4_BufferedInputStream::AddReference ( ) [virtual]

Implements AP4_Referenceable.

AP4_Result AP4_BufferedInputStream::GetSize ( AP4_LargeSize & size ) [inline, virtual]

Implements AP4_ByteStream.

Definition at line 183 of file Ap4ByteStream.h.

References AP4_ByteStream::GetSize().

AP4_Result AP4_BufferedInputStream::ReadPartial | ( | void * | buffer,
 |  | AP4_Size | bytes_to_read,
 |  | AP4_Size & | bytes_read |
 | ) |  |  | [virtual]

Implements AP4_ByteStream.

AP4_Result AP4_BufferedInputStream::Refill ( ) [protected]
void AP4_BufferedInputStream::Release ( ) [virtual]

Implements AP4_Referenceable.

AP4_Result AP4_BufferedInputStream::Seek ( AP4_Position position ) [virtual]

Implements AP4_ByteStream.

AP4_Result AP4_BufferedInputStream::Tell ( AP4_Position & position ) [virtual]

Implements AP4_ByteStream.

AP4_Result AP4_BufferedInputStream::WritePartial | ( | const void * | buffer,
 |  | AP4_Size | bytes_to_write,
 |  | AP4_Size & | bytes_written |
 | ) |  |  | [virtual]

Implements AP4_ByteStream.

The documentation for this class was generated from the following file:
  • Ap4ByteStream.h
Generated on Thu May 13 16:36:52 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_BufferedInputStream Member List

This is the complete list of members for AP4_BufferedInputStream, including all inherited members.
AddReference() | AP4_BufferedInputStream | [virtual]
AP4_BufferedInputStream(AP4_ByteStream &source, AP4_Size buffer_size=4096, AP4_Size seek_as_read_threshold=1024 *128) | AP4_BufferedInputStream |
CopyTo(AP4_ByteStream &stream, AP4_LargeSize size) | AP4_ByteStream | [virtual]
Flush() | AP4_ByteStream | [inline, virtual]
GetSize(AP4_LargeSize &size) | AP4_BufferedInputStream | [inline, virtual]
Read(void *buffer, AP4_Size bytes_to_read) | AP4_ByteStream |
ReadDouble(double &value) | AP4_ByteStream |
ReadPartial(void *buffer, AP4_Size bytes_to_read, AP4_Size &bytes_read) | AP4_BufferedInputStream | [virtual]
ReadString(char *buffer, AP4_Size size) | AP4_ByteStream |
ReadUI08(AP4_UI08 &value) | AP4_ByteStream |
ReadUI16(AP4_UI16 &value) | AP4_ByteStream |
ReadUI24(AP4_UI32 &value) | AP4_ByteStream |
ReadUI32(AP4_UI32 &value) | AP4_ByteStream |
ReadUI64(AP4_UI64 &value) | AP4_ByteStream |
Refill() | AP4_BufferedInputStream | [protected]
Release() | AP4_BufferedInputStream | [virtual]
Seek(AP4_Position position) | AP4_BufferedInputStream | [virtual]
Tell(AP4_Position &position) | AP4_BufferedInputStream | [virtual]
Write(const void *buffer, AP4_Size bytes_to_write) | AP4_ByteStream |
WriteDouble(double value) | AP4_ByteStream |
WritePartial(const void *buffer, AP4_Size bytes_to_write, AP4_Size &bytes_written) | AP4_BufferedInputStream | [virtual]
WriteString(const char *string_buffer) | AP4_ByteStream |
WriteUI08(AP4_UI08 value) | AP4_ByteStream |
WriteUI16(AP4_UI16 value) | AP4_ByteStream |
WriteUI24(AP4_UI32 value) | AP4_ByteStream |
WriteUI32(AP4_UI32 value) | AP4_ByteStream |
WriteUI64(AP4_UI64 value) | AP4_ByteStream |
~AP4_BufferedInputStream() | AP4_BufferedInputStream | [inline, protected]
~AP4_Referenceable() | AP4_Referenceable | [inline, virtual]
Generated on Thu May 13 16:36:52 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_ByteStream Class Reference

AP4_ByteStream Class Reference

#include <Ap4ByteStream.h>

Inheritance diagram for AP4_ByteStream:
AP4_Referenceable AP4_BufferedInputStream AP4_DecryptingStream AP4_EncryptingStream AP4_FileByteStream AP4_MemoryByteStream AP4_SubStream

List of all members.

Public Member Functions

virtual AP4_Result | ReadPartial (void *buffer, AP4_Size bytes_to_read, AP4_Size &bytes_read)=0
AP4_Result | Read (void *buffer, AP4_Size bytes_to_read)
AP4_Result | ReadDouble (double &value)
AP4_Result | ReadUI64 (AP4_UI64 &value)
AP4_Result | ReadUI32 (AP4_UI32 &value)
AP4_Result | ReadUI24 (AP4_UI32 &value)
AP4_Result | ReadUI16 (AP4_UI16 &value)
AP4_Result | ReadUI08 (AP4_UI08 &value)
AP4_Result | ReadString (char *buffer, AP4_Size size)
virtual AP4_Result | WritePartial (const void *buffer, AP4_Size bytes_to_write, AP4_Size &bytes_written)=0
AP4_Result | Write (const void *buffer, AP4_Size bytes_to_write)
AP4_Result | WriteString (const char *string_buffer)
AP4_Result | WriteDouble (double value)
AP4_Result | WriteUI64 (AP4_UI64 value)
AP4_Result | WriteUI32 (AP4_UI32 value)
AP4_Result | WriteUI24 (AP4_UI32 value)
AP4_Result | WriteUI16 (AP4_UI16 value)
AP4_Result | WriteUI08 (AP4_UI08 value)
virtual AP4_Result | Seek (AP4_Position position)=0
virtual AP4_Result | Tell (AP4_Position &position)=0
virtual AP4_Result | GetSize (AP4_LargeSize &size)=0
virtual AP4_Result | CopyTo (AP4_ByteStream &stream, AP4_LargeSize size)
virtual AP4_Result | Flush ()

Detailed Description

Definition at line 43 of file Ap4ByteStream.h.

Member Function Documentation

virtual AP4_Result AP4_ByteStream::CopyTo | ( | AP4_ByteStream & | stream,
 |  | AP4_LargeSize | size |
 | ) |  |  | [virtual]
virtual AP4_Result AP4_ByteStream::Flush ( ) [inline, virtual]

Reimplemented in AP4_FileByteStream.

Definition at line 73 of file Ap4ByteStream.h.

References AP4_SUCCESS.

Referenced by AP4_FileByteStream::Flush().

virtual AP4_Result AP4_ByteStream::GetSize ( AP4_LargeSize & size ) [pure virtual]

Implemented in AP4_SubStream, AP4_MemoryByteStream, AP4_BufferedInputStream, AP4_FileByteStream, AP4_DecryptingStream, and AP4_EncryptingStream.

Referenced by AP4_FileByteStream::GetSize(), and AP4_BufferedInputStream::GetSize().

AP4_Result AP4_ByteStream::Read | ( | void * | buffer,
 |  | AP4_Size | bytes_to_read
 | ) |  |
AP4_Result AP4_ByteStream::ReadDouble ( double & value )
virtual AP4_Result AP4_ByteStream::ReadPartial | ( | void * | buffer,
 |  | AP4_Size | bytes_to_read,
 |  | AP4_Size & | bytes_read |
 | ) |  |  | [pure virtual]

Implemented in AP4_SubStream, AP4_MemoryByteStream, AP4_BufferedInputStream, AP4_FileByteStream, AP4_DecryptingStream, and AP4_EncryptingStream.

Referenced by AP4_FileByteStream::ReadPartial().

AP4_Result AP4_ByteStream::ReadString | ( | char * | buffer,
 |  | AP4_Size | size
 | ) |  |
AP4_Result AP4_ByteStream::ReadUI08 ( AP4_UI08 & value )
AP4_Result AP4_ByteStream::ReadUI16 ( AP4_UI16 & value )
AP4_Result AP4_ByteStream::ReadUI24 ( AP4_UI32 & value )
AP4_Result AP4_ByteStream::ReadUI32 ( AP4_UI32 & value )
AP4_Result AP4_ByteStream::ReadUI64 ( AP4_UI64 & value )
virtual AP4_Result AP4_ByteStream::Seek ( AP4_Position position ) [pure virtual]

Implemented in AP4_SubStream, AP4_MemoryByteStream, AP4_BufferedInputStream, AP4_FileByteStream, AP4_DecryptingStream, and AP4_EncryptingStream.

Referenced by AP4_FileByteStream::Seek().

virtual AP4_Result AP4_ByteStream::Tell ( AP4_Position & position ) [pure virtual]

Implemented in AP4_SubStream, AP4_MemoryByteStream, AP4_BufferedInputStream, AP4_FileByteStream, AP4_DecryptingStream, and AP4_EncryptingStream.

Referenced by AP4_FileByteStream::Tell().

AP4_Result AP4_ByteStream::Write | ( | const void * | buffer,
 |  | AP4_Size | bytes_to_write
 | ) |  |
AP4_Result AP4_ByteStream::WriteDouble ( double value )
virtual AP4_Result AP4_ByteStream::WritePartial | ( | const void * | buffer,
 |  | AP4_Size | bytes_to_write,
 |  | AP4_Size & | bytes_written |
 | ) |  |  | [pure virtual]

Implemented in AP4_SubStream, AP4_MemoryByteStream, AP4_BufferedInputStream, AP4_FileByteStream, AP4_DecryptingStream, and AP4_EncryptingStream.

Referenced by AP4_FileByteStream::WritePartial().

AP4_Result AP4_ByteStream::WriteString ( const char * string_buffer )
AP4_Result AP4_ByteStream::WriteUI08 ( AP4_UI08 value )
AP4_Result AP4_ByteStream::WriteUI16 ( AP4_UI16 value )
AP4_Result AP4_ByteStream::WriteUI24 ( AP4_UI32 value )
AP4_Result AP4_ByteStream::WriteUI32 ( AP4_UI32 value )
AP4_Result AP4_ByteStream::WriteUI64 ( AP4_UI64 value )
The documentation for this class was generated from the following file:
  • Ap4ByteStream.h
Generated on Thu May 13 16:36:53 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_ByteStream Member List

This is the complete list of members for AP4_ByteStream, including all inherited members.
AddReference()=0 | AP4_Referenceable | [pure virtual]
CopyTo(AP4_ByteStream &stream, AP4_LargeSize size) | AP4_ByteStream | [virtual]
Flush() | AP4_ByteStream | [inline, virtual]
GetSize(AP4_LargeSize &size)=0 | AP4_ByteStream | [pure virtual]
Read(void *buffer, AP4_Size bytes_to_read) | AP4_ByteStream |
ReadDouble(double &value) | AP4_ByteStream |
ReadPartial(void *buffer, AP4_Size bytes_to_read, AP4_Size &bytes_read)=0 | AP4_ByteStream | [pure virtual]
ReadString(char *buffer, AP4_Size size) | AP4_ByteStream |
ReadUI08(AP4_UI08 &value) | AP4_ByteStream |
ReadUI16(AP4_UI16 &value) | AP4_ByteStream |
ReadUI24(AP4_UI32 &value) | AP4_ByteStream |
ReadUI32(AP4_UI32 &value) | AP4_ByteStream |
ReadUI64(AP4_UI64 &value) | AP4_ByteStream |
Release()=0 | AP4_Referenceable | [pure virtual]
Seek(AP4_Position position)=0 | AP4_ByteStream | [pure virtual]
Tell(AP4_Position &position)=0 | AP4_ByteStream | [pure virtual]
Write(const void *buffer, AP4_Size bytes_to_write) | AP4_ByteStream |
WriteDouble(double value) | AP4_ByteStream |
WritePartial(const void *buffer, AP4_Size bytes_to_write, AP4_Size &bytes_written)=0 | AP4_ByteStream | [pure virtual]
WriteString(const char *string_buffer) | AP4_ByteStream |
WriteUI08(AP4_UI08 value) | AP4_ByteStream |
WriteUI16(AP4_UI16 value) | AP4_ByteStream |
WriteUI24(AP4_UI32 value) | AP4_ByteStream |
WriteUI32(AP4_UI32 value) | AP4_ByteStream |
WriteUI64(AP4_UI64 value) | AP4_ByteStream |
~AP4_Referenceable() | AP4_Referenceable | [inline, virtual]
Generated on Thu May 13 16:36:53 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_CbcStreamCipher Class Reference

AP4_CbcStreamCipher Class Reference

#include <Ap4StreamCipher.h>

Inheritance diagram for AP4_CbcStreamCipher:
AP4_StreamCipher

List of all members.

Public Member Functions

AP4_CbcStreamCipher (AP4_BlockCipher *block_cipher, CipherDirection direction)
The block cipher is passed with transfer of ownership (it will be destroyed when this object is destroyed).
~AP4_CbcStreamCipher ()
virtual AP4_Result | SetStreamOffset (AP4_UI64 offset, AP4_Cardinal *preroll)
virtual AP4_UI64 | GetStreamOffset ()
virtual AP4_Result | ProcessBuffer (const AP4_UI08 *in, AP4_Size in_size, AP4_UI08 *out, AP4_Size *out_size, bool is_last_buffer=false)
virtual AP4_Result | SetIV (const AP4_UI08 *iv)
virtual const AP4_UI08 * | GetIV ()

Detailed Description

Definition at line 125 of file Ap4StreamCipher.h.

Constructor & Destructor Documentation

AP4_CbcStreamCipher::AP4_CbcStreamCipher | ( | AP4_BlockCipher * | block_cipher,
 |  | CipherDirection | direction
 | ) |  |

The block cipher is passed with transfer of ownership (it will be destroyed when this object is destroyed).

AP4_CbcStreamCipher::~AP4_CbcStreamCipher ( )

Member Function Documentation

virtual const AP4_UI08* AP4_CbcStreamCipher::GetIV ( ) [inline, virtual]

Implements AP4_StreamCipher.

Definition at line 147 of file Ap4StreamCipher.h.

virtual AP4_UI64 AP4_CbcStreamCipher::GetStreamOffset ( ) [inline, virtual]

Implements AP4_StreamCipher.

Definition at line 140 of file Ap4StreamCipher.h.

virtual AP4_Result AP4_CbcStreamCipher::ProcessBuffer | ( | const AP4_UI08 * | in,
 |  | AP4_Size | in_size,
 |  | AP4_UI08 * | out,
 |  | AP4_Size * | out_size,
 |  | bool | is_last_buffer = false |
 | ) |  |  | [virtual]

Implements AP4_StreamCipher.

virtual AP4_Result AP4_CbcStreamCipher::SetIV ( const AP4_UI08 * iv ) [virtual]

Implements AP4_StreamCipher.

virtual AP4_Result AP4_CbcStreamCipher::SetStreamOffset | ( | AP4_UI64 | offset,
 |  | AP4_Cardinal * | preroll |
 | ) |  |  | [virtual]

Implements AP4_StreamCipher.

The documentation for this class was generated from the following file:
  • Ap4StreamCipher.h
Generated on Thu May 13 16:36:53 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_CbcStreamCipher Member List

This is the complete list of members for AP4_CbcStreamCipher, including all inherited members.
AP4_CbcStreamCipher(AP4_BlockCipher *block_cipher, CipherDirection direction) | AP4_CbcStreamCipher |
CipherDirection enum name | AP4_StreamCipher |
DECRYPT enum value | AP4_StreamCipher |
ENCRYPT enum value | AP4_StreamCipher |
GetIV() | AP4_CbcStreamCipher | [inline, virtual]
GetStreamOffset() | AP4_CbcStreamCipher | [inline, virtual]
ProcessBuffer(const AP4_UI08 *in, AP4_Size in_size, AP4_UI08 *out, AP4_Size *out_size, bool is_last_buffer=false) | AP4_CbcStreamCipher | [virtual]
SetIV(const AP4_UI08 *iv) | AP4_CbcStreamCipher | [virtual]
SetStreamOffset(AP4_UI64 offset, AP4_Cardinal *preroll) | AP4_CbcStreamCipher | [virtual]
~AP4_CbcStreamCipher() | AP4_CbcStreamCipher |
~AP4_StreamCipher() | AP4_StreamCipher | [inline, virtual]
Generated on Thu May 13 16:36:53 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_Co64Atom Class Reference

AP4_Co64Atom Class Reference

#include <Ap4Co64Atom.h>

Inheritance diagram for AP4_Co64Atom:
AP4_Atom

List of all members.

Public Member Functions

AP4_Co64Atom (AP4_UI64 *offsets, AP4_UI32 offset_count)
~AP4_Co64Atom ()
virtual AP4_Result | InspectFields (AP4_AtomInspector &inspector)
virtual AP4_Result | WriteFields (AP4_ByteStream &stream)
AP4_Cardinal GetChunkCount ()
AP4_UI64 * GetChunkOffsets ()
AP4_Result | GetChunkOffset (AP4_Ordinal chunk, AP4_UI64 &chunk_offset)
AP4_Result | SetChunkOffset (AP4_Ordinal chunk, AP4_UI64 chunk_offset)
AP4_Result | AdjustChunkOffsets (AP4_SI64 delta)

Static Public Member Functions

static AP4_Co64Atom * | Create (AP4_Size size, AP4_ByteStream &stream)

Detailed Description

Definition at line 41 of file Ap4Co64Atom.h.

Constructor & Destructor Documentation

AP4_Co64Atom::AP4_Co64Atom | ( | AP4_UI64 * | offsets,
 |  | AP4_UI32 | offset_count
 | ) |  |
AP4_Co64Atom::~AP4_Co64Atom ( )

Member Function Documentation

AP4_Result AP4_Co64Atom::AdjustChunkOffsets ( AP4_SI64 delta )
static AP4_Co64Atom* AP4_Co64Atom::Create | ( | AP4_Size | size,
 |  | AP4_ByteStream & | stream |
 | ) |  |  | [static]
AP4_Cardinal AP4_Co64Atom::GetChunkCount ( ) [inline]

Definition at line 54 of file Ap4Co64Atom.h.

AP4_Result AP4_Co64Atom::GetChunkOffset | ( | AP4_Ordinal | chunk,
 |  | AP4_UI64 & | chunk_offset
 | ) |  |
AP4_UI64* AP4_Co64Atom::GetChunkOffsets ( ) [inline]

Definition at line 55 of file Ap4Co64Atom.h.

virtual AP4_Result AP4_Co64Atom::InspectFields ( AP4_AtomInspector & inspector ) [virtual]

Reimplemented from AP4_Atom.

AP4_Result AP4_Co64Atom::SetChunkOffset | ( | AP4_Ordinal | chunk,
 |  | AP4_UI64 | chunk_offset
 | ) |  |
virtual AP4_Result AP4_Co64Atom::WriteFields ( AP4_ByteStream & stream ) [virtual]

Implements AP4_Atom.

The documentation for this class was generated from the following file:
  • Ap4Co64Atom.h
Generated on Thu May 13 16:36:53 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_Co64Atom Member List

This is the complete list of members for AP4_Co64Atom, including all inherited members.
AdjustChunkOffsets(AP4_SI64 delta) | AP4_Co64Atom |
AP4_Atom(Type type, AP4_UI32 size=AP4_ATOM_HEADER_SIZE) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64=false) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_Co64Atom(AP4_UI64 *offsets, AP4_UI32 offset_count) | AP4_Co64Atom |
Clone() | AP4_Atom | [virtual]
Create(AP4_Size size, AP4_ByteStream &stream) | AP4_Co64Atom | [static]
Detach() | AP4_Atom | [virtual]
GetChunkCount() | AP4_Co64Atom | [inline]
GetChunkOffset(AP4_Ordinal chunk, AP4_UI64 &chunk_offset) | AP4_Co64Atom |
GetChunkOffsets() | AP4_Co64Atom | [inline]
GetFlags() const | AP4_Atom | [inline]
GetHeaderSize() const | AP4_Atom | [virtual]
GetParent() | AP4_Atom | [inline, virtual]
GetSize() const | AP4_Atom | [inline]
GetSize32() const | AP4_Atom | [inline]
GetSize64() const | AP4_Atom | [inline]
GetType() const | AP4_Atom | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
InspectFields(AP4_AtomInspector &inspector) | AP4_Co64Atom | [virtual]
InspectHeader(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
m_Flags | AP4_Atom | [protected]
m_IsFull | AP4_Atom | [protected]
m_Parent | AP4_Atom | [protected]
m_Size32 | AP4_Atom | [protected]
m_Size64 | AP4_Atom | [protected]
m_Type | AP4_Atom | [protected]
m_Version | AP4_Atom | [protected]
ReadFullHeader(AP4_ByteStream &stream, AP4_UI32 &version, AP4_UI32 &flags) | AP4_Atom | [static]
SetChunkOffset(AP4_Ordinal chunk, AP4_UI64 chunk_offset) | AP4_Co64Atom |
SetFlags(AP4_UI32 flags) | AP4_Atom | [inline]
SetParent(AP4_AtomParent *parent) | AP4_Atom | [inline, virtual]
SetSize(AP4_UI64 size, bool force_64=false) | AP4_Atom |
SetSize32(AP4_UI32 size) | AP4_Atom | [inline]
SetSize64(AP4_UI64 size) | AP4_Atom | [inline]
SetType(Type type) | AP4_Atom | [inline]
Type typedef | AP4_Atom |
TypeFromString(const char *four_cc) | AP4_Atom | [static]
Write(AP4_ByteStream &stream) | AP4_Atom | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_Co64Atom | [virtual]
WriteHeader(AP4_ByteStream &stream) | AP4_Atom | [virtual]
~AP4_Atom() | AP4_Atom | [inline, virtual]
~AP4_Co64Atom() | AP4_Co64Atom |
Generated on Thu May 13 16:36:53 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_Command Class Reference

AP4_Command Class Reference

#include <Ap4Command.h>

Inheritance diagram for AP4_Command:
AP4_Expandable AP4_DescriptorUpdateCommand AP4_UnknownCommand

List of all members.

Public Member Functions

AP4_Command (AP4_UI08 tag, AP4_Size header_size, AP4_Size payload_size)
virtual AP4_Result Inspect (AP4_AtomInspector &inspector)
AP4_UI08 GetTag ()

Detailed Description

Definition at line 53 of file Ap4Command.h.

Constructor & Destructor Documentation

AP4_Command::AP4_Command | ( | AP4_UI08 | tag,
 |  | AP4_Size | header_size,
 |  | AP4_Size | payload_size |
 | ) |  |  | [inline]

Definition at line 59 of file Ap4Command.h.

Member Function Documentation

AP4_UI08 AP4_Command::GetTag ( ) [inline]

Definition at line 66 of file Ap4Command.h.

References AP4_Expandable::m_ClassId.

virtual AP4_Result AP4_Command::Inspect ( AP4_AtomInspector & inspector ) [virtual]

Reimplemented from AP4_Expandable.

Reimplemented in AP4_DescriptorUpdateCommand.

The documentation for this class was generated from the following file:
  • Ap4Command.h
Generated on Thu May 13 16:36:53 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_Command Member List

This is the complete list of members for AP4_Command, including all inherited members.
AP4_Command(AP4_UI08 tag, AP4_Size header_size, AP4_Size payload_size) | AP4_Command | [inline]
AP4_Expandable(AP4_UI32 class_id, ClassIdSize class_id_size, AP4_Size header_size, AP4_Size payload_size) | AP4_Expandable |
CLASS_ID_SIZE_08 enum value | AP4_Expandable |
ClassIdSize enum name | AP4_Expandable |
GetClassId() | AP4_Expandable | [inline]
GetHeaderSize() | AP4_Expandable | [inline]
GetSize() | AP4_Expandable | [inline]
GetTag() | AP4_Command | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_Command | [virtual]
m_ClassId | AP4_Expandable | [protected]
m_ClassIdSize | AP4_Expandable | [protected]
m_HeaderSize | AP4_Expandable | [protected]
m_PayloadSize | AP4_Expandable | [protected]
MinHeaderSize(AP4_Size payload_size) | AP4_Expandable | [static]
Write(AP4_ByteStream &stream) | AP4_Expandable | [virtual]
WriteFields(AP4_ByteStream &stream)=0 | AP4_Expandable | [pure virtual]
~AP4_Expandable() | AP4_Expandable | [inline, virtual]
Generated on Thu May 13 16:36:53 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_CommandFactory Class Reference

AP4_CommandFactory Class Reference

#include <Ap4CommandFactory.h>

List of all members.

Static Public Member Functions

static AP4_Result CreateCommandFromStream (AP4_ByteStream &stream, AP4_Command *&command)

Detailed Description

Definition at line 46 of file Ap4CommandFactory.h.

Member Function Documentation

static AP4_Result AP4_CommandFactory::CreateCommandFromStream | ( | AP4_ByteStream & | stream,
 |  | AP4_Command *& | command |
 | ) |  |  | [static]
The documentation for this class was generated from the following file:
  • Ap4CommandFactory.h
Generated on Thu May 13 16:36:53 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_CommandFactory Member List

This is the complete list of members for AP4_CommandFactory, including all inherited members.
CreateCommandFromStream(AP4_ByteStream &stream, AP4_Command *&command) AP4_CommandFactory [static]
Generated on Thu May 13 16:36:53 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_ContainerAtom Class Reference

AP4_ContainerAtom Class Reference

#include <Ap4ContainerAtom.h>

Inheritance diagram for AP4_ContainerAtom:
AP4_Atom AP4_AtomParent AP4_DrefAtom AP4_IproAtom AP4_MoovAtom AP4_OdheAtom AP4_OhdrAtom AP4_SampleEntry AP4_StsdAtom AP4_TrakAtom

List of all members.

Public Member Functions

AP4_ContainerAtom (Type type)
AP4_ContainerAtom (Type type, AP4_UI32 version, AP4_UI32 flags)
AP4_ContainerAtom (Type type, AP4_UI64 size, bool force_64)
AP4_ContainerAtom (Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags)
AP4_List< AP4_Atom > & GetChildren ()
virtual AP4_Result | InspectFields (AP4_AtomInspector &inspector)
virtual AP4_Result | InspectChildren (AP4_AtomInspector &inspector)
virtual AP4_Result | WriteFields (AP4_ByteStream &stream)
virtual AP4_Atom * | Clone ()
Create a clone of the object.
virtual void | OnChildChanged (AP4_Atom *child)
virtual void | OnChildAdded (AP4_Atom *child)
virtual void | OnChildRemoved (AP4_Atom *child)

Static Public Member Functions

static AP4_ContainerAtom * | Create (Type type, AP4_UI64 size, bool is_full, bool force_64, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory)

Protected Member Functions

AP4_ContainerAtom (Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory)
AP4_ContainerAtom (Type type, AP4_UI64 size, bool force_64, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory)
void | ReadChildren (AP4_AtomFactory &atom_factory, AP4_ByteStream &stream, AP4_UI64 size)

Detailed Description

Definition at line 48 of file Ap4ContainerAtom.h.

Constructor & Destructor Documentation

AP4_ContainerAtom::AP4_ContainerAtom ( Type type ) [explicit]
AP4_ContainerAtom::AP4_ContainerAtom | ( | Type | type,
 |  | AP4_UI32 | version,
 |  | AP4_UI32 | flags |
 | ) |  |  | [explicit]
AP4_ContainerAtom::AP4_ContainerAtom | ( | Type | type,
 |  | AP4_UI64 | size,
 |  | bool | force_64 |
 | ) |  |  | [explicit]
AP4_ContainerAtom::AP4_ContainerAtom | ( | Type | type,
 |  | AP4_UI64 | size,
 |  | bool | force_64,
 |  | AP4_UI32 | version,
 |  | AP4_UI32 | flags |
 | ) |  |  | [explicit]
AP4_ContainerAtom::AP4_ContainerAtom | ( | Type | type,
 |  | AP4_UI64 | size,
 |  | bool | force_64,
 |  | AP4_UI32 | version,
 |  | AP4_UI32 | flags,
 |  | AP4_ByteStream & | stream,
 |  | AP4_AtomFactory & | atom_factory |
 | ) |  |  | [protected]
AP4_ContainerAtom::AP4_ContainerAtom | ( | Type | type,
 |  | AP4_UI64 | size,
 |  | bool | force_64,
 |  | AP4_ByteStream & | stream,
 |  | AP4_AtomFactory & | atom_factory |
 | ) |  |  | [protected]

Member Function Documentation

virtual AP4_Atom* AP4_ContainerAtom::Clone ( ) [virtual]

Create a clone of the object.

This method returns a clone of the atom, or NULL if the atom cannot be cloned. Override this if your want to make an atom cloneable in a more efficient way than the default implementation.

Reimplemented from AP4_Atom.

Reimplemented in AP4_OhdrAtom.

static AP4_ContainerAtom* AP4_ContainerAtom::Create | ( | Type | type,
 |  | AP4_UI64 | size,
 |  | bool | is_full,
 |  | bool | force_64,
 |  | AP4_ByteStream & | stream,
 |  | AP4_AtomFactory & | atom_factory |
 | ) |  |  | [static]
AP4_List<AP4_Atom>& AP4_ContainerAtom::GetChildren ( ) [inline]

Reimplemented from AP4_AtomParent.

Definition at line 66 of file Ap4ContainerAtom.h.

References AP4_AtomParent::m_Children.

virtual AP4_Result AP4_ContainerAtom::InspectChildren ( AP4_AtomInspector & inspector ) [virtual]
virtual AP4_Result AP4_ContainerAtom::InspectFields ( AP4_AtomInspector & inspector ) [virtual]

Reimplemented from AP4_Atom.

Reimplemented in AP4_IproAtom, AP4_OdheAtom, AP4_OhdrAtom, AP4_SampleEntry, AP4_AudioSampleEntry, AP4_VisualSampleEntry, AP4_RtpHintSampleEntry, and AP4_StsdAtom.

virtual void AP4_ContainerAtom::OnChildAdded ( AP4_Atom * child ) [virtual]

Reimplemented from AP4_AtomParent.

Reimplemented in AP4_MoovAtom.

virtual void AP4_ContainerAtom::OnChildChanged ( AP4_Atom * child ) [virtual]

Reimplemented from AP4_AtomParent.

Reimplemented in AP4_OdheAtom, AP4_SampleEntry, and AP4_StsdAtom.

virtual void AP4_ContainerAtom::OnChildRemoved ( AP4_Atom * child ) [virtual]

Reimplemented from AP4_AtomParent.

Reimplemented in AP4_MoovAtom.

void AP4_ContainerAtom::ReadChildren | ( | AP4_AtomFactory & | atom_factory,
 |  | AP4_ByteStream & | stream,
 |  | AP4_UI64 | size |
 | ) |  |  | [protected]
virtual AP4_Result AP4_ContainerAtom::WriteFields ( AP4_ByteStream & stream ) [virtual]

Implements AP4_Atom.

Reimplemented in AP4_DrefAtom, AP4_IproAtom, AP4_OdheAtom, AP4_OhdrAtom, AP4_SampleEntry, AP4_UnknownSampleEntry, AP4_AudioSampleEntry, AP4_VisualSampleEntry, AP4_RtpHintSampleEntry, and AP4_StsdAtom.

The documentation for this class was generated from the following file:
  • Ap4ContainerAtom.h
Generated on Thu May 13 16:36:53 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_ContainerAtom Member List

This is the complete list of members for AP4_ContainerAtom, including all inherited members.
AddChild(AP4_Atom *child, int position=-1) | AP4_AtomParent | [virtual]
AP4_Atom(Type type, AP4_UI32 size=AP4_ATOM_HEADER_SIZE) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64=false) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_ContainerAtom(Type type) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI32 version, AP4_UI32 flags) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_ContainerAtom | [protected]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_ContainerAtom | [protected]
Clone() | AP4_ContainerAtom | [virtual]
Create(Type type, AP4_UI64 size, bool is_full, bool force_64, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_ContainerAtom | [static]
DeleteChild(AP4_Atom::Type type, AP4_Ordinal index=0) | AP4_AtomParent | [virtual]
Detach() | AP4_Atom | [virtual]
FindChild(const char *path, bool auto_create=false, bool auto_create_full=false) | AP4_AtomParent | [virtual]
GetChild(AP4_Atom::Type type, AP4_Ordinal index=0) const | AP4_AtomParent | [virtual]
GetChild(const AP4_UI08 *uuid, AP4_Ordinal index=0) const | AP4_AtomParent | [virtual]
GetChildren() | AP4_ContainerAtom | [inline]
GetFlags() const | AP4_Atom | [inline]
GetHeaderSize() const | AP4_Atom | [virtual]
GetParent() | AP4_Atom | [inline, virtual]
GetSize() const | AP4_Atom | [inline]
GetSize32() const | AP4_Atom | [inline]
GetSize64() const | AP4_Atom | [inline]
GetType() const | AP4_Atom | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
InspectChildren(AP4_AtomInspector &inspector) | AP4_ContainerAtom | [virtual]
InspectFields(AP4_AtomInspector &inspector) | AP4_ContainerAtom | [virtual]
InspectHeader(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
m_Children | AP4_AtomParent | [protected]
m_Flags | AP4_Atom | [protected]
m_IsFull | AP4_Atom | [protected]
m_Parent | AP4_Atom | [protected]
m_Size32 | AP4_Atom | [protected]
m_Size64 | AP4_Atom | [protected]
m_Type | AP4_Atom | [protected]
m_Version | AP4_Atom | [protected]
OnChildAdded(AP4_Atom *child) | AP4_ContainerAtom | [virtual]
OnChildChanged(AP4_Atom *child) | AP4_ContainerAtom | [virtual]
OnChildRemoved(AP4_Atom *child) | AP4_ContainerAtom | [virtual]
ReadChildren(AP4_AtomFactory &atom_factory, AP4_ByteStream &stream, AP4_UI64 size) | AP4_ContainerAtom | [protected]
ReadFullHeader(AP4_ByteStream &stream, AP4_UI32 &version, AP4_UI32 &flags) | AP4_Atom | [static]
RemoveChild(AP4_Atom *child) | AP4_AtomParent | [virtual]
SetFlags(AP4_UI32 flags) | AP4_Atom | [inline]
SetParent(AP4_AtomParent *parent) | AP4_Atom | [inline, virtual]
SetSize(AP4_UI64 size, bool force_64=false) | AP4_Atom |
SetSize32(AP4_UI32 size) | AP4_Atom | [inline]
SetSize64(AP4_UI64 size) | AP4_Atom | [inline]
SetType(Type type) | AP4_Atom | [inline]
Type typedef | AP4_Atom |
TypeFromString(const char *four_cc) | AP4_Atom | [static]
Write(AP4_ByteStream &stream) | AP4_Atom | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_ContainerAtom | [virtual]
WriteHeader(AP4_ByteStream &stream) | AP4_Atom | [virtual]
~AP4_Atom() | AP4_Atom | [inline, virtual]
~AP4_AtomParent() | AP4_AtomParent | [virtual]
Generated on Thu May 13 16:36:53 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_CtrStreamCipher Class Reference

AP4_CtrStreamCipher Class Reference

#include <Ap4StreamCipher.h>

Inheritance diagram for AP4_CtrStreamCipher:
AP4_StreamCipher

List of all members.

Public Member Functions

AP4_CtrStreamCipher (AP4_BlockCipher *block_cipher, const AP4_UI08 *salt, AP4_Size counter_size)
The block cipher is passed with transfer of ownership (it will be destroyed when this object is destroyed).
~AP4_CtrStreamCipher ()
virtual AP4_Result | SetStreamOffset (AP4_UI64 offset, AP4_Cardinal *preroll=NULL)
virtual AP4_UI64 | GetStreamOffset ()
virtual AP4_Result | ProcessBuffer (const AP4_UI08 *in, AP4_Size in_size, AP4_UI08 *out, AP4_Size *out_size=NULL, bool is_last_buffer=false)
virtual AP4_Result | SetIV (const AP4_UI08 *iv)
virtual const AP4_UI08 * | GetIV ()

Detailed Description

Definition at line 82 of file Ap4StreamCipher.h.

Constructor & Destructor Documentation

AP4_CtrStreamCipher::AP4_CtrStreamCipher | ( | AP4_BlockCipher * | block_cipher,
 |  | const AP4_UI08 * | salt,
 |  | AP4_Size | counter_size
 | ) |  |

The block cipher is passed with transfer of ownership (it will be destroyed when this object is destroyed).

AP4_CtrStreamCipher::~AP4_CtrStreamCipher ( )

Member Function Documentation

virtual const AP4_UI08* AP4_CtrStreamCipher::GetIV ( ) [inline, virtual]

Implements AP4_StreamCipher.

Definition at line 107 of file Ap4StreamCipher.h.

virtual AP4_UI64 AP4_CtrStreamCipher::GetStreamOffset ( ) [inline, virtual]

Implements AP4_StreamCipher.

Definition at line 99 of file Ap4StreamCipher.h.

virtual AP4_Result AP4_CtrStreamCipher::ProcessBuffer | ( | const AP4_UI08 * | in,
 |  | AP4_Size | in_size,
 |  | AP4_UI08 * | out,
 |  | AP4_Size * | out_size = NULL,
 |  | bool | is_last_buffer = false |
 | ) |  |  | [virtual]

Implements AP4_StreamCipher.

virtual AP4_Result AP4_CtrStreamCipher::SetIV ( const AP4_UI08 * iv ) [virtual]

Implements AP4_StreamCipher.

virtual AP4_Result AP4_CtrStreamCipher::SetStreamOffset | ( | AP4_UI64 | offset,
 |  | AP4_Cardinal * | preroll = NULL |
 | ) |  |  | [virtual]

Implements AP4_StreamCipher.

The documentation for this class was generated from the following file:
  • Ap4StreamCipher.h
Generated on Thu May 13 16:36:53 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_CtrStreamCipher Member List

This is the complete list of members for AP4_CtrStreamCipher, including all inherited members.
AP4_CtrStreamCipher(AP4_BlockCipher *block_cipher, const AP4_UI08 *salt, AP4_Size counter_size) | AP4_CtrStreamCipher |
CipherDirection enum name | AP4_StreamCipher |
DECRYPT enum value | AP4_StreamCipher |
ENCRYPT enum value | AP4_StreamCipher |
GetIV() | AP4_CtrStreamCipher | [inline, virtual]
GetStreamOffset() | AP4_CtrStreamCipher | [inline, virtual]
ProcessBuffer(const AP4_UI08 *in, AP4_Size in_size, AP4_UI08 *out, AP4_Size *out_size=NULL, bool is_last_buffer=false) | AP4_CtrStreamCipher | [virtual]
SetIV(const AP4_UI08 *iv) | AP4_CtrStreamCipher | [virtual]
SetStreamOffset(AP4_UI64 offset, AP4_Cardinal *preroll=NULL) | AP4_CtrStreamCipher | [virtual]
~AP4_CtrStreamCipher() | AP4_CtrStreamCipher |
~AP4_StreamCipher() | AP4_StreamCipher | [inline, virtual]
Generated on Thu May 13 16:36:53 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_CttsAtom Class Reference

AP4_CttsAtom Class Reference

#include <Ap4CttsAtom.h>

Inheritance diagram for AP4_CttsAtom:
AP4_Atom

List of all members.

Public Member Functions

AP4_CttsAtom ()
virtual AP4_Result | InspectFields (AP4_AtomInspector &inspector)
virtual AP4_Result | WriteFields (AP4_ByteStream &stream)
AP4_Result | AddEntry (AP4_UI32 count, AP4_UI32 cts_offset)
AP4_Result | GetCtsOffset (AP4_Ordinal sample, AP4_UI32 &cts_offset)

Static Public Member Functions

static AP4_CttsAtom * | Create (AP4_UI32 size, AP4_ByteStream &stream)

Detailed Description

Definition at line 64 of file Ap4CttsAtom.h.

Constructor & Destructor Documentation

AP4_CttsAtom::AP4_CttsAtom ( )

Member Function Documentation

AP4_Result AP4_CttsAtom::AddEntry | ( | AP4_UI32 | count,
 |  | AP4_UI32 | cts_offset
 | ) |  |
static AP4_CttsAtom* AP4_CttsAtom::Create | ( | AP4_UI32 | size,
 |  | AP4_ByteStream & | stream |
 | ) |  |  | [static]
AP4_Result AP4_CttsAtom::GetCtsOffset | ( | AP4_Ordinal | sample,
 |  | AP4_UI32 & | cts_offset
 | ) |  |
virtual AP4_Result AP4_CttsAtom::InspectFields ( AP4_AtomInspector & inspector ) [virtual]

Reimplemented from AP4_Atom.

virtual AP4_Result AP4_CttsAtom::WriteFields ( AP4_ByteStream & stream ) [virtual]

Implements AP4_Atom.

Member Data Documentation

AP4_Ordinal AP4_CttsAtom::entry_index

Definition at line 92 of file Ap4CttsAtom.h.

AP4_Ordinal AP4_CttsAtom::sample

Definition at line 91 of file Ap4CttsAtom.h.

The documentation for this class was generated from the following file:
  • Ap4CttsAtom.h
Generated on Thu May 13 16:36:54 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_CttsAtom Member List

This is the complete list of members for AP4_CttsAtom, including all inherited members.
AddEntry(AP4_UI32 count, AP4_UI32 cts_offset) | AP4_CttsAtom |
AP4_Atom(Type type, AP4_UI32 size=AP4_ATOM_HEADER_SIZE) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64=false) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_CttsAtom() | AP4_CttsAtom |
Clone() | AP4_Atom | [virtual]
Create(AP4_UI32 size, AP4_ByteStream &stream) | AP4_CttsAtom | [static]
Detach() | AP4_Atom | [virtual]
entry_index | AP4_CttsAtom |
GetCtsOffset(AP4_Ordinal sample, AP4_UI32 &cts_offset) | AP4_CttsAtom |
GetFlags() const | AP4_Atom | [inline]
GetHeaderSize() const | AP4_Atom | [virtual]
GetParent() | AP4_Atom | [inline, virtual]
GetSize() const | AP4_Atom | [inline]
GetSize32() const | AP4_Atom | [inline]
GetSize64() const | AP4_Atom | [inline]
GetType() const | AP4_Atom | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
InspectFields(AP4_AtomInspector &inspector) | AP4_CttsAtom | [virtual]
InspectHeader(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
m_Flags | AP4_Atom | [protected]
m_IsFull | AP4_Atom | [protected]
m_Parent | AP4_Atom | [protected]
m_Size32 | AP4_Atom | [protected]
m_Size64 | AP4_Atom | [protected]
m_Type | AP4_Atom | [protected]
m_Version | AP4_Atom | [protected]
ReadFullHeader(AP4_ByteStream &stream, AP4_UI32 &version, AP4_UI32 &flags) | AP4_Atom | [static]
sample | AP4_CttsAtom |
SetFlags(AP4_UI32 flags) | AP4_Atom | [inline]
SetParent(AP4_AtomParent *parent) | AP4_Atom | [inline, virtual]
SetSize(AP4_UI64 size, bool force_64=false) | AP4_Atom |
SetSize32(AP4_UI32 size) | AP4_Atom | [inline]
SetSize64(AP4_UI64 size) | AP4_Atom | [inline]
SetType(Type type) | AP4_Atom | [inline]
Type typedef | AP4_Atom |
TypeFromString(const char *four_cc) | AP4_Atom | [static]
Write(AP4_ByteStream &stream) | AP4_Atom | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_CttsAtom | [virtual]
WriteHeader(AP4_ByteStream &stream) | AP4_Atom | [virtual]
~AP4_Atom() | AP4_Atom | [inline, virtual]
Generated on Thu May 13 16:36:54 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_CttsTableEntry Class Reference

AP4_CttsTableEntry Class Reference

#include <Ap4CttsAtom.h>

List of all members.

Public Member Functions

AP4_CttsTableEntry ()
AP4_CttsTableEntry (AP4_UI32 sample_count, AP4_UI32 sample_offset)

Public Attributes

AP4_UI32 m_SampleCount
AP4_UI32 m_SampleOffset

Detailed Description

Definition at line 47 of file Ap4CttsAtom.h.

Constructor & Destructor Documentation

AP4_CttsTableEntry::AP4_CttsTableEntry ( ) [inline]

Definition at line 49 of file Ap4CttsAtom.h.

AP4_CttsTableEntry::AP4_CttsTableEntry | ( | AP4_UI32 | sample_count,
 |  | AP4_UI32 | sample_offset |
 | ) |  |  | [inline]

Definition at line 52 of file Ap4CttsAtom.h.

Member Data Documentation

AP4_UI32 AP4_CttsTableEntry::m_SampleCount

Definition at line 57 of file Ap4CttsAtom.h.

AP4_UI32 AP4_CttsTableEntry::m_SampleOffset

Definition at line 58 of file Ap4CttsAtom.h.

The documentation for this class was generated from the following file:
  • Ap4CttsAtom.h
Generated on Thu May 13 16:36:54 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_CttsTableEntry Member List

This is the complete list of members for AP4_CttsTableEntry, including all inherited members.
AP4_CttsTableEntry() | AP4_CttsTableEntry | [inline]
AP4_CttsTableEntry(AP4_UI32 sample_count, AP4_UI32 sample_offset) | AP4_CttsTableEntry | [inline]
m_SampleCount | AP4_CttsTableEntry |
m_SampleOffset | AP4_CttsTableEntry |
Generated on Thu May 13 16:36:54 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_DataAtom Class Reference

AP4_DataAtom Class Reference

#include <Ap4MetaData.h>

Inheritance diagram for AP4_DataAtom:
AP4_Atom

List of all members.

Public Types

enum DataType {
DATA_TYPE_BINARY = 0,
DATA_TYPE_STRING_UTF_8 = 1,
DATA_TYPE_STRING_UTF_16 = 2,
DATA_TYPE_STRING_PASCAL = 3,
DATA_TYPE_GIF = 13,
DATA_TYPE_JPEG = 14,
DATA_TYPE_SIGNED_INT_BE = 21,
DATA_TYPE_FLOAT_32_BE = 22,
DATA_TYPE_FLOAT_64_BE = 23
}
enum | DataLang { LANGUAGE_ENGLISH = 0 }

Public Member Functions

AP4_DataAtom (const AP4_MetaData::Value &value)
AP4_DataAtom (AP4_UI32 size, AP4_ByteStream &stream)
~AP4_DataAtom ()
virtual AP4_Result | InspectFields (AP4_AtomInspector &inspector)
virtual AP4_Result | WriteFields (AP4_ByteStream &stream)
DataType GetDataType ()
DataLang GetDataLang ()
AP4_MetaData::Value::Type GetValueType ()
AP4_Result | LoadString (AP4_String *&string)
AP4_Result | LoadBytes (AP4_DataBuffer &bytes)
AP4_Result | LoadInteger (long &value)

Detailed Description

Definition at line 450 of file Ap4MetaData.h.

Member Enumeration Documentation

enum AP4_DataAtom::DataLang
Enumerator:
LANGUAGE_ENGLISH

Definition at line 467 of file Ap4MetaData.h.

enum AP4_DataAtom::DataType
Enumerator:
DATA_TYPE_BINARY
DATA_TYPE_STRING_UTF_8
DATA_TYPE_STRING_UTF_16
DATA_TYPE_STRING_PASCAL
DATA_TYPE_GIF
DATA_TYPE_JPEG
DATA_TYPE_SIGNED_INT_BE
DATA_TYPE_FLOAT_32_BE
DATA_TYPE_FLOAT_64_BE

Definition at line 455 of file Ap4MetaData.h.

Constructor & Destructor Documentation

AP4_DataAtom::AP4_DataAtom ( const AP4_MetaData::Value & value )
AP4_DataAtom::AP4_DataAtom | ( | AP4_UI32 | size,
 |  | AP4_ByteStream & | stream
 | ) |  |
AP4_DataAtom::~AP4_DataAtom ( )

Member Function Documentation

DataLang AP4_DataAtom::GetDataLang ( ) [inline]

Definition at line 484 of file Ap4MetaData.h.

DataType AP4_DataAtom::GetDataType ( ) [inline]

Definition at line 483 of file Ap4MetaData.h.

AP4_MetaData::Value::Type AP4_DataAtom::GetValueType ( )
virtual AP4_Result AP4_DataAtom::InspectFields ( AP4_AtomInspector & inspector ) [virtual]

Reimplemented from AP4_Atom.

AP4_Result AP4_DataAtom::LoadBytes ( AP4_DataBuffer & bytes )
AP4_Result AP4_DataAtom::LoadInteger ( long & value )
AP4_Result AP4_DataAtom::LoadString ( AP4_String *& string )
virtual AP4_Result AP4_DataAtom::WriteFields ( AP4_ByteStream & stream ) [virtual]

Implements AP4_Atom.

The documentation for this class was generated from the following file:
  • Ap4MetaData.h
Generated on Thu May 13 16:36:54 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_DataAtom Member List

This is the complete list of members for AP4_DataAtom, including all inherited members.
AP4_Atom(Type type, AP4_UI32 size=AP4_ATOM_HEADER_SIZE) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64=false) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_DataAtom(const AP4_MetaData::Value &value) | AP4_DataAtom |
AP4_DataAtom(AP4_UI32 size, AP4_ByteStream &stream) | AP4_DataAtom |
Clone() | AP4_Atom | [virtual]
DATA_TYPE_BINARY enum value | AP4_DataAtom |
DATA_TYPE_FLOAT_32_BE enum value | AP4_DataAtom |
DATA_TYPE_FLOAT_64_BE enum value | AP4_DataAtom |
DATA_TYPE_GIF enum value | AP4_DataAtom |
DATA_TYPE_JPEG enum value | AP4_DataAtom |
DATA_TYPE_SIGNED_INT_BE enum value | AP4_DataAtom |
DATA_TYPE_STRING_PASCAL enum value | AP4_DataAtom |
DATA_TYPE_STRING_UTF_16 enum value | AP4_DataAtom |
DATA_TYPE_STRING_UTF_8 enum value | AP4_DataAtom |
DataLang enum name | AP4_DataAtom |
DataType enum name | AP4_DataAtom |
Detach() | AP4_Atom | [virtual]
GetDataLang() | AP4_DataAtom | [inline]
GetDataType() | AP4_DataAtom | [inline]
GetFlags() const | AP4_Atom | [inline]
GetHeaderSize() const | AP4_Atom | [virtual]
GetParent() | AP4_Atom | [inline, virtual]
GetSize() const | AP4_Atom | [inline]
GetSize32() const | AP4_Atom | [inline]
GetSize64() const | AP4_Atom | [inline]
GetType() const | AP4_Atom | [inline]
GetValueType() | AP4_DataAtom |
Inspect(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
InspectFields(AP4_AtomInspector &inspector) | AP4_DataAtom | [virtual]
InspectHeader(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
LANGUAGE_ENGLISH enum value | AP4_DataAtom |
LoadBytes(AP4_DataBuffer &bytes) | AP4_DataAtom |
LoadInteger(long &value) | AP4_DataAtom |
LoadString(AP4_String *&string) | AP4_DataAtom |
m_Flags | AP4_Atom | [protected]
m_IsFull | AP4_Atom | [protected]
m_Parent | AP4_Atom | [protected]
m_Size32 | AP4_Atom | [protected]
m_Size64 | AP4_Atom | [protected]
m_Type | AP4_Atom | [protected]
m_Version | AP4_Atom | [protected]
ReadFullHeader(AP4_ByteStream &stream, AP4_UI32 &version, AP4_UI32 &flags) | AP4_Atom | [static]
SetFlags(AP4_UI32 flags) | AP4_Atom | [inline]
SetParent(AP4_AtomParent *parent) | AP4_Atom | [inline, virtual]
SetSize(AP4_UI64 size, bool force_64=false) | AP4_Atom |
SetSize32(AP4_UI32 size) | AP4_Atom | [inline]
SetSize64(AP4_UI64 size) | AP4_Atom | [inline]
SetType(Type type) | AP4_Atom | [inline]
Type typedef | AP4_Atom |
TypeFromString(const char *four_cc) | AP4_Atom | [static]
Write(AP4_ByteStream &stream) | AP4_Atom | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_DataAtom | [virtual]
WriteHeader(AP4_ByteStream &stream) | AP4_Atom | [virtual]
~AP4_Atom() | AP4_Atom | [inline, virtual]
~AP4_DataAtom() | AP4_DataAtom |
Generated on Thu May 13 16:36:54 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_DataBuffer Class Reference

AP4_DataBuffer Class Reference

#include <Ap4DataBuffer.h>

List of all members.

Public Member Functions

AP4_DataBuffer ()
AP4_DataBuffer (AP4_Size size)
AP4_DataBuffer (const void *data, AP4_Size data_size)
AP4_DataBuffer (const AP4_DataBuffer &other)
virtual | ~AP4_DataBuffer ()
AP4_Result | SetBuffer (AP4_Byte *buffer, AP4_Size buffer_size)
AP4_Result | SetBufferSize (AP4_Size buffer_size)
AP4_Size | GetBufferSize () const
const AP4_Byte * | GetData () const
AP4_Byte * UseData ()
AP4_Size | GetDataSize () const
AP4_Result | SetDataSize (AP4_Size size)
AP4_Result | SetData (const AP4_Byte *data, AP4_Size data_size)
AP4_Result | Reserve (AP4_Size size)

Protected Member Functions

AP4_Result | ReallocateBuffer (AP4_Size size)

Protected Attributes

bool | m_BufferIsLocal
AP4_Byte * m_Buffer
AP4_Size m_BufferSize
AP4_Size m_DataSize

Detailed Description

Definition at line 40 of file Ap4DataBuffer.h.

Constructor & Destructor Documentation

AP4_DataBuffer::AP4_DataBuffer ( )
AP4_DataBuffer::AP4_DataBuffer ( AP4_Size size )
AP4_DataBuffer::AP4_DataBuffer | ( | const void * | data,
 |  | AP4_Size | data_size
 | ) |  |
AP4_DataBuffer::AP4_DataBuffer ( const AP4_DataBuffer & other )
virtual AP4_DataBuffer::~AP4_DataBuffer ( ) [virtual]

Member Function Documentation

AP4_Size AP4_DataBuffer::GetBufferSize ( ) const [inline]

Definition at line 53 of file Ap4DataBuffer.h.

References m_BufferSize.

const AP4_Byte* AP4_DataBuffer::GetData ( ) const [inline]

Definition at line 56 of file Ap4DataBuffer.h.

References m_Buffer.

Referenced by AP4_PiffNullSampleDecrypter::DecryptSampleData(), and AP4_MemoryByteStream::GetData().

AP4_Size AP4_DataBuffer::GetDataSize ( ) const [inline]

Definition at line 58 of file Ap4DataBuffer.h.

References m_DataSize.

Referenced by AP4_PiffNullSampleDecrypter::DecryptSampleData(), AP4_ImmediateRtpConstructor::GetConstructedDataSize(), AP4_MemoryByteStream::GetDataSize(), and AP4_MemoryByteStream::GetSize().

AP4_Result AP4_DataBuffer::ReallocateBuffer ( AP4_Size size ) [protected]
AP4_Result AP4_DataBuffer::Reserve ( AP4_Size size )
AP4_Result AP4_DataBuffer::SetBuffer | ( | AP4_Byte * | buffer,
 |  | AP4_Size | buffer_size
 | ) |  |
AP4_Result AP4_DataBuffer::SetBufferSize ( AP4_Size buffer_size )
AP4_Result AP4_DataBuffer::SetData | ( | const AP4_Byte * | data,
 |  | AP4_Size | data_size
 | ) |  |

Referenced by AP4_PiffNullSampleDecrypter::DecryptSampleData().

AP4_Result AP4_DataBuffer::SetDataSize ( AP4_Size size )
AP4_Byte* AP4_DataBuffer::UseData ( ) [inline]

Definition at line 57 of file Ap4DataBuffer.h.

References m_Buffer.

Referenced by AP4_MemoryByteStream::UseData().

Member Data Documentation

AP4_Byte* AP4_DataBuffer::m_Buffer [protected]

Definition at line 68 of file Ap4DataBuffer.h.

Referenced by GetData(), and UseData().

bool AP4_DataBuffer::m_BufferIsLocal [protected]

Definition at line 67 of file Ap4DataBuffer.h.

AP4_Size AP4_DataBuffer::m_BufferSize [protected]

Definition at line 69 of file Ap4DataBuffer.h.

Referenced by GetBufferSize().

AP4_Size AP4_DataBuffer::m_DataSize [protected]

Definition at line 70 of file Ap4DataBuffer.h.

Referenced by GetDataSize().

The documentation for this class was generated from the following file:
  • Ap4DataBuffer.h
Generated on Thu May 13 16:36:54 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_DataBuffer Member List

This is the complete list of members for AP4_DataBuffer, including all inherited members.
AP4_DataBuffer() | AP4_DataBuffer |
AP4_DataBuffer(AP4_Size size) | AP4_DataBuffer |
AP4_DataBuffer(const void *data, AP4_Size data_size) | AP4_DataBuffer |
AP4_DataBuffer(const AP4_DataBuffer &other) | AP4_DataBuffer |
GetBufferSize() const | AP4_DataBuffer | [inline]
GetData() const | AP4_DataBuffer | [inline]
GetDataSize() const | AP4_DataBuffer | [inline]
m_Buffer | AP4_DataBuffer | [protected]
m_BufferIsLocal | AP4_DataBuffer | [protected]
m_BufferSize | AP4_DataBuffer | [protected]
m_DataSize | AP4_DataBuffer | [protected]
ReallocateBuffer(AP4_Size size) | AP4_DataBuffer | [protected]
Reserve(AP4_Size size) | AP4_DataBuffer |
SetBuffer(AP4_Byte *buffer, AP4_Size buffer_size) | AP4_DataBuffer |
SetBufferSize(AP4_Size buffer_size) | AP4_DataBuffer |
SetData(const AP4_Byte *data, AP4_Size data_size) | AP4_DataBuffer |
SetDataSize(AP4_Size size) | AP4_DataBuffer |
UseData() | AP4_DataBuffer | [inline]
~AP4_DataBuffer() | AP4_DataBuffer | [virtual]
Generated on Thu May 13 16:36:54 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_DcfdAtom Class Reference

AP4_DcfdAtom Class Reference

#include <Ap4MetaData.h>

Inheritance diagram for AP4_DcfdAtom:
AP4_Atom

List of all members.

Public Member Functions

AP4_DcfdAtom (AP4_UI32 version, AP4_UI32 flags, AP4_ByteStream &stream)
AP4_DcfdAtom (AP4_UI32 duration)
virtual AP4_Result | InspectFields (AP4_AtomInspector &inspector)
virtual AP4_Result | WriteFields (AP4_ByteStream &stream)
AP4_UI32 | GetDuration () const

Static Public Member Functions

static AP4_DcfdAtom * | Create (AP4_UI32 size, AP4_ByteStream &stream)

Detailed Description

Definition at line 398 of file Ap4MetaData.h.

Constructor & Destructor Documentation

AP4_DcfdAtom::AP4_DcfdAtom | ( | AP4_UI32 | version,
 |  | AP4_UI32 | flags,
 |  | AP4_ByteStream & | stream
 | ) |  |
AP4_DcfdAtom::AP4_DcfdAtom ( AP4_UI32 duration )

Member Function Documentation

static AP4_DcfdAtom* AP4_DcfdAtom::Create | ( | AP4_UI32 | size,
 |  | AP4_ByteStream & | stream |
 | ) |  |  | [static]
AP4_UI32 AP4_DcfdAtom::GetDuration ( ) const [inline]

Definition at line 417 of file Ap4MetaData.h.

virtual AP4_Result AP4_DcfdAtom::InspectFields ( AP4_AtomInspector & inspector ) [virtual]

Reimplemented from AP4_Atom.

virtual AP4_Result AP4_DcfdAtom::WriteFields ( AP4_ByteStream & stream ) [virtual]

Implements AP4_Atom.

The documentation for this class was generated from the following file:
  • Ap4MetaData.h
Generated on Thu May 13 16:36:54 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_DcfdAtom Member List

This is the complete list of members for AP4_DcfdAtom, including all inherited members.
AP4_Atom(Type type, AP4_UI32 size=AP4_ATOM_HEADER_SIZE) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64=false) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_DcfdAtom(AP4_UI32 version, AP4_UI32 flags, AP4_ByteStream &stream) | AP4_DcfdAtom |
AP4_DcfdAtom(AP4_UI32 duration) | AP4_DcfdAtom |
Clone() | AP4_Atom | [virtual]
Create(AP4_UI32 size, AP4_ByteStream &stream) | AP4_DcfdAtom | [static]
Detach() | AP4_Atom | [virtual]
GetDuration() const | AP4_DcfdAtom | [inline]
GetFlags() const | AP4_Atom | [inline]
GetHeaderSize() const | AP4_Atom | [virtual]
GetParent() | AP4_Atom | [inline, virtual]
GetSize() const | AP4_Atom | [inline]
GetSize32() const | AP4_Atom | [inline]
GetSize64() const | AP4_Atom | [inline]
GetType() const | AP4_Atom | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
InspectFields(AP4_AtomInspector &inspector) | AP4_DcfdAtom | [virtual]
InspectHeader(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
m_Flags | AP4_Atom | [protected]
m_IsFull | AP4_Atom | [protected]
m_Parent | AP4_Atom | [protected]
m_Size32 | AP4_Atom | [protected]
m_Size64 | AP4_Atom | [protected]
m_Type | AP4_Atom | [protected]
m_Version | AP4_Atom | [protected]
ReadFullHeader(AP4_ByteStream &stream, AP4_UI32 &version, AP4_UI32 &flags) | AP4_Atom | [static]
SetFlags(AP4_UI32 flags) | AP4_Atom | [inline]
SetParent(AP4_AtomParent *parent) | AP4_Atom | [inline, virtual]
SetSize(AP4_UI64 size, bool force_64=false) | AP4_Atom |
SetSize32(AP4_UI32 size) | AP4_Atom | [inline]
SetSize64(AP4_UI64 size) | AP4_Atom | [inline]
SetType(Type type) | AP4_Atom | [inline]
Type typedef | AP4_Atom |
TypeFromString(const char *four_cc) | AP4_Atom | [static]
Write(AP4_ByteStream &stream) | AP4_Atom | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_DcfdAtom | [virtual]
WriteHeader(AP4_ByteStream &stream) | AP4_Atom | [virtual]
~AP4_Atom() | AP4_Atom | [inline, virtual]
Generated on Thu May 13 16:36:54 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_DcfStringAtom Class Reference

AP4_DcfStringAtom Class Reference

#include <Ap4MetaData.h>

Inheritance diagram for AP4_DcfStringAtom:
AP4_Atom

List of all members.

Public Member Functions

AP4_DcfStringAtom (Type type, const char *value)
AP4_DcfStringAtom (Type type, AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags, AP4_ByteStream &stream)
virtual AP4_Result | InspectFields (AP4_AtomInspector &inspector)
virtual AP4_Result | WriteFields (AP4_ByteStream &stream)
const AP4_String & | GetValue () const

Static Public Member Functions

static AP4_DcfStringAtom * | Create (Type type, AP4_UI32 size, AP4_ByteStream &stream)

Detailed Description

Definition at line 367 of file Ap4MetaData.h.

Constructor & Destructor Documentation

AP4_DcfStringAtom::AP4_DcfStringAtom | ( | Type | type,
 |  | const char * | value
 | ) |  |
AP4_DcfStringAtom::AP4_DcfStringAtom | ( | Type | type,
 |  | AP4_UI32 | size,
 |  | AP4_UI32 | version,
 |  | AP4_UI32 | flags,
 |  | AP4_ByteStream & | stream
 | ) |  |

Member Function Documentation

static AP4_DcfStringAtom* AP4_DcfStringAtom::Create | ( | Type | type,
 |  | AP4_UI32 | size,
 |  | AP4_ByteStream & | stream |
 | ) |  |  | [static]
const AP4_String& AP4_DcfStringAtom::GetValue ( ) const [inline]

Definition at line 388 of file Ap4MetaData.h.

virtual AP4_Result AP4_DcfStringAtom::InspectFields ( AP4_AtomInspector & inspector ) [virtual]

Reimplemented from AP4_Atom.

virtual AP4_Result AP4_DcfStringAtom::WriteFields ( AP4_ByteStream & stream ) [virtual]

Implements AP4_Atom.

The documentation for this class was generated from the following file:
  • Ap4MetaData.h
Generated on Thu May 13 16:36:54 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_DcfStringAtom Member List

This is the complete list of members for AP4_DcfStringAtom, including all inherited members.
AP4_Atom(Type type, AP4_UI32 size=AP4_ATOM_HEADER_SIZE) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64=false) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_DcfStringAtom(Type type, const char *value) | AP4_DcfStringAtom |
AP4_DcfStringAtom(Type type, AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags, AP4_ByteStream &stream) | AP4_DcfStringAtom |
Clone() | AP4_Atom | [virtual]
Create(Type type, AP4_UI32 size, AP4_ByteStream &stream) | AP4_DcfStringAtom | [static]
Detach() | AP4_Atom | [virtual]
GetFlags() const | AP4_Atom | [inline]
GetHeaderSize() const | AP4_Atom | [virtual]
GetParent() | AP4_Atom | [inline, virtual]
GetSize() const | AP4_Atom | [inline]
GetSize32() const | AP4_Atom | [inline]
GetSize64() const | AP4_Atom | [inline]
GetType() const | AP4_Atom | [inline]
GetValue() const | AP4_DcfStringAtom | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
InspectFields(AP4_AtomInspector &inspector) | AP4_DcfStringAtom | [virtual]
InspectHeader(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
m_Flags | AP4_Atom | [protected]
m_IsFull | AP4_Atom | [protected]
m_Parent | AP4_Atom | [protected]
m_Size32 | AP4_Atom | [protected]
m_Size64 | AP4_Atom | [protected]
m_Type | AP4_Atom | [protected]
m_Version | AP4_Atom | [protected]
ReadFullHeader(AP4_ByteStream &stream, AP4_UI32 &version, AP4_UI32 &flags) | AP4_Atom | [static]
SetFlags(AP4_UI32 flags) | AP4_Atom | [inline]
SetParent(AP4_AtomParent *parent) | AP4_Atom | [inline, virtual]
SetSize(AP4_UI64 size, bool force_64=false) | AP4_Atom |
SetSize32(AP4_UI32 size) | AP4_Atom | [inline]
SetSize64(AP4_UI64 size) | AP4_Atom | [inline]
SetType(Type type) | AP4_Atom | [inline]
Type typedef | AP4_Atom |
TypeFromString(const char *four_cc) | AP4_Atom | [static]
Write(AP4_ByteStream &stream) | AP4_Atom | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_DcfStringAtom | [virtual]
WriteHeader(AP4_ByteStream &stream) | AP4_Atom | [virtual]
~AP4_Atom() | AP4_Atom | [inline, virtual]
Generated on Thu May 13 16:36:54 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_DecoderConfigDescriptor Class Reference

AP4_DecoderConfigDescriptor Class Reference

#include <Ap4DecoderConfigDescriptor.h>

Inheritance diagram for AP4_DecoderConfigDescriptor:
AP4_Descriptor AP4_Expandable

List of all members.

Public Member Functions

AP4_DecoderConfigDescriptor (AP4_UI08 stream_type, AP4_UI08 oti, AP4_UI32 buffer_size, AP4_UI32 max_bitrate, AP4_UI32 avg_bitrate, AP4_DecoderSpecificInfoDescriptor *dsi)
AP4_DecoderConfigDescriptor (AP4_ByteStream &stream, AP4_Size header_size, AP4_Size payload_size)
virtual | ~AP4_DecoderConfigDescriptor ()
virtual AP4_Result | WriteFields (AP4_ByteStream &stream)
virtual AP4_Result | Inspect (AP4_AtomInspector &inspector)
virtual const
AP4_DecoderSpecificInfoDescriptor * 		GetDecoderSpecificInfoDescriptor () const
virtual AP4_UI08 | GetObjectTypeIndication () const
virtual AP4_UI08 | GetStreamType () const
virtual AP4_UI32 | GetBufferSize () const
virtual AP4_UI32 | GetMaxBitrate () const
virtual AP4_UI32 | GetAvgBitrate () const

Detailed Description

Definition at line 53 of file Ap4DecoderConfigDescriptor.h.

Constructor & Destructor Documentation

AP4_DecoderConfigDescriptor::AP4_DecoderConfigDescriptor | ( | AP4_UI08 | stream_type,
 |  | AP4_UI08 | oti,
 |  | AP4_UI32 | buffer_size,
 |  | AP4_UI32 | max_bitrate,
 |  | AP4_UI32 | avg_bitrate,
 |  | AP4_DecoderSpecificInfoDescriptor * | dsi
 | ) |  |
AP4_DecoderConfigDescriptor::AP4_DecoderConfigDescriptor | ( | AP4_ByteStream & | stream,
 |  | AP4_Size | header_size,
 |  | AP4_Size | payload_size
 | ) |  |
virtual AP4_DecoderConfigDescriptor::~AP4_DecoderConfigDescriptor ( ) [virtual]

Member Function Documentation

virtual AP4_UI32 AP4_DecoderConfigDescriptor::GetAvgBitrate ( ) const [inline, virtual]

Definition at line 81 of file Ap4DecoderConfigDescriptor.h.

virtual AP4_UI32 AP4_DecoderConfigDescriptor::GetBufferSize ( ) const [inline, virtual]

Definition at line 79 of file Ap4DecoderConfigDescriptor.h.

virtual const AP4_DecoderSpecificInfoDescriptor* AP4_DecoderConfigDescriptor::GetDecoderSpecificInfoDescriptor ( ) const [virtual]
virtual AP4_UI32 AP4_DecoderConfigDescriptor::GetMaxBitrate ( ) const [inline, virtual]

Definition at line 80 of file Ap4DecoderConfigDescriptor.h.

virtual AP4_UI08 AP4_DecoderConfigDescriptor::GetObjectTypeIndication ( ) const [inline, virtual]

Definition at line 75 of file Ap4DecoderConfigDescriptor.h.

virtual AP4_UI08 AP4_DecoderConfigDescriptor::GetStreamType ( ) const [inline, virtual]

Definition at line 78 of file Ap4DecoderConfigDescriptor.h.

virtual AP4_Result AP4_DecoderConfigDescriptor::Inspect ( AP4_AtomInspector & inspector ) [virtual]

Reimplemented from AP4_Descriptor.

virtual AP4_Result AP4_DecoderConfigDescriptor::WriteFields ( AP4_ByteStream & stream ) [virtual]

Implements AP4_Expandable.

The documentation for this class was generated from the following file:
  • Ap4DecoderConfigDescriptor.h
Generated on Thu May 13 16:36:54 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_DecoderConfigDescriptor Member List

This is the complete list of members for AP4_DecoderConfigDescriptor, including all inherited members.
AP4_DecoderConfigDescriptor(AP4_UI08 stream_type, AP4_UI08 oti, AP4_UI32 buffer_size, AP4_UI32 max_bitrate, AP4_UI32 avg_bitrate, AP4_DecoderSpecificInfoDescriptor *dsi) | AP4_DecoderConfigDescriptor |
AP4_DecoderConfigDescriptor(AP4_ByteStream &stream, AP4_Size header_size, AP4_Size payload_size) | AP4_DecoderConfigDescriptor |
AP4_Descriptor(AP4_UI08 tag, AP4_Size header_size, AP4_Size payload_size) | AP4_Descriptor | [inline]
AP4_Expandable(AP4_UI32 class_id, ClassIdSize class_id_size, AP4_Size header_size, AP4_Size payload_size) | AP4_Expandable |
CLASS_ID_SIZE_08 enum value | AP4_Expandable |
ClassIdSize enum name | AP4_Expandable |
GetAvgBitrate() const | AP4_DecoderConfigDescriptor | [inline, virtual]
GetBufferSize() const | AP4_DecoderConfigDescriptor | [inline, virtual]
GetClassId() | AP4_Expandable | [inline]
GetDecoderSpecificInfoDescriptor() const | AP4_DecoderConfigDescriptor | [virtual]
GetHeaderSize() | AP4_Expandable | [inline]
GetMaxBitrate() const | AP4_DecoderConfigDescriptor | [inline, virtual]
GetObjectTypeIndication() const | AP4_DecoderConfigDescriptor | [inline, virtual]
GetSize() | AP4_Expandable | [inline]
GetStreamType() const | AP4_DecoderConfigDescriptor | [inline, virtual]
GetTag() | AP4_Descriptor | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_DecoderConfigDescriptor | [virtual]
m_ClassId | AP4_Expandable | [protected]
m_ClassIdSize | AP4_Expandable | [protected]
m_HeaderSize | AP4_Expandable | [protected]
m_PayloadSize | AP4_Expandable | [protected]
MinHeaderSize(AP4_Size payload_size) | AP4_Expandable | [static]
Write(AP4_ByteStream &stream) | AP4_Expandable | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_DecoderConfigDescriptor | [virtual]
~AP4_DecoderConfigDescriptor() | AP4_DecoderConfigDescriptor | [virtual]
~AP4_Expandable() | AP4_Expandable | [inline, virtual]
Generated on Thu May 13 16:36:54 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_DecoderSpecificInfoDescriptor Class Reference

AP4_DecoderSpecificInfoDescriptor Class Reference

#include <Ap4DecoderSpecificInfoDescriptor.h>

Inheritance diagram for AP4_DecoderSpecificInfoDescriptor:
AP4_Descriptor AP4_Expandable

List of all members.

Public Member Functions

AP4_DecoderSpecificInfoDescriptor (const AP4_DataBuffer &data)
AP4_DecoderSpecificInfoDescriptor (AP4_ByteStream &stream, AP4_Size header_size, AP4_Size payload_size)
virtual | ~AP4_DecoderSpecificInfoDescriptor ()
virtual AP4_Result | WriteFields (AP4_ByteStream &stream)
virtual AP4_Result | Inspect (AP4_AtomInspector &inspector)
virtual const AP4_DataBuffer & | GetDecoderSpecificInfo () const

Detailed Description

Definition at line 53 of file Ap4DecoderSpecificInfoDescriptor.h.

Constructor & Destructor Documentation

AP4_DecoderSpecificInfoDescriptor::AP4_DecoderSpecificInfoDescriptor ( const AP4_DataBuffer & data )
AP4_DecoderSpecificInfoDescriptor::AP4_DecoderSpecificInfoDescriptor | ( | AP4_ByteStream & | stream,
 |  | AP4_Size | header_size,
 |  | AP4_Size | payload_size
 | ) |  |
virtual AP4_DecoderSpecificInfoDescriptor::~AP4_DecoderSpecificInfoDescriptor ( ) [virtual]

Member Function Documentation

virtual const AP4_DataBuffer& AP4_DecoderSpecificInfoDescriptor::GetDecoderSpecificInfo ( ) const [inline, virtual]

Definition at line 66 of file Ap4DecoderSpecificInfoDescriptor.h.

virtual AP4_Result AP4_DecoderSpecificInfoDescriptor::Inspect ( AP4_AtomInspector & inspector ) [virtual]

Reimplemented from AP4_Descriptor.

virtual AP4_Result AP4_DecoderSpecificInfoDescriptor::WriteFields ( AP4_ByteStream & stream ) [virtual]

Implements AP4_Expandable.

The documentation for this class was generated from the following file:
  • Ap4DecoderSpecificInfoDescriptor.h
Generated on Thu May 13 16:36:54 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_DecoderSpecificInfoDescriptor Member List

This is the complete list of members for AP4_DecoderSpecificInfoDescriptor, including all inherited members.
AP4_DecoderSpecificInfoDescriptor(const AP4_DataBuffer &data) | AP4_DecoderSpecificInfoDescriptor |
AP4_DecoderSpecificInfoDescriptor(AP4_ByteStream &stream, AP4_Size header_size, AP4_Size payload_size) | AP4_DecoderSpecificInfoDescriptor |
AP4_Descriptor(AP4_UI08 tag, AP4_Size header_size, AP4_Size payload_size) | AP4_Descriptor | [inline]
AP4_Expandable(AP4_UI32 class_id, ClassIdSize class_id_size, AP4_Size header_size, AP4_Size payload_size) | AP4_Expandable |
CLASS_ID_SIZE_08 enum value | AP4_Expandable |
ClassIdSize enum name | AP4_Expandable |
GetClassId() | AP4_Expandable | [inline]
GetDecoderSpecificInfo() const | AP4_DecoderSpecificInfoDescriptor | [inline, virtual]
GetHeaderSize() | AP4_Expandable | [inline]
GetSize() | AP4_Expandable | [inline]
GetTag() | AP4_Descriptor | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_DecoderSpecificInfoDescriptor | [virtual]
m_ClassId | AP4_Expandable | [protected]
m_ClassIdSize | AP4_Expandable | [protected]
m_HeaderSize | AP4_Expandable | [protected]
m_PayloadSize | AP4_Expandable | [protected]
MinHeaderSize(AP4_Size payload_size) | AP4_Expandable | [static]
Write(AP4_ByteStream &stream) | AP4_Expandable | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_DecoderSpecificInfoDescriptor | [virtual]
~AP4_DecoderSpecificInfoDescriptor() | AP4_DecoderSpecificInfoDescriptor | [virtual]
~AP4_Expandable() | AP4_Expandable | [inline, virtual]
Generated on Thu May 13 16:36:54 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_DecryptingStream Class Reference

AP4_DecryptingStream Class Reference

#include <Ap4Protection.h>

Inheritance diagram for AP4_DecryptingStream:
AP4_ByteStream AP4_Referenceable

List of all members.

Public Types

enum CipherMode {
CIPHER_MODE_CTR,
CIPHER_MODE_CBC
}

Public Member Functions

virtual AP4_Result | ReadPartial (void *buffer, AP4_Size bytes_to_read, AP4_Size &bytes_read)
virtual AP4_Result | WritePartial (const void *buffer, AP4_Size bytes_to_write, AP4_Size &bytes_written)
virtual AP4_Result | Seek (AP4_Position position)
virtual AP4_Result | Tell (AP4_Position &position)
virtual AP4_Result | GetSize (AP4_LargeSize &size)
virtual void | AddReference ()
virtual void | Release ()

Static Public Member Functions

static AP4_Result | Create (CipherMode mode, AP4_ByteStream &encrypted_stream, AP4_LargeSize cleartext_size, const AP4_UI08 *iv, AP4_Size iv_size, const AP4_UI08 *key, AP4_Size key_size, AP4_BlockCipherFactory *block_cipher_factory, AP4_ByteStream *&stream)

Detailed Description

Definition at line 373 of file Ap4Protection.h.

Member Enumeration Documentation

enum AP4_DecryptingStream::CipherMode
Enumerator:
CIPHER_MODE_CTR
CIPHER_MODE_CBC

Definition at line 376 of file Ap4Protection.h.

Member Function Documentation

virtual void AP4_DecryptingStream::AddReference ( ) [virtual]

Implements AP4_Referenceable.

static AP4_Result AP4_DecryptingStream::Create | ( | CipherMode | mode,
 |  | AP4_ByteStream & | encrypted_stream,
 |  | AP4_LargeSize | cleartext_size,
 |  | const AP4_UI08 * | iv,
 |  | AP4_Size | iv_size,
 |  | const AP4_UI08 * | key,
 |  | AP4_Size | key_size,
 |  | AP4_BlockCipherFactory * | block_cipher_factory,
 |  | AP4_ByteStream *& | stream |
 | ) |  |  | [static]
virtual AP4_Result AP4_DecryptingStream::GetSize ( AP4_LargeSize & size ) [virtual]

Implements AP4_ByteStream.

virtual AP4_Result AP4_DecryptingStream::ReadPartial | ( | void * | buffer,
 |  | AP4_Size | bytes_to_read,
 |  | AP4_Size & | bytes_read |
 | ) |  |  | [virtual]

Implements AP4_ByteStream.

virtual void AP4_DecryptingStream::Release ( ) [virtual]

Implements AP4_Referenceable.

virtual AP4_Result AP4_DecryptingStream::Seek ( AP4_Position position ) [virtual]

Implements AP4_ByteStream.

virtual AP4_Result AP4_DecryptingStream::Tell ( AP4_Position & position ) [virtual]

Implements AP4_ByteStream.

virtual AP4_Result AP4_DecryptingStream::WritePartial | ( | const void * | buffer,
 |  | AP4_Size | bytes_to_write,
 |  | AP4_Size & | bytes_written |
 | ) |  |  | [virtual]

Implements AP4_ByteStream.

The documentation for this class was generated from the following file:
  • Ap4Protection.h
Generated on Thu May 13 16:36:54 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_DecryptingStream Member List

This is the complete list of members for AP4_DecryptingStream, including all inherited members.
AddReference() | AP4_DecryptingStream | [virtual]
CIPHER_MODE_CBC enum value | AP4_DecryptingStream |
CIPHER_MODE_CTR enum value | AP4_DecryptingStream |
CipherMode enum name | AP4_DecryptingStream |
CopyTo(AP4_ByteStream &stream, AP4_LargeSize size) | AP4_ByteStream | [virtual]
Create(CipherMode mode, AP4_ByteStream &encrypted_stream, AP4_LargeSize cleartext_size, const AP4_UI08 *iv, AP4_Size iv_size, const AP4_UI08 *key, AP4_Size key_size, AP4_BlockCipherFactory *block_cipher_factory, AP4_ByteStream *&stream) | AP4_DecryptingStream | [static]
Flush() | AP4_ByteStream | [inline, virtual]
GetSize(AP4_LargeSize &size) | AP4_DecryptingStream | [virtual]
Read(void *buffer, AP4_Size bytes_to_read) | AP4_ByteStream |
ReadDouble(double &value) | AP4_ByteStream |
ReadPartial(void *buffer, AP4_Size bytes_to_read, AP4_Size &bytes_read) | AP4_DecryptingStream | [virtual]
ReadString(char *buffer, AP4_Size size) | AP4_ByteStream |
ReadUI08(AP4_UI08 &value) | AP4_ByteStream |
ReadUI16(AP4_UI16 &value) | AP4_ByteStream |
ReadUI24(AP4_UI32 &value) | AP4_ByteStream |
ReadUI32(AP4_UI32 &value) | AP4_ByteStream |
ReadUI64(AP4_UI64 &value) | AP4_ByteStream |
Release() | AP4_DecryptingStream | [virtual]
Seek(AP4_Position position) | AP4_DecryptingStream | [virtual]
Tell(AP4_Position &position) | AP4_DecryptingStream | [virtual]
Write(const void *buffer, AP4_Size bytes_to_write) | AP4_ByteStream |
WriteDouble(double value) | AP4_ByteStream |
WritePartial(const void *buffer, AP4_Size bytes_to_write, AP4_Size &bytes_written) | AP4_DecryptingStream | [virtual]
WriteString(const char *string_buffer) | AP4_ByteStream |
WriteUI08(AP4_UI08 value) | AP4_ByteStream |
WriteUI16(AP4_UI16 value) | AP4_ByteStream |
WriteUI24(AP4_UI32 value) | AP4_ByteStream |
WriteUI32(AP4_UI32 value) | AP4_ByteStream |
WriteUI64(AP4_UI64 value) | AP4_ByteStream |
~AP4_Referenceable() | AP4_Referenceable | [inline, virtual]
Generated on Thu May 13 16:36:54 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_DefaultAtomFactory Class Reference

AP4_DefaultAtomFactory Class Reference

#include <Ap4AtomFactory.h>

Inheritance diagram for AP4_DefaultAtomFactory:
AP4_AtomFactory

List of all members.

Public Member Functions

AP4_DefaultAtomFactory ()

Static Public Attributes

static AP4_DefaultAtomFactory Instance

Detailed Description

Definition at line 99 of file Ap4AtomFactory.h.

Constructor & Destructor Documentation

AP4_DefaultAtomFactory::AP4_DefaultAtomFactory ( )

Member Data Documentation

AP4_DefaultAtomFactory AP4_DefaultAtomFactory::Instance [static]

Definition at line 102 of file Ap4AtomFactory.h.

The documentation for this class was generated from the following file:
  • Ap4AtomFactory.h
Generated on Thu May 13 16:36:54 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_DefaultAtomFactory Member List

This is the complete list of members for AP4_DefaultAtomFactory, including all inherited members.
AddTypeHandler(TypeHandler *handler) | AP4_AtomFactory |
AP4_AtomFactory() | AP4_AtomFactory | [inline]
AP4_DefaultAtomFactory() | AP4_DefaultAtomFactory |
CreateAtomFromStream(AP4_ByteStream &stream, AP4_LargeSize &bytes_available, AP4_Atom *&atom) | AP4_AtomFactory |
CreateAtomFromStream(AP4_ByteStream &stream, AP4_UI32 type, AP4_UI32 size_32, AP4_UI64 size_64, AP4_Atom *&atom) | AP4_AtomFactory | [virtual]
CreateAtomFromStream(AP4_ByteStream &stream, AP4_Atom *&atom) | AP4_AtomFactory |
CreateAtomsFromStream(AP4_ByteStream &stream, AP4_AtomParent &atoms) | AP4_AtomFactory |
CreateAtomsFromStream(AP4_ByteStream &stream, AP4_LargeSize bytes_available, AP4_AtomParent &atoms) | AP4_AtomFactory |
GetContext(AP4_Ordinal depth=0) | AP4_AtomFactory |
Instance | AP4_DefaultAtomFactory | [static]
PopContext() | AP4_AtomFactory |
PushContext(AP4_Atom::Type context) | AP4_AtomFactory |
RemoveTypeHandler(TypeHandler *handler) | AP4_AtomFactory |
~AP4_AtomFactory() | AP4_AtomFactory | [virtual]
Generated on Thu May 13 16:36:54 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_DefaultBlockCipherFactory Class Reference

AP4_DefaultBlockCipherFactory Class Reference

#include <Ap4Protection.h>

Inheritance diagram for AP4_DefaultBlockCipherFactory:
AP4_BlockCipherFactory

List of all members.

Public Member Functions

virtual AP4_Result Create (AP4_BlockCipher::CipherType type, AP4_BlockCipher::CipherDirection direction, const AP4_UI08 *key, AP4_Size key_size, AP4_BlockCipher *&cipher)

Static Public Attributes

static
AP4_DefaultBlockCipherFactory 		Instance

Detailed Description

Definition at line 297 of file Ap4Protection.h.

Member Function Documentation

virtual AP4_Result AP4_DefaultBlockCipherFactory::Create | ( | AP4_BlockCipher::CipherType | type,
 |  | AP4_BlockCipher::CipherDirection | direction,
 |  | const AP4_UI08 * | key,
 |  | AP4_Size | key_size,
 |  | AP4_BlockCipher *& | cipher |
 | ) |  |  | [virtual]

Implements AP4_BlockCipherFactory.

Member Data Documentation

AP4_DefaultBlockCipherFactory AP4_DefaultBlockCipherFactory::Instance [static]

Definition at line 301 of file Ap4Protection.h.

The documentation for this class was generated from the following file:
  • Ap4Protection.h
Generated on Thu May 13 16:36:55 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_DefaultBlockCipherFactory Member List

This is the complete list of members for AP4_DefaultBlockCipherFactory, including all inherited members.
Create(AP4_BlockCipher::CipherType type, AP4_BlockCipher::CipherDirection direction, const AP4_UI08 *key, AP4_Size key_size, AP4_BlockCipher *&cipher) | AP4_DefaultBlockCipherFactory | [virtual]
Instance | AP4_DefaultBlockCipherFactory | [static]
~AP4_BlockCipherFactory() | AP4_BlockCipherFactory | [inline, virtual]
Generated on Thu May 13 16:36:55 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_Descriptor Class Reference

AP4_Descriptor Class Reference

#include <Ap4Descriptor.h>

Inheritance diagram for AP4_Descriptor:
AP4_Expandable AP4_DecoderConfigDescriptor AP4_DecoderSpecificInfoDescriptor AP4_EsDescriptor AP4_EsIdIncDescriptor AP4_EsIdRefDescriptor AP4_IpmpDescriptor AP4_IpmpDescriptorPointer AP4_ObjectDescriptor AP4_SLConfigDescriptor AP4_UnknownDescriptor

List of all members.

Public Member Functions

AP4_Descriptor (AP4_UI08 tag, AP4_Size header_size, AP4_Size payload_size)
virtual AP4_Result Inspect (AP4_AtomInspector &inspector)
AP4_UI08 GetTag ()

Detailed Description

Definition at line 48 of file Ap4Descriptor.h.

Constructor & Destructor Documentation

AP4_Descriptor::AP4_Descriptor | ( | AP4_UI08 | tag,
 |  | AP4_Size | header_size,
 |  | AP4_Size | payload_size |
 | ) |  |  | [inline]

Definition at line 54 of file Ap4Descriptor.h.

Member Function Documentation

AP4_UI08 AP4_Descriptor::GetTag ( ) [inline]

Definition at line 61 of file Ap4Descriptor.h.

References AP4_Expandable::m_ClassId.

Referenced by AP4_DescriptorFinder::Test().

virtual AP4_Result AP4_Descriptor::Inspect ( AP4_AtomInspector & inspector ) [virtual]

Reimplemented from AP4_Expandable.

Reimplemented in AP4_DecoderConfigDescriptor, AP4_DecoderSpecificInfoDescriptor, AP4_EsDescriptor, AP4_EsIdIncDescriptor, AP4_EsIdRefDescriptor, AP4_IpmpDescriptorPointer, AP4_IpmpDescriptor, AP4_ObjectDescriptor, and AP4_InitialObjectDescriptor.

Referenced by AP4_DescriptorListInspector::Action().

The documentation for this class was generated from the following file:
  • Ap4Descriptor.h
Generated on Thu May 13 16:36:55 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_Descriptor Member List

This is the complete list of members for AP4_Descriptor, including all inherited members.
AP4_Descriptor(AP4_UI08 tag, AP4_Size header_size, AP4_Size payload_size) | AP4_Descriptor | [inline]
AP4_Expandable(AP4_UI32 class_id, ClassIdSize class_id_size, AP4_Size header_size, AP4_Size payload_size) | AP4_Expandable |
CLASS_ID_SIZE_08 enum value | AP4_Expandable |
ClassIdSize enum name | AP4_Expandable |
GetClassId() | AP4_Expandable | [inline]
GetHeaderSize() | AP4_Expandable | [inline]
GetSize() | AP4_Expandable | [inline]
GetTag() | AP4_Descriptor | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_Descriptor | [virtual]
m_ClassId | AP4_Expandable | [protected]
m_ClassIdSize | AP4_Expandable | [protected]
m_HeaderSize | AP4_Expandable | [protected]
m_PayloadSize | AP4_Expandable | [protected]
MinHeaderSize(AP4_Size payload_size) | AP4_Expandable | [static]
Write(AP4_ByteStream &stream) | AP4_Expandable | [virtual]
WriteFields(AP4_ByteStream &stream)=0 | AP4_Expandable | [pure virtual]
~AP4_Expandable() | AP4_Expandable | [inline, virtual]
Generated on Thu May 13 16:36:55 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_DescriptorFactory Class Reference

AP4_DescriptorFactory Class Reference

#include <Ap4DescriptorFactory.h>

List of all members.

Static Public Member Functions

static AP4_Result CreateDescriptorFromStream (AP4_ByteStream &stream, AP4_Descriptor *&descriptor)

Detailed Description

Definition at line 46 of file Ap4DescriptorFactory.h.

Member Function Documentation

static AP4_Result AP4_DescriptorFactory::CreateDescriptorFromStream | ( | AP4_ByteStream & | stream,
 |  | AP4_Descriptor *& | descriptor |
 | ) |  |  | [static]
The documentation for this class was generated from the following file:
  • Ap4DescriptorFactory.h
Generated on Thu May 13 16:36:55 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_DescriptorFactory Member List

This is the complete list of members for AP4_DescriptorFactory, including all inherited members.
CreateDescriptorFromStream(AP4_ByteStream &stream, AP4_Descriptor *&descriptor) AP4_DescriptorFactory [static]
Generated on Thu May 13 16:36:55 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_DescriptorFinder Class Reference

AP4_DescriptorFinder Class Reference

#include <Ap4Descriptor.h>

Inheritance diagram for AP4_DescriptorFinder:
AP4_List< T >::Item::Finder

List of all members.

Public Member Functions

AP4_DescriptorFinder (AP4_UI08 tag)
AP4_Result Test (AP4_Descriptor *descriptor) const

Detailed Description

Definition at line 87 of file Ap4Descriptor.h.

Constructor & Destructor Documentation

AP4_DescriptorFinder::AP4_DescriptorFinder ( AP4_UI08 tag ) [inline]

Definition at line 90 of file Ap4Descriptor.h.

Member Function Documentation

AP4_Result AP4_DescriptorFinder::Test ( AP4_Descriptor * descriptor ) const [inline]

Definition at line 91 of file Ap4Descriptor.h.

References AP4_FAILURE, AP4_SUCCESS, and AP4_Descriptor::GetTag().

The documentation for this class was generated from the following file:
  • Ap4Descriptor.h
Generated on Thu May 13 16:36:55 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_DescriptorFinder Member List

This is the complete list of members for AP4_DescriptorFinder, including all inherited members.
AP4_DescriptorFinder(AP4_UI08 tag) | AP4_DescriptorFinder | [inline]
Test(AP4_Descriptor *descriptor) const | AP4_DescriptorFinder | [inline]
AP4_List::Item::Finder::Test(T *data) const =0 | AP4_List< T >::Item::Finder | [pure virtual]
~Finder() | AP4_List< T >::Item::Finder | [inline, virtual]
Generated on Thu May 13 16:36:55 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_DescriptorListInspector Class Reference

AP4_DescriptorListInspector Class Reference

#include <Ap4Descriptor.h>

Inheritance diagram for AP4_DescriptorListInspector:
AP4_List< T >::Item::Operator

List of all members.

Public Member Functions

AP4_DescriptorListInspector (AP4_AtomInspector &inspector)
AP4_Result Action (AP4_Descriptor *descriptor) const

Detailed Description

Definition at line 118 of file Ap4Descriptor.h.

Constructor & Destructor Documentation

AP4_DescriptorListInspector::AP4_DescriptorListInspector ( AP4_AtomInspector & inspector ) [inline]

Definition at line 121 of file Ap4Descriptor.h.

Member Function Documentation

AP4_Result AP4_DescriptorListInspector::Action ( AP4_Descriptor * descriptor ) const [inline]

Definition at line 123 of file Ap4Descriptor.h.

References AP4_SUCCESS, and AP4_Descriptor::Inspect().

The documentation for this class was generated from the following file:
  • Ap4Descriptor.h
Generated on Thu May 13 16:36:55 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_DescriptorListInspector Member List

This is the complete list of members for AP4_DescriptorListInspector, including all inherited members.
Action(AP4_Descriptor *descriptor) const | AP4_DescriptorListInspector | [inline]
AP4_List::Item::Operator::Action(T *data) const =0 | AP4_List< T >::Item::Operator | [pure virtual]
AP4_DescriptorListInspector(AP4_AtomInspector &inspector) | AP4_DescriptorListInspector | [inline]
~Operator() | AP4_List< T >::Item::Operator | [inline, virtual]
Generated on Thu May 13 16:36:55 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_DescriptorListWriter Class Reference

AP4_DescriptorListWriter Class Reference

#include <Ap4Descriptor.h>

Inheritance diagram for AP4_DescriptorListWriter:
AP4_List< T >::Item::Operator

List of all members.

Public Member Functions

AP4_DescriptorListWriter (AP4_ByteStream &stream)
AP4_Result Action (AP4_Descriptor *descriptor) const

Detailed Description

Definition at line 102 of file Ap4Descriptor.h.

Constructor & Destructor Documentation

AP4_DescriptorListWriter::AP4_DescriptorListWriter ( AP4_ByteStream & stream ) [inline]

Definition at line 105 of file Ap4Descriptor.h.

Member Function Documentation

AP4_Result AP4_DescriptorListWriter::Action ( AP4_Descriptor * descriptor ) const [inline]

Definition at line 107 of file Ap4Descriptor.h.

References AP4_Expandable::Write().

The documentation for this class was generated from the following file:
  • Ap4Descriptor.h
Generated on Thu May 13 16:36:55 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_DescriptorListWriter Member List

This is the complete list of members for AP4_DescriptorListWriter, including all inherited members.
Action(AP4_Descriptor *descriptor) const | AP4_DescriptorListWriter | [inline]
AP4_List::Item::Operator::Action(T *data) const =0 | AP4_List< T >::Item::Operator | [pure virtual]
AP4_DescriptorListWriter(AP4_ByteStream &stream) | AP4_DescriptorListWriter | [inline]
~Operator() | AP4_List< T >::Item::Operator | [inline, virtual]
Generated on Thu May 13 16:36:55 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_DescriptorUpdateCommand Class Reference

AP4_DescriptorUpdateCommand Class Reference

This class is used for ObjectDescriptorUpdateCommand and IPMP_DescriptorUpdateCommand. More...

#include <Ap4ObjectDescriptor.h>

Inheritance diagram for AP4_DescriptorUpdateCommand:
AP4_Command AP4_Expandable

List of all members.

Public Member Functions

AP4_DescriptorUpdateCommand (AP4_UI08 tag)
AP4_DescriptorUpdateCommand (AP4_ByteStream &stream, AP4_UI08 tag, AP4_Size header_size, AP4_Size payload_size)
virtual | ~AP4_DescriptorUpdateCommand ()
virtual AP4_Result | AddDescriptor (AP4_Descriptor *descriptor)
virtual AP4_Result | WriteFields (AP4_ByteStream &stream)
virtual AP4_Result | Inspect (AP4_AtomInspector &inspector)
const AP4_List< AP4_Descriptor > & | GetDescriptors ()

Protected Attributes

AP4_List< AP4_Descriptor > m_Descriptors

Detailed Description

This class is used for ObjectDescriptorUpdateCommand and IPMP_DescriptorUpdateCommand.

Definition at line 143 of file Ap4ObjectDescriptor.h.

Constructor & Destructor Documentation

AP4_DescriptorUpdateCommand::AP4_DescriptorUpdateCommand ( AP4_UI08 tag )
AP4_DescriptorUpdateCommand::AP4_DescriptorUpdateCommand | ( | AP4_ByteStream & | stream,
 |  | AP4_UI08 | tag,
 |  | AP4_Size | header_size,
 |  | AP4_Size | payload_size
 | ) |  |
virtual AP4_DescriptorUpdateCommand::~AP4_DescriptorUpdateCommand ( ) [virtual]

Member Function Documentation

virtual AP4_Result AP4_DescriptorUpdateCommand::AddDescriptor ( AP4_Descriptor * descriptor ) [virtual]
const AP4_List<AP4_Descriptor>& AP4_DescriptorUpdateCommand::GetDescriptors ( ) [inline]

Definition at line 160 of file Ap4ObjectDescriptor.h.

References m_Descriptors.

virtual AP4_Result AP4_DescriptorUpdateCommand::Inspect ( AP4_AtomInspector & inspector ) [virtual]

Reimplemented from AP4_Command.

virtual AP4_Result AP4_DescriptorUpdateCommand::WriteFields ( AP4_ByteStream & stream ) [virtual]

Implements AP4_Expandable.

Member Data Documentation

AP4_List<AP4_Descriptor> AP4_DescriptorUpdateCommand::m_Descriptors [mutable, protected]

Definition at line 164 of file Ap4ObjectDescriptor.h.

Referenced by GetDescriptors().

The documentation for this class was generated from the following file:
  • Ap4ObjectDescriptor.h
Generated on Thu May 13 16:36:55 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_DescriptorUpdateCommand Member List

This is the complete list of members for AP4_DescriptorUpdateCommand, including all inherited members.
AddDescriptor(AP4_Descriptor *descriptor) | AP4_DescriptorUpdateCommand | [virtual]
AP4_Command(AP4_UI08 tag, AP4_Size header_size, AP4_Size payload_size) | AP4_Command | [inline]
AP4_DescriptorUpdateCommand(AP4_UI08 tag) | AP4_DescriptorUpdateCommand |
AP4_DescriptorUpdateCommand(AP4_ByteStream &stream, AP4_UI08 tag, AP4_Size header_size, AP4_Size payload_size) | AP4_DescriptorUpdateCommand |
AP4_Expandable(AP4_UI32 class_id, ClassIdSize class_id_size, AP4_Size header_size, AP4_Size payload_size) | AP4_Expandable |
CLASS_ID_SIZE_08 enum value | AP4_Expandable |
ClassIdSize enum name | AP4_Expandable |
GetClassId() | AP4_Expandable | [inline]
GetDescriptors() | AP4_DescriptorUpdateCommand | [inline]
GetHeaderSize() | AP4_Expandable | [inline]
GetSize() | AP4_Expandable | [inline]
GetTag() | AP4_Command | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_DescriptorUpdateCommand | [virtual]
m_ClassId | AP4_Expandable | [protected]
m_ClassIdSize | AP4_Expandable | [protected]
m_Descriptors | AP4_DescriptorUpdateCommand | [mutable, protected]
m_HeaderSize | AP4_Expandable | [protected]
m_PayloadSize | AP4_Expandable | [protected]
MinHeaderSize(AP4_Size payload_size) | AP4_Expandable | [static]
Write(AP4_ByteStream &stream) | AP4_Expandable | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_DescriptorUpdateCommand | [virtual]
~AP4_DescriptorUpdateCommand() | AP4_DescriptorUpdateCommand | [virtual]
~AP4_Expandable() | AP4_Expandable | [inline, virtual]
Generated on Thu May 13 16:36:55 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_DrefAtom Class Reference

AP4_DrefAtom Class Reference

#include <Ap4DrefAtom.h>

Inheritance diagram for AP4_DrefAtom:
AP4_ContainerAtom AP4_Atom AP4_AtomParent

List of all members.

Public Member Functions

AP4_DrefAtom (AP4_Atom **refs, AP4_Cardinal refs_count)
virtual AP4_Result | WriteFields (AP4_ByteStream &stream)

Static Public Member Functions

static AP4_DrefAtom * | Create (AP4_UI32 size, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory)

Detailed Description

Definition at line 47 of file Ap4DrefAtom.h.

Constructor & Destructor Documentation

AP4_DrefAtom::AP4_DrefAtom | ( | AP4_Atom ** | refs,
 |  | AP4_Cardinal | refs_count
 | ) |  |

Member Function Documentation

static AP4_DrefAtom* AP4_DrefAtom::Create | ( | AP4_UI32 | size,
 |  | AP4_ByteStream & | stream,
 |  | AP4_AtomFactory & | atom_factory |
 | ) |  |  | [static]
virtual AP4_Result AP4_DrefAtom::WriteFields ( AP4_ByteStream & stream ) [virtual]

Reimplemented from AP4_ContainerAtom.

The documentation for this class was generated from the following file:
  • Ap4DrefAtom.h
Generated on Thu May 13 16:36:55 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_DrefAtom Member List

This is the complete list of members for AP4_DrefAtom, including all inherited members.
AddChild(AP4_Atom *child, int position=-1) | AP4_AtomParent | [virtual]
AP4_Atom(Type type, AP4_UI32 size=AP4_ATOM_HEADER_SIZE) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64=false) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_ContainerAtom(Type type) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI32 version, AP4_UI32 flags) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_ContainerAtom | [protected]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_ContainerAtom | [protected]
AP4_DrefAtom(AP4_Atom **refs, AP4_Cardinal refs_count) | AP4_DrefAtom |
Clone() | AP4_ContainerAtom | [virtual]
Create(AP4_UI32 size, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_DrefAtom | [static]
AP4_ContainerAtom::Create(Type type, AP4_UI64 size, bool is_full, bool force_64, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_ContainerAtom | [static]
DeleteChild(AP4_Atom::Type type, AP4_Ordinal index=0) | AP4_AtomParent | [virtual]
Detach() | AP4_Atom | [virtual]
FindChild(const char *path, bool auto_create=false, bool auto_create_full=false) | AP4_AtomParent | [virtual]
GetChild(AP4_Atom::Type type, AP4_Ordinal index=0) const | AP4_AtomParent | [virtual]
GetChild(const AP4_UI08 *uuid, AP4_Ordinal index=0) const | AP4_AtomParent | [virtual]
GetChildren() | AP4_ContainerAtom | [inline]
GetFlags() const | AP4_Atom | [inline]
GetHeaderSize() const | AP4_Atom | [virtual]
GetParent() | AP4_Atom | [inline, virtual]
GetSize() const | AP4_Atom | [inline]
GetSize32() const | AP4_Atom | [inline]
GetSize64() const | AP4_Atom | [inline]
GetType() const | AP4_Atom | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
InspectChildren(AP4_AtomInspector &inspector) | AP4_ContainerAtom | [virtual]
InspectFields(AP4_AtomInspector &inspector) | AP4_ContainerAtom | [virtual]
InspectHeader(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
m_Children | AP4_AtomParent | [protected]
m_Flags | AP4_Atom | [protected]
m_IsFull | AP4_Atom | [protected]
m_Parent | AP4_Atom | [protected]
m_Size32 | AP4_Atom | [protected]
m_Size64 | AP4_Atom | [protected]
m_Type | AP4_Atom | [protected]
m_Version | AP4_Atom | [protected]
OnChildAdded(AP4_Atom *child) | AP4_ContainerAtom | [virtual]
OnChildChanged(AP4_Atom *child) | AP4_ContainerAtom | [virtual]
OnChildRemoved(AP4_Atom *child) | AP4_ContainerAtom | [virtual]
ReadChildren(AP4_AtomFactory &atom_factory, AP4_ByteStream &stream, AP4_UI64 size) | AP4_ContainerAtom | [protected]
ReadFullHeader(AP4_ByteStream &stream, AP4_UI32 &version, AP4_UI32 &flags) | AP4_Atom | [static]
RemoveChild(AP4_Atom *child) | AP4_AtomParent | [virtual]
SetFlags(AP4_UI32 flags) | AP4_Atom | [inline]
SetParent(AP4_AtomParent *parent) | AP4_Atom | [inline, virtual]
SetSize(AP4_UI64 size, bool force_64=false) | AP4_Atom |
SetSize32(AP4_UI32 size) | AP4_Atom | [inline]
SetSize64(AP4_UI64 size) | AP4_Atom | [inline]
SetType(Type type) | AP4_Atom | [inline]
Type typedef | AP4_Atom |
TypeFromString(const char *four_cc) | AP4_Atom | [static]
Write(AP4_ByteStream &stream) | AP4_Atom | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_DrefAtom | [virtual]
WriteHeader(AP4_ByteStream &stream) | AP4_Atom | [virtual]
~AP4_Atom() | AP4_Atom | [inline, virtual]
~AP4_AtomParent() | AP4_AtomParent | [virtual]
Generated on Thu May 13 16:36:55 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_DrmiSampleEntry Class Reference

AP4_DrmiSampleEntry Class Reference

#include <Ap4Protection.h>

Inheritance diagram for AP4_DrmiSampleEntry:
AP4_EncvSampleEntry AP4_VisualSampleEntry AP4_SampleEntry AP4_ContainerAtom AP4_Atom AP4_AtomParent

List of all members.

Public Member Functions

AP4_DrmiSampleEntry (AP4_Size size, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory)

Detailed Description

Definition at line 120 of file Ap4Protection.h.

Constructor & Destructor Documentation

AP4_DrmiSampleEntry::AP4_DrmiSampleEntry | ( | AP4_Size | size,
 |  | AP4_ByteStream & | stream,
 |  | AP4_AtomFactory & | atom_factory
 | ) |  |
The documentation for this class was generated from the following file:
  • Ap4Protection.h
Generated on Thu May 13 16:36:56 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_DrmiSampleEntry Member List

This is the complete list of members for AP4_DrmiSampleEntry, including all inherited members.
AddChild(AP4_Atom *child, int position=-1) | AP4_AtomParent | [virtual]
AP4_Atom(Type type, AP4_UI32 size=AP4_ATOM_HEADER_SIZE) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64=false) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_ContainerAtom(Type type) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI32 version, AP4_UI32 flags) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_ContainerAtom | [protected]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_ContainerAtom | [protected]
AP4_DrmiSampleEntry(AP4_Size size, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_DrmiSampleEntry |
AP4_EncvSampleEntry(AP4_Size size, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_EncvSampleEntry |
AP4_EncvSampleEntry(AP4_UI32 type, AP4_Size size, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_EncvSampleEntry |
AP4_SampleEntry(AP4_Atom::Type format, AP4_UI16 data_ref_index=1) | AP4_SampleEntry |
AP4_SampleEntry(AP4_Atom::Type format, AP4_Size size, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_SampleEntry |
AP4_SampleEntry(AP4_Atom::Type format, AP4_Size size) | AP4_SampleEntry | [protected]
AP4_VisualSampleEntry(AP4_Atom::Type format, AP4_UI16 width, AP4_UI16 height, AP4_UI16 depth, const char *compressor_name) | AP4_VisualSampleEntry |
AP4_VisualSampleEntry(AP4_Atom::Type format, AP4_Size size, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_VisualSampleEntry |
Clone() | AP4_ContainerAtom | [virtual]
Create(Type type, AP4_UI64 size, bool is_full, bool force_64, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_ContainerAtom | [static]
DeleteChild(AP4_Atom::Type type, AP4_Ordinal index=0) | AP4_AtomParent | [virtual]
Detach() | AP4_Atom | [virtual]
FindChild(const char *path, bool auto_create=false, bool auto_create_full=false) | AP4_AtomParent | [virtual]
GetChild(AP4_Atom::Type type, AP4_Ordinal index=0) const | AP4_AtomParent | [virtual]
GetChild(const AP4_UI08 *uuid, AP4_Ordinal index=0) const | AP4_AtomParent | [virtual]
GetChildren() | AP4_ContainerAtom | [inline]
GetCompressorName() | AP4_VisualSampleEntry | [inline]
GetDataReferenceIndex() | AP4_SampleEntry | [inline]
GetDepth() | AP4_VisualSampleEntry | [inline]
GetFieldsSize() | AP4_VisualSampleEntry | [protected, virtual]
GetFlags() const | AP4_Atom | [inline]
GetHeaderSize() const | AP4_Atom | [virtual]
GetHeight() | AP4_VisualSampleEntry | [inline]
GetHorizResolution() | AP4_VisualSampleEntry | [inline]
GetParent() | AP4_Atom | [inline, virtual]
GetSize() const | AP4_Atom | [inline]
GetSize32() const | AP4_Atom | [inline]
GetSize64() const | AP4_Atom | [inline]
GetType() const | AP4_Atom | [inline]
GetVertResolution() | AP4_VisualSampleEntry | [inline]
GetWidth() | AP4_VisualSampleEntry | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_SampleEntry | [virtual]
InspectChildren(AP4_AtomInspector &inspector) | AP4_ContainerAtom | [virtual]
InspectFields(AP4_AtomInspector &inspector) | AP4_VisualSampleEntry | [protected, virtual]
InspectHeader(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
m_Children | AP4_AtomParent | [protected]
m_CompressorName | AP4_VisualSampleEntry | [protected]
m_DataReferenceIndex | AP4_SampleEntry | [protected]
m_Depth | AP4_VisualSampleEntry | [protected]
m_Flags | AP4_Atom | [protected]
m_FrameCount | AP4_VisualSampleEntry | [protected]
m_Height | AP4_VisualSampleEntry | [protected]
m_HorizResolution | AP4_VisualSampleEntry | [protected]
m_IsFull | AP4_Atom | [protected]
m_Parent | AP4_Atom | [protected]
m_Predefined1 | AP4_VisualSampleEntry | [protected]
m_Predefined2 | AP4_VisualSampleEntry | [protected]
m_Predefined3 | AP4_VisualSampleEntry | [protected]
m_Reserved1 | AP4_SampleEntry | [protected]
m_Reserved2 | AP4_VisualSampleEntry | [protected]
m_Reserved3 | AP4_VisualSampleEntry | [protected]
m_Size32 | AP4_Atom | [protected]
m_Size64 | AP4_Atom | [protected]
m_Type | AP4_Atom | [protected]
m_Version | AP4_Atom | [protected]
m_VertResolution | AP4_VisualSampleEntry | [protected]
m_Width | AP4_VisualSampleEntry | [protected]
OnChildAdded(AP4_Atom *child) | AP4_ContainerAtom | [virtual]
OnChildChanged(AP4_Atom *child) | AP4_SampleEntry | [virtual]
OnChildRemoved(AP4_Atom *child) | AP4_ContainerAtom | [virtual]
Read(AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_SampleEntry | [protected, virtual]
ReadChildren(AP4_AtomFactory &atom_factory, AP4_ByteStream &stream, AP4_UI64 size) | AP4_ContainerAtom | [protected]
ReadFields(AP4_ByteStream &stream) | AP4_VisualSampleEntry | [protected, virtual]
ReadFullHeader(AP4_ByteStream &stream, AP4_UI32 &version, AP4_UI32 &flags) | AP4_Atom | [static]
RemoveChild(AP4_Atom *child) | AP4_AtomParent | [virtual]
SetFlags(AP4_UI32 flags) | AP4_Atom | [inline]
SetParent(AP4_AtomParent *parent) | AP4_Atom | [inline, virtual]
SetSize(AP4_UI64 size, bool force_64=false) | AP4_Atom |
SetSize32(AP4_UI32 size) | AP4_Atom | [inline]
SetSize64(AP4_UI64 size) | AP4_Atom | [inline]
SetType(Type type) | AP4_Atom | [inline]
ToSampleDescription() | AP4_EncvSampleEntry | [virtual]
ToTargetSampleDescription(AP4_UI32 format) | AP4_EncvSampleEntry | [virtual]
Type typedef | AP4_Atom |
TypeFromString(const char *four_cc) | AP4_Atom | [static]
Write(AP4_ByteStream &stream) | AP4_SampleEntry | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_VisualSampleEntry | [protected, virtual]
WriteHeader(AP4_ByteStream &stream) | AP4_Atom | [virtual]
~AP4_Atom() | AP4_Atom | [inline, virtual]
~AP4_AtomParent() | AP4_AtomParent | [virtual]
~AP4_SampleEntry() | AP4_SampleEntry | [inline, virtual]
Generated on Thu May 13 16:36:56 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_DrmsSampleEntry Class Reference

AP4_DrmsSampleEntry Class Reference

#include <Ap4Protection.h>

Inheritance diagram for AP4_DrmsSampleEntry:
AP4_EncaSampleEntry AP4_AudioSampleEntry AP4_SampleEntry AP4_ContainerAtom AP4_Atom AP4_AtomParent

List of all members.

Public Member Functions

AP4_DrmsSampleEntry (AP4_Size size, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory)

Detailed Description

Definition at line 108 of file Ap4Protection.h.

Constructor & Destructor Documentation

AP4_DrmsSampleEntry::AP4_DrmsSampleEntry | ( | AP4_Size | size,
 |  | AP4_ByteStream & | stream,
 |  | AP4_AtomFactory & | atom_factory
 | ) |  |
The documentation for this class was generated from the following file:
  • Ap4Protection.h
Generated on Thu May 13 16:36:56 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_DrmsSampleEntry Member List

This is the complete list of members for AP4_DrmsSampleEntry, including all inherited members.
AddChild(AP4_Atom *child, int position=-1) | AP4_AtomParent | [virtual]
AP4_Atom(Type type, AP4_UI32 size=AP4_ATOM_HEADER_SIZE) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64=false) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_AudioSampleEntry(AP4_Atom::Type format, AP4_UI32 sample_rate, AP4_UI16 sample_size, AP4_UI16 channel_count) | AP4_AudioSampleEntry |
AP4_AudioSampleEntry(AP4_Atom::Type format, AP4_Size size, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_AudioSampleEntry |
AP4_ContainerAtom(Type type) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI32 version, AP4_UI32 flags) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_ContainerAtom | [protected]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_ContainerAtom | [protected]
AP4_DrmsSampleEntry(AP4_Size size, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_DrmsSampleEntry |
AP4_EncaSampleEntry(AP4_Size size, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_EncaSampleEntry |
AP4_EncaSampleEntry(AP4_UI32 type, AP4_Size size, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_EncaSampleEntry |
AP4_SampleEntry(AP4_Atom::Type format, AP4_UI16 data_ref_index=1) | AP4_SampleEntry |
AP4_SampleEntry(AP4_Atom::Type format, AP4_Size size, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_SampleEntry |
AP4_SampleEntry(AP4_Atom::Type format, AP4_Size size) | AP4_SampleEntry | [protected]
Clone() | AP4_ContainerAtom | [virtual]
Create(Type type, AP4_UI64 size, bool is_full, bool force_64, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_ContainerAtom | [static]
DeleteChild(AP4_Atom::Type type, AP4_Ordinal index=0) | AP4_AtomParent | [virtual]
Detach() | AP4_Atom | [virtual]
FindChild(const char *path, bool auto_create=false, bool auto_create_full=false) | AP4_AtomParent | [virtual]
GetChannelCount() | AP4_AudioSampleEntry |
GetChild(AP4_Atom::Type type, AP4_Ordinal index=0) const | AP4_AtomParent | [virtual]
GetChild(const AP4_UI08 *uuid, AP4_Ordinal index=0) const | AP4_AtomParent | [virtual]
GetChildren() | AP4_ContainerAtom | [inline]
GetDataReferenceIndex() | AP4_SampleEntry | [inline]
GetFieldsSize() | AP4_AudioSampleEntry | [protected, virtual]
GetFlags() const | AP4_Atom | [inline]
GetHeaderSize() const | AP4_Atom | [virtual]
GetParent() | AP4_Atom | [inline, virtual]
GetSampleRate() | AP4_AudioSampleEntry |
GetSampleSize() | AP4_AudioSampleEntry | [inline]
GetSize() const | AP4_Atom | [inline]
GetSize32() const | AP4_Atom | [inline]
GetSize64() const | AP4_Atom | [inline]
GetType() const | AP4_Atom | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_SampleEntry | [virtual]
InspectChildren(AP4_AtomInspector &inspector) | AP4_ContainerAtom | [virtual]
InspectFields(AP4_AtomInspector &inspector) | AP4_AudioSampleEntry | [protected, virtual]
InspectHeader(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
m_ChannelCount | AP4_AudioSampleEntry | [protected]
m_Children | AP4_AtomParent | [protected]
m_DataReferenceIndex | AP4_SampleEntry | [protected]
m_Flags | AP4_Atom | [protected]
m_IsFull | AP4_Atom | [protected]
m_Parent | AP4_Atom | [protected]
m_QtCompressionId | AP4_AudioSampleEntry | [protected]
m_QtPacketSize | AP4_AudioSampleEntry | [protected]
m_QtRevision | AP4_AudioSampleEntry | [protected]
m_QtV1BytesPerFrame | AP4_AudioSampleEntry | [protected]
m_QtV1BytesPerPacket | AP4_AudioSampleEntry | [protected]
m_QtV1BytesPerSample | AP4_AudioSampleEntry | [protected]
m_QtV1SamplesPerPacket | AP4_AudioSampleEntry | [protected]
m_QtV2BitsPerChannel | AP4_AudioSampleEntry | [protected]
m_QtV2BytesPerAudioPacket | AP4_AudioSampleEntry | [protected]
m_QtV2ChannelCount | AP4_AudioSampleEntry | [protected]
m_QtV2Extension | AP4_AudioSampleEntry | [protected]
m_QtV2FormatSpecificFlags | AP4_AudioSampleEntry | [protected]
m_QtV2LPCMFramesPerAudioPacket | AP4_AudioSampleEntry | [protected]
m_QtV2Reserved | AP4_AudioSampleEntry | [protected]
m_QtV2SampleRate64 | AP4_AudioSampleEntry | [protected]
m_QtV2StructSize | AP4_AudioSampleEntry | [protected]
m_QtVendor | AP4_AudioSampleEntry | [protected]
m_QtVersion | AP4_AudioSampleEntry | [protected]
m_Reserved1 | AP4_SampleEntry | [protected]
m_SampleRate | AP4_AudioSampleEntry | [protected]
m_SampleSize | AP4_AudioSampleEntry | [protected]
m_Size32 | AP4_Atom | [protected]
m_Size64 | AP4_Atom | [protected]
m_Type | AP4_Atom | [protected]
m_Version | AP4_Atom | [protected]
OnChildAdded(AP4_Atom *child) | AP4_ContainerAtom | [virtual]
OnChildChanged(AP4_Atom *child) | AP4_SampleEntry | [virtual]
OnChildRemoved(AP4_Atom *child) | AP4_ContainerAtom | [virtual]
Read(AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_SampleEntry | [protected, virtual]
ReadChildren(AP4_AtomFactory &atom_factory, AP4_ByteStream &stream, AP4_UI64 size) | AP4_ContainerAtom | [protected]
ReadFields(AP4_ByteStream &stream) | AP4_AudioSampleEntry | [protected, virtual]
ReadFullHeader(AP4_ByteStream &stream, AP4_UI32 &version, AP4_UI32 &flags) | AP4_Atom | [static]
RemoveChild(AP4_Atom *child) | AP4_AtomParent | [virtual]
SetFlags(AP4_UI32 flags) | AP4_Atom | [inline]
SetParent(AP4_AtomParent *parent) | AP4_Atom | [inline, virtual]
SetSize(AP4_UI64 size, bool force_64=false) | AP4_Atom |
SetSize32(AP4_UI32 size) | AP4_Atom | [inline]
SetSize64(AP4_UI64 size) | AP4_Atom | [inline]
SetType(Type type) | AP4_Atom | [inline]
ToSampleDescription() | AP4_EncaSampleEntry | [virtual]
ToTargetSampleDescription(AP4_UI32 format) | AP4_EncaSampleEntry | [virtual]
Type typedef | AP4_Atom |
TypeFromString(const char *four_cc) | AP4_Atom | [static]
Write(AP4_ByteStream &stream) | AP4_SampleEntry | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_AudioSampleEntry | [protected, virtual]
WriteHeader(AP4_ByteStream &stream) | AP4_Atom | [virtual]
~AP4_Atom() | AP4_Atom | [inline, virtual]
~AP4_AtomParent() | AP4_AtomParent | [virtual]
~AP4_SampleEntry() | AP4_SampleEntry | [inline, virtual]
Generated on Thu May 13 16:36:56 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_ElstAtom Class Reference

AP4_ElstAtom Class Reference

#include <Ap4ElstAtom.h>

Inheritance diagram for AP4_ElstAtom:
AP4_Atom

List of all members.

Public Member Functions

virtual AP4_Result | InspectFields (AP4_AtomInspector &inspector)
virtual AP4_Result | WriteFields (AP4_ByteStream &stream)

Static Public Member Functions

static AP4_ElstAtom * | Create (AP4_Size size, AP4_ByteStream &stream)

Detailed Description

Definition at line 59 of file Ap4ElstAtom.h.

Member Function Documentation

static AP4_ElstAtom* AP4_ElstAtom::Create | ( | AP4_Size | size,
 |  | AP4_ByteStream & | stream |
 | ) |  |  | [static]
virtual AP4_Result AP4_ElstAtom::InspectFields ( AP4_AtomInspector & inspector ) [virtual]

Reimplemented from AP4_Atom.

virtual AP4_Result AP4_ElstAtom::WriteFields ( AP4_ByteStream & stream ) [virtual]

Implements AP4_Atom.

The documentation for this class was generated from the following file:
  • Ap4ElstAtom.h
Generated on Thu May 13 16:36:56 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_ElstAtom Member List

This is the complete list of members for AP4_ElstAtom, including all inherited members.
AP4_Atom(Type type, AP4_UI32 size=AP4_ATOM_HEADER_SIZE) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64=false) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
Clone() | AP4_Atom | [virtual]
Create(AP4_Size size, AP4_ByteStream &stream) | AP4_ElstAtom | [static]
Detach() | AP4_Atom | [virtual]
GetFlags() const | AP4_Atom | [inline]
GetHeaderSize() const | AP4_Atom | [virtual]
GetParent() | AP4_Atom | [inline, virtual]
GetSize() const | AP4_Atom | [inline]
GetSize32() const | AP4_Atom | [inline]
GetSize64() const | AP4_Atom | [inline]
GetType() const | AP4_Atom | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
InspectFields(AP4_AtomInspector &inspector) | AP4_ElstAtom | [virtual]
InspectHeader(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
m_Flags | AP4_Atom | [protected]
m_IsFull | AP4_Atom | [protected]
m_Parent | AP4_Atom | [protected]
m_Size32 | AP4_Atom | [protected]
m_Size64 | AP4_Atom | [protected]
m_Type | AP4_Atom | [protected]
m_Version | AP4_Atom | [protected]
ReadFullHeader(AP4_ByteStream &stream, AP4_UI32 &version, AP4_UI32 &flags) | AP4_Atom | [static]
SetFlags(AP4_UI32 flags) | AP4_Atom | [inline]
SetParent(AP4_AtomParent *parent) | AP4_Atom | [inline, virtual]
SetSize(AP4_UI64 size, bool force_64=false) | AP4_Atom |
SetSize32(AP4_UI32 size) | AP4_Atom | [inline]
SetSize64(AP4_UI64 size) | AP4_Atom | [inline]
SetType(Type type) | AP4_Atom | [inline]
Type typedef | AP4_Atom |
TypeFromString(const char *four_cc) | AP4_Atom | [static]
Write(AP4_ByteStream &stream) | AP4_Atom | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_ElstAtom | [virtual]
WriteHeader(AP4_ByteStream &stream) | AP4_Atom | [virtual]
~AP4_Atom() | AP4_Atom | [inline, virtual]
Generated on Thu May 13 16:36:56 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_ElstEntry Class Reference

AP4_ElstEntry Class Reference

#include <Ap4ElstAtom.h>

List of all members.

Public Member Functions

AP4_ElstEntry (AP4_UI64 segment_duration=0, AP4_SI64 media_time=0, AP4_UI16 media_rate=1)

Public Attributes

AP4_UI64 m_SegmentDuration
AP4_SI64 m_MediaTime
AP4_UI16 m_MediaRate

Detailed Description

Definition at line 47 of file Ap4ElstAtom.h.

Constructor & Destructor Documentation

AP4_ElstEntry::AP4_ElstEntry | ( | AP4_UI64 | segment_duration = 0,
 |  | AP4_SI64 | media_time = 0,
 |  | AP4_UI16 | media_rate = 1 |
 | ) |  |  | [inline]

Definition at line 49 of file Ap4ElstAtom.h.

Member Data Documentation

AP4_UI16 AP4_ElstEntry::m_MediaRate

Definition at line 56 of file Ap4ElstAtom.h.

AP4_SI64 AP4_ElstEntry::m_MediaTime

Definition at line 55 of file Ap4ElstAtom.h.

AP4_UI64 AP4_ElstEntry::m_SegmentDuration

Definition at line 54 of file Ap4ElstAtom.h.

The documentation for this class was generated from the following file:
  • Ap4ElstAtom.h
Generated on Thu May 13 16:36:56 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_ElstEntry Member List

This is the complete list of members for AP4_ElstEntry, including all inherited members.
AP4_ElstEntry(AP4_UI64 segment_duration=0, AP4_SI64 media_time=0, AP4_UI16 media_rate=1) | AP4_ElstEntry | [inline]
m_MediaRate | AP4_ElstEntry |
m_MediaTime | AP4_ElstEntry |
m_SegmentDuration | AP4_ElstEntry |
Generated on Thu May 13 16:36:56 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_EncaSampleEntry Class Reference

AP4_EncaSampleEntry Class Reference

#include <Ap4Protection.h>

Inheritance diagram for AP4_EncaSampleEntry:
AP4_AudioSampleEntry AP4_SampleEntry AP4_ContainerAtom AP4_Atom AP4_AtomParent AP4_DrmsSampleEntry

List of all members.

Public Member Functions

AP4_EncaSampleEntry (AP4_Size size, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory)
AP4_EncaSampleEntry (AP4_UI32 type, AP4_Size size, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory)
AP4_SampleDescription * ToSampleDescription ()
virtual AP4_SampleDescription * ToTargetSampleDescription (AP4_UI32 format)

Detailed Description

Definition at line 58 of file Ap4Protection.h.

Constructor & Destructor Documentation

AP4_EncaSampleEntry::AP4_EncaSampleEntry | ( | AP4_Size | size,
 |  | AP4_ByteStream & | stream,
 |  | AP4_AtomFactory & | atom_factory
 | ) |  |
AP4_EncaSampleEntry::AP4_EncaSampleEntry | ( | AP4_UI32 | type,
 |  | AP4_Size | size,
 |  | AP4_ByteStream & | stream,
 |  | AP4_AtomFactory & | atom_factory
 | ) |  |

Member Function Documentation

AP4_SampleDescription* AP4_EncaSampleEntry::ToSampleDescription ( ) [virtual]

Reimplemented from AP4_AudioSampleEntry.

virtual AP4_SampleDescription* AP4_EncaSampleEntry::ToTargetSampleDescription ( AP4_UI32 format ) [virtual]
The documentation for this class was generated from the following file:
  • Ap4Protection.h
Generated on Thu May 13 16:36:56 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_EncaSampleEntry Member List

This is the complete list of members for AP4_EncaSampleEntry, including all inherited members.
AddChild(AP4_Atom *child, int position=-1) | AP4_AtomParent | [virtual]
AP4_Atom(Type type, AP4_UI32 size=AP4_ATOM_HEADER_SIZE) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64=false) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_AudioSampleEntry(AP4_Atom::Type format, AP4_UI32 sample_rate, AP4_UI16 sample_size, AP4_UI16 channel_count) | AP4_AudioSampleEntry |
AP4_AudioSampleEntry(AP4_Atom::Type format, AP4_Size size, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_AudioSampleEntry |
AP4_ContainerAtom(Type type) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI32 version, AP4_UI32 flags) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_ContainerAtom | [protected]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_ContainerAtom | [protected]
AP4_EncaSampleEntry(AP4_Size size, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_EncaSampleEntry |
AP4_EncaSampleEntry(AP4_UI32 type, AP4_Size size, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_EncaSampleEntry |
AP4_SampleEntry(AP4_Atom::Type format, AP4_UI16 data_ref_index=1) | AP4_SampleEntry |
AP4_SampleEntry(AP4_Atom::Type format, AP4_Size size, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_SampleEntry |
AP4_SampleEntry(AP4_Atom::Type format, AP4_Size size) | AP4_SampleEntry | [protected]
Clone() | AP4_ContainerAtom | [virtual]
Create(Type type, AP4_UI64 size, bool is_full, bool force_64, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_ContainerAtom | [static]
DeleteChild(AP4_Atom::Type type, AP4_Ordinal index=0) | AP4_AtomParent | [virtual]
Detach() | AP4_Atom | [virtual]
FindChild(const char *path, bool auto_create=false, bool auto_create_full=false) | AP4_AtomParent | [virtual]
GetChannelCount() | AP4_AudioSampleEntry |
GetChild(AP4_Atom::Type type, AP4_Ordinal index=0) const | AP4_AtomParent | [virtual]
GetChild(const AP4_UI08 *uuid, AP4_Ordinal index=0) const | AP4_AtomParent | [virtual]
GetChildren() | AP4_ContainerAtom | [inline]
GetDataReferenceIndex() | AP4_SampleEntry | [inline]
GetFieldsSize() | AP4_AudioSampleEntry | [protected, virtual]
GetFlags() const | AP4_Atom | [inline]
GetHeaderSize() const | AP4_Atom | [virtual]
GetParent() | AP4_Atom | [inline, virtual]
GetSampleRate() | AP4_AudioSampleEntry |
GetSampleSize() | AP4_AudioSampleEntry | [inline]
GetSize() const | AP4_Atom | [inline]
GetSize32() const | AP4_Atom | [inline]
GetSize64() const | AP4_Atom | [inline]
GetType() const | AP4_Atom | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_SampleEntry | [virtual]
InspectChildren(AP4_AtomInspector &inspector) | AP4_ContainerAtom | [virtual]
InspectFields(AP4_AtomInspector &inspector) | AP4_AudioSampleEntry | [protected, virtual]
InspectHeader(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
m_ChannelCount | AP4_AudioSampleEntry | [protected]
m_Children | AP4_AtomParent | [protected]
m_DataReferenceIndex | AP4_SampleEntry | [protected]
m_Flags | AP4_Atom | [protected]
m_IsFull | AP4_Atom | [protected]
m_Parent | AP4_Atom | [protected]
m_QtCompressionId | AP4_AudioSampleEntry | [protected]
m_QtPacketSize | AP4_AudioSampleEntry | [protected]
m_QtRevision | AP4_AudioSampleEntry | [protected]
m_QtV1BytesPerFrame | AP4_AudioSampleEntry | [protected]
m_QtV1BytesPerPacket | AP4_AudioSampleEntry | [protected]
m_QtV1BytesPerSample | AP4_AudioSampleEntry | [protected]
m_QtV1SamplesPerPacket | AP4_AudioSampleEntry | [protected]
m_QtV2BitsPerChannel | AP4_AudioSampleEntry | [protected]
m_QtV2BytesPerAudioPacket | AP4_AudioSampleEntry | [protected]
m_QtV2ChannelCount | AP4_AudioSampleEntry | [protected]
m_QtV2Extension | AP4_AudioSampleEntry | [protected]
m_QtV2FormatSpecificFlags | AP4_AudioSampleEntry | [protected]
m_QtV2LPCMFramesPerAudioPacket | AP4_AudioSampleEntry | [protected]
m_QtV2Reserved | AP4_AudioSampleEntry | [protected]
m_QtV2SampleRate64 | AP4_AudioSampleEntry | [protected]
m_QtV2StructSize | AP4_AudioSampleEntry | [protected]
m_QtVendor | AP4_AudioSampleEntry | [protected]
m_QtVersion | AP4_AudioSampleEntry | [protected]
m_Reserved1 | AP4_SampleEntry | [protected]
m_SampleRate | AP4_AudioSampleEntry | [protected]
m_SampleSize | AP4_AudioSampleEntry | [protected]
m_Size32 | AP4_Atom | [protected]
m_Size64 | AP4_Atom | [protected]
m_Type | AP4_Atom | [protected]
m_Version | AP4_Atom | [protected]
OnChildAdded(AP4_Atom *child) | AP4_ContainerAtom | [virtual]
OnChildChanged(AP4_Atom *child) | AP4_SampleEntry | [virtual]
OnChildRemoved(AP4_Atom *child) | AP4_ContainerAtom | [virtual]
Read(AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_SampleEntry | [protected, virtual]
ReadChildren(AP4_AtomFactory &atom_factory, AP4_ByteStream &stream, AP4_UI64 size) | AP4_ContainerAtom | [protected]
ReadFields(AP4_ByteStream &stream) | AP4_AudioSampleEntry | [protected, virtual]
ReadFullHeader(AP4_ByteStream &stream, AP4_UI32 &version, AP4_UI32 &flags) | AP4_Atom | [static]
RemoveChild(AP4_Atom *child) | AP4_AtomParent | [virtual]
SetFlags(AP4_UI32 flags) | AP4_Atom | [inline]
SetParent(AP4_AtomParent *parent) | AP4_Atom | [inline, virtual]
SetSize(AP4_UI64 size, bool force_64=false) | AP4_Atom |
SetSize32(AP4_UI32 size) | AP4_Atom | [inline]
SetSize64(AP4_UI64 size) | AP4_Atom | [inline]
SetType(Type type) | AP4_Atom | [inline]
ToSampleDescription() | AP4_EncaSampleEntry | [virtual]
ToTargetSampleDescription(AP4_UI32 format) | AP4_EncaSampleEntry | [virtual]
Type typedef | AP4_Atom |
TypeFromString(const char *four_cc) | AP4_Atom | [static]
Write(AP4_ByteStream &stream) | AP4_SampleEntry | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_AudioSampleEntry | [protected, virtual]
WriteHeader(AP4_ByteStream &stream) | AP4_Atom | [virtual]
~AP4_Atom() | AP4_Atom | [inline, virtual]
~AP4_AtomParent() | AP4_AtomParent | [virtual]
~AP4_SampleEntry() | AP4_SampleEntry | [inline, virtual]
Generated on Thu May 13 16:36:56 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_EncryptingStream Class Reference

AP4_EncryptingStream Class Reference

#include <Ap4Protection.h>

Inheritance diagram for AP4_EncryptingStream:
AP4_ByteStream AP4_Referenceable

List of all members.

Public Types

enum CipherMode {
CIPHER_MODE_CTR,
CIPHER_MODE_CBC
}

Public Member Functions

virtual AP4_Result | ReadPartial (void *buffer, AP4_Size bytes_to_read, AP4_Size &bytes_read)
virtual AP4_Result | WritePartial (const void *buffer, AP4_Size bytes_to_write, AP4_Size &bytes_written)
virtual AP4_Result | Seek (AP4_Position position)
virtual AP4_Result | Tell (AP4_Position &position)
virtual AP4_Result | GetSize (AP4_LargeSize &size)
virtual void | AddReference ()
virtual void | Release ()

Static Public Member Functions

static AP4_Result | Create (CipherMode mode, AP4_ByteStream &cleartext_stream, const AP4_UI08 *iv, AP4_Size iv_size, const AP4_UI08 *key, AP4_Size key_size, bool prepend_iv, AP4_BlockCipherFactory *block_cipher_factory, AP4_ByteStream *&stream)

Detailed Description

Definition at line 428 of file Ap4Protection.h.

Member Enumeration Documentation

enum AP4_EncryptingStream::CipherMode
Enumerator:
CIPHER_MODE_CTR
CIPHER_MODE_CBC

Definition at line 431 of file Ap4Protection.h.

Member Function Documentation

virtual void AP4_EncryptingStream::AddReference ( ) [virtual]

Implements AP4_Referenceable.

static AP4_Result AP4_EncryptingStream::Create | ( | CipherMode | mode,
 |  | AP4_ByteStream & | cleartext_stream,
 |  | const AP4_UI08 * | iv,
 |  | AP4_Size | iv_size,
 |  | const AP4_UI08 * | key,
 |  | AP4_Size | key_size,
 |  | bool | prepend_iv,
 |  | AP4_BlockCipherFactory * | block_cipher_factory,
 |  | AP4_ByteStream *& | stream |
 | ) |  |  | [static]
virtual AP4_Result AP4_EncryptingStream::GetSize ( AP4_LargeSize & size ) [virtual]

Implements AP4_ByteStream.

virtual AP4_Result AP4_EncryptingStream::ReadPartial | ( | void * | buffer,
 |  | AP4_Size | bytes_to_read,
 |  | AP4_Size & | bytes_read |
 | ) |  |  | [virtual]

Implements AP4_ByteStream.

virtual void AP4_EncryptingStream::Release ( ) [virtual]

Implements AP4_Referenceable.

virtual AP4_Result AP4_EncryptingStream::Seek ( AP4_Position position ) [virtual]

Implements AP4_ByteStream.

virtual AP4_Result AP4_EncryptingStream::Tell ( AP4_Position & position ) [virtual]

Implements AP4_ByteStream.

virtual AP4_Result AP4_EncryptingStream::WritePartial | ( | const void * | buffer,
 |  | AP4_Size | bytes_to_write,
 |  | AP4_Size & | bytes_written |
 | ) |  |  | [virtual]

Implements AP4_ByteStream.

The documentation for this class was generated from the following file:
  • Ap4Protection.h
Generated on Thu May 13 16:36:56 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_EncryptingStream Member List

This is the complete list of members for AP4_EncryptingStream, including all inherited members.
AddReference() | AP4_EncryptingStream | [virtual]
CIPHER_MODE_CBC enum value | AP4_EncryptingStream |
CIPHER_MODE_CTR enum value | AP4_EncryptingStream |
CipherMode enum name | AP4_EncryptingStream |
CopyTo(AP4_ByteStream &stream, AP4_LargeSize size) | AP4_ByteStream | [virtual]
Create(CipherMode mode, AP4_ByteStream &cleartext_stream, const AP4_UI08 *iv, AP4_Size iv_size, const AP4_UI08 *key, AP4_Size key_size, bool prepend_iv, AP4_BlockCipherFactory *block_cipher_factory, AP4_ByteStream *&stream) | AP4_EncryptingStream | [static]
Flush() | AP4_ByteStream | [inline, virtual]
GetSize(AP4_LargeSize &size) | AP4_EncryptingStream | [virtual]
Read(void *buffer, AP4_Size bytes_to_read) | AP4_ByteStream |
ReadDouble(double &value) | AP4_ByteStream |
ReadPartial(void *buffer, AP4_Size bytes_to_read, AP4_Size &bytes_read) | AP4_EncryptingStream | [virtual]
ReadString(char *buffer, AP4_Size size) | AP4_ByteStream |
ReadUI08(AP4_UI08 &value) | AP4_ByteStream |
ReadUI16(AP4_UI16 &value) | AP4_ByteStream |
ReadUI24(AP4_UI32 &value) | AP4_ByteStream |
ReadUI32(AP4_UI32 &value) | AP4_ByteStream |
ReadUI64(AP4_UI64 &value) | AP4_ByteStream |
Release() | AP4_EncryptingStream | [virtual]
Seek(AP4_Position position) | AP4_EncryptingStream | [virtual]
Tell(AP4_Position &position) | AP4_EncryptingStream | [virtual]
Write(const void *buffer, AP4_Size bytes_to_write) | AP4_ByteStream |
WriteDouble(double value) | AP4_ByteStream |
WritePartial(const void *buffer, AP4_Size bytes_to_write, AP4_Size &bytes_written) | AP4_EncryptingStream | [virtual]
WriteString(const char *string_buffer) | AP4_ByteStream |
WriteUI08(AP4_UI08 value) | AP4_ByteStream |
WriteUI16(AP4_UI16 value) | AP4_ByteStream |
WriteUI24(AP4_UI32 value) | AP4_ByteStream |
WriteUI32(AP4_UI32 value) | AP4_ByteStream |
WriteUI64(AP4_UI64 value) | AP4_ByteStream |
~AP4_Referenceable() | AP4_Referenceable | [inline, virtual]
Generated on Thu May 13 16:36:56 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_EncvSampleEntry Class Reference

AP4_EncvSampleEntry Class Reference

#include <Ap4Protection.h>

Inheritance diagram for AP4_EncvSampleEntry:
AP4_VisualSampleEntry AP4_SampleEntry AP4_ContainerAtom AP4_Atom AP4_AtomParent AP4_DrmiSampleEntry

List of all members.

Public Member Functions

AP4_EncvSampleEntry (AP4_Size size, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory)
AP4_EncvSampleEntry (AP4_UI32 type, AP4_Size size, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory)
AP4_SampleDescription * ToSampleDescription ()
virtual AP4_SampleDescription * ToTargetSampleDescription (AP4_UI32 format)

Detailed Description

Definition at line 83 of file Ap4Protection.h.

Constructor & Destructor Documentation

AP4_EncvSampleEntry::AP4_EncvSampleEntry | ( | AP4_Size | size,
 |  | AP4_ByteStream & | stream,
 |  | AP4_AtomFactory & | atom_factory
 | ) |  |
AP4_EncvSampleEntry::AP4_EncvSampleEntry | ( | AP4_UI32 | type,
 |  | AP4_Size | size,
 |  | AP4_ByteStream & | stream,
 |  | AP4_AtomFactory & | atom_factory
 | ) |  |

Member Function Documentation

AP4_SampleDescription* AP4_EncvSampleEntry::ToSampleDescription ( ) [virtual]

Reimplemented from AP4_VisualSampleEntry.

virtual AP4_SampleDescription* AP4_EncvSampleEntry::ToTargetSampleDescription ( AP4_UI32 format ) [virtual]
The documentation for this class was generated from the following file:
  • Ap4Protection.h
Generated on Thu May 13 16:36:56 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_EncvSampleEntry Member List

This is the complete list of members for AP4_EncvSampleEntry, including all inherited members.
AddChild(AP4_Atom *child, int position=-1) | AP4_AtomParent | [virtual]
AP4_Atom(Type type, AP4_UI32 size=AP4_ATOM_HEADER_SIZE) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64=false) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_ContainerAtom(Type type) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI32 version, AP4_UI32 flags) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_ContainerAtom | [protected]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_ContainerAtom | [protected]
AP4_EncvSampleEntry(AP4_Size size, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_EncvSampleEntry |
AP4_EncvSampleEntry(AP4_UI32 type, AP4_Size size, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_EncvSampleEntry |
AP4_SampleEntry(AP4_Atom::Type format, AP4_UI16 data_ref_index=1) | AP4_SampleEntry |
AP4_SampleEntry(AP4_Atom::Type format, AP4_Size size, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_SampleEntry |
AP4_SampleEntry(AP4_Atom::Type format, AP4_Size size) | AP4_SampleEntry | [protected]
AP4_VisualSampleEntry(AP4_Atom::Type format, AP4_UI16 width, AP4_UI16 height, AP4_UI16 depth, const char *compressor_name) | AP4_VisualSampleEntry |
AP4_VisualSampleEntry(AP4_Atom::Type format, AP4_Size size, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_VisualSampleEntry |
Clone() | AP4_ContainerAtom | [virtual]
Create(Type type, AP4_UI64 size, bool is_full, bool force_64, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_ContainerAtom | [static]
DeleteChild(AP4_Atom::Type type, AP4_Ordinal index=0) | AP4_AtomParent | [virtual]
Detach() | AP4_Atom | [virtual]
FindChild(const char *path, bool auto_create=false, bool auto_create_full=false) | AP4_AtomParent | [virtual]
GetChild(AP4_Atom::Type type, AP4_Ordinal index=0) const | AP4_AtomParent | [virtual]
GetChild(const AP4_UI08 *uuid, AP4_Ordinal index=0) const | AP4_AtomParent | [virtual]
GetChildren() | AP4_ContainerAtom | [inline]
GetCompressorName() | AP4_VisualSampleEntry | [inline]
GetDataReferenceIndex() | AP4_SampleEntry | [inline]
GetDepth() | AP4_VisualSampleEntry | [inline]
GetFieldsSize() | AP4_VisualSampleEntry | [protected, virtual]
GetFlags() const | AP4_Atom | [inline]
GetHeaderSize() const | AP4_Atom | [virtual]
GetHeight() | AP4_VisualSampleEntry | [inline]
GetHorizResolution() | AP4_VisualSampleEntry | [inline]
GetParent() | AP4_Atom | [inline, virtual]
GetSize() const | AP4_Atom | [inline]
GetSize32() const | AP4_Atom | [inline]
GetSize64() const | AP4_Atom | [inline]
GetType() const | AP4_Atom | [inline]
GetVertResolution() | AP4_VisualSampleEntry | [inline]
GetWidth() | AP4_VisualSampleEntry | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_SampleEntry | [virtual]
InspectChildren(AP4_AtomInspector &inspector) | AP4_ContainerAtom | [virtual]
InspectFields(AP4_AtomInspector &inspector) | AP4_VisualSampleEntry | [protected, virtual]
InspectHeader(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
m_Children | AP4_AtomParent | [protected]
m_CompressorName | AP4_VisualSampleEntry | [protected]
m_DataReferenceIndex | AP4_SampleEntry | [protected]
m_Depth | AP4_VisualSampleEntry | [protected]
m_Flags | AP4_Atom | [protected]
m_FrameCount | AP4_VisualSampleEntry | [protected]
m_Height | AP4_VisualSampleEntry | [protected]
m_HorizResolution | AP4_VisualSampleEntry | [protected]
m_IsFull | AP4_Atom | [protected]
m_Parent | AP4_Atom | [protected]
m_Predefined1 | AP4_VisualSampleEntry | [protected]
m_Predefined2 | AP4_VisualSampleEntry | [protected]
m_Predefined3 | AP4_VisualSampleEntry | [protected]
m_Reserved1 | AP4_SampleEntry | [protected]
m_Reserved2 | AP4_VisualSampleEntry | [protected]
m_Reserved3 | AP4_VisualSampleEntry | [protected]
m_Size32 | AP4_Atom | [protected]
m_Size64 | AP4_Atom | [protected]
m_Type | AP4_Atom | [protected]
m_Version | AP4_Atom | [protected]
m_VertResolution | AP4_VisualSampleEntry | [protected]
m_Width | AP4_VisualSampleEntry | [protected]
OnChildAdded(AP4_Atom *child) | AP4_ContainerAtom | [virtual]
OnChildChanged(AP4_Atom *child) | AP4_SampleEntry | [virtual]
OnChildRemoved(AP4_Atom *child) | AP4_ContainerAtom | [virtual]
Read(AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_SampleEntry | [protected, virtual]
ReadChildren(AP4_AtomFactory &atom_factory, AP4_ByteStream &stream, AP4_UI64 size) | AP4_ContainerAtom | [protected]
ReadFields(AP4_ByteStream &stream) | AP4_VisualSampleEntry | [protected, virtual]
ReadFullHeader(AP4_ByteStream &stream, AP4_UI32 &version, AP4_UI32 &flags) | AP4_Atom | [static]
RemoveChild(AP4_Atom *child) | AP4_AtomParent | [virtual]
SetFlags(AP4_UI32 flags) | AP4_Atom | [inline]
SetParent(AP4_AtomParent *parent) | AP4_Atom | [inline, virtual]
SetSize(AP4_UI64 size, bool force_64=false) | AP4_Atom |
SetSize32(AP4_UI32 size) | AP4_Atom | [inline]
SetSize64(AP4_UI64 size) | AP4_Atom | [inline]
SetType(Type type) | AP4_Atom | [inline]
ToSampleDescription() | AP4_EncvSampleEntry | [virtual]
ToTargetSampleDescription(AP4_UI32 format) | AP4_EncvSampleEntry | [virtual]
Type typedef | AP4_Atom |
TypeFromString(const char *four_cc) | AP4_Atom | [static]
Write(AP4_ByteStream &stream) | AP4_SampleEntry | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_VisualSampleEntry | [protected, virtual]
WriteHeader(AP4_ByteStream &stream) | AP4_Atom | [virtual]
~AP4_Atom() | AP4_Atom | [inline, virtual]
~AP4_AtomParent() | AP4_AtomParent | [virtual]
~AP4_SampleEntry() | AP4_SampleEntry | [inline, virtual]
Generated on Thu May 13 16:36:56 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_EsDescriptor Class Reference

AP4_EsDescriptor Class Reference

#include <Ap4EsDescriptor.h>

Inheritance diagram for AP4_EsDescriptor:
AP4_Descriptor AP4_Expandable

List of all members.

Public Member Functions

AP4_EsDescriptor (AP4_UI16 es_id)
AP4_EsDescriptor (AP4_ByteStream &stream, AP4_Size header_size, AP4_Size payload_size)
~AP4_EsDescriptor ()
virtual AP4_Result | AddSubDescriptor (AP4_Descriptor *descriptor)
virtual AP4_Result | WriteFields (AP4_ByteStream &stream)
virtual AP4_Result | Inspect (AP4_AtomInspector &inspector)
virtual const
AP4_DecoderConfigDescriptor * 		GetDecoderConfigDescriptor () const

Detailed Description

Definition at line 59 of file Ap4EsDescriptor.h.

Constructor & Destructor Documentation

AP4_EsDescriptor::AP4_EsDescriptor ( AP4_UI16 es_id )
AP4_EsDescriptor::AP4_EsDescriptor | ( | AP4_ByteStream & | stream,
 |  | AP4_Size | header_size,
 |  | AP4_Size | payload_size
 | ) |  |
AP4_EsDescriptor::~AP4_EsDescriptor ( )

Member Function Documentation

virtual AP4_Result AP4_EsDescriptor::AddSubDescriptor ( AP4_Descriptor * descriptor ) [virtual]
virtual const AP4_DecoderConfigDescriptor* AP4_EsDescriptor::GetDecoderConfigDescriptor ( ) const [virtual]
virtual AP4_Result AP4_EsDescriptor::Inspect ( AP4_AtomInspector & inspector ) [virtual]

Reimplemented from AP4_Descriptor.

virtual AP4_Result AP4_EsDescriptor::WriteFields ( AP4_ByteStream & stream ) [virtual]

Implements AP4_Expandable.

The documentation for this class was generated from the following file:
  • Ap4EsDescriptor.h
Generated on Thu May 13 16:36:56 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_EsDescriptor Member List

This is the complete list of members for AP4_EsDescriptor, including all inherited members.
AddSubDescriptor(AP4_Descriptor *descriptor) | AP4_EsDescriptor | [virtual]
AP4_Descriptor(AP4_UI08 tag, AP4_Size header_size, AP4_Size payload_size) | AP4_Descriptor | [inline]
AP4_EsDescriptor(AP4_UI16 es_id) | AP4_EsDescriptor |
AP4_EsDescriptor(AP4_ByteStream &stream, AP4_Size header_size, AP4_Size payload_size) | AP4_EsDescriptor |
AP4_Expandable(AP4_UI32 class_id, ClassIdSize class_id_size, AP4_Size header_size, AP4_Size payload_size) | AP4_Expandable |
CLASS_ID_SIZE_08 enum value | AP4_Expandable |
ClassIdSize enum name | AP4_Expandable |
GetClassId() | AP4_Expandable | [inline]
GetDecoderConfigDescriptor() const | AP4_EsDescriptor | [virtual]
GetHeaderSize() | AP4_Expandable | [inline]
GetSize() | AP4_Expandable | [inline]
GetTag() | AP4_Descriptor | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_EsDescriptor | [virtual]
m_ClassId | AP4_Expandable | [protected]
m_ClassIdSize | AP4_Expandable | [protected]
m_HeaderSize | AP4_Expandable | [protected]
m_PayloadSize | AP4_Expandable | [protected]
MinHeaderSize(AP4_Size payload_size) | AP4_Expandable | [static]
Write(AP4_ByteStream &stream) | AP4_Expandable | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_EsDescriptor | [virtual]
~AP4_EsDescriptor() | AP4_EsDescriptor |
~AP4_Expandable() | AP4_Expandable | [inline, virtual]
Generated on Thu May 13 16:36:56 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_EsdsAtom Class Reference

AP4_EsdsAtom Class Reference

#include <Ap4EsdsAtom.h>

Inheritance diagram for AP4_EsdsAtom:
AP4_Atom

List of all members.

Public Member Functions

AP4_EsdsAtom (AP4_EsDescriptor *descriptor)
~AP4_EsdsAtom ()
virtual AP4_Result | WriteFields (AP4_ByteStream &stream)
virtual AP4_Result | InspectFields (AP4_AtomInspector &inspector)
const AP4_EsDescriptor * | GetEsDescriptor () const

Static Public Member Functions

static AP4_EsdsAtom * | Create (AP4_Size size, AP4_ByteStream &stream)

Detailed Description

Definition at line 47 of file Ap4EsdsAtom.h.

Constructor & Destructor Documentation

AP4_EsdsAtom::AP4_EsdsAtom ( AP4_EsDescriptor * descriptor )
AP4_EsdsAtom::~AP4_EsdsAtom ( )

Member Function Documentation

static AP4_EsdsAtom* AP4_EsdsAtom::Create | ( | AP4_Size | size,
 |  | AP4_ByteStream & | stream |
 | ) |  |  | [static]
const AP4_EsDescriptor* AP4_EsdsAtom::GetEsDescriptor ( ) const [inline]

Definition at line 60 of file Ap4EsdsAtom.h.

virtual AP4_Result AP4_EsdsAtom::InspectFields ( AP4_AtomInspector & inspector ) [virtual]

Reimplemented from AP4_Atom.

virtual AP4_Result AP4_EsdsAtom::WriteFields ( AP4_ByteStream & stream ) [virtual]

Implements AP4_Atom.

The documentation for this class was generated from the following file:
  • Ap4EsdsAtom.h
Generated on Thu May 13 16:36:57 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_EsdsAtom Member List

This is the complete list of members for AP4_EsdsAtom, including all inherited members.
AP4_Atom(Type type, AP4_UI32 size=AP4_ATOM_HEADER_SIZE) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64=false) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_EsdsAtom(AP4_EsDescriptor *descriptor) | AP4_EsdsAtom |
Clone() | AP4_Atom | [virtual]
Create(AP4_Size size, AP4_ByteStream &stream) | AP4_EsdsAtom | [static]
Detach() | AP4_Atom | [virtual]
GetEsDescriptor() const | AP4_EsdsAtom | [inline]
GetFlags() const | AP4_Atom | [inline]
GetHeaderSize() const | AP4_Atom | [virtual]
GetParent() | AP4_Atom | [inline, virtual]
GetSize() const | AP4_Atom | [inline]
GetSize32() const | AP4_Atom | [inline]
GetSize64() const | AP4_Atom | [inline]
GetType() const | AP4_Atom | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
InspectFields(AP4_AtomInspector &inspector) | AP4_EsdsAtom | [virtual]
InspectHeader(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
m_Flags | AP4_Atom | [protected]
m_IsFull | AP4_Atom | [protected]
m_Parent | AP4_Atom | [protected]
m_Size32 | AP4_Atom | [protected]
m_Size64 | AP4_Atom | [protected]
m_Type | AP4_Atom | [protected]
m_Version | AP4_Atom | [protected]
ReadFullHeader(AP4_ByteStream &stream, AP4_UI32 &version, AP4_UI32 &flags) | AP4_Atom | [static]
SetFlags(AP4_UI32 flags) | AP4_Atom | [inline]
SetParent(AP4_AtomParent *parent) | AP4_Atom | [inline, virtual]
SetSize(AP4_UI64 size, bool force_64=false) | AP4_Atom |
SetSize32(AP4_UI32 size) | AP4_Atom | [inline]
SetSize64(AP4_UI64 size) | AP4_Atom | [inline]
SetType(Type type) | AP4_Atom | [inline]
Type typedef | AP4_Atom |
TypeFromString(const char *four_cc) | AP4_Atom | [static]
Write(AP4_ByteStream &stream) | AP4_Atom | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_EsdsAtom | [virtual]
WriteHeader(AP4_ByteStream &stream) | AP4_Atom | [virtual]
~AP4_Atom() | AP4_Atom | [inline, virtual]
~AP4_EsdsAtom() | AP4_EsdsAtom |
Generated on Thu May 13 16:36:57 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_EsIdIncDescriptor Class Reference

AP4_EsIdIncDescriptor Class Reference

#include <Ap4EsDescriptor.h>

Inheritance diagram for AP4_EsIdIncDescriptor:
AP4_Descriptor AP4_Expandable

List of all members.

Public Member Functions

AP4_EsIdIncDescriptor (AP4_UI32 track_id)
AP4_EsIdIncDescriptor (AP4_ByteStream &stream, AP4_Size header_size, AP4_Size payload_size)
virtual AP4_Result | WriteFields (AP4_ByteStream &stream)
virtual AP4_Result | Inspect (AP4_AtomInspector &inspector)
AP4_UI32 | GetTrackId () const

Detailed Description

Definition at line 89 of file Ap4EsDescriptor.h.

Constructor & Destructor Documentation

AP4_EsIdIncDescriptor::AP4_EsIdIncDescriptor ( AP4_UI32 track_id )
AP4_EsIdIncDescriptor::AP4_EsIdIncDescriptor | ( | AP4_ByteStream & | stream,
 |  | AP4_Size | header_size,
 |  | AP4_Size | payload_size
 | ) |  |

Member Function Documentation

AP4_UI32 AP4_EsIdIncDescriptor::GetTrackId ( ) const [inline]

Definition at line 103 of file Ap4EsDescriptor.h.

virtual AP4_Result AP4_EsIdIncDescriptor::Inspect ( AP4_AtomInspector & inspector ) [virtual]

Reimplemented from AP4_Descriptor.

virtual AP4_Result AP4_EsIdIncDescriptor::WriteFields ( AP4_ByteStream & stream ) [virtual]

Implements AP4_Expandable.

The documentation for this class was generated from the following file:
  • Ap4EsDescriptor.h
Generated on Thu May 13 16:36:57 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_EsIdIncDescriptor Member List

This is the complete list of members for AP4_EsIdIncDescriptor, including all inherited members.
AP4_Descriptor(AP4_UI08 tag, AP4_Size header_size, AP4_Size payload_size) | AP4_Descriptor | [inline]
AP4_EsIdIncDescriptor(AP4_UI32 track_id) | AP4_EsIdIncDescriptor |
AP4_EsIdIncDescriptor(AP4_ByteStream &stream, AP4_Size header_size, AP4_Size payload_size) | AP4_EsIdIncDescriptor |
AP4_Expandable(AP4_UI32 class_id, ClassIdSize class_id_size, AP4_Size header_size, AP4_Size payload_size) | AP4_Expandable |
CLASS_ID_SIZE_08 enum value | AP4_Expandable |
ClassIdSize enum name | AP4_Expandable |
GetClassId() | AP4_Expandable | [inline]
GetHeaderSize() | AP4_Expandable | [inline]
GetSize() | AP4_Expandable | [inline]
GetTag() | AP4_Descriptor | [inline]
GetTrackId() const | AP4_EsIdIncDescriptor | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_EsIdIncDescriptor | [virtual]
m_ClassId | AP4_Expandable | [protected]
m_ClassIdSize | AP4_Expandable | [protected]
m_HeaderSize | AP4_Expandable | [protected]
m_PayloadSize | AP4_Expandable | [protected]
MinHeaderSize(AP4_Size payload_size) | AP4_Expandable | [static]
Write(AP4_ByteStream &stream) | AP4_Expandable | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_EsIdIncDescriptor | [virtual]
~AP4_Expandable() | AP4_Expandable | [inline, virtual]
Generated on Thu May 13 16:36:57 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_EsIdRefDescriptor Class Reference

AP4_EsIdRefDescriptor Class Reference

#include <Ap4EsDescriptor.h>

Inheritance diagram for AP4_EsIdRefDescriptor:
AP4_Descriptor AP4_Expandable

List of all members.

Public Member Functions

AP4_EsIdRefDescriptor (AP4_UI16 ref_index)
AP4_EsIdRefDescriptor (AP4_ByteStream &stream, AP4_Size header_size, AP4_Size payload_size)
virtual AP4_Result | WriteFields (AP4_ByteStream &stream)
virtual AP4_Result | Inspect (AP4_AtomInspector &inspector)
AP4_UI16 | GetRefIndex () const

Detailed Description

Definition at line 113 of file Ap4EsDescriptor.h.

Constructor & Destructor Documentation

AP4_EsIdRefDescriptor::AP4_EsIdRefDescriptor ( AP4_UI16 ref_index )
AP4_EsIdRefDescriptor::AP4_EsIdRefDescriptor | ( | AP4_ByteStream & | stream,
 |  | AP4_Size | header_size,
 |  | AP4_Size | payload_size
 | ) |  |

Member Function Documentation

AP4_UI16 AP4_EsIdRefDescriptor::GetRefIndex ( ) const [inline]

Definition at line 127 of file Ap4EsDescriptor.h.

virtual AP4_Result AP4_EsIdRefDescriptor::Inspect ( AP4_AtomInspector & inspector ) [virtual]

Reimplemented from AP4_Descriptor.

virtual AP4_Result AP4_EsIdRefDescriptor::WriteFields ( AP4_ByteStream & stream ) [virtual]

Implements AP4_Expandable.

The documentation for this class was generated from the following file:
  • Ap4EsDescriptor.h
Generated on Thu May 13 16:37:17 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_EsIdRefDescriptor Member List

This is the complete list of members for AP4_EsIdRefDescriptor, including all inherited members.
AP4_Descriptor(AP4_UI08 tag, AP4_Size header_size, AP4_Size payload_size) | AP4_Descriptor | [inline]
AP4_EsIdRefDescriptor(AP4_UI16 ref_index) | AP4_EsIdRefDescriptor |
AP4_EsIdRefDescriptor(AP4_ByteStream &stream, AP4_Size header_size, AP4_Size payload_size) | AP4_EsIdRefDescriptor |
AP4_Expandable(AP4_UI32 class_id, ClassIdSize class_id_size, AP4_Size header_size, AP4_Size payload_size) | AP4_Expandable |
CLASS_ID_SIZE_08 enum value | AP4_Expandable |
ClassIdSize enum name | AP4_Expandable |
GetClassId() | AP4_Expandable | [inline]
GetHeaderSize() | AP4_Expandable | [inline]
GetRefIndex() const | AP4_EsIdRefDescriptor | [inline]
GetSize() | AP4_Expandable | [inline]
GetTag() | AP4_Descriptor | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_EsIdRefDescriptor | [virtual]
m_ClassId | AP4_Expandable | [protected]
m_ClassIdSize | AP4_Expandable | [protected]
m_HeaderSize | AP4_Expandable | [protected]
m_PayloadSize | AP4_Expandable | [protected]
MinHeaderSize(AP4_Size payload_size) | AP4_Expandable | [static]
Write(AP4_ByteStream &stream) | AP4_Expandable | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_EsIdRefDescriptor | [virtual]
~AP4_Expandable() | AP4_Expandable | [inline, virtual]
Generated on Thu May 13 16:37:17 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_Exception Class Reference

AP4_Exception Class Reference

#include <Ap4Interfaces.h>

List of all members.

Public Member Functions

AP4_Exception (AP4_Result error)

Public Attributes

AP4_Result m_Error

Detailed Description

Definition at line 47 of file Ap4Interfaces.h.

Constructor & Destructor Documentation

AP4_Exception::AP4_Exception ( AP4_Result error ) [inline]

Definition at line 51 of file Ap4Interfaces.h.

Member Data Documentation

AP4_Result AP4_Exception::m_Error

Definition at line 54 of file Ap4Interfaces.h.

The documentation for this class was generated from the following file:
  • Ap4Interfaces.h
Generated on Thu May 13 16:37:17 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_Exception Member List

This is the complete list of members for AP4_Exception, including all inherited members.
AP4_Exception(AP4_Result error) | AP4_Exception | [inline]
m_Error | AP4_Exception |
Generated on Thu May 13 16:37:17 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_Expandable Class Reference

AP4_Expandable Class Reference

#include <Ap4Expandable.h>

Inheritance diagram for AP4_Expandable:
AP4_Command AP4_Descriptor AP4_UnknownExpandable AP4_DescriptorUpdateCommand AP4_UnknownCommand AP4_DecoderConfigDescriptor AP4_DecoderSpecificInfoDescriptor AP4_EsDescriptor AP4_EsIdIncDescriptor AP4_EsIdRefDescriptor AP4_IpmpDescriptor AP4_IpmpDescriptorPointer AP4_ObjectDescriptor AP4_SLConfigDescriptor AP4_UnknownDescriptor

List of all members.

Public Types

enum | ClassIdSize { CLASS_ID_SIZE_08 }

Public Member Functions

AP4_Expandable (AP4_UI32 class_id, ClassIdSize class_id_size, AP4_Size header_size, AP4_Size payload_size)
virtual | ~AP4_Expandable ()
AP4_UI32 GetClassId ()
AP4_Size GetSize ()
AP4_Size GetHeaderSize ()
virtual AP4_Result | Write (AP4_ByteStream &stream)
virtual AP4_Result | WriteFields (AP4_ByteStream &stream)=0
virtual AP4_Result | Inspect (AP4_AtomInspector &inspector)

Static Public Member Functions

static AP4_Size | MinHeaderSize (AP4_Size payload_size)

Protected Attributes

AP4_UI32 m_ClassId
ClassIdSize m_ClassIdSize
AP4_Size m_HeaderSize
AP4_Size m_PayloadSize

Detailed Description

Definition at line 47 of file Ap4Expandable.h.

Member Enumeration Documentation

enum AP4_Expandable::ClassIdSize
Enumerator:
CLASS_ID_SIZE_08

Definition at line 51 of file Ap4Expandable.h.

Constructor & Destructor Documentation

AP4_Expandable::AP4_Expandable | ( | AP4_UI32 | class_id,
 |  | ClassIdSize | class_id_size,
 |  | AP4_Size | header_size,
 |  | AP4_Size | payload_size
 | ) |  |
virtual AP4_Expandable::~AP4_Expandable ( ) [inline, virtual]

Definition at line 63 of file Ap4Expandable.h.

Member Function Documentation

AP4_UI32 AP4_Expandable::GetClassId ( ) [inline]

Definition at line 64 of file Ap4Expandable.h.

References m_ClassId.

AP4_Size AP4_Expandable::GetHeaderSize ( ) [inline]

Definition at line 66 of file Ap4Expandable.h.

References m_HeaderSize.

AP4_Size AP4_Expandable::GetSize ( ) [inline]

Definition at line 65 of file Ap4Expandable.h.

References m_HeaderSize, and m_PayloadSize.

virtual AP4_Result AP4_Expandable::Inspect ( AP4_AtomInspector & inspector ) [virtual]

Reimplemented in AP4_Command, AP4_DecoderConfigDescriptor, AP4_DecoderSpecificInfoDescriptor, AP4_Descriptor, AP4_EsDescriptor, AP4_EsIdIncDescriptor, AP4_EsIdRefDescriptor, AP4_IpmpDescriptorPointer, AP4_IpmpDescriptor, AP4_ObjectDescriptor, AP4_InitialObjectDescriptor, and AP4_DescriptorUpdateCommand.

static AP4_Size AP4_Expandable::MinHeaderSize ( AP4_Size payload_size ) [static]
virtual AP4_Result AP4_Expandable::Write ( AP4_ByteStream & stream ) [virtual]

Referenced by AP4_DescriptorListWriter::Action().

virtual AP4_Result AP4_Expandable::WriteFields ( AP4_ByteStream & stream ) [pure virtual]

Implemented in AP4_UnknownCommand, AP4_DecoderConfigDescriptor, AP4_DecoderSpecificInfoDescriptor, AP4_UnknownDescriptor, AP4_EsDescriptor, AP4_EsIdIncDescriptor, AP4_EsIdRefDescriptor, AP4_UnknownExpandable, AP4_IpmpDescriptorPointer, AP4_IpmpDescriptor, AP4_ObjectDescriptor, AP4_InitialObjectDescriptor, AP4_DescriptorUpdateCommand, and AP4_SLConfigDescriptor.

Member Data Documentation

AP4_UI32 AP4_Expandable::m_ClassId [protected]

Definition at line 73 of file Ap4Expandable.h.

Referenced by GetClassId(), AP4_Descriptor::GetTag(), and AP4_Command::GetTag().

ClassIdSize AP4_Expandable::m_ClassIdSize [protected]

Definition at line 74 of file Ap4Expandable.h.

AP4_Size AP4_Expandable::m_HeaderSize [protected]

Definition at line 75 of file Ap4Expandable.h.

Referenced by GetHeaderSize(), and GetSize().

AP4_Size AP4_Expandable::m_PayloadSize [protected]

Definition at line 76 of file Ap4Expandable.h.

Referenced by GetSize().

The documentation for this class was generated from the following file:
  • Ap4Expandable.h
Generated on Thu May 13 16:37:18 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_Expandable Member List

This is the complete list of members for AP4_Expandable, including all inherited members.
AP4_Expandable(AP4_UI32 class_id, ClassIdSize class_id_size, AP4_Size header_size, AP4_Size payload_size) | AP4_Expandable |
CLASS_ID_SIZE_08 enum value | AP4_Expandable |
ClassIdSize enum name | AP4_Expandable |
GetClassId() | AP4_Expandable | [inline]
GetHeaderSize() | AP4_Expandable | [inline]
GetSize() | AP4_Expandable | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_Expandable | [virtual]
m_ClassId | AP4_Expandable | [protected]
m_ClassIdSize | AP4_Expandable | [protected]
m_HeaderSize | AP4_Expandable | [protected]
m_PayloadSize | AP4_Expandable | [protected]
MinHeaderSize(AP4_Size payload_size) | AP4_Expandable | [static]
Write(AP4_ByteStream &stream) | AP4_Expandable | [virtual]
WriteFields(AP4_ByteStream &stream)=0 | AP4_Expandable | [pure virtual]
~AP4_Expandable() | AP4_Expandable | [inline, virtual]
Generated on Thu May 13 16:37:18 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_File Class Reference

AP4_File Class Reference

The AP4_File object is the top level object for MP4 Files. More...

#include <Ap4File.h>

Inheritance diagram for AP4_File:
AP4_AtomParent

List of all members.

Public Member Functions

AP4_File (AP4_Movie *movie=NULL)
Constructs an AP4_File from an AP4_Movie (used for writing).
AP4_File (AP4_ByteStream &stream, AP4_AtomFactory &atom_factory=AP4_DefaultAtomFactory::Instance, bool moov_only=false)
Constructs an AP4_File from a stream.
virtual | ~AP4_File ()
Destroys the AP4_File instance.
AP4_List< AP4_Atom > & GetTopLevelAtoms ()
Get the top level atoms of the file.
AP4_Movie * GetMovie ()
Get the AP4_Movie object of this file.
AP4_FtypAtom * GetFileType ()
Get the file type atom of this file.
AP4_Result | SetFileType (AP4_UI32 major_brand, AP4_UI32 minor_version, AP4_UI32 *compatible_brands=NULL, AP4_Cardinal compatible_brand_count=0)
Set the file type.
bool | IsMoovBeforeMdat () const
Ask whether the moov atom appears before the first mdat atom.
const AP4_MetaData * | GetMetaData ()
Get the file's metadata description.
virtual AP4_Result | Inspect (AP4_AtomInspector &inspector)
Inspect the content of the file with an AP4_AtomInspector.

Detailed Description

The AP4_File object is the top level object for MP4 Files.

Definition at line 74 of file Ap4File.h.

Constructor & Destructor Documentation

AP4_File::AP4_File ( AP4_Movie * movie = NULL )

Constructs an AP4_File from an AP4_Movie (used for writing).

Parameters:
movie the movie
AP4_File::AP4_File | ( | AP4_ByteStream & | stream,
 |  | AP4_AtomFactory & | atom_factory = AP4_DefaultAtomFactory::Instance,
 |  | bool | moov_only = false
 | ) |  |

Constructs an AP4_File from a stream.

Parameters:
stream | the stream containing the data of the file
factory | the atom factory that will be used to parse the stream
moov_only | indicates whether parsing of the atoms should stop when the moov atom is found or if all atoms should be parsed until the end of the file.
virtual AP4_File::~AP4_File ( ) [virtual]

Destroys the AP4_File instance.

Member Function Documentation

AP4_FtypAtom* AP4_File::GetFileType ( ) [inline]

Get the file type atom of this file.

Definition at line 114 of file Ap4File.h.

const AP4_MetaData* AP4_File::GetMetaData ( )

Get the file's metadata description.

AP4_Movie* AP4_File::GetMovie ( ) [inline]

Get the AP4_Movie object of this file.

Definition at line 108 of file Ap4File.h.

AP4_List<AP4_Atom>& AP4_File::GetTopLevelAtoms ( ) [inline]

Get the top level atoms of the file.

Definition at line 103 of file Ap4File.h.

References AP4_AtomParent::m_Children.

virtual AP4_Result AP4_File::Inspect ( AP4_AtomInspector & inspector ) [virtual]

Inspect the content of the file with an AP4_AtomInspector.

bool AP4_File::IsMoovBeforeMdat ( ) const [inline]

Ask whether the moov atom appears before the first mdat atom.

Definition at line 128 of file Ap4File.h.

AP4_Result AP4_File::SetFileType | ( | AP4_UI32 | major_brand,
 |  | AP4_UI32 | minor_version,
 |  | AP4_UI32 * | compatible_brands = NULL,
 |  | AP4_Cardinal | compatible_brand_count = 0
 | ) |  |

Set the file type.

Will internally create an AP4_Ftyp atom and attach it to the file

The documentation for this class was generated from the following file:
  • Ap4File.h
Generated on Thu May 13 16:37:18 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_File Member List

This is the complete list of members for AP4_File, including all inherited members.
AddChild(AP4_Atom *child, int position=-1) | AP4_AtomParent | [virtual]
AP4_File(AP4_Movie *movie=NULL) | AP4_File |
AP4_File(AP4_ByteStream &stream, AP4_AtomFactory &atom_factory=AP4_DefaultAtomFactory::Instance, bool moov_only=false) | AP4_File |
DeleteChild(AP4_Atom::Type type, AP4_Ordinal index=0) | AP4_AtomParent | [virtual]
FindChild(const char *path, bool auto_create=false, bool auto_create_full=false) | AP4_AtomParent | [virtual]
GetChild(AP4_Atom::Type type, AP4_Ordinal index=0) const | AP4_AtomParent | [virtual]
GetChild(const AP4_UI08 *uuid, AP4_Ordinal index=0) const | AP4_AtomParent | [virtual]
GetChildren() | AP4_AtomParent | [inline]
GetFileType() | AP4_File | [inline]
GetMetaData() | AP4_File |
GetMovie() | AP4_File | [inline]
GetTopLevelAtoms() | AP4_File | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_File | [virtual]
IsMoovBeforeMdat() const | AP4_File | [inline]
m_Children | AP4_AtomParent | [protected]
OnChildAdded(AP4_Atom *) | AP4_AtomParent | [inline, virtual]
OnChildChanged(AP4_Atom *) | AP4_AtomParent | [inline, virtual]
OnChildRemoved(AP4_Atom *) | AP4_AtomParent | [inline, virtual]
RemoveChild(AP4_Atom *child) | AP4_AtomParent | [virtual]
SetFileType(AP4_UI32 major_brand, AP4_UI32 minor_version, AP4_UI32 *compatible_brands=NULL, AP4_Cardinal compatible_brand_count=0) | AP4_File |
~AP4_AtomParent() | AP4_AtomParent | [virtual]
~AP4_File() | AP4_File | [virtual]
Generated on Thu May 13 16:37:18 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_FileByteStream Class Reference

AP4_FileByteStream Class Reference

#include <Ap4FileByteStream.h>

Inheritance diagram for AP4_FileByteStream:
AP4_ByteStream AP4_Referenceable

List of all members.

Public Types

enum Mode {
STREAM_MODE_READ = 0,
STREAM_MODE_WRITE = 1,
STREAM_MODE_READ_WRITE = 2
}

Public Member Functions

AP4_FileByteStream (AP4_ByteStream *delegate)
AP4_FileByteStream (const char *name, Mode mode)
AP4_Result | ReadPartial (void *buffer, AP4_Size bytesToRead, AP4_Size &bytesRead)
AP4_Result | WritePartial (const void *buffer, AP4_Size bytesToWrite, AP4_Size &bytesWritten)
AP4_Result | Seek (AP4_Position position)
AP4_Result | Tell (AP4_Position &position)
AP4_Result | GetSize (AP4_LargeSize &size)
AP4_Result Flush ()
void | AddReference ()
void | Release ()

Static Public Member Functions

static AP4_Result | Create (const char *name, Mode mode, AP4_ByteStream *&stream)
Create a stream from a file (opened or created).

Protected Member Functions

virtual | ~AP4_FileByteStream ()

Protected Attributes

AP4_ByteStream * m_Delegate

Detailed Description

Definition at line 42 of file Ap4FileByteStream.h.

Member Enumeration Documentation

enum AP4_FileByteStream::Mode
Enumerator:
STREAM_MODE_READ
STREAM_MODE_WRITE
STREAM_MODE_READ_WRITE

Definition at line 46 of file Ap4FileByteStream.h.

Constructor & Destructor Documentation

AP4_FileByteStream::AP4_FileByteStream ( AP4_ByteStream * delegate ) [inline]

Definition at line 65 of file Ap4FileByteStream.h.

AP4_FileByteStream::AP4_FileByteStream | ( | const char * | name,
 |  | Mode | mode
 | ) |  |
Deprecated:
virtual AP4_FileByteStream::~AP4_FileByteStream ( ) [inline, protected, virtual]

Definition at line 96 of file Ap4FileByteStream.h.

References m_Delegate.

Member Function Documentation

void AP4_FileByteStream::AddReference ( ) [inline, virtual]

Implements AP4_Referenceable.

Definition at line 91 of file Ap4FileByteStream.h.

References AP4_Referenceable::AddReference(), and m_Delegate.

static AP4_Result AP4_FileByteStream::Create | ( | const char * | name,
 |  | Mode | mode,
 |  | AP4_ByteStream *& | stream |
 | ) |  |  | [static]

Create a stream from a file (opened or created).

Parameters:
name | Name of the file open or create
mode | Mode to use for the file
stream | Refrence to a pointer where the stream object will be returned
Returns:
AP4_SUCCESS if the file can be opened or created, or an error code if it cannot
AP4_Result AP4_FileByteStream::Flush ( ) [inline, virtual]

Reimplemented from AP4_ByteStream.

Definition at line 88 of file Ap4FileByteStream.h.

References AP4_ByteStream::Flush(), and m_Delegate.

AP4_Result AP4_FileByteStream::GetSize ( AP4_LargeSize & size ) [inline, virtual]

Implements AP4_ByteStream.

Definition at line 87 of file Ap4FileByteStream.h.

References AP4_ByteStream::GetSize(), and m_Delegate.

AP4_Result AP4_FileByteStream::ReadPartial | ( | void * | buffer,
 |  | AP4_Size | bytesToRead,
 |  | AP4_Size & | bytesRead |
 | ) |  |  | [inline, virtual]

Implements AP4_ByteStream.

Definition at line 75 of file Ap4FileByteStream.h.

References m_Delegate, and AP4_ByteStream::ReadPartial().

void AP4_FileByteStream::Release ( ) [inline, virtual]

Implements AP4_Referenceable.

Definition at line 92 of file Ap4FileByteStream.h.

References m_Delegate, and AP4_Referenceable::Release().

AP4_Result AP4_FileByteStream::Seek ( AP4_Position position ) [inline, virtual]

Implements AP4_ByteStream.

Definition at line 85 of file Ap4FileByteStream.h.

References m_Delegate, and AP4_ByteStream::Seek().

AP4_Result AP4_FileByteStream::Tell ( AP4_Position & position ) [inline, virtual]

Implements AP4_ByteStream.

Definition at line 86 of file Ap4FileByteStream.h.

References m_Delegate, and AP4_ByteStream::Tell().

AP4_Result AP4_FileByteStream::WritePartial | ( | const void * | buffer,
 |  | AP4_Size | bytesToWrite,
 |  | AP4_Size & | bytesWritten |
 | ) |  |  | [inline, virtual]

Implements AP4_ByteStream.

Definition at line 80 of file Ap4FileByteStream.h.

References m_Delegate, and AP4_ByteStream::WritePartial().

Member Data Documentation

AP4_ByteStream* AP4_FileByteStream::m_Delegate [protected]

Definition at line 101 of file Ap4FileByteStream.h.

Referenced by AddReference(), Flush(), GetSize(), ReadPartial(), Release(), Seek(), Tell(), WritePartial(), and ~AP4_FileByteStream().

The documentation for this class was generated from the following file:
  • Ap4FileByteStream.h
Generated on Thu May 13 16:37:18 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_FileByteStream Member List

This is the complete list of members for AP4_FileByteStream, including all inherited members.
AddReference() | AP4_FileByteStream | [inline, virtual]
AP4_FileByteStream(AP4_ByteStream *delegate) | AP4_FileByteStream | [inline]
AP4_FileByteStream(const char *name, Mode mode) | AP4_FileByteStream |
CopyTo(AP4_ByteStream &stream, AP4_LargeSize size) | AP4_ByteStream | [virtual]
Create(const char *name, Mode mode, AP4_ByteStream *&stream) | AP4_FileByteStream | [static]
Flush() | AP4_FileByteStream | [inline, virtual]
GetSize(AP4_LargeSize &size) | AP4_FileByteStream | [inline, virtual]
m_Delegate | AP4_FileByteStream | [protected]
Mode enum name | AP4_FileByteStream |
Read(void *buffer, AP4_Size bytes_to_read) | AP4_ByteStream |
ReadDouble(double &value) | AP4_ByteStream |
ReadPartial(void *buffer, AP4_Size bytesToRead, AP4_Size &bytesRead) | AP4_FileByteStream | [inline, virtual]
ReadString(char *buffer, AP4_Size size) | AP4_ByteStream |
ReadUI08(AP4_UI08 &value) | AP4_ByteStream |
ReadUI16(AP4_UI16 &value) | AP4_ByteStream |
ReadUI24(AP4_UI32 &value) | AP4_ByteStream |
ReadUI32(AP4_UI32 &value) | AP4_ByteStream |
ReadUI64(AP4_UI64 &value) | AP4_ByteStream |
Release() | AP4_FileByteStream | [inline, virtual]
Seek(AP4_Position position) | AP4_FileByteStream | [inline, virtual]
STREAM_MODE_READ enum value | AP4_FileByteStream |
STREAM_MODE_READ_WRITE enum value | AP4_FileByteStream |
STREAM_MODE_WRITE enum value | AP4_FileByteStream |
Tell(AP4_Position &position) | AP4_FileByteStream | [inline, virtual]
Write(const void *buffer, AP4_Size bytes_to_write) | AP4_ByteStream |
WriteDouble(double value) | AP4_ByteStream |
WritePartial(const void *buffer, AP4_Size bytesToWrite, AP4_Size &bytesWritten) | AP4_FileByteStream | [inline, virtual]
WriteString(const char *string_buffer) | AP4_ByteStream |
WriteUI08(AP4_UI08 value) | AP4_ByteStream |
WriteUI16(AP4_UI16 value) | AP4_ByteStream |
WriteUI24(AP4_UI32 value) | AP4_ByteStream |
WriteUI32(AP4_UI32 value) | AP4_ByteStream |
WriteUI64(AP4_UI64 value) | AP4_ByteStream |
~AP4_FileByteStream() | AP4_FileByteStream | [inline, protected, virtual]
~AP4_Referenceable() | AP4_Referenceable | [inline, virtual]
Generated on Thu May 13 16:37:18 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_FileCopier Class Reference

AP4_FileCopier Class Reference

#include <Ap4FileCopier.h>

List of all members.

Static Public Member Functions

static AP4_Result Write (AP4_File &file, AP4_ByteStream &stream)

Detailed Description

Definition at line 46 of file Ap4FileCopier.h.

Member Function Documentation

static AP4_Result AP4_FileCopier::Write | ( | AP4_File & | file,
 |  | AP4_ByteStream & | stream |
 | ) |  |  | [static]
The documentation for this class was generated from the following file:
  • Ap4FileCopier.h
Generated on Thu May 13 16:37:18 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_FileCopier Member List

This is the complete list of members for AP4_FileCopier, including all inherited members.
Write(AP4_File &file, AP4_ByteStream &stream) AP4_FileCopier [static]
Generated on Thu May 13 16:37:18 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_FileWriter Class Reference

AP4_FileWriter Class Reference

#include <Ap4FileWriter.h>

List of all members.

Public Types

enum | Interleaving { INTERLEAVING_SEQUENTIAL }

Static Public Member Functions

static AP4_Result | Write (AP4_File &file, AP4_ByteStream &stream, Interleaving interleaving=INTERLEAVING_SEQUENTIAL)

Detailed Description

Definition at line 46 of file Ap4FileWriter.h.

Member Enumeration Documentation

enum AP4_FileWriter::Interleaving
Enumerator:
INTERLEAVING_SEQUENTIAL

Definition at line 49 of file Ap4FileWriter.h.

Member Function Documentation

static AP4_Result AP4_FileWriter::Write | ( | AP4_File & | file,
 |  | AP4_ByteStream & | stream,
 |  | Interleaving | interleaving = INTERLEAVING_SEQUENTIAL |
 | ) |  |  | [static]
The documentation for this class was generated from the following file:
  • Ap4FileWriter.h
Generated on Thu May 13 16:37:18 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_FileWriter Member List

This is the complete list of members for AP4_FileWriter, including all inherited members.
Interleaving enum name | AP4_FileWriter |
INTERLEAVING_SEQUENTIAL enum value | AP4_FileWriter |
Write(AP4_File &file, AP4_ByteStream &stream, Interleaving interleaving=INTERLEAVING_SEQUENTIAL) | AP4_FileWriter | [static]
Generated on Thu May 13 16:37:18 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_FragmentSampleTable Class Reference

AP4_FragmentSampleTable Class Reference

#include <Ap4FragmentSampleTable.h>

Inheritance diagram for AP4_FragmentSampleTable:
AP4_SampleTable

List of all members.

Public Member Functions

AP4_FragmentSampleTable (AP4_ContainerAtom *traf, AP4_TrexAtom *trex, AP4_ByteStream *sample_stream, AP4_Position moof_offset, AP4_Position mdat_payload_offset, AP4_UI64 dts_origin=0)
virtual | ~AP4_FragmentSampleTable ()
virtual AP4_Result | GetSample (AP4_Ordinal sample_index, AP4_Sample &sample)
virtual AP4_Cardinal | GetSampleCount ()
virtual AP4_SampleDescription * | GetSampleDescription (AP4_Ordinal sd_index)
virtual AP4_Cardinal | GetSampleDescriptionCount ()
virtual AP4_Result | GetSampleChunkPosition (AP4_Ordinal sample_index, AP4_Ordinal &chunk_index, AP4_Ordinal &position_in_chunk)
virtual AP4_Result | GetSampleIndexForTimeStamp (AP4_UI64 ts, AP4_Ordinal &sample_index)
virtual AP4_Ordinal | GetNearestSyncSampleIndex (AP4_Ordinal index, bool before=true)
AP4_UI64 GetDuration ()

Detailed Description

Definition at line 51 of file Ap4FragmentSampleTable.h.

Constructor & Destructor Documentation

AP4_FragmentSampleTable::AP4_FragmentSampleTable | ( | AP4_ContainerAtom * | traf,
 |  | AP4_TrexAtom * | trex,
 |  | AP4_ByteStream * | sample_stream,
 |  | AP4_Position | moof_offset,
 |  | AP4_Position | mdat_payload_offset,
 |  | AP4_UI64 | dts_origin = 0
 | ) |  |
virtual AP4_FragmentSampleTable::~AP4_FragmentSampleTable ( ) [virtual]

Member Function Documentation

AP4_UI64 AP4_FragmentSampleTable::GetDuration ( ) [inline]

Definition at line 75 of file Ap4FragmentSampleTable.h.

virtual AP4_Ordinal AP4_FragmentSampleTable::GetNearestSyncSampleIndex | ( | AP4_Ordinal | index,
 |  | bool | before = true |
 | ) |  |  | [virtual]

Implements AP4_SampleTable.

virtual AP4_Result AP4_FragmentSampleTable::GetSample | ( | AP4_Ordinal | sample_index,
 |  | AP4_Sample & | sample |
 | ) |  |  | [virtual]

Implements AP4_SampleTable.

virtual AP4_Result AP4_FragmentSampleTable::GetSampleChunkPosition | ( | AP4_Ordinal | sample_index,
 |  | AP4_Ordinal & | chunk_index,
 |  | AP4_Ordinal & | position_in_chunk |
 | ) |  |  | [virtual]

Implements AP4_SampleTable.

virtual AP4_Cardinal AP4_FragmentSampleTable::GetSampleCount ( ) [virtual]

Implements AP4_SampleTable.

virtual AP4_SampleDescription* AP4_FragmentSampleTable::GetSampleDescription ( AP4_Ordinal sd_index ) [virtual]

Implements AP4_SampleTable.

virtual AP4_Cardinal AP4_FragmentSampleTable::GetSampleDescriptionCount ( ) [virtual]

Implements AP4_SampleTable.

virtual AP4_Result AP4_FragmentSampleTable::GetSampleIndexForTimeStamp | ( | AP4_UI64 | ts,
 |  | AP4_Ordinal & | sample_index |
 | ) |  |  | [virtual]

Implements AP4_SampleTable.

The documentation for this class was generated from the following file:
  • Ap4FragmentSampleTable.h
Generated on Thu May 13 16:37:18 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_FragmentSampleTable Member List

This is the complete list of members for AP4_FragmentSampleTable, including all inherited members.
AP4_FragmentSampleTable(AP4_ContainerAtom *traf, AP4_TrexAtom *trex, AP4_ByteStream *sample_stream, AP4_Position moof_offset, AP4_Position mdat_payload_offset, AP4_UI64 dts_origin=0) | AP4_FragmentSampleTable |
GenerateStblAtom(AP4_ContainerAtom *&stbl) | AP4_SampleTable | [virtual]
GetDuration() | AP4_FragmentSampleTable | [inline]
GetNearestSyncSampleIndex(AP4_Ordinal index, bool before=true) | AP4_FragmentSampleTable | [virtual]
GetSample(AP4_Ordinal sample_index, AP4_Sample &sample) | AP4_FragmentSampleTable | [virtual]
GetSampleChunkPosition(AP4_Ordinal sample_index, AP4_Ordinal &chunk_index, AP4_Ordinal &position_in_chunk) | AP4_FragmentSampleTable | [virtual]
GetSampleCount() | AP4_FragmentSampleTable | [virtual]
GetSampleDescription(AP4_Ordinal sd_index) | AP4_FragmentSampleTable | [virtual]
GetSampleDescriptionCount() | AP4_FragmentSampleTable | [virtual]
GetSampleIndexForTimeStamp(AP4_UI64 ts, AP4_Ordinal &sample_index) | AP4_FragmentSampleTable | [virtual]
~AP4_FragmentSampleTable() | AP4_FragmentSampleTable | [virtual]
~AP4_SampleTable() | AP4_SampleTable | [inline, virtual]
Generated on Thu May 13 16:37:18 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_FrmaAtom Class Reference

AP4_FrmaAtom Class Reference

#include <Ap4FrmaAtom.h>

Inheritance diagram for AP4_FrmaAtom:
AP4_Atom

List of all members.

Public Member Functions

AP4_FrmaAtom (AP4_UI32 original_format)
virtual AP4_Result | InspectFields (AP4_AtomInspector &inspector)
virtual AP4_Result | WriteFields (AP4_ByteStream &stream)
AP4_UI32 GetOriginalFormat ()

Static Public Member Functions

static AP4_FrmaAtom * | Create (AP4_Size size, AP4_ByteStream &stream)

Detailed Description

Definition at line 46 of file Ap4FrmaAtom.h.

Constructor & Destructor Documentation

AP4_FrmaAtom::AP4_FrmaAtom ( AP4_UI32 original_format )

Referenced by Create().

Member Function Documentation

static AP4_FrmaAtom* AP4_FrmaAtom::Create | ( | AP4_Size | size,
 |  | AP4_ByteStream & | stream |
 | ) |  |  | [inline, static]

Definition at line 52 of file Ap4FrmaAtom.h.

References AP4_FrmaAtom().

AP4_UI32 AP4_FrmaAtom::GetOriginalFormat ( ) [inline]

Definition at line 62 of file Ap4FrmaAtom.h.

virtual AP4_Result AP4_FrmaAtom::InspectFields ( AP4_AtomInspector & inspector ) [virtual]

Reimplemented from AP4_Atom.

virtual AP4_Result AP4_FrmaAtom::WriteFields ( AP4_ByteStream & stream ) [virtual]

Implements AP4_Atom.

The documentation for this class was generated from the following file:
  • Ap4FrmaAtom.h
Generated on Thu May 13 16:37:18 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_FrmaAtom Member List

This is the complete list of members for AP4_FrmaAtom, including all inherited members.
AP4_Atom(Type type, AP4_UI32 size=AP4_ATOM_HEADER_SIZE) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64=false) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_FrmaAtom(AP4_UI32 original_format) | AP4_FrmaAtom |
Clone() | AP4_Atom | [virtual]
Create(AP4_Size size, AP4_ByteStream &stream) | AP4_FrmaAtom | [inline, static]
Detach() | AP4_Atom | [virtual]
GetFlags() const | AP4_Atom | [inline]
GetHeaderSize() const | AP4_Atom | [virtual]
GetOriginalFormat() | AP4_FrmaAtom | [inline]
GetParent() | AP4_Atom | [inline, virtual]
GetSize() const | AP4_Atom | [inline]
GetSize32() const | AP4_Atom | [inline]
GetSize64() const | AP4_Atom | [inline]
GetType() const | AP4_Atom | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
InspectFields(AP4_AtomInspector &inspector) | AP4_FrmaAtom | [virtual]
InspectHeader(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
m_Flags | AP4_Atom | [protected]
m_IsFull | AP4_Atom | [protected]
m_Parent | AP4_Atom | [protected]
m_Size32 | AP4_Atom | [protected]
m_Size64 | AP4_Atom | [protected]
m_Type | AP4_Atom | [protected]
m_Version | AP4_Atom | [protected]
ReadFullHeader(AP4_ByteStream &stream, AP4_UI32 &version, AP4_UI32 &flags) | AP4_Atom | [static]
SetFlags(AP4_UI32 flags) | AP4_Atom | [inline]
SetParent(AP4_AtomParent *parent) | AP4_Atom | [inline, virtual]
SetSize(AP4_UI64 size, bool force_64=false) | AP4_Atom |
SetSize32(AP4_UI32 size) | AP4_Atom | [inline]
SetSize64(AP4_UI64 size) | AP4_Atom | [inline]
SetType(Type type) | AP4_Atom | [inline]
Type typedef | AP4_Atom |
TypeFromString(const char *four_cc) | AP4_Atom | [static]
Write(AP4_ByteStream &stream) | AP4_Atom | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_FrmaAtom | [virtual]
WriteHeader(AP4_ByteStream &stream) | AP4_Atom | [virtual]
~AP4_Atom() | AP4_Atom | [inline, virtual]
Generated on Thu May 13 16:37:18 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_FtypAtom Class Reference

AP4_FtypAtom Class Reference

#include <Ap4FtypAtom.h>

Inheritance diagram for AP4_FtypAtom:
AP4_Atom

List of all members.

Public Member Functions

AP4_FtypAtom (AP4_UI32 major_brand, AP4_UI32 minor_version, AP4_UI32 *compatible_brands=NULL, AP4_Cardinal compatible_brand_count=0)
virtual AP4_Result | InspectFields (AP4_AtomInspector &inspector)
virtual AP4_Result | WriteFields (AP4_ByteStream &stream)
AP4_UI32 GetMajorBrand ()
AP4_UI32 GetMinorVersion ()
AP4_Array< AP4_UI32 > & GetCompatibleBrands ()
bool | HasCompatibleBrand (AP4_UI32 brand)

Static Public Member Functions

static AP4_FtypAtom * | Create (AP4_Size size, AP4_ByteStream &stream)

Detailed Description

Definition at line 52 of file Ap4FtypAtom.h.

Constructor & Destructor Documentation

AP4_FtypAtom::AP4_FtypAtom | ( | AP4_UI32 | major_brand,
 |  | AP4_UI32 | minor_version,
 |  | AP4_UI32 * | compatible_brands = NULL,
 |  | AP4_Cardinal | compatible_brand_count = 0
 | ) |  |

Referenced by Create().

Member Function Documentation

static AP4_FtypAtom* AP4_FtypAtom::Create | ( | AP4_Size | size,
 |  | AP4_ByteStream & | stream |
 | ) |  |  | [inline, static]

Definition at line 58 of file Ap4FtypAtom.h.

References AP4_FtypAtom().

AP4_Array<AP4_UI32>& AP4_FtypAtom::GetCompatibleBrands ( ) [inline]

Definition at line 73 of file Ap4FtypAtom.h.

AP4_UI32 AP4_FtypAtom::GetMajorBrand ( ) [inline]

Definition at line 71 of file Ap4FtypAtom.h.

AP4_UI32 AP4_FtypAtom::GetMinorVersion ( ) [inline]

Definition at line 72 of file Ap4FtypAtom.h.

bool AP4_FtypAtom::HasCompatibleBrand ( AP4_UI32 brand )
virtual AP4_Result AP4_FtypAtom::InspectFields ( AP4_AtomInspector & inspector ) [virtual]

Reimplemented from AP4_Atom.

virtual AP4_Result AP4_FtypAtom::WriteFields ( AP4_ByteStream & stream ) [virtual]

Implements AP4_Atom.

The documentation for this class was generated from the following file:
  • Ap4FtypAtom.h
Generated on Thu May 13 16:37:18 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_FtypAtom Member List

This is the complete list of members for AP4_FtypAtom, including all inherited members.
AP4_Atom(Type type, AP4_UI32 size=AP4_ATOM_HEADER_SIZE) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64=false) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_FtypAtom(AP4_UI32 major_brand, AP4_UI32 minor_version, AP4_UI32 *compatible_brands=NULL, AP4_Cardinal compatible_brand_count=0) | AP4_FtypAtom |
Clone() | AP4_Atom | [virtual]
Create(AP4_Size size, AP4_ByteStream &stream) | AP4_FtypAtom | [inline, static]
Detach() | AP4_Atom | [virtual]
GetCompatibleBrands() | AP4_FtypAtom | [inline]
GetFlags() const | AP4_Atom | [inline]
GetHeaderSize() const | AP4_Atom | [virtual]
GetMajorBrand() | AP4_FtypAtom | [inline]
GetMinorVersion() | AP4_FtypAtom | [inline]
GetParent() | AP4_Atom | [inline, virtual]
GetSize() const | AP4_Atom | [inline]
GetSize32() const | AP4_Atom | [inline]
GetSize64() const | AP4_Atom | [inline]
GetType() const | AP4_Atom | [inline]
HasCompatibleBrand(AP4_UI32 brand) | AP4_FtypAtom |
Inspect(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
InspectFields(AP4_AtomInspector &inspector) | AP4_FtypAtom | [virtual]
InspectHeader(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
m_Flags | AP4_Atom | [protected]
m_IsFull | AP4_Atom | [protected]
m_Parent | AP4_Atom | [protected]
m_Size32 | AP4_Atom | [protected]
m_Size64 | AP4_Atom | [protected]
m_Type | AP4_Atom | [protected]
m_Version | AP4_Atom | [protected]
ReadFullHeader(AP4_ByteStream &stream, AP4_UI32 &version, AP4_UI32 &flags) | AP4_Atom | [static]
SetFlags(AP4_UI32 flags) | AP4_Atom | [inline]
SetParent(AP4_AtomParent *parent) | AP4_Atom | [inline, virtual]
SetSize(AP4_UI64 size, bool force_64=false) | AP4_Atom |
SetSize32(AP4_UI32 size) | AP4_Atom | [inline]
SetSize64(AP4_UI64 size) | AP4_Atom | [inline]
SetType(Type type) | AP4_Atom | [inline]
Type typedef | AP4_Atom |
TypeFromString(const char *four_cc) | AP4_Atom | [static]
Write(AP4_ByteStream &stream) | AP4_Atom | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_FtypAtom | [virtual]
WriteHeader(AP4_ByteStream &stream) | AP4_Atom | [virtual]
~AP4_Atom() | AP4_Atom | [inline, virtual]
Generated on Thu May 13 16:37:18 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_GenericAudioSampleDescription Class Reference

AP4_GenericAudioSampleDescription Class Reference

#include <Ap4SampleDescription.h>

Inheritance diagram for AP4_GenericAudioSampleDescription:
AP4_SampleDescription AP4_AudioSampleDescription

List of all members.

Public Member Functions

AP4_GenericAudioSampleDescription (AP4_UI32 format, unsigned int sample_rate, unsigned int sample_size, unsigned int channel_count, AP4_AtomParent *details)

Detailed Description

Definition at line 208 of file Ap4SampleDescription.h.

Constructor & Destructor Documentation

AP4_GenericAudioSampleDescription::AP4_GenericAudioSampleDescription | ( | AP4_UI32 | format,
 |  | unsigned int | sample_rate,
 |  | unsigned int | sample_size,
 |  | unsigned int | channel_count,
 |  | AP4_AtomParent * | details |
 | ) |  |  | [inline]

Definition at line 215 of file Ap4SampleDescription.h.

The documentation for this class was generated from the following file:
  • Ap4SampleDescription.h
Generated on Thu May 13 16:37:18 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_GenericAudioSampleDescription Member List

This is the complete list of members for AP4_GenericAudioSampleDescription, including all inherited members.
AP4_AudioSampleDescription(unsigned int sample_rate, unsigned int sample_size, unsigned int channel_count) | AP4_AudioSampleDescription | [inline]
AP4_GenericAudioSampleDescription(AP4_UI32 format, unsigned int sample_rate, unsigned int sample_size, unsigned int channel_count, AP4_AtomParent *details) | AP4_GenericAudioSampleDescription | [inline]
AP4_SampleDescription(Type type, AP4_UI32 format, AP4_AtomParent *details) | AP4_SampleDescription |
Clone(AP4_Result *result=NULL) | AP4_SampleDescription | [virtual]
GetChannelCount() | AP4_AudioSampleDescription | [inline]
GetDetails() | AP4_SampleDescription | [inline]
GetFormat() const | AP4_SampleDescription | [inline]
GetSampleRate() | AP4_AudioSampleDescription | [inline]
GetSampleSize() | AP4_AudioSampleDescription | [inline]
GetType() const | AP4_SampleDescription | [inline]
m_ChannelCount | AP4_AudioSampleDescription | [protected]
m_Details | AP4_SampleDescription | [protected]
m_Format | AP4_SampleDescription | [protected]
m_SampleRate | AP4_AudioSampleDescription | [protected]
m_SampleSize | AP4_AudioSampleDescription | [protected]
m_Type | AP4_SampleDescription | [protected]
ToAtom() const | AP4_SampleDescription | [virtual]
Type enum name | AP4_SampleDescription |
TYPE_AVC enum value | AP4_SampleDescription |
TYPE_MPEG enum value | AP4_SampleDescription |
TYPE_PROTECTED enum value | AP4_SampleDescription |
TYPE_UNKNOWN enum value | AP4_SampleDescription |
~AP4_SampleDescription() | AP4_SampleDescription | [inline, virtual]
Generated on Thu May 13 16:37:18 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_GenericVideoSampleDescription Class Reference

AP4_GenericVideoSampleDescription Class Reference

#include <Ap4SampleDescription.h>

Inheritance diagram for AP4_GenericVideoSampleDescription:
AP4_SampleDescription AP4_VideoSampleDescription

List of all members.

Public Member Functions

AP4_GenericVideoSampleDescription (AP4_UI32 format, AP4_UI16 width, AP4_UI16 height, AP4_UI16 depth, const char *compressor_name, AP4_AtomParent *details)

Detailed Description

Definition at line 227 of file Ap4SampleDescription.h.

Constructor & Destructor Documentation

AP4_GenericVideoSampleDescription::AP4_GenericVideoSampleDescription | ( | AP4_UI32 | format,
 |  | AP4_UI16 | width,
 |  | AP4_UI16 | height,
 |  | AP4_UI16 | depth,
 |  | const char * | compressor_name,
 |  | AP4_AtomParent * | details |
 | ) |  |  | [inline]

Definition at line 234 of file Ap4SampleDescription.h.

The documentation for this class was generated from the following file:
  • Ap4SampleDescription.h
Generated on Thu May 13 16:37:19 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_GenericVideoSampleDescription Member List

This is the complete list of members for AP4_GenericVideoSampleDescription, including all inherited members.
AP4_GenericVideoSampleDescription(AP4_UI32 format, AP4_UI16 width, AP4_UI16 height, AP4_UI16 depth, const char *compressor_name, AP4_AtomParent *details) | AP4_GenericVideoSampleDescription | [inline]
AP4_SampleDescription(Type type, AP4_UI32 format, AP4_AtomParent *details) | AP4_SampleDescription |
AP4_VideoSampleDescription(AP4_UI16 width, AP4_UI16 height, AP4_UI16 depth, const char *compressor_name) | AP4_VideoSampleDescription | [inline]
Clone(AP4_Result *result=NULL) | AP4_SampleDescription | [virtual]
GetCompressorName() | AP4_VideoSampleDescription | [inline]
GetDepth() | AP4_VideoSampleDescription | [inline]
GetDetails() | AP4_SampleDescription | [inline]
GetFormat() const | AP4_SampleDescription | [inline]
GetHeight() | AP4_VideoSampleDescription | [inline]
GetType() const | AP4_SampleDescription | [inline]
GetWidth() | AP4_VideoSampleDescription | [inline]
m_CompressorName | AP4_VideoSampleDescription | [protected]
m_Depth | AP4_VideoSampleDescription | [protected]
m_Details | AP4_SampleDescription | [protected]
m_Format | AP4_SampleDescription | [protected]
m_Height | AP4_VideoSampleDescription | [protected]
m_Type | AP4_SampleDescription | [protected]
m_Width | AP4_VideoSampleDescription | [protected]
ToAtom() const | AP4_SampleDescription | [virtual]
Type enum name | AP4_SampleDescription |
TYPE_AVC enum value | AP4_SampleDescription |
TYPE_MPEG enum value | AP4_SampleDescription |
TYPE_PROTECTED enum value | AP4_SampleDescription |
TYPE_UNKNOWN enum value | AP4_SampleDescription |
~AP4_SampleDescription() | AP4_SampleDescription | [inline, virtual]
Generated on Thu May 13 16:37:19 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_GrpiAtom Class Reference

AP4_GrpiAtom Class Reference

#include <Ap4GrpiAtom.h>

Inheritance diagram for AP4_GrpiAtom:
AP4_Atom

List of all members.

Public Member Functions

AP4_GrpiAtom (AP4_UI08 key_encryption_method, const char *group_id, const AP4_UI08 *group_key, AP4_Size group_key_length)
virtual AP4_Result | InspectFields (AP4_AtomInspector &inspector)
virtual AP4_Result | WriteFields (AP4_ByteStream &stream)
virtual AP4_Atom * | Clone ()
Create a clone of the object.
AP4_UI08 | GetKeyEncryptionMethod () const
void | SetKeyEncryptionMethod (AP4_UI08 encryption_method)
const AP4_String & | GetGroupId () const
const AP4_DataBuffer & | GetGroupKey () const

Static Public Member Functions

static AP4_GrpiAtom * | Create (AP4_Size size, AP4_ByteStream &stream)

Detailed Description

Definition at line 43 of file Ap4GrpiAtom.h.

Constructor & Destructor Documentation

AP4_GrpiAtom::AP4_GrpiAtom | ( | AP4_UI08 | key_encryption_method,
 |  | const char * | group_id,
 |  | const AP4_UI08 * | group_key,
 |  | AP4_Size | group_key_length
 | ) |  |

Member Function Documentation

virtual AP4_Atom* AP4_GrpiAtom::Clone ( ) [virtual]

Create a clone of the object.

This method returns a clone of the atom, or NULL if the atom cannot be cloned. Override this if your want to make an atom cloneable in a more efficient way than the default implementation.

Reimplemented from AP4_Atom.

static AP4_GrpiAtom* AP4_GrpiAtom::Create | ( | AP4_Size | size,
 |  | AP4_ByteStream & | stream |
 | ) |  |  | [static]
const AP4_String& AP4_GrpiAtom::GetGroupId ( ) const [inline]

Definition at line 66 of file Ap4GrpiAtom.h.

const AP4_DataBuffer& AP4_GrpiAtom::GetGroupKey ( ) const [inline]

Definition at line 67 of file Ap4GrpiAtom.h.

AP4_UI08 AP4_GrpiAtom::GetKeyEncryptionMethod ( ) const [inline]

Definition at line 64 of file Ap4GrpiAtom.h.

virtual AP4_Result AP4_GrpiAtom::InspectFields ( AP4_AtomInspector & inspector ) [virtual]

Reimplemented from AP4_Atom.

void AP4_GrpiAtom::SetKeyEncryptionMethod ( AP4_UI08 encryption_method ) [inline]

Definition at line 65 of file Ap4GrpiAtom.h.

virtual AP4_Result AP4_GrpiAtom::WriteFields ( AP4_ByteStream & stream ) [virtual]

Implements AP4_Atom.

The documentation for this class was generated from the following file:
  • Ap4GrpiAtom.h
Generated on Thu May 13 16:37:19 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_GrpiAtom Member List

This is the complete list of members for AP4_GrpiAtom, including all inherited members.
AP4_Atom(Type type, AP4_UI32 size=AP4_ATOM_HEADER_SIZE) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64=false) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_GrpiAtom(AP4_UI08 key_encryption_method, const char *group_id, const AP4_UI08 *group_key, AP4_Size group_key_length) | AP4_GrpiAtom |
Clone() | AP4_GrpiAtom | [virtual]
Create(AP4_Size size, AP4_ByteStream &stream) | AP4_GrpiAtom | [static]
Detach() | AP4_Atom | [virtual]
GetFlags() const | AP4_Atom | [inline]
GetGroupId() const | AP4_GrpiAtom | [inline]
GetGroupKey() const | AP4_GrpiAtom | [inline]
GetHeaderSize() const | AP4_Atom | [virtual]
GetKeyEncryptionMethod() const | AP4_GrpiAtom | [inline]
GetParent() | AP4_Atom | [inline, virtual]
GetSize() const | AP4_Atom | [inline]
GetSize32() const | AP4_Atom | [inline]
GetSize64() const | AP4_Atom | [inline]
GetType() const | AP4_Atom | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
InspectFields(AP4_AtomInspector &inspector) | AP4_GrpiAtom | [virtual]
InspectHeader(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
m_Flags | AP4_Atom | [protected]
m_IsFull | AP4_Atom | [protected]
m_Parent | AP4_Atom | [protected]
m_Size32 | AP4_Atom | [protected]
m_Size64 | AP4_Atom | [protected]
m_Type | AP4_Atom | [protected]
m_Version | AP4_Atom | [protected]
ReadFullHeader(AP4_ByteStream &stream, AP4_UI32 &version, AP4_UI32 &flags) | AP4_Atom | [static]
SetFlags(AP4_UI32 flags) | AP4_Atom | [inline]
SetKeyEncryptionMethod(AP4_UI08 encryption_method) | AP4_GrpiAtom | [inline]
SetParent(AP4_AtomParent *parent) | AP4_Atom | [inline, virtual]
SetSize(AP4_UI64 size, bool force_64=false) | AP4_Atom |
SetSize32(AP4_UI32 size) | AP4_Atom | [inline]
SetSize64(AP4_UI64 size) | AP4_Atom | [inline]
SetType(Type type) | AP4_Atom | [inline]
Type typedef | AP4_Atom |
TypeFromString(const char *four_cc) | AP4_Atom | [static]
Write(AP4_ByteStream &stream) | AP4_Atom | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_GrpiAtom | [virtual]
WriteHeader(AP4_ByteStream &stream) | AP4_Atom | [virtual]
~AP4_Atom() | AP4_Atom | [inline, virtual]
Generated on Thu May 13 16:37:19 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_HdlrAtom Class Reference

AP4_HdlrAtom Class Reference

#include <Ap4HdlrAtom.h>

Inheritance diagram for AP4_HdlrAtom:
AP4_Atom

List of all members.

Public Member Functions

AP4_HdlrAtom (AP4_UI32 hdlr_type, const char *hdlr_name)
virtual AP4_Result | InspectFields (AP4_AtomInspector &inspector)
virtual AP4_Result | WriteFields (AP4_ByteStream &stream)
AP4_UI32 GetHandlerType ()
AP4_String GetHandlerName ()

Static Public Member Functions

static AP4_HdlrAtom * | Create (AP4_Size size, AP4_ByteStream &stream)

Detailed Description

Definition at line 59 of file Ap4HdlrAtom.h.

Constructor & Destructor Documentation

AP4_HdlrAtom::AP4_HdlrAtom | ( | AP4_UI32 | hdlr_type,
 |  | const char * | hdlr_name
 | ) |  |

Member Function Documentation

static AP4_HdlrAtom* AP4_HdlrAtom::Create | ( | AP4_Size | size,
 |  | AP4_ByteStream & | stream |
 | ) |  |  | [static]
AP4_String AP4_HdlrAtom::GetHandlerName ( ) [inline]

Definition at line 73 of file Ap4HdlrAtom.h.

AP4_UI32 AP4_HdlrAtom::GetHandlerType ( ) [inline]

Definition at line 72 of file Ap4HdlrAtom.h.

virtual AP4_Result AP4_HdlrAtom::InspectFields ( AP4_AtomInspector & inspector ) [virtual]

Reimplemented from AP4_Atom.

virtual AP4_Result AP4_HdlrAtom::WriteFields ( AP4_ByteStream & stream ) [virtual]

Implements AP4_Atom.

The documentation for this class was generated from the following file:
  • Ap4HdlrAtom.h
Generated on Thu May 13 16:37:19 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_HdlrAtom Member List

This is the complete list of members for AP4_HdlrAtom, including all inherited members.
AP4_Atom(Type type, AP4_UI32 size=AP4_ATOM_HEADER_SIZE) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64=false) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_HdlrAtom(AP4_UI32 hdlr_type, const char *hdlr_name) | AP4_HdlrAtom |
Clone() | AP4_Atom | [virtual]
Create(AP4_Size size, AP4_ByteStream &stream) | AP4_HdlrAtom | [static]
Detach() | AP4_Atom | [virtual]
GetFlags() const | AP4_Atom | [inline]
GetHandlerName() | AP4_HdlrAtom | [inline]
GetHandlerType() | AP4_HdlrAtom | [inline]
GetHeaderSize() const | AP4_Atom | [virtual]
GetParent() | AP4_Atom | [inline, virtual]
GetSize() const | AP4_Atom | [inline]
GetSize32() const | AP4_Atom | [inline]
GetSize64() const | AP4_Atom | [inline]
GetType() const | AP4_Atom | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
InspectFields(AP4_AtomInspector &inspector) | AP4_HdlrAtom | [virtual]
InspectHeader(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
m_Flags | AP4_Atom | [protected]
m_IsFull | AP4_Atom | [protected]
m_Parent | AP4_Atom | [protected]
m_Size32 | AP4_Atom | [protected]
m_Size64 | AP4_Atom | [protected]
m_Type | AP4_Atom | [protected]
m_Version | AP4_Atom | [protected]
ReadFullHeader(AP4_ByteStream &stream, AP4_UI32 &version, AP4_UI32 &flags) | AP4_Atom | [static]
SetFlags(AP4_UI32 flags) | AP4_Atom | [inline]
SetParent(AP4_AtomParent *parent) | AP4_Atom | [inline, virtual]
SetSize(AP4_UI64 size, bool force_64=false) | AP4_Atom |
SetSize32(AP4_UI32 size) | AP4_Atom | [inline]
SetSize64(AP4_UI64 size) | AP4_Atom | [inline]
SetType(Type type) | AP4_Atom | [inline]
Type typedef | AP4_Atom |
TypeFromString(const char *four_cc) | AP4_Atom | [static]
Write(AP4_ByteStream &stream) | AP4_Atom | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_HdlrAtom | [virtual]
WriteHeader(AP4_ByteStream &stream) | AP4_Atom | [virtual]
~AP4_Atom() | AP4_Atom | [inline, virtual]
Generated on Thu May 13 16:37:19 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_HintTrackReader Class Reference

AP4_HintTrackReader Class Reference

#include <Ap4HintTrackReader.h>

List of all members.

Public Member Functions

~AP4_HintTrackReader ()
AP4_Result | GetNextPacket (AP4_DataBuffer &packet, AP4_UI32 &ts_ms)
AP4_Result | SeekToTimeStampMs (AP4_UI32 desired_ts_ms, AP4_UI32 &actual_ts_ms)
AP4_UI32 GetCurrentTimeStampMs ()
AP4_Result Rewind ()
AP4_Result | GetSdpText (AP4_String &sdp)
AP4_Track * GetMediaTrack ()

Static Public Member Functions

static AP4_Result | Create (AP4_Track &hint_track, AP4_Movie &movie, AP4_UI32 ssrc, AP4_HintTrackReader *&reader)

Detailed Description

Definition at line 53 of file Ap4HintTrackReader.h.

Constructor & Destructor Documentation

AP4_HintTrackReader::~AP4_HintTrackReader ( )

Member Function Documentation

static AP4_Result AP4_HintTrackReader::Create | ( | AP4_Track & | hint_track,
 |  | AP4_Movie & | movie,
 |  | AP4_UI32 | ssrc,
 |  | AP4_HintTrackReader *& | reader |
 | ) |  |  | [static]
AP4_UI32 AP4_HintTrackReader::GetCurrentTimeStampMs ( )
AP4_Track* AP4_HintTrackReader::GetMediaTrack ( ) [inline]

Definition at line 71 of file Ap4HintTrackReader.h.

AP4_Result AP4_HintTrackReader::GetNextPacket | ( | AP4_DataBuffer & | packet,
 |  | AP4_UI32 & | ts_ms
 | ) |  |
AP4_Result AP4_HintTrackReader::GetSdpText ( AP4_String & sdp )
AP4_Result AP4_HintTrackReader::Rewind ( )
AP4_Result AP4_HintTrackReader::SeekToTimeStampMs | ( | AP4_UI32 | desired_ts_ms,
 |  | AP4_UI32 & | actual_ts_ms
 | ) |  |
The documentation for this class was generated from the following file:
  • Ap4HintTrackReader.h
Generated on Thu May 13 16:37:19 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_HintTrackReader Member List

This is the complete list of members for AP4_HintTrackReader, including all inherited members.
Create(AP4_Track &hint_track, AP4_Movie &movie, AP4_UI32 ssrc, AP4_HintTrackReader *&reader) | AP4_HintTrackReader | [static]
GetCurrentTimeStampMs() | AP4_HintTrackReader |
GetMediaTrack() | AP4_HintTrackReader | [inline]
GetNextPacket(AP4_DataBuffer &packet, AP4_UI32 &ts_ms) | AP4_HintTrackReader |
GetSdpText(AP4_String &sdp) | AP4_HintTrackReader |
Rewind() | AP4_HintTrackReader |
SeekToTimeStampMs(AP4_UI32 desired_ts_ms, AP4_UI32 &actual_ts_ms) | AP4_HintTrackReader |
~AP4_HintTrackReader() | AP4_HintTrackReader |
Generated on Thu May 13 16:37:19 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_Hmac Class Reference

AP4_Hmac Class Reference

#include <Ap4Hmac.h>

List of all members.

Public Types

enum | Algorithm { SHA256 }

Public Member Functions

virtual | ~AP4_Hmac ()
virtual AP4_Result | Update (const AP4_UI08 *data, AP4_Size data_size)=0
virtual AP4_Result | Final (AP4_DataBuffer &mac)=0

Static Public Member Functions

static AP4_Result | Create (Algorithm algorithm, const AP4_UI08 *key, AP4_Size key_size, AP4_Hmac *&hmac)

Detailed Description

Definition at line 42 of file Ap4Hmac.h.

Member Enumeration Documentation

enum AP4_Hmac::Algorithm
Enumerator:
SHA256

Definition at line 46 of file Ap4Hmac.h.

Constructor & Destructor Documentation

virtual AP4_Hmac::~AP4_Hmac ( ) [inline, virtual]

Definition at line 57 of file Ap4Hmac.h.

Member Function Documentation

static AP4_Result AP4_Hmac::Create | ( | Algorithm | algorithm,
 |  | const AP4_UI08 * | key,
 |  | AP4_Size | key_size,
 |  | AP4_Hmac *& | hmac |
 | ) |  |  | [static]
virtual AP4_Result AP4_Hmac::Final ( AP4_DataBuffer & mac ) [pure virtual]
virtual AP4_Result AP4_Hmac::Update | ( | const AP4_UI08 * | data,
 |  | AP4_Size | data_size |
 | ) |  |  | [pure virtual]
The documentation for this class was generated from the following file:
  • Ap4Hmac.h
Generated on Thu May 13 16:37:19 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_Hmac Member List

This is the complete list of members for AP4_Hmac, including all inherited members.
Algorithm enum name | AP4_Hmac |
Create(Algorithm algorithm, const AP4_UI08 *key, AP4_Size key_size, AP4_Hmac *&hmac) | AP4_Hmac | [static]
Final(AP4_DataBuffer &mac)=0 | AP4_Hmac | [pure virtual]
SHA256 enum value | AP4_Hmac |
Update(const AP4_UI08 *data, AP4_Size data_size)=0 | AP4_Hmac | [pure virtual]
~AP4_Hmac() | AP4_Hmac | [inline, virtual]
Generated on Thu May 13 16:37:19 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_HmhdAtom Class Reference

AP4_HmhdAtom Class Reference

#include <Ap4HmhdAtom.h>

Inheritance diagram for AP4_HmhdAtom:
AP4_Atom

List of all members.

Public Member Functions

virtual AP4_Result | InspectFields (AP4_AtomInspector &inspector)
virtual AP4_Result | WriteFields (AP4_ByteStream &stream)

Static Public Member Functions

static AP4_HmhdAtom * | Create (AP4_Size size, AP4_ByteStream &stream)

Detailed Description

Definition at line 46 of file Ap4HmhdAtom.h.

Member Function Documentation

static AP4_HmhdAtom* AP4_HmhdAtom::Create | ( | AP4_Size | size,
 |  | AP4_ByteStream & | stream |
 | ) |  |  | [static]
virtual AP4_Result AP4_HmhdAtom::InspectFields ( AP4_AtomInspector & inspector ) [virtual]

Reimplemented from AP4_Atom.

virtual AP4_Result AP4_HmhdAtom::WriteFields ( AP4_ByteStream & stream ) [virtual]

Implements AP4_Atom.

The documentation for this class was generated from the following file:
  • Ap4HmhdAtom.h
Generated on Thu May 13 16:37:19 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_HmhdAtom Member List

This is the complete list of members for AP4_HmhdAtom, including all inherited members.
AP4_Atom(Type type, AP4_UI32 size=AP4_ATOM_HEADER_SIZE) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64=false) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
Clone() | AP4_Atom | [virtual]
Create(AP4_Size size, AP4_ByteStream &stream) | AP4_HmhdAtom | [static]
Detach() | AP4_Atom | [virtual]
GetFlags() const | AP4_Atom | [inline]
GetHeaderSize() const | AP4_Atom | [virtual]
GetParent() | AP4_Atom | [inline, virtual]
GetSize() const | AP4_Atom | [inline]
GetSize32() const | AP4_Atom | [inline]
GetSize64() const | AP4_Atom | [inline]
GetType() const | AP4_Atom | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
InspectFields(AP4_AtomInspector &inspector) | AP4_HmhdAtom | [virtual]
InspectHeader(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
m_Flags | AP4_Atom | [protected]
m_IsFull | AP4_Atom | [protected]
m_Parent | AP4_Atom | [protected]
m_Size32 | AP4_Atom | [protected]
m_Size64 | AP4_Atom | [protected]
m_Type | AP4_Atom | [protected]
m_Version | AP4_Atom | [protected]
ReadFullHeader(AP4_ByteStream &stream, AP4_UI32 &version, AP4_UI32 &flags) | AP4_Atom | [static]
SetFlags(AP4_UI32 flags) | AP4_Atom | [inline]
SetParent(AP4_AtomParent *parent) | AP4_Atom | [inline, virtual]
SetSize(AP4_UI64 size, bool force_64=false) | AP4_Atom |
SetSize32(AP4_UI32 size) | AP4_Atom | [inline]
SetSize64(AP4_UI64 size) | AP4_Atom | [inline]
SetType(Type type) | AP4_Atom | [inline]
Type typedef | AP4_Atom |
TypeFromString(const char *four_cc) | AP4_Atom | [static]
Write(AP4_ByteStream &stream) | AP4_Atom | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_HmhdAtom | [virtual]
WriteHeader(AP4_ByteStream &stream) | AP4_Atom | [virtual]
~AP4_Atom() | AP4_Atom | [inline, virtual]
Generated on Thu May 13 16:37:19 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_IkmsAtom Class Reference

AP4_IkmsAtom Class Reference

#include <Ap4IkmsAtom.h>

Inheritance diagram for AP4_IkmsAtom:
AP4_Atom

List of all members.

Public Member Functions

AP4_IkmsAtom (const char *kms_uri, AP4_UI32 kms_id=0, AP4_UI32 kms_version=0)
virtual AP4_Atom * | Clone ()
Create a clone of the object.
virtual AP4_Result | InspectFields (AP4_AtomInspector &inspector)
virtual AP4_Result | WriteFields (AP4_ByteStream &stream)
const AP4_String & | GetKmsUri ()
AP4_UI32 GetKmsId ()
AP4_UI32 GetKmsVersion ()

Static Public Member Functions

static AP4_IkmsAtom * | Create (AP4_Size size, AP4_ByteStream &stream)

Detailed Description

Definition at line 42 of file Ap4IkmsAtom.h.

Constructor & Destructor Documentation

AP4_IkmsAtom::AP4_IkmsAtom | ( | const char * | kms_uri,
 |  | AP4_UI32 | kms_id = 0,
 |  | AP4_UI32 | kms_version = 0
 | ) |  |

Member Function Documentation

virtual AP4_Atom* AP4_IkmsAtom::Clone ( ) [virtual]

Create a clone of the object.

This method returns a clone of the atom, or NULL if the atom cannot be cloned. Override this if your want to make an atom cloneable in a more efficient way than the default implementation.

Reimplemented from AP4_Atom.

static AP4_IkmsAtom* AP4_IkmsAtom::Create | ( | AP4_Size | size,
 |  | AP4_ByteStream & | stream |
 | ) |  |  | [static]
AP4_UI32 AP4_IkmsAtom::GetKmsId ( ) [inline]

Definition at line 60 of file Ap4IkmsAtom.h.

const AP4_String& AP4_IkmsAtom::GetKmsUri ( ) [inline]

Definition at line 59 of file Ap4IkmsAtom.h.

AP4_UI32 AP4_IkmsAtom::GetKmsVersion ( ) [inline]

Definition at line 61 of file Ap4IkmsAtom.h.

virtual AP4_Result AP4_IkmsAtom::InspectFields ( AP4_AtomInspector & inspector ) [virtual]

Reimplemented from AP4_Atom.

virtual AP4_Result AP4_IkmsAtom::WriteFields ( AP4_ByteStream & stream ) [virtual]

Implements AP4_Atom.

The documentation for this class was generated from the following file:
  • Ap4IkmsAtom.h
Generated on Thu May 13 16:37:19 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_IkmsAtom Member List

This is the complete list of members for AP4_IkmsAtom, including all inherited members.
AP4_Atom(Type type, AP4_UI32 size=AP4_ATOM_HEADER_SIZE) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64=false) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_IkmsAtom(const char *kms_uri, AP4_UI32 kms_id=0, AP4_UI32 kms_version=0) | AP4_IkmsAtom |
Clone() | AP4_IkmsAtom | [virtual]
Create(AP4_Size size, AP4_ByteStream &stream) | AP4_IkmsAtom | [static]
Detach() | AP4_Atom | [virtual]
GetFlags() const | AP4_Atom | [inline]
GetHeaderSize() const | AP4_Atom | [virtual]
GetKmsId() | AP4_IkmsAtom | [inline]
GetKmsUri() | AP4_IkmsAtom | [inline]
GetKmsVersion() | AP4_IkmsAtom | [inline]
GetParent() | AP4_Atom | [inline, virtual]
GetSize() const | AP4_Atom | [inline]
GetSize32() const | AP4_Atom | [inline]
GetSize64() const | AP4_Atom | [inline]
GetType() const | AP4_Atom | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
InspectFields(AP4_AtomInspector &inspector) | AP4_IkmsAtom | [virtual]
InspectHeader(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
m_Flags | AP4_Atom | [protected]
m_IsFull | AP4_Atom | [protected]
m_Parent | AP4_Atom | [protected]
m_Size32 | AP4_Atom | [protected]
m_Size64 | AP4_Atom | [protected]
m_Type | AP4_Atom | [protected]
m_Version | AP4_Atom | [protected]
ReadFullHeader(AP4_ByteStream &stream, AP4_UI32 &version, AP4_UI32 &flags) | AP4_Atom | [static]
SetFlags(AP4_UI32 flags) | AP4_Atom | [inline]
SetParent(AP4_AtomParent *parent) | AP4_Atom | [inline, virtual]
SetSize(AP4_UI64 size, bool force_64=false) | AP4_Atom |
SetSize32(AP4_UI32 size) | AP4_Atom | [inline]
SetSize64(AP4_UI64 size) | AP4_Atom | [inline]
SetType(Type type) | AP4_Atom | [inline]
Type typedef | AP4_Atom |
TypeFromString(const char *four_cc) | AP4_Atom | [static]
Write(AP4_ByteStream &stream) | AP4_Atom | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_IkmsAtom | [virtual]
WriteHeader(AP4_ByteStream &stream) | AP4_Atom | [virtual]
~AP4_Atom() | AP4_Atom | [inline, virtual]
Generated on Thu May 13 16:37:19 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_ImmediateRtpConstructor Class Reference

AP4_ImmediateRtpConstructor Class Reference

#include <Ap4RtpHint.h>

Inheritance diagram for AP4_ImmediateRtpConstructor:
AP4_RtpConstructor AP4_Referenceable

List of all members.

Public Member Functions

AP4_ImmediateRtpConstructor (AP4_ByteStream &stream)
AP4_ImmediateRtpConstructor (const AP4_DataBuffer &data)
const AP4_DataBuffer & | GetData () const
virtual AP4_Size | GetConstructedDataSize ()

Protected Member Functions

virtual AP4_Result | DoWrite (AP4_ByteStream &stream)

Protected Attributes

AP4_DataBuffer m_Data

Detailed Description

Definition at line 200 of file Ap4RtpHint.h.

Constructor & Destructor Documentation

AP4_ImmediateRtpConstructor::AP4_ImmediateRtpConstructor ( AP4_ByteStream & stream )
AP4_ImmediateRtpConstructor::AP4_ImmediateRtpConstructor ( const AP4_DataBuffer & data )

Member Function Documentation

virtual AP4_Result AP4_ImmediateRtpConstructor::DoWrite ( AP4_ByteStream & stream ) [protected, virtual]

Implements AP4_RtpConstructor.

virtual AP4_Size AP4_ImmediateRtpConstructor::GetConstructedDataSize ( ) [inline, virtual]

Implements AP4_RtpConstructor.

Definition at line 211 of file Ap4RtpHint.h.

References AP4_DataBuffer::GetDataSize(), and m_Data.

const AP4_DataBuffer& AP4_ImmediateRtpConstructor::GetData ( ) const [inline]

Definition at line 208 of file Ap4RtpHint.h.

References m_Data.

Member Data Documentation

AP4_DataBuffer AP4_ImmediateRtpConstructor::m_Data [protected]

Definition at line 218 of file Ap4RtpHint.h.

Referenced by GetConstructedDataSize(), and GetData().

The documentation for this class was generated from the following file:
  • Ap4RtpHint.h
Generated on Thu May 13 16:37:19 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_ImmediateRtpConstructor Member List

This is the complete list of members for AP4_ImmediateRtpConstructor, including all inherited members.
AddReference() | AP4_RtpConstructor | [virtual]
AP4_ImmediateRtpConstructor(AP4_ByteStream &stream) | AP4_ImmediateRtpConstructor |
AP4_ImmediateRtpConstructor(const AP4_DataBuffer &data) | AP4_ImmediateRtpConstructor |
AP4_RtpConstructor(Type type) | AP4_RtpConstructor | [inline]
DoWrite(AP4_ByteStream &stream) | AP4_ImmediateRtpConstructor | [protected, virtual]
GetConstructedDataSize() | AP4_ImmediateRtpConstructor | [inline, virtual]
GetData() const | AP4_ImmediateRtpConstructor | [inline]
GetType() const | AP4_RtpConstructor | [inline]
m_Data | AP4_ImmediateRtpConstructor | [protected]
m_ReferenceCount | AP4_RtpConstructor | [protected]
m_Type | AP4_RtpConstructor | [protected]
Release() | AP4_RtpConstructor | [virtual]
Type typedef | AP4_RtpConstructor |
Write(AP4_ByteStream &stream) | AP4_RtpConstructor |
~AP4_Referenceable() | AP4_Referenceable | [inline, virtual]
~AP4_RtpConstructor() | AP4_RtpConstructor | [inline, protected, virtual]
Generated on Thu May 13 16:37:19 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_InitialObjectDescriptor Class Reference

AP4_InitialObjectDescriptor Class Reference

#include <Ap4ObjectDescriptor.h>

Inheritance diagram for AP4_InitialObjectDescriptor:
AP4_ObjectDescriptor AP4_Descriptor AP4_Expandable

List of all members.

Public Member Functions

AP4_InitialObjectDescriptor (AP4_ByteStream &stream, AP4_UI08 tag, AP4_Size header_size, AP4_Size payload_size)
AP4_InitialObjectDescriptor (AP4_UI08 tag, AP4_UI16 object_descriptor_id, bool include_inline_profile_level, AP4_UI08 od_profile_level_indication, AP4_UI08 scene_profile_level_indication, AP4_UI08 audio_profile_level_indication, AP4_UI08 visual_profile_level_indication, AP4_UI08 graphics_profile_level_indication)
virtual AP4_Result | WriteFields (AP4_ByteStream &stream)
virtual AP4_Result | Inspect (AP4_AtomInspector &inspector)
bool | GetIncludeProfileLevelFlag () const
AP4_UI08 | GetOdProfileLevelIndication () const
AP4_UI08 | GetSceneProfileLevelIndication () const
AP4_UI08 | GetAudioProfileLevelIndication () const
AP4_UI08 | GetVisualProfileLevelIndication () const
AP4_UI08 | GetGraphicsProfileLevelIndication () const

Detailed Description

Definition at line 98 of file Ap4ObjectDescriptor.h.

Constructor & Destructor Documentation

AP4_InitialObjectDescriptor::AP4_InitialObjectDescriptor | ( | AP4_ByteStream & | stream,
 |  | AP4_UI08 | tag,
 |  | AP4_Size | header_size,
 |  | AP4_Size | payload_size
 | ) |  |
AP4_InitialObjectDescriptor::AP4_InitialObjectDescriptor | ( | AP4_UI08 | tag,
 |  | AP4_UI16 | object_descriptor_id,
 |  | bool | include_inline_profile_level,
 |  | AP4_UI08 | od_profile_level_indication,
 |  | AP4_UI08 | scene_profile_level_indication,
 |  | AP4_UI08 | audio_profile_level_indication,
 |  | AP4_UI08 | visual_profile_level_indication,
 |  | AP4_UI08 | graphics_profile_level_indication
 | ) |  |

Member Function Documentation

AP4_UI08 AP4_InitialObjectDescriptor::GetAudioProfileLevelIndication ( ) const [inline]

Definition at line 122 of file Ap4ObjectDescriptor.h.

AP4_UI08 AP4_InitialObjectDescriptor::GetGraphicsProfileLevelIndication ( ) const [inline]

Definition at line 124 of file Ap4ObjectDescriptor.h.

bool AP4_InitialObjectDescriptor::GetIncludeProfileLevelFlag ( ) const [inline]

Definition at line 119 of file Ap4ObjectDescriptor.h.

AP4_UI08 AP4_InitialObjectDescriptor::GetOdProfileLevelIndication ( ) const [inline]

Definition at line 120 of file Ap4ObjectDescriptor.h.

AP4_UI08 AP4_InitialObjectDescriptor::GetSceneProfileLevelIndication ( ) const [inline]

Definition at line 121 of file Ap4ObjectDescriptor.h.

AP4_UI08 AP4_InitialObjectDescriptor::GetVisualProfileLevelIndication ( ) const [inline]

Definition at line 123 of file Ap4ObjectDescriptor.h.

virtual AP4_Result AP4_InitialObjectDescriptor::Inspect ( AP4_AtomInspector & inspector ) [virtual]

Reimplemented from AP4_ObjectDescriptor.

virtual AP4_Result AP4_InitialObjectDescriptor::WriteFields ( AP4_ByteStream & stream ) [virtual]

Reimplemented from AP4_ObjectDescriptor.

The documentation for this class was generated from the following file:
  • Ap4ObjectDescriptor.h
Generated on Thu May 13 16:37:19 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_InitialObjectDescriptor Member List

This is the complete list of members for AP4_InitialObjectDescriptor, including all inherited members.
AddSubDescriptor(AP4_Descriptor *descriptor) | AP4_ObjectDescriptor | [virtual]
AP4_Descriptor(AP4_UI08 tag, AP4_Size header_size, AP4_Size payload_size) | AP4_Descriptor | [inline]
AP4_Expandable(AP4_UI32 class_id, ClassIdSize class_id_size, AP4_Size header_size, AP4_Size payload_size) | AP4_Expandable |
AP4_InitialObjectDescriptor(AP4_ByteStream &stream, AP4_UI08 tag, AP4_Size header_size, AP4_Size payload_size) | AP4_InitialObjectDescriptor |
AP4_InitialObjectDescriptor(AP4_UI08 tag, AP4_UI16 object_descriptor_id, bool include_inline_profile_level, AP4_UI08 od_profile_level_indication, AP4_UI08 scene_profile_level_indication, AP4_UI08 audio_profile_level_indication, AP4_UI08 visual_profile_level_indication, AP4_UI08 graphics_profile_level_indication) | AP4_InitialObjectDescriptor |
AP4_ObjectDescriptor(AP4_ByteStream &stream, AP4_UI08 tag, AP4_Size header_size, AP4_Size payload_size) | AP4_ObjectDescriptor |
AP4_ObjectDescriptor(AP4_UI08 tag, AP4_UI16 id) | AP4_ObjectDescriptor |
AP4_ObjectDescriptor(AP4_UI08 tag, AP4_Size header_size, AP4_Size payload_size) | AP4_ObjectDescriptor | [protected]
CLASS_ID_SIZE_08 enum value | AP4_Expandable |
ClassIdSize enum name | AP4_Expandable |
FindSubDescriptor(AP4_UI08 tag) const | AP4_ObjectDescriptor | [virtual]
GetAudioProfileLevelIndication() const | AP4_InitialObjectDescriptor | [inline]
GetClassId() | AP4_Expandable | [inline]
GetGraphicsProfileLevelIndication() const | AP4_InitialObjectDescriptor | [inline]
GetHeaderSize() | AP4_Expandable | [inline]
GetIncludeProfileLevelFlag() const | AP4_InitialObjectDescriptor | [inline]
GetObjectDescriptorId() const | AP4_ObjectDescriptor | [inline]
GetOdProfileLevelIndication() const | AP4_InitialObjectDescriptor | [inline]
GetSceneProfileLevelIndication() const | AP4_InitialObjectDescriptor | [inline]
GetSize() | AP4_Expandable | [inline]
GetTag() | AP4_Descriptor | [inline]
GetUrl() const | AP4_ObjectDescriptor | [inline]
GetUrlFlag() const | AP4_ObjectDescriptor | [inline]
GetVisualProfileLevelIndication() const | AP4_InitialObjectDescriptor | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_InitialObjectDescriptor | [virtual]
m_ClassId | AP4_Expandable | [protected]
m_ClassIdSize | AP4_Expandable | [protected]
m_HeaderSize | AP4_Expandable | [protected]
m_ObjectDescriptorId | AP4_ObjectDescriptor | [protected]
m_PayloadSize | AP4_Expandable | [protected]
m_SubDescriptors | AP4_ObjectDescriptor | [mutable, protected]
m_Url | AP4_ObjectDescriptor | [protected]
m_UrlFlag | AP4_ObjectDescriptor | [protected]
MinHeaderSize(AP4_Size payload_size) | AP4_Expandable | [static]
Write(AP4_ByteStream &stream) | AP4_Expandable | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_InitialObjectDescriptor | [virtual]
~AP4_Expandable() | AP4_Expandable | [inline, virtual]
~AP4_ObjectDescriptor() | AP4_ObjectDescriptor | [virtual]
Generated on Thu May 13 16:37:19 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_IntegerMetaDataValue Class Reference

AP4_IntegerMetaDataValue Class Reference

#include <Ap4MetaData.h>

Inheritance diagram for AP4_IntegerMetaDataValue:
AP4_MetaData::Value

List of all members.

Public Member Functions

AP4_IntegerMetaDataValue (Type type, long value)
virtual AP4_String | ToString () const
virtual AP4_Result | ToBytes (AP4_DataBuffer &bytes) const
virtual long | ToInteger () const

Detailed Description

Definition at line 522 of file Ap4MetaData.h.

Constructor & Destructor Documentation

AP4_IntegerMetaDataValue::AP4_IntegerMetaDataValue | ( | Type | type,
 |  | long | value |
 | ) |  |  | [inline]

Definition at line 525 of file Ap4MetaData.h.

Member Function Documentation

virtual AP4_Result AP4_IntegerMetaDataValue::ToBytes ( AP4_DataBuffer & bytes ) const [virtual]

Implements AP4_MetaData::Value.

virtual long AP4_IntegerMetaDataValue::ToInteger ( ) const [virtual]

Implements AP4_MetaData::Value.

virtual AP4_String AP4_IntegerMetaDataValue::ToString ( ) const [virtual]

Implements AP4_MetaData::Value.

The documentation for this class was generated from the following file:
  • Ap4MetaData.h
Generated on Thu May 13 16:37:20 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_IntegerMetaDataValue Member List

This is the complete list of members for AP4_IntegerMetaDataValue, including all inherited members.
AP4_IntegerMetaDataValue(Type type, long value) | AP4_IntegerMetaDataValue | [inline]
GetLanguage() const | AP4_MetaData::Value | [inline]
GetMeaning() const | AP4_MetaData::Value | [inline]
GetType() const | AP4_MetaData::Value | [inline]
GetTypeCategory() const | AP4_MetaData::Value |
m_Language | AP4_MetaData::Value | [protected]
m_Meaning | AP4_MetaData::Value | [protected]
m_Type | AP4_MetaData::Value | [protected]
MapTypeToCategory(Type type) | AP4_MetaData::Value | [protected, static]
Meaning enum name | AP4_MetaData::Value |
MEANING_BINARY_ENCODED_CHARS enum value | AP4_MetaData::Value |
MEANING_BOOLEAN enum value | AP4_MetaData::Value |
MEANING_FILE_KIND enum value | AP4_MetaData::Value |
MEANING_ID3_GENRE enum value | AP4_MetaData::Value |
MEANING_UNKNOWN enum value | AP4_MetaData::Value |
SetLanguage(const char *language) | AP4_MetaData::Value | [inline]
ToBytes(AP4_DataBuffer &bytes) const | AP4_IntegerMetaDataValue | [virtual]
ToInteger() const | AP4_IntegerMetaDataValue | [virtual]
ToString() const | AP4_IntegerMetaDataValue | [virtual]
Type enum name | AP4_MetaData::Value |
TYPE_BINARY enum value | AP4_MetaData::Value |
TYPE_CATEGORY_BINARY enum value | AP4_MetaData::Value |
TYPE_CATEGORY_FLOAT enum value | AP4_MetaData::Value |
TYPE_CATEGORY_INTEGER enum value | AP4_MetaData::Value |
TYPE_CATEGORY_STRING enum value | AP4_MetaData::Value |
TYPE_FLOAT_32_BE enum value | AP4_MetaData::Value |
TYPE_FLOAT_64_BE enum value | AP4_MetaData::Value |
TYPE_GIF enum value | AP4_MetaData::Value |
TYPE_INT_08_BE enum value | AP4_MetaData::Value |
TYPE_INT_16_BE enum value | AP4_MetaData::Value |
TYPE_INT_32_BE enum value | AP4_MetaData::Value |
TYPE_JPEG enum value | AP4_MetaData::Value |
TYPE_STRING_PASCAL enum value | AP4_MetaData::Value |
TYPE_STRING_UTF_16 enum value | AP4_MetaData::Value |
TYPE_STRING_UTF_8 enum value | AP4_MetaData::Value |
TypeCategory enum name | AP4_MetaData::Value |
Value(Type type, Meaning meaning=MEANING_UNKNOWN, const char *language=NULL) | AP4_MetaData::Value | [inline, protected]
~Value() | AP4_MetaData::Value | [inline, virtual]
Generated on Thu May 13 16:37:20 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_IodsAtom Class Reference

AP4_IodsAtom Class Reference

#include <Ap4IodsAtom.h>

Inheritance diagram for AP4_IodsAtom:
AP4_Atom

List of all members.

Public Member Functions

AP4_IodsAtom (AP4_ObjectDescriptor *descriptor)
~AP4_IodsAtom ()
virtual AP4_Result | WriteFields (AP4_ByteStream &stream)
virtual AP4_Result | InspectFields (AP4_AtomInspector &inspector)
const AP4_ObjectDescriptor * | GetObjectDescriptor () const

Static Public Member Functions

static AP4_IodsAtom * | Create (AP4_Size size, AP4_ByteStream &stream)

Detailed Description

Definition at line 47 of file Ap4IodsAtom.h.

Constructor & Destructor Documentation

AP4_IodsAtom::AP4_IodsAtom ( AP4_ObjectDescriptor * descriptor )
AP4_IodsAtom::~AP4_IodsAtom ( )

Member Function Documentation

static AP4_IodsAtom* AP4_IodsAtom::Create | ( | AP4_Size | size,
 |  | AP4_ByteStream & | stream |
 | ) |  |  | [static]
const AP4_ObjectDescriptor* AP4_IodsAtom::GetObjectDescriptor ( ) const [inline]

Definition at line 60 of file Ap4IodsAtom.h.

virtual AP4_Result AP4_IodsAtom::InspectFields ( AP4_AtomInspector & inspector ) [virtual]

Reimplemented from AP4_Atom.

virtual AP4_Result AP4_IodsAtom::WriteFields ( AP4_ByteStream & stream ) [virtual]

Implements AP4_Atom.

The documentation for this class was generated from the following file:
  • Ap4IodsAtom.h
Generated on Thu May 13 16:37:20 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_IodsAtom Member List

This is the complete list of members for AP4_IodsAtom, including all inherited members.
AP4_Atom(Type type, AP4_UI32 size=AP4_ATOM_HEADER_SIZE) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64=false) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_IodsAtom(AP4_ObjectDescriptor *descriptor) | AP4_IodsAtom |
Clone() | AP4_Atom | [virtual]
Create(AP4_Size size, AP4_ByteStream &stream) | AP4_IodsAtom | [static]
Detach() | AP4_Atom | [virtual]
GetFlags() const | AP4_Atom | [inline]
GetHeaderSize() const | AP4_Atom | [virtual]
GetObjectDescriptor() const | AP4_IodsAtom | [inline]
GetParent() | AP4_Atom | [inline, virtual]
GetSize() const | AP4_Atom | [inline]
GetSize32() const | AP4_Atom | [inline]
GetSize64() const | AP4_Atom | [inline]
GetType() const | AP4_Atom | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
InspectFields(AP4_AtomInspector &inspector) | AP4_IodsAtom | [virtual]
InspectHeader(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
m_Flags | AP4_Atom | [protected]
m_IsFull | AP4_Atom | [protected]
m_Parent | AP4_Atom | [protected]
m_Size32 | AP4_Atom | [protected]
m_Size64 | AP4_Atom | [protected]
m_Type | AP4_Atom | [protected]
m_Version | AP4_Atom | [protected]
ReadFullHeader(AP4_ByteStream &stream, AP4_UI32 &version, AP4_UI32 &flags) | AP4_Atom | [static]
SetFlags(AP4_UI32 flags) | AP4_Atom | [inline]
SetParent(AP4_AtomParent *parent) | AP4_Atom | [inline, virtual]
SetSize(AP4_UI64 size, bool force_64=false) | AP4_Atom |
SetSize32(AP4_UI32 size) | AP4_Atom | [inline]
SetSize64(AP4_UI64 size) | AP4_Atom | [inline]
SetType(Type type) | AP4_Atom | [inline]
Type typedef | AP4_Atom |
TypeFromString(const char *four_cc) | AP4_Atom | [static]
Write(AP4_ByteStream &stream) | AP4_Atom | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_IodsAtom | [virtual]
WriteHeader(AP4_ByteStream &stream) | AP4_Atom | [virtual]
~AP4_Atom() | AP4_Atom | [inline, virtual]
~AP4_IodsAtom() | AP4_IodsAtom |
Generated on Thu May 13 16:37:20 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_IpmpDescriptor Class Reference

AP4_IpmpDescriptor Class Reference

#include <Ap4Ipmp.h>

Inheritance diagram for AP4_IpmpDescriptor:
AP4_Descriptor AP4_Expandable

List of all members.

Public Member Functions

AP4_IpmpDescriptor (AP4_UI08 descriptor_id, AP4_UI16 ipmps_type)
AP4_IpmpDescriptor (AP4_ByteStream &stream, AP4_Size header_size, AP4_Size payload_size)
virtual AP4_Result | WriteFields (AP4_ByteStream &stream)
virtual AP4_Result | Inspect (AP4_AtomInspector &inspector)
AP4_UI08 | GetDescriptorId () const
AP4_UI16 | GetIpmpsType () const
AP4_UI16 | GetDescriptorIdEx () const
const AP4_UI08 * | GetToolId () const
AP4_UI08 | GetControlPointCode () const
AP4_UI08 | GetSequenceCode () const
const AP4_String & | GetUrl () const
const AP4_DataBuffer & | GetData () const
void | SetData (const unsigned char *data, AP4_Size data_size)

Detailed Description

Definition at line 76 of file Ap4Ipmp.h.

Constructor & Destructor Documentation

AP4_IpmpDescriptor::AP4_IpmpDescriptor | ( | AP4_UI08 | descriptor_id,
 |  | AP4_UI16 | ipmps_type
 | ) |  |
AP4_IpmpDescriptor::AP4_IpmpDescriptor | ( | AP4_ByteStream & | stream,
 |  | AP4_Size | header_size,
 |  | AP4_Size | payload_size
 | ) |  |

Member Function Documentation

AP4_UI08 AP4_IpmpDescriptor::GetControlPointCode ( ) const [inline]

Definition at line 94 of file Ap4Ipmp.h.

const AP4_DataBuffer& AP4_IpmpDescriptor::GetData ( ) const [inline]

Definition at line 97 of file Ap4Ipmp.h.

AP4_UI08 AP4_IpmpDescriptor::GetDescriptorId ( ) const [inline]

Definition at line 90 of file Ap4Ipmp.h.

AP4_UI16 AP4_IpmpDescriptor::GetDescriptorIdEx ( ) const [inline]

Definition at line 92 of file Ap4Ipmp.h.

AP4_UI16 AP4_IpmpDescriptor::GetIpmpsType ( ) const [inline]

Definition at line 91 of file Ap4Ipmp.h.

AP4_UI08 AP4_IpmpDescriptor::GetSequenceCode ( ) const [inline]

Definition at line 95 of file Ap4Ipmp.h.

const AP4_UI08* AP4_IpmpDescriptor::GetToolId ( ) const [inline]

Definition at line 93 of file Ap4Ipmp.h.

const AP4_String& AP4_IpmpDescriptor::GetUrl ( ) const [inline]

Definition at line 96 of file Ap4Ipmp.h.

virtual AP4_Result AP4_IpmpDescriptor::Inspect ( AP4_AtomInspector & inspector ) [virtual]

Reimplemented from AP4_Descriptor.

void AP4_IpmpDescriptor::SetData | ( | const unsigned char * | data,
 |  | AP4_Size | data_size
 | ) |  |
virtual AP4_Result AP4_IpmpDescriptor::WriteFields ( AP4_ByteStream & stream ) [virtual]

Implements AP4_Expandable.

The documentation for this class was generated from the following file:
  • Ap4Ipmp.h
Generated on Thu May 13 16:37:20 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_IpmpDescriptor Member List

This is the complete list of members for AP4_IpmpDescriptor, including all inherited members.
AP4_Descriptor(AP4_UI08 tag, AP4_Size header_size, AP4_Size payload_size) | AP4_Descriptor | [inline]
AP4_Expandable(AP4_UI32 class_id, ClassIdSize class_id_size, AP4_Size header_size, AP4_Size payload_size) | AP4_Expandable |
AP4_IpmpDescriptor(AP4_UI08 descriptor_id, AP4_UI16 ipmps_type) | AP4_IpmpDescriptor |
AP4_IpmpDescriptor(AP4_ByteStream &stream, AP4_Size header_size, AP4_Size payload_size) | AP4_IpmpDescriptor |
CLASS_ID_SIZE_08 enum value | AP4_Expandable |
ClassIdSize enum name | AP4_Expandable |
GetClassId() | AP4_Expandable | [inline]
GetControlPointCode() const | AP4_IpmpDescriptor | [inline]
GetData() const | AP4_IpmpDescriptor | [inline]
GetDescriptorId() const | AP4_IpmpDescriptor | [inline]
GetDescriptorIdEx() const | AP4_IpmpDescriptor | [inline]
GetHeaderSize() | AP4_Expandable | [inline]
GetIpmpsType() const | AP4_IpmpDescriptor | [inline]
GetSequenceCode() const | AP4_IpmpDescriptor | [inline]
GetSize() | AP4_Expandable | [inline]
GetTag() | AP4_Descriptor | [inline]
GetToolId() const | AP4_IpmpDescriptor | [inline]
GetUrl() const | AP4_IpmpDescriptor | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_IpmpDescriptor | [virtual]
m_ClassId | AP4_Expandable | [protected]
m_ClassIdSize | AP4_Expandable | [protected]
m_HeaderSize | AP4_Expandable | [protected]
m_PayloadSize | AP4_Expandable | [protected]
MinHeaderSize(AP4_Size payload_size) | AP4_Expandable | [static]
SetData(const unsigned char *data, AP4_Size data_size) | AP4_IpmpDescriptor |
Write(AP4_ByteStream &stream) | AP4_Expandable | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_IpmpDescriptor | [virtual]
~AP4_Expandable() | AP4_Expandable | [inline, virtual]
Generated on Thu May 13 16:37:20 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_IpmpDescriptorPointer Class Reference

AP4_IpmpDescriptorPointer Class Reference

#include <Ap4Ipmp.h>

Inheritance diagram for AP4_IpmpDescriptorPointer:
AP4_Descriptor AP4_Expandable

List of all members.

Public Member Functions

AP4_IpmpDescriptorPointer (AP4_UI08 descriptor_id)
AP4_IpmpDescriptorPointer (AP4_ByteStream &stream, AP4_Size header_size, AP4_Size payload_size)
virtual AP4_Result | WriteFields (AP4_ByteStream &stream)
virtual AP4_Result | Inspect (AP4_AtomInspector &inspector)
AP4_UI08 | GetDescriptorId () const
AP4_UI16 | GetDescriptorIdEx () const
AP4_UI16 | GetEsId () const

Detailed Description

Definition at line 48 of file Ap4Ipmp.h.

Constructor & Destructor Documentation

AP4_IpmpDescriptorPointer::AP4_IpmpDescriptorPointer ( AP4_UI08 descriptor_id )
AP4_IpmpDescriptorPointer::AP4_IpmpDescriptorPointer | ( | AP4_ByteStream & | stream,
 |  | AP4_Size | header_size,
 |  | AP4_Size | payload_size
 | ) |  |

Member Function Documentation

AP4_UI08 AP4_IpmpDescriptorPointer::GetDescriptorId ( ) const [inline]

Definition at line 62 of file Ap4Ipmp.h.

AP4_UI16 AP4_IpmpDescriptorPointer::GetDescriptorIdEx ( ) const [inline]

Definition at line 63 of file Ap4Ipmp.h.

AP4_UI16 AP4_IpmpDescriptorPointer::GetEsId ( ) const [inline]

Definition at line 64 of file Ap4Ipmp.h.

virtual AP4_Result AP4_IpmpDescriptorPointer::Inspect ( AP4_AtomInspector & inspector ) [virtual]

Reimplemented from AP4_Descriptor.

virtual AP4_Result AP4_IpmpDescriptorPointer::WriteFields ( AP4_ByteStream & stream ) [virtual]

Implements AP4_Expandable.

The documentation for this class was generated from the following file:
  • Ap4Ipmp.h
Generated on Thu May 13 16:37:20 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_IpmpDescriptorPointer Member List

This is the complete list of members for AP4_IpmpDescriptorPointer, including all inherited members.
AP4_Descriptor(AP4_UI08 tag, AP4_Size header_size, AP4_Size payload_size) | AP4_Descriptor | [inline]
AP4_Expandable(AP4_UI32 class_id, ClassIdSize class_id_size, AP4_Size header_size, AP4_Size payload_size) | AP4_Expandable |
AP4_IpmpDescriptorPointer(AP4_UI08 descriptor_id) | AP4_IpmpDescriptorPointer |
AP4_IpmpDescriptorPointer(AP4_ByteStream &stream, AP4_Size header_size, AP4_Size payload_size) | AP4_IpmpDescriptorPointer |
CLASS_ID_SIZE_08 enum value | AP4_Expandable |
ClassIdSize enum name | AP4_Expandable |
GetClassId() | AP4_Expandable | [inline]
GetDescriptorId() const | AP4_IpmpDescriptorPointer | [inline]
GetDescriptorIdEx() const | AP4_IpmpDescriptorPointer | [inline]
GetEsId() const | AP4_IpmpDescriptorPointer | [inline]
GetHeaderSize() | AP4_Expandable | [inline]
GetSize() | AP4_Expandable | [inline]
GetTag() | AP4_Descriptor | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_IpmpDescriptorPointer | [virtual]
m_ClassId | AP4_Expandable | [protected]
m_ClassIdSize | AP4_Expandable | [protected]
m_HeaderSize | AP4_Expandable | [protected]
m_PayloadSize | AP4_Expandable | [protected]
MinHeaderSize(AP4_Size payload_size) | AP4_Expandable | [static]
Write(AP4_ByteStream &stream) | AP4_Expandable | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_IpmpDescriptorPointer | [virtual]
~AP4_Expandable() | AP4_Expandable | [inline, virtual]
Generated on Thu May 13 16:37:20 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_IproAtom Class Reference

AP4_IproAtom Class Reference

#include <Ap4IproAtom.h>

Inheritance diagram for AP4_IproAtom:
AP4_ContainerAtom AP4_Atom AP4_AtomParent

List of all members.

Public Member Functions

virtual AP4_Result | InspectFields (AP4_AtomInspector &inspector)
virtual AP4_Result | WriteFields (AP4_ByteStream &stream)

Static Public Member Functions

static AP4_IproAtom * | Create (AP4_Size size, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory)

Detailed Description

Definition at line 42 of file Ap4IproAtom.h.

Member Function Documentation

static AP4_IproAtom* AP4_IproAtom::Create | ( | AP4_Size | size,
 |  | AP4_ByteStream & | stream,
 |  | AP4_AtomFactory & | atom_factory |
 | ) |  |  | [static]
virtual AP4_Result AP4_IproAtom::InspectFields ( AP4_AtomInspector & inspector ) [virtual]

Reimplemented from AP4_ContainerAtom.

virtual AP4_Result AP4_IproAtom::WriteFields ( AP4_ByteStream & stream ) [virtual]

Reimplemented from AP4_ContainerAtom.

The documentation for this class was generated from the following file:
  • Ap4IproAtom.h
Generated on Thu May 13 16:37:20 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_IproAtom Member List

This is the complete list of members for AP4_IproAtom, including all inherited members.
AddChild(AP4_Atom *child, int position=-1) | AP4_AtomParent | [virtual]
AP4_Atom(Type type, AP4_UI32 size=AP4_ATOM_HEADER_SIZE) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64=false) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_ContainerAtom(Type type) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI32 version, AP4_UI32 flags) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_ContainerAtom | [protected]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_ContainerAtom | [protected]
Clone() | AP4_ContainerAtom | [virtual]
Create(AP4_Size size, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_IproAtom | [static]
AP4_ContainerAtom::Create(Type type, AP4_UI64 size, bool is_full, bool force_64, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_ContainerAtom | [static]
DeleteChild(AP4_Atom::Type type, AP4_Ordinal index=0) | AP4_AtomParent | [virtual]
Detach() | AP4_Atom | [virtual]
FindChild(const char *path, bool auto_create=false, bool auto_create_full=false) | AP4_AtomParent | [virtual]
GetChild(AP4_Atom::Type type, AP4_Ordinal index=0) const | AP4_AtomParent | [virtual]
GetChild(const AP4_UI08 *uuid, AP4_Ordinal index=0) const | AP4_AtomParent | [virtual]
GetChildren() | AP4_ContainerAtom | [inline]
GetFlags() const | AP4_Atom | [inline]
GetHeaderSize() const | AP4_Atom | [virtual]
GetParent() | AP4_Atom | [inline, virtual]
GetSize() const | AP4_Atom | [inline]
GetSize32() const | AP4_Atom | [inline]
GetSize64() const | AP4_Atom | [inline]
GetType() const | AP4_Atom | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
InspectChildren(AP4_AtomInspector &inspector) | AP4_ContainerAtom | [virtual]
InspectFields(AP4_AtomInspector &inspector) | AP4_IproAtom | [virtual]
InspectHeader(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
m_Children | AP4_AtomParent | [protected]
m_Flags | AP4_Atom | [protected]
m_IsFull | AP4_Atom | [protected]
m_Parent | AP4_Atom | [protected]
m_Size32 | AP4_Atom | [protected]
m_Size64 | AP4_Atom | [protected]
m_Type | AP4_Atom | [protected]
m_Version | AP4_Atom | [protected]
OnChildAdded(AP4_Atom *child) | AP4_ContainerAtom | [virtual]
OnChildChanged(AP4_Atom *child) | AP4_ContainerAtom | [virtual]
OnChildRemoved(AP4_Atom *child) | AP4_ContainerAtom | [virtual]
ReadChildren(AP4_AtomFactory &atom_factory, AP4_ByteStream &stream, AP4_UI64 size) | AP4_ContainerAtom | [protected]
ReadFullHeader(AP4_ByteStream &stream, AP4_UI32 &version, AP4_UI32 &flags) | AP4_Atom | [static]
RemoveChild(AP4_Atom *child) | AP4_AtomParent | [virtual]
SetFlags(AP4_UI32 flags) | AP4_Atom | [inline]
SetParent(AP4_AtomParent *parent) | AP4_Atom | [inline, virtual]
SetSize(AP4_UI64 size, bool force_64=false) | AP4_Atom |
SetSize32(AP4_UI32 size) | AP4_Atom | [inline]
SetSize64(AP4_UI64 size) | AP4_Atom | [inline]
SetType(Type type) | AP4_Atom | [inline]
Type typedef | AP4_Atom |
TypeFromString(const char *four_cc) | AP4_Atom | [static]
Write(AP4_ByteStream &stream) | AP4_Atom | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_IproAtom | [virtual]
WriteHeader(AP4_ByteStream &stream) | AP4_Atom | [virtual]
~AP4_Atom() | AP4_Atom | [inline, virtual]
~AP4_AtomParent() | AP4_AtomParent | [virtual]
Generated on Thu May 13 16:37:20 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_IsfmAtom Class Reference

AP4_IsfmAtom Class Reference

#include <Ap4IsfmAtom.h>

Inheritance diagram for AP4_IsfmAtom:
AP4_Atom

List of all members.

Public Member Functions

AP4_IsfmAtom (bool m_SelectiveEncryption, AP4_UI08 m_KeyIndicatorLength, AP4_UI08 m_IvLength)
virtual AP4_Atom * | Clone ()
Create a clone of the object.
virtual AP4_Result | InspectFields (AP4_AtomInspector &inspector)
virtual AP4_Result | WriteFields (AP4_ByteStream &stream)
bool | GetSelectiveEncryption ()
AP4_UI08 GetKeyIndicatorLength ()
AP4_UI08 GetIvLength ()

Static Public Member Functions

static AP4_IsfmAtom * | Create (AP4_Size size, AP4_ByteStream &stream)

Detailed Description

Definition at line 41 of file Ap4IsfmAtom.h.

Constructor & Destructor Documentation

AP4_IsfmAtom::AP4_IsfmAtom | ( | bool | m_SelectiveEncryption,
 |  | AP4_UI08 | m_KeyIndicatorLength,
 |  | AP4_UI08 | m_IvLength
 | ) |  |

Member Function Documentation

virtual AP4_Atom* AP4_IsfmAtom::Clone ( ) [virtual]

Create a clone of the object.

This method returns a clone of the atom, or NULL if the atom cannot be cloned. Override this if your want to make an atom cloneable in a more efficient way than the default implementation.

Reimplemented from AP4_Atom.

static AP4_IsfmAtom* AP4_IsfmAtom::Create | ( | AP4_Size | size,
 |  | AP4_ByteStream & | stream |
 | ) |  |  | [static]
AP4_UI08 AP4_IsfmAtom::GetIvLength ( ) [inline]

Definition at line 60 of file Ap4IsfmAtom.h.

AP4_UI08 AP4_IsfmAtom::GetKeyIndicatorLength ( ) [inline]

Definition at line 59 of file Ap4IsfmAtom.h.

bool AP4_IsfmAtom::GetSelectiveEncryption ( ) [inline]

Definition at line 58 of file Ap4IsfmAtom.h.

virtual AP4_Result AP4_IsfmAtom::InspectFields ( AP4_AtomInspector & inspector ) [virtual]

Reimplemented from AP4_Atom.

virtual AP4_Result AP4_IsfmAtom::WriteFields ( AP4_ByteStream & stream ) [virtual]

Implements AP4_Atom.

The documentation for this class was generated from the following file:
  • Ap4IsfmAtom.h
Generated on Thu May 13 16:37:20 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_IsfmAtom Member List

This is the complete list of members for AP4_IsfmAtom, including all inherited members.
AP4_Atom(Type type, AP4_UI32 size=AP4_ATOM_HEADER_SIZE) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64=false) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_IsfmAtom(bool m_SelectiveEncryption, AP4_UI08 m_KeyIndicatorLength, AP4_UI08 m_IvLength) | AP4_IsfmAtom |
Clone() | AP4_IsfmAtom | [virtual]
Create(AP4_Size size, AP4_ByteStream &stream) | AP4_IsfmAtom | [static]
Detach() | AP4_Atom | [virtual]
GetFlags() const | AP4_Atom | [inline]
GetHeaderSize() const | AP4_Atom | [virtual]
GetIvLength() | AP4_IsfmAtom | [inline]
GetKeyIndicatorLength() | AP4_IsfmAtom | [inline]
GetParent() | AP4_Atom | [inline, virtual]
GetSelectiveEncryption() | AP4_IsfmAtom | [inline]
GetSize() const | AP4_Atom | [inline]
GetSize32() const | AP4_Atom | [inline]
GetSize64() const | AP4_Atom | [inline]
GetType() const | AP4_Atom | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
InspectFields(AP4_AtomInspector &inspector) | AP4_IsfmAtom | [virtual]
InspectHeader(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
m_Flags | AP4_Atom | [protected]
m_IsFull | AP4_Atom | [protected]
m_Parent | AP4_Atom | [protected]
m_Size32 | AP4_Atom | [protected]
m_Size64 | AP4_Atom | [protected]
m_Type | AP4_Atom | [protected]
m_Version | AP4_Atom | [protected]
ReadFullHeader(AP4_ByteStream &stream, AP4_UI32 &version, AP4_UI32 &flags) | AP4_Atom | [static]
SetFlags(AP4_UI32 flags) | AP4_Atom | [inline]
SetParent(AP4_AtomParent *parent) | AP4_Atom | [inline, virtual]
SetSize(AP4_UI64 size, bool force_64=false) | AP4_Atom |
SetSize32(AP4_UI32 size) | AP4_Atom | [inline]
SetSize64(AP4_UI64 size) | AP4_Atom | [inline]
SetType(Type type) | AP4_Atom | [inline]
Type typedef | AP4_Atom |
TypeFromString(const char *four_cc) | AP4_Atom | [static]
Write(AP4_ByteStream &stream) | AP4_Atom | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_IsfmAtom | [virtual]
WriteHeader(AP4_ByteStream &stream) | AP4_Atom | [virtual]
~AP4_Atom() | AP4_Atom | [inline, virtual]
Generated on Thu May 13 16:37:20 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_IsltAtom Class Reference

AP4_IsltAtom Class Reference

#include <Ap4IsltAtom.h>

Inheritance diagram for AP4_IsltAtom:
AP4_Atom

List of all members.

Public Member Functions

AP4_IsltAtom (const AP4_UI08 *salt)
virtual AP4_Result | InspectFields (AP4_AtomInspector &inspector)
virtual AP4_Result | WriteFields (AP4_ByteStream &stream)
const AP4_UI08 * | GetSalt ()

Static Public Member Functions

static AP4_IsltAtom * | Create (AP4_Size size, AP4_ByteStream &stream)

Detailed Description

Definition at line 41 of file Ap4IsltAtom.h.

Constructor & Destructor Documentation

AP4_IsltAtom::AP4_IsltAtom ( const AP4_UI08 * salt )

Referenced by Create().

Member Function Documentation

static AP4_IsltAtom* AP4_IsltAtom::Create | ( | AP4_Size | size,
 |  | AP4_ByteStream & | stream |
 | ) |  |  | [inline, static]

Definition at line 47 of file Ap4IsltAtom.h.

References AP4_ATOM_HEADER_SIZE, and AP4_IsltAtom().

const AP4_UI08* AP4_IsltAtom::GetSalt ( ) [inline]

Definition at line 58 of file Ap4IsltAtom.h.

virtual AP4_Result AP4_IsltAtom::InspectFields ( AP4_AtomInspector & inspector ) [virtual]

Reimplemented from AP4_Atom.

virtual AP4_Result AP4_IsltAtom::WriteFields ( AP4_ByteStream & stream ) [virtual]

Implements AP4_Atom.

The documentation for this class was generated from the following file:
  • Ap4IsltAtom.h
Generated on Thu May 13 16:37:20 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_IsltAtom Member List

This is the complete list of members for AP4_IsltAtom, including all inherited members.
AP4_Atom(Type type, AP4_UI32 size=AP4_ATOM_HEADER_SIZE) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64=false) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_IsltAtom(const AP4_UI08 *salt) | AP4_IsltAtom |
Clone() | AP4_Atom | [virtual]
Create(AP4_Size size, AP4_ByteStream &stream) | AP4_IsltAtom | [inline, static]
Detach() | AP4_Atom | [virtual]
GetFlags() const | AP4_Atom | [inline]
GetHeaderSize() const | AP4_Atom | [virtual]
GetParent() | AP4_Atom | [inline, virtual]
GetSalt() | AP4_IsltAtom | [inline]
GetSize() const | AP4_Atom | [inline]
GetSize32() const | AP4_Atom | [inline]
GetSize64() const | AP4_Atom | [inline]
GetType() const | AP4_Atom | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
InspectFields(AP4_AtomInspector &inspector) | AP4_IsltAtom | [virtual]
InspectHeader(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
m_Flags | AP4_Atom | [protected]
m_IsFull | AP4_Atom | [protected]
m_Parent | AP4_Atom | [protected]
m_Size32 | AP4_Atom | [protected]
m_Size64 | AP4_Atom | [protected]
m_Type | AP4_Atom | [protected]
m_Version | AP4_Atom | [protected]
ReadFullHeader(AP4_ByteStream &stream, AP4_UI32 &version, AP4_UI32 &flags) | AP4_Atom | [static]
SetFlags(AP4_UI32 flags) | AP4_Atom | [inline]
SetParent(AP4_AtomParent *parent) | AP4_Atom | [inline, virtual]
SetSize(AP4_UI64 size, bool force_64=false) | AP4_Atom |
SetSize32(AP4_UI32 size) | AP4_Atom | [inline]
SetSize64(AP4_UI64 size) | AP4_Atom | [inline]
SetType(Type type) | AP4_Atom | [inline]
Type typedef | AP4_Atom |
TypeFromString(const char *four_cc) | AP4_Atom | [static]
Write(AP4_ByteStream &stream) | AP4_Atom | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_IsltAtom | [virtual]
WriteHeader(AP4_ByteStream &stream) | AP4_Atom | [virtual]
~AP4_Atom() | AP4_Atom | [inline, virtual]
Generated on Thu May 13 16:37:20 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_IsmaCipher Class Reference

AP4_IsmaCipher Class Reference

#include <Ap4IsmaCryp.h>

Inheritance diagram for AP4_IsmaCipher:
AP4_SampleDecrypter

List of all members.

Public Member Functions

AP4_IsmaCipher (AP4_BlockCipher *block_cipher, const AP4_UI08 *salt, AP4_UI08 iv_length, AP4_UI08 key_indicator_length, bool selective_encryption)
~AP4_IsmaCipher ()
AP4_Result | EncryptSampleData (AP4_DataBuffer &data_in, AP4_DataBuffer &data_out, AP4_UI32 offset)
AP4_Result | DecryptSampleData (AP4_DataBuffer &data_in, AP4_DataBuffer &data_out, const AP4_UI08 *iv=NULL)
AP4_Size | GetDecryptedSampleSize (AP4_Sample &sample)
AP4_CtrStreamCipher * GetCipher ()
AP4_UI08 GetIvLength ()
AP4_UI08 GetKeyIndicatorLength ()
bool | GetSelectiveEncryption ()

Static Public Member Functions

static AP4_Result | CreateSampleDecrypter (AP4_ProtectedSampleDescription *sample_description, const AP4_UI08 *key, AP4_Size key_size, AP4_BlockCipherFactory *block_cipher_factory, AP4_IsmaCipher *&decrypter)

Detailed Description

Definition at line 57 of file Ap4IsmaCryp.h.

Constructor & Destructor Documentation

AP4_IsmaCipher::AP4_IsmaCipher | ( | AP4_BlockCipher * | block_cipher,
 |  | const AP4_UI08 * | salt,
 |  | AP4_UI08 | iv_length,
 |  | AP4_UI08 | key_indicator_length,
 |  | bool | selective_encryption
 | ) |  |
AP4_IsmaCipher::~AP4_IsmaCipher ( )

Member Function Documentation

static AP4_Result AP4_IsmaCipher::CreateSampleDecrypter | ( | AP4_ProtectedSampleDescription * | sample_description,
 |  | const AP4_UI08 * | key,
 |  | AP4_Size | key_size,
 |  | AP4_BlockCipherFactory * | block_cipher_factory,
 |  | AP4_IsmaCipher *& | decrypter |
 | ) |  |  | [static]
AP4_Result AP4_IsmaCipher::DecryptSampleData | ( | AP4_DataBuffer & | data_in,
 |  | AP4_DataBuffer & | data_out,
 |  | const AP4_UI08 * | iv = NULL |
 | ) |  |  | [virtual]

Implements AP4_SampleDecrypter.

AP4_Result AP4_IsmaCipher::EncryptSampleData | ( | AP4_DataBuffer & | data_in,
 |  | AP4_DataBuffer & | data_out,
 |  | AP4_UI32 | offset
 | ) |  |
AP4_CtrStreamCipher* AP4_IsmaCipher::GetCipher ( ) [inline]

Definition at line 81 of file Ap4IsmaCryp.h.

AP4_Size AP4_IsmaCipher::GetDecryptedSampleSize ( AP4_Sample & sample ) [virtual]

Reimplemented from AP4_SampleDecrypter.

AP4_UI08 AP4_IsmaCipher::GetIvLength ( ) [inline]

Definition at line 82 of file Ap4IsmaCryp.h.

AP4_UI08 AP4_IsmaCipher::GetKeyIndicatorLength ( ) [inline]

Definition at line 83 of file Ap4IsmaCryp.h.

bool AP4_IsmaCipher::GetSelectiveEncryption ( ) [inline]

Definition at line 84 of file Ap4IsmaCryp.h.

The documentation for this class was generated from the following file:
  • Ap4IsmaCryp.h
Generated on Thu May 13 16:37:20 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_IsmaCipher Member List

This is the complete list of members for AP4_IsmaCipher, including all inherited members.
AP4_IsmaCipher(AP4_BlockCipher *block_cipher, const AP4_UI08 *salt, AP4_UI08 iv_length, AP4_UI08 key_indicator_length, bool selective_encryption) | AP4_IsmaCipher |
Create(AP4_ProtectedSampleDescription *sample_description, const AP4_UI08 *key, AP4_Size key_size, AP4_BlockCipherFactory *block_cipher_factory=NULL) | AP4_SampleDecrypter | [static]
Create(AP4_ProtectedSampleDescription *sample_description, AP4_ContainerAtom *traf, const AP4_UI08 *key, AP4_Size key_size, AP4_BlockCipherFactory *block_cipher_factory=NULL) | AP4_SampleDecrypter | [static]
CreateSampleDecrypter(AP4_ProtectedSampleDescription *sample_description, const AP4_UI08 *key, AP4_Size key_size, AP4_BlockCipherFactory *block_cipher_factory, AP4_IsmaCipher *&decrypter) | AP4_IsmaCipher | [static]
DecryptSampleData(AP4_DataBuffer &data_in, AP4_DataBuffer &data_out, const AP4_UI08 *iv=NULL) | AP4_IsmaCipher | [virtual]
EncryptSampleData(AP4_DataBuffer &data_in, AP4_DataBuffer &data_out, AP4_UI32 offset) | AP4_IsmaCipher |
GetCipher() | AP4_IsmaCipher | [inline]
GetDecryptedSampleSize(AP4_Sample &sample) | AP4_IsmaCipher | [virtual]
GetIvLength() | AP4_IsmaCipher | [inline]
GetKeyIndicatorLength() | AP4_IsmaCipher | [inline]
GetSelectiveEncryption() | AP4_IsmaCipher | [inline]
SetSampleIndex(AP4_Ordinal) | AP4_SampleDecrypter | [inline, virtual]
~AP4_IsmaCipher() | AP4_IsmaCipher |
~AP4_SampleDecrypter() | AP4_SampleDecrypter | [inline, virtual]
Generated on Thu May 13 16:37:20 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_IsmaEncryptingProcessor Class Reference

AP4_IsmaEncryptingProcessor Class Reference

#include <Ap4IsmaCryp.h>

Inheritance diagram for AP4_IsmaEncryptingProcessor:
AP4_Processor

List of all members.

Public Member Functions

AP4_IsmaEncryptingProcessor (const char *kms_uri, AP4_BlockCipherFactory *block_cipher_factory=NULL)
AP4_ProtectionKeyMap & GetKeyMap ()
virtual
AP4_Processor::TrackHandler * 		CreateTrackHandler (AP4_TrakAtom *trak)
This method can be overridden by concrete subclasses.

Detailed Description

Definition at line 130 of file Ap4IsmaCryp.h.

Constructor & Destructor Documentation

AP4_IsmaEncryptingProcessor::AP4_IsmaEncryptingProcessor | ( | const char * | kms_uri,
 |  | AP4_BlockCipherFactory * | block_cipher_factory = NULL
 | ) |  |

Member Function Documentation

virtual AP4_Processor::TrackHandler* AP4_IsmaEncryptingProcessor::CreateTrackHandler ( AP4_TrakAtom * ) [virtual]

This method can be overridden by concrete subclasses.

It is called once for each track in the input file.

Parameters:
track Pointer to the track for which a handler should be created.
Returns:
A pointer to a track handler, or NULL if no handler needs to be created for that track.

Reimplemented from AP4_Processor.

AP4_ProtectionKeyMap& AP4_IsmaEncryptingProcessor::GetKeyMap ( ) [inline]

Definition at line 138 of file Ap4IsmaCryp.h.

The documentation for this class was generated from the following file:
  • Ap4IsmaCryp.h
Generated on Thu May 13 16:37:21 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_IsmaEncryptingProcessor Member List

This is the complete list of members for AP4_IsmaEncryptingProcessor, including all inherited members.
AP4_IsmaEncryptingProcessor(const char *kms_uri, AP4_BlockCipherFactory *block_cipher_factory=NULL) | AP4_IsmaEncryptingProcessor |
CreateFragmentHandler(AP4_ContainerAtom *) | AP4_Processor | [inline, virtual]
CreateTrackHandler(AP4_TrakAtom *trak) | AP4_IsmaEncryptingProcessor | [virtual]
Finalize(AP4_AtomParent &top_level, ProgressListener *listener=NULL) | AP4_Processor | [virtual]
GetKeyMap() | AP4_IsmaEncryptingProcessor | [inline]
Initialize(AP4_AtomParent &top_level, AP4_ByteStream &stream, ProgressListener *listener=NULL) | AP4_Processor | [virtual]
m_ExternalTrackData | AP4_Processor | [protected]
Process(AP4_ByteStream &input, AP4_ByteStream &output, ProgressListener *listener=NULL, AP4_AtomFactory &atom_factory=AP4_DefaultAtomFactory::Instance) | AP4_Processor |
ProcessFragments(AP4_MoovAtom *moov, AP4_List< AP4_MoofLocator > &moofs, AP4_ContainerAtom *mfra, AP4_ByteStream &input, AP4_ByteStream &output) | AP4_Processor | [protected]
~AP4_Processor() | AP4_Processor | [inline, virtual]
Generated on Thu May 13 16:37:21 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_IsmaTrackDecrypter Class Reference

AP4_IsmaTrackDecrypter Class Reference

#include <Ap4IsmaCryp.h>

Inheritance diagram for AP4_IsmaTrackDecrypter:
AP4_Processor::TrackHandler

List of all members.

Public Member Functions

virtual | ~AP4_IsmaTrackDecrypter ()
virtual AP4_Size | GetProcessedSampleSize (AP4_Sample &sample)
Returns the size of a sample after processing.
virtual AP4_Result | ProcessTrack ()
A track handler may override this method if it needs to modify the track atoms before processing the track samples.
virtual AP4_Result | ProcessSample (AP4_DataBuffer &data_in, AP4_DataBuffer &data_out)
Process the data of one sample.

Static Public Member Functions

static AP4_Result | Create (const AP4_UI08 *key, AP4_Size key_size, AP4_ProtectedSampleDescription *sample_description, AP4_SampleEntry *sample_entry, AP4_BlockCipherFactory *block_cipher_factory, AP4_IsmaTrackDecrypter *&decrypter)

Detailed Description

Definition at line 97 of file Ap4IsmaCryp.h.

Constructor & Destructor Documentation

virtual AP4_IsmaTrackDecrypter::~AP4_IsmaTrackDecrypter ( ) [virtual]

Member Function Documentation

static AP4_Result AP4_IsmaTrackDecrypter::Create | ( | const AP4_UI08 * | key,
 |  | AP4_Size | key_size,
 |  | AP4_ProtectedSampleDescription * | sample_description,
 |  | AP4_SampleEntry * | sample_entry,
 |  | AP4_BlockCipherFactory * | block_cipher_factory,
 |  | AP4_IsmaTrackDecrypter *& | decrypter |
 | ) |  |  | [static]
virtual AP4_Size AP4_IsmaTrackDecrypter::GetProcessedSampleSize ( AP4_Sample & sample ) [virtual]

Returns the size of a sample after processing.

Parameters:
sample Sample of which the processed size is requested.
Returns:
Size of the sample data after processing.

Reimplemented from AP4_Processor::TrackHandler.

virtual AP4_Result AP4_IsmaTrackDecrypter::ProcessSample | ( | AP4_DataBuffer & | data_in,
 |  | AP4_DataBuffer & | data_out |
 | ) |  |  | [virtual]

Process the data of one sample.

Parameters:
data_in | Data buffer with the data of the sample to process.
data_out | Data buffer in which the processed sample data is returned.

Implements AP4_Processor::TrackHandler.

virtual AP4_Result AP4_IsmaTrackDecrypter::ProcessTrack ( ) [virtual]

A track handler may override this method if it needs to modify the track atoms before processing the track samples.

Reimplemented from AP4_Processor::TrackHandler.

The documentation for this class was generated from the following file:
  • Ap4IsmaCryp.h
Generated on Thu May 13 16:37:21 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_IsmaTrackDecrypter Member List

This is the complete list of members for AP4_IsmaTrackDecrypter, including all inherited members.
Create(const AP4_UI08 *key, AP4_Size key_size, AP4_ProtectedSampleDescription *sample_description, AP4_SampleEntry *sample_entry, AP4_BlockCipherFactory *block_cipher_factory, AP4_IsmaTrackDecrypter *&decrypter) | AP4_IsmaTrackDecrypter | [static]
GetProcessedSampleSize(AP4_Sample &sample) | AP4_IsmaTrackDecrypter | [virtual]
ProcessSample(AP4_DataBuffer &data_in, AP4_DataBuffer &data_out) | AP4_IsmaTrackDecrypter | [virtual]
ProcessTrack() | AP4_IsmaTrackDecrypter | [virtual]
~AP4_IsmaTrackDecrypter() | AP4_IsmaTrackDecrypter | [virtual]
~TrackHandler() | AP4_Processor::TrackHandler | [inline, virtual]
Generated on Thu May 13 16:37:21 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_LinearReader Class Reference

AP4_LinearReader Class Reference

#include <Ap4LinearReader.h>

List of all members.

Classes

class | SampleBuffer
class | Tracker

Public Member Functions

AP4_LinearReader (AP4_Movie &movie, AP4_Size max_buffer=AP4_LINEAR_READER_DEFAULT_BUFFER_SIZE)
~AP4_LinearReader ()
AP4_Result | EnableTrack (AP4_UI32 track_id)
AP4_Result | ReadNextSample (AP4_Sample &sample, AP4_DataBuffer &sample_data, AP4_UI32 &track_id)
Read the next sample in storage order, from any track.
AP4_Result | ReadNextSample (AP4_UI32 track_id, AP4_Sample &sample, AP4_DataBuffer &sample_data)
Read the next sample in storage order from a specific track.
AP4_Result | SetSampleIndex (AP4_UI32 track_id, AP4_UI32 sample_index)
AP4_Size GetBufferFullness ()

Detailed Description

Definition at line 56 of file Ap4LinearReader.h.

Constructor & Destructor Documentation

AP4_LinearReader::AP4_LinearReader | ( | AP4_Movie & | movie,
 |  | AP4_Size | max_buffer = AP4_LINEAR_READER_DEFAULT_BUFFER_SIZE
 | ) |  |
AP4_LinearReader::~AP4_LinearReader ( )

Member Function Documentation

AP4_Result AP4_LinearReader::EnableTrack ( AP4_UI32 track_id )
AP4_Size AP4_LinearReader::GetBufferFullness ( ) [inline]

Definition at line 79 of file Ap4LinearReader.h.

AP4_Result AP4_LinearReader::ReadNextSample | ( | AP4_UI32 | track_id,
 |  | AP4_Sample & | sample,
 |  | AP4_DataBuffer & | sample_data
 | ) |  |

Read the next sample in storage order from a specific track.

AP4_Result AP4_LinearReader::ReadNextSample | ( | AP4_Sample & | sample,
 |  | AP4_DataBuffer & | sample_data,
 |  | AP4_UI32 & | track_id
 | ) |  |

Read the next sample in storage order, from any track.

track_id is updated to reflect the track from which the sample was read.

AP4_Result AP4_LinearReader::SetSampleIndex | ( | AP4_UI32 | track_id,
 |  | AP4_UI32 | sample_index
 | ) |  |
The documentation for this class was generated from the following file:
  • Ap4LinearReader.h
Generated on Thu May 13 16:37:21 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_LinearReader Member List

This is the complete list of members for AP4_LinearReader, including all inherited members.
AP4_LinearReader(AP4_Movie &movie, AP4_Size max_buffer=AP4_LINEAR_READER_DEFAULT_BUFFER_SIZE) | AP4_LinearReader |
EnableTrack(AP4_UI32 track_id) | AP4_LinearReader |
GetBufferFullness() | AP4_LinearReader | [inline]
ReadNextSample(AP4_Sample &sample, AP4_DataBuffer &sample_data, AP4_UI32 &track_id) | AP4_LinearReader |
ReadNextSample(AP4_UI32 track_id, AP4_Sample &sample, AP4_DataBuffer &sample_data) | AP4_LinearReader |
SetSampleIndex(AP4_UI32 track_id, AP4_UI32 sample_index) | AP4_LinearReader |
~AP4_LinearReader() | AP4_LinearReader |
Generated on Thu May 13 16:37:21 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_List< T > Class Template Reference

AP4_List< T > Class Template Reference

#include <Ap4List.h>

List of all members.

Classes

class | Item

Public Member Functions

AP4_List ()
virtual | ~AP4_List ()
AP4_Result Clear ()
AP4_Result | Add (T *data)
AP4_Result | Add (Item *item)
AP4_Result | Remove (T *data)
AP4_Result | Insert (Item *where, T *data)
AP4_Result | Get (AP4_Ordinal idx, T *&data) const
AP4_Result | PopHead (T *&data)
AP4_Result | Apply (const typename Item::Operator &op) const
AP4_Result | ApplyUntilFailure (const typename Item::Operator &op) const
AP4_Result | ApplyUntilSuccess (const typename Item::Operator &op) const
AP4_Result | ReverseApply (const typename Item::Operator &op) const
AP4_Result | Find (const typename Item::Finder &finder, T *&data) const
AP4_Result | ReverseFind (const typename Item::Finder &finder, T *&data) const
AP4_Result DeleteReferences ()
AP4_Cardinal | ItemCount () const
Item * | FirstItem () const
Item * | LastItem () const

Protected Attributes

AP4_Cardinal m_ItemCount
Item * m_Head
Item * m_Tail

Detailed Description

template<typename T>
class AP4_List< T >

Definition at line 47 of file Ap4List.h.

Constructor & Destructor Documentation

template<typename T>
AP4_List< T >::AP4_List ( ) [inline]
template<typename T >
AP4_List< T >::~AP4_List ( ) [inline, virtual]

Definition at line 125 of file Ap4List.h.

References AP4_List< T >::Clear().

Member Function Documentation

template<typename T>
AP4_Result AP4_List< T >::Add ( Item * item ) [inline]

Definition at line 167 of file Ap4List.h.

References AP4_SUCCESS, AP4_List< T >::m_Head, AP4_List< T >::m_ItemCount, and AP4_List< T >::m_Tail.

template<typename T>
AP4_Result AP4_List< T >::Add ( T * data ) [inline]

Definition at line 157 of file Ap4List.h.

Referenced by AP4_List< T >::Insert().

template<typename T >
AP4_Result AP4_List< T >::Apply ( const typename Item::Operator & op ) const [inline]

Definition at line 337 of file Ap4List.h.

References AP4_List< T >::Item::Operator::Action(), AP4_SUCCESS, and AP4_List< T >::m_Head.

template<typename T >
AP4_Result AP4_List< T >::ApplyUntilFailure ( const typename Item::Operator & op ) const [inline]

Definition at line 355 of file Ap4List.h.

References AP4_List< T >::Item::Operator::Action(), AP4_SUCCESS, and AP4_List< T >::m_Head.

template<typename T >
AP4_Result AP4_List< T >::ApplyUntilSuccess ( const typename Item::Operator & op ) const [inline]

Definition at line 375 of file Ap4List.h.

References AP4_List< T >::Item::Operator::Action(), AP4_FAILURE, AP4_SUCCESS, and AP4_List< T >::m_Head.

template<typename T >
AP4_Result AP4_List< T >::Clear ( ) [inline]

Definition at line 136 of file Ap4List.h.

References AP4_SUCCESS, AP4_List< T >::m_Head, AP4_List< T >::m_ItemCount, and AP4_List< T >::m_Tail.

Referenced by AP4_List< T >::~AP4_List().

template<typename T >
AP4_Result AP4_List< T >::DeleteReferences ( ) [inline]

Definition at line 459 of file Ap4List.h.

References AP4_SUCCESS, AP4_List< T >::m_Head, AP4_List< T >::m_ItemCount, and AP4_List< T >::m_Tail.

Referenced by AP4_Processor::~AP4_Processor().

template<typename T>
AP4_Result AP4_List< T >::Find | ( | const typename Item::Finder & | finder,
 |  | T *& | data |
 | ) |  |  | const [inline]

Definition at line 415 of file Ap4List.h.

References AP4_ERROR_NO_SUCH_ITEM, AP4_SUCCESS, AP4_List< T >::m_Head, and AP4_List< T >::Item::Finder::Test().

template<typename T>
Item* AP4_List< T >::FirstItem ( ) const [inline]

Definition at line 106 of file Ap4List.h.

template<typename T>
AP4_Result AP4_List< T >::Get | ( | AP4_Ordinal | idx,
 |  | T *& | data |
 | ) |  |  | const [inline]

Definition at line 286 of file Ap4List.h.

References AP4_ERROR_NO_SUCH_ITEM, AP4_SUCCESS, AP4_List< T >::m_Head, and AP4_List< T >::m_ItemCount.

template<typename T>
AP4_Result AP4_List< T >::Insert | ( | Item * | where,
 |  | T * | data |
 | ) |  |  | [inline]

Definition at line 242 of file Ap4List.h.

References AP4_List< T >::Add(), AP4_SUCCESS, AP4_List< T >::m_Head, AP4_List< T >::m_ItemCount, and AP4_List< T >::m_Tail.

template<typename T>
AP4_Cardinal AP4_List< T >::ItemCount ( ) const [inline]

Definition at line 105 of file Ap4List.h.

template<typename T>
Item* AP4_List< T >::LastItem ( ) const [inline]

Definition at line 107 of file Ap4List.h.

template<typename T>
AP4_Result AP4_List< T >::PopHead ( T *& data ) [inline]

Definition at line 305 of file Ap4List.h.

References AP4_ERROR_LIST_EMPTY, AP4_SUCCESS, AP4_List< T >::m_Head, AP4_List< T >::m_ItemCount, and AP4_List< T >::m_Tail.

template<typename T>
AP4_Result AP4_List< T >::Remove ( T * data ) [inline]

Definition at line 193 of file Ap4List.h.

References AP4_ERROR_NO_SUCH_ITEM, AP4_SUCCESS, AP4_List< T >::m_Head, AP4_List< T >::m_ItemCount, and AP4_List< T >::m_Tail.

template<typename T >
AP4_Result AP4_List< T >::ReverseApply ( const typename Item::Operator & op ) const [inline]

Definition at line 395 of file Ap4List.h.

References AP4_List< T >::Item::Operator::Action(), AP4_ERROR_LIST_OPERATION_ABORTED, AP4_SUCCESS, and AP4_List< T >::m_Tail.

template<typename T>
AP4_Result AP4_List< T >::ReverseFind | ( | const typename Item::Finder & | finder,
 |  | T *& | data |
 | ) |  |  | const [inline]

Definition at line 437 of file Ap4List.h.

References AP4_ERROR_NO_SUCH_ITEM, AP4_SUCCESS, AP4_List< T >::m_Tail, and AP4_List< T >::Item::Finder::Test().

Member Data Documentation

template<typename T>
Item* AP4_List< T >::m_Head [protected]

Definition at line 112 of file Ap4List.h.

Referenced by AP4_List< T >::Add(), AP4_List< T >::Apply(), AP4_List< T >::ApplyUntilFailure(), AP4_List< T >::ApplyUntilSuccess(), AP4_List< T >::Clear(), AP4_List< T >::DeleteReferences(), AP4_List< T >::Find(), AP4_List< AP4_RtpPacket >::FirstItem(), AP4_List< T >::Get(), AP4_List< T >::Insert(), AP4_List< T >::PopHead(), and AP4_List< T >::Remove().

template<typename T>
AP4_Cardinal AP4_List< T >::m_ItemCount [protected]

Definition at line 111 of file Ap4List.h.

Referenced by AP4_List< T >::Add(), AP4_List< T >::Clear(), AP4_List< T >::DeleteReferences(), AP4_List< T >::Get(), AP4_List< T >::Insert(), AP4_List< AP4_RtpPacket >::ItemCount(), AP4_List< T >::PopHead(), and AP4_List< T >::Remove().

template<typename T>
Item* AP4_List< T >::m_Tail [protected]

Definition at line 113 of file Ap4List.h.

Referenced by AP4_List< T >::Add(), AP4_List< T >::Clear(), AP4_List< T >::DeleteReferences(), AP4_List< T >::Insert(), AP4_List< AP4_RtpPacket >::LastItem(), AP4_List< T >::PopHead(), AP4_List< T >::Remove(), AP4_List< T >::ReverseApply(), and AP4_List< T >::ReverseFind().

The documentation for this class was generated from the following file:
  • Ap4List.h
Generated on Thu May 13 16:37:21 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_List< T > Member List

This is the complete list of members for AP4_List< T >, including all inherited members.
Add(T *data) | AP4_List< T > | [inline]
Add(Item *item) | AP4_List< T > | [inline]
AP4_List() | AP4_List< T > | [inline]
Apply(const typename Item::Operator &op) const | AP4_List< T > | [inline]
ApplyUntilFailure(const typename Item::Operator &op) const | AP4_List< T > | [inline]
ApplyUntilSuccess(const typename Item::Operator &op) const | AP4_List< T > | [inline]
Clear() | AP4_List< T > | [inline]
DeleteReferences() | AP4_List< T > | [inline]
Find(const typename Item::Finder &finder, T *&data) const | AP4_List< T > | [inline]
FirstItem() const | AP4_List< T > | [inline]
Get(AP4_Ordinal idx, T *&data) const | AP4_List< T > | [inline]
Insert(Item *where, T *data) | AP4_List< T > | [inline]
ItemCount() const | AP4_List< T > | [inline]
LastItem() const | AP4_List< T > | [inline]
m_Head | AP4_List< T > | [protected]
m_ItemCount | AP4_List< T > | [protected]
m_Tail | AP4_List< T > | [protected]
PopHead(T *&data) | AP4_List< T > | [inline]
Remove(T *data) | AP4_List< T > | [inline]
ReverseApply(const typename Item::Operator &op) const | AP4_List< T > | [inline]
ReverseFind(const typename Item::Finder &finder, T *&data) const | AP4_List< T > | [inline]
~AP4_List() | AP4_List< T > | [inline, virtual]
Generated on Thu May 13 16:37:21 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_MarlinIpmpDecryptingProcessor Class Reference

AP4_MarlinIpmpDecryptingProcessor Class Reference

#include <Ap4Marlin.h>

Inheritance diagram for AP4_MarlinIpmpDecryptingProcessor:
AP4_Processor

List of all members.

Public Member Functions

AP4_MarlinIpmpDecryptingProcessor (const AP4_ProtectionKeyMap *key_map=NULL, AP4_BlockCipherFactory *block_cipher_factory=NULL)
~AP4_MarlinIpmpDecryptingProcessor ()
AP4_ProtectionKeyMap & GetKeyMap ()
virtual AP4_Result Initialize (AP4_AtomParent &top_level, AP4_ByteStream &stream, ProgressListener *listener)
This method can be overridden by concrete subclasses.
virtual
AP4_Processor::TrackHandler * 		CreateTrackHandler (AP4_TrakAtom *trak)
This method can be overridden by concrete subclasses.

Detailed Description

Definition at line 92 of file Ap4Marlin.h.

Constructor & Destructor Documentation

AP4_MarlinIpmpDecryptingProcessor::AP4_MarlinIpmpDecryptingProcessor | ( | const AP4_ProtectionKeyMap * | key_map = NULL,
 |  | AP4_BlockCipherFactory * | block_cipher_factory = NULL
 | ) |  |
AP4_MarlinIpmpDecryptingProcessor::~AP4_MarlinIpmpDecryptingProcessor ( )

Member Function Documentation

virtual AP4_Processor::TrackHandler* AP4_MarlinIpmpDecryptingProcessor::CreateTrackHandler ( AP4_TrakAtom * ) [virtual]

This method can be overridden by concrete subclasses.

It is called once for each track in the input file.

Parameters:
track Pointer to the track for which a handler should be created.
Returns:
A pointer to a track handler, or NULL if no handler needs to be created for that track.

Reimplemented from AP4_Processor.

AP4_ProtectionKeyMap& AP4_MarlinIpmpDecryptingProcessor::GetKeyMap ( ) [inline]

Definition at line 101 of file Ap4Marlin.h.

virtual AP4_Result AP4_MarlinIpmpDecryptingProcessor::Initialize | ( | AP4_AtomParent & | top_level,
 |  | AP4_ByteStream & | stream,
 |  | ProgressListener * | listener |
 | ) |  |  | [virtual]

This method can be overridden by concrete subclasses.

It is called just after the input stream has been parsed into an atom tree, before the processing of the tracks.

Parameters:
top_level Container atom containing all the atoms parsed from the input stream. Note that this atom does not actually exist in the file; it is a synthetised container created for the purpose of holding together all the input's top-level atoms.

Reimplemented from AP4_Processor.

The documentation for this class was generated from the following file:
  • Ap4Marlin.h
Generated on Thu May 13 16:37:21 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_MarlinIpmpDecryptingProcessor Member List

This is the complete list of members for AP4_MarlinIpmpDecryptingProcessor, including all inherited members.
AP4_MarlinIpmpDecryptingProcessor(const AP4_ProtectionKeyMap *key_map=NULL, AP4_BlockCipherFactory *block_cipher_factory=NULL) | AP4_MarlinIpmpDecryptingProcessor |
CreateFragmentHandler(AP4_ContainerAtom *) | AP4_Processor | [inline, virtual]
CreateTrackHandler(AP4_TrakAtom *trak) | AP4_MarlinIpmpDecryptingProcessor | [virtual]
Finalize(AP4_AtomParent &top_level, ProgressListener *listener=NULL) | AP4_Processor | [virtual]
GetKeyMap() | AP4_MarlinIpmpDecryptingProcessor | [inline]
Initialize(AP4_AtomParent &top_level, AP4_ByteStream &stream, ProgressListener *listener) | AP4_MarlinIpmpDecryptingProcessor | [virtual]
m_ExternalTrackData | AP4_Processor | [protected]
Process(AP4_ByteStream &input, AP4_ByteStream &output, ProgressListener *listener=NULL, AP4_AtomFactory &atom_factory=AP4_DefaultAtomFactory::Instance) | AP4_Processor |
ProcessFragments(AP4_MoovAtom *moov, AP4_List< AP4_MoofLocator > &moofs, AP4_ContainerAtom *mfra, AP4_ByteStream &input, AP4_ByteStream &output) | AP4_Processor | [protected]
~AP4_MarlinIpmpDecryptingProcessor() | AP4_MarlinIpmpDecryptingProcessor |
~AP4_Processor() | AP4_Processor | [inline, virtual]
Generated on Thu May 13 16:37:21 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_MarlinIpmpEncryptingProcessor Class Reference

AP4_MarlinIpmpEncryptingProcessor Class Reference

#include <Ap4Marlin.h>

Inheritance diagram for AP4_MarlinIpmpEncryptingProcessor:
AP4_Processor

List of all members.

Public Member Functions

AP4_MarlinIpmpEncryptingProcessor (bool use_group_key=false, const AP4_ProtectionKeyMap *key_map=NULL, AP4_BlockCipherFactory *block_cipher_factory=NULL)
AP4_ProtectionKeyMap & GetKeyMap ()
AP4_TrackPropertyMap & GetPropertyMap ()
virtual AP4_Result Initialize (AP4_AtomParent &top_level, AP4_ByteStream &stream, AP4_Processor::ProgressListener *listener=NULL)
This method can be overridden by concrete subclasses.
virtual
AP4_Processor::TrackHandler * 		CreateTrackHandler (AP4_TrakAtom *trak)
This method can be overridden by concrete subclasses.

Detailed Description

Definition at line 148 of file Ap4Marlin.h.

Constructor & Destructor Documentation

AP4_MarlinIpmpEncryptingProcessor::AP4_MarlinIpmpEncryptingProcessor | ( | bool | use_group_key = false,
 |  | const AP4_ProtectionKeyMap * | key_map = NULL,
 |  | AP4_BlockCipherFactory * | block_cipher_factory = NULL
 | ) |  |

Member Function Documentation

virtual AP4_Processor::TrackHandler* AP4_MarlinIpmpEncryptingProcessor::CreateTrackHandler ( AP4_TrakAtom * ) [virtual]

This method can be overridden by concrete subclasses.

It is called once for each track in the input file.

Parameters:
track Pointer to the track for which a handler should be created.
Returns:
A pointer to a track handler, or NULL if no handler needs to be created for that track.

Reimplemented from AP4_Processor.

AP4_ProtectionKeyMap& AP4_MarlinIpmpEncryptingProcessor::GetKeyMap ( ) [inline]

Definition at line 157 of file Ap4Marlin.h.

AP4_TrackPropertyMap& AP4_MarlinIpmpEncryptingProcessor::GetPropertyMap ( ) [inline]

Definition at line 158 of file Ap4Marlin.h.

virtual AP4_Result AP4_MarlinIpmpEncryptingProcessor::Initialize | ( | AP4_AtomParent & | top_level,
 |  | AP4_ByteStream & | stream,
 |  | AP4_Processor::ProgressListener * | listener = NULL |
 | ) |  |  | [virtual]

This method can be overridden by concrete subclasses.

It is called just after the input stream has been parsed into an atom tree, before the processing of the tracks.

Parameters:
top_level Container atom containing all the atoms parsed from the input stream. Note that this atom does not actually exist in the file; it is a synthetised container created for the purpose of holding together all the input's top-level atoms.

Reimplemented from AP4_Processor.

The documentation for this class was generated from the following file:
  • Ap4Marlin.h
Generated on Thu May 13 16:37:21 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_MarlinIpmpEncryptingProcessor Member List

This is the complete list of members for AP4_MarlinIpmpEncryptingProcessor, including all inherited members.
AP4_MarlinIpmpEncryptingProcessor(bool use_group_key=false, const AP4_ProtectionKeyMap *key_map=NULL, AP4_BlockCipherFactory *block_cipher_factory=NULL) | AP4_MarlinIpmpEncryptingProcessor |
CreateFragmentHandler(AP4_ContainerAtom *) | AP4_Processor | [inline, virtual]
CreateTrackHandler(AP4_TrakAtom *trak) | AP4_MarlinIpmpEncryptingProcessor | [virtual]
Finalize(AP4_AtomParent &top_level, ProgressListener *listener=NULL) | AP4_Processor | [virtual]
GetKeyMap() | AP4_MarlinIpmpEncryptingProcessor | [inline]
GetPropertyMap() | AP4_MarlinIpmpEncryptingProcessor | [inline]
Initialize(AP4_AtomParent &top_level, AP4_ByteStream &stream, AP4_Processor::ProgressListener *listener=NULL) | AP4_MarlinIpmpEncryptingProcessor | [virtual]
m_ExternalTrackData | AP4_Processor | [protected]
Process(AP4_ByteStream &input, AP4_ByteStream &output, ProgressListener *listener=NULL, AP4_AtomFactory &atom_factory=AP4_DefaultAtomFactory::Instance) | AP4_Processor |
ProcessFragments(AP4_MoovAtom *moov, AP4_List< AP4_MoofLocator > &moofs, AP4_ContainerAtom *mfra, AP4_ByteStream &input, AP4_ByteStream &output) | AP4_Processor | [protected]
~AP4_Processor() | AP4_Processor | [inline, virtual]
Generated on Thu May 13 16:37:21 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_MarlinIpmpParser Class Reference

AP4_MarlinIpmpParser Class Reference

#include <Ap4Marlin.h>

List of all members.

Classes

struct | SinfEntry

Static Public Member Functions

static AP4_Result | Parse (AP4_AtomParent &top_level, AP4_ByteStream &stream, AP4_List< SinfEntry > &sinf_entries, bool remove_od_data=false)

Detailed Description

Definition at line 67 of file Ap4Marlin.h.

Member Function Documentation

static AP4_Result AP4_MarlinIpmpParser::Parse | ( | AP4_AtomParent & | top_level,
 |  | AP4_ByteStream & | stream,
 |  | AP4_List< SinfEntry > & | sinf_entries,
 |  | bool | remove_od_data = false |
 | ) |  |  | [static]
The documentation for this class was generated from the following file:
  • Ap4Marlin.h
Generated on Thu May 13 16:37:21 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_MarlinIpmpParser Member List

This is the complete list of members for AP4_MarlinIpmpParser, including all inherited members.
Parse(AP4_AtomParent &top_level, AP4_ByteStream &stream, AP4_List< SinfEntry > &sinf_entries, bool remove_od_data=false) AP4_MarlinIpmpParser [static]
Generated on Thu May 13 16:37:21 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_MarlinIpmpTrackDecrypter Class Reference

AP4_MarlinIpmpTrackDecrypter Class Reference

#include <Ap4Marlin.h>

Inheritance diagram for AP4_MarlinIpmpTrackDecrypter:
AP4_Processor::TrackHandler

List of all members.

Public Member Functions

~AP4_MarlinIpmpTrackDecrypter ()
virtual AP4_Size | GetProcessedSampleSize (AP4_Sample &sample)
Returns the size of a sample after processing.
virtual AP4_Result | ProcessSample (AP4_DataBuffer &data_in, AP4_DataBuffer &data_out)
Process the data of one sample.

Static Public Member Functions

static AP4_Result | Create (AP4_BlockCipherFactory &cipher_factory, const AP4_UI08 *key, AP4_MarlinIpmpTrackDecrypter *&decrypter)

Detailed Description

Definition at line 120 of file Ap4Marlin.h.

Constructor & Destructor Documentation

AP4_MarlinIpmpTrackDecrypter::~AP4_MarlinIpmpTrackDecrypter ( )

Member Function Documentation

static AP4_Result AP4_MarlinIpmpTrackDecrypter::Create | ( | AP4_BlockCipherFactory & | cipher_factory,
 |  | const AP4_UI08 * | key,
 |  | AP4_MarlinIpmpTrackDecrypter *& | decrypter |
 | ) |  |  | [static]
virtual AP4_Size AP4_MarlinIpmpTrackDecrypter::GetProcessedSampleSize ( AP4_Sample & sample ) [virtual]

Returns the size of a sample after processing.

Parameters:
sample Sample of which the processed size is requested.
Returns:
Size of the sample data after processing.

Reimplemented from AP4_Processor::TrackHandler.

virtual AP4_Result AP4_MarlinIpmpTrackDecrypter::ProcessSample | ( | AP4_DataBuffer & | data_in,
 |  | AP4_DataBuffer & | data_out |
 | ) |  |  | [virtual]

Process the data of one sample.

Parameters:
data_in | Data buffer with the data of the sample to process.
data_out | Data buffer in which the processed sample data is returned.

Implements AP4_Processor::TrackHandler.

The documentation for this class was generated from the following file:
  • Ap4Marlin.h
Generated on Thu May 13 16:37:21 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_MarlinIpmpTrackDecrypter Member List

This is the complete list of members for AP4_MarlinIpmpTrackDecrypter, including all inherited members.
Create(AP4_BlockCipherFactory &cipher_factory, const AP4_UI08 *key, AP4_MarlinIpmpTrackDecrypter *&decrypter) | AP4_MarlinIpmpTrackDecrypter | [static]
GetProcessedSampleSize(AP4_Sample &sample) | AP4_MarlinIpmpTrackDecrypter | [virtual]
ProcessSample(AP4_DataBuffer &data_in, AP4_DataBuffer &data_out) | AP4_MarlinIpmpTrackDecrypter | [virtual]
ProcessTrack() | AP4_Processor::TrackHandler | [inline, virtual]
~AP4_MarlinIpmpTrackDecrypter() | AP4_MarlinIpmpTrackDecrypter |
~TrackHandler() | AP4_Processor::TrackHandler | [inline, virtual]
Generated on Thu May 13 16:37:21 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_MarlinIpmpTrackEncrypter Class Reference

AP4_MarlinIpmpTrackEncrypter Class Reference

#include <Ap4Marlin.h>

Inheritance diagram for AP4_MarlinIpmpTrackEncrypter:
AP4_Processor::TrackHandler

List of all members.

Public Member Functions

~AP4_MarlinIpmpTrackEncrypter ()
virtual AP4_Size | GetProcessedSampleSize (AP4_Sample &sample)
Returns the size of a sample after processing.
virtual AP4_Result | ProcessSample (AP4_DataBuffer &data_in, AP4_DataBuffer &data_out)
Process the data of one sample.

Static Public Member Functions

static AP4_Result | Create (AP4_BlockCipherFactory &cipher_factory, const AP4_UI08 *key, const AP4_UI08 *iv, AP4_MarlinIpmpTrackEncrypter *&encrypter)

Detailed Description

Definition at line 177 of file Ap4Marlin.h.

Constructor & Destructor Documentation

AP4_MarlinIpmpTrackEncrypter::~AP4_MarlinIpmpTrackEncrypter ( )

Member Function Documentation

static AP4_Result AP4_MarlinIpmpTrackEncrypter::Create | ( | AP4_BlockCipherFactory & | cipher_factory,
 |  | const AP4_UI08 * | key,
 |  | const AP4_UI08 * | iv,
 |  | AP4_MarlinIpmpTrackEncrypter *& | encrypter |
 | ) |  |  | [static]
virtual AP4_Size AP4_MarlinIpmpTrackEncrypter::GetProcessedSampleSize ( AP4_Sample & sample ) [virtual]

Returns the size of a sample after processing.

Parameters:
sample Sample of which the processed size is requested.
Returns:
Size of the sample data after processing.

Reimplemented from AP4_Processor::TrackHandler.

virtual AP4_Result AP4_MarlinIpmpTrackEncrypter::ProcessSample | ( | AP4_DataBuffer & | data_in,
 |  | AP4_DataBuffer & | data_out |
 | ) |  |  | [virtual]

Process the data of one sample.

Parameters:
data_in | Data buffer with the data of the sample to process.
data_out | Data buffer in which the processed sample data is returned.

Implements AP4_Processor::TrackHandler.

The documentation for this class was generated from the following file:
  • Ap4Marlin.h
Generated on Thu May 13 16:37:22 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_MarlinIpmpTrackEncrypter Member List

This is the complete list of members for AP4_MarlinIpmpTrackEncrypter, including all inherited members.
Create(AP4_BlockCipherFactory &cipher_factory, const AP4_UI08 *key, const AP4_UI08 *iv, AP4_MarlinIpmpTrackEncrypter *&encrypter) | AP4_MarlinIpmpTrackEncrypter | [static]
GetProcessedSampleSize(AP4_Sample &sample) | AP4_MarlinIpmpTrackEncrypter | [virtual]
ProcessSample(AP4_DataBuffer &data_in, AP4_DataBuffer &data_out) | AP4_MarlinIpmpTrackEncrypter | [virtual]
ProcessTrack() | AP4_Processor::TrackHandler | [inline, virtual]
~AP4_MarlinIpmpTrackEncrypter() | AP4_MarlinIpmpTrackEncrypter |
~TrackHandler() | AP4_Processor::TrackHandler | [inline, virtual]
Generated on Thu May 13 16:37:22 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_MdhdAtom Class Reference

AP4_MdhdAtom Class Reference

#include <Ap4MdhdAtom.h>

Inheritance diagram for AP4_MdhdAtom:
AP4_Atom

List of all members.

Public Member Functions

AP4_MdhdAtom (AP4_UI32 creation_time, AP4_UI32 modification_time, AP4_UI32 time_scale, AP4_UI64 duration, const char *language)
virtual AP4_Result | InspectFields (AP4_AtomInspector &inspector)
virtual AP4_Result | WriteFields (AP4_ByteStream &stream)
AP4_UI32 GetDurationMs ()
AP4_UI64 GetDuration ()
void | SetDuration (AP4_UI64 duration)
AP4_UI32 GetTimeScale ()
void | SetTimeScale (AP4_UI32 timescale)
const AP4_String & | GetLanguage ()

Static Public Member Functions

static AP4_MdhdAtom * | Create (AP4_Size size, AP4_ByteStream &stream)

Detailed Description

Definition at line 47 of file Ap4MdhdAtom.h.

Constructor & Destructor Documentation

AP4_MdhdAtom::AP4_MdhdAtom | ( | AP4_UI32 | creation_time,
 |  | AP4_UI32 | modification_time,
 |  | AP4_UI32 | time_scale,
 |  | AP4_UI64 | duration,
 |  | const char * | language
 | ) |  |

Member Function Documentation

static AP4_MdhdAtom* AP4_MdhdAtom::Create | ( | AP4_Size | size,
 |  | AP4_ByteStream & | stream |
 | ) |  |  | [static]
AP4_UI64 AP4_MdhdAtom::GetDuration ( ) [inline]

Definition at line 65 of file Ap4MdhdAtom.h.

AP4_UI32 AP4_MdhdAtom::GetDurationMs ( )
const AP4_String& AP4_MdhdAtom::GetLanguage ( ) [inline]

Definition at line 69 of file Ap4MdhdAtom.h.

AP4_UI32 AP4_MdhdAtom::GetTimeScale ( ) [inline]

Definition at line 67 of file Ap4MdhdAtom.h.

virtual AP4_Result AP4_MdhdAtom::InspectFields ( AP4_AtomInspector & inspector ) [virtual]

Reimplemented from AP4_Atom.

void AP4_MdhdAtom::SetDuration ( AP4_UI64 duration ) [inline]

Definition at line 66 of file Ap4MdhdAtom.h.

void AP4_MdhdAtom::SetTimeScale ( AP4_UI32 timescale ) [inline]

Definition at line 68 of file Ap4MdhdAtom.h.

virtual AP4_Result AP4_MdhdAtom::WriteFields ( AP4_ByteStream & stream ) [virtual]

Implements AP4_Atom.

The documentation for this class was generated from the following file:
  • Ap4MdhdAtom.h
Generated on Thu May 13 16:37:22 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_MdhdAtom Member List

This is the complete list of members for AP4_MdhdAtom, including all inherited members.
AP4_Atom(Type type, AP4_UI32 size=AP4_ATOM_HEADER_SIZE) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64=false) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_MdhdAtom(AP4_UI32 creation_time, AP4_UI32 modification_time, AP4_UI32 time_scale, AP4_UI64 duration, const char *language) | AP4_MdhdAtom |
Clone() | AP4_Atom | [virtual]
Create(AP4_Size size, AP4_ByteStream &stream) | AP4_MdhdAtom | [static]
Detach() | AP4_Atom | [virtual]
GetDuration() | AP4_MdhdAtom | [inline]
GetDurationMs() | AP4_MdhdAtom |
GetFlags() const | AP4_Atom | [inline]
GetHeaderSize() const | AP4_Atom | [virtual]
GetLanguage() | AP4_MdhdAtom | [inline]
GetParent() | AP4_Atom | [inline, virtual]
GetSize() const | AP4_Atom | [inline]
GetSize32() const | AP4_Atom | [inline]
GetSize64() const | AP4_Atom | [inline]
GetTimeScale() | AP4_MdhdAtom | [inline]
GetType() const | AP4_Atom | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
InspectFields(AP4_AtomInspector &inspector) | AP4_MdhdAtom | [virtual]
InspectHeader(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
m_Flags | AP4_Atom | [protected]
m_IsFull | AP4_Atom | [protected]
m_Parent | AP4_Atom | [protected]
m_Size32 | AP4_Atom | [protected]
m_Size64 | AP4_Atom | [protected]
m_Type | AP4_Atom | [protected]
m_Version | AP4_Atom | [protected]
ReadFullHeader(AP4_ByteStream &stream, AP4_UI32 &version, AP4_UI32 &flags) | AP4_Atom | [static]
SetDuration(AP4_UI64 duration) | AP4_MdhdAtom | [inline]
SetFlags(AP4_UI32 flags) | AP4_Atom | [inline]
SetParent(AP4_AtomParent *parent) | AP4_Atom | [inline, virtual]
SetSize(AP4_UI64 size, bool force_64=false) | AP4_Atom |
SetSize32(AP4_UI32 size) | AP4_Atom | [inline]
SetSize64(AP4_UI64 size) | AP4_Atom | [inline]
SetTimeScale(AP4_UI32 timescale) | AP4_MdhdAtom | [inline]
SetType(Type type) | AP4_Atom | [inline]
Type typedef | AP4_Atom |
TypeFromString(const char *four_cc) | AP4_Atom | [static]
Write(AP4_ByteStream &stream) | AP4_Atom | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_MdhdAtom | [virtual]
WriteHeader(AP4_ByteStream &stream) | AP4_Atom | [virtual]
~AP4_Atom() | AP4_Atom | [inline, virtual]
Generated on Thu May 13 16:37:22 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_MehdAtom Class Reference

AP4_MehdAtom Class Reference

#include <Ap4MehdAtom.h>

Inheritance diagram for AP4_MehdAtom:
AP4_Atom

List of all members.

Public Member Functions

AP4_MehdAtom (AP4_UI64 duration)
virtual AP4_Result | InspectFields (AP4_AtomInspector &inspector)
virtual AP4_Result | WriteFields (AP4_ByteStream &stream)
AP4_UI64 GetDuration ()
void | SetDuration (AP4_UI64 duration)

Static Public Member Functions

static AP4_MehdAtom * | Create (AP4_Size size, AP4_ByteStream &stream)

Detailed Description

Definition at line 41 of file Ap4MehdAtom.h.

Constructor & Destructor Documentation

AP4_MehdAtom::AP4_MehdAtom ( AP4_UI64 duration )

Member Function Documentation

static AP4_MehdAtom* AP4_MehdAtom::Create | ( | AP4_Size | size,
 |  | AP4_ByteStream & | stream |
 | ) |  |  | [static]
AP4_UI64 AP4_MehdAtom::GetDuration ( ) [inline]

Definition at line 53 of file Ap4MehdAtom.h.

virtual AP4_Result AP4_MehdAtom::InspectFields ( AP4_AtomInspector & inspector ) [virtual]

Reimplemented from AP4_Atom.

void AP4_MehdAtom::SetDuration ( AP4_UI64 duration ) [inline]

Definition at line 54 of file Ap4MehdAtom.h.

virtual AP4_Result AP4_MehdAtom::WriteFields ( AP4_ByteStream & stream ) [virtual]

Implements AP4_Atom.

The documentation for this class was generated from the following file:
  • Ap4MehdAtom.h
Generated on Thu May 13 16:37:22 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_MehdAtom Member List

This is the complete list of members for AP4_MehdAtom, including all inherited members.
AP4_Atom(Type type, AP4_UI32 size=AP4_ATOM_HEADER_SIZE) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64=false) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_MehdAtom(AP4_UI64 duration) | AP4_MehdAtom |
Clone() | AP4_Atom | [virtual]
Create(AP4_Size size, AP4_ByteStream &stream) | AP4_MehdAtom | [static]
Detach() | AP4_Atom | [virtual]
GetDuration() | AP4_MehdAtom | [inline]
GetFlags() const | AP4_Atom | [inline]
GetHeaderSize() const | AP4_Atom | [virtual]
GetParent() | AP4_Atom | [inline, virtual]
GetSize() const | AP4_Atom | [inline]
GetSize32() const | AP4_Atom | [inline]
GetSize64() const | AP4_Atom | [inline]
GetType() const | AP4_Atom | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
InspectFields(AP4_AtomInspector &inspector) | AP4_MehdAtom | [virtual]
InspectHeader(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
m_Flags | AP4_Atom | [protected]
m_IsFull | AP4_Atom | [protected]
m_Parent | AP4_Atom | [protected]
m_Size32 | AP4_Atom | [protected]
m_Size64 | AP4_Atom | [protected]
m_Type | AP4_Atom | [protected]
m_Version | AP4_Atom | [protected]
ReadFullHeader(AP4_ByteStream &stream, AP4_UI32 &version, AP4_UI32 &flags) | AP4_Atom | [static]
SetDuration(AP4_UI64 duration) | AP4_MehdAtom | [inline]
SetFlags(AP4_UI32 flags) | AP4_Atom | [inline]
SetParent(AP4_AtomParent *parent) | AP4_Atom | [inline, virtual]
SetSize(AP4_UI64 size, bool force_64=false) | AP4_Atom |
SetSize32(AP4_UI32 size) | AP4_Atom | [inline]
SetSize64(AP4_UI64 size) | AP4_Atom | [inline]
SetType(Type type) | AP4_Atom | [inline]
Type typedef | AP4_Atom |
TypeFromString(const char *four_cc) | AP4_Atom | [static]
Write(AP4_ByteStream &stream) | AP4_Atom | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_MehdAtom | [virtual]
WriteHeader(AP4_ByteStream &stream) | AP4_Atom | [virtual]
~AP4_Atom() | AP4_Atom | [inline, virtual]
Generated on Thu May 13 16:37:22 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_MemoryByteStream Class Reference

AP4_MemoryByteStream Class Reference

#include <Ap4ByteStream.h>

Inheritance diagram for AP4_MemoryByteStream:
AP4_ByteStream AP4_Referenceable

List of all members.

Public Member Functions

AP4_MemoryByteStream (AP4_Size size=0)
AP4_MemoryByteStream (const AP4_UI08 *buffer, AP4_Size size)
AP4_MemoryByteStream (AP4_DataBuffer &data_buffer)
AP4_Result | ReadPartial (void *buffer, AP4_Size bytes_to_read, AP4_Size &bytes_read)
AP4_Result | WritePartial (const void *buffer, AP4_Size bytes_to_write, AP4_Size &bytes_written)
AP4_Result | Seek (AP4_Position position)
AP4_Result | Tell (AP4_Position &position)
AP4_Result | GetSize (AP4_LargeSize &size)
void | AddReference ()
void | Release ()
const AP4_UI08 * | GetData ()
AP4_UI08 * UseData ()
AP4_Size GetDataSize ()

Protected Member Functions

virtual | ~AP4_MemoryByteStream ()

Detailed Description

Definition at line 121 of file Ap4ByteStream.h.

Constructor & Destructor Documentation

AP4_MemoryByteStream::AP4_MemoryByteStream ( AP4_Size size = 0 )
AP4_MemoryByteStream::AP4_MemoryByteStream | ( | const AP4_UI08 * | buffer,
 |  | AP4_Size | size
 | ) |  |
AP4_MemoryByteStream::AP4_MemoryByteStream ( AP4_DataBuffer & data_buffer )
virtual AP4_MemoryByteStream::~AP4_MemoryByteStream ( ) [protected, virtual]

Member Function Documentation

void AP4_MemoryByteStream::AddReference ( ) [virtual]

Implements AP4_Referenceable.

const AP4_UI08* AP4_MemoryByteStream::GetData ( ) [inline]

Definition at line 150 of file Ap4ByteStream.h.

References AP4_DataBuffer::GetData().

AP4_Size AP4_MemoryByteStream::GetDataSize ( ) [inline]

Definition at line 152 of file Ap4ByteStream.h.

References AP4_DataBuffer::GetDataSize().

AP4_Result AP4_MemoryByteStream::GetSize ( AP4_LargeSize & size ) [inline, virtual]

Implements AP4_ByteStream.

Definition at line 140 of file Ap4ByteStream.h.

References AP4_SUCCESS, and AP4_DataBuffer::GetDataSize().

AP4_Result AP4_MemoryByteStream::ReadPartial | ( | void * | buffer,
 |  | AP4_Size | bytes_to_read,
 |  | AP4_Size & | bytes_read |
 | ) |  |  | [virtual]

Implements AP4_ByteStream.

void AP4_MemoryByteStream::Release ( ) [virtual]

Implements AP4_Referenceable.

AP4_Result AP4_MemoryByteStream::Seek ( AP4_Position position ) [virtual]

Implements AP4_ByteStream.

AP4_Result AP4_MemoryByteStream::Tell ( AP4_Position & position ) [inline, virtual]

Implements AP4_ByteStream.

Definition at line 136 of file Ap4ByteStream.h.

References AP4_SUCCESS.

AP4_UI08* AP4_MemoryByteStream::UseData ( ) [inline]

Definition at line 151 of file Ap4ByteStream.h.

References AP4_DataBuffer::UseData().

AP4_Result AP4_MemoryByteStream::WritePartial | ( | const void * | buffer,
 |  | AP4_Size | bytes_to_write,
 |  | AP4_Size & | bytes_written |
 | ) |  |  | [virtual]

Implements AP4_ByteStream.

The documentation for this class was generated from the following file:
  • Ap4ByteStream.h
Generated on Thu May 13 16:37:22 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_MemoryByteStream Member List

This is the complete list of members for AP4_MemoryByteStream, including all inherited members.
AddReference() | AP4_MemoryByteStream | [virtual]
AP4_MemoryByteStream(AP4_Size size=0) | AP4_MemoryByteStream |
AP4_MemoryByteStream(const AP4_UI08 *buffer, AP4_Size size) | AP4_MemoryByteStream |
AP4_MemoryByteStream(AP4_DataBuffer &data_buffer) | AP4_MemoryByteStream |
CopyTo(AP4_ByteStream &stream, AP4_LargeSize size) | AP4_ByteStream | [virtual]
Flush() | AP4_ByteStream | [inline, virtual]
GetData() | AP4_MemoryByteStream | [inline]
GetDataSize() | AP4_MemoryByteStream | [inline]
GetSize(AP4_LargeSize &size) | AP4_MemoryByteStream | [inline, virtual]
Read(void *buffer, AP4_Size bytes_to_read) | AP4_ByteStream |
ReadDouble(double &value) | AP4_ByteStream |
ReadPartial(void *buffer, AP4_Size bytes_to_read, AP4_Size &bytes_read) | AP4_MemoryByteStream | [virtual]
ReadString(char *buffer, AP4_Size size) | AP4_ByteStream |
ReadUI08(AP4_UI08 &value) | AP4_ByteStream |
ReadUI16(AP4_UI16 &value) | AP4_ByteStream |
ReadUI24(AP4_UI32 &value) | AP4_ByteStream |
ReadUI32(AP4_UI32 &value) | AP4_ByteStream |
ReadUI64(AP4_UI64 &value) | AP4_ByteStream |
Release() | AP4_MemoryByteStream | [virtual]
Seek(AP4_Position position) | AP4_MemoryByteStream | [virtual]
Tell(AP4_Position &position) | AP4_MemoryByteStream | [inline, virtual]
UseData() | AP4_MemoryByteStream | [inline]
Write(const void *buffer, AP4_Size bytes_to_write) | AP4_ByteStream |
WriteDouble(double value) | AP4_ByteStream |
WritePartial(const void *buffer, AP4_Size bytes_to_write, AP4_Size &bytes_written) | AP4_MemoryByteStream | [virtual]
WriteString(const char *string_buffer) | AP4_ByteStream |
WriteUI08(AP4_UI08 value) | AP4_ByteStream |
WriteUI16(AP4_UI16 value) | AP4_ByteStream |
WriteUI24(AP4_UI32 value) | AP4_ByteStream |
WriteUI32(AP4_UI32 value) | AP4_ByteStream |
WriteUI64(AP4_UI64 value) | AP4_ByteStream |
~AP4_MemoryByteStream() | AP4_MemoryByteStream | [protected, virtual]
~AP4_Referenceable() | AP4_Referenceable | [inline, virtual]
Generated on Thu May 13 16:37:22 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_MetaData Class Reference

AP4_MetaData Class Reference

#include <Ap4MetaData.h>

List of all members.

Classes

class | Entry
class | Key
class | KeyInfo
class | Value

Public Member Functions

AP4_MetaData (AP4_File *file)
AP4_Result | ParseMoov (AP4_MoovAtom *moov)
AP4_Result | ParseUdta (AP4_ContainerAtom *udta, const char *namespc)
~AP4_MetaData ()
const AP4_List< Entry > & | GetEntries () const
AP4_Result | ResolveKeyName (AP4_Atom::Type atom_type, AP4_String &value)
AP4_Result | AddIlstEntries (AP4_ContainerAtom *atom, const char *namespc)
AP4_Result | Add3GppEntry (AP4_3GppLocalizedStringAtom *atom, const char *namespc)
AP4_Result | AddDcfStringEntry (AP4_DcfStringAtom *atom, const char *namespc)
AP4_Result | AddDcfdEntry (AP4_DcfdAtom *atom, const char *namespc)

Static Public Attributes

static AP4_Array< KeyInfo > | KeyInfos

Detailed Description

Definition at line 129 of file Ap4MetaData.h.

Constructor & Destructor Documentation

AP4_MetaData::AP4_MetaData ( AP4_File * file )
AP4_MetaData::~AP4_MetaData ( )

Member Function Documentation

AP4_Result AP4_MetaData::Add3GppEntry | ( | AP4_3GppLocalizedStringAtom * | atom,
 |  | const char * | namespc
 | ) |  |
AP4_Result AP4_MetaData::AddDcfdEntry | ( | AP4_DcfdAtom * | atom,
 |  | const char * | namespc
 | ) |  |
AP4_Result AP4_MetaData::AddDcfStringEntry | ( | AP4_DcfStringAtom * | atom,
 |  | const char * | namespc
 | ) |  |
AP4_Result AP4_MetaData::AddIlstEntries | ( | AP4_ContainerAtom * | atom,
 |  | const char * | namespc
 | ) |  |
const AP4_List<Entry>& AP4_MetaData::GetEntries ( ) const [inline]

Definition at line 255 of file Ap4MetaData.h.

AP4_Result AP4_MetaData::ParseMoov ( AP4_MoovAtom * moov )
AP4_Result AP4_MetaData::ParseUdta | ( | AP4_ContainerAtom * | udta,
 |  | const char * | namespc
 | ) |  |
AP4_Result AP4_MetaData::ResolveKeyName | ( | AP4_Atom::Type | atom_type,
 |  | AP4_String & | value
 | ) |  |

Member Data Documentation

AP4_Array<KeyInfo> AP4_MetaData::KeyInfos [static]

Definition at line 242 of file Ap4MetaData.h.

The documentation for this class was generated from the following file:
  • Ap4MetaData.h
Generated on Thu May 13 16:37:22 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_MetaData Member List

This is the complete list of members for AP4_MetaData, including all inherited members.
Add3GppEntry(AP4_3GppLocalizedStringAtom *atom, const char *namespc) | AP4_MetaData |
AddDcfdEntry(AP4_DcfdAtom *atom, const char *namespc) | AP4_MetaData |
AddDcfStringEntry(AP4_DcfStringAtom *atom, const char *namespc) | AP4_MetaData |
AddIlstEntries(AP4_ContainerAtom *atom, const char *namespc) | AP4_MetaData |
AP4_MetaData(AP4_File *file) | AP4_MetaData |
GetEntries() const | AP4_MetaData | [inline]
KeyInfos | AP4_MetaData | [static]
ParseMoov(AP4_MoovAtom *moov) | AP4_MetaData |
ParseUdta(AP4_ContainerAtom *udta, const char *namespc) | AP4_MetaData |
ResolveKeyName(AP4_Atom::Type atom_type, AP4_String &value) | AP4_MetaData |
~AP4_MetaData() | AP4_MetaData |
Generated on Thu May 13 16:37:22 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_MetaDataAtomTypeHandler Class Reference

AP4_MetaDataAtomTypeHandler Class Reference

#include <Ap4MetaData.h>

Inheritance diagram for AP4_MetaDataAtomTypeHandler:
AP4_AtomFactory::TypeHandler

List of all members.

Classes

struct | TypeList

Public Member Functions

AP4_MetaDataAtomTypeHandler (AP4_AtomFactory *atom_factory)
virtual AP4_Result | CreateAtom (AP4_Atom::Type type, AP4_UI32 size, AP4_ByteStream &stream, AP4_Atom::Type context, AP4_Atom *&atom)

Static Public Member Functions

static bool | IsTypeInList (AP4_Atom::Type type, const TypeList &list)

Static Public Attributes

static const AP4_Atom::Type | IlstTypes []
static const TypeList | IlstTypeList
static const AP4_Atom::Type | _3gppLocalizedStringTypes []
static const TypeList | _3gppLocalizedStringTypeList
static const AP4_Atom::Type | _3gppOtherTypes []
static const TypeList | _3gppOtherTypeList
static const AP4_Atom::Type | DcfStringTypes []
static const TypeList | DcfStringTypeList

Detailed Description

Definition at line 272 of file Ap4MetaData.h.

Constructor & Destructor Documentation

AP4_MetaDataAtomTypeHandler::AP4_MetaDataAtomTypeHandler ( AP4_AtomFactory * atom_factory ) [inline]

Definition at line 276 of file Ap4MetaData.h.

Member Function Documentation

virtual AP4_Result AP4_MetaDataAtomTypeHandler::CreateAtom | ( | AP4_Atom::Type | type,
 |  | AP4_UI32 | size,
 |  | AP4_ByteStream & | stream,
 |  | AP4_Atom::Type | context,
 |  | AP4_Atom *& | atom |
 | ) |  |  | [virtual]

Implements AP4_AtomFactory::TypeHandler.

static bool AP4_MetaDataAtomTypeHandler::IsTypeInList | ( | AP4_Atom::Type | type,
 |  | const TypeList & | list |
 | ) |  |  | [static]

Member Data Documentation

const TypeList AP4_MetaDataAtomTypeHandler::_3gppLocalizedStringTypeList [static]

Definition at line 294 of file Ap4MetaData.h.

const AP4_Atom::Type AP4_MetaDataAtomTypeHandler::_3gppLocalizedStringTypes[] [static]

Definition at line 293 of file Ap4MetaData.h.

const TypeList AP4_MetaDataAtomTypeHandler::_3gppOtherTypeList [static]

Definition at line 296 of file Ap4MetaData.h.

const AP4_Atom::Type AP4_MetaDataAtomTypeHandler::_3gppOtherTypes[] [static]

Definition at line 295 of file Ap4MetaData.h.

const TypeList AP4_MetaDataAtomTypeHandler::DcfStringTypeList [static]

Definition at line 298 of file Ap4MetaData.h.

const AP4_Atom::Type AP4_MetaDataAtomTypeHandler::DcfStringTypes[] [static]

Definition at line 297 of file Ap4MetaData.h.

const TypeList AP4_MetaDataAtomTypeHandler::IlstTypeList [static]

Definition at line 292 of file Ap4MetaData.h.

const AP4_Atom::Type AP4_MetaDataAtomTypeHandler::IlstTypes[] [static]

Definition at line 291 of file Ap4MetaData.h.

The documentation for this class was generated from the following file:
  • Ap4MetaData.h
Generated on Thu May 13 16:37:22 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_MetaDataAtomTypeHandler Member List

This is the complete list of members for AP4_MetaDataAtomTypeHandler, including all inherited members.
_3gppLocalizedStringTypeList | AP4_MetaDataAtomTypeHandler | [static]
_3gppLocalizedStringTypes | AP4_MetaDataAtomTypeHandler | [static]
_3gppOtherTypeList | AP4_MetaDataAtomTypeHandler | [static]
_3gppOtherTypes | AP4_MetaDataAtomTypeHandler | [static]
AP4_MetaDataAtomTypeHandler(AP4_AtomFactory *atom_factory) | AP4_MetaDataAtomTypeHandler | [inline]
CreateAtom(AP4_Atom::Type type, AP4_UI32 size, AP4_ByteStream &stream, AP4_Atom::Type context, AP4_Atom *&atom) | AP4_MetaDataAtomTypeHandler | [virtual]
DcfStringTypeList | AP4_MetaDataAtomTypeHandler | [static]
DcfStringTypes | AP4_MetaDataAtomTypeHandler | [static]
IlstTypeList | AP4_MetaDataAtomTypeHandler | [static]
IlstTypes | AP4_MetaDataAtomTypeHandler | [static]
IsTypeInList(AP4_Atom::Type type, const TypeList &list) | AP4_MetaDataAtomTypeHandler | [static]
~TypeHandler() | AP4_AtomFactory::TypeHandler | [inline, virtual]
Generated on Thu May 13 16:37:22 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_MetaDataStringAtom Class Reference

AP4_MetaDataStringAtom Class Reference

#include <Ap4MetaData.h>

Inheritance diagram for AP4_MetaDataStringAtom:
AP4_Atom

List of all members.

Public Member Functions

AP4_MetaDataStringAtom (Type type, const char *value)
AP4_MetaDataStringAtom (Type type, AP4_UI32 size, AP4_ByteStream &stream)
virtual AP4_Result | InspectFields (AP4_AtomInspector &inspector)
virtual AP4_Result | WriteFields (AP4_ByteStream &stream)
const AP4_String & | GetValue ()

Detailed Description

Definition at line 427 of file Ap4MetaData.h.

Constructor & Destructor Documentation

AP4_MetaDataStringAtom::AP4_MetaDataStringAtom | ( | Type | type,
 |  | const char * | value
 | ) |  |
AP4_MetaDataStringAtom::AP4_MetaDataStringAtom | ( | Type | type,
 |  | AP4_UI32 | size,
 |  | AP4_ByteStream & | stream
 | ) |  |

Member Function Documentation

const AP4_String& AP4_MetaDataStringAtom::GetValue ( ) [inline]

Definition at line 439 of file Ap4MetaData.h.

virtual AP4_Result AP4_MetaDataStringAtom::InspectFields ( AP4_AtomInspector & inspector ) [virtual]

Reimplemented from AP4_Atom.

virtual AP4_Result AP4_MetaDataStringAtom::WriteFields ( AP4_ByteStream & stream ) [virtual]

Implements AP4_Atom.

The documentation for this class was generated from the following file:
  • Ap4MetaData.h
Generated on Thu May 13 16:37:23 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_MetaDataStringAtom Member List

This is the complete list of members for AP4_MetaDataStringAtom, including all inherited members.
AP4_Atom(Type type, AP4_UI32 size=AP4_ATOM_HEADER_SIZE) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64=false) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_MetaDataStringAtom(Type type, const char *value) | AP4_MetaDataStringAtom |
AP4_MetaDataStringAtom(Type type, AP4_UI32 size, AP4_ByteStream &stream) | AP4_MetaDataStringAtom |
Clone() | AP4_Atom | [virtual]
Detach() | AP4_Atom | [virtual]
GetFlags() const | AP4_Atom | [inline]
GetHeaderSize() const | AP4_Atom | [virtual]
GetParent() | AP4_Atom | [inline, virtual]
GetSize() const | AP4_Atom | [inline]
GetSize32() const | AP4_Atom | [inline]
GetSize64() const | AP4_Atom | [inline]
GetType() const | AP4_Atom | [inline]
GetValue() | AP4_MetaDataStringAtom | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
InspectFields(AP4_AtomInspector &inspector) | AP4_MetaDataStringAtom | [virtual]
InspectHeader(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
m_Flags | AP4_Atom | [protected]
m_IsFull | AP4_Atom | [protected]
m_Parent | AP4_Atom | [protected]
m_Size32 | AP4_Atom | [protected]
m_Size64 | AP4_Atom | [protected]
m_Type | AP4_Atom | [protected]
m_Version | AP4_Atom | [protected]
ReadFullHeader(AP4_ByteStream &stream, AP4_UI32 &version, AP4_UI32 &flags) | AP4_Atom | [static]
SetFlags(AP4_UI32 flags) | AP4_Atom | [inline]
SetParent(AP4_AtomParent *parent) | AP4_Atom | [inline, virtual]
SetSize(AP4_UI64 size, bool force_64=false) | AP4_Atom |
SetSize32(AP4_UI32 size) | AP4_Atom | [inline]
SetSize64(AP4_UI64 size) | AP4_Atom | [inline]
SetType(Type type) | AP4_Atom | [inline]
Type typedef | AP4_Atom |
TypeFromString(const char *four_cc) | AP4_Atom | [static]
Write(AP4_ByteStream &stream) | AP4_Atom | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_MetaDataStringAtom | [virtual]
WriteHeader(AP4_ByteStream &stream) | AP4_Atom | [virtual]
~AP4_Atom() | AP4_Atom | [inline, virtual]
Generated on Thu May 13 16:37:23 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_MetaDataTag Class Reference

AP4_MetaDataTag Class Reference

#include <Ap4MetaData.h>

List of all members.

Public Member Functions

virtual | ~AP4_MetaDataTag ()
virtual AP4_Result | Write (AP4_ByteStream &stream)
virtual AP4_Result | Inspect (AP4_AtomInspector &inspector)

Protected Member Functions

AP4_MetaDataTag (AP4_UI32 data_type, AP4_UI32 data_lang, AP4_Size size, AP4_ByteStream &stream)

Detailed Description

Definition at line 311 of file Ap4MetaData.h.

Constructor & Destructor Documentation

virtual AP4_MetaDataTag::~AP4_MetaDataTag ( ) [inline, virtual]

Definition at line 316 of file Ap4MetaData.h.

AP4_MetaDataTag::AP4_MetaDataTag | ( | AP4_UI32 | data_type,
 |  | AP4_UI32 | data_lang,
 |  | AP4_Size | size,
 |  | AP4_ByteStream & | stream |
 | ) |  |  | [protected]

Member Function Documentation

virtual AP4_Result AP4_MetaDataTag::Inspect ( AP4_AtomInspector & inspector ) [virtual]
virtual AP4_Result AP4_MetaDataTag::Write ( AP4_ByteStream & stream ) [virtual]
The documentation for this class was generated from the following file:
  • Ap4MetaData.h
Generated on Thu May 13 16:37:23 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_MetaDataTag Member List

This is the complete list of members for AP4_MetaDataTag, including all inherited members.
AP4_MetaDataTag(AP4_UI32 data_type, AP4_UI32 data_lang, AP4_Size size, AP4_ByteStream &stream) | AP4_MetaDataTag | [protected]
Inspect(AP4_AtomInspector &inspector) | AP4_MetaDataTag | [virtual]
Write(AP4_ByteStream &stream) | AP4_MetaDataTag | [virtual]
~AP4_MetaDataTag() | AP4_MetaDataTag | [inline, virtual]
Generated on Thu May 13 16:37:23 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_MfhdAtom Class Reference

AP4_MfhdAtom Class Reference

#include <Ap4MfhdAtom.h>

Inheritance diagram for AP4_MfhdAtom:
AP4_Atom

List of all members.

Public Member Functions

AP4_MfhdAtom (AP4_UI32 sequence_number)
virtual AP4_Result | InspectFields (AP4_AtomInspector &inspector)
virtual AP4_Result | WriteFields (AP4_ByteStream &stream)
AP4_UI32 GetSequenceNumber ()
void | SetSequenceNumber (AP4_UI32 sequence_number)

Static Public Member Functions

static AP4_MfhdAtom * | Create (AP4_Size size, AP4_ByteStream &stream)

Detailed Description

Definition at line 40 of file Ap4MfhdAtom.h.

Constructor & Destructor Documentation

AP4_MfhdAtom::AP4_MfhdAtom ( AP4_UI32 sequence_number )

Member Function Documentation

static AP4_MfhdAtom* AP4_MfhdAtom::Create | ( | AP4_Size | size,
 |  | AP4_ByteStream & | stream |
 | ) |  |  | [static]
AP4_UI32 AP4_MfhdAtom::GetSequenceNumber ( ) [inline]

Definition at line 53 of file Ap4MfhdAtom.h.

virtual AP4_Result AP4_MfhdAtom::InspectFields ( AP4_AtomInspector & inspector ) [virtual]

Reimplemented from AP4_Atom.

void AP4_MfhdAtom::SetSequenceNumber ( AP4_UI32 sequence_number ) [inline]

Definition at line 54 of file Ap4MfhdAtom.h.

virtual AP4_Result AP4_MfhdAtom::WriteFields ( AP4_ByteStream & stream ) [virtual]

Implements AP4_Atom.

The documentation for this class was generated from the following file:
  • Ap4MfhdAtom.h
Generated on Thu May 13 16:37:23 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_MfhdAtom Member List

This is the complete list of members for AP4_MfhdAtom, including all inherited members.
AP4_Atom(Type type, AP4_UI32 size=AP4_ATOM_HEADER_SIZE) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64=false) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_MfhdAtom(AP4_UI32 sequence_number) | AP4_MfhdAtom |
Clone() | AP4_Atom | [virtual]
Create(AP4_Size size, AP4_ByteStream &stream) | AP4_MfhdAtom | [static]
Detach() | AP4_Atom | [virtual]
GetFlags() const | AP4_Atom | [inline]
GetHeaderSize() const | AP4_Atom | [virtual]
GetParent() | AP4_Atom | [inline, virtual]
GetSequenceNumber() | AP4_MfhdAtom | [inline]
GetSize() const | AP4_Atom | [inline]
GetSize32() const | AP4_Atom | [inline]
GetSize64() const | AP4_Atom | [inline]
GetType() const | AP4_Atom | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
InspectFields(AP4_AtomInspector &inspector) | AP4_MfhdAtom | [virtual]
InspectHeader(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
m_Flags | AP4_Atom | [protected]
m_IsFull | AP4_Atom | [protected]
m_Parent | AP4_Atom | [protected]
m_Size32 | AP4_Atom | [protected]
m_Size64 | AP4_Atom | [protected]
m_Type | AP4_Atom | [protected]
m_Version | AP4_Atom | [protected]
ReadFullHeader(AP4_ByteStream &stream, AP4_UI32 &version, AP4_UI32 &flags) | AP4_Atom | [static]
SetFlags(AP4_UI32 flags) | AP4_Atom | [inline]
SetParent(AP4_AtomParent *parent) | AP4_Atom | [inline, virtual]
SetSequenceNumber(AP4_UI32 sequence_number) | AP4_MfhdAtom | [inline]
SetSize(AP4_UI64 size, bool force_64=false) | AP4_Atom |
SetSize32(AP4_UI32 size) | AP4_Atom | [inline]
SetSize64(AP4_UI64 size) | AP4_Atom | [inline]
SetType(Type type) | AP4_Atom | [inline]
Type typedef | AP4_Atom |
TypeFromString(const char *four_cc) | AP4_Atom | [static]
Write(AP4_ByteStream &stream) | AP4_Atom | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_MfhdAtom | [virtual]
WriteHeader(AP4_ByteStream &stream) | AP4_Atom | [virtual]
~AP4_Atom() | AP4_Atom | [inline, virtual]
Generated on Thu May 13 16:37:23 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_MfroAtom Class Reference

AP4_MfroAtom Class Reference

#include <Ap4MfroAtom.h>

Inheritance diagram for AP4_MfroAtom:
AP4_Atom

List of all members.

Public Member Functions

AP4_MfroAtom (AP4_UI32 mfra_size)
virtual AP4_Result | InspectFields (AP4_AtomInspector &inspector)
virtual AP4_Result | WriteFields (AP4_ByteStream &stream)
AP4_UI32 GetMfraSize ()

Static Public Member Functions

static AP4_MfroAtom * | Create (AP4_Size size, AP4_ByteStream &stream)

Detailed Description

Definition at line 47 of file Ap4MfroAtom.h.

Constructor & Destructor Documentation

AP4_MfroAtom::AP4_MfroAtom ( AP4_UI32 mfra_size )

Member Function Documentation

static AP4_MfroAtom* AP4_MfroAtom::Create | ( | AP4_Size | size,
 |  | AP4_ByteStream & | stream |
 | ) |  |  | [static]
AP4_UI32 AP4_MfroAtom::GetMfraSize ( ) [inline]

Definition at line 61 of file Ap4MfroAtom.h.

virtual AP4_Result AP4_MfroAtom::InspectFields ( AP4_AtomInspector & inspector ) [virtual]

Reimplemented from AP4_Atom.

virtual AP4_Result AP4_MfroAtom::WriteFields ( AP4_ByteStream & stream ) [virtual]

Implements AP4_Atom.

The documentation for this class was generated from the following file:
  • Ap4MfroAtom.h
Generated on Thu May 13 16:37:23 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_MfroAtom Member List

This is the complete list of members for AP4_MfroAtom, including all inherited members.
AP4_Atom(Type type, AP4_UI32 size=AP4_ATOM_HEADER_SIZE) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64=false) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_MfroAtom(AP4_UI32 mfra_size) | AP4_MfroAtom |
Clone() | AP4_Atom | [virtual]
Create(AP4_Size size, AP4_ByteStream &stream) | AP4_MfroAtom | [static]
Detach() | AP4_Atom | [virtual]
GetFlags() const | AP4_Atom | [inline]
GetHeaderSize() const | AP4_Atom | [virtual]
GetMfraSize() | AP4_MfroAtom | [inline]
GetParent() | AP4_Atom | [inline, virtual]
GetSize() const | AP4_Atom | [inline]
GetSize32() const | AP4_Atom | [inline]
GetSize64() const | AP4_Atom | [inline]
GetType() const | AP4_Atom | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
InspectFields(AP4_AtomInspector &inspector) | AP4_MfroAtom | [virtual]
InspectHeader(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
m_Flags | AP4_Atom | [protected]
m_IsFull | AP4_Atom | [protected]
m_Parent | AP4_Atom | [protected]
m_Size32 | AP4_Atom | [protected]
m_Size64 | AP4_Atom | [protected]
m_Type | AP4_Atom | [protected]
m_Version | AP4_Atom | [protected]
ReadFullHeader(AP4_ByteStream &stream, AP4_UI32 &version, AP4_UI32 &flags) | AP4_Atom | [static]
SetFlags(AP4_UI32 flags) | AP4_Atom | [inline]
SetParent(AP4_AtomParent *parent) | AP4_Atom | [inline, virtual]
SetSize(AP4_UI64 size, bool force_64=false) | AP4_Atom |
SetSize32(AP4_UI32 size) | AP4_Atom | [inline]
SetSize64(AP4_UI64 size) | AP4_Atom | [inline]
SetType(Type type) | AP4_Atom | [inline]
Type typedef | AP4_Atom |
TypeFromString(const char *four_cc) | AP4_Atom | [static]
Write(AP4_ByteStream &stream) | AP4_Atom | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_MfroAtom | [virtual]
WriteHeader(AP4_ByteStream &stream) | AP4_Atom | [virtual]
~AP4_Atom() | AP4_Atom | [inline, virtual]
Generated on Thu May 13 16:37:23 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_MoovAtom Class Reference

AP4_MoovAtom Class Reference

#include <Ap4MoovAtom.h>

Inheritance diagram for AP4_MoovAtom:
AP4_ContainerAtom AP4_Atom AP4_AtomParent

List of all members.

Public Member Functions

AP4_MoovAtom ()
AP4_List< AP4_TrakAtom > & GetTrakAtoms ()
AP4_UI32 GetTimeScale ()
AP4_Result | AdjustChunkOffsets (AP4_SI64 offset)
void | OnChildAdded (AP4_Atom *atom)
void | OnChildRemoved (AP4_Atom *atom)

Static Public Member Functions

static AP4_MoovAtom * | Create (AP4_Size size, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory)

Detailed Description

Definition at line 47 of file Ap4MoovAtom.h.

Constructor & Destructor Documentation

AP4_MoovAtom::AP4_MoovAtom ( )

Referenced by Create().

Member Function Documentation

AP4_Result AP4_MoovAtom::AdjustChunkOffsets ( AP4_SI64 offset )
static AP4_MoovAtom* AP4_MoovAtom::Create | ( | AP4_Size | size,
 |  | AP4_ByteStream & | stream,
 |  | AP4_AtomFactory & | atom_factory |
 | ) |  |  | [inline, static]

Definition at line 53 of file Ap4MoovAtom.h.

References AP4_MoovAtom().

AP4_UI32 AP4_MoovAtom::GetTimeScale ( ) [inline]

Definition at line 64 of file Ap4MoovAtom.h.

AP4_List<AP4_TrakAtom>& AP4_MoovAtom::GetTrakAtoms ( ) [inline]

Definition at line 61 of file Ap4MoovAtom.h.

void AP4_MoovAtom::OnChildAdded ( AP4_Atom * atom ) [virtual]

Reimplemented from AP4_ContainerAtom.

void AP4_MoovAtom::OnChildRemoved ( AP4_Atom * atom ) [virtual]

Reimplemented from AP4_ContainerAtom.

The documentation for this class was generated from the following file:
  • Ap4MoovAtom.h
Generated on Thu May 13 16:37:23 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_MoovAtom Member List

This is the complete list of members for AP4_MoovAtom, including all inherited members.
AddChild(AP4_Atom *child, int position=-1) | AP4_AtomParent | [virtual]
AdjustChunkOffsets(AP4_SI64 offset) | AP4_MoovAtom |
AP4_Atom(Type type, AP4_UI32 size=AP4_ATOM_HEADER_SIZE) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64=false) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_ContainerAtom(Type type) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI32 version, AP4_UI32 flags) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_ContainerAtom | [protected]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_ContainerAtom | [protected]
AP4_MoovAtom() | AP4_MoovAtom |
Clone() | AP4_ContainerAtom | [virtual]
Create(AP4_Size size, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_MoovAtom | [inline, static]
AP4_ContainerAtom::Create(Type type, AP4_UI64 size, bool is_full, bool force_64, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_ContainerAtom | [static]
DeleteChild(AP4_Atom::Type type, AP4_Ordinal index=0) | AP4_AtomParent | [virtual]
Detach() | AP4_Atom | [virtual]
FindChild(const char *path, bool auto_create=false, bool auto_create_full=false) | AP4_AtomParent | [virtual]
GetChild(AP4_Atom::Type type, AP4_Ordinal index=0) const | AP4_AtomParent | [virtual]
GetChild(const AP4_UI08 *uuid, AP4_Ordinal index=0) const | AP4_AtomParent | [virtual]
GetChildren() | AP4_ContainerAtom | [inline]
GetFlags() const | AP4_Atom | [inline]
GetHeaderSize() const | AP4_Atom | [virtual]
GetParent() | AP4_Atom | [inline, virtual]
GetSize() const | AP4_Atom | [inline]
GetSize32() const | AP4_Atom | [inline]
GetSize64() const | AP4_Atom | [inline]
GetTimeScale() | AP4_MoovAtom | [inline]
GetTrakAtoms() | AP4_MoovAtom | [inline]
GetType() const | AP4_Atom | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
InspectChildren(AP4_AtomInspector &inspector) | AP4_ContainerAtom | [virtual]
InspectFields(AP4_AtomInspector &inspector) | AP4_ContainerAtom | [virtual]
InspectHeader(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
m_Children | AP4_AtomParent | [protected]
m_Flags | AP4_Atom | [protected]
m_IsFull | AP4_Atom | [protected]
m_Parent | AP4_Atom | [protected]
m_Size32 | AP4_Atom | [protected]
m_Size64 | AP4_Atom | [protected]
m_Type | AP4_Atom | [protected]
m_Version | AP4_Atom | [protected]
OnChildAdded(AP4_Atom *atom) | AP4_MoovAtom | [virtual]
OnChildChanged(AP4_Atom *child) | AP4_ContainerAtom | [virtual]
OnChildRemoved(AP4_Atom *atom) | AP4_MoovAtom | [virtual]
ReadChildren(AP4_AtomFactory &atom_factory, AP4_ByteStream &stream, AP4_UI64 size) | AP4_ContainerAtom | [protected]
ReadFullHeader(AP4_ByteStream &stream, AP4_UI32 &version, AP4_UI32 &flags) | AP4_Atom | [static]
RemoveChild(AP4_Atom *child) | AP4_AtomParent | [virtual]
SetFlags(AP4_UI32 flags) | AP4_Atom | [inline]
SetParent(AP4_AtomParent *parent) | AP4_Atom | [inline, virtual]
SetSize(AP4_UI64 size, bool force_64=false) | AP4_Atom |
SetSize32(AP4_UI32 size) | AP4_Atom | [inline]
SetSize64(AP4_UI64 size) | AP4_Atom | [inline]
SetType(Type type) | AP4_Atom | [inline]
Type typedef | AP4_Atom |
TypeFromString(const char *four_cc) | AP4_Atom | [static]
Write(AP4_ByteStream &stream) | AP4_Atom | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_ContainerAtom | [virtual]
WriteHeader(AP4_ByteStream &stream) | AP4_Atom | [virtual]
~AP4_Atom() | AP4_Atom | [inline, virtual]
~AP4_AtomParent() | AP4_AtomParent | [virtual]
Generated on Thu May 13 16:37:23 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_Movie Class Reference

AP4_Movie Class Reference

#include <Ap4Movie.h>

List of all members.

Public Member Functions

AP4_Movie (AP4_UI32 time_scale=0)
AP4_Movie (AP4_MoovAtom *moov, AP4_ByteStream &sample_stream, bool transfer_moov_ownership=true)
virtual | ~AP4_Movie ()
AP4_Result | Inspect (AP4_AtomInspector &inspector)
AP4_MoovAtom * GetMoovAtom ()
AP4_MvhdAtom * GetMvhdAtom ()
AP4_List< AP4_Track > & GetTracks ()
AP4_Track * | GetTrack (AP4_UI32 track_id)
AP4_Track * | GetTrack (AP4_Track::Type type, AP4_Ordinal index=0)
AP4_Result | AddTrack (AP4_Track *track)
AP4_UI32 GetTimeScale ()
AP4_UI64 GetDuration ()
AP4_UI32 GetDurationMs ()

Detailed Description

Definition at line 51 of file Ap4Movie.h.

Constructor & Destructor Documentation

AP4_Movie::AP4_Movie ( AP4_UI32 time_scale = 0 )
AP4_Movie::AP4_Movie | ( | AP4_MoovAtom * | moov,
 |  | AP4_ByteStream & | sample_stream,
 |  | bool | transfer_moov_ownership = true
 | ) |  |
virtual AP4_Movie::~AP4_Movie ( ) [virtual]

Member Function Documentation

AP4_Result AP4_Movie::AddTrack ( AP4_Track * track )
AP4_UI64 AP4_Movie::GetDuration ( )
AP4_UI32 AP4_Movie::GetDurationMs ( )
AP4_MoovAtom* AP4_Movie::GetMoovAtom ( ) [inline]

Definition at line 59 of file Ap4Movie.h.

AP4_MvhdAtom* AP4_Movie::GetMvhdAtom ( ) [inline]

Definition at line 60 of file Ap4Movie.h.

AP4_UI32 AP4_Movie::GetTimeScale ( )
AP4_Track* AP4_Movie::GetTrack | ( | AP4_Track::Type | type,
 |  | AP4_Ordinal | index = 0
 | ) |  |
AP4_Track* AP4_Movie::GetTrack ( AP4_UI32 track_id )
AP4_List<AP4_Track>& AP4_Movie::GetTracks ( ) [inline]

Definition at line 61 of file Ap4Movie.h.

AP4_Result AP4_Movie::Inspect ( AP4_AtomInspector & inspector )
The documentation for this class was generated from the following file:
  • Ap4Movie.h
Generated on Thu May 13 16:37:23 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_Movie Member List

This is the complete list of members for AP4_Movie, including all inherited members.
AddTrack(AP4_Track *track) | AP4_Movie |
AP4_Movie(AP4_UI32 time_scale=0) | AP4_Movie |
AP4_Movie(AP4_MoovAtom *moov, AP4_ByteStream &sample_stream, bool transfer_moov_ownership=true) | AP4_Movie |
GetDuration() | AP4_Movie |
GetDurationMs() | AP4_Movie |
GetMoovAtom() | AP4_Movie | [inline]
GetMvhdAtom() | AP4_Movie | [inline]
GetTimeScale() | AP4_Movie |
GetTrack(AP4_UI32 track_id) | AP4_Movie |
GetTrack(AP4_Track::Type type, AP4_Ordinal index=0) | AP4_Movie |
GetTracks() | AP4_Movie | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_Movie |
~AP4_Movie() | AP4_Movie | [virtual]
Generated on Thu May 13 16:37:23 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_MovieFragment Class Reference

AP4_MovieFragment Class Reference

#include <Ap4MovieFragment.h>

List of all members.

Public Member Functions

AP4_MovieFragment (AP4_ContainerAtom *moof)
virtual | ~AP4_MovieFragment ()
AP4_ContainerAtom * GetMoofAtom ()
AP4_MfhdAtom * GetMfhdAtom ()
AP4_UI32 GetSequenceNumber ()
AP4_Result | GetTrackIds (AP4_Array< AP4_UI32 > &ids)
AP4_Result | GetTrafAtom (AP4_UI32 track_id, AP4_ContainerAtom *&traf)
AP4_Result | CreateSampleTable (AP4_MoovAtom *moov, AP4_UI32 track_id, AP4_ByteStream *sample_stream, AP4_Position moof_offset, AP4_Position mdat_payload_offset, AP4_FragmentSampleTable *&sample_table)
AP4_Result | CreateSampleTable (AP4_Movie *movie, AP4_UI32 track_id, AP4_ByteStream *sample_stream, AP4_Position moof_offset, AP4_Position mdat_payload_offset, AP4_FragmentSampleTable *&sample_table)

Detailed Description

Definition at line 56 of file Ap4MovieFragment.h.

Constructor & Destructor Documentation

AP4_MovieFragment::AP4_MovieFragment ( AP4_ContainerAtom * moof )
virtual AP4_MovieFragment::~AP4_MovieFragment ( ) [virtual]

Member Function Documentation

AP4_Result AP4_MovieFragment::CreateSampleTable | ( | AP4_Movie * | movie,
 |  | AP4_UI32 | track_id,
 |  | AP4_ByteStream * | sample_stream,
 |  | AP4_Position | moof_offset,
 |  | AP4_Position | mdat_payload_offset,
 |  | AP4_FragmentSampleTable *& | sample_table
 | ) |  |
AP4_Result AP4_MovieFragment::CreateSampleTable | ( | AP4_MoovAtom * | moov,
 |  | AP4_UI32 | track_id,
 |  | AP4_ByteStream * | sample_stream,
 |  | AP4_Position | moof_offset,
 |  | AP4_Position | mdat_payload_offset,
 |  | AP4_FragmentSampleTable *& | sample_table
 | ) |  |
AP4_MfhdAtom* AP4_MovieFragment::GetMfhdAtom ( ) [inline]

Definition at line 64 of file Ap4MovieFragment.h.

AP4_ContainerAtom* AP4_MovieFragment::GetMoofAtom ( ) [inline]

Definition at line 63 of file Ap4MovieFragment.h.

AP4_UI32 AP4_MovieFragment::GetSequenceNumber ( )
AP4_Result AP4_MovieFragment::GetTrackIds ( AP4_Array< AP4_UI32 > & ids )
AP4_Result AP4_MovieFragment::GetTrafAtom | ( | AP4_UI32 | track_id,
 |  | AP4_ContainerAtom *& | traf
 | ) |  |
The documentation for this class was generated from the following file:
  • Ap4MovieFragment.h
Generated on Thu May 13 16:37:23 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_MovieFragment Member List

This is the complete list of members for AP4_MovieFragment, including all inherited members.
AP4_MovieFragment(AP4_ContainerAtom *moof) | AP4_MovieFragment |
CreateSampleTable(AP4_MoovAtom *moov, AP4_UI32 track_id, AP4_ByteStream *sample_stream, AP4_Position moof_offset, AP4_Position mdat_payload_offset, AP4_FragmentSampleTable *&sample_table) | AP4_MovieFragment |
CreateSampleTable(AP4_Movie *movie, AP4_UI32 track_id, AP4_ByteStream *sample_stream, AP4_Position moof_offset, AP4_Position mdat_payload_offset, AP4_FragmentSampleTable *&sample_table) | AP4_MovieFragment |
GetMfhdAtom() | AP4_MovieFragment | [inline]
GetMoofAtom() | AP4_MovieFragment | [inline]
GetSequenceNumber() | AP4_MovieFragment |
GetTrackIds(AP4_Array< AP4_UI32 > &ids) | AP4_MovieFragment |
GetTrafAtom(AP4_UI32 track_id, AP4_ContainerAtom *&traf) | AP4_MovieFragment |
~AP4_MovieFragment() | AP4_MovieFragment | [virtual]
Generated on Thu May 13 16:37:23 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_Mp4aSampleEntry Class Reference

AP4_Mp4aSampleEntry Class Reference

#include <Ap4SampleEntry.h>

Inheritance diagram for AP4_Mp4aSampleEntry:
AP4_MpegAudioSampleEntry AP4_AudioSampleEntry AP4_SampleEntry AP4_ContainerAtom AP4_Atom AP4_AtomParent

List of all members.

Public Member Functions

AP4_Mp4aSampleEntry (AP4_Size size, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory)
AP4_Mp4aSampleEntry (AP4_UI32 sample_rate, AP4_UI16 sample_size, AP4_UI16 channel_count, AP4_EsDescriptor *descriptor)

Detailed Description

Definition at line 300 of file Ap4SampleEntry.h.

Constructor & Destructor Documentation

AP4_Mp4aSampleEntry::AP4_Mp4aSampleEntry | ( | AP4_Size | size,
 |  | AP4_ByteStream & | stream,
 |  | AP4_AtomFactory & | atom_factory
 | ) |  |
AP4_Mp4aSampleEntry::AP4_Mp4aSampleEntry | ( | AP4_UI32 | sample_rate,
 |  | AP4_UI16 | sample_size,
 |  | AP4_UI16 | channel_count,
 |  | AP4_EsDescriptor * | descriptor
 | ) |  |
The documentation for this class was generated from the following file:
  • Ap4SampleEntry.h
Generated on Thu May 13 16:37:23 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_Mp4aSampleEntry Member List

This is the complete list of members for AP4_Mp4aSampleEntry, including all inherited members.
AddChild(AP4_Atom *child, int position=-1) | AP4_AtomParent | [virtual]
AP4_Atom(Type type, AP4_UI32 size=AP4_ATOM_HEADER_SIZE) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64=false) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_AudioSampleEntry(AP4_Atom::Type format, AP4_UI32 sample_rate, AP4_UI16 sample_size, AP4_UI16 channel_count) | AP4_AudioSampleEntry |
AP4_AudioSampleEntry(AP4_Atom::Type format, AP4_Size size, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_AudioSampleEntry |
AP4_ContainerAtom(Type type) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI32 version, AP4_UI32 flags) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_ContainerAtom | [protected]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_ContainerAtom | [protected]
AP4_Mp4aSampleEntry(AP4_Size size, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_Mp4aSampleEntry |
AP4_Mp4aSampleEntry(AP4_UI32 sample_rate, AP4_UI16 sample_size, AP4_UI16 channel_count, AP4_EsDescriptor *descriptor) | AP4_Mp4aSampleEntry |
AP4_MpegAudioSampleEntry(AP4_UI32 type, AP4_UI32 sample_rate, AP4_UI16 sample_size, AP4_UI16 channel_count, AP4_EsDescriptor *descriptor) | AP4_MpegAudioSampleEntry |
AP4_MpegAudioSampleEntry(AP4_UI32 type, AP4_Size size, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_MpegAudioSampleEntry |
AP4_SampleEntry(AP4_Atom::Type format, AP4_UI16 data_ref_index=1) | AP4_SampleEntry |
AP4_SampleEntry(AP4_Atom::Type format, AP4_Size size, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_SampleEntry |
AP4_SampleEntry(AP4_Atom::Type format, AP4_Size size) | AP4_SampleEntry | [protected]
Clone() | AP4_ContainerAtom | [virtual]
Create(Type type, AP4_UI64 size, bool is_full, bool force_64, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_ContainerAtom | [static]
DeleteChild(AP4_Atom::Type type, AP4_Ordinal index=0) | AP4_AtomParent | [virtual]
Detach() | AP4_Atom | [virtual]
FindChild(const char *path, bool auto_create=false, bool auto_create_full=false) | AP4_AtomParent | [virtual]
GetChannelCount() | AP4_AudioSampleEntry |
GetChild(AP4_Atom::Type type, AP4_Ordinal index=0) const | AP4_AtomParent | [virtual]
GetChild(const AP4_UI08 *uuid, AP4_Ordinal index=0) const | AP4_AtomParent | [virtual]
GetChildren() | AP4_ContainerAtom | [inline]
GetDataReferenceIndex() | AP4_SampleEntry | [inline]
GetFieldsSize() | AP4_AudioSampleEntry | [protected, virtual]
GetFlags() const | AP4_Atom | [inline]
GetHeaderSize() const | AP4_Atom | [virtual]
GetParent() | AP4_Atom | [inline, virtual]
GetSampleRate() | AP4_AudioSampleEntry |
GetSampleSize() | AP4_AudioSampleEntry | [inline]
GetSize() const | AP4_Atom | [inline]
GetSize32() const | AP4_Atom | [inline]
GetSize64() const | AP4_Atom | [inline]
GetType() const | AP4_Atom | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_SampleEntry | [virtual]
InspectChildren(AP4_AtomInspector &inspector) | AP4_ContainerAtom | [virtual]
InspectFields(AP4_AtomInspector &inspector) | AP4_AudioSampleEntry | [protected, virtual]
InspectHeader(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
m_ChannelCount | AP4_AudioSampleEntry | [protected]
m_Children | AP4_AtomParent | [protected]
m_DataReferenceIndex | AP4_SampleEntry | [protected]
m_Flags | AP4_Atom | [protected]
m_IsFull | AP4_Atom | [protected]
m_Parent | AP4_Atom | [protected]
m_QtCompressionId | AP4_AudioSampleEntry | [protected]
m_QtPacketSize | AP4_AudioSampleEntry | [protected]
m_QtRevision | AP4_AudioSampleEntry | [protected]
m_QtV1BytesPerFrame | AP4_AudioSampleEntry | [protected]
m_QtV1BytesPerPacket | AP4_AudioSampleEntry | [protected]
m_QtV1BytesPerSample | AP4_AudioSampleEntry | [protected]
m_QtV1SamplesPerPacket | AP4_AudioSampleEntry | [protected]
m_QtV2BitsPerChannel | AP4_AudioSampleEntry | [protected]
m_QtV2BytesPerAudioPacket | AP4_AudioSampleEntry | [protected]
m_QtV2ChannelCount | AP4_AudioSampleEntry | [protected]
m_QtV2Extension | AP4_AudioSampleEntry | [protected]
m_QtV2FormatSpecificFlags | AP4_AudioSampleEntry | [protected]
m_QtV2LPCMFramesPerAudioPacket | AP4_AudioSampleEntry | [protected]
m_QtV2Reserved | AP4_AudioSampleEntry | [protected]
m_QtV2SampleRate64 | AP4_AudioSampleEntry | [protected]
m_QtV2StructSize | AP4_AudioSampleEntry | [protected]
m_QtVendor | AP4_AudioSampleEntry | [protected]
m_QtVersion | AP4_AudioSampleEntry | [protected]
m_Reserved1 | AP4_SampleEntry | [protected]
m_SampleRate | AP4_AudioSampleEntry | [protected]
m_SampleSize | AP4_AudioSampleEntry | [protected]
m_Size32 | AP4_Atom | [protected]
m_Size64 | AP4_Atom | [protected]
m_Type | AP4_Atom | [protected]
m_Version | AP4_Atom | [protected]
OnChildAdded(AP4_Atom *child) | AP4_ContainerAtom | [virtual]
OnChildChanged(AP4_Atom *child) | AP4_SampleEntry | [virtual]
OnChildRemoved(AP4_Atom *child) | AP4_ContainerAtom | [virtual]
Read(AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_SampleEntry | [protected, virtual]
ReadChildren(AP4_AtomFactory &atom_factory, AP4_ByteStream &stream, AP4_UI64 size) | AP4_ContainerAtom | [protected]
ReadFields(AP4_ByteStream &stream) | AP4_AudioSampleEntry | [protected, virtual]
ReadFullHeader(AP4_ByteStream &stream, AP4_UI32 &version, AP4_UI32 &flags) | AP4_Atom | [static]
RemoveChild(AP4_Atom *child) | AP4_AtomParent | [virtual]
SetFlags(AP4_UI32 flags) | AP4_Atom | [inline]
SetParent(AP4_AtomParent *parent) | AP4_Atom | [inline, virtual]
SetSize(AP4_UI64 size, bool force_64=false) | AP4_Atom |
SetSize32(AP4_UI32 size) | AP4_Atom | [inline]
SetSize64(AP4_UI64 size) | AP4_Atom | [inline]
SetType(Type type) | AP4_Atom | [inline]
ToSampleDescription() | AP4_MpegAudioSampleEntry | [virtual]
Type typedef | AP4_Atom |
TypeFromString(const char *four_cc) | AP4_Atom | [static]
Write(AP4_ByteStream &stream) | AP4_SampleEntry | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_AudioSampleEntry | [protected, virtual]
WriteHeader(AP4_ByteStream &stream) | AP4_Atom | [virtual]
~AP4_Atom() | AP4_Atom | [inline, virtual]
~AP4_AtomParent() | AP4_AtomParent | [virtual]
~AP4_SampleEntry() | AP4_SampleEntry | [inline, virtual]
Generated on Thu May 13 16:37:23 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_Mp4sSampleEntry Class Reference

AP4_Mp4sSampleEntry Class Reference

#include <Ap4SampleEntry.h>

Inheritance diagram for AP4_Mp4sSampleEntry:
AP4_MpegSystemSampleEntry AP4_SampleEntry AP4_ContainerAtom AP4_Atom AP4_AtomParent

List of all members.

Public Member Functions

AP4_Mp4sSampleEntry (AP4_Size size, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory)
AP4_Mp4sSampleEntry (AP4_EsDescriptor *descriptor)
AP4_SampleDescription * ToSampleDescription ()

Detailed Description

Definition at line 284 of file Ap4SampleEntry.h.

Constructor & Destructor Documentation

AP4_Mp4sSampleEntry::AP4_Mp4sSampleEntry | ( | AP4_Size | size,
 |  | AP4_ByteStream & | stream,
 |  | AP4_AtomFactory & | atom_factory
 | ) |  |
AP4_Mp4sSampleEntry::AP4_Mp4sSampleEntry ( AP4_EsDescriptor * descriptor )

Member Function Documentation

AP4_SampleDescription* AP4_Mp4sSampleEntry::ToSampleDescription ( ) [virtual]

Reimplemented from AP4_MpegSystemSampleEntry.

The documentation for this class was generated from the following file:
  • Ap4SampleEntry.h
Generated on Thu May 13 16:37:23 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_Mp4sSampleEntry Member List

This is the complete list of members for AP4_Mp4sSampleEntry, including all inherited members.
AddChild(AP4_Atom *child, int position=-1) | AP4_AtomParent | [virtual]
AP4_Atom(Type type, AP4_UI32 size=AP4_ATOM_HEADER_SIZE) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64=false) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_ContainerAtom(Type type) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI32 version, AP4_UI32 flags) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_ContainerAtom | [protected]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_ContainerAtom | [protected]
AP4_Mp4sSampleEntry(AP4_Size size, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_Mp4sSampleEntry |
AP4_Mp4sSampleEntry(AP4_EsDescriptor *descriptor) | AP4_Mp4sSampleEntry |
AP4_MpegSystemSampleEntry(AP4_UI32 type, AP4_EsDescriptor *descriptor) | AP4_MpegSystemSampleEntry |
AP4_MpegSystemSampleEntry(AP4_UI32 type, AP4_Size size, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_MpegSystemSampleEntry |
AP4_SampleEntry(AP4_Atom::Type format, AP4_UI16 data_ref_index=1) | AP4_SampleEntry |
AP4_SampleEntry(AP4_Atom::Type format, AP4_Size size, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_SampleEntry |
AP4_SampleEntry(AP4_Atom::Type format, AP4_Size size) | AP4_SampleEntry | [protected]
Clone() | AP4_ContainerAtom | [virtual]
Create(Type type, AP4_UI64 size, bool is_full, bool force_64, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_ContainerAtom | [static]
DeleteChild(AP4_Atom::Type type, AP4_Ordinal index=0) | AP4_AtomParent | [virtual]
Detach() | AP4_Atom | [virtual]
FindChild(const char *path, bool auto_create=false, bool auto_create_full=false) | AP4_AtomParent | [virtual]
GetChild(AP4_Atom::Type type, AP4_Ordinal index=0) const | AP4_AtomParent | [virtual]
GetChild(const AP4_UI08 *uuid, AP4_Ordinal index=0) const | AP4_AtomParent | [virtual]
GetChildren() | AP4_ContainerAtom | [inline]
GetDataReferenceIndex() | AP4_SampleEntry | [inline]
GetFieldsSize() | AP4_SampleEntry | [protected, virtual]
GetFlags() const | AP4_Atom | [inline]
GetHeaderSize() const | AP4_Atom | [virtual]
GetParent() | AP4_Atom | [inline, virtual]
GetSize() const | AP4_Atom | [inline]
GetSize32() const | AP4_Atom | [inline]
GetSize64() const | AP4_Atom | [inline]
GetType() const | AP4_Atom | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_SampleEntry | [virtual]
InspectChildren(AP4_AtomInspector &inspector) | AP4_ContainerAtom | [virtual]
InspectFields(AP4_AtomInspector &inspector) | AP4_SampleEntry | [protected, virtual]
InspectHeader(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
m_Children | AP4_AtomParent | [protected]
m_DataReferenceIndex | AP4_SampleEntry | [protected]
m_Flags | AP4_Atom | [protected]
m_IsFull | AP4_Atom | [protected]
m_Parent | AP4_Atom | [protected]
m_Reserved1 | AP4_SampleEntry | [protected]
m_Size32 | AP4_Atom | [protected]
m_Size64 | AP4_Atom | [protected]
m_Type | AP4_Atom | [protected]
m_Version | AP4_Atom | [protected]
OnChildAdded(AP4_Atom *child) | AP4_ContainerAtom | [virtual]
OnChildChanged(AP4_Atom *child) | AP4_SampleEntry | [virtual]
OnChildRemoved(AP4_Atom *child) | AP4_ContainerAtom | [virtual]
Read(AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_SampleEntry | [protected, virtual]
ReadChildren(AP4_AtomFactory &atom_factory, AP4_ByteStream &stream, AP4_UI64 size) | AP4_ContainerAtom | [protected]
ReadFields(AP4_ByteStream &stream) | AP4_SampleEntry | [protected, virtual]
ReadFullHeader(AP4_ByteStream &stream, AP4_UI32 &version, AP4_UI32 &flags) | AP4_Atom | [static]
RemoveChild(AP4_Atom *child) | AP4_AtomParent | [virtual]
SetFlags(AP4_UI32 flags) | AP4_Atom | [inline]
SetParent(AP4_AtomParent *parent) | AP4_Atom | [inline, virtual]
SetSize(AP4_UI64 size, bool force_64=false) | AP4_Atom |
SetSize32(AP4_UI32 size) | AP4_Atom | [inline]
SetSize64(AP4_UI64 size) | AP4_Atom | [inline]
SetType(Type type) | AP4_Atom | [inline]
ToSampleDescription() | AP4_Mp4sSampleEntry | [virtual]
Type typedef | AP4_Atom |
TypeFromString(const char *four_cc) | AP4_Atom | [static]
Write(AP4_ByteStream &stream) | AP4_SampleEntry | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_SampleEntry | [protected, virtual]
WriteHeader(AP4_ByteStream &stream) | AP4_Atom | [virtual]
~AP4_Atom() | AP4_Atom | [inline, virtual]
~AP4_AtomParent() | AP4_AtomParent | [virtual]
~AP4_SampleEntry() | AP4_SampleEntry | [inline, virtual]
Generated on Thu May 13 16:37:23 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_Mp4vSampleEntry Class Reference

AP4_Mp4vSampleEntry Class Reference

#include <Ap4SampleEntry.h>

Inheritance diagram for AP4_Mp4vSampleEntry:
AP4_MpegVideoSampleEntry AP4_VisualSampleEntry AP4_SampleEntry AP4_ContainerAtom AP4_Atom AP4_AtomParent

List of all members.

Public Member Functions

AP4_Mp4vSampleEntry (AP4_Size size, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory)
AP4_Mp4vSampleEntry (AP4_UI16 width, AP4_UI16 height, AP4_UI16 depth, const char *compressor_name, AP4_EsDescriptor *descriptor)

Detailed Description

Definition at line 316 of file Ap4SampleEntry.h.

Constructor & Destructor Documentation

AP4_Mp4vSampleEntry::AP4_Mp4vSampleEntry | ( | AP4_Size | size,
 |  | AP4_ByteStream & | stream,
 |  | AP4_AtomFactory & | atom_factory
 | ) |  |
AP4_Mp4vSampleEntry::AP4_Mp4vSampleEntry | ( | AP4_UI16 | width,
 |  | AP4_UI16 | height,
 |  | AP4_UI16 | depth,
 |  | const char * | compressor_name,
 |  | AP4_EsDescriptor * | descriptor
 | ) |  |
The documentation for this class was generated from the following file:
  • Ap4SampleEntry.h
Generated on Thu May 13 16:37:24 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_Mp4vSampleEntry Member List

This is the complete list of members for AP4_Mp4vSampleEntry, including all inherited members.
AddChild(AP4_Atom *child, int position=-1) | AP4_AtomParent | [virtual]
AP4_Atom(Type type, AP4_UI32 size=AP4_ATOM_HEADER_SIZE) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64=false) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_ContainerAtom(Type type) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI32 version, AP4_UI32 flags) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_ContainerAtom | [protected]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_ContainerAtom | [protected]
AP4_Mp4vSampleEntry(AP4_Size size, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_Mp4vSampleEntry |
AP4_Mp4vSampleEntry(AP4_UI16 width, AP4_UI16 height, AP4_UI16 depth, const char *compressor_name, AP4_EsDescriptor *descriptor) | AP4_Mp4vSampleEntry |
AP4_MpegVideoSampleEntry(AP4_UI32 type, AP4_UI16 width, AP4_UI16 height, AP4_UI16 depth, const char *compressor_name, AP4_EsDescriptor *descriptor) | AP4_MpegVideoSampleEntry |
AP4_MpegVideoSampleEntry(AP4_UI32 type, AP4_Size size, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_MpegVideoSampleEntry |
AP4_SampleEntry(AP4_Atom::Type format, AP4_UI16 data_ref_index=1) | AP4_SampleEntry |
AP4_SampleEntry(AP4_Atom::Type format, AP4_Size size, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_SampleEntry |
AP4_SampleEntry(AP4_Atom::Type format, AP4_Size size) | AP4_SampleEntry | [protected]
AP4_VisualSampleEntry(AP4_Atom::Type format, AP4_UI16 width, AP4_UI16 height, AP4_UI16 depth, const char *compressor_name) | AP4_VisualSampleEntry |
AP4_VisualSampleEntry(AP4_Atom::Type format, AP4_Size size, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_VisualSampleEntry |
Clone() | AP4_ContainerAtom | [virtual]
Create(Type type, AP4_UI64 size, bool is_full, bool force_64, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_ContainerAtom | [static]
DeleteChild(AP4_Atom::Type type, AP4_Ordinal index=0) | AP4_AtomParent | [virtual]
Detach() | AP4_Atom | [virtual]
FindChild(const char *path, bool auto_create=false, bool auto_create_full=false) | AP4_AtomParent | [virtual]
GetChild(AP4_Atom::Type type, AP4_Ordinal index=0) const | AP4_AtomParent | [virtual]
GetChild(const AP4_UI08 *uuid, AP4_Ordinal index=0) const | AP4_AtomParent | [virtual]
GetChildren() | AP4_ContainerAtom | [inline]
GetCompressorName() | AP4_VisualSampleEntry | [inline]
GetDataReferenceIndex() | AP4_SampleEntry | [inline]
GetDepth() | AP4_VisualSampleEntry | [inline]
GetFieldsSize() | AP4_VisualSampleEntry | [protected, virtual]
GetFlags() const | AP4_Atom | [inline]
GetHeaderSize() const | AP4_Atom | [virtual]
GetHeight() | AP4_VisualSampleEntry | [inline]
GetHorizResolution() | AP4_VisualSampleEntry | [inline]
GetParent() | AP4_Atom | [inline, virtual]
GetSize() const | AP4_Atom | [inline]
GetSize32() const | AP4_Atom | [inline]
GetSize64() const | AP4_Atom | [inline]
GetType() const | AP4_Atom | [inline]
GetVertResolution() | AP4_VisualSampleEntry | [inline]
GetWidth() | AP4_VisualSampleEntry | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_SampleEntry | [virtual]
InspectChildren(AP4_AtomInspector &inspector) | AP4_ContainerAtom | [virtual]
InspectFields(AP4_AtomInspector &inspector) | AP4_VisualSampleEntry | [protected, virtual]
InspectHeader(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
m_Children | AP4_AtomParent | [protected]
m_CompressorName | AP4_VisualSampleEntry | [protected]
m_DataReferenceIndex | AP4_SampleEntry | [protected]
m_Depth | AP4_VisualSampleEntry | [protected]
m_Flags | AP4_Atom | [protected]
m_FrameCount | AP4_VisualSampleEntry | [protected]
m_Height | AP4_VisualSampleEntry | [protected]
m_HorizResolution | AP4_VisualSampleEntry | [protected]
m_IsFull | AP4_Atom | [protected]
m_Parent | AP4_Atom | [protected]
m_Predefined1 | AP4_VisualSampleEntry | [protected]
m_Predefined2 | AP4_VisualSampleEntry | [protected]
m_Predefined3 | AP4_VisualSampleEntry | [protected]
m_Reserved1 | AP4_SampleEntry | [protected]
m_Reserved2 | AP4_VisualSampleEntry | [protected]
m_Reserved3 | AP4_VisualSampleEntry | [protected]
m_Size32 | AP4_Atom | [protected]
m_Size64 | AP4_Atom | [protected]
m_Type | AP4_Atom | [protected]
m_Version | AP4_Atom | [protected]
m_VertResolution | AP4_VisualSampleEntry | [protected]
m_Width | AP4_VisualSampleEntry | [protected]
OnChildAdded(AP4_Atom *child) | AP4_ContainerAtom | [virtual]
OnChildChanged(AP4_Atom *child) | AP4_SampleEntry | [virtual]
OnChildRemoved(AP4_Atom *child) | AP4_ContainerAtom | [virtual]
Read(AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_SampleEntry | [protected, virtual]
ReadChildren(AP4_AtomFactory &atom_factory, AP4_ByteStream &stream, AP4_UI64 size) | AP4_ContainerAtom | [protected]
ReadFields(AP4_ByteStream &stream) | AP4_VisualSampleEntry | [protected, virtual]
ReadFullHeader(AP4_ByteStream &stream, AP4_UI32 &version, AP4_UI32 &flags) | AP4_Atom | [static]
RemoveChild(AP4_Atom *child) | AP4_AtomParent | [virtual]
SetFlags(AP4_UI32 flags) | AP4_Atom | [inline]
SetParent(AP4_AtomParent *parent) | AP4_Atom | [inline, virtual]
SetSize(AP4_UI64 size, bool force_64=false) | AP4_Atom |
SetSize32(AP4_UI32 size) | AP4_Atom | [inline]
SetSize64(AP4_UI64 size) | AP4_Atom | [inline]
SetType(Type type) | AP4_Atom | [inline]
ToSampleDescription() | AP4_MpegVideoSampleEntry | [virtual]
Type typedef | AP4_Atom |
TypeFromString(const char *four_cc) | AP4_Atom | [static]
Write(AP4_ByteStream &stream) | AP4_SampleEntry | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_VisualSampleEntry | [protected, virtual]
WriteHeader(AP4_ByteStream &stream) | AP4_Atom | [virtual]
~AP4_Atom() | AP4_Atom | [inline, virtual]
~AP4_AtomParent() | AP4_AtomParent | [virtual]
~AP4_SampleEntry() | AP4_SampleEntry | [inline, virtual]
Generated on Thu May 13 16:37:24 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_Mpeg2TsWriter Class Reference

AP4_Mpeg2TsWriter Class Reference

This class is a simple implementation of a converter that can convert MP4 audio and video access units into an MPEG2 transport stream. More...

#include <Ap4Mpeg2Ts.h>

List of all members.

Classes

class | SampleStream
class | Stream

Public Member Functions

AP4_Mpeg2TsWriter ()
~AP4_Mpeg2TsWriter ()
Stream * GetPAT ()
Stream * GetPMT ()
AP4_Result | WritePAT (AP4_ByteStream &output)
AP4_Result | WritePMT (AP4_ByteStream &output)
AP4_Result | SetAudioStream (AP4_UI32 timescale, SampleStream *&stream)
AP4_Result | SetVideoStream (AP4_UI32 timescale, SampleStream *&stream)

Detailed Description

This class is a simple implementation of a converter that can convert MP4 audio and video access units into an MPEG2 transport stream.

It currently only supports one audio tracks with MPEG4 AAC LC, and one video track with MPEG4 AVC.

Definition at line 66 of file Ap4Mpeg2Ts.h.

Constructor & Destructor Documentation

AP4_Mpeg2TsWriter::AP4_Mpeg2TsWriter ( )
AP4_Mpeg2TsWriter::~AP4_Mpeg2TsWriter ( )

Member Function Documentation

Stream* AP4_Mpeg2TsWriter::GetPAT ( ) [inline]

Definition at line 116 of file Ap4Mpeg2Ts.h.

Stream* AP4_Mpeg2TsWriter::GetPMT ( ) [inline]

Definition at line 117 of file Ap4Mpeg2Ts.h.

AP4_Result AP4_Mpeg2TsWriter::SetAudioStream | ( | AP4_UI32 | timescale,
 |  | SampleStream *& | stream
 | ) |  |
AP4_Result AP4_Mpeg2TsWriter::SetVideoStream | ( | AP4_UI32 | timescale,
 |  | SampleStream *& | stream
 | ) |  |
AP4_Result AP4_Mpeg2TsWriter::WritePAT ( AP4_ByteStream & output )
AP4_Result AP4_Mpeg2TsWriter::WritePMT ( AP4_ByteStream & output )
The documentation for this class was generated from the following file:
  • Ap4Mpeg2Ts.h
Generated on Thu May 13 16:37:24 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_Mpeg2TsWriter Member List

This is the complete list of members for AP4_Mpeg2TsWriter, including all inherited members.
AP4_Mpeg2TsWriter() | AP4_Mpeg2TsWriter |
GetPAT() | AP4_Mpeg2TsWriter | [inline]
GetPMT() | AP4_Mpeg2TsWriter | [inline]
SetAudioStream(AP4_UI32 timescale, SampleStream *&stream) | AP4_Mpeg2TsWriter |
SetVideoStream(AP4_UI32 timescale, SampleStream *&stream) | AP4_Mpeg2TsWriter |
WritePAT(AP4_ByteStream &output) | AP4_Mpeg2TsWriter |
WritePMT(AP4_ByteStream &output) | AP4_Mpeg2TsWriter |
~AP4_Mpeg2TsWriter() | AP4_Mpeg2TsWriter |
Generated on Thu May 13 16:37:24 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_MpegAudioSampleDescription Class Reference

AP4_MpegAudioSampleDescription Class Reference

#include <Ap4SampleDescription.h>

Inheritance diagram for AP4_MpegAudioSampleDescription:
AP4_MpegSampleDescription AP4_AudioSampleDescription AP4_SampleDescription

List of all members.

Public Types

typedef AP4_UI08 | Mpeg4AudioObjectType

Public Member Functions

AP4_MpegAudioSampleDescription (unsigned int sample_rate, unsigned int sample_size, unsigned int channel_count, AP4_EsdsAtom *esds)
AP4_MpegAudioSampleDescription (OTI oti, unsigned int sample_rate, unsigned int sample_size, unsigned int channel_count, const AP4_DataBuffer *decoder_info, AP4_UI32 buffer_size, AP4_UI32 max_bitrate, AP4_UI32 avg_bitrate)
AP4_Atom * | ToAtom () const
Mpeg4AudioObjectType | GetMpeg4AudioObjectType () const
For sample descriptions of MPEG-4 audio tracks (i.e GetObjectTypeId() returns AP4_OTI_MPEG4_AUDIO), this method returns the MPEG4 Audio Object Type.

Static Public Member Functions

static const char * | GetMpeg4AudioObjectTypeString (Mpeg4AudioObjectType type)

Detailed Description

Definition at line 372 of file Ap4SampleDescription.h.

Member Typedef Documentation

typedef AP4_UI08 AP4_MpegAudioSampleDescription::Mpeg4AudioObjectType

Definition at line 379 of file Ap4SampleDescription.h.

Constructor & Destructor Documentation

AP4_MpegAudioSampleDescription::AP4_MpegAudioSampleDescription | ( | unsigned int | sample_rate,
 |  | unsigned int | sample_size,
 |  | unsigned int | channel_count,
 |  | AP4_EsdsAtom * | esds
 | ) |  |
AP4_MpegAudioSampleDescription::AP4_MpegAudioSampleDescription | ( | OTI | oti,
 |  | unsigned int | sample_rate,
 |  | unsigned int | sample_size,
 |  | unsigned int | channel_count,
 |  | const AP4_DataBuffer * | decoder_info,
 |  | AP4_UI32 | buffer_size,
 |  | AP4_UI32 | max_bitrate,
 |  | AP4_UI32 | avg_bitrate
 | ) |  |

Member Function Documentation

Mpeg4AudioObjectType AP4_MpegAudioSampleDescription::GetMpeg4AudioObjectType ( ) const

For sample descriptions of MPEG-4 audio tracks (i.e GetObjectTypeId() returns AP4_OTI_MPEG4_AUDIO), this method returns the MPEG4 Audio Object Type.

For other sample descriptions, this method returns 0.

static const char* AP4_MpegAudioSampleDescription::GetMpeg4AudioObjectTypeString ( Mpeg4AudioObjectType type ) [static]
AP4_Atom* AP4_MpegAudioSampleDescription::ToAtom ( ) const [virtual]

Reimplemented from AP4_SampleDescription.

The documentation for this class was generated from the following file:
  • Ap4SampleDescription.h
Generated on Thu May 13 16:37:24 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_MpegAudioSampleDescription Member List

This is the complete list of members for AP4_MpegAudioSampleDescription, including all inherited members.
AP4_AudioSampleDescription(unsigned int sample_rate, unsigned int sample_size, unsigned int channel_count) | AP4_AudioSampleDescription | [inline]
AP4_MpegAudioSampleDescription(unsigned int sample_rate, unsigned int sample_size, unsigned int channel_count, AP4_EsdsAtom *esds) | AP4_MpegAudioSampleDescription |
AP4_MpegAudioSampleDescription(OTI oti, unsigned int sample_rate, unsigned int sample_size, unsigned int channel_count, const AP4_DataBuffer *decoder_info, AP4_UI32 buffer_size, AP4_UI32 max_bitrate, AP4_UI32 avg_bitrate) | AP4_MpegAudioSampleDescription |
AP4_MpegSampleDescription(AP4_UI32 format, AP4_EsdsAtom *esds) | AP4_MpegSampleDescription |
AP4_MpegSampleDescription(AP4_UI32 format, StreamType stream_type, OTI oti, const AP4_DataBuffer *decoder_info, AP4_UI32 buffer_size, AP4_UI32 max_bitrate, AP4_UI32 avg_bitrate) | AP4_MpegSampleDescription |
AP4_SampleDescription(Type type, AP4_UI32 format, AP4_AtomParent *details) | AP4_SampleDescription |
Clone(AP4_Result *result=NULL) | AP4_SampleDescription | [virtual]
CreateEsDescriptor() const | AP4_MpegSampleDescription |
GetAvgBitrate() const | AP4_MpegSampleDescription | [inline]
GetBufferSize() const | AP4_MpegSampleDescription | [inline]
GetChannelCount() | AP4_AudioSampleDescription | [inline]
GetDecoderInfo() const | AP4_MpegSampleDescription | [inline]
GetDetails() | AP4_SampleDescription | [inline]
GetFormat() const | AP4_SampleDescription | [inline]
GetMaxBitrate() const | AP4_MpegSampleDescription | [inline]
GetMpeg4AudioObjectType() const | AP4_MpegAudioSampleDescription |
GetMpeg4AudioObjectTypeString(Mpeg4AudioObjectType type) | AP4_MpegAudioSampleDescription | [static]
GetObjectTypeId() const | AP4_MpegSampleDescription | [inline]
GetObjectTypeString(OTI oti) | AP4_MpegSampleDescription | [static]
GetSampleRate() | AP4_AudioSampleDescription | [inline]
GetSampleSize() | AP4_AudioSampleDescription | [inline]
GetStreamType() const | AP4_MpegSampleDescription | [inline]
GetStreamTypeString(StreamType type) | AP4_MpegSampleDescription | [static]
GetType() const | AP4_SampleDescription | [inline]
m_AvgBitrate | AP4_MpegSampleDescription | [protected]
m_BufferSize | AP4_MpegSampleDescription | [protected]
m_ChannelCount | AP4_AudioSampleDescription | [protected]
m_DecoderInfo | AP4_MpegSampleDescription | [protected]
m_Details | AP4_SampleDescription | [protected]
m_Format | AP4_MpegSampleDescription | [protected]
m_MaxBitrate | AP4_MpegSampleDescription | [protected]
m_ObjectTypeId | AP4_MpegSampleDescription | [protected]
m_SampleRate | AP4_AudioSampleDescription | [protected]
m_SampleSize | AP4_AudioSampleDescription | [protected]
m_StreamType | AP4_MpegSampleDescription | [protected]
m_Type | AP4_SampleDescription | [protected]
Mpeg4AudioObjectType typedef | AP4_MpegAudioSampleDescription |
OTI typedef | AP4_MpegSampleDescription |
StreamType typedef | AP4_MpegSampleDescription |
ToAtom() const | AP4_MpegAudioSampleDescription | [virtual]
Type enum name | AP4_SampleDescription |
TYPE_AVC enum value | AP4_SampleDescription |
TYPE_MPEG enum value | AP4_SampleDescription |
TYPE_PROTECTED enum value | AP4_SampleDescription |
TYPE_UNKNOWN enum value | AP4_SampleDescription |
~AP4_SampleDescription() | AP4_SampleDescription | [inline, virtual]
Generated on Thu May 13 16:37:24 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_MpegAudioSampleEntry Class Reference

AP4_MpegAudioSampleEntry Class Reference

#include <Ap4SampleEntry.h>

Inheritance diagram for AP4_MpegAudioSampleEntry:
AP4_AudioSampleEntry AP4_SampleEntry AP4_ContainerAtom AP4_Atom AP4_AtomParent AP4_Mp4aSampleEntry

List of all members.

Public Member Functions

AP4_MpegAudioSampleEntry (AP4_UI32 type, AP4_UI32 sample_rate, AP4_UI16 sample_size, AP4_UI16 channel_count, AP4_EsDescriptor *descriptor)
AP4_MpegAudioSampleEntry (AP4_UI32 type, AP4_Size size, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory)
AP4_SampleDescription * ToSampleDescription ()

Detailed Description

Definition at line 241 of file Ap4SampleEntry.h.

Constructor & Destructor Documentation

AP4_MpegAudioSampleEntry::AP4_MpegAudioSampleEntry | ( | AP4_UI32 | type,
 |  | AP4_UI32 | sample_rate,
 |  | AP4_UI16 | sample_size,
 |  | AP4_UI16 | channel_count,
 |  | AP4_EsDescriptor * | descriptor
 | ) |  |
AP4_MpegAudioSampleEntry::AP4_MpegAudioSampleEntry | ( | AP4_UI32 | type,
 |  | AP4_Size | size,
 |  | AP4_ByteStream & | stream,
 |  | AP4_AtomFactory & | atom_factory
 | ) |  |

Member Function Documentation

AP4_SampleDescription* AP4_MpegAudioSampleEntry::ToSampleDescription ( ) [virtual]

Reimplemented from AP4_AudioSampleEntry.

The documentation for this class was generated from the following file:
  • Ap4SampleEntry.h
Generated on Thu May 13 16:37:24 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_MpegAudioSampleEntry Member List

This is the complete list of members for AP4_MpegAudioSampleEntry, including all inherited members.
AddChild(AP4_Atom *child, int position=-1) | AP4_AtomParent | [virtual]
AP4_Atom(Type type, AP4_UI32 size=AP4_ATOM_HEADER_SIZE) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64=false) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_AudioSampleEntry(AP4_Atom::Type format, AP4_UI32 sample_rate, AP4_UI16 sample_size, AP4_UI16 channel_count) | AP4_AudioSampleEntry |
AP4_AudioSampleEntry(AP4_Atom::Type format, AP4_Size size, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_AudioSampleEntry |
AP4_ContainerAtom(Type type) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI32 version, AP4_UI32 flags) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_ContainerAtom | [protected]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_ContainerAtom | [protected]
AP4_MpegAudioSampleEntry(AP4_UI32 type, AP4_UI32 sample_rate, AP4_UI16 sample_size, AP4_UI16 channel_count, AP4_EsDescriptor *descriptor) | AP4_MpegAudioSampleEntry |
AP4_MpegAudioSampleEntry(AP4_UI32 type, AP4_Size size, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_MpegAudioSampleEntry |
AP4_SampleEntry(AP4_Atom::Type format, AP4_UI16 data_ref_index=1) | AP4_SampleEntry |
AP4_SampleEntry(AP4_Atom::Type format, AP4_Size size, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_SampleEntry |
AP4_SampleEntry(AP4_Atom::Type format, AP4_Size size) | AP4_SampleEntry | [protected]
Clone() | AP4_ContainerAtom | [virtual]
Create(Type type, AP4_UI64 size, bool is_full, bool force_64, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_ContainerAtom | [static]
DeleteChild(AP4_Atom::Type type, AP4_Ordinal index=0) | AP4_AtomParent | [virtual]
Detach() | AP4_Atom | [virtual]
FindChild(const char *path, bool auto_create=false, bool auto_create_full=false) | AP4_AtomParent | [virtual]
GetChannelCount() | AP4_AudioSampleEntry |
GetChild(AP4_Atom::Type type, AP4_Ordinal index=0) const | AP4_AtomParent | [virtual]
GetChild(const AP4_UI08 *uuid, AP4_Ordinal index=0) const | AP4_AtomParent | [virtual]
GetChildren() | AP4_ContainerAtom | [inline]
GetDataReferenceIndex() | AP4_SampleEntry | [inline]
GetFieldsSize() | AP4_AudioSampleEntry | [protected, virtual]
GetFlags() const | AP4_Atom | [inline]
GetHeaderSize() const | AP4_Atom | [virtual]
GetParent() | AP4_Atom | [inline, virtual]
GetSampleRate() | AP4_AudioSampleEntry |
GetSampleSize() | AP4_AudioSampleEntry | [inline]
GetSize() const | AP4_Atom | [inline]
GetSize32() const | AP4_Atom | [inline]
GetSize64() const | AP4_Atom | [inline]
GetType() const | AP4_Atom | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_SampleEntry | [virtual]
InspectChildren(AP4_AtomInspector &inspector) | AP4_ContainerAtom | [virtual]
InspectFields(AP4_AtomInspector &inspector) | AP4_AudioSampleEntry | [protected, virtual]
InspectHeader(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
m_ChannelCount | AP4_AudioSampleEntry | [protected]
m_Children | AP4_AtomParent | [protected]
m_DataReferenceIndex | AP4_SampleEntry | [protected]
m_Flags | AP4_Atom | [protected]
m_IsFull | AP4_Atom | [protected]
m_Parent | AP4_Atom | [protected]
m_QtCompressionId | AP4_AudioSampleEntry | [protected]
m_QtPacketSize | AP4_AudioSampleEntry | [protected]
m_QtRevision | AP4_AudioSampleEntry | [protected]
m_QtV1BytesPerFrame | AP4_AudioSampleEntry | [protected]
m_QtV1BytesPerPacket | AP4_AudioSampleEntry | [protected]
m_QtV1BytesPerSample | AP4_AudioSampleEntry | [protected]
m_QtV1SamplesPerPacket | AP4_AudioSampleEntry | [protected]
m_QtV2BitsPerChannel | AP4_AudioSampleEntry | [protected]
m_QtV2BytesPerAudioPacket | AP4_AudioSampleEntry | [protected]
m_QtV2ChannelCount | AP4_AudioSampleEntry | [protected]
m_QtV2Extension | AP4_AudioSampleEntry | [protected]
m_QtV2FormatSpecificFlags | AP4_AudioSampleEntry | [protected]
m_QtV2LPCMFramesPerAudioPacket | AP4_AudioSampleEntry | [protected]
m_QtV2Reserved | AP4_AudioSampleEntry | [protected]
m_QtV2SampleRate64 | AP4_AudioSampleEntry | [protected]
m_QtV2StructSize | AP4_AudioSampleEntry | [protected]
m_QtVendor | AP4_AudioSampleEntry | [protected]
m_QtVersion | AP4_AudioSampleEntry | [protected]
m_Reserved1 | AP4_SampleEntry | [protected]
m_SampleRate | AP4_AudioSampleEntry | [protected]
m_SampleSize | AP4_AudioSampleEntry | [protected]
m_Size32 | AP4_Atom | [protected]
m_Size64 | AP4_Atom | [protected]
m_Type | AP4_Atom | [protected]
m_Version | AP4_Atom | [protected]
OnChildAdded(AP4_Atom *child) | AP4_ContainerAtom | [virtual]
OnChildChanged(AP4_Atom *child) | AP4_SampleEntry | [virtual]
OnChildRemoved(AP4_Atom *child) | AP4_ContainerAtom | [virtual]
Read(AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_SampleEntry | [protected, virtual]
ReadChildren(AP4_AtomFactory &atom_factory, AP4_ByteStream &stream, AP4_UI64 size) | AP4_ContainerAtom | [protected]
ReadFields(AP4_ByteStream &stream) | AP4_AudioSampleEntry | [protected, virtual]
ReadFullHeader(AP4_ByteStream &stream, AP4_UI32 &version, AP4_UI32 &flags) | AP4_Atom | [static]
RemoveChild(AP4_Atom *child) | AP4_AtomParent | [virtual]
SetFlags(AP4_UI32 flags) | AP4_Atom | [inline]
SetParent(AP4_AtomParent *parent) | AP4_Atom | [inline, virtual]
SetSize(AP4_UI64 size, bool force_64=false) | AP4_Atom |
SetSize32(AP4_UI32 size) | AP4_Atom | [inline]
SetSize64(AP4_UI64 size) | AP4_Atom | [inline]
SetType(Type type) | AP4_Atom | [inline]
ToSampleDescription() | AP4_MpegAudioSampleEntry | [virtual]
Type typedef | AP4_Atom |
TypeFromString(const char *four_cc) | AP4_Atom | [static]
Write(AP4_ByteStream &stream) | AP4_SampleEntry | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_AudioSampleEntry | [protected, virtual]
WriteHeader(AP4_ByteStream &stream) | AP4_Atom | [virtual]
~AP4_Atom() | AP4_Atom | [inline, virtual]
~AP4_AtomParent() | AP4_AtomParent | [virtual]
~AP4_SampleEntry() | AP4_SampleEntry | [inline, virtual]
Generated on Thu May 13 16:37:24 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_MpegSampleDescription Class Reference

AP4_MpegSampleDescription Class Reference

#include <Ap4SampleDescription.h>

Inheritance diagram for AP4_MpegSampleDescription:
AP4_SampleDescription AP4_MpegAudioSampleDescription AP4_MpegSystemSampleDescription AP4_MpegVideoSampleDescription

List of all members.

Public Types

typedef AP4_UI08 | StreamType
typedef AP4_UI08 | OTI

Public Member Functions

AP4_MpegSampleDescription (AP4_UI32 format, AP4_EsdsAtom *esds)
AP4_MpegSampleDescription (AP4_UI32 format, StreamType stream_type, OTI oti, const AP4_DataBuffer *decoder_info, AP4_UI32 buffer_size, AP4_UI32 max_bitrate, AP4_UI32 avg_bitrate)
AP4_Byte | GetStreamType () const
AP4_Byte | GetObjectTypeId () const
AP4_UI32 | GetBufferSize () const
AP4_UI32 | GetMaxBitrate () const
AP4_UI32 | GetAvgBitrate () const
const AP4_DataBuffer & | GetDecoderInfo () const
AP4_EsDescriptor * | CreateEsDescriptor () const

Static Public Member Functions

static const char * | GetStreamTypeString (StreamType type)
static const char * | GetObjectTypeString (OTI oti)

Protected Attributes

AP4_UI32 m_Format
StreamType m_StreamType
OTI m_ObjectTypeId
AP4_UI32 m_BufferSize
AP4_UI32 m_MaxBitrate
AP4_UI32 m_AvgBitrate
AP4_DataBuffer m_DecoderInfo

Detailed Description

Definition at line 302 of file Ap4SampleDescription.h.

Member Typedef Documentation

typedef AP4_UI08 AP4_MpegSampleDescription::OTI

Definition at line 309 of file Ap4SampleDescription.h.

typedef AP4_UI08 AP4_MpegSampleDescription::StreamType

Definition at line 308 of file Ap4SampleDescription.h.

Constructor & Destructor Documentation

AP4_MpegSampleDescription::AP4_MpegSampleDescription | ( | AP4_UI32 | format,
 |  | AP4_EsdsAtom * | esds
 | ) |  |
AP4_MpegSampleDescription::AP4_MpegSampleDescription | ( | AP4_UI32 | format,
 |  | StreamType | stream_type,
 |  | OTI | oti,
 |  | const AP4_DataBuffer * | decoder_info,
 |  | AP4_UI32 | buffer_size,
 |  | AP4_UI32 | max_bitrate,
 |  | AP4_UI32 | avg_bitrate
 | ) |  |

Member Function Documentation

AP4_EsDescriptor* AP4_MpegSampleDescription::CreateEsDescriptor ( ) const
AP4_UI32 AP4_MpegSampleDescription::GetAvgBitrate ( ) const [inline]

Definition at line 331 of file Ap4SampleDescription.h.

References m_AvgBitrate.

AP4_UI32 AP4_MpegSampleDescription::GetBufferSize ( ) const [inline]

Definition at line 329 of file Ap4SampleDescription.h.

References m_BufferSize.

const AP4_DataBuffer& AP4_MpegSampleDescription::GetDecoderInfo ( ) const [inline]

Definition at line 332 of file Ap4SampleDescription.h.

References m_DecoderInfo.

AP4_UI32 AP4_MpegSampleDescription::GetMaxBitrate ( ) const [inline]

Definition at line 330 of file Ap4SampleDescription.h.

References m_MaxBitrate.

AP4_Byte AP4_MpegSampleDescription::GetObjectTypeId ( ) const [inline]

Definition at line 328 of file Ap4SampleDescription.h.

References m_ObjectTypeId.

static const char* AP4_MpegSampleDescription::GetObjectTypeString ( OTI oti ) [static]
AP4_Byte AP4_MpegSampleDescription::GetStreamType ( ) const [inline]

Definition at line 327 of file Ap4SampleDescription.h.

References m_StreamType.

static const char* AP4_MpegSampleDescription::GetStreamTypeString ( StreamType type ) [static]

Member Data Documentation

AP4_UI32 AP4_MpegSampleDescription::m_AvgBitrate [protected]

Definition at line 344 of file Ap4SampleDescription.h.

Referenced by GetAvgBitrate().

AP4_UI32 AP4_MpegSampleDescription::m_BufferSize [protected]

Definition at line 342 of file Ap4SampleDescription.h.

Referenced by GetBufferSize().

AP4_DataBuffer AP4_MpegSampleDescription::m_DecoderInfo [protected]

Definition at line 345 of file Ap4SampleDescription.h.

Referenced by GetDecoderInfo().

AP4_UI32 AP4_MpegSampleDescription::m_Format [protected]

Reimplemented from AP4_SampleDescription.

Definition at line 339 of file Ap4SampleDescription.h.

AP4_UI32 AP4_MpegSampleDescription::m_MaxBitrate [protected]

Definition at line 343 of file Ap4SampleDescription.h.

Referenced by GetMaxBitrate().

OTI AP4_MpegSampleDescription::m_ObjectTypeId [protected]

Definition at line 341 of file Ap4SampleDescription.h.

Referenced by GetObjectTypeId().

StreamType AP4_MpegSampleDescription::m_StreamType [protected]

Definition at line 340 of file Ap4SampleDescription.h.

Referenced by GetStreamType().

The documentation for this class was generated from the following file:
  • Ap4SampleDescription.h
Generated on Thu May 13 16:37:24 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_MpegSampleDescription Member List

This is the complete list of members for AP4_MpegSampleDescription, including all inherited members.
AP4_MpegSampleDescription(AP4_UI32 format, AP4_EsdsAtom *esds) | AP4_MpegSampleDescription |
AP4_MpegSampleDescription(AP4_UI32 format, StreamType stream_type, OTI oti, const AP4_DataBuffer *decoder_info, AP4_UI32 buffer_size, AP4_UI32 max_bitrate, AP4_UI32 avg_bitrate) | AP4_MpegSampleDescription |
AP4_SampleDescription(Type type, AP4_UI32 format, AP4_AtomParent *details) | AP4_SampleDescription |
Clone(AP4_Result *result=NULL) | AP4_SampleDescription | [virtual]
CreateEsDescriptor() const | AP4_MpegSampleDescription |
GetAvgBitrate() const | AP4_MpegSampleDescription | [inline]
GetBufferSize() const | AP4_MpegSampleDescription | [inline]
GetDecoderInfo() const | AP4_MpegSampleDescription | [inline]
GetDetails() | AP4_SampleDescription | [inline]
GetFormat() const | AP4_SampleDescription | [inline]
GetMaxBitrate() const | AP4_MpegSampleDescription | [inline]
GetObjectTypeId() const | AP4_MpegSampleDescription | [inline]
GetObjectTypeString(OTI oti) | AP4_MpegSampleDescription | [static]
GetStreamType() const | AP4_MpegSampleDescription | [inline]
GetStreamTypeString(StreamType type) | AP4_MpegSampleDescription | [static]
GetType() const | AP4_SampleDescription | [inline]
m_AvgBitrate | AP4_MpegSampleDescription | [protected]
m_BufferSize | AP4_MpegSampleDescription | [protected]
m_DecoderInfo | AP4_MpegSampleDescription | [protected]
m_Details | AP4_SampleDescription | [protected]
m_Format | AP4_MpegSampleDescription | [protected]
m_MaxBitrate | AP4_MpegSampleDescription | [protected]
m_ObjectTypeId | AP4_MpegSampleDescription | [protected]
m_StreamType | AP4_MpegSampleDescription | [protected]
m_Type | AP4_SampleDescription | [protected]
OTI typedef | AP4_MpegSampleDescription |
StreamType typedef | AP4_MpegSampleDescription |
ToAtom() const | AP4_SampleDescription | [virtual]
Type enum name | AP4_SampleDescription |
TYPE_AVC enum value | AP4_SampleDescription |
TYPE_MPEG enum value | AP4_SampleDescription |
TYPE_PROTECTED enum value | AP4_SampleDescription |
TYPE_UNKNOWN enum value | AP4_SampleDescription |
~AP4_SampleDescription() | AP4_SampleDescription | [inline, virtual]
Generated on Thu May 13 16:37:24 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_MpegSystemSampleDescription Class Reference

AP4_MpegSystemSampleDescription Class Reference

#include <Ap4SampleDescription.h>

Inheritance diagram for AP4_MpegSystemSampleDescription:
AP4_MpegSampleDescription AP4_SampleDescription

List of all members.

Public Member Functions

AP4_MpegSystemSampleDescription (AP4_EsdsAtom *esds)
AP4_MpegSystemSampleDescription (StreamType stream_type, OTI oti, const AP4_DataBuffer *decoder_info, AP4_UI32 buffer_size, AP4_UI32 max_bitrate, AP4_UI32 avg_bitrate)
AP4_Atom * ToAtom () const

Detailed Description

Definition at line 351 of file Ap4SampleDescription.h.

Constructor & Destructor Documentation

AP4_MpegSystemSampleDescription::AP4_MpegSystemSampleDescription ( AP4_EsdsAtom * esds )
AP4_MpegSystemSampleDescription::AP4_MpegSystemSampleDescription | ( | StreamType | stream_type,
 |  | OTI | oti,
 |  | const AP4_DataBuffer * | decoder_info,
 |  | AP4_UI32 | buffer_size,
 |  | AP4_UI32 | max_bitrate,
 |  | AP4_UI32 | avg_bitrate
 | ) |  |

Member Function Documentation

AP4_Atom* AP4_MpegSystemSampleDescription::ToAtom ( ) const [virtual]

Reimplemented from AP4_SampleDescription.

The documentation for this class was generated from the following file:
  • Ap4SampleDescription.h
Generated on Thu May 13 16:37:24 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_MpegSystemSampleDescription Member List

This is the complete list of members for AP4_MpegSystemSampleDescription, including all inherited members.
AP4_MpegSampleDescription(AP4_UI32 format, AP4_EsdsAtom *esds) | AP4_MpegSampleDescription |
AP4_MpegSampleDescription(AP4_UI32 format, StreamType stream_type, OTI oti, const AP4_DataBuffer *decoder_info, AP4_UI32 buffer_size, AP4_UI32 max_bitrate, AP4_UI32 avg_bitrate) | AP4_MpegSampleDescription |
AP4_MpegSystemSampleDescription(AP4_EsdsAtom *esds) | AP4_MpegSystemSampleDescription |
AP4_MpegSystemSampleDescription(StreamType stream_type, OTI oti, const AP4_DataBuffer *decoder_info, AP4_UI32 buffer_size, AP4_UI32 max_bitrate, AP4_UI32 avg_bitrate) | AP4_MpegSystemSampleDescription |
AP4_SampleDescription(Type type, AP4_UI32 format, AP4_AtomParent *details) | AP4_SampleDescription |
Clone(AP4_Result *result=NULL) | AP4_SampleDescription | [virtual]
CreateEsDescriptor() const | AP4_MpegSampleDescription |
GetAvgBitrate() const | AP4_MpegSampleDescription | [inline]
GetBufferSize() const | AP4_MpegSampleDescription | [inline]
GetDecoderInfo() const | AP4_MpegSampleDescription | [inline]
GetDetails() | AP4_SampleDescription | [inline]
GetFormat() const | AP4_SampleDescription | [inline]
GetMaxBitrate() const | AP4_MpegSampleDescription | [inline]
GetObjectTypeId() const | AP4_MpegSampleDescription | [inline]
GetObjectTypeString(OTI oti) | AP4_MpegSampleDescription | [static]
GetStreamType() const | AP4_MpegSampleDescription | [inline]
GetStreamTypeString(StreamType type) | AP4_MpegSampleDescription | [static]
GetType() const | AP4_SampleDescription | [inline]
m_AvgBitrate | AP4_MpegSampleDescription | [protected]
m_BufferSize | AP4_MpegSampleDescription | [protected]
m_DecoderInfo | AP4_MpegSampleDescription | [protected]
m_Details | AP4_SampleDescription | [protected]
m_Format | AP4_MpegSampleDescription | [protected]
m_MaxBitrate | AP4_MpegSampleDescription | [protected]
m_ObjectTypeId | AP4_MpegSampleDescription | [protected]
m_StreamType | AP4_MpegSampleDescription | [protected]
m_Type | AP4_SampleDescription | [protected]
OTI typedef | AP4_MpegSampleDescription |
StreamType typedef | AP4_MpegSampleDescription |
ToAtom() const | AP4_MpegSystemSampleDescription | [virtual]
Type enum name | AP4_SampleDescription |
TYPE_AVC enum value | AP4_SampleDescription |
TYPE_MPEG enum value | AP4_SampleDescription |
TYPE_PROTECTED enum value | AP4_SampleDescription |
TYPE_UNKNOWN enum value | AP4_SampleDescription |
~AP4_SampleDescription() | AP4_SampleDescription | [inline, virtual]
Generated on Thu May 13 16:37:24 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_MpegSystemSampleEntry Class Reference

AP4_MpegSystemSampleEntry Class Reference

#include <Ap4SampleEntry.h>

Inheritance diagram for AP4_MpegSystemSampleEntry:
AP4_SampleEntry AP4_ContainerAtom AP4_Atom AP4_AtomParent AP4_Mp4sSampleEntry

List of all members.

Public Member Functions

AP4_MpegSystemSampleEntry (AP4_UI32 type, AP4_EsDescriptor *descriptor)
AP4_MpegSystemSampleEntry (AP4_UI32 type, AP4_Size size, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory)
AP4_SampleDescription * ToSampleDescription ()

Detailed Description

Definition at line 223 of file Ap4SampleEntry.h.

Constructor & Destructor Documentation

AP4_MpegSystemSampleEntry::AP4_MpegSystemSampleEntry | ( | AP4_UI32 | type,
 |  | AP4_EsDescriptor * | descriptor
 | ) |  |
AP4_MpegSystemSampleEntry::AP4_MpegSystemSampleEntry | ( | AP4_UI32 | type,
 |  | AP4_Size | size,
 |  | AP4_ByteStream & | stream,
 |  | AP4_AtomFactory & | atom_factory
 | ) |  |

Member Function Documentation

AP4_SampleDescription* AP4_MpegSystemSampleEntry::ToSampleDescription ( ) [virtual]

Reimplemented from AP4_SampleEntry.

Reimplemented in AP4_Mp4sSampleEntry.

The documentation for this class was generated from the following file:
  • Ap4SampleEntry.h
Generated on Thu May 13 16:37:25 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_MpegSystemSampleEntry Member List

This is the complete list of members for AP4_MpegSystemSampleEntry, including all inherited members.
AddChild(AP4_Atom *child, int position=-1) | AP4_AtomParent | [virtual]
AP4_Atom(Type type, AP4_UI32 size=AP4_ATOM_HEADER_SIZE) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64=false) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_ContainerAtom(Type type) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI32 version, AP4_UI32 flags) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_ContainerAtom | [protected]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_ContainerAtom | [protected]
AP4_MpegSystemSampleEntry(AP4_UI32 type, AP4_EsDescriptor *descriptor) | AP4_MpegSystemSampleEntry |
AP4_MpegSystemSampleEntry(AP4_UI32 type, AP4_Size size, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_MpegSystemSampleEntry |
AP4_SampleEntry(AP4_Atom::Type format, AP4_UI16 data_ref_index=1) | AP4_SampleEntry |
AP4_SampleEntry(AP4_Atom::Type format, AP4_Size size, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_SampleEntry |
AP4_SampleEntry(AP4_Atom::Type format, AP4_Size size) | AP4_SampleEntry | [protected]
Clone() | AP4_ContainerAtom | [virtual]
Create(Type type, AP4_UI64 size, bool is_full, bool force_64, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_ContainerAtom | [static]
DeleteChild(AP4_Atom::Type type, AP4_Ordinal index=0) | AP4_AtomParent | [virtual]
Detach() | AP4_Atom | [virtual]
FindChild(const char *path, bool auto_create=false, bool auto_create_full=false) | AP4_AtomParent | [virtual]
GetChild(AP4_Atom::Type type, AP4_Ordinal index=0) const | AP4_AtomParent | [virtual]
GetChild(const AP4_UI08 *uuid, AP4_Ordinal index=0) const | AP4_AtomParent | [virtual]
GetChildren() | AP4_ContainerAtom | [inline]
GetDataReferenceIndex() | AP4_SampleEntry | [inline]
GetFieldsSize() | AP4_SampleEntry | [protected, virtual]
GetFlags() const | AP4_Atom | [inline]
GetHeaderSize() const | AP4_Atom | [virtual]
GetParent() | AP4_Atom | [inline, virtual]
GetSize() const | AP4_Atom | [inline]
GetSize32() const | AP4_Atom | [inline]
GetSize64() const | AP4_Atom | [inline]
GetType() const | AP4_Atom | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_SampleEntry | [virtual]
InspectChildren(AP4_AtomInspector &inspector) | AP4_ContainerAtom | [virtual]
InspectFields(AP4_AtomInspector &inspector) | AP4_SampleEntry | [protected, virtual]
InspectHeader(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
m_Children | AP4_AtomParent | [protected]
m_DataReferenceIndex | AP4_SampleEntry | [protected]
m_Flags | AP4_Atom | [protected]
m_IsFull | AP4_Atom | [protected]
m_Parent | AP4_Atom | [protected]
m_Reserved1 | AP4_SampleEntry | [protected]
m_Size32 | AP4_Atom | [protected]
m_Size64 | AP4_Atom | [protected]
m_Type | AP4_Atom | [protected]
m_Version | AP4_Atom | [protected]
OnChildAdded(AP4_Atom *child) | AP4_ContainerAtom | [virtual]
OnChildChanged(AP4_Atom *child) | AP4_SampleEntry | [virtual]
OnChildRemoved(AP4_Atom *child) | AP4_ContainerAtom | [virtual]
Read(AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_SampleEntry | [protected, virtual]
ReadChildren(AP4_AtomFactory &atom_factory, AP4_ByteStream &stream, AP4_UI64 size) | AP4_ContainerAtom | [protected]
ReadFields(AP4_ByteStream &stream) | AP4_SampleEntry | [protected, virtual]
ReadFullHeader(AP4_ByteStream &stream, AP4_UI32 &version, AP4_UI32 &flags) | AP4_Atom | [static]
RemoveChild(AP4_Atom *child) | AP4_AtomParent | [virtual]
SetFlags(AP4_UI32 flags) | AP4_Atom | [inline]
SetParent(AP4_AtomParent *parent) | AP4_Atom | [inline, virtual]
SetSize(AP4_UI64 size, bool force_64=false) | AP4_Atom |
SetSize32(AP4_UI32 size) | AP4_Atom | [inline]
SetSize64(AP4_UI64 size) | AP4_Atom | [inline]
SetType(Type type) | AP4_Atom | [inline]
ToSampleDescription() | AP4_MpegSystemSampleEntry | [virtual]
Type typedef | AP4_Atom |
TypeFromString(const char *four_cc) | AP4_Atom | [static]
Write(AP4_ByteStream &stream) | AP4_SampleEntry | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_SampleEntry | [protected, virtual]
WriteHeader(AP4_ByteStream &stream) | AP4_Atom | [virtual]
~AP4_Atom() | AP4_Atom | [inline, virtual]
~AP4_AtomParent() | AP4_AtomParent | [virtual]
~AP4_SampleEntry() | AP4_SampleEntry | [inline, virtual]
Generated on Thu May 13 16:37:25 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_MpegVideoSampleDescription Class Reference

AP4_MpegVideoSampleDescription Class Reference

#include <Ap4SampleDescription.h>

Inheritance diagram for AP4_MpegVideoSampleDescription:
AP4_MpegSampleDescription AP4_VideoSampleDescription AP4_SampleDescription

List of all members.

Public Member Functions

AP4_MpegVideoSampleDescription (AP4_UI16 width, AP4_UI16 height, AP4_UI16 depth, const char *compressor_name, AP4_EsdsAtom *esds)
AP4_MpegVideoSampleDescription (OTI oti, AP4_UI16 width, AP4_UI16 height, AP4_UI16 depth, const char *compressor_name, const AP4_DataBuffer *decoder_info, AP4_UI32 buffer_size, AP4_UI32 max_bitrate, AP4_UI32 avg_bitrate)
AP4_Atom * ToAtom () const

Detailed Description

Definition at line 413 of file Ap4SampleDescription.h.

Constructor & Destructor Documentation

AP4_MpegVideoSampleDescription::AP4_MpegVideoSampleDescription | ( | AP4_UI16 | width,
 |  | AP4_UI16 | height,
 |  | AP4_UI16 | depth,
 |  | const char * | compressor_name,
 |  | AP4_EsdsAtom * | esds
 | ) |  |
AP4_MpegVideoSampleDescription::AP4_MpegVideoSampleDescription | ( | OTI | oti,
 |  | AP4_UI16 | width,
 |  | AP4_UI16 | height,
 |  | AP4_UI16 | depth,
 |  | const char * | compressor_name,
 |  | const AP4_DataBuffer * | decoder_info,
 |  | AP4_UI32 | buffer_size,
 |  | AP4_UI32 | max_bitrate,
 |  | AP4_UI32 | avg_bitrate
 | ) |  |

Member Function Documentation

AP4_Atom* AP4_MpegVideoSampleDescription::ToAtom ( ) const [virtual]

Reimplemented from AP4_SampleDescription.

The documentation for this class was generated from the following file:
  • Ap4SampleDescription.h
Generated on Thu May 13 16:37:25 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_MpegVideoSampleDescription Member List

This is the complete list of members for AP4_MpegVideoSampleDescription, including all inherited members.
AP4_MpegSampleDescription(AP4_UI32 format, AP4_EsdsAtom *esds) | AP4_MpegSampleDescription |
AP4_MpegSampleDescription(AP4_UI32 format, StreamType stream_type, OTI oti, const AP4_DataBuffer *decoder_info, AP4_UI32 buffer_size, AP4_UI32 max_bitrate, AP4_UI32 avg_bitrate) | AP4_MpegSampleDescription |
AP4_MpegVideoSampleDescription(AP4_UI16 width, AP4_UI16 height, AP4_UI16 depth, const char *compressor_name, AP4_EsdsAtom *esds) | AP4_MpegVideoSampleDescription |
AP4_MpegVideoSampleDescription(OTI oti, AP4_UI16 width, AP4_UI16 height, AP4_UI16 depth, const char *compressor_name, const AP4_DataBuffer *decoder_info, AP4_UI32 buffer_size, AP4_UI32 max_bitrate, AP4_UI32 avg_bitrate) | AP4_MpegVideoSampleDescription |
AP4_SampleDescription(Type type, AP4_UI32 format, AP4_AtomParent *details) | AP4_SampleDescription |
AP4_VideoSampleDescription(AP4_UI16 width, AP4_UI16 height, AP4_UI16 depth, const char *compressor_name) | AP4_VideoSampleDescription | [inline]
Clone(AP4_Result *result=NULL) | AP4_SampleDescription | [virtual]
CreateEsDescriptor() const | AP4_MpegSampleDescription |
GetAvgBitrate() const | AP4_MpegSampleDescription | [inline]
GetBufferSize() const | AP4_MpegSampleDescription | [inline]
GetCompressorName() | AP4_VideoSampleDescription | [inline]
GetDecoderInfo() const | AP4_MpegSampleDescription | [inline]
GetDepth() | AP4_VideoSampleDescription | [inline]
GetDetails() | AP4_SampleDescription | [inline]
GetFormat() const | AP4_SampleDescription | [inline]
GetHeight() | AP4_VideoSampleDescription | [inline]
GetMaxBitrate() const | AP4_MpegSampleDescription | [inline]
GetObjectTypeId() const | AP4_MpegSampleDescription | [inline]
GetObjectTypeString(OTI oti) | AP4_MpegSampleDescription | [static]
GetStreamType() const | AP4_MpegSampleDescription | [inline]
GetStreamTypeString(StreamType type) | AP4_MpegSampleDescription | [static]
GetType() const | AP4_SampleDescription | [inline]
GetWidth() | AP4_VideoSampleDescription | [inline]
m_AvgBitrate | AP4_MpegSampleDescription | [protected]
m_BufferSize | AP4_MpegSampleDescription | [protected]
m_CompressorName | AP4_VideoSampleDescription | [protected]
m_DecoderInfo | AP4_MpegSampleDescription | [protected]
m_Depth | AP4_VideoSampleDescription | [protected]
m_Details | AP4_SampleDescription | [protected]
m_Format | AP4_MpegSampleDescription | [protected]
m_Height | AP4_VideoSampleDescription | [protected]
m_MaxBitrate | AP4_MpegSampleDescription | [protected]
m_ObjectTypeId | AP4_MpegSampleDescription | [protected]
m_StreamType | AP4_MpegSampleDescription | [protected]
m_Type | AP4_SampleDescription | [protected]
m_Width | AP4_VideoSampleDescription | [protected]
OTI typedef | AP4_MpegSampleDescription |
StreamType typedef | AP4_MpegSampleDescription |
ToAtom() const | AP4_MpegVideoSampleDescription | [virtual]
Type enum name | AP4_SampleDescription |
TYPE_AVC enum value | AP4_SampleDescription |
TYPE_MPEG enum value | AP4_SampleDescription |
TYPE_PROTECTED enum value | AP4_SampleDescription |
TYPE_UNKNOWN enum value | AP4_SampleDescription |
~AP4_SampleDescription() | AP4_SampleDescription | [inline, virtual]
Generated on Thu May 13 16:37:25 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_MpegVideoSampleEntry Class Reference

AP4_MpegVideoSampleEntry Class Reference

#include <Ap4SampleEntry.h>

Inheritance diagram for AP4_MpegVideoSampleEntry:
AP4_VisualSampleEntry AP4_SampleEntry AP4_ContainerAtom AP4_Atom AP4_AtomParent AP4_Mp4vSampleEntry

List of all members.

Public Member Functions

AP4_MpegVideoSampleEntry (AP4_UI32 type, AP4_UI16 width, AP4_UI16 height, AP4_UI16 depth, const char *compressor_name, AP4_EsDescriptor *descriptor)
AP4_MpegVideoSampleEntry (AP4_UI32 type, AP4_Size size, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory)
AP4_SampleDescription * ToSampleDescription ()

Detailed Description

Definition at line 262 of file Ap4SampleEntry.h.

Constructor & Destructor Documentation

AP4_MpegVideoSampleEntry::AP4_MpegVideoSampleEntry | ( | AP4_UI32 | type,
 |  | AP4_UI16 | width,
 |  | AP4_UI16 | height,
 |  | AP4_UI16 | depth,
 |  | const char * | compressor_name,
 |  | AP4_EsDescriptor * | descriptor
 | ) |  |
AP4_MpegVideoSampleEntry::AP4_MpegVideoSampleEntry | ( | AP4_UI32 | type,
 |  | AP4_Size | size,
 |  | AP4_ByteStream & | stream,
 |  | AP4_AtomFactory & | atom_factory
 | ) |  |

Member Function Documentation

AP4_SampleDescription* AP4_MpegVideoSampleEntry::ToSampleDescription ( ) [virtual]

Reimplemented from AP4_VisualSampleEntry.

The documentation for this class was generated from the following file:
  • Ap4SampleEntry.h
Generated on Thu May 13 16:37:25 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_MpegVideoSampleEntry Member List

This is the complete list of members for AP4_MpegVideoSampleEntry, including all inherited members.
AddChild(AP4_Atom *child, int position=-1) | AP4_AtomParent | [virtual]
AP4_Atom(Type type, AP4_UI32 size=AP4_ATOM_HEADER_SIZE) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64=false) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_ContainerAtom(Type type) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI32 version, AP4_UI32 flags) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_ContainerAtom | [protected]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_ContainerAtom | [protected]
AP4_MpegVideoSampleEntry(AP4_UI32 type, AP4_UI16 width, AP4_UI16 height, AP4_UI16 depth, const char *compressor_name, AP4_EsDescriptor *descriptor) | AP4_MpegVideoSampleEntry |
AP4_MpegVideoSampleEntry(AP4_UI32 type, AP4_Size size, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_MpegVideoSampleEntry |
AP4_SampleEntry(AP4_Atom::Type format, AP4_UI16 data_ref_index=1) | AP4_SampleEntry |
AP4_SampleEntry(AP4_Atom::Type format, AP4_Size size, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_SampleEntry |
AP4_SampleEntry(AP4_Atom::Type format, AP4_Size size) | AP4_SampleEntry | [protected]
AP4_VisualSampleEntry(AP4_Atom::Type format, AP4_UI16 width, AP4_UI16 height, AP4_UI16 depth, const char *compressor_name) | AP4_VisualSampleEntry |
AP4_VisualSampleEntry(AP4_Atom::Type format, AP4_Size size, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_VisualSampleEntry |
Clone() | AP4_ContainerAtom | [virtual]
Create(Type type, AP4_UI64 size, bool is_full, bool force_64, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_ContainerAtom | [static]
DeleteChild(AP4_Atom::Type type, AP4_Ordinal index=0) | AP4_AtomParent | [virtual]
Detach() | AP4_Atom | [virtual]
FindChild(const char *path, bool auto_create=false, bool auto_create_full=false) | AP4_AtomParent | [virtual]
GetChild(AP4_Atom::Type type, AP4_Ordinal index=0) const | AP4_AtomParent | [virtual]
GetChild(const AP4_UI08 *uuid, AP4_Ordinal index=0) const | AP4_AtomParent | [virtual]
GetChildren() | AP4_ContainerAtom | [inline]
GetCompressorName() | AP4_VisualSampleEntry | [inline]
GetDataReferenceIndex() | AP4_SampleEntry | [inline]
GetDepth() | AP4_VisualSampleEntry | [inline]
GetFieldsSize() | AP4_VisualSampleEntry | [protected, virtual]
GetFlags() const | AP4_Atom | [inline]
GetHeaderSize() const | AP4_Atom | [virtual]
GetHeight() | AP4_VisualSampleEntry | [inline]
GetHorizResolution() | AP4_VisualSampleEntry | [inline]
GetParent() | AP4_Atom | [inline, virtual]
GetSize() const | AP4_Atom | [inline]
GetSize32() const | AP4_Atom | [inline]
GetSize64() const | AP4_Atom | [inline]
GetType() const | AP4_Atom | [inline]
GetVertResolution() | AP4_VisualSampleEntry | [inline]
GetWidth() | AP4_VisualSampleEntry | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_SampleEntry | [virtual]
InspectChildren(AP4_AtomInspector &inspector) | AP4_ContainerAtom | [virtual]
InspectFields(AP4_AtomInspector &inspector) | AP4_VisualSampleEntry | [protected, virtual]
InspectHeader(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
m_Children | AP4_AtomParent | [protected]
m_CompressorName | AP4_VisualSampleEntry | [protected]
m_DataReferenceIndex | AP4_SampleEntry | [protected]
m_Depth | AP4_VisualSampleEntry | [protected]
m_Flags | AP4_Atom | [protected]
m_FrameCount | AP4_VisualSampleEntry | [protected]
m_Height | AP4_VisualSampleEntry | [protected]
m_HorizResolution | AP4_VisualSampleEntry | [protected]
m_IsFull | AP4_Atom | [protected]
m_Parent | AP4_Atom | [protected]
m_Predefined1 | AP4_VisualSampleEntry | [protected]
m_Predefined2 | AP4_VisualSampleEntry | [protected]
m_Predefined3 | AP4_VisualSampleEntry | [protected]
m_Reserved1 | AP4_SampleEntry | [protected]
m_Reserved2 | AP4_VisualSampleEntry | [protected]
m_Reserved3 | AP4_VisualSampleEntry | [protected]
m_Size32 | AP4_Atom | [protected]
m_Size64 | AP4_Atom | [protected]
m_Type | AP4_Atom | [protected]
m_Version | AP4_Atom | [protected]
m_VertResolution | AP4_VisualSampleEntry | [protected]
m_Width | AP4_VisualSampleEntry | [protected]
OnChildAdded(AP4_Atom *child) | AP4_ContainerAtom | [virtual]
OnChildChanged(AP4_Atom *child) | AP4_SampleEntry | [virtual]
OnChildRemoved(AP4_Atom *child) | AP4_ContainerAtom | [virtual]
Read(AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_SampleEntry | [protected, virtual]
ReadChildren(AP4_AtomFactory &atom_factory, AP4_ByteStream &stream, AP4_UI64 size) | AP4_ContainerAtom | [protected]
ReadFields(AP4_ByteStream &stream) | AP4_VisualSampleEntry | [protected, virtual]
ReadFullHeader(AP4_ByteStream &stream, AP4_UI32 &version, AP4_UI32 &flags) | AP4_Atom | [static]
RemoveChild(AP4_Atom *child) | AP4_AtomParent | [virtual]
SetFlags(AP4_UI32 flags) | AP4_Atom | [inline]
SetParent(AP4_AtomParent *parent) | AP4_Atom | [inline, virtual]
SetSize(AP4_UI64 size, bool force_64=false) | AP4_Atom |
SetSize32(AP4_UI32 size) | AP4_Atom | [inline]
SetSize64(AP4_UI64 size) | AP4_Atom | [inline]
SetType(Type type) | AP4_Atom | [inline]
ToSampleDescription() | AP4_MpegVideoSampleEntry | [virtual]
Type typedef | AP4_Atom |
TypeFromString(const char *four_cc) | AP4_Atom | [static]
Write(AP4_ByteStream &stream) | AP4_SampleEntry | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_VisualSampleEntry | [protected, virtual]
WriteHeader(AP4_ByteStream &stream) | AP4_Atom | [virtual]
~AP4_Atom() | AP4_Atom | [inline, virtual]
~AP4_AtomParent() | AP4_AtomParent | [virtual]
~AP4_SampleEntry() | AP4_SampleEntry | [inline, virtual]
Generated on Thu May 13 16:37:25 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_MvhdAtom Class Reference

AP4_MvhdAtom Class Reference

#include <Ap4MvhdAtom.h>

Inheritance diagram for AP4_MvhdAtom:
AP4_Atom

List of all members.

Public Member Functions

AP4_MvhdAtom (AP4_UI32 creation_time, AP4_UI32 modification_time, AP4_UI32 time_scale, AP4_UI32 duration, AP4_UI32 rate, AP4_UI16 volume)
virtual AP4_Result | InspectFields (AP4_AtomInspector &inspector)
virtual AP4_Result | WriteFields (AP4_ByteStream &stream)
AP4_UI64 GetDuration ()
void | SetDuration (AP4_UI64 duration)
AP4_UI32 GetDurationMs ()
AP4_UI32 GetTimeScale ()
AP4_Result | SetTimeScale (AP4_UI32 time_scale)

Static Public Member Functions

static AP4_MvhdAtom * | Create (AP4_Size size, AP4_ByteStream &stream)

Detailed Description

Definition at line 41 of file Ap4MvhdAtom.h.

Constructor & Destructor Documentation

AP4_MvhdAtom::AP4_MvhdAtom | ( | AP4_UI32 | creation_time,
 |  | AP4_UI32 | modification_time,
 |  | AP4_UI32 | time_scale,
 |  | AP4_UI32 | duration,
 |  | AP4_UI32 | rate,
 |  | AP4_UI16 | volume
 | ) |  |

Member Function Documentation

static AP4_MvhdAtom* AP4_MvhdAtom::Create | ( | AP4_Size | size,
 |  | AP4_ByteStream & | stream |
 | ) |  |  | [static]
AP4_UI64 AP4_MvhdAtom::GetDuration ( ) [inline]

Definition at line 58 of file Ap4MvhdAtom.h.

AP4_UI32 AP4_MvhdAtom::GetDurationMs ( )
AP4_UI32 AP4_MvhdAtom::GetTimeScale ( ) [inline]

Definition at line 61 of file Ap4MvhdAtom.h.

virtual AP4_Result AP4_MvhdAtom::InspectFields ( AP4_AtomInspector & inspector ) [virtual]

Reimplemented from AP4_Atom.

void AP4_MvhdAtom::SetDuration ( AP4_UI64 duration ) [inline]

Definition at line 59 of file Ap4MvhdAtom.h.

AP4_Result AP4_MvhdAtom::SetTimeScale ( AP4_UI32 time_scale ) [inline]

Definition at line 62 of file Ap4MvhdAtom.h.

References AP4_SUCCESS.

virtual AP4_Result AP4_MvhdAtom::WriteFields ( AP4_ByteStream & stream ) [virtual]

Implements AP4_Atom.

The documentation for this class was generated from the following file:
  • Ap4MvhdAtom.h
Generated on Thu May 13 16:37:25 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_MvhdAtom Member List

This is the complete list of members for AP4_MvhdAtom, including all inherited members.
AP4_Atom(Type type, AP4_UI32 size=AP4_ATOM_HEADER_SIZE) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64=false) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_MvhdAtom(AP4_UI32 creation_time, AP4_UI32 modification_time, AP4_UI32 time_scale, AP4_UI32 duration, AP4_UI32 rate, AP4_UI16 volume) | AP4_MvhdAtom |
Clone() | AP4_Atom | [virtual]
Create(AP4_Size size, AP4_ByteStream &stream) | AP4_MvhdAtom | [static]
Detach() | AP4_Atom | [virtual]
GetDuration() | AP4_MvhdAtom | [inline]
GetDurationMs() | AP4_MvhdAtom |
GetFlags() const | AP4_Atom | [inline]
GetHeaderSize() const | AP4_Atom | [virtual]
GetParent() | AP4_Atom | [inline, virtual]
GetSize() const | AP4_Atom | [inline]
GetSize32() const | AP4_Atom | [inline]
GetSize64() const | AP4_Atom | [inline]
GetTimeScale() | AP4_MvhdAtom | [inline]
GetType() const | AP4_Atom | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
InspectFields(AP4_AtomInspector &inspector) | AP4_MvhdAtom | [virtual]
InspectHeader(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
m_Flags | AP4_Atom | [protected]
m_IsFull | AP4_Atom | [protected]
m_Parent | AP4_Atom | [protected]
m_Size32 | AP4_Atom | [protected]
m_Size64 | AP4_Atom | [protected]
m_Type | AP4_Atom | [protected]
m_Version | AP4_Atom | [protected]
ReadFullHeader(AP4_ByteStream &stream, AP4_UI32 &version, AP4_UI32 &flags) | AP4_Atom | [static]
SetDuration(AP4_UI64 duration) | AP4_MvhdAtom | [inline]
SetFlags(AP4_UI32 flags) | AP4_Atom | [inline]
SetParent(AP4_AtomParent *parent) | AP4_Atom | [inline, virtual]
SetSize(AP4_UI64 size, bool force_64=false) | AP4_Atom |
SetSize32(AP4_UI32 size) | AP4_Atom | [inline]
SetSize64(AP4_UI64 size) | AP4_Atom | [inline]
SetTimeScale(AP4_UI32 time_scale) | AP4_MvhdAtom | [inline]
SetType(Type type) | AP4_Atom | [inline]
Type typedef | AP4_Atom |
TypeFromString(const char *four_cc) | AP4_Atom | [static]
Write(AP4_ByteStream &stream) | AP4_Atom | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_MvhdAtom | [virtual]
WriteHeader(AP4_ByteStream &stream) | AP4_Atom | [virtual]
~AP4_Atom() | AP4_Atom | [inline, virtual]
Generated on Thu May 13 16:37:25 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_NmhdAtom Class Reference

AP4_NmhdAtom Class Reference

#include <Ap4NmhdAtom.h>

Inheritance diagram for AP4_NmhdAtom:
AP4_Atom

List of all members.

Public Member Functions

AP4_NmhdAtom ()
virtual AP4_Result | WriteFields (AP4_ByteStream &stream)

Static Public Member Functions

static AP4_NmhdAtom * | Create (AP4_Size size, AP4_ByteStream &stream)

Detailed Description

Definition at line 40 of file Ap4NmhdAtom.h.

Constructor & Destructor Documentation

AP4_NmhdAtom::AP4_NmhdAtom ( )

Member Function Documentation

static AP4_NmhdAtom* AP4_NmhdAtom::Create | ( | AP4_Size | size,
 |  | AP4_ByteStream & | stream |
 | ) |  |  | [static]
virtual AP4_Result AP4_NmhdAtom::WriteFields ( AP4_ByteStream & stream ) [virtual]

Implements AP4_Atom.

The documentation for this class was generated from the following file:
  • Ap4NmhdAtom.h
Generated on Thu May 13 16:37:25 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_NmhdAtom Member List

This is the complete list of members for AP4_NmhdAtom, including all inherited members.
AP4_Atom(Type type, AP4_UI32 size=AP4_ATOM_HEADER_SIZE) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64=false) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_NmhdAtom() | AP4_NmhdAtom |
Clone() | AP4_Atom | [virtual]
Create(AP4_Size size, AP4_ByteStream &stream) | AP4_NmhdAtom | [static]
Detach() | AP4_Atom | [virtual]
GetFlags() const | AP4_Atom | [inline]
GetHeaderSize() const | AP4_Atom | [virtual]
GetParent() | AP4_Atom | [inline, virtual]
GetSize() const | AP4_Atom | [inline]
GetSize32() const | AP4_Atom | [inline]
GetSize64() const | AP4_Atom | [inline]
GetType() const | AP4_Atom | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
InspectFields(AP4_AtomInspector &) | AP4_Atom | [inline, virtual]
InspectHeader(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
m_Flags | AP4_Atom | [protected]
m_IsFull | AP4_Atom | [protected]
m_Parent | AP4_Atom | [protected]
m_Size32 | AP4_Atom | [protected]
m_Size64 | AP4_Atom | [protected]
m_Type | AP4_Atom | [protected]
m_Version | AP4_Atom | [protected]
ReadFullHeader(AP4_ByteStream &stream, AP4_UI32 &version, AP4_UI32 &flags) | AP4_Atom | [static]
SetFlags(AP4_UI32 flags) | AP4_Atom | [inline]
SetParent(AP4_AtomParent *parent) | AP4_Atom | [inline, virtual]
SetSize(AP4_UI64 size, bool force_64=false) | AP4_Atom |
SetSize32(AP4_UI32 size) | AP4_Atom | [inline]
SetSize64(AP4_UI64 size) | AP4_Atom | [inline]
SetType(Type type) | AP4_Atom | [inline]
Type typedef | AP4_Atom |
TypeFromString(const char *four_cc) | AP4_Atom | [static]
Write(AP4_ByteStream &stream) | AP4_Atom | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_NmhdAtom | [virtual]
WriteHeader(AP4_ByteStream &stream) | AP4_Atom | [virtual]
~AP4_Atom() | AP4_Atom | [inline, virtual]
Generated on Thu May 13 16:37:25 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_NoopRtpConstructor Class Reference

AP4_NoopRtpConstructor Class Reference

#include <Ap4RtpHint.h>

Inheritance diagram for AP4_NoopRtpConstructor:
AP4_RtpConstructor AP4_Referenceable

List of all members.

Public Member Functions

AP4_NoopRtpConstructor (AP4_ByteStream &stream)
AP4_NoopRtpConstructor ()
virtual AP4_Size | GetConstructedDataSize ()

Protected Member Functions

virtual AP4_Result | DoWrite (AP4_ByteStream &stream)

Detailed Description

Definition at line 182 of file Ap4RtpHint.h.

Constructor & Destructor Documentation

AP4_NoopRtpConstructor::AP4_NoopRtpConstructor ( AP4_ByteStream & stream )
AP4_NoopRtpConstructor::AP4_NoopRtpConstructor ( ) [inline]

Definition at line 187 of file Ap4RtpHint.h.

Member Function Documentation

virtual AP4_Result AP4_NoopRtpConstructor::DoWrite ( AP4_ByteStream & stream ) [protected, virtual]

Implements AP4_RtpConstructor.

virtual AP4_Size AP4_NoopRtpConstructor::GetConstructedDataSize ( ) [inline, virtual]

Implements AP4_RtpConstructor.

Definition at line 190 of file Ap4RtpHint.h.

The documentation for this class was generated from the following file:
  • Ap4RtpHint.h
Generated on Thu May 13 16:37:25 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_NoopRtpConstructor Member List

This is the complete list of members for AP4_NoopRtpConstructor, including all inherited members.
AddReference() | AP4_RtpConstructor | [virtual]
AP4_NoopRtpConstructor(AP4_ByteStream &stream) | AP4_NoopRtpConstructor |
AP4_NoopRtpConstructor() | AP4_NoopRtpConstructor | [inline]
AP4_RtpConstructor(Type type) | AP4_RtpConstructor | [inline]
DoWrite(AP4_ByteStream &stream) | AP4_NoopRtpConstructor | [protected, virtual]
GetConstructedDataSize() | AP4_NoopRtpConstructor | [inline, virtual]
GetType() const | AP4_RtpConstructor | [inline]
m_ReferenceCount | AP4_RtpConstructor | [protected]
m_Type | AP4_RtpConstructor | [protected]
Release() | AP4_RtpConstructor | [virtual]
Type typedef | AP4_RtpConstructor |
Write(AP4_ByteStream &stream) | AP4_RtpConstructor |
~AP4_Referenceable() | AP4_Referenceable | [inline, virtual]
~AP4_RtpConstructor() | AP4_RtpConstructor | [inline, protected, virtual]
Generated on Thu May 13 16:37:25 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_NullTerminatedStringAtom Class Reference

AP4_NullTerminatedStringAtom Class Reference

Generic Class usd for all atoms that contain a single null-terminated string. More...

#include <Ap4Atom.h>

Inheritance diagram for AP4_NullTerminatedStringAtom:
AP4_Atom

List of all members.

Public Member Functions

AP4_NullTerminatedStringAtom (AP4_Atom::Type type, AP4_UI64 size, AP4_ByteStream &stream)
AP4_NullTerminatedStringAtom (AP4_Atom::Type type, const char *value)
const AP4_String & | GetValue ()
virtual AP4_Result | InspectFields (AP4_AtomInspector &inspector)
virtual AP4_Result | WriteFields (AP4_ByteStream &stream)

Detailed Description

Generic Class usd for all atoms that contain a single null-terminated string.

Definition at line 318 of file Ap4Atom.h.

Constructor & Destructor Documentation

AP4_NullTerminatedStringAtom::AP4_NullTerminatedStringAtom | ( | AP4_Atom::Type | type,
 |  | AP4_UI64 | size,
 |  | AP4_ByteStream & | stream
 | ) |  |
AP4_NullTerminatedStringAtom::AP4_NullTerminatedStringAtom | ( | AP4_Atom::Type | type,
 |  | const char * | value
 | ) |  |

Member Function Documentation

const AP4_String& AP4_NullTerminatedStringAtom::GetValue ( ) [inline]

Definition at line 328 of file Ap4Atom.h.

virtual AP4_Result AP4_NullTerminatedStringAtom::InspectFields ( AP4_AtomInspector & inspector ) [virtual]

Reimplemented from AP4_Atom.

virtual AP4_Result AP4_NullTerminatedStringAtom::WriteFields ( AP4_ByteStream & stream ) [virtual]

Implements AP4_Atom.

The documentation for this class was generated from the following file:
  • Ap4Atom.h
Generated on Thu May 13 16:37:25 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_NullTerminatedStringAtom Member List

This is the complete list of members for AP4_NullTerminatedStringAtom, including all inherited members.
AP4_Atom(Type type, AP4_UI32 size=AP4_ATOM_HEADER_SIZE) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64=false) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_NullTerminatedStringAtom(AP4_Atom::Type type, AP4_UI64 size, AP4_ByteStream &stream) | AP4_NullTerminatedStringAtom |
AP4_NullTerminatedStringAtom(AP4_Atom::Type type, const char *value) | AP4_NullTerminatedStringAtom |
Clone() | AP4_Atom | [virtual]
Detach() | AP4_Atom | [virtual]
GetFlags() const | AP4_Atom | [inline]
GetHeaderSize() const | AP4_Atom | [virtual]
GetParent() | AP4_Atom | [inline, virtual]
GetSize() const | AP4_Atom | [inline]
GetSize32() const | AP4_Atom | [inline]
GetSize64() const | AP4_Atom | [inline]
GetType() const | AP4_Atom | [inline]
GetValue() | AP4_NullTerminatedStringAtom | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
InspectFields(AP4_AtomInspector &inspector) | AP4_NullTerminatedStringAtom | [virtual]
InspectHeader(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
m_Flags | AP4_Atom | [protected]
m_IsFull | AP4_Atom | [protected]
m_Parent | AP4_Atom | [protected]
m_Size32 | AP4_Atom | [protected]
m_Size64 | AP4_Atom | [protected]
m_Type | AP4_Atom | [protected]
m_Version | AP4_Atom | [protected]
ReadFullHeader(AP4_ByteStream &stream, AP4_UI32 &version, AP4_UI32 &flags) | AP4_Atom | [static]
SetFlags(AP4_UI32 flags) | AP4_Atom | [inline]
SetParent(AP4_AtomParent *parent) | AP4_Atom | [inline, virtual]
SetSize(AP4_UI64 size, bool force_64=false) | AP4_Atom |
SetSize32(AP4_UI32 size) | AP4_Atom | [inline]
SetSize64(AP4_UI64 size) | AP4_Atom | [inline]
SetType(Type type) | AP4_Atom | [inline]
Type typedef | AP4_Atom |
TypeFromString(const char *four_cc) | AP4_Atom | [static]
Write(AP4_ByteStream &stream) | AP4_Atom | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_NullTerminatedStringAtom | [virtual]
WriteHeader(AP4_ByteStream &stream) | AP4_Atom | [virtual]
~AP4_Atom() | AP4_Atom | [inline, virtual]
Generated on Thu May 13 16:37:25 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_ObjectDescriptor Class Reference

AP4_ObjectDescriptor Class Reference

#include <Ap4ObjectDescriptor.h>

Inheritance diagram for AP4_ObjectDescriptor:
AP4_Descriptor AP4_Expandable AP4_InitialObjectDescriptor

List of all members.

Public Member Functions

AP4_ObjectDescriptor (AP4_ByteStream &stream, AP4_UI08 tag, AP4_Size header_size, AP4_Size payload_size)
AP4_ObjectDescriptor (AP4_UI08 tag, AP4_UI16 id)
virtual | ~AP4_ObjectDescriptor ()
virtual AP4_Result | AddSubDescriptor (AP4_Descriptor *descriptor)
Add a sub-descriptor.
virtual AP4_Descriptor * | FindSubDescriptor (AP4_UI08 tag) const
virtual AP4_Result | WriteFields (AP4_ByteStream &stream)
virtual AP4_Result | Inspect (AP4_AtomInspector &inspector)
AP4_UI16 | GetObjectDescriptorId () const
bool | GetUrlFlag () const
const AP4_String & | GetUrl () const

Protected Member Functions

AP4_ObjectDescriptor (AP4_UI08 tag, AP4_Size header_size, AP4_Size payload_size)

Protected Attributes

AP4_UI16 m_ObjectDescriptorId
bool | m_UrlFlag
AP4_String m_Url
AP4_List< AP4_Descriptor > m_SubDescriptors

Detailed Description

Definition at line 56 of file Ap4ObjectDescriptor.h.

Constructor & Destructor Documentation

AP4_ObjectDescriptor::AP4_ObjectDescriptor | ( | AP4_ByteStream & | stream,
 |  | AP4_UI08 | tag,
 |  | AP4_Size | header_size,
 |  | AP4_Size | payload_size
 | ) |  |
AP4_ObjectDescriptor::AP4_ObjectDescriptor | ( | AP4_UI08 | tag,
 |  | AP4_UI16 | id
 | ) |  |
virtual AP4_ObjectDescriptor::~AP4_ObjectDescriptor ( ) [virtual]
AP4_ObjectDescriptor::AP4_ObjectDescriptor | ( | AP4_UI08 | tag,
 |  | AP4_Size | header_size,
 |  | AP4_Size | payload_size |
 | ) |  |  | [protected]

Member Function Documentation

virtual AP4_Result AP4_ObjectDescriptor::AddSubDescriptor ( AP4_Descriptor * descriptor ) [virtual]

Add a sub-descriptor.

Ownership of the sub-descriptor object is transfered.

virtual AP4_Descriptor* AP4_ObjectDescriptor::FindSubDescriptor ( AP4_UI08 tag ) const [virtual]
AP4_UI16 AP4_ObjectDescriptor::GetObjectDescriptorId ( ) const [inline]

Definition at line 80 of file Ap4ObjectDescriptor.h.

References m_ObjectDescriptorId.

const AP4_String& AP4_ObjectDescriptor::GetUrl ( ) const [inline]

Definition at line 82 of file Ap4ObjectDescriptor.h.

References m_Url.

bool AP4_ObjectDescriptor::GetUrlFlag ( ) const [inline]

Definition at line 81 of file Ap4ObjectDescriptor.h.

References m_UrlFlag.

virtual AP4_Result AP4_ObjectDescriptor::Inspect ( AP4_AtomInspector & inspector ) [virtual]

Reimplemented from AP4_Descriptor.

Reimplemented in AP4_InitialObjectDescriptor.

virtual AP4_Result AP4_ObjectDescriptor::WriteFields ( AP4_ByteStream & stream ) [virtual]

Implements AP4_Expandable.

Reimplemented in AP4_InitialObjectDescriptor.

Member Data Documentation

AP4_UI16 AP4_ObjectDescriptor::m_ObjectDescriptorId [protected]

Definition at line 89 of file Ap4ObjectDescriptor.h.

Referenced by GetObjectDescriptorId().

AP4_List<AP4_Descriptor> AP4_ObjectDescriptor::m_SubDescriptors [mutable, protected]

Definition at line 92 of file Ap4ObjectDescriptor.h.

AP4_String AP4_ObjectDescriptor::m_Url [protected]

Definition at line 91 of file Ap4ObjectDescriptor.h.

Referenced by GetUrl().

bool AP4_ObjectDescriptor::m_UrlFlag [protected]

Definition at line 90 of file Ap4ObjectDescriptor.h.

Referenced by GetUrlFlag().

The documentation for this class was generated from the following file:
  • Ap4ObjectDescriptor.h
Generated on Thu May 13 16:37:26 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_ObjectDescriptor Member List

This is the complete list of members for AP4_ObjectDescriptor, including all inherited members.
AddSubDescriptor(AP4_Descriptor *descriptor) | AP4_ObjectDescriptor | [virtual]
AP4_Descriptor(AP4_UI08 tag, AP4_Size header_size, AP4_Size payload_size) | AP4_Descriptor | [inline]
AP4_Expandable(AP4_UI32 class_id, ClassIdSize class_id_size, AP4_Size header_size, AP4_Size payload_size) | AP4_Expandable |
AP4_ObjectDescriptor(AP4_ByteStream &stream, AP4_UI08 tag, AP4_Size header_size, AP4_Size payload_size) | AP4_ObjectDescriptor |
AP4_ObjectDescriptor(AP4_UI08 tag, AP4_UI16 id) | AP4_ObjectDescriptor |
AP4_ObjectDescriptor(AP4_UI08 tag, AP4_Size header_size, AP4_Size payload_size) | AP4_ObjectDescriptor | [protected]
CLASS_ID_SIZE_08 enum value | AP4_Expandable |
ClassIdSize enum name | AP4_Expandable |
FindSubDescriptor(AP4_UI08 tag) const | AP4_ObjectDescriptor | [virtual]
GetClassId() | AP4_Expandable | [inline]
GetHeaderSize() | AP4_Expandable | [inline]
GetObjectDescriptorId() const | AP4_ObjectDescriptor | [inline]
GetSize() | AP4_Expandable | [inline]
GetTag() | AP4_Descriptor | [inline]
GetUrl() const | AP4_ObjectDescriptor | [inline]
GetUrlFlag() const | AP4_ObjectDescriptor | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_ObjectDescriptor | [virtual]
m_ClassId | AP4_Expandable | [protected]
m_ClassIdSize | AP4_Expandable | [protected]
m_HeaderSize | AP4_Expandable | [protected]
m_ObjectDescriptorId | AP4_ObjectDescriptor | [protected]
m_PayloadSize | AP4_Expandable | [protected]
m_SubDescriptors | AP4_ObjectDescriptor | [mutable, protected]
m_Url | AP4_ObjectDescriptor | [protected]
m_UrlFlag | AP4_ObjectDescriptor | [protected]
MinHeaderSize(AP4_Size payload_size) | AP4_Expandable | [static]
Write(AP4_ByteStream &stream) | AP4_Expandable | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_ObjectDescriptor | [virtual]
~AP4_Expandable() | AP4_Expandable | [inline, virtual]
~AP4_ObjectDescriptor() | AP4_ObjectDescriptor | [virtual]
Generated on Thu May 13 16:37:26 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_OdafAtom Class Reference

AP4_OdafAtom Class Reference

#include <Ap4OdafAtom.h>

Inheritance diagram for AP4_OdafAtom:
AP4_Atom

List of all members.

Public Member Functions

AP4_OdafAtom (bool m_SelectiveEncryption, AP4_UI08 m_KeyIndicatorLength, AP4_UI08 m_IvLength)
virtual AP4_Result | InspectFields (AP4_AtomInspector &inspector)
virtual AP4_Result | WriteFields (AP4_ByteStream &stream)
bool | GetSelectiveEncryption ()
AP4_UI08 GetKeyIndicatorLength ()
AP4_UI08 GetIvLength ()

Static Public Member Functions

static AP4_OdafAtom * | Create (AP4_Size size, AP4_ByteStream &stream)

Detailed Description

Definition at line 41 of file Ap4OdafAtom.h.

Constructor & Destructor Documentation

AP4_OdafAtom::AP4_OdafAtom | ( | bool | m_SelectiveEncryption,
 |  | AP4_UI08 | m_KeyIndicatorLength,
 |  | AP4_UI08 | m_IvLength
 | ) |  |

Member Function Documentation

static AP4_OdafAtom* AP4_OdafAtom::Create | ( | AP4_Size | size,
 |  | AP4_ByteStream & | stream |
 | ) |  |  | [static]
AP4_UI08 AP4_OdafAtom::GetIvLength ( ) [inline]

Definition at line 59 of file Ap4OdafAtom.h.

AP4_UI08 AP4_OdafAtom::GetKeyIndicatorLength ( ) [inline]

Definition at line 58 of file Ap4OdafAtom.h.

bool AP4_OdafAtom::GetSelectiveEncryption ( ) [inline]

Definition at line 57 of file Ap4OdafAtom.h.

virtual AP4_Result AP4_OdafAtom::InspectFields ( AP4_AtomInspector & inspector ) [virtual]

Reimplemented from AP4_Atom.

virtual AP4_Result AP4_OdafAtom::WriteFields ( AP4_ByteStream & stream ) [virtual]

Implements AP4_Atom.

The documentation for this class was generated from the following file:
  • Ap4OdafAtom.h
Generated on Thu May 13 16:37:26 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_OdafAtom Member List

This is the complete list of members for AP4_OdafAtom, including all inherited members.
AP4_Atom(Type type, AP4_UI32 size=AP4_ATOM_HEADER_SIZE) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64=false) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_OdafAtom(bool m_SelectiveEncryption, AP4_UI08 m_KeyIndicatorLength, AP4_UI08 m_IvLength) | AP4_OdafAtom |
Clone() | AP4_Atom | [virtual]
Create(AP4_Size size, AP4_ByteStream &stream) | AP4_OdafAtom | [static]
Detach() | AP4_Atom | [virtual]
GetFlags() const | AP4_Atom | [inline]
GetHeaderSize() const | AP4_Atom | [virtual]
GetIvLength() | AP4_OdafAtom | [inline]
GetKeyIndicatorLength() | AP4_OdafAtom | [inline]
GetParent() | AP4_Atom | [inline, virtual]
GetSelectiveEncryption() | AP4_OdafAtom | [inline]
GetSize() const | AP4_Atom | [inline]
GetSize32() const | AP4_Atom | [inline]
GetSize64() const | AP4_Atom | [inline]
GetType() const | AP4_Atom | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
InspectFields(AP4_AtomInspector &inspector) | AP4_OdafAtom | [virtual]
InspectHeader(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
m_Flags | AP4_Atom | [protected]
m_IsFull | AP4_Atom | [protected]
m_Parent | AP4_Atom | [protected]
m_Size32 | AP4_Atom | [protected]
m_Size64 | AP4_Atom | [protected]
m_Type | AP4_Atom | [protected]
m_Version | AP4_Atom | [protected]
ReadFullHeader(AP4_ByteStream &stream, AP4_UI32 &version, AP4_UI32 &flags) | AP4_Atom | [static]
SetFlags(AP4_UI32 flags) | AP4_Atom | [inline]
SetParent(AP4_AtomParent *parent) | AP4_Atom | [inline, virtual]
SetSize(AP4_UI64 size, bool force_64=false) | AP4_Atom |
SetSize32(AP4_UI32 size) | AP4_Atom | [inline]
SetSize64(AP4_UI64 size) | AP4_Atom | [inline]
SetType(Type type) | AP4_Atom | [inline]
Type typedef | AP4_Atom |
TypeFromString(const char *four_cc) | AP4_Atom | [static]
Write(AP4_ByteStream &stream) | AP4_Atom | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_OdafAtom | [virtual]
WriteHeader(AP4_ByteStream &stream) | AP4_Atom | [virtual]
~AP4_Atom() | AP4_Atom | [inline, virtual]
Generated on Thu May 13 16:37:26 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_OddaAtom Class Reference

AP4_OddaAtom Class Reference

#include <Ap4OddaAtom.h>

Inheritance diagram for AP4_OddaAtom:
AP4_Atom

List of all members.

Public Member Functions

AP4_OddaAtom (AP4_ByteStream &encrypted_payload)
~AP4_OddaAtom ()
virtual AP4_Result | InspectFields (AP4_AtomInspector &inspector)
virtual AP4_Result | WriteFields (AP4_ByteStream &stream)
AP4_UI64 GetEncryptedDataLength ()
AP4_Result | SetEncryptedPayload (AP4_ByteStream &stream)
Sets the encrypted payload stream (and releases any existing stream references).
AP4_Result | SetEncryptedPayload (AP4_ByteStream &stream, AP4_LargeSize length)
AP4_ByteStream & GetEncryptedPayload ()
Returns a reference to the encrypted payload stream (does not increment the reference counter).

Static Public Member Functions

static AP4_OddaAtom * | Create (AP4_UI64 size, AP4_ByteStream &stream)

Detailed Description

Definition at line 42 of file Ap4OddaAtom.h.

Constructor & Destructor Documentation

AP4_OddaAtom::AP4_OddaAtom ( AP4_ByteStream & encrypted_payload )
AP4_OddaAtom::~AP4_OddaAtom ( )

Member Function Documentation

static AP4_OddaAtom* AP4_OddaAtom::Create | ( | AP4_UI64 | size,
 |  | AP4_ByteStream & | stream |
 | ) |  |  | [static]
AP4_UI64 AP4_OddaAtom::GetEncryptedDataLength ( ) [inline]

Definition at line 62 of file Ap4OddaAtom.h.

AP4_ByteStream& AP4_OddaAtom::GetEncryptedPayload ( ) [inline]

Returns a reference to the encrypted payload stream (does not increment the reference counter).

Definition at line 73 of file Ap4OddaAtom.h.

virtual AP4_Result AP4_OddaAtom::InspectFields ( AP4_AtomInspector & inspector ) [virtual]

Reimplemented from AP4_Atom.

AP4_Result AP4_OddaAtom::SetEncryptedPayload | ( | AP4_ByteStream & | stream,
 |  | AP4_LargeSize | length
 | ) |  |
AP4_Result AP4_OddaAtom::SetEncryptedPayload ( AP4_ByteStream & stream )

Sets the encrypted payload stream (and releases any existing stream references).

virtual AP4_Result AP4_OddaAtom::WriteFields ( AP4_ByteStream & stream ) [virtual]

Implements AP4_Atom.

The documentation for this class was generated from the following file:
  • Ap4OddaAtom.h
Generated on Thu May 13 16:37:26 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_OddaAtom Member List

This is the complete list of members for AP4_OddaAtom, including all inherited members.
AP4_Atom(Type type, AP4_UI32 size=AP4_ATOM_HEADER_SIZE) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64=false) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_OddaAtom(AP4_ByteStream &encrypted_payload) | AP4_OddaAtom |
Clone() | AP4_Atom | [virtual]
Create(AP4_UI64 size, AP4_ByteStream &stream) | AP4_OddaAtom | [static]
Detach() | AP4_Atom | [virtual]
GetEncryptedDataLength() | AP4_OddaAtom | [inline]
GetEncryptedPayload() | AP4_OddaAtom | [inline]
GetFlags() const | AP4_Atom | [inline]
GetHeaderSize() const | AP4_Atom | [virtual]
GetParent() | AP4_Atom | [inline, virtual]
GetSize() const | AP4_Atom | [inline]
GetSize32() const | AP4_Atom | [inline]
GetSize64() const | AP4_Atom | [inline]
GetType() const | AP4_Atom | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
InspectFields(AP4_AtomInspector &inspector) | AP4_OddaAtom | [virtual]
InspectHeader(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
m_Flags | AP4_Atom | [protected]
m_IsFull | AP4_Atom | [protected]
m_Parent | AP4_Atom | [protected]
m_Size32 | AP4_Atom | [protected]
m_Size64 | AP4_Atom | [protected]
m_Type | AP4_Atom | [protected]
m_Version | AP4_Atom | [protected]
ReadFullHeader(AP4_ByteStream &stream, AP4_UI32 &version, AP4_UI32 &flags) | AP4_Atom | [static]
SetEncryptedPayload(AP4_ByteStream &stream) | AP4_OddaAtom |
SetEncryptedPayload(AP4_ByteStream &stream, AP4_LargeSize length) | AP4_OddaAtom |
SetFlags(AP4_UI32 flags) | AP4_Atom | [inline]
SetParent(AP4_AtomParent *parent) | AP4_Atom | [inline, virtual]
SetSize(AP4_UI64 size, bool force_64=false) | AP4_Atom |
SetSize32(AP4_UI32 size) | AP4_Atom | [inline]
SetSize64(AP4_UI64 size) | AP4_Atom | [inline]
SetType(Type type) | AP4_Atom | [inline]
Type typedef | AP4_Atom |
TypeFromString(const char *four_cc) | AP4_Atom | [static]
Write(AP4_ByteStream &stream) | AP4_Atom | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_OddaAtom | [virtual]
WriteHeader(AP4_ByteStream &stream) | AP4_Atom | [virtual]
~AP4_Atom() | AP4_Atom | [inline, virtual]
~AP4_OddaAtom() | AP4_OddaAtom |
Generated on Thu May 13 16:37:26 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_OdheAtom Class Reference

AP4_OdheAtom Class Reference

#include <Ap4OdheAtom.h>

Inheritance diagram for AP4_OdheAtom:
AP4_ContainerAtom AP4_Atom AP4_AtomParent

List of all members.

Public Member Functions

AP4_OdheAtom (const char *content_type, AP4_OhdrAtom *ohdr)
virtual AP4_Result | InspectFields (AP4_AtomInspector &inspector)
virtual AP4_Result | WriteFields (AP4_ByteStream &stream)
virtual void | OnChildChanged (AP4_Atom *child)
const AP4_String & | GetContentType ()

Static Public Member Functions

static AP4_OdheAtom * | Create (AP4_Size size, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory)

Detailed Description

Definition at line 48 of file Ap4OdheAtom.h.

Constructor & Destructor Documentation

AP4_OdheAtom::AP4_OdheAtom | ( | const char * | content_type,
 |  | AP4_OhdrAtom * | ohdr
 | ) |  |
Parameters:
ohdr ohdr atom passed with transfer of ownership semantics

Member Function Documentation

static AP4_OdheAtom* AP4_OdheAtom::Create | ( | AP4_Size | size,
 |  | AP4_ByteStream & | stream,
 |  | AP4_AtomFactory & | atom_factory |
 | ) |  |  | [static]
const AP4_String& AP4_OdheAtom::GetContentType ( ) [inline]

Definition at line 72 of file Ap4OdheAtom.h.

virtual AP4_Result AP4_OdheAtom::InspectFields ( AP4_AtomInspector & inspector ) [virtual]

Reimplemented from AP4_ContainerAtom.

virtual void AP4_OdheAtom::OnChildChanged ( AP4_Atom * child ) [virtual]

Reimplemented from AP4_ContainerAtom.

virtual AP4_Result AP4_OdheAtom::WriteFields ( AP4_ByteStream & stream ) [virtual]

Reimplemented from AP4_ContainerAtom.

The documentation for this class was generated from the following file:
  • Ap4OdheAtom.h
Generated on Thu May 13 16:37:26 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_OdheAtom Member List

This is the complete list of members for AP4_OdheAtom, including all inherited members.
AddChild(AP4_Atom *child, int position=-1) | AP4_AtomParent | [virtual]
AP4_Atom(Type type, AP4_UI32 size=AP4_ATOM_HEADER_SIZE) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64=false) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_ContainerAtom(Type type) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI32 version, AP4_UI32 flags) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_ContainerAtom | [protected]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_ContainerAtom | [protected]
AP4_OdheAtom(const char *content_type, AP4_OhdrAtom *ohdr) | AP4_OdheAtom |
Clone() | AP4_ContainerAtom | [virtual]
Create(AP4_Size size, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_OdheAtom | [static]
AP4_ContainerAtom::Create(Type type, AP4_UI64 size, bool is_full, bool force_64, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_ContainerAtom | [static]
DeleteChild(AP4_Atom::Type type, AP4_Ordinal index=0) | AP4_AtomParent | [virtual]
Detach() | AP4_Atom | [virtual]
FindChild(const char *path, bool auto_create=false, bool auto_create_full=false) | AP4_AtomParent | [virtual]
GetChild(AP4_Atom::Type type, AP4_Ordinal index=0) const | AP4_AtomParent | [virtual]
GetChild(const AP4_UI08 *uuid, AP4_Ordinal index=0) const | AP4_AtomParent | [virtual]
GetChildren() | AP4_ContainerAtom | [inline]
GetContentType() | AP4_OdheAtom | [inline]
GetFlags() const | AP4_Atom | [inline]
GetHeaderSize() const | AP4_Atom | [virtual]
GetParent() | AP4_Atom | [inline, virtual]
GetSize() const | AP4_Atom | [inline]
GetSize32() const | AP4_Atom | [inline]
GetSize64() const | AP4_Atom | [inline]
GetType() const | AP4_Atom | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
InspectChildren(AP4_AtomInspector &inspector) | AP4_ContainerAtom | [virtual]
InspectFields(AP4_AtomInspector &inspector) | AP4_OdheAtom | [virtual]
InspectHeader(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
m_Children | AP4_AtomParent | [protected]
m_Flags | AP4_Atom | [protected]
m_IsFull | AP4_Atom | [protected]
m_Parent | AP4_Atom | [protected]
m_Size32 | AP4_Atom | [protected]
m_Size64 | AP4_Atom | [protected]
m_Type | AP4_Atom | [protected]
m_Version | AP4_Atom | [protected]
OnChildAdded(AP4_Atom *child) | AP4_ContainerAtom | [virtual]
OnChildChanged(AP4_Atom *child) | AP4_OdheAtom | [virtual]
OnChildRemoved(AP4_Atom *child) | AP4_ContainerAtom | [virtual]
ReadChildren(AP4_AtomFactory &atom_factory, AP4_ByteStream &stream, AP4_UI64 size) | AP4_ContainerAtom | [protected]
ReadFullHeader(AP4_ByteStream &stream, AP4_UI32 &version, AP4_UI32 &flags) | AP4_Atom | [static]
RemoveChild(AP4_Atom *child) | AP4_AtomParent | [virtual]
SetFlags(AP4_UI32 flags) | AP4_Atom | [inline]
SetParent(AP4_AtomParent *parent) | AP4_Atom | [inline, virtual]
SetSize(AP4_UI64 size, bool force_64=false) | AP4_Atom |
SetSize32(AP4_UI32 size) | AP4_Atom | [inline]
SetSize64(AP4_UI64 size) | AP4_Atom | [inline]
SetType(Type type) | AP4_Atom | [inline]
Type typedef | AP4_Atom |
TypeFromString(const char *four_cc) | AP4_Atom | [static]
Write(AP4_ByteStream &stream) | AP4_Atom | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_OdheAtom | [virtual]
WriteHeader(AP4_ByteStream &stream) | AP4_Atom | [virtual]
~AP4_Atom() | AP4_Atom | [inline, virtual]
~AP4_AtomParent() | AP4_AtomParent | [virtual]
Generated on Thu May 13 16:37:26 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_OhdrAtom Class Reference

AP4_OhdrAtom Class Reference

#include <Ap4OhdrAtom.h>

Inheritance diagram for AP4_OhdrAtom:
AP4_ContainerAtom AP4_OmaDrmInfo AP4_Atom AP4_AtomParent

List of all members.

Public Member Functions

AP4_OhdrAtom (AP4_UI08 encryption_method, AP4_UI08 padding_scheme, AP4_UI64 plaintext_length, const char *content_id, const char *rights_issuer_url, const AP4_Byte *textual_headers, AP4_Size textual_headers_size)
virtual AP4_Result | InspectFields (AP4_AtomInspector &inspector)
virtual AP4_Result | WriteFields (AP4_ByteStream &stream)
virtual AP4_Atom * | Clone ()
Create a clone of the object.
AP4_UI08 | GetEncryptionMethod () const
void | SetEncryptionMethod (AP4_UI08 encryption_method)
AP4_UI08 | GetPaddingScheme () const
void | SetPaddingScheme (AP4_UI08 padding_scheme)
AP4_UI64 | GetPlaintextLength () const
const AP4_String & | GetContentId () const
const AP4_String & | GetRightsIssuerUrl () const
const AP4_DataBuffer & | GetTextualHeaders () const

Static Public Member Functions

static AP4_OhdrAtom * | Create (AP4_Size size, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory)

Detailed Description

Definition at line 54 of file Ap4OhdrAtom.h.

Constructor & Destructor Documentation

AP4_OhdrAtom::AP4_OhdrAtom | ( | AP4_UI08 | encryption_method,
 |  | AP4_UI08 | padding_scheme,
 |  | AP4_UI64 | plaintext_length,
 |  | const char * | content_id,
 |  | const char * | rights_issuer_url,
 |  | const AP4_Byte * | textual_headers,
 |  | AP4_Size | textual_headers_size
 | ) |  |

Member Function Documentation

virtual AP4_Atom* AP4_OhdrAtom::Clone ( ) [virtual]

Create a clone of the object.

This method returns a clone of the atom, or NULL if the atom cannot be cloned. Override this if your want to make an atom cloneable in a more efficient way than the default implementation.

Reimplemented from AP4_ContainerAtom.

static AP4_OhdrAtom* AP4_OhdrAtom::Create | ( | AP4_Size | size,
 |  | AP4_ByteStream & | stream,
 |  | AP4_AtomFactory & | atom_factory |
 | ) |  |  | [static]
const AP4_String& AP4_OhdrAtom::GetContentId ( ) const [inline, virtual]

Implements AP4_OmaDrmInfo.

Definition at line 86 of file Ap4OhdrAtom.h.

AP4_UI08 AP4_OhdrAtom::GetEncryptionMethod ( ) const [inline]

Definition at line 79 of file Ap4OhdrAtom.h.

AP4_UI08 AP4_OhdrAtom::GetPaddingScheme ( ) const [inline]

Definition at line 81 of file Ap4OhdrAtom.h.

AP4_UI64 AP4_OhdrAtom::GetPlaintextLength ( ) const [inline]

Definition at line 83 of file Ap4OhdrAtom.h.

const AP4_String& AP4_OhdrAtom::GetRightsIssuerUrl ( ) const [inline, virtual]

Implements AP4_OmaDrmInfo.

Definition at line 87 of file Ap4OhdrAtom.h.

const AP4_DataBuffer& AP4_OhdrAtom::GetTextualHeaders ( ) const [inline, virtual]

Implements AP4_OmaDrmInfo.

Definition at line 88 of file Ap4OhdrAtom.h.

virtual AP4_Result AP4_OhdrAtom::InspectFields ( AP4_AtomInspector & inspector ) [virtual]

Reimplemented from AP4_ContainerAtom.

void AP4_OhdrAtom::SetEncryptionMethod ( AP4_UI08 encryption_method ) [inline]

Definition at line 80 of file Ap4OhdrAtom.h.

void AP4_OhdrAtom::SetPaddingScheme ( AP4_UI08 padding_scheme ) [inline]

Definition at line 82 of file Ap4OhdrAtom.h.

virtual AP4_Result AP4_OhdrAtom::WriteFields ( AP4_ByteStream & stream ) [virtual]

Reimplemented from AP4_ContainerAtom.

The documentation for this class was generated from the following file:
  • Ap4OhdrAtom.h
Generated on Thu May 13 16:37:26 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_OhdrAtom Member List

This is the complete list of members for AP4_OhdrAtom, including all inherited members.
AddChild(AP4_Atom *child, int position=-1) | AP4_AtomParent | [virtual]
AP4_Atom(Type type, AP4_UI32 size=AP4_ATOM_HEADER_SIZE) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64=false) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_ContainerAtom(Type type) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI32 version, AP4_UI32 flags) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_ContainerAtom | [protected]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_ContainerAtom | [protected]
AP4_OhdrAtom(AP4_UI08 encryption_method, AP4_UI08 padding_scheme, AP4_UI64 plaintext_length, const char *content_id, const char *rights_issuer_url, const AP4_Byte *textual_headers, AP4_Size textual_headers_size) | AP4_OhdrAtom |
Clone() | AP4_OhdrAtom | [virtual]
Create(AP4_Size size, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_OhdrAtom | [static]
AP4_ContainerAtom::Create(Type type, AP4_UI64 size, bool is_full, bool force_64, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_ContainerAtom | [static]
DeleteChild(AP4_Atom::Type type, AP4_Ordinal index=0) | AP4_AtomParent | [virtual]
Detach() | AP4_Atom | [virtual]
FindChild(const char *path, bool auto_create=false, bool auto_create_full=false) | AP4_AtomParent | [virtual]
GetChild(AP4_Atom::Type type, AP4_Ordinal index=0) const | AP4_AtomParent | [virtual]
GetChild(const AP4_UI08 *uuid, AP4_Ordinal index=0) const | AP4_AtomParent | [virtual]
GetChildren() | AP4_ContainerAtom | [inline]
GetContentId() const | AP4_OhdrAtom | [inline, virtual]
GetEncryptionMethod() const | AP4_OhdrAtom | [inline]
GetFlags() const | AP4_Atom | [inline]
GetHeaderSize() const | AP4_Atom | [virtual]
GetPaddingScheme() const | AP4_OhdrAtom | [inline]
GetParent() | AP4_Atom | [inline, virtual]
GetPlaintextLength() const | AP4_OhdrAtom | [inline]
GetRightsIssuerUrl() const | AP4_OhdrAtom | [inline, virtual]
GetSize() const | AP4_Atom | [inline]
GetSize32() const | AP4_Atom | [inline]
GetSize64() const | AP4_Atom | [inline]
GetTextualHeaders() const | AP4_OhdrAtom | [inline, virtual]
GetType() const | AP4_Atom | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
InspectChildren(AP4_AtomInspector &inspector) | AP4_ContainerAtom | [virtual]
InspectFields(AP4_AtomInspector &inspector) | AP4_OhdrAtom | [virtual]
InspectHeader(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
m_Children | AP4_AtomParent | [protected]
m_Flags | AP4_Atom | [protected]
m_IsFull | AP4_Atom | [protected]
m_Parent | AP4_Atom | [protected]
m_Size32 | AP4_Atom | [protected]
m_Size64 | AP4_Atom | [protected]
m_Type | AP4_Atom | [protected]
m_Version | AP4_Atom | [protected]
OnChildAdded(AP4_Atom *child) | AP4_ContainerAtom | [virtual]
OnChildChanged(AP4_Atom *child) | AP4_ContainerAtom | [virtual]
OnChildRemoved(AP4_Atom *child) | AP4_ContainerAtom | [virtual]
ReadChildren(AP4_AtomFactory &atom_factory, AP4_ByteStream &stream, AP4_UI64 size) | AP4_ContainerAtom | [protected]
ReadFullHeader(AP4_ByteStream &stream, AP4_UI32 &version, AP4_UI32 &flags) | AP4_Atom | [static]
RemoveChild(AP4_Atom *child) | AP4_AtomParent | [virtual]
SetEncryptionMethod(AP4_UI08 encryption_method) | AP4_OhdrAtom | [inline]
SetFlags(AP4_UI32 flags) | AP4_Atom | [inline]
SetPaddingScheme(AP4_UI08 padding_scheme) | AP4_OhdrAtom | [inline]
SetParent(AP4_AtomParent *parent) | AP4_Atom | [inline, virtual]
SetSize(AP4_UI64 size, bool force_64=false) | AP4_Atom |
SetSize32(AP4_UI32 size) | AP4_Atom | [inline]
SetSize64(AP4_UI64 size) | AP4_Atom | [inline]
SetType(Type type) | AP4_Atom | [inline]
Type typedef | AP4_Atom |
TypeFromString(const char *four_cc) | AP4_Atom | [static]
Write(AP4_ByteStream &stream) | AP4_Atom | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_OhdrAtom | [virtual]
WriteHeader(AP4_ByteStream &stream) | AP4_Atom | [virtual]
~AP4_Atom() | AP4_Atom | [inline, virtual]
~AP4_AtomParent() | AP4_AtomParent | [virtual]
~AP4_OmaDrmInfo() | AP4_OmaDrmInfo | [inline, virtual]
Generated on Thu May 13 16:37:26 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_OmaDcfAtomDecrypter Class Reference

AP4_OmaDcfAtomDecrypter Class Reference

#include <Ap4OmaDcf.h>

List of all members.

Static Public Member Functions

static AP4_Result | DecryptAtoms (AP4_AtomParent &atoms, AP4_Processor::ProgressListener *listener, AP4_BlockCipherFactory *block_cipher_factory, AP4_ProtectionKeyMap &key_map)
static AP4_Result | CreateDecryptingStream (AP4_ContainerAtom &odrm_atom, const AP4_UI08 *key, AP4_Size key_size, AP4_BlockCipherFactory *block_cipher_factory, AP4_ByteStream *&stream)
static AP4_Result | CreateDecryptingStream (AP4_OmaDcfCipherMode mode, AP4_ByteStream &encrypted_stream, AP4_LargeSize cleartext_size, const AP4_UI08 *key, AP4_Size key_size, AP4_BlockCipherFactory *block_cipher_factory, AP4_ByteStream *&stream)

Detailed Description

Definition at line 68 of file Ap4OmaDcf.h.

Member Function Documentation

static AP4_Result AP4_OmaDcfAtomDecrypter::CreateDecryptingStream | ( | AP4_OmaDcfCipherMode | mode,
 |  | AP4_ByteStream & | encrypted_stream,
 |  | AP4_LargeSize | cleartext_size,
 |  | const AP4_UI08 * | key,
 |  | AP4_Size | key_size,
 |  | AP4_BlockCipherFactory * | block_cipher_factory,
 |  | AP4_ByteStream *& | stream |
 | ) |  |  | [static]
static AP4_Result AP4_OmaDcfAtomDecrypter::CreateDecryptingStream | ( | AP4_ContainerAtom & | odrm_atom,
 |  | const AP4_UI08 * | key,
 |  | AP4_Size | key_size,
 |  | AP4_BlockCipherFactory * | block_cipher_factory,
 |  | AP4_ByteStream *& | stream |
 | ) |  |  | [static]
static AP4_Result AP4_OmaDcfAtomDecrypter::DecryptAtoms | ( | AP4_AtomParent & | atoms,
 |  | AP4_Processor::ProgressListener * | listener,
 |  | AP4_BlockCipherFactory * | block_cipher_factory,
 |  | AP4_ProtectionKeyMap & | key_map |
 | ) |  |  | [static]
The documentation for this class was generated from the following file:
  • Ap4OmaDcf.h
Generated on Thu May 13 16:37:26 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_OmaDcfAtomDecrypter Member List

This is the complete list of members for AP4_OmaDcfAtomDecrypter, including all inherited members.
CreateDecryptingStream(AP4_ContainerAtom &odrm_atom, const AP4_UI08 *key, AP4_Size key_size, AP4_BlockCipherFactory *block_cipher_factory, AP4_ByteStream *&stream) | AP4_OmaDcfAtomDecrypter | [static]
CreateDecryptingStream(AP4_OmaDcfCipherMode mode, AP4_ByteStream &encrypted_stream, AP4_LargeSize cleartext_size, const AP4_UI08 *key, AP4_Size key_size, AP4_BlockCipherFactory *block_cipher_factory, AP4_ByteStream *&stream) | AP4_OmaDcfAtomDecrypter | [static]
DecryptAtoms(AP4_AtomParent &atoms, AP4_Processor::ProgressListener *listener, AP4_BlockCipherFactory *block_cipher_factory, AP4_ProtectionKeyMap &key_map) | AP4_OmaDcfAtomDecrypter | [static]
Generated on Thu May 13 16:37:26 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_OmaDcfCbcSampleDecrypter Class Reference

AP4_OmaDcfCbcSampleDecrypter Class Reference

#include <Ap4OmaDcf.h>

Inheritance diagram for AP4_OmaDcfCbcSampleDecrypter:
AP4_OmaDcfSampleDecrypter AP4_SampleDecrypter

List of all members.

Public Member Functions

AP4_OmaDcfCbcSampleDecrypter (AP4_BlockCipher *block_cipher, bool selective_encryption)
~AP4_OmaDcfCbcSampleDecrypter ()
virtual AP4_Result | DecryptSampleData (AP4_DataBuffer &data_in, AP4_DataBuffer &data_out, const AP4_UI08 *iv=NULL)
virtual AP4_Size | GetDecryptedSampleSize (AP4_Sample &sample)

Detailed Description

Definition at line 148 of file Ap4OmaDcf.h.

Constructor & Destructor Documentation

AP4_OmaDcfCbcSampleDecrypter::AP4_OmaDcfCbcSampleDecrypter | ( | AP4_BlockCipher * | block_cipher,
 |  | bool | selective_encryption
 | ) |  |
AP4_OmaDcfCbcSampleDecrypter::~AP4_OmaDcfCbcSampleDecrypter ( )

Member Function Documentation

virtual AP4_Result AP4_OmaDcfCbcSampleDecrypter::DecryptSampleData | ( | AP4_DataBuffer & | data_in,
 |  | AP4_DataBuffer & | data_out,
 |  | const AP4_UI08 * | iv = NULL |
 | ) |  |  | [virtual]

Implements AP4_SampleDecrypter.

virtual AP4_Size AP4_OmaDcfCbcSampleDecrypter::GetDecryptedSampleSize ( AP4_Sample & sample ) [virtual]

Reimplemented from AP4_SampleDecrypter.

The documentation for this class was generated from the following file:
  • Ap4OmaDcf.h
Generated on Thu May 13 16:37:26 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_OmaDcfCbcSampleDecrypter Member List

This is the complete list of members for AP4_OmaDcfCbcSampleDecrypter, including all inherited members.
AP4_OmaDcfCbcSampleDecrypter(AP4_BlockCipher *block_cipher, bool selective_encryption) | AP4_OmaDcfCbcSampleDecrypter |
AP4_OmaDcfSampleDecrypter(AP4_Size iv_length, bool selective_encryption) | AP4_OmaDcfSampleDecrypter | [inline]
Create(AP4_ProtectedSampleDescription *sample_description, const AP4_UI08 *key, AP4_Size key_size, AP4_BlockCipherFactory *block_cipher_factory, AP4_OmaDcfSampleDecrypter *&cipher) | AP4_OmaDcfSampleDecrypter | [static]
AP4_SampleDecrypter::Create(AP4_ProtectedSampleDescription *sample_description, const AP4_UI08 *key, AP4_Size key_size, AP4_BlockCipherFactory *block_cipher_factory=NULL) | AP4_SampleDecrypter | [static]
AP4_SampleDecrypter::Create(AP4_ProtectedSampleDescription *sample_description, AP4_ContainerAtom *traf, const AP4_UI08 *key, AP4_Size key_size, AP4_BlockCipherFactory *block_cipher_factory=NULL) | AP4_SampleDecrypter | [static]
DecryptSampleData(AP4_DataBuffer &data_in, AP4_DataBuffer &data_out, const AP4_UI08 *iv=NULL) | AP4_OmaDcfCbcSampleDecrypter | [virtual]
GetDecryptedSampleSize(AP4_Sample &sample) | AP4_OmaDcfCbcSampleDecrypter | [virtual]
m_IvLength | AP4_OmaDcfSampleDecrypter | [protected]
m_KeyIndicatorLength | AP4_OmaDcfSampleDecrypter | [protected]
m_SelectiveEncryption | AP4_OmaDcfSampleDecrypter | [protected]
SetSampleIndex(AP4_Ordinal) | AP4_SampleDecrypter | [inline, virtual]
~AP4_OmaDcfCbcSampleDecrypter() | AP4_OmaDcfCbcSampleDecrypter |
~AP4_SampleDecrypter() | AP4_SampleDecrypter | [inline, virtual]
Generated on Thu May 13 16:37:26 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_OmaDcfCbcSampleEncrypter Class Reference

AP4_OmaDcfCbcSampleEncrypter Class Reference

#include <Ap4OmaDcf.h>

Inheritance diagram for AP4_OmaDcfCbcSampleEncrypter:
AP4_OmaDcfSampleEncrypter

List of all members.

Public Member Functions

AP4_OmaDcfCbcSampleEncrypter (AP4_BlockCipher *block_cipher, const AP4_UI08 *salt)
~AP4_OmaDcfCbcSampleEncrypter ()
virtual AP4_Result | EncryptSampleData (AP4_DataBuffer &data_in, AP4_DataBuffer &data_out, AP4_UI64 bso, bool skip_encryption)
virtual AP4_Size | GetEncryptedSampleSize (AP4_Sample &sample)

Detailed Description

Definition at line 247 of file Ap4OmaDcf.h.

Constructor & Destructor Documentation

AP4_OmaDcfCbcSampleEncrypter::AP4_OmaDcfCbcSampleEncrypter | ( | AP4_BlockCipher * | block_cipher,
 |  | const AP4_UI08 * | salt
 | ) |  |
AP4_OmaDcfCbcSampleEncrypter::~AP4_OmaDcfCbcSampleEncrypter ( )

Member Function Documentation

virtual AP4_Result AP4_OmaDcfCbcSampleEncrypter::EncryptSampleData | ( | AP4_DataBuffer & | data_in,
 |  | AP4_DataBuffer & | data_out,
 |  | AP4_UI64 | bso,
 |  | bool | skip_encryption |
 | ) |  |  | [virtual]

Implements AP4_OmaDcfSampleEncrypter.

virtual AP4_Size AP4_OmaDcfCbcSampleEncrypter::GetEncryptedSampleSize ( AP4_Sample & sample ) [virtual]

Implements AP4_OmaDcfSampleEncrypter.

The documentation for this class was generated from the following file:
  • Ap4OmaDcf.h
Generated on Thu May 13 16:37:27 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_OmaDcfCbcSampleEncrypter Member List

This is the complete list of members for AP4_OmaDcfCbcSampleEncrypter, including all inherited members.
AP4_OmaDcfCbcSampleEncrypter(AP4_BlockCipher *block_cipher, const AP4_UI08 *salt) | AP4_OmaDcfCbcSampleEncrypter |
AP4_OmaDcfSampleEncrypter(const AP4_UI08 *salt) | AP4_OmaDcfSampleEncrypter |
EncryptSampleData(AP4_DataBuffer &data_in, AP4_DataBuffer &data_out, AP4_UI64 bso, bool skip_encryption) | AP4_OmaDcfCbcSampleEncrypter | [virtual]
GetEncryptedSampleSize(AP4_Sample &sample) | AP4_OmaDcfCbcSampleEncrypter | [virtual]
m_Salt | AP4_OmaDcfSampleEncrypter | [protected]
~AP4_OmaDcfCbcSampleEncrypter() | AP4_OmaDcfCbcSampleEncrypter |
~AP4_OmaDcfSampleEncrypter() | AP4_OmaDcfSampleEncrypter | [inline, virtual]
Generated on Thu May 13 16:37:27 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_OmaDcfCtrSampleDecrypter Class Reference

AP4_OmaDcfCtrSampleDecrypter Class Reference

#include <Ap4OmaDcf.h>

Inheritance diagram for AP4_OmaDcfCtrSampleDecrypter:
AP4_OmaDcfSampleDecrypter AP4_SampleDecrypter

List of all members.

Public Member Functions

AP4_OmaDcfCtrSampleDecrypter (AP4_BlockCipher *block_cipher, AP4_Size iv_length, bool selective_encryption)
~AP4_OmaDcfCtrSampleDecrypter ()
virtual AP4_Result | DecryptSampleData (AP4_DataBuffer &data_in, AP4_DataBuffer &data_out, const AP4_UI08 *iv=NULL)
virtual AP4_Size | GetDecryptedSampleSize (AP4_Sample &sample)

Detailed Description

Definition at line 125 of file Ap4OmaDcf.h.

Constructor & Destructor Documentation

AP4_OmaDcfCtrSampleDecrypter::AP4_OmaDcfCtrSampleDecrypter | ( | AP4_BlockCipher * | block_cipher,
 |  | AP4_Size | iv_length,
 |  | bool | selective_encryption
 | ) |  |
AP4_OmaDcfCtrSampleDecrypter::~AP4_OmaDcfCtrSampleDecrypter ( )

Member Function Documentation

virtual AP4_Result AP4_OmaDcfCtrSampleDecrypter::DecryptSampleData | ( | AP4_DataBuffer & | data_in,
 |  | AP4_DataBuffer & | data_out,
 |  | const AP4_UI08 * | iv = NULL |
 | ) |  |  | [virtual]

Implements AP4_SampleDecrypter.

virtual AP4_Size AP4_OmaDcfCtrSampleDecrypter::GetDecryptedSampleSize ( AP4_Sample & sample ) [virtual]

Reimplemented from AP4_SampleDecrypter.

The documentation for this class was generated from the following file:
  • Ap4OmaDcf.h
Generated on Thu May 13 16:37:39 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_OmaDcfCtrSampleDecrypter Member List

This is the complete list of members for AP4_OmaDcfCtrSampleDecrypter, including all inherited members.
AP4_OmaDcfCtrSampleDecrypter(AP4_BlockCipher *block_cipher, AP4_Size iv_length, bool selective_encryption) | AP4_OmaDcfCtrSampleDecrypter |
AP4_OmaDcfSampleDecrypter(AP4_Size iv_length, bool selective_encryption) | AP4_OmaDcfSampleDecrypter | [inline]
Create(AP4_ProtectedSampleDescription *sample_description, const AP4_UI08 *key, AP4_Size key_size, AP4_BlockCipherFactory *block_cipher_factory, AP4_OmaDcfSampleDecrypter *&cipher) | AP4_OmaDcfSampleDecrypter | [static]
AP4_SampleDecrypter::Create(AP4_ProtectedSampleDescription *sample_description, const AP4_UI08 *key, AP4_Size key_size, AP4_BlockCipherFactory *block_cipher_factory=NULL) | AP4_SampleDecrypter | [static]
AP4_SampleDecrypter::Create(AP4_ProtectedSampleDescription *sample_description, AP4_ContainerAtom *traf, const AP4_UI08 *key, AP4_Size key_size, AP4_BlockCipherFactory *block_cipher_factory=NULL) | AP4_SampleDecrypter | [static]
DecryptSampleData(AP4_DataBuffer &data_in, AP4_DataBuffer &data_out, const AP4_UI08 *iv=NULL) | AP4_OmaDcfCtrSampleDecrypter | [virtual]
GetDecryptedSampleSize(AP4_Sample &sample) | AP4_OmaDcfCtrSampleDecrypter | [virtual]
m_IvLength | AP4_OmaDcfSampleDecrypter | [protected]
m_KeyIndicatorLength | AP4_OmaDcfSampleDecrypter | [protected]
m_SelectiveEncryption | AP4_OmaDcfSampleDecrypter | [protected]
SetSampleIndex(AP4_Ordinal) | AP4_SampleDecrypter | [inline, virtual]
~AP4_OmaDcfCtrSampleDecrypter() | AP4_OmaDcfCtrSampleDecrypter |
~AP4_SampleDecrypter() | AP4_SampleDecrypter | [inline, virtual]
Generated on Thu May 13 16:37:39 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_OmaDcfCtrSampleEncrypter Class Reference

AP4_OmaDcfCtrSampleEncrypter Class Reference

#include <Ap4OmaDcf.h>

Inheritance diagram for AP4_OmaDcfCtrSampleEncrypter:
AP4_OmaDcfSampleEncrypter

List of all members.

Public Member Functions

AP4_OmaDcfCtrSampleEncrypter (AP4_BlockCipher *block_cipher, const AP4_UI08 *salt)
~AP4_OmaDcfCtrSampleEncrypter ()
virtual AP4_Result | EncryptSampleData (AP4_DataBuffer &data_in, AP4_DataBuffer &data_out, AP4_UI64 bso, bool skip_encryption)
virtual AP4_Size | GetEncryptedSampleSize (AP4_Sample &sample)

Detailed Description

Definition at line 224 of file Ap4OmaDcf.h.

Constructor & Destructor Documentation

AP4_OmaDcfCtrSampleEncrypter::AP4_OmaDcfCtrSampleEncrypter | ( | AP4_BlockCipher * | block_cipher,
 |  | const AP4_UI08 * | salt
 | ) |  |
AP4_OmaDcfCtrSampleEncrypter::~AP4_OmaDcfCtrSampleEncrypter ( )

Member Function Documentation

virtual AP4_Result AP4_OmaDcfCtrSampleEncrypter::EncryptSampleData | ( | AP4_DataBuffer & | data_in,
 |  | AP4_DataBuffer & | data_out,
 |  | AP4_UI64 | bso,
 |  | bool | skip_encryption |
 | ) |  |  | [virtual]

Implements AP4_OmaDcfSampleEncrypter.

virtual AP4_Size AP4_OmaDcfCtrSampleEncrypter::GetEncryptedSampleSize ( AP4_Sample & sample ) [virtual]

Implements AP4_OmaDcfSampleEncrypter.

The documentation for this class was generated from the following file:
  • Ap4OmaDcf.h
Generated on Thu May 13 16:37:39 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_OmaDcfCtrSampleEncrypter Member List

This is the complete list of members for AP4_OmaDcfCtrSampleEncrypter, including all inherited members.
AP4_OmaDcfCtrSampleEncrypter(AP4_BlockCipher *block_cipher, const AP4_UI08 *salt) | AP4_OmaDcfCtrSampleEncrypter |
AP4_OmaDcfSampleEncrypter(const AP4_UI08 *salt) | AP4_OmaDcfSampleEncrypter |
EncryptSampleData(AP4_DataBuffer &data_in, AP4_DataBuffer &data_out, AP4_UI64 bso, bool skip_encryption) | AP4_OmaDcfCtrSampleEncrypter | [virtual]
GetEncryptedSampleSize(AP4_Sample &sample) | AP4_OmaDcfCtrSampleEncrypter | [virtual]
m_Salt | AP4_OmaDcfSampleEncrypter | [protected]
~AP4_OmaDcfCtrSampleEncrypter() | AP4_OmaDcfCtrSampleEncrypter |
~AP4_OmaDcfSampleEncrypter() | AP4_OmaDcfSampleEncrypter | [inline, virtual]
Generated on Thu May 13 16:37:39 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_OmaDcfDecryptingProcessor Class Reference

AP4_OmaDcfDecryptingProcessor Class Reference

Use for DCF only, not PDCF. More...

#include <Ap4OmaDcf.h>

Inheritance diagram for AP4_OmaDcfDecryptingProcessor:
AP4_Processor

List of all members.

Public Member Functions

AP4_OmaDcfDecryptingProcessor (const AP4_ProtectionKeyMap *key_map=NULL, AP4_BlockCipherFactory *block_cipher_factory=NULL)
AP4_ProtectionKeyMap & GetKeyMap ()
virtual AP4_Result Initialize (AP4_AtomParent &top_level, AP4_ByteStream &stream, ProgressListener *listener)
This method can be overridden by concrete subclasses.

Detailed Description

Use for DCF only, not PDCF.

For PDCF, use the AP4_StandardDecryptingProcessor class

Definition at line 274 of file Ap4OmaDcf.h.

Constructor & Destructor Documentation

AP4_OmaDcfDecryptingProcessor::AP4_OmaDcfDecryptingProcessor | ( | const AP4_ProtectionKeyMap * | key_map = NULL,
 |  | AP4_BlockCipherFactory * | block_cipher_factory = NULL
 | ) |  |

Member Function Documentation

AP4_ProtectionKeyMap& AP4_OmaDcfDecryptingProcessor::GetKeyMap ( ) [inline]

Definition at line 282 of file Ap4OmaDcf.h.

virtual AP4_Result AP4_OmaDcfDecryptingProcessor::Initialize | ( | AP4_AtomParent & | top_level,
 |  | AP4_ByteStream & | stream,
 |  | ProgressListener * | listener |
 | ) |  |  | [virtual]

This method can be overridden by concrete subclasses.

It is called just after the input stream has been parsed into an atom tree, before the processing of the tracks.

Parameters:
top_level Container atom containing all the atoms parsed from the input stream. Note that this atom does not actually exist in the file; it is a synthetised container created for the purpose of holding together all the input's top-level atoms.

Reimplemented from AP4_Processor.

The documentation for this class was generated from the following file:
  • Ap4OmaDcf.h
Generated on Thu May 13 16:37:39 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_OmaDcfDecryptingProcessor Member List

This is the complete list of members for AP4_OmaDcfDecryptingProcessor, including all inherited members.
AP4_OmaDcfDecryptingProcessor(const AP4_ProtectionKeyMap *key_map=NULL, AP4_BlockCipherFactory *block_cipher_factory=NULL) | AP4_OmaDcfDecryptingProcessor |
CreateFragmentHandler(AP4_ContainerAtom *) | AP4_Processor | [inline, virtual]
CreateTrackHandler(AP4_TrakAtom *) | AP4_Processor | [inline, virtual]
Finalize(AP4_AtomParent &top_level, ProgressListener *listener=NULL) | AP4_Processor | [virtual]
GetKeyMap() | AP4_OmaDcfDecryptingProcessor | [inline]
Initialize(AP4_AtomParent &top_level, AP4_ByteStream &stream, ProgressListener *listener) | AP4_OmaDcfDecryptingProcessor | [virtual]
m_ExternalTrackData | AP4_Processor | [protected]
Process(AP4_ByteStream &input, AP4_ByteStream &output, ProgressListener *listener=NULL, AP4_AtomFactory &atom_factory=AP4_DefaultAtomFactory::Instance) | AP4_Processor |
ProcessFragments(AP4_MoovAtom *moov, AP4_List< AP4_MoofLocator > &moofs, AP4_ContainerAtom *mfra, AP4_ByteStream &input, AP4_ByteStream &output) | AP4_Processor | [protected]
~AP4_Processor() | AP4_Processor | [inline, virtual]
Generated on Thu May 13 16:37:39 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_OmaDcfEncryptingProcessor Class Reference

AP4_OmaDcfEncryptingProcessor Class Reference

#include <Ap4OmaDcf.h>

Inheritance diagram for AP4_OmaDcfEncryptingProcessor:
AP4_Processor

List of all members.

Public Member Functions

AP4_OmaDcfEncryptingProcessor (AP4_OmaDcfCipherMode cipher_mode, AP4_BlockCipherFactory *block_cipher_factory=NULL)
AP4_ProtectionKeyMap & GetKeyMap ()
AP4_TrackPropertyMap & GetPropertyMap ()
virtual AP4_Result Initialize (AP4_AtomParent &top_level, AP4_ByteStream &stream, AP4_Processor::ProgressListener *listener=NULL)
This method can be overridden by concrete subclasses.
virtual
AP4_Processor::TrackHandler * 		CreateTrackHandler (AP4_TrakAtom *trak)
This method can be overridden by concrete subclasses.

Detailed Description

Definition at line 298 of file Ap4OmaDcf.h.

Constructor & Destructor Documentation

AP4_OmaDcfEncryptingProcessor::AP4_OmaDcfEncryptingProcessor | ( | AP4_OmaDcfCipherMode | cipher_mode,
 |  | AP4_BlockCipherFactory * | block_cipher_factory = NULL
 | ) |  |

Member Function Documentation

virtual AP4_Processor::TrackHandler* AP4_OmaDcfEncryptingProcessor::CreateTrackHandler ( AP4_TrakAtom * ) [virtual]

This method can be overridden by concrete subclasses.

It is called once for each track in the input file.

Parameters:
track Pointer to the track for which a handler should be created.
Returns:
A pointer to a track handler, or NULL if no handler needs to be created for that track.

Reimplemented from AP4_Processor.

AP4_ProtectionKeyMap& AP4_OmaDcfEncryptingProcessor::GetKeyMap ( ) [inline]

Definition at line 306 of file Ap4OmaDcf.h.

AP4_TrackPropertyMap& AP4_OmaDcfEncryptingProcessor::GetPropertyMap ( ) [inline]

Definition at line 307 of file Ap4OmaDcf.h.

virtual AP4_Result AP4_OmaDcfEncryptingProcessor::Initialize | ( | AP4_AtomParent & | top_level,
 |  | AP4_ByteStream & | stream,
 |  | AP4_Processor::ProgressListener * | listener = NULL |
 | ) |  |  | [virtual]

This method can be overridden by concrete subclasses.

It is called just after the input stream has been parsed into an atom tree, before the processing of the tracks.

Parameters:
top_level Container atom containing all the atoms parsed from the input stream. Note that this atom does not actually exist in the file; it is a synthetised container created for the purpose of holding together all the input's top-level atoms.

Reimplemented from AP4_Processor.

The documentation for this class was generated from the following file:
  • Ap4OmaDcf.h
Generated on Thu May 13 16:37:39 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_OmaDcfEncryptingProcessor Member List

This is the complete list of members for AP4_OmaDcfEncryptingProcessor, including all inherited members.
AP4_OmaDcfEncryptingProcessor(AP4_OmaDcfCipherMode cipher_mode, AP4_BlockCipherFactory *block_cipher_factory=NULL) | AP4_OmaDcfEncryptingProcessor |
CreateFragmentHandler(AP4_ContainerAtom *) | AP4_Processor | [inline, virtual]
CreateTrackHandler(AP4_TrakAtom *trak) | AP4_OmaDcfEncryptingProcessor | [virtual]
Finalize(AP4_AtomParent &top_level, ProgressListener *listener=NULL) | AP4_Processor | [virtual]
GetKeyMap() | AP4_OmaDcfEncryptingProcessor | [inline]
GetPropertyMap() | AP4_OmaDcfEncryptingProcessor | [inline]
Initialize(AP4_AtomParent &top_level, AP4_ByteStream &stream, AP4_Processor::ProgressListener *listener=NULL) | AP4_OmaDcfEncryptingProcessor | [virtual]
m_ExternalTrackData | AP4_Processor | [protected]
Process(AP4_ByteStream &input, AP4_ByteStream &output, ProgressListener *listener=NULL, AP4_AtomFactory &atom_factory=AP4_DefaultAtomFactory::Instance) | AP4_Processor |
ProcessFragments(AP4_MoovAtom *moov, AP4_List< AP4_MoofLocator > &moofs, AP4_ContainerAtom *mfra, AP4_ByteStream &input, AP4_ByteStream &output) | AP4_Processor | [protected]
~AP4_Processor() | AP4_Processor | [inline, virtual]
Generated on Thu May 13 16:37:39 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_OmaDcfSampleDecrypter Class Reference

AP4_OmaDcfSampleDecrypter Class Reference

#include <Ap4OmaDcf.h>

Inheritance diagram for AP4_OmaDcfSampleDecrypter:
AP4_SampleDecrypter AP4_OmaDcfCbcSampleDecrypter AP4_OmaDcfCtrSampleDecrypter

List of all members.

Public Member Functions

AP4_OmaDcfSampleDecrypter (AP4_Size iv_length, bool selective_encryption)

Static Public Member Functions

static AP4_Result | Create (AP4_ProtectedSampleDescription *sample_description, const AP4_UI08 *key, AP4_Size key_size, AP4_BlockCipherFactory *block_cipher_factory, AP4_OmaDcfSampleDecrypter *&cipher)

Protected Attributes

AP4_Size m_IvLength
AP4_Size m_KeyIndicatorLength
bool | m_SelectiveEncryption

Detailed Description

Definition at line 100 of file Ap4OmaDcf.h.

Constructor & Destructor Documentation

AP4_OmaDcfSampleDecrypter::AP4_OmaDcfSampleDecrypter | ( | AP4_Size | iv_length,
 |  | bool | selective_encryption |
 | ) |  |  | [inline]

Definition at line 111 of file Ap4OmaDcf.h.

Member Function Documentation

static AP4_Result AP4_OmaDcfSampleDecrypter::Create | ( | AP4_ProtectedSampleDescription * | sample_description,
 |  | const AP4_UI08 * | key,
 |  | AP4_Size | key_size,
 |  | AP4_BlockCipherFactory * | block_cipher_factory,
 |  | AP4_OmaDcfSampleDecrypter *& | cipher |
 | ) |  |  | [static]

Member Data Documentation

AP4_Size AP4_OmaDcfSampleDecrypter::m_IvLength [protected]

Definition at line 117 of file Ap4OmaDcf.h.

AP4_Size AP4_OmaDcfSampleDecrypter::m_KeyIndicatorLength [protected]

Definition at line 118 of file Ap4OmaDcf.h.

bool AP4_OmaDcfSampleDecrypter::m_SelectiveEncryption [protected]

Definition at line 119 of file Ap4OmaDcf.h.

The documentation for this class was generated from the following file:
  • Ap4OmaDcf.h
Generated on Thu May 13 16:37:39 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_OmaDcfSampleDecrypter Member List

This is the complete list of members for AP4_OmaDcfSampleDecrypter, including all inherited members.
AP4_OmaDcfSampleDecrypter(AP4_Size iv_length, bool selective_encryption) | AP4_OmaDcfSampleDecrypter | [inline]
Create(AP4_ProtectedSampleDescription *sample_description, const AP4_UI08 *key, AP4_Size key_size, AP4_BlockCipherFactory *block_cipher_factory, AP4_OmaDcfSampleDecrypter *&cipher) | AP4_OmaDcfSampleDecrypter | [static]
AP4_SampleDecrypter::Create(AP4_ProtectedSampleDescription *sample_description, const AP4_UI08 *key, AP4_Size key_size, AP4_BlockCipherFactory *block_cipher_factory=NULL) | AP4_SampleDecrypter | [static]
AP4_SampleDecrypter::Create(AP4_ProtectedSampleDescription *sample_description, AP4_ContainerAtom *traf, const AP4_UI08 *key, AP4_Size key_size, AP4_BlockCipherFactory *block_cipher_factory=NULL) | AP4_SampleDecrypter | [static]
DecryptSampleData(AP4_DataBuffer &data_in, AP4_DataBuffer &data_out, const AP4_UI08 *iv=NULL)=0 | AP4_SampleDecrypter | [pure virtual]
GetDecryptedSampleSize(AP4_Sample &sample) | AP4_SampleDecrypter | [inline, virtual]
m_IvLength | AP4_OmaDcfSampleDecrypter | [protected]
m_KeyIndicatorLength | AP4_OmaDcfSampleDecrypter | [protected]
m_SelectiveEncryption | AP4_OmaDcfSampleDecrypter | [protected]
SetSampleIndex(AP4_Ordinal) | AP4_SampleDecrypter | [inline, virtual]
~AP4_SampleDecrypter() | AP4_SampleDecrypter | [inline, virtual]
Generated on Thu May 13 16:37:39 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_OmaDcfSampleEncrypter Class Reference

AP4_OmaDcfSampleEncrypter Class Reference

#include <Ap4OmaDcf.h>

Inheritance diagram for AP4_OmaDcfSampleEncrypter:
AP4_OmaDcfCbcSampleEncrypter AP4_OmaDcfCtrSampleEncrypter

List of all members.

Public Member Functions

AP4_OmaDcfSampleEncrypter (const AP4_UI08 *salt)
virtual | ~AP4_OmaDcfSampleEncrypter ()
virtual AP4_Result | EncryptSampleData (AP4_DataBuffer &data_in, AP4_DataBuffer &data_out, AP4_UI64 bso, bool skip_encryption)=0
virtual AP4_Size | GetEncryptedSampleSize (AP4_Sample &sample)=0

Protected Attributes

AP4_UI08 | m_Salt [16]

Detailed Description

Definition at line 202 of file Ap4OmaDcf.h.

Constructor & Destructor Documentation

AP4_OmaDcfSampleEncrypter::AP4_OmaDcfSampleEncrypter ( const AP4_UI08 * salt )
virtual AP4_OmaDcfSampleEncrypter::~AP4_OmaDcfSampleEncrypter ( ) [inline, virtual]

Definition at line 207 of file Ap4OmaDcf.h.

Member Function Documentation

virtual AP4_Result AP4_OmaDcfSampleEncrypter::EncryptSampleData | ( | AP4_DataBuffer & | data_in,
 |  | AP4_DataBuffer & | data_out,
 |  | AP4_UI64 | bso,
 |  | bool | skip_encryption |
 | ) |  |  | [pure virtual]

Implemented in AP4_OmaDcfCtrSampleEncrypter, and AP4_OmaDcfCbcSampleEncrypter.

virtual AP4_Size AP4_OmaDcfSampleEncrypter::GetEncryptedSampleSize ( AP4_Sample & sample ) [pure virtual]

Implemented in AP4_OmaDcfCtrSampleEncrypter, and AP4_OmaDcfCbcSampleEncrypter.

Member Data Documentation

AP4_UI08 AP4_OmaDcfSampleEncrypter::m_Salt[16] [protected]

Definition at line 218 of file Ap4OmaDcf.h.

The documentation for this class was generated from the following file:
  • Ap4OmaDcf.h
Generated on Thu May 13 16:37:40 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_OmaDcfSampleEncrypter Member List

This is the complete list of members for AP4_OmaDcfSampleEncrypter, including all inherited members.
AP4_OmaDcfSampleEncrypter(const AP4_UI08 *salt) | AP4_OmaDcfSampleEncrypter |
EncryptSampleData(AP4_DataBuffer &data_in, AP4_DataBuffer &data_out, AP4_UI64 bso, bool skip_encryption)=0 | AP4_OmaDcfSampleEncrypter | [pure virtual]
GetEncryptedSampleSize(AP4_Sample &sample)=0 | AP4_OmaDcfSampleEncrypter | [pure virtual]
m_Salt | AP4_OmaDcfSampleEncrypter | [protected]
~AP4_OmaDcfSampleEncrypter() | AP4_OmaDcfSampleEncrypter | [inline, virtual]
Generated on Thu May 13 16:37:40 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_OmaDcfTrackDecrypter Class Reference

AP4_OmaDcfTrackDecrypter Class Reference

#include <Ap4OmaDcf.h>

Inheritance diagram for AP4_OmaDcfTrackDecrypter:
AP4_Processor::TrackHandler

List of all members.

Public Member Functions

virtual | ~AP4_OmaDcfTrackDecrypter ()
virtual AP4_Size | GetProcessedSampleSize (AP4_Sample &sample)
Returns the size of a sample after processing.
virtual AP4_Result | ProcessTrack ()
A track handler may override this method if it needs to modify the track atoms before processing the track samples.
virtual AP4_Result | ProcessSample (AP4_DataBuffer &data_in, AP4_DataBuffer &data_out)
Process the data of one sample.

Static Public Member Functions

static AP4_Result | Create (const AP4_UI08 *key, AP4_Size key_size, AP4_ProtectedSampleDescription *sample_description, AP4_SampleEntry *sample_entry, AP4_BlockCipherFactory *block_cipher_factory, AP4_OmaDcfTrackDecrypter *&decrypter)

Detailed Description

Definition at line 170 of file Ap4OmaDcf.h.

Constructor & Destructor Documentation

virtual AP4_OmaDcfTrackDecrypter::~AP4_OmaDcfTrackDecrypter ( ) [virtual]

Member Function Documentation

static AP4_Result AP4_OmaDcfTrackDecrypter::Create | ( | const AP4_UI08 * | key,
 |  | AP4_Size | key_size,
 |  | AP4_ProtectedSampleDescription * | sample_description,
 |  | AP4_SampleEntry * | sample_entry,
 |  | AP4_BlockCipherFactory * | block_cipher_factory,
 |  | AP4_OmaDcfTrackDecrypter *& | decrypter |
 | ) |  |  | [static]
virtual AP4_Size AP4_OmaDcfTrackDecrypter::GetProcessedSampleSize ( AP4_Sample & sample ) [virtual]

Returns the size of a sample after processing.

Parameters:
sample Sample of which the processed size is requested.
Returns:
Size of the sample data after processing.

Reimplemented from AP4_Processor::TrackHandler.

virtual AP4_Result AP4_OmaDcfTrackDecrypter::ProcessSample | ( | AP4_DataBuffer & | data_in,
 |  | AP4_DataBuffer & | data_out |
 | ) |  |  | [virtual]

Process the data of one sample.

Parameters:
data_in | Data buffer with the data of the sample to process.
data_out | Data buffer in which the processed sample data is returned.

Implements AP4_Processor::TrackHandler.

virtual AP4_Result AP4_OmaDcfTrackDecrypter::ProcessTrack ( ) [virtual]

A track handler may override this method if it needs to modify the track atoms before processing the track samples.

Reimplemented from AP4_Processor::TrackHandler.

The documentation for this class was generated from the following file:
  • Ap4OmaDcf.h
Generated on Thu May 13 16:37:40 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_OmaDcfTrackDecrypter Member List

This is the complete list of members for AP4_OmaDcfTrackDecrypter, including all inherited members.
Create(const AP4_UI08 *key, AP4_Size key_size, AP4_ProtectedSampleDescription *sample_description, AP4_SampleEntry *sample_entry, AP4_BlockCipherFactory *block_cipher_factory, AP4_OmaDcfTrackDecrypter *&decrypter) | AP4_OmaDcfTrackDecrypter | [static]
GetProcessedSampleSize(AP4_Sample &sample) | AP4_OmaDcfTrackDecrypter | [virtual]
ProcessSample(AP4_DataBuffer &data_in, AP4_DataBuffer &data_out) | AP4_OmaDcfTrackDecrypter | [virtual]
ProcessTrack() | AP4_OmaDcfTrackDecrypter | [virtual]
~AP4_OmaDcfTrackDecrypter() | AP4_OmaDcfTrackDecrypter | [virtual]
~TrackHandler() | AP4_Processor::TrackHandler | [inline, virtual]
Generated on Thu May 13 16:37:40 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_OmaDrmInfo Class Reference

AP4_OmaDrmInfo Class Reference

#include <Ap4OmaDcf.h>

Inheritance diagram for AP4_OmaDrmInfo:
AP4_OhdrAtom

List of all members.

Public Member Functions

virtual | ~AP4_OmaDrmInfo ()
virtual const AP4_String & | GetContentId () const =0
virtual const AP4_String & | GetRightsIssuerUrl () const =0
virtual const AP4_DataBuffer & | GetTextualHeaders () const =0

Detailed Description

Definition at line 326 of file Ap4OmaDcf.h.

Constructor & Destructor Documentation

virtual AP4_OmaDrmInfo::~AP4_OmaDrmInfo ( ) [inline, virtual]

Definition at line 330 of file Ap4OmaDcf.h.

Member Function Documentation

virtual const AP4_String& AP4_OmaDrmInfo::GetContentId ( ) const [pure virtual]

Implemented in AP4_OhdrAtom.

virtual const AP4_String& AP4_OmaDrmInfo::GetRightsIssuerUrl ( ) const [pure virtual]

Implemented in AP4_OhdrAtom.

virtual const AP4_DataBuffer& AP4_OmaDrmInfo::GetTextualHeaders ( ) const [pure virtual]

Implemented in AP4_OhdrAtom.

The documentation for this class was generated from the following file:
  • Ap4OmaDcf.h
Generated on Thu May 13 16:37:40 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_OmaDrmInfo Member List

This is the complete list of members for AP4_OmaDrmInfo, including all inherited members.
GetContentId() const =0 | AP4_OmaDrmInfo | [pure virtual]
GetRightsIssuerUrl() const =0 | AP4_OmaDrmInfo | [pure virtual]
GetTextualHeaders() const =0 | AP4_OmaDrmInfo | [pure virtual]
~AP4_OmaDrmInfo() | AP4_OmaDrmInfo | [inline, virtual]
Generated on Thu May 13 16:37:40 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_PiffAvcCbcSampleDecrypter Class Reference

AP4_PiffAvcCbcSampleDecrypter Class Reference

#include <Ap4Piff.h>

Inheritance diagram for AP4_PiffAvcCbcSampleDecrypter:
AP4_PiffCbcSampleDecrypter AP4_PiffSampleDecrypter AP4_SampleDecrypter

List of all members.

Public Member Functions

AP4_PiffAvcCbcSampleDecrypter (AP4_BlockCipher *block_cipher, AP4_PiffSampleEncryptionAtom *sample_encryption_atom, AP4_Size nalu_length_size)
virtual AP4_Result DecryptSampleData (AP4_DataBuffer &data_in, AP4_DataBuffer &data_out, const AP4_UI08 *iv=NULL)

Detailed Description

Definition at line 328 of file Ap4Piff.h.

Constructor & Destructor Documentation

AP4_PiffAvcCbcSampleDecrypter::AP4_PiffAvcCbcSampleDecrypter | ( | AP4_BlockCipher * | block_cipher,
 |  | AP4_PiffSampleEncryptionAtom * | sample_encryption_atom,
 |  | AP4_Size | nalu_length_size |
 | ) |  |  | [inline]

Definition at line 332 of file Ap4Piff.h.

Member Function Documentation

virtual AP4_Result AP4_PiffAvcCbcSampleDecrypter::DecryptSampleData | ( | AP4_DataBuffer & | data_in,
 |  | AP4_DataBuffer & | data_out,
 |  | const AP4_UI08 * | iv = NULL |
 | ) |  |  | [virtual]

Reimplemented from AP4_PiffCbcSampleDecrypter.

The documentation for this class was generated from the following file:
  • Ap4Piff.h
Generated on Thu May 13 16:37:40 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_PiffAvcCbcSampleDecrypter Member List

This is the complete list of members for AP4_PiffAvcCbcSampleDecrypter, including all inherited members.
AP4_PiffAvcCbcSampleDecrypter(AP4_BlockCipher *block_cipher, AP4_PiffSampleEncryptionAtom *sample_encryption_atom, AP4_Size nalu_length_size) | AP4_PiffAvcCbcSampleDecrypter | [inline]
AP4_PiffCbcSampleDecrypter(AP4_BlockCipher *block_cipher, AP4_PiffSampleEncryptionAtom *sample_encryption_atom) | AP4_PiffCbcSampleDecrypter |
AP4_PiffSampleDecrypter(AP4_PiffSampleEncryptionAtom *sample_encryption_atom) | AP4_PiffSampleDecrypter | [inline, protected]
Create(AP4_ProtectedSampleDescription *sample_description, AP4_ContainerAtom *traf, const AP4_UI08 *key, AP4_Size key_size, AP4_BlockCipherFactory *block_cipher_factory, AP4_PiffSampleDecrypter *&decrypter) | AP4_PiffSampleDecrypter | [static]
AP4_SampleDecrypter::Create(AP4_ProtectedSampleDescription *sample_description, const AP4_UI08 *key, AP4_Size key_size, AP4_BlockCipherFactory *block_cipher_factory=NULL) | AP4_SampleDecrypter | [static]
AP4_SampleDecrypter::Create(AP4_ProtectedSampleDescription *sample_description, AP4_ContainerAtom *traf, const AP4_UI08 *key, AP4_Size key_size, AP4_BlockCipherFactory *block_cipher_factory=NULL) | AP4_SampleDecrypter | [static]
DecryptSampleData(AP4_DataBuffer &data_in, AP4_DataBuffer &data_out, const AP4_UI08 *iv=NULL) | AP4_PiffAvcCbcSampleDecrypter | [virtual]
GetDecryptedSampleSize(AP4_Sample &sample) | AP4_SampleDecrypter | [inline, virtual]
m_Cipher | AP4_PiffCbcSampleDecrypter | [protected]
m_SampleEncryptionAtom | AP4_PiffSampleDecrypter | [protected]
m_SampleIndex | AP4_PiffSampleDecrypter | [protected]
SetSampleIndex(AP4_Ordinal sample_index) | AP4_PiffSampleDecrypter | [virtual]
~AP4_PiffCbcSampleDecrypter() | AP4_PiffCbcSampleDecrypter |
~AP4_SampleDecrypter() | AP4_SampleDecrypter | [inline, virtual]
Generated on Thu May 13 16:37:40 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_PiffAvcCbcSampleEncrypter Class Reference

AP4_PiffAvcCbcSampleEncrypter Class Reference

#include <Ap4Piff.h>

Inheritance diagram for AP4_PiffAvcCbcSampleEncrypter:
AP4_PiffCbcSampleEncrypter AP4_PiffSampleEncrypter

List of all members.

Public Member Functions

AP4_PiffAvcCbcSampleEncrypter (AP4_BlockCipher *block_cipher, AP4_Size nalu_length_size)
virtual AP4_Result EncryptSampleData (AP4_DataBuffer &data_in, AP4_DataBuffer &data_out)

Detailed Description

Definition at line 155 of file Ap4Piff.h.

Constructor & Destructor Documentation

AP4_PiffAvcCbcSampleEncrypter::AP4_PiffAvcCbcSampleEncrypter | ( | AP4_BlockCipher * | block_cipher,
 |  | AP4_Size | nalu_length_size |
 | ) |  |  | [inline]

Definition at line 159 of file Ap4Piff.h.

Member Function Documentation

virtual AP4_Result AP4_PiffAvcCbcSampleEncrypter::EncryptSampleData | ( | AP4_DataBuffer & | data_in,
 |  | AP4_DataBuffer & | data_out |
 | ) |  |  | [virtual]

Reimplemented from AP4_PiffCbcSampleEncrypter.

The documentation for this class was generated from the following file:
  • Ap4Piff.h
Generated on Thu May 13 16:37:40 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_PiffAvcCbcSampleEncrypter Member List

This is the complete list of members for AP4_PiffAvcCbcSampleEncrypter, including all inherited members.
AP4_PiffAvcCbcSampleEncrypter(AP4_BlockCipher *block_cipher, AP4_Size nalu_length_size) | AP4_PiffAvcCbcSampleEncrypter | [inline]
AP4_PiffCbcSampleEncrypter(AP4_BlockCipher *block_cipher) | AP4_PiffCbcSampleEncrypter |
AP4_PiffSampleEncrypter() | AP4_PiffSampleEncrypter | [inline]
EncryptSampleData(AP4_DataBuffer &data_in, AP4_DataBuffer &data_out) | AP4_PiffAvcCbcSampleEncrypter | [virtual]
GetIv() | AP4_PiffSampleEncrypter | [inline]
m_Cipher | AP4_PiffCbcSampleEncrypter | [protected]
m_Iv | AP4_PiffSampleEncrypter | [protected]
SetIv(const AP4_UI08 *iv) | AP4_PiffSampleEncrypter | [inline]
~AP4_PiffCbcSampleEncrypter() | AP4_PiffCbcSampleEncrypter |
~AP4_PiffSampleEncrypter() | AP4_PiffSampleEncrypter | [inline, virtual]
Generated on Thu May 13 16:37:40 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_PiffAvcCtrSampleDecrypter Class Reference

AP4_PiffAvcCtrSampleDecrypter Class Reference

#include <Ap4Piff.h>

Inheritance diagram for AP4_PiffAvcCtrSampleDecrypter:
AP4_PiffCtrSampleDecrypter AP4_PiffSampleDecrypter AP4_SampleDecrypter

List of all members.

Public Member Functions

AP4_PiffAvcCtrSampleDecrypter (AP4_BlockCipher *block_cipher, AP4_Size iv_size, AP4_PiffSampleEncryptionAtom *sample_encryption_atom, AP4_Size nalu_length_size)
virtual AP4_Result DecryptSampleData (AP4_DataBuffer &data_in, AP4_DataBuffer &data_out, const AP4_UI08 *iv=NULL)

Detailed Description

Definition at line 283 of file Ap4Piff.h.

Constructor & Destructor Documentation

AP4_PiffAvcCtrSampleDecrypter::AP4_PiffAvcCtrSampleDecrypter | ( | AP4_BlockCipher * | block_cipher,
 |  | AP4_Size | iv_size,
 |  | AP4_PiffSampleEncryptionAtom * | sample_encryption_atom,
 |  | AP4_Size | nalu_length_size |
 | ) |  |  | [inline]

Definition at line 287 of file Ap4Piff.h.

Member Function Documentation

virtual AP4_Result AP4_PiffAvcCtrSampleDecrypter::DecryptSampleData | ( | AP4_DataBuffer & | data_in,
 |  | AP4_DataBuffer & | data_out,
 |  | const AP4_UI08 * | iv = NULL |
 | ) |  |  | [virtual]

Reimplemented from AP4_PiffCtrSampleDecrypter.

The documentation for this class was generated from the following file:
  • Ap4Piff.h
Generated on Thu May 13 16:37:40 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_PiffAvcCtrSampleDecrypter Member List

This is the complete list of members for AP4_PiffAvcCtrSampleDecrypter, including all inherited members.
AP4_PiffAvcCtrSampleDecrypter(AP4_BlockCipher *block_cipher, AP4_Size iv_size, AP4_PiffSampleEncryptionAtom *sample_encryption_atom, AP4_Size nalu_length_size) | AP4_PiffAvcCtrSampleDecrypter | [inline]
AP4_PiffCtrSampleDecrypter(AP4_BlockCipher *block_cipher, AP4_Size iv_size, AP4_PiffSampleEncryptionAtom *sample_encryption_atom) | AP4_PiffCtrSampleDecrypter |
AP4_PiffSampleDecrypter(AP4_PiffSampleEncryptionAtom *sample_encryption_atom) | AP4_PiffSampleDecrypter | [inline, protected]
Create(AP4_ProtectedSampleDescription *sample_description, AP4_ContainerAtom *traf, const AP4_UI08 *key, AP4_Size key_size, AP4_BlockCipherFactory *block_cipher_factory, AP4_PiffSampleDecrypter *&decrypter) | AP4_PiffSampleDecrypter | [static]
AP4_SampleDecrypter::Create(AP4_ProtectedSampleDescription *sample_description, const AP4_UI08 *key, AP4_Size key_size, AP4_BlockCipherFactory *block_cipher_factory=NULL) | AP4_SampleDecrypter | [static]
AP4_SampleDecrypter::Create(AP4_ProtectedSampleDescription *sample_description, AP4_ContainerAtom *traf, const AP4_UI08 *key, AP4_Size key_size, AP4_BlockCipherFactory *block_cipher_factory=NULL) | AP4_SampleDecrypter | [static]
DecryptSampleData(AP4_DataBuffer &data_in, AP4_DataBuffer &data_out, const AP4_UI08 *iv=NULL) | AP4_PiffAvcCtrSampleDecrypter | [virtual]
GetDecryptedSampleSize(AP4_Sample &sample) | AP4_SampleDecrypter | [inline, virtual]
m_SampleEncryptionAtom | AP4_PiffSampleDecrypter | [protected]
m_SampleIndex | AP4_PiffSampleDecrypter | [protected]
SetSampleIndex(AP4_Ordinal sample_index) | AP4_PiffSampleDecrypter | [virtual]
~AP4_PiffCtrSampleDecrypter() | AP4_PiffCtrSampleDecrypter |
~AP4_SampleDecrypter() | AP4_SampleDecrypter | [inline, virtual]
Generated on Thu May 13 16:37:40 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_PiffAvcCtrSampleEncrypter Class Reference

AP4_PiffAvcCtrSampleEncrypter Class Reference

#include <Ap4Piff.h>

Inheritance diagram for AP4_PiffAvcCtrSampleEncrypter:
AP4_PiffCtrSampleEncrypter AP4_PiffSampleEncrypter

List of all members.

Public Member Functions

AP4_PiffAvcCtrSampleEncrypter (AP4_BlockCipher *block_cipher, AP4_Size nalu_length_size)
virtual AP4_Result EncryptSampleData (AP4_DataBuffer &data_in, AP4_DataBuffer &data_out)

Detailed Description

Definition at line 115 of file Ap4Piff.h.

Constructor & Destructor Documentation

AP4_PiffAvcCtrSampleEncrypter::AP4_PiffAvcCtrSampleEncrypter | ( | AP4_BlockCipher * | block_cipher,
 |  | AP4_Size | nalu_length_size |
 | ) |  |  | [inline]

Definition at line 119 of file Ap4Piff.h.

Member Function Documentation

virtual AP4_Result AP4_PiffAvcCtrSampleEncrypter::EncryptSampleData | ( | AP4_DataBuffer & | data_in,
 |  | AP4_DataBuffer & | data_out |
 | ) |  |  | [virtual]

Reimplemented from AP4_PiffCtrSampleEncrypter.

The documentation for this class was generated from the following file:
  • Ap4Piff.h
Generated on Thu May 13 16:37:41 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_PiffAvcCtrSampleEncrypter Member List

This is the complete list of members for AP4_PiffAvcCtrSampleEncrypter, including all inherited members.
AP4_PiffAvcCtrSampleEncrypter(AP4_BlockCipher *block_cipher, AP4_Size nalu_length_size) | AP4_PiffAvcCtrSampleEncrypter | [inline]
AP4_PiffCtrSampleEncrypter(AP4_BlockCipher *block_cipher) | AP4_PiffCtrSampleEncrypter |
AP4_PiffSampleEncrypter() | AP4_PiffSampleEncrypter | [inline]
EncryptSampleData(AP4_DataBuffer &data_in, AP4_DataBuffer &data_out) | AP4_PiffAvcCtrSampleEncrypter | [virtual]
GetIv() | AP4_PiffSampleEncrypter | [inline]
m_Cipher | AP4_PiffCtrSampleEncrypter | [protected]
m_Iv | AP4_PiffSampleEncrypter | [protected]
SetIv(const AP4_UI08 *iv) | AP4_PiffSampleEncrypter | [inline]
~AP4_PiffCtrSampleEncrypter() | AP4_PiffCtrSampleEncrypter |
~AP4_PiffSampleEncrypter() | AP4_PiffSampleEncrypter | [inline, virtual]
Generated on Thu May 13 16:37:41 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_PiffCbcSampleDecrypter Class Reference

AP4_PiffCbcSampleDecrypter Class Reference

#include <Ap4Piff.h>

Inheritance diagram for AP4_PiffCbcSampleDecrypter:
AP4_PiffSampleDecrypter AP4_SampleDecrypter AP4_PiffAvcCbcSampleDecrypter

List of all members.

Public Member Functions

AP4_PiffCbcSampleDecrypter (AP4_BlockCipher *block_cipher, AP4_PiffSampleEncryptionAtom *sample_encryption_atom)
~AP4_PiffCbcSampleDecrypter ()
virtual AP4_Result DecryptSampleData (AP4_DataBuffer &data_in, AP4_DataBuffer &data_out, const AP4_UI08 *iv=NULL)

Protected Attributes

AP4_CbcStreamCipher * m_Cipher

Detailed Description

Definition at line 307 of file Ap4Piff.h.

Constructor & Destructor Documentation

AP4_PiffCbcSampleDecrypter::AP4_PiffCbcSampleDecrypter | ( | AP4_BlockCipher * | block_cipher,
 |  | AP4_PiffSampleEncryptionAtom * | sample_encryption_atom
 | ) |  |
AP4_PiffCbcSampleDecrypter::~AP4_PiffCbcSampleDecrypter ( )

Member Function Documentation

virtual AP4_Result AP4_PiffCbcSampleDecrypter::DecryptSampleData | ( | AP4_DataBuffer & | data_in,
 |  | AP4_DataBuffer & | data_out,
 |  | const AP4_UI08 * | iv = NULL |
 | ) |  |  | [virtual]

Implements AP4_SampleDecrypter.

Reimplemented in AP4_PiffAvcCbcSampleDecrypter.

Member Data Documentation

AP4_CbcStreamCipher* AP4_PiffCbcSampleDecrypter::m_Cipher [protected]

Definition at line 322 of file Ap4Piff.h.

The documentation for this class was generated from the following file:
  • Ap4Piff.h
Generated on Thu May 13 16:37:41 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_PiffCbcSampleDecrypter Member List

This is the complete list of members for AP4_PiffCbcSampleDecrypter, including all inherited members.
AP4_PiffCbcSampleDecrypter(AP4_BlockCipher *block_cipher, AP4_PiffSampleEncryptionAtom *sample_encryption_atom) | AP4_PiffCbcSampleDecrypter |
AP4_PiffSampleDecrypter(AP4_PiffSampleEncryptionAtom *sample_encryption_atom) | AP4_PiffSampleDecrypter | [inline, protected]
Create(AP4_ProtectedSampleDescription *sample_description, AP4_ContainerAtom *traf, const AP4_UI08 *key, AP4_Size key_size, AP4_BlockCipherFactory *block_cipher_factory, AP4_PiffSampleDecrypter *&decrypter) | AP4_PiffSampleDecrypter | [static]
AP4_SampleDecrypter::Create(AP4_ProtectedSampleDescription *sample_description, const AP4_UI08 *key, AP4_Size key_size, AP4_BlockCipherFactory *block_cipher_factory=NULL) | AP4_SampleDecrypter | [static]
AP4_SampleDecrypter::Create(AP4_ProtectedSampleDescription *sample_description, AP4_ContainerAtom *traf, const AP4_UI08 *key, AP4_Size key_size, AP4_BlockCipherFactory *block_cipher_factory=NULL) | AP4_SampleDecrypter | [static]
DecryptSampleData(AP4_DataBuffer &data_in, AP4_DataBuffer &data_out, const AP4_UI08 *iv=NULL) | AP4_PiffCbcSampleDecrypter | [virtual]
GetDecryptedSampleSize(AP4_Sample &sample) | AP4_SampleDecrypter | [inline, virtual]
m_Cipher | AP4_PiffCbcSampleDecrypter | [protected]
m_SampleEncryptionAtom | AP4_PiffSampleDecrypter | [protected]
m_SampleIndex | AP4_PiffSampleDecrypter | [protected]
SetSampleIndex(AP4_Ordinal sample_index) | AP4_PiffSampleDecrypter | [virtual]
~AP4_PiffCbcSampleDecrypter() | AP4_PiffCbcSampleDecrypter |
~AP4_SampleDecrypter() | AP4_SampleDecrypter | [inline, virtual]
Generated on Thu May 13 16:37:41 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_PiffCbcSampleEncrypter Class Reference

AP4_PiffCbcSampleEncrypter Class Reference

#include <Ap4Piff.h>

Inheritance diagram for AP4_PiffCbcSampleEncrypter:
AP4_PiffSampleEncrypter AP4_PiffAvcCbcSampleEncrypter

List of all members.

Public Member Functions

AP4_PiffCbcSampleEncrypter (AP4_BlockCipher *block_cipher)
~AP4_PiffCbcSampleEncrypter ()
virtual AP4_Result EncryptSampleData (AP4_DataBuffer &data_in, AP4_DataBuffer &data_out)

Protected Attributes

AP4_CbcStreamCipher * m_Cipher

Detailed Description

Definition at line 136 of file Ap4Piff.h.

Constructor & Destructor Documentation

AP4_PiffCbcSampleEncrypter::AP4_PiffCbcSampleEncrypter ( AP4_BlockCipher * block_cipher )
AP4_PiffCbcSampleEncrypter::~AP4_PiffCbcSampleEncrypter ( )

Member Function Documentation

virtual AP4_Result AP4_PiffCbcSampleEncrypter::EncryptSampleData | ( | AP4_DataBuffer & | data_in,
 |  | AP4_DataBuffer & | data_out |
 | ) |  |  | [virtual]

Implements AP4_PiffSampleEncrypter.

Reimplemented in AP4_PiffAvcCbcSampleEncrypter.

Member Data Documentation

AP4_CbcStreamCipher* AP4_PiffCbcSampleEncrypter::m_Cipher [protected]

Definition at line 149 of file Ap4Piff.h.

The documentation for this class was generated from the following file:
  • Ap4Piff.h
Generated on Thu May 13 16:37:41 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_PiffCbcSampleEncrypter Member List

This is the complete list of members for AP4_PiffCbcSampleEncrypter, including all inherited members.
AP4_PiffCbcSampleEncrypter(AP4_BlockCipher *block_cipher) | AP4_PiffCbcSampleEncrypter |
AP4_PiffSampleEncrypter() | AP4_PiffSampleEncrypter | [inline]
EncryptSampleData(AP4_DataBuffer &data_in, AP4_DataBuffer &data_out) | AP4_PiffCbcSampleEncrypter | [virtual]
GetIv() | AP4_PiffSampleEncrypter | [inline]
m_Cipher | AP4_PiffCbcSampleEncrypter | [protected]
m_Iv | AP4_PiffSampleEncrypter | [protected]
SetIv(const AP4_UI08 *iv) | AP4_PiffSampleEncrypter | [inline]
~AP4_PiffCbcSampleEncrypter() | AP4_PiffCbcSampleEncrypter |
~AP4_PiffSampleEncrypter() | AP4_PiffSampleEncrypter | [inline, virtual]
Generated on Thu May 13 16:37:41 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_PiffCtrSampleDecrypter Class Reference

AP4_PiffCtrSampleDecrypter Class Reference

#include <Ap4Piff.h>

Inheritance diagram for AP4_PiffCtrSampleDecrypter:
AP4_PiffSampleDecrypter AP4_SampleDecrypter AP4_PiffAvcCtrSampleDecrypter

List of all members.

Public Member Functions

AP4_PiffCtrSampleDecrypter (AP4_BlockCipher *block_cipher, AP4_Size iv_size, AP4_PiffSampleEncryptionAtom *sample_encryption_atom)
~AP4_PiffCtrSampleDecrypter ()
virtual AP4_Result DecryptSampleData (AP4_DataBuffer &data_in, AP4_DataBuffer &data_out, const AP4_UI08 *iv=NULL)

Detailed Description

Definition at line 260 of file Ap4Piff.h.

Constructor & Destructor Documentation

AP4_PiffCtrSampleDecrypter::AP4_PiffCtrSampleDecrypter | ( | AP4_BlockCipher * | block_cipher,
 |  | AP4_Size | iv_size,
 |  | AP4_PiffSampleEncryptionAtom * | sample_encryption_atom
 | ) |  |
AP4_PiffCtrSampleDecrypter::~AP4_PiffCtrSampleDecrypter ( )

Member Function Documentation

virtual AP4_Result AP4_PiffCtrSampleDecrypter::DecryptSampleData | ( | AP4_DataBuffer & | data_in,
 |  | AP4_DataBuffer & | data_out,
 |  | const AP4_UI08 * | iv = NULL |
 | ) |  |  | [virtual]

Implements AP4_SampleDecrypter.

Reimplemented in AP4_PiffAvcCtrSampleDecrypter.

The documentation for this class was generated from the following file:
  • Ap4Piff.h
Generated on Thu May 13 16:37:42 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_PiffCtrSampleDecrypter Member List

This is the complete list of members for AP4_PiffCtrSampleDecrypter, including all inherited members.
AP4_PiffCtrSampleDecrypter(AP4_BlockCipher *block_cipher, AP4_Size iv_size, AP4_PiffSampleEncryptionAtom *sample_encryption_atom) | AP4_PiffCtrSampleDecrypter |
AP4_PiffSampleDecrypter(AP4_PiffSampleEncryptionAtom *sample_encryption_atom) | AP4_PiffSampleDecrypter | [inline, protected]
Create(AP4_ProtectedSampleDescription *sample_description, AP4_ContainerAtom *traf, const AP4_UI08 *key, AP4_Size key_size, AP4_BlockCipherFactory *block_cipher_factory, AP4_PiffSampleDecrypter *&decrypter) | AP4_PiffSampleDecrypter | [static]
AP4_SampleDecrypter::Create(AP4_ProtectedSampleDescription *sample_description, const AP4_UI08 *key, AP4_Size key_size, AP4_BlockCipherFactory *block_cipher_factory=NULL) | AP4_SampleDecrypter | [static]
AP4_SampleDecrypter::Create(AP4_ProtectedSampleDescription *sample_description, AP4_ContainerAtom *traf, const AP4_UI08 *key, AP4_Size key_size, AP4_BlockCipherFactory *block_cipher_factory=NULL) | AP4_SampleDecrypter | [static]
DecryptSampleData(AP4_DataBuffer &data_in, AP4_DataBuffer &data_out, const AP4_UI08 *iv=NULL) | AP4_PiffCtrSampleDecrypter | [virtual]
GetDecryptedSampleSize(AP4_Sample &sample) | AP4_SampleDecrypter | [inline, virtual]
m_SampleEncryptionAtom | AP4_PiffSampleDecrypter | [protected]
m_SampleIndex | AP4_PiffSampleDecrypter | [protected]
SetSampleIndex(AP4_Ordinal sample_index) | AP4_PiffSampleDecrypter | [virtual]
~AP4_PiffCtrSampleDecrypter() | AP4_PiffCtrSampleDecrypter |
~AP4_SampleDecrypter() | AP4_SampleDecrypter | [inline, virtual]
Generated on Thu May 13 16:37:42 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_PiffCtrSampleEncrypter Class Reference

AP4_PiffCtrSampleEncrypter Class Reference

#include <Ap4Piff.h>

Inheritance diagram for AP4_PiffCtrSampleEncrypter:
AP4_PiffSampleEncrypter AP4_PiffAvcCtrSampleEncrypter

List of all members.

Public Member Functions

AP4_PiffCtrSampleEncrypter (AP4_BlockCipher *block_cipher)
~AP4_PiffCtrSampleEncrypter ()
virtual AP4_Result EncryptSampleData (AP4_DataBuffer &data_in, AP4_DataBuffer &data_out)

Protected Attributes

AP4_CtrStreamCipher * m_Cipher

Detailed Description

Definition at line 96 of file Ap4Piff.h.

Constructor & Destructor Documentation

AP4_PiffCtrSampleEncrypter::AP4_PiffCtrSampleEncrypter ( AP4_BlockCipher * block_cipher )
AP4_PiffCtrSampleEncrypter::~AP4_PiffCtrSampleEncrypter ( )

Member Function Documentation

virtual AP4_Result AP4_PiffCtrSampleEncrypter::EncryptSampleData | ( | AP4_DataBuffer & | data_in,
 |  | AP4_DataBuffer & | data_out |
 | ) |  |  | [virtual]

Implements AP4_PiffSampleEncrypter.

Reimplemented in AP4_PiffAvcCtrSampleEncrypter.

Member Data Documentation

AP4_CtrStreamCipher* AP4_PiffCtrSampleEncrypter::m_Cipher [protected]

Definition at line 109 of file Ap4Piff.h.

The documentation for this class was generated from the following file:
  • Ap4Piff.h
Generated on Thu May 13 16:37:42 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_PiffCtrSampleEncrypter Member List

This is the complete list of members for AP4_PiffCtrSampleEncrypter, including all inherited members.
AP4_PiffCtrSampleEncrypter(AP4_BlockCipher *block_cipher) | AP4_PiffCtrSampleEncrypter |
AP4_PiffSampleEncrypter() | AP4_PiffSampleEncrypter | [inline]
EncryptSampleData(AP4_DataBuffer &data_in, AP4_DataBuffer &data_out) | AP4_PiffCtrSampleEncrypter | [virtual]
GetIv() | AP4_PiffSampleEncrypter | [inline]
m_Cipher | AP4_PiffCtrSampleEncrypter | [protected]
m_Iv | AP4_PiffSampleEncrypter | [protected]
SetIv(const AP4_UI08 *iv) | AP4_PiffSampleEncrypter | [inline]
~AP4_PiffCtrSampleEncrypter() | AP4_PiffCtrSampleEncrypter |
~AP4_PiffSampleEncrypter() | AP4_PiffSampleEncrypter | [inline, virtual]
Generated on Thu May 13 16:37:42 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_PiffEncryptingProcessor Class Reference

AP4_PiffEncryptingProcessor Class Reference

#include <Ap4Piff.h>

Inheritance diagram for AP4_PiffEncryptingProcessor:
AP4_Processor

List of all members.

Classes

struct | Encrypter

Public Member Functions

AP4_PiffEncryptingProcessor (AP4_PiffCipherMode cipher_mode, AP4_BlockCipherFactory *block_cipher_factory=NULL)
~AP4_PiffEncryptingProcessor ()
AP4_ProtectionKeyMap & GetKeyMap ()
AP4_TrackPropertyMap & GetPropertyMap ()
virtual AP4_Result | Initialize (AP4_AtomParent &top_level, AP4_ByteStream &stream, AP4_Processor::ProgressListener *listener=NULL)
This method can be overridden by concrete subclasses.
virtual
AP4_Processor::TrackHandler * 		CreateTrackHandler (AP4_TrakAtom *trak)
This method can be overridden by concrete subclasses.
virtual
AP4_Processor::FragmentHandler * 		CreateFragmentHandler (AP4_ContainerAtom *traf)
This method can be overridden by concrete subclasses.

Protected Attributes

AP4_PiffCipherMode m_CipherMode
AP4_BlockCipherFactory * m_BlockCipherFactory
AP4_ProtectionKeyMap m_KeyMap
AP4_TrackPropertyMap m_PropertyMap
AP4_List< Encrypter > m_Encrypters

Detailed Description

Definition at line 176 of file Ap4Piff.h.

Constructor & Destructor Documentation

AP4_PiffEncryptingProcessor::AP4_PiffEncryptingProcessor | ( | AP4_PiffCipherMode | cipher_mode,
 |  | AP4_BlockCipherFactory * | block_cipher_factory = NULL
 | ) |  |
AP4_PiffEncryptingProcessor::~AP4_PiffEncryptingProcessor ( )

Member Function Documentation

virtual AP4_Processor::FragmentHandler* AP4_PiffEncryptingProcessor::CreateFragmentHandler ( AP4_ContainerAtom * ) [virtual]

This method can be overridden by concrete subclasses.

It is called once for each fragment in the input file.

Parameters:
track Pointer to the fragment for which a handler should be created.
Returns:
A pointer to a fragment handler, or NULL if no handler needs to be created for that fragment.

Reimplemented from AP4_Processor.

virtual AP4_Processor::TrackHandler* AP4_PiffEncryptingProcessor::CreateTrackHandler ( AP4_TrakAtom * ) [virtual]

This method can be overridden by concrete subclasses.

It is called once for each track in the input file.

Parameters:
track Pointer to the track for which a handler should be created.
Returns:
A pointer to a track handler, or NULL if no handler needs to be created for that track.

Reimplemented from AP4_Processor.

AP4_ProtectionKeyMap& AP4_PiffEncryptingProcessor::GetKeyMap ( ) [inline]

Definition at line 195 of file Ap4Piff.h.

References m_KeyMap.

AP4_TrackPropertyMap& AP4_PiffEncryptingProcessor::GetPropertyMap ( ) [inline]

Definition at line 196 of file Ap4Piff.h.

References m_PropertyMap.

virtual AP4_Result AP4_PiffEncryptingProcessor::Initialize | ( | AP4_AtomParent & | top_level,
 |  | AP4_ByteStream & | stream,
 |  | AP4_Processor::ProgressListener * | listener = NULL |
 | ) |  |  | [virtual]

This method can be overridden by concrete subclasses.

It is called just after the input stream has been parsed into an atom tree, before the processing of the tracks.

Parameters:
top_level Container atom containing all the atoms parsed from the input stream. Note that this atom does not actually exist in the file; it is a synthetised container created for the purpose of holding together all the input's top-level atoms.

Reimplemented from AP4_Processor.

Member Data Documentation

AP4_BlockCipherFactory* AP4_PiffEncryptingProcessor::m_BlockCipherFactory [protected]

Definition at line 208 of file Ap4Piff.h.

AP4_PiffCipherMode AP4_PiffEncryptingProcessor::m_CipherMode [protected]

Definition at line 207 of file Ap4Piff.h.

AP4_List<Encrypter> AP4_PiffEncryptingProcessor::m_Encrypters [protected]

Definition at line 211 of file Ap4Piff.h.

AP4_ProtectionKeyMap AP4_PiffEncryptingProcessor::m_KeyMap [protected]

Definition at line 209 of file Ap4Piff.h.

Referenced by GetKeyMap().

AP4_TrackPropertyMap AP4_PiffEncryptingProcessor::m_PropertyMap [protected]

Definition at line 210 of file Ap4Piff.h.

Referenced by GetPropertyMap().

The documentation for this class was generated from the following file:
  • Ap4Piff.h
Generated on Thu May 13 16:37:42 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_PiffEncryptingProcessor Member List

This is the complete list of members for AP4_PiffEncryptingProcessor, including all inherited members.
AP4_PiffEncryptingProcessor(AP4_PiffCipherMode cipher_mode, AP4_BlockCipherFactory *block_cipher_factory=NULL) | AP4_PiffEncryptingProcessor |
CreateFragmentHandler(AP4_ContainerAtom *traf) | AP4_PiffEncryptingProcessor | [virtual]
CreateTrackHandler(AP4_TrakAtom *trak) | AP4_PiffEncryptingProcessor | [virtual]
Finalize(AP4_AtomParent &top_level, ProgressListener *listener=NULL) | AP4_Processor | [virtual]
GetKeyMap() | AP4_PiffEncryptingProcessor | [inline]
GetPropertyMap() | AP4_PiffEncryptingProcessor | [inline]
Initialize(AP4_AtomParent &top_level, AP4_ByteStream &stream, AP4_Processor::ProgressListener *listener=NULL) | AP4_PiffEncryptingProcessor | [virtual]
m_BlockCipherFactory | AP4_PiffEncryptingProcessor | [protected]
m_CipherMode | AP4_PiffEncryptingProcessor | [protected]
m_Encrypters | AP4_PiffEncryptingProcessor | [protected]
m_ExternalTrackData | AP4_Processor | [protected]
m_KeyMap | AP4_PiffEncryptingProcessor | [protected]
m_PropertyMap | AP4_PiffEncryptingProcessor | [protected]
Process(AP4_ByteStream &input, AP4_ByteStream &output, ProgressListener *listener=NULL, AP4_AtomFactory &atom_factory=AP4_DefaultAtomFactory::Instance) | AP4_Processor |
ProcessFragments(AP4_MoovAtom *moov, AP4_List< AP4_MoofLocator > &moofs, AP4_ContainerAtom *mfra, AP4_ByteStream &input, AP4_ByteStream &output) | AP4_Processor | [protected]
~AP4_PiffEncryptingProcessor() | AP4_PiffEncryptingProcessor |
~AP4_Processor() | AP4_Processor | [inline, virtual]
Generated on Thu May 13 16:37:42 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_PiffNullSampleDecrypter Class Reference

AP4_PiffNullSampleDecrypter Class Reference

#include <Ap4Piff.h>

Inheritance diagram for AP4_PiffNullSampleDecrypter:
AP4_PiffSampleDecrypter AP4_SampleDecrypter

List of all members.

Public Member Functions

AP4_PiffNullSampleDecrypter ()
virtual AP4_Result DecryptSampleData (AP4_DataBuffer &data_in, AP4_DataBuffer &data_out, const AP4_UI08 *)

Detailed Description

Definition at line 242 of file Ap4Piff.h.

Constructor & Destructor Documentation

AP4_PiffNullSampleDecrypter::AP4_PiffNullSampleDecrypter ( ) [inline]

Definition at line 246 of file Ap4Piff.h.

Member Function Documentation

virtual AP4_Result AP4_PiffNullSampleDecrypter::DecryptSampleData | ( | AP4_DataBuffer & | data_in,
 |  | AP4_DataBuffer & | data_out,
 |  | const AP4_UI08 * |  |
 | ) |  |  | [inline, virtual]

Implements AP4_SampleDecrypter.

Definition at line 249 of file Ap4Piff.h.

References AP4_SUCCESS, AP4_DataBuffer::GetData(), AP4_DataBuffer::GetDataSize(), and AP4_DataBuffer::SetData().

The documentation for this class was generated from the following file:
  • Ap4Piff.h
Generated on Thu May 13 16:37:43 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_PiffNullSampleDecrypter Member List

This is the complete list of members for AP4_PiffNullSampleDecrypter, including all inherited members.
AP4_PiffNullSampleDecrypter() | AP4_PiffNullSampleDecrypter | [inline]
AP4_PiffSampleDecrypter(AP4_PiffSampleEncryptionAtom *sample_encryption_atom) | AP4_PiffSampleDecrypter | [inline, protected]
Create(AP4_ProtectedSampleDescription *sample_description, AP4_ContainerAtom *traf, const AP4_UI08 *key, AP4_Size key_size, AP4_BlockCipherFactory *block_cipher_factory, AP4_PiffSampleDecrypter *&decrypter) | AP4_PiffSampleDecrypter | [static]
AP4_SampleDecrypter::Create(AP4_ProtectedSampleDescription *sample_description, const AP4_UI08 *key, AP4_Size key_size, AP4_BlockCipherFactory *block_cipher_factory=NULL) | AP4_SampleDecrypter | [static]
AP4_SampleDecrypter::Create(AP4_ProtectedSampleDescription *sample_description, AP4_ContainerAtom *traf, const AP4_UI08 *key, AP4_Size key_size, AP4_BlockCipherFactory *block_cipher_factory=NULL) | AP4_SampleDecrypter | [static]
DecryptSampleData(AP4_DataBuffer &data_in, AP4_DataBuffer &data_out, const AP4_UI08 *) | AP4_PiffNullSampleDecrypter | [inline, virtual]
GetDecryptedSampleSize(AP4_Sample &sample) | AP4_SampleDecrypter | [inline, virtual]
m_SampleEncryptionAtom | AP4_PiffSampleDecrypter | [protected]
m_SampleIndex | AP4_PiffSampleDecrypter | [protected]
SetSampleIndex(AP4_Ordinal sample_index) | AP4_PiffSampleDecrypter | [virtual]
~AP4_SampleDecrypter() | AP4_SampleDecrypter | [inline, virtual]
Generated on Thu May 13 16:37:43 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_PiffSampleDecrypter Class Reference

AP4_PiffSampleDecrypter Class Reference

#include <Ap4Piff.h>

Inheritance diagram for AP4_PiffSampleDecrypter:
AP4_SampleDecrypter AP4_PiffCbcSampleDecrypter AP4_PiffCtrSampleDecrypter AP4_PiffNullSampleDecrypter AP4_PiffAvcCbcSampleDecrypter AP4_PiffAvcCtrSampleDecrypter

List of all members.

Public Member Functions

virtual AP4_Result | SetSampleIndex (AP4_Ordinal sample_index)

Static Public Member Functions

static AP4_Result | Create (AP4_ProtectedSampleDescription *sample_description, AP4_ContainerAtom *traf, const AP4_UI08 *key, AP4_Size key_size, AP4_BlockCipherFactory *block_cipher_factory, AP4_PiffSampleDecrypter *&decrypter)

Protected Member Functions

AP4_PiffSampleDecrypter (AP4_PiffSampleEncryptionAtom *sample_encryption_atom)

Protected Attributes

AP4_PiffSampleEncryptionAtom * m_SampleEncryptionAtom
AP4_Ordinal m_SampleIndex

Detailed Description

Definition at line 217 of file Ap4Piff.h.

Constructor & Destructor Documentation

AP4_PiffSampleDecrypter::AP4_PiffSampleDecrypter ( AP4_PiffSampleEncryptionAtom * sample_encryption_atom ) [inline, protected]

Definition at line 232 of file Ap4Piff.h.

Member Function Documentation

static AP4_Result AP4_PiffSampleDecrypter::Create | ( | AP4_ProtectedSampleDescription * | sample_description,
 |  | AP4_ContainerAtom * | traf,
 |  | const AP4_UI08 * | key,
 |  | AP4_Size | key_size,
 |  | AP4_BlockCipherFactory * | block_cipher_factory,
 |  | AP4_PiffSampleDecrypter *& | decrypter |
 | ) |  |  | [static]
virtual AP4_Result AP4_PiffSampleDecrypter::SetSampleIndex ( AP4_Ordinal sample_index ) [virtual]

Reimplemented from AP4_SampleDecrypter.

Member Data Documentation

AP4_PiffSampleEncryptionAtom* AP4_PiffSampleDecrypter::m_SampleEncryptionAtom [protected]

Definition at line 235 of file Ap4Piff.h.

AP4_Ordinal AP4_PiffSampleDecrypter::m_SampleIndex [protected]

Definition at line 236 of file Ap4Piff.h.

The documentation for this class was generated from the following file:
  • Ap4Piff.h
Generated on Thu May 13 16:37:43 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_PiffSampleDecrypter Member List

This is the complete list of members for AP4_PiffSampleDecrypter, including all inherited members.
AP4_PiffSampleDecrypter(AP4_PiffSampleEncryptionAtom *sample_encryption_atom) | AP4_PiffSampleDecrypter | [inline, protected]
Create(AP4_ProtectedSampleDescription *sample_description, AP4_ContainerAtom *traf, const AP4_UI08 *key, AP4_Size key_size, AP4_BlockCipherFactory *block_cipher_factory, AP4_PiffSampleDecrypter *&decrypter) | AP4_PiffSampleDecrypter | [static]
AP4_SampleDecrypter::Create(AP4_ProtectedSampleDescription *sample_description, const AP4_UI08 *key, AP4_Size key_size, AP4_BlockCipherFactory *block_cipher_factory=NULL) | AP4_SampleDecrypter | [static]
AP4_SampleDecrypter::Create(AP4_ProtectedSampleDescription *sample_description, AP4_ContainerAtom *traf, const AP4_UI08 *key, AP4_Size key_size, AP4_BlockCipherFactory *block_cipher_factory=NULL) | AP4_SampleDecrypter | [static]
DecryptSampleData(AP4_DataBuffer &data_in, AP4_DataBuffer &data_out, const AP4_UI08 *iv=NULL)=0 | AP4_SampleDecrypter | [pure virtual]
GetDecryptedSampleSize(AP4_Sample &sample) | AP4_SampleDecrypter | [inline, virtual]
m_SampleEncryptionAtom | AP4_PiffSampleDecrypter | [protected]
m_SampleIndex | AP4_PiffSampleDecrypter | [protected]
SetSampleIndex(AP4_Ordinal sample_index) | AP4_PiffSampleDecrypter | [virtual]
~AP4_SampleDecrypter() | AP4_SampleDecrypter | [inline, virtual]
Generated on Thu May 13 16:37:43 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_PiffSampleEncrypter Class Reference

AP4_PiffSampleEncrypter Class Reference

#include <Ap4Piff.h>

Inheritance diagram for AP4_PiffSampleEncrypter:
AP4_PiffCbcSampleEncrypter AP4_PiffCtrSampleEncrypter AP4_PiffAvcCbcSampleEncrypter AP4_PiffAvcCtrSampleEncrypter

List of all members.

Public Member Functions

AP4_PiffSampleEncrypter ()
virtual | ~AP4_PiffSampleEncrypter ()
virtual AP4_Result | EncryptSampleData (AP4_DataBuffer &data_in, AP4_DataBuffer &data_out)=0
void | SetIv (const AP4_UI08 *iv)
const AP4_UI08 * | GetIv ()

Protected Attributes

AP4_UI08 | m_Iv [16]

Detailed Description

Definition at line 75 of file Ap4Piff.h.

Constructor & Destructor Documentation

AP4_PiffSampleEncrypter::AP4_PiffSampleEncrypter ( ) [inline]

Definition at line 79 of file Ap4Piff.h.

References m_Iv.

virtual AP4_PiffSampleEncrypter::~AP4_PiffSampleEncrypter ( ) [inline, virtual]

Definition at line 80 of file Ap4Piff.h.

Member Function Documentation

virtual AP4_Result AP4_PiffSampleEncrypter::EncryptSampleData | ( | AP4_DataBuffer & | data_in,
 |  | AP4_DataBuffer & | data_out |
 | ) |  |  | [pure virtual]

Implemented in AP4_PiffCtrSampleEncrypter, AP4_PiffAvcCtrSampleEncrypter, AP4_PiffCbcSampleEncrypter, and AP4_PiffAvcCbcSampleEncrypter.

const AP4_UI08* AP4_PiffSampleEncrypter::GetIv ( ) [inline]

Definition at line 87 of file Ap4Piff.h.

References m_Iv.

void AP4_PiffSampleEncrypter::SetIv ( const AP4_UI08 * iv ) [inline]

Definition at line 86 of file Ap4Piff.h.

References m_Iv.

Member Data Documentation

AP4_UI08 AP4_PiffSampleEncrypter::m_Iv[16] [protected]

Definition at line 90 of file Ap4Piff.h.

Referenced by AP4_PiffSampleEncrypter(), GetIv(), and SetIv().

The documentation for this class was generated from the following file:
  • Ap4Piff.h
Generated on Thu May 13 16:37:43 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_PiffSampleEncrypter Member List

This is the complete list of members for AP4_PiffSampleEncrypter, including all inherited members.
AP4_PiffSampleEncrypter() | AP4_PiffSampleEncrypter | [inline]
EncryptSampleData(AP4_DataBuffer &data_in, AP4_DataBuffer &data_out)=0 | AP4_PiffSampleEncrypter | [pure virtual]
GetIv() | AP4_PiffSampleEncrypter | [inline]
m_Iv | AP4_PiffSampleEncrypter | [protected]
SetIv(const AP4_UI08 *iv) | AP4_PiffSampleEncrypter | [inline]
~AP4_PiffSampleEncrypter() | AP4_PiffSampleEncrypter | [inline, virtual]
Generated on Thu May 13 16:37:43 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_PiffSampleEncryptionAtom Class Reference

AP4_PiffSampleEncryptionAtom Class Reference

#include <Ap4Piff.h>

Inheritance diagram for AP4_PiffSampleEncryptionAtom:
AP4_UuidAtom AP4_Atom

List of all members.

Public Member Functions

AP4_PiffSampleEncryptionAtom (AP4_Cardinal sample_count)
AP4_PiffSampleEncryptionAtom (AP4_UI32 algorithm_id, AP4_UI08 iv_size, const AP4_UI08 *kid, AP4_Cardinal sample_count)
virtual AP4_Result | InspectFields (AP4_AtomInspector &inspector)
virtual AP4_Result | WriteFields (AP4_ByteStream &stream)
AP4_UI32 GetAlgorithmId ()
AP4_UI08 GetIvSize ()
AP4_Result | SetIvSize (AP4_UI08 iv_size)
const AP4_UI08 * | GetKid ()
AP4_Cardinal GetIvCount ()
const AP4_UI08 * | GetIv (AP4_Ordinal indx)
AP4_Result | SetIv (AP4_Ordinal indx, const AP4_UI08 *iv)

Static Public Member Functions

static
AP4_PiffSampleEncryptionAtom * 		Create (AP4_Size size, AP4_ByteStream &stream)

Detailed Description

Definition at line 390 of file Ap4Piff.h.

Constructor & Destructor Documentation

AP4_PiffSampleEncryptionAtom::AP4_PiffSampleEncryptionAtom ( AP4_Cardinal sample_count )
AP4_PiffSampleEncryptionAtom::AP4_PiffSampleEncryptionAtom | ( | AP4_UI32 | algorithm_id,
 |  | AP4_UI08 | iv_size,
 |  | const AP4_UI08 * | kid,
 |  | AP4_Cardinal | sample_count
 | ) |  |

Member Function Documentation

static AP4_PiffSampleEncryptionAtom* AP4_PiffSampleEncryptionAtom::Create | ( | AP4_Size | size,
 |  | AP4_ByteStream & | stream |
 | ) |  |  | [static]
AP4_UI32 AP4_PiffSampleEncryptionAtom::GetAlgorithmId ( ) [inline]

Definition at line 411 of file Ap4Piff.h.

const AP4_UI08* AP4_PiffSampleEncryptionAtom::GetIv ( AP4_Ordinal indx )
AP4_Cardinal AP4_PiffSampleEncryptionAtom::GetIvCount ( ) [inline]

Definition at line 415 of file Ap4Piff.h.

AP4_UI08 AP4_PiffSampleEncryptionAtom::GetIvSize ( ) [inline]

Definition at line 412 of file Ap4Piff.h.

const AP4_UI08* AP4_PiffSampleEncryptionAtom::GetKid ( ) [inline]

Definition at line 414 of file Ap4Piff.h.

virtual AP4_Result AP4_PiffSampleEncryptionAtom::InspectFields ( AP4_AtomInspector & inspector ) [virtual]

Reimplemented from AP4_Atom.

AP4_Result AP4_PiffSampleEncryptionAtom::SetIv | ( | AP4_Ordinal | indx,
 |  | const AP4_UI08 * | iv
 | ) |  |
AP4_Result AP4_PiffSampleEncryptionAtom::SetIvSize ( AP4_UI08 iv_size )
virtual AP4_Result AP4_PiffSampleEncryptionAtom::WriteFields ( AP4_ByteStream & stream ) [virtual]

Implements AP4_Atom.

The documentation for this class was generated from the following file:
  • Ap4Piff.h
Generated on Thu May 13 16:37:44 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_PiffSampleEncryptionAtom Member List

This is the complete list of members for AP4_PiffSampleEncryptionAtom, including all inherited members.
AP4_Atom(Type type, AP4_UI32 size=AP4_ATOM_HEADER_SIZE) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64=false) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_PiffSampleEncryptionAtom(AP4_Cardinal sample_count) | AP4_PiffSampleEncryptionAtom |
AP4_PiffSampleEncryptionAtom(AP4_UI32 algorithm_id, AP4_UI08 iv_size, const AP4_UI08 *kid, AP4_Cardinal sample_count) | AP4_PiffSampleEncryptionAtom |
AP4_UuidAtom(AP4_UI64 size, const AP4_UI08 *uuid) | AP4_UuidAtom | [protected]
AP4_UuidAtom(AP4_UI64 size, const AP4_UI08 *uuid, AP4_UI32 version, AP4_UI32 flags) | AP4_UuidAtom | [protected]
AP4_UuidAtom(AP4_UI64 size, bool is_full, AP4_ByteStream &stream) | AP4_UuidAtom | [protected]
Clone() | AP4_Atom | [virtual]
Create(AP4_Size size, AP4_ByteStream &stream) | AP4_PiffSampleEncryptionAtom | [static]
Detach() | AP4_Atom | [virtual]
GetAlgorithmId() | AP4_PiffSampleEncryptionAtom | [inline]
GetFlags() const | AP4_Atom | [inline]
GetHeaderSize() const | AP4_UuidAtom | [virtual]
GetIv(AP4_Ordinal indx) | AP4_PiffSampleEncryptionAtom |
GetIvCount() | AP4_PiffSampleEncryptionAtom | [inline]
GetIvSize() | AP4_PiffSampleEncryptionAtom | [inline]
GetKid() | AP4_PiffSampleEncryptionAtom | [inline]
GetParent() | AP4_Atom | [inline, virtual]
GetSize() const | AP4_Atom | [inline]
GetSize32() const | AP4_Atom | [inline]
GetSize64() const | AP4_Atom | [inline]
GetType() const | AP4_Atom | [inline]
GetUuid() | AP4_UuidAtom | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
InspectFields(AP4_AtomInspector &inspector) | AP4_PiffSampleEncryptionAtom | [virtual]
InspectHeader(AP4_AtomInspector &inspector) | AP4_UuidAtom | [virtual]
m_Flags | AP4_Atom | [protected]
m_IsFull | AP4_Atom | [protected]
m_Parent | AP4_Atom | [protected]
m_Size32 | AP4_Atom | [protected]
m_Size64 | AP4_Atom | [protected]
m_Type | AP4_Atom | [protected]
m_Uuid | AP4_UuidAtom | [protected]
m_Version | AP4_Atom | [protected]
ReadFullHeader(AP4_ByteStream &stream, AP4_UI32 &version, AP4_UI32 &flags) | AP4_Atom | [static]
SetFlags(AP4_UI32 flags) | AP4_Atom | [inline]
SetIv(AP4_Ordinal indx, const AP4_UI08 *iv) | AP4_PiffSampleEncryptionAtom |
SetIvSize(AP4_UI08 iv_size) | AP4_PiffSampleEncryptionAtom |
SetParent(AP4_AtomParent *parent) | AP4_Atom | [inline, virtual]
SetSize(AP4_UI64 size, bool force_64=false) | AP4_Atom |
SetSize32(AP4_UI32 size) | AP4_Atom | [inline]
SetSize64(AP4_UI64 size) | AP4_Atom | [inline]
SetType(Type type) | AP4_Atom | [inline]
Type typedef | AP4_Atom |
TypeFromString(const char *four_cc) | AP4_Atom | [static]
Write(AP4_ByteStream &stream) | AP4_Atom | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_PiffSampleEncryptionAtom | [virtual]
WriteHeader(AP4_ByteStream &stream) | AP4_UuidAtom | [virtual]
~AP4_Atom() | AP4_Atom | [inline, virtual]
~AP4_UuidAtom() | AP4_UuidAtom | [inline, virtual]
Generated on Thu May 13 16:37:44 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_PiffTrackEncryptionAtom Class Reference

AP4_PiffTrackEncryptionAtom Class Reference

#include <Ap4Piff.h>

Inheritance diagram for AP4_PiffTrackEncryptionAtom:
AP4_UuidAtom AP4_Atom

List of all members.

Public Member Functions

AP4_PiffTrackEncryptionAtom (AP4_UI32 default_algorithm_id, AP4_UI08 default_iv_size, const AP4_UI08 *default_kid)
virtual AP4_Result | InspectFields (AP4_AtomInspector &inspector)
virtual AP4_Result | WriteFields (AP4_ByteStream &stream)
AP4_UI32 GetDefaultAlgorithmId ()
AP4_UI08 GetDefaultIvSize ()
const AP4_UI08 * | GetDefaultKid ()

Static Public Member Functions

static
AP4_PiffTrackEncryptionAtom * 		Create (AP4_Size size, AP4_ByteStream &stream)

Detailed Description

Definition at line 351 of file Ap4Piff.h.

Constructor & Destructor Documentation

AP4_PiffTrackEncryptionAtom::AP4_PiffTrackEncryptionAtom | ( | AP4_UI32 | default_algorithm_id,
 |  | AP4_UI08 | default_iv_size,
 |  | const AP4_UI08 * | default_kid
 | ) |  |

Member Function Documentation

static AP4_PiffTrackEncryptionAtom* AP4_PiffTrackEncryptionAtom::Create | ( | AP4_Size | size,
 |  | AP4_ByteStream & | stream |
 | ) |  |  | [static]
AP4_UI32 AP4_PiffTrackEncryptionAtom::GetDefaultAlgorithmId ( ) [inline]

Definition at line 370 of file Ap4Piff.h.

AP4_UI08 AP4_PiffTrackEncryptionAtom::GetDefaultIvSize ( ) [inline]

Definition at line 371 of file Ap4Piff.h.

const AP4_UI08* AP4_PiffTrackEncryptionAtom::GetDefaultKid ( ) [inline]

Definition at line 372 of file Ap4Piff.h.

virtual AP4_Result AP4_PiffTrackEncryptionAtom::InspectFields ( AP4_AtomInspector & inspector ) [virtual]

Reimplemented from AP4_Atom.

virtual AP4_Result AP4_PiffTrackEncryptionAtom::WriteFields ( AP4_ByteStream & stream ) [virtual]

Implements AP4_Atom.

The documentation for this class was generated from the following file:
  • Ap4Piff.h
Generated on Thu May 13 16:37:44 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_PiffTrackEncryptionAtom Member List

This is the complete list of members for AP4_PiffTrackEncryptionAtom, including all inherited members.
AP4_Atom(Type type, AP4_UI32 size=AP4_ATOM_HEADER_SIZE) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64=false) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_PiffTrackEncryptionAtom(AP4_UI32 default_algorithm_id, AP4_UI08 default_iv_size, const AP4_UI08 *default_kid) | AP4_PiffTrackEncryptionAtom |
AP4_UuidAtom(AP4_UI64 size, const AP4_UI08 *uuid) | AP4_UuidAtom | [protected]
AP4_UuidAtom(AP4_UI64 size, const AP4_UI08 *uuid, AP4_UI32 version, AP4_UI32 flags) | AP4_UuidAtom | [protected]
AP4_UuidAtom(AP4_UI64 size, bool is_full, AP4_ByteStream &stream) | AP4_UuidAtom | [protected]
Clone() | AP4_Atom | [virtual]
Create(AP4_Size size, AP4_ByteStream &stream) | AP4_PiffTrackEncryptionAtom | [static]
Detach() | AP4_Atom | [virtual]
GetDefaultAlgorithmId() | AP4_PiffTrackEncryptionAtom | [inline]
GetDefaultIvSize() | AP4_PiffTrackEncryptionAtom | [inline]
GetDefaultKid() | AP4_PiffTrackEncryptionAtom | [inline]
GetFlags() const | AP4_Atom | [inline]
GetHeaderSize() const | AP4_UuidAtom | [virtual]
GetParent() | AP4_Atom | [inline, virtual]
GetSize() const | AP4_Atom | [inline]
GetSize32() const | AP4_Atom | [inline]
GetSize64() const | AP4_Atom | [inline]
GetType() const | AP4_Atom | [inline]
GetUuid() | AP4_UuidAtom | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
InspectFields(AP4_AtomInspector &inspector) | AP4_PiffTrackEncryptionAtom | [virtual]
InspectHeader(AP4_AtomInspector &inspector) | AP4_UuidAtom | [virtual]
m_Flags | AP4_Atom | [protected]
m_IsFull | AP4_Atom | [protected]
m_Parent | AP4_Atom | [protected]
m_Size32 | AP4_Atom | [protected]
m_Size64 | AP4_Atom | [protected]
m_Type | AP4_Atom | [protected]
m_Uuid | AP4_UuidAtom | [protected]
m_Version | AP4_Atom | [protected]
ReadFullHeader(AP4_ByteStream &stream, AP4_UI32 &version, AP4_UI32 &flags) | AP4_Atom | [static]
SetFlags(AP4_UI32 flags) | AP4_Atom | [inline]
SetParent(AP4_AtomParent *parent) | AP4_Atom | [inline, virtual]
SetSize(AP4_UI64 size, bool force_64=false) | AP4_Atom |
SetSize32(AP4_UI32 size) | AP4_Atom | [inline]
SetSize64(AP4_UI64 size) | AP4_Atom | [inline]
SetType(Type type) | AP4_Atom | [inline]
Type typedef | AP4_Atom |
TypeFromString(const char *four_cc) | AP4_Atom | [static]
Write(AP4_ByteStream &stream) | AP4_Atom | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_PiffTrackEncryptionAtom | [virtual]
WriteHeader(AP4_ByteStream &stream) | AP4_UuidAtom | [virtual]
~AP4_Atom() | AP4_Atom | [inline, virtual]
~AP4_UuidAtom() | AP4_UuidAtom | [inline, virtual]
Generated on Thu May 13 16:37:44 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_PrintInspector Class Reference

AP4_PrintInspector Class Reference

#include <Ap4Atom.h>

Inheritance diagram for AP4_PrintInspector:
AP4_AtomInspector

List of all members.

Public Member Functions

AP4_PrintInspector (AP4_ByteStream &stream, AP4_Cardinal indent=0)
~AP4_PrintInspector ()
void | StartElement (const char *name, const char *info)
void | EndElement ()
void | AddField (const char *name, AP4_UI64 value, FormatHint hint)
void | AddFieldF (const char *name, float value, FormatHint hint)
void | AddField (const char *name, const char *value, FormatHint hint)
void | AddField (const char *name, const unsigned char *bytes, AP4_Size size, FormatHint hint)

Detailed Description

Definition at line 127 of file Ap4Atom.h.

Constructor & Destructor Documentation

AP4_PrintInspector::AP4_PrintInspector | ( | AP4_ByteStream & | stream,
 |  | AP4_Cardinal | indent = 0
 | ) |  |
AP4_PrintInspector::~AP4_PrintInspector ( )

Member Function Documentation

void AP4_PrintInspector::AddField | ( | const char * | name,
 |  | const unsigned char * | bytes,
 |  | AP4_Size | size,
 |  | FormatHint | hint |
 | ) |  |  | [virtual]

Reimplemented from AP4_AtomInspector.

void AP4_PrintInspector::AddField | ( | const char * | name,
 |  | const char * | value,
 |  | FormatHint | hint |
 | ) |  |  | [virtual]

Reimplemented from AP4_AtomInspector.

void AP4_PrintInspector::AddField | ( | const char * | name,
 |  | AP4_UI64 | value,
 |  | FormatHint | hint |
 | ) |  |  | [virtual]

Reimplemented from AP4_AtomInspector.

void AP4_PrintInspector::AddFieldF | ( | const char * | name,
 |  | float | value,
 |  | FormatHint | hint |
 | ) |  |  | [virtual]

Reimplemented from AP4_AtomInspector.

void AP4_PrintInspector::EndElement ( ) [virtual]

Reimplemented from AP4_AtomInspector.

void AP4_PrintInspector::StartElement | ( | const char * | name,
 |  | const char * | info |
 | ) |  |  | [virtual]

Reimplemented from AP4_AtomInspector.

The documentation for this class was generated from the following file:
  • Ap4Atom.h
Generated on Thu May 13 16:37:44 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_PrintInspector Member List

This is the complete list of members for AP4_PrintInspector, including all inherited members.
AddField(const char *name, AP4_UI64 value, FormatHint hint) | AP4_PrintInspector | [virtual]
AddField(const char *name, const char *value, FormatHint hint) | AP4_PrintInspector | [virtual]
AddField(const char *name, const unsigned char *bytes, AP4_Size size, FormatHint hint) | AP4_PrintInspector | [virtual]
AddFieldF(const char *name, float value, FormatHint hint) | AP4_PrintInspector | [virtual]
AP4_AtomInspector() | AP4_AtomInspector | [inline]
AP4_PrintInspector(AP4_ByteStream &stream, AP4_Cardinal indent=0) | AP4_PrintInspector |
EndElement() | AP4_PrintInspector | [virtual]
FormatHint enum name | AP4_AtomInspector |
GetVerbosity() | AP4_AtomInspector | [inline]
HINT_BOOLEAN enum value | AP4_AtomInspector |
HINT_HEX enum value | AP4_AtomInspector |
HINT_NONE enum value | AP4_AtomInspector |
m_Verbosity | AP4_AtomInspector | [protected]
SetVerbosity(AP4_Ordinal verbosity) | AP4_AtomInspector | [inline]
StartElement(const char *name, const char *info) | AP4_PrintInspector | [virtual]
~AP4_AtomInspector() | AP4_AtomInspector | [inline, virtual]
~AP4_PrintInspector() | AP4_PrintInspector |
Generated on Thu May 13 16:37:44 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_Processor Class Reference

AP4_Processor Class Reference

#include <Ap4Processor.h>

Inheritance diagram for AP4_Processor:
AP4_IsmaEncryptingProcessor AP4_MarlinIpmpDecryptingProcessor AP4_MarlinIpmpEncryptingProcessor AP4_OmaDcfDecryptingProcessor AP4_OmaDcfEncryptingProcessor AP4_PiffEncryptingProcessor AP4_StandardDecryptingProcessor

List of all members.

Classes

class | ExternalTrackData
class | FragmentHandler
Abstract class that defines the interface implemented by concrete fragment handlers. More...
class | ProgressListener
Abstract class that defines the interface implemented by progress listeners. More...
class | TrackHandler
Abstract class that defines the interface implemented by concrete track handlers. More...

Public Member Functions

virtual | ~AP4_Processor ()
Default destructor.
AP4_Result | Process (AP4_ByteStream &input, AP4_ByteStream &output, ProgressListener *listener=NULL, AP4_AtomFactory &atom_factory=AP4_DefaultAtomFactory::Instance)
Process the input stream into an output stream.
virtual AP4_Result | Initialize (AP4_AtomParent &top_level, AP4_ByteStream &stream, ProgressListener *listener=NULL)
This method can be overridden by concrete subclasses.
virtual AP4_Result | Finalize (AP4_AtomParent &top_level, ProgressListener *listener=NULL)
This method can be overridden by concrete subclasses.
virtual TrackHandler * | CreateTrackHandler (AP4_TrakAtom *)
This method can be overridden by concrete subclasses.
virtual FragmentHandler * | CreateFragmentHandler (AP4_ContainerAtom *)
This method can be overridden by concrete subclasses.

Protected Member Functions

AP4_Result | ProcessFragments (AP4_MoovAtom *moov, AP4_List< AP4_MoofLocator > &moofs, AP4_ContainerAtom *mfra, AP4_ByteStream &input, AP4_ByteStream &output)

Protected Attributes

AP4_List< ExternalTrackData > m_ExternalTrackData

Detailed Description

Definition at line 53 of file Ap4Processor.h.

Constructor & Destructor Documentation

virtual AP4_Processor::~AP4_Processor ( ) [inline, virtual]

Default destructor.

Definition at line 158 of file Ap4Processor.h.

References AP4_List< T >::DeleteReferences(), and m_ExternalTrackData.

Member Function Documentation

virtual FragmentHandler* AP4_Processor::CreateFragmentHandler ( AP4_ContainerAtom * ) [inline, virtual]

This method can be overridden by concrete subclasses.

It is called once for each fragment in the input file.

Parameters:
track Pointer to the fragment for which a handler should be created.
Returns:
A pointer to a fragment handler, or NULL if no handler needs to be created for that fragment.

Reimplemented in AP4_PiffEncryptingProcessor.

Definition at line 213 of file Ap4Processor.h.

virtual TrackHandler* AP4_Processor::CreateTrackHandler ( AP4_TrakAtom * ) [inline, virtual]

This method can be overridden by concrete subclasses.

It is called once for each track in the input file.

Parameters:
track Pointer to the track for which a handler should be created.
Returns:
A pointer to a track handler, or NULL if no handler needs to be created for that track.

Reimplemented in AP4_IsmaEncryptingProcessor, AP4_MarlinIpmpDecryptingProcessor, AP4_MarlinIpmpEncryptingProcessor, AP4_OmaDcfEncryptingProcessor, AP4_PiffEncryptingProcessor, and AP4_StandardDecryptingProcessor.

Definition at line 203 of file Ap4Processor.h.

virtual AP4_Result AP4_Processor::Finalize | ( | AP4_AtomParent & | top_level,
 |  | ProgressListener * | listener = NULL |
 | ) |  |  | [virtual]

This method can be overridden by concrete subclasses.

It is called just after the tracks have been processed.

virtual AP4_Result AP4_Processor::Initialize | ( | AP4_AtomParent & | top_level,
 |  | AP4_ByteStream & | stream,
 |  | ProgressListener * | listener = NULL |
 | ) |  |  | [virtual]

This method can be overridden by concrete subclasses.

It is called just after the input stream has been parsed into an atom tree, before the processing of the tracks.

Parameters:
top_level Container atom containing all the atoms parsed from the input stream. Note that this atom does not actually exist in the file; it is a synthetised container created for the purpose of holding together all the input's top-level atoms.

Reimplemented in AP4_MarlinIpmpDecryptingProcessor, AP4_MarlinIpmpEncryptingProcessor, AP4_OmaDcfDecryptingProcessor, AP4_OmaDcfEncryptingProcessor, AP4_PiffEncryptingProcessor, and AP4_StandardDecryptingProcessor.

AP4_Result AP4_Processor::Process | ( | AP4_ByteStream & | input,
 |  | AP4_ByteStream & | output,
 |  | ProgressListener * | listener = NULL,
 |  | AP4_AtomFactory & | atom_factory = AP4_DefaultAtomFactory::Instance
 | ) |  |

Process the input stream into an output stream.

Parameters:
input | Reference to the file to process.
output | Output stream to which the processed input will be written.
listener | Pointer to a listener, or NULL. The listener will be called one or more times before this method returns, with progress information.
AP4_Result AP4_Processor::ProcessFragments | ( | AP4_MoovAtom * | moov,
 |  | AP4_List< AP4_MoofLocator > & | moofs,
 |  | AP4_ContainerAtom * | mfra,
 |  | AP4_ByteStream & | input,
 |  | AP4_ByteStream & | output |
 | ) |  |  | [protected]

Member Data Documentation

AP4_List<ExternalTrackData> AP4_Processor::m_ExternalTrackData [protected]

Definition at line 234 of file Ap4Processor.h.

Referenced by ~AP4_Processor().

The documentation for this class was generated from the following file:
  • Ap4Processor.h
Generated on Thu May 13 16:37:44 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_Processor Member List

This is the complete list of members for AP4_Processor, including all inherited members.
CreateFragmentHandler(AP4_ContainerAtom *) | AP4_Processor | [inline, virtual]
CreateTrackHandler(AP4_TrakAtom *) | AP4_Processor | [inline, virtual]
Finalize(AP4_AtomParent &top_level, ProgressListener *listener=NULL) | AP4_Processor | [virtual]
Initialize(AP4_AtomParent &top_level, AP4_ByteStream &stream, ProgressListener *listener=NULL) | AP4_Processor | [virtual]
m_ExternalTrackData | AP4_Processor | [protected]
Process(AP4_ByteStream &input, AP4_ByteStream &output, ProgressListener *listener=NULL, AP4_AtomFactory &atom_factory=AP4_DefaultAtomFactory::Instance) | AP4_Processor |
ProcessFragments(AP4_MoovAtom *moov, AP4_List< AP4_MoofLocator > &moofs, AP4_ContainerAtom *mfra, AP4_ByteStream &input, AP4_ByteStream &output) | AP4_Processor | [protected]
~AP4_Processor() | AP4_Processor | [inline, virtual]
Generated on Thu May 13 16:37:44 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_ProtectedSampleDescription Class Reference

AP4_ProtectedSampleDescription Class Reference

#include <Ap4Protection.h>

Inheritance diagram for AP4_ProtectedSampleDescription:
AP4_SampleDescription

List of all members.

Public Member Functions

AP4_ProtectedSampleDescription (AP4_UI32 format, AP4_SampleDescription *original_sample_description, AP4_UI32 original_format, AP4_UI32 scheme_type, AP4_UI32 scheme_version, const char *scheme_uri, AP4_ContainerAtom *schi_atom, bool transfer_ownership_of_original=true)
~AP4_ProtectedSampleDescription ()
AP4_SampleDescription * GetOriginalSampleDescription ()
AP4_UI32 | GetOriginalFormat () const
AP4_UI32 | GetSchemeType () const
AP4_UI32 | GetSchemeVersion () const
const AP4_String & | GetSchemeUri () const
AP4_ProtectionSchemeInfo * | GetSchemeInfo () const
virtual AP4_Atom * | ToAtom () const

Detailed Description

Definition at line 214 of file Ap4Protection.h.

Constructor & Destructor Documentation

AP4_ProtectedSampleDescription::AP4_ProtectedSampleDescription | ( | AP4_UI32 | format,
 |  | AP4_SampleDescription * | original_sample_description,
 |  | AP4_UI32 | original_format,
 |  | AP4_UI32 | scheme_type,
 |  | AP4_UI32 | scheme_version,
 |  | const char * | scheme_uri,
 |  | AP4_ContainerAtom * | schi_atom,
 |  | bool | transfer_ownership_of_original = true
 | ) |  |
AP4_ProtectedSampleDescription::~AP4_ProtectedSampleDescription ( )

Member Function Documentation

AP4_UI32 AP4_ProtectedSampleDescription::GetOriginalFormat ( ) const [inline]

Definition at line 234 of file Ap4Protection.h.

AP4_SampleDescription* AP4_ProtectedSampleDescription::GetOriginalSampleDescription ( ) [inline]

Definition at line 231 of file Ap4Protection.h.

AP4_ProtectionSchemeInfo* AP4_ProtectedSampleDescription::GetSchemeInfo ( ) const [inline]

Definition at line 238 of file Ap4Protection.h.

AP4_UI32 AP4_ProtectedSampleDescription::GetSchemeType ( ) const [inline]

Definition at line 235 of file Ap4Protection.h.

const AP4_String& AP4_ProtectedSampleDescription::GetSchemeUri ( ) const [inline]

Definition at line 237 of file Ap4Protection.h.

AP4_UI32 AP4_ProtectedSampleDescription::GetSchemeVersion ( ) const [inline]

Definition at line 236 of file Ap4Protection.h.

virtual AP4_Atom* AP4_ProtectedSampleDescription::ToAtom ( ) const [virtual]

Reimplemented from AP4_SampleDescription.

The documentation for this class was generated from the following file:
  • Ap4Protection.h
Generated on Thu May 13 16:37:45 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_ProtectedSampleDescription Member List

This is the complete list of members for AP4_ProtectedSampleDescription, including all inherited members.
AP4_ProtectedSampleDescription(AP4_UI32 format, AP4_SampleDescription *original_sample_description, AP4_UI32 original_format, AP4_UI32 scheme_type, AP4_UI32 scheme_version, const char *scheme_uri, AP4_ContainerAtom *schi_atom, bool transfer_ownership_of_original=true) | AP4_ProtectedSampleDescription |
AP4_SampleDescription(Type type, AP4_UI32 format, AP4_AtomParent *details) | AP4_SampleDescription |
Clone(AP4_Result *result=NULL) | AP4_SampleDescription | [virtual]
GetDetails() | AP4_SampleDescription | [inline]
GetFormat() const | AP4_SampleDescription | [inline]
GetOriginalFormat() const | AP4_ProtectedSampleDescription | [inline]
GetOriginalSampleDescription() | AP4_ProtectedSampleDescription | [inline]
GetSchemeInfo() const | AP4_ProtectedSampleDescription | [inline]
GetSchemeType() const | AP4_ProtectedSampleDescription | [inline]
GetSchemeUri() const | AP4_ProtectedSampleDescription | [inline]
GetSchemeVersion() const | AP4_ProtectedSampleDescription | [inline]
GetType() const | AP4_SampleDescription | [inline]
m_Details | AP4_SampleDescription | [protected]
m_Format | AP4_SampleDescription | [protected]
m_Type | AP4_SampleDescription | [protected]
ToAtom() const | AP4_ProtectedSampleDescription | [virtual]
Type enum name | AP4_SampleDescription |
TYPE_AVC enum value | AP4_SampleDescription |
TYPE_MPEG enum value | AP4_SampleDescription |
TYPE_PROTECTED enum value | AP4_SampleDescription |
TYPE_UNKNOWN enum value | AP4_SampleDescription |
~AP4_ProtectedSampleDescription() | AP4_ProtectedSampleDescription |
~AP4_SampleDescription() | AP4_SampleDescription | [inline, virtual]
Generated on Thu May 13 16:37:45 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_ProtectionKeyMap Class Reference

AP4_ProtectionKeyMap Class Reference

#include <Ap4Protection.h>

List of all members.

Classes

class | KeyEntry

Public Member Functions

AP4_ProtectionKeyMap ()
~AP4_ProtectionKeyMap ()
AP4_Result | SetKey (AP4_UI32 track_id, const AP4_UI08 *key, const AP4_UI08 *iv=NULL)
AP4_Result | SetKeys (const AP4_ProtectionKeyMap &key_map)
AP4_Result | GetKeyAndIv (AP4_UI32 track_id, const AP4_UI08 *&key, const AP4_UI08 *&iv)
const AP4_UI08 * | GetKey (AP4_UI32 track_id) const

Detailed Description

Definition at line 132 of file Ap4Protection.h.

Constructor & Destructor Documentation

AP4_ProtectionKeyMap::AP4_ProtectionKeyMap ( )
AP4_ProtectionKeyMap::~AP4_ProtectionKeyMap ( )

Member Function Documentation

const AP4_UI08* AP4_ProtectionKeyMap::GetKey ( AP4_UI32 track_id ) const
AP4_Result AP4_ProtectionKeyMap::GetKeyAndIv | ( | AP4_UI32 | track_id,
 |  | const AP4_UI08 *& | key,
 |  | const AP4_UI08 *& | iv
 | ) |  |
AP4_Result AP4_ProtectionKeyMap::SetKey | ( | AP4_UI32 | track_id,
 |  | const AP4_UI08 * | key,
 |  | const AP4_UI08 * | iv = NULL
 | ) |  |
AP4_Result AP4_ProtectionKeyMap::SetKeys ( const AP4_ProtectionKeyMap & key_map )
The documentation for this class was generated from the following file:
  • Ap4Protection.h
Generated on Thu May 13 16:37:45 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_ProtectionKeyMap Member List

This is the complete list of members for AP4_ProtectionKeyMap, including all inherited members.
AP4_ProtectionKeyMap() | AP4_ProtectionKeyMap
GetKey(AP4_UI32 track_id) const | AP4_ProtectionKeyMap
GetKeyAndIv(AP4_UI32 track_id, const AP4_UI08 *&key, const AP4_UI08 *&iv) | AP4_ProtectionKeyMap
SetKey(AP4_UI32 track_id, const AP4_UI08 *key, const AP4_UI08 *iv=NULL) | AP4_ProtectionKeyMap
SetKeys(const AP4_ProtectionKeyMap &key_map) | AP4_ProtectionKeyMap
~AP4_ProtectionKeyMap() | AP4_ProtectionKeyMap
Generated on Thu May 13 16:37:45 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_ProtectionSchemeInfo Class Reference

AP4_ProtectionSchemeInfo Class Reference

#include <Ap4Protection.h>

List of all members.

Public Member Functions

AP4_ProtectionSchemeInfo (AP4_ContainerAtom *schi)
virtual ~AP4_ProtectionSchemeInfo ()
AP4_ContainerAtom * GetSchiAtom ()

Protected Attributes

AP4_ContainerAtom * m_SchiAtom

Detailed Description

Definition at line 197 of file Ap4Protection.h.

Constructor & Destructor Documentation

AP4_ProtectionSchemeInfo::AP4_ProtectionSchemeInfo ( AP4_ContainerAtom * schi )
virtual AP4_ProtectionSchemeInfo::~AP4_ProtectionSchemeInfo ( ) [virtual]

Member Function Documentation

AP4_ContainerAtom* AP4_ProtectionSchemeInfo::GetSchiAtom ( ) [inline]

Definition at line 205 of file Ap4Protection.h.

References m_SchiAtom.

Member Data Documentation

AP4_ContainerAtom* AP4_ProtectionSchemeInfo::m_SchiAtom [protected]

Definition at line 208 of file Ap4Protection.h.

Referenced by GetSchiAtom().

The documentation for this class was generated from the following file:
  • Ap4Protection.h
Generated on Thu May 13 16:37:45 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_ProtectionSchemeInfo Member List

This is the complete list of members for AP4_ProtectionSchemeInfo, including all inherited members.
AP4_ProtectionSchemeInfo(AP4_ContainerAtom *schi) | AP4_ProtectionSchemeInfo |
GetSchiAtom() | AP4_ProtectionSchemeInfo | [inline]
m_SchiAtom | AP4_ProtectionSchemeInfo | [protected]
~AP4_ProtectionSchemeInfo() | AP4_ProtectionSchemeInfo | [virtual]
Generated on Thu May 13 16:37:45 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_Referenceable Class Reference

AP4_Referenceable Class Reference

#include <Ap4Interfaces.h>

Inheritance diagram for AP4_Referenceable:
AP4_ByteStream AP4_RtpConstructor AP4_RtpPacket AP4_BufferedInputStream AP4_DecryptingStream AP4_EncryptingStream AP4_FileByteStream AP4_MemoryByteStream AP4_SubStream AP4_ImmediateRtpConstructor AP4_NoopRtpConstructor AP4_SampleDescRtpConstructor AP4_SampleRtpConstructor

List of all members.

Public Member Functions

virtual | ~AP4_Referenceable ()
virtual void | AddReference ()=0
virtual void | Release ()=0

Detailed Description

Definition at line 61 of file Ap4Interfaces.h.

Constructor & Destructor Documentation

virtual AP4_Referenceable::~AP4_Referenceable ( ) [inline, virtual]

Definition at line 65 of file Ap4Interfaces.h.

Member Function Documentation

virtual void AP4_Referenceable::AddReference ( ) [pure virtual]

Implemented in AP4_SubStream, AP4_MemoryByteStream, AP4_BufferedInputStream, AP4_FileByteStream, AP4_DecryptingStream, AP4_EncryptingStream, AP4_RtpPacket, and AP4_RtpConstructor.

Referenced by AP4_FileByteStream::AddReference(), and AP4_Processor::ExternalTrackData::ExternalTrackData().

virtual void AP4_Referenceable::Release ( ) [pure virtual]

Implemented in AP4_SubStream, AP4_MemoryByteStream, AP4_BufferedInputStream, AP4_FileByteStream, AP4_DecryptingStream, AP4_EncryptingStream, AP4_RtpPacket, and AP4_RtpConstructor.

Referenced by AP4_FileByteStream::Release(), AP4_BufferedInputStream::~AP4_BufferedInputStream(), and AP4_Processor::ExternalTrackData::~ExternalTrackData().

The documentation for this class was generated from the following file:
  • Ap4Interfaces.h
Generated on Thu May 13 16:37:45 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_Referenceable Member List

This is the complete list of members for AP4_Referenceable, including all inherited members.
AddReference()=0 | AP4_Referenceable | [pure virtual]
Release()=0 | AP4_Referenceable | [pure virtual]
~AP4_Referenceable() | AP4_Referenceable | [inline, virtual]
Generated on Thu May 13 16:37:45 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_RtpAtom Class Reference

AP4_RtpAtom Class Reference

#include <Ap4RtpAtom.h>

Inheritance diagram for AP4_RtpAtom:
AP4_Atom

List of all members.

Public Member Functions

const AP4_String & | GetSdpText ()
virtual AP4_Result | InspectFields (AP4_AtomInspector &inspector)
virtual AP4_Result | WriteFields (AP4_ByteStream &stream)

Static Public Member Functions

static AP4_RtpAtom * | Create (AP4_Size size, AP4_ByteStream &stream)

Detailed Description

Definition at line 48 of file Ap4RtpAtom.h.

Member Function Documentation

static AP4_RtpAtom* AP4_RtpAtom::Create | ( | AP4_Size | size,
 |  | AP4_ByteStream & | stream |
 | ) |  |  | [inline, static]

Definition at line 52 of file Ap4RtpAtom.h.

const AP4_String& AP4_RtpAtom::GetSdpText ( ) [inline]

Definition at line 57 of file Ap4RtpAtom.h.

virtual AP4_Result AP4_RtpAtom::InspectFields ( AP4_AtomInspector & inspector ) [virtual]

Reimplemented from AP4_Atom.

virtual AP4_Result AP4_RtpAtom::WriteFields ( AP4_ByteStream & stream ) [virtual]

Implements AP4_Atom.

The documentation for this class was generated from the following file:
  • Ap4RtpAtom.h
Generated on Thu May 13 16:37:45 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_RtpAtom Member List

This is the complete list of members for AP4_RtpAtom, including all inherited members.
AP4_Atom(Type type, AP4_UI32 size=AP4_ATOM_HEADER_SIZE) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64=false) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
Clone() | AP4_Atom | [virtual]
Create(AP4_Size size, AP4_ByteStream &stream) | AP4_RtpAtom | [inline, static]
Detach() | AP4_Atom | [virtual]
GetFlags() const | AP4_Atom | [inline]
GetHeaderSize() const | AP4_Atom | [virtual]
GetParent() | AP4_Atom | [inline, virtual]
GetSdpText() | AP4_RtpAtom | [inline]
GetSize() const | AP4_Atom | [inline]
GetSize32() const | AP4_Atom | [inline]
GetSize64() const | AP4_Atom | [inline]
GetType() const | AP4_Atom | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
InspectFields(AP4_AtomInspector &inspector) | AP4_RtpAtom | [virtual]
InspectHeader(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
m_Flags | AP4_Atom | [protected]
m_IsFull | AP4_Atom | [protected]
m_Parent | AP4_Atom | [protected]
m_Size32 | AP4_Atom | [protected]
m_Size64 | AP4_Atom | [protected]
m_Type | AP4_Atom | [protected]
m_Version | AP4_Atom | [protected]
ReadFullHeader(AP4_ByteStream &stream, AP4_UI32 &version, AP4_UI32 &flags) | AP4_Atom | [static]
SetFlags(AP4_UI32 flags) | AP4_Atom | [inline]
SetParent(AP4_AtomParent *parent) | AP4_Atom | [inline, virtual]
SetSize(AP4_UI64 size, bool force_64=false) | AP4_Atom |
SetSize32(AP4_UI32 size) | AP4_Atom | [inline]
SetSize64(AP4_UI64 size) | AP4_Atom | [inline]
SetType(Type type) | AP4_Atom | [inline]
Type typedef | AP4_Atom |
TypeFromString(const char *four_cc) | AP4_Atom | [static]
Write(AP4_ByteStream &stream) | AP4_Atom | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_RtpAtom | [virtual]
WriteHeader(AP4_ByteStream &stream) | AP4_Atom | [virtual]
~AP4_Atom() | AP4_Atom | [inline, virtual]
Generated on Thu May 13 16:37:45 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_RtpConstructor Class Reference

AP4_RtpConstructor Class Reference

#include <Ap4RtpHint.h>

Inheritance diagram for AP4_RtpConstructor:
AP4_Referenceable AP4_ImmediateRtpConstructor AP4_NoopRtpConstructor AP4_SampleDescRtpConstructor AP4_SampleRtpConstructor

List of all members.

Public Types

typedef AP4_UI08 | Type

Public Member Functions

AP4_RtpConstructor (Type type)
Type | GetType () const
AP4_Result | Write (AP4_ByteStream &stream)
virtual AP4_Size | GetConstructedDataSize ()=0
void | AddReference ()
void | Release ()

Protected Member Functions

virtual | ~AP4_RtpConstructor ()
virtual AP4_Result | DoWrite (AP4_ByteStream &stream)=0

Protected Attributes

AP4_Cardinal m_ReferenceCount
Type m_Type

Detailed Description

Definition at line 138 of file Ap4RtpHint.h.

Member Typedef Documentation

typedef AP4_UI08 AP4_RtpConstructor::Type

Definition at line 142 of file Ap4RtpHint.h.

Constructor & Destructor Documentation

AP4_RtpConstructor::AP4_RtpConstructor ( Type type ) [inline]

Definition at line 145 of file Ap4RtpHint.h.

virtual AP4_RtpConstructor::~AP4_RtpConstructor ( ) [inline, protected, virtual]

Definition at line 158 of file Ap4RtpHint.h.

Member Function Documentation

void AP4_RtpConstructor::AddReference ( ) [virtual]

Implements AP4_Referenceable.

virtual AP4_Result AP4_RtpConstructor::DoWrite ( AP4_ByteStream & stream ) [protected, pure virtual]

Implemented in AP4_NoopRtpConstructor, AP4_ImmediateRtpConstructor, AP4_SampleRtpConstructor, and AP4_SampleDescRtpConstructor.

virtual AP4_Size AP4_RtpConstructor::GetConstructedDataSize ( ) [pure virtual]

Implemented in AP4_NoopRtpConstructor, AP4_ImmediateRtpConstructor, AP4_SampleRtpConstructor, and AP4_SampleDescRtpConstructor.

Type AP4_RtpConstructor::GetType ( ) const [inline]

Definition at line 148 of file Ap4RtpHint.h.

References m_Type.

void AP4_RtpConstructor::Release ( ) [virtual]

Implements AP4_Referenceable.

AP4_Result AP4_RtpConstructor::Write ( AP4_ByteStream & stream )

Member Data Documentation

AP4_Cardinal AP4_RtpConstructor::m_ReferenceCount [protected]

Definition at line 162 of file Ap4RtpHint.h.

Type AP4_RtpConstructor::m_Type [protected]

Definition at line 163 of file Ap4RtpHint.h.

Referenced by GetType().

The documentation for this class was generated from the following file:
  • Ap4RtpHint.h
Generated on Thu May 13 16:37:45 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_RtpConstructor Member List

This is the complete list of members for AP4_RtpConstructor, including all inherited members.
AddReference() | AP4_RtpConstructor | [virtual]
AP4_RtpConstructor(Type type) | AP4_RtpConstructor | [inline]
DoWrite(AP4_ByteStream &stream)=0 | AP4_RtpConstructor | [protected, pure virtual]
GetConstructedDataSize()=0 | AP4_RtpConstructor | [pure virtual]
GetType() const | AP4_RtpConstructor | [inline]
m_ReferenceCount | AP4_RtpConstructor | [protected]
m_Type | AP4_RtpConstructor | [protected]
Release() | AP4_RtpConstructor | [virtual]
Type typedef | AP4_RtpConstructor |
Write(AP4_ByteStream &stream) | AP4_RtpConstructor |
~AP4_Referenceable() | AP4_Referenceable | [inline, virtual]
~AP4_RtpConstructor() | AP4_RtpConstructor | [inline, protected, virtual]
Generated on Thu May 13 16:37:45 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_RtpConstructorFactory Class Reference

AP4_RtpConstructorFactory Class Reference

#include <Ap4RtpHint.h>

List of all members.

Static Public Member Functions

static AP4_Result CreateConstructorFromStream (AP4_ByteStream &stream, AP4_RtpConstructor *&constructor)

Detailed Description

Definition at line 290 of file Ap4RtpHint.h.

Member Function Documentation

static AP4_Result AP4_RtpConstructorFactory::CreateConstructorFromStream | ( | AP4_ByteStream & | stream,
 |  | AP4_RtpConstructor *& | constructor |
 | ) |  |  | [static]
The documentation for this class was generated from the following file:
  • Ap4RtpHint.h
Generated on Thu May 13 16:37:45 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_RtpConstructorFactory Member List

This is the complete list of members for AP4_RtpConstructorFactory, including all inherited members.
CreateConstructorFromStream(AP4_ByteStream &stream, AP4_RtpConstructor *&constructor) AP4_RtpConstructorFactory [static]
Generated on Thu May 13 16:37:45 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_RtpHintSampleEntry Class Reference

AP4_RtpHintSampleEntry Class Reference

#include <Ap4SampleEntry.h>

Inheritance diagram for AP4_RtpHintSampleEntry:
AP4_SampleEntry AP4_ContainerAtom AP4_Atom AP4_AtomParent

List of all members.

Public Member Functions

AP4_RtpHintSampleEntry (AP4_UI16 hint_track_version, AP4_UI16 highest_compatible_version, AP4_UI32 max_packet_size, AP4_UI32 timescale)
AP4_RtpHintSampleEntry (AP4_Size size, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory)

Protected Member Functions

virtual AP4_Size | GetFieldsSize ()
virtual AP4_Result | ReadFields (AP4_ByteStream &stream)
virtual AP4_Result | WriteFields (AP4_ByteStream &stream)
virtual AP4_Result | InspectFields (AP4_AtomInspector &inspector)

Protected Attributes

AP4_UI16 m_HintTrackVersion
AP4_UI16 m_HighestCompatibleVersion
AP4_UI32 m_MaxPacketSize

Detailed Description

Definition at line 353 of file Ap4SampleEntry.h.

Constructor & Destructor Documentation

AP4_RtpHintSampleEntry::AP4_RtpHintSampleEntry | ( | AP4_UI16 | hint_track_version,
 |  | AP4_UI16 | highest_compatible_version,
 |  | AP4_UI32 | max_packet_size,
 |  | AP4_UI32 | timescale
 | ) |  |
AP4_RtpHintSampleEntry::AP4_RtpHintSampleEntry | ( | AP4_Size | size,
 |  | AP4_ByteStream & | stream,
 |  | AP4_AtomFactory & | atom_factory
 | ) |  |

Member Function Documentation

virtual AP4_Size AP4_RtpHintSampleEntry::GetFieldsSize ( ) [protected, virtual]

Reimplemented from AP4_SampleEntry.

virtual AP4_Result AP4_RtpHintSampleEntry::InspectFields ( AP4_AtomInspector & inspector ) [protected, virtual]

Reimplemented from AP4_SampleEntry.

virtual AP4_Result AP4_RtpHintSampleEntry::ReadFields ( AP4_ByteStream & stream ) [protected, virtual]

Reimplemented from AP4_SampleEntry.

virtual AP4_Result AP4_RtpHintSampleEntry::WriteFields ( AP4_ByteStream & stream ) [protected, virtual]

Reimplemented from AP4_SampleEntry.

Member Data Documentation

AP4_UI16 AP4_RtpHintSampleEntry::m_HighestCompatibleVersion [protected]

Definition at line 374 of file Ap4SampleEntry.h.

AP4_UI16 AP4_RtpHintSampleEntry::m_HintTrackVersion [protected]

Definition at line 373 of file Ap4SampleEntry.h.

AP4_UI32 AP4_RtpHintSampleEntry::m_MaxPacketSize [protected]

Definition at line 375 of file Ap4SampleEntry.h.

The documentation for this class was generated from the following file:
  • Ap4SampleEntry.h
Generated on Thu May 13 16:37:46 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_RtpHintSampleEntry Member List

This is the complete list of members for AP4_RtpHintSampleEntry, including all inherited members.
AddChild(AP4_Atom *child, int position=-1) | AP4_AtomParent | [virtual]
AP4_Atom(Type type, AP4_UI32 size=AP4_ATOM_HEADER_SIZE) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64=false) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_ContainerAtom(Type type) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI32 version, AP4_UI32 flags) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_ContainerAtom | [protected]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_ContainerAtom | [protected]
AP4_RtpHintSampleEntry(AP4_UI16 hint_track_version, AP4_UI16 highest_compatible_version, AP4_UI32 max_packet_size, AP4_UI32 timescale) | AP4_RtpHintSampleEntry |
AP4_RtpHintSampleEntry(AP4_Size size, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_RtpHintSampleEntry |
AP4_SampleEntry(AP4_Atom::Type format, AP4_UI16 data_ref_index=1) | AP4_SampleEntry |
AP4_SampleEntry(AP4_Atom::Type format, AP4_Size size, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_SampleEntry |
AP4_SampleEntry(AP4_Atom::Type format, AP4_Size size) | AP4_SampleEntry | [protected]
Clone() | AP4_ContainerAtom | [virtual]
Create(Type type, AP4_UI64 size, bool is_full, bool force_64, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_ContainerAtom | [static]
DeleteChild(AP4_Atom::Type type, AP4_Ordinal index=0) | AP4_AtomParent | [virtual]
Detach() | AP4_Atom | [virtual]
FindChild(const char *path, bool auto_create=false, bool auto_create_full=false) | AP4_AtomParent | [virtual]
GetChild(AP4_Atom::Type type, AP4_Ordinal index=0) const | AP4_AtomParent | [virtual]
GetChild(const AP4_UI08 *uuid, AP4_Ordinal index=0) const | AP4_AtomParent | [virtual]
GetChildren() | AP4_ContainerAtom | [inline]
GetDataReferenceIndex() | AP4_SampleEntry | [inline]
GetFieldsSize() | AP4_RtpHintSampleEntry | [protected, virtual]
GetFlags() const | AP4_Atom | [inline]
GetHeaderSize() const | AP4_Atom | [virtual]
GetParent() | AP4_Atom | [inline, virtual]
GetSize() const | AP4_Atom | [inline]
GetSize32() const | AP4_Atom | [inline]
GetSize64() const | AP4_Atom | [inline]
GetType() const | AP4_Atom | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_SampleEntry | [virtual]
InspectChildren(AP4_AtomInspector &inspector) | AP4_ContainerAtom | [virtual]
InspectFields(AP4_AtomInspector &inspector) | AP4_RtpHintSampleEntry | [protected, virtual]
InspectHeader(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
m_Children | AP4_AtomParent | [protected]
m_DataReferenceIndex | AP4_SampleEntry | [protected]
m_Flags | AP4_Atom | [protected]
m_HighestCompatibleVersion | AP4_RtpHintSampleEntry | [protected]
m_HintTrackVersion | AP4_RtpHintSampleEntry | [protected]
m_IsFull | AP4_Atom | [protected]
m_MaxPacketSize | AP4_RtpHintSampleEntry | [protected]
m_Parent | AP4_Atom | [protected]
m_Reserved1 | AP4_SampleEntry | [protected]
m_Size32 | AP4_Atom | [protected]
m_Size64 | AP4_Atom | [protected]
m_Type | AP4_Atom | [protected]
m_Version | AP4_Atom | [protected]
OnChildAdded(AP4_Atom *child) | AP4_ContainerAtom | [virtual]
OnChildChanged(AP4_Atom *child) | AP4_SampleEntry | [virtual]
OnChildRemoved(AP4_Atom *child) | AP4_ContainerAtom | [virtual]
Read(AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_SampleEntry | [protected, virtual]
ReadChildren(AP4_AtomFactory &atom_factory, AP4_ByteStream &stream, AP4_UI64 size) | AP4_ContainerAtom | [protected]
ReadFields(AP4_ByteStream &stream) | AP4_RtpHintSampleEntry | [protected, virtual]
ReadFullHeader(AP4_ByteStream &stream, AP4_UI32 &version, AP4_UI32 &flags) | AP4_Atom | [static]
RemoveChild(AP4_Atom *child) | AP4_AtomParent | [virtual]
SetFlags(AP4_UI32 flags) | AP4_Atom | [inline]
SetParent(AP4_AtomParent *parent) | AP4_Atom | [inline, virtual]
SetSize(AP4_UI64 size, bool force_64=false) | AP4_Atom |
SetSize32(AP4_UI32 size) | AP4_Atom | [inline]
SetSize64(AP4_UI64 size) | AP4_Atom | [inline]
SetType(Type type) | AP4_Atom | [inline]
ToSampleDescription() | AP4_SampleEntry | [virtual]
Type typedef | AP4_Atom |
TypeFromString(const char *four_cc) | AP4_Atom | [static]
Write(AP4_ByteStream &stream) | AP4_SampleEntry | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_RtpHintSampleEntry | [protected, virtual]
WriteHeader(AP4_ByteStream &stream) | AP4_Atom | [virtual]
~AP4_Atom() | AP4_Atom | [inline, virtual]
~AP4_AtomParent() | AP4_AtomParent | [virtual]
~AP4_SampleEntry() | AP4_SampleEntry | [inline, virtual]
Generated on Thu May 13 16:37:46 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_RtpPacket Class Reference

AP4_RtpPacket Class Reference

#include <Ap4RtpHint.h>

Inheritance diagram for AP4_RtpPacket:
AP4_Referenceable

List of all members.

Public Member Functions

AP4_RtpPacket (AP4_ByteStream &stream)
AP4_RtpPacket (int relative_time, bool p_bit, bool x_bit, bool m_bit, AP4_UI08 payload_type, AP4_UI16 sequence_seed, int time_stamp_offset=0, bool bframe_flag=false, bool repeat_flag=false)
~AP4_RtpPacket ()
AP4_Result | Write (AP4_ByteStream &stream)
AP4_Result | AddConstructor (AP4_RtpConstructor *constructor)
AP4_Size GetSize ()
AP4_Size GetConstructedDataSize ()
void | AddReference ()
void | Release ()
int | GetRelativeTime () const
bool | GetPBit () const
bool | GetXBit () const
bool | GetMBit () const
AP4_UI08 | GetPayloadType () const
AP4_UI16 | GetSequenceSeed () const
int | GetTimeStampOffset () const
bool | GetBFrameFlag () const
bool | GetRepeatFlag () const
AP4_List< AP4_RtpConstructor > & GetConstructors ()

Detailed Description

Definition at line 80 of file Ap4RtpHint.h.

Constructor & Destructor Documentation

AP4_RtpPacket::AP4_RtpPacket ( AP4_ByteStream & stream )
AP4_RtpPacket::AP4_RtpPacket | ( | int | relative_time,
 |  | bool | p_bit,
 |  | bool | x_bit,
 |  | bool | m_bit,
 |  | AP4_UI08 | payload_type,
 |  | AP4_UI16 | sequence_seed,
 |  | int | time_stamp_offset = 0,
 |  | bool | bframe_flag = false,
 |  | bool | repeat_flag = false
 | ) |  |
AP4_RtpPacket::~AP4_RtpPacket ( )

Member Function Documentation

AP4_Result AP4_RtpPacket::AddConstructor ( AP4_RtpConstructor * constructor )
void AP4_RtpPacket::AddReference ( ) [virtual]

Implements AP4_Referenceable.

bool AP4_RtpPacket::GetBFrameFlag ( ) const [inline]

Definition at line 114 of file Ap4RtpHint.h.

AP4_Size AP4_RtpPacket::GetConstructedDataSize ( )
AP4_List<AP4_RtpConstructor>& AP4_RtpPacket::GetConstructors ( ) [inline]

Definition at line 116 of file Ap4RtpHint.h.

bool AP4_RtpPacket::GetMBit ( ) const [inline]

Definition at line 110 of file Ap4RtpHint.h.

AP4_UI08 AP4_RtpPacket::GetPayloadType ( ) const [inline]

Definition at line 111 of file Ap4RtpHint.h.

bool AP4_RtpPacket::GetPBit ( ) const [inline]

Definition at line 108 of file Ap4RtpHint.h.

int AP4_RtpPacket::GetRelativeTime ( ) const [inline]

Definition at line 107 of file Ap4RtpHint.h.

bool AP4_RtpPacket::GetRepeatFlag ( ) const [inline]

Definition at line 115 of file Ap4RtpHint.h.

AP4_UI16 AP4_RtpPacket::GetSequenceSeed ( ) const [inline]

Definition at line 112 of file Ap4RtpHint.h.

AP4_Size AP4_RtpPacket::GetSize ( )
int AP4_RtpPacket::GetTimeStampOffset ( ) const [inline]

Definition at line 113 of file Ap4RtpHint.h.

bool AP4_RtpPacket::GetXBit ( ) const [inline]

Definition at line 109 of file Ap4RtpHint.h.

void AP4_RtpPacket::Release ( ) [virtual]

Implements AP4_Referenceable.

AP4_Result AP4_RtpPacket::Write ( AP4_ByteStream & stream )
The documentation for this class was generated from the following file:
  • Ap4RtpHint.h
Generated on Thu May 13 16:37:46 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_RtpPacket Member List

This is the complete list of members for AP4_RtpPacket, including all inherited members.
AddConstructor(AP4_RtpConstructor *constructor) | AP4_RtpPacket |
AddReference() | AP4_RtpPacket | [virtual]
AP4_RtpPacket(AP4_ByteStream &stream) | AP4_RtpPacket |
AP4_RtpPacket(int relative_time, bool p_bit, bool x_bit, bool m_bit, AP4_UI08 payload_type, AP4_UI16 sequence_seed, int time_stamp_offset=0, bool bframe_flag=false, bool repeat_flag=false) | AP4_RtpPacket |
GetBFrameFlag() const | AP4_RtpPacket | [inline]
GetConstructedDataSize() | AP4_RtpPacket |
GetConstructors() | AP4_RtpPacket | [inline]
GetMBit() const | AP4_RtpPacket | [inline]
GetPayloadType() const | AP4_RtpPacket | [inline]
GetPBit() const | AP4_RtpPacket | [inline]
GetRelativeTime() const | AP4_RtpPacket | [inline]
GetRepeatFlag() const | AP4_RtpPacket | [inline]
GetSequenceSeed() const | AP4_RtpPacket | [inline]
GetSize() | AP4_RtpPacket |
GetTimeStampOffset() const | AP4_RtpPacket | [inline]
GetXBit() const | AP4_RtpPacket | [inline]
Release() | AP4_RtpPacket | [virtual]
Write(AP4_ByteStream &stream) | AP4_RtpPacket |
~AP4_Referenceable() | AP4_Referenceable | [inline, virtual]
~AP4_RtpPacket() | AP4_RtpPacket |
Generated on Thu May 13 16:37:46 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_RtpSampleData Class Reference

AP4_RtpSampleData Class Reference

#include <Ap4RtpHint.h>

List of all members.

Public Member Functions

AP4_RtpSampleData (AP4_ByteStream &stream, AP4_UI32 size)
AP4_RtpSampleData ()
virtual | ~AP4_RtpSampleData ()
virtual AP4_Result | AddPacket (AP4_RtpPacket *packet)
virtual AP4_Size | GetSize ()
virtual AP4_ByteStream * | ToByteStream ()
AP4_List< AP4_RtpPacket > & GetPackets ()
const AP4_DataBuffer & | GetExtraData () const

Protected Attributes

AP4_List< AP4_RtpPacket > m_Packets
AP4_DataBuffer m_ExtraData

Detailed Description

Definition at line 50 of file Ap4RtpHint.h.

Constructor & Destructor Documentation

AP4_RtpSampleData::AP4_RtpSampleData | ( | AP4_ByteStream & | stream,
 |  | AP4_UI32 | size
 | ) |  |
AP4_RtpSampleData::AP4_RtpSampleData ( ) [inline]

Definition at line 55 of file Ap4RtpHint.h.

virtual AP4_RtpSampleData::~AP4_RtpSampleData ( ) [virtual]

Member Function Documentation

virtual AP4_Result AP4_RtpSampleData::AddPacket ( AP4_RtpPacket * packet ) [virtual]
const AP4_DataBuffer& AP4_RtpSampleData::GetExtraData ( ) const [inline]

Definition at line 67 of file Ap4RtpHint.h.

References m_ExtraData.

AP4_List<AP4_RtpPacket>& AP4_RtpSampleData::GetPackets ( ) [inline]

Definition at line 64 of file Ap4RtpHint.h.

References m_Packets.

virtual AP4_Size AP4_RtpSampleData::GetSize ( ) [virtual]
virtual AP4_ByteStream* AP4_RtpSampleData::ToByteStream ( ) [virtual]

Member Data Documentation

AP4_DataBuffer AP4_RtpSampleData::m_ExtraData [protected]

Definition at line 74 of file Ap4RtpHint.h.

Referenced by GetExtraData().

AP4_List<AP4_RtpPacket> AP4_RtpSampleData::m_Packets [protected]

Definition at line 73 of file Ap4RtpHint.h.

Referenced by GetPackets().

The documentation for this class was generated from the following file:
  • Ap4RtpHint.h
Generated on Thu May 13 16:37:46 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_RtpSampleData Member List

This is the complete list of members for AP4_RtpSampleData, including all inherited members.
AddPacket(AP4_RtpPacket *packet) | AP4_RtpSampleData | [virtual]
AP4_RtpSampleData(AP4_ByteStream &stream, AP4_UI32 size) | AP4_RtpSampleData |
AP4_RtpSampleData() | AP4_RtpSampleData | [inline]
GetExtraData() const | AP4_RtpSampleData | [inline]
GetPackets() | AP4_RtpSampleData | [inline]
GetSize() | AP4_RtpSampleData | [virtual]
m_ExtraData | AP4_RtpSampleData | [protected]
m_Packets | AP4_RtpSampleData | [protected]
ToByteStream() | AP4_RtpSampleData | [virtual]
~AP4_RtpSampleData() | AP4_RtpSampleData | [virtual]
Generated on Thu May 13 16:37:46 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_Sample Class Reference

AP4_Sample Class Reference

#include <Ap4Sample.h>

List of all members.

Public Member Functions

AP4_Sample ()
Default constructor.
AP4_Sample (const AP4_Sample &other)
Copy constructor.
AP4_Sample (AP4_ByteStream &data_stream, AP4_Position offset, AP4_Size size, AP4_UI32 duration, AP4_Ordinal description_index, AP4_UI64 dts, AP4_UI32 cts_delta, bool sync_flag)
Construct an AP4_Sample referencing a data stream.
~AP4_Sample ()
AP4_Sample & | operator= (const AP4_Sample &other)
AP4_Result | ReadData (AP4_DataBuffer &data)
AP4_Result | ReadData (AP4_DataBuffer &data, AP4_Size size, AP4_Size offset=0)
AP4_ByteStream * GetDataStream ()
void | SetDataStream (AP4_ByteStream &stream)
AP4_Position | GetOffset () const
void | SetOffset (AP4_Position offset)
AP4_Size GetSize ()
void | SetSize (AP4_Size size)
AP4_Ordinal | GetDescriptionIndex () const
void | SetDescriptionIndex (AP4_Ordinal index)
AP4_UI64 | GetDts () const
Get the DTS (Decoding Time Stamp) of the sample in the timescale of the media.
void | SetDts (AP4_UI64 dts)
Set the DTS (Decoding Time Stamp) of the sample in the timescale of the media.
AP4_UI64 | GetCts () const
Get the CTS (Composition Time Stamp) of the sample in the timescale of the media.
void | SetCts (AP4_UI64 cts)
Set the CTS (Composition Time Stamp) of the sample in the timescale of the media.
AP4_UI32 | GetCtsDelta () const
Get the CTS Delta (difference between the CTS (Composition Time Stamp) and DTS (Decoding Time Stamp) of the sample in the timescale of the media.
void | SetCtsDelta (AP4_UI32 delta)
Set the CTS Delta (difference between the CTS (Composition Time Stamp) and DTS (Decoding Time Stamp) of the sample in the timescale of the media.
AP4_UI32 | GetDuration () const
Get the duration of the sample in the timescale of the media.
void | SetDuration (AP4_UI32 duration)
Set the duration of the sample in the timescale of the media.
bool | IsSync () const
Return whether the sample is a sync (random-access point) sample or not.
void | SetSync (bool is_sync)
Set whether the sample is a sync (random-access point) sample or not.
void | Reset ()
Resets the sample: will also release any data stream reference.

Protected Attributes

AP4_ByteStream * m_DataStream
AP4_Position m_Offset
AP4_Size m_Size
AP4_UI32 m_Duration
AP4_Ordinal m_DescriptionIndex
AP4_UI64 m_Dts
AP4_SI32 m_CtsDelta
bool | m_IsSync

Detailed Description

Definition at line 46 of file Ap4Sample.h.

Constructor & Destructor Documentation

AP4_Sample::AP4_Sample ( )

Default constructor.

AP4_Sample::AP4_Sample ( const AP4_Sample & other )

Copy constructor.

AP4_Sample::AP4_Sample | ( | AP4_ByteStream & | data_stream,
 |  | AP4_Position | offset,
 |  | AP4_Size | size,
 |  | AP4_UI32 | duration,
 |  | AP4_Ordinal | description_index,
 |  | AP4_UI64 | dts,
 |  | AP4_UI32 | cts_delta,
 |  | bool | sync_flag
 | ) |  |

Construct an AP4_Sample referencing a data stream.

Parameters:
data_stream | The byte stream that contains the sample data. The sample object added to the track will keep a reference to that byte stream
offset | Position of the first byte of sample data within the stream
size | Size in bytes of the sample data
description_index | Index of the sample description that applies to this sample
dts | Decoding timestamp of the sample
cts_delta | Difference between the CTS (composition/display timestamp) and the DTS (decoding timestamp), in the timescale of the media.
sync_flag | Boolean flag indicating whether this is a sync sample or not
AP4_Sample::~AP4_Sample ( )

Member Function Documentation

AP4_UI64 AP4_Sample::GetCts ( ) const [inline]

Get the CTS (Composition Time Stamp) of the sample in the timescale of the media.

Definition at line 118 of file Ap4Sample.h.

References m_CtsDelta, and m_Dts.

AP4_UI32 AP4_Sample::GetCtsDelta ( ) const [inline]

Get the CTS Delta (difference between the CTS (Composition Time Stamp) and DTS (Decoding Time Stamp) of the sample in the timescale of the media.

Definition at line 129 of file Ap4Sample.h.

References m_CtsDelta.

AP4_ByteStream* AP4_Sample::GetDataStream ( )
AP4_Ordinal AP4_Sample::GetDescriptionIndex ( ) const [inline]

Definition at line 102 of file Ap4Sample.h.

References m_DescriptionIndex.

AP4_UI64 AP4_Sample::GetDts ( ) const [inline]

Get the DTS (Decoding Time Stamp) of the sample in the timescale of the media.

Definition at line 108 of file Ap4Sample.h.

References m_Dts.

AP4_UI32 AP4_Sample::GetDuration ( ) const [inline]

Get the duration of the sample in the timescale of the media.

Definition at line 140 of file Ap4Sample.h.

References m_Duration.

AP4_Position AP4_Sample::GetOffset ( ) const [inline]

Definition at line 98 of file Ap4Sample.h.

References m_Offset.

AP4_Size AP4_Sample::GetSize ( ) [inline]

Definition at line 100 of file Ap4Sample.h.

References m_Size.

Referenced by AP4_SampleDecrypter::GetDecryptedSampleSize(), AP4_Processor::FragmentHandler::GetProcessedSampleSize(), and AP4_Processor::TrackHandler::GetProcessedSampleSize().

bool AP4_Sample::IsSync ( ) const [inline]

Return whether the sample is a sync (random-access point) sample or not.

Definition at line 150 of file Ap4Sample.h.

References m_IsSync.

AP4_Sample& AP4_Sample::operator= ( const AP4_Sample & other )
AP4_Result AP4_Sample::ReadData | ( | AP4_DataBuffer & | data,
 |  | AP4_Size | size,
 |  | AP4_Size | offset = 0
 | ) |  |
AP4_Result AP4_Sample::ReadData ( AP4_DataBuffer & data )
void AP4_Sample::Reset ( )

Resets the sample: will also release any data stream reference.

void AP4_Sample::SetCts ( AP4_UI64 cts ) [inline]

Set the CTS (Composition Time Stamp) of the sample in the timescale of the media.

Definition at line 123 of file Ap4Sample.h.

References m_CtsDelta, and m_Dts.

void AP4_Sample::SetCtsDelta ( AP4_UI32 delta ) [inline]

Set the CTS Delta (difference between the CTS (Composition Time Stamp) and DTS (Decoding Time Stamp) of the sample in the timescale of the media.

Definition at line 135 of file Ap4Sample.h.

References m_CtsDelta.

void AP4_Sample::SetDataStream ( AP4_ByteStream & stream )
void AP4_Sample::SetDescriptionIndex ( AP4_Ordinal index ) [inline]

Definition at line 103 of file Ap4Sample.h.

References m_DescriptionIndex.

void AP4_Sample::SetDts ( AP4_UI64 dts ) [inline]

Set the DTS (Decoding Time Stamp) of the sample in the timescale of the media.

Definition at line 113 of file Ap4Sample.h.

References m_Dts.

void AP4_Sample::SetDuration ( AP4_UI32 duration ) [inline]

Set the duration of the sample in the timescale of the media.

Definition at line 145 of file Ap4Sample.h.

References m_Duration.

void AP4_Sample::SetOffset ( AP4_Position offset ) [inline]

Definition at line 99 of file Ap4Sample.h.

References m_Offset.

void AP4_Sample::SetSize ( AP4_Size size ) [inline]

Definition at line 101 of file Ap4Sample.h.

References m_Size.

void AP4_Sample::SetSync ( bool is_sync ) [inline]

Set whether the sample is a sync (random-access point) sample or not.

Definition at line 155 of file Ap4Sample.h.

References m_IsSync.

Member Data Documentation

AP4_SI32 AP4_Sample::m_CtsDelta [protected]

Definition at line 169 of file Ap4Sample.h.

Referenced by GetCts(), GetCtsDelta(), SetCts(), and SetCtsDelta().

AP4_ByteStream* AP4_Sample::m_DataStream [protected]

Definition at line 163 of file Ap4Sample.h.

AP4_Ordinal AP4_Sample::m_DescriptionIndex [protected]

Definition at line 167 of file Ap4Sample.h.

Referenced by GetDescriptionIndex(), and SetDescriptionIndex().

AP4_UI64 AP4_Sample::m_Dts [protected]

Definition at line 168 of file Ap4Sample.h.

Referenced by GetCts(), GetDts(), SetCts(), and SetDts().

AP4_UI32 AP4_Sample::m_Duration [protected]

Definition at line 166 of file Ap4Sample.h.

Referenced by GetDuration(), and SetDuration().

bool AP4_Sample::m_IsSync [protected]

Definition at line 170 of file Ap4Sample.h.

Referenced by IsSync(), and SetSync().

AP4_Position AP4_Sample::m_Offset [protected]

Definition at line 164 of file Ap4Sample.h.

Referenced by GetOffset(), and SetOffset().

AP4_Size AP4_Sample::m_Size [protected]

Definition at line 165 of file Ap4Sample.h.

Referenced by GetSize(), and SetSize().

The documentation for this class was generated from the following file:
  • Ap4Sample.h
Generated on Thu May 13 16:37:46 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_Sample Member List

This is the complete list of members for AP4_Sample, including all inherited members.
AP4_Sample() | AP4_Sample |
AP4_Sample(const AP4_Sample &other) | AP4_Sample |
AP4_Sample(AP4_ByteStream &data_stream, AP4_Position offset, AP4_Size size, AP4_UI32 duration, AP4_Ordinal description_index, AP4_UI64 dts, AP4_UI32 cts_delta, bool sync_flag) | AP4_Sample |
GetCts() const | AP4_Sample | [inline]
GetCtsDelta() const | AP4_Sample | [inline]
GetDataStream() | AP4_Sample |
GetDescriptionIndex() const | AP4_Sample | [inline]
GetDts() const | AP4_Sample | [inline]
GetDuration() const | AP4_Sample | [inline]
GetOffset() const | AP4_Sample | [inline]
GetSize() | AP4_Sample | [inline]
IsSync() const | AP4_Sample | [inline]
m_CtsDelta | AP4_Sample | [protected]
m_DataStream | AP4_Sample | [protected]
m_DescriptionIndex | AP4_Sample | [protected]
m_Dts | AP4_Sample | [protected]
m_Duration | AP4_Sample | [protected]
m_IsSync | AP4_Sample | [protected]
m_Offset | AP4_Sample | [protected]
m_Size | AP4_Sample | [protected]
operator=(const AP4_Sample &other) | AP4_Sample |
ReadData(AP4_DataBuffer &data) | AP4_Sample |
ReadData(AP4_DataBuffer &data, AP4_Size size, AP4_Size offset=0) | AP4_Sample |
Reset() | AP4_Sample |
SetCts(AP4_UI64 cts) | AP4_Sample | [inline]
SetCtsDelta(AP4_UI32 delta) | AP4_Sample | [inline]
SetDataStream(AP4_ByteStream &stream) | AP4_Sample |
SetDescriptionIndex(AP4_Ordinal index) | AP4_Sample | [inline]
SetDts(AP4_UI64 dts) | AP4_Sample | [inline]
SetDuration(AP4_UI32 duration) | AP4_Sample | [inline]
SetOffset(AP4_Position offset) | AP4_Sample | [inline]
SetSize(AP4_Size size) | AP4_Sample | [inline]
SetSync(bool is_sync) | AP4_Sample | [inline]
~AP4_Sample() | AP4_Sample |
Generated on Thu May 13 16:37:46 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_SampleDecrypter Class Reference

AP4_SampleDecrypter Class Reference

#include <Ap4Protection.h>

Inheritance diagram for AP4_SampleDecrypter:
AP4_IsmaCipher AP4_OmaDcfSampleDecrypter AP4_PiffSampleDecrypter AP4_OmaDcfCbcSampleDecrypter AP4_OmaDcfCtrSampleDecrypter AP4_PiffCbcSampleDecrypter AP4_PiffCtrSampleDecrypter AP4_PiffNullSampleDecrypter AP4_PiffAvcCbcSampleDecrypter AP4_PiffAvcCtrSampleDecrypter

List of all members.

Public Member Functions

virtual | ~AP4_SampleDecrypter ()
virtual AP4_Size | GetDecryptedSampleSize (AP4_Sample &sample)
virtual AP4_Result | SetSampleIndex (AP4_Ordinal)
virtual AP4_Result | DecryptSampleData (AP4_DataBuffer &data_in, AP4_DataBuffer &data_out, const AP4_UI08 *iv=NULL)=0

Static Public Member Functions

static AP4_SampleDecrypter * | Create (AP4_ProtectedSampleDescription *sample_description, const AP4_UI08 *key, AP4_Size key_size, AP4_BlockCipherFactory *block_cipher_factory=NULL)
Create a sample decrypter given a protected sample description.
static AP4_SampleDecrypter * | Create (AP4_ProtectedSampleDescription *sample_description, AP4_ContainerAtom *traf, const AP4_UI08 *key, AP4_Size key_size, AP4_BlockCipherFactory *block_cipher_factory=NULL)
Create a fragment sample decrypter given a protected sample description and a track fragment.

Detailed Description

Definition at line 314 of file Ap4Protection.h.

Constructor & Destructor Documentation

virtual AP4_SampleDecrypter::~AP4_SampleDecrypter ( ) [inline, virtual]

Definition at line 335 of file Ap4Protection.h.

Member Function Documentation

static AP4_SampleDecrypter* AP4_SampleDecrypter::Create | ( | AP4_ProtectedSampleDescription * | sample_description,
 |  | AP4_ContainerAtom * | traf,
 |  | const AP4_UI08 * | key,
 |  | AP4_Size | key_size,
 |  | AP4_BlockCipherFactory * | block_cipher_factory = NULL |
 | ) |  |  | [static]

Create a fragment sample decrypter given a protected sample description and a track fragment.

static AP4_SampleDecrypter* AP4_SampleDecrypter::Create | ( | AP4_ProtectedSampleDescription * | sample_description,
 |  | const AP4_UI08 * | key,
 |  | AP4_Size | key_size,
 |  | AP4_BlockCipherFactory * | block_cipher_factory = NULL |
 | ) |  |  | [static]

Create a sample decrypter given a protected sample description.

virtual AP4_Result AP4_SampleDecrypter::DecryptSampleData | ( | AP4_DataBuffer & | data_in,
 |  | AP4_DataBuffer & | data_out,
 |  | const AP4_UI08 * | iv = NULL |
 | ) |  |  | [pure virtual]

Implemented in AP4_IsmaCipher, AP4_OmaDcfCtrSampleDecrypter, AP4_OmaDcfCbcSampleDecrypter, AP4_PiffNullSampleDecrypter, AP4_PiffCtrSampleDecrypter, AP4_PiffAvcCtrSampleDecrypter, AP4_PiffCbcSampleDecrypter, and AP4_PiffAvcCbcSampleDecrypter.

virtual AP4_Size AP4_SampleDecrypter::GetDecryptedSampleSize ( AP4_Sample & sample ) [inline, virtual]

Reimplemented in AP4_IsmaCipher, AP4_OmaDcfCtrSampleDecrypter, and AP4_OmaDcfCbcSampleDecrypter.

Definition at line 338 of file Ap4Protection.h.

References AP4_Sample::GetSize().

virtual AP4_Result AP4_SampleDecrypter::SetSampleIndex ( AP4_Ordinal ) [inline, virtual]

Reimplemented in AP4_PiffSampleDecrypter.

Definition at line 339 of file Ap4Protection.h.

References AP4_SUCCESS.

The documentation for this class was generated from the following file:
  • Ap4Protection.h
Generated on Thu May 13 16:37:46 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_SampleDecrypter Member List

This is the complete list of members for AP4_SampleDecrypter, including all inherited members.
Create(AP4_ProtectedSampleDescription *sample_description, const AP4_UI08 *key, AP4_Size key_size, AP4_BlockCipherFactory *block_cipher_factory=NULL) | AP4_SampleDecrypter | [static]
Create(AP4_ProtectedSampleDescription *sample_description, AP4_ContainerAtom *traf, const AP4_UI08 *key, AP4_Size key_size, AP4_BlockCipherFactory *block_cipher_factory=NULL) | AP4_SampleDecrypter | [static]
DecryptSampleData(AP4_DataBuffer &data_in, AP4_DataBuffer &data_out, const AP4_UI08 *iv=NULL)=0 | AP4_SampleDecrypter | [pure virtual]
GetDecryptedSampleSize(AP4_Sample &sample) | AP4_SampleDecrypter | [inline, virtual]
SetSampleIndex(AP4_Ordinal) | AP4_SampleDecrypter | [inline, virtual]
~AP4_SampleDecrypter() | AP4_SampleDecrypter | [inline, virtual]
Generated on Thu May 13 16:37:46 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_SampleDescription Class Reference

AP4_SampleDescription Class Reference

#include <Ap4SampleDescription.h>

Inheritance diagram for AP4_SampleDescription:
AP4_AvcSampleDescription AP4_GenericAudioSampleDescription AP4_GenericVideoSampleDescription AP4_MpegSampleDescription AP4_ProtectedSampleDescription AP4_UnknownSampleDescription AP4_MpegAudioSampleDescription AP4_MpegSystemSampleDescription AP4_MpegVideoSampleDescription

List of all members.

Public Types

enum Type {
TYPE_UNKNOWN = 0x00,
TYPE_MPEG = 0x01,
TYPE_PROTECTED = 0x02,
TYPE_AVC = 0x03
}

Public Member Functions

AP4_SampleDescription (Type type, AP4_UI32 format, AP4_AtomParent *details)
virtual | ~AP4_SampleDescription ()
virtual AP4_SampleDescription * | Clone (AP4_Result *result=NULL)
Type | GetType () const
AP4_UI32 | GetFormat () const
AP4_AtomParent & GetDetails ()
virtual AP4_Atom * | ToAtom () const

Protected Attributes

Type m_Type
AP4_UI32 m_Format
AP4_AtomParent m_Details

Detailed Description

Definition at line 89 of file Ap4SampleDescription.h.

Member Enumeration Documentation

enum AP4_SampleDescription::Type
Enumerator:
TYPE_UNKNOWN
TYPE_MPEG
TYPE_PROTECTED
TYPE_AVC

Definition at line 95 of file Ap4SampleDescription.h.

Constructor & Destructor Documentation

AP4_SampleDescription::AP4_SampleDescription | ( | Type | type,
 |  | AP4_UI32 | format,
 |  | AP4_AtomParent * | details
 | ) |  |
virtual AP4_SampleDescription::~AP4_SampleDescription ( ) [inline, virtual]

Definition at line 106 of file Ap4SampleDescription.h.

Member Function Documentation

virtual AP4_SampleDescription* AP4_SampleDescription::Clone ( AP4_Result * result = NULL ) [virtual]

Reimplemented in AP4_UnknownSampleDescription.

AP4_AtomParent& AP4_SampleDescription::GetDetails ( ) [inline]

Definition at line 112 of file Ap4SampleDescription.h.

References m_Details.

AP4_UI32 AP4_SampleDescription::GetFormat ( ) const [inline]

Definition at line 111 of file Ap4SampleDescription.h.

References m_Format.

Type AP4_SampleDescription::GetType ( ) const [inline]

Definition at line 110 of file Ap4SampleDescription.h.

References m_Type.

virtual AP4_Atom* AP4_SampleDescription::ToAtom ( ) const [virtual]

Reimplemented in AP4_ProtectedSampleDescription, AP4_UnknownSampleDescription, AP4_AvcSampleDescription, AP4_MpegSystemSampleDescription, AP4_MpegAudioSampleDescription, and AP4_MpegVideoSampleDescription.

Member Data Documentation

AP4_AtomParent AP4_SampleDescription::m_Details [protected]

Definition at line 120 of file Ap4SampleDescription.h.

Referenced by GetDetails().

AP4_UI32 AP4_SampleDescription::m_Format [protected]

Reimplemented in AP4_MpegSampleDescription.

Definition at line 119 of file Ap4SampleDescription.h.

Referenced by GetFormat().

Type AP4_SampleDescription::m_Type [protected]

Definition at line 118 of file Ap4SampleDescription.h.

Referenced by GetType().

The documentation for this class was generated from the following file:
  • Ap4SampleDescription.h
Generated on Thu May 13 16:37:46 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_SampleDescription Member List

This is the complete list of members for AP4_SampleDescription, including all inherited members.
AP4_SampleDescription(Type type, AP4_UI32 format, AP4_AtomParent *details) | AP4_SampleDescription |
Clone(AP4_Result *result=NULL) | AP4_SampleDescription | [virtual]
GetDetails() | AP4_SampleDescription | [inline]
GetFormat() const | AP4_SampleDescription | [inline]
GetType() const | AP4_SampleDescription | [inline]
m_Details | AP4_SampleDescription | [protected]
m_Format | AP4_SampleDescription | [protected]
m_Type | AP4_SampleDescription | [protected]
ToAtom() const | AP4_SampleDescription | [virtual]
Type enum name | AP4_SampleDescription |
TYPE_AVC enum value | AP4_SampleDescription |
TYPE_MPEG enum value | AP4_SampleDescription |
TYPE_PROTECTED enum value | AP4_SampleDescription |
TYPE_UNKNOWN enum value | AP4_SampleDescription |
~AP4_SampleDescription() | AP4_SampleDescription | [inline, virtual]
Generated on Thu May 13 16:37:46 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_SampleDescRtpConstructor Class Reference

AP4_SampleDescRtpConstructor Class Reference

#include <Ap4RtpHint.h>

Inheritance diagram for AP4_SampleDescRtpConstructor:
AP4_RtpConstructor AP4_Referenceable

List of all members.

Public Member Functions

AP4_SampleDescRtpConstructor (AP4_ByteStream &stream)
AP4_SampleDescRtpConstructor (AP4_UI08 track_ref_index, AP4_UI16 length, AP4_UI32 sample_desc_index, AP4_UI32 sample_desc_offset)
AP4_UI08 | GetTrackRefIndex () const
AP4_UI16 | GetLength () const
AP4_UI32 | GetSampleDescIndex () const
AP4_UI32 | GetSampleDescOffset () const
virtual AP4_Size | GetConstructedDataSize ()

Protected Member Functions

virtual AP4_Result | DoWrite (AP4_ByteStream &stream)

Protected Attributes

AP4_UI08 m_TrackRefIndex
AP4_UI16 m_Length
AP4_UI32 m_SampleDescIndex
AP4_UI32 m_SampleDescOffset

Detailed Description

Definition at line 257 of file Ap4RtpHint.h.

Constructor & Destructor Documentation

AP4_SampleDescRtpConstructor::AP4_SampleDescRtpConstructor ( AP4_ByteStream & stream )
AP4_SampleDescRtpConstructor::AP4_SampleDescRtpConstructor | ( | AP4_UI08 | track_ref_index,
 |  | AP4_UI16 | length,
 |  | AP4_UI32 | sample_desc_index,
 |  | AP4_UI32 | sample_desc_offset
 | ) |  |

Member Function Documentation

virtual AP4_Result AP4_SampleDescRtpConstructor::DoWrite ( AP4_ByteStream & stream ) [protected, virtual]

Implements AP4_RtpConstructor.

virtual AP4_Size AP4_SampleDescRtpConstructor::GetConstructedDataSize ( ) [inline, virtual]

Implements AP4_RtpConstructor.

Definition at line 274 of file Ap4RtpHint.h.

References m_Length.

AP4_UI16 AP4_SampleDescRtpConstructor::GetLength ( ) const [inline]

Definition at line 269 of file Ap4RtpHint.h.

References m_Length.

AP4_UI32 AP4_SampleDescRtpConstructor::GetSampleDescIndex ( ) const [inline]

Definition at line 270 of file Ap4RtpHint.h.

References m_SampleDescIndex.

AP4_UI32 AP4_SampleDescRtpConstructor::GetSampleDescOffset ( ) const [inline]

Definition at line 271 of file Ap4RtpHint.h.

References m_SampleDescOffset.

AP4_UI08 AP4_SampleDescRtpConstructor::GetTrackRefIndex ( ) const [inline]

Definition at line 268 of file Ap4RtpHint.h.

References m_TrackRefIndex.

Member Data Documentation

AP4_UI16 AP4_SampleDescRtpConstructor::m_Length [protected]

Definition at line 282 of file Ap4RtpHint.h.

Referenced by GetConstructedDataSize(), and GetLength().

AP4_UI32 AP4_SampleDescRtpConstructor::m_SampleDescIndex [protected]

Definition at line 283 of file Ap4RtpHint.h.

Referenced by GetSampleDescIndex().

AP4_UI32 AP4_SampleDescRtpConstructor::m_SampleDescOffset [protected]

Definition at line 284 of file Ap4RtpHint.h.

Referenced by GetSampleDescOffset().

AP4_UI08 AP4_SampleDescRtpConstructor::m_TrackRefIndex [protected]

Definition at line 281 of file Ap4RtpHint.h.

Referenced by GetTrackRefIndex().

The documentation for this class was generated from the following file:
  • Ap4RtpHint.h
Generated on Thu May 13 16:37:47 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_SampleDescRtpConstructor Member List

This is the complete list of members for AP4_SampleDescRtpConstructor, including all inherited members.
AddReference() | AP4_RtpConstructor | [virtual]
AP4_RtpConstructor(Type type) | AP4_RtpConstructor | [inline]
AP4_SampleDescRtpConstructor(AP4_ByteStream &stream) | AP4_SampleDescRtpConstructor |
AP4_SampleDescRtpConstructor(AP4_UI08 track_ref_index, AP4_UI16 length, AP4_UI32 sample_desc_index, AP4_UI32 sample_desc_offset) | AP4_SampleDescRtpConstructor |
DoWrite(AP4_ByteStream &stream) | AP4_SampleDescRtpConstructor | [protected, virtual]
GetConstructedDataSize() | AP4_SampleDescRtpConstructor | [inline, virtual]
GetLength() const | AP4_SampleDescRtpConstructor | [inline]
GetSampleDescIndex() const | AP4_SampleDescRtpConstructor | [inline]
GetSampleDescOffset() const | AP4_SampleDescRtpConstructor | [inline]
GetTrackRefIndex() const | AP4_SampleDescRtpConstructor | [inline]
GetType() const | AP4_RtpConstructor | [inline]
m_Length | AP4_SampleDescRtpConstructor | [protected]
m_ReferenceCount | AP4_RtpConstructor | [protected]
m_SampleDescIndex | AP4_SampleDescRtpConstructor | [protected]
m_SampleDescOffset | AP4_SampleDescRtpConstructor | [protected]
m_TrackRefIndex | AP4_SampleDescRtpConstructor | [protected]
m_Type | AP4_RtpConstructor | [protected]
Release() | AP4_RtpConstructor | [virtual]
Type typedef | AP4_RtpConstructor |
Write(AP4_ByteStream &stream) | AP4_RtpConstructor |
~AP4_Referenceable() | AP4_Referenceable | [inline, virtual]
~AP4_RtpConstructor() | AP4_RtpConstructor | [inline, protected, virtual]
Generated on Thu May 13 16:37:47 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_SampleEntry Class Reference

AP4_SampleEntry Class Reference

#include <Ap4SampleEntry.h>

Inheritance diagram for AP4_SampleEntry:
AP4_ContainerAtom AP4_Atom AP4_AtomParent AP4_AudioSampleEntry AP4_MpegSystemSampleEntry AP4_RtpHintSampleEntry AP4_UnknownSampleEntry AP4_VisualSampleEntry AP4_EncaSampleEntry AP4_MpegAudioSampleEntry AP4_Mp4sSampleEntry AP4_Avc1SampleEntry AP4_EncvSampleEntry AP4_MpegVideoSampleEntry AP4_DrmsSampleEntry AP4_Mp4aSampleEntry AP4_DrmiSampleEntry AP4_Mp4vSampleEntry

List of all members.

Public Member Functions

AP4_SampleEntry (AP4_Atom::Type format, AP4_UI16 data_ref_index=1)
AP4_SampleEntry (AP4_Atom::Type format, AP4_Size size, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory)
virtual | ~AP4_SampleEntry ()
AP4_UI16 GetDataReferenceIndex ()
virtual AP4_Result | Write (AP4_ByteStream &stream)
virtual AP4_Result | Inspect (AP4_AtomInspector &inspector)
virtual AP4_SampleDescription * | ToSampleDescription ()
virtual void | OnChildChanged (AP4_Atom *child)

Protected Member Functions

AP4_SampleEntry (AP4_Atom::Type format, AP4_Size size)
virtual void | Read (AP4_ByteStream &stream, AP4_AtomFactory &atom_factory)
virtual AP4_Size | GetFieldsSize ()
virtual AP4_Result | ReadFields (AP4_ByteStream &stream)
virtual AP4_Result | WriteFields (AP4_ByteStream &stream)
virtual AP4_Result | InspectFields (AP4_AtomInspector &inspector)

Protected Attributes

AP4_UI08 | m_Reserved1 [6]
AP4_UI16 m_DataReferenceIndex

Detailed Description

Definition at line 51 of file Ap4SampleEntry.h.

Constructor & Destructor Documentation

AP4_SampleEntry::AP4_SampleEntry | ( | AP4_Atom::Type | format,
 |  | AP4_UI16 | data_ref_index = 1
 | ) |  |
AP4_SampleEntry::AP4_SampleEntry | ( | AP4_Atom::Type | format,
 |  | AP4_Size | size,
 |  | AP4_ByteStream & | stream,
 |  | AP4_AtomFactory & | atom_factory
 | ) |  |
virtual AP4_SampleEntry::~AP4_SampleEntry ( ) [inline, virtual]

Definition at line 62 of file Ap4SampleEntry.h.

AP4_SampleEntry::AP4_SampleEntry | ( | AP4_Atom::Type | format,
 |  | AP4_Size | size |
 | ) |  |  | [protected]

Member Function Documentation

AP4_UI16 AP4_SampleEntry::GetDataReferenceIndex ( ) [inline]

Definition at line 64 of file Ap4SampleEntry.h.

References m_DataReferenceIndex.

virtual AP4_Size AP4_SampleEntry::GetFieldsSize ( ) [protected, virtual]

Reimplemented in AP4_UnknownSampleEntry, AP4_AudioSampleEntry, AP4_VisualSampleEntry, and AP4_RtpHintSampleEntry.

virtual AP4_Result AP4_SampleEntry::Inspect ( AP4_AtomInspector & inspector ) [virtual]

Reimplemented from AP4_Atom.

virtual AP4_Result AP4_SampleEntry::InspectFields ( AP4_AtomInspector & inspector ) [protected, virtual]

Reimplemented from AP4_ContainerAtom.

Reimplemented in AP4_AudioSampleEntry, AP4_VisualSampleEntry, and AP4_RtpHintSampleEntry.

virtual void AP4_SampleEntry::OnChildChanged ( AP4_Atom * child ) [virtual]

Reimplemented from AP4_ContainerAtom.

virtual void AP4_SampleEntry::Read | ( | AP4_ByteStream & | stream,
 |  | AP4_AtomFactory & | atom_factory |
 | ) |  |  | [protected, virtual]
virtual AP4_Result AP4_SampleEntry::ReadFields ( AP4_ByteStream & stream ) [protected, virtual]

Reimplemented in AP4_UnknownSampleEntry, AP4_AudioSampleEntry, AP4_VisualSampleEntry, and AP4_RtpHintSampleEntry.

virtual AP4_SampleDescription* AP4_SampleEntry::ToSampleDescription ( ) [virtual]

Reimplemented in AP4_EncaSampleEntry, AP4_EncvSampleEntry, AP4_UnknownSampleEntry, AP4_AudioSampleEntry, AP4_VisualSampleEntry, AP4_MpegSystemSampleEntry, AP4_MpegAudioSampleEntry, AP4_MpegVideoSampleEntry, AP4_Mp4sSampleEntry, and AP4_Avc1SampleEntry.

virtual AP4_Result AP4_SampleEntry::Write ( AP4_ByteStream & stream ) [virtual]

Reimplemented from AP4_Atom.

virtual AP4_Result AP4_SampleEntry::WriteFields ( AP4_ByteStream & stream ) [protected, virtual]

Reimplemented from AP4_ContainerAtom.

Reimplemented in AP4_UnknownSampleEntry, AP4_AudioSampleEntry, AP4_VisualSampleEntry, and AP4_RtpHintSampleEntry.

Member Data Documentation

AP4_UI16 AP4_SampleEntry::m_DataReferenceIndex [protected]

Definition at line 85 of file Ap4SampleEntry.h.

Referenced by GetDataReferenceIndex().

AP4_UI08 AP4_SampleEntry::m_Reserved1[6] [protected]

Definition at line 84 of file Ap4SampleEntry.h.

The documentation for this class was generated from the following file:
  • Ap4SampleEntry.h
Generated on Thu May 13 16:37:47 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_SampleEntry Member List

This is the complete list of members for AP4_SampleEntry, including all inherited members.
AddChild(AP4_Atom *child, int position=-1) | AP4_AtomParent | [virtual]
AP4_Atom(Type type, AP4_UI32 size=AP4_ATOM_HEADER_SIZE) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64=false) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_ContainerAtom(Type type) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI32 version, AP4_UI32 flags) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_ContainerAtom | [protected]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_ContainerAtom | [protected]
AP4_SampleEntry(AP4_Atom::Type format, AP4_UI16 data_ref_index=1) | AP4_SampleEntry |
AP4_SampleEntry(AP4_Atom::Type format, AP4_Size size, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_SampleEntry |
AP4_SampleEntry(AP4_Atom::Type format, AP4_Size size) | AP4_SampleEntry | [protected]
Clone() | AP4_ContainerAtom | [virtual]
Create(Type type, AP4_UI64 size, bool is_full, bool force_64, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_ContainerAtom | [static]
DeleteChild(AP4_Atom::Type type, AP4_Ordinal index=0) | AP4_AtomParent | [virtual]
Detach() | AP4_Atom | [virtual]
FindChild(const char *path, bool auto_create=false, bool auto_create_full=false) | AP4_AtomParent | [virtual]
GetChild(AP4_Atom::Type type, AP4_Ordinal index=0) const | AP4_AtomParent | [virtual]
GetChild(const AP4_UI08 *uuid, AP4_Ordinal index=0) const | AP4_AtomParent | [virtual]
GetChildren() | AP4_ContainerAtom | [inline]
GetDataReferenceIndex() | AP4_SampleEntry | [inline]
GetFieldsSize() | AP4_SampleEntry | [protected, virtual]
GetFlags() const | AP4_Atom | [inline]
GetHeaderSize() const | AP4_Atom | [virtual]
GetParent() | AP4_Atom | [inline, virtual]
GetSize() const | AP4_Atom | [inline]
GetSize32() const | AP4_Atom | [inline]
GetSize64() const | AP4_Atom | [inline]
GetType() const | AP4_Atom | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_SampleEntry | [virtual]
InspectChildren(AP4_AtomInspector &inspector) | AP4_ContainerAtom | [virtual]
InspectFields(AP4_AtomInspector &inspector) | AP4_SampleEntry | [protected, virtual]
InspectHeader(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
m_Children | AP4_AtomParent | [protected]
m_DataReferenceIndex | AP4_SampleEntry | [protected]
m_Flags | AP4_Atom | [protected]
m_IsFull | AP4_Atom | [protected]
m_Parent | AP4_Atom | [protected]
m_Reserved1 | AP4_SampleEntry | [protected]
m_Size32 | AP4_Atom | [protected]
m_Size64 | AP4_Atom | [protected]
m_Type | AP4_Atom | [protected]
m_Version | AP4_Atom | [protected]
OnChildAdded(AP4_Atom *child) | AP4_ContainerAtom | [virtual]
OnChildChanged(AP4_Atom *child) | AP4_SampleEntry | [virtual]
OnChildRemoved(AP4_Atom *child) | AP4_ContainerAtom | [virtual]
Read(AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_SampleEntry | [protected, virtual]
ReadChildren(AP4_AtomFactory &atom_factory, AP4_ByteStream &stream, AP4_UI64 size) | AP4_ContainerAtom | [protected]
ReadFields(AP4_ByteStream &stream) | AP4_SampleEntry | [protected, virtual]
ReadFullHeader(AP4_ByteStream &stream, AP4_UI32 &version, AP4_UI32 &flags) | AP4_Atom | [static]
RemoveChild(AP4_Atom *child) | AP4_AtomParent | [virtual]
SetFlags(AP4_UI32 flags) | AP4_Atom | [inline]
SetParent(AP4_AtomParent *parent) | AP4_Atom | [inline, virtual]
SetSize(AP4_UI64 size, bool force_64=false) | AP4_Atom |
SetSize32(AP4_UI32 size) | AP4_Atom | [inline]
SetSize64(AP4_UI64 size) | AP4_Atom | [inline]
SetType(Type type) | AP4_Atom | [inline]
ToSampleDescription() | AP4_SampleEntry | [virtual]
Type typedef | AP4_Atom |
TypeFromString(const char *four_cc) | AP4_Atom | [static]
Write(AP4_ByteStream &stream) | AP4_SampleEntry | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_SampleEntry | [protected, virtual]
WriteHeader(AP4_ByteStream &stream) | AP4_Atom | [virtual]
~AP4_Atom() | AP4_Atom | [inline, virtual]
~AP4_AtomParent() | AP4_AtomParent | [virtual]
~AP4_SampleEntry() | AP4_SampleEntry | [inline, virtual]
Generated on Thu May 13 16:37:47 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_SampleRtpConstructor Class Reference

AP4_SampleRtpConstructor Class Reference

#include <Ap4RtpHint.h>

Inheritance diagram for AP4_SampleRtpConstructor:
AP4_RtpConstructor AP4_Referenceable

List of all members.

Public Member Functions

AP4_SampleRtpConstructor (AP4_ByteStream &stream)
AP4_SampleRtpConstructor (AP4_UI08 track_ref_index, AP4_UI16 length, AP4_UI32 sample_num, AP4_UI32 sample_offset)
AP4_UI08 | GetTrackRefIndex () const
AP4_UI16 | GetLength () const
AP4_UI32 | GetSampleNum () const
AP4_UI32 | GetSampleOffset () const
virtual AP4_Size | GetConstructedDataSize ()

Protected Member Functions

virtual AP4_Result | DoWrite (AP4_ByteStream &stream)

Protected Attributes

AP4_UI08 m_TrackRefIndex
AP4_UI16 m_Length
AP4_UI32 m_SampleNum
AP4_UI32 m_SampleOffset

Detailed Description

Definition at line 224 of file Ap4RtpHint.h.

Constructor & Destructor Documentation

AP4_SampleRtpConstructor::AP4_SampleRtpConstructor ( AP4_ByteStream & stream )
AP4_SampleRtpConstructor::AP4_SampleRtpConstructor | ( | AP4_UI08 | track_ref_index,
 |  | AP4_UI16 | length,
 |  | AP4_UI32 | sample_num,
 |  | AP4_UI32 | sample_offset
 | ) |  |

Member Function Documentation

virtual AP4_Result AP4_SampleRtpConstructor::DoWrite ( AP4_ByteStream & stream ) [protected, virtual]

Implements AP4_RtpConstructor.

virtual AP4_Size AP4_SampleRtpConstructor::GetConstructedDataSize ( ) [inline, virtual]

Implements AP4_RtpConstructor.

Definition at line 241 of file Ap4RtpHint.h.

References m_Length.

AP4_UI16 AP4_SampleRtpConstructor::GetLength ( ) const [inline]

Definition at line 236 of file Ap4RtpHint.h.

References m_Length.

AP4_UI32 AP4_SampleRtpConstructor::GetSampleNum ( ) const [inline]

Definition at line 237 of file Ap4RtpHint.h.

References m_SampleNum.

AP4_UI32 AP4_SampleRtpConstructor::GetSampleOffset ( ) const [inline]

Definition at line 238 of file Ap4RtpHint.h.

References m_SampleOffset.

AP4_UI08 AP4_SampleRtpConstructor::GetTrackRefIndex ( ) const [inline]

Definition at line 235 of file Ap4RtpHint.h.

References m_TrackRefIndex.

Member Data Documentation

AP4_UI16 AP4_SampleRtpConstructor::m_Length [protected]

Definition at line 249 of file Ap4RtpHint.h.

Referenced by GetConstructedDataSize(), and GetLength().

AP4_UI32 AP4_SampleRtpConstructor::m_SampleNum [protected]

Definition at line 250 of file Ap4RtpHint.h.

Referenced by GetSampleNum().

AP4_UI32 AP4_SampleRtpConstructor::m_SampleOffset [protected]

Definition at line 251 of file Ap4RtpHint.h.

Referenced by GetSampleOffset().

AP4_UI08 AP4_SampleRtpConstructor::m_TrackRefIndex [protected]

Definition at line 248 of file Ap4RtpHint.h.

Referenced by GetTrackRefIndex().

The documentation for this class was generated from the following file:
  • Ap4RtpHint.h
Generated on Thu May 13 16:37:47 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_SampleRtpConstructor Member List

This is the complete list of members for AP4_SampleRtpConstructor, including all inherited members.
AddReference() | AP4_RtpConstructor | [virtual]
AP4_RtpConstructor(Type type) | AP4_RtpConstructor | [inline]
AP4_SampleRtpConstructor(AP4_ByteStream &stream) | AP4_SampleRtpConstructor |
AP4_SampleRtpConstructor(AP4_UI08 track_ref_index, AP4_UI16 length, AP4_UI32 sample_num, AP4_UI32 sample_offset) | AP4_SampleRtpConstructor |
DoWrite(AP4_ByteStream &stream) | AP4_SampleRtpConstructor | [protected, virtual]
GetConstructedDataSize() | AP4_SampleRtpConstructor | [inline, virtual]
GetLength() const | AP4_SampleRtpConstructor | [inline]
GetSampleNum() const | AP4_SampleRtpConstructor | [inline]
GetSampleOffset() const | AP4_SampleRtpConstructor | [inline]
GetTrackRefIndex() const | AP4_SampleRtpConstructor | [inline]
GetType() const | AP4_RtpConstructor | [inline]
m_Length | AP4_SampleRtpConstructor | [protected]
m_ReferenceCount | AP4_RtpConstructor | [protected]
m_SampleNum | AP4_SampleRtpConstructor | [protected]
m_SampleOffset | AP4_SampleRtpConstructor | [protected]
m_TrackRefIndex | AP4_SampleRtpConstructor | [protected]
m_Type | AP4_RtpConstructor | [protected]
Release() | AP4_RtpConstructor | [virtual]
Type typedef | AP4_RtpConstructor |
Write(AP4_ByteStream &stream) | AP4_RtpConstructor |
~AP4_Referenceable() | AP4_Referenceable | [inline, virtual]
~AP4_RtpConstructor() | AP4_RtpConstructor | [inline, protected, virtual]
Generated on Thu May 13 16:37:47 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_SampleSource Class Reference

AP4_SampleSource Class Reference

#include <Ap4SampleSource.h>

Inheritance diagram for AP4_SampleSource:
AP4_TrackSampleSource

List of all members.

Public Member Functions

virtual | ~AP4_SampleSource ()
virtual AP4_UI32 | GetTimeScale ()=0
Return the timscale of the sample's media.
virtual AP4_UI32 | GetDurationMs ()=0
Return the duration in milliseconds.
virtual AP4_UI32 | GetTrackId ()=0
Return the track ID associated with this source, or 0 if there is no track ID associated with it.
virtual AP4_Result | ReadNextSample (AP4_Sample &sample, AP4_DataBuffer &buffer)=0
Read the next sample from the source.
virtual AP4_Ordinal | GetNearestSyncSampleIndex (AP4_Ordinal indx, bool before=true)=0
Return the index of the nearest sync sample from a given sample index.
virtual AP4_Result | GetSampleIndexForTimeStampMs (AP4_UI32 timestamp, AP4_Ordinal &indx)=0
Return the sample index given a timestamp in milliseconds.
virtual AP4_Result | SetSampleIndex (AP4_Ordinal indx)=0
Seek to a specific sample index.
virtual AP4_SampleDescription * | GetSampleDescription (AP4_Ordinal indx)=0
Return a sample description by index.

Detailed Description

Definition at line 48 of file Ap4SampleSource.h.

Constructor & Destructor Documentation

virtual AP4_SampleSource::~AP4_SampleSource ( ) [inline, virtual]

Definition at line 51 of file Ap4SampleSource.h.

Member Function Documentation

virtual AP4_UI32 AP4_SampleSource::GetDurationMs ( ) [pure virtual]

Return the duration in milliseconds.

Implemented in AP4_TrackSampleSource.

virtual AP4_Ordinal AP4_SampleSource::GetNearestSyncSampleIndex | ( | AP4_Ordinal | indx,
 |  | bool | before = true |
 | ) |  |  | [pure virtual]

Return the index of the nearest sync sample from a given sample index.

Implemented in AP4_TrackSampleSource.

virtual AP4_SampleDescription* AP4_SampleSource::GetSampleDescription ( AP4_Ordinal indx ) [pure virtual]

Return a sample description by index.

Returns NULL if there is no sample description with the requested index.

Implemented in AP4_TrackSampleSource.

virtual AP4_Result AP4_SampleSource::GetSampleIndexForTimeStampMs | ( | AP4_UI32 | timestamp,
 |  | AP4_Ordinal & | indx |
 | ) |  |  | [pure virtual]

Return the sample index given a timestamp in milliseconds.

Implemented in AP4_TrackSampleSource.

virtual AP4_UI32 AP4_SampleSource::GetTimeScale ( ) [pure virtual]

Return the timscale of the sample's media.

Implemented in AP4_TrackSampleSource.

virtual AP4_UI32 AP4_SampleSource::GetTrackId ( ) [pure virtual]

Return the track ID associated with this source, or 0 if there is no track ID associated with it.

Implemented in AP4_TrackSampleSource.

virtual AP4_Result AP4_SampleSource::ReadNextSample | ( | AP4_Sample & | sample,
 |  | AP4_DataBuffer & | buffer |
 | ) |  |  | [pure virtual]

Read the next sample from the source.

Implemented in AP4_TrackSampleSource.

virtual AP4_Result AP4_SampleSource::SetSampleIndex ( AP4_Ordinal indx ) [pure virtual]

Seek to a specific sample index.

Implemented in AP4_TrackSampleSource.

The documentation for this class was generated from the following file:
  • Ap4SampleSource.h
Generated on Thu May 13 16:37:49 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_SampleSource Member List

This is the complete list of members for AP4_SampleSource, including all inherited members.
GetDurationMs()=0 | AP4_SampleSource | [pure virtual]
GetNearestSyncSampleIndex(AP4_Ordinal indx, bool before=true)=0 | AP4_SampleSource | [pure virtual]
GetSampleDescription(AP4_Ordinal indx)=0 | AP4_SampleSource | [pure virtual]
GetSampleIndexForTimeStampMs(AP4_UI32 timestamp, AP4_Ordinal &indx)=0 | AP4_SampleSource | [pure virtual]
GetTimeScale()=0 | AP4_SampleSource | [pure virtual]
GetTrackId()=0 | AP4_SampleSource | [pure virtual]
ReadNextSample(AP4_Sample &sample, AP4_DataBuffer &buffer)=0 | AP4_SampleSource | [pure virtual]
SetSampleIndex(AP4_Ordinal indx)=0 | AP4_SampleSource | [pure virtual]
~AP4_SampleSource() | AP4_SampleSource | [inline, virtual]
Generated on Thu May 13 16:37:49 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_SampleTable Class Reference

AP4_SampleTable Class Reference

#include <Ap4SampleTable.h>

Inheritance diagram for AP4_SampleTable:
AP4_AtomSampleTable AP4_FragmentSampleTable AP4_SyntheticSampleTable

List of all members.

Public Member Functions

virtual | ~AP4_SampleTable ()
virtual AP4_Result | GenerateStblAtom (AP4_ContainerAtom *&stbl)
virtual AP4_Result | GetSample (AP4_Ordinal sample_index, AP4_Sample &sample)=0
virtual AP4_Cardinal | GetSampleCount ()=0
virtual AP4_Result | GetSampleChunkPosition (AP4_Ordinal sample_index, AP4_Ordinal &chunk_index, AP4_Ordinal &position_in_chunk)=0
virtual AP4_Cardinal | GetSampleDescriptionCount ()=0
virtual AP4_SampleDescription * | GetSampleDescription (AP4_Ordinal index)=0
virtual AP4_Result | GetSampleIndexForTimeStamp (AP4_UI64 ts, AP4_Ordinal &index)=0
virtual AP4_Ordinal | GetNearestSyncSampleIndex (AP4_Ordinal index, bool before=true)=0

Detailed Description

Definition at line 48 of file Ap4SampleTable.h.

Constructor & Destructor Documentation

virtual AP4_SampleTable::~AP4_SampleTable ( ) [inline, virtual]

Definition at line 53 of file Ap4SampleTable.h.

Member Function Documentation

virtual AP4_Result AP4_SampleTable::GenerateStblAtom ( AP4_ContainerAtom *& stbl ) [virtual]
virtual AP4_Ordinal AP4_SampleTable::GetNearestSyncSampleIndex | ( | AP4_Ordinal | index,
 |  | bool | before = true |
 | ) |  |  | [pure virtual]

Implemented in AP4_AtomSampleTable, AP4_FragmentSampleTable, and AP4_SyntheticSampleTable.

virtual AP4_Result AP4_SampleTable::GetSample | ( | AP4_Ordinal | sample_index,
 |  | AP4_Sample & | sample |
 | ) |  |  | [pure virtual]

Implemented in AP4_AtomSampleTable, AP4_FragmentSampleTable, and AP4_SyntheticSampleTable.

virtual AP4_Result AP4_SampleTable::GetSampleChunkPosition | ( | AP4_Ordinal | sample_index,
 |  | AP4_Ordinal & | chunk_index,
 |  | AP4_Ordinal & | position_in_chunk |
 | ) |  |  | [pure virtual]

Implemented in AP4_AtomSampleTable, AP4_FragmentSampleTable, and AP4_SyntheticSampleTable.

virtual AP4_Cardinal AP4_SampleTable::GetSampleCount ( ) [pure virtual]

Implemented in AP4_AtomSampleTable, AP4_FragmentSampleTable, and AP4_SyntheticSampleTable.

virtual AP4_SampleDescription* AP4_SampleTable::GetSampleDescription ( AP4_Ordinal index ) [pure virtual]

Implemented in AP4_AtomSampleTable, AP4_FragmentSampleTable, and AP4_SyntheticSampleTable.

virtual AP4_Cardinal AP4_SampleTable::GetSampleDescriptionCount ( ) [pure virtual]

Implemented in AP4_AtomSampleTable, AP4_FragmentSampleTable, and AP4_SyntheticSampleTable.

virtual AP4_Result AP4_SampleTable::GetSampleIndexForTimeStamp | ( | AP4_UI64 | ts,
 |  | AP4_Ordinal & | index |
 | ) |  |  | [pure virtual]

Implemented in AP4_AtomSampleTable, AP4_FragmentSampleTable, and AP4_SyntheticSampleTable.

The documentation for this class was generated from the following file:
  • Ap4SampleTable.h
Generated on Thu May 13 16:37:49 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_SampleTable Member List

This is the complete list of members for AP4_SampleTable, including all inherited members.
GenerateStblAtom(AP4_ContainerAtom *&stbl) | AP4_SampleTable | [virtual]
GetNearestSyncSampleIndex(AP4_Ordinal index, bool before=true)=0 | AP4_SampleTable | [pure virtual]
GetSample(AP4_Ordinal sample_index, AP4_Sample &sample)=0 | AP4_SampleTable | [pure virtual]
GetSampleChunkPosition(AP4_Ordinal sample_index, AP4_Ordinal &chunk_index, AP4_Ordinal &position_in_chunk)=0 | AP4_SampleTable | [pure virtual]
GetSampleCount()=0 | AP4_SampleTable | [pure virtual]
GetSampleDescription(AP4_Ordinal index)=0 | AP4_SampleTable | [pure virtual]
GetSampleDescriptionCount()=0 | AP4_SampleTable | [pure virtual]
GetSampleIndexForTimeStamp(AP4_UI64 ts, AP4_Ordinal &index)=0 | AP4_SampleTable | [pure virtual]
~AP4_SampleTable() | AP4_SampleTable | [inline, virtual]
Generated on Thu May 13 16:37:49 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_SchmAtom Class Reference

AP4_SchmAtom Class Reference

#include <Ap4SchmAtom.h>

Inheritance diagram for AP4_SchmAtom:
AP4_Atom

List of all members.

Public Member Functions

AP4_SchmAtom (AP4_UI32 scheme_type, AP4_UI32 scheme_version, const char *scheme_uri=NULL, bool short_form=false)
virtual AP4_Result | InspectFields (AP4_AtomInspector &inspector)
virtual AP4_Result | WriteFields (AP4_ByteStream &stream)
AP4_UI32 GetSchemeType ()
AP4_UI32 GetSchemeVersion ()
AP4_String & GetSchemeUri ()

Static Public Member Functions

static AP4_SchmAtom * | Create (AP4_Size size, AP4_Array< AP4_Atom::Type > *context, AP4_ByteStream &stream)

Detailed Description

Definition at line 48 of file Ap4SchmAtom.h.

Constructor & Destructor Documentation

AP4_SchmAtom::AP4_SchmAtom | ( | AP4_UI32 | scheme_type,
 |  | AP4_UI32 | scheme_version,
 |  | const char * | scheme_uri = NULL,
 |  | bool | short_form = false
 | ) |  |

Member Function Documentation

static AP4_SchmAtom* AP4_SchmAtom::Create | ( | AP4_Size | size,
 |  | AP4_Array< AP4_Atom::Type > * | context,
 |  | AP4_ByteStream & | stream |
 | ) |  |  | [static]
AP4_UI32 AP4_SchmAtom::GetSchemeType ( ) [inline]

Definition at line 69 of file Ap4SchmAtom.h.

AP4_String& AP4_SchmAtom::GetSchemeUri ( ) [inline]

Definition at line 71 of file Ap4SchmAtom.h.

AP4_UI32 AP4_SchmAtom::GetSchemeVersion ( ) [inline]

Definition at line 70 of file Ap4SchmAtom.h.

virtual AP4_Result AP4_SchmAtom::InspectFields ( AP4_AtomInspector & inspector ) [virtual]

Reimplemented from AP4_Atom.

virtual AP4_Result AP4_SchmAtom::WriteFields ( AP4_ByteStream & stream ) [virtual]

Implements AP4_Atom.

The documentation for this class was generated from the following file:
  • Ap4SchmAtom.h
Generated on Thu May 13 16:37:49 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_SchmAtom Member List

This is the complete list of members for AP4_SchmAtom, including all inherited members.
AP4_Atom(Type type, AP4_UI32 size=AP4_ATOM_HEADER_SIZE) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64=false) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_SchmAtom(AP4_UI32 scheme_type, AP4_UI32 scheme_version, const char *scheme_uri=NULL, bool short_form=false) | AP4_SchmAtom |
Clone() | AP4_Atom | [virtual]
Create(AP4_Size size, AP4_Array< AP4_Atom::Type > *context, AP4_ByteStream &stream) | AP4_SchmAtom | [static]
Detach() | AP4_Atom | [virtual]
GetFlags() const | AP4_Atom | [inline]
GetHeaderSize() const | AP4_Atom | [virtual]
GetParent() | AP4_Atom | [inline, virtual]
GetSchemeType() | AP4_SchmAtom | [inline]
GetSchemeUri() | AP4_SchmAtom | [inline]
GetSchemeVersion() | AP4_SchmAtom | [inline]
GetSize() const | AP4_Atom | [inline]
GetSize32() const | AP4_Atom | [inline]
GetSize64() const | AP4_Atom | [inline]
GetType() const | AP4_Atom | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
InspectFields(AP4_AtomInspector &inspector) | AP4_SchmAtom | [virtual]
InspectHeader(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
m_Flags | AP4_Atom | [protected]
m_IsFull | AP4_Atom | [protected]
m_Parent | AP4_Atom | [protected]
m_Size32 | AP4_Atom | [protected]
m_Size64 | AP4_Atom | [protected]
m_Type | AP4_Atom | [protected]
m_Version | AP4_Atom | [protected]
ReadFullHeader(AP4_ByteStream &stream, AP4_UI32 &version, AP4_UI32 &flags) | AP4_Atom | [static]
SetFlags(AP4_UI32 flags) | AP4_Atom | [inline]
SetParent(AP4_AtomParent *parent) | AP4_Atom | [inline, virtual]
SetSize(AP4_UI64 size, bool force_64=false) | AP4_Atom |
SetSize32(AP4_UI32 size) | AP4_Atom | [inline]
SetSize64(AP4_UI64 size) | AP4_Atom | [inline]
SetType(Type type) | AP4_Atom | [inline]
Type typedef | AP4_Atom |
TypeFromString(const char *four_cc) | AP4_Atom | [static]
Write(AP4_ByteStream &stream) | AP4_Atom | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_SchmAtom | [virtual]
WriteHeader(AP4_ByteStream &stream) | AP4_Atom | [virtual]
~AP4_Atom() | AP4_Atom | [inline, virtual]
Generated on Thu May 13 16:37:49 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_SdpAtom Class Reference

AP4_SdpAtom Class Reference

#include <Ap4SdpAtom.h>

Inheritance diagram for AP4_SdpAtom:
AP4_Atom

List of all members.

Public Member Functions

AP4_SdpAtom (const char *sdp_text)
virtual AP4_Result | InspectFields (AP4_AtomInspector &inspector)
virtual AP4_Result | WriteFields (AP4_ByteStream &stream)
const AP4_String & | GetSdpText () const

Static Public Member Functions

static AP4_SdpAtom * | Create (AP4_Size size, AP4_ByteStream &stream)

Detailed Description

Definition at line 47 of file Ap4SdpAtom.h.

Constructor & Destructor Documentation

AP4_SdpAtom::AP4_SdpAtom ( const char * sdp_text )

Referenced by Create().

Member Function Documentation

static AP4_SdpAtom* AP4_SdpAtom::Create | ( | AP4_Size | size,
 |  | AP4_ByteStream & | stream |
 | ) |  |  | [inline, static]

Definition at line 51 of file Ap4SdpAtom.h.

References AP4_SdpAtom().

const AP4_String& AP4_SdpAtom::GetSdpText ( ) const
virtual AP4_Result AP4_SdpAtom::InspectFields ( AP4_AtomInspector & inspector ) [virtual]

Reimplemented from AP4_Atom.

virtual AP4_Result AP4_SdpAtom::WriteFields ( AP4_ByteStream & stream ) [virtual]

Implements AP4_Atom.

The documentation for this class was generated from the following file:
  • Ap4SdpAtom.h
Generated on Thu May 13 16:37:50 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_SdpAtom Member List

This is the complete list of members for AP4_SdpAtom, including all inherited members.
AP4_Atom(Type type, AP4_UI32 size=AP4_ATOM_HEADER_SIZE) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64=false) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_SdpAtom(const char *sdp_text) | AP4_SdpAtom |
Clone() | AP4_Atom | [virtual]
Create(AP4_Size size, AP4_ByteStream &stream) | AP4_SdpAtom | [inline, static]
Detach() | AP4_Atom | [virtual]
GetFlags() const | AP4_Atom | [inline]
GetHeaderSize() const | AP4_Atom | [virtual]
GetParent() | AP4_Atom | [inline, virtual]
GetSdpText() const | AP4_SdpAtom |
GetSize() const | AP4_Atom | [inline]
GetSize32() const | AP4_Atom | [inline]
GetSize64() const | AP4_Atom | [inline]
GetType() const | AP4_Atom | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
InspectFields(AP4_AtomInspector &inspector) | AP4_SdpAtom | [virtual]
InspectHeader(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
m_Flags | AP4_Atom | [protected]
m_IsFull | AP4_Atom | [protected]
m_Parent | AP4_Atom | [protected]
m_Size32 | AP4_Atom | [protected]
m_Size64 | AP4_Atom | [protected]
m_Type | AP4_Atom | [protected]
m_Version | AP4_Atom | [protected]
ReadFullHeader(AP4_ByteStream &stream, AP4_UI32 &version, AP4_UI32 &flags) | AP4_Atom | [static]
SetFlags(AP4_UI32 flags) | AP4_Atom | [inline]
SetParent(AP4_AtomParent *parent) | AP4_Atom | [inline, virtual]
SetSize(AP4_UI64 size, bool force_64=false) | AP4_Atom |
SetSize32(AP4_UI32 size) | AP4_Atom | [inline]
SetSize64(AP4_UI64 size) | AP4_Atom | [inline]
SetType(Type type) | AP4_Atom | [inline]
Type typedef | AP4_Atom |
TypeFromString(const char *four_cc) | AP4_Atom | [static]
Write(AP4_ByteStream &stream) | AP4_Atom | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_SdpAtom | [virtual]
WriteHeader(AP4_ByteStream &stream) | AP4_Atom | [virtual]
~AP4_Atom() | AP4_Atom | [inline, virtual]
Generated on Thu May 13 16:37:50 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_SLConfigDescriptor Class Reference

AP4_SLConfigDescriptor Class Reference

#include <Ap4SLConfigDescriptor.h>

Inheritance diagram for AP4_SLConfigDescriptor:
AP4_Descriptor AP4_Expandable

List of all members.

Public Member Functions

AP4_SLConfigDescriptor (AP4_Size header_size=2)
virtual AP4_Result WriteFields (AP4_ByteStream &stream)

Detailed Description

Definition at line 46 of file Ap4SLConfigDescriptor.h.

Constructor & Destructor Documentation

AP4_SLConfigDescriptor::AP4_SLConfigDescriptor ( AP4_Size header_size = 2 )

Member Function Documentation

virtual AP4_Result AP4_SLConfigDescriptor::WriteFields ( AP4_ByteStream & stream ) [virtual]

Implements AP4_Expandable.

The documentation for this class was generated from the following file:
  • Ap4SLConfigDescriptor.h
Generated on Thu May 13 16:37:50 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_SLConfigDescriptor Member List

This is the complete list of members for AP4_SLConfigDescriptor, including all inherited members.
AP4_Descriptor(AP4_UI08 tag, AP4_Size header_size, AP4_Size payload_size) | AP4_Descriptor | [inline]
AP4_Expandable(AP4_UI32 class_id, ClassIdSize class_id_size, AP4_Size header_size, AP4_Size payload_size) | AP4_Expandable |
AP4_SLConfigDescriptor(AP4_Size header_size=2) | AP4_SLConfigDescriptor |
CLASS_ID_SIZE_08 enum value | AP4_Expandable |
ClassIdSize enum name | AP4_Expandable |
GetClassId() | AP4_Expandable | [inline]
GetHeaderSize() | AP4_Expandable | [inline]
GetSize() | AP4_Expandable | [inline]
GetTag() | AP4_Descriptor | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_Descriptor | [virtual]
m_ClassId | AP4_Expandable | [protected]
m_ClassIdSize | AP4_Expandable | [protected]
m_HeaderSize | AP4_Expandable | [protected]
m_PayloadSize | AP4_Expandable | [protected]
MinHeaderSize(AP4_Size payload_size) | AP4_Expandable | [static]
Write(AP4_ByteStream &stream) | AP4_Expandable | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_SLConfigDescriptor | [virtual]
~AP4_Expandable() | AP4_Expandable | [inline, virtual]
Generated on Thu May 13 16:37:50 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_SmhdAtom Class Reference

AP4_SmhdAtom Class Reference

#include <Ap4SmhdAtom.h>

Inheritance diagram for AP4_SmhdAtom:
AP4_Atom

List of all members.

Public Member Functions

AP4_SmhdAtom (AP4_UI16 balance)
virtual AP4_Result | InspectFields (AP4_AtomInspector &inspector)
virtual AP4_Result | WriteFields (AP4_ByteStream &stream)

Static Public Member Functions

static AP4_SmhdAtom * | Create (AP4_Size size, AP4_ByteStream &stream)

Detailed Description

Definition at line 41 of file Ap4SmhdAtom.h.

Constructor & Destructor Documentation

AP4_SmhdAtom::AP4_SmhdAtom ( AP4_UI16 balance )

Member Function Documentation

static AP4_SmhdAtom* AP4_SmhdAtom::Create | ( | AP4_Size | size,
 |  | AP4_ByteStream & | stream |
 | ) |  |  | [static]
virtual AP4_Result AP4_SmhdAtom::InspectFields ( AP4_AtomInspector & inspector ) [virtual]

Reimplemented from AP4_Atom.

virtual AP4_Result AP4_SmhdAtom::WriteFields ( AP4_ByteStream & stream ) [virtual]

Implements AP4_Atom.

The documentation for this class was generated from the following file:
  • Ap4SmhdAtom.h
Generated on Thu May 13 16:37:50 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_SmhdAtom Member List

This is the complete list of members for AP4_SmhdAtom, including all inherited members.
AP4_Atom(Type type, AP4_UI32 size=AP4_ATOM_HEADER_SIZE) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64=false) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_SmhdAtom(AP4_UI16 balance) | AP4_SmhdAtom |
Clone() | AP4_Atom | [virtual]
Create(AP4_Size size, AP4_ByteStream &stream) | AP4_SmhdAtom | [static]
Detach() | AP4_Atom | [virtual]
GetFlags() const | AP4_Atom | [inline]
GetHeaderSize() const | AP4_Atom | [virtual]
GetParent() | AP4_Atom | [inline, virtual]
GetSize() const | AP4_Atom | [inline]
GetSize32() const | AP4_Atom | [inline]
GetSize64() const | AP4_Atom | [inline]
GetType() const | AP4_Atom | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
InspectFields(AP4_AtomInspector &inspector) | AP4_SmhdAtom | [virtual]
InspectHeader(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
m_Flags | AP4_Atom | [protected]
m_IsFull | AP4_Atom | [protected]
m_Parent | AP4_Atom | [protected]
m_Size32 | AP4_Atom | [protected]
m_Size64 | AP4_Atom | [protected]
m_Type | AP4_Atom | [protected]
m_Version | AP4_Atom | [protected]
ReadFullHeader(AP4_ByteStream &stream, AP4_UI32 &version, AP4_UI32 &flags) | AP4_Atom | [static]
SetFlags(AP4_UI32 flags) | AP4_Atom | [inline]
SetParent(AP4_AtomParent *parent) | AP4_Atom | [inline, virtual]
SetSize(AP4_UI64 size, bool force_64=false) | AP4_Atom |
SetSize32(AP4_UI32 size) | AP4_Atom | [inline]
SetSize64(AP4_UI64 size) | AP4_Atom | [inline]
SetType(Type type) | AP4_Atom | [inline]
Type typedef | AP4_Atom |
TypeFromString(const char *four_cc) | AP4_Atom | [static]
Write(AP4_ByteStream &stream) | AP4_Atom | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_SmhdAtom | [virtual]
WriteHeader(AP4_ByteStream &stream) | AP4_Atom | [virtual]
~AP4_Atom() | AP4_Atom | [inline, virtual]
Generated on Thu May 13 16:37:50 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_StandardDecryptingProcessor Class Reference

AP4_StandardDecryptingProcessor Class Reference

#include <Ap4Protection.h>

Inheritance diagram for AP4_StandardDecryptingProcessor:
AP4_Processor

List of all members.

Public Member Functions

AP4_StandardDecryptingProcessor (const AP4_ProtectionKeyMap *key_map=NULL, AP4_BlockCipherFactory *block_cipher_factory=NULL)
AP4_ProtectionKeyMap & GetKeyMap ()
virtual AP4_Result Initialize (AP4_AtomParent &top_level, AP4_ByteStream &stream, ProgressListener *listener)
This method can be overridden by concrete subclasses.
virtual
AP4_Processor::TrackHandler * 		CreateTrackHandler (AP4_TrakAtom *trak)
This method can be overridden by concrete subclasses.

Detailed Description

Definition at line 348 of file Ap4Protection.h.

Constructor & Destructor Documentation

AP4_StandardDecryptingProcessor::AP4_StandardDecryptingProcessor | ( | const AP4_ProtectionKeyMap * | key_map = NULL,
 |  | AP4_BlockCipherFactory * | block_cipher_factory = NULL
 | ) |  |

Member Function Documentation

virtual AP4_Processor::TrackHandler* AP4_StandardDecryptingProcessor::CreateTrackHandler ( AP4_TrakAtom * ) [virtual]

This method can be overridden by concrete subclasses.

It is called once for each track in the input file.

Parameters:
track Pointer to the track for which a handler should be created.
Returns:
A pointer to a track handler, or NULL if no handler needs to be created for that track.

Reimplemented from AP4_Processor.

AP4_ProtectionKeyMap& AP4_StandardDecryptingProcessor::GetKeyMap ( ) [inline]

Definition at line 356 of file Ap4Protection.h.

virtual AP4_Result AP4_StandardDecryptingProcessor::Initialize | ( | AP4_AtomParent & | top_level,
 |  | AP4_ByteStream & | stream,
 |  | ProgressListener * | listener |
 | ) |  |  | [virtual]

This method can be overridden by concrete subclasses.

It is called just after the input stream has been parsed into an atom tree, before the processing of the tracks.

Parameters:
top_level Container atom containing all the atoms parsed from the input stream. Note that this atom does not actually exist in the file; it is a synthetised container created for the purpose of holding together all the input's top-level atoms.

Reimplemented from AP4_Processor.

The documentation for this class was generated from the following file:
  • Ap4Protection.h
Generated on Thu May 13 16:37:50 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_StandardDecryptingProcessor Member List

This is the complete list of members for AP4_StandardDecryptingProcessor, including all inherited members.
AP4_StandardDecryptingProcessor(const AP4_ProtectionKeyMap *key_map=NULL, AP4_BlockCipherFactory *block_cipher_factory=NULL) | AP4_StandardDecryptingProcessor |
CreateFragmentHandler(AP4_ContainerAtom *) | AP4_Processor | [inline, virtual]
CreateTrackHandler(AP4_TrakAtom *trak) | AP4_StandardDecryptingProcessor | [virtual]
Finalize(AP4_AtomParent &top_level, ProgressListener *listener=NULL) | AP4_Processor | [virtual]
GetKeyMap() | AP4_StandardDecryptingProcessor | [inline]
Initialize(AP4_AtomParent &top_level, AP4_ByteStream &stream, ProgressListener *listener) | AP4_StandardDecryptingProcessor | [virtual]
m_ExternalTrackData | AP4_Processor | [protected]
Process(AP4_ByteStream &input, AP4_ByteStream &output, ProgressListener *listener=NULL, AP4_AtomFactory &atom_factory=AP4_DefaultAtomFactory::Instance) | AP4_Processor |
ProcessFragments(AP4_MoovAtom *moov, AP4_List< AP4_MoofLocator > &moofs, AP4_ContainerAtom *mfra, AP4_ByteStream &input, AP4_ByteStream &output) | AP4_Processor | [protected]
~AP4_Processor() | AP4_Processor | [inline, virtual]
Generated on Thu May 13 16:37:50 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_StcoAtom Class Reference

AP4_StcoAtom Class Reference

#include <Ap4StcoAtom.h>

Inheritance diagram for AP4_StcoAtom:
AP4_Atom

List of all members.

Public Member Functions

AP4_StcoAtom (AP4_UI32 *offsets, AP4_UI32 offset_count)
~AP4_StcoAtom ()
virtual AP4_Result | InspectFields (AP4_AtomInspector &inspector)
virtual AP4_Result | WriteFields (AP4_ByteStream &stream)
AP4_Cardinal GetChunkCount ()
AP4_UI32 * GetChunkOffsets ()
AP4_Result | GetChunkOffset (AP4_Ordinal chunk, AP4_UI32 &chunk_offset)
AP4_Result | SetChunkOffset (AP4_Ordinal chunk, AP4_UI32 chunk_offset)
AP4_Result | AdjustChunkOffsets (int delta)

Static Public Member Functions

static AP4_StcoAtom * | Create (AP4_Size size, AP4_ByteStream &stream)

Detailed Description

Definition at line 41 of file Ap4StcoAtom.h.

Constructor & Destructor Documentation

AP4_StcoAtom::AP4_StcoAtom | ( | AP4_UI32 * | offsets,
 |  | AP4_UI32 | offset_count
 | ) |  |
AP4_StcoAtom::~AP4_StcoAtom ( )

Member Function Documentation

AP4_Result AP4_StcoAtom::AdjustChunkOffsets ( int delta )
static AP4_StcoAtom* AP4_StcoAtom::Create | ( | AP4_Size | size,
 |  | AP4_ByteStream & | stream |
 | ) |  |  | [static]
AP4_Cardinal AP4_StcoAtom::GetChunkCount ( ) [inline]

Definition at line 54 of file Ap4StcoAtom.h.

AP4_Result AP4_StcoAtom::GetChunkOffset | ( | AP4_Ordinal | chunk,
 |  | AP4_UI32 & | chunk_offset
 | ) |  |
AP4_UI32* AP4_StcoAtom::GetChunkOffsets ( ) [inline]

Definition at line 55 of file Ap4StcoAtom.h.

virtual AP4_Result AP4_StcoAtom::InspectFields ( AP4_AtomInspector & inspector ) [virtual]

Reimplemented from AP4_Atom.

AP4_Result AP4_StcoAtom::SetChunkOffset | ( | AP4_Ordinal | chunk,
 |  | AP4_UI32 | chunk_offset
 | ) |  |
virtual AP4_Result AP4_StcoAtom::WriteFields ( AP4_ByteStream & stream ) [virtual]

Implements AP4_Atom.

The documentation for this class was generated from the following file:
  • Ap4StcoAtom.h
Generated on Thu May 13 16:37:50 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_StcoAtom Member List

This is the complete list of members for AP4_StcoAtom, including all inherited members.
AdjustChunkOffsets(int delta) | AP4_StcoAtom |
AP4_Atom(Type type, AP4_UI32 size=AP4_ATOM_HEADER_SIZE) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64=false) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_StcoAtom(AP4_UI32 *offsets, AP4_UI32 offset_count) | AP4_StcoAtom |
Clone() | AP4_Atom | [virtual]
Create(AP4_Size size, AP4_ByteStream &stream) | AP4_StcoAtom | [static]
Detach() | AP4_Atom | [virtual]
GetChunkCount() | AP4_StcoAtom | [inline]
GetChunkOffset(AP4_Ordinal chunk, AP4_UI32 &chunk_offset) | AP4_StcoAtom |
GetChunkOffsets() | AP4_StcoAtom | [inline]
GetFlags() const | AP4_Atom | [inline]
GetHeaderSize() const | AP4_Atom | [virtual]
GetParent() | AP4_Atom | [inline, virtual]
GetSize() const | AP4_Atom | [inline]
GetSize32() const | AP4_Atom | [inline]
GetSize64() const | AP4_Atom | [inline]
GetType() const | AP4_Atom | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
InspectFields(AP4_AtomInspector &inspector) | AP4_StcoAtom | [virtual]
InspectHeader(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
m_Flags | AP4_Atom | [protected]
m_IsFull | AP4_Atom | [protected]
m_Parent | AP4_Atom | [protected]
m_Size32 | AP4_Atom | [protected]
m_Size64 | AP4_Atom | [protected]
m_Type | AP4_Atom | [protected]
m_Version | AP4_Atom | [protected]
ReadFullHeader(AP4_ByteStream &stream, AP4_UI32 &version, AP4_UI32 &flags) | AP4_Atom | [static]
SetChunkOffset(AP4_Ordinal chunk, AP4_UI32 chunk_offset) | AP4_StcoAtom |
SetFlags(AP4_UI32 flags) | AP4_Atom | [inline]
SetParent(AP4_AtomParent *parent) | AP4_Atom | [inline, virtual]
SetSize(AP4_UI64 size, bool force_64=false) | AP4_Atom |
SetSize32(AP4_UI32 size) | AP4_Atom | [inline]
SetSize64(AP4_UI64 size) | AP4_Atom | [inline]
SetType(Type type) | AP4_Atom | [inline]
Type typedef | AP4_Atom |
TypeFromString(const char *four_cc) | AP4_Atom | [static]
Write(AP4_ByteStream &stream) | AP4_Atom | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_StcoAtom | [virtual]
WriteHeader(AP4_ByteStream &stream) | AP4_Atom | [virtual]
~AP4_Atom() | AP4_Atom | [inline, virtual]
~AP4_StcoAtom() | AP4_StcoAtom |
Generated on Thu May 13 16:37:50 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_StreamCipher Class Reference

AP4_StreamCipher Class Reference

#include <Ap4StreamCipher.h>

Inheritance diagram for AP4_StreamCipher:
AP4_CbcStreamCipher AP4_CtrStreamCipher

List of all members.

Public Types

enum CipherDirection {
ENCRYPT,
DECRYPT
}

Public Member Functions

virtual | ~AP4_StreamCipher ()
virtual AP4_UI64 | GetStreamOffset ()=0
virtual AP4_Result | ProcessBuffer (const AP4_UI08 *in, AP4_Size in_size, AP4_UI08 *out, AP4_Size *out_size, bool is_last_buffer=false)=0
virtual AP4_Result | SetStreamOffset (AP4_UI64 offset, AP4_Cardinal *preroll)=0
virtual AP4_Result | SetIV (const AP4_UI08 *iv)=0
virtual const AP4_UI08 * | GetIV ()=0

Detailed Description

Definition at line 48 of file Ap4StreamCipher.h.

Member Enumeration Documentation

enum AP4_StreamCipher::CipherDirection
Enumerator:
ENCRYPT
DECRYPT

Definition at line 52 of file Ap4StreamCipher.h.

Constructor & Destructor Documentation

virtual AP4_StreamCipher::~AP4_StreamCipher ( ) [inline, virtual]

Definition at line 58 of file Ap4StreamCipher.h.

Member Function Documentation

virtual const AP4_UI08* AP4_StreamCipher::GetIV ( ) [pure virtual]

Implemented in AP4_CtrStreamCipher, and AP4_CbcStreamCipher.

virtual AP4_UI64 AP4_StreamCipher::GetStreamOffset ( ) [pure virtual]

Implemented in AP4_CtrStreamCipher, and AP4_CbcStreamCipher.

virtual AP4_Result AP4_StreamCipher::ProcessBuffer | ( | const AP4_UI08 * | in,
 |  | AP4_Size | in_size,
 |  | AP4_UI08 * | out,
 |  | AP4_Size * | out_size,
 |  | bool | is_last_buffer = false |
 | ) |  |  | [pure virtual]

Implemented in AP4_CtrStreamCipher, and AP4_CbcStreamCipher.

virtual AP4_Result AP4_StreamCipher::SetIV ( const AP4_UI08 * iv ) [pure virtual]

Implemented in AP4_CtrStreamCipher, and AP4_CbcStreamCipher.

virtual AP4_Result AP4_StreamCipher::SetStreamOffset | ( | AP4_UI64 | offset,
 |  | AP4_Cardinal * | preroll |
 | ) |  |  | [pure virtual]

Implemented in AP4_CtrStreamCipher, and AP4_CbcStreamCipher.

The documentation for this class was generated from the following file:
  • Ap4StreamCipher.h
Generated on Thu May 13 16:37:50 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_StreamCipher Member List

This is the complete list of members for AP4_StreamCipher, including all inherited members.
CipherDirection enum name | AP4_StreamCipher |
DECRYPT enum value | AP4_StreamCipher |
ENCRYPT enum value | AP4_StreamCipher |
GetIV()=0 | AP4_StreamCipher | [pure virtual]
GetStreamOffset()=0 | AP4_StreamCipher | [pure virtual]
ProcessBuffer(const AP4_UI08 *in, AP4_Size in_size, AP4_UI08 *out, AP4_Size *out_size, bool is_last_buffer=false)=0 | AP4_StreamCipher | [pure virtual]
SetIV(const AP4_UI08 *iv)=0 | AP4_StreamCipher | [pure virtual]
SetStreamOffset(AP4_UI64 offset, AP4_Cardinal *preroll)=0 | AP4_StreamCipher | [pure virtual]
~AP4_StreamCipher() | AP4_StreamCipher | [inline, virtual]
Generated on Thu May 13 16:37:50 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_String Class Reference

AP4_String Class Reference

#include <Ap4String.h>

List of all members.

Public Member Functions

AP4_String ()
AP4_String (const char *s)
AP4_String (const char *s, AP4_Size size)
AP4_String (const AP4_String &s)
AP4_String (AP4_Size size)
~AP4_String ()
const AP4_String & | operator= (const AP4_String &s)
const AP4_String & | operator= (const char *s)
char | operator[] (unsigned int index) const
bool | operator== (const AP4_String &s) const
bool | operator!= (const AP4_String &s) const
bool | operator== (const char *s) const
bool | operator!= (const char *s) const
AP4_Size | GetLength () const
const char * | GetChars () const
char * | UseChars ()
void | Assign (const char *chars, AP4_Size size)
int | Find (char c, unsigned int start=0) const

Detailed Description

Definition at line 41 of file Ap4String.h.

Constructor & Destructor Documentation

AP4_String::AP4_String ( )
AP4_String::AP4_String ( const char * s )
AP4_String::AP4_String | ( | const char * | s,
 |  | AP4_Size | size
 | ) |  |
AP4_String::AP4_String ( const AP4_String & s )
AP4_String::AP4_String ( AP4_Size size ) [explicit]
AP4_String::~AP4_String ( )

Member Function Documentation

void AP4_String::Assign | ( | const char * | chars,
 |  | AP4_Size | size
 | ) |  |
int AP4_String::Find | ( | char | c,
 |  | unsigned int | start = 0 |
 | ) |  |  | const
const char* AP4_String::GetChars ( ) const [inline]

Definition at line 67 of file Ap4String.h.

Referenced by AP4_VisualSampleEntry::GetCompressorName(), and AP4_VideoSampleDescription::GetCompressorName().

AP4_Size AP4_String::GetLength ( ) const [inline]

Definition at line 66 of file Ap4String.h.

bool AP4_String::operator!= ( const char * s ) const [inline]

Definition at line 63 of file Ap4String.h.

bool AP4_String::operator!= ( const AP4_String & s ) const [inline]

Definition at line 61 of file Ap4String.h.

const AP4_String& AP4_String::operator= ( const char * s )
const AP4_String& AP4_String::operator= ( const AP4_String & s )
bool AP4_String::operator== ( const char * s ) const
bool AP4_String::operator== ( const AP4_String & s ) const
char AP4_String::operator[] ( unsigned int index ) const [inline]

Definition at line 57 of file Ap4String.h.

char* AP4_String::UseChars ( ) [inline]

Definition at line 68 of file Ap4String.h.

The documentation for this class was generated from the following file:
  • Ap4String.h
Generated on Thu May 13 16:37:50 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_String Member List

This is the complete list of members for AP4_String, including all inherited members.
AP4_String() | AP4_String |
AP4_String(const char *s) | AP4_String |
AP4_String(const char *s, AP4_Size size) | AP4_String |
AP4_String(const AP4_String &s) | AP4_String |
AP4_String(AP4_Size size) | AP4_String | [explicit]
Assign(const char *chars, AP4_Size size) | AP4_String |
Find(char c, unsigned int start=0) const | AP4_String |
GetChars() const | AP4_String | [inline]
GetLength() const | AP4_String | [inline]
operator!=(const AP4_String &s) const | AP4_String | [inline]
operator!=(const char *s) const | AP4_String | [inline]
operator=(const AP4_String &s) | AP4_String |
operator=(const char *s) | AP4_String |
operator==(const AP4_String &s) const | AP4_String |
operator==(const char *s) const | AP4_String |
operator[](unsigned int index) const | AP4_String | [inline]
UseChars() | AP4_String | [inline]
~AP4_String() | AP4_String |
Generated on Thu May 13 16:37:50 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_StringMetaDataValue Class Reference

AP4_StringMetaDataValue Class Reference

#include <Ap4MetaData.h>

Inheritance diagram for AP4_StringMetaDataValue:
AP4_MetaData::Value

List of all members.

Public Member Functions

AP4_StringMetaDataValue (const char *value, const char *language=NULL)
virtual AP4_String | ToString () const
virtual AP4_Result | ToBytes (AP4_DataBuffer &bytes) const
virtual long | ToInteger () const

Detailed Description

Definition at line 502 of file Ap4MetaData.h.

Constructor & Destructor Documentation

AP4_StringMetaDataValue::AP4_StringMetaDataValue | ( | const char * | value,
 |  | const char * | language = NULL |
 | ) |  |  | [inline]

Definition at line 505 of file Ap4MetaData.h.

Member Function Documentation

virtual AP4_Result AP4_StringMetaDataValue::ToBytes ( AP4_DataBuffer & bytes ) const [virtual]

Implements AP4_MetaData::Value.

virtual long AP4_StringMetaDataValue::ToInteger ( ) const [virtual]

Implements AP4_MetaData::Value.

virtual AP4_String AP4_StringMetaDataValue::ToString ( ) const [virtual]

Implements AP4_MetaData::Value.

The documentation for this class was generated from the following file:
  • Ap4MetaData.h
Generated on Thu May 13 16:37:51 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_StringMetaDataValue Member List

This is the complete list of members for AP4_StringMetaDataValue, including all inherited members.
AP4_StringMetaDataValue(const char *value, const char *language=NULL) | AP4_StringMetaDataValue | [inline]
GetLanguage() const | AP4_MetaData::Value | [inline]
GetMeaning() const | AP4_MetaData::Value | [inline]
GetType() const | AP4_MetaData::Value | [inline]
GetTypeCategory() const | AP4_MetaData::Value |
m_Language | AP4_MetaData::Value | [protected]
m_Meaning | AP4_MetaData::Value | [protected]
m_Type | AP4_MetaData::Value | [protected]
MapTypeToCategory(Type type) | AP4_MetaData::Value | [protected, static]
Meaning enum name | AP4_MetaData::Value |
MEANING_BINARY_ENCODED_CHARS enum value | AP4_MetaData::Value |
MEANING_BOOLEAN enum value | AP4_MetaData::Value |
MEANING_FILE_KIND enum value | AP4_MetaData::Value |
MEANING_ID3_GENRE enum value | AP4_MetaData::Value |
MEANING_UNKNOWN enum value | AP4_MetaData::Value |
SetLanguage(const char *language) | AP4_MetaData::Value | [inline]
ToBytes(AP4_DataBuffer &bytes) const | AP4_StringMetaDataValue | [virtual]
ToInteger() const | AP4_StringMetaDataValue | [virtual]
ToString() const | AP4_StringMetaDataValue | [virtual]
Type enum name | AP4_MetaData::Value |
TYPE_BINARY enum value | AP4_MetaData::Value |
TYPE_CATEGORY_BINARY enum value | AP4_MetaData::Value |
TYPE_CATEGORY_FLOAT enum value | AP4_MetaData::Value |
TYPE_CATEGORY_INTEGER enum value | AP4_MetaData::Value |
TYPE_CATEGORY_STRING enum value | AP4_MetaData::Value |
TYPE_FLOAT_32_BE enum value | AP4_MetaData::Value |
TYPE_FLOAT_64_BE enum value | AP4_MetaData::Value |
TYPE_GIF enum value | AP4_MetaData::Value |
TYPE_INT_08_BE enum value | AP4_MetaData::Value |
TYPE_INT_16_BE enum value | AP4_MetaData::Value |
TYPE_INT_32_BE enum value | AP4_MetaData::Value |
TYPE_JPEG enum value | AP4_MetaData::Value |
TYPE_STRING_PASCAL enum value | AP4_MetaData::Value |
TYPE_STRING_UTF_16 enum value | AP4_MetaData::Value |
TYPE_STRING_UTF_8 enum value | AP4_MetaData::Value |
TypeCategory enum name | AP4_MetaData::Value |
Value(Type type, Meaning meaning=MEANING_UNKNOWN, const char *language=NULL) | AP4_MetaData::Value | [inline, protected]
~Value() | AP4_MetaData::Value | [inline, virtual]
Generated on Thu May 13 16:37:51 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_StscAtom Class Reference

AP4_StscAtom Class Reference

#include <Ap4StscAtom.h>

Inheritance diagram for AP4_StscAtom:
AP4_Atom

List of all members.

Public Member Functions

AP4_StscAtom ()
virtual AP4_Result | InspectFields (AP4_AtomInspector &inspector)
virtual AP4_Result | GetChunkForSample (AP4_Ordinal sample, AP4_Ordinal &chunk, AP4_Ordinal &skip, AP4_Ordinal &sample_description_index)
virtual AP4_Result | AddEntry (AP4_Cardinal chunk_count, AP4_Cardinal samples_per_chunk, AP4_Ordinal sample_description_index)
virtual AP4_Result | WriteFields (AP4_ByteStream &stream)

Static Public Member Functions

static AP4_StscAtom * | Create (AP4_Size size, AP4_ByteStream &stream)

Detailed Description

Definition at line 79 of file Ap4StscAtom.h.

Constructor & Destructor Documentation

AP4_StscAtom::AP4_StscAtom ( )

Member Function Documentation

virtual AP4_Result AP4_StscAtom::AddEntry | ( | AP4_Cardinal | chunk_count,
 |  | AP4_Cardinal | samples_per_chunk,
 |  | AP4_Ordinal | sample_description_index |
 | ) |  |  | [virtual]
static AP4_StscAtom* AP4_StscAtom::Create | ( | AP4_Size | size,
 |  | AP4_ByteStream & | stream |
 | ) |  |  | [static]
virtual AP4_Result AP4_StscAtom::GetChunkForSample | ( | AP4_Ordinal | sample,
 |  | AP4_Ordinal & | chunk,
 |  | AP4_Ordinal & | skip,
 |  | AP4_Ordinal & | sample_description_index |
 | ) |  |  | [virtual]
virtual AP4_Result AP4_StscAtom::InspectFields ( AP4_AtomInspector & inspector ) [virtual]

Reimplemented from AP4_Atom.

virtual AP4_Result AP4_StscAtom::WriteFields ( AP4_ByteStream & stream ) [virtual]

Implements AP4_Atom.

The documentation for this class was generated from the following file:
  • Ap4StscAtom.h
Generated on Thu May 13 16:37:51 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_StscAtom Member List

This is the complete list of members for AP4_StscAtom, including all inherited members.
AddEntry(AP4_Cardinal chunk_count, AP4_Cardinal samples_per_chunk, AP4_Ordinal sample_description_index) | AP4_StscAtom | [virtual]
AP4_Atom(Type type, AP4_UI32 size=AP4_ATOM_HEADER_SIZE) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64=false) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_StscAtom() | AP4_StscAtom |
Clone() | AP4_Atom | [virtual]
Create(AP4_Size size, AP4_ByteStream &stream) | AP4_StscAtom | [static]
Detach() | AP4_Atom | [virtual]
GetChunkForSample(AP4_Ordinal sample, AP4_Ordinal &chunk, AP4_Ordinal &skip, AP4_Ordinal &sample_description_index) | AP4_StscAtom | [virtual]
GetFlags() const | AP4_Atom | [inline]
GetHeaderSize() const | AP4_Atom | [virtual]
GetParent() | AP4_Atom | [inline, virtual]
GetSize() const | AP4_Atom | [inline]
GetSize32() const | AP4_Atom | [inline]
GetSize64() const | AP4_Atom | [inline]
GetType() const | AP4_Atom | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
InspectFields(AP4_AtomInspector &inspector) | AP4_StscAtom | [virtual]
InspectHeader(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
m_Flags | AP4_Atom | [protected]
m_IsFull | AP4_Atom | [protected]
m_Parent | AP4_Atom | [protected]
m_Size32 | AP4_Atom | [protected]
m_Size64 | AP4_Atom | [protected]
m_Type | AP4_Atom | [protected]
m_Version | AP4_Atom | [protected]
ReadFullHeader(AP4_ByteStream &stream, AP4_UI32 &version, AP4_UI32 &flags) | AP4_Atom | [static]
SetFlags(AP4_UI32 flags) | AP4_Atom | [inline]
SetParent(AP4_AtomParent *parent) | AP4_Atom | [inline, virtual]
SetSize(AP4_UI64 size, bool force_64=false) | AP4_Atom |
SetSize32(AP4_UI32 size) | AP4_Atom | [inline]
SetSize64(AP4_UI64 size) | AP4_Atom | [inline]
SetType(Type type) | AP4_Atom | [inline]
Type typedef | AP4_Atom |
TypeFromString(const char *four_cc) | AP4_Atom | [static]
Write(AP4_ByteStream &stream) | AP4_Atom | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_StscAtom | [virtual]
WriteHeader(AP4_ByteStream &stream) | AP4_Atom | [virtual]
~AP4_Atom() | AP4_Atom | [inline, virtual]
Generated on Thu May 13 16:37:51 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_StscTableEntry Class Reference

AP4_StscTableEntry Class Reference

#include <Ap4StscAtom.h>

List of all members.

Public Member Functions

AP4_StscTableEntry ()
AP4_StscTableEntry (AP4_Ordinal first_chunk, AP4_Ordinal first_sample, AP4_Cardinal samples_per_chunk, AP4_Ordinal sample_description_index)
AP4_StscTableEntry (AP4_Ordinal first_chunk, AP4_Ordinal first_sample, AP4_Cardinal chunk_count, AP4_Cardinal samples_per_chunk, AP4_Ordinal sample_description_index)

Public Attributes

AP4_Ordinal m_FirstChunk
AP4_Ordinal m_FirstSample
AP4_Cardinal m_ChunkCount
AP4_Cardinal m_SamplesPerChunk
AP4_Ordinal m_SampleDescriptionIndex

Detailed Description

Definition at line 42 of file Ap4StscAtom.h.

Constructor & Destructor Documentation

AP4_StscTableEntry::AP4_StscTableEntry ( ) [inline]

Definition at line 44 of file Ap4StscAtom.h.

AP4_StscTableEntry::AP4_StscTableEntry | ( | AP4_Ordinal | first_chunk,
 |  | AP4_Ordinal | first_sample,
 |  | AP4_Cardinal | samples_per_chunk,
 |  | AP4_Ordinal | sample_description_index |
 | ) |  |  | [inline]

Definition at line 50 of file Ap4StscAtom.h.

AP4_StscTableEntry::AP4_StscTableEntry | ( | AP4_Ordinal | first_chunk,
 |  | AP4_Ordinal | first_sample,
 |  | AP4_Cardinal | chunk_count,
 |  | AP4_Cardinal | samples_per_chunk,
 |  | AP4_Ordinal | sample_description_index |
 | ) |  |  | [inline]

Definition at line 59 of file Ap4StscAtom.h.

Member Data Documentation

AP4_Cardinal AP4_StscTableEntry::m_ChunkCount

Definition at line 71 of file Ap4StscAtom.h.

AP4_Ordinal AP4_StscTableEntry::m_FirstChunk

Definition at line 69 of file Ap4StscAtom.h.

AP4_Ordinal AP4_StscTableEntry::m_FirstSample

Definition at line 70 of file Ap4StscAtom.h.

AP4_Ordinal AP4_StscTableEntry::m_SampleDescriptionIndex

Definition at line 73 of file Ap4StscAtom.h.

AP4_Cardinal AP4_StscTableEntry::m_SamplesPerChunk

Definition at line 72 of file Ap4StscAtom.h.

The documentation for this class was generated from the following file:
  • Ap4StscAtom.h
Generated on Thu May 13 16:37:51 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_StscTableEntry Member List

This is the complete list of members for AP4_StscTableEntry, including all inherited members.
AP4_StscTableEntry() | AP4_StscTableEntry | [inline]
AP4_StscTableEntry(AP4_Ordinal first_chunk, AP4_Ordinal first_sample, AP4_Cardinal samples_per_chunk, AP4_Ordinal sample_description_index) | AP4_StscTableEntry | [inline]
AP4_StscTableEntry(AP4_Ordinal first_chunk, AP4_Ordinal first_sample, AP4_Cardinal chunk_count, AP4_Cardinal samples_per_chunk, AP4_Ordinal sample_description_index) | AP4_StscTableEntry | [inline]
m_ChunkCount | AP4_StscTableEntry |
m_FirstChunk | AP4_StscTableEntry |
m_FirstSample | AP4_StscTableEntry |
m_SampleDescriptionIndex | AP4_StscTableEntry |
m_SamplesPerChunk | AP4_StscTableEntry |
Generated on Thu May 13 16:37:51 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_StsdAtom Class Reference

AP4_StsdAtom Class Reference

#include <Ap4StsdAtom.h>

Inheritance diagram for AP4_StsdAtom:
AP4_ContainerAtom AP4_Atom AP4_AtomParent

List of all members.

Public Member Functions

AP4_StsdAtom (AP4_SampleTable *sample_table)
~AP4_StsdAtom ()
virtual AP4_Result | InspectFields (AP4_AtomInspector &inspector)
virtual AP4_Result | WriteFields (AP4_ByteStream &stream)
virtual AP4_Cardinal | GetSampleDescriptionCount ()
virtual AP4_SampleDescription * | GetSampleDescription (AP4_Ordinal index)
virtual AP4_SampleEntry * | GetSampleEntry (AP4_Ordinal index)
void | OnChildChanged (AP4_Atom *child)

Static Public Member Functions

static AP4_StsdAtom * | Create (AP4_Size size, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory)

Detailed Description

Definition at line 49 of file Ap4StsdAtom.h.

Constructor & Destructor Documentation

AP4_StsdAtom::AP4_StsdAtom ( AP4_SampleTable * sample_table )
AP4_StsdAtom::~AP4_StsdAtom ( )

Member Function Documentation

static AP4_StsdAtom* AP4_StsdAtom::Create | ( | AP4_Size | size,
 |  | AP4_ByteStream & | stream,
 |  | AP4_AtomFactory & | atom_factory |
 | ) |  |  | [static]
virtual AP4_SampleDescription* AP4_StsdAtom::GetSampleDescription ( AP4_Ordinal index ) [virtual]
virtual AP4_Cardinal AP4_StsdAtom::GetSampleDescriptionCount ( ) [virtual]
virtual AP4_SampleEntry* AP4_StsdAtom::GetSampleEntry ( AP4_Ordinal index ) [virtual]
virtual AP4_Result AP4_StsdAtom::InspectFields ( AP4_AtomInspector & inspector ) [virtual]

Reimplemented from AP4_ContainerAtom.

void AP4_StsdAtom::OnChildChanged ( AP4_Atom * child ) [virtual]

Reimplemented from AP4_ContainerAtom.

virtual AP4_Result AP4_StsdAtom::WriteFields ( AP4_ByteStream & stream ) [virtual]

Reimplemented from AP4_ContainerAtom.

The documentation for this class was generated from the following file:
  • Ap4StsdAtom.h
Generated on Thu May 13 16:37:51 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_StsdAtom Member List

This is the complete list of members for AP4_StsdAtom, including all inherited members.
AddChild(AP4_Atom *child, int position=-1) | AP4_AtomParent | [virtual]
AP4_Atom(Type type, AP4_UI32 size=AP4_ATOM_HEADER_SIZE) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64=false) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_ContainerAtom(Type type) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI32 version, AP4_UI32 flags) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_ContainerAtom | [protected]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_ContainerAtom | [protected]
AP4_StsdAtom(AP4_SampleTable *sample_table) | AP4_StsdAtom |
Clone() | AP4_ContainerAtom | [virtual]
Create(AP4_Size size, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_StsdAtom | [static]
AP4_ContainerAtom::Create(Type type, AP4_UI64 size, bool is_full, bool force_64, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_ContainerAtom | [static]
DeleteChild(AP4_Atom::Type type, AP4_Ordinal index=0) | AP4_AtomParent | [virtual]
Detach() | AP4_Atom | [virtual]
FindChild(const char *path, bool auto_create=false, bool auto_create_full=false) | AP4_AtomParent | [virtual]
GetChild(AP4_Atom::Type type, AP4_Ordinal index=0) const | AP4_AtomParent | [virtual]
GetChild(const AP4_UI08 *uuid, AP4_Ordinal index=0) const | AP4_AtomParent | [virtual]
GetChildren() | AP4_ContainerAtom | [inline]
GetFlags() const | AP4_Atom | [inline]
GetHeaderSize() const | AP4_Atom | [virtual]
GetParent() | AP4_Atom | [inline, virtual]
GetSampleDescription(AP4_Ordinal index) | AP4_StsdAtom | [virtual]
GetSampleDescriptionCount() | AP4_StsdAtom | [virtual]
GetSampleEntry(AP4_Ordinal index) | AP4_StsdAtom | [virtual]
GetSize() const | AP4_Atom | [inline]
GetSize32() const | AP4_Atom | [inline]
GetSize64() const | AP4_Atom | [inline]
GetType() const | AP4_Atom | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
InspectChildren(AP4_AtomInspector &inspector) | AP4_ContainerAtom | [virtual]
InspectFields(AP4_AtomInspector &inspector) | AP4_StsdAtom | [virtual]
InspectHeader(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
m_Children | AP4_AtomParent | [protected]
m_Flags | AP4_Atom | [protected]
m_IsFull | AP4_Atom | [protected]
m_Parent | AP4_Atom | [protected]
m_Size32 | AP4_Atom | [protected]
m_Size64 | AP4_Atom | [protected]
m_Type | AP4_Atom | [protected]
m_Version | AP4_Atom | [protected]
OnChildAdded(AP4_Atom *child) | AP4_ContainerAtom | [virtual]
OnChildChanged(AP4_Atom *child) | AP4_StsdAtom | [virtual]
OnChildRemoved(AP4_Atom *child) | AP4_ContainerAtom | [virtual]
ReadChildren(AP4_AtomFactory &atom_factory, AP4_ByteStream &stream, AP4_UI64 size) | AP4_ContainerAtom | [protected]
ReadFullHeader(AP4_ByteStream &stream, AP4_UI32 &version, AP4_UI32 &flags) | AP4_Atom | [static]
RemoveChild(AP4_Atom *child) | AP4_AtomParent | [virtual]
SetFlags(AP4_UI32 flags) | AP4_Atom | [inline]
SetParent(AP4_AtomParent *parent) | AP4_Atom | [inline, virtual]
SetSize(AP4_UI64 size, bool force_64=false) | AP4_Atom |
SetSize32(AP4_UI32 size) | AP4_Atom | [inline]
SetSize64(AP4_UI64 size) | AP4_Atom | [inline]
SetType(Type type) | AP4_Atom | [inline]
Type typedef | AP4_Atom |
TypeFromString(const char *four_cc) | AP4_Atom | [static]
Write(AP4_ByteStream &stream) | AP4_Atom | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_StsdAtom | [virtual]
WriteHeader(AP4_ByteStream &stream) | AP4_Atom | [virtual]
~AP4_Atom() | AP4_Atom | [inline, virtual]
~AP4_AtomParent() | AP4_AtomParent | [virtual]
~AP4_StsdAtom() | AP4_StsdAtom |
Generated on Thu May 13 16:37:51 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_StssAtom Class Reference

AP4_StssAtom Class Reference

#include <Ap4StssAtom.h>

Inheritance diagram for AP4_StssAtom:
AP4_Atom

List of all members.

Public Member Functions

AP4_StssAtom ()
const AP4_Array< AP4_UI32 > & | GetEntries ()
AP4_Result | AddEntry (AP4_UI32 sample)
virtual AP4_Result | InspectFields (AP4_AtomInspector &inspector)
virtual bool | IsSampleSync (AP4_Ordinal sample)
virtual AP4_Result | WriteFields (AP4_ByteStream &stream)

Static Public Member Functions

static AP4_StssAtom * | Create (AP4_Size size, AP4_ByteStream &stream)

Detailed Description

Definition at line 41 of file Ap4StssAtom.h.

Constructor & Destructor Documentation

AP4_StssAtom::AP4_StssAtom ( )

Member Function Documentation

AP4_Result AP4_StssAtom::AddEntry ( AP4_UI32 sample )
static AP4_StssAtom* AP4_StssAtom::Create | ( | AP4_Size | size,
 |  | AP4_ByteStream & | stream |
 | ) |  |  | [static]
const AP4_Array<AP4_UI32>& AP4_StssAtom::GetEntries ( ) [inline]

Definition at line 54 of file Ap4StssAtom.h.

virtual AP4_Result AP4_StssAtom::InspectFields ( AP4_AtomInspector & inspector ) [virtual]

Reimplemented from AP4_Atom.

virtual bool AP4_StssAtom::IsSampleSync ( AP4_Ordinal sample ) [virtual]
virtual AP4_Result AP4_StssAtom::WriteFields ( AP4_ByteStream & stream ) [virtual]

Implements AP4_Atom.

The documentation for this class was generated from the following file:
  • Ap4StssAtom.h
Generated on Thu May 13 16:37:51 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_StssAtom Member List

This is the complete list of members for AP4_StssAtom, including all inherited members.
AddEntry(AP4_UI32 sample) | AP4_StssAtom |
AP4_Atom(Type type, AP4_UI32 size=AP4_ATOM_HEADER_SIZE) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64=false) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_StssAtom() | AP4_StssAtom |
Clone() | AP4_Atom | [virtual]
Create(AP4_Size size, AP4_ByteStream &stream) | AP4_StssAtom | [static]
Detach() | AP4_Atom | [virtual]
GetEntries() | AP4_StssAtom | [inline]
GetFlags() const | AP4_Atom | [inline]
GetHeaderSize() const | AP4_Atom | [virtual]
GetParent() | AP4_Atom | [inline, virtual]
GetSize() const | AP4_Atom | [inline]
GetSize32() const | AP4_Atom | [inline]
GetSize64() const | AP4_Atom | [inline]
GetType() const | AP4_Atom | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
InspectFields(AP4_AtomInspector &inspector) | AP4_StssAtom | [virtual]
InspectHeader(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
IsSampleSync(AP4_Ordinal sample) | AP4_StssAtom | [virtual]
m_Flags | AP4_Atom | [protected]
m_IsFull | AP4_Atom | [protected]
m_Parent | AP4_Atom | [protected]
m_Size32 | AP4_Atom | [protected]
m_Size64 | AP4_Atom | [protected]
m_Type | AP4_Atom | [protected]
m_Version | AP4_Atom | [protected]
ReadFullHeader(AP4_ByteStream &stream, AP4_UI32 &version, AP4_UI32 &flags) | AP4_Atom | [static]
SetFlags(AP4_UI32 flags) | AP4_Atom | [inline]
SetParent(AP4_AtomParent *parent) | AP4_Atom | [inline, virtual]
SetSize(AP4_UI64 size, bool force_64=false) | AP4_Atom |
SetSize32(AP4_UI32 size) | AP4_Atom | [inline]
SetSize64(AP4_UI64 size) | AP4_Atom | [inline]
SetType(Type type) | AP4_Atom | [inline]
Type typedef | AP4_Atom |
TypeFromString(const char *four_cc) | AP4_Atom | [static]
Write(AP4_ByteStream &stream) | AP4_Atom | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_StssAtom | [virtual]
WriteHeader(AP4_ByteStream &stream) | AP4_Atom | [virtual]
~AP4_Atom() | AP4_Atom | [inline, virtual]
Generated on Thu May 13 16:37:51 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_StszAtom Class Reference

AP4_StszAtom Class Reference

#include <Ap4StszAtom.h>

Inheritance diagram for AP4_StszAtom:
AP4_Atom

List of all members.

Public Member Functions

AP4_StszAtom ()
virtual AP4_Result | InspectFields (AP4_AtomInspector &inspector)
virtual AP4_Result | WriteFields (AP4_ByteStream &stream)
virtual AP4_UI32 | GetSampleCount ()
virtual AP4_Result | GetSampleSize (AP4_Ordinal sample, AP4_Size &sample_size)
virtual AP4_Result | SetSampleSize (AP4_Ordinal sample, AP4_Size sample_size)
Set the sample size.
virtual AP4_Result | AddEntry (AP4_UI32 size)

Static Public Member Functions

static AP4_StszAtom * | Create (AP4_Size size, AP4_ByteStream &stream)

Detailed Description

Definition at line 41 of file Ap4StszAtom.h.

Constructor & Destructor Documentation

AP4_StszAtom::AP4_StszAtom ( )

Member Function Documentation

virtual AP4_Result AP4_StszAtom::AddEntry ( AP4_UI32 size ) [virtual]
static AP4_StszAtom* AP4_StszAtom::Create | ( | AP4_Size | size,
 |  | AP4_ByteStream & | stream |
 | ) |  |  | [static]
virtual AP4_UI32 AP4_StszAtom::GetSampleCount ( ) [virtual]
virtual AP4_Result AP4_StszAtom::GetSampleSize | ( | AP4_Ordinal | sample,
 |  | AP4_Size & | sample_size |
 | ) |  |  | [virtual]
virtual AP4_Result AP4_StszAtom::InspectFields ( AP4_AtomInspector & inspector ) [virtual]

Reimplemented from AP4_Atom.

virtual AP4_Result AP4_StszAtom::SetSampleSize | ( | AP4_Ordinal | sample,
 |  | AP4_Size | sample_size |
 | ) |  |  | [virtual]

Set the sample size.

Parameters:
sample | 1-based index of a sample.
sample_size | Size of the sample. If this table represents a global-size table (one where there are no individual entries for each sample, but all sample have the same size = m_SampleSize), then calling this method with sample=1 will update the global size, and calling with sample>1 will check that the value of sample_size is the same as the global size m_SampleSize.
virtual AP4_Result AP4_StszAtom::WriteFields ( AP4_ByteStream & stream ) [virtual]

Implements AP4_Atom.

The documentation for this class was generated from the following file:
  • Ap4StszAtom.h
Generated on Thu May 13 16:37:51 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_StszAtom Member List

This is the complete list of members for AP4_StszAtom, including all inherited members.
AddEntry(AP4_UI32 size) | AP4_StszAtom | [virtual]
AP4_Atom(Type type, AP4_UI32 size=AP4_ATOM_HEADER_SIZE) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64=false) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_StszAtom() | AP4_StszAtom |
Clone() | AP4_Atom | [virtual]
Create(AP4_Size size, AP4_ByteStream &stream) | AP4_StszAtom | [static]
Detach() | AP4_Atom | [virtual]
GetFlags() const | AP4_Atom | [inline]
GetHeaderSize() const | AP4_Atom | [virtual]
GetParent() | AP4_Atom | [inline, virtual]
GetSampleCount() | AP4_StszAtom | [virtual]
GetSampleSize(AP4_Ordinal sample, AP4_Size &sample_size) | AP4_StszAtom | [virtual]
GetSize() const | AP4_Atom | [inline]
GetSize32() const | AP4_Atom | [inline]
GetSize64() const | AP4_Atom | [inline]
GetType() const | AP4_Atom | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
InspectFields(AP4_AtomInspector &inspector) | AP4_StszAtom | [virtual]
InspectHeader(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
m_Flags | AP4_Atom | [protected]
m_IsFull | AP4_Atom | [protected]
m_Parent | AP4_Atom | [protected]
m_Size32 | AP4_Atom | [protected]
m_Size64 | AP4_Atom | [protected]
m_Type | AP4_Atom | [protected]
m_Version | AP4_Atom | [protected]
ReadFullHeader(AP4_ByteStream &stream, AP4_UI32 &version, AP4_UI32 &flags) | AP4_Atom | [static]
SetFlags(AP4_UI32 flags) | AP4_Atom | [inline]
SetParent(AP4_AtomParent *parent) | AP4_Atom | [inline, virtual]
SetSampleSize(AP4_Ordinal sample, AP4_Size sample_size) | AP4_StszAtom | [virtual]
SetSize(AP4_UI64 size, bool force_64=false) | AP4_Atom |
SetSize32(AP4_UI32 size) | AP4_Atom | [inline]
SetSize64(AP4_UI64 size) | AP4_Atom | [inline]
SetType(Type type) | AP4_Atom | [inline]
Type typedef | AP4_Atom |
TypeFromString(const char *four_cc) | AP4_Atom | [static]
Write(AP4_ByteStream &stream) | AP4_Atom | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_StszAtom | [virtual]
WriteHeader(AP4_ByteStream &stream) | AP4_Atom | [virtual]
~AP4_Atom() | AP4_Atom | [inline, virtual]
Generated on Thu May 13 16:37:51 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_SttsAtom Class Reference

AP4_SttsAtom Class Reference

#include <Ap4SttsAtom.h>

Inheritance diagram for AP4_SttsAtom:
AP4_Atom

List of all members.

Public Member Functions

AP4_SttsAtom ()
virtual AP4_Result | InspectFields (AP4_AtomInspector &inspector)
virtual AP4_Result | GetDts (AP4_Ordinal sample, AP4_UI64 &dts, AP4_UI32 *duration=NULL)
virtual AP4_Result | AddEntry (AP4_UI32 sample_count, AP4_UI32 sample_duration)
virtual AP4_Result | GetSampleIndexForTimeStamp (AP4_UI64 ts, AP4_Ordinal &sample_index)
virtual AP4_Result | WriteFields (AP4_ByteStream &stream)

Static Public Member Functions

static AP4_SttsAtom * | Create (AP4_Size size, AP4_ByteStream &stream)

Detailed Description

Definition at line 58 of file Ap4SttsAtom.h.

Constructor & Destructor Documentation

AP4_SttsAtom::AP4_SttsAtom ( )

Member Function Documentation

virtual AP4_Result AP4_SttsAtom::AddEntry | ( | AP4_UI32 | sample_count,
 |  | AP4_UI32 | sample_duration |
 | ) |  |  | [virtual]
static AP4_SttsAtom* AP4_SttsAtom::Create | ( | AP4_Size | size,
 |  | AP4_ByteStream & | stream |
 | ) |  |  | [static]
virtual AP4_Result AP4_SttsAtom::GetDts | ( | AP4_Ordinal | sample,
 |  | AP4_UI64 & | dts,
 |  | AP4_UI32 * | duration = NULL |
 | ) |  |  | [virtual]
virtual AP4_Result AP4_SttsAtom::GetSampleIndexForTimeStamp | ( | AP4_UI64 | ts,
 |  | AP4_Ordinal & | sample_index |
 | ) |  |  | [virtual]
virtual AP4_Result AP4_SttsAtom::InspectFields ( AP4_AtomInspector & inspector ) [virtual]

Reimplemented from AP4_Atom.

virtual AP4_Result AP4_SttsAtom::WriteFields ( AP4_ByteStream & stream ) [virtual]

Implements AP4_Atom.

Member Data Documentation

AP4_UI64 AP4_SttsAtom::dts

Definition at line 87 of file Ap4SttsAtom.h.

AP4_Ordinal AP4_SttsAtom::entry_index

Definition at line 85 of file Ap4SttsAtom.h.

AP4_Ordinal AP4_SttsAtom::sample

Definition at line 86 of file Ap4SttsAtom.h.

The documentation for this class was generated from the following file:
  • Ap4SttsAtom.h
Generated on Thu May 13 16:37:51 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_SttsAtom Member List

This is the complete list of members for AP4_SttsAtom, including all inherited members.
AddEntry(AP4_UI32 sample_count, AP4_UI32 sample_duration) | AP4_SttsAtom | [virtual]
AP4_Atom(Type type, AP4_UI32 size=AP4_ATOM_HEADER_SIZE) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64=false) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_SttsAtom() | AP4_SttsAtom |
Clone() | AP4_Atom | [virtual]
Create(AP4_Size size, AP4_ByteStream &stream) | AP4_SttsAtom | [static]
Detach() | AP4_Atom | [virtual]
dts | AP4_SttsAtom |
entry_index | AP4_SttsAtom |
GetDts(AP4_Ordinal sample, AP4_UI64 &dts, AP4_UI32 *duration=NULL) | AP4_SttsAtom | [virtual]
GetFlags() const | AP4_Atom | [inline]
GetHeaderSize() const | AP4_Atom | [virtual]
GetParent() | AP4_Atom | [inline, virtual]
GetSampleIndexForTimeStamp(AP4_UI64 ts, AP4_Ordinal &sample_index) | AP4_SttsAtom | [virtual]
GetSize() const | AP4_Atom | [inline]
GetSize32() const | AP4_Atom | [inline]
GetSize64() const | AP4_Atom | [inline]
GetType() const | AP4_Atom | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
InspectFields(AP4_AtomInspector &inspector) | AP4_SttsAtom | [virtual]
InspectHeader(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
m_Flags | AP4_Atom | [protected]
m_IsFull | AP4_Atom | [protected]
m_Parent | AP4_Atom | [protected]
m_Size32 | AP4_Atom | [protected]
m_Size64 | AP4_Atom | [protected]
m_Type | AP4_Atom | [protected]
m_Version | AP4_Atom | [protected]
ReadFullHeader(AP4_ByteStream &stream, AP4_UI32 &version, AP4_UI32 &flags) | AP4_Atom | [static]
sample | AP4_SttsAtom |
SetFlags(AP4_UI32 flags) | AP4_Atom | [inline]
SetParent(AP4_AtomParent *parent) | AP4_Atom | [inline, virtual]
SetSize(AP4_UI64 size, bool force_64=false) | AP4_Atom |
SetSize32(AP4_UI32 size) | AP4_Atom | [inline]
SetSize64(AP4_UI64 size) | AP4_Atom | [inline]
SetType(Type type) | AP4_Atom | [inline]
Type typedef | AP4_Atom |
TypeFromString(const char *four_cc) | AP4_Atom | [static]
Write(AP4_ByteStream &stream) | AP4_Atom | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_SttsAtom | [virtual]
WriteHeader(AP4_ByteStream &stream) | AP4_Atom | [virtual]
~AP4_Atom() | AP4_Atom | [inline, virtual]
Generated on Thu May 13 16:37:51 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_SttsTableEntry Class Reference

AP4_SttsTableEntry Class Reference

#include <Ap4SttsAtom.h>

List of all members.

Public Member Functions

AP4_SttsTableEntry ()
AP4_SttsTableEntry (AP4_UI32 sample_count, AP4_UI32 sample_duration)

Public Attributes

AP4_UI32 m_SampleCount
AP4_UI32 m_SampleDuration

Detailed Description

Definition at line 41 of file Ap4SttsAtom.h.

Constructor & Destructor Documentation

AP4_SttsTableEntry::AP4_SttsTableEntry ( ) [inline]

Definition at line 43 of file Ap4SttsAtom.h.

AP4_SttsTableEntry::AP4_SttsTableEntry | ( | AP4_UI32 | sample_count,
 |  | AP4_UI32 | sample_duration |
 | ) |  |  | [inline]

Definition at line 46 of file Ap4SttsAtom.h.

Member Data Documentation

AP4_UI32 AP4_SttsTableEntry::m_SampleCount

Definition at line 51 of file Ap4SttsAtom.h.

AP4_UI32 AP4_SttsTableEntry::m_SampleDuration

Definition at line 52 of file Ap4SttsAtom.h.

The documentation for this class was generated from the following file:
  • Ap4SttsAtom.h
Generated on Thu May 13 16:37:51 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_SttsTableEntry Member List

This is the complete list of members for AP4_SttsTableEntry, including all inherited members.
AP4_SttsTableEntry() | AP4_SttsTableEntry | [inline]
AP4_SttsTableEntry(AP4_UI32 sample_count, AP4_UI32 sample_duration) | AP4_SttsTableEntry | [inline]
m_SampleCount | AP4_SttsTableEntry |
m_SampleDuration | AP4_SttsTableEntry |
Generated on Thu May 13 16:37:51 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_SubStream Class Reference

AP4_SubStream Class Reference

#include <Ap4ByteStream.h>

Inheritance diagram for AP4_SubStream:
AP4_ByteStream AP4_Referenceable

List of all members.

Public Member Functions

AP4_SubStream (AP4_ByteStream &container, AP4_Position position, AP4_LargeSize size)
AP4_Result | ReadPartial (void *buffer, AP4_Size bytes_to_read, AP4_Size &bytes_read)
AP4_Result | WritePartial (const void *buffer, AP4_Size bytes_to_write, AP4_Size &bytes_written)
AP4_Result | Seek (AP4_Position position)
AP4_Result | Tell (AP4_Position &position)
AP4_Result | GetSize (AP4_LargeSize &size)
void | AddReference ()
void | Release ()

Protected Member Functions

virtual | ~AP4_SubStream ()

Detailed Description

Definition at line 79 of file Ap4ByteStream.h.

Constructor & Destructor Documentation

AP4_SubStream::AP4_SubStream | ( | AP4_ByteStream & | container,
 |  | AP4_Position | position,
 |  | AP4_LargeSize | size
 | ) |  |
virtual AP4_SubStream::~AP4_SubStream ( ) [protected, virtual]

Member Function Documentation

void AP4_SubStream::AddReference ( ) [virtual]

Implements AP4_Referenceable.

AP4_Result AP4_SubStream::GetSize ( AP4_LargeSize & size ) [inline, virtual]

Implements AP4_ByteStream.

Definition at line 98 of file Ap4ByteStream.h.

References AP4_SUCCESS.

AP4_Result AP4_SubStream::ReadPartial | ( | void * | buffer,
 |  | AP4_Size | bytes_to_read,
 |  | AP4_Size & | bytes_read |
 | ) |  |  | [virtual]

Implements AP4_ByteStream.

void AP4_SubStream::Release ( ) [virtual]

Implements AP4_Referenceable.

AP4_Result AP4_SubStream::Seek ( AP4_Position position ) [virtual]

Implements AP4_ByteStream.

AP4_Result AP4_SubStream::Tell ( AP4_Position & position ) [inline, virtual]

Implements AP4_ByteStream.

Definition at line 94 of file Ap4ByteStream.h.

References AP4_SUCCESS.

AP4_Result AP4_SubStream::WritePartial | ( | const void * | buffer,
 |  | AP4_Size | bytes_to_write,
 |  | AP4_Size & | bytes_written |
 | ) |  |  | [virtual]

Implements AP4_ByteStream.

The documentation for this class was generated from the following file:
  • Ap4ByteStream.h
Generated on Thu May 13 16:37:52 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_SubStream Member List

This is the complete list of members for AP4_SubStream, including all inherited members.
AddReference() | AP4_SubStream | [virtual]
AP4_SubStream(AP4_ByteStream &container, AP4_Position position, AP4_LargeSize size) | AP4_SubStream |
CopyTo(AP4_ByteStream &stream, AP4_LargeSize size) | AP4_ByteStream | [virtual]
Flush() | AP4_ByteStream | [inline, virtual]
GetSize(AP4_LargeSize &size) | AP4_SubStream | [inline, virtual]
Read(void *buffer, AP4_Size bytes_to_read) | AP4_ByteStream |
ReadDouble(double &value) | AP4_ByteStream |
ReadPartial(void *buffer, AP4_Size bytes_to_read, AP4_Size &bytes_read) | AP4_SubStream | [virtual]
ReadString(char *buffer, AP4_Size size) | AP4_ByteStream |
ReadUI08(AP4_UI08 &value) | AP4_ByteStream |
ReadUI16(AP4_UI16 &value) | AP4_ByteStream |
ReadUI24(AP4_UI32 &value) | AP4_ByteStream |
ReadUI32(AP4_UI32 &value) | AP4_ByteStream |
ReadUI64(AP4_UI64 &value) | AP4_ByteStream |
Release() | AP4_SubStream | [virtual]
Seek(AP4_Position position) | AP4_SubStream | [virtual]
Tell(AP4_Position &position) | AP4_SubStream | [inline, virtual]
Write(const void *buffer, AP4_Size bytes_to_write) | AP4_ByteStream |
WriteDouble(double value) | AP4_ByteStream |
WritePartial(const void *buffer, AP4_Size bytes_to_write, AP4_Size &bytes_written) | AP4_SubStream | [virtual]
WriteString(const char *string_buffer) | AP4_ByteStream |
WriteUI08(AP4_UI08 value) | AP4_ByteStream |
WriteUI16(AP4_UI16 value) | AP4_ByteStream |
WriteUI24(AP4_UI32 value) | AP4_ByteStream |
WriteUI32(AP4_UI32 value) | AP4_ByteStream |
WriteUI64(AP4_UI64 value) | AP4_ByteStream |
~AP4_Referenceable() | AP4_Referenceable | [inline, virtual]
~AP4_SubStream() | AP4_SubStream | [protected, virtual]
Generated on Thu May 13 16:37:52 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_SyntheticSampleTable Class Reference

AP4_SyntheticSampleTable Class Reference

#include <Ap4SyntheticSampleTable.h>

Inheritance diagram for AP4_SyntheticSampleTable:
AP4_SampleTable

List of all members.

Classes

class | SampleDescriptionHolder

Public Member Functions

AP4_SyntheticSampleTable (AP4_Cardinal chunk_size=AP4_SYNTHETIC_SAMPLE_TABLE_DEFAULT_CHUNK_SIZE)
virtual | ~AP4_SyntheticSampleTable ()
virtual AP4_Result | GetSample (AP4_Ordinal index, AP4_Sample &sample)
virtual AP4_Cardinal | GetSampleCount ()
virtual AP4_Result | GetSampleChunkPosition (AP4_Ordinal sample_index, AP4_Ordinal &chunk_index, AP4_Ordinal &position_in_chunk)
virtual AP4_Cardinal | GetSampleDescriptionCount ()
virtual AP4_SampleDescription * | GetSampleDescription (AP4_Ordinal index)
virtual AP4_Result | GetSampleIndexForTimeStamp (AP4_UI64 ts, AP4_Ordinal &index)
virtual AP4_Ordinal | GetNearestSyncSampleIndex (AP4_Ordinal index, bool before)
virtual AP4_Result | AddSampleDescription (AP4_SampleDescription *description, bool transfer_ownership=true)
Add a sample description to the sample table.
virtual AP4_Result | AddSample (AP4_ByteStream &data_stream, AP4_Position offset, AP4_Size size, AP4_UI32 duration, AP4_Ordinal description_index, AP4_UI64 dts, AP4_UI32 cts_delta, bool sync)
Add a sample to the sample table, where the sample duration is given.

Detailed Description

Definition at line 54 of file Ap4SyntheticSampleTable.h.

Constructor & Destructor Documentation

AP4_SyntheticSampleTable::AP4_SyntheticSampleTable ( AP4_Cardinal chunk_size = AP4_SYNTHETIC_SAMPLE_TABLE_DEFAULT_CHUNK_SIZE )
virtual AP4_SyntheticSampleTable::~AP4_SyntheticSampleTable ( ) [virtual]

Member Function Documentation

virtual AP4_Result AP4_SyntheticSampleTable::AddSample | ( | AP4_ByteStream & | data_stream,
 |  | AP4_Position | offset,
 |  | AP4_Size | size,
 |  | AP4_UI32 | duration,
 |  | AP4_Ordinal | description_index,
 |  | AP4_UI64 | dts,
 |  | AP4_UI32 | cts_delta,
 |  | bool | sync |
 | ) |  |  | [virtual]

Add a sample to the sample table, where the sample duration is given.

Parameters:
data_stream | The byte stream that contains the sample data. The sample object added to the track will keep a reference to that byte stream.
offset | Position of the first byte of sample data within the stream
size | Size in bytes of the sample data
duration | Duration of the sample (in the timescale of the media). This value can be 0 if the duration is not known. In that case, the next sample added to the table MUST have a non-zero value for the DTS (decoding timestamp), which will allow the actual duration of this sample to be computed.
description_index | Index of the sample description that applies to this sample (typically 0).
dts | DTS (decoding timestamp) of the sample. If this value is 0, and there already are samples in the table, the DTS of the sample will be automatically computed based on the DTS and duration of the preceding sample. If this value is not equal to the DTS+duration of the preceding sample, the duration of the preceding sample is automatically adjusted, unless it has a non-zero value, in which case AP4_ERROR_INVALID_PARAMETERS is returned. The DTS of the first sample in the table MUST always be 0.
cts_delta | Difference between the CTS (composition/display timestamp) and DTS (decoding timestamp) of the sample (in the timescale of the media)
sync | Boolean flag indicating whether this is a sync sample or not.
virtual AP4_Result AP4_SyntheticSampleTable::AddSampleDescription | ( | AP4_SampleDescription * | description,
 |  | bool | transfer_ownership = true |
 | ) |  |  | [virtual]

Add a sample description to the sample table.

Each added sample description will have the next available index, starting at 0

Parameters:
description | Pointer to the sample description to add
transfer_ownership | Boolean flag indicating whether the ownership of the sample description object is transfered to the sample table object (true by default). If true, the sample table object will own the sample description object, and will delete it when it is itself deleted. If false, the ownership remains with the caller, and only a referencing pointer is kept, thus the caller must ensure that the object is not deleted before the sample table is deleted.
virtual AP4_Ordinal AP4_SyntheticSampleTable::GetNearestSyncSampleIndex | ( | AP4_Ordinal | index,
 |  | bool | before |
 | ) |  |  | [virtual]

Implements AP4_SampleTable.

virtual AP4_Result AP4_SyntheticSampleTable::GetSample | ( | AP4_Ordinal | index,
 |  | AP4_Sample & | sample |
 | ) |  |  | [virtual]

Implements AP4_SampleTable.

virtual AP4_Result AP4_SyntheticSampleTable::GetSampleChunkPosition | ( | AP4_Ordinal | sample_index,
 |  | AP4_Ordinal & | chunk_index,
 |  | AP4_Ordinal & | position_in_chunk |
 | ) |  |  | [virtual]

Implements AP4_SampleTable.

virtual AP4_Cardinal AP4_SyntheticSampleTable::GetSampleCount ( ) [virtual]

Implements AP4_SampleTable.

virtual AP4_SampleDescription* AP4_SyntheticSampleTable::GetSampleDescription ( AP4_Ordinal index ) [virtual]

Implements AP4_SampleTable.

virtual AP4_Cardinal AP4_SyntheticSampleTable::GetSampleDescriptionCount ( ) [virtual]

Implements AP4_SampleTable.

virtual AP4_Result AP4_SyntheticSampleTable::GetSampleIndexForTimeStamp | ( | AP4_UI64 | ts,
 |  | AP4_Ordinal & | index |
 | ) |  |  | [virtual]

Implements AP4_SampleTable.

Member Data Documentation

AP4_Ordinal AP4_SyntheticSampleTable::m_Chunk

Definition at line 140 of file Ap4SyntheticSampleTable.h.

AP4_Ordinal AP4_SyntheticSampleTable::m_Sample

Definition at line 139 of file Ap4SyntheticSampleTable.h.

The documentation for this class was generated from the following file:
  • Ap4SyntheticSampleTable.h
Generated on Thu May 13 16:37:52 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_SyntheticSampleTable Member List

This is the complete list of members for AP4_SyntheticSampleTable, including all inherited members.
AddSample(AP4_ByteStream &data_stream, AP4_Position offset, AP4_Size size, AP4_UI32 duration, AP4_Ordinal description_index, AP4_UI64 dts, AP4_UI32 cts_delta, bool sync) | AP4_SyntheticSampleTable | [virtual]
AddSampleDescription(AP4_SampleDescription *description, bool transfer_ownership=true) | AP4_SyntheticSampleTable | [virtual]
AP4_SyntheticSampleTable(AP4_Cardinal chunk_size=AP4_SYNTHETIC_SAMPLE_TABLE_DEFAULT_CHUNK_SIZE) | AP4_SyntheticSampleTable |
GenerateStblAtom(AP4_ContainerAtom *&stbl) | AP4_SampleTable | [virtual]
GetNearestSyncSampleIndex(AP4_Ordinal index, bool before) | AP4_SyntheticSampleTable | [virtual]
GetSample(AP4_Ordinal index, AP4_Sample &sample) | AP4_SyntheticSampleTable | [virtual]
GetSampleChunkPosition(AP4_Ordinal sample_index, AP4_Ordinal &chunk_index, AP4_Ordinal &position_in_chunk) | AP4_SyntheticSampleTable | [virtual]
GetSampleCount() | AP4_SyntheticSampleTable | [virtual]
GetSampleDescription(AP4_Ordinal index) | AP4_SyntheticSampleTable | [virtual]
GetSampleDescriptionCount() | AP4_SyntheticSampleTable | [virtual]
GetSampleIndexForTimeStamp(AP4_UI64 ts, AP4_Ordinal &index) | AP4_SyntheticSampleTable | [virtual]
m_Chunk | AP4_SyntheticSampleTable |
m_Sample | AP4_SyntheticSampleTable |
~AP4_SampleTable() | AP4_SampleTable | [inline, virtual]
~AP4_SyntheticSampleTable() | AP4_SyntheticSampleTable | [virtual]
Generated on Thu May 13 16:37:52 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_TfhdAtom Class Reference

AP4_TfhdAtom Class Reference

#include <Ap4TfhdAtom.h>

Inheritance diagram for AP4_TfhdAtom:
AP4_Atom

List of all members.

Public Member Functions

AP4_TfhdAtom (AP4_UI32 flags, AP4_UI32 track_id, AP4_UI64 base_data_offset, AP4_UI32 sample_description_index, AP4_UI32 default_sample_duration, AP4_UI32 default_sample_size, AP4_UI32 default_sample_flags)
virtual AP4_Result | InspectFields (AP4_AtomInspector &inspector)
virtual AP4_Result | WriteFields (AP4_ByteStream &stream)
AP4_UI32 GetTrackId ()
void | SetTrackId (AP4_UI32 track_id)
AP4_UI64 GetBaseDataOffset ()
void | SetBaseDataOffset (AP4_UI64 offset)
AP4_UI32 GetSampleDescriptionIndex ()
void | SetSampleDescriptionIndex (AP4_UI32 indx)
AP4_UI32 GetDefaultSampleDuration ()
void | SetDefaultSampleDuration (AP4_UI32 duration)
AP4_UI32 GetDefaultSampleSize ()
void | SetDefaultSampleSize (AP4_UI32 size)
AP4_UI32 GetDefaultSampleFlags ()
void | SetDefaultSampleFlags (AP4_UI32 flags)

Static Public Member Functions

static AP4_TfhdAtom * | Create (AP4_Size size, AP4_ByteStream &stream)
static AP4_UI32 | ComputeSize (AP4_UI32 flags)

Detailed Description

Definition at line 50 of file Ap4TfhdAtom.h.

Constructor & Destructor Documentation

AP4_TfhdAtom::AP4_TfhdAtom | ( | AP4_UI32 | flags,
 |  | AP4_UI32 | track_id,
 |  | AP4_UI64 | base_data_offset,
 |  | AP4_UI32 | sample_description_index,
 |  | AP4_UI32 | default_sample_duration,
 |  | AP4_UI32 | default_sample_size,
 |  | AP4_UI32 | default_sample_flags
 | ) |  |

Member Function Documentation

static AP4_UI32 AP4_TfhdAtom::ComputeSize ( AP4_UI32 flags ) [static]
static AP4_TfhdAtom* AP4_TfhdAtom::Create | ( | AP4_Size | size,
 |  | AP4_ByteStream & | stream |
 | ) |  |  | [static]
AP4_UI64 AP4_TfhdAtom::GetBaseDataOffset ( ) [inline]

Definition at line 72 of file Ap4TfhdAtom.h.

AP4_UI32 AP4_TfhdAtom::GetDefaultSampleDuration ( ) [inline]

Definition at line 76 of file Ap4TfhdAtom.h.

AP4_UI32 AP4_TfhdAtom::GetDefaultSampleFlags ( ) [inline]

Definition at line 80 of file Ap4TfhdAtom.h.

AP4_UI32 AP4_TfhdAtom::GetDefaultSampleSize ( ) [inline]

Definition at line 78 of file Ap4TfhdAtom.h.

AP4_UI32 AP4_TfhdAtom::GetSampleDescriptionIndex ( ) [inline]

Definition at line 74 of file Ap4TfhdAtom.h.

AP4_UI32 AP4_TfhdAtom::GetTrackId ( ) [inline]

Definition at line 70 of file Ap4TfhdAtom.h.

virtual AP4_Result AP4_TfhdAtom::InspectFields ( AP4_AtomInspector & inspector ) [virtual]

Reimplemented from AP4_Atom.

void AP4_TfhdAtom::SetBaseDataOffset ( AP4_UI64 offset ) [inline]

Definition at line 73 of file Ap4TfhdAtom.h.

void AP4_TfhdAtom::SetDefaultSampleDuration ( AP4_UI32 duration ) [inline]

Definition at line 77 of file Ap4TfhdAtom.h.

void AP4_TfhdAtom::SetDefaultSampleFlags ( AP4_UI32 flags ) [inline]

Definition at line 81 of file Ap4TfhdAtom.h.

void AP4_TfhdAtom::SetDefaultSampleSize ( AP4_UI32 size ) [inline]

Definition at line 79 of file Ap4TfhdAtom.h.

void AP4_TfhdAtom::SetSampleDescriptionIndex ( AP4_UI32 indx ) [inline]

Definition at line 75 of file Ap4TfhdAtom.h.

void AP4_TfhdAtom::SetTrackId ( AP4_UI32 track_id ) [inline]

Definition at line 71 of file Ap4TfhdAtom.h.

virtual AP4_Result AP4_TfhdAtom::WriteFields ( AP4_ByteStream & stream ) [virtual]

Implements AP4_Atom.

The documentation for this class was generated from the following file:
  • Ap4TfhdAtom.h
Generated on Thu May 13 16:37:52 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_TfhdAtom Member List

This is the complete list of members for AP4_TfhdAtom, including all inherited members.
AP4_Atom(Type type, AP4_UI32 size=AP4_ATOM_HEADER_SIZE) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64=false) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_TfhdAtom(AP4_UI32 flags, AP4_UI32 track_id, AP4_UI64 base_data_offset, AP4_UI32 sample_description_index, AP4_UI32 default_sample_duration, AP4_UI32 default_sample_size, AP4_UI32 default_sample_flags) | AP4_TfhdAtom |
Clone() | AP4_Atom | [virtual]
ComputeSize(AP4_UI32 flags) | AP4_TfhdAtom | [static]
Create(AP4_Size size, AP4_ByteStream &stream) | AP4_TfhdAtom | [static]
Detach() | AP4_Atom | [virtual]
GetBaseDataOffset() | AP4_TfhdAtom | [inline]
GetDefaultSampleDuration() | AP4_TfhdAtom | [inline]
GetDefaultSampleFlags() | AP4_TfhdAtom | [inline]
GetDefaultSampleSize() | AP4_TfhdAtom | [inline]
GetFlags() const | AP4_Atom | [inline]
GetHeaderSize() const | AP4_Atom | [virtual]
GetParent() | AP4_Atom | [inline, virtual]
GetSampleDescriptionIndex() | AP4_TfhdAtom | [inline]
GetSize() const | AP4_Atom | [inline]
GetSize32() const | AP4_Atom | [inline]
GetSize64() const | AP4_Atom | [inline]
GetTrackId() | AP4_TfhdAtom | [inline]
GetType() const | AP4_Atom | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
InspectFields(AP4_AtomInspector &inspector) | AP4_TfhdAtom | [virtual]
InspectHeader(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
m_Flags | AP4_Atom | [protected]
m_IsFull | AP4_Atom | [protected]
m_Parent | AP4_Atom | [protected]
m_Size32 | AP4_Atom | [protected]
m_Size64 | AP4_Atom | [protected]
m_Type | AP4_Atom | [protected]
m_Version | AP4_Atom | [protected]
ReadFullHeader(AP4_ByteStream &stream, AP4_UI32 &version, AP4_UI32 &flags) | AP4_Atom | [static]
SetBaseDataOffset(AP4_UI64 offset) | AP4_TfhdAtom | [inline]
SetDefaultSampleDuration(AP4_UI32 duration) | AP4_TfhdAtom | [inline]
SetDefaultSampleFlags(AP4_UI32 flags) | AP4_TfhdAtom | [inline]
SetDefaultSampleSize(AP4_UI32 size) | AP4_TfhdAtom | [inline]
SetFlags(AP4_UI32 flags) | AP4_Atom | [inline]
SetParent(AP4_AtomParent *parent) | AP4_Atom | [inline, virtual]
SetSampleDescriptionIndex(AP4_UI32 indx) | AP4_TfhdAtom | [inline]
SetSize(AP4_UI64 size, bool force_64=false) | AP4_Atom |
SetSize32(AP4_UI32 size) | AP4_Atom | [inline]
SetSize64(AP4_UI64 size) | AP4_Atom | [inline]
SetTrackId(AP4_UI32 track_id) | AP4_TfhdAtom | [inline]
SetType(Type type) | AP4_Atom | [inline]
Type typedef | AP4_Atom |
TypeFromString(const char *four_cc) | AP4_Atom | [static]
Write(AP4_ByteStream &stream) | AP4_Atom | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_TfhdAtom | [virtual]
WriteHeader(AP4_ByteStream &stream) | AP4_Atom | [virtual]
~AP4_Atom() | AP4_Atom | [inline, virtual]
Generated on Thu May 13 16:37:52 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_TfraAtom Class Reference

AP4_TfraAtom Class Reference

#include <Ap4TfraAtom.h>

Inheritance diagram for AP4_TfraAtom:
AP4_Atom

List of all members.

Classes

struct | Entry

Public Member Functions

AP4_TfraAtom ()
virtual AP4_Result | InspectFields (AP4_AtomInspector &inspector)
virtual AP4_Result | WriteFields (AP4_ByteStream &stream)
AP4_Array< Entry > & GetEntries ()

Static Public Member Functions

static AP4_TfraAtom * | Create (AP4_Size size, AP4_ByteStream &stream)

Detailed Description

Definition at line 47 of file Ap4TfraAtom.h.

Constructor & Destructor Documentation

AP4_TfraAtom::AP4_TfraAtom ( )

Member Function Documentation

static AP4_TfraAtom* AP4_TfraAtom::Create | ( | AP4_Size | size,
 |  | AP4_ByteStream & | stream |
 | ) |  |  | [static]
AP4_Array<Entry>& AP4_TfraAtom::GetEntries ( ) [inline]

Definition at line 73 of file Ap4TfraAtom.h.

virtual AP4_Result AP4_TfraAtom::InspectFields ( AP4_AtomInspector & inspector ) [virtual]

Reimplemented from AP4_Atom.

virtual AP4_Result AP4_TfraAtom::WriteFields ( AP4_ByteStream & stream ) [virtual]

Implements AP4_Atom.

The documentation for this class was generated from the following file:
  • Ap4TfraAtom.h
Generated on Thu May 13 16:37:52 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_TfraAtom Member List

This is the complete list of members for AP4_TfraAtom, including all inherited members.
AP4_Atom(Type type, AP4_UI32 size=AP4_ATOM_HEADER_SIZE) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64=false) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_TfraAtom() | AP4_TfraAtom |
Clone() | AP4_Atom | [virtual]
Create(AP4_Size size, AP4_ByteStream &stream) | AP4_TfraAtom | [static]
Detach() | AP4_Atom | [virtual]
GetEntries() | AP4_TfraAtom | [inline]
GetFlags() const | AP4_Atom | [inline]
GetHeaderSize() const | AP4_Atom | [virtual]
GetParent() | AP4_Atom | [inline, virtual]
GetSize() const | AP4_Atom | [inline]
GetSize32() const | AP4_Atom | [inline]
GetSize64() const | AP4_Atom | [inline]
GetType() const | AP4_Atom | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
InspectFields(AP4_AtomInspector &inspector) | AP4_TfraAtom | [virtual]
InspectHeader(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
m_Flags | AP4_Atom | [protected]
m_IsFull | AP4_Atom | [protected]
m_Parent | AP4_Atom | [protected]
m_Size32 | AP4_Atom | [protected]
m_Size64 | AP4_Atom | [protected]
m_Type | AP4_Atom | [protected]
m_Version | AP4_Atom | [protected]
ReadFullHeader(AP4_ByteStream &stream, AP4_UI32 &version, AP4_UI32 &flags) | AP4_Atom | [static]
SetFlags(AP4_UI32 flags) | AP4_Atom | [inline]
SetParent(AP4_AtomParent *parent) | AP4_Atom | [inline, virtual]
SetSize(AP4_UI64 size, bool force_64=false) | AP4_Atom |
SetSize32(AP4_UI32 size) | AP4_Atom | [inline]
SetSize64(AP4_UI64 size) | AP4_Atom | [inline]
SetType(Type type) | AP4_Atom | [inline]
Type typedef | AP4_Atom |
TypeFromString(const char *four_cc) | AP4_Atom | [static]
Write(AP4_ByteStream &stream) | AP4_Atom | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_TfraAtom | [virtual]
WriteHeader(AP4_ByteStream &stream) | AP4_Atom | [virtual]
~AP4_Atom() | AP4_Atom | [inline, virtual]
Generated on Thu May 13 16:37:52 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_TimsAtom Class Reference

AP4_TimsAtom Class Reference

#include <Ap4TimsAtom.h>

Inheritance diagram for AP4_TimsAtom:
AP4_Atom

List of all members.

Public Member Functions

AP4_TimsAtom (AP4_UI32 timescale)
virtual AP4_Result | InspectFields (AP4_AtomInspector &inspector)
virtual AP4_Result | WriteFields (AP4_ByteStream &stream)
virtual AP4_UI32 | GetTimeScale ()

Static Public Member Functions

static AP4_TimsAtom * | Create (AP4_Size size, AP4_ByteStream &stream)

Detailed Description

Definition at line 40 of file Ap4TimsAtom.h.

Constructor & Destructor Documentation

AP4_TimsAtom::AP4_TimsAtom ( AP4_UI32 timescale )

Referenced by Create().

Member Function Documentation

static AP4_TimsAtom* AP4_TimsAtom::Create | ( | AP4_Size | size,
 |  | AP4_ByteStream & | stream |
 | ) |  |  | [inline, static]

Definition at line 44 of file Ap4TimsAtom.h.

References AP4_TimsAtom().

virtual AP4_UI32 AP4_TimsAtom::GetTimeScale ( ) [inline, virtual]

Definition at line 54 of file Ap4TimsAtom.h.

virtual AP4_Result AP4_TimsAtom::InspectFields ( AP4_AtomInspector & inspector ) [virtual]

Reimplemented from AP4_Atom.

virtual AP4_Result AP4_TimsAtom::WriteFields ( AP4_ByteStream & stream ) [virtual]

Implements AP4_Atom.

The documentation for this class was generated from the following file:
  • Ap4TimsAtom.h
Generated on Thu May 13 16:37:52 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_TimsAtom Member List

This is the complete list of members for AP4_TimsAtom, including all inherited members.
AP4_Atom(Type type, AP4_UI32 size=AP4_ATOM_HEADER_SIZE) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64=false) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_TimsAtom(AP4_UI32 timescale) | AP4_TimsAtom |
Clone() | AP4_Atom | [virtual]
Create(AP4_Size size, AP4_ByteStream &stream) | AP4_TimsAtom | [inline, static]
Detach() | AP4_Atom | [virtual]
GetFlags() const | AP4_Atom | [inline]
GetHeaderSize() const | AP4_Atom | [virtual]
GetParent() | AP4_Atom | [inline, virtual]
GetSize() const | AP4_Atom | [inline]
GetSize32() const | AP4_Atom | [inline]
GetSize64() const | AP4_Atom | [inline]
GetTimeScale() | AP4_TimsAtom | [inline, virtual]
GetType() const | AP4_Atom | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
InspectFields(AP4_AtomInspector &inspector) | AP4_TimsAtom | [virtual]
InspectHeader(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
m_Flags | AP4_Atom | [protected]
m_IsFull | AP4_Atom | [protected]
m_Parent | AP4_Atom | [protected]
m_Size32 | AP4_Atom | [protected]
m_Size64 | AP4_Atom | [protected]
m_Type | AP4_Atom | [protected]
m_Version | AP4_Atom | [protected]
ReadFullHeader(AP4_ByteStream &stream, AP4_UI32 &version, AP4_UI32 &flags) | AP4_Atom | [static]
SetFlags(AP4_UI32 flags) | AP4_Atom | [inline]
SetParent(AP4_AtomParent *parent) | AP4_Atom | [inline, virtual]
SetSize(AP4_UI64 size, bool force_64=false) | AP4_Atom |
SetSize32(AP4_UI32 size) | AP4_Atom | [inline]
SetSize64(AP4_UI64 size) | AP4_Atom | [inline]
SetType(Type type) | AP4_Atom | [inline]
Type typedef | AP4_Atom |
TypeFromString(const char *four_cc) | AP4_Atom | [static]
Write(AP4_ByteStream &stream) | AP4_Atom | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_TimsAtom | [virtual]
WriteHeader(AP4_ByteStream &stream) | AP4_Atom | [virtual]
~AP4_Atom() | AP4_Atom | [inline, virtual]
Generated on Thu May 13 16:37:52 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_TkhdAtom Class Reference

AP4_TkhdAtom Class Reference

#include <Ap4TkhdAtom.h>

Inheritance diagram for AP4_TkhdAtom:
AP4_Atom

List of all members.

Public Member Functions

AP4_TkhdAtom (AP4_UI32 creation_time, AP4_UI32 modification_time, AP4_UI32 track_id, AP4_UI64 duration, AP4_UI16 volume, AP4_UI32 width, AP4_UI32 height)
virtual AP4_Result | InspectFields (AP4_AtomInspector &inspector)
virtual AP4_Result | WriteFields (AP4_ByteStream &stream)
AP4_UI64 GetDuration ()
void | SetDuration (AP4_UI64 duration)
AP4_UI32 GetTrackId ()
void | SetTrackId (AP4_UI32 track_id)
void | GetTranslation (float &x, float &y)
AP4_UI32 GetWidth ()
void | SetWidth (AP4_UI32 width)
AP4_UI32 GetHeight ()
void | SetHeight (AP4_UI32 height)

Static Public Member Functions

static AP4_TkhdAtom * | Create (AP4_Size size, AP4_ByteStream &stream)

Detailed Description

Definition at line 49 of file Ap4TkhdAtom.h.

Constructor & Destructor Documentation

AP4_TkhdAtom::AP4_TkhdAtom | ( | AP4_UI32 | creation_time,
 |  | AP4_UI32 | modification_time,
 |  | AP4_UI32 | track_id,
 |  | AP4_UI64 | duration,
 |  | AP4_UI16 | volume,
 |  | AP4_UI32 | width,
 |  | AP4_UI32 | height
 | ) |  |

Member Function Documentation

static AP4_TkhdAtom* AP4_TkhdAtom::Create | ( | AP4_Size | size,
 |  | AP4_ByteStream & | stream |
 | ) |  |  | [static]
AP4_UI64 AP4_TkhdAtom::GetDuration ( ) [inline]

Definition at line 68 of file Ap4TkhdAtom.h.

AP4_UI32 AP4_TkhdAtom::GetHeight ( ) [inline]

Definition at line 80 of file Ap4TkhdAtom.h.

AP4_UI32 AP4_TkhdAtom::GetTrackId ( ) [inline]

Definition at line 70 of file Ap4TkhdAtom.h.

void AP4_TkhdAtom::GetTranslation | ( | float & | x,
 |  | float & | y |
 | ) |  |  | [inline]

Definition at line 73 of file Ap4TkhdAtom.h.

AP4_UI32 AP4_TkhdAtom::GetWidth ( ) [inline]

Definition at line 78 of file Ap4TkhdAtom.h.

virtual AP4_Result AP4_TkhdAtom::InspectFields ( AP4_AtomInspector & inspector ) [virtual]

Reimplemented from AP4_Atom.

void AP4_TkhdAtom::SetDuration ( AP4_UI64 duration ) [inline]

Definition at line 69 of file Ap4TkhdAtom.h.

void AP4_TkhdAtom::SetHeight ( AP4_UI32 height ) [inline]

Definition at line 81 of file Ap4TkhdAtom.h.

void AP4_TkhdAtom::SetTrackId ( AP4_UI32 track_id ) [inline]

Definition at line 71 of file Ap4TkhdAtom.h.

void AP4_TkhdAtom::SetWidth ( AP4_UI32 width ) [inline]

Definition at line 79 of file Ap4TkhdAtom.h.

virtual AP4_Result AP4_TkhdAtom::WriteFields ( AP4_ByteStream & stream ) [virtual]

Implements AP4_Atom.

The documentation for this class was generated from the following file:
  • Ap4TkhdAtom.h
Generated on Thu May 13 16:37:53 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_TkhdAtom Member List

This is the complete list of members for AP4_TkhdAtom, including all inherited members.
AP4_Atom(Type type, AP4_UI32 size=AP4_ATOM_HEADER_SIZE) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64=false) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_TkhdAtom(AP4_UI32 creation_time, AP4_UI32 modification_time, AP4_UI32 track_id, AP4_UI64 duration, AP4_UI16 volume, AP4_UI32 width, AP4_UI32 height) | AP4_TkhdAtom |
Clone() | AP4_Atom | [virtual]
Create(AP4_Size size, AP4_ByteStream &stream) | AP4_TkhdAtom | [static]
Detach() | AP4_Atom | [virtual]
GetDuration() | AP4_TkhdAtom | [inline]
GetFlags() const | AP4_Atom | [inline]
GetHeaderSize() const | AP4_Atom | [virtual]
GetHeight() | AP4_TkhdAtom | [inline]
GetParent() | AP4_Atom | [inline, virtual]
GetSize() const | AP4_Atom | [inline]
GetSize32() const | AP4_Atom | [inline]
GetSize64() const | AP4_Atom | [inline]
GetTrackId() | AP4_TkhdAtom | [inline]
GetTranslation(float &x, float &y) | AP4_TkhdAtom | [inline]
GetType() const | AP4_Atom | [inline]
GetWidth() | AP4_TkhdAtom | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
InspectFields(AP4_AtomInspector &inspector) | AP4_TkhdAtom | [virtual]
InspectHeader(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
m_Flags | AP4_Atom | [protected]
m_IsFull | AP4_Atom | [protected]
m_Parent | AP4_Atom | [protected]
m_Size32 | AP4_Atom | [protected]
m_Size64 | AP4_Atom | [protected]
m_Type | AP4_Atom | [protected]
m_Version | AP4_Atom | [protected]
ReadFullHeader(AP4_ByteStream &stream, AP4_UI32 &version, AP4_UI32 &flags) | AP4_Atom | [static]
SetDuration(AP4_UI64 duration) | AP4_TkhdAtom | [inline]
SetFlags(AP4_UI32 flags) | AP4_Atom | [inline]
SetHeight(AP4_UI32 height) | AP4_TkhdAtom | [inline]
SetParent(AP4_AtomParent *parent) | AP4_Atom | [inline, virtual]
SetSize(AP4_UI64 size, bool force_64=false) | AP4_Atom |
SetSize32(AP4_UI32 size) | AP4_Atom | [inline]
SetSize64(AP4_UI64 size) | AP4_Atom | [inline]
SetTrackId(AP4_UI32 track_id) | AP4_TkhdAtom | [inline]
SetType(Type type) | AP4_Atom | [inline]
SetWidth(AP4_UI32 width) | AP4_TkhdAtom | [inline]
Type typedef | AP4_Atom |
TypeFromString(const char *four_cc) | AP4_Atom | [static]
Write(AP4_ByteStream &stream) | AP4_Atom | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_TkhdAtom | [virtual]
WriteHeader(AP4_ByteStream &stream) | AP4_Atom | [virtual]
~AP4_Atom() | AP4_Atom | [inline, virtual]
Generated on Thu May 13 16:37:53 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_Track Class Reference

AP4_Track Class Reference

#include <Ap4Track.h>

List of all members.

Public Types

enum Type {
TYPE_UNKNOWN = 0,
TYPE_AUDIO = 1,
TYPE_VIDEO = 2,
TYPE_SYSTEM = 3,
TYPE_HINT = 4,
TYPE_TEXT = 5,
TYPE_JPEG = 6,
TYPE_RTP = 7
}

Public Member Functions

AP4_Track (Type type, AP4_SampleTable *sample_table, AP4_UI32 track_id, AP4_UI32 movie_time_scale, AP4_UI64 track_duration, AP4_UI32 media_time_scale, AP4_UI64 media_duration, const char *language, AP4_UI32 width, AP4_UI32 height)
AP4_Track (AP4_TrakAtom &atom, AP4_ByteStream &sample_stream, AP4_UI32 movie_time_scale)
virtual | ~AP4_Track ()
AP4_Track * | Clone (AP4_Result *result=NULL)
Clone a track.
AP4_UI32 GetFlags ()
AP4_Result | SetFlags (AP4_UI32 flags)
AP4_Track::Type GetType ()
AP4_UI32 GetHandlerType ()
AP4_UI64 GetDuration ()
AP4_UI32 GetDurationMs ()
AP4_UI32 GetWidth ()
AP4_UI32 GetHeight ()
AP4_Cardinal GetSampleCount ()
AP4_Result | GetSample (AP4_Ordinal index, AP4_Sample &sample)
AP4_Result | ReadSample (AP4_Ordinal index, AP4_Sample &sample, AP4_DataBuffer &data)
AP4_Result | GetSampleIndexForTimeStampMs (AP4_UI32 ts_ms, AP4_Ordinal &index)
AP4_Ordinal | GetNearestSyncSampleIndex (AP4_Ordinal index, bool before=true)
AP4_SampleDescription * | GetSampleDescription (AP4_Ordinal index)
AP4_SampleTable * GetSampleTable ()
AP4_UI32 GetId ()
AP4_Result | SetId (AP4_UI32 track_id)
AP4_TrakAtom * GetTrakAtom ()
AP4_Result | SetMovieTimeScale (AP4_UI32 time_scale)
AP4_UI32 GetMovieTimeScale ()
AP4_UI32 GetMediaTimeScale ()
AP4_UI64 GetMediaDuration ()
const char * | GetTrackName ()
const char * | GetTrackLanguage ()
AP4_Result | Attach (AP4_MoovAtom *moov)

Protected Attributes

AP4_TrakAtom * m_TrakAtom
bool | m_TrakAtomIsOwned
Type m_Type
AP4_SampleTable * m_SampleTable
bool | m_SampleTableIsOwned
AP4_UI32 m_MovieTimeScale

Detailed Description

Definition at line 62 of file Ap4Track.h.

Member Enumeration Documentation

enum AP4_Track::Type
Enumerator:
TYPE_UNKNOWN
TYPE_AUDIO
TYPE_VIDEO
TYPE_SYSTEM
TYPE_HINT
TYPE_TEXT
TYPE_JPEG
TYPE_RTP

Definition at line 65 of file Ap4Track.h.

Constructor & Destructor Documentation

AP4_Track::AP4_Track | ( | Type | type,
 |  | AP4_SampleTable * | sample_table,
 |  | AP4_UI32 | track_id,
 |  | AP4_UI32 | movie_time_scale,
 |  | AP4_UI64 | track_duration,
 |  | AP4_UI32 | media_time_scale,
 |  | AP4_UI64 | media_duration,
 |  | const char * | language,
 |  | AP4_UI32 | width,
 |  | AP4_UI32 | height
 | ) |  |
AP4_Track::AP4_Track | ( | AP4_TrakAtom & | atom,
 |  | AP4_ByteStream & | sample_stream,
 |  | AP4_UI32 | movie_time_scale
 | ) |  |
virtual AP4_Track::~AP4_Track ( ) [virtual]

Member Function Documentation

AP4_Result AP4_Track::Attach ( AP4_MoovAtom * moov )
AP4_Track* AP4_Track::Clone ( AP4_Result * result = NULL )

Clone a track.

This is useful if you want to create a track from a non-synthetic track (parsed from a file for example) and write it out

AP4_UI64 AP4_Track::GetDuration ( )
AP4_UI32 AP4_Track::GetDurationMs ( )
AP4_UI32 AP4_Track::GetFlags ( )
AP4_UI32 AP4_Track::GetHandlerType ( )
AP4_UI32 AP4_Track::GetHeight ( )
AP4_UI32 AP4_Track::GetId ( )
AP4_UI64 AP4_Track::GetMediaDuration ( )
AP4_UI32 AP4_Track::GetMediaTimeScale ( )
AP4_UI32 AP4_Track::GetMovieTimeScale ( ) [inline]

Definition at line 121 of file Ap4Track.h.

References m_MovieTimeScale.

AP4_Ordinal AP4_Track::GetNearestSyncSampleIndex | ( | AP4_Ordinal | index,
 |  | bool | before = true
 | ) |  |
AP4_Result AP4_Track::GetSample | ( | AP4_Ordinal | index,
 |  | AP4_Sample & | sample
 | ) |  |
AP4_Cardinal AP4_Track::GetSampleCount ( )
AP4_SampleDescription* AP4_Track::GetSampleDescription ( AP4_Ordinal index )
AP4_Result AP4_Track::GetSampleIndexForTimeStampMs | ( | AP4_UI32 | ts_ms,
 |  | AP4_Ordinal & | index
 | ) |  |
AP4_SampleTable* AP4_Track::GetSampleTable ( ) [inline]

Definition at line 116 of file Ap4Track.h.

References m_SampleTable.

const char* AP4_Track::GetTrackLanguage ( )
const char* AP4_Track::GetTrackName ( )
AP4_TrakAtom* AP4_Track::GetTrakAtom ( ) [inline]

Definition at line 119 of file Ap4Track.h.

References m_TrakAtom.

AP4_Track::Type AP4_Track::GetType ( ) [inline]

Definition at line 101 of file Ap4Track.h.

References m_Type.

AP4_UI32 AP4_Track::GetWidth ( )
AP4_Result AP4_Track::ReadSample | ( | AP4_Ordinal | index,
 |  | AP4_Sample & | sample,
 |  | AP4_DataBuffer & | data
 | ) |  |
AP4_Result AP4_Track::SetFlags ( AP4_UI32 flags )
AP4_Result AP4_Track::SetId ( AP4_UI32 track_id )
AP4_Result AP4_Track::SetMovieTimeScale ( AP4_UI32 time_scale )

Member Data Documentation

AP4_UI32 AP4_Track::m_MovieTimeScale [protected]

Definition at line 135 of file Ap4Track.h.

Referenced by GetMovieTimeScale().

AP4_SampleTable* AP4_Track::m_SampleTable [protected]

Definition at line 133 of file Ap4Track.h.

Referenced by GetSampleTable().

bool AP4_Track::m_SampleTableIsOwned [protected]

Definition at line 134 of file Ap4Track.h.

AP4_TrakAtom* AP4_Track::m_TrakAtom [protected]

Definition at line 130 of file Ap4Track.h.

Referenced by GetTrakAtom().

bool AP4_Track::m_TrakAtomIsOwned [protected]

Definition at line 131 of file Ap4Track.h.

Type AP4_Track::m_Type [protected]

Definition at line 132 of file Ap4Track.h.

Referenced by GetType().

The documentation for this class was generated from the following file:
  • Ap4Track.h
Generated on Thu May 13 16:37:53 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_Track Member List

This is the complete list of members for AP4_Track, including all inherited members.
AP4_Track(Type type, AP4_SampleTable *sample_table, AP4_UI32 track_id, AP4_UI32 movie_time_scale, AP4_UI64 track_duration, AP4_UI32 media_time_scale, AP4_UI64 media_duration, const char *language, AP4_UI32 width, AP4_UI32 height) | AP4_Track |
AP4_Track(AP4_TrakAtom &atom, AP4_ByteStream &sample_stream, AP4_UI32 movie_time_scale) | AP4_Track |
Attach(AP4_MoovAtom *moov) | AP4_Track |
Clone(AP4_Result *result=NULL) | AP4_Track |
GetDuration() | AP4_Track |
GetDurationMs() | AP4_Track |
GetFlags() | AP4_Track |
GetHandlerType() | AP4_Track |
GetHeight() | AP4_Track |
GetId() | AP4_Track |
GetMediaDuration() | AP4_Track |
GetMediaTimeScale() | AP4_Track |
GetMovieTimeScale() | AP4_Track | [inline]
GetNearestSyncSampleIndex(AP4_Ordinal index, bool before=true) | AP4_Track |
GetSample(AP4_Ordinal index, AP4_Sample &sample) | AP4_Track |
GetSampleCount() | AP4_Track |
GetSampleDescription(AP4_Ordinal index) | AP4_Track |
GetSampleIndexForTimeStampMs(AP4_UI32 ts_ms, AP4_Ordinal &index) | AP4_Track |
GetSampleTable() | AP4_Track | [inline]
GetTrackLanguage() | AP4_Track |
GetTrackName() | AP4_Track |
GetTrakAtom() | AP4_Track | [inline]
GetType() | AP4_Track | [inline]
GetWidth() | AP4_Track |
m_MovieTimeScale | AP4_Track | [protected]
m_SampleTable | AP4_Track | [protected]
m_SampleTableIsOwned | AP4_Track | [protected]
m_TrakAtom | AP4_Track | [protected]
m_TrakAtomIsOwned | AP4_Track | [protected]
m_Type | AP4_Track | [protected]
ReadSample(AP4_Ordinal index, AP4_Sample &sample, AP4_DataBuffer &data) | AP4_Track |
SetFlags(AP4_UI32 flags) | AP4_Track |
SetId(AP4_UI32 track_id) | AP4_Track |
SetMovieTimeScale(AP4_UI32 time_scale) | AP4_Track |
Type enum name | AP4_Track |
TYPE_AUDIO enum value | AP4_Track |
TYPE_HINT enum value | AP4_Track |
TYPE_JPEG enum value | AP4_Track |
TYPE_RTP enum value | AP4_Track |
TYPE_SYSTEM enum value | AP4_Track |
TYPE_TEXT enum value | AP4_Track |
TYPE_UNKNOWN enum value | AP4_Track |
TYPE_VIDEO enum value | AP4_Track |
~AP4_Track() | AP4_Track | [virtual]
Generated on Thu May 13 16:37:53 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_TrackPropertyMap Class Reference

AP4_TrackPropertyMap Class Reference

#include <Ap4Protection.h>

List of all members.

Classes

class | Entry

Public Member Functions

AP4_Result | SetProperty (AP4_UI32 track_id, const char *name, const char *value)
AP4_Result | SetProperties (const AP4_TrackPropertyMap &properties)
const char * | GetProperty (AP4_UI32 track_id, const char *name)
AP4_Result | GetTextualHeaders (AP4_UI32 track_id, AP4_DataBuffer &buffer)
virtual | ~AP4_TrackPropertyMap ()

Detailed Description

Definition at line 166 of file Ap4Protection.h.

Constructor & Destructor Documentation

virtual AP4_TrackPropertyMap::~AP4_TrackPropertyMap ( ) [virtual]

Member Function Documentation

const char* AP4_TrackPropertyMap::GetProperty | ( | AP4_UI32 | track_id,
 |  | const char * | name
 | ) |  |
AP4_Result AP4_TrackPropertyMap::GetTextualHeaders | ( | AP4_UI32 | track_id,
 |  | AP4_DataBuffer & | buffer
 | ) |  |
AP4_Result AP4_TrackPropertyMap::SetProperties ( const AP4_TrackPropertyMap & properties )
AP4_Result AP4_TrackPropertyMap::SetProperty | ( | AP4_UI32 | track_id,
 |  | const char * | name,
 |  | const char * | value
 | ) |  |
The documentation for this class was generated from the following file:
  • Ap4Protection.h
Generated on Thu May 13 16:37:53 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_TrackPropertyMap Member List

This is the complete list of members for AP4_TrackPropertyMap, including all inherited members.
GetProperty(AP4_UI32 track_id, const char *name) | AP4_TrackPropertyMap |
GetTextualHeaders(AP4_UI32 track_id, AP4_DataBuffer &buffer) | AP4_TrackPropertyMap |
SetProperties(const AP4_TrackPropertyMap &properties) | AP4_TrackPropertyMap |
SetProperty(AP4_UI32 track_id, const char *name, const char *value) | AP4_TrackPropertyMap |
~AP4_TrackPropertyMap() | AP4_TrackPropertyMap | [virtual]
Generated on Thu May 13 16:37:53 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_TrackSampleSource Class Reference

AP4_TrackSampleSource Class Reference

#include <Ap4SampleSource.h>

Inheritance diagram for AP4_TrackSampleSource:
AP4_SampleSource

List of all members.

Public Member Functions

AP4_TrackSampleSource (AP4_Track *track)
virtual AP4_UI32 | GetTimeScale ()
Return the timscale of the sample's media.
virtual AP4_UI32 | GetDurationMs ()
Return the duration in milliseconds.
virtual AP4_UI32 | GetTrackId ()
Return the track ID associated with this source, or 0 if there is no track ID associated with it.
virtual AP4_Result | ReadNextSample (AP4_Sample &sample, AP4_DataBuffer &buffer)
Read the next sample from the source.
virtual AP4_Ordinal | GetNearestSyncSampleIndex (AP4_Ordinal indx, bool before=true)
Return the index of the nearest sync sample from a given sample index.
virtual AP4_Result | GetSampleIndexForTimeStampMs (AP4_UI32 timestamp, AP4_Ordinal &indx)
Return the sample index given a timestamp in milliseconds.
virtual AP4_Result | SetSampleIndex (AP4_Ordinal indx)
Seek to a specific sample index.
virtual AP4_SampleDescription * | GetSampleDescription (AP4_Ordinal indx)
Return a sample description by index.

Detailed Description

Definition at line 99 of file Ap4SampleSource.h.

Constructor & Destructor Documentation

AP4_TrackSampleSource::AP4_TrackSampleSource ( AP4_Track * track )

Member Function Documentation

virtual AP4_UI32 AP4_TrackSampleSource::GetDurationMs ( ) [virtual]

Return the duration in milliseconds.

Implements AP4_SampleSource.

virtual AP4_Ordinal AP4_TrackSampleSource::GetNearestSyncSampleIndex | ( | AP4_Ordinal | indx,
 |  | bool | before = true |
 | ) |  |  | [virtual]

Return the index of the nearest sync sample from a given sample index.

Implements AP4_SampleSource.

virtual AP4_SampleDescription* AP4_TrackSampleSource::GetSampleDescription ( AP4_Ordinal indx ) [virtual]

Return a sample description by index.

Returns NULL if there is no sample description with the requested index.

Implements AP4_SampleSource.

virtual AP4_Result AP4_TrackSampleSource::GetSampleIndexForTimeStampMs | ( | AP4_UI32 | timestamp,
 |  | AP4_Ordinal & | indx |
 | ) |  |  | [virtual]

Return the sample index given a timestamp in milliseconds.

Implements AP4_SampleSource.

virtual AP4_UI32 AP4_TrackSampleSource::GetTimeScale ( ) [virtual]

Return the timscale of the sample's media.

Implements AP4_SampleSource.

virtual AP4_UI32 AP4_TrackSampleSource::GetTrackId ( ) [virtual]

Return the track ID associated with this source, or 0 if there is no track ID associated with it.

Implements AP4_SampleSource.

virtual AP4_Result AP4_TrackSampleSource::ReadNextSample | ( | AP4_Sample & | sample,
 |  | AP4_DataBuffer & | buffer |
 | ) |  |  | [virtual]

Read the next sample from the source.

Implements AP4_SampleSource.

virtual AP4_Result AP4_TrackSampleSource::SetSampleIndex ( AP4_Ordinal indx ) [virtual]

Seek to a specific sample index.

Implements AP4_SampleSource.

The documentation for this class was generated from the following file:
  • Ap4SampleSource.h
Generated on Thu May 13 16:37:53 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_TrackSampleSource Member List

This is the complete list of members for AP4_TrackSampleSource, including all inherited members.
AP4_TrackSampleSource(AP4_Track *track) | AP4_TrackSampleSource |
GetDurationMs() | AP4_TrackSampleSource | [virtual]
GetNearestSyncSampleIndex(AP4_Ordinal indx, bool before=true) | AP4_TrackSampleSource | [virtual]
GetSampleDescription(AP4_Ordinal indx) | AP4_TrackSampleSource | [virtual]
GetSampleIndexForTimeStampMs(AP4_UI32 timestamp, AP4_Ordinal &indx) | AP4_TrackSampleSource | [virtual]
GetTimeScale() | AP4_TrackSampleSource | [virtual]
GetTrackId() | AP4_TrackSampleSource | [virtual]
ReadNextSample(AP4_Sample &sample, AP4_DataBuffer &buffer) | AP4_TrackSampleSource | [virtual]
SetSampleIndex(AP4_Ordinal indx) | AP4_TrackSampleSource | [virtual]
~AP4_SampleSource() | AP4_SampleSource | [inline, virtual]
Generated on Thu May 13 16:37:53 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_TrakAtom Class Reference

AP4_TrakAtom Class Reference

#include <Ap4TrakAtom.h>

Inheritance diagram for AP4_TrakAtom:
AP4_ContainerAtom AP4_Atom AP4_AtomParent

List of all members.

Public Member Functions

AP4_TrakAtom (AP4_SampleTable *sample_table, AP4_Atom::Type hdlr_type, const char *hdlr_name, AP4_UI32 track_id, AP4_UI32 creation_time, AP4_UI32 modification_time, AP4_UI64 track_duration, AP4_UI32 media_time_scale, AP4_UI64 media_duration, AP4_UI16 volume, const char *language, AP4_UI32 width, AP4_UI32 heigh)
AP4_TkhdAtom * GetTkhdAtom ()
AP4_Result | AdjustChunkOffsets (AP4_SI64 delta)
AP4_Result | GetChunkOffsets (AP4_Array< AP4_UI64 > &chunk_offsets)
AP4_Result | SetChunkOffsets (const AP4_Array< AP4_UI64 > &chunk_offsets)
AP4_UI32 GetId ()
AP4_Result | SetId (AP4_UI32 track_id)
AP4_UI64 GetDuration ()
AP4_Result | SetDuration (AP4_UI64 duration)
AP4_UI64 GetMediaDuration ()
AP4_Result | SetMediaDuration (AP4_UI32 duration)
AP4_UI32 GetMediaTimeScale ()
AP4_Result | SetMediaTimeScale (AP4_UI32 timescale)
AP4_UI32 GetWidth ()
AP4_Result | SetWidth (AP4_UI32 width)
AP4_UI32 GetHeight ()
AP4_Result | SetHeight (AP4_UI32 height)

Static Public Member Functions

static AP4_TrakAtom * | Create (AP4_Size size, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory)

Detailed Description

Definition at line 49 of file Ap4TrakAtom.h.

Constructor & Destructor Documentation

AP4_TrakAtom::AP4_TrakAtom | ( | AP4_SampleTable * | sample_table,
 |  | AP4_Atom::Type | hdlr_type,
 |  | const char * | hdlr_name,
 |  | AP4_UI32 | track_id,
 |  | AP4_UI32 | creation_time,
 |  | AP4_UI32 | modification_time,
 |  | AP4_UI64 | track_duration,
 |  | AP4_UI32 | media_time_scale,
 |  | AP4_UI64 | media_duration,
 |  | AP4_UI16 | volume,
 |  | const char * | language,
 |  | AP4_UI32 | width,
 |  | AP4_UI32 | heigh
 | ) |  |

Referenced by Create().

Member Function Documentation

AP4_Result AP4_TrakAtom::AdjustChunkOffsets ( AP4_SI64 delta )
static AP4_TrakAtom* AP4_TrakAtom::Create | ( | AP4_Size | size,
 |  | AP4_ByteStream & | stream,
 |  | AP4_AtomFactory & | atom_factory |
 | ) |  |  | [inline, static]

Definition at line 55 of file Ap4TrakAtom.h.

References AP4_TrakAtom().

AP4_Result AP4_TrakAtom::GetChunkOffsets ( AP4_Array< AP4_UI64 > & chunk_offsets )
AP4_UI64 AP4_TrakAtom::GetDuration ( )
AP4_UI32 AP4_TrakAtom::GetHeight ( )
AP4_UI32 AP4_TrakAtom::GetId ( )
AP4_UI64 AP4_TrakAtom::GetMediaDuration ( )
AP4_UI32 AP4_TrakAtom::GetMediaTimeScale ( )
AP4_TkhdAtom* AP4_TrakAtom::GetTkhdAtom ( ) [inline]

Definition at line 75 of file Ap4TrakAtom.h.

AP4_UI32 AP4_TrakAtom::GetWidth ( )
AP4_Result AP4_TrakAtom::SetChunkOffsets ( const AP4_Array< AP4_UI64 > & chunk_offsets )
AP4_Result AP4_TrakAtom::SetDuration ( AP4_UI64 duration )
AP4_Result AP4_TrakAtom::SetHeight ( AP4_UI32 height )
AP4_Result AP4_TrakAtom::SetId ( AP4_UI32 track_id )
AP4_Result AP4_TrakAtom::SetMediaDuration ( AP4_UI32 duration )
AP4_Result AP4_TrakAtom::SetMediaTimeScale ( AP4_UI32 timescale )
AP4_Result AP4_TrakAtom::SetWidth ( AP4_UI32 width )
The documentation for this class was generated from the following file:
  • Ap4TrakAtom.h
Generated on Thu May 13 16:37:53 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_TrakAtom Member List

This is the complete list of members for AP4_TrakAtom, including all inherited members.
AddChild(AP4_Atom *child, int position=-1) | AP4_AtomParent | [virtual]
AdjustChunkOffsets(AP4_SI64 delta) | AP4_TrakAtom |
AP4_Atom(Type type, AP4_UI32 size=AP4_ATOM_HEADER_SIZE) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64=false) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_ContainerAtom(Type type) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI32 version, AP4_UI32 flags) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_ContainerAtom | [protected]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_ContainerAtom | [protected]
AP4_TrakAtom(AP4_SampleTable *sample_table, AP4_Atom::Type hdlr_type, const char *hdlr_name, AP4_UI32 track_id, AP4_UI32 creation_time, AP4_UI32 modification_time, AP4_UI64 track_duration, AP4_UI32 media_time_scale, AP4_UI64 media_duration, AP4_UI16 volume, const char *language, AP4_UI32 width, AP4_UI32 heigh) | AP4_TrakAtom |
Clone() | AP4_ContainerAtom | [virtual]
Create(AP4_Size size, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_TrakAtom | [inline, static]
AP4_ContainerAtom::Create(Type type, AP4_UI64 size, bool is_full, bool force_64, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_ContainerAtom | [static]
DeleteChild(AP4_Atom::Type type, AP4_Ordinal index=0) | AP4_AtomParent | [virtual]
Detach() | AP4_Atom | [virtual]
FindChild(const char *path, bool auto_create=false, bool auto_create_full=false) | AP4_AtomParent | [virtual]
GetChild(AP4_Atom::Type type, AP4_Ordinal index=0) const | AP4_AtomParent | [virtual]
GetChild(const AP4_UI08 *uuid, AP4_Ordinal index=0) const | AP4_AtomParent | [virtual]
GetChildren() | AP4_ContainerAtom | [inline]
GetChunkOffsets(AP4_Array< AP4_UI64 > &chunk_offsets) | AP4_TrakAtom |
GetDuration() | AP4_TrakAtom |
GetFlags() const | AP4_Atom | [inline]
GetHeaderSize() const | AP4_Atom | [virtual]
GetHeight() | AP4_TrakAtom |
GetId() | AP4_TrakAtom |
GetMediaDuration() | AP4_TrakAtom |
GetMediaTimeScale() | AP4_TrakAtom |
GetParent() | AP4_Atom | [inline, virtual]
GetSize() const | AP4_Atom | [inline]
GetSize32() const | AP4_Atom | [inline]
GetSize64() const | AP4_Atom | [inline]
GetTkhdAtom() | AP4_TrakAtom | [inline]
GetType() const | AP4_Atom | [inline]
GetWidth() | AP4_TrakAtom |
Inspect(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
InspectChildren(AP4_AtomInspector &inspector) | AP4_ContainerAtom | [virtual]
InspectFields(AP4_AtomInspector &inspector) | AP4_ContainerAtom | [virtual]
InspectHeader(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
m_Children | AP4_AtomParent | [protected]
m_Flags | AP4_Atom | [protected]
m_IsFull | AP4_Atom | [protected]
m_Parent | AP4_Atom | [protected]
m_Size32 | AP4_Atom | [protected]
m_Size64 | AP4_Atom | [protected]
m_Type | AP4_Atom | [protected]
m_Version | AP4_Atom | [protected]
OnChildAdded(AP4_Atom *child) | AP4_ContainerAtom | [virtual]
OnChildChanged(AP4_Atom *child) | AP4_ContainerAtom | [virtual]
OnChildRemoved(AP4_Atom *child) | AP4_ContainerAtom | [virtual]
ReadChildren(AP4_AtomFactory &atom_factory, AP4_ByteStream &stream, AP4_UI64 size) | AP4_ContainerAtom | [protected]
ReadFullHeader(AP4_ByteStream &stream, AP4_UI32 &version, AP4_UI32 &flags) | AP4_Atom | [static]
RemoveChild(AP4_Atom *child) | AP4_AtomParent | [virtual]
SetChunkOffsets(const AP4_Array< AP4_UI64 > &chunk_offsets) | AP4_TrakAtom |
SetDuration(AP4_UI64 duration) | AP4_TrakAtom |
SetFlags(AP4_UI32 flags) | AP4_Atom | [inline]
SetHeight(AP4_UI32 height) | AP4_TrakAtom |
SetId(AP4_UI32 track_id) | AP4_TrakAtom |
SetMediaDuration(AP4_UI32 duration) | AP4_TrakAtom |
SetMediaTimeScale(AP4_UI32 timescale) | AP4_TrakAtom |
SetParent(AP4_AtomParent *parent) | AP4_Atom | [inline, virtual]
SetSize(AP4_UI64 size, bool force_64=false) | AP4_Atom |
SetSize32(AP4_UI32 size) | AP4_Atom | [inline]
SetSize64(AP4_UI64 size) | AP4_Atom | [inline]
SetType(Type type) | AP4_Atom | [inline]
SetWidth(AP4_UI32 width) | AP4_TrakAtom |
Type typedef | AP4_Atom |
TypeFromString(const char *four_cc) | AP4_Atom | [static]
Write(AP4_ByteStream &stream) | AP4_Atom | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_ContainerAtom | [virtual]
WriteHeader(AP4_ByteStream &stream) | AP4_Atom | [virtual]
~AP4_Atom() | AP4_Atom | [inline, virtual]
~AP4_AtomParent() | AP4_AtomParent | [virtual]
Generated on Thu May 13 16:37:53 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_TrefTypeAtom Class Reference

AP4_TrefTypeAtom Class Reference

#include <Ap4TrefTypeAtom.h>

Inheritance diagram for AP4_TrefTypeAtom:
AP4_Atom

List of all members.

Public Member Functions

AP4_TrefTypeAtom (AP4_Atom::Type type)
virtual AP4_Result | InspectFields (AP4_AtomInspector &inspector)
virtual AP4_Result | WriteFields (AP4_ByteStream &stream)
AP4_Result | AddTrackId (AP4_UI32 track_id)
const AP4_Array< AP4_UI32 > & | GetTrackIds ()

Static Public Member Functions

static AP4_TrefTypeAtom * | Create (AP4_Atom::Type type, AP4_UI32 size, AP4_ByteStream &stream)

Detailed Description

Definition at line 41 of file Ap4TrefTypeAtom.h.

Constructor & Destructor Documentation

AP4_TrefTypeAtom::AP4_TrefTypeAtom ( AP4_Atom::Type type )

Referenced by Create().

Member Function Documentation

AP4_Result AP4_TrefTypeAtom::AddTrackId ( AP4_UI32 track_id )
static AP4_TrefTypeAtom* AP4_TrefTypeAtom::Create | ( | AP4_Atom::Type | type,
 |  | AP4_UI32 | size,
 |  | AP4_ByteStream & | stream |
 | ) |  |  | [inline, static]

Definition at line 47 of file Ap4TrefTypeAtom.h.

References AP4_TrefTypeAtom().

const AP4_Array<AP4_UI32>& AP4_TrefTypeAtom::GetTrackIds ( ) [inline]

Definition at line 62 of file Ap4TrefTypeAtom.h.

virtual AP4_Result AP4_TrefTypeAtom::InspectFields ( AP4_AtomInspector & inspector ) [virtual]

Reimplemented from AP4_Atom.

virtual AP4_Result AP4_TrefTypeAtom::WriteFields ( AP4_ByteStream & stream ) [virtual]

Implements AP4_Atom.

The documentation for this class was generated from the following file:
  • Ap4TrefTypeAtom.h
Generated on Thu May 13 16:37:53 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_TrefTypeAtom Member List

This is the complete list of members for AP4_TrefTypeAtom, including all inherited members.
AddTrackId(AP4_UI32 track_id) | AP4_TrefTypeAtom |
AP4_Atom(Type type, AP4_UI32 size=AP4_ATOM_HEADER_SIZE) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64=false) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_TrefTypeAtom(AP4_Atom::Type type) | AP4_TrefTypeAtom |
Clone() | AP4_Atom | [virtual]
Create(AP4_Atom::Type type, AP4_UI32 size, AP4_ByteStream &stream) | AP4_TrefTypeAtom | [inline, static]
Detach() | AP4_Atom | [virtual]
GetFlags() const | AP4_Atom | [inline]
GetHeaderSize() const | AP4_Atom | [virtual]
GetParent() | AP4_Atom | [inline, virtual]
GetSize() const | AP4_Atom | [inline]
GetSize32() const | AP4_Atom | [inline]
GetSize64() const | AP4_Atom | [inline]
GetTrackIds() | AP4_TrefTypeAtom | [inline]
GetType() const | AP4_Atom | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
InspectFields(AP4_AtomInspector &inspector) | AP4_TrefTypeAtom | [virtual]
InspectHeader(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
m_Flags | AP4_Atom | [protected]
m_IsFull | AP4_Atom | [protected]
m_Parent | AP4_Atom | [protected]
m_Size32 | AP4_Atom | [protected]
m_Size64 | AP4_Atom | [protected]
m_Type | AP4_Atom | [protected]
m_Version | AP4_Atom | [protected]
ReadFullHeader(AP4_ByteStream &stream, AP4_UI32 &version, AP4_UI32 &flags) | AP4_Atom | [static]
SetFlags(AP4_UI32 flags) | AP4_Atom | [inline]
SetParent(AP4_AtomParent *parent) | AP4_Atom | [inline, virtual]
SetSize(AP4_UI64 size, bool force_64=false) | AP4_Atom |
SetSize32(AP4_UI32 size) | AP4_Atom | [inline]
SetSize64(AP4_UI64 size) | AP4_Atom | [inline]
SetType(Type type) | AP4_Atom | [inline]
Type typedef | AP4_Atom |
TypeFromString(const char *four_cc) | AP4_Atom | [static]
Write(AP4_ByteStream &stream) | AP4_Atom | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_TrefTypeAtom | [virtual]
WriteHeader(AP4_ByteStream &stream) | AP4_Atom | [virtual]
~AP4_Atom() | AP4_Atom | [inline, virtual]
Generated on Thu May 13 16:37:53 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_TrexAtom Class Reference

AP4_TrexAtom Class Reference

#include <Ap4TrexAtom.h>

Inheritance diagram for AP4_TrexAtom:
AP4_Atom

List of all members.

Public Member Functions

AP4_TrexAtom (AP4_UI32 track_id, AP4_UI32 default_sample_description_index, AP4_UI32 default_sample_duration, AP4_UI32 default_sample_size, AP4_UI32 default_sample_flags)
virtual AP4_Result | InspectFields (AP4_AtomInspector &inspector)
virtual AP4_Result | WriteFields (AP4_ByteStream &stream)
AP4_UI32 GetTrackId ()
AP4_UI32 GetDefaultSampleDescriptionIndex ()
AP4_UI32 GetDefaultSampleDuration ()
AP4_UI32 GetDefaultSampleSize ()
AP4_UI32 GetDefaultSampleFlags ()

Static Public Member Functions

static AP4_TrexAtom * | Create (AP4_Size size, AP4_ByteStream &stream)

Detailed Description

Definition at line 46 of file Ap4TrexAtom.h.

Constructor & Destructor Documentation

AP4_TrexAtom::AP4_TrexAtom | ( | AP4_UI32 | track_id,
 |  | AP4_UI32 | default_sample_description_index,
 |  | AP4_UI32 | default_sample_duration,
 |  | AP4_UI32 | default_sample_size,
 |  | AP4_UI32 | default_sample_flags
 | ) |  |

Member Function Documentation

static AP4_TrexAtom* AP4_TrexAtom::Create | ( | AP4_Size | size,
 |  | AP4_ByteStream & | stream |
 | ) |  |  | [static]
AP4_UI32 AP4_TrexAtom::GetDefaultSampleDescriptionIndex ( ) [inline]

Definition at line 65 of file Ap4TrexAtom.h.

AP4_UI32 AP4_TrexAtom::GetDefaultSampleDuration ( ) [inline]

Definition at line 66 of file Ap4TrexAtom.h.

AP4_UI32 AP4_TrexAtom::GetDefaultSampleFlags ( ) [inline]

Definition at line 68 of file Ap4TrexAtom.h.

AP4_UI32 AP4_TrexAtom::GetDefaultSampleSize ( ) [inline]

Definition at line 67 of file Ap4TrexAtom.h.

AP4_UI32 AP4_TrexAtom::GetTrackId ( ) [inline]

Definition at line 64 of file Ap4TrexAtom.h.

virtual AP4_Result AP4_TrexAtom::InspectFields ( AP4_AtomInspector & inspector ) [virtual]

Reimplemented from AP4_Atom.

virtual AP4_Result AP4_TrexAtom::WriteFields ( AP4_ByteStream & stream ) [virtual]

Implements AP4_Atom.

The documentation for this class was generated from the following file:
  • Ap4TrexAtom.h
Generated on Thu May 13 16:37:53 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_TrexAtom Member List

This is the complete list of members for AP4_TrexAtom, including all inherited members.
AP4_Atom(Type type, AP4_UI32 size=AP4_ATOM_HEADER_SIZE) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64=false) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_TrexAtom(AP4_UI32 track_id, AP4_UI32 default_sample_description_index, AP4_UI32 default_sample_duration, AP4_UI32 default_sample_size, AP4_UI32 default_sample_flags) | AP4_TrexAtom |
Clone() | AP4_Atom | [virtual]
Create(AP4_Size size, AP4_ByteStream &stream) | AP4_TrexAtom | [static]
Detach() | AP4_Atom | [virtual]
GetDefaultSampleDescriptionIndex() | AP4_TrexAtom | [inline]
GetDefaultSampleDuration() | AP4_TrexAtom | [inline]
GetDefaultSampleFlags() | AP4_TrexAtom | [inline]
GetDefaultSampleSize() | AP4_TrexAtom | [inline]
GetFlags() const | AP4_Atom | [inline]
GetHeaderSize() const | AP4_Atom | [virtual]
GetParent() | AP4_Atom | [inline, virtual]
GetSize() const | AP4_Atom | [inline]
GetSize32() const | AP4_Atom | [inline]
GetSize64() const | AP4_Atom | [inline]
GetTrackId() | AP4_TrexAtom | [inline]
GetType() const | AP4_Atom | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
InspectFields(AP4_AtomInspector &inspector) | AP4_TrexAtom | [virtual]
InspectHeader(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
m_Flags | AP4_Atom | [protected]
m_IsFull | AP4_Atom | [protected]
m_Parent | AP4_Atom | [protected]
m_Size32 | AP4_Atom | [protected]
m_Size64 | AP4_Atom | [protected]
m_Type | AP4_Atom | [protected]
m_Version | AP4_Atom | [protected]
ReadFullHeader(AP4_ByteStream &stream, AP4_UI32 &version, AP4_UI32 &flags) | AP4_Atom | [static]
SetFlags(AP4_UI32 flags) | AP4_Atom | [inline]
SetParent(AP4_AtomParent *parent) | AP4_Atom | [inline, virtual]
SetSize(AP4_UI64 size, bool force_64=false) | AP4_Atom |
SetSize32(AP4_UI32 size) | AP4_Atom | [inline]
SetSize64(AP4_UI64 size) | AP4_Atom | [inline]
SetType(Type type) | AP4_Atom | [inline]
Type typedef | AP4_Atom |
TypeFromString(const char *four_cc) | AP4_Atom | [static]
Write(AP4_ByteStream &stream) | AP4_Atom | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_TrexAtom | [virtual]
WriteHeader(AP4_ByteStream &stream) | AP4_Atom | [virtual]
~AP4_Atom() | AP4_Atom | [inline, virtual]
Generated on Thu May 13 16:37:53 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_TrunAtom Class Reference

AP4_TrunAtom Class Reference

#include <Ap4TrunAtom.h>

Inheritance diagram for AP4_TrunAtom:
AP4_Atom

List of all members.

Classes

struct | Entry

Public Member Functions

AP4_TrunAtom (AP4_UI32 flags, AP4_SI32 data_offset, AP4_UI32 first_sample_flags)
virtual AP4_Result | InspectFields (AP4_AtomInspector &inspector)
virtual AP4_Result | WriteFields (AP4_ByteStream &stream)
AP4_SI32 GetDataOffset ()
AP4_UI32 GetFirstSampleFlags ()
const AP4_Array< Entry > & | GetEntries ()

Static Public Member Functions

static AP4_TrunAtom * | Create (AP4_Size size, AP4_ByteStream &stream)
static unsigned int | ComputeOptionalFieldsCount (AP4_UI32 flags)
static unsigned int | ComputeRecordFieldsCount (AP4_UI32 flags)

Detailed Description

Definition at line 51 of file Ap4TrunAtom.h.

Constructor & Destructor Documentation

AP4_TrunAtom::AP4_TrunAtom | ( | AP4_UI32 | flags,
 |  | AP4_SI32 | data_offset,
 |  | AP4_UI32 | first_sample_flags
 | ) |  |

Member Function Documentation

static unsigned int AP4_TrunAtom::ComputeOptionalFieldsCount ( AP4_UI32 flags ) [static]
static unsigned int AP4_TrunAtom::ComputeRecordFieldsCount ( AP4_UI32 flags ) [static]
static AP4_TrunAtom* AP4_TrunAtom::Create | ( | AP4_Size | size,
 |  | AP4_ByteStream & | stream |
 | ) |  |  | [static]
AP4_SI32 AP4_TrunAtom::GetDataOffset ( ) [inline]

Definition at line 78 of file Ap4TrunAtom.h.

const AP4_Array<Entry>& AP4_TrunAtom::GetEntries ( ) [inline]

Definition at line 80 of file Ap4TrunAtom.h.

AP4_UI32 AP4_TrunAtom::GetFirstSampleFlags ( ) [inline]

Definition at line 79 of file Ap4TrunAtom.h.

virtual AP4_Result AP4_TrunAtom::InspectFields ( AP4_AtomInspector & inspector ) [virtual]

Reimplemented from AP4_Atom.

virtual AP4_Result AP4_TrunAtom::WriteFields ( AP4_ByteStream & stream ) [virtual]

Implements AP4_Atom.

The documentation for this class was generated from the following file:
  • Ap4TrunAtom.h
Generated on Thu May 13 16:37:54 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_TrunAtom Member List

This is the complete list of members for AP4_TrunAtom, including all inherited members.
AP4_Atom(Type type, AP4_UI32 size=AP4_ATOM_HEADER_SIZE) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64=false) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_TrunAtom(AP4_UI32 flags, AP4_SI32 data_offset, AP4_UI32 first_sample_flags) | AP4_TrunAtom |
Clone() | AP4_Atom | [virtual]
ComputeOptionalFieldsCount(AP4_UI32 flags) | AP4_TrunAtom | [static]
ComputeRecordFieldsCount(AP4_UI32 flags) | AP4_TrunAtom | [static]
Create(AP4_Size size, AP4_ByteStream &stream) | AP4_TrunAtom | [static]
Detach() | AP4_Atom | [virtual]
GetDataOffset() | AP4_TrunAtom | [inline]
GetEntries() | AP4_TrunAtom | [inline]
GetFirstSampleFlags() | AP4_TrunAtom | [inline]
GetFlags() const | AP4_Atom | [inline]
GetHeaderSize() const | AP4_Atom | [virtual]
GetParent() | AP4_Atom | [inline, virtual]
GetSize() const | AP4_Atom | [inline]
GetSize32() const | AP4_Atom | [inline]
GetSize64() const | AP4_Atom | [inline]
GetType() const | AP4_Atom | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
InspectFields(AP4_AtomInspector &inspector) | AP4_TrunAtom | [virtual]
InspectHeader(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
m_Flags | AP4_Atom | [protected]
m_IsFull | AP4_Atom | [protected]
m_Parent | AP4_Atom | [protected]
m_Size32 | AP4_Atom | [protected]
m_Size64 | AP4_Atom | [protected]
m_Type | AP4_Atom | [protected]
m_Version | AP4_Atom | [protected]
ReadFullHeader(AP4_ByteStream &stream, AP4_UI32 &version, AP4_UI32 &flags) | AP4_Atom | [static]
SetFlags(AP4_UI32 flags) | AP4_Atom | [inline]
SetParent(AP4_AtomParent *parent) | AP4_Atom | [inline, virtual]
SetSize(AP4_UI64 size, bool force_64=false) | AP4_Atom |
SetSize32(AP4_UI32 size) | AP4_Atom | [inline]
SetSize64(AP4_UI64 size) | AP4_Atom | [inline]
SetType(Type type) | AP4_Atom | [inline]
Type typedef | AP4_Atom |
TypeFromString(const char *four_cc) | AP4_Atom | [static]
Write(AP4_ByteStream &stream) | AP4_Atom | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_TrunAtom | [virtual]
WriteHeader(AP4_ByteStream &stream) | AP4_Atom | [virtual]
~AP4_Atom() | AP4_Atom | [inline, virtual]
Generated on Thu May 13 16:37:54 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_UI64 Struct Reference

AP4_UI64 Struct Reference

#include <Ap4Types.h>

List of all members.

Public Attributes

AP4_UI32 hi
AP4_UI32 lo

Detailed Description

Definition at line 63 of file Ap4Types.h.

Member Data Documentation

AP4_UI32 AP4_UI64::hi

Definition at line 64 of file Ap4Types.h.

AP4_UI32 AP4_UI64::lo

Definition at line 65 of file Ap4Types.h.

The documentation for this struct was generated from the following file:
  • Ap4Types.h
Generated on Thu May 13 16:37:56 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_UI64 Member List

This is the complete list of members for AP4_UI64, including all inherited members.
hi | AP4_UI64
lo | AP4_UI64
Generated on Thu May 13 16:37:56 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_UnknownAtom Class Reference

AP4_UnknownAtom Class Reference

Class that represents atoms for which there is no specific support. More...

#include <Ap4Atom.h>

Inheritance diagram for AP4_UnknownAtom:
AP4_Atom

List of all members.

Public Member Functions

AP4_UnknownAtom (AP4_Atom::Type type, AP4_UI64 size, AP4_ByteStream &stream)
AP4_UnknownAtom (AP4_Atom::Type type, const AP4_UI08 *payload, AP4_Size payload_size)
AP4_UnknownAtom (const AP4_UnknownAtom &other)
~AP4_UnknownAtom ()
virtual AP4_Result | WriteFields (AP4_ByteStream &stream)
virtual AP4_Atom * | Clone ()
Create a clone of the object.

Detailed Description

Class that represents atoms for which there is no specific support.

Instances of this class keep a reference to the stream from which the atom is parsed, so that it can read the atom's payload when it is serialized. If the atom is small, its payload is actually read and stored in a data buffer, so no reference to the source stream is kept

Definition at line 290 of file Ap4Atom.h.

Constructor & Destructor Documentation

AP4_UnknownAtom::AP4_UnknownAtom | ( | AP4_Atom::Type | type,
 |  | AP4_UI64 | size,
 |  | AP4_ByteStream & | stream
 | ) |  |
AP4_UnknownAtom::AP4_UnknownAtom | ( | AP4_Atom::Type | type,
 |  | const AP4_UI08 * | payload,
 |  | AP4_Size | payload_size
 | ) |  |
AP4_UnknownAtom::AP4_UnknownAtom ( const AP4_UnknownAtom & other )
AP4_UnknownAtom::~AP4_UnknownAtom ( )

Member Function Documentation

virtual AP4_Atom* AP4_UnknownAtom::Clone ( ) [virtual]

Create a clone of the object.

This method returns a clone of the atom, or NULL if the atom cannot be cloned. Override this if your want to make an atom cloneable in a more efficient way than the default implementation.

Reimplemented from AP4_Atom.

virtual AP4_Result AP4_UnknownAtom::WriteFields ( AP4_ByteStream & stream ) [virtual]

Implements AP4_Atom.

The documentation for this class was generated from the following file:
  • Ap4Atom.h
Generated on Thu May 13 16:37:56 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_UnknownAtom Member List

This is the complete list of members for AP4_UnknownAtom, including all inherited members.
AP4_Atom(Type type, AP4_UI32 size=AP4_ATOM_HEADER_SIZE) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64=false) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_UnknownAtom(AP4_Atom::Type type, AP4_UI64 size, AP4_ByteStream &stream) | AP4_UnknownAtom |
AP4_UnknownAtom(AP4_Atom::Type type, const AP4_UI08 *payload, AP4_Size payload_size) | AP4_UnknownAtom |
AP4_UnknownAtom(const AP4_UnknownAtom &other) | AP4_UnknownAtom |
Clone() | AP4_UnknownAtom | [virtual]
Detach() | AP4_Atom | [virtual]
GetFlags() const | AP4_Atom | [inline]
GetHeaderSize() const | AP4_Atom | [virtual]
GetParent() | AP4_Atom | [inline, virtual]
GetSize() const | AP4_Atom | [inline]
GetSize32() const | AP4_Atom | [inline]
GetSize64() const | AP4_Atom | [inline]
GetType() const | AP4_Atom | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
InspectFields(AP4_AtomInspector &) | AP4_Atom | [inline, virtual]
InspectHeader(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
m_Flags | AP4_Atom | [protected]
m_IsFull | AP4_Atom | [protected]
m_Parent | AP4_Atom | [protected]
m_Size32 | AP4_Atom | [protected]
m_Size64 | AP4_Atom | [protected]
m_Type | AP4_Atom | [protected]
m_Version | AP4_Atom | [protected]
ReadFullHeader(AP4_ByteStream &stream, AP4_UI32 &version, AP4_UI32 &flags) | AP4_Atom | [static]
SetFlags(AP4_UI32 flags) | AP4_Atom | [inline]
SetParent(AP4_AtomParent *parent) | AP4_Atom | [inline, virtual]
SetSize(AP4_UI64 size, bool force_64=false) | AP4_Atom |
SetSize32(AP4_UI32 size) | AP4_Atom | [inline]
SetSize64(AP4_UI64 size) | AP4_Atom | [inline]
SetType(Type type) | AP4_Atom | [inline]
Type typedef | AP4_Atom |
TypeFromString(const char *four_cc) | AP4_Atom | [static]
Write(AP4_ByteStream &stream) | AP4_Atom | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_UnknownAtom | [virtual]
WriteHeader(AP4_ByteStream &stream) | AP4_Atom | [virtual]
~AP4_Atom() | AP4_Atom | [inline, virtual]
~AP4_UnknownAtom() | AP4_UnknownAtom |
Generated on Thu May 13 16:37:56 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_UnknownCommand Class Reference

AP4_UnknownCommand Class Reference

#include <Ap4Command.h>

Inheritance diagram for AP4_UnknownCommand:
AP4_Command AP4_Expandable

List of all members.

Public Member Functions

AP4_UnknownCommand (AP4_ByteStream &stream, AP4_UI08 tag, AP4_Size header_size, AP4_Size payload_size)
virtual AP4_Result WriteFields (AP4_ByteStream &stream)

Detailed Description

Definition at line 72 of file Ap4Command.h.

Constructor & Destructor Documentation

AP4_UnknownCommand::AP4_UnknownCommand | ( | AP4_ByteStream & | stream,
 |  | AP4_UI08 | tag,
 |  | AP4_Size | header_size,
 |  | AP4_Size | payload_size
 | ) |  |

Member Function Documentation

virtual AP4_Result AP4_UnknownCommand::WriteFields ( AP4_ByteStream & stream ) [virtual]

Implements AP4_Expandable.

The documentation for this class was generated from the following file:
  • Ap4Command.h
Generated on Thu May 13 16:37:56 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_UnknownCommand Member List

This is the complete list of members for AP4_UnknownCommand, including all inherited members.
AP4_Command(AP4_UI08 tag, AP4_Size header_size, AP4_Size payload_size) | AP4_Command | [inline]
AP4_Expandable(AP4_UI32 class_id, ClassIdSize class_id_size, AP4_Size header_size, AP4_Size payload_size) | AP4_Expandable |
AP4_UnknownCommand(AP4_ByteStream &stream, AP4_UI08 tag, AP4_Size header_size, AP4_Size payload_size) | AP4_UnknownCommand |
CLASS_ID_SIZE_08 enum value | AP4_Expandable |
ClassIdSize enum name | AP4_Expandable |
GetClassId() | AP4_Expandable | [inline]
GetHeaderSize() | AP4_Expandable | [inline]
GetSize() | AP4_Expandable | [inline]
GetTag() | AP4_Command | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_Command | [virtual]
m_ClassId | AP4_Expandable | [protected]
m_ClassIdSize | AP4_Expandable | [protected]
m_HeaderSize | AP4_Expandable | [protected]
m_PayloadSize | AP4_Expandable | [protected]
MinHeaderSize(AP4_Size payload_size) | AP4_Expandable | [static]
Write(AP4_ByteStream &stream) | AP4_Expandable | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_UnknownCommand | [virtual]
~AP4_Expandable() | AP4_Expandable | [inline, virtual]
Generated on Thu May 13 16:37:56 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_UnknownDescriptor Class Reference

AP4_UnknownDescriptor Class Reference

#include <Ap4Descriptor.h>

Inheritance diagram for AP4_UnknownDescriptor:
AP4_Descriptor AP4_Expandable

List of all members.

Public Member Functions

AP4_UnknownDescriptor (AP4_ByteStream &stream, AP4_UI08 tag, AP4_Size header_size, AP4_Size payload_size)
virtual AP4_Result WriteFields (AP4_ByteStream &stream)

Detailed Description

Definition at line 67 of file Ap4Descriptor.h.

Constructor & Destructor Documentation

AP4_UnknownDescriptor::AP4_UnknownDescriptor | ( | AP4_ByteStream & | stream,
 |  | AP4_UI08 | tag,
 |  | AP4_Size | header_size,
 |  | AP4_Size | payload_size
 | ) |  |

Member Function Documentation

virtual AP4_Result AP4_UnknownDescriptor::WriteFields ( AP4_ByteStream & stream ) [virtual]

Implements AP4_Expandable.

The documentation for this class was generated from the following file:
  • Ap4Descriptor.h
Generated on Thu May 13 16:37:56 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_UnknownDescriptor Member List

This is the complete list of members for AP4_UnknownDescriptor, including all inherited members.
AP4_Descriptor(AP4_UI08 tag, AP4_Size header_size, AP4_Size payload_size) | AP4_Descriptor | [inline]
AP4_Expandable(AP4_UI32 class_id, ClassIdSize class_id_size, AP4_Size header_size, AP4_Size payload_size) | AP4_Expandable |
AP4_UnknownDescriptor(AP4_ByteStream &stream, AP4_UI08 tag, AP4_Size header_size, AP4_Size payload_size) | AP4_UnknownDescriptor |
CLASS_ID_SIZE_08 enum value | AP4_Expandable |
ClassIdSize enum name | AP4_Expandable |
GetClassId() | AP4_Expandable | [inline]
GetHeaderSize() | AP4_Expandable | [inline]
GetSize() | AP4_Expandable | [inline]
GetTag() | AP4_Descriptor | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_Descriptor | [virtual]
m_ClassId | AP4_Expandable | [protected]
m_ClassIdSize | AP4_Expandable | [protected]
m_HeaderSize | AP4_Expandable | [protected]
m_PayloadSize | AP4_Expandable | [protected]
MinHeaderSize(AP4_Size payload_size) | AP4_Expandable | [static]
Write(AP4_ByteStream &stream) | AP4_Expandable | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_UnknownDescriptor | [virtual]
~AP4_Expandable() | AP4_Expandable | [inline, virtual]
Generated on Thu May 13 16:37:56 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_UnknownExpandable Class Reference

AP4_UnknownExpandable Class Reference

#include <Ap4Expandable.h>

Inheritance diagram for AP4_UnknownExpandable:
AP4_Expandable

List of all members.

Public Member Functions

AP4_UnknownExpandable (AP4_ByteStream &stream, AP4_UI32 class_id, ClassIdSize class_id_size, AP4_Size header_size, AP4_Size payload_size)
virtual AP4_Result WriteFields (AP4_ByteStream &stream)

Detailed Description

Definition at line 82 of file Ap4Expandable.h.

Constructor & Destructor Documentation

AP4_UnknownExpandable::AP4_UnknownExpandable | ( | AP4_ByteStream & | stream,
 |  | AP4_UI32 | class_id,
 |  | ClassIdSize | class_id_size,
 |  | AP4_Size | header_size,
 |  | AP4_Size | payload_size
 | ) |  |

Member Function Documentation

virtual AP4_Result AP4_UnknownExpandable::WriteFields ( AP4_ByteStream & stream ) [virtual]

Implements AP4_Expandable.

The documentation for this class was generated from the following file:
  • Ap4Expandable.h
Generated on Thu May 13 16:37:56 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_UnknownExpandable Member List

This is the complete list of members for AP4_UnknownExpandable, including all inherited members.
AP4_Expandable(AP4_UI32 class_id, ClassIdSize class_id_size, AP4_Size header_size, AP4_Size payload_size) | AP4_Expandable |
AP4_UnknownExpandable(AP4_ByteStream &stream, AP4_UI32 class_id, ClassIdSize class_id_size, AP4_Size header_size, AP4_Size payload_size) | AP4_UnknownExpandable |
CLASS_ID_SIZE_08 enum value | AP4_Expandable |
ClassIdSize enum name | AP4_Expandable |
GetClassId() | AP4_Expandable | [inline]
GetHeaderSize() | AP4_Expandable | [inline]
GetSize() | AP4_Expandable | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_Expandable | [virtual]
m_ClassId | AP4_Expandable | [protected]
m_ClassIdSize | AP4_Expandable | [protected]
m_HeaderSize | AP4_Expandable | [protected]
m_PayloadSize | AP4_Expandable | [protected]
MinHeaderSize(AP4_Size payload_size) | AP4_Expandable | [static]
Write(AP4_ByteStream &stream) | AP4_Expandable | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_UnknownExpandable | [virtual]
~AP4_Expandable() | AP4_Expandable | [inline, virtual]
Generated on Thu May 13 16:37:57 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_UnknownSampleDescription Class Reference

AP4_UnknownSampleDescription Class Reference

#include <Ap4SampleDescription.h>

Inheritance diagram for AP4_UnknownSampleDescription:
AP4_SampleDescription

List of all members.

Public Member Functions

AP4_UnknownSampleDescription (AP4_Atom *atom)
~AP4_UnknownSampleDescription ()
virtual AP4_SampleDescription * | Clone (AP4_Result *result)
virtual AP4_Atom * | ToAtom () const
const AP4_Atom * | GetAtom ()

Detailed Description

Definition at line 126 of file Ap4SampleDescription.h.

Constructor & Destructor Documentation

AP4_UnknownSampleDescription::AP4_UnknownSampleDescription ( AP4_Atom * atom )
AP4_UnknownSampleDescription::~AP4_UnknownSampleDescription ( )

Member Function Documentation

virtual AP4_SampleDescription* AP4_UnknownSampleDescription::Clone ( AP4_Result * result ) [virtual]

Reimplemented from AP4_SampleDescription.

const AP4_Atom* AP4_UnknownSampleDescription::GetAtom ( ) [inline]

Definition at line 139 of file Ap4SampleDescription.h.

virtual AP4_Atom* AP4_UnknownSampleDescription::ToAtom ( ) const [virtual]

Reimplemented from AP4_SampleDescription.

The documentation for this class was generated from the following file:
  • Ap4SampleDescription.h
Generated on Thu May 13 16:37:57 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_UnknownSampleDescription Member List

This is the complete list of members for AP4_UnknownSampleDescription, including all inherited members.
AP4_SampleDescription(Type type, AP4_UI32 format, AP4_AtomParent *details) | AP4_SampleDescription |
AP4_UnknownSampleDescription(AP4_Atom *atom) | AP4_UnknownSampleDescription |
Clone(AP4_Result *result) | AP4_UnknownSampleDescription | [virtual]
GetAtom() | AP4_UnknownSampleDescription | [inline]
GetDetails() | AP4_SampleDescription | [inline]
GetFormat() const | AP4_SampleDescription | [inline]
GetType() const | AP4_SampleDescription | [inline]
m_Details | AP4_SampleDescription | [protected]
m_Format | AP4_SampleDescription | [protected]
m_Type | AP4_SampleDescription | [protected]
ToAtom() const | AP4_UnknownSampleDescription | [virtual]
Type enum name | AP4_SampleDescription |
TYPE_AVC enum value | AP4_SampleDescription |
TYPE_MPEG enum value | AP4_SampleDescription |
TYPE_PROTECTED enum value | AP4_SampleDescription |
TYPE_UNKNOWN enum value | AP4_SampleDescription |
~AP4_SampleDescription() | AP4_SampleDescription | [inline, virtual]
~AP4_UnknownSampleDescription() | AP4_UnknownSampleDescription |
Generated on Thu May 13 16:37:57 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_UnknownSampleEntry Class Reference

AP4_UnknownSampleEntry Class Reference

#include <Ap4SampleEntry.h>

Inheritance diagram for AP4_UnknownSampleEntry:
AP4_SampleEntry AP4_ContainerAtom AP4_Atom AP4_AtomParent

List of all members.

Public Member Functions

AP4_UnknownSampleEntry (AP4_Atom::Type type, AP4_Size size, AP4_ByteStream &stream)
virtual AP4_SampleDescription * | ToSampleDescription ()
const AP4_DataBuffer & | GetPayload ()

Protected Member Functions

virtual AP4_Size | GetFieldsSize ()
virtual AP4_Result | ReadFields (AP4_ByteStream &stream)
virtual AP4_Result | WriteFields (AP4_ByteStream &stream)

Protected Attributes

AP4_DataBuffer m_Payload

Detailed Description

Definition at line 91 of file Ap4SampleEntry.h.

Constructor & Destructor Documentation

AP4_UnknownSampleEntry::AP4_UnknownSampleEntry | ( | AP4_Atom::Type | type,
 |  | AP4_Size | size,
 |  | AP4_ByteStream & | stream
 | ) |  |

Member Function Documentation

virtual AP4_Size AP4_UnknownSampleEntry::GetFieldsSize ( ) [protected, virtual]

Reimplemented from AP4_SampleEntry.

const AP4_DataBuffer& AP4_UnknownSampleEntry::GetPayload ( ) [inline]

Definition at line 101 of file Ap4SampleEntry.h.

References m_Payload.

virtual AP4_Result AP4_UnknownSampleEntry::ReadFields ( AP4_ByteStream & stream ) [protected, virtual]

Reimplemented from AP4_SampleEntry.

virtual AP4_SampleDescription* AP4_UnknownSampleEntry::ToSampleDescription ( ) [virtual]

Reimplemented from AP4_SampleEntry.

virtual AP4_Result AP4_UnknownSampleEntry::WriteFields ( AP4_ByteStream & stream ) [protected, virtual]

Reimplemented from AP4_SampleEntry.

Member Data Documentation

AP4_DataBuffer AP4_UnknownSampleEntry::m_Payload [protected]

Definition at line 110 of file Ap4SampleEntry.h.

Referenced by GetPayload().

The documentation for this class was generated from the following file:
  • Ap4SampleEntry.h
Generated on Thu May 13 16:38:10 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_UnknownSampleEntry Member List

This is the complete list of members for AP4_UnknownSampleEntry, including all inherited members.
AddChild(AP4_Atom *child, int position=-1) | AP4_AtomParent | [virtual]
AP4_Atom(Type type, AP4_UI32 size=AP4_ATOM_HEADER_SIZE) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64=false) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_ContainerAtom(Type type) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI32 version, AP4_UI32 flags) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_ContainerAtom | [protected]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_ContainerAtom | [protected]
AP4_SampleEntry(AP4_Atom::Type format, AP4_UI16 data_ref_index=1) | AP4_SampleEntry |
AP4_SampleEntry(AP4_Atom::Type format, AP4_Size size, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_SampleEntry |
AP4_SampleEntry(AP4_Atom::Type format, AP4_Size size) | AP4_SampleEntry | [protected]
AP4_UnknownSampleEntry(AP4_Atom::Type type, AP4_Size size, AP4_ByteStream &stream) | AP4_UnknownSampleEntry |
Clone() | AP4_ContainerAtom | [virtual]
Create(Type type, AP4_UI64 size, bool is_full, bool force_64, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_ContainerAtom | [static]
DeleteChild(AP4_Atom::Type type, AP4_Ordinal index=0) | AP4_AtomParent | [virtual]
Detach() | AP4_Atom | [virtual]
FindChild(const char *path, bool auto_create=false, bool auto_create_full=false) | AP4_AtomParent | [virtual]
GetChild(AP4_Atom::Type type, AP4_Ordinal index=0) const | AP4_AtomParent | [virtual]
GetChild(const AP4_UI08 *uuid, AP4_Ordinal index=0) const | AP4_AtomParent | [virtual]
GetChildren() | AP4_ContainerAtom | [inline]
GetDataReferenceIndex() | AP4_SampleEntry | [inline]
GetFieldsSize() | AP4_UnknownSampleEntry | [protected, virtual]
GetFlags() const | AP4_Atom | [inline]
GetHeaderSize() const | AP4_Atom | [virtual]
GetParent() | AP4_Atom | [inline, virtual]
GetPayload() | AP4_UnknownSampleEntry | [inline]
GetSize() const | AP4_Atom | [inline]
GetSize32() const | AP4_Atom | [inline]
GetSize64() const | AP4_Atom | [inline]
GetType() const | AP4_Atom | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_SampleEntry | [virtual]
InspectChildren(AP4_AtomInspector &inspector) | AP4_ContainerAtom | [virtual]
InspectFields(AP4_AtomInspector &inspector) | AP4_SampleEntry | [protected, virtual]
InspectHeader(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
m_Children | AP4_AtomParent | [protected]
m_DataReferenceIndex | AP4_SampleEntry | [protected]
m_Flags | AP4_Atom | [protected]
m_IsFull | AP4_Atom | [protected]
m_Parent | AP4_Atom | [protected]
m_Payload | AP4_UnknownSampleEntry | [protected]
m_Reserved1 | AP4_SampleEntry | [protected]
m_Size32 | AP4_Atom | [protected]
m_Size64 | AP4_Atom | [protected]
m_Type | AP4_Atom | [protected]
m_Version | AP4_Atom | [protected]
OnChildAdded(AP4_Atom *child) | AP4_ContainerAtom | [virtual]
OnChildChanged(AP4_Atom *child) | AP4_SampleEntry | [virtual]
OnChildRemoved(AP4_Atom *child) | AP4_ContainerAtom | [virtual]
Read(AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_SampleEntry | [protected, virtual]
ReadChildren(AP4_AtomFactory &atom_factory, AP4_ByteStream &stream, AP4_UI64 size) | AP4_ContainerAtom | [protected]
ReadFields(AP4_ByteStream &stream) | AP4_UnknownSampleEntry | [protected, virtual]
ReadFullHeader(AP4_ByteStream &stream, AP4_UI32 &version, AP4_UI32 &flags) | AP4_Atom | [static]
RemoveChild(AP4_Atom *child) | AP4_AtomParent | [virtual]
SetFlags(AP4_UI32 flags) | AP4_Atom | [inline]
SetParent(AP4_AtomParent *parent) | AP4_Atom | [inline, virtual]
SetSize(AP4_UI64 size, bool force_64=false) | AP4_Atom |
SetSize32(AP4_UI32 size) | AP4_Atom | [inline]
SetSize64(AP4_UI64 size) | AP4_Atom | [inline]
SetType(Type type) | AP4_Atom | [inline]
ToSampleDescription() | AP4_UnknownSampleEntry | [virtual]
Type typedef | AP4_Atom |
TypeFromString(const char *four_cc) | AP4_Atom | [static]
Write(AP4_ByteStream &stream) | AP4_SampleEntry | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_UnknownSampleEntry | [protected, virtual]
WriteHeader(AP4_ByteStream &stream) | AP4_Atom | [virtual]
~AP4_Atom() | AP4_Atom | [inline, virtual]
~AP4_AtomParent() | AP4_AtomParent | [virtual]
~AP4_SampleEntry() | AP4_SampleEntry | [inline, virtual]
Generated on Thu May 13 16:38:10 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_UnknownUuidAtom Class Reference

AP4_UnknownUuidAtom Class Reference

Unknown uuid atoms. More...

#include <Ap4UuidAtom.h>

Inheritance diagram for AP4_UnknownUuidAtom:
AP4_UuidAtom AP4_Atom

List of all members.

Public Member Functions

AP4_UnknownUuidAtom (AP4_UI64 size, AP4_ByteStream &stream)
AP4_UnknownUuidAtom (AP4_UI64 size, const AP4_UI08 *uuid, AP4_ByteStream &stream)
virtual AP4_Result WriteFields (AP4_ByteStream &stream)

Protected Attributes

AP4_DataBuffer m_Data

Detailed Description

Unknown uuid atoms.

Definition at line 83 of file Ap4UuidAtom.h.

Constructor & Destructor Documentation

AP4_UnknownUuidAtom::AP4_UnknownUuidAtom | ( | AP4_UI64 | size,
 |  | AP4_ByteStream & | stream
 | ) |  |
AP4_UnknownUuidAtom::AP4_UnknownUuidAtom | ( | AP4_UI64 | size,
 |  | const AP4_UI08 * | uuid,
 |  | AP4_ByteStream & | stream
 | ) |  |

Member Function Documentation

virtual AP4_Result AP4_UnknownUuidAtom::WriteFields ( AP4_ByteStream & stream ) [virtual]

Implements AP4_Atom.

Member Data Documentation

AP4_DataBuffer AP4_UnknownUuidAtom::m_Data [protected]

Definition at line 96 of file Ap4UuidAtom.h.

The documentation for this class was generated from the following file:
  • Ap4UuidAtom.h
Generated on Thu May 13 16:38:10 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_UnknownUuidAtom Member List

This is the complete list of members for AP4_UnknownUuidAtom, including all inherited members.
AP4_Atom(Type type, AP4_UI32 size=AP4_ATOM_HEADER_SIZE) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64=false) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_UnknownUuidAtom(AP4_UI64 size, AP4_ByteStream &stream) | AP4_UnknownUuidAtom |
AP4_UnknownUuidAtom(AP4_UI64 size, const AP4_UI08 *uuid, AP4_ByteStream &stream) | AP4_UnknownUuidAtom |
AP4_UuidAtom(AP4_UI64 size, const AP4_UI08 *uuid) | AP4_UuidAtom | [protected]
AP4_UuidAtom(AP4_UI64 size, const AP4_UI08 *uuid, AP4_UI32 version, AP4_UI32 flags) | AP4_UuidAtom | [protected]
AP4_UuidAtom(AP4_UI64 size, bool is_full, AP4_ByteStream &stream) | AP4_UuidAtom | [protected]
Clone() | AP4_Atom | [virtual]
Detach() | AP4_Atom | [virtual]
GetFlags() const | AP4_Atom | [inline]
GetHeaderSize() const | AP4_UuidAtom | [virtual]
GetParent() | AP4_Atom | [inline, virtual]
GetSize() const | AP4_Atom | [inline]
GetSize32() const | AP4_Atom | [inline]
GetSize64() const | AP4_Atom | [inline]
GetType() const | AP4_Atom | [inline]
GetUuid() | AP4_UuidAtom | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
InspectFields(AP4_AtomInspector &) | AP4_Atom | [inline, virtual]
InspectHeader(AP4_AtomInspector &inspector) | AP4_UuidAtom | [virtual]
m_Data | AP4_UnknownUuidAtom | [protected]
m_Flags | AP4_Atom | [protected]
m_IsFull | AP4_Atom | [protected]
m_Parent | AP4_Atom | [protected]
m_Size32 | AP4_Atom | [protected]
m_Size64 | AP4_Atom | [protected]
m_Type | AP4_Atom | [protected]
m_Uuid | AP4_UuidAtom | [protected]
m_Version | AP4_Atom | [protected]
ReadFullHeader(AP4_ByteStream &stream, AP4_UI32 &version, AP4_UI32 &flags) | AP4_Atom | [static]
SetFlags(AP4_UI32 flags) | AP4_Atom | [inline]
SetParent(AP4_AtomParent *parent) | AP4_Atom | [inline, virtual]
SetSize(AP4_UI64 size, bool force_64=false) | AP4_Atom |
SetSize32(AP4_UI32 size) | AP4_Atom | [inline]
SetSize64(AP4_UI64 size) | AP4_Atom | [inline]
SetType(Type type) | AP4_Atom | [inline]
Type typedef | AP4_Atom |
TypeFromString(const char *four_cc) | AP4_Atom | [static]
Write(AP4_ByteStream &stream) | AP4_Atom | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_UnknownUuidAtom | [virtual]
WriteHeader(AP4_ByteStream &stream) | AP4_UuidAtom | [virtual]
~AP4_Atom() | AP4_Atom | [inline, virtual]
~AP4_UuidAtom() | AP4_UuidAtom | [inline, virtual]
Generated on Thu May 13 16:38:10 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_UrlAtom Class Reference

AP4_UrlAtom Class Reference

#include <Ap4UrlAtom.h>

Inheritance diagram for AP4_UrlAtom:
AP4_Atom

List of all members.

Public Member Functions

AP4_UrlAtom ()
virtual AP4_Result | InspectFields (AP4_AtomInspector &inspector)
virtual AP4_Result | WriteFields (AP4_ByteStream &stream)

Static Public Member Functions

static AP4_UrlAtom * | Create (AP4_Size size, AP4_ByteStream &stream)

Detailed Description

Definition at line 41 of file Ap4UrlAtom.h.

Constructor & Destructor Documentation

AP4_UrlAtom::AP4_UrlAtom ( )

Member Function Documentation

static AP4_UrlAtom* AP4_UrlAtom::Create | ( | AP4_Size | size,
 |  | AP4_ByteStream & | stream |
 | ) |  |  | [static]
virtual AP4_Result AP4_UrlAtom::InspectFields ( AP4_AtomInspector & inspector ) [virtual]

Reimplemented from AP4_Atom.

virtual AP4_Result AP4_UrlAtom::WriteFields ( AP4_ByteStream & stream ) [virtual]

Implements AP4_Atom.

The documentation for this class was generated from the following file:
  • Ap4UrlAtom.h
Generated on Thu May 13 16:38:10 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_UrlAtom Member List

This is the complete list of members for AP4_UrlAtom, including all inherited members.
AP4_Atom(Type type, AP4_UI32 size=AP4_ATOM_HEADER_SIZE) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64=false) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_UrlAtom() | AP4_UrlAtom |
Clone() | AP4_Atom | [virtual]
Create(AP4_Size size, AP4_ByteStream &stream) | AP4_UrlAtom | [static]
Detach() | AP4_Atom | [virtual]
GetFlags() const | AP4_Atom | [inline]
GetHeaderSize() const | AP4_Atom | [virtual]
GetParent() | AP4_Atom | [inline, virtual]
GetSize() const | AP4_Atom | [inline]
GetSize32() const | AP4_Atom | [inline]
GetSize64() const | AP4_Atom | [inline]
GetType() const | AP4_Atom | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
InspectFields(AP4_AtomInspector &inspector) | AP4_UrlAtom | [virtual]
InspectHeader(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
m_Flags | AP4_Atom | [protected]
m_IsFull | AP4_Atom | [protected]
m_Parent | AP4_Atom | [protected]
m_Size32 | AP4_Atom | [protected]
m_Size64 | AP4_Atom | [protected]
m_Type | AP4_Atom | [protected]
m_Version | AP4_Atom | [protected]
ReadFullHeader(AP4_ByteStream &stream, AP4_UI32 &version, AP4_UI32 &flags) | AP4_Atom | [static]
SetFlags(AP4_UI32 flags) | AP4_Atom | [inline]
SetParent(AP4_AtomParent *parent) | AP4_Atom | [inline, virtual]
SetSize(AP4_UI64 size, bool force_64=false) | AP4_Atom |
SetSize32(AP4_UI32 size) | AP4_Atom | [inline]
SetSize64(AP4_UI64 size) | AP4_Atom | [inline]
SetType(Type type) | AP4_Atom | [inline]
Type typedef | AP4_Atom |
TypeFromString(const char *four_cc) | AP4_Atom | [static]
Write(AP4_ByteStream &stream) | AP4_Atom | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_UrlAtom | [virtual]
WriteHeader(AP4_ByteStream &stream) | AP4_Atom | [virtual]
~AP4_Atom() | AP4_Atom | [inline, virtual]
Generated on Thu May 13 16:38:10 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_UuidAtom Class Reference

AP4_UuidAtom Class Reference

Base class for uuid atoms. More...

#include <Ap4UuidAtom.h>

Inheritance diagram for AP4_UuidAtom:
AP4_Atom AP4_PiffSampleEncryptionAtom AP4_PiffTrackEncryptionAtom AP4_UnknownUuidAtom

List of all members.

Public Member Functions

virtual | ~AP4_UuidAtom ()
virtual AP4_Size | GetHeaderSize () const
virtual AP4_Result | WriteHeader (AP4_ByteStream &stream)
virtual AP4_Result | InspectHeader (AP4_AtomInspector &inspector)
const AP4_UI08 * | GetUuid ()

Protected Member Functions

AP4_UuidAtom (AP4_UI64 size, const AP4_UI08 *uuid)
AP4_UuidAtom (AP4_UI64 size, const AP4_UI08 *uuid, AP4_UI32 version, AP4_UI32 flags)
AP4_UuidAtom (AP4_UI64 size, bool is_full, AP4_ByteStream &stream)

Protected Attributes

AP4_UI08 | m_Uuid [16]

Detailed Description

Base class for uuid atoms.

Definition at line 54 of file Ap4UuidAtom.h.

Constructor & Destructor Documentation

virtual AP4_UuidAtom::~AP4_UuidAtom ( ) [inline, virtual]

Definition at line 59 of file Ap4UuidAtom.h.

AP4_UuidAtom::AP4_UuidAtom | ( | AP4_UI64 | size,
 |  | const AP4_UI08 * | uuid |
 | ) |  |  | [protected]
AP4_UuidAtom::AP4_UuidAtom | ( | AP4_UI64 | size,
 |  | const AP4_UI08 * | uuid,
 |  | AP4_UI32 | version,
 |  | AP4_UI32 | flags |
 | ) |  |  | [protected]
AP4_UuidAtom::AP4_UuidAtom | ( | AP4_UI64 | size,
 |  | bool | is_full,
 |  | AP4_ByteStream & | stream |
 | ) |  |  | [protected]

Member Function Documentation

virtual AP4_Size AP4_UuidAtom::GetHeaderSize ( ) const [virtual]

Reimplemented from AP4_Atom.

const AP4_UI08* AP4_UuidAtom::GetUuid ( ) [inline]

Definition at line 67 of file Ap4UuidAtom.h.

References m_Uuid.

virtual AP4_Result AP4_UuidAtom::InspectHeader ( AP4_AtomInspector & inspector ) [virtual]

Reimplemented from AP4_Atom.

virtual AP4_Result AP4_UuidAtom::WriteHeader ( AP4_ByteStream & stream ) [virtual]

Reimplemented from AP4_Atom.

Member Data Documentation

AP4_UI08 AP4_UuidAtom::m_Uuid[16] [protected]

Definition at line 74 of file Ap4UuidAtom.h.

Referenced by GetUuid().

The documentation for this class was generated from the following file:
  • Ap4UuidAtom.h
Generated on Thu May 13 16:38:11 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_UuidAtom Member List

This is the complete list of members for AP4_UuidAtom, including all inherited members.
AP4_Atom(Type type, AP4_UI32 size=AP4_ATOM_HEADER_SIZE) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64=false) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_UuidAtom(AP4_UI64 size, const AP4_UI08 *uuid) | AP4_UuidAtom | [protected]
AP4_UuidAtom(AP4_UI64 size, const AP4_UI08 *uuid, AP4_UI32 version, AP4_UI32 flags) | AP4_UuidAtom | [protected]
AP4_UuidAtom(AP4_UI64 size, bool is_full, AP4_ByteStream &stream) | AP4_UuidAtom | [protected]
Clone() | AP4_Atom | [virtual]
Detach() | AP4_Atom | [virtual]
GetFlags() const | AP4_Atom | [inline]
GetHeaderSize() const | AP4_UuidAtom | [virtual]
GetParent() | AP4_Atom | [inline, virtual]
GetSize() const | AP4_Atom | [inline]
GetSize32() const | AP4_Atom | [inline]
GetSize64() const | AP4_Atom | [inline]
GetType() const | AP4_Atom | [inline]
GetUuid() | AP4_UuidAtom | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
InspectFields(AP4_AtomInspector &) | AP4_Atom | [inline, virtual]
InspectHeader(AP4_AtomInspector &inspector) | AP4_UuidAtom | [virtual]
m_Flags | AP4_Atom | [protected]
m_IsFull | AP4_Atom | [protected]
m_Parent | AP4_Atom | [protected]
m_Size32 | AP4_Atom | [protected]
m_Size64 | AP4_Atom | [protected]
m_Type | AP4_Atom | [protected]
m_Uuid | AP4_UuidAtom | [protected]
m_Version | AP4_Atom | [protected]
ReadFullHeader(AP4_ByteStream &stream, AP4_UI32 &version, AP4_UI32 &flags) | AP4_Atom | [static]
SetFlags(AP4_UI32 flags) | AP4_Atom | [inline]
SetParent(AP4_AtomParent *parent) | AP4_Atom | [inline, virtual]
SetSize(AP4_UI64 size, bool force_64=false) | AP4_Atom |
SetSize32(AP4_UI32 size) | AP4_Atom | [inline]
SetSize64(AP4_UI64 size) | AP4_Atom | [inline]
SetType(Type type) | AP4_Atom | [inline]
Type typedef | AP4_Atom |
TypeFromString(const char *four_cc) | AP4_Atom | [static]
Write(AP4_ByteStream &stream) | AP4_Atom | [virtual]
WriteFields(AP4_ByteStream &stream)=0 | AP4_Atom | [pure virtual]
WriteHeader(AP4_ByteStream &stream) | AP4_UuidAtom | [virtual]
~AP4_Atom() | AP4_Atom | [inline, virtual]
~AP4_UuidAtom() | AP4_UuidAtom | [inline, virtual]
Generated on Thu May 13 16:38:11 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_VideoSampleDescription Class Reference

AP4_VideoSampleDescription Class Reference

#include <Ap4SampleDescription.h>

Inheritance diagram for AP4_VideoSampleDescription:
AP4_AvcSampleDescription AP4_GenericVideoSampleDescription AP4_MpegVideoSampleDescription

List of all members.

Public Member Functions

AP4_VideoSampleDescription (AP4_UI16 width, AP4_UI16 height, AP4_UI16 depth, const char *compressor_name)
AP4_UI16 GetWidth ()
AP4_UI16 GetHeight ()
AP4_UI16 GetDepth ()
const char * GetCompressorName ()

Protected Attributes

AP4_UI16 m_Width
AP4_UI16 m_Height
AP4_UI16 m_Depth
AP4_String m_CompressorName

Detailed Description

Definition at line 176 of file Ap4SampleDescription.h.

Constructor & Destructor Documentation

AP4_VideoSampleDescription::AP4_VideoSampleDescription | ( | AP4_UI16 | width,
 |  | AP4_UI16 | height,
 |  | AP4_UI16 | depth,
 |  | const char * | compressor_name |
 | ) |  |  | [inline]

Definition at line 182 of file Ap4SampleDescription.h.

Member Function Documentation

const char* AP4_VideoSampleDescription::GetCompressorName ( ) [inline]

Definition at line 195 of file Ap4SampleDescription.h.

References AP4_String::GetChars(), and m_CompressorName.

AP4_UI16 AP4_VideoSampleDescription::GetDepth ( ) [inline]

Definition at line 194 of file Ap4SampleDescription.h.

References m_Depth.

AP4_UI16 AP4_VideoSampleDescription::GetHeight ( ) [inline]

Definition at line 193 of file Ap4SampleDescription.h.

References m_Height.

AP4_UI16 AP4_VideoSampleDescription::GetWidth ( ) [inline]

Definition at line 192 of file Ap4SampleDescription.h.

References m_Width.

Member Data Documentation

AP4_String AP4_VideoSampleDescription::m_CompressorName [protected]

Definition at line 202 of file Ap4SampleDescription.h.

Referenced by GetCompressorName().

AP4_UI16 AP4_VideoSampleDescription::m_Depth [protected]

Definition at line 201 of file Ap4SampleDescription.h.

Referenced by GetDepth().

AP4_UI16 AP4_VideoSampleDescription::m_Height [protected]

Definition at line 200 of file Ap4SampleDescription.h.

Referenced by GetHeight().

AP4_UI16 AP4_VideoSampleDescription::m_Width [protected]

Definition at line 199 of file Ap4SampleDescription.h.

Referenced by GetWidth().

The documentation for this class was generated from the following file:
  • Ap4SampleDescription.h
Generated on Thu May 13 16:38:11 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_VideoSampleDescription Member List

This is the complete list of members for AP4_VideoSampleDescription, including all inherited members.
AP4_VideoSampleDescription(AP4_UI16 width, AP4_UI16 height, AP4_UI16 depth, const char *compressor_name) | AP4_VideoSampleDescription | [inline]
GetCompressorName() | AP4_VideoSampleDescription | [inline]
GetDepth() | AP4_VideoSampleDescription | [inline]
GetHeight() | AP4_VideoSampleDescription | [inline]
GetWidth() | AP4_VideoSampleDescription | [inline]
m_CompressorName | AP4_VideoSampleDescription | [protected]
m_Depth | AP4_VideoSampleDescription | [protected]
m_Height | AP4_VideoSampleDescription | [protected]
m_Width | AP4_VideoSampleDescription | [protected]
Generated on Thu May 13 16:38:11 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_VisualSampleEntry Class Reference

AP4_VisualSampleEntry Class Reference

#include <Ap4SampleEntry.h>

Inheritance diagram for AP4_VisualSampleEntry:
AP4_SampleEntry AP4_ContainerAtom AP4_Atom AP4_AtomParent AP4_Avc1SampleEntry AP4_EncvSampleEntry AP4_MpegVideoSampleEntry AP4_DrmiSampleEntry AP4_Mp4vSampleEntry

List of all members.

Public Member Functions

AP4_VisualSampleEntry (AP4_Atom::Type format, AP4_UI16 width, AP4_UI16 height, AP4_UI16 depth, const char *compressor_name)
AP4_VisualSampleEntry (AP4_Atom::Type format, AP4_Size size, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory)
AP4_UI16 GetWidth ()
AP4_UI16 GetHeight ()
AP4_UI16 GetHorizResolution ()
AP4_UI16 GetVertResolution ()
AP4_UI16 GetDepth ()
const char * | GetCompressorName ()
AP4_SampleDescription * ToSampleDescription ()

Protected Member Functions

virtual AP4_Size | GetFieldsSize ()
virtual AP4_Result | ReadFields (AP4_ByteStream &stream)
virtual AP4_Result | WriteFields (AP4_ByteStream &stream)
virtual AP4_Result | InspectFields (AP4_AtomInspector &inspector)

Protected Attributes

AP4_UI16 m_Predefined1
AP4_UI16 m_Reserved2
AP4_UI08 | m_Predefined2 [12]
AP4_UI16 m_Width
AP4_UI16 m_Height
AP4_UI32 m_HorizResolution
AP4_UI32 m_VertResolution
AP4_UI32 m_Reserved3
AP4_UI16 m_FrameCount
AP4_String m_CompressorName
AP4_UI16 m_Depth
AP4_UI16 m_Predefined3

Detailed Description

Definition at line 173 of file Ap4SampleEntry.h.

Constructor & Destructor Documentation

AP4_VisualSampleEntry::AP4_VisualSampleEntry | ( | AP4_Atom::Type | format,
 |  | AP4_UI16 | width,
 |  | AP4_UI16 | height,
 |  | AP4_UI16 | depth,
 |  | const char * | compressor_name
 | ) |  |
AP4_VisualSampleEntry::AP4_VisualSampleEntry | ( | AP4_Atom::Type | format,
 |  | AP4_Size | size,
 |  | AP4_ByteStream & | stream,
 |  | AP4_AtomFactory & | atom_factory
 | ) |  |

Member Function Documentation

const char* AP4_VisualSampleEntry::GetCompressorName ( ) [inline]

Definition at line 193 of file Ap4SampleEntry.h.

References AP4_String::GetChars(), and m_CompressorName.

AP4_UI16 AP4_VisualSampleEntry::GetDepth ( ) [inline]

Definition at line 192 of file Ap4SampleEntry.h.

References m_Depth.

virtual AP4_Size AP4_VisualSampleEntry::GetFieldsSize ( ) [protected, virtual]

Reimplemented from AP4_SampleEntry.

AP4_UI16 AP4_VisualSampleEntry::GetHeight ( ) [inline]

Definition at line 189 of file Ap4SampleEntry.h.

References m_Height.

AP4_UI16 AP4_VisualSampleEntry::GetHorizResolution ( ) [inline]

Definition at line 190 of file Ap4SampleEntry.h.

References m_HorizResolution.

AP4_UI16 AP4_VisualSampleEntry::GetVertResolution ( ) [inline]

Definition at line 191 of file Ap4SampleEntry.h.

References m_VertResolution.

AP4_UI16 AP4_VisualSampleEntry::GetWidth ( ) [inline]

Definition at line 188 of file Ap4SampleEntry.h.

References m_Width.

virtual AP4_Result AP4_VisualSampleEntry::InspectFields ( AP4_AtomInspector & inspector ) [protected, virtual]

Reimplemented from AP4_SampleEntry.

virtual AP4_Result AP4_VisualSampleEntry::ReadFields ( AP4_ByteStream & stream ) [protected, virtual]

Reimplemented from AP4_SampleEntry.

AP4_SampleDescription* AP4_VisualSampleEntry::ToSampleDescription ( ) [virtual]

Reimplemented from AP4_SampleEntry.

Reimplemented in AP4_EncvSampleEntry, AP4_MpegVideoSampleEntry, and AP4_Avc1SampleEntry.

virtual AP4_Result AP4_VisualSampleEntry::WriteFields ( AP4_ByteStream & stream ) [protected, virtual]

Reimplemented from AP4_SampleEntry.

Member Data Documentation

AP4_String AP4_VisualSampleEntry::m_CompressorName [protected]

Definition at line 215 of file Ap4SampleEntry.h.

Referenced by GetCompressorName().

AP4_UI16 AP4_VisualSampleEntry::m_Depth [protected]

Definition at line 216 of file Ap4SampleEntry.h.

Referenced by GetDepth().

AP4_UI16 AP4_VisualSampleEntry::m_FrameCount [protected]

Definition at line 214 of file Ap4SampleEntry.h.

AP4_UI16 AP4_VisualSampleEntry::m_Height [protected]

Definition at line 210 of file Ap4SampleEntry.h.

Referenced by GetHeight().

AP4_UI32 AP4_VisualSampleEntry::m_HorizResolution [protected]

Definition at line 211 of file Ap4SampleEntry.h.

Referenced by GetHorizResolution().

AP4_UI16 AP4_VisualSampleEntry::m_Predefined1 [protected]

Definition at line 206 of file Ap4SampleEntry.h.

AP4_UI08 AP4_VisualSampleEntry::m_Predefined2[12] [protected]

Definition at line 208 of file Ap4SampleEntry.h.

AP4_UI16 AP4_VisualSampleEntry::m_Predefined3 [protected]

Definition at line 217 of file Ap4SampleEntry.h.

AP4_UI16 AP4_VisualSampleEntry::m_Reserved2 [protected]

Definition at line 207 of file Ap4SampleEntry.h.

AP4_UI32 AP4_VisualSampleEntry::m_Reserved3 [protected]

Definition at line 213 of file Ap4SampleEntry.h.

AP4_UI32 AP4_VisualSampleEntry::m_VertResolution [protected]

Definition at line 212 of file Ap4SampleEntry.h.

Referenced by GetVertResolution().

AP4_UI16 AP4_VisualSampleEntry::m_Width [protected]

Definition at line 209 of file Ap4SampleEntry.h.

Referenced by GetWidth().

The documentation for this class was generated from the following file:
  • Ap4SampleEntry.h
Generated on Thu May 13 16:38:11 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_VisualSampleEntry Member List

This is the complete list of members for AP4_VisualSampleEntry, including all inherited members.
AddChild(AP4_Atom *child, int position=-1) | AP4_AtomParent | [virtual]
AP4_Atom(Type type, AP4_UI32 size=AP4_ATOM_HEADER_SIZE) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64=false) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_ContainerAtom(Type type) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI32 version, AP4_UI32 flags) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_ContainerAtom | [explicit]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_ContainerAtom | [protected]
AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_ContainerAtom | [protected]
AP4_SampleEntry(AP4_Atom::Type format, AP4_UI16 data_ref_index=1) | AP4_SampleEntry |
AP4_SampleEntry(AP4_Atom::Type format, AP4_Size size, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_SampleEntry |
AP4_SampleEntry(AP4_Atom::Type format, AP4_Size size) | AP4_SampleEntry | [protected]
AP4_VisualSampleEntry(AP4_Atom::Type format, AP4_UI16 width, AP4_UI16 height, AP4_UI16 depth, const char *compressor_name) | AP4_VisualSampleEntry |
AP4_VisualSampleEntry(AP4_Atom::Type format, AP4_Size size, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_VisualSampleEntry |
Clone() | AP4_ContainerAtom | [virtual]
Create(Type type, AP4_UI64 size, bool is_full, bool force_64, AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_ContainerAtom | [static]
DeleteChild(AP4_Atom::Type type, AP4_Ordinal index=0) | AP4_AtomParent | [virtual]
Detach() | AP4_Atom | [virtual]
FindChild(const char *path, bool auto_create=false, bool auto_create_full=false) | AP4_AtomParent | [virtual]
GetChild(AP4_Atom::Type type, AP4_Ordinal index=0) const | AP4_AtomParent | [virtual]
GetChild(const AP4_UI08 *uuid, AP4_Ordinal index=0) const | AP4_AtomParent | [virtual]
GetChildren() | AP4_ContainerAtom | [inline]
GetCompressorName() | AP4_VisualSampleEntry | [inline]
GetDataReferenceIndex() | AP4_SampleEntry | [inline]
GetDepth() | AP4_VisualSampleEntry | [inline]
GetFieldsSize() | AP4_VisualSampleEntry | [protected, virtual]
GetFlags() const | AP4_Atom | [inline]
GetHeaderSize() const | AP4_Atom | [virtual]
GetHeight() | AP4_VisualSampleEntry | [inline]
GetHorizResolution() | AP4_VisualSampleEntry | [inline]
GetParent() | AP4_Atom | [inline, virtual]
GetSize() const | AP4_Atom | [inline]
GetSize32() const | AP4_Atom | [inline]
GetSize64() const | AP4_Atom | [inline]
GetType() const | AP4_Atom | [inline]
GetVertResolution() | AP4_VisualSampleEntry | [inline]
GetWidth() | AP4_VisualSampleEntry | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_SampleEntry | [virtual]
InspectChildren(AP4_AtomInspector &inspector) | AP4_ContainerAtom | [virtual]
InspectFields(AP4_AtomInspector &inspector) | AP4_VisualSampleEntry | [protected, virtual]
InspectHeader(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
m_Children | AP4_AtomParent | [protected]
m_CompressorName | AP4_VisualSampleEntry | [protected]
m_DataReferenceIndex | AP4_SampleEntry | [protected]
m_Depth | AP4_VisualSampleEntry | [protected]
m_Flags | AP4_Atom | [protected]
m_FrameCount | AP4_VisualSampleEntry | [protected]
m_Height | AP4_VisualSampleEntry | [protected]
m_HorizResolution | AP4_VisualSampleEntry | [protected]
m_IsFull | AP4_Atom | [protected]
m_Parent | AP4_Atom | [protected]
m_Predefined1 | AP4_VisualSampleEntry | [protected]
m_Predefined2 | AP4_VisualSampleEntry | [protected]
m_Predefined3 | AP4_VisualSampleEntry | [protected]
m_Reserved1 | AP4_SampleEntry | [protected]
m_Reserved2 | AP4_VisualSampleEntry | [protected]
m_Reserved3 | AP4_VisualSampleEntry | [protected]
m_Size32 | AP4_Atom | [protected]
m_Size64 | AP4_Atom | [protected]
m_Type | AP4_Atom | [protected]
m_Version | AP4_Atom | [protected]
m_VertResolution | AP4_VisualSampleEntry | [protected]
m_Width | AP4_VisualSampleEntry | [protected]
OnChildAdded(AP4_Atom *child) | AP4_ContainerAtom | [virtual]
OnChildChanged(AP4_Atom *child) | AP4_SampleEntry | [virtual]
OnChildRemoved(AP4_Atom *child) | AP4_ContainerAtom | [virtual]
Read(AP4_ByteStream &stream, AP4_AtomFactory &atom_factory) | AP4_SampleEntry | [protected, virtual]
ReadChildren(AP4_AtomFactory &atom_factory, AP4_ByteStream &stream, AP4_UI64 size) | AP4_ContainerAtom | [protected]
ReadFields(AP4_ByteStream &stream) | AP4_VisualSampleEntry | [protected, virtual]
ReadFullHeader(AP4_ByteStream &stream, AP4_UI32 &version, AP4_UI32 &flags) | AP4_Atom | [static]
RemoveChild(AP4_Atom *child) | AP4_AtomParent | [virtual]
SetFlags(AP4_UI32 flags) | AP4_Atom | [inline]
SetParent(AP4_AtomParent *parent) | AP4_Atom | [inline, virtual]
SetSize(AP4_UI64 size, bool force_64=false) | AP4_Atom |
SetSize32(AP4_UI32 size) | AP4_Atom | [inline]
SetSize64(AP4_UI64 size) | AP4_Atom | [inline]
SetType(Type type) | AP4_Atom | [inline]
ToSampleDescription() | AP4_VisualSampleEntry | [virtual]
Type typedef | AP4_Atom |
TypeFromString(const char *four_cc) | AP4_Atom | [static]
Write(AP4_ByteStream &stream) | AP4_SampleEntry | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_VisualSampleEntry | [protected, virtual]
WriteHeader(AP4_ByteStream &stream) | AP4_Atom | [virtual]
~AP4_Atom() | AP4_Atom | [inline, virtual]
~AP4_AtomParent() | AP4_AtomParent | [virtual]
~AP4_SampleEntry() | AP4_SampleEntry | [inline, virtual]
Generated on Thu May 13 16:38:11 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_VmhdAtom Class Reference

AP4_VmhdAtom Class Reference

#include <Ap4VmhdAtom.h>

Inheritance diagram for AP4_VmhdAtom:
AP4_Atom

List of all members.

Public Member Functions

AP4_VmhdAtom (AP4_UI16 graphics_mode, AP4_UI16 r, AP4_UI16 g, AP4_UI16 b)
virtual AP4_Result | InspectFields (AP4_AtomInspector &inspector)
virtual AP4_Result | WriteFields (AP4_ByteStream &stream)

Static Public Member Functions

static AP4_VmhdAtom * | Create (AP4_Size size, AP4_ByteStream &stream)

Detailed Description

Definition at line 40 of file Ap4VmhdAtom.h.

Constructor & Destructor Documentation

AP4_VmhdAtom::AP4_VmhdAtom | ( | AP4_UI16 | graphics_mode,
 |  | AP4_UI16 | r,
 |  | AP4_UI16 | g,
 |  | AP4_UI16 | b
 | ) |  |

Member Function Documentation

static AP4_VmhdAtom* AP4_VmhdAtom::Create | ( | AP4_Size | size,
 |  | AP4_ByteStream & | stream |
 | ) |  |  | [static]
virtual AP4_Result AP4_VmhdAtom::InspectFields ( AP4_AtomInspector & inspector ) [virtual]

Reimplemented from AP4_Atom.

virtual AP4_Result AP4_VmhdAtom::WriteFields ( AP4_ByteStream & stream ) [virtual]

Implements AP4_Atom.

The documentation for this class was generated from the following file:
  • Ap4VmhdAtom.h
Generated on Thu May 13 16:38:11 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_VmhdAtom Member List

This is the complete list of members for AP4_VmhdAtom, including all inherited members.
AP4_Atom(Type type, AP4_UI32 size=AP4_ATOM_HEADER_SIZE) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64=false) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_Atom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags) | AP4_Atom | [explicit]
AP4_VmhdAtom(AP4_UI16 graphics_mode, AP4_UI16 r, AP4_UI16 g, AP4_UI16 b) | AP4_VmhdAtom |
Clone() | AP4_Atom | [virtual]
Create(AP4_Size size, AP4_ByteStream &stream) | AP4_VmhdAtom | [static]
Detach() | AP4_Atom | [virtual]
GetFlags() const | AP4_Atom | [inline]
GetHeaderSize() const | AP4_Atom | [virtual]
GetParent() | AP4_Atom | [inline, virtual]
GetSize() const | AP4_Atom | [inline]
GetSize32() const | AP4_Atom | [inline]
GetSize64() const | AP4_Atom | [inline]
GetType() const | AP4_Atom | [inline]
Inspect(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
InspectFields(AP4_AtomInspector &inspector) | AP4_VmhdAtom | [virtual]
InspectHeader(AP4_AtomInspector &inspector) | AP4_Atom | [virtual]
m_Flags | AP4_Atom | [protected]
m_IsFull | AP4_Atom | [protected]
m_Parent | AP4_Atom | [protected]
m_Size32 | AP4_Atom | [protected]
m_Size64 | AP4_Atom | [protected]
m_Type | AP4_Atom | [protected]
m_Version | AP4_Atom | [protected]
ReadFullHeader(AP4_ByteStream &stream, AP4_UI32 &version, AP4_UI32 &flags) | AP4_Atom | [static]
SetFlags(AP4_UI32 flags) | AP4_Atom | [inline]
SetParent(AP4_AtomParent *parent) | AP4_Atom | [inline, virtual]
SetSize(AP4_UI64 size, bool force_64=false) | AP4_Atom |
SetSize32(AP4_UI32 size) | AP4_Atom | [inline]
SetSize64(AP4_UI64 size) | AP4_Atom | [inline]
SetType(Type type) | AP4_Atom | [inline]
Type typedef | AP4_Atom |
TypeFromString(const char *four_cc) | AP4_Atom | [static]
Write(AP4_ByteStream &stream) | AP4_Atom | [virtual]
WriteFields(AP4_ByteStream &stream) | AP4_VmhdAtom | [virtual]
WriteHeader(AP4_ByteStream &stream) | AP4_Atom | [virtual]
~AP4_Atom() | AP4_Atom | [inline, virtual]
Generated on Thu May 13 16:38:11 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_PiffEncryptingProcessor::Encrypter Struct Reference

AP4_PiffEncryptingProcessor::Encrypter

AP4_PiffEncryptingProcessor::Encrypter Struct Reference

#include <Ap4Piff.h>

List of all members.

Public Member Functions

Encrypter (AP4_UI32 track_id, AP4_PiffSampleEncrypter *sample_encrypter)
Encrypter ()

Public Attributes

AP4_UI32 m_TrackId
AP4_PiffSampleEncrypter * m_SampleEncrypter

Detailed Description

Definition at line 180 of file Ap4Piff.h.

Constructor & Destructor Documentation

AP4_PiffEncryptingProcessor::Encrypter::Encrypter | ( | AP4_UI32 | track_id,
 |  | AP4_PiffSampleEncrypter * | sample_encrypter |
 | ) |  |  | [inline]

Definition at line 181 of file Ap4Piff.h.

AP4_PiffEncryptingProcessor::Encrypter::Encrypter ( ) [inline]

Definition at line 184 of file Ap4Piff.h.

References m_SampleEncrypter.

Member Data Documentation

AP4_PiffSampleEncrypter* AP4_PiffEncryptingProcessor::Encrypter::m_SampleEncrypter

Definition at line 186 of file Ap4Piff.h.

Referenced by Encrypter().

AP4_UI32 AP4_PiffEncryptingProcessor::Encrypter::m_TrackId

Definition at line 185 of file Ap4Piff.h.

The documentation for this struct was generated from the following file:
  • Ap4Piff.h
Generated on Thu May 13 16:37:42 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_PiffEncryptingProcessor::Encrypter Member List

This is the complete list of members for AP4_PiffEncryptingProcessor::Encrypter, including all inherited members.
Encrypter(AP4_UI32 track_id, AP4_PiffSampleEncrypter *sample_encrypter) | AP4_PiffEncryptingProcessor::Encrypter | [inline]
Encrypter() | AP4_PiffEncryptingProcessor::Encrypter | [inline]
m_SampleEncrypter | AP4_PiffEncryptingProcessor::Encrypter |
m_TrackId | AP4_PiffEncryptingProcessor::Encrypter |
Generated on Thu May 13 16:37:42 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_TrunAtom::Entry Struct Reference

AP4_TrunAtom::Entry

AP4_TrunAtom::Entry Struct Reference

#include <Ap4TrunAtom.h>

List of all members.

Public Member Functions

Entry ()

Public Attributes

AP4_UI32 sample_duration
AP4_UI32 sample_size
AP4_UI32 sample_flags
AP4_UI32 sample_composition_time_offset

Detailed Description

Definition at line 57 of file Ap4TrunAtom.h.

Constructor & Destructor Documentation

AP4_TrunAtom::Entry::Entry ( ) [inline]

Definition at line 58 of file Ap4TrunAtom.h.

Member Data Documentation

AP4_UI32 AP4_TrunAtom::Entry::sample_composition_time_offset

Definition at line 62 of file Ap4TrunAtom.h.

AP4_UI32 AP4_TrunAtom::Entry::sample_duration

Definition at line 59 of file Ap4TrunAtom.h.

AP4_UI32 AP4_TrunAtom::Entry::sample_flags

Definition at line 61 of file Ap4TrunAtom.h.

AP4_UI32 AP4_TrunAtom::Entry::sample_size

Definition at line 60 of file Ap4TrunAtom.h.

The documentation for this struct was generated from the following file:
  • Ap4TrunAtom.h
Generated on Thu May 13 16:37:56 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_TrunAtom::Entry Member List

This is the complete list of members for AP4_TrunAtom::Entry, including all inherited members.
Entry() | AP4_TrunAtom::Entry | [inline]
sample_composition_time_offset | AP4_TrunAtom::Entry |
sample_duration | AP4_TrunAtom::Entry |
sample_flags | AP4_TrunAtom::Entry |
sample_size | AP4_TrunAtom::Entry |
Generated on Thu May 13 16:37:56 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_MetaData::Entry Class Reference

AP4_MetaData::Entry

AP4_MetaData::Entry Class Reference

#include <Ap4MetaData.h>

List of all members.

Public Member Functions

Entry (const char *name, const char *ns, Value *value)
~Entry ()
AP4_Result | AddToFile (AP4_File &file, AP4_Ordinal index=0)
AP4_Result | AddToFileIlst (AP4_File &file, AP4_Ordinal index=0)
AP4_Result | AddToFileDcf (AP4_File &file, AP4_Ordinal index=0)
AP4_Result | RemoveFromFile (AP4_File &file, AP4_Ordinal index)
AP4_Result | RemoveFromFileIlst (AP4_File &file, AP4_Ordinal index)
AP4_Result | RemoveFromFileDcf (AP4_File &file, AP4_Ordinal index)
AP4_ContainerAtom * | FindInIlst (AP4_ContainerAtom *ilst) const
AP4_Result | ToAtom (AP4_Atom *&atom) const

Public Attributes

Key m_Key
Value * m_Value

Detailed Description

Definition at line 217 of file Ap4MetaData.h.

Constructor & Destructor Documentation

AP4_MetaData::Entry::Entry | ( | const char * | name,
 |  | const char * | ns,
 |  | Value * | value |
 | ) |  |  | [inline]

Definition at line 220 of file Ap4MetaData.h.

AP4_MetaData::Entry::~Entry ( ) [inline]

Definition at line 224 of file Ap4MetaData.h.

References m_Value.

Member Function Documentation

AP4_Result AP4_MetaData::Entry::AddToFile | ( | AP4_File & | file,
 |  | AP4_Ordinal | index = 0
 | ) |  |
AP4_Result AP4_MetaData::Entry::AddToFileDcf | ( | AP4_File & | file,
 |  | AP4_Ordinal | index = 0
 | ) |  |
AP4_Result AP4_MetaData::Entry::AddToFileIlst | ( | AP4_File & | file,
 |  | AP4_Ordinal | index = 0
 | ) |  |
AP4_ContainerAtom* AP4_MetaData::Entry::FindInIlst ( AP4_ContainerAtom * ilst ) const
AP4_Result AP4_MetaData::Entry::RemoveFromFile | ( | AP4_File & | file,
 |  | AP4_Ordinal | index
 | ) |  |
AP4_Result AP4_MetaData::Entry::RemoveFromFileDcf | ( | AP4_File & | file,
 |  | AP4_Ordinal | index
 | ) |  |
AP4_Result AP4_MetaData::Entry::RemoveFromFileIlst | ( | AP4_File & | file,
 |  | AP4_Ordinal | index
 | ) |  |
AP4_Result AP4_MetaData::Entry::ToAtom ( AP4_Atom *& atom ) const

Member Data Documentation

Key AP4_MetaData::Entry::m_Key

Definition at line 237 of file Ap4MetaData.h.

Value* AP4_MetaData::Entry::m_Value

Definition at line 238 of file Ap4MetaData.h.

Referenced by ~Entry().

The documentation for this class was generated from the following file:
  • Ap4MetaData.h
Generated on Thu May 13 16:37:22 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_MetaData::Entry Member List

This is the complete list of members for AP4_MetaData::Entry, including all inherited members.
AddToFile(AP4_File &file, AP4_Ordinal index=0) | AP4_MetaData::Entry |
AddToFileDcf(AP4_File &file, AP4_Ordinal index=0) | AP4_MetaData::Entry |
AddToFileIlst(AP4_File &file, AP4_Ordinal index=0) | AP4_MetaData::Entry |
Entry(const char *name, const char *ns, Value *value) | AP4_MetaData::Entry | [inline]
FindInIlst(AP4_ContainerAtom *ilst) const | AP4_MetaData::Entry |
m_Key | AP4_MetaData::Entry |
m_Value | AP4_MetaData::Entry |
RemoveFromFile(AP4_File &file, AP4_Ordinal index) | AP4_MetaData::Entry |
RemoveFromFileDcf(AP4_File &file, AP4_Ordinal index) | AP4_MetaData::Entry |
RemoveFromFileIlst(AP4_File &file, AP4_Ordinal index) | AP4_MetaData::Entry |
ToAtom(AP4_Atom *&atom) const | AP4_MetaData::Entry |
~Entry() | AP4_MetaData::Entry | [inline]
Generated on Thu May 13 16:37:22 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_TfraAtom::Entry Struct Reference

AP4_TfraAtom::Entry

AP4_TfraAtom::Entry Struct Reference

#include <Ap4TfraAtom.h>

List of all members.

Public Member Functions

Entry ()

Public Attributes

AP4_UI64 m_Time
AP4_UI64 m_MoofOffset
AP4_UI32 m_TrafNumber
AP4_UI32 m_TrunNumber
AP4_UI32 m_SampleNumber

Detailed Description

Definition at line 53 of file Ap4TfraAtom.h.

Constructor & Destructor Documentation

AP4_TfraAtom::Entry::Entry ( ) [inline]

Definition at line 54 of file Ap4TfraAtom.h.

Member Data Documentation

AP4_UI64 AP4_TfraAtom::Entry::m_MoofOffset

Definition at line 56 of file Ap4TfraAtom.h.

AP4_UI32 AP4_TfraAtom::Entry::m_SampleNumber

Definition at line 59 of file Ap4TfraAtom.h.

AP4_UI64 AP4_TfraAtom::Entry::m_Time

Definition at line 55 of file Ap4TfraAtom.h.

AP4_UI32 AP4_TfraAtom::Entry::m_TrafNumber

Definition at line 57 of file Ap4TfraAtom.h.

AP4_UI32 AP4_TfraAtom::Entry::m_TrunNumber

Definition at line 58 of file Ap4TfraAtom.h.

The documentation for this struct was generated from the following file:
  • Ap4TfraAtom.h
Generated on Thu May 13 16:37:52 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_TfraAtom::Entry Member List

This is the complete list of members for AP4_TfraAtom::Entry, including all inherited members.
Entry() | AP4_TfraAtom::Entry | [inline]
m_MoofOffset | AP4_TfraAtom::Entry |
m_SampleNumber | AP4_TfraAtom::Entry |
m_Time | AP4_TfraAtom::Entry |
m_TrafNumber | AP4_TfraAtom::Entry |
m_TrunNumber | AP4_TfraAtom::Entry |
Generated on Thu May 13 16:37:52 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_Processor::ExternalTrackData Class Reference

AP4_Processor::ExternalTrackData

AP4_Processor::ExternalTrackData Class Reference

#include <Ap4Processor.h>

List of all members.

Public Member Functions

ExternalTrackData (unsigned int track_id, AP4_ByteStream *media_data)
~ExternalTrackData ()

Public Attributes

unsigned int m_TrackId
AP4_ByteStream * m_MediaData

Detailed Description

Definition at line 216 of file Ap4Processor.h.

Constructor & Destructor Documentation

AP4_Processor::ExternalTrackData::ExternalTrackData | ( | unsigned int | track_id,
 |  | AP4_ByteStream * | media_data |
 | ) |  |  | [inline]

Definition at line 218 of file Ap4Processor.h.

References AP4_Referenceable::AddReference().

AP4_Processor::ExternalTrackData::~ExternalTrackData ( ) [inline]

Definition at line 222 of file Ap4Processor.h.

References m_MediaData, and AP4_Referenceable::Release().

Member Data Documentation

AP4_ByteStream* AP4_Processor::ExternalTrackData::m_MediaData

Definition at line 224 of file Ap4Processor.h.

Referenced by ~ExternalTrackData().

unsigned int AP4_Processor::ExternalTrackData::m_TrackId

Definition at line 223 of file Ap4Processor.h.

The documentation for this class was generated from the following file:
  • Ap4Processor.h
Generated on Thu May 13 16:37:44 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_Processor::ExternalTrackData Member List

This is the complete list of members for AP4_Processor::ExternalTrackData, including all inherited members.
ExternalTrackData(unsigned int track_id, AP4_ByteStream *media_data) | AP4_Processor::ExternalTrackData | [inline]
m_MediaData | AP4_Processor::ExternalTrackData |
m_TrackId | AP4_Processor::ExternalTrackData |
~ExternalTrackData() | AP4_Processor::ExternalTrackData | [inline]
Generated on Thu May 13 16:37:44 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_List< T >::Item::Finder Class Reference

AP4_List::Item::Finder

AP4_List< T >::Item::Finder Class Reference

#include <Ap4List.h>

Inheritance diagram for AP4_List< T >::Item::Finder:
AP4_AtomFinder AP4_DescriptorFinder

List of all members.

Public Member Functions

virtual | ~Finder ()
virtual AP4_Result | Test (T *data) const =0

Detailed Description

template<typename T>
class AP4_List< T >::Item::Finder

Definition at line 63 of file Ap4List.h.

Constructor & Destructor Documentation

template<typename T>
virtual AP4_List< T >::Item::Finder::~Finder ( ) [inline, virtual]

Definition at line 67 of file Ap4List.h.

Member Function Documentation

template<typename T>
virtual AP4_Result AP4_List< T >::Item::Finder::Test ( T * data ) const [pure virtual]

Referenced by AP4_List< T >::Find(), and AP4_List< T >::ReverseFind().

The documentation for this class was generated from the following file:
  • Ap4List.h
Generated on Thu May 13 16:37:21 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_List< T >::Item::Finder Member List

This is the complete list of members for AP4_List< T >::Item::Finder, including all inherited members.
Test(T *data) const =0 | AP4_List< T >::Item::Finder | [pure virtual]
~Finder() | AP4_List< T >::Item::Finder | [inline, virtual]
Generated on Thu May 13 16:37:21 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_Processor::FragmentHandler Class Reference

AP4_Processor::FragmentHandler

AP4_Processor::FragmentHandler Class Reference

Abstract class that defines the interface implemented by concrete fragment handlers. More...

#include <Ap4Processor.h>

List of all members.

Public Member Functions

virtual | ~FragmentHandler ()
Default destructor.
virtual AP4_Result | ProcessFragment ()
A fragment handler may override this method if it needs to modify the fragment atoms before processing the fragment samples.
virtual AP4_Result | FinishFragment ()
A fragment handler may override this method if it needs to modify the fragment atoms after processing the fragment samples.
virtual AP4_Size | GetProcessedSampleSize (AP4_Sample &sample)
Returns the size of a sample after processing.
virtual AP4_Result | ProcessSample (AP4_DataBuffer &data_in, AP4_DataBuffer &data_out)=0
Process the data of one sample.

Detailed Description

Abstract class that defines the interface implemented by concrete fragment handlers.

A fragment handler is responsible for processing a fragment and its media samples.

Definition at line 118 of file Ap4Processor.h.

Constructor & Destructor Documentation

virtual AP4_Processor::FragmentHandler::~FragmentHandler ( ) [inline, virtual]

Default destructor.

Definition at line 123 of file Ap4Processor.h.

Member Function Documentation

virtual AP4_Result AP4_Processor::FragmentHandler::FinishFragment ( ) [inline, virtual]

A fragment handler may override this method if it needs to modify the fragment atoms after processing the fragment samples.

NOTE: this method MUST NOT change the size of any of the atoms.

Definition at line 136 of file Ap4Processor.h.

References AP4_ERROR_NOT_SUPPORTED.

virtual AP4_Size AP4_Processor::FragmentHandler::GetProcessedSampleSize ( AP4_Sample & sample ) [inline, virtual]

Returns the size of a sample after processing.

Parameters:
sample Sample of which the processed size is requested.
Returns:
Size of the sample data after processing.

Definition at line 143 of file Ap4Processor.h.

References AP4_Sample::GetSize().

virtual AP4_Result AP4_Processor::FragmentHandler::ProcessFragment ( ) [inline, virtual]

A fragment handler may override this method if it needs to modify the fragment atoms before processing the fragment samples.

Definition at line 129 of file Ap4Processor.h.

References AP4_SUCCESS.

virtual AP4_Result AP4_Processor::FragmentHandler::ProcessSample | ( | AP4_DataBuffer & | data_in,
 |  | AP4_DataBuffer & | data_out |
 | ) |  |  | [pure virtual]

Process the data of one sample.

Parameters:
data_in | Data buffer with the data of the sample to process.
data_out | Data buffer in which the processed sample data is returned.
The documentation for this class was generated from the following file:
  • Ap4Processor.h
Generated on Thu May 13 16:37:44 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_Processor::FragmentHandler Member List

This is the complete list of members for AP4_Processor::FragmentHandler, including all inherited members.
FinishFragment() | AP4_Processor::FragmentHandler | [inline, virtual]
GetProcessedSampleSize(AP4_Sample &sample) | AP4_Processor::FragmentHandler | [inline, virtual]
ProcessFragment() | AP4_Processor::FragmentHandler | [inline, virtual]
ProcessSample(AP4_DataBuffer &data_in, AP4_DataBuffer &data_out)=0 | AP4_Processor::FragmentHandler | [pure virtual]
~FragmentHandler() | AP4_Processor::FragmentHandler | [inline, virtual]
Generated on Thu May 13 16:37:44 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_List< T >::Item Class Reference

AP4_List::Item

AP4_List< T >::Item Class Reference

#include <Ap4List.h>

List of all members.

Classes

class | Finder
class | Operator

Public Member Functions

Item (T *data)
~Item ()
Item * GetNext ()
Item * GetPrev ()
T * | GetData ()

Friends

class | AP4_List

Detailed Description

template<typename T>
class AP4_List< T >::Item

Definition at line 51 of file Ap4List.h.

Constructor & Destructor Documentation

template<typename T>
AP4_List< T >::Item::Item ( T * data ) [inline]

Definition at line 72 of file Ap4List.h.

template<typename T>
AP4_List< T >::Item::~Item ( ) [inline]

Definition at line 73 of file Ap4List.h.

Member Function Documentation

template<typename T>
T* AP4_List< T >::Item::GetData ( ) [inline]

Definition at line 76 of file Ap4List.h.

template<typename T>
Item* AP4_List< T >::Item::GetNext ( ) [inline]

Definition at line 74 of file Ap4List.h.

template<typename T>
Item* AP4_List< T >::Item::GetPrev ( ) [inline]

Definition at line 75 of file Ap4List.h.

Friends And Related Function Documentation

template<typename T>
friend class AP4_List [friend]

Definition at line 85 of file Ap4List.h.

The documentation for this class was generated from the following file:
  • Ap4List.h
Generated on Thu May 13 16:37:21 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_List< T >::Item Member List

This is the complete list of members for AP4_List< T >::Item, including all inherited members.
AP4_List class | AP4_List< T >::Item | [friend]
GetData() | AP4_List< T >::Item | [inline]
GetNext() | AP4_List< T >::Item | [inline]
GetPrev() | AP4_List< T >::Item | [inline]
Item(T *data) | AP4_List< T >::Item | [inline]
~Item() | AP4_List< T >::Item | [inline]
Generated on Thu May 13 16:37:21 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_MetaData::Key Class Reference

AP4_MetaData::Key

AP4_MetaData::Key Class Reference

#include <Ap4MetaData.h>

List of all members.

Public Member Functions

Key (const char *name, const char *ns)
const AP4_String & | GetNamespace () const
const AP4_String & | GetName () const

Detailed Description

Definition at line 131 of file Ap4MetaData.h.

Constructor & Destructor Documentation

AP4_MetaData::Key::Key | ( | const char * | name,
 |  | const char * | ns |
 | ) |  |  | [inline]

Definition at line 134 of file Ap4MetaData.h.

Member Function Documentation

const AP4_String& AP4_MetaData::Key::GetName ( ) const [inline]

Definition at line 139 of file Ap4MetaData.h.

const AP4_String& AP4_MetaData::Key::GetNamespace ( ) const [inline]

Definition at line 138 of file Ap4MetaData.h.

The documentation for this class was generated from the following file:
  • Ap4MetaData.h
Generated on Thu May 13 16:37:22 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_MetaData::Key Member List

This is the complete list of members for AP4_MetaData::Key, including all inherited members.
GetName() const | AP4_MetaData::Key | [inline]
GetNamespace() const | AP4_MetaData::Key | [inline]
Key(const char *name, const char *ns) | AP4_MetaData::Key | [inline]
Generated on Thu May 13 16:37:22 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_MetaData::KeyInfo Class Reference

AP4_MetaData::KeyInfo

AP4_MetaData::KeyInfo Class Reference

#include <Ap4MetaData.h>

List of all members.

Public Attributes

const char * | name
const char * | description
AP4_UI32 four_cc
Value::Type value_type

Detailed Description

Definition at line 208 of file Ap4MetaData.h.

Member Data Documentation

const char* AP4_MetaData::KeyInfo::description

Definition at line 212 of file Ap4MetaData.h.

AP4_UI32 AP4_MetaData::KeyInfo::four_cc

Definition at line 213 of file Ap4MetaData.h.

const char* AP4_MetaData::KeyInfo::name

Definition at line 211 of file Ap4MetaData.h.

Value::Type AP4_MetaData::KeyInfo::value_type

Definition at line 214 of file Ap4MetaData.h.

The documentation for this class was generated from the following file:
  • Ap4MetaData.h
Generated on Thu May 13 16:37:22 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_MetaData::KeyInfo Member List

This is the complete list of members for AP4_MetaData::KeyInfo, including all inherited members.
description | AP4_MetaData::KeyInfo
four_cc | AP4_MetaData::KeyInfo
name | AP4_MetaData::KeyInfo
value_type | AP4_MetaData::KeyInfo
Generated on Thu May 13 16:37:22 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_List< T >::Item::Operator Class Reference

AP4_List::Item::Operator

AP4_List< T >::Item::Operator Class Reference

#include <Ap4List.h>

Inheritance diagram for AP4_List< T >::Item::Operator:
AP4_AtomListInspector AP4_AtomListWriter AP4_AtomSizeAdder AP4_DescriptorListInspector AP4_DescriptorListWriter

List of all members.

Public Member Functions

virtual | ~Operator ()
virtual AP4_Result | Action (T *data) const =0

Detailed Description

template<typename T>
class AP4_List< T >::Item::Operator

Definition at line 55 of file Ap4List.h.

Constructor & Destructor Documentation

template<typename T>
virtual AP4_List< T >::Item::Operator::~Operator ( ) [inline, virtual]

Definition at line 59 of file Ap4List.h.

Member Function Documentation

template<typename T>
virtual AP4_Result AP4_List< T >::Item::Operator::Action ( T * data ) const [pure virtual]

Referenced by AP4_List< T >::Apply(), AP4_List< T >::ApplyUntilFailure(), AP4_List< T >::ApplyUntilSuccess(), and AP4_List< T >::ReverseApply().

The documentation for this class was generated from the following file:
  • Ap4List.h
Generated on Thu May 13 16:37:21 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_List< T >::Item::Operator Member List

This is the complete list of members for AP4_List< T >::Item::Operator, including all inherited members.
Action(T *data) const =0 | AP4_List< T >::Item::Operator | [pure virtual]
~Operator() | AP4_List< T >::Item::Operator | [inline, virtual]
Generated on Thu May 13 16:37:21 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_Processor::ProgressListener Class Reference

AP4_Processor::ProgressListener

AP4_Processor::ProgressListener Class Reference

Abstract class that defines the interface implemented by progress listeners. More...

#include <Ap4Processor.h>

List of all members.

Public Member Functions

virtual | ~ProgressListener ()
virtual AP4_Result | OnProgress (unsigned int step, unsigned int total)=0
This method is called during the call to AP4_Processor::Process() to notify of the progress of the operation.

Detailed Description

Abstract class that defines the interface implemented by progress listeners.

A progress listener is called during the AP4_Processor::Process() method to notify of progres information.

Definition at line 60 of file Ap4Processor.h.

Constructor & Destructor Documentation

virtual AP4_Processor::ProgressListener::~ProgressListener ( ) [inline, virtual]

Definition at line 62 of file Ap4Processor.h.

Member Function Documentation

virtual AP4_Result AP4_Processor::ProgressListener::OnProgress | ( | unsigned int | step,
 |  | unsigned int | total |
 | ) |  |  | [pure virtual]

This method is called during the call to AP4_Processor::Process() to notify of the progress of the operation.

If this method returns an error result, processing is aborted.

Parameters:
step | Ordinal of the current progress step.
total | Total number of steps.
Returns:
A result code. If this method returns AP4_SUCCESS, the processing continues. If an error code is returned, the processing is aborted.
The documentation for this class was generated from the following file:
  • Ap4Processor.h
Generated on Thu May 13 16:37:44 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_Processor::ProgressListener Member List

This is the complete list of members for AP4_Processor::ProgressListener, including all inherited members.
OnProgress(unsigned int step, unsigned int total)=0 | AP4_Processor::ProgressListener | [pure virtual]
~ProgressListener() | AP4_Processor::ProgressListener | [inline, virtual]
Generated on Thu May 13 16:37:44 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_Mpeg2TsWriter::SampleStream Class Reference

AP4_Mpeg2TsWriter::SampleStream

AP4_Mpeg2TsWriter::SampleStream Class Reference

#include <Ap4Mpeg2Ts.h>

Inheritance diagram for AP4_Mpeg2TsWriter::SampleStream:
AP4_Mpeg2TsWriter::Stream

List of all members.

Public Member Functions

SampleStream (AP4_UI16 pid, AP4_UI16 stream_id, AP4_UI08 stream_type, AP4_UI32 timescale)
virtual AP4_Result | WritePES (const unsigned char *data, unsigned int data_size, AP4_UI64 dts, bool with_dts, AP4_UI64 pts, bool with_pcr, AP4_ByteStream &output)
virtual AP4_Result | WriteSample (AP4_Sample &sample, AP4_SampleDescription *sample_description, bool with_pcr, AP4_ByteStream &output)=0

Public Attributes

unsigned int | m_StreamId
AP4_UI08 m_StreamType
AP4_UI32 m_TimeScale

Detailed Description

Definition at line 87 of file Ap4Mpeg2Ts.h.

Constructor & Destructor Documentation

AP4_Mpeg2TsWriter::SampleStream::SampleStream | ( | AP4_UI16 | pid,
 |  | AP4_UI16 | stream_id,
 |  | AP4_UI08 | stream_type,
 |  | AP4_UI32 | timescale |
 | ) |  |  | [inline]

Definition at line 89 of file Ap4Mpeg2Ts.h.

Member Function Documentation

virtual AP4_Result AP4_Mpeg2TsWriter::SampleStream::WritePES | ( | const unsigned char * | data,
 |  | unsigned int | data_size,
 |  | AP4_UI64 | dts,
 |  | bool | with_dts,
 |  | AP4_UI64 | pts,
 |  | bool | with_pcr,
 |  | AP4_ByteStream & | output |
 | ) |  |  | [virtual]
virtual AP4_Result AP4_Mpeg2TsWriter::SampleStream::WriteSample | ( | AP4_Sample & | sample,
 |  | AP4_SampleDescription * | sample_description,
 |  | bool | with_pcr,
 |  | AP4_ByteStream & | output |
 | ) |  |  | [pure virtual]

Member Data Documentation

unsigned int AP4_Mpeg2TsWriter::SampleStream::m_StreamId

Definition at line 107 of file Ap4Mpeg2Ts.h.

AP4_UI08 AP4_Mpeg2TsWriter::SampleStream::m_StreamType

Definition at line 108 of file Ap4Mpeg2Ts.h.

AP4_UI32 AP4_Mpeg2TsWriter::SampleStream::m_TimeScale

Definition at line 109 of file Ap4Mpeg2Ts.h.

The documentation for this class was generated from the following file:
  • Ap4Mpeg2Ts.h
Generated on Thu May 13 16:37:24 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_Mpeg2TsWriter::SampleStream Member List

This is the complete list of members for AP4_Mpeg2TsWriter::SampleStream, including all inherited members.
GetPID() | AP4_Mpeg2TsWriter::Stream | [inline]
m_StreamId | AP4_Mpeg2TsWriter::SampleStream |
m_StreamType | AP4_Mpeg2TsWriter::SampleStream |
m_TimeScale | AP4_Mpeg2TsWriter::SampleStream |
SampleStream(AP4_UI16 pid, AP4_UI16 stream_id, AP4_UI08 stream_type, AP4_UI32 timescale) | AP4_Mpeg2TsWriter::SampleStream | [inline]
Stream(AP4_UI16 pid) | AP4_Mpeg2TsWriter::Stream | [inline]
WritePacketHeader(bool payload_start, unsigned int &payload_size, bool with_pcr, AP4_UI64 pcr, AP4_ByteStream &output) | AP4_Mpeg2TsWriter::Stream |
WritePES(const unsigned char *data, unsigned int data_size, AP4_UI64 dts, bool with_dts, AP4_UI64 pts, bool with_pcr, AP4_ByteStream &output) | AP4_Mpeg2TsWriter::SampleStream | [virtual]
WriteSample(AP4_Sample &sample, AP4_SampleDescription *sample_description, bool with_pcr, AP4_ByteStream &output)=0 | AP4_Mpeg2TsWriter::SampleStream | [pure virtual]
~Stream() | AP4_Mpeg2TsWriter::Stream | [inline, virtual]
Generated on Thu May 13 16:37:24 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_MarlinIpmpParser::SinfEntry Struct Reference

AP4_MarlinIpmpParser::SinfEntry

AP4_MarlinIpmpParser::SinfEntry Struct Reference

#include <Ap4Marlin.h>

List of all members.

Public Member Functions

SinfEntry (AP4_UI32 track_id, AP4_ContainerAtom *sinf)
~SinfEntry ()

Public Attributes

AP4_UI32 m_TrackId
AP4_ContainerAtom * m_Sinf

Detailed Description

Definition at line 71 of file Ap4Marlin.h.

Constructor & Destructor Documentation

AP4_MarlinIpmpParser::SinfEntry::SinfEntry | ( | AP4_UI32 | track_id,
 |  | AP4_ContainerAtom * | sinf |
 | ) |  |  | [inline]

Definition at line 72 of file Ap4Marlin.h.

AP4_MarlinIpmpParser::SinfEntry::~SinfEntry ( ) [inline]

Definition at line 74 of file Ap4Marlin.h.

References m_Sinf.

Member Data Documentation

AP4_ContainerAtom* AP4_MarlinIpmpParser::SinfEntry::m_Sinf

Definition at line 76 of file Ap4Marlin.h.

Referenced by ~SinfEntry().

AP4_UI32 AP4_MarlinIpmpParser::SinfEntry::m_TrackId

Definition at line 75 of file Ap4Marlin.h.

The documentation for this struct was generated from the following file:
  • Ap4Marlin.h
Generated on Thu May 13 16:37:21 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_MarlinIpmpParser::SinfEntry Member List

This is the complete list of members for AP4_MarlinIpmpParser::SinfEntry, including all inherited members.
m_Sinf | AP4_MarlinIpmpParser::SinfEntry |
m_TrackId | AP4_MarlinIpmpParser::SinfEntry |
SinfEntry(AP4_UI32 track_id, AP4_ContainerAtom *sinf) | AP4_MarlinIpmpParser::SinfEntry | [inline]
~SinfEntry() | AP4_MarlinIpmpParser::SinfEntry | [inline]
Generated on Thu May 13 16:37:21 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_Mpeg2TsWriter::Stream Class Reference

AP4_Mpeg2TsWriter::Stream

AP4_Mpeg2TsWriter::Stream Class Reference

#include <Ap4Mpeg2Ts.h>

Inheritance diagram for AP4_Mpeg2TsWriter::Stream:
AP4_Mpeg2TsWriter::SampleStream

List of all members.

Public Member Functions

Stream (AP4_UI16 pid)
virtual | ~Stream ()
AP4_UI16 GetPID ()
void | WritePacketHeader (bool payload_start, unsigned int &payload_size, bool with_pcr, AP4_UI64 pcr, AP4_ByteStream &output)

Detailed Description

Definition at line 70 of file Ap4Mpeg2Ts.h.

Constructor & Destructor Documentation

AP4_Mpeg2TsWriter::Stream::Stream ( AP4_UI16 pid ) [inline]

Definition at line 72 of file Ap4Mpeg2Ts.h.

virtual AP4_Mpeg2TsWriter::Stream::~Stream ( ) [inline, virtual]

Definition at line 73 of file Ap4Mpeg2Ts.h.

Member Function Documentation

AP4_UI16 AP4_Mpeg2TsWriter::Stream::GetPID ( ) [inline]

Definition at line 75 of file Ap4Mpeg2Ts.h.

void AP4_Mpeg2TsWriter::Stream::WritePacketHeader | ( | bool | payload_start,
 |  | unsigned int & | payload_size,
 |  | bool | with_pcr,
 |  | AP4_UI64 | pcr,
 |  | AP4_ByteStream & | output
 | ) |  |
The documentation for this class was generated from the following file:
  • Ap4Mpeg2Ts.h
Generated on Thu May 13 16:37:24 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_Mpeg2TsWriter::Stream Member List

This is the complete list of members for AP4_Mpeg2TsWriter::Stream, including all inherited members.
GetPID() | AP4_Mpeg2TsWriter::Stream | [inline]
Stream(AP4_UI16 pid) | AP4_Mpeg2TsWriter::Stream | [inline]
WritePacketHeader(bool payload_start, unsigned int &payload_size, bool with_pcr, AP4_UI64 pcr, AP4_ByteStream &output) | AP4_Mpeg2TsWriter::Stream |
~Stream() | AP4_Mpeg2TsWriter::Stream | [inline, virtual]
Generated on Thu May 13 16:37:24 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_Processor::TrackHandler Class Reference

AP4_Processor::TrackHandler

AP4_Processor::TrackHandler Class Reference

Abstract class that defines the interface implemented by concrete track handlers. More...

#include <Ap4Processor.h>

Inheritance diagram for AP4_Processor::TrackHandler:
AP4_IsmaTrackDecrypter AP4_MarlinIpmpTrackDecrypter AP4_MarlinIpmpTrackEncrypter AP4_OmaDcfTrackDecrypter

List of all members.

Public Member Functions

virtual | ~TrackHandler ()
Default destructor.
virtual AP4_Result | ProcessTrack ()
A track handler may override this method if it needs to modify the track atoms before processing the track samples.
virtual AP4_Size | GetProcessedSampleSize (AP4_Sample &sample)
Returns the size of a sample after processing.
virtual AP4_Result | ProcessSample (AP4_DataBuffer &data_in, AP4_DataBuffer &data_out)=0
Process the data of one sample.

Detailed Description

Abstract class that defines the interface implemented by concrete track handlers.

A track handler is responsible for processing a track and its media samples.

Definition at line 83 of file Ap4Processor.h.

Constructor & Destructor Documentation

virtual AP4_Processor::TrackHandler::~TrackHandler ( ) [inline, virtual]

Default destructor.

Definition at line 88 of file Ap4Processor.h.

Member Function Documentation

virtual AP4_Size AP4_Processor::TrackHandler::GetProcessedSampleSize ( AP4_Sample & sample ) [inline, virtual]

Returns the size of a sample after processing.

Parameters:
sample Sample of which the processed size is requested.
Returns:
Size of the sample data after processing.

Reimplemented in AP4_IsmaTrackDecrypter, AP4_MarlinIpmpTrackDecrypter, AP4_MarlinIpmpTrackEncrypter, and AP4_OmaDcfTrackDecrypter.

Definition at line 101 of file Ap4Processor.h.

References AP4_Sample::GetSize().

virtual AP4_Result AP4_Processor::TrackHandler::ProcessSample | ( | AP4_DataBuffer & | data_in,
 |  | AP4_DataBuffer & | data_out |
 | ) |  |  | [pure virtual]

Process the data of one sample.

Parameters:
data_in | Data buffer with the data of the sample to process.
data_out | Data buffer in which the processed sample data is returned.

Implemented in AP4_IsmaTrackDecrypter, AP4_MarlinIpmpTrackDecrypter, AP4_MarlinIpmpTrackEncrypter, and AP4_OmaDcfTrackDecrypter.

virtual AP4_Result AP4_Processor::TrackHandler::ProcessTrack ( ) [inline, virtual]

A track handler may override this method if it needs to modify the track atoms before processing the track samples.

Reimplemented in AP4_IsmaTrackDecrypter, and AP4_OmaDcfTrackDecrypter.

Definition at line 94 of file Ap4Processor.h.

References AP4_SUCCESS.

The documentation for this class was generated from the following file:
  • Ap4Processor.h
Generated on Thu May 13 16:37:44 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_Processor::TrackHandler Member List

This is the complete list of members for AP4_Processor::TrackHandler, including all inherited members.
GetProcessedSampleSize(AP4_Sample &sample) | AP4_Processor::TrackHandler | [inline, virtual]
ProcessSample(AP4_DataBuffer &data_in, AP4_DataBuffer &data_out)=0 | AP4_Processor::TrackHandler | [pure virtual]
ProcessTrack() | AP4_Processor::TrackHandler | [inline, virtual]
~TrackHandler() | AP4_Processor::TrackHandler | [inline, virtual]
Generated on Thu May 13 16:37:44 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_AtomFactory::TypeHandler Class Reference

AP4_AtomFactory::TypeHandler

AP4_AtomFactory::TypeHandler Class Reference

#include <Ap4AtomFactory.h>

Inheritance diagram for AP4_AtomFactory::TypeHandler:
AP4_MetaDataAtomTypeHandler

List of all members.

Public Member Functions

virtual | ~TypeHandler ()
virtual AP4_Result | CreateAtom (AP4_Atom::Type type, AP4_UI32 size, AP4_ByteStream &stream, AP4_Atom::Type context, AP4_Atom *&atom)=0

Detailed Description

Definition at line 50 of file Ap4AtomFactory.h.

Constructor & Destructor Documentation

virtual AP4_AtomFactory::TypeHandler::~TypeHandler ( ) [inline, virtual]

Definition at line 52 of file Ap4AtomFactory.h.

Member Function Documentation

virtual AP4_Result AP4_AtomFactory::TypeHandler::CreateAtom | ( | AP4_Atom::Type | type,
 |  | AP4_UI32 | size,
 |  | AP4_ByteStream & | stream,
 |  | AP4_Atom::Type | context,
 |  | AP4_Atom *& | atom |
 | ) |  |  | [pure virtual]

Implemented in AP4_MetaDataAtomTypeHandler.

The documentation for this class was generated from the following file:
  • Ap4AtomFactory.h
Generated on Thu May 13 16:36:45 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_AtomFactory::TypeHandler Member List

This is the complete list of members for AP4_AtomFactory::TypeHandler, including all inherited members.
CreateAtom(AP4_Atom::Type type, AP4_UI32 size, AP4_ByteStream &stream, AP4_Atom::Type context, AP4_Atom *&atom)=0 | AP4_AtomFactory::TypeHandler | [pure virtual]
~TypeHandler() | AP4_AtomFactory::TypeHandler | [inline, virtual]
Generated on Thu May 13 16:36:45 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_MetaDataAtomTypeHandler::TypeList Struct Reference

AP4_MetaDataAtomTypeHandler::TypeList

AP4_MetaDataAtomTypeHandler::TypeList Struct Reference

#include <Ap4MetaData.h>

List of all members.

Public Attributes

const AP4_Atom::Type * m_Types
AP4_Size m_Size

Detailed Description

Definition at line 285 of file Ap4MetaData.h.

Member Data Documentation

AP4_Size AP4_MetaDataAtomTypeHandler::TypeList::m_Size

Definition at line 287 of file Ap4MetaData.h.

const AP4_Atom::Type* AP4_MetaDataAtomTypeHandler::TypeList::m_Types

Definition at line 286 of file Ap4MetaData.h.

The documentation for this struct was generated from the following file:
  • Ap4MetaData.h
Generated on Thu May 13 16:37:22 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_MetaDataAtomTypeHandler::TypeList Member List

This is the complete list of members for AP4_MetaDataAtomTypeHandler::TypeList, including all inherited members.
m_Size | AP4_MetaDataAtomTypeHandler::TypeList
m_Types | AP4_MetaDataAtomTypeHandler::TypeList
Generated on Thu May 13 16:37:22 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: AP4_MetaData::Value Class Reference

AP4_MetaData::Value

AP4_MetaData::Value Class Reference

#include <Ap4MetaData.h>

Inheritance diagram for AP4_MetaData::Value:
AP4_AtomMetaDataValue AP4_BinaryMetaDataValue AP4_IntegerMetaDataValue AP4_StringMetaDataValue

List of all members.

Public Types

enum Type {
TYPE_BINARY,
TYPE_STRING_UTF_8,
TYPE_STRING_UTF_16,
TYPE_STRING_PASCAL,
TYPE_GIF,
TYPE_JPEG,
TYPE_INT_08_BE,
TYPE_INT_16_BE,
TYPE_INT_32_BE,
TYPE_FLOAT_32_BE,
TYPE_FLOAT_64_BE
}
enum TypeCategory {
TYPE_CATEGORY_STRING,
TYPE_CATEGORY_BINARY,
TYPE_CATEGORY_INTEGER,
TYPE_CATEGORY_FLOAT
}
enum Meaning {
MEANING_UNKNOWN,
MEANING_ID3_GENRE,
MEANING_BOOLEAN,
MEANING_FILE_KIND,
MEANING_BINARY_ENCODED_CHARS
}

Public Member Functions

virtual | ~Value ()
Type | GetType () const
TypeCategory | GetTypeCategory () const
Meaning | GetMeaning () const
const AP4_String & | GetLanguage () const
void | SetLanguage (const char *language)
virtual AP4_String | ToString () const =0
virtual AP4_Result | ToBytes (AP4_DataBuffer &bytes) const =0
virtual long | ToInteger () const =0

Protected Member Functions

Value (Type type, Meaning meaning=MEANING_UNKNOWN, const char *language=NULL)

Static Protected Member Functions

static TypeCategory | MapTypeToCategory (Type type)

Protected Attributes

Type m_Type
Meaning m_Meaning
AP4_String m_Language

Detailed Description

Definition at line 147 of file Ap4MetaData.h.

Member Enumeration Documentation

enum AP4_MetaData::Value::Meaning
Enumerator:
MEANING_UNKNOWN
MEANING_ID3_GENRE
MEANING_BOOLEAN
MEANING_FILE_KIND
MEANING_BINARY_ENCODED_CHARS

Definition at line 171 of file Ap4MetaData.h.

enum AP4_MetaData::Value::Type
Enumerator:
TYPE_BINARY
TYPE_STRING_UTF_8
TYPE_STRING_UTF_16
TYPE_STRING_PASCAL
TYPE_GIF
TYPE_JPEG
TYPE_INT_08_BE
TYPE_INT_16_BE
TYPE_INT_32_BE
TYPE_FLOAT_32_BE
TYPE_FLOAT_64_BE

Definition at line 150 of file Ap4MetaData.h.

enum AP4_MetaData::Value::TypeCategory
Enumerator:
TYPE_CATEGORY_STRING
TYPE_CATEGORY_BINARY
TYPE_CATEGORY_INTEGER
TYPE_CATEGORY_FLOAT

Definition at line 164 of file Ap4MetaData.h.

Constructor & Destructor Documentation

virtual AP4_MetaData::Value::~Value ( ) [inline, virtual]

Definition at line 180 of file Ap4MetaData.h.

AP4_MetaData::Value::Value | ( | Type | type,
 |  | Meaning | meaning = MEANING_UNKNOWN,
 |  | const char * | language = NULL |
 | ) |  |  | [inline, protected]

Definition at line 197 of file Ap4MetaData.h.

Member Function Documentation

const AP4_String& AP4_MetaData::Value::GetLanguage ( ) const [inline]

Definition at line 186 of file Ap4MetaData.h.

References m_Language.

Meaning AP4_MetaData::Value::GetMeaning ( ) const [inline]

Definition at line 185 of file Ap4MetaData.h.

References m_Meaning.

Type AP4_MetaData::Value::GetType ( ) const [inline]

Definition at line 183 of file Ap4MetaData.h.

References m_Type.

TypeCategory AP4_MetaData::Value::GetTypeCategory ( ) const
static TypeCategory AP4_MetaData::Value::MapTypeToCategory ( Type type ) [static, protected]
void AP4_MetaData::Value::SetLanguage ( const char * language ) [inline]

Definition at line 187 of file Ap4MetaData.h.

References m_Language.

virtual AP4_Result AP4_MetaData::Value::ToBytes ( AP4_DataBuffer & bytes ) const [pure virtual]

Implemented in AP4_StringMetaDataValue, AP4_IntegerMetaDataValue, AP4_BinaryMetaDataValue, and AP4_AtomMetaDataValue.

virtual long AP4_MetaData::Value::ToInteger ( ) const [pure virtual]

Implemented in AP4_StringMetaDataValue, AP4_IntegerMetaDataValue, AP4_BinaryMetaDataValue, and AP4_AtomMetaDataValue.

virtual AP4_String AP4_MetaData::Value::ToString ( ) const [pure virtual]

Implemented in AP4_StringMetaDataValue, AP4_IntegerMetaDataValue, AP4_BinaryMetaDataValue, and AP4_AtomMetaDataValue.

Member Data Documentation

AP4_String AP4_MetaData::Value::m_Language [protected]

Definition at line 205 of file Ap4MetaData.h.

Referenced by GetLanguage(), and SetLanguage().

Meaning AP4_MetaData::Value::m_Meaning [protected]

Definition at line 204 of file Ap4MetaData.h.

Referenced by GetMeaning().

Type AP4_MetaData::Value::m_Type [protected]

Definition at line 203 of file Ap4MetaData.h.

Referenced by GetType().

The documentation for this class was generated from the following file:
  • Ap4MetaData.h
Generated on Thu May 13 16:37:22 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Member List

AP4_MetaData::Value Member List

This is the complete list of members for AP4_MetaData::Value, including all inherited members.
GetLanguage() const | AP4_MetaData::Value | [inline]
GetMeaning() const | AP4_MetaData::Value | [inline]
GetType() const | AP4_MetaData::Value | [inline]
GetTypeCategory() const | AP4_MetaData::Value |
m_Language | AP4_MetaData::Value | [protected]
m_Meaning | AP4_MetaData::Value | [protected]
m_Type | AP4_MetaData::Value | [protected]
MapTypeToCategory(Type type) | AP4_MetaData::Value | [protected, static]
Meaning enum name | AP4_MetaData::Value |
MEANING_BINARY_ENCODED_CHARS enum value | AP4_MetaData::Value |
MEANING_BOOLEAN enum value | AP4_MetaData::Value |
MEANING_FILE_KIND enum value | AP4_MetaData::Value |
MEANING_ID3_GENRE enum value | AP4_MetaData::Value |
MEANING_UNKNOWN enum value | AP4_MetaData::Value |
SetLanguage(const char *language) | AP4_MetaData::Value | [inline]
ToBytes(AP4_DataBuffer &bytes) const =0 | AP4_MetaData::Value | [pure virtual]
ToInteger() const =0 | AP4_MetaData::Value | [pure virtual]
ToString() const =0 | AP4_MetaData::Value | [pure virtual]
Type enum name | AP4_MetaData::Value |
TYPE_BINARY enum value | AP4_MetaData::Value |
TYPE_CATEGORY_BINARY enum value | AP4_MetaData::Value |
TYPE_CATEGORY_FLOAT enum value | AP4_MetaData::Value |
TYPE_CATEGORY_INTEGER enum value | AP4_MetaData::Value |
TYPE_CATEGORY_STRING enum value | AP4_MetaData::Value |
TYPE_FLOAT_32_BE enum value | AP4_MetaData::Value |
TYPE_FLOAT_64_BE enum value | AP4_MetaData::Value |
TYPE_GIF enum value | AP4_MetaData::Value |
TYPE_INT_08_BE enum value | AP4_MetaData::Value |
TYPE_INT_16_BE enum value | AP4_MetaData::Value |
TYPE_INT_32_BE enum value | AP4_MetaData::Value |
TYPE_JPEG enum value | AP4_MetaData::Value |
TYPE_STRING_PASCAL enum value | AP4_MetaData::Value |
TYPE_STRING_UTF_16 enum value | AP4_MetaData::Value |
TYPE_STRING_UTF_8 enum value | AP4_MetaData::Value |
TypeCategory enum name | AP4_MetaData::Value |
Value(Type type, Meaning meaning=MEANING_UNKNOWN, const char *language=NULL) | AP4_MetaData::Value | [inline, protected]
~Value() | AP4_MetaData::Value | [inline, virtual]
Generated on Thu May 13 16:37:22 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Hierarchical Index

Class Hierarchy

This inheritance list is sorted roughly, but not completely, alphabetically:
  • AP4_Array< T >
  • AP4_Atom
    • AP4_3GppLocalizedStringAtom
    • AP4_8bdlAtom
    • AP4_AvccAtom
    • AP4_Co64Atom
    • AP4_ContainerAtom
      • AP4_DrefAtom
      • AP4_IproAtom
      • AP4_MoovAtom
      • AP4_OdheAtom
      • AP4_OhdrAtom
      • AP4_SampleEntry
        • AP4_AudioSampleEntry
          • AP4_EncaSampleEntry
            • AP4_DrmsSampleEntry
          • AP4_MpegAudioSampleEntry
            • AP4_Mp4aSampleEntry
        • AP4_MpegSystemSampleEntry
          • AP4_Mp4sSampleEntry
        • AP4_RtpHintSampleEntry
        • AP4_UnknownSampleEntry
        • AP4_VisualSampleEntry
          • AP4_Avc1SampleEntry
          • AP4_EncvSampleEntry
            • AP4_DrmiSampleEntry
          • AP4_MpegVideoSampleEntry
            • AP4_Mp4vSampleEntry
      • AP4_StsdAtom
      • AP4_TrakAtom
    • AP4_CttsAtom
    • AP4_DataAtom
    • AP4_DcfdAtom
    • AP4_DcfStringAtom
    • AP4_ElstAtom
    • AP4_EsdsAtom
    • AP4_FrmaAtom
    • AP4_FtypAtom
    • AP4_GrpiAtom
    • AP4_HdlrAtom
    • AP4_HmhdAtom
    • AP4_IkmsAtom
    • AP4_IodsAtom
    • AP4_IsfmAtom
    • AP4_IsltAtom
    • AP4_MdhdAtom
    • AP4_MehdAtom
    • AP4_MetaDataStringAtom
    • AP4_MfhdAtom
    • AP4_MfroAtom
    • AP4_MvhdAtom
    • AP4_NmhdAtom
    • AP4_NullTerminatedStringAtom
    • AP4_OdafAtom
    • AP4_OddaAtom
    • AP4_RtpAtom
    • AP4_SchmAtom
    • AP4_SdpAtom
    • AP4_SmhdAtom
    • AP4_StcoAtom
    • AP4_StscAtom
    • AP4_StssAtom
    • AP4_StszAtom
    • AP4_SttsAtom
    • AP4_TfhdAtom
    • AP4_TfraAtom
    • AP4_TimsAtom
    • AP4_TkhdAtom
    • AP4_TrefTypeAtom
    • AP4_TrexAtom
    • AP4_TrunAtom
    • AP4_UnknownAtom
    • AP4_UrlAtom
    • AP4_UuidAtom
      • AP4_PiffSampleEncryptionAtom
      • AP4_PiffTrackEncryptionAtom
      • AP4_UnknownUuidAtom
    • AP4_VmhdAtom
  • AP4_AtomFactory
    • AP4_DefaultAtomFactory
  • AP4_AtomInspector
    • AP4_PrintInspector
  • AP4_AtomParent
    • AP4_ContainerAtom
    • AP4_File
  • AP4_AudioSampleDescription
    • AP4_GenericAudioSampleDescription
    • AP4_MpegAudioSampleDescription
  • AP4_BitWriter
  • AP4_BlockCipher
    • AP4_AesBlockCipher
  • AP4_BlockCipherFactory
    • AP4_DefaultBlockCipherFactory
  • AP4_CommandFactory
  • AP4_CttsTableEntry
  • AP4_DataBuffer
  • AP4_DescriptorFactory
  • AP4_ElstEntry
  • AP4_Exception
  • AP4_Expandable
    • AP4_Command
      • AP4_DescriptorUpdateCommand
      • AP4_UnknownCommand
    • AP4_Descriptor
      • AP4_DecoderConfigDescriptor
      • AP4_DecoderSpecificInfoDescriptor
      • AP4_EsDescriptor
      • AP4_EsIdIncDescriptor
      • AP4_EsIdRefDescriptor
      • AP4_IpmpDescriptor
      • AP4_IpmpDescriptorPointer
      • AP4_ObjectDescriptor
        • AP4_InitialObjectDescriptor
      • AP4_SLConfigDescriptor
      • AP4_UnknownDescriptor
    • AP4_UnknownExpandable
  • AP4_FileCopier
  • AP4_FileWriter
  • AP4_HintTrackReader
  • AP4_Hmac
  • AP4_LinearReader
  • AP4_List< T >
  • AP4_MarlinIpmpParser
  • AP4_MetaData
  • AP4_MetaDataTag
  • AP4_Movie
  • AP4_MovieFragment
  • AP4_Mpeg2TsWriter
  • AP4_OmaDcfAtomDecrypter
  • AP4_OmaDcfSampleEncrypter
    • AP4_OmaDcfCbcSampleEncrypter
    • AP4_OmaDcfCtrSampleEncrypter
  • AP4_OmaDrmInfo
    • AP4_OhdrAtom
  • AP4_PiffSampleEncrypter
    • AP4_PiffCbcSampleEncrypter
      • AP4_PiffAvcCbcSampleEncrypter
    • AP4_PiffCtrSampleEncrypter
      • AP4_PiffAvcCtrSampleEncrypter
  • AP4_Processor
    • AP4_IsmaEncryptingProcessor
    • AP4_MarlinIpmpDecryptingProcessor
    • AP4_MarlinIpmpEncryptingProcessor
    • AP4_OmaDcfDecryptingProcessor
    • AP4_OmaDcfEncryptingProcessor
    • AP4_PiffEncryptingProcessor
    • AP4_StandardDecryptingProcessor
  • AP4_ProtectionKeyMap
  • AP4_ProtectionSchemeInfo
  • AP4_Referenceable
    • AP4_ByteStream
      • AP4_BufferedInputStream
      • AP4_DecryptingStream
      • AP4_EncryptingStream
      • AP4_FileByteStream
      • AP4_MemoryByteStream
      • AP4_SubStream
    • AP4_RtpConstructor
      • AP4_ImmediateRtpConstructor
      • AP4_NoopRtpConstructor
      • AP4_SampleDescRtpConstructor
      • AP4_SampleRtpConstructor
    • AP4_RtpPacket
  • AP4_RtpConstructorFactory
  • AP4_RtpSampleData
  • AP4_Sample
  • AP4_SampleDecrypter
    • AP4_IsmaCipher
    • AP4_OmaDcfSampleDecrypter
      • AP4_OmaDcfCbcSampleDecrypter
      • AP4_OmaDcfCtrSampleDecrypter
    • AP4_PiffSampleDecrypter
      • AP4_PiffCbcSampleDecrypter
        • AP4_PiffAvcCbcSampleDecrypter
      • AP4_PiffCtrSampleDecrypter
        • AP4_PiffAvcCtrSampleDecrypter
      • AP4_PiffNullSampleDecrypter
  • AP4_SampleDescription
    • AP4_AvcSampleDescription
    • AP4_GenericAudioSampleDescription
    • AP4_GenericVideoSampleDescription
    • AP4_MpegSampleDescription
      • AP4_MpegAudioSampleDescription
      • AP4_MpegSystemSampleDescription
      • AP4_MpegVideoSampleDescription
    • AP4_ProtectedSampleDescription
    • AP4_UnknownSampleDescription
  • AP4_SampleSource
    • AP4_TrackSampleSource
  • AP4_SampleTable
    • AP4_AtomSampleTable
    • AP4_FragmentSampleTable
    • AP4_SyntheticSampleTable
  • AP4_StreamCipher
    • AP4_CbcStreamCipher
    • AP4_CtrStreamCipher
  • AP4_String
  • AP4_StscTableEntry
  • AP4_SttsTableEntry
  • AP4_Track
  • AP4_TrackPropertyMap
  • AP4_UI64
  • AP4_VideoSampleDescription
    • AP4_AvcSampleDescription
    • AP4_GenericVideoSampleDescription
    • AP4_MpegVideoSampleDescription
  • AP4_PiffEncryptingProcessor::Encrypter
  • AP4_TrunAtom::Entry
  • AP4_MetaData::Entry
  • AP4_TfraAtom::Entry
  • AP4_Processor::ExternalTrackData
  • AP4_List< T >::Item::Finder
    • AP4_AtomFinder
    • AP4_DescriptorFinder
  • AP4_Processor::FragmentHandler
  • AP4_List< T >::Item
  • AP4_MetaData::Key
  • AP4_MetaData::KeyInfo
  • AP4_List< T >::Item::Operator
    • AP4_AtomListInspector
    • AP4_AtomListWriter
    • AP4_AtomSizeAdder
    • AP4_DescriptorListInspector
    • AP4_DescriptorListWriter
  • AP4_Processor::ProgressListener
  • AP4_MarlinIpmpParser::SinfEntry
  • AP4_Mpeg2TsWriter::Stream
    • AP4_Mpeg2TsWriter::SampleStream
  • AP4_Processor::TrackHandler
    • AP4_IsmaTrackDecrypter
    • AP4_MarlinIpmpTrackDecrypter
    • AP4_MarlinIpmpTrackEncrypter
    • AP4_OmaDcfTrackDecrypter
  • AP4_AtomFactory::TypeHandler
    • AP4_MetaDataAtomTypeHandler
  • AP4_MetaDataAtomTypeHandler::TypeList
  • AP4_MetaData::Value
    • AP4_AtomMetaDataValue
    • AP4_BinaryMetaDataValue
    • AP4_IntegerMetaDataValue
    • AP4_StringMetaDataValue
Generated on Thu May 13 16:36:41 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all class members with links to the classes they belong to:

- _ -

  • _3gppLocalizedStringTypeList : AP4_MetaDataAtomTypeHandler
  • _3gppLocalizedStringTypes : AP4_MetaDataAtomTypeHandler
  • _3gppOtherTypeList : AP4_MetaDataAtomTypeHandler
  • _3gppOtherTypes : AP4_MetaDataAtomTypeHandler
Generated on Thu May 13 16:36:41 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all class members with links to the classes they belong to:

- k -

  • Key() : AP4_MetaData::Key
  • KeyInfos : AP4_MetaData
Generated on Thu May 13 16:36:42 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all class members with links to the classes they belong to:

- l -

  • LANGUAGE_ENGLISH : AP4_DataAtom
  • LastItem() : AP4_List< T >
  • lo : AP4_UI64
  • LoadBytes() : AP4_DataAtom
  • LoadInteger() : AP4_DataAtom
  • LoadString() : AP4_DataAtom
Generated on Thu May 13 16:36:42 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all class members with links to the classes they belong to:

- m -

  • m_AllocatedCount : AP4_Array< T >
  • m_AvgBitrate : AP4_MpegSampleDescription
  • m_BlockCipherFactory : AP4_PiffEncryptingProcessor
  • m_Buffer : AP4_DataBuffer
  • m_BufferIsLocal : AP4_DataBuffer
  • m_BufferSize : AP4_DataBuffer , AP4_MpegSampleDescription
  • m_ChannelCount : AP4_AudioSampleDescription , AP4_AudioSampleEntry
  • m_Children : AP4_AtomParent
  • m_Chunk : AP4_SyntheticSampleTable
  • m_ChunkCount : AP4_StscTableEntry
  • m_Cipher : AP4_PiffCtrSampleEncrypter , AP4_PiffCbcSampleEncrypter , AP4_PiffCbcSampleDecrypter
  • m_CipherMode : AP4_PiffEncryptingProcessor
  • m_ClassId : AP4_Expandable
  • m_ClassIdSize : AP4_Expandable
  • m_CompressorName : AP4_VideoSampleDescription , AP4_VisualSampleEntry
  • m_CtsDelta : AP4_Sample
  • m_Data : AP4_ImmediateRtpConstructor , AP4_UnknownUuidAtom
  • m_DataReferenceIndex : AP4_SampleEntry
  • m_DataSize : AP4_DataBuffer
  • m_DataStream : AP4_Sample
  • m_DecoderInfo : AP4_MpegSampleDescription
  • m_Delegate : AP4_FileByteStream
  • m_Depth : AP4_VideoSampleDescription , AP4_VisualSampleEntry
  • m_DescriptionIndex : AP4_Sample
  • m_Descriptors : AP4_DescriptorUpdateCommand
  • m_Details : AP4_SampleDescription
  • m_Dts : AP4_Sample
  • m_Duration : AP4_Sample
  • m_Encrypters : AP4_PiffEncryptingProcessor
  • m_Error : AP4_Exception
  • m_ExternalTrackData : AP4_Processor
  • m_ExtraData : AP4_RtpSampleData
  • m_FirstChunk : AP4_StscTableEntry
  • m_FirstSample : AP4_StscTableEntry
  • m_Flags : AP4_Atom
  • m_Format : AP4_SampleDescription , AP4_MpegSampleDescription
  • m_FrameCount : AP4_VisualSampleEntry
  • m_Head : AP4_List< T >
  • m_HeaderSize : AP4_Expandable
  • m_Height : AP4_VideoSampleDescription , AP4_VisualSampleEntry
  • m_HighestCompatibleVersion : AP4_RtpHintSampleEntry
  • m_HintTrackVersion : AP4_RtpHintSampleEntry
  • m_HorizResolution : AP4_VisualSampleEntry
  • m_IsFull : AP4_Atom
  • m_IsSync : AP4_Sample
  • m_ItemCount : AP4_Array< T > , AP4_List< T >
  • m_Items : AP4_Array< T >
  • m_Iv : AP4_PiffSampleEncrypter
  • m_IvLength : AP4_OmaDcfSampleDecrypter
  • m_Key : AP4_MetaData::Entry
  • m_KeyIndicatorLength : AP4_OmaDcfSampleDecrypter
  • m_KeyMap : AP4_PiffEncryptingProcessor
  • m_Language : AP4_MetaData::Value
  • m_Length : AP4_SampleRtpConstructor , AP4_SampleDescRtpConstructor
  • m_MaxBitrate : AP4_MpegSampleDescription
  • m_MaxPacketSize : AP4_RtpHintSampleEntry
  • m_Meaning : AP4_MetaData::Value
  • m_MediaData : AP4_Processor::ExternalTrackData
  • m_MediaRate : AP4_ElstEntry
  • m_MediaTime : AP4_ElstEntry
  • m_MoofOffset : AP4_TfraAtom::Entry
  • m_MovieTimeScale : AP4_Track
  • m_ObjectDescriptorId : AP4_ObjectDescriptor
  • m_ObjectTypeId : AP4_MpegSampleDescription
  • m_Offset : AP4_Sample
  • m_Packets : AP4_RtpSampleData
  • m_Parent : AP4_Atom
  • m_Payload : AP4_UnknownSampleEntry
  • m_PayloadSize : AP4_Expandable
  • m_Predefined1 : AP4_VisualSampleEntry
  • m_Predefined2 : AP4_VisualSampleEntry
  • m_Predefined3 : AP4_VisualSampleEntry
  • m_PropertyMap : AP4_PiffEncryptingProcessor
  • m_QtCompressionId : AP4_AudioSampleEntry
  • m_QtPacketSize : AP4_AudioSampleEntry
  • m_QtRevision : AP4_AudioSampleEntry
  • m_QtV1BytesPerFrame : AP4_AudioSampleEntry
  • m_QtV1BytesPerPacket : AP4_AudioSampleEntry
  • m_QtV1BytesPerSample : AP4_AudioSampleEntry
  • m_QtV1SamplesPerPacket : AP4_AudioSampleEntry
  • m_QtV2BitsPerChannel : AP4_AudioSampleEntry
  • m_QtV2BytesPerAudioPacket : AP4_AudioSampleEntry
  • m_QtV2ChannelCount : AP4_AudioSampleEntry
  • m_QtV2Extension : AP4_AudioSampleEntry
  • m_QtV2FormatSpecificFlags : AP4_AudioSampleEntry
  • m_QtV2LPCMFramesPerAudioPacket : AP4_AudioSampleEntry
  • m_QtV2Reserved : AP4_AudioSampleEntry
  • m_QtV2SampleRate64 : AP4_AudioSampleEntry
  • m_QtV2StructSize : AP4_AudioSampleEntry
  • m_QtVendor : AP4_AudioSampleEntry
  • m_QtVersion : AP4_AudioSampleEntry
  • m_ReferenceCount : AP4_RtpConstructor
  • m_Reserved1 : AP4_SampleEntry
  • m_Reserved2 : AP4_VisualSampleEntry
  • m_Reserved3 : AP4_VisualSampleEntry
  • m_Salt : AP4_OmaDcfSampleEncrypter
  • m_Sample : AP4_SyntheticSampleTable
  • m_SampleCount : AP4_CttsTableEntry , AP4_SttsTableEntry
  • m_SampleDescIndex : AP4_SampleDescRtpConstructor
  • m_SampleDescOffset : AP4_SampleDescRtpConstructor
  • m_SampleDescriptionIndex : AP4_StscTableEntry
  • m_SampleDuration : AP4_SttsTableEntry
  • m_SampleEncrypter : AP4_PiffEncryptingProcessor::Encrypter
  • m_SampleEncryptionAtom : AP4_PiffSampleDecrypter
  • m_SampleIndex : AP4_PiffSampleDecrypter
  • m_SampleNum : AP4_SampleRtpConstructor
  • m_SampleNumber : AP4_TfraAtom::Entry
  • m_SampleOffset : AP4_SampleRtpConstructor , AP4_CttsTableEntry
  • m_SampleRate : AP4_AudioSampleEntry , AP4_AudioSampleDescription
  • m_SampleSize : AP4_AudioSampleEntry , AP4_AudioSampleDescription
  • m_SamplesPerChunk : AP4_StscTableEntry
  • m_SampleTable : AP4_Track
  • m_SampleTableIsOwned : AP4_Track
  • m_SchiAtom : AP4_ProtectionSchemeInfo
  • m_SegmentDuration : AP4_ElstEntry
  • m_SelectiveEncryption : AP4_OmaDcfSampleDecrypter
  • m_Sinf : AP4_MarlinIpmpParser::SinfEntry
  • m_Size : AP4_Sample , AP4_MetaDataAtomTypeHandler::TypeList
  • m_Size32 : AP4_Atom
  • m_Size64 : AP4_Atom
  • m_StreamId : AP4_Mpeg2TsWriter::SampleStream
  • m_StreamType : AP4_Mpeg2TsWriter::SampleStream , AP4_MpegSampleDescription
  • m_SubDescriptors : AP4_ObjectDescriptor
  • m_Tail : AP4_List< T >
  • m_Time : AP4_TfraAtom::Entry
  • m_TimeScale : AP4_Mpeg2TsWriter::SampleStream
  • m_TrackId
: AP4_Processor::ExternalTrackData
, AP4_PiffEncryptingProcessor::Encrypter
, AP4_MarlinIpmpParser::SinfEntry
  • m_TrackRefIndex : AP4_SampleDescRtpConstructor , AP4_SampleRtpConstructor
  • m_TrafNumber : AP4_TfraAtom::Entry
  • m_TrakAtom : AP4_Track
  • m_TrakAtomIsOwned : AP4_Track
  • m_TrunNumber : AP4_TfraAtom::Entry
  • m_Type : AP4_MetaData::Value , AP4_Track , AP4_Atom , AP4_RtpConstructor , AP4_SampleDescription
  • m_Types : AP4_MetaDataAtomTypeHandler::TypeList
  • m_Url : AP4_ObjectDescriptor
  • m_UrlFlag : AP4_ObjectDescriptor
  • m_Uuid : AP4_UuidAtom
  • m_Value : AP4_MetaData::Entry
  • m_Verbosity : AP4_AtomInspector
  • m_Version : AP4_Atom
  • m_VertResolution : AP4_VisualSampleEntry
  • m_Width : AP4_VideoSampleDescription , AP4_VisualSampleEntry
  • MapTypeToCategory() : AP4_MetaData::Value
  • Meaning : AP4_MetaData::Value
  • MEANING_BINARY_ENCODED_CHARS : AP4_MetaData::Value
  • MEANING_BOOLEAN : AP4_MetaData::Value
  • MEANING_FILE_KIND : AP4_MetaData::Value
  • MEANING_ID3_GENRE : AP4_MetaData::Value
  • MEANING_UNKNOWN : AP4_MetaData::Value
  • MinHeaderSize() : AP4_Expandable
  • Mode : AP4_FileByteStream
  • Mpeg4AudioObjectType : AP4_MpegAudioSampleDescription
Generated on Thu May 13 16:36:42 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all class members with links to the classes they belong to:

- n -

  • name : AP4_MetaData::KeyInfo
Generated on Thu May 13 16:36:42 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all class members with links to the classes they belong to:

- o -

  • OnChildAdded() : AP4_AtomParent , AP4_ContainerAtom , AP4_MoovAtom
  • OnChildChanged() : AP4_AtomParent , AP4_StsdAtom , AP4_ContainerAtom , AP4_OdheAtom , AP4_SampleEntry
  • OnChildRemoved() : AP4_AtomParent , AP4_ContainerAtom , AP4_MoovAtom
  • OnProgress() : AP4_Processor::ProgressListener
  • operator!=() : AP4_String
  • operator=() : AP4_String , AP4_Sample
  • operator==() : AP4_String
  • operator[]() : AP4_Array< T > , AP4_String
  • OTI : AP4_MpegSampleDescription
Generated on Thu May 13 16:36:42 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all class members with links to the classes they belong to:

- ~ -

  • ~AP4_AesBlockCipher() : AP4_AesBlockCipher
  • ~AP4_Array() : AP4_Array< T >
  • ~AP4_Atom() : AP4_Atom
  • ~AP4_AtomFactory() : AP4_AtomFactory
  • ~AP4_AtomInspector() : AP4_AtomInspector
  • ~AP4_AtomParent() : AP4_AtomParent
  • ~AP4_AtomSampleTable() : AP4_AtomSampleTable
  • ~AP4_BitWriter() : AP4_BitWriter
  • ~AP4_BlockCipher() : AP4_BlockCipher
  • ~AP4_BlockCipherFactory() : AP4_BlockCipherFactory
  • ~AP4_BufferedInputStream() : AP4_BufferedInputStream
  • ~AP4_CbcStreamCipher() : AP4_CbcStreamCipher
  • ~AP4_Co64Atom() : AP4_Co64Atom
  • ~AP4_CtrStreamCipher() : AP4_CtrStreamCipher
  • ~AP4_DataAtom() : AP4_DataAtom
  • ~AP4_DataBuffer() : AP4_DataBuffer
  • ~AP4_DecoderConfigDescriptor() : AP4_DecoderConfigDescriptor
  • ~AP4_DecoderSpecificInfoDescriptor() : AP4_DecoderSpecificInfoDescriptor
  • ~AP4_DescriptorUpdateCommand() : AP4_DescriptorUpdateCommand
  • ~AP4_EsDescriptor() : AP4_EsDescriptor
  • ~AP4_EsdsAtom() : AP4_EsdsAtom
  • ~AP4_Expandable() : AP4_Expandable
  • ~AP4_File() : AP4_File
  • ~AP4_FileByteStream() : AP4_FileByteStream
  • ~AP4_FragmentSampleTable() : AP4_FragmentSampleTable
  • ~AP4_HintTrackReader() : AP4_HintTrackReader
  • ~AP4_Hmac() : AP4_Hmac
  • ~AP4_IodsAtom() : AP4_IodsAtom
  • ~AP4_IsmaCipher() : AP4_IsmaCipher
  • ~AP4_IsmaTrackDecrypter() : AP4_IsmaTrackDecrypter
  • ~AP4_LinearReader() : AP4_LinearReader
  • ~AP4_List() : AP4_List< T >
  • ~AP4_MarlinIpmpDecryptingProcessor() : AP4_MarlinIpmpDecryptingProcessor
  • ~AP4_MarlinIpmpTrackDecrypter() : AP4_MarlinIpmpTrackDecrypter
  • ~AP4_MarlinIpmpTrackEncrypter() : AP4_MarlinIpmpTrackEncrypter
  • ~AP4_MemoryByteStream() : AP4_MemoryByteStream
  • ~AP4_MetaData() : AP4_MetaData
  • ~AP4_MetaDataTag() : AP4_MetaDataTag
  • ~AP4_Movie() : AP4_Movie
  • ~AP4_MovieFragment() : AP4_MovieFragment
  • ~AP4_Mpeg2TsWriter() : AP4_Mpeg2TsWriter
  • ~AP4_ObjectDescriptor() : AP4_ObjectDescriptor
  • ~AP4_OddaAtom() : AP4_OddaAtom
  • ~AP4_OmaDcfCbcSampleDecrypter() : AP4_OmaDcfCbcSampleDecrypter
  • ~AP4_OmaDcfCbcSampleEncrypter() : AP4_OmaDcfCbcSampleEncrypter
  • ~AP4_OmaDcfCtrSampleDecrypter() : AP4_OmaDcfCtrSampleDecrypter
  • ~AP4_OmaDcfCtrSampleEncrypter() : AP4_OmaDcfCtrSampleEncrypter
  • ~AP4_OmaDcfSampleEncrypter() : AP4_OmaDcfSampleEncrypter
  • ~AP4_OmaDcfTrackDecrypter() : AP4_OmaDcfTrackDecrypter
  • ~AP4_OmaDrmInfo() : AP4_OmaDrmInfo
  • ~AP4_PiffCbcSampleDecrypter() : AP4_PiffCbcSampleDecrypter
  • ~AP4_PiffCbcSampleEncrypter() : AP4_PiffCbcSampleEncrypter
  • ~AP4_PiffCtrSampleDecrypter() : AP4_PiffCtrSampleDecrypter
  • ~AP4_PiffCtrSampleEncrypter() : AP4_PiffCtrSampleEncrypter
  • ~AP4_PiffEncryptingProcessor() : AP4_PiffEncryptingProcessor
  • ~AP4_PiffSampleEncrypter() : AP4_PiffSampleEncrypter
  • ~AP4_PrintInspector() : AP4_PrintInspector
  • ~AP4_Processor() : AP4_Processor
  • ~AP4_ProtectedSampleDescription() : AP4_ProtectedSampleDescription
  • ~AP4_ProtectionKeyMap() : AP4_ProtectionKeyMap
  • ~AP4_ProtectionSchemeInfo() : AP4_ProtectionSchemeInfo
  • ~AP4_Referenceable() : AP4_Referenceable
  • ~AP4_RtpConstructor() : AP4_RtpConstructor
  • ~AP4_RtpPacket() : AP4_RtpPacket
  • ~AP4_RtpSampleData() : AP4_RtpSampleData
  • ~AP4_Sample() : AP4_Sample
  • ~AP4_SampleDecrypter() : AP4_SampleDecrypter
  • ~AP4_SampleDescription() : AP4_SampleDescription
  • ~AP4_SampleEntry() : AP4_SampleEntry
  • ~AP4_SampleSource() : AP4_SampleSource
  • ~AP4_SampleTable() : AP4_SampleTable
  • ~AP4_StcoAtom() : AP4_StcoAtom
  • ~AP4_StreamCipher() : AP4_StreamCipher
  • ~AP4_String() : AP4_String
  • ~AP4_StsdAtom() : AP4_StsdAtom
  • ~AP4_SubStream() : AP4_SubStream
  • ~AP4_SyntheticSampleTable() : AP4_SyntheticSampleTable
  • ~AP4_Track() : AP4_Track
  • ~AP4_TrackPropertyMap() : AP4_TrackPropertyMap
  • ~AP4_UnknownAtom() : AP4_UnknownAtom
  • ~AP4_UnknownSampleDescription() : AP4_UnknownSampleDescription
  • ~AP4_UuidAtom() : AP4_UuidAtom
  • ~Entry() : AP4_MetaData::Entry
  • ~ExternalTrackData() : AP4_Processor::ExternalTrackData
  • ~Finder() : AP4_List< T >::Item::Finder
  • ~FragmentHandler() : AP4_Processor::FragmentHandler
  • ~Item() : AP4_List< T >::Item
  • ~Operator() : AP4_List< T >::Item::Operator
  • ~ProgressListener() : AP4_Processor::ProgressListener
  • ~SinfEntry() : AP4_MarlinIpmpParser::SinfEntry
  • ~Stream() : AP4_Mpeg2TsWriter::Stream
  • ~TrackHandler() : AP4_Processor::TrackHandler
  • ~TypeHandler() : AP4_AtomFactory::TypeHandler
  • ~Value() : AP4_MetaData::Value
Generated on Thu May 13 16:36:42 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all class members with links to the classes they belong to:

- a -

  • Action() : AP4_AtomListInspector , AP4_AtomListWriter , AP4_DescriptorListInspector , AP4_List< T >::Item::Operator , AP4_DescriptorListWriter
  • Add() : AP4_List< T >
  • Add3GppEntry() : AP4_MetaData
  • AddChild() : AP4_AtomParent
  • AddConstructor() : AP4_RtpPacket
  • AddDcfdEntry() : AP4_MetaData
  • AddDcfStringEntry() : AP4_MetaData
  • AddDescriptor() : AP4_DescriptorUpdateCommand
  • AddEntry() : AP4_StssAtom , AP4_StszAtom , AP4_SttsAtom , AP4_CttsAtom , AP4_StscAtom
  • AddField() : AP4_AtomInspector , AP4_PrintInspector
  • AddFieldF() : AP4_AtomInspector , AP4_PrintInspector
  • AddIlstEntries() : AP4_MetaData
  • AddPacket() : AP4_RtpSampleData
  • AddReference() : AP4_FileByteStream , AP4_Referenceable , AP4_DecryptingStream , AP4_EncryptingStream , AP4_RtpPacket , AP4_RtpConstructor , AP4_SubStream , AP4_MemoryByteStream , AP4_BufferedInputStream
  • AddSample() : AP4_SyntheticSampleTable
  • AddSampleDescription() : AP4_SyntheticSampleTable
  • AddSubDescriptor() : AP4_EsDescriptor , AP4_ObjectDescriptor
  • AddToFile() : AP4_MetaData::Entry
  • AddToFileDcf() : AP4_MetaData::Entry
  • AddToFileIlst() : AP4_MetaData::Entry
  • AddTrack() : AP4_Movie
  • AddTrackId() : AP4_TrefTypeAtom
  • AddTypeHandler() : AP4_AtomFactory
  • AdjustChunkOffsets() : AP4_Co64Atom , AP4_MoovAtom , AP4_StcoAtom , AP4_TrakAtom
  • AES_128 : AP4_BlockCipher
  • Algorithm : AP4_Hmac
  • AP4_3GppLocalizedStringAtom() : AP4_3GppLocalizedStringAtom
  • AP4_8bdlAtom() : AP4_8bdlAtom
  • AP4_AesBlockCipher() : AP4_AesBlockCipher
  • AP4_Array() : AP4_Array< T >
  • AP4_Atom() : AP4_Atom
  • AP4_AtomFactory() : AP4_AtomFactory
  • AP4_AtomFinder() : AP4_AtomFinder
  • AP4_AtomInspector() : AP4_AtomInspector
  • AP4_AtomListInspector() : AP4_AtomListInspector
  • AP4_AtomListWriter() : AP4_AtomListWriter
  • AP4_AtomMetaDataValue() : AP4_AtomMetaDataValue
  • AP4_AtomSampleTable() : AP4_AtomSampleTable
  • AP4_AtomSizeAdder() : AP4_AtomSizeAdder
  • AP4_AudioSampleDescription() : AP4_AudioSampleDescription
  • AP4_AudioSampleEntry() : AP4_AudioSampleEntry
  • AP4_Avc1SampleEntry() : AP4_Avc1SampleEntry
  • AP4_AvccAtom() : AP4_AvccAtom
  • AP4_AvcSampleDescription() : AP4_AvcSampleDescription
  • AP4_BinaryMetaDataValue() : AP4_BinaryMetaDataValue
  • AP4_BitWriter() : AP4_BitWriter
  • AP4_BufferedInputStream() : AP4_BufferedInputStream
  • AP4_CbcStreamCipher() : AP4_CbcStreamCipher
  • AP4_Co64Atom() : AP4_Co64Atom
  • AP4_Command() : AP4_Command
  • AP4_ContainerAtom() : AP4_ContainerAtom
  • AP4_CtrStreamCipher() : AP4_CtrStreamCipher
  • AP4_CttsAtom() : AP4_CttsAtom
  • AP4_CttsTableEntry() : AP4_CttsTableEntry
  • AP4_DataAtom() : AP4_DataAtom
  • AP4_DataBuffer() : AP4_DataBuffer
  • AP4_DcfdAtom() : AP4_DcfdAtom
  • AP4_DcfStringAtom() : AP4_DcfStringAtom
  • AP4_DecoderConfigDescriptor() : AP4_DecoderConfigDescriptor
  • AP4_DecoderSpecificInfoDescriptor() : AP4_DecoderSpecificInfoDescriptor
  • AP4_DefaultAtomFactory() : AP4_DefaultAtomFactory
  • AP4_Descriptor() : AP4_Descriptor
  • AP4_DescriptorFinder() : AP4_DescriptorFinder
  • AP4_DescriptorListInspector() : AP4_DescriptorListInspector
  • AP4_DescriptorListWriter() : AP4_DescriptorListWriter
  • AP4_DescriptorUpdateCommand() : AP4_DescriptorUpdateCommand
  • AP4_DrefAtom() : AP4_DrefAtom
  • AP4_DrmiSampleEntry() : AP4_DrmiSampleEntry
  • AP4_DrmsSampleEntry() : AP4_DrmsSampleEntry
  • AP4_ElstEntry() : AP4_ElstEntry
  • AP4_EncaSampleEntry() : AP4_EncaSampleEntry
  • AP4_EncvSampleEntry() : AP4_EncvSampleEntry
  • AP4_EsDescriptor() : AP4_EsDescriptor
  • AP4_EsdsAtom() : AP4_EsdsAtom
  • AP4_EsIdIncDescriptor() : AP4_EsIdIncDescriptor
  • AP4_EsIdRefDescriptor() : AP4_EsIdRefDescriptor
  • AP4_Exception() : AP4_Exception
  • AP4_Expandable() : AP4_Expandable
  • AP4_File() : AP4_File
  • AP4_FileByteStream() : AP4_FileByteStream
  • AP4_FragmentSampleTable() : AP4_FragmentSampleTable
  • AP4_FrmaAtom() : AP4_FrmaAtom
  • AP4_FtypAtom() : AP4_FtypAtom
  • AP4_GenericAudioSampleDescription() : AP4_GenericAudioSampleDescription
  • AP4_GenericVideoSampleDescription() : AP4_GenericVideoSampleDescription
  • AP4_GrpiAtom() : AP4_GrpiAtom
  • AP4_HdlrAtom() : AP4_HdlrAtom
  • AP4_IkmsAtom() : AP4_IkmsAtom
  • AP4_ImmediateRtpConstructor() : AP4_ImmediateRtpConstructor
  • AP4_InitialObjectDescriptor() : AP4_InitialObjectDescriptor
  • AP4_IntegerMetaDataValue() : AP4_IntegerMetaDataValue
  • AP4_IodsAtom() : AP4_IodsAtom
  • AP4_IpmpDescriptor() : AP4_IpmpDescriptor
  • AP4_IpmpDescriptorPointer() : AP4_IpmpDescriptorPointer
  • AP4_IsfmAtom() : AP4_IsfmAtom
  • AP4_IsltAtom() : AP4_IsltAtom
  • AP4_IsmaCipher() : AP4_IsmaCipher
  • AP4_IsmaEncryptingProcessor() : AP4_IsmaEncryptingProcessor
  • AP4_LinearReader() : AP4_LinearReader
  • AP4_List : AP4_List< T >::Item , AP4_List< T >
  • AP4_MarlinIpmpDecryptingProcessor() : AP4_MarlinIpmpDecryptingProcessor
  • AP4_MarlinIpmpEncryptingProcessor() : AP4_MarlinIpmpEncryptingProcessor
  • AP4_MdhdAtom() : AP4_MdhdAtom
  • AP4_MehdAtom() : AP4_MehdAtom
  • AP4_MemoryByteStream() : AP4_MemoryByteStream
  • AP4_MetaData() : AP4_MetaData
  • AP4_MetaDataAtomTypeHandler() : AP4_MetaDataAtomTypeHandler
  • AP4_MetaDataStringAtom() : AP4_MetaDataStringAtom
  • AP4_MetaDataTag() : AP4_MetaDataTag
  • AP4_MfhdAtom() : AP4_MfhdAtom
  • AP4_MfroAtom() : AP4_MfroAtom
  • AP4_MoovAtom() : AP4_MoovAtom
  • AP4_Movie() : AP4_Movie
  • AP4_MovieFragment() : AP4_MovieFragment
  • AP4_Mp4aSampleEntry() : AP4_Mp4aSampleEntry
  • AP4_Mp4sSampleEntry() : AP4_Mp4sSampleEntry
  • AP4_Mp4vSampleEntry() : AP4_Mp4vSampleEntry
  • AP4_Mpeg2TsWriter() : AP4_Mpeg2TsWriter
  • AP4_MpegAudioSampleDescription() : AP4_MpegAudioSampleDescription
  • AP4_MpegAudioSampleEntry() : AP4_MpegAudioSampleEntry
  • AP4_MpegSampleDescription() : AP4_MpegSampleDescription
  • AP4_MpegSystemSampleDescription() : AP4_MpegSystemSampleDescription
  • AP4_MpegSystemSampleEntry() : AP4_MpegSystemSampleEntry
  • AP4_MpegVideoSampleDescription() : AP4_MpegVideoSampleDescription
  • AP4_MpegVideoSampleEntry() : AP4_MpegVideoSampleEntry
  • AP4_MvhdAtom() : AP4_MvhdAtom
  • AP4_NmhdAtom() : AP4_NmhdAtom
  • AP4_NoopRtpConstructor() : AP4_NoopRtpConstructor
  • AP4_NullTerminatedStringAtom() : AP4_NullTerminatedStringAtom
  • AP4_ObjectDescriptor() : AP4_ObjectDescriptor
  • AP4_OdafAtom() : AP4_OdafAtom
  • AP4_OddaAtom() : AP4_OddaAtom
  • AP4_OdheAtom() : AP4_OdheAtom
  • AP4_OhdrAtom() : AP4_OhdrAtom
  • AP4_OmaDcfCbcSampleDecrypter() : AP4_OmaDcfCbcSampleDecrypter
  • AP4_OmaDcfCbcSampleEncrypter() : AP4_OmaDcfCbcSampleEncrypter
  • AP4_OmaDcfCtrSampleDecrypter() : AP4_OmaDcfCtrSampleDecrypter
  • AP4_OmaDcfCtrSampleEncrypter() : AP4_OmaDcfCtrSampleEncrypter
  • AP4_OmaDcfDecryptingProcessor() : AP4_OmaDcfDecryptingProcessor
  • AP4_OmaDcfEncryptingProcessor() : AP4_OmaDcfEncryptingProcessor
  • AP4_OmaDcfSampleDecrypter() : AP4_OmaDcfSampleDecrypter
  • AP4_OmaDcfSampleEncrypter() : AP4_OmaDcfSampleEncrypter
  • AP4_PiffAvcCbcSampleDecrypter() : AP4_PiffAvcCbcSampleDecrypter
  • AP4_PiffAvcCbcSampleEncrypter() : AP4_PiffAvcCbcSampleEncrypter
  • AP4_PiffAvcCtrSampleDecrypter() : AP4_PiffAvcCtrSampleDecrypter
  • AP4_PiffAvcCtrSampleEncrypter() : AP4_PiffAvcCtrSampleEncrypter
  • AP4_PiffCbcSampleDecrypter() : AP4_PiffCbcSampleDecrypter
  • AP4_PiffCbcSampleEncrypter() : AP4_PiffCbcSampleEncrypter
  • AP4_PiffCtrSampleDecrypter() : AP4_PiffCtrSampleDecrypter
  • AP4_PiffCtrSampleEncrypter() : AP4_PiffCtrSampleEncrypter
  • AP4_PiffEncryptingProcessor() : AP4_PiffEncryptingProcessor
  • AP4_PiffNullSampleDecrypter() : AP4_PiffNullSampleDecrypter
  • AP4_PiffSampleDecrypter() : AP4_PiffSampleDecrypter
  • AP4_PiffSampleEncrypter() : AP4_PiffSampleEncrypter
  • AP4_PiffSampleEncryptionAtom() : AP4_PiffSampleEncryptionAtom
  • AP4_PiffTrackEncryptionAtom() : AP4_PiffTrackEncryptionAtom
  • AP4_PrintInspector() : AP4_PrintInspector
  • AP4_ProtectedSampleDescription() : AP4_ProtectedSampleDescription
  • AP4_ProtectionKeyMap() : AP4_ProtectionKeyMap
  • AP4_ProtectionSchemeInfo() : AP4_ProtectionSchemeInfo
  • AP4_RtpConstructor() : AP4_RtpConstructor
  • AP4_RtpHintSampleEntry() : AP4_RtpHintSampleEntry
  • AP4_RtpPacket() : AP4_RtpPacket
  • AP4_RtpSampleData() : AP4_RtpSampleData
  • AP4_Sample() : AP4_Sample
  • AP4_SampleDescription() : AP4_SampleDescription
  • AP4_SampleDescRtpConstructor() : AP4_SampleDescRtpConstructor
  • AP4_SampleEntry() : AP4_SampleEntry
  • AP4_SampleRtpConstructor() : AP4_SampleRtpConstructor
  • AP4_SchmAtom() : AP4_SchmAtom
  • AP4_SdpAtom() : AP4_SdpAtom
  • AP4_SLConfigDescriptor() : AP4_SLConfigDescriptor
  • AP4_SmhdAtom() : AP4_SmhdAtom
  • AP4_StandardDecryptingProcessor() : AP4_StandardDecryptingProcessor
  • AP4_StcoAtom() : AP4_StcoAtom
  • AP4_String() : AP4_String
  • AP4_StringMetaDataValue() : AP4_StringMetaDataValue
  • AP4_StscAtom() : AP4_StscAtom
  • AP4_StscTableEntry() : AP4_StscTableEntry
  • AP4_StsdAtom() : AP4_StsdAtom
  • AP4_StssAtom() : AP4_StssAtom
  • AP4_StszAtom() : AP4_StszAtom
  • AP4_SttsAtom() : AP4_SttsAtom
  • AP4_SttsTableEntry() : AP4_SttsTableEntry
  • AP4_SubStream() : AP4_SubStream
  • AP4_SyntheticSampleTable() : AP4_SyntheticSampleTable
  • AP4_TfhdAtom() : AP4_TfhdAtom
  • AP4_TfraAtom() : AP4_TfraAtom
  • AP4_TimsAtom() : AP4_TimsAtom
  • AP4_TkhdAtom() : AP4_TkhdAtom
  • AP4_Track() : AP4_Track
  • AP4_TrackSampleSource() : AP4_TrackSampleSource
  • AP4_TrakAtom() : AP4_TrakAtom
  • AP4_TrefTypeAtom() : AP4_TrefTypeAtom
  • AP4_TrexAtom() : AP4_TrexAtom
  • AP4_TrunAtom() : AP4_TrunAtom
  • AP4_UnknownAtom() : AP4_UnknownAtom
  • AP4_UnknownCommand() : AP4_UnknownCommand
  • AP4_UnknownDescriptor() : AP4_UnknownDescriptor
  • AP4_UnknownExpandable() : AP4_UnknownExpandable
  • AP4_UnknownSampleDescription() : AP4_UnknownSampleDescription
  • AP4_UnknownSampleEntry() : AP4_UnknownSampleEntry
  • AP4_UnknownUuidAtom() : AP4_UnknownUuidAtom
  • AP4_UrlAtom() : AP4_UrlAtom
  • AP4_UuidAtom() : AP4_UuidAtom
  • AP4_VideoSampleDescription() : AP4_VideoSampleDescription
  • AP4_VisualSampleEntry() : AP4_VisualSampleEntry
  • AP4_VmhdAtom() : AP4_VmhdAtom
  • Append() : AP4_Array< T >
  • Apply() : AP4_List< T >
  • ApplyUntilFailure() : AP4_List< T >
  • ApplyUntilSuccess() : AP4_List< T >
  • Assign() : AP4_String
  • Attach() : AP4_Track
Generated on Thu May 13 16:36:41 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all class members with links to the classes they belong to:

- c -

  • CIPHER_MODE_CBC : AP4_DecryptingStream , AP4_EncryptingStream
  • CIPHER_MODE_CTR : AP4_EncryptingStream , AP4_DecryptingStream
  • CipherDirection : AP4_BlockCipher , AP4_StreamCipher
  • CipherMode : AP4_EncryptingStream , AP4_DecryptingStream
  • CipherType : AP4_BlockCipher
  • CLASS_ID_SIZE_08 : AP4_Expandable
  • ClassIdSize : AP4_Expandable
  • Clear() : AP4_Array< T > , AP4_List< T >
  • Clone() : AP4_ContainerAtom , AP4_GrpiAtom , AP4_IkmsAtom , AP4_IsfmAtom , AP4_OhdrAtom , AP4_SampleDescription , AP4_UnknownSampleDescription , AP4_Track , AP4_Atom , AP4_UnknownAtom
  • ComputeOptionalFieldsCount() : AP4_TrunAtom
  • ComputeRecordFieldsCount() : AP4_TrunAtom
  • ComputeSize() : AP4_TfhdAtom
  • CopyTo() : AP4_ByteStream
  • Create() : AP4_DcfStringAtom , AP4_3GppLocalizedStringAtom , AP4_Hmac , AP4_CttsAtom , AP4_UrlAtom , AP4_TrunAtom , AP4_PiffSampleDecrypter , AP4_PiffTrackEncryptionAtom , AP4_TrakAtom , AP4_TkhdAtom , AP4_TimsAtom , AP4_DrefAtom , AP4_TfhdAtom , AP4_SttsAtom , AP4_PiffSampleEncryptionAtom , AP4_BlockCipherFactory , AP4_StsdAtom , AP4_StscAtom , AP4_StcoAtom , AP4_ElstAtom , AP4_SdpAtom , AP4_SchmAtom , AP4_DefaultBlockCipherFactory , AP4_SampleDecrypter , AP4_EsdsAtom , AP4_SampleDecrypter , AP4_DecryptingStream , AP4_FileByteStream , AP4_EncryptingStream , AP4_RtpAtom , AP4_FrmaAtom , AP4_FtypAtom , AP4_OmaDcfTrackDecrypter , AP4_OmaDcfSampleDecrypter , AP4_OhdrAtom , AP4_SmhdAtom , AP4_OddaAtom , AP4_OdafAtom , AP4_GrpiAtom , AP4_HdlrAtom , AP4_MoovAtom , AP4_StssAtom , AP4_StszAtom , AP4_HintTrackReader , AP4_MdhdAtom , AP4_HmhdAtom , AP4_TfraAtom , AP4_IkmsAtom , AP4_IsltAtom , AP4_VmhdAtom , AP4_IodsAtom , AP4_TrefTypeAtom , AP4_TrexAtom , AP4_IproAtom , AP4_IsfmAtom , AP4_IsmaTrackDecrypter , AP4_DcfdAtom , AP4_MarlinIpmpTrackDecrypter , AP4_MarlinIpmpTrackEncrypter , AP4_MehdAtom , AP4_MfhdAtom , AP4_MfroAtom , AP4_8bdlAtom , AP4_MvhdAtom , AP4_ContainerAtom , AP4_OdheAtom , AP4_NmhdAtom , AP4_AvccAtom , AP4_Co64Atom
  • CreateAtom() : AP4_MetaDataAtomTypeHandler , AP4_AtomFactory::TypeHandler
  • CreateAtomFromStream() : AP4_AtomFactory
  • CreateAtomsFromStream() : AP4_AtomFactory
  • CreateCommandFromStream() : AP4_CommandFactory
  • CreateConstructorFromStream() : AP4_RtpConstructorFactory
  • CreateDecryptingStream() : AP4_OmaDcfAtomDecrypter
  • CreateDescriptorFromStream() : AP4_DescriptorFactory
  • CreateEsDescriptor() : AP4_MpegSampleDescription
  • CreateFragmentHandler() : AP4_Processor , AP4_PiffEncryptingProcessor
  • CreateSampleDecrypter() : AP4_IsmaCipher
  • CreateSampleTable() : AP4_MovieFragment
  • CreateTrackHandler() : AP4_StandardDecryptingProcessor , AP4_MarlinIpmpEncryptingProcessor , AP4_OmaDcfEncryptingProcessor , AP4_IsmaEncryptingProcessor , AP4_Processor , AP4_MarlinIpmpDecryptingProcessor , AP4_PiffEncryptingProcessor
Generated on Thu May 13 16:36:41 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all class members with links to the classes they belong to:

- d -

  • DATA_TYPE_BINARY : AP4_DataAtom
  • DATA_TYPE_FLOAT_32_BE : AP4_DataAtom
  • DATA_TYPE_FLOAT_64_BE : AP4_DataAtom
  • DATA_TYPE_GIF : AP4_DataAtom
  • DATA_TYPE_JPEG : AP4_DataAtom
  • DATA_TYPE_SIGNED_INT_BE : AP4_DataAtom
  • DATA_TYPE_STRING_PASCAL : AP4_DataAtom
  • DATA_TYPE_STRING_UTF_16 : AP4_DataAtom
  • DATA_TYPE_STRING_UTF_8 : AP4_DataAtom
  • DataLang : AP4_DataAtom
  • DataType : AP4_DataAtom
  • DcfStringTypeList : AP4_MetaDataAtomTypeHandler
  • DcfStringTypes : AP4_MetaDataAtomTypeHandler
  • DECRYPT : AP4_BlockCipher , AP4_StreamCipher
  • DecryptAtoms() : AP4_OmaDcfAtomDecrypter
  • DecryptSampleData() : AP4_IsmaCipher , AP4_OmaDcfCtrSampleDecrypter , AP4_OmaDcfCbcSampleDecrypter , AP4_PiffNullSampleDecrypter , AP4_PiffCtrSampleDecrypter , AP4_PiffAvcCtrSampleDecrypter , AP4_SampleDecrypter , AP4_PiffAvcCbcSampleDecrypter , AP4_PiffCbcSampleDecrypter
  • DeleteChild() : AP4_AtomParent
  • DeleteReferences() : AP4_List< T >
  • description : AP4_MetaData::KeyInfo
  • Detach() : AP4_Atom
  • DoWrite() : AP4_RtpConstructor , AP4_NoopRtpConstructor , AP4_ImmediateRtpConstructor , AP4_SampleDescRtpConstructor , AP4_SampleRtpConstructor
  • dts : AP4_SttsAtom
Generated on Thu May 13 16:36:42 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all class members with links to the classes they belong to:

- e -

  • EnableTrack() : AP4_LinearReader
  • ENCRYPT : AP4_BlockCipher , AP4_StreamCipher
  • Encrypter() : AP4_PiffEncryptingProcessor::Encrypter
  • EncryptSampleData() : AP4_OmaDcfCtrSampleEncrypter , AP4_OmaDcfCbcSampleEncrypter , AP4_PiffSampleEncrypter , AP4_PiffCtrSampleEncrypter , AP4_IsmaCipher , AP4_PiffAvcCbcSampleEncrypter , AP4_PiffAvcCtrSampleEncrypter , AP4_PiffCbcSampleEncrypter , AP4_OmaDcfSampleEncrypter
  • EndElement() : AP4_PrintInspector , AP4_AtomInspector
  • EnsureCapacity() : AP4_Array< T >
  • Entry()
: AP4_MetaData::Entry
, AP4_TrunAtom::Entry
, AP4_TfraAtom::Entry
  • entry_index : AP4_CttsAtom , AP4_SttsAtom
  • ExternalTrackData() : AP4_Processor::ExternalTrackData
Generated on Thu May 13 16:36:42 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all class members with links to the classes they belong to:

- f -

  • Final() : AP4_Hmac
  • Finalize() : AP4_Processor
  • Find() : AP4_String , AP4_List< T >
  • FindChild() : AP4_AtomParent
  • FindInIlst() : AP4_MetaData::Entry
  • FindSubDescriptor() : AP4_ObjectDescriptor
  • FinishFragment() : AP4_Processor::FragmentHandler
  • FirstItem() : AP4_List< T >
  • Flush() : AP4_ByteStream , AP4_FileByteStream
  • FormatHint : AP4_AtomInspector
  • four_cc : AP4_MetaData::KeyInfo
Generated on Thu May 13 16:36:42 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all class members with links to the classes they belong to:

- g -

  • GenerateStblAtom() : AP4_SampleTable
  • Get() : AP4_List< T >
  • GetAlgorithmId() : AP4_PiffSampleEncryptionAtom
  • GetAtom() : AP4_UnknownSampleDescription
  • GetAudioProfileLevelIndication() : AP4_InitialObjectDescriptor
  • GetAvgBitrate() : AP4_DecoderConfigDescriptor , AP4_MpegSampleDescription
  • GetBaseDataOffset() : AP4_TfhdAtom
  • GetBFrameFlag() : AP4_RtpPacket
  • GetBitCount() : AP4_BitWriter
  • GetBufferFullness() : AP4_LinearReader
  • GetBufferSize() : AP4_DataBuffer , AP4_DecoderConfigDescriptor , AP4_MpegSampleDescription
  • GetBundleData() : AP4_8bdlAtom
  • GetChannelCount() : AP4_AudioSampleDescription , AP4_AudioSampleEntry
  • GetChars() : AP4_String
  • GetChild() : AP4_AtomParent
  • GetChildren() : AP4_AtomParent , AP4_ContainerAtom
  • GetChunkCount() : AP4_Co64Atom , AP4_StcoAtom
  • GetChunkForSample() : AP4_AtomSampleTable , AP4_StscAtom
  • GetChunkOffset() : AP4_AtomSampleTable , AP4_Co64Atom , AP4_StcoAtom
  • GetChunkOffsets() : AP4_TrakAtom , AP4_Co64Atom , AP4_StcoAtom
  • GetCipher() : AP4_IsmaCipher
  • GetClassId() : AP4_Expandable
  • GetCompatibleBrands() : AP4_FtypAtom
  • GetCompressorName() : AP4_VideoSampleDescription , AP4_VisualSampleEntry
  • GetConfigurationVersion() : AP4_AvccAtom , AP4_AvcSampleDescription
  • GetConstructedDataSize() : AP4_RtpPacket , AP4_RtpConstructor , AP4_NoopRtpConstructor , AP4_ImmediateRtpConstructor , AP4_SampleRtpConstructor , AP4_SampleDescRtpConstructor
  • GetConstructors() : AP4_RtpPacket
  • GetContentId() : AP4_OhdrAtom , AP4_OmaDrmInfo
  • GetContentType() : AP4_OdheAtom
  • GetContext() : AP4_AtomFactory
  • GetControlPointCode() : AP4_IpmpDescriptor
  • GetCts() : AP4_Sample
  • GetCtsDelta() : AP4_Sample
  • GetCtsOffset() : AP4_CttsAtom
  • GetCurrentTimeStampMs() : AP4_HintTrackReader
  • GetData() : AP4_MemoryByteStream , AP4_DataBuffer , AP4_IpmpDescriptor , AP4_List< T >::Item , AP4_ImmediateRtpConstructor , AP4_BitWriter
  • GetDataLang() : AP4_DataAtom
  • GetDataOffset() : AP4_TrunAtom
  • GetDataReferenceIndex() : AP4_SampleEntry
  • GetDataSize() : AP4_MemoryByteStream , AP4_DataBuffer
  • GetDataStream() : AP4_Sample
  • GetDataType() : AP4_DataAtom
  • GetDecoderConfigDescriptor() : AP4_EsDescriptor
  • GetDecoderInfo() : AP4_MpegSampleDescription
  • GetDecoderSpecificInfo() : AP4_DecoderSpecificInfoDescriptor
  • GetDecoderSpecificInfoDescriptor() : AP4_DecoderConfigDescriptor
  • GetDecryptedSampleSize() : AP4_IsmaCipher , AP4_OmaDcfCtrSampleDecrypter , AP4_OmaDcfCbcSampleDecrypter , AP4_SampleDecrypter
  • GetDefaultAlgorithmId() : AP4_PiffTrackEncryptionAtom
  • GetDefaultIvSize() : AP4_PiffTrackEncryptionAtom
  • GetDefaultKid() : AP4_PiffTrackEncryptionAtom
  • GetDefaultSampleDescriptionIndex() : AP4_TrexAtom
  • GetDefaultSampleDuration() : AP4_TfhdAtom , AP4_TrexAtom
  • GetDefaultSampleFlags() : AP4_TfhdAtom , AP4_TrexAtom
  • GetDefaultSampleSize() : AP4_TfhdAtom , AP4_TrexAtom
  • GetDepth() : AP4_VideoSampleDescription , AP4_VisualSampleEntry
  • GetDescriptionIndex() : AP4_Sample
  • GetDescriptorId() : AP4_IpmpDescriptorPointer , AP4_IpmpDescriptor
  • GetDescriptorIdEx() : AP4_IpmpDescriptorPointer , AP4_IpmpDescriptor
  • GetDescriptors() : AP4_DescriptorUpdateCommand
  • GetDetails() : AP4_SampleDescription
  • GetDts() : AP4_Sample , AP4_SttsAtom
  • GetDuration() : AP4_FragmentSampleTable , AP4_MdhdAtom , AP4_MehdAtom , AP4_Movie , AP4_MvhdAtom , AP4_Sample , AP4_TkhdAtom , AP4_Track , AP4_TrakAtom , AP4_DcfdAtom
  • GetDurationMs() : AP4_MdhdAtom , AP4_Movie , AP4_MvhdAtom , AP4_SampleSource , AP4_TrackSampleSource , AP4_Track
  • GetEncoding() : AP4_8bdlAtom
  • GetEncodingVersion() : AP4_8bdlAtom
  • GetEncryptedDataLength() : AP4_OddaAtom
  • GetEncryptedPayload() : AP4_OddaAtom
  • GetEncryptedSampleSize() : AP4_OmaDcfSampleEncrypter , AP4_OmaDcfCtrSampleEncrypter , AP4_OmaDcfCbcSampleEncrypter
  • GetEncryptionMethod() : AP4_OhdrAtom
  • GetEntries() : AP4_StssAtom , AP4_TfraAtom , AP4_TrunAtom , AP4_MetaData
  • GetEsDescriptor() : AP4_EsdsAtom
  • GetEsId() : AP4_IpmpDescriptorPointer
  • GetExtraData() : AP4_RtpSampleData
  • GetFieldsSize() : AP4_SampleEntry , AP4_UnknownSampleEntry , AP4_AudioSampleEntry , AP4_VisualSampleEntry , AP4_RtpHintSampleEntry
  • GetFileType() : AP4_File
  • GetFirstSampleFlags() : AP4_TrunAtom
  • GetFlags() : AP4_Atom , AP4_Track
  • GetFormat() : AP4_SampleDescription
  • GetGraphicsProfileLevelIndication() : AP4_InitialObjectDescriptor
  • GetGroupId() : AP4_GrpiAtom
  • GetGroupKey() : AP4_GrpiAtom
  • GetHandlerName() : AP4_HdlrAtom
  • GetHandlerType() : AP4_HdlrAtom , AP4_Track
  • GetHeaderSize() : AP4_Atom , AP4_Expandable , AP4_UuidAtom
  • GetHeight() : AP4_VideoSampleDescription , AP4_VisualSampleEntry , AP4_TkhdAtom , AP4_Track , AP4_TrakAtom
  • GetHorizResolution() : AP4_VisualSampleEntry
  • GetId() : AP4_Track , AP4_TrakAtom
  • GetIncludeProfileLevelFlag() : AP4_InitialObjectDescriptor
  • GetIpmpsType() : AP4_IpmpDescriptor
  • GetIV() : AP4_StreamCipher , AP4_CtrStreamCipher , AP4_CbcStreamCipher
  • GetIv() : AP4_PiffSampleEncrypter , AP4_PiffSampleEncryptionAtom
  • GetIvCount() : AP4_PiffSampleEncryptionAtom
  • GetIvLength() : AP4_IsfmAtom , AP4_IsmaCipher , AP4_OdafAtom
  • GetIvSize() : AP4_PiffSampleEncryptionAtom
  • GetKey() : AP4_ProtectionKeyMap
  • GetKeyAndIv() : AP4_ProtectionKeyMap
  • GetKeyEncryptionMethod() : AP4_GrpiAtom
  • GetKeyIndicatorLength() : AP4_IsfmAtom , AP4_IsmaCipher , AP4_OdafAtom
  • GetKeyMap() : AP4_IsmaEncryptingProcessor , AP4_MarlinIpmpDecryptingProcessor , AP4_MarlinIpmpEncryptingProcessor , AP4_OmaDcfDecryptingProcessor , AP4_OmaDcfEncryptingProcessor , AP4_PiffEncryptingProcessor , AP4_StandardDecryptingProcessor
  • GetKid() : AP4_PiffSampleEncryptionAtom
  • GetKmsId() : AP4_IkmsAtom
  • GetKmsUri() : AP4_IkmsAtom
  • GetKmsVersion() : AP4_IkmsAtom
  • GetLanguage() : AP4_MdhdAtom , AP4_MetaData::Value , AP4_3GppLocalizedStringAtom
  • GetLength() : AP4_SampleRtpConstructor , AP4_SampleDescRtpConstructor , AP4_String
  • GetLevel() : AP4_AvccAtom , AP4_AvcSampleDescription
  • GetMajorBrand() : AP4_FtypAtom
  • GetMaxBitrate() : AP4_DecoderConfigDescriptor , AP4_MpegSampleDescription
  • GetMBit() : AP4_RtpPacket
  • GetMeaning() : AP4_MetaData::Value
  • GetMediaDuration() : AP4_Track , AP4_TrakAtom
  • GetMediaTimeScale() : AP4_Track , AP4_TrakAtom
  • GetMediaTrack() : AP4_HintTrackReader
  • GetMetaData() : AP4_File
  • GetMfhdAtom() : AP4_MovieFragment
  • GetMfraSize() : AP4_MfroAtom
  • GetMinorVersion() : AP4_FtypAtom
  • GetMoofAtom() : AP4_MovieFragment
  • GetMoovAtom() : AP4_Movie
  • GetMovie() : AP4_File
  • GetMovieTimeScale() : AP4_Track
  • GetMpeg4AudioObjectType() : AP4_MpegAudioSampleDescription
  • GetMpeg4AudioObjectTypeString() : AP4_MpegAudioSampleDescription
  • GetMvhdAtom() : AP4_Movie
  • GetNaluLengthSize() : AP4_AvcSampleDescription , AP4_AvccAtom
  • GetName() : AP4_MetaData::Key
  • GetNamespace() : AP4_MetaData::Key
  • GetNearestSyncSampleIndex() : AP4_FragmentSampleTable , AP4_SyntheticSampleTable , AP4_AtomSampleTable , AP4_SampleSource , AP4_TrackSampleSource , AP4_SampleTable , AP4_Track
  • GetNext() : AP4_List< T >::Item
  • GetNextPacket() : AP4_HintTrackReader
  • GetObjectDescriptor() : AP4_IodsAtom
  • GetObjectDescriptorId() : AP4_ObjectDescriptor
  • GetObjectTypeId() : AP4_MpegSampleDescription
  • GetObjectTypeIndication() : AP4_DecoderConfigDescriptor
  • GetObjectTypeString() : AP4_MpegSampleDescription
  • GetOdProfileLevelIndication() : AP4_InitialObjectDescriptor
  • GetOffset() : AP4_Sample
  • GetOriginalFormat() : AP4_ProtectedSampleDescription , AP4_FrmaAtom
  • GetOriginalSampleDescription() : AP4_ProtectedSampleDescription
  • GetPackets() : AP4_RtpSampleData
  • GetPaddingScheme() : AP4_OhdrAtom
  • GetParent() : AP4_Atom
  • GetPAT() : AP4_Mpeg2TsWriter
  • GetPayload() : AP4_UnknownSampleEntry
  • GetPayloadType() : AP4_RtpPacket
  • GetPBit() : AP4_RtpPacket
  • GetPictureParameters() : AP4_AvccAtom , AP4_AvcSampleDescription
  • GetPID() : AP4_Mpeg2TsWriter::Stream
  • GetPlaintextLength() : AP4_OhdrAtom
  • GetPMT() : AP4_Mpeg2TsWriter
  • GetPrev() : AP4_List< T >::Item
  • GetProcessedSampleSize() : AP4_MarlinIpmpTrackDecrypter , AP4_Processor::FragmentHandler , AP4_IsmaTrackDecrypter , AP4_MarlinIpmpTrackEncrypter , AP4_OmaDcfTrackDecrypter , AP4_Processor::TrackHandler
  • GetProfile() : AP4_AvccAtom , AP4_AvcSampleDescription
  • GetProfileCompatibility() : AP4_AvccAtom , AP4_AvcSampleDescription
  • GetProfileName() : AP4_AvccAtom , AP4_AvcSampleDescription
  • GetProperty() : AP4_TrackPropertyMap
  • GetPropertyMap() : AP4_OmaDcfEncryptingProcessor , AP4_PiffEncryptingProcessor , AP4_MarlinIpmpEncryptingProcessor
  • GetRawBytes() : AP4_AvccAtom , AP4_AvcSampleDescription
  • GetRefIndex() : AP4_EsIdRefDescriptor
  • GetRelativeTime() : AP4_RtpPacket
  • GetRepeatFlag() : AP4_RtpPacket
  • GetRightsIssuerUrl() : AP4_OmaDrmInfo , AP4_OhdrAtom
  • GetSalt() : AP4_IsltAtom
  • GetSample() : AP4_AtomSampleTable , AP4_FragmentSampleTable , AP4_SampleTable , AP4_SyntheticSampleTable , AP4_Track
  • GetSampleChunkPosition() : AP4_FragmentSampleTable , AP4_SampleTable , AP4_SyntheticSampleTable , AP4_AtomSampleTable
  • GetSampleCount() : AP4_SyntheticSampleTable , AP4_SampleTable , AP4_FragmentSampleTable , AP4_StszAtom , AP4_Track , AP4_AtomSampleTable
  • GetSampleDescIndex() : AP4_SampleDescRtpConstructor
  • GetSampleDescOffset() : AP4_SampleDescRtpConstructor
  • GetSampleDescription() : AP4_AtomSampleTable , AP4_SampleTable , AP4_Track , AP4_TrackSampleSource , AP4_FragmentSampleTable , AP4_StsdAtom , AP4_SampleSource , AP4_SyntheticSampleTable
  • GetSampleDescriptionCount() : AP4_FragmentSampleTable , AP4_SampleTable , AP4_StsdAtom , AP4_SyntheticSampleTable , AP4_AtomSampleTable
  • GetSampleDescriptionIndex() : AP4_TfhdAtom
  • GetSampleEntry() : AP4_StsdAtom
  • GetSampleIndexForTimeStamp() : AP4_AtomSampleTable , AP4_SampleTable , AP4_SyntheticSampleTable , AP4_SttsAtom , AP4_FragmentSampleTable
  • GetSampleIndexForTimeStampMs() : AP4_TrackSampleSource , AP4_Track , AP4_SampleSource
  • GetSampleNum() : AP4_SampleRtpConstructor
  • GetSampleOffset() : AP4_SampleRtpConstructor
  • GetSampleRate() : AP4_AudioSampleDescription , AP4_AudioSampleEntry
  • GetSampleSize() : AP4_StszAtom , AP4_AudioSampleEntry , AP4_AudioSampleDescription
  • GetSampleTable() : AP4_Track
  • GetSceneProfileLevelIndication() : AP4_InitialObjectDescriptor
  • GetSchemeInfo() : AP4_ProtectedSampleDescription
  • GetSchemeType() : AP4_SchmAtom , AP4_ProtectedSampleDescription
  • GetSchemeUri() : AP4_ProtectedSampleDescription , AP4_SchmAtom
  • GetSchemeVersion() : AP4_ProtectedSampleDescription , AP4_SchmAtom
  • GetSchiAtom() : AP4_ProtectionSchemeInfo
  • GetSdpText() : AP4_RtpAtom , AP4_HintTrackReader , AP4_SdpAtom
  • GetSelectiveEncryption() : AP4_OdafAtom , AP4_IsmaCipher , AP4_IsfmAtom
  • GetSequenceCode() : AP4_IpmpDescriptor
  • GetSequenceNumber() : AP4_MfhdAtom , AP4_MovieFragment
  • GetSequenceParameters() : AP4_AvccAtom , AP4_AvcSampleDescription
  • GetSequenceSeed() : AP4_RtpPacket
  • GetSize() : AP4_SubStream , AP4_EncryptingStream , AP4_MemoryByteStream , AP4_RtpPacket , AP4_ByteStream , AP4_RtpSampleData , AP4_Sample , AP4_BufferedInputStream , AP4_DecryptingStream , AP4_FileByteStream , AP4_Expandable , AP4_Atom
  • GetSize32() : AP4_Atom
  • GetSize64() : AP4_Atom
  • GetStreamOffset() : AP4_CbcStreamCipher , AP4_StreamCipher , AP4_CtrStreamCipher
  • GetStreamType() : AP4_DecoderConfigDescriptor , AP4_MpegSampleDescription
  • GetStreamTypeString() : AP4_MpegSampleDescription
  • GetTag() : AP4_Descriptor , AP4_Command
  • GetTextualHeaders() : AP4_OmaDrmInfo , AP4_OhdrAtom , AP4_TrackPropertyMap
  • GetTimeScale() : AP4_MvhdAtom , AP4_TimsAtom , AP4_Movie , AP4_TrackSampleSource , AP4_MoovAtom , AP4_SampleSource , AP4_MdhdAtom
  • GetTimeStampOffset() : AP4_RtpPacket
  • GetTkhdAtom() : AP4_TrakAtom
  • GetToolId() : AP4_IpmpDescriptor
  • GetTopLevelAtoms() : AP4_File
  • GetTrack() : AP4_Movie
  • GetTrackId() : AP4_TrexAtom , AP4_TkhdAtom , AP4_EsIdIncDescriptor , AP4_TfhdAtom , AP4_SampleSource , AP4_TrackSampleSource
  • GetTrackIds() : AP4_MovieFragment , AP4_TrefTypeAtom
  • GetTrackLanguage() : AP4_Track
  • GetTrackName() : AP4_Track
  • GetTrackRefIndex() : AP4_SampleDescRtpConstructor , AP4_SampleRtpConstructor
  • GetTracks() : AP4_Movie
  • GetTrafAtom() : AP4_MovieFragment
  • GetTrakAtom() : AP4_Track
  • GetTrakAtoms() : AP4_MoovAtom
  • GetTranslation() : AP4_TkhdAtom
  • GetType() : AP4_SampleDescription , AP4_Track , AP4_RtpConstructor , AP4_MetaData::Value , AP4_Atom
  • GetTypeCategory() : AP4_MetaData::Value
  • GetUrl() : AP4_IpmpDescriptor , AP4_ObjectDescriptor
  • GetUrlFlag() : AP4_ObjectDescriptor
  • GetUuid() : AP4_UuidAtom
  • GetValue() : AP4_MetaDataStringAtom , AP4_NullTerminatedStringAtom , AP4_DcfStringAtom , AP4_3GppLocalizedStringAtom
  • GetValueType() : AP4_DataAtom
  • GetVerbosity() : AP4_AtomInspector
  • GetVertResolution() : AP4_VisualSampleEntry
  • GetVisualProfileLevelIndication() : AP4_InitialObjectDescriptor
  • GetWidth() : AP4_TkhdAtom , AP4_VideoSampleDescription , AP4_TrakAtom , AP4_VisualSampleEntry , AP4_Track
  • GetXBit() : AP4_RtpPacket
Generated on Thu May 13 16:36:42 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all class members with links to the classes they belong to:

- h -

  • HasCompatibleBrand() : AP4_FtypAtom
  • hi : AP4_UI64
  • HINT_BOOLEAN : AP4_AtomInspector
  • HINT_HEX : AP4_AtomInspector
  • HINT_NONE : AP4_AtomInspector
Generated on Thu May 13 16:36:42 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all class members with links to the classes they belong to:

- i -

  • IlstTypeList : AP4_MetaDataAtomTypeHandler
  • IlstTypes : AP4_MetaDataAtomTypeHandler
  • Initialize() : AP4_MarlinIpmpEncryptingProcessor , AP4_Processor , AP4_StandardDecryptingProcessor , AP4_OmaDcfDecryptingProcessor , AP4_MarlinIpmpDecryptingProcessor , AP4_OmaDcfEncryptingProcessor , AP4_PiffEncryptingProcessor
  • Insert() : AP4_List< T >
  • Inspect() : AP4_EsDescriptor , AP4_EsIdIncDescriptor , AP4_EsIdRefDescriptor , AP4_Expandable , AP4_File , AP4_IpmpDescriptorPointer , AP4_Atom , AP4_IpmpDescriptor , AP4_Movie , AP4_Command , AP4_ObjectDescriptor , AP4_InitialObjectDescriptor , AP4_DecoderConfigDescriptor , AP4_DescriptorUpdateCommand , AP4_SampleEntry , AP4_DecoderSpecificInfoDescriptor , AP4_MetaDataTag , AP4_Descriptor
  • InspectChildren() : AP4_ContainerAtom
  • InspectFields() : AP4_3GppLocalizedStringAtom , AP4_StssAtom , AP4_StsdAtom , AP4_StscAtom , AP4_NullTerminatedStringAtom , AP4_RtpHintSampleEntry , AP4_SchmAtom , AP4_AvccAtom , AP4_SdpAtom , AP4_VisualSampleEntry , AP4_AudioSampleEntry , AP4_SampleEntry , AP4_SmhdAtom , AP4_PiffSampleEncryptionAtom , AP4_PiffTrackEncryptionAtom , AP4_OhdrAtom , AP4_Co64Atom , AP4_OddaAtom , AP4_StcoAtom , AP4_MvhdAtom , AP4_ContainerAtom , AP4_MfhdAtom , AP4_CttsAtom , AP4_StszAtom , AP4_SttsAtom , AP4_IsfmAtom , AP4_IproAtom , AP4_IodsAtom , AP4_IkmsAtom , AP4_HmhdAtom , AP4_DcfStringAtom , AP4_GrpiAtom , AP4_ElstAtom , AP4_EsdsAtom , AP4_TimsAtom , AP4_FrmaAtom , AP4_FtypAtom , AP4_TrunAtom , AP4_UrlAtom , AP4_HdlrAtom , AP4_DcfdAtom , AP4_Atom , AP4_RtpAtom , AP4_TkhdAtom , AP4_OdheAtom , AP4_OdafAtom , AP4_MfroAtom , AP4_MehdAtom , AP4_MdhdAtom , AP4_DataAtom , AP4_MetaDataStringAtom , AP4_TrefTypeAtom , AP4_VmhdAtom , AP4_IsltAtom , AP4_TrexAtom , AP4_TfhdAtom , AP4_TfraAtom , AP4_8bdlAtom
  • InspectHeader() : AP4_UuidAtom , AP4_Atom
  • Instance : AP4_DefaultBlockCipherFactory , AP4_DefaultAtomFactory
  • Interleaving : AP4_FileWriter
  • INTERLEAVING_SEQUENTIAL : AP4_FileWriter
  • IsMoovBeforeMdat() : AP4_File
  • IsSampleSync() : AP4_StssAtom
  • IsSync() : AP4_Sample
  • IsTypeInList() : AP4_MetaDataAtomTypeHandler
  • Item() : AP4_List< T >::Item
  • ItemCount() : AP4_List< T > , AP4_Array< T >
Generated on Thu May 13 16:36:42 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all class members with links to the classes they belong to:

- p -

  • Parse() : AP4_MarlinIpmpParser
  • ParseMoov() : AP4_MetaData
  • ParseUdta() : AP4_MetaData
  • PopContext() : AP4_AtomFactory
  • PopHead() : AP4_List< T >
  • Process() : AP4_Processor
  • ProcessBlock() : AP4_AesBlockCipher , AP4_BlockCipher
  • ProcessBuffer() : AP4_StreamCipher , AP4_CtrStreamCipher , AP4_CbcStreamCipher
  • ProcessFragment() : AP4_Processor::FragmentHandler
  • ProcessFragments() : AP4_Processor
  • ProcessSample() : AP4_IsmaTrackDecrypter , AP4_MarlinIpmpTrackEncrypter , AP4_OmaDcfTrackDecrypter , AP4_Processor::TrackHandler , AP4_MarlinIpmpTrackDecrypter , AP4_Processor::FragmentHandler
  • ProcessTrack() : AP4_Processor::TrackHandler , AP4_OmaDcfTrackDecrypter , AP4_IsmaTrackDecrypter
  • PushContext() : AP4_AtomFactory
Generated on Thu May 13 16:36:42 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all class members with links to the classes they belong to:

- r -

  • Read() : AP4_ByteStream , AP4_SampleEntry
  • ReadChildren() : AP4_ContainerAtom
  • ReadData() : AP4_Sample
  • ReadDouble() : AP4_ByteStream
  • ReadFields() : AP4_UnknownSampleEntry , AP4_AudioSampleEntry , AP4_VisualSampleEntry , AP4_RtpHintSampleEntry , AP4_SampleEntry
  • ReadFullHeader() : AP4_Atom
  • ReadNextSample() : AP4_TrackSampleSource , AP4_LinearReader , AP4_SampleSource
  • ReadPartial() : AP4_ByteStream , AP4_SubStream , AP4_MemoryByteStream , AP4_BufferedInputStream , AP4_FileByteStream , AP4_DecryptingStream , AP4_EncryptingStream
  • ReadSample() : AP4_Track
  • ReadString() : AP4_ByteStream
  • ReadUI08() : AP4_ByteStream
  • ReadUI16() : AP4_ByteStream
  • ReadUI24() : AP4_ByteStream
  • ReadUI32() : AP4_ByteStream
  • ReadUI64() : AP4_ByteStream
  • ReallocateBuffer() : AP4_DataBuffer
  • Refill() : AP4_BufferedInputStream
  • Release() : AP4_SubStream , AP4_MemoryByteStream , AP4_EncryptingStream , AP4_FileByteStream , AP4_DecryptingStream , AP4_Referenceable , AP4_RtpPacket , AP4_BufferedInputStream , AP4_RtpConstructor
  • Remove() : AP4_List< T >
  • RemoveChild() : AP4_AtomParent
  • RemoveFromFile() : AP4_MetaData::Entry
  • RemoveFromFileDcf() : AP4_MetaData::Entry
  • RemoveFromFileIlst() : AP4_MetaData::Entry
  • RemoveLast() : AP4_Array< T >
  • RemoveTypeHandler() : AP4_AtomFactory
  • Reserve() : AP4_DataBuffer
  • Reset() : AP4_Sample
  • ResolveKeyName() : AP4_MetaData
  • ReverseApply() : AP4_List< T >
  • ReverseFind() : AP4_List< T >
  • Rewind() : AP4_HintTrackReader
Generated on Thu May 13 16:36:42 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all class members with links to the classes they belong to:

- s -

  • sample : AP4_CttsAtom , AP4_SttsAtom
  • sample_composition_time_offset : AP4_TrunAtom::Entry
  • sample_duration : AP4_TrunAtom::Entry
  • sample_flags : AP4_TrunAtom::Entry
  • sample_size : AP4_TrunAtom::Entry
  • SampleStream() : AP4_Mpeg2TsWriter::SampleStream
  • Seek() : AP4_ByteStream , AP4_SubStream , AP4_MemoryByteStream , AP4_BufferedInputStream , AP4_FileByteStream , AP4_DecryptingStream , AP4_EncryptingStream
  • SeekToTimeStampMs() : AP4_HintTrackReader
  • SetAudioStream() : AP4_Mpeg2TsWriter
  • SetBaseDataOffset() : AP4_TfhdAtom
  • SetBuffer() : AP4_DataBuffer
  • SetBufferSize() : AP4_DataBuffer
  • SetChunkOffset() : AP4_AtomSampleTable , AP4_Co64Atom , AP4_StcoAtom
  • SetChunkOffsets() : AP4_TrakAtom
  • SetCts() : AP4_Sample
  • SetCtsDelta() : AP4_Sample
  • SetData() : AP4_DataBuffer , AP4_IpmpDescriptor
  • SetDataSize() : AP4_DataBuffer
  • SetDataStream() : AP4_Sample
  • SetDefaultSampleDuration() : AP4_TfhdAtom
  • SetDefaultSampleFlags() : AP4_TfhdAtom
  • SetDefaultSampleSize() : AP4_TfhdAtom
  • SetDescriptionIndex() : AP4_Sample
  • SetDts() : AP4_Sample
  • SetDuration() : AP4_MdhdAtom , AP4_MehdAtom , AP4_MvhdAtom , AP4_Sample , AP4_TkhdAtom , AP4_TrakAtom
  • SetEncryptedPayload() : AP4_OddaAtom
  • SetEncryptionMethod() : AP4_OhdrAtom
  • SetFileType() : AP4_File
  • SetFlags() : AP4_Atom , AP4_Track
  • SetHeight() : AP4_TkhdAtom , AP4_TrakAtom
  • SetId() : AP4_Track , AP4_TrakAtom
  • SetItemCount() : AP4_Array< T >
  • SetIV() : AP4_CtrStreamCipher
  • SetIv() : AP4_PiffSampleEncrypter , AP4_PiffSampleEncryptionAtom
  • SetIV() : AP4_StreamCipher , AP4_CbcStreamCipher
  • SetIvSize() : AP4_PiffSampleEncryptionAtom
  • SetKey() : AP4_ProtectionKeyMap
  • SetKeyEncryptionMethod() : AP4_GrpiAtom
  • SetKeys() : AP4_ProtectionKeyMap
  • SetLanguage() : AP4_MetaData::Value
  • SetMediaDuration() : AP4_TrakAtom
  • SetMediaTimeScale() : AP4_TrakAtom
  • SetMovieTimeScale() : AP4_Track
  • SetOffset() : AP4_Sample
  • SetPaddingScheme() : AP4_OhdrAtom
  • SetParent() : AP4_Atom
  • SetProperties() : AP4_TrackPropertyMap
  • SetProperty() : AP4_TrackPropertyMap
  • SetSampleDescriptionIndex() : AP4_TfhdAtom
  • SetSampleIndex() : AP4_SampleDecrypter , AP4_PiffSampleDecrypter , AP4_SampleSource , AP4_LinearReader , AP4_TrackSampleSource
  • SetSampleSize() : AP4_AtomSampleTable , AP4_StszAtom
  • SetSequenceNumber() : AP4_MfhdAtom
  • SetSize() : AP4_Sample , AP4_Atom
  • SetSize32() : AP4_Atom
  • SetSize64() : AP4_Atom
  • SetStreamOffset() : AP4_StreamCipher , AP4_CtrStreamCipher , AP4_CbcStreamCipher
  • SetSync() : AP4_Sample
  • SetTimeScale() : AP4_MvhdAtom , AP4_MdhdAtom
  • SetTrackId() : AP4_TfhdAtom , AP4_TkhdAtom
  • SetType() : AP4_Atom
  • SetVerbosity() : AP4_AtomInspector
  • SetVideoStream() : AP4_Mpeg2TsWriter
  • SetWidth() : AP4_TrakAtom , AP4_TkhdAtom
  • SHA256 : AP4_Hmac
  • SinfEntry() : AP4_MarlinIpmpParser::SinfEntry
  • StartElement() : AP4_AtomInspector , AP4_PrintInspector
  • Stream() : AP4_Mpeg2TsWriter::Stream
  • STREAM_MODE_READ : AP4_FileByteStream
  • STREAM_MODE_READ_WRITE : AP4_FileByteStream
  • STREAM_MODE_WRITE : AP4_FileByteStream
  • StreamType : AP4_MpegSampleDescription
Generated on Thu May 13 16:36:42 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all class members with links to the classes they belong to:

- t -

  • Tell() : AP4_ByteStream , AP4_SubStream , AP4_BufferedInputStream , AP4_FileByteStream , AP4_MemoryByteStream , AP4_DecryptingStream , AP4_EncryptingStream
  • Test() : AP4_AtomFinder , AP4_DescriptorFinder , AP4_List< T >::Item::Finder
  • ToAtom() : AP4_MpegAudioSampleDescription , AP4_MpegVideoSampleDescription , AP4_MetaData::Entry , AP4_ProtectedSampleDescription , AP4_SampleDescription , AP4_UnknownSampleDescription , AP4_AvcSampleDescription , AP4_MpegSystemSampleDescription
  • ToBytes() : AP4_MetaData::Value , AP4_StringMetaDataValue , AP4_IntegerMetaDataValue , AP4_BinaryMetaDataValue , AP4_AtomMetaDataValue
  • ToByteStream() : AP4_RtpSampleData
  • ToInteger() : AP4_MetaData::Value , AP4_StringMetaDataValue , AP4_IntegerMetaDataValue , AP4_BinaryMetaDataValue , AP4_AtomMetaDataValue
  • ToSampleDescription() : AP4_SampleEntry , AP4_UnknownSampleEntry , AP4_AudioSampleEntry , AP4_VisualSampleEntry , AP4_MpegSystemSampleEntry , AP4_MpegAudioSampleEntry , AP4_MpegVideoSampleEntry , AP4_Mp4sSampleEntry , AP4_Avc1SampleEntry , AP4_EncaSampleEntry , AP4_EncvSampleEntry
  • ToString() : AP4_MetaData::Value , AP4_StringMetaDataValue , AP4_IntegerMetaDataValue , AP4_BinaryMetaDataValue , AP4_AtomMetaDataValue
  • ToTargetSampleDescription() : AP4_EncvSampleEntry , AP4_EncaSampleEntry
  • Type : AP4_Atom , AP4_SampleDescription , AP4_Track , AP4_MetaData::Value , AP4_RtpConstructor
  • TYPE_AUDIO : AP4_Track
  • TYPE_AVC : AP4_SampleDescription
  • TYPE_BINARY : AP4_MetaData::Value
  • TYPE_CATEGORY_BINARY : AP4_MetaData::Value
  • TYPE_CATEGORY_FLOAT : AP4_MetaData::Value
  • TYPE_CATEGORY_INTEGER : AP4_MetaData::Value
  • TYPE_CATEGORY_STRING : AP4_MetaData::Value
  • TYPE_FLOAT_32_BE : AP4_MetaData::Value
  • TYPE_FLOAT_64_BE : AP4_MetaData::Value
  • TYPE_GIF : AP4_MetaData::Value
  • TYPE_HINT : AP4_Track
  • TYPE_INT_08_BE : AP4_MetaData::Value
  • TYPE_INT_16_BE : AP4_MetaData::Value
  • TYPE_INT_32_BE : AP4_MetaData::Value
  • TYPE_JPEG : AP4_MetaData::Value , AP4_Track
  • TYPE_MPEG : AP4_SampleDescription
  • TYPE_PROTECTED : AP4_SampleDescription
  • TYPE_RTP : AP4_Track
  • TYPE_STRING_PASCAL : AP4_MetaData::Value
  • TYPE_STRING_UTF_16 : AP4_MetaData::Value
  • TYPE_STRING_UTF_8 : AP4_MetaData::Value
  • TYPE_SYSTEM : AP4_Track
  • TYPE_TEXT : AP4_Track
  • TYPE_UNKNOWN : AP4_Track , AP4_SampleDescription
  • TYPE_VIDEO : AP4_Track
  • TypeCategory : AP4_MetaData::Value
  • TypeFromString() : AP4_Atom
Generated on Thu May 13 16:36:42 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all class members with links to the classes they belong to:

- u -

  • Update() : AP4_Hmac
  • UseChars() : AP4_String
  • UseData() : AP4_MemoryByteStream , AP4_DataBuffer
Generated on Thu May 13 16:36:42 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all class members with links to the classes they belong to:

- v -

  • Value() : AP4_MetaData::Value
  • value_type : AP4_MetaData::KeyInfo
Generated on Thu May 13 16:36:42 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all class members with links to the classes they belong to:

- w -

  • Write() : AP4_Atom , AP4_ByteStream , AP4_FileCopier , AP4_SampleEntry , AP4_BitWriter , AP4_FileWriter , AP4_MetaDataTag , AP4_Expandable , AP4_RtpPacket , AP4_RtpConstructor
  • WriteDouble() : AP4_ByteStream
  • WriteFields() : AP4_AvccAtom , AP4_FrmaAtom , AP4_RtpHintSampleEntry , AP4_SchmAtom , AP4_FtypAtom , AP4_SdpAtom , AP4_SLConfigDescriptor , AP4_Co64Atom , AP4_GrpiAtom , AP4_SmhdAtom , AP4_DataAtom , AP4_StcoAtom , AP4_DcfdAtom , AP4_DcfStringAtom , AP4_3GppLocalizedStringAtom , AP4_VmhdAtom , AP4_UnknownUuidAtom , AP4_UrlAtom , AP4_HdlrAtom , AP4_StscAtom , AP4_TrefTypeAtom , AP4_TkhdAtom , AP4_TimsAtom , AP4_TfraAtom , AP4_TfhdAtom , AP4_SttsAtom , AP4_StsdAtom , AP4_UnknownCommand , AP4_HmhdAtom , AP4_StssAtom , AP4_StszAtom , AP4_IkmsAtom , AP4_ContainerAtom , AP4_IodsAtom , AP4_IpmpDescriptorPointer , AP4_CttsAtom , AP4_VisualSampleEntry , AP4_AudioSampleEntry , AP4_UnknownSampleEntry , AP4_SampleEntry , AP4_RtpAtom , AP4_PiffSampleEncryptionAtom , AP4_PiffTrackEncryptionAtom , AP4_IpmpDescriptor , AP4_OdheAtom , AP4_OddaAtom , AP4_OdafAtom , AP4_DescriptorUpdateCommand , AP4_InitialObjectDescriptor , AP4_ObjectDescriptor , AP4_TrexAtom , AP4_TrunAtom , AP4_MfroAtom , AP4_MfhdAtom , AP4_MehdAtom , AP4_MetaDataStringAtom , AP4_IproAtom , AP4_DecoderConfigDescriptor , AP4_IsfmAtom , AP4_IsltAtom , AP4_DecoderSpecificInfoDescriptor , AP4_MdhdAtom , AP4_UnknownDescriptor , AP4_8bdlAtom , AP4_DrefAtom , AP4_MvhdAtom , AP4_NmhdAtom , AP4_ElstAtom , AP4_UnknownExpandable , AP4_Expandable , AP4_EsdsAtom , AP4_OhdrAtom , AP4_Atom , AP4_EsDescriptor , AP4_EsIdIncDescriptor , AP4_UnknownAtom , AP4_EsIdRefDescriptor , AP4_NullTerminatedStringAtom
  • WriteHeader() : AP4_Atom , AP4_UuidAtom
  • WritePacketHeader() : AP4_Mpeg2TsWriter::Stream
  • WritePartial() : AP4_SubStream , AP4_FileByteStream , AP4_ByteStream , AP4_MemoryByteStream , AP4_DecryptingStream , AP4_BufferedInputStream , AP4_EncryptingStream
  • WritePAT() : AP4_Mpeg2TsWriter
  • WritePES() : AP4_Mpeg2TsWriter::SampleStream
  • WritePMT() : AP4_Mpeg2TsWriter
  • WriteSample() : AP4_Mpeg2TsWriter::SampleStream
  • WriteString() : AP4_ByteStream
  • WriteUI08() : AP4_ByteStream
  • WriteUI16() : AP4_ByteStream
  • WriteUI24() : AP4_ByteStream
  • WriteUI32() : AP4_ByteStream
  • WriteUI64() : AP4_ByteStream
Generated on Thu May 13 16:36:42 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Class Members - Enumerations

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • Algorithm : AP4_Hmac
  • CipherDirection : AP4_BlockCipher , AP4_StreamCipher
  • CipherMode : AP4_EncryptingStream , AP4_DecryptingStream
  • CipherType : AP4_BlockCipher
  • ClassIdSize : AP4_Expandable
  • DataLang : AP4_DataAtom
  • DataType : AP4_DataAtom
  • FormatHint : AP4_AtomInspector
  • Interleaving : AP4_FileWriter
  • Meaning : AP4_MetaData::Value
  • Mode : AP4_FileByteStream
  • Type : AP4_SampleDescription , AP4_Track , AP4_MetaData::Value
  • TypeCategory : AP4_MetaData::Value
Generated on Thu May 13 16:36:42 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Class Members - Enumerator

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • c
  • d
  • e
  • h
  • i
  • l
  • m
  • s
  • t

- a -

  • AES_128 : AP4_BlockCipher

- c -

  • CIPHER_MODE_CBC : AP4_DecryptingStream , AP4_EncryptingStream
  • CIPHER_MODE_CTR : AP4_EncryptingStream , AP4_DecryptingStream
  • CLASS_ID_SIZE_08 : AP4_Expandable

- d -

  • DATA_TYPE_BINARY : AP4_DataAtom
  • DATA_TYPE_FLOAT_32_BE : AP4_DataAtom
  • DATA_TYPE_FLOAT_64_BE : AP4_DataAtom
  • DATA_TYPE_GIF : AP4_DataAtom
  • DATA_TYPE_JPEG : AP4_DataAtom
  • DATA_TYPE_SIGNED_INT_BE : AP4_DataAtom
  • DATA_TYPE_STRING_PASCAL : AP4_DataAtom
  • DATA_TYPE_STRING_UTF_16 : AP4_DataAtom
  • DATA_TYPE_STRING_UTF_8 : AP4_DataAtom
  • DECRYPT : AP4_BlockCipher , AP4_StreamCipher

- e -

  • ENCRYPT : AP4_BlockCipher , AP4_StreamCipher

- h -

  • HINT_BOOLEAN : AP4_AtomInspector
  • HINT_HEX : AP4_AtomInspector
  • HINT_NONE : AP4_AtomInspector

- i -

  • INTERLEAVING_SEQUENTIAL : AP4_FileWriter

- l -

  • LANGUAGE_ENGLISH : AP4_DataAtom

- m -

  • MEANING_BINARY_ENCODED_CHARS : AP4_MetaData::Value
  • MEANING_BOOLEAN : AP4_MetaData::Value
  • MEANING_FILE_KIND : AP4_MetaData::Value
  • MEANING_ID3_GENRE : AP4_MetaData::Value
  • MEANING_UNKNOWN : AP4_MetaData::Value

- s -

  • SHA256 : AP4_Hmac
  • STREAM_MODE_READ : AP4_FileByteStream
  • STREAM_MODE_READ_WRITE : AP4_FileByteStream
  • STREAM_MODE_WRITE : AP4_FileByteStream

- t -

  • TYPE_AUDIO : AP4_Track
  • TYPE_AVC : AP4_SampleDescription
  • TYPE_BINARY : AP4_MetaData::Value
  • TYPE_CATEGORY_BINARY : AP4_MetaData::Value
  • TYPE_CATEGORY_FLOAT : AP4_MetaData::Value
  • TYPE_CATEGORY_INTEGER : AP4_MetaData::Value
  • TYPE_CATEGORY_STRING : AP4_MetaData::Value
  • TYPE_FLOAT_32_BE : AP4_MetaData::Value
  • TYPE_FLOAT_64_BE : AP4_MetaData::Value
  • TYPE_GIF : AP4_MetaData::Value
  • TYPE_HINT : AP4_Track
  • TYPE_INT_08_BE : AP4_MetaData::Value
  • TYPE_INT_16_BE : AP4_MetaData::Value
  • TYPE_INT_32_BE : AP4_MetaData::Value
  • TYPE_JPEG : AP4_MetaData::Value , AP4_Track
  • TYPE_MPEG : AP4_SampleDescription
  • TYPE_PROTECTED : AP4_SampleDescription
  • TYPE_RTP : AP4_Track
  • TYPE_STRING_PASCAL : AP4_MetaData::Value
  • TYPE_STRING_UTF_16 : AP4_MetaData::Value
  • TYPE_STRING_UTF_8 : AP4_MetaData::Value
  • TYPE_SYSTEM : AP4_Track
  • TYPE_TEXT : AP4_Track
  • TYPE_UNKNOWN : AP4_Track , AP4_SampleDescription
  • TYPE_VIDEO : AP4_Track
Generated on Thu May 13 16:36:42 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- a -

  • Action() : AP4_AtomListInspector , AP4_AtomListWriter , AP4_DescriptorListInspector , AP4_List< T >::Item::Operator , AP4_DescriptorListWriter
  • Add() : AP4_List< T >
  • Add3GppEntry() : AP4_MetaData
  • AddChild() : AP4_AtomParent
  • AddConstructor() : AP4_RtpPacket
  • AddDcfdEntry() : AP4_MetaData
  • AddDcfStringEntry() : AP4_MetaData
  • AddDescriptor() : AP4_DescriptorUpdateCommand
  • AddEntry() : AP4_StssAtom , AP4_StszAtom , AP4_SttsAtom , AP4_CttsAtom , AP4_StscAtom
  • AddField() : AP4_AtomInspector , AP4_PrintInspector
  • AddFieldF() : AP4_AtomInspector , AP4_PrintInspector
  • AddIlstEntries() : AP4_MetaData
  • AddPacket() : AP4_RtpSampleData
  • AddReference() : AP4_FileByteStream , AP4_Referenceable , AP4_DecryptingStream , AP4_EncryptingStream , AP4_RtpPacket , AP4_RtpConstructor , AP4_SubStream , AP4_MemoryByteStream , AP4_BufferedInputStream
  • AddSample() : AP4_SyntheticSampleTable
  • AddSampleDescription() : AP4_SyntheticSampleTable
  • AddSubDescriptor() : AP4_EsDescriptor , AP4_ObjectDescriptor
  • AddToFile() : AP4_MetaData::Entry
  • AddToFileDcf() : AP4_MetaData::Entry
  • AddToFileIlst() : AP4_MetaData::Entry
  • AddTrack() : AP4_Movie
  • AddTrackId() : AP4_TrefTypeAtom
  • AddTypeHandler() : AP4_AtomFactory
  • AdjustChunkOffsets() : AP4_Co64Atom , AP4_MoovAtom , AP4_StcoAtom , AP4_TrakAtom
  • AP4_3GppLocalizedStringAtom() : AP4_3GppLocalizedStringAtom
  • AP4_8bdlAtom() : AP4_8bdlAtom
  • AP4_AesBlockCipher() : AP4_AesBlockCipher
  • AP4_Array() : AP4_Array< T >
  • AP4_Atom() : AP4_Atom
  • AP4_AtomFactory() : AP4_AtomFactory
  • AP4_AtomFinder() : AP4_AtomFinder
  • AP4_AtomInspector() : AP4_AtomInspector
  • AP4_AtomListInspector() : AP4_AtomListInspector
  • AP4_AtomListWriter() : AP4_AtomListWriter
  • AP4_AtomMetaDataValue() : AP4_AtomMetaDataValue
  • AP4_AtomSampleTable() : AP4_AtomSampleTable
  • AP4_AtomSizeAdder() : AP4_AtomSizeAdder
  • AP4_AudioSampleDescription() : AP4_AudioSampleDescription
  • AP4_AudioSampleEntry() : AP4_AudioSampleEntry
  • AP4_Avc1SampleEntry() : AP4_Avc1SampleEntry
  • AP4_AvccAtom() : AP4_AvccAtom
  • AP4_AvcSampleDescription() : AP4_AvcSampleDescription
  • AP4_BinaryMetaDataValue() : AP4_BinaryMetaDataValue
  • AP4_BitWriter() : AP4_BitWriter
  • AP4_BufferedInputStream() : AP4_BufferedInputStream
  • AP4_CbcStreamCipher() : AP4_CbcStreamCipher
  • AP4_Co64Atom() : AP4_Co64Atom
  • AP4_Command() : AP4_Command
  • AP4_ContainerAtom() : AP4_ContainerAtom
  • AP4_CtrStreamCipher() : AP4_CtrStreamCipher
  • AP4_CttsAtom() : AP4_CttsAtom
  • AP4_CttsTableEntry() : AP4_CttsTableEntry
  • AP4_DataAtom() : AP4_DataAtom
  • AP4_DataBuffer() : AP4_DataBuffer
  • AP4_DcfdAtom() : AP4_DcfdAtom
  • AP4_DcfStringAtom() : AP4_DcfStringAtom
  • AP4_DecoderConfigDescriptor() : AP4_DecoderConfigDescriptor
  • AP4_DecoderSpecificInfoDescriptor() : AP4_DecoderSpecificInfoDescriptor
  • AP4_DefaultAtomFactory() : AP4_DefaultAtomFactory
  • AP4_Descriptor() : AP4_Descriptor
  • AP4_DescriptorFinder() : AP4_DescriptorFinder
  • AP4_DescriptorListInspector() : AP4_DescriptorListInspector
  • AP4_DescriptorListWriter() : AP4_DescriptorListWriter
  • AP4_DescriptorUpdateCommand() : AP4_DescriptorUpdateCommand
  • AP4_DrefAtom() : AP4_DrefAtom
  • AP4_DrmiSampleEntry() : AP4_DrmiSampleEntry
  • AP4_DrmsSampleEntry() : AP4_DrmsSampleEntry
  • AP4_ElstEntry() : AP4_ElstEntry
  • AP4_EncaSampleEntry() : AP4_EncaSampleEntry
  • AP4_EncvSampleEntry() : AP4_EncvSampleEntry
  • AP4_EsDescriptor() : AP4_EsDescriptor
  • AP4_EsdsAtom() : AP4_EsdsAtom
  • AP4_EsIdIncDescriptor() : AP4_EsIdIncDescriptor
  • AP4_EsIdRefDescriptor() : AP4_EsIdRefDescriptor
  • AP4_Exception() : AP4_Exception
  • AP4_Expandable() : AP4_Expandable
  • AP4_File() : AP4_File
  • AP4_FileByteStream() : AP4_FileByteStream
  • AP4_FragmentSampleTable() : AP4_FragmentSampleTable
  • AP4_FrmaAtom() : AP4_FrmaAtom
  • AP4_FtypAtom() : AP4_FtypAtom
  • AP4_GenericAudioSampleDescription() : AP4_GenericAudioSampleDescription
  • AP4_GenericVideoSampleDescription() : AP4_GenericVideoSampleDescription
  • AP4_GrpiAtom() : AP4_GrpiAtom
  • AP4_HdlrAtom() : AP4_HdlrAtom
  • AP4_IkmsAtom() : AP4_IkmsAtom
  • AP4_ImmediateRtpConstructor() : AP4_ImmediateRtpConstructor
  • AP4_InitialObjectDescriptor() : AP4_InitialObjectDescriptor
  • AP4_IntegerMetaDataValue() : AP4_IntegerMetaDataValue
  • AP4_IodsAtom() : AP4_IodsAtom
  • AP4_IpmpDescriptor() : AP4_IpmpDescriptor
  • AP4_IpmpDescriptorPointer() : AP4_IpmpDescriptorPointer
  • AP4_IsfmAtom() : AP4_IsfmAtom
  • AP4_IsltAtom() : AP4_IsltAtom
  • AP4_IsmaCipher() : AP4_IsmaCipher
  • AP4_IsmaEncryptingProcessor() : AP4_IsmaEncryptingProcessor
  • AP4_LinearReader() : AP4_LinearReader
  • AP4_List() : AP4_List< T >
  • AP4_MarlinIpmpDecryptingProcessor() : AP4_MarlinIpmpDecryptingProcessor
  • AP4_MarlinIpmpEncryptingProcessor() : AP4_MarlinIpmpEncryptingProcessor
  • AP4_MdhdAtom() : AP4_MdhdAtom
  • AP4_MehdAtom() : AP4_MehdAtom
  • AP4_MemoryByteStream() : AP4_MemoryByteStream
  • AP4_MetaData() : AP4_MetaData
  • AP4_MetaDataAtomTypeHandler() : AP4_MetaDataAtomTypeHandler
  • AP4_MetaDataStringAtom() : AP4_MetaDataStringAtom
  • AP4_MetaDataTag() : AP4_MetaDataTag
  • AP4_MfhdAtom() : AP4_MfhdAtom
  • AP4_MfroAtom() : AP4_MfroAtom
  • AP4_MoovAtom() : AP4_MoovAtom
  • AP4_Movie() : AP4_Movie
  • AP4_MovieFragment() : AP4_MovieFragment
  • AP4_Mp4aSampleEntry() : AP4_Mp4aSampleEntry
  • AP4_Mp4sSampleEntry() : AP4_Mp4sSampleEntry
  • AP4_Mp4vSampleEntry() : AP4_Mp4vSampleEntry
  • AP4_Mpeg2TsWriter() : AP4_Mpeg2TsWriter
  • AP4_MpegAudioSampleDescription() : AP4_MpegAudioSampleDescription
  • AP4_MpegAudioSampleEntry() : AP4_MpegAudioSampleEntry
  • AP4_MpegSampleDescription() : AP4_MpegSampleDescription
  • AP4_MpegSystemSampleDescription() : AP4_MpegSystemSampleDescription
  • AP4_MpegSystemSampleEntry() : AP4_MpegSystemSampleEntry
  • AP4_MpegVideoSampleDescription() : AP4_MpegVideoSampleDescription
  • AP4_MpegVideoSampleEntry() : AP4_MpegVideoSampleEntry
  • AP4_MvhdAtom() : AP4_MvhdAtom
  • AP4_NmhdAtom() : AP4_NmhdAtom
  • AP4_NoopRtpConstructor() : AP4_NoopRtpConstructor
  • AP4_NullTerminatedStringAtom() : AP4_NullTerminatedStringAtom
  • AP4_ObjectDescriptor() : AP4_ObjectDescriptor
  • AP4_OdafAtom() : AP4_OdafAtom
  • AP4_OddaAtom() : AP4_OddaAtom
  • AP4_OdheAtom() : AP4_OdheAtom
  • AP4_OhdrAtom() : AP4_OhdrAtom
  • AP4_OmaDcfCbcSampleDecrypter() : AP4_OmaDcfCbcSampleDecrypter
  • AP4_OmaDcfCbcSampleEncrypter() : AP4_OmaDcfCbcSampleEncrypter
  • AP4_OmaDcfCtrSampleDecrypter() : AP4_OmaDcfCtrSampleDecrypter
  • AP4_OmaDcfCtrSampleEncrypter() : AP4_OmaDcfCtrSampleEncrypter
  • AP4_OmaDcfDecryptingProcessor() : AP4_OmaDcfDecryptingProcessor
  • AP4_OmaDcfEncryptingProcessor() : AP4_OmaDcfEncryptingProcessor
  • AP4_OmaDcfSampleDecrypter() : AP4_OmaDcfSampleDecrypter
  • AP4_OmaDcfSampleEncrypter() : AP4_OmaDcfSampleEncrypter
  • AP4_PiffAvcCbcSampleDecrypter() : AP4_PiffAvcCbcSampleDecrypter
  • AP4_PiffAvcCbcSampleEncrypter() : AP4_PiffAvcCbcSampleEncrypter
  • AP4_PiffAvcCtrSampleDecrypter() : AP4_PiffAvcCtrSampleDecrypter
  • AP4_PiffAvcCtrSampleEncrypter() : AP4_PiffAvcCtrSampleEncrypter
  • AP4_PiffCbcSampleDecrypter() : AP4_PiffCbcSampleDecrypter
  • AP4_PiffCbcSampleEncrypter() : AP4_PiffCbcSampleEncrypter
  • AP4_PiffCtrSampleDecrypter() : AP4_PiffCtrSampleDecrypter
  • AP4_PiffCtrSampleEncrypter() : AP4_PiffCtrSampleEncrypter
  • AP4_PiffEncryptingProcessor() : AP4_PiffEncryptingProcessor
  • AP4_PiffNullSampleDecrypter() : AP4_PiffNullSampleDecrypter
  • AP4_PiffSampleDecrypter() : AP4_PiffSampleDecrypter
  • AP4_PiffSampleEncrypter() : AP4_PiffSampleEncrypter
  • AP4_PiffSampleEncryptionAtom() : AP4_PiffSampleEncryptionAtom
  • AP4_PiffTrackEncryptionAtom() : AP4_PiffTrackEncryptionAtom
  • AP4_PrintInspector() : AP4_PrintInspector
  • AP4_ProtectedSampleDescription() : AP4_ProtectedSampleDescription
  • AP4_ProtectionKeyMap() : AP4_ProtectionKeyMap
  • AP4_ProtectionSchemeInfo() : AP4_ProtectionSchemeInfo
  • AP4_RtpConstructor() : AP4_RtpConstructor
  • AP4_RtpHintSampleEntry() : AP4_RtpHintSampleEntry
  • AP4_RtpPacket() : AP4_RtpPacket
  • AP4_RtpSampleData() : AP4_RtpSampleData
  • AP4_Sample() : AP4_Sample
  • AP4_SampleDescription() : AP4_SampleDescription
  • AP4_SampleDescRtpConstructor() : AP4_SampleDescRtpConstructor
  • AP4_SampleEntry() : AP4_SampleEntry
  • AP4_SampleRtpConstructor() : AP4_SampleRtpConstructor
  • AP4_SchmAtom() : AP4_SchmAtom
  • AP4_SdpAtom() : AP4_SdpAtom
  • AP4_SLConfigDescriptor() : AP4_SLConfigDescriptor
  • AP4_SmhdAtom() : AP4_SmhdAtom
  • AP4_StandardDecryptingProcessor() : AP4_StandardDecryptingProcessor
  • AP4_StcoAtom() : AP4_StcoAtom
  • AP4_String() : AP4_String
  • AP4_StringMetaDataValue() : AP4_StringMetaDataValue
  • AP4_StscAtom() : AP4_StscAtom
  • AP4_StscTableEntry() : AP4_StscTableEntry
  • AP4_StsdAtom() : AP4_StsdAtom
  • AP4_StssAtom() : AP4_StssAtom
  • AP4_StszAtom() : AP4_StszAtom
  • AP4_SttsAtom() : AP4_SttsAtom
  • AP4_SttsTableEntry() : AP4_SttsTableEntry
  • AP4_SubStream() : AP4_SubStream
  • AP4_SyntheticSampleTable() : AP4_SyntheticSampleTable
  • AP4_TfhdAtom() : AP4_TfhdAtom
  • AP4_TfraAtom() : AP4_TfraAtom
  • AP4_TimsAtom() : AP4_TimsAtom
  • AP4_TkhdAtom() : AP4_TkhdAtom
  • AP4_Track() : AP4_Track
  • AP4_TrackSampleSource() : AP4_TrackSampleSource
  • AP4_TrakAtom() : AP4_TrakAtom
  • AP4_TrefTypeAtom() : AP4_TrefTypeAtom
  • AP4_TrexAtom() : AP4_TrexAtom
  • AP4_TrunAtom() : AP4_TrunAtom
  • AP4_UnknownAtom() : AP4_UnknownAtom
  • AP4_UnknownCommand() : AP4_UnknownCommand
  • AP4_UnknownDescriptor() : AP4_UnknownDescriptor
  • AP4_UnknownExpandable() : AP4_UnknownExpandable
  • AP4_UnknownSampleDescription() : AP4_UnknownSampleDescription
  • AP4_UnknownSampleEntry() : AP4_UnknownSampleEntry
  • AP4_UnknownUuidAtom() : AP4_UnknownUuidAtom
  • AP4_UrlAtom() : AP4_UrlAtom
  • AP4_UuidAtom() : AP4_UuidAtom
  • AP4_VideoSampleDescription() : AP4_VideoSampleDescription
  • AP4_VisualSampleEntry() : AP4_VisualSampleEntry
  • AP4_VmhdAtom() : AP4_VmhdAtom
  • Append() : AP4_Array< T >
  • Apply() : AP4_List< T >
  • ApplyUntilFailure() : AP4_List< T >
  • ApplyUntilSuccess() : AP4_List< T >
  • Assign() : AP4_String
  • Attach() : AP4_Track
Generated on Thu May 13 16:36:42 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- k -

  • Key() : AP4_MetaData::Key
Generated on Thu May 13 16:36:42 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- l -

  • LastItem() : AP4_List< T >
  • LoadBytes() : AP4_DataAtom
  • LoadInteger() : AP4_DataAtom
  • LoadString() : AP4_DataAtom
Generated on Thu May 13 16:36:42 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- m -

  • MapTypeToCategory() : AP4_MetaData::Value
  • MinHeaderSize() : AP4_Expandable
Generated on Thu May 13 16:36:42 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- o -

  • OnChildAdded() : AP4_AtomParent , AP4_ContainerAtom , AP4_MoovAtom
  • OnChildChanged() : AP4_AtomParent , AP4_StsdAtom , AP4_ContainerAtom , AP4_OdheAtom , AP4_SampleEntry
  • OnChildRemoved() : AP4_AtomParent , AP4_ContainerAtom , AP4_MoovAtom
  • OnProgress() : AP4_Processor::ProgressListener
  • operator!=() : AP4_String
  • operator=() : AP4_String , AP4_Sample
  • operator==() : AP4_String
  • operator[]() : AP4_Array< T > , AP4_String , AP4_Array< T >
Generated on Thu May 13 16:36:42 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- ~ -

  • ~AP4_AesBlockCipher() : AP4_AesBlockCipher
  • ~AP4_Array() : AP4_Array< T >
  • ~AP4_Atom() : AP4_Atom
  • ~AP4_AtomFactory() : AP4_AtomFactory
  • ~AP4_AtomInspector() : AP4_AtomInspector
  • ~AP4_AtomParent() : AP4_AtomParent
  • ~AP4_AtomSampleTable() : AP4_AtomSampleTable
  • ~AP4_BitWriter() : AP4_BitWriter
  • ~AP4_BlockCipher() : AP4_BlockCipher
  • ~AP4_BlockCipherFactory() : AP4_BlockCipherFactory
  • ~AP4_BufferedInputStream() : AP4_BufferedInputStream
  • ~AP4_CbcStreamCipher() : AP4_CbcStreamCipher
  • ~AP4_Co64Atom() : AP4_Co64Atom
  • ~AP4_CtrStreamCipher() : AP4_CtrStreamCipher
  • ~AP4_DataAtom() : AP4_DataAtom
  • ~AP4_DataBuffer() : AP4_DataBuffer
  • ~AP4_DecoderConfigDescriptor() : AP4_DecoderConfigDescriptor
  • ~AP4_DecoderSpecificInfoDescriptor() : AP4_DecoderSpecificInfoDescriptor
  • ~AP4_DescriptorUpdateCommand() : AP4_DescriptorUpdateCommand
  • ~AP4_EsDescriptor() : AP4_EsDescriptor
  • ~AP4_EsdsAtom() : AP4_EsdsAtom
  • ~AP4_Expandable() : AP4_Expandable
  • ~AP4_File() : AP4_File
  • ~AP4_FileByteStream() : AP4_FileByteStream
  • ~AP4_FragmentSampleTable() : AP4_FragmentSampleTable
  • ~AP4_HintTrackReader() : AP4_HintTrackReader
  • ~AP4_Hmac() : AP4_Hmac
  • ~AP4_IodsAtom() : AP4_IodsAtom
  • ~AP4_IsmaCipher() : AP4_IsmaCipher
  • ~AP4_IsmaTrackDecrypter() : AP4_IsmaTrackDecrypter
  • ~AP4_LinearReader() : AP4_LinearReader
  • ~AP4_List() : AP4_List< T >
  • ~AP4_MarlinIpmpDecryptingProcessor() : AP4_MarlinIpmpDecryptingProcessor
  • ~AP4_MarlinIpmpTrackDecrypter() : AP4_MarlinIpmpTrackDecrypter
  • ~AP4_MarlinIpmpTrackEncrypter() : AP4_MarlinIpmpTrackEncrypter
  • ~AP4_MemoryByteStream() : AP4_MemoryByteStream
  • ~AP4_MetaData() : AP4_MetaData
  • ~AP4_MetaDataTag() : AP4_MetaDataTag
  • ~AP4_Movie() : AP4_Movie
  • ~AP4_MovieFragment() : AP4_MovieFragment
  • ~AP4_Mpeg2TsWriter() : AP4_Mpeg2TsWriter
  • ~AP4_ObjectDescriptor() : AP4_ObjectDescriptor
  • ~AP4_OddaAtom() : AP4_OddaAtom
  • ~AP4_OmaDcfCbcSampleDecrypter() : AP4_OmaDcfCbcSampleDecrypter
  • ~AP4_OmaDcfCbcSampleEncrypter() : AP4_OmaDcfCbcSampleEncrypter
  • ~AP4_OmaDcfCtrSampleDecrypter() : AP4_OmaDcfCtrSampleDecrypter
  • ~AP4_OmaDcfCtrSampleEncrypter() : AP4_OmaDcfCtrSampleEncrypter
  • ~AP4_OmaDcfSampleEncrypter() : AP4_OmaDcfSampleEncrypter
  • ~AP4_OmaDcfTrackDecrypter() : AP4_OmaDcfTrackDecrypter
  • ~AP4_OmaDrmInfo() : AP4_OmaDrmInfo
  • ~AP4_PiffCbcSampleDecrypter() : AP4_PiffCbcSampleDecrypter
  • ~AP4_PiffCbcSampleEncrypter() : AP4_PiffCbcSampleEncrypter
  • ~AP4_PiffCtrSampleDecrypter() : AP4_PiffCtrSampleDecrypter
  • ~AP4_PiffCtrSampleEncrypter() : AP4_PiffCtrSampleEncrypter
  • ~AP4_PiffEncryptingProcessor() : AP4_PiffEncryptingProcessor
  • ~AP4_PiffSampleEncrypter() : AP4_PiffSampleEncrypter
  • ~AP4_PrintInspector() : AP4_PrintInspector
  • ~AP4_Processor() : AP4_Processor
  • ~AP4_ProtectedSampleDescription() : AP4_ProtectedSampleDescription
  • ~AP4_ProtectionKeyMap() : AP4_ProtectionKeyMap
  • ~AP4_ProtectionSchemeInfo() : AP4_ProtectionSchemeInfo
  • ~AP4_Referenceable() : AP4_Referenceable
  • ~AP4_RtpConstructor() : AP4_RtpConstructor
  • ~AP4_RtpPacket() : AP4_RtpPacket
  • ~AP4_RtpSampleData() : AP4_RtpSampleData
  • ~AP4_Sample() : AP4_Sample
  • ~AP4_SampleDecrypter() : AP4_SampleDecrypter
  • ~AP4_SampleDescription() : AP4_SampleDescription
  • ~AP4_SampleEntry() : AP4_SampleEntry
  • ~AP4_SampleSource() : AP4_SampleSource
  • ~AP4_SampleTable() : AP4_SampleTable
  • ~AP4_StcoAtom() : AP4_StcoAtom
  • ~AP4_StreamCipher() : AP4_StreamCipher
  • ~AP4_String() : AP4_String
  • ~AP4_StsdAtom() : AP4_StsdAtom
  • ~AP4_SubStream() : AP4_SubStream
  • ~AP4_SyntheticSampleTable() : AP4_SyntheticSampleTable
  • ~AP4_Track() : AP4_Track
  • ~AP4_TrackPropertyMap() : AP4_TrackPropertyMap
  • ~AP4_UnknownAtom() : AP4_UnknownAtom
  • ~AP4_UnknownSampleDescription() : AP4_UnknownSampleDescription
  • ~AP4_UuidAtom() : AP4_UuidAtom
  • ~Entry() : AP4_MetaData::Entry
  • ~ExternalTrackData() : AP4_Processor::ExternalTrackData
  • ~Finder() : AP4_List< T >::Item::Finder
  • ~FragmentHandler() : AP4_Processor::FragmentHandler
  • ~Item() : AP4_List< T >::Item
  • ~Operator() : AP4_List< T >::Item::Operator
  • ~ProgressListener() : AP4_Processor::ProgressListener
  • ~SinfEntry() : AP4_MarlinIpmpParser::SinfEntry
  • ~Stream() : AP4_Mpeg2TsWriter::Stream
  • ~TrackHandler() : AP4_Processor::TrackHandler
  • ~TypeHandler() : AP4_AtomFactory::TypeHandler
  • ~Value() : AP4_MetaData::Value
Generated on Thu May 13 16:36:42 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- c -

  • Clear() : AP4_Array< T > , AP4_List< T >
  • Clone() : AP4_UnknownAtom , AP4_IsfmAtom , AP4_OhdrAtom , AP4_ContainerAtom , AP4_SampleDescription , AP4_UnknownSampleDescription , AP4_Atom , AP4_GrpiAtom , AP4_Track , AP4_IkmsAtom
  • ComputeOptionalFieldsCount() : AP4_TrunAtom
  • ComputeRecordFieldsCount() : AP4_TrunAtom
  • ComputeSize() : AP4_TfhdAtom
  • CopyTo() : AP4_ByteStream
  • Create() : AP4_IkmsAtom , AP4_SdpAtom , AP4_SmhdAtom , AP4_IodsAtom , AP4_StcoAtom , AP4_StscAtom , AP4_8bdlAtom , AP4_IproAtom , AP4_StsdAtom , AP4_StssAtom , AP4_DcfdAtom , AP4_DcfStringAtom , AP4_3GppLocalizedStringAtom , AP4_Hmac , AP4_IsfmAtom , AP4_StszAtom , AP4_TrunAtom , AP4_TrexAtom , AP4_TrefTypeAtom , AP4_TrakAtom , AP4_TkhdAtom , AP4_TimsAtom , AP4_SttsAtom , AP4_AvccAtom , AP4_IsltAtom , AP4_TfhdAtom , AP4_TfraAtom , AP4_IsmaTrackDecrypter , AP4_Co64Atom , AP4_MarlinIpmpTrackDecrypter , AP4_MarlinIpmpTrackEncrypter , AP4_ContainerAtom , AP4_SchmAtom , AP4_RtpAtom , AP4_EncryptingStream , AP4_MdhdAtom , AP4_SampleDecrypter , AP4_UrlAtom , AP4_VmhdAtom , AP4_PiffSampleEncryptionAtom , AP4_PiffTrackEncryptionAtom , AP4_PiffSampleDecrypter , AP4_MehdAtom , AP4_OmaDcfSampleDecrypter , AP4_OhdrAtom , AP4_CttsAtom , AP4_MfhdAtom , AP4_OdafAtom , AP4_NmhdAtom , AP4_MfroAtom , AP4_DrefAtom , AP4_MoovAtom , AP4_MvhdAtom , AP4_ElstAtom , AP4_EsdsAtom , AP4_OddaAtom , AP4_OdheAtom , AP4_FileByteStream , AP4_FrmaAtom , AP4_OmaDcfTrackDecrypter , AP4_FtypAtom , AP4_GrpiAtom , AP4_BlockCipherFactory , AP4_HmhdAtom , AP4_DecryptingStream , AP4_DefaultBlockCipherFactory , AP4_HdlrAtom , AP4_HintTrackReader
  • CreateAtom() : AP4_AtomFactory::TypeHandler , AP4_MetaDataAtomTypeHandler
  • CreateAtomFromStream() : AP4_AtomFactory
  • CreateAtomsFromStream() : AP4_AtomFactory
  • CreateCommandFromStream() : AP4_CommandFactory
  • CreateConstructorFromStream() : AP4_RtpConstructorFactory
  • CreateDecryptingStream() : AP4_OmaDcfAtomDecrypter
  • CreateDescriptorFromStream() : AP4_DescriptorFactory
  • CreateEsDescriptor() : AP4_MpegSampleDescription
  • CreateFragmentHandler() : AP4_PiffEncryptingProcessor , AP4_Processor
  • CreateSampleDecrypter() : AP4_IsmaCipher
  • CreateSampleTable() : AP4_MovieFragment
  • CreateTrackHandler() : AP4_Processor , AP4_PiffEncryptingProcessor , AP4_MarlinIpmpDecryptingProcessor , AP4_MarlinIpmpEncryptingProcessor , AP4_IsmaEncryptingProcessor , AP4_OmaDcfEncryptingProcessor , AP4_StandardDecryptingProcessor
Generated on Thu May 13 16:36:42 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- d -

  • DecryptAtoms() : AP4_OmaDcfAtomDecrypter
  • DecryptSampleData() : AP4_IsmaCipher , AP4_OmaDcfCbcSampleDecrypter , AP4_PiffCbcSampleDecrypter , AP4_PiffAvcCbcSampleDecrypter , AP4_PiffNullSampleDecrypter , AP4_SampleDecrypter , AP4_OmaDcfCtrSampleDecrypter , AP4_PiffCtrSampleDecrypter , AP4_PiffAvcCtrSampleDecrypter
  • DeleteChild() : AP4_AtomParent
  • DeleteReferences() : AP4_List< T >
  • Detach() : AP4_Atom
  • DoWrite() : AP4_NoopRtpConstructor , AP4_SampleRtpConstructor , AP4_ImmediateRtpConstructor , AP4_SampleDescRtpConstructor , AP4_RtpConstructor
Generated on Thu May 13 16:36:42 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- e -

  • EnableTrack() : AP4_LinearReader
  • Encrypter() : AP4_PiffEncryptingProcessor::Encrypter
  • EncryptSampleData() : AP4_IsmaCipher , AP4_PiffSampleEncrypter , AP4_PiffCtrSampleEncrypter , AP4_OmaDcfSampleEncrypter , AP4_PiffAvcCtrSampleEncrypter , AP4_PiffCbcSampleEncrypter , AP4_OmaDcfCtrSampleEncrypter , AP4_PiffAvcCbcSampleEncrypter , AP4_OmaDcfCbcSampleEncrypter
  • EndElement() : AP4_AtomInspector , AP4_PrintInspector
  • EnsureCapacity() : AP4_Array< T >
  • Entry()
: AP4_TrunAtom::Entry
, AP4_TfraAtom::Entry
, AP4_MetaData::Entry
  • ExternalTrackData() : AP4_Processor::ExternalTrackData
Generated on Thu May 13 16:36:42 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- f -

  • Final() : AP4_Hmac
  • Finalize() : AP4_Processor
  • Find() : AP4_String , AP4_List< T >
  • FindChild() : AP4_AtomParent
  • FindInIlst() : AP4_MetaData::Entry
  • FindSubDescriptor() : AP4_ObjectDescriptor
  • FinishFragment() : AP4_Processor::FragmentHandler
  • FirstItem() : AP4_List< T >
  • Flush() : AP4_FileByteStream , AP4_ByteStream
Generated on Thu May 13 16:36:42 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- g -

  • GenerateStblAtom() : AP4_SampleTable
  • Get() : AP4_List< T >
  • GetAlgorithmId() : AP4_PiffSampleEncryptionAtom
  • GetAtom() : AP4_UnknownSampleDescription
  • GetAudioProfileLevelIndication() : AP4_InitialObjectDescriptor
  • GetAvgBitrate() : AP4_DecoderConfigDescriptor , AP4_MpegSampleDescription
  • GetBaseDataOffset() : AP4_TfhdAtom
  • GetBFrameFlag() : AP4_RtpPacket
  • GetBitCount() : AP4_BitWriter
  • GetBufferFullness() : AP4_LinearReader
  • GetBufferSize() : AP4_DataBuffer , AP4_DecoderConfigDescriptor , AP4_MpegSampleDescription
  • GetBundleData() : AP4_8bdlAtom
  • GetChannelCount() : AP4_AudioSampleDescription , AP4_AudioSampleEntry
  • GetChars() : AP4_String
  • GetChild() : AP4_AtomParent
  • GetChildren() : AP4_AtomParent , AP4_ContainerAtom
  • GetChunkCount() : AP4_Co64Atom , AP4_StcoAtom
  • GetChunkForSample() : AP4_AtomSampleTable , AP4_StscAtom
  • GetChunkOffset() : AP4_AtomSampleTable , AP4_Co64Atom , AP4_StcoAtom
  • GetChunkOffsets() : AP4_TrakAtom , AP4_Co64Atom , AP4_StcoAtom
  • GetCipher() : AP4_IsmaCipher
  • GetClassId() : AP4_Expandable
  • GetCompatibleBrands() : AP4_FtypAtom
  • GetCompressorName() : AP4_VideoSampleDescription , AP4_VisualSampleEntry
  • GetConfigurationVersion() : AP4_AvccAtom , AP4_AvcSampleDescription
  • GetConstructedDataSize() : AP4_RtpPacket , AP4_RtpConstructor , AP4_NoopRtpConstructor , AP4_ImmediateRtpConstructor , AP4_SampleRtpConstructor , AP4_SampleDescRtpConstructor
  • GetConstructors() : AP4_RtpPacket
  • GetContentId() : AP4_OhdrAtom , AP4_OmaDrmInfo
  • GetContentType() : AP4_OdheAtom
  • GetContext() : AP4_AtomFactory
  • GetControlPointCode() : AP4_IpmpDescriptor
  • GetCts() : AP4_Sample
  • GetCtsDelta() : AP4_Sample
  • GetCtsOffset() : AP4_CttsAtom
  • GetCurrentTimeStampMs() : AP4_HintTrackReader
  • GetData() : AP4_MemoryByteStream , AP4_DataBuffer , AP4_IpmpDescriptor , AP4_List< T >::Item , AP4_ImmediateRtpConstructor , AP4_BitWriter
  • GetDataLang() : AP4_DataAtom
  • GetDataOffset() : AP4_TrunAtom
  • GetDataReferenceIndex() : AP4_SampleEntry
  • GetDataSize() : AP4_MemoryByteStream , AP4_DataBuffer
  • GetDataStream() : AP4_Sample
  • GetDataType() : AP4_DataAtom
  • GetDecoderConfigDescriptor() : AP4_EsDescriptor
  • GetDecoderInfo() : AP4_MpegSampleDescription
  • GetDecoderSpecificInfo() : AP4_DecoderSpecificInfoDescriptor
  • GetDecoderSpecificInfoDescriptor() : AP4_DecoderConfigDescriptor
  • GetDecryptedSampleSize() : AP4_IsmaCipher , AP4_OmaDcfCtrSampleDecrypter , AP4_OmaDcfCbcSampleDecrypter , AP4_SampleDecrypter
  • GetDefaultAlgorithmId() : AP4_PiffTrackEncryptionAtom
  • GetDefaultIvSize() : AP4_PiffTrackEncryptionAtom
  • GetDefaultKid() : AP4_PiffTrackEncryptionAtom
  • GetDefaultSampleDescriptionIndex() : AP4_TrexAtom
  • GetDefaultSampleDuration() : AP4_TfhdAtom , AP4_TrexAtom
  • GetDefaultSampleFlags() : AP4_TfhdAtom , AP4_TrexAtom
  • GetDefaultSampleSize() : AP4_TfhdAtom , AP4_TrexAtom
  • GetDepth() : AP4_VideoSampleDescription , AP4_VisualSampleEntry
  • GetDescriptionIndex() : AP4_Sample
  • GetDescriptorId() : AP4_IpmpDescriptorPointer , AP4_IpmpDescriptor
  • GetDescriptorIdEx() : AP4_IpmpDescriptorPointer , AP4_IpmpDescriptor
  • GetDescriptors() : AP4_DescriptorUpdateCommand
  • GetDetails() : AP4_SampleDescription
  • GetDts() : AP4_Sample , AP4_SttsAtom
  • GetDuration() : AP4_FragmentSampleTable , AP4_MdhdAtom , AP4_MehdAtom , AP4_Movie , AP4_MvhdAtom , AP4_Sample , AP4_TkhdAtom , AP4_Track , AP4_TrakAtom , AP4_DcfdAtom
  • GetDurationMs() : AP4_MdhdAtom , AP4_Movie , AP4_MvhdAtom , AP4_SampleSource , AP4_TrackSampleSource , AP4_Track
  • GetEncoding() : AP4_8bdlAtom
  • GetEncodingVersion() : AP4_8bdlAtom
  • GetEncryptedDataLength() : AP4_OddaAtom
  • GetEncryptedPayload() : AP4_OddaAtom
  • GetEncryptedSampleSize() : AP4_OmaDcfSampleEncrypter , AP4_OmaDcfCtrSampleEncrypter , AP4_OmaDcfCbcSampleEncrypter
  • GetEncryptionMethod() : AP4_OhdrAtom
  • GetEntries() : AP4_StssAtom , AP4_TfraAtom , AP4_TrunAtom , AP4_MetaData
  • GetEsDescriptor() : AP4_EsdsAtom
  • GetEsId() : AP4_IpmpDescriptorPointer
  • GetExtraData() : AP4_RtpSampleData
  • GetFieldsSize() : AP4_SampleEntry , AP4_UnknownSampleEntry , AP4_AudioSampleEntry , AP4_VisualSampleEntry , AP4_RtpHintSampleEntry
  • GetFileType() : AP4_File
  • GetFirstSampleFlags() : AP4_TrunAtom
  • GetFlags() : AP4_Atom , AP4_Track
  • GetFormat() : AP4_SampleDescription
  • GetGraphicsProfileLevelIndication() : AP4_InitialObjectDescriptor
  • GetGroupId() : AP4_GrpiAtom
  • GetGroupKey() : AP4_GrpiAtom
  • GetHandlerName() : AP4_HdlrAtom
  • GetHandlerType() : AP4_HdlrAtom , AP4_Track
  • GetHeaderSize() : AP4_Atom , AP4_Expandable , AP4_UuidAtom
  • GetHeight() : AP4_VideoSampleDescription , AP4_VisualSampleEntry , AP4_TkhdAtom , AP4_Track , AP4_TrakAtom
  • GetHorizResolution() : AP4_VisualSampleEntry
  • GetId() : AP4_Track , AP4_TrakAtom
  • GetIncludeProfileLevelFlag() : AP4_InitialObjectDescriptor
  • GetIpmpsType() : AP4_IpmpDescriptor
  • GetIV() : AP4_StreamCipher , AP4_CtrStreamCipher , AP4_CbcStreamCipher
  • GetIv() : AP4_PiffSampleEncrypter , AP4_PiffSampleEncryptionAtom
  • GetIvCount() : AP4_PiffSampleEncryptionAtom
  • GetIvLength() : AP4_IsfmAtom , AP4_IsmaCipher , AP4_OdafAtom
  • GetIvSize() : AP4_PiffSampleEncryptionAtom
  • GetKey() : AP4_ProtectionKeyMap
  • GetKeyAndIv() : AP4_ProtectionKeyMap
  • GetKeyEncryptionMethod() : AP4_GrpiAtom
  • GetKeyIndicatorLength() : AP4_IsfmAtom , AP4_IsmaCipher , AP4_OdafAtom
  • GetKeyMap() : AP4_IsmaEncryptingProcessor , AP4_MarlinIpmpDecryptingProcessor , AP4_MarlinIpmpEncryptingProcessor , AP4_OmaDcfDecryptingProcessor , AP4_OmaDcfEncryptingProcessor , AP4_PiffEncryptingProcessor , AP4_StandardDecryptingProcessor
  • GetKid() : AP4_PiffSampleEncryptionAtom
  • GetKmsId() : AP4_IkmsAtom
  • GetKmsUri() : AP4_IkmsAtom
  • GetKmsVersion() : AP4_IkmsAtom
  • GetLanguage() : AP4_MdhdAtom , AP4_MetaData::Value , AP4_3GppLocalizedStringAtom
  • GetLength() : AP4_SampleRtpConstructor , AP4_SampleDescRtpConstructor , AP4_String
  • GetLevel() : AP4_AvccAtom , AP4_AvcSampleDescription
  • GetMajorBrand() : AP4_FtypAtom
  • GetMaxBitrate() : AP4_DecoderConfigDescriptor , AP4_MpegSampleDescription
  • GetMBit() : AP4_RtpPacket
  • GetMeaning() : AP4_MetaData::Value
  • GetMediaDuration() : AP4_Track , AP4_TrakAtom
  • GetMediaTimeScale() : AP4_Track , AP4_TrakAtom
  • GetMediaTrack() : AP4_HintTrackReader
  • GetMetaData() : AP4_File
  • GetMfhdAtom() : AP4_MovieFragment
  • GetMfraSize() : AP4_MfroAtom
  • GetMinorVersion() : AP4_FtypAtom
  • GetMoofAtom() : AP4_MovieFragment
  • GetMoovAtom() : AP4_Movie
  • GetMovie() : AP4_File
  • GetMovieTimeScale() : AP4_Track
  • GetMpeg4AudioObjectType() : AP4_MpegAudioSampleDescription
  • GetMpeg4AudioObjectTypeString() : AP4_MpegAudioSampleDescription
  • GetMvhdAtom() : AP4_Movie
  • GetNaluLengthSize() : AP4_AvcSampleDescription , AP4_AvccAtom
  • GetName() : AP4_MetaData::Key
  • GetNamespace() : AP4_MetaData::Key
  • GetNearestSyncSampleIndex() : AP4_FragmentSampleTable , AP4_SyntheticSampleTable , AP4_AtomSampleTable , AP4_SampleSource , AP4_TrackSampleSource , AP4_SampleTable , AP4_Track
  • GetNext() : AP4_List< T >::Item
  • GetNextPacket() : AP4_HintTrackReader
  • GetObjectDescriptor() : AP4_IodsAtom
  • GetObjectDescriptorId() : AP4_ObjectDescriptor
  • GetObjectTypeId() : AP4_MpegSampleDescription
  • GetObjectTypeIndication() : AP4_DecoderConfigDescriptor
  • GetObjectTypeString() : AP4_MpegSampleDescription
  • GetOdProfileLevelIndication() : AP4_InitialObjectDescriptor
  • GetOffset() : AP4_Sample
  • GetOriginalFormat() : AP4_ProtectedSampleDescription , AP4_FrmaAtom
  • GetOriginalSampleDescription() : AP4_ProtectedSampleDescription
  • GetPackets() : AP4_RtpSampleData
  • GetPaddingScheme() : AP4_OhdrAtom
  • GetParent() : AP4_Atom
  • GetPAT() : AP4_Mpeg2TsWriter
  • GetPayload() : AP4_UnknownSampleEntry
  • GetPayloadType() : AP4_RtpPacket
  • GetPBit() : AP4_RtpPacket
  • GetPictureParameters() : AP4_AvccAtom , AP4_AvcSampleDescription
  • GetPID() : AP4_Mpeg2TsWriter::Stream
  • GetPlaintextLength() : AP4_OhdrAtom
  • GetPMT() : AP4_Mpeg2TsWriter
  • GetPrev() : AP4_List< T >::Item
  • GetProcessedSampleSize() : AP4_MarlinIpmpTrackDecrypter , AP4_Processor::FragmentHandler , AP4_IsmaTrackDecrypter , AP4_MarlinIpmpTrackEncrypter , AP4_OmaDcfTrackDecrypter , AP4_Processor::TrackHandler
  • GetProfile() : AP4_AvccAtom , AP4_AvcSampleDescription
  • GetProfileCompatibility() : AP4_AvccAtom , AP4_AvcSampleDescription
  • GetProfileName() : AP4_AvccAtom , AP4_AvcSampleDescription
  • GetProperty() : AP4_TrackPropertyMap
  • GetPropertyMap() : AP4_OmaDcfEncryptingProcessor , AP4_PiffEncryptingProcessor , AP4_MarlinIpmpEncryptingProcessor
  • GetRawBytes() : AP4_AvccAtom , AP4_AvcSampleDescription
  • GetRefIndex() : AP4_EsIdRefDescriptor
  • GetRelativeTime() : AP4_RtpPacket
  • GetRepeatFlag() : AP4_RtpPacket
  • GetRightsIssuerUrl() : AP4_OmaDrmInfo , AP4_OhdrAtom
  • GetSalt() : AP4_IsltAtom
  • GetSample() : AP4_AtomSampleTable , AP4_FragmentSampleTable , AP4_SampleTable , AP4_SyntheticSampleTable , AP4_Track
  • GetSampleChunkPosition() : AP4_FragmentSampleTable , AP4_SampleTable , AP4_SyntheticSampleTable , AP4_AtomSampleTable
  • GetSampleCount() : AP4_SyntheticSampleTable , AP4_SampleTable , AP4_FragmentSampleTable , AP4_StszAtom , AP4_Track , AP4_AtomSampleTable
  • GetSampleDescIndex() : AP4_SampleDescRtpConstructor
  • GetSampleDescOffset() : AP4_SampleDescRtpConstructor
  • GetSampleDescription() : AP4_AtomSampleTable , AP4_SampleTable , AP4_Track , AP4_TrackSampleSource , AP4_FragmentSampleTable , AP4_StsdAtom , AP4_SampleSource , AP4_SyntheticSampleTable
  • GetSampleDescriptionCount() : AP4_FragmentSampleTable , AP4_SampleTable , AP4_StsdAtom , AP4_SyntheticSampleTable , AP4_AtomSampleTable
  • GetSampleDescriptionIndex() : AP4_TfhdAtom
  • GetSampleEntry() : AP4_StsdAtom
  • GetSampleIndexForTimeStamp() : AP4_AtomSampleTable , AP4_SampleTable , AP4_SyntheticSampleTable , AP4_SttsAtom , AP4_FragmentSampleTable
  • GetSampleIndexForTimeStampMs() : AP4_TrackSampleSource , AP4_Track , AP4_SampleSource
  • GetSampleNum() : AP4_SampleRtpConstructor
  • GetSampleOffset() : AP4_SampleRtpConstructor
  • GetSampleRate() : AP4_AudioSampleDescription , AP4_AudioSampleEntry
  • GetSampleSize() : AP4_StszAtom , AP4_AudioSampleEntry , AP4_AudioSampleDescription
  • GetSampleTable() : AP4_Track
  • GetSceneProfileLevelIndication() : AP4_InitialObjectDescriptor
  • GetSchemeInfo() : AP4_ProtectedSampleDescription
  • GetSchemeType() : AP4_SchmAtom , AP4_ProtectedSampleDescription
  • GetSchemeUri() : AP4_ProtectedSampleDescription , AP4_SchmAtom
  • GetSchemeVersion() : AP4_ProtectedSampleDescription , AP4_SchmAtom
  • GetSchiAtom() : AP4_ProtectionSchemeInfo
  • GetSdpText() : AP4_RtpAtom , AP4_HintTrackReader , AP4_SdpAtom
  • GetSelectiveEncryption() : AP4_OdafAtom , AP4_IsmaCipher , AP4_IsfmAtom
  • GetSequenceCode() : AP4_IpmpDescriptor
  • GetSequenceNumber() : AP4_MfhdAtom , AP4_MovieFragment
  • GetSequenceParameters() : AP4_AvccAtom , AP4_AvcSampleDescription
  • GetSequenceSeed() : AP4_RtpPacket
  • GetSize() : AP4_SubStream , AP4_EncryptingStream , AP4_MemoryByteStream , AP4_RtpPacket , AP4_ByteStream , AP4_RtpSampleData , AP4_Sample , AP4_BufferedInputStream , AP4_DecryptingStream , AP4_FileByteStream , AP4_Expandable , AP4_Atom
  • GetSize32() : AP4_Atom
  • GetSize64() : AP4_Atom
  • GetStreamOffset() : AP4_CbcStreamCipher , AP4_StreamCipher , AP4_CtrStreamCipher
  • GetStreamType() : AP4_DecoderConfigDescriptor , AP4_MpegSampleDescription
  • GetStreamTypeString() : AP4_MpegSampleDescription
  • GetTag() : AP4_Descriptor , AP4_Command
  • GetTextualHeaders() : AP4_OmaDrmInfo , AP4_OhdrAtom , AP4_TrackPropertyMap
  • GetTimeScale() : AP4_MvhdAtom , AP4_TimsAtom , AP4_Movie , AP4_TrackSampleSource , AP4_MoovAtom , AP4_SampleSource , AP4_MdhdAtom
  • GetTimeStampOffset() : AP4_RtpPacket
  • GetTkhdAtom() : AP4_TrakAtom
  • GetToolId() : AP4_IpmpDescriptor
  • GetTopLevelAtoms() : AP4_File
  • GetTrack() : AP4_Movie
  • GetTrackId() : AP4_TrexAtom , AP4_TkhdAtom , AP4_EsIdIncDescriptor , AP4_TfhdAtom , AP4_SampleSource , AP4_TrackSampleSource
  • GetTrackIds() : AP4_MovieFragment , AP4_TrefTypeAtom
  • GetTrackLanguage() : AP4_Track
  • GetTrackName() : AP4_Track
  • GetTrackRefIndex() : AP4_SampleDescRtpConstructor , AP4_SampleRtpConstructor
  • GetTracks() : AP4_Movie
  • GetTrafAtom() : AP4_MovieFragment
  • GetTrakAtom() : AP4_Track
  • GetTrakAtoms() : AP4_MoovAtom
  • GetTranslation() : AP4_TkhdAtom
  • GetType() : AP4_SampleDescription , AP4_Track , AP4_RtpConstructor , AP4_MetaData::Value , AP4_Atom
  • GetTypeCategory() : AP4_MetaData::Value
  • GetUrl() : AP4_IpmpDescriptor , AP4_ObjectDescriptor
  • GetUrlFlag() : AP4_ObjectDescriptor
  • GetUuid() : AP4_UuidAtom
  • GetValue() : AP4_MetaDataStringAtom , AP4_NullTerminatedStringAtom , AP4_DcfStringAtom , AP4_3GppLocalizedStringAtom
  • GetValueType() : AP4_DataAtom
  • GetVerbosity() : AP4_AtomInspector
  • GetVertResolution() : AP4_VisualSampleEntry
  • GetVisualProfileLevelIndication() : AP4_InitialObjectDescriptor
  • GetWidth() : AP4_TkhdAtom , AP4_VideoSampleDescription , AP4_TrakAtom , AP4_VisualSampleEntry , AP4_Track
  • GetXBit() : AP4_RtpPacket
Generated on Thu May 13 16:36:42 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- h -

  • HasCompatibleBrand() : AP4_FtypAtom
Generated on Thu May 13 16:36:42 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- i -

  • Initialize() : AP4_MarlinIpmpDecryptingProcessor , AP4_MarlinIpmpEncryptingProcessor , AP4_OmaDcfEncryptingProcessor , AP4_PiffEncryptingProcessor , AP4_OmaDcfDecryptingProcessor , AP4_Processor , AP4_StandardDecryptingProcessor
  • Insert() : AP4_List< T >
  • Inspect() : AP4_EsIdRefDescriptor , AP4_Expandable , AP4_Atom , AP4_File , AP4_IpmpDescriptorPointer , AP4_Command , AP4_IpmpDescriptor , AP4_Movie , AP4_DecoderConfigDescriptor , AP4_ObjectDescriptor , AP4_InitialObjectDescriptor , AP4_DecoderSpecificInfoDescriptor , AP4_DescriptorUpdateCommand , AP4_SampleEntry , AP4_Descriptor , AP4_MetaDataTag , AP4_EsDescriptor , AP4_EsIdIncDescriptor
  • InspectChildren() : AP4_ContainerAtom
  • InspectFields() : AP4_TrexAtom , AP4_StscAtom , AP4_StcoAtom , AP4_MetaDataStringAtom , AP4_Co64Atom , AP4_SchmAtom , AP4_RtpHintSampleEntry , AP4_VisualSampleEntry , AP4_SdpAtom , AP4_SampleEntry , AP4_RtpAtom , AP4_PiffSampleEncryptionAtom , AP4_SmhdAtom , AP4_OhdrAtom , AP4_OdheAtom , AP4_OddaAtom , AP4_OdafAtom , AP4_MvhdAtom , AP4_ContainerAtom , AP4_CttsAtom , AP4_StsdAtom , AP4_MdhdAtom , AP4_ElstAtom , AP4_IsfmAtom , AP4_IproAtom , AP4_IodsAtom , AP4_IkmsAtom , AP4_HmhdAtom , AP4_VmhdAtom , AP4_GrpiAtom , AP4_TrefTypeAtom , AP4_DataAtom , AP4_EsdsAtom , AP4_TfhdAtom , AP4_FrmaAtom , AP4_FtypAtom , AP4_TrunAtom , AP4_AvccAtom , AP4_AudioSampleEntry , AP4_Atom , AP4_PiffTrackEncryptionAtom , AP4_TimsAtom , AP4_TkhdAtom , AP4_MfroAtom , AP4_MfhdAtom , AP4_IsltAtom , AP4_3GppLocalizedStringAtom , AP4_DcfStringAtom , AP4_HdlrAtom , AP4_DcfdAtom , AP4_UrlAtom , AP4_StssAtom , AP4_StszAtom , AP4_NullTerminatedStringAtom , AP4_8bdlAtom , AP4_MehdAtom , AP4_TfraAtom , AP4_SttsAtom
  • InspectHeader() : AP4_Atom , AP4_UuidAtom
  • IsMoovBeforeMdat() : AP4_File
  • IsSampleSync() : AP4_StssAtom
  • IsSync() : AP4_Sample
  • IsTypeInList() : AP4_MetaDataAtomTypeHandler
  • Item() : AP4_List< T >::Item
  • ItemCount() : AP4_List< T > , AP4_Array< T >
Generated on Thu May 13 16:36:42 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- p -

  • Parse() : AP4_MarlinIpmpParser
  • ParseMoov() : AP4_MetaData
  • ParseUdta() : AP4_MetaData
  • PopContext() : AP4_AtomFactory
  • PopHead() : AP4_List< T >
  • Process() : AP4_Processor
  • ProcessBlock() : AP4_AesBlockCipher , AP4_BlockCipher
  • ProcessBuffer() : AP4_StreamCipher , AP4_CtrStreamCipher , AP4_CbcStreamCipher
  • ProcessFragment() : AP4_Processor::FragmentHandler
  • ProcessFragments() : AP4_Processor
  • ProcessSample() : AP4_IsmaTrackDecrypter , AP4_MarlinIpmpTrackEncrypter , AP4_OmaDcfTrackDecrypter , AP4_Processor::TrackHandler , AP4_MarlinIpmpTrackDecrypter , AP4_Processor::FragmentHandler
  • ProcessTrack() : AP4_Processor::TrackHandler , AP4_OmaDcfTrackDecrypter , AP4_IsmaTrackDecrypter
  • PushContext() : AP4_AtomFactory
Generated on Thu May 13 16:36:42 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- r -

  • Read() : AP4_ByteStream , AP4_SampleEntry
  • ReadChildren() : AP4_ContainerAtom
  • ReadData() : AP4_Sample
  • ReadDouble() : AP4_ByteStream
  • ReadFields() : AP4_UnknownSampleEntry , AP4_AudioSampleEntry , AP4_VisualSampleEntry , AP4_RtpHintSampleEntry , AP4_SampleEntry
  • ReadFullHeader() : AP4_Atom
  • ReadNextSample() : AP4_TrackSampleSource , AP4_LinearReader , AP4_SampleSource
  • ReadPartial() : AP4_ByteStream , AP4_SubStream , AP4_MemoryByteStream , AP4_BufferedInputStream , AP4_FileByteStream , AP4_DecryptingStream , AP4_EncryptingStream
  • ReadSample() : AP4_Track
  • ReadString() : AP4_ByteStream
  • ReadUI08() : AP4_ByteStream
  • ReadUI16() : AP4_ByteStream
  • ReadUI24() : AP4_ByteStream
  • ReadUI32() : AP4_ByteStream
  • ReadUI64() : AP4_ByteStream
  • ReallocateBuffer() : AP4_DataBuffer
  • Refill() : AP4_BufferedInputStream
  • Release() : AP4_SubStream , AP4_MemoryByteStream , AP4_EncryptingStream , AP4_FileByteStream , AP4_DecryptingStream , AP4_Referenceable , AP4_RtpPacket , AP4_BufferedInputStream , AP4_RtpConstructor
  • Remove() : AP4_List< T >
  • RemoveChild() : AP4_AtomParent
  • RemoveFromFile() : AP4_MetaData::Entry
  • RemoveFromFileDcf() : AP4_MetaData::Entry
  • RemoveFromFileIlst() : AP4_MetaData::Entry
  • RemoveLast() : AP4_Array< T >
  • RemoveTypeHandler() : AP4_AtomFactory
  • Reserve() : AP4_DataBuffer
  • Reset() : AP4_Sample
  • ResolveKeyName() : AP4_MetaData
  • ReverseApply() : AP4_List< T >
  • ReverseFind() : AP4_List< T >
  • Rewind() : AP4_HintTrackReader
Generated on Thu May 13 16:36:42 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- s -

  • SampleStream() : AP4_Mpeg2TsWriter::SampleStream
  • Seek() : AP4_ByteStream , AP4_MemoryByteStream , AP4_EncryptingStream , AP4_BufferedInputStream , AP4_SubStream , AP4_FileByteStream , AP4_DecryptingStream
  • SeekToTimeStampMs() : AP4_HintTrackReader
  • SetAudioStream() : AP4_Mpeg2TsWriter
  • SetBaseDataOffset() : AP4_TfhdAtom
  • SetBuffer() : AP4_DataBuffer
  • SetBufferSize() : AP4_DataBuffer
  • SetChunkOffset() : AP4_StcoAtom , AP4_AtomSampleTable , AP4_Co64Atom
  • SetChunkOffsets() : AP4_TrakAtom
  • SetCts() : AP4_Sample
  • SetCtsDelta() : AP4_Sample
  • SetData() : AP4_DataBuffer , AP4_IpmpDescriptor
  • SetDataSize() : AP4_DataBuffer
  • SetDataStream() : AP4_Sample
  • SetDefaultSampleDuration() : AP4_TfhdAtom
  • SetDefaultSampleFlags() : AP4_TfhdAtom
  • SetDefaultSampleSize() : AP4_TfhdAtom
  • SetDescriptionIndex() : AP4_Sample
  • SetDts() : AP4_Sample
  • SetDuration() : AP4_Sample , AP4_TkhdAtom , AP4_TrakAtom , AP4_MdhdAtom , AP4_MehdAtom , AP4_MvhdAtom
  • SetEncryptedPayload() : AP4_OddaAtom
  • SetEncryptionMethod() : AP4_OhdrAtom
  • SetFileType() : AP4_File
  • SetFlags() : AP4_Atom , AP4_Track
  • SetHeight() : AP4_TkhdAtom , AP4_TrakAtom
  • SetId() : AP4_Track , AP4_TrakAtom
  • SetItemCount() : AP4_Array< T >
  • SetIv() : AP4_PiffSampleEncrypter , AP4_PiffSampleEncryptionAtom
  • SetIV() : AP4_StreamCipher , AP4_CtrStreamCipher , AP4_CbcStreamCipher
  • SetIvSize() : AP4_PiffSampleEncryptionAtom
  • SetKey() : AP4_ProtectionKeyMap
  • SetKeyEncryptionMethod() : AP4_GrpiAtom
  • SetKeys() : AP4_ProtectionKeyMap
  • SetLanguage() : AP4_MetaData::Value
  • SetMediaDuration() : AP4_TrakAtom
  • SetMediaTimeScale() : AP4_TrakAtom
  • SetMovieTimeScale() : AP4_Track
  • SetOffset() : AP4_Sample
  • SetPaddingScheme() : AP4_OhdrAtom
  • SetParent() : AP4_Atom
  • SetProperties() : AP4_TrackPropertyMap
  • SetProperty() : AP4_TrackPropertyMap
  • SetSampleDescriptionIndex() : AP4_TfhdAtom
  • SetSampleIndex() : AP4_LinearReader , AP4_PiffSampleDecrypter , AP4_SampleSource , AP4_TrackSampleSource , AP4_SampleDecrypter
  • SetSampleSize() : AP4_StszAtom , AP4_AtomSampleTable
  • SetSequenceNumber() : AP4_MfhdAtom
  • SetSize() : AP4_Sample , AP4_Atom
  • SetSize32() : AP4_Atom
  • SetSize64() : AP4_Atom
  • SetStreamOffset() : AP4_StreamCipher , AP4_CbcStreamCipher , AP4_CtrStreamCipher
  • SetSync() : AP4_Sample
  • SetTimeScale() : AP4_MdhdAtom , AP4_MvhdAtom
  • SetTrackId() : AP4_TfhdAtom , AP4_TkhdAtom
  • SetType() : AP4_Atom
  • SetVerbosity() : AP4_AtomInspector
  • SetVideoStream() : AP4_Mpeg2TsWriter
  • SetWidth() : AP4_TkhdAtom , AP4_TrakAtom
  • SinfEntry() : AP4_MarlinIpmpParser::SinfEntry
  • StartElement() : AP4_PrintInspector , AP4_AtomInspector
  • Stream() : AP4_Mpeg2TsWriter::Stream
Generated on Thu May 13 16:36:42 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- t -

  • Tell() : AP4_ByteStream , AP4_SubStream , AP4_BufferedInputStream , AP4_FileByteStream , AP4_MemoryByteStream , AP4_DecryptingStream , AP4_EncryptingStream
  • Test() : AP4_AtomFinder , AP4_DescriptorFinder , AP4_List< T >::Item::Finder
  • ToAtom() : AP4_MpegAudioSampleDescription , AP4_MpegVideoSampleDescription , AP4_MetaData::Entry , AP4_ProtectedSampleDescription , AP4_SampleDescription , AP4_UnknownSampleDescription , AP4_AvcSampleDescription , AP4_MpegSystemSampleDescription
  • ToBytes() : AP4_MetaData::Value , AP4_StringMetaDataValue , AP4_IntegerMetaDataValue , AP4_BinaryMetaDataValue , AP4_AtomMetaDataValue
  • ToByteStream() : AP4_RtpSampleData
  • ToInteger() : AP4_IntegerMetaDataValue , AP4_MetaData::Value , AP4_StringMetaDataValue , AP4_BinaryMetaDataValue , AP4_AtomMetaDataValue
  • ToSampleDescription() : AP4_SampleEntry , AP4_Mp4sSampleEntry , AP4_MpegSystemSampleEntry , AP4_UnknownSampleEntry , AP4_AudioSampleEntry , AP4_MpegVideoSampleEntry , AP4_EncvSampleEntry , AP4_Avc1SampleEntry , AP4_MpegAudioSampleEntry , AP4_VisualSampleEntry , AP4_EncaSampleEntry
  • ToString() : AP4_IntegerMetaDataValue , AP4_BinaryMetaDataValue , AP4_MetaData::Value , AP4_StringMetaDataValue , AP4_AtomMetaDataValue
  • ToTargetSampleDescription() : AP4_EncaSampleEntry , AP4_EncvSampleEntry
  • TypeFromString() : AP4_Atom
Generated on Thu May 13 16:36:42 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- u -

  • Update() : AP4_Hmac
  • UseChars() : AP4_String
  • UseData() : AP4_MemoryByteStream , AP4_DataBuffer
Generated on Thu May 13 16:36:42 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- v -

  • Value() : AP4_MetaData::Value
Generated on Thu May 13 16:36:42 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- w -

  • Write() : AP4_Atom , AP4_ByteStream , AP4_FileCopier , AP4_SampleEntry , AP4_BitWriter , AP4_FileWriter , AP4_MetaDataTag , AP4_Expandable , AP4_RtpPacket , AP4_RtpConstructor
  • WriteDouble() : AP4_ByteStream
  • WriteFields() : AP4_AvccAtom , AP4_FrmaAtom , AP4_RtpHintSampleEntry , AP4_SchmAtom , AP4_FtypAtom , AP4_SdpAtom , AP4_SLConfigDescriptor , AP4_Co64Atom , AP4_GrpiAtom , AP4_SmhdAtom , AP4_DataAtom , AP4_StcoAtom , AP4_DcfdAtom , AP4_DcfStringAtom , AP4_3GppLocalizedStringAtom , AP4_VmhdAtom , AP4_UnknownUuidAtom , AP4_UrlAtom , AP4_HdlrAtom , AP4_StscAtom , AP4_TrefTypeAtom , AP4_TkhdAtom , AP4_TimsAtom , AP4_TfraAtom , AP4_TfhdAtom , AP4_SttsAtom , AP4_StsdAtom , AP4_UnknownCommand , AP4_HmhdAtom , AP4_StssAtom , AP4_StszAtom , AP4_IkmsAtom , AP4_ContainerAtom , AP4_IodsAtom , AP4_IpmpDescriptorPointer , AP4_CttsAtom , AP4_VisualSampleEntry , AP4_AudioSampleEntry , AP4_UnknownSampleEntry , AP4_SampleEntry , AP4_RtpAtom , AP4_PiffSampleEncryptionAtom , AP4_PiffTrackEncryptionAtom , AP4_IpmpDescriptor , AP4_OdheAtom , AP4_OddaAtom , AP4_OdafAtom , AP4_DescriptorUpdateCommand , AP4_InitialObjectDescriptor , AP4_ObjectDescriptor , AP4_TrexAtom , AP4_TrunAtom , AP4_MfroAtom , AP4_MfhdAtom , AP4_MehdAtom , AP4_MetaDataStringAtom , AP4_IproAtom , AP4_DecoderConfigDescriptor , AP4_IsfmAtom , AP4_IsltAtom , AP4_DecoderSpecificInfoDescriptor , AP4_MdhdAtom , AP4_UnknownDescriptor , AP4_8bdlAtom , AP4_DrefAtom , AP4_MvhdAtom , AP4_NmhdAtom , AP4_ElstAtom , AP4_UnknownExpandable , AP4_Expandable , AP4_EsdsAtom , AP4_OhdrAtom , AP4_Atom , AP4_EsDescriptor , AP4_EsIdIncDescriptor , AP4_UnknownAtom , AP4_EsIdRefDescriptor , AP4_NullTerminatedStringAtom
  • WriteHeader() : AP4_Atom , AP4_UuidAtom
  • WritePacketHeader() : AP4_Mpeg2TsWriter::Stream
  • WritePartial() : AP4_SubStream , AP4_FileByteStream , AP4_ByteStream , AP4_MemoryByteStream , AP4_DecryptingStream , AP4_BufferedInputStream , AP4_EncryptingStream
  • WritePAT() : AP4_Mpeg2TsWriter
  • WritePES() : AP4_Mpeg2TsWriter::SampleStream
  • WritePMT() : AP4_Mpeg2TsWriter
  • WriteSample() : AP4_Mpeg2TsWriter::SampleStream
  • WriteString() : AP4_ByteStream
  • WriteUI08() : AP4_ByteStream
  • WriteUI16() : AP4_ByteStream
  • WriteUI24() : AP4_ByteStream
  • WriteUI32() : AP4_ByteStream
  • WriteUI64() : AP4_ByteStream
Generated on Thu May 13 16:36:42 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Class Members - Related Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • AP4_List : AP4_List< T >::Item
Generated on Thu May 13 16:36:42 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Class Members - Typedefs

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • Mpeg4AudioObjectType : AP4_MpegAudioSampleDescription
  • OTI : AP4_MpegSampleDescription
  • StreamType : AP4_MpegSampleDescription
  • Type : AP4_Atom , AP4_RtpConstructor
Generated on Thu May 13 16:36:42 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Class Members - Variables

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • d
  • e
  • f
  • h
  • i
  • k
  • l
  • m
  • n
  • s
  • v

- _ -

  • _3gppLocalizedStringTypeList : AP4_MetaDataAtomTypeHandler
  • _3gppLocalizedStringTypes : AP4_MetaDataAtomTypeHandler
  • _3gppOtherTypeList : AP4_MetaDataAtomTypeHandler
  • _3gppOtherTypes : AP4_MetaDataAtomTypeHandler

- d -

  • DcfStringTypeList : AP4_MetaDataAtomTypeHandler
  • DcfStringTypes : AP4_MetaDataAtomTypeHandler
  • description : AP4_MetaData::KeyInfo
  • dts : AP4_SttsAtom

- e -

  • entry_index : AP4_CttsAtom , AP4_SttsAtom

- f -

  • four_cc : AP4_MetaData::KeyInfo

- h -

  • hi : AP4_UI64

- i -

  • IlstTypeList : AP4_MetaDataAtomTypeHandler
  • IlstTypes : AP4_MetaDataAtomTypeHandler
  • Instance : AP4_DefaultAtomFactory , AP4_DefaultBlockCipherFactory

- k -

  • KeyInfos : AP4_MetaData

- l -

  • lo : AP4_UI64

- m -

  • m_AllocatedCount : AP4_Array< T >
  • m_AvgBitrate : AP4_MpegSampleDescription
  • m_BlockCipherFactory : AP4_PiffEncryptingProcessor
  • m_Buffer : AP4_DataBuffer
  • m_BufferIsLocal : AP4_DataBuffer
  • m_BufferSize : AP4_DataBuffer , AP4_MpegSampleDescription
  • m_ChannelCount : AP4_AudioSampleDescription , AP4_AudioSampleEntry
  • m_Children : AP4_AtomParent
  • m_Chunk : AP4_SyntheticSampleTable
  • m_ChunkCount : AP4_StscTableEntry
  • m_Cipher : AP4_PiffCtrSampleEncrypter , AP4_PiffCbcSampleEncrypter , AP4_PiffCbcSampleDecrypter
  • m_CipherMode : AP4_PiffEncryptingProcessor
  • m_ClassId : AP4_Expandable
  • m_ClassIdSize : AP4_Expandable
  • m_CompressorName : AP4_VideoSampleDescription , AP4_VisualSampleEntry
  • m_CtsDelta : AP4_Sample
  • m_Data : AP4_ImmediateRtpConstructor , AP4_UnknownUuidAtom
  • m_DataReferenceIndex : AP4_SampleEntry
  • m_DataSize : AP4_DataBuffer
  • m_DataStream : AP4_Sample
  • m_DecoderInfo : AP4_MpegSampleDescription
  • m_Delegate : AP4_FileByteStream
  • m_Depth : AP4_VideoSampleDescription , AP4_VisualSampleEntry
  • m_DescriptionIndex : AP4_Sample
  • m_Descriptors : AP4_DescriptorUpdateCommand
  • m_Details : AP4_SampleDescription
  • m_Dts : AP4_Sample
  • m_Duration : AP4_Sample
  • m_Encrypters : AP4_PiffEncryptingProcessor
  • m_Error : AP4_Exception
  • m_ExternalTrackData : AP4_Processor
  • m_ExtraData : AP4_RtpSampleData
  • m_FirstChunk : AP4_StscTableEntry
  • m_FirstSample : AP4_StscTableEntry
  • m_Flags : AP4_Atom
  • m_Format : AP4_SampleDescription , AP4_MpegSampleDescription
  • m_FrameCount : AP4_VisualSampleEntry
  • m_Head : AP4_List< T >
  • m_HeaderSize : AP4_Expandable
  • m_Height : AP4_VideoSampleDescription , AP4_VisualSampleEntry
  • m_HighestCompatibleVersion : AP4_RtpHintSampleEntry
  • m_HintTrackVersion : AP4_RtpHintSampleEntry
  • m_HorizResolution : AP4_VisualSampleEntry
  • m_IsFull : AP4_Atom
  • m_IsSync : AP4_Sample
  • m_ItemCount : AP4_Array< T > , AP4_List< T >
  • m_Items : AP4_Array< T >
  • m_Iv : AP4_PiffSampleEncrypter
  • m_IvLength : AP4_OmaDcfSampleDecrypter
  • m_Key : AP4_MetaData::Entry
  • m_KeyIndicatorLength : AP4_OmaDcfSampleDecrypter
  • m_KeyMap : AP4_PiffEncryptingProcessor
  • m_Language : AP4_MetaData::Value
  • m_Length : AP4_SampleRtpConstructor , AP4_SampleDescRtpConstructor
  • m_MaxBitrate : AP4_MpegSampleDescription
  • m_MaxPacketSize : AP4_RtpHintSampleEntry
  • m_Meaning : AP4_MetaData::Value
  • m_MediaData : AP4_Processor::ExternalTrackData
  • m_MediaRate : AP4_ElstEntry
  • m_MediaTime : AP4_ElstEntry
  • m_MoofOffset : AP4_TfraAtom::Entry
  • m_MovieTimeScale : AP4_Track
  • m_ObjectDescriptorId : AP4_ObjectDescriptor
  • m_ObjectTypeId : AP4_MpegSampleDescription
  • m_Offset : AP4_Sample
  • m_Packets : AP4_RtpSampleData
  • m_Parent : AP4_Atom
  • m_Payload : AP4_UnknownSampleEntry
  • m_PayloadSize : AP4_Expandable
  • m_Predefined1 : AP4_VisualSampleEntry
  • m_Predefined2 : AP4_VisualSampleEntry
  • m_Predefined3 : AP4_VisualSampleEntry
  • m_PropertyMap : AP4_PiffEncryptingProcessor
  • m_QtCompressionId : AP4_AudioSampleEntry
  • m_QtPacketSize : AP4_AudioSampleEntry
  • m_QtRevision : AP4_AudioSampleEntry
  • m_QtV1BytesPerFrame : AP4_AudioSampleEntry
  • m_QtV1BytesPerPacket : AP4_AudioSampleEntry
  • m_QtV1BytesPerSample : AP4_AudioSampleEntry
  • m_QtV1SamplesPerPacket : AP4_AudioSampleEntry
  • m_QtV2BitsPerChannel : AP4_AudioSampleEntry
  • m_QtV2BytesPerAudioPacket : AP4_AudioSampleEntry
  • m_QtV2ChannelCount : AP4_AudioSampleEntry
  • m_QtV2Extension : AP4_AudioSampleEntry
  • m_QtV2FormatSpecificFlags : AP4_AudioSampleEntry
  • m_QtV2LPCMFramesPerAudioPacket : AP4_AudioSampleEntry
  • m_QtV2Reserved : AP4_AudioSampleEntry
  • m_QtV2SampleRate64 : AP4_AudioSampleEntry
  • m_QtV2StructSize : AP4_AudioSampleEntry
  • m_QtVendor : AP4_AudioSampleEntry
  • m_QtVersion : AP4_AudioSampleEntry
  • m_ReferenceCount : AP4_RtpConstructor
  • m_Reserved1 : AP4_SampleEntry
  • m_Reserved2 : AP4_VisualSampleEntry
  • m_Reserved3 : AP4_VisualSampleEntry
  • m_Salt : AP4_OmaDcfSampleEncrypter
  • m_Sample : AP4_SyntheticSampleTable
  • m_SampleCount : AP4_CttsTableEntry , AP4_SttsTableEntry
  • m_SampleDescIndex : AP4_SampleDescRtpConstructor
  • m_SampleDescOffset : AP4_SampleDescRtpConstructor
  • m_SampleDescriptionIndex : AP4_StscTableEntry
  • m_SampleDuration : AP4_SttsTableEntry
  • m_SampleEncrypter : AP4_PiffEncryptingProcessor::Encrypter
  • m_SampleEncryptionAtom : AP4_PiffSampleDecrypter
  • m_SampleIndex : AP4_PiffSampleDecrypter
  • m_SampleNum : AP4_SampleRtpConstructor
  • m_SampleNumber : AP4_TfraAtom::Entry
  • m_SampleOffset : AP4_SampleRtpConstructor , AP4_CttsTableEntry
  • m_SampleRate : AP4_AudioSampleEntry , AP4_AudioSampleDescription
  • m_SampleSize : AP4_AudioSampleEntry , AP4_AudioSampleDescription
  • m_SamplesPerChunk : AP4_StscTableEntry
  • m_SampleTable : AP4_Track
  • m_SampleTableIsOwned : AP4_Track
  • m_SchiAtom : AP4_ProtectionSchemeInfo
  • m_SegmentDuration : AP4_ElstEntry
  • m_SelectiveEncryption : AP4_OmaDcfSampleDecrypter
  • m_Sinf : AP4_MarlinIpmpParser::SinfEntry
  • m_Size : AP4_MetaDataAtomTypeHandler::TypeList , AP4_Sample
  • m_Size32 : AP4_Atom
  • m_Size64 : AP4_Atom
  • m_StreamId : AP4_Mpeg2TsWriter::SampleStream
  • m_StreamType : AP4_Mpeg2TsWriter::SampleStream , AP4_MpegSampleDescription
  • m_SubDescriptors : AP4_ObjectDescriptor
  • m_Tail : AP4_List< T >
  • m_Time : AP4_TfraAtom::Entry
  • m_TimeScale : AP4_Mpeg2TsWriter::SampleStream
  • m_TrackId
: AP4_MarlinIpmpParser::SinfEntry
, AP4_PiffEncryptingProcessor::Encrypter
, AP4_Processor::ExternalTrackData
  • m_TrackRefIndex : AP4_SampleDescRtpConstructor , AP4_SampleRtpConstructor
  • m_TrafNumber : AP4_TfraAtom::Entry
  • m_TrakAtom : AP4_Track
  • m_TrakAtomIsOwned : AP4_Track
  • m_TrunNumber : AP4_TfraAtom::Entry
  • m_Type : AP4_RtpConstructor , AP4_SampleDescription , AP4_Atom , AP4_MetaData::Value , AP4_Track
  • m_Types : AP4_MetaDataAtomTypeHandler::TypeList
  • m_Url : AP4_ObjectDescriptor
  • m_UrlFlag : AP4_ObjectDescriptor
  • m_Uuid : AP4_UuidAtom
  • m_Value : AP4_MetaData::Entry
  • m_Verbosity : AP4_AtomInspector
  • m_Version : AP4_Atom
  • m_VertResolution : AP4_VisualSampleEntry
  • m_Width : AP4_VisualSampleEntry , AP4_VideoSampleDescription

- n -

  • name : AP4_MetaData::KeyInfo

- s -

  • sample : AP4_CttsAtom , AP4_SttsAtom
  • sample_composition_time_offset : AP4_TrunAtom::Entry
  • sample_duration : AP4_TrunAtom::Entry
  • sample_flags : AP4_TrunAtom::Entry
  • sample_size : AP4_TrunAtom::Entry

- v -

  • value_type : AP4_MetaData::KeyInfo
Generated on Thu May 13 16:36:42 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: File Index

  • File List
  • File Members

File List

Here is a list of all files with brief descriptions:
Ap4.h [code] | Top Level include file
Ap48bdlAtom.h [code] |
Ap4AesBlockCipher.h [code] |
Ap4Array.h [code] | Arrays
Ap4Atom.h [code] | Atoms
Ap4AtomFactory.h [code] |
Ap4AtomSampleTable.h [code] |
Ap4AvccAtom.h [code] |
Ap4ByteStream.h [code] |
Ap4Co64Atom.h [code] |
Ap4Command.h [code] |
Ap4CommandFactory.h [code] |
Ap4Config.h [code] | Platform Configuration
Ap4Constants.h [code] |
Ap4ContainerAtom.h [code] |
Ap4CttsAtom.h [code] |
Ap4DataBuffer.h [code] |
Ap4Debug.h [code] |
Ap4DecoderConfigDescriptor.h [code] |
Ap4DecoderSpecificInfoDescriptor.h [code] |
Ap4Descriptor.h [code] |
Ap4DescriptorFactory.h [code] |
Ap4DrefAtom.h [code] |
Ap4DynamicCast.h [code] | Dynamic Cast Support
Ap4ElstAtom.h [code] |
Ap4EsDescriptor.h [code] |
Ap4EsdsAtom.h [code] |
Ap4Expandable.h [code] |
Ap4File.h [code] |
Ap4FileByteStream.h [code] |
Ap4FileCopier.h [code] |
Ap4FileWriter.h [code] |
Ap4FragmentSampleTable.h [code] |
Ap4FrmaAtom.h [code] |
Ap4FtypAtom.h [code] |
Ap4GrpiAtom.h [code] |
Ap4HdlrAtom.h [code] |
Ap4HintTrackReader.h [code] |
Ap4Hmac.h [code] |
Ap4HmhdAtom.h [code] |
Ap4IkmsAtom.h [code] |
Ap4Interfaces.h [code] |
Ap4IodsAtom.h [code] |
Ap4Ipmp.h [code] |
Ap4IproAtom.h [code] |
Ap4IsfmAtom.h [code] |
Ap4IsltAtom.h [code] |
Ap4IsmaCryp.h [code] |
Ap4KeyWrap.h [code] |
Ap4LinearReader.h [code] |
Ap4List.h [code] |
Ap4Marlin.h [code] |
Ap4MdhdAtom.h [code] |
Ap4MehdAtom.h [code] |
Ap4MetaData.h [code] |
Ap4MfhdAtom.h [code] |
Ap4MfroAtom.h [code] |
Ap4MoovAtom.h [code] |
Ap4Movie.h [code] |
Ap4MovieFragment.h [code] |
Ap4Mpeg2Ts.h [code] |
Ap4MvhdAtom.h [code] |
Ap4NmhdAtom.h [code] |
Ap4ObjectDescriptor.h [code] |
Ap4OdafAtom.h [code] |
Ap4OddaAtom.h [code] |
Ap4OdheAtom.h [code] |
Ap4OhdrAtom.h [code] |
Ap4OmaDcf.h [code] |
Ap4Piff.h [code] |
Ap4Processor.h [code] |
Ap4Protection.h [code] |
Ap4Results.h [code] |
Ap4RtpAtom.h [code] |
Ap4RtpHint.h [code] |
Ap4Sample.h [code] |
Ap4SampleDescription.h [code] |
Ap4SampleEntry.h [code] |
Ap4SampleSource.h [code] |
Ap4SampleTable.h [code] |
Ap4SchmAtom.h [code] |
Ap4SdpAtom.h [code] |
Ap4SLConfigDescriptor.h [code] |
Ap4SmhdAtom.h [code] |
Ap4StcoAtom.h [code] |
Ap4StreamCipher.h [code] |
Ap4String.h [code] |
Ap4StscAtom.h [code] |
Ap4StsdAtom.h [code] |
Ap4StssAtom.h [code] |
Ap4StszAtom.h [code] |
Ap4SttsAtom.h [code] |
Ap4SyntheticSampleTable.h [code] |
Ap4TfhdAtom.h [code] |
Ap4TfraAtom.h [code] |
Ap4TimsAtom.h [code] |
Ap4TkhdAtom.h [code] |
Ap4Track.h [code] |
Ap4TrakAtom.h [code] |
Ap4TrefTypeAtom.h [code] |
Ap4TrexAtom.h [code] |
Ap4TrunAtom.h [code] |
Ap4Types.h [code] |
Ap4UrlAtom.h [code] |
Ap4Utils.h [code] |
Ap4UuidAtom.h [code] | UUID Atoms
Ap4Version.h [code] |
Ap4VmhdAtom.h [code] |
Generated on Thu May 13 16:38:12 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4.h File Reference

  • File List
  • File Members

Ap4.h File Reference

Top Level include file. More...

#include "Ap4Config.h"
#include "Ap4Config.h"
#include <assert.h>
#include "Ap4Types.h"
#include "Ap4Results.h"
#include <stdio.h>
#include <string.h>
#include "Ap4List.h"
#include "Ap4ByteStream.h"
#include "Ap4Debug.h"
#include "Ap4DynamicCast.h"
#include "Ap4Atom.h"
#include <new>
#include "Ap4Track.h"
#include "Ap4Array.h"
#include "Ap4AtomFactory.h"
#include "Ap4File.h"
#include "Ap4Sample.h"
#include "Ap4MetaData.h"
#include "Ap4String.h"
#include "Ap4DataBuffer.h"
#include "Ap4Descriptor.h"
#include "Ap4ContainerAtom.h"
#include "Ap4SampleTable.h"
#include "Ap4EsDescriptor.h"
#include "Ap4EsdsAtom.h"
#include "Ap4MoovAtom.h"
#include "Ap4MvhdAtom.h"
#include "Ap4SampleEntry.h"
#include "Ap4SampleDescription.h"
#include "Ap4Processor.h"
#include "Ap4Protection.h"
#include "Ap4OmaDcf.h"
#include "Ap4AvccAtom.h"
#include "Ap4TrefTypeAtom.h"
#include "Ap4Expandable.h"
#include "Ap4Command.h"
#include "Ap4Movie.h"
#include "Ap4UuidAtom.h"

Go to the source code of this file.

Detailed Description

Top Level include file.

Applications should only need to include that file, as it will include all the more specific include files required to use the API

Definition in file Ap4.h.

Generated on Thu May 13 16:36:34 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4.h Source File

  • File List
  • File Members

Ap4.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - Main Header
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027  ****************************************************************/
00220 #ifndef _AP4_H_
00221 #define _AP4_H_
00222
00223 /*----------------------------------------------------------------------
00224 |   includes
00225 +---------------------------------------------------------------------*/
00226 #include "Ap4Config.h"
00227 #include "Ap4Version.h"
00228 #include "Ap4Types.h"
00229 #include "Ap4Constants.h"
00230 #include "Ap4Results.h"
00231 #include "Ap4Debug.h"
00232 #include "Ap4Utils.h"
00233 #include "Ap4DynamicCast.h"
00234 #include "Ap4FileByteStream.h"
00235 #include "Ap4Movie.h"
00236 #include "Ap4Track.h"
00237 #include "Ap4File.h"
00238 #include "Ap4FileWriter.h"
00239 #include "Ap4FileCopier.h"
00240 #include "Ap4HintTrackReader.h"
00241 #include "Ap4Processor.h"
00242 #include "Ap4MetaData.h"
00243 #include "Ap4AtomFactory.h"
00244 #include "Ap4SampleEntry.h"
00245 #include "Ap4Sample.h"
00246 #include "Ap4DataBuffer.h"
00247 #include "Ap4SampleTable.h"
00248 #include "Ap4SyntheticSampleTable.h"
00249 #include "Ap4AtomSampleTable.h"
00250 #include "Ap4FragmentSampleTable.h"
00251 #include "Ap4UrlAtom.h"
00252 #include "Ap4MoovAtom.h"
00253 #include "Ap4MvhdAtom.h"
00254 #include "Ap4MehdAtom.h"
00255 #include "Ap4TrakAtom.h"
00256 #include "Ap4TrexAtom.h"
00257 #include "Ap4HdlrAtom.h"
00258 #include "Ap4DrefAtom.h"
00259 #include "Ap4TkhdAtom.h"
00260 #include "Ap4MdhdAtom.h"
00261 #include "Ap4StsdAtom.h"
00262 #include "Ap4StscAtom.h"
00263 #include "Ap4StcoAtom.h"
00264 #include "Ap4StszAtom.h"
00265 #include "Ap4EsdsAtom.h"
00266 #include "Ap4SttsAtom.h"
00267 #include "Ap4CttsAtom.h"
00268 #include "Ap4StssAtom.h"
00269 #include "Ap4FtypAtom.h"
00270 #include "Ap4VmhdAtom.h"
00271 #include "Ap4SmhdAtom.h"
00272 #include "Ap4NmhdAtom.h"
00273 #include "Ap4HmhdAtom.h"
00274 #include "Ap4SchmAtom.h"
00275 #include "Ap4FrmaAtom.h"
00276 #include "Ap4TimsAtom.h"
00277 #include "Ap4RtpAtom.h"
00278 #include "Ap4SdpAtom.h"
00279 #include "Ap4IkmsAtom.h"
00280 #include "Ap4IsfmAtom.h"
00281 #include "Ap4IsltAtom.h"
00282 #include "Ap4TrefTypeAtom.h"
00283 #include "Ap4OmaDcf.h"
00284 #include "Ap4IsmaCryp.h"
00285 #include "Ap4OdafAtom.h"
00286 #include "Ap4OhdrAtom.h"
00287 #include "Ap4OdheAtom.h"
00288 #include "Ap4OddaAtom.h"
00289 #include "Ap4AvccAtom.h"
00290 #include "Ap4Marlin.h"
00291 #include "Ap4GrpiAtom.h"
00292 #include "Ap48bdlAtom.h"
00293 #include "Ap4MovieFragment.h"
00294 #include "Ap4LinearReader.h"
00295 #include "Ap4TfhdAtom.h"
00296 #include "Ap4SampleSource.h"
00297 #include "Ap4Mpeg2Ts.h"
00298 #include "Ap4Piff.h"
00299
00300 #endif // _AP4_H_
Generated on Thu May 13 16:36:31 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap48bdlAtom.h File Reference

  • File List
  • File Members

Ap48bdlAtom.h File Reference

#include "Ap4DataBuffer.h"
#include "Ap4Atom.h"
#include "Ap4DynamicCast.h"

Go to the source code of this file.

Classes

class | AP4_8bdlAtom

Variables

const AP4_UI32 | AP4_8BDL_XML_DATA_ENCODING = AP4_ATOM_TYPE('x','m','l',' ')

Variable Documentation

const AP4_UI32 AP4_8BDL_XML_DATA_ENCODING = AP4_ATOM_TYPE('x','m','l',' ')

Definition at line 42 of file Ap48bdlAtom.h.

Generated on Thu May 13 16:36:35 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap48bdlAtom.h Source File

  • File List
  • File Members

Ap48bdlAtom.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - 8bdl Atoms
00004 |
00005 |    Copyright 2002-2009 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027  ****************************************************************/
00028
00029  #ifndef _AP4_8BDL_ATOM_H_
00030  #define _AP4_8BDL_ATOM_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4DataBuffer.h"
00036 #include "Ap4Atom.h"
00037 #include "Ap4DynamicCast.h"
00038
00039 /*----------------------------------------------------------------------
00040 |   constants
00041 +---------------------------------------------------------------------*/
00042 const AP4_UI32 AP4_8BDL_XML_DATA_ENCODING = AP4_ATOM_TYPE('x','m','l',' ');
00043
00044 /*----------------------------------------------------------------------
00045 |   AP4_8bdlAtom
00046 +---------------------------------------------------------------------*/
00047 class AP4_8bdlAtom : public AP4_Atom
00048 {
00049 public:
00050     AP4_IMPLEMENT_DYNAMIC_CAST_D(AP4_8bdlAtom, AP4_Atom)
00051
00052     // virtual constructor
00053     static AP4_8bdlAtom* Create(AP4_Size size, AP4_ByteStream& stream);
00054
00055     // constructors
00056     AP4_8bdlAtom(AP4_UI32        encoding,
00057                  AP4_UI32        encoding_version,
00058                  const AP4_Byte* data,
00059                  AP4_Size        data_size);
00060
00061     // methods
00062     virtual AP4_Result InspectFields(AP4_AtomInspector& inspector);
00063     virtual AP4_Result WriteFields(AP4_ByteStream& stream);
00064
00065     // accessors
00066     AP4_UI32              GetEncoding()        { return m_Encoding; }
00067     AP4_UI32              GetEncodingVersion() { return m_EncodingVersion; }
00068     const AP4_DataBuffer& GetBundleData()      { return m_BundleData; }
00069
00070 private:
00071     // methods
00072     AP4_8bdlAtom(AP4_Size        size,
00073                  AP4_ByteStream& stream);
00074
00075     // members
00076     AP4_UI32       m_Encoding;
00077     AP4_UI32       m_EncodingVersion;
00078     AP4_DataBuffer m_BundleData;
00079 };
00080
00081 #endif // _AP4_8BDL_ATOM_H_
Generated on Thu May 13 16:36:31 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4AesBlockCipher.h File Reference

  • File List
  • File Members

Ap4AesBlockCipher.h File Reference

#include "Ap4Types.h"
#include "Ap4Config.h"
#include "Ap4Protection.h"

Go to the source code of this file.

Classes

class | AP4_AesBlockCipher

Defines

#define | AP4_AES_BLOCK_SIZE 16
#define | AP4_AES_KEY_LENGTH 16

Define Documentation

#define AP4_AES_BLOCK_SIZE 16

Definition at line 54 of file Ap4AesBlockCipher.h.

#define AP4_AES_KEY_LENGTH 16

Definition at line 55 of file Ap4AesBlockCipher.h.

Generated on Thu May 13 16:36:35 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4AesBlockCipher.h Source File

  • File List
  • File Members

Ap4AesBlockCipher.h

Go to the documentation of this file.
00001 /*
00002  * AES Block cipher
00003  * (c) 2005-2008 Axiomatic Systems, LLC
00004  * Portions (c) 2001, Dr Brian Gladman (see below)
00005  */
00006
00007 /*
00008  -------------------------------------------------------------------------
00009  Copyright (c) 2001, Dr Brian Gladman <brg@gladman.me.uk>, Worcester, UK.
00010  All rights reserved.
00011
00012  LICENSE TERMS
00013
00014  The free distribution and use of this software in both source and binary
00015  form is allowed (with or without changes) provided that:
00016
00017    1. distributions of this source code include the above copyright
00018       notice, this list of conditions and the following disclaimer;
00019
00020    2. distributions in binary form include the above copyright
00021       notice, this list of conditions and the following disclaimer
00022       in the documentation and/or other associated materials;
00023
00024    3. the copyright holder's name is not used to endorse products
00025       built using this software without specific written permission.
00026
00027  DISCLAIMER
00028
00029  This software is provided 'as is' with no explicit or implied warranties
00030  in respect of its properties, including, but not limited to, correctness
00031  and fitness for purpose.
00032  -------------------------------------------------------------------------
00033  Issue Date: 29/07/2002
00034 */
00035
00036 #ifndef _AP4_AES_BLOCK_CIPHER_H_
00037 #define _AP4_AES_BLOCK_CIPHER_H_
00038
00039 /*----------------------------------------------------------------------
00040 |   includes
00041 +---------------------------------------------------------------------*/
00042 #include "Ap4Types.h"
00043 #include "Ap4Config.h"
00044 #include "Ap4Protection.h"
00045
00046 /*----------------------------------------------------------------------
00047 |   class references
00048 +---------------------------------------------------------------------*/
00049 struct aes_ctx;
00050
00051 /*----------------------------------------------------------------------
00052 |   AES constants
00053 +---------------------------------------------------------------------*/
00054 #define AP4_AES_BLOCK_SIZE  16
00055 #define AP4_AES_KEY_LENGTH  16
00056
00057 /*----------------------------------------------------------------------
00058 |   AP4_AesBlockCipher class
00059 +---------------------------------------------------------------------*/
00060 class AP4_AesBlockCipher : public AP4_BlockCipher
00061 {
00062 public:
00063     // constructor and destructor
00064     AP4_AesBlockCipher(const AP4_UI08*                  key,
00065                        AP4_BlockCipher::CipherDirection direction);
00066    ~AP4_AesBlockCipher();
00067
00068    // AP4_AesBlockCipher methods
00069    virtual AP4_Result ProcessBlock(const AP4_UI08* input,
00070                                    AP4_UI08*       output);
00071
00072 private:
00073     // members
00074     CipherDirection m_Direction;
00075     aes_ctx*        m_Context;
00076 };
00077
00078 #endif // _AP4_AES_BLOCK_CIPHER_H_
Generated on Thu May 13 16:36:31 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4Array.h File Reference

  • File List
  • File Members

Ap4Array.h File Reference

Arrays. More...

#include "Ap4Config.h"
#include "Ap4Types.h"
#include "Ap4Results.h"

Go to the source code of this file.

Classes

class | AP4_Array< T >

Variables

const int | AP4_ARRAY_INITIAL_COUNT = 64

Detailed Description

Arrays.

Definition in file Ap4Array.h.

Variable Documentation

const int AP4_ARRAY_INITIAL_COUNT = 64

Definition at line 49 of file Ap4Array.h.

Referenced by AP4_Array< T >::Append().

Generated on Thu May 13 16:36:35 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4Array.h Source File

  • File List
  • File Members

Ap4Array.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - Arrays
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027  ****************************************************************/
00033 #ifndef _AP4_ARRAY_H_
00034 #define _AP4_ARRAY_H_
00035
00036 /*----------------------------------------------------------------------
00037 |   includes
00038 +---------------------------------------------------------------------*/
00039 #include "Ap4Config.h"
00040 #if defined(APT_CONFIG_HAVE_NEW_H)
00041 #include <new>
00042 #endif
00043 #include "Ap4Types.h"
00044 #include "Ap4Results.h"
00045
00046 /*----------------------------------------------------------------------
00047 |   constants
00048 +---------------------------------------------------------------------*/
00049 const int AP4_ARRAY_INITIAL_COUNT = 64;
00050
00051 /*----------------------------------------------------------------------
00052 |   AP4_Array
00053 +---------------------------------------------------------------------*/
00054 template <typename T>
00055 class AP4_Array
00056 {
00057 public:
00058     // methods
00059              AP4_Array(): m_AllocatedCount(0), m_ItemCount(0), m_Items(0) {}
00060              AP4_Array(const T* items, AP4_Size count);
00061     virtual ~AP4_Array();
00062     AP4_Cardinal ItemCount() const { return m_ItemCount; }
00063     AP4_Result   Append(const T& item);
00064     AP4_Result   RemoveLast();
00065     T& operator[](unsigned long idx) { return m_Items[idx]; }
00066     const T& operator[](unsigned long idx) const { return m_Items[idx]; }
00067     AP4_Result Clear();
00068     AP4_Result EnsureCapacity(AP4_Cardinal count);
00069     AP4_Result SetItemCount(AP4_Cardinal item_count);
00070
00071 protected:
00072     // members
00073     AP4_Cardinal m_AllocatedCount;
00074     AP4_Cardinal m_ItemCount;
00075     T*           m_Items;
00076 };
00077
00078 /*----------------------------------------------------------------------
00079 |   AP4_Array<T>::AP4_Array<T>
00080 +---------------------------------------------------------------------*/
00081 template <typename T>
00082 AP4_Array<T>::AP4_Array(const T* items, AP4_Size count) :
00083     m_AllocatedCount(count),
00084     m_ItemCount(count),
00085     m_Items((T*)::operator new(count*sizeof(T)))
00086 {
00087     for (unsigned int i=0; i<count; i++) {
00088         new ((void*)&m_Items[i]) T(items[i]);
00089     }
00090 }
00091
00092 /*----------------------------------------------------------------------
00093 |   AP4_Array<T>::~AP4_Array<T>
00094 +---------------------------------------------------------------------*/
00095 template <typename T>
00096 AP4_Array<T>::~AP4_Array()
00097 {
00098     Clear();
00099     ::operator delete((void*)m_Items);
00100 }
00101
00102 /*----------------------------------------------------------------------
00103 |   NPT_Array<T>::Clear
00104 +---------------------------------------------------------------------*/
00105 template <typename T>
00106 AP4_Result
00107 AP4_Array<T>::Clear()
00108 {
00109     // destroy all items
00110     for (AP4_Ordinal i=0; i<m_ItemCount; i++) {
00111         m_Items[i].~T();
00112     }
00113
00114     m_ItemCount = 0;
00115
00116     return AP4_SUCCESS;
00117 }
00118
00119 /*----------------------------------------------------------------------
00120 |   AP4_Array<T>::EnsureCapacity
00121 +---------------------------------------------------------------------*/
00122 template <typename T>
00123 AP4_Result
00124 AP4_Array<T>::EnsureCapacity(AP4_Cardinal count)
00125 {
00126     // check if we already have enough
00127     if (count <= m_AllocatedCount) return AP4_SUCCESS;
00128
00129     // (re)allocate the items
00130     T* new_items = (T*) ::operator new (count*sizeof(T));
00131     if (new_items == NULL) {
00132         return AP4_ERROR_OUT_OF_MEMORY;
00133     }
00134     if (m_ItemCount && m_Items) {
00135         for (unsigned int i=0; i<m_ItemCount; i++) {
00136             new ((void*)&new_items[i]) T(m_Items[i]);
00137             m_Items[i].~T();
00138         }
00139         ::operator delete((void*)m_Items);
00140     }
00141     m_Items = new_items;
00142     m_AllocatedCount = count;
00143
00144     return AP4_SUCCESS;
00145 }
00146
00147 /*----------------------------------------------------------------------
00148 |   AP4_Array<T>::SetItemCount
00149 +---------------------------------------------------------------------*/
00150 template <typename T>
00151 AP4_Result
00152 AP4_Array<T>::SetItemCount(AP4_Cardinal item_count)
00153 {
00154     // shortcut
00155     if (item_count == m_ItemCount) return AP4_SUCCESS;
00156
00157     // check for a reduction in the number of items
00158     if (item_count < m_ItemCount) {
00159         // destruct the items that are no longer needed
00160         for (unsigned int i=item_count; i<m_ItemCount; i++) {
00161             m_Items[i].~T();
00162         }
00163         m_ItemCount = item_count;
00164         return AP4_SUCCESS;
00165     }
00166
00167     // grow the list
00168     AP4_Result result = EnsureCapacity(item_count);
00169     if (AP4_FAILED(result)) return result;
00170
00171     // construct the new items
00172     for (unsigned int i=m_ItemCount; i<item_count; i++) {
00173         new ((void*)&m_Items[i]) T();
00174     }
00175     m_ItemCount = item_count;
00176     return AP4_SUCCESS;
00177 }
00178
00179 /*----------------------------------------------------------------------
00180 |   AP4_Array<T>::RemoveLast
00181 +---------------------------------------------------------------------*/
00182 template <typename T>
00183 AP4_Result
00184 AP4_Array<T>::RemoveLast()
00185 {
00186     if (m_ItemCount) {
00187         m_Items[--m_ItemCount].~T();
00188         return AP4_SUCCESS;
00189     } else {
00190         return AP4_ERROR_OUT_OF_RANGE;
00191     }
00192 }
00193
00194 /*----------------------------------------------------------------------
00195 |   AP4_Array<T>::Append
00196 +---------------------------------------------------------------------*/
00197 template <typename T>
00198 AP4_Result
00199 AP4_Array<T>::Append(const T& item)
00200 {
00201     // ensure that we have enough space
00202     if (m_AllocatedCount < m_ItemCount+1) {
00203         // try double the size, with a minimum
00204         unsigned long new_count = m_AllocatedCount?2*m_AllocatedCount:AP4_ARRAY_INITIAL_COUNT;
00205
00206         // if that's still not enough, just ask for what we need
00207         if (new_count < m_ItemCount+1) new_count = m_ItemCount+1;
00208
00209         // reserve the space
00210         AP4_Result result = EnsureCapacity(new_count);
00211         if (result != AP4_SUCCESS) return result;
00212     }
00213
00214     // store the item
00215     new ((void*)&m_Items[m_ItemCount++]) T(item);
00216
00217     return AP4_SUCCESS;
00218 }
00219
00220 #endif // _AP4_ARRAY_H_
00221
00222
00223
00224
00225
00226
00227
00228
00229
00230
00231
00232
00233
Generated on Thu May 13 16:36:31 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4Atom.h File Reference

  • File List
  • File Members

Ap4Atom.h File Reference

Atoms. More...

#include "Ap4Types.h"
#include "Ap4List.h"
#include "Ap4ByteStream.h"
#include "Ap4String.h"
#include "Ap4Debug.h"
#include "Ap4DynamicCast.h"

Go to the source code of this file.

Classes

class | AP4_AtomInspector
Class used in a visitor pattern to walk all the atoms in a tree of AP4_Atom objects. More...
class | AP4_PrintInspector
class | AP4_Atom
Abstract base class for all atom types. More...
class | AP4_AtomParent
Base class for containers of atoms. More...
class | AP4_UnknownAtom
Class that represents atoms for which there is no specific support. More...
class | AP4_NullTerminatedStringAtom
Generic Class usd for all atoms that contain a single null-terminated string. More...
class | AP4_AtomListInspector
class | AP4_AtomListWriter
class | AP4_AtomFinder
class | AP4_AtomSizeAdder

Defines

#define | AP4_ATOM_TYPE(c1, c2, c3, c4)

Variables

const AP4_UI32 | AP4_ATOM_HEADER_SIZE = 8
const AP4_UI32 | AP4_ATOM_HEADER_SIZE_64 = 16
const AP4_UI32 | AP4_FULL_ATOM_HEADER_SIZE = 12
const AP4_UI32 | AP4_FULL_ATOM_HEADER_SIZE_64 = 20
const AP4_UI32 | AP4_ATOM_MAX_NAME_SIZE = 256
const AP4_UI32 | AP4_ATOM_MAX_URI_SIZE = 512
const AP4_Atom::Type | AP4_ATOM_TYPE_UDTA = AP4_ATOM_TYPE('u','d','t','a')
const AP4_Atom::Type | AP4_ATOM_TYPE_URL = AP4_ATOM_TYPE('u','r','l',' ')
const AP4_Atom::Type | AP4_ATOM_TYPE_TRAK = AP4_ATOM_TYPE('t','r','a','k')
const AP4_Atom::Type | AP4_ATOM_TYPE_TRAF = AP4_ATOM_TYPE('t','r','a','f')
const AP4_Atom::Type | AP4_ATOM_TYPE_TKHD = AP4_ATOM_TYPE('t','k','h','d')
const AP4_Atom::Type | AP4_ATOM_TYPE_TFHD = AP4_ATOM_TYPE('t','f','h','d')
const AP4_Atom::Type | AP4_ATOM_TYPE_TRUN = AP4_ATOM_TYPE('t','r','u','n')
const AP4_Atom::Type | AP4_ATOM_TYPE_STTS = AP4_ATOM_TYPE('s','t','t','s')
const AP4_Atom::Type | AP4_ATOM_TYPE_STSZ = AP4_ATOM_TYPE('s','t','s','z')
const AP4_Atom::Type | AP4_ATOM_TYPE_STSS = AP4_ATOM_TYPE('s','t','s','s')
const AP4_Atom::Type | AP4_ATOM_TYPE_STSD = AP4_ATOM_TYPE('s','t','s','d')
const AP4_Atom::Type | AP4_ATOM_TYPE_STSC = AP4_ATOM_TYPE('s','t','s','c')
const AP4_Atom::Type | AP4_ATOM_TYPE_STCO = AP4_ATOM_TYPE('s','t','c','o')
const AP4_Atom::Type | AP4_ATOM_TYPE_CO64 = AP4_ATOM_TYPE('c','o','6','4')
const AP4_Atom::Type | AP4_ATOM_TYPE_STBL = AP4_ATOM_TYPE('s','t','b','l')
const AP4_Atom::Type | AP4_ATOM_TYPE_SINF = AP4_ATOM_TYPE('s','i','n','f')
const AP4_Atom::Type | AP4_ATOM_TYPE_SCHM = AP4_ATOM_TYPE('s','c','h','m')
const AP4_Atom::Type | AP4_ATOM_TYPE_SCHI = AP4_ATOM_TYPE('s','c','h','i')
const AP4_Atom::Type | AP4_ATOM_TYPE_MVHD = AP4_ATOM_TYPE('m','v','h','d')
const AP4_Atom::Type | AP4_ATOM_TYPE_MEHD = AP4_ATOM_TYPE('m','e','h','d')
const AP4_Atom::Type | AP4_ATOM_TYPE_MP4S = AP4_ATOM_TYPE('m','p','4','s')
const AP4_Atom::Type | AP4_ATOM_TYPE_MP4A = AP4_ATOM_TYPE('m','p','4','a')
const AP4_Atom::Type | AP4_ATOM_TYPE_MP4V = AP4_ATOM_TYPE('m','p','4','v')
const AP4_Atom::Type | AP4_ATOM_TYPE_AVC1 = AP4_ATOM_TYPE('a','v','c','1')
const AP4_Atom::Type | AP4_ATOM_TYPE_ALAC = AP4_ATOM_TYPE('a','l','a','c')
const AP4_Atom::Type | AP4_ATOM_TYPE_ENCA = AP4_ATOM_TYPE('e','n','c','a')
const AP4_Atom::Type | AP4_ATOM_TYPE_ENCV = AP4_ATOM_TYPE('e','n','c','v')
const AP4_Atom::Type | AP4_ATOM_TYPE_MOOV = AP4_ATOM_TYPE('m','o','o','v')
const AP4_Atom::Type | AP4_ATOM_TYPE_MOOF = AP4_ATOM_TYPE('m','o','o','f')
const AP4_Atom::Type | AP4_ATOM_TYPE_MVEX = AP4_ATOM_TYPE('m','v','e','x')
const AP4_Atom::Type | AP4_ATOM_TYPE_TREX = AP4_ATOM_TYPE('t','r','e','x')
const AP4_Atom::Type | AP4_ATOM_TYPE_MINF = AP4_ATOM_TYPE('m','i','n','f')
const AP4_Atom::Type | AP4_ATOM_TYPE_META = AP4_ATOM_TYPE('m','e','t','a')
const AP4_Atom::Type | AP4_ATOM_TYPE_MDHD = AP4_ATOM_TYPE('m','d','h','d')
const AP4_Atom::Type | AP4_ATOM_TYPE_MFHD = AP4_ATOM_TYPE('m','f','h','d')
const AP4_Atom::Type | AP4_ATOM_TYPE_ILST = AP4_ATOM_TYPE('i','l','s','t')
const AP4_Atom::Type | AP4_ATOM_TYPE_HDLR = AP4_ATOM_TYPE('h','d','l','r')
const AP4_Atom::Type | AP4_ATOM_TYPE_FTYP = AP4_ATOM_TYPE('f','t','y','p')
const AP4_Atom::Type | AP4_ATOM_TYPE_IODS = AP4_ATOM_TYPE('i','o','d','s')
const AP4_Atom::Type | AP4_ATOM_TYPE_ESDS = AP4_ATOM_TYPE('e','s','d','s')
const AP4_Atom::Type | AP4_ATOM_TYPE_EDTS = AP4_ATOM_TYPE('e','d','t','s')
const AP4_Atom::Type | AP4_ATOM_TYPE_DRMS = AP4_ATOM_TYPE('d','r','m','s')
const AP4_Atom::Type | AP4_ATOM_TYPE_DRMI = AP4_ATOM_TYPE('d','r','m','i')
const AP4_Atom::Type | AP4_ATOM_TYPE_DREF = AP4_ATOM_TYPE('d','r','e','f')
const AP4_Atom::Type | AP4_ATOM_TYPE_DINF = AP4_ATOM_TYPE('d','i','n','f')
const AP4_Atom::Type | AP4_ATOM_TYPE_CTTS = AP4_ATOM_TYPE('c','t','t','s')
const AP4_Atom::Type | AP4_ATOM_TYPE_MDIA = AP4_ATOM_TYPE('m','d','i','a')
const AP4_Atom::Type | AP4_ATOM_TYPE_ELST = AP4_ATOM_TYPE('e','l','s','t')
const AP4_Atom::Type | AP4_ATOM_TYPE_VMHD = AP4_ATOM_TYPE('v','m','h','d')
const AP4_Atom::Type | AP4_ATOM_TYPE_SMHD = AP4_ATOM_TYPE('s','m','h','d')
const AP4_Atom::Type | AP4_ATOM_TYPE_NMHD = AP4_ATOM_TYPE('n','m','h','d')
const AP4_Atom::Type | AP4_ATOM_TYPE_HMHD = AP4_ATOM_TYPE('h','m','h','d')
const AP4_Atom::Type | AP4_ATOM_TYPE_FRMA = AP4_ATOM_TYPE('f','r','m','a')
const AP4_Atom::Type | AP4_ATOM_TYPE_MDAT = AP4_ATOM_TYPE('m','d','a','t')
const AP4_Atom::Type | AP4_ATOM_TYPE_FREE = AP4_ATOM_TYPE('f','r','e','e')
const AP4_Atom::Type | AP4_ATOM_TYPE_TIMS = AP4_ATOM_TYPE('t','i','m','s')
const AP4_Atom::Type | AP4_ATOM_TYPE_RTP_ = AP4_ATOM_TYPE('r','t','p',' ')
const AP4_Atom::Type | AP4_ATOM_TYPE_HNTI = AP4_ATOM_TYPE('h','n','t','i')
const AP4_Atom::Type | AP4_ATOM_TYPE_SDP_ = AP4_ATOM_TYPE('s','d','p',' ')
const AP4_Atom::Type | AP4_ATOM_TYPE_IKMS = AP4_ATOM_TYPE('i','K','M','S')
const AP4_Atom::Type | AP4_ATOM_TYPE_ISFM = AP4_ATOM_TYPE('i','S','F','M')
const AP4_Atom::Type | AP4_ATOM_TYPE_ISLT = AP4_ATOM_TYPE('i','S','L','T')
const AP4_Atom::Type | AP4_ATOM_TYPE_TREF = AP4_ATOM_TYPE('t','r','e','f')
const AP4_Atom::Type | AP4_ATOM_TYPE_HINT = AP4_ATOM_TYPE('h','i','n','t')
const AP4_Atom::Type | AP4_ATOM_TYPE_CDSC = AP4_ATOM_TYPE('c','d','s','c')
const AP4_Atom::Type | AP4_ATOM_TYPE_MPOD = AP4_ATOM_TYPE('m','p','o','d')
const AP4_Atom::Type | AP4_ATOM_TYPE_IPIR = AP4_ATOM_TYPE('i','p','i','r')
const AP4_Atom::Type | AP4_ATOM_TYPE_CHAP = AP4_ATOM_TYPE('c','h','a','p')
const AP4_Atom::Type | AP4_ATOM_TYPE_ALIS = AP4_ATOM_TYPE('a','l','i','s')
const AP4_Atom::Type | AP4_ATOM_TYPE_SYNC = AP4_ATOM_TYPE('s','y','n','c')
const AP4_Atom::Type | AP4_ATOM_TYPE_DPND = AP4_ATOM_TYPE('d','p','n','d')
const AP4_Atom::Type | AP4_ATOM_TYPE_ODRM = AP4_ATOM_TYPE('o','d','r','m')
const AP4_Atom::Type | AP4_ATOM_TYPE_ODKM = AP4_ATOM_TYPE('o','d','k','m')
const AP4_Atom::Type | AP4_ATOM_TYPE_OHDR = AP4_ATOM_TYPE('o','h','d','r')
const AP4_Atom::Type | AP4_ATOM_TYPE_ODDA = AP4_ATOM_TYPE('o','d','d','a')
const AP4_Atom::Type | AP4_ATOM_TYPE_ODHE = AP4_ATOM_TYPE('o','d','h','e')
const AP4_Atom::Type | AP4_ATOM_TYPE_ODAF = AP4_ATOM_TYPE('o','d','a','f')
const AP4_Atom::Type | AP4_ATOM_TYPE_GRPI = AP4_ATOM_TYPE('g','r','p','i')
const AP4_Atom::Type | AP4_ATOM_TYPE_IPRO = AP4_ATOM_TYPE('i','p','r','o')
const AP4_Atom::Type | AP4_ATOM_TYPE_MDRI = AP4_ATOM_TYPE('m','d','r','i')
const AP4_Atom::Type | AP4_ATOM_TYPE_AVCC = AP4_ATOM_TYPE('a','v','c','C')
const AP4_Atom::Type | AP4_ATOM_TYPE_WAVE = AP4_ATOM_TYPE('w','a','v','e')
const AP4_Atom::Type | AP4_ATOM_TYPE_WIDE = AP4_ATOM_TYPE('w','i','d','e')
const AP4_Atom::Type | AP4_ATOM_TYPE_UUID = AP4_ATOM_TYPE('u','u','i','d')
const AP4_Atom::Type | AP4_ATOM_TYPE_8ID_ = AP4_ATOM_TYPE('8','i','d',' ')
const AP4_Atom::Type | AP4_ATOM_TYPE_8BDL = AP4_ATOM_TYPE('8','b','d','l')
const AP4_Atom::Type | AP4_ATOM_TYPE_AC_3 = AP4_ATOM_TYPE('a','c','-','3')
const AP4_Atom::Type | AP4_ATOM_TYPE_EC_3 = AP4_ATOM_TYPE('e','c','-','3')
const AP4_Atom::Type | AP4_ATOM_TYPE_MFRA = AP4_ATOM_TYPE('m','f','r','a')
const AP4_Atom::Type | AP4_ATOM_TYPE_TFRA = AP4_ATOM_TYPE('t','f','r','a')
const AP4_Atom::Type | AP4_ATOM_TYPE_MFRO = AP4_ATOM_TYPE('m','f','r','o')

Detailed Description

Atoms.

Definition in file Ap4Atom.h.

Define Documentation

#define AP4_ATOM_TYPE | ( | c1,
 |  | c2,
 |  | c3,
 |  | c4 | )
Value:
((((AP4_UI32)c1)<<24) |  \
    (((AP4_UI32)c2)<<16) |  \
    (((AP4_UI32)c3)<< 8) |  \
    (((AP4_UI32)c4)    ))

Definition at line 49 of file Ap4Atom.h.

Variable Documentation

const AP4_UI32 AP4_ATOM_HEADER_SIZE = 8

Definition at line 58 of file Ap4Atom.h.

Referenced by AP4_IsltAtom::Create().

const AP4_UI32 AP4_ATOM_HEADER_SIZE_64 = 16

Definition at line 59 of file Ap4Atom.h.

const AP4_UI32 AP4_ATOM_MAX_NAME_SIZE = 256

Definition at line 62 of file Ap4Atom.h.

const AP4_UI32 AP4_ATOM_MAX_URI_SIZE = 512

Definition at line 63 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_8BDL = AP4_ATOM_TYPE('8','b','d','l')

Definition at line 427 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_8ID_ = AP4_ATOM_TYPE('8','i','d',' ')

Definition at line 426 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_AC_3 = AP4_ATOM_TYPE('a','c','-','3')

Definition at line 428 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_ALAC = AP4_ATOM_TYPE('a','l','a','c')

Definition at line 366 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_ALIS = AP4_ATOM_TYPE('a','l','i','s')

Definition at line 410 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_AVC1 = AP4_ATOM_TYPE('a','v','c','1')

Definition at line 365 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_AVCC = AP4_ATOM_TYPE('a','v','c','C')

Definition at line 422 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_CDSC = AP4_ATOM_TYPE('c','d','s','c')

Definition at line 406 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_CHAP = AP4_ATOM_TYPE('c','h','a','p')

Definition at line 409 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_CO64 = AP4_ATOM_TYPE('c','o','6','4')

Definition at line 355 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_CTTS = AP4_ATOM_TYPE('c','t','t','s')

Definition at line 387 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_DINF = AP4_ATOM_TYPE('d','i','n','f')

Definition at line 386 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_DPND = AP4_ATOM_TYPE('d','p','n','d')

Definition at line 412 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_DREF = AP4_ATOM_TYPE('d','r','e','f')

Definition at line 385 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_DRMI = AP4_ATOM_TYPE('d','r','m','i')

Definition at line 384 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_DRMS = AP4_ATOM_TYPE('d','r','m','s')

Definition at line 383 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_EC_3 = AP4_ATOM_TYPE('e','c','-','3')

Definition at line 429 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_EDTS = AP4_ATOM_TYPE('e','d','t','s')

Definition at line 382 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_ELST = AP4_ATOM_TYPE('e','l','s','t')

Definition at line 389 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_ENCA = AP4_ATOM_TYPE('e','n','c','a')

Definition at line 367 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_ENCV = AP4_ATOM_TYPE('e','n','c','v')

Definition at line 368 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_ESDS = AP4_ATOM_TYPE('e','s','d','s')

Definition at line 381 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_FREE = AP4_ATOM_TYPE('f','r','e','e')

Definition at line 396 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_FRMA = AP4_ATOM_TYPE('f','r','m','a')

Definition at line 394 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_FTYP = AP4_ATOM_TYPE('f','t','y','p')

Definition at line 379 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_GRPI = AP4_ATOM_TYPE('g','r','p','i')

Definition at line 419 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_HDLR = AP4_ATOM_TYPE('h','d','l','r')

Definition at line 378 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_HINT = AP4_ATOM_TYPE('h','i','n','t')

Definition at line 405 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_HMHD = AP4_ATOM_TYPE('h','m','h','d')

Definition at line 393 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_HNTI = AP4_ATOM_TYPE('h','n','t','i')

Definition at line 399 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_IKMS = AP4_ATOM_TYPE('i','K','M','S')

Definition at line 401 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_ILST = AP4_ATOM_TYPE('i','l','s','t')

Definition at line 377 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_IODS = AP4_ATOM_TYPE('i','o','d','s')

Definition at line 380 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_IPIR = AP4_ATOM_TYPE('i','p','i','r')

Definition at line 408 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_IPRO = AP4_ATOM_TYPE('i','p','r','o')

Definition at line 420 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_ISFM = AP4_ATOM_TYPE('i','S','F','M')

Definition at line 402 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_ISLT = AP4_ATOM_TYPE('i','S','L','T')

Definition at line 403 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_MDAT = AP4_ATOM_TYPE('m','d','a','t')

Definition at line 395 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_MDHD = AP4_ATOM_TYPE('m','d','h','d')

Definition at line 375 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_MDIA = AP4_ATOM_TYPE('m','d','i','a')

Definition at line 388 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_MDRI = AP4_ATOM_TYPE('m','d','r','i')

Definition at line 421 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_MEHD = AP4_ATOM_TYPE('m','e','h','d')

Definition at line 361 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_META = AP4_ATOM_TYPE('m','e','t','a')

Definition at line 374 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_MFHD = AP4_ATOM_TYPE('m','f','h','d')

Definition at line 376 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_MFRA = AP4_ATOM_TYPE('m','f','r','a')

Definition at line 430 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_MFRO = AP4_ATOM_TYPE('m','f','r','o')

Definition at line 432 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_MINF = AP4_ATOM_TYPE('m','i','n','f')

Definition at line 373 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_MOOF = AP4_ATOM_TYPE('m','o','o','f')

Definition at line 370 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_MOOV = AP4_ATOM_TYPE('m','o','o','v')

Definition at line 369 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_MP4A = AP4_ATOM_TYPE('m','p','4','a')

Definition at line 363 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_MP4S = AP4_ATOM_TYPE('m','p','4','s')

Definition at line 362 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_MP4V = AP4_ATOM_TYPE('m','p','4','v')

Definition at line 364 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_MPOD = AP4_ATOM_TYPE('m','p','o','d')

Definition at line 407 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_MVEX = AP4_ATOM_TYPE('m','v','e','x')

Definition at line 371 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_MVHD = AP4_ATOM_TYPE('m','v','h','d')

Definition at line 360 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_NMHD = AP4_ATOM_TYPE('n','m','h','d')

Definition at line 392 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_ODAF = AP4_ATOM_TYPE('o','d','a','f')

Definition at line 418 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_ODDA = AP4_ATOM_TYPE('o','d','d','a')

Definition at line 416 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_ODHE = AP4_ATOM_TYPE('o','d','h','e')

Definition at line 417 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_ODKM = AP4_ATOM_TYPE('o','d','k','m')

Definition at line 414 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_ODRM = AP4_ATOM_TYPE('o','d','r','m')

Definition at line 413 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_OHDR = AP4_ATOM_TYPE('o','h','d','r')

Definition at line 415 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_RTP_ = AP4_ATOM_TYPE('r','t','p',' ')

Definition at line 398 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_SCHI = AP4_ATOM_TYPE('s','c','h','i')

Definition at line 359 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_SCHM = AP4_ATOM_TYPE('s','c','h','m')

Definition at line 358 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_SDP_ = AP4_ATOM_TYPE('s','d','p',' ')

Definition at line 400 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_SINF = AP4_ATOM_TYPE('s','i','n','f')

Definition at line 357 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_SMHD = AP4_ATOM_TYPE('s','m','h','d')

Definition at line 391 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_STBL = AP4_ATOM_TYPE('s','t','b','l')

Definition at line 356 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_STCO = AP4_ATOM_TYPE('s','t','c','o')

Definition at line 354 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_STSC = AP4_ATOM_TYPE('s','t','s','c')

Definition at line 353 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_STSD = AP4_ATOM_TYPE('s','t','s','d')

Definition at line 352 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_STSS = AP4_ATOM_TYPE('s','t','s','s')

Definition at line 351 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_STSZ = AP4_ATOM_TYPE('s','t','s','z')

Definition at line 350 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_STTS = AP4_ATOM_TYPE('s','t','t','s')

Definition at line 349 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_SYNC = AP4_ATOM_TYPE('s','y','n','c')

Definition at line 411 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_TFHD = AP4_ATOM_TYPE('t','f','h','d')

Definition at line 347 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_TFRA = AP4_ATOM_TYPE('t','f','r','a')

Definition at line 431 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_TIMS = AP4_ATOM_TYPE('t','i','m','s')

Definition at line 397 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_TKHD = AP4_ATOM_TYPE('t','k','h','d')

Definition at line 346 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_TRAF = AP4_ATOM_TYPE('t','r','a','f')

Definition at line 345 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_TRAK = AP4_ATOM_TYPE('t','r','a','k')

Definition at line 344 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_TREF = AP4_ATOM_TYPE('t','r','e','f')

Definition at line 404 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_TREX = AP4_ATOM_TYPE('t','r','e','x')

Definition at line 372 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_TRUN = AP4_ATOM_TYPE('t','r','u','n')

Definition at line 348 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_UDTA = AP4_ATOM_TYPE('u','d','t','a')

Definition at line 342 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_URL = AP4_ATOM_TYPE('u','r','l',' ')

Definition at line 343 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_UUID = AP4_ATOM_TYPE('u','u','i','d')

Definition at line 425 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_VMHD = AP4_ATOM_TYPE('v','m','h','d')

Definition at line 390 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_WAVE = AP4_ATOM_TYPE('w','a','v','e')

Definition at line 423 of file Ap4Atom.h.

const AP4_Atom::Type AP4_ATOM_TYPE_WIDE = AP4_ATOM_TYPE('w','i','d','e')

Definition at line 424 of file Ap4Atom.h.

const AP4_UI32 AP4_FULL_ATOM_HEADER_SIZE = 12

Definition at line 60 of file Ap4Atom.h.

const AP4_UI32 AP4_FULL_ATOM_HEADER_SIZE_64 = 20

Definition at line 61 of file Ap4Atom.h.

Generated on Thu May 13 16:36:35 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4Atom.h Source File

  • File List
  • File Members

Ap4Atom.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - Atoms
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027  ****************************************************************/
00033 #ifndef _AP4_ATOM_H_
00034 #define _AP4_ATOM_H_
00035
00036 /*----------------------------------------------------------------------
00037 |   includes
00038 +---------------------------------------------------------------------*/
00039 #include "Ap4Types.h"
00040 #include "Ap4List.h"
00041 #include "Ap4ByteStream.h"
00042 #include "Ap4String.h"
00043 #include "Ap4Debug.h"
00044 #include "Ap4DynamicCast.h"
00045
00046 /*----------------------------------------------------------------------
00047 |   macros
00048 +---------------------------------------------------------------------*/
00049 #define AP4_ATOM_TYPE(c1,c2,c3,c4)  \
00050    ((((AP4_UI32)c1)<<24) |  \
00051     (((AP4_UI32)c2)<<16) |  \
00052     (((AP4_UI32)c3)<< 8) |  \
00053     (((AP4_UI32)c4)    ))
00054
00055 /*----------------------------------------------------------------------
00056 |   constants
00057 +---------------------------------------------------------------------*/
00058 const AP4_UI32 AP4_ATOM_HEADER_SIZE         = 8;
00059 const AP4_UI32 AP4_ATOM_HEADER_SIZE_64      = 16;
00060 const AP4_UI32 AP4_FULL_ATOM_HEADER_SIZE    = 12;
00061 const AP4_UI32 AP4_FULL_ATOM_HEADER_SIZE_64 = 20;
00062 const AP4_UI32 AP4_ATOM_MAX_NAME_SIZE       = 256;
00063 const AP4_UI32 AP4_ATOM_MAX_URI_SIZE        = 512;
00064
00065 /*----------------------------------------------------------------------
00066 |   forward references
00067 +---------------------------------------------------------------------*/
00068 class AP4_AtomParent;
00069
00070 /*----------------------------------------------------------------------
00071 |   AP4_AtomInspector
00072 +---------------------------------------------------------------------*/
00077 class AP4_AtomInspector {
00078 public:
00079     // types
00080     typedef enum {
00081         HINT_NONE       = 0,
00082         HINT_HEX        = 1,
00083         HINT_BOOLEAN    = 2
00084     } FormatHint;
00085
00086     // constructor and destructor
00087     AP4_AtomInspector() {}
00088     virtual ~AP4_AtomInspector() {}
00089
00090     // methods
00091     void        SetVerbosity(AP4_Ordinal verbosity) { m_Verbosity = verbosity; }
00092     AP4_Ordinal GetVerbosity()                      { return m_Verbosity;      }
00093
00094     // virtual methods
00095     virtual void StartElement(const char* /* name */,
00096                               const char* /* extra = NULL */) {}
00097     virtual void EndElement() {}
00098     virtual void AddField(const char* /* name */,
00099                           AP4_UI64    /* value */,
00100                           FormatHint  hint = HINT_NONE) {
00101         (void)hint; // gcc warning
00102     }
00103     virtual void AddFieldF(const char* /* name */,
00104                            float       /* value */,
00105                            FormatHint  hint = HINT_NONE) {
00106         (void)hint; // gcc warning
00107     }
00108     virtual void AddField(const char* /* name */,
00109                           const char* /* value */,
00110                           FormatHint  hint = HINT_NONE) {
00111         (void)hint; // gcc warning
00112     }
00113     virtual void AddField(const char*          /* name */,
00114                           const unsigned char* /* bytes */,
00115                           AP4_Size             /* byte_count */,
00116                           FormatHint           hint = HINT_NONE) {
00117         (void)hint; // gcc warning
00118     }
00119
00120 protected:
00121     AP4_Ordinal m_Verbosity;
00122 };
00123
00124 /*----------------------------------------------------------------------
00125 |   AP4_PrintInspector
00126 +---------------------------------------------------------------------*/
00127 class AP4_PrintInspector : public AP4_AtomInspector {
00128 public:
00129     AP4_PrintInspector(AP4_ByteStream& stream, AP4_Cardinal indent=0);
00130     ~AP4_PrintInspector();
00131
00132     // methods
00133     void StartElement(const char* name, const char* info);
00134     void EndElement();
00135     void AddField(const char* name, AP4_UI64 value, FormatHint hint);
00136     void AddFieldF(const char* name, float value, FormatHint hint);
00137     void AddField(const char* name, const char* value, FormatHint hint);
00138     void AddField(const char* name, const unsigned char* bytes, AP4_Size size, FormatHint hint);
00139
00140 private:
00141     // members
00142     AP4_ByteStream* m_Stream;
00143     AP4_Cardinal    m_Indent;
00144 };
00145
00146 /*----------------------------------------------------------------------
00147 |   AP4_Atom
00148 +---------------------------------------------------------------------*/
00152 class AP4_Atom {
00153 public:
00154      AP4_IMPLEMENT_DYNAMIC_CAST(AP4_Atom)
00155
00156    // types
00157     typedef AP4_UI32 Type;
00158
00159     // class methods
00160     static Type TypeFromString(const char* four_cc);
00161     static AP4_Result ReadFullHeader(AP4_ByteStream& stream,
00162                                      AP4_UI32&       version,
00163                                      AP4_UI32&       flags);
00164
00165     // constructors
00169     explicit AP4_Atom(Type type, AP4_UI32 size = AP4_ATOM_HEADER_SIZE);
00170
00174     explicit AP4_Atom(Type type, AP4_UI64 size, bool force_64=false);
00175
00179     explicit AP4_Atom(Type     type,
00180                       AP4_UI32 size,
00181                       AP4_UI32 version,
00182                       AP4_UI32 flags);
00183
00187     explicit AP4_Atom(Type     type,
00188                       AP4_UI64 size,
00189                       bool     force_64,
00190                       AP4_UI32 version,
00191                       AP4_UI32 flags);
00192
00193     // destructor
00194     virtual ~AP4_Atom() {}
00195
00196     // methods
00197     AP4_UI32           GetFlags() const { return m_Flags; }
00198     void               SetFlags(AP4_UI32 flags) { m_Flags = flags; }
00199     Type               GetType() const { return m_Type; }
00200     void               SetType(Type type) { m_Type = type; }
00201     virtual AP4_Size   GetHeaderSize() const;
00202     AP4_UI64           GetSize() const { return m_Size32 == 1?m_Size64:m_Size32; }
00203     void               SetSize(AP4_UI64 size, bool force_64 = false);
00204     AP4_UI32           GetSize32() const { return m_Size32; }
00205     void               SetSize32(AP4_UI32 size) { m_Size32 = size; }
00206     AP4_UI64           GetSize64() const { return m_Size64; }
00207     void               SetSize64(AP4_UI64 size) { m_Size64 = size; }
00208     virtual AP4_Result Write(AP4_ByteStream& stream);
00209     virtual AP4_Result WriteHeader(AP4_ByteStream& stream);
00210     virtual AP4_Result WriteFields(AP4_ByteStream& stream) = 0;
00211     virtual AP4_Result Inspect(AP4_AtomInspector& inspector);
00212     virtual AP4_Result InspectHeader(AP4_AtomInspector& inspector);
00213     virtual AP4_Result InspectFields(AP4_AtomInspector& /* inspector */) {
00214         return AP4_SUCCESS;
00215     }
00216
00217     // parent/child relationship methods
00218     virtual AP4_Result SetParent(AP4_AtomParent* parent) {
00219         m_Parent = parent;
00220         return AP4_SUCCESS;
00221     }
00222     virtual AP4_AtomParent* GetParent() { return m_Parent; }
00223     virtual AP4_Result      Detach();
00224
00232     virtual AP4_Atom* Clone();
00233
00234  protected:
00235     // members
00236     Type            m_Type;
00237     AP4_UI32        m_Size32;
00238     AP4_UI64        m_Size64; // this is 0 if m_Size is not 1 (encoded in 32-bits)
00239                               // and non-zero only if m_Size is 1 (encoded in 64-bits)
00240     bool            m_IsFull;
00241     AP4_UI32        m_Version;
00242     AP4_UI32        m_Flags;
00243     AP4_AtomParent* m_Parent;
00244 };
00245
00246 /*----------------------------------------------------------------------
00247 |   AP4_AtomParent
00248 +---------------------------------------------------------------------*/
00253 class AP4_AtomParent {
00254 public:
00255     AP4_IMPLEMENT_DYNAMIC_CAST(AP4_AtomParent)
00256
00257     // base methods
00258     virtual ~AP4_AtomParent();
00259     AP4_List<AP4_Atom>& GetChildren() { return m_Children; }
00260     virtual AP4_Result  AddChild(AP4_Atom* child, int position = -1);
00261     virtual AP4_Result  RemoveChild(AP4_Atom* child);
00262     virtual AP4_Result  DeleteChild(AP4_Atom::Type type, AP4_Ordinal index = 0);
00263     virtual AP4_Atom*   GetChild(AP4_Atom::Type type, AP4_Ordinal index = 0) const;
00264     virtual AP4_Atom*   GetChild(const AP4_UI08* uuid, AP4_Ordinal index = 0) const;
00265     virtual AP4_Atom*   FindChild(const char* path,
00266                                   bool        auto_create = false,
00267                                   bool        auto_create_full = false);
00268
00269     // methods designed to be overridden
00270     virtual void OnChildChanged(AP4_Atom* /* child */) {}
00271     virtual void OnChildAdded(AP4_Atom* /* child */)   {}
00272     virtual void OnChildRemoved(AP4_Atom* /* child */) {}
00273
00274 protected:
00275     // members
00276     AP4_List<AP4_Atom> m_Children;
00277 };
00278
00279 /*----------------------------------------------------------------------
00280 |   AP4_UnknownAtom
00281 +---------------------------------------------------------------------*/
00290 class AP4_UnknownAtom : public AP4_Atom {
00291 public:
00292     // constructor and destructor
00293     AP4_UnknownAtom(AP4_Atom::Type   type,
00294                     AP4_UI64         size,
00295                     AP4_ByteStream&  stream);
00296     AP4_UnknownAtom(AP4_Atom::Type type, const AP4_UI08* payload, AP4_Size payload_size);
00297     AP4_UnknownAtom(const AP4_UnknownAtom& other);
00298     ~AP4_UnknownAtom();
00299
00300     // methods
00301     virtual AP4_Result WriteFields(AP4_ByteStream& stream);
00302     virtual AP4_Atom*  Clone();
00303
00304 private:
00305     // members
00306     AP4_ByteStream* m_SourceStream;
00307     AP4_Position    m_SourcePosition;
00308     AP4_DataBuffer  m_Payload;
00309 };
00310
00311 /*----------------------------------------------------------------------
00312 |   AP4_NullTerminatedStringAtom
00313 +---------------------------------------------------------------------*/
00318 class AP4_NullTerminatedStringAtom : public AP4_Atom
00319 {
00320 public:
00321     AP4_IMPLEMENT_DYNAMIC_CAST_D(AP4_NullTerminatedStringAtom, AP4_Atom)
00322
00323     // constructors
00324     AP4_NullTerminatedStringAtom(AP4_Atom::Type type, AP4_UI64 size, AP4_ByteStream& stream);
00325     AP4_NullTerminatedStringAtom(AP4_Atom::Type type, const char* value);
00326
00327     // accessors
00328     const AP4_String& GetValue() { return m_Value; }
00329
00330     // methods
00331     virtual AP4_Result InspectFields(AP4_AtomInspector& inspector);
00332     virtual AP4_Result WriteFields(AP4_ByteStream& stream);
00333
00334 private:
00335     // members
00336     AP4_String m_Value;
00337 };
00338
00339 /*----------------------------------------------------------------------
00340 |   atom types
00341 +---------------------------------------------------------------------*/
00342 const AP4_Atom::Type AP4_ATOM_TYPE_UDTA = AP4_ATOM_TYPE('u','d','t','a');
00343 const AP4_Atom::Type AP4_ATOM_TYPE_URL  = AP4_ATOM_TYPE('u','r','l',' ');
00344 const AP4_Atom::Type AP4_ATOM_TYPE_TRAK = AP4_ATOM_TYPE('t','r','a','k');
00345 const AP4_Atom::Type AP4_ATOM_TYPE_TRAF = AP4_ATOM_TYPE('t','r','a','f');
00346 const AP4_Atom::Type AP4_ATOM_TYPE_TKHD = AP4_ATOM_TYPE('t','k','h','d');
00347 const AP4_Atom::Type AP4_ATOM_TYPE_TFHD = AP4_ATOM_TYPE('t','f','h','d');
00348 const AP4_Atom::Type AP4_ATOM_TYPE_TRUN = AP4_ATOM_TYPE('t','r','u','n');
00349 const AP4_Atom::Type AP4_ATOM_TYPE_STTS = AP4_ATOM_TYPE('s','t','t','s');
00350 const AP4_Atom::Type AP4_ATOM_TYPE_STSZ = AP4_ATOM_TYPE('s','t','s','z');
00351 const AP4_Atom::Type AP4_ATOM_TYPE_STSS = AP4_ATOM_TYPE('s','t','s','s');
00352 const AP4_Atom::Type AP4_ATOM_TYPE_STSD = AP4_ATOM_TYPE('s','t','s','d');
00353 const AP4_Atom::Type AP4_ATOM_TYPE_STSC = AP4_ATOM_TYPE('s','t','s','c');
00354 const AP4_Atom::Type AP4_ATOM_TYPE_STCO = AP4_ATOM_TYPE('s','t','c','o');
00355 const AP4_Atom::Type AP4_ATOM_TYPE_CO64 = AP4_ATOM_TYPE('c','o','6','4');
00356 const AP4_Atom::Type AP4_ATOM_TYPE_STBL = AP4_ATOM_TYPE('s','t','b','l');
00357 const AP4_Atom::Type AP4_ATOM_TYPE_SINF = AP4_ATOM_TYPE('s','i','n','f');
00358 const AP4_Atom::Type AP4_ATOM_TYPE_SCHM = AP4_ATOM_TYPE('s','c','h','m');
00359 const AP4_Atom::Type AP4_ATOM_TYPE_SCHI = AP4_ATOM_TYPE('s','c','h','i');
00360 const AP4_Atom::Type AP4_ATOM_TYPE_MVHD = AP4_ATOM_TYPE('m','v','h','d');
00361 const AP4_Atom::Type AP4_ATOM_TYPE_MEHD = AP4_ATOM_TYPE('m','e','h','d');
00362 const AP4_Atom::Type AP4_ATOM_TYPE_MP4S = AP4_ATOM_TYPE('m','p','4','s');
00363 const AP4_Atom::Type AP4_ATOM_TYPE_MP4A = AP4_ATOM_TYPE('m','p','4','a');
00364 const AP4_Atom::Type AP4_ATOM_TYPE_MP4V = AP4_ATOM_TYPE('m','p','4','v');
00365 const AP4_Atom::Type AP4_ATOM_TYPE_AVC1 = AP4_ATOM_TYPE('a','v','c','1');
00366 const AP4_Atom::Type AP4_ATOM_TYPE_ALAC = AP4_ATOM_TYPE('a','l','a','c');
00367 const AP4_Atom::Type AP4_ATOM_TYPE_ENCA = AP4_ATOM_TYPE('e','n','c','a');
00368 const AP4_Atom::Type AP4_ATOM_TYPE_ENCV = AP4_ATOM_TYPE('e','n','c','v');
00369 const AP4_Atom::Type AP4_ATOM_TYPE_MOOV = AP4_ATOM_TYPE('m','o','o','v');
00370 const AP4_Atom::Type AP4_ATOM_TYPE_MOOF = AP4_ATOM_TYPE('m','o','o','f');
00371 const AP4_Atom::Type AP4_ATOM_TYPE_MVEX = AP4_ATOM_TYPE('m','v','e','x');
00372 const AP4_Atom::Type AP4_ATOM_TYPE_TREX = AP4_ATOM_TYPE('t','r','e','x');
00373 const AP4_Atom::Type AP4_ATOM_TYPE_MINF = AP4_ATOM_TYPE('m','i','n','f');
00374 const AP4_Atom::Type AP4_ATOM_TYPE_META = AP4_ATOM_TYPE('m','e','t','a');
00375 const AP4_Atom::Type AP4_ATOM_TYPE_MDHD = AP4_ATOM_TYPE('m','d','h','d');
00376 const AP4_Atom::Type AP4_ATOM_TYPE_MFHD = AP4_ATOM_TYPE('m','f','h','d');
00377 const AP4_Atom::Type AP4_ATOM_TYPE_ILST = AP4_ATOM_TYPE('i','l','s','t');
00378 const AP4_Atom::Type AP4_ATOM_TYPE_HDLR = AP4_ATOM_TYPE('h','d','l','r');
00379 const AP4_Atom::Type AP4_ATOM_TYPE_FTYP = AP4_ATOM_TYPE('f','t','y','p');
00380 const AP4_Atom::Type AP4_ATOM_TYPE_IODS = AP4_ATOM_TYPE('i','o','d','s');
00381 const AP4_Atom::Type AP4_ATOM_TYPE_ESDS = AP4_ATOM_TYPE('e','s','d','s');
00382 const AP4_Atom::Type AP4_ATOM_TYPE_EDTS = AP4_ATOM_TYPE('e','d','t','s');
00383 const AP4_Atom::Type AP4_ATOM_TYPE_DRMS = AP4_ATOM_TYPE('d','r','m','s');
00384 const AP4_Atom::Type AP4_ATOM_TYPE_DRMI = AP4_ATOM_TYPE('d','r','m','i');
00385 const AP4_Atom::Type AP4_ATOM_TYPE_DREF = AP4_ATOM_TYPE('d','r','e','f');
00386 const AP4_Atom::Type AP4_ATOM_TYPE_DINF = AP4_ATOM_TYPE('d','i','n','f');
00387 const AP4_Atom::Type AP4_ATOM_TYPE_CTTS = AP4_ATOM_TYPE('c','t','t','s');
00388 const AP4_Atom::Type AP4_ATOM_TYPE_MDIA = AP4_ATOM_TYPE('m','d','i','a');
00389 const AP4_Atom::Type AP4_ATOM_TYPE_ELST = AP4_ATOM_TYPE('e','l','s','t');
00390 const AP4_Atom::Type AP4_ATOM_TYPE_VMHD = AP4_ATOM_TYPE('v','m','h','d');
00391 const AP4_Atom::Type AP4_ATOM_TYPE_SMHD = AP4_ATOM_TYPE('s','m','h','d');
00392 const AP4_Atom::Type AP4_ATOM_TYPE_NMHD = AP4_ATOM_TYPE('n','m','h','d');
00393 const AP4_Atom::Type AP4_ATOM_TYPE_HMHD = AP4_ATOM_TYPE('h','m','h','d');
00394 const AP4_Atom::Type AP4_ATOM_TYPE_FRMA = AP4_ATOM_TYPE('f','r','m','a');
00395 const AP4_Atom::Type AP4_ATOM_TYPE_MDAT = AP4_ATOM_TYPE('m','d','a','t');
00396 const AP4_Atom::Type AP4_ATOM_TYPE_FREE = AP4_ATOM_TYPE('f','r','e','e');
00397 const AP4_Atom::Type AP4_ATOM_TYPE_TIMS = AP4_ATOM_TYPE('t','i','m','s');
00398 const AP4_Atom::Type AP4_ATOM_TYPE_RTP_ = AP4_ATOM_TYPE('r','t','p',' ');
00399 const AP4_Atom::Type AP4_ATOM_TYPE_HNTI = AP4_ATOM_TYPE('h','n','t','i');
00400 const AP4_Atom::Type AP4_ATOM_TYPE_SDP_ = AP4_ATOM_TYPE('s','d','p',' ');
00401 const AP4_Atom::Type AP4_ATOM_TYPE_IKMS = AP4_ATOM_TYPE('i','K','M','S');
00402 const AP4_Atom::Type AP4_ATOM_TYPE_ISFM = AP4_ATOM_TYPE('i','S','F','M');
00403 const AP4_Atom::Type AP4_ATOM_TYPE_ISLT = AP4_ATOM_TYPE('i','S','L','T');
00404 const AP4_Atom::Type AP4_ATOM_TYPE_TREF = AP4_ATOM_TYPE('t','r','e','f');
00405 const AP4_Atom::Type AP4_ATOM_TYPE_HINT = AP4_ATOM_TYPE('h','i','n','t');
00406 const AP4_Atom::Type AP4_ATOM_TYPE_CDSC = AP4_ATOM_TYPE('c','d','s','c');
00407 const AP4_Atom::Type AP4_ATOM_TYPE_MPOD = AP4_ATOM_TYPE('m','p','o','d');
00408 const AP4_Atom::Type AP4_ATOM_TYPE_IPIR = AP4_ATOM_TYPE('i','p','i','r');
00409 const AP4_Atom::Type AP4_ATOM_TYPE_CHAP = AP4_ATOM_TYPE('c','h','a','p');
00410 const AP4_Atom::Type AP4_ATOM_TYPE_ALIS = AP4_ATOM_TYPE('a','l','i','s');
00411 const AP4_Atom::Type AP4_ATOM_TYPE_SYNC = AP4_ATOM_TYPE('s','y','n','c');
00412 const AP4_Atom::Type AP4_ATOM_TYPE_DPND = AP4_ATOM_TYPE('d','p','n','d');
00413 const AP4_Atom::Type AP4_ATOM_TYPE_ODRM = AP4_ATOM_TYPE('o','d','r','m');
00414 const AP4_Atom::Type AP4_ATOM_TYPE_ODKM = AP4_ATOM_TYPE('o','d','k','m');
00415 const AP4_Atom::Type AP4_ATOM_TYPE_OHDR = AP4_ATOM_TYPE('o','h','d','r');
00416 const AP4_Atom::Type AP4_ATOM_TYPE_ODDA = AP4_ATOM_TYPE('o','d','d','a');
00417 const AP4_Atom::Type AP4_ATOM_TYPE_ODHE = AP4_ATOM_TYPE('o','d','h','e');
00418 const AP4_Atom::Type AP4_ATOM_TYPE_ODAF = AP4_ATOM_TYPE('o','d','a','f');
00419 const AP4_Atom::Type AP4_ATOM_TYPE_GRPI = AP4_ATOM_TYPE('g','r','p','i');
00420 const AP4_Atom::Type AP4_ATOM_TYPE_IPRO = AP4_ATOM_TYPE('i','p','r','o');
00421 const AP4_Atom::Type AP4_ATOM_TYPE_MDRI = AP4_ATOM_TYPE('m','d','r','i');
00422 const AP4_Atom::Type AP4_ATOM_TYPE_AVCC = AP4_ATOM_TYPE('a','v','c','C');
00423 const AP4_Atom::Type AP4_ATOM_TYPE_WAVE = AP4_ATOM_TYPE('w','a','v','e');
00424 const AP4_Atom::Type AP4_ATOM_TYPE_WIDE = AP4_ATOM_TYPE('w','i','d','e');
00425 const AP4_Atom::Type AP4_ATOM_TYPE_UUID = AP4_ATOM_TYPE('u','u','i','d');
00426 const AP4_Atom::Type AP4_ATOM_TYPE_8ID_ = AP4_ATOM_TYPE('8','i','d',' ');
00427 const AP4_Atom::Type AP4_ATOM_TYPE_8BDL = AP4_ATOM_TYPE('8','b','d','l');
00428 const AP4_Atom::Type AP4_ATOM_TYPE_AC_3 = AP4_ATOM_TYPE('a','c','-','3');
00429 const AP4_Atom::Type AP4_ATOM_TYPE_EC_3 = AP4_ATOM_TYPE('e','c','-','3');
00430 const AP4_Atom::Type AP4_ATOM_TYPE_MFRA = AP4_ATOM_TYPE('m','f','r','a');
00431 const AP4_Atom::Type AP4_ATOM_TYPE_TFRA = AP4_ATOM_TYPE('t','f','r','a');
00432 const AP4_Atom::Type AP4_ATOM_TYPE_MFRO = AP4_ATOM_TYPE('m','f','r','o');
00433
00434 /*----------------------------------------------------------------------
00435 |   AP4_AtomListInspector
00436 +---------------------------------------------------------------------*/
00437 class AP4_AtomListInspector : public AP4_List<AP4_Atom>::Item::Operator
00438 {
00439  public:
00440     AP4_AtomListInspector(AP4_AtomInspector& inspector) :
00441         m_Inspector(inspector) {}
00442     AP4_Result Action(AP4_Atom* atom) const {
00443         atom->Inspect(m_Inspector);
00444         return AP4_SUCCESS;
00445     }
00446
00447  private:
00448     AP4_AtomInspector& m_Inspector;
00449 };
00450
00451 /*----------------------------------------------------------------------
00452 |   AP4_AtomListWriter
00453 +---------------------------------------------------------------------*/
00454 class AP4_AtomListWriter : public AP4_List<AP4_Atom>::Item::Operator
00455 {
00456  public:
00457     AP4_AtomListWriter(AP4_ByteStream& stream) :
00458         m_Stream(stream) {}
00459     AP4_Result Action(AP4_Atom* atom) const;
00460
00461  private:
00462     AP4_ByteStream& m_Stream;
00463 };
00464
00465 /*----------------------------------------------------------------------
00466 |   AP4_AtomFinder
00467 +---------------------------------------------------------------------*/
00468 class AP4_AtomFinder : public AP4_List<AP4_Atom>::Item::Finder
00469 {
00470  public:
00471     AP4_AtomFinder(AP4_Atom::Type type, AP4_Ordinal index = 0) :
00472        m_Type(type), m_Index(index) {}
00473     AP4_Result Test(AP4_Atom* atom) const {
00474         if (atom->GetType() == m_Type) {
00475             if (m_Index-- == 0) {
00476                 return AP4_SUCCESS;
00477             } else {
00478                 return AP4_FAILURE;
00479             }
00480         } else {
00481             return AP4_FAILURE;
00482         }
00483     }
00484  private:
00485     AP4_Atom::Type      m_Type;
00486     mutable AP4_Ordinal m_Index;
00487 };
00488
00489 /*----------------------------------------------------------------------
00490 |   AP4_AtomSizeAdder
00491 +---------------------------------------------------------------------*/
00492 class AP4_AtomSizeAdder : public AP4_List<AP4_Atom>::Item::Operator {
00493 public:
00494     AP4_AtomSizeAdder(AP4_UI64& size) : m_Size(size) {}
00495
00496 private:
00497     AP4_Result Action(AP4_Atom* atom) const {
00498         m_Size += atom->GetSize();
00499         return AP4_SUCCESS;
00500     }
00501     AP4_UI64& m_Size;
00502 };
00503
00504 #endif // _AP4_ATOM_H_
Generated on Thu May 13 16:36:31 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4AtomFactory.h File Reference

  • File List
  • File Members

Ap4AtomFactory.h File Reference

#include "Ap4Types.h"
#include "Ap4Atom.h"
#include "Ap4Array.h"

Go to the source code of this file.

Classes

class | AP4_AtomFactory
class | AP4_AtomFactory::TypeHandler
class | AP4_DefaultAtomFactory
Generated on Thu May 13 16:36:35 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4AtomFactory.h Source File

  • File List
  • File Members

Ap4AtomFactory.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - Atom Factory
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027  ****************************************************************/
00028
00029 #ifndef _AP4_ATOM_FACTORY_H_
00030 #define _AP4_ATOM_FACTORY_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Types.h"
00036 #include "Ap4Atom.h"
00037 #include "Ap4Array.h"
00038
00039 /*----------------------------------------------------------------------
00040 |   class references
00041 +---------------------------------------------------------------------*/
00042 class AP4_ByteStream;
00043
00044 /*----------------------------------------------------------------------
00045 |   AP4_AtomFactory
00046 +---------------------------------------------------------------------*/
00047 class AP4_AtomFactory {
00048  public:
00049     // types
00050      class TypeHandler {
00051      public:
00052          virtual ~TypeHandler() {};
00053          virtual AP4_Result CreateAtom(AP4_Atom::Type  type,
00054                                        AP4_UI32        size,
00055                                        AP4_ByteStream& stream,
00056                                        AP4_Atom::Type  context,
00057                                        AP4_Atom*&      atom) = 0;
00058     };
00059
00060     // constructor
00061     AP4_AtomFactory() {}
00062
00063     // destructor
00064     virtual ~AP4_AtomFactory();
00065
00066     // methods
00067     AP4_Result AddTypeHandler(TypeHandler* handler);
00068     AP4_Result RemoveTypeHandler(TypeHandler* handler);
00069     AP4_Result CreateAtomFromStream(AP4_ByteStream& stream,
00070                                     AP4_LargeSize&  bytes_available,
00071                                     AP4_Atom*&      atom);
00072     virtual AP4_Result CreateAtomFromStream(AP4_ByteStream& stream,
00073                                             AP4_UI32        type,
00074                                             AP4_UI32        size_32,
00075                                             AP4_UI64        size_64,
00076                                             AP4_Atom*&      atom);
00077     AP4_Result CreateAtomFromStream(AP4_ByteStream&  stream,
00078                                     AP4_Atom*&       atom);
00079     AP4_Result CreateAtomsFromStream(AP4_ByteStream& stream,
00080                                      AP4_AtomParent& atoms);
00081     AP4_Result CreateAtomsFromStream(AP4_ByteStream& stream,
00082                                      AP4_LargeSize   bytes_available,
00083                                      AP4_AtomParent& atoms);
00084
00085     // context
00086     void PushContext(AP4_Atom::Type context);
00087     void PopContext();
00088     AP4_Atom::Type GetContext(AP4_Ordinal depth=0);
00089
00090 private:
00091     // members
00092     AP4_Array<AP4_Atom::Type> m_ContextStack;
00093     AP4_List<TypeHandler>     m_TypeHandlers;
00094 };
00095
00096 /*----------------------------------------------------------------------
00097 |   AP4_DefaultAtomFactory
00098 +---------------------------------------------------------------------*/
00099 class AP4_DefaultAtomFactory : public AP4_AtomFactory {
00100 public:
00101     // class members
00102     static AP4_DefaultAtomFactory Instance;
00103
00104     // constructor
00105     AP4_DefaultAtomFactory();
00106 };
00107
00108 #endif // _AP4_ATOM_FACTORY_H_
Generated on Thu May 13 16:36:31 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4AtomSampleTable.h File Reference

  • File List
  • File Members

Ap4AtomSampleTable.h File Reference

#include "Ap4Types.h"
#include "Ap4SampleTable.h"

Go to the source code of this file.

Classes

class AP4_AtomSampleTable
Generated on Thu May 13 16:36:35 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4AtomSampleTable.h Source File

  • File List
  • File Members

Ap4AtomSampleTable.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - Atom Based Sample Table
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This atom is part of AP4 (MP4 Audio Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the atom COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027  ****************************************************************/
00028
00029 #ifndef _AP4_ATOM_SAMPLE_TABLE_H_
00030 #define _AP4_ATOM_SAMPLE_TABLE_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Types.h"
00036 #include "Ap4SampleTable.h"
00037
00038 /*----------------------------------------------------------------------
00039 |   forward declarations
00040 +---------------------------------------------------------------------*/
00041 class AP4_Atom;
00042 class AP4_ByteStream;
00043 class AP4_StscAtom;
00044 class AP4_StcoAtom;
00045 class AP4_StszAtom;
00046 class AP4_SttsAtom;
00047 class AP4_CttsAtom;
00048 class AP4_StssAtom;
00049 class AP4_StsdAtom;
00050 class AP4_Co64Atom;
00051
00052 /*----------------------------------------------------------------------
00053 |   AP4_AtomSampleTable
00054 +---------------------------------------------------------------------*/
00055 class AP4_AtomSampleTable : public AP4_SampleTable
00056 {
00057  public:
00058     AP4_IMPLEMENT_DYNAMIC_CAST_D(AP4_AtomSampleTable, AP4_SampleTable)
00059
00060     // methods
00061              AP4_AtomSampleTable(AP4_ContainerAtom* stbl_atom,
00062                                  AP4_ByteStream&    sample_stream);
00063     virtual ~AP4_AtomSampleTable();
00064
00065     // AP4_SampleTable methods
00066     virtual AP4_Result   GetSample(AP4_Ordinal sample_index, AP4_Sample& sample);
00067     virtual AP4_Cardinal GetSampleCount();
00068     virtual AP4_SampleDescription* GetSampleDescription(AP4_Ordinal sd_index);
00069     virtual AP4_Cardinal GetSampleDescriptionCount();
00070     virtual AP4_Result   GetSampleChunkPosition(AP4_Ordinal  sample_index,
00071                                                 AP4_Ordinal& chunk_index,
00072                                                 AP4_Ordinal& position_in_chunk);
00073     virtual AP4_Result   GetSampleIndexForTimeStamp(AP4_UI64 ts, AP4_Ordinal& sample_index);
00074     virtual AP4_Ordinal  GetNearestSyncSampleIndex(AP4_Ordinal index, bool before=true);
00075
00076     // local methods
00077     virtual AP4_Result GetChunkForSample(AP4_Ordinal   sample_index,
00078                                          AP4_Ordinal&  chunk_index,
00079                                          AP4_Ordinal&  position_in_chunk,
00080                                          AP4_Ordinal&  sample_description_index);
00081     virtual AP4_Result GetChunkOffset(AP4_Ordinal chunk_index, AP4_Position& offset);
00082     virtual AP4_Result SetChunkOffset(AP4_Ordinal chunk_index, AP4_Position offset);
00083     virtual AP4_Result SetSampleSize(AP4_Ordinal sample_index, AP4_Size size);
00084
00085 private:
00086     // members
00087     AP4_ByteStream& m_SampleStream;
00088     AP4_StscAtom*   m_StscAtom;
00089     AP4_StcoAtom*   m_StcoAtom;
00090     AP4_StszAtom*   m_StszAtom;
00091     AP4_SttsAtom*   m_SttsAtom;
00092     AP4_CttsAtom*   m_CttsAtom;
00093     AP4_StsdAtom*   m_StsdAtom;
00094     AP4_StssAtom*   m_StssAtom;
00095     AP4_Co64Atom*   m_Co64Atom;
00096 };
00097
00098 #endif // _AP4_ATOM_SAMPLE_TABLE_H_
Generated on Thu May 13 16:36:31 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4AvccAtom.h File Reference

  • File List
  • File Members

Ap4AvccAtom.h File Reference

#include "Ap4Atom.h"
#include "Ap4Array.h"

Go to the source code of this file.

Classes

class | AP4_AvccAtom

Variables

const AP4_UI08 | AP4_AVC_PROFILE_BASELINE = 66
const AP4_UI08 | AP4_AVC_PROFILE_MAIN = 77
const AP4_UI08 | AP4_AVC_PROFILE_EXTENDED = 88
const AP4_UI08 | AP4_AVC_PROFILE_HIGH = 100
const AP4_UI08 | AP4_AVC_PROFILE_HIGH_10 = 110
const AP4_UI08 | AP4_AVC_PROFILE_HIGH_422 = 122
const AP4_UI08 | AP4_AVC_PROFILE_HIGH_444 = 144

Variable Documentation

const AP4_UI08 AP4_AVC_PROFILE_BASELINE = 66

Definition at line 41 of file Ap4AvccAtom.h.

const AP4_UI08 AP4_AVC_PROFILE_EXTENDED = 88

Definition at line 43 of file Ap4AvccAtom.h.

const AP4_UI08 AP4_AVC_PROFILE_HIGH = 100

Definition at line 44 of file Ap4AvccAtom.h.

const AP4_UI08 AP4_AVC_PROFILE_HIGH_10 = 110

Definition at line 45 of file Ap4AvccAtom.h.

const AP4_UI08 AP4_AVC_PROFILE_HIGH_422 = 122

Definition at line 46 of file Ap4AvccAtom.h.

const AP4_UI08 AP4_AVC_PROFILE_HIGH_444 = 144

Definition at line 47 of file Ap4AvccAtom.h.

const AP4_UI08 AP4_AVC_PROFILE_MAIN = 77

Definition at line 42 of file Ap4AvccAtom.h.

Generated on Thu May 13 16:36:35 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4AvccAtom.h Source File

  • File List
  • File Members

Ap4AvccAtom.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - avcC Atoms
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027 ****************************************************************/
00028
00029 #ifndef _AP4_AVCC_ATOM_H_
00030 #define _AP4_AVCC_ATOM_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Atom.h"
00036 #include "Ap4Array.h"
00037
00038 /*----------------------------------------------------------------------
00039 |   constants
00040 +---------------------------------------------------------------------*/
00041 const AP4_UI08 AP4_AVC_PROFILE_BASELINE = 66;
00042 const AP4_UI08 AP4_AVC_PROFILE_MAIN     = 77;
00043 const AP4_UI08 AP4_AVC_PROFILE_EXTENDED = 88;
00044 const AP4_UI08 AP4_AVC_PROFILE_HIGH     = 100;
00045 const AP4_UI08 AP4_AVC_PROFILE_HIGH_10  = 110;
00046 const AP4_UI08 AP4_AVC_PROFILE_HIGH_422 = 122;
00047 const AP4_UI08 AP4_AVC_PROFILE_HIGH_444 = 144;
00048
00049
00050 /*----------------------------------------------------------------------
00051 |   AP4_AvccAtom
00052 +---------------------------------------------------------------------*/
00053 class AP4_AvccAtom : public AP4_Atom
00054 {
00055 public:
00056     AP4_IMPLEMENT_DYNAMIC_CAST_D(AP4_AvccAtom, AP4_Atom)
00057
00058     // class methods
00059     static AP4_AvccAtom* Create(AP4_Size size, AP4_ByteStream& stream);
00060     static const char*   GetProfileName(AP4_UI08 profile);
00061
00062     // constructors
00063     AP4_AvccAtom();
00064     AP4_AvccAtom(AP4_UI08 profile,
00065                  AP4_UI08 level,
00066                  AP4_UI08 profile_compatibility,
00067                  AP4_UI08 length_size,
00068                  const AP4_Array<AP4_DataBuffer>& sequence_parameters,
00069                  const AP4_Array<AP4_DataBuffer>& picture_parameters);
00070     AP4_AvccAtom(const AP4_AvccAtom& other); // copy construtor
00071
00072     // methods
00073     virtual AP4_Result InspectFields(AP4_AtomInspector& inspector);
00074     virtual AP4_Result WriteFields(AP4_ByteStream& stream);
00075
00076     // accessors
00077     AP4_UI08 GetConfigurationVersion() const { return m_ConfigurationVersion; }
00078     AP4_UI08 GetProfile() const              { return m_Profile; }
00079     AP4_UI08 GetLevel() const                { return m_Level; }
00080     AP4_UI08 GetProfileCompatibility() const { return m_ProfileCompatibility; }
00081     AP4_UI08 GetNaluLengthSize() const       { return m_NaluLengthSize; }
00082     AP4_Array<AP4_DataBuffer>& GetSequenceParameters() { return m_SequenceParameters; }
00083     AP4_Array<AP4_DataBuffer>& GetPictureParameters()  { return m_PictureParameters; }
00084     const AP4_DataBuffer& GetRawBytes() const { return m_RawBytes; }
00085
00086 private:
00087     // methods
00088     AP4_AvccAtom(AP4_UI32 size, const AP4_UI08* payload);
00089     void UpdateRawBytes();
00090
00091     // members
00092     AP4_UI08                  m_ConfigurationVersion;
00093     AP4_UI08                  m_Profile;
00094     AP4_UI08                  m_Level;
00095     AP4_UI08                  m_ProfileCompatibility;
00096     AP4_UI08                  m_NaluLengthSize;
00097     AP4_Array<AP4_DataBuffer> m_SequenceParameters;
00098     AP4_Array<AP4_DataBuffer> m_PictureParameters;
00099     AP4_DataBuffer            m_RawBytes;
00100 };
00101
00102 #endif // _AP4_AVCC_ATOM_H_
Generated on Thu May 13 16:36:31 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4ByteStream.h File Reference

  • File List
  • File Members

Ap4ByteStream.h File Reference

#include "Ap4Types.h"
#include "Ap4Interfaces.h"
#include "Ap4Results.h"
#include "Ap4DataBuffer.h"

Go to the source code of this file.

Classes

class | AP4_ByteStream
class | AP4_SubStream
class | AP4_MemoryByteStream
class | AP4_BufferedInputStream
Generated on Thu May 13 16:36:35 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4ByteStream.h Source File

  • File List
  • File Members

Ap4ByteStream.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - ByteStream Interface
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027  ****************************************************************/
00028
00029 #ifndef _AP4_BYTE_STREAM_H_
00030 #define _AP4_BYTE_STREAM_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Types.h"
00036 #include "Ap4Interfaces.h"
00037 #include "Ap4Results.h"
00038 #include "Ap4DataBuffer.h"
00039
00040 /*----------------------------------------------------------------------
00041 |   AP4_ByteStream
00042 +---------------------------------------------------------------------*/
00043 class AP4_ByteStream : public AP4_Referenceable
00044 {
00045  public:
00046     // methods
00047     virtual AP4_Result ReadPartial(void*     buffer,
00048                                    AP4_Size  bytes_to_read,
00049                                    AP4_Size& bytes_read) = 0;
00050     AP4_Result Read(void* buffer, AP4_Size bytes_to_read);
00051     AP4_Result ReadDouble(double& value);
00052     AP4_Result ReadUI64(AP4_UI64& value);
00053     AP4_Result ReadUI32(AP4_UI32& value);
00054     AP4_Result ReadUI24(AP4_UI32& value);
00055     AP4_Result ReadUI16(AP4_UI16& value);
00056     AP4_Result ReadUI08(AP4_UI08& value);
00057     AP4_Result ReadString(char* buffer, AP4_Size size);
00058     virtual AP4_Result WritePartial(const void* buffer,
00059                                     AP4_Size    bytes_to_write,
00060                                     AP4_Size&   bytes_written) = 0;
00061     AP4_Result Write(const void* buffer, AP4_Size bytes_to_write);
00062     AP4_Result WriteString(const char* string_buffer);
00063     AP4_Result WriteDouble(double value);
00064     AP4_Result WriteUI64(AP4_UI64 value);
00065     AP4_Result WriteUI32(AP4_UI32 value);
00066     AP4_Result WriteUI24(AP4_UI32 value);
00067     AP4_Result WriteUI16(AP4_UI16 value);
00068     AP4_Result WriteUI08(AP4_UI08 value);
00069     virtual AP4_Result Seek(AP4_Position position) = 0;
00070     virtual AP4_Result Tell(AP4_Position& position) = 0;
00071     virtual AP4_Result GetSize(AP4_LargeSize& size) = 0;
00072     virtual AP4_Result CopyTo(AP4_ByteStream& stream, AP4_LargeSize size);
00073     virtual AP4_Result Flush() { return AP4_SUCCESS; }
00074 };
00075
00076 /*----------------------------------------------------------------------
00077 |   AP4_SubStream
00078 +---------------------------------------------------------------------*/
00079 class AP4_SubStream : public AP4_ByteStream
00080 {
00081  public:
00082     AP4_SubStream(AP4_ByteStream& container,
00083                   AP4_Position    position,
00084                   AP4_LargeSize   size);
00085
00086     // AP4_ByteStream methods
00087     AP4_Result ReadPartial(void*     buffer,
00088                            AP4_Size  bytes_to_read,
00089                            AP4_Size& bytes_read);
00090     AP4_Result WritePartial(const void* buffer,
00091                             AP4_Size    bytes_to_write,
00092                             AP4_Size&   bytes_written);
00093     AP4_Result Seek(AP4_Position position);
00094     AP4_Result Tell(AP4_Position& position) {
00095         position = m_Position;
00096         return AP4_SUCCESS;
00097     }
00098     AP4_Result GetSize(AP4_LargeSize& size) {
00099         size = m_Size;
00100         return AP4_SUCCESS;
00101     }
00102
00103     // AP4_Referenceable methods
00104     void AddReference();
00105     void Release();
00106
00107  protected:
00108     virtual ~AP4_SubStream();
00109
00110  private:
00111     AP4_ByteStream& m_Container;
00112     AP4_Position    m_Offset;
00113     AP4_LargeSize   m_Size;
00114     AP4_Position    m_Position;
00115     AP4_Cardinal    m_ReferenceCount;
00116 };
00117
00118 /*----------------------------------------------------------------------
00119 |   AP4_MemoryByteStream
00120 +---------------------------------------------------------------------*/
00121 class AP4_MemoryByteStream : public AP4_ByteStream
00122 {
00123 public:
00124     AP4_MemoryByteStream(AP4_Size size = 0); // filled with zeros
00125     AP4_MemoryByteStream(const AP4_UI08* buffer, AP4_Size size);
00126     AP4_MemoryByteStream(AP4_DataBuffer& data_buffer); // data is read/written from/to supplied buffer
00127
00128     // AP4_ByteStream methods
00129     AP4_Result ReadPartial(void*     buffer,
00130                            AP4_Size  bytes_to_read,
00131                            AP4_Size& bytes_read);
00132     AP4_Result WritePartial(const void* buffer,
00133                             AP4_Size    bytes_to_write,
00134                             AP4_Size&   bytes_written);
00135     AP4_Result Seek(AP4_Position position);
00136     AP4_Result Tell(AP4_Position& position) {
00137         position = m_Position;
00138         return AP4_SUCCESS;
00139     }
00140     AP4_Result GetSize(AP4_LargeSize& size) {
00141         size = m_Buffer->GetDataSize();
00142         return AP4_SUCCESS;
00143     }
00144
00145     // AP4_Referenceable methods
00146     void AddReference();
00147     void Release();
00148
00149     // methods
00150     const AP4_UI08* GetData()     { return m_Buffer->GetData(); }
00151     AP4_UI08*       UseData()     { return m_Buffer->UseData(); }
00152     AP4_Size        GetDataSize() { return m_Buffer->GetDataSize(); }
00153
00154 protected:
00155     virtual ~AP4_MemoryByteStream();
00156
00157 private:
00158     AP4_DataBuffer* m_Buffer;
00159     bool            m_BufferIsLocal;
00160     AP4_Position    m_Position;
00161     AP4_Cardinal    m_ReferenceCount;
00162 };
00163
00164 /*----------------------------------------------------------------------
00165 |   AP4_BufferedInputStream
00166 +---------------------------------------------------------------------*/
00167 class AP4_BufferedInputStream : public AP4_ByteStream
00168 {
00169 public:
00170     AP4_BufferedInputStream(AP4_ByteStream& source,
00171                             AP4_Size        buffer_size=4096,
00172                             AP4_Size        seek_as_read_threshold=1024*128);
00173
00174     // AP4_ByteStream methods
00175     AP4_Result ReadPartial(void*     buffer,
00176                            AP4_Size  bytes_to_read,
00177                            AP4_Size& bytes_read);
00178     AP4_Result WritePartial(const void* buffer,
00179                             AP4_Size    bytes_to_write,
00180                             AP4_Size&   bytes_written);
00181     AP4_Result Seek(AP4_Position position);
00182     AP4_Result Tell(AP4_Position& position);
00183     AP4_Result GetSize(AP4_LargeSize& size) { return m_Source.GetSize(size); }
00184
00185     // AP4_Referenceable methods
00186     void AddReference();
00187     void Release();
00188
00189 protected:
00190    ~AP4_BufferedInputStream() { m_Source.Release(); }
00191     AP4_Result Refill();
00192
00193 private:
00194     AP4_DataBuffer  m_Buffer;
00195     AP4_Size        m_BufferPosition;
00196     AP4_ByteStream& m_Source;
00197     AP4_Position    m_SourcePosition;
00198     AP4_Size        m_SeekAsReadThreshold;
00199     AP4_Cardinal    m_ReferenceCount;
00200 };
00201
00202 #endif // _AP4_BYTE_STREAM_H_
Generated on Thu May 13 16:36:31 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4Co64Atom.h File Reference

  • File List
  • File Members

Ap4Co64Atom.h File Reference

#include "Ap4Types.h"
#include "Ap4Atom.h"

Go to the source code of this file.

Classes

class AP4_Co64Atom
Generated on Thu May 13 16:36:35 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4Co64Atom.h Source File

  • File List
  • File Members

Ap4Co64Atom.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - co64 Atoms
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027  ****************************************************************/
00028
00029 #ifndef _AP4_CO64_ATOM_H_
00030 #define _AP4_CO64_ATOM_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Types.h"
00036 #include "Ap4Atom.h"
00037
00038 /*----------------------------------------------------------------------
00039 |   AP4_Co64Atom
00040 +---------------------------------------------------------------------*/
00041 class AP4_Co64Atom : public AP4_Atom
00042 {
00043 public:
00044     AP4_IMPLEMENT_DYNAMIC_CAST_D(AP4_Co64Atom, AP4_Atom)
00045
00046     // class methods
00047     static AP4_Co64Atom* Create(AP4_Size size, AP4_ByteStream& stream);
00048
00049     // methods
00050     AP4_Co64Atom(AP4_UI64* offsets, AP4_UI32 offset_count);
00051     ~AP4_Co64Atom();
00052     virtual AP4_Result InspectFields(AP4_AtomInspector& inspector);
00053     virtual AP4_Result WriteFields(AP4_ByteStream& stream);
00054     AP4_Cardinal GetChunkCount()   { return m_EntryCount; }
00055     AP4_UI64*    GetChunkOffsets() { return m_Entries;    }
00056     AP4_Result   GetChunkOffset(AP4_Ordinal chunk, AP4_UI64& chunk_offset);
00057     AP4_Result   SetChunkOffset(AP4_Ordinal chunk, AP4_UI64  chunk_offset);
00058     AP4_Result   AdjustChunkOffsets(AP4_SI64 delta);
00059
00060 private:
00061     // methods
00062     AP4_Co64Atom(AP4_UI32        size,
00063                  AP4_UI32        version,
00064                  AP4_UI32        flags,
00065                  AP4_ByteStream& stream);
00066
00067     // members
00068     AP4_UI64* m_Entries;
00069     AP4_UI32  m_EntryCount;
00070 };
00071
00072 #endif // _AP4_CO64_ATOM_H_
Generated on Thu May 13 16:36:31 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4Command.h File Reference

  • File List
  • File Members

Ap4Command.h File Reference

#include "Ap4Expandable.h"
#include "Ap4DynamicCast.h"

Go to the source code of this file.

Classes

class | AP4_Command
class | AP4_UnknownCommand

Variables

const AP4_UI08 | AP4_COMMAND_TAG_OBJECT_DESCRIPTOR_UPDATE = 0x01
const AP4_UI08 | AP4_COMMAND_TAG_OBJECT_DESCRIPTOR_REMOVE = 0x02
const AP4_UI08 | AP4_COMMAND_TAG_ES_DESCRIPTOR_UPDATE = 0x03
const AP4_UI08 | AP4_COMMAND_TAG_ES_DESCRIPTOR_REMOVE = 0x04
const AP4_UI08 | AP4_COMMAND_TAG_IPMP_DESCRIPTOR_UPDATE = 0x05
const AP4_UI08 | AP4_COMMAND_TAG_IPMP_DESCRIPTOR_REMOVE = 0x06
const AP4_UI08 | AP4_COMMAND_TAG_ES_DESCRIPTOR_REMOVE_REF = 0x07
const AP4_UI08 | AP4_COMMAND_TAG_OBJECT_DESCRIPTOR_EXECUTE = 0x08

Variable Documentation

const AP4_UI08 AP4_COMMAND_TAG_ES_DESCRIPTOR_REMOVE = 0x04

Definition at line 44 of file Ap4Command.h.

const AP4_UI08 AP4_COMMAND_TAG_ES_DESCRIPTOR_REMOVE_REF = 0x07

Definition at line 47 of file Ap4Command.h.

const AP4_UI08 AP4_COMMAND_TAG_ES_DESCRIPTOR_UPDATE = 0x03

Definition at line 43 of file Ap4Command.h.

const AP4_UI08 AP4_COMMAND_TAG_IPMP_DESCRIPTOR_REMOVE = 0x06

Definition at line 46 of file Ap4Command.h.

const AP4_UI08 AP4_COMMAND_TAG_IPMP_DESCRIPTOR_UPDATE = 0x05

Definition at line 45 of file Ap4Command.h.

const AP4_UI08 AP4_COMMAND_TAG_OBJECT_DESCRIPTOR_EXECUTE = 0x08

Definition at line 48 of file Ap4Command.h.

const AP4_UI08 AP4_COMMAND_TAG_OBJECT_DESCRIPTOR_REMOVE = 0x02

Definition at line 42 of file Ap4Command.h.

const AP4_UI08 AP4_COMMAND_TAG_OBJECT_DESCRIPTOR_UPDATE = 0x01

Definition at line 41 of file Ap4Command.h.

Generated on Thu May 13 16:36:35 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4Command.h Source File

  • File List
  • File Members

Ap4Command.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - Commands
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027  ****************************************************************/
00028
00029 #ifndef _AP4_COMMAND_H_
00030 #define _AP4_COMMAND_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Expandable.h"
00036 #include "Ap4DynamicCast.h"
00037
00038 /*----------------------------------------------------------------------
00039 |   constants
00040 +---------------------------------------------------------------------*/
00041 const AP4_UI08 AP4_COMMAND_TAG_OBJECT_DESCRIPTOR_UPDATE  = 0x01;
00042 const AP4_UI08 AP4_COMMAND_TAG_OBJECT_DESCRIPTOR_REMOVE  = 0x02;
00043 const AP4_UI08 AP4_COMMAND_TAG_ES_DESCRIPTOR_UPDATE      = 0x03;
00044 const AP4_UI08 AP4_COMMAND_TAG_ES_DESCRIPTOR_REMOVE      = 0x04;
00045 const AP4_UI08 AP4_COMMAND_TAG_IPMP_DESCRIPTOR_UPDATE    = 0x05;
00046 const AP4_UI08 AP4_COMMAND_TAG_IPMP_DESCRIPTOR_REMOVE    = 0x06;
00047 const AP4_UI08 AP4_COMMAND_TAG_ES_DESCRIPTOR_REMOVE_REF  = 0x07;
00048 const AP4_UI08 AP4_COMMAND_TAG_OBJECT_DESCRIPTOR_EXECUTE = 0x08;
00049
00050 /*----------------------------------------------------------------------
00051 |   AP4_Command
00052 +---------------------------------------------------------------------*/
00053 class AP4_Command : public AP4_Expandable
00054 {
00055  public:
00056      AP4_IMPLEMENT_DYNAMIC_CAST(AP4_Command)
00057
00058     // constructor
00059     AP4_Command(AP4_UI08 tag, AP4_Size header_size, AP4_Size payload_size) :
00060         AP4_Expandable(tag, CLASS_ID_SIZE_08, header_size, payload_size) {}
00061
00062     // AP4_Exandable methods
00063     virtual AP4_Result Inspect(AP4_AtomInspector& inspector);
00064
00065     // methods
00066     AP4_UI08 GetTag() { return (AP4_UI08)m_ClassId; }
00067 };
00068
00069 /*----------------------------------------------------------------------
00070 |   AP4_UnknownCommand
00071 +---------------------------------------------------------------------*/
00072 class AP4_UnknownCommand : public AP4_Command
00073 {
00074 public:
00075     // contrusctor
00076     AP4_UnknownCommand(AP4_ByteStream& stream,
00077                        AP4_UI08        tag,
00078                        AP4_Size        header_size,
00079                        AP4_Size        payload_size);
00080
00081     // AP4_Expandable methods
00082     virtual AP4_Result WriteFields(AP4_ByteStream& stream);
00083
00084 private:
00085     // members
00086     AP4_DataBuffer m_Data;
00087 };
00088
00089 #endif // _AP4_COMMAND_H_
Generated on Thu May 13 16:36:31 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4CommandFactory.h File Reference

  • File List
  • File Members

Ap4CommandFactory.h File Reference

#include "Ap4Types.h"
#include "Ap4Command.h"

Go to the source code of this file.

Classes

class AP4_CommandFactory
Generated on Thu May 13 16:36:35 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4CommandFactory.h Source File

  • File List
  • File Members

Ap4CommandFactory.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - Command Factory
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027  ****************************************************************/
00028
00029 #ifndef _AP4_COMMAND_FACTORY_H_
00030 #define _AP4_COMMAND_FACTORY_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Types.h"
00036 #include "Ap4Command.h"
00037
00038 /*----------------------------------------------------------------------
00039 |   class references
00040 +---------------------------------------------------------------------*/
00041 class AP4_ByteStream;
00042
00043 /*----------------------------------------------------------------------
00044 |   AP4_CommandFactory
00045 +---------------------------------------------------------------------*/
00046 class AP4_CommandFactory
00047 {
00048  public:
00049     // class methods
00050     static AP4_Result CreateCommandFromStream(AP4_ByteStream& stream,
00051                                               AP4_Command*&   command);
00052 };
00053
00054 #endif // _AP4_COMMAND_FACTORY_H_
Generated on Thu May 13 16:36:31 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4Config.h File Reference

  • File List
  • File Members

Ap4Config.h File Reference

Platform Configuration. More...

Go to the source code of this file.

Defines

#define | AP4_CONFIG_HAVE_STDIO_H
#define | AP4_CONFIG_HAVE_ASSERT_H
#define | AP4_CONFIG_HAVE_STRING_H
#define | AP4_CONFIG_HAVE_SNPRINTF
#define | AP4_CONFIG_HAVE_VSNPRINTF
#define | AP4_CONFIG_HAVE_INT64
#define | AP4_PLATFORM_BYTE_ORDER_BIG_ENDIAN 0
#define | AP4_PLATFORM_BYTE_ORDER_LITTLE_ENDIAN 1
#define | APT_CONFIG_HAVE_NEW_H
#define | AP4_fseek fseeko
#define | AP4_ftell ftello
#define | AP4_snprintf snprintf
#define | AP4_vsnprintf vsnprintf

Detailed Description

Platform Configuration.

Definition in file Ap4Config.h.

Define Documentation

#define AP4_CONFIG_HAVE_ASSERT_H

Definition at line 39 of file Ap4Config.h.

#define AP4_CONFIG_HAVE_INT64

Definition at line 43 of file Ap4Config.h.

#define AP4_CONFIG_HAVE_SNPRINTF

Definition at line 41 of file Ap4Config.h.

#define AP4_CONFIG_HAVE_STDIO_H

Definition at line 38 of file Ap4Config.h.

#define AP4_CONFIG_HAVE_STRING_H

Definition at line 40 of file Ap4Config.h.

#define AP4_CONFIG_HAVE_VSNPRINTF

Definition at line 42 of file Ap4Config.h.

#define AP4_fseek fseeko

Definition at line 126 of file Ap4Config.h.

#define AP4_ftell ftello

Definition at line 129 of file Ap4Config.h.

#define AP4_PLATFORM_BYTE_ORDER_BIG_ENDIAN 0

Definition at line 49 of file Ap4Config.h.

#define AP4_PLATFORM_BYTE_ORDER_LITTLE_ENDIAN 1

Definition at line 50 of file Ap4Config.h.

#define AP4_snprintf snprintf

Definition at line 134 of file Ap4Config.h.

#define AP4_vsnprintf vsnprintf

Definition at line 137 of file Ap4Config.h.

#define APT_CONFIG_HAVE_NEW_H

Definition at line 63 of file Ap4Config.h.

Generated on Thu May 13 16:36:35 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4Config.h Source File

  • File List
  • File Members

Ap4Config.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - Target Platform and Compiler Configuration
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027  ****************************************************************/
00032 #ifndef _AP4_CONFIG_H_
00033 #define _AP4_CONFIG_H_
00034
00035 /*----------------------------------------------------------------------
00036 |   defaults
00037 +---------------------------------------------------------------------*/
00038 #define AP4_CONFIG_HAVE_STDIO_H
00039 #define AP4_CONFIG_HAVE_ASSERT_H
00040 #define AP4_CONFIG_HAVE_STRING_H
00041 #define AP4_CONFIG_HAVE_SNPRINTF
00042 #define AP4_CONFIG_HAVE_VSNPRINTF
00043 #define AP4_CONFIG_HAVE_INT64
00044
00045 /*----------------------------------------------------------------------
00046 |   byte order
00047 +---------------------------------------------------------------------*/
00048 // define AP4_PLATFORM_BYTE_ORDER to one of these two choices
00049 #define AP4_PLATFORM_BYTE_ORDER_BIG_ENDIAN    0
00050 #define AP4_PLATFORM_BYTE_ORDER_LITTLE_ENDIAN 1
00051
00052 #if !defined(AP4_PLATFORM_BYTE_ORDER)
00053 #if defined(__ppc__)
00054 #define AP4_PLATFORM_BYTE_ORDER AP4_PLATFORM_BYTE_ORDER_BIG_ENDIAN
00055 #elif defined(__i386__) || defined(__x86_64__) || defined(__arm__)
00056 #define AP4_PLATFORM_BYTE_ORDER AP4_PLATFORM_BYTE_ORDER_LITTLE_ENDIAN
00057 #endif
00058 #endif
00059
00060 /*----------------------------------------------------------------------
00061 |   standard C++ runtime
00062 +---------------------------------------------------------------------*/
00063 #define APT_CONFIG_HAVE_NEW_H
00064
00065 /*----------------------------------------------------------------------
00066 |   platform specifics
00067 +---------------------------------------------------------------------*/
00068
00069 /* Microsoft Platforms */
00070 #if defined(_MSC_VER)
00071 #define AP4_CONFIG_INT64_TYPE __int64
00072 #if (_MSC_VER >= 1400) && !defined(_WIN32_WCE)
00073 #define AP4_CONFIG_HAVE_FOPEN_S
00074 #define AP4_snprintf(s,c,f,...) _snprintf_s(s,c,_TRUNCATE,f,__VA_ARGS__)
00075 #define AP4_vsnprintf(s,c,f,a)  _vsnprintf_s(s,c,_TRUNCATE,f,a)
00076 #define fileno _fileno
00077 #define AP4_fseek _fseeki64
00078 #define AP4_ftell _ftelli64
00079 #else
00080 #define AP4_snprintf   _snprintf
00081 #define AP4_vsnprintf  _vsnprintf
00082 #endif
00083 #if defined(_WIN32_WCE)
00084 #define AP4_fseek fseek
00085 #define AP4_ftell ftell
00086 #endif
00087 #if defined(_DEBUG)
00088 #define _CRTDBG_MAP_ALLOC
00089 #endif
00090 #endif
00091
00092 /* Cygwin */
00093 #if defined(__CYGWIN__)
00094 #define AP4_fseek fseek
00095 #define AP4_ftell ftell
00096 #endif
00097
00098 /* Symbian */
00099 #if defined(__SYMBIAN32__)
00100 #undef APT_CONFIG_HAVE_NEW_H
00101 #include "e32std.h"
00106 #define AP4_PLATFORM_BYTE_ORDER AP4_PLATFORM_BYTE_ORDER_LITTLE_ENDIAN
00107 #define AP4_fseek fseek
00108 #define AP4_ftell ftell
00109 #define explicit
00110 #endif
00111
00112 /* Android */
00113 #if defined(ANDROID)
00114 #define AP4_CONFIG_NO_RTTI
00115 #define AP4_CONFIG_NO_EXCEPTIONS
00116 #endif
00117
00118 /*----------------------------------------------------------------------
00119 |    defaults
00120 +---------------------------------------------------------------------*/
00121 #if !defined(AP4_CONFIG_INT64_TYPE)
00122 #define AP4_CONFIG_INT64_TYPE long long
00123 #endif
00124
00125 #if !defined(AP4_fseek)
00126 #define AP4_fseek fseeko
00127 #endif
00128 #if !defined(AP4_ftell)
00129 #define AP4_ftell ftello
00130 #endif
00131
00132 /* some compilers (ex: MSVC 8) deprecate those, so we rename them */
00133 #if !defined(AP4_snprintf)
00134 #define AP4_snprintf snprintf
00135 #endif
00136 #if !defined(AP4_vsnprintf)
00137 #define AP4_vsnprintf vsnprintf
00138 #endif
00139
00140 #endif // _AP4_CONFIG_H_
Generated on Thu May 13 16:36:31 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4Constants.h File Reference

  • File List
  • File Members

Ap4Constants.h File Reference

Go to the source code of this file.

Generated on Thu May 13 16:36:35 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4Constants.h Source File

  • File List
  • File Members

Ap4Constants.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - Shared Constants
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027  ****************************************************************/
00028
00029 #ifndef _AP4_CONSTANTS_H_
00030 #define _AP4_CONSTANTS_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #ifndef NULL
00036 #define NULL 0
00037 #endif
00038
00039 #endif // _AP4_CONSTANTS_H_
Generated on Thu May 13 16:36:31 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4ContainerAtom.h File Reference

  • File List
  • File Members

Ap4ContainerAtom.h File Reference

#include "Ap4Types.h"
#include "Ap4List.h"
#include "Ap4Atom.h"

Go to the source code of this file.

Classes

class AP4_ContainerAtom
Generated on Thu May 13 16:36:35 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4ContainerAtom.h Source File

  • File List
  • File Members

Ap4ContainerAtom.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - Container Atoms
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027  ****************************************************************/
00028
00029 #ifndef _AP4_CONTAINER_ATOM_H_
00030 #define _AP4_CONTAINER_ATOM_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Types.h"
00036 #include "Ap4List.h"
00037 #include "Ap4Atom.h"
00038
00039 /*----------------------------------------------------------------------
00040 |   class references
00041 +---------------------------------------------------------------------*/
00042 class AP4_ByteStream;
00043 class AP4_AtomFactory;
00044
00045 /*----------------------------------------------------------------------
00046 |   AP4_ContainerAtom
00047 +---------------------------------------------------------------------*/
00048 class AP4_ContainerAtom : public AP4_Atom, public AP4_AtomParent
00049 {
00050 public:
00051     AP4_IMPLEMENT_DYNAMIC_CAST_D2(AP4_ContainerAtom, AP4_Atom, AP4_AtomParent)
00052
00053     // class methods
00054     static AP4_ContainerAtom* Create(Type             type,
00055                                      AP4_UI64         size,
00056                                      bool             is_full,
00057                                      bool             force_64,
00058                                      AP4_ByteStream&  stream,
00059                                      AP4_AtomFactory& atom_factory);
00060
00061     // methods
00062     explicit AP4_ContainerAtom(Type type);
00063     explicit AP4_ContainerAtom(Type type, AP4_UI32 version, AP4_UI32 flags);
00064     explicit AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64);
00065     explicit AP4_ContainerAtom(Type type, AP4_UI64 size, bool force_64, AP4_UI32 version, AP4_UI32 flags);
00066     AP4_List<AP4_Atom>& GetChildren() { return m_Children; }
00067     virtual AP4_Result InspectFields(AP4_AtomInspector& inspector);
00068     virtual AP4_Result InspectChildren(AP4_AtomInspector& inspector);
00069     virtual AP4_Result WriteFields(AP4_ByteStream& stream);
00070     virtual AP4_Atom*  Clone();
00071
00072     // AP4_AtomParent methods
00073     virtual void OnChildChanged(AP4_Atom* child);
00074     virtual void OnChildAdded(AP4_Atom* child);
00075     virtual void OnChildRemoved(AP4_Atom* child);
00076
00077 protected:
00078     // constructors
00079     AP4_ContainerAtom(Type             type,
00080                       AP4_UI64         size,
00081                       bool             force_64,
00082                       AP4_UI32         version,
00083                       AP4_UI32         flags,
00084                       AP4_ByteStream&  stream,
00085                       AP4_AtomFactory& atom_factory);
00086     AP4_ContainerAtom(Type             type,
00087                       AP4_UI64         size,
00088                       bool             force_64,
00089                       AP4_ByteStream&  stream,
00090                       AP4_AtomFactory& atom_factory);
00091
00092     // methods
00093     void ReadChildren(AP4_AtomFactory& atom_factory,
00094                       AP4_ByteStream&  stream,
00095                       AP4_UI64         size);
00096 };
00097
00098 #endif // _AP4_CONTAINER_ATOM_H_
Generated on Thu May 13 16:36:31 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4CttsAtom.h File Reference

  • File List
  • File Members

Ap4CttsAtom.h File Reference

#include "Ap4Atom.h"
#include "Ap4Types.h"
#include "Ap4Array.h"

Go to the source code of this file.

Classes

class | AP4_CttsTableEntry
class | AP4_CttsAtom
Generated on Thu May 13 16:36:35 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4CttsAtom.h Source File

  • File List
  • File Members

Ap4CttsAtom.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - ctts Atoms
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027  ****************************************************************/
00028
00029 #ifndef _AP4_CTTS_ATOM_H_
00030 #define _AP4_CTTS_ATOM_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Atom.h"
00036 #include "Ap4Types.h"
00037 #include "Ap4Array.h"
00038
00039 /*----------------------------------------------------------------------
00040 |   class references
00041 +---------------------------------------------------------------------*/
00042 class AP4_ByteStream;
00043
00044 /*----------------------------------------------------------------------
00045 |   AP4_CttsTableEntry
00046 +---------------------------------------------------------------------*/
00047 class AP4_CttsTableEntry {
00048  public:
00049     AP4_CttsTableEntry() :
00050         m_SampleCount(0),
00051         m_SampleOffset(0) {}
00052     AP4_CttsTableEntry(AP4_UI32 sample_count,
00053                        AP4_UI32 sample_offset) :
00054         m_SampleCount(sample_count),
00055         m_SampleOffset(sample_offset) {}
00056
00057     AP4_UI32 m_SampleCount;
00058     AP4_UI32 m_SampleOffset;
00059 };
00060
00061 /*----------------------------------------------------------------------
00062 |   AP4_CttsAtom
00063 +---------------------------------------------------------------------*/
00064 class AP4_CttsAtom : public AP4_Atom
00065 {
00066 public:
00067     AP4_IMPLEMENT_DYNAMIC_CAST_D(AP4_CttsAtom, AP4_Atom)
00068
00069     // class methods
00070     static AP4_CttsAtom* Create(AP4_UI32 size, AP4_ByteStream& stream);
00071
00072     // constructor
00073     AP4_CttsAtom();
00074
00075     // methods
00076     virtual AP4_Result InspectFields(AP4_AtomInspector& inspector);
00077     virtual AP4_Result WriteFields(AP4_ByteStream& stream);
00078     AP4_Result AddEntry(AP4_UI32 count, AP4_UI32 cts_offset);
00079     AP4_Result GetCtsOffset(AP4_Ordinal sample, AP4_UI32& cts_offset);
00080
00081 private:
00082     // methods
00083     AP4_CttsAtom(AP4_UI32        size,
00084                  AP4_UI32        version,
00085                  AP4_UI32        flags,
00086                  AP4_ByteStream& stream);
00087
00088     // members
00089     AP4_Array<AP4_CttsTableEntry> m_Entries;
00090     struct {
00091         AP4_Ordinal sample;
00092         AP4_Ordinal entry_index;
00093     } m_LookupCache;
00094 };
00095
00096 #endif // _AP4_CTTS_ATOM_H_
Generated on Thu May 13 16:36:31 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4DataBuffer.h File Reference

  • File List
  • File Members

Ap4DataBuffer.h File Reference

#include "Ap4Types.h"

Go to the source code of this file.

Classes

class AP4_DataBuffer
Generated on Thu May 13 16:36:35 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4DataBuffer.h Source File

  • File List
  • File Members

Ap4DataBuffer.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - Data Buffer Objects
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027  ****************************************************************/
00028
00029 #ifndef _AP4_DATA_BUFFER_H_
00030 #define _AP4_DATA_BUFFER_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Types.h"
00036
00037 /*----------------------------------------------------------------------
00038 |   AP4_DataBuffer
00039 +---------------------------------------------------------------------*/
00040 class AP4_DataBuffer
00041 {
00042  public:
00043     // constructors & destructor
00044     AP4_DataBuffer();
00045     AP4_DataBuffer(AP4_Size size);
00046     AP4_DataBuffer(const void* data, AP4_Size data_size);
00047     AP4_DataBuffer(const AP4_DataBuffer& other);
00048     virtual ~AP4_DataBuffer();
00049
00050     // data buffer handling methods
00051     AP4_Result SetBuffer(AP4_Byte* buffer, AP4_Size buffer_size);
00052     AP4_Result SetBufferSize(AP4_Size buffer_size);
00053     AP4_Size   GetBufferSize() const { return m_BufferSize; }
00054
00055     // data handling methods
00056     const AP4_Byte* GetData() const { return m_Buffer; }
00057     AP4_Byte*       UseData() { return m_Buffer; };
00058     AP4_Size        GetDataSize() const { return m_DataSize; }
00059     AP4_Result      SetDataSize(AP4_Size size);
00060     AP4_Result      SetData(const AP4_Byte* data, AP4_Size data_size);
00061
00062     // memory management
00063     AP4_Result      Reserve(AP4_Size size);
00064
00065  protected:
00066     // members
00067     bool      m_BufferIsLocal;
00068     AP4_Byte* m_Buffer;
00069     AP4_Size  m_BufferSize;
00070     AP4_Size  m_DataSize;
00071
00072     // methods
00073     AP4_Result ReallocateBuffer(AP4_Size size);
00074
00075 private:
00076     // forbid this
00077     AP4_DataBuffer& operator=(const AP4_DataBuffer& other);
00078 };
00079
00080 #endif // _AP4_DATA_BUFFER_H_
00081
Generated on Thu May 13 16:36:31 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4Debug.h File Reference

  • File List
  • File Members

Ap4Debug.h File Reference

#include "Ap4Config.h"

Go to the source code of this file.

Functions

void AP4_Debug (const char *format,...)

Function Documentation

void AP4_Debug | ( | const char * | format,
 |  |  | ...
 | ) |  |
Generated on Thu May 13 16:36:35 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4Debug.h Source File

  • File List
  • File Members

Ap4Debug.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - Debug Support
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027  ****************************************************************/
00028
00029 #ifndef _AP4_DEBUG_H_
00030 #define _AP4_DEBUG_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Config.h"
00036
00037 /*----------------------------------------------------------------------
00038 |   AP4_Debug
00039 +---------------------------------------------------------------------*/
00040 extern void AP4_Debug(const char* format, ...);
00041
00042 /*----------------------------------------------------------------------
00043 |   AP4_ASSERT
00044 +---------------------------------------------------------------------*/
00045 #if defined (AP4_CONFIG_HAVE_ASSERT_H)
00046 #include <assert.h>
00047 #define AP4_ASSERT assert
00048 #endif
00049
00050
00051 #endif // _AP4_DEBUG_H_
Generated on Thu May 13 16:36:31 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4DecoderConfigDescriptor.h File Reference

  • File List
  • File Members

Ap4DecoderConfigDescriptor.h File Reference

#include "Ap4Types.h"
#include "Ap4List.h"
#include "Ap4Descriptor.h"
#include "Ap4DecoderSpecificInfoDescriptor.h"

Go to the source code of this file.

Classes

class | AP4_DecoderConfigDescriptor

Variables

const AP4_UI08 | AP4_DESCRIPTOR_TAG_DECODER_CONFIG = 0x04

Variable Documentation

const AP4_UI08 AP4_DESCRIPTOR_TAG_DECODER_CONFIG = 0x04

Definition at line 48 of file Ap4DecoderConfigDescriptor.h.

Generated on Thu May 13 16:36:36 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4DecoderConfigDescriptor.h Source File

  • File List
  • File Members

Ap4DecoderConfigDescriptor.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - DecoderConfig Descriptor
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027  ****************************************************************/
00028
00029 #ifndef _AP4_DECODER_CONFIG_DESCRIPTOR_H_
00030 #define _AP4_DECODER_CONFIG_DESCRIPTOR_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Types.h"
00036 #include "Ap4List.h"
00037 #include "Ap4Descriptor.h"
00038 #include "Ap4DecoderSpecificInfoDescriptor.h"
00039
00040 /*----------------------------------------------------------------------
00041 |   class references
00042 +---------------------------------------------------------------------*/
00043 class AP4_ByteStream;
00044
00045 /*----------------------------------------------------------------------
00046 |   constants
00047 +---------------------------------------------------------------------*/
00048 const AP4_UI08 AP4_DESCRIPTOR_TAG_DECODER_CONFIG = 0x04;
00049
00050 /*----------------------------------------------------------------------
00051 |   AP4_DecoderConfigDescriptor
00052 +---------------------------------------------------------------------*/
00053 class AP4_DecoderConfigDescriptor : public AP4_Descriptor
00054 {
00055  public:
00056     AP4_IMPLEMENT_DYNAMIC_CAST_D(AP4_DecoderConfigDescriptor, AP4_Descriptor)
00057
00058     // methods
00059     AP4_DecoderConfigDescriptor(AP4_UI08 stream_type,
00060                                 AP4_UI08 oti,
00061                                 AP4_UI32 buffer_size,
00062                                 AP4_UI32 max_bitrate,
00063                                 AP4_UI32 avg_bitrate,
00064                                 AP4_DecoderSpecificInfoDescriptor* dsi);
00065     AP4_DecoderConfigDescriptor(AP4_ByteStream& stream,
00066                                 AP4_Size        header_size,
00067                                 AP4_Size        payload_size);
00068     virtual ~AP4_DecoderConfigDescriptor();
00069     virtual AP4_Result WriteFields(AP4_ByteStream& stream);
00070     virtual AP4_Result Inspect(AP4_AtomInspector& inspector);
00071
00072     // accessors
00073     virtual const AP4_DecoderSpecificInfoDescriptor*
00074         GetDecoderSpecificInfoDescriptor() const;
00075     virtual AP4_UI08 GetObjectTypeIndication() const {
00076         return m_ObjectTypeIndication;
00077     }
00078     virtual AP4_UI08 GetStreamType() const { return m_StreamType; }
00079     virtual AP4_UI32 GetBufferSize() const { return m_BufferSize; }
00080     virtual AP4_UI32 GetMaxBitrate() const { return m_MaxBitrate; }
00081     virtual AP4_UI32 GetAvgBitrate() const { return m_AverageBitrate; }
00082
00083  private:
00084     // members
00085     AP4_UI08                         m_StreamType;
00086     AP4_UI08                         m_ObjectTypeIndication;
00087     bool                             m_UpStream;
00088     AP4_UI32                         m_BufferSize;
00089     AP4_UI32                         m_MaxBitrate;
00090     AP4_UI32                         m_AverageBitrate;
00091     mutable AP4_List<AP4_Descriptor> m_SubDescriptors;
00092 };
00093
00094 #endif // _AP4_DECODER_CONFIG_DESCRIPTOR_H_
Generated on Thu May 13 16:36:32 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4DecoderSpecificInfoDescriptor.h File Reference

  • File List
  • File Members

Ap4DecoderSpecificInfoDescriptor.h File Reference

#include "Ap4Types.h"
#include "Ap4List.h"
#include "Ap4Descriptor.h"
#include "Ap4DataBuffer.h"

Go to the source code of this file.

Classes

class | AP4_DecoderSpecificInfoDescriptor

Variables

const AP4_UI08 | AP4_DESCRIPTOR_TAG_DECODER_SPECIFIC_INFO = 0x05

Variable Documentation

const AP4_UI08 AP4_DESCRIPTOR_TAG_DECODER_SPECIFIC_INFO = 0x05

Definition at line 48 of file Ap4DecoderSpecificInfoDescriptor.h.

Generated on Thu May 13 16:36:36 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4DecoderSpecificInfoDescriptor.h Source File

  • File List
  • File Members

Ap4DecoderSpecificInfoDescriptor.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - DecoderSpecificInfo Descriptor
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027  ****************************************************************/
00028
00029 #ifndef _AP4_DECODER_SPECIFIC_INFO_DESCRIPTOR_H_
00030 #define _AP4_DECODER_SPECIFIC_INFO_DESCRIPTOR_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Types.h"
00036 #include "Ap4List.h"
00037 #include "Ap4Descriptor.h"
00038 #include "Ap4DataBuffer.h"
00039
00040 /*----------------------------------------------------------------------
00041 |   class references
00042 +---------------------------------------------------------------------*/
00043 class AP4_ByteStream;
00044
00045 /*----------------------------------------------------------------------
00046 |   constants
00047 +---------------------------------------------------------------------*/
00048 const AP4_UI08 AP4_DESCRIPTOR_TAG_DECODER_SPECIFIC_INFO = 0x05;
00049
00050 /*----------------------------------------------------------------------
00051 |   AP4_DecoderSpecificInfoDescriptor
00052 +---------------------------------------------------------------------*/
00053 class AP4_DecoderSpecificInfoDescriptor : public AP4_Descriptor
00054 {
00055 public:
00056     AP4_IMPLEMENT_DYNAMIC_CAST_D(AP4_DecoderSpecificInfoDescriptor, AP4_Descriptor)
00057
00058     // methods
00059     AP4_DecoderSpecificInfoDescriptor(const AP4_DataBuffer& data);
00060     AP4_DecoderSpecificInfoDescriptor(AP4_ByteStream& stream,
00061                                       AP4_Size        header_size,
00062                                       AP4_Size        payload_size);
00063     virtual ~AP4_DecoderSpecificInfoDescriptor();
00064     virtual AP4_Result WriteFields(AP4_ByteStream& stream);
00065     virtual AP4_Result Inspect(AP4_AtomInspector& inspector);
00066     virtual const AP4_DataBuffer& GetDecoderSpecificInfo() const { return m_Info; }
00067
00068 private:
00069     // members
00070     AP4_DataBuffer m_Info;
00071 };
00072
00073 #endif // _AP4_DECODER_SPECIFIC_INFO_DESCRIPTOR_H_
Generated on Thu May 13 16:36:32 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4Descriptor.h File Reference

  • File List
  • File Members

Ap4Descriptor.h File Reference

#include "Ap4Expandable.h"
#include "Ap4List.h"
#include "Ap4DynamicCast.h"

Go to the source code of this file.

Classes

class | AP4_Descriptor
class | AP4_UnknownDescriptor
class | AP4_DescriptorFinder
class | AP4_DescriptorListWriter
class | AP4_DescriptorListInspector
Generated on Thu May 13 16:36:36 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4Descriptor.h Source File

  • File List
  • File Members

Ap4Descriptor.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - Descriptors
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027  ****************************************************************/
00028
00029 #ifndef _AP4_DESCRIPTOR_H_
00030 #define _AP4_DESCRIPTOR_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Expandable.h"
00036 #include "Ap4List.h"
00037 #include "Ap4DynamicCast.h"
00038
00039 /*----------------------------------------------------------------------
00040 |   class references
00041 +---------------------------------------------------------------------*/
00042 class AP4_ByteStream;
00043 class AP4_AtomInspector;
00044
00045 /*----------------------------------------------------------------------
00046 |   AP4_Descriptor
00047 +---------------------------------------------------------------------*/
00048 class AP4_Descriptor : public AP4_Expandable
00049 {
00050  public:
00051     AP4_IMPLEMENT_DYNAMIC_CAST(AP4_Descriptor)
00052
00053     // constructor
00054     AP4_Descriptor(AP4_UI08 tag, AP4_Size header_size, AP4_Size payload_size) :
00055         AP4_Expandable(tag, CLASS_ID_SIZE_08, header_size, payload_size) {}
00056
00057     // AP4_Exandable methods
00058     virtual AP4_Result Inspect(AP4_AtomInspector& inspector);
00059
00060     // methods
00061     AP4_UI08 GetTag() { return (AP4_UI08)m_ClassId; }
00062 };
00063
00064 /*----------------------------------------------------------------------
00065 |   AP4_UnknownDescriptor
00066 +---------------------------------------------------------------------*/
00067 class AP4_UnknownDescriptor : public AP4_Descriptor
00068 {
00069 public:
00070     // contrusctor
00071     AP4_UnknownDescriptor(AP4_ByteStream& stream,
00072                           AP4_UI08        tag,
00073                           AP4_Size        header_size,
00074                           AP4_Size        payload_size);
00075
00076     // AP4_Expandable methods
00077     virtual AP4_Result WriteFields(AP4_ByteStream& stream);
00078
00079 private:
00080     // members
00081     AP4_DataBuffer m_Data;
00082 };
00083
00084 /*----------------------------------------------------------------------
00085 |   AP4_DescriptorFinder
00086 +---------------------------------------------------------------------*/
00087 class AP4_DescriptorFinder : public AP4_List<AP4_Descriptor>::Item::Finder
00088 {
00089  public:
00090     AP4_DescriptorFinder(AP4_UI08 tag) : m_Tag(tag) {}
00091     AP4_Result Test(AP4_Descriptor* descriptor) const {
00092         return descriptor->GetTag() == m_Tag ? AP4_SUCCESS : AP4_FAILURE;
00093     }
00094
00095  private:
00096     AP4_UI08 m_Tag;
00097 };
00098
00099 /*----------------------------------------------------------------------
00100 |   AP4_DescriptorListWriter
00101 +---------------------------------------------------------------------*/
00102 class AP4_DescriptorListWriter : public AP4_List<AP4_Descriptor>::Item::Operator
00103 {
00104 public:
00105     AP4_DescriptorListWriter(AP4_ByteStream& stream) :
00106       m_Stream(stream) {}
00107     AP4_Result Action(AP4_Descriptor* descriptor) const {
00108         return descriptor->Write(m_Stream);
00109     }
00110
00111 private:
00112     AP4_ByteStream& m_Stream;
00113 };
00114
00115 /*----------------------------------------------------------------------
00116 |   AP4_DescriptorListInspector
00117 +---------------------------------------------------------------------*/
00118 class AP4_DescriptorListInspector : public AP4_List<AP4_Descriptor>::Item::Operator
00119 {
00120  public:
00121     AP4_DescriptorListInspector(AP4_AtomInspector& inspector) :
00122         m_Inspector(inspector) {}
00123     AP4_Result Action(AP4_Descriptor* descriptor) const {
00124         descriptor->Inspect(m_Inspector);
00125         return AP4_SUCCESS;
00126     }
00127
00128  private:
00129     AP4_AtomInspector& m_Inspector;
00130 };
00131
00132 #endif // _AP4_DESCRIPTOR_H_
Generated on Thu May 13 16:36:32 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4DescriptorFactory.h File Reference

  • File List
  • File Members

Ap4DescriptorFactory.h File Reference

#include "Ap4Types.h"

Go to the source code of this file.

Classes

class AP4_DescriptorFactory
Generated on Thu May 13 16:36:36 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4DescriptorFactory.h Source File

  • File List
  • File Members

Ap4DescriptorFactory.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - Descriptor Factory
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027  ****************************************************************/
00028
00029 #ifndef _AP4_DESCRIPTOR_FACTORY_H_
00030 #define _AP4_DESCRIPTOR_FACTORY_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Types.h"
00036
00037 /*----------------------------------------------------------------------
00038 |   class references
00039 +---------------------------------------------------------------------*/
00040 class AP4_ByteStream;
00041 class AP4_Descriptor;
00042
00043 /*----------------------------------------------------------------------
00044 |   AP4_DescriptorFactory
00045 +---------------------------------------------------------------------*/
00046 class AP4_DescriptorFactory
00047 {
00048  public:
00049     // class methods
00050     static AP4_Result CreateDescriptorFromStream(AP4_ByteStream&  stream,
00051                                                  AP4_Descriptor*& descriptor);
00052 };
00053
00054 #endif // _AP4_DESCRIPTOR_FACTORY_H_
Generated on Thu May 13 16:36:32 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4DrefAtom.h File Reference

  • File List
  • File Members

Ap4DrefAtom.h File Reference

#include "Ap4Types.h"
#include "Ap4ContainerAtom.h"

Go to the source code of this file.

Classes

class AP4_DrefAtom
Generated on Thu May 13 16:36:37 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4DrefAtom.h Source File

  • File List
  • File Members

Ap4DrefAtom.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - dref Atoms
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027  ****************************************************************/
00028
00029 #ifndef _AP4_DREF_ATOM_H_
00030 #define _AP4_DREF_ATOM_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Types.h"
00036 #include "Ap4ContainerAtom.h"
00037
00038 /*----------------------------------------------------------------------
00039 |   class references
00040 +---------------------------------------------------------------------*/
00041 class AP4_ByteStream;
00042 class AP4_AtomFactory;
00043
00044 /*----------------------------------------------------------------------
00045 |   AP4_DrefAtom
00046 +---------------------------------------------------------------------*/
00047 class AP4_DrefAtom : public AP4_ContainerAtom
00048 {
00049 public:
00050     // class methods
00051     static AP4_DrefAtom* Create(AP4_UI32         size,
00052                                 AP4_ByteStream&  stream,
00053                                 AP4_AtomFactory& atom_factory);
00054
00055     // methods
00056     AP4_DrefAtom(AP4_Atom** refs, AP4_Cardinal refs_count);
00057     virtual AP4_Result WriteFields(AP4_ByteStream& stream);
00058
00059 private:
00060     // methods
00061     AP4_DrefAtom(AP4_UI32         size,
00062                  AP4_UI32         version,
00063                  AP4_UI32         flags,
00064                  AP4_ByteStream&  stream,
00065                  AP4_AtomFactory& atom_factory);
00066 };
00067
00068 #endif // _AP4_DREF_ATOM_H_
Generated on Thu May 13 16:36:32 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4DynamicCast.h File Reference

  • File List
  • File Members

Ap4DynamicCast.h File Reference

Dynamic Cast Support. More...

#include "Ap4Config.h"

Go to the source code of this file.

Defines

#define | AP4_DYNAMIC_CAST(_class, _object) dynamic_cast<_class*>(_object)
#define | AP4_IMPLEMENT_DYNAMIC_CAST(_class)
#define | AP4_IMPLEMENT_DYNAMIC_CAST_D(_class, _superclass)
#define | AP4_IMPLEMENT_DYNAMIC_CAST_D2(_class, _superclass, _mixin)
#define | AP4_DEFINE_DYNAMIC_CAST_ANCHOR(_class)

Detailed Description

Dynamic Cast Support.

Definition in file Ap4DynamicCast.h.

Define Documentation

#define AP4_DEFINE_DYNAMIC_CAST_ANCHOR ( _class )

Definition at line 82 of file Ap4DynamicCast.h.

#define AP4_DYNAMIC_CAST | ( | _class,
 |  | _object | ) | dynamic_cast<_class*>(_object)

Definition at line 78 of file Ap4DynamicCast.h.

#define AP4_IMPLEMENT_DYNAMIC_CAST ( _class )

Definition at line 79 of file Ap4DynamicCast.h.

#define AP4_IMPLEMENT_DYNAMIC_CAST_D | ( | _class,
 |  | _superclass | )

Definition at line 80 of file Ap4DynamicCast.h.

#define AP4_IMPLEMENT_DYNAMIC_CAST_D2 | ( | _class,
 |  | _superclass,
 |  | _mixin | )

Definition at line 81 of file Ap4DynamicCast.h.

Generated on Thu May 13 16:36:37 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4DynamicCast.h Source File

  • File List
  • File Members

Ap4DynamicCast.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - Target Platform and Compiler Configuration
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027  ****************************************************************/
00032 #ifndef _AP4_DYNAMIC_CAST_H_
00033 #define _AP4_DYNAMIC_CAST_H_
00034
00035 /*----------------------------------------------------------------------
00036 |   includes
00037 +---------------------------------------------------------------------*/
00038 #include "Ap4Config.h"
00039
00040 /*----------------------------------------------------------------------
00041 |   macros
00042 +---------------------------------------------------------------------*/
00043 #if defined(AP4_CONFIG_NO_RTTI)
00044 #define AP4_DYNAMIC_CAST(_class,_object) \
00045 ( ((_object)==0) ? 0 : reinterpret_cast<_class*>((_object)->DynamicCast(&_class::_class_##_class)) )
00046 #define AP4_IMPLEMENT_DYNAMIC_CAST(_class)              \
00047 static int _class_##_class;                             \
00048 virtual void* DynamicCast(const void* class_anchor) {   \
00049     if (class_anchor ==  &_class::_class_##_class) {    \
00050         return static_cast<_class*>(this);              \
00051     }                                                   \
00052     return NULL;                                        \
00053 }
00054 #define AP4_IMPLEMENT_DYNAMIC_CAST_D(_class,_superclass)\
00055 static int _class_##_class;                             \
00056 virtual void* DynamicCast(const void* class_anchor) {   \
00057     if (class_anchor ==  &_class::_class_##_class) {    \
00058         return static_cast<_class*>(this);              \
00059     } else {                                            \
00060         return _superclass::DynamicCast(class_anchor);  \
00061     }                                                   \
00062 }
00063 #define AP4_IMPLEMENT_DYNAMIC_CAST_D2(_class,_superclass,_mixin)\
00064 static int _class_##_class;                                 \
00065 virtual void* DynamicCast(const void* class_anchor) {       \
00066     if (class_anchor ==  &_class::_class_##_class) {        \
00067         return static_cast<_class*>(this);                  \
00068     } else {                                                \
00069         void* sup = _superclass::DynamicCast(class_anchor); \
00070         if (sup) return sup;                                \
00071         return _mixin::DynamicCast(class_anchor);           \
00072     }                                                       \
00073 }
00074 #define AP4_DEFINE_DYNAMIC_CAST_ANCHOR(_class) int _class::_class_##_class = 0;
00075
00076 #else
00077
00078 #define AP4_DYNAMIC_CAST(_class,_object) dynamic_cast<_class*>(_object)
00079 #define AP4_IMPLEMENT_DYNAMIC_CAST(_class)
00080 #define AP4_IMPLEMENT_DYNAMIC_CAST_D(_class,_superclass)
00081 #define AP4_IMPLEMENT_DYNAMIC_CAST_D2(_class,_superclass,_mixin)
00082 #define AP4_DEFINE_DYNAMIC_CAST_ANCHOR(_class)
00083
00084 #endif
00085
00086 #endif // _AP4_DYNAMIC_CAST_H_
Generated on Thu May 13 16:36:32 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4ElstAtom.h File Reference

  • File List
  • File Members

Ap4ElstAtom.h File Reference

#include "Ap4Types.h"
#include "Ap4Atom.h"
#include "Ap4Array.h"

Go to the source code of this file.

Classes

class | AP4_ElstEntry
class | AP4_ElstAtom
Generated on Thu May 13 16:36:37 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4ElstAtom.h Source File

  • File List
  • File Members

Ap4ElstAtom.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - elst Atoms
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027  ****************************************************************/
00028
00029 #ifndef _AP4_ELST_ATOM_H_
00030 #define _AP4_ELST_ATOM_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Types.h"
00036 #include "Ap4Atom.h"
00037 #include "Ap4Array.h"
00038
00039 /*----------------------------------------------------------------------
00040 |   class references
00041 +---------------------------------------------------------------------*/
00042 class AP4_ByteStream;
00043
00044 /*----------------------------------------------------------------------
00045 |   AP4_ElstAtom
00046 +---------------------------------------------------------------------*/
00047 class AP4_ElstEntry {
00048 public:
00049     AP4_ElstEntry(AP4_UI64 segment_duration = 0, AP4_SI64 media_time = 0, AP4_UI16 media_rate = 1) :
00050       m_SegmentDuration(segment_duration),
00051       m_MediaTime(media_time),
00052       m_MediaRate(media_rate) {}
00053
00054     AP4_UI64 m_SegmentDuration;
00055     AP4_SI64 m_MediaTime;
00056     AP4_UI16 m_MediaRate;
00057 };
00058
00059 class AP4_ElstAtom : public AP4_Atom
00060 {
00061 public:
00062     // class methods
00063     static AP4_ElstAtom* Create(AP4_Size size, AP4_ByteStream& stream);
00064
00065     // methods
00066     virtual AP4_Result InspectFields(AP4_AtomInspector& inspector);
00067     virtual AP4_Result WriteFields(AP4_ByteStream& stream);
00068
00069 private:
00070     // methods
00071     AP4_ElstAtom(AP4_UI32        size,
00072                  AP4_UI32        version,
00073                  AP4_UI32        flags,
00074                  AP4_ByteStream& stream);
00075
00076     // members
00077     AP4_Array<AP4_ElstEntry> m_Entries;
00078 };
00079
00080 #endif // _AP4_ELST_ATOM_H_
Generated on Thu May 13 16:36:32 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4EsDescriptor.h File Reference

  • File List
  • File Members

Ap4EsDescriptor.h File Reference

#include "Ap4List.h"
#include "Ap4String.h"
#include "Ap4Descriptor.h"
#include "Ap4DecoderConfigDescriptor.h"

Go to the source code of this file.

Classes

class | AP4_EsDescriptor
class | AP4_EsIdIncDescriptor
class | AP4_EsIdRefDescriptor

Variables

const AP4_UI08 | AP4_DESCRIPTOR_TAG_ES = 0x03
const AP4_UI08 | AP4_DESCRIPTOR_TAG_ES_ID_INC = 0x0E
const AP4_UI08 | AP4_DESCRIPTOR_TAG_ES_ID_REF = 0x0F
const int | AP4_ES_DESCRIPTOR_FLAG_STREAM_DEPENDENCY = 1
const int | AP4_ES_DESCRIPTOR_FLAG_URL = 2
const int | AP4_ES_DESCRIPTOR_FLAG_OCR_STREAM = 4

Variable Documentation

const AP4_UI08 AP4_DESCRIPTOR_TAG_ES = 0x03

Definition at line 48 of file Ap4EsDescriptor.h.

const AP4_UI08 AP4_DESCRIPTOR_TAG_ES_ID_INC = 0x0E

Definition at line 49 of file Ap4EsDescriptor.h.

const AP4_UI08 AP4_DESCRIPTOR_TAG_ES_ID_REF = 0x0F

Definition at line 50 of file Ap4EsDescriptor.h.

const int AP4_ES_DESCRIPTOR_FLAG_OCR_STREAM = 4

Definition at line 54 of file Ap4EsDescriptor.h.

const int AP4_ES_DESCRIPTOR_FLAG_STREAM_DEPENDENCY = 1

Definition at line 52 of file Ap4EsDescriptor.h.

const int AP4_ES_DESCRIPTOR_FLAG_URL = 2

Definition at line 53 of file Ap4EsDescriptor.h.

Generated on Thu May 13 16:36:37 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4EsDescriptor.h Source File

  • File List
  • File Members

Ap4EsDescriptor.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - ES Descriptor
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027  ****************************************************************/
00028
00029 #ifndef _AP4_ES_DESCRIPTOR_H_
00030 #define _AP4_ES_DESCRIPTOR_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4List.h"
00036 #include "Ap4String.h"
00037 #include "Ap4Descriptor.h"
00038 #include "Ap4DecoderConfigDescriptor.h"
00039
00040 /*----------------------------------------------------------------------
00041 |   class references
00042 +---------------------------------------------------------------------*/
00043 class AP4_ByteStream;
00044
00045 /*----------------------------------------------------------------------
00046 |   constants
00047 +---------------------------------------------------------------------*/
00048 const AP4_UI08 AP4_DESCRIPTOR_TAG_ES        = 0x03;
00049 const AP4_UI08 AP4_DESCRIPTOR_TAG_ES_ID_INC = 0x0E;
00050 const AP4_UI08 AP4_DESCRIPTOR_TAG_ES_ID_REF = 0x0F;
00051
00052 const int AP4_ES_DESCRIPTOR_FLAG_STREAM_DEPENDENCY = 1;
00053 const int AP4_ES_DESCRIPTOR_FLAG_URL               = 2;
00054 const int AP4_ES_DESCRIPTOR_FLAG_OCR_STREAM        = 4;
00055
00056 /*----------------------------------------------------------------------
00057 |   AP4_EsDescriptor
00058 +---------------------------------------------------------------------*/
00059 class AP4_EsDescriptor : public AP4_Descriptor
00060 {
00061  public:
00062     AP4_IMPLEMENT_DYNAMIC_CAST_D(AP4_EsDescriptor, AP4_Descriptor)
00063
00064     // methods
00065     AP4_EsDescriptor(AP4_UI16 es_id);
00066     AP4_EsDescriptor(AP4_ByteStream& stream,
00067                      AP4_Size        header_size,
00068                      AP4_Size        payload_size);
00069     ~AP4_EsDescriptor();
00070     virtual AP4_Result AddSubDescriptor(AP4_Descriptor* descriptor);
00071     virtual AP4_Result WriteFields(AP4_ByteStream& stream);
00072     virtual AP4_Result Inspect(AP4_AtomInspector& inspector);
00073     virtual const AP4_DecoderConfigDescriptor* GetDecoderConfigDescriptor() const;
00074
00075  private:
00076     // members
00077     unsigned short                   m_EsId;
00078     unsigned short                   m_OcrEsId;
00079     AP4_Flags                        m_Flags;
00080     unsigned char                    m_StreamPriority;
00081     unsigned short                   m_DependsOn;
00082     AP4_String                       m_Url;
00083     mutable AP4_List<AP4_Descriptor> m_SubDescriptors;
00084 };
00085
00086 /*----------------------------------------------------------------------
00087 |   AP4_EsIdIncDescriptor
00088 +---------------------------------------------------------------------*/
00089 class AP4_EsIdIncDescriptor : public AP4_Descriptor
00090 {
00091  public:
00092     AP4_IMPLEMENT_DYNAMIC_CAST_D(AP4_EsIdIncDescriptor, AP4_Descriptor)
00093
00094     // methods
00095     AP4_EsIdIncDescriptor(AP4_UI32 track_id);
00096     AP4_EsIdIncDescriptor(AP4_ByteStream& stream,
00097                           AP4_Size        header_size,
00098                           AP4_Size        payload_size);
00099     virtual AP4_Result WriteFields(AP4_ByteStream& stream);
00100     virtual AP4_Result Inspect(AP4_AtomInspector& inspector);
00101
00102     // accessors
00103     AP4_UI32 GetTrackId() const { return m_TrackId; }
00104
00105  private:
00106     // members
00107     AP4_UI32 m_TrackId;
00108 };
00109
00110 /*----------------------------------------------------------------------
00111 |   AP4_EsIdRefDescriptor
00112 +---------------------------------------------------------------------*/
00113 class AP4_EsIdRefDescriptor : public AP4_Descriptor
00114 {
00115  public:
00116     AP4_IMPLEMENT_DYNAMIC_CAST_D(AP4_EsIdRefDescriptor, AP4_Descriptor)
00117
00118     // methods
00119     AP4_EsIdRefDescriptor(AP4_UI16 ref_index);
00120     AP4_EsIdRefDescriptor(AP4_ByteStream& stream,
00121                           AP4_Size        header_size,
00122                           AP4_Size        payload_size);
00123     virtual AP4_Result WriteFields(AP4_ByteStream& stream);
00124     virtual AP4_Result Inspect(AP4_AtomInspector& inspector);
00125
00126     // accessors
00127     AP4_UI16 GetRefIndex() const { return m_RefIndex; }
00128
00129  private:
00130     // members
00131     AP4_UI16 m_RefIndex;
00132 };
00133
00134 #endif // _AP4_ES_DESCRIPTOR_H_
Generated on Thu May 13 16:36:32 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4EsdsAtom.h File Reference

  • File List
  • File Members

Ap4EsdsAtom.h File Reference

#include "Ap4Types.h"
#include "Ap4Atom.h"
#include "Ap4EsDescriptor.h"

Go to the source code of this file.

Classes

class AP4_EsdsAtom
Generated on Thu May 13 16:36:37 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4EsdsAtom.h Source File

  • File List
  • File Members

Ap4EsdsAtom.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - esds Atoms
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027  ****************************************************************/
00028
00029 #ifndef _AP4_ESDS_ATOM_H_
00030 #define _AP4_ESDS_ATOM_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Types.h"
00036 #include "Ap4Atom.h"
00037 #include "Ap4EsDescriptor.h"
00038
00039 /*----------------------------------------------------------------------
00040 |   class references
00041 +---------------------------------------------------------------------*/
00042 class AP4_ByteStream;
00043
00044 /*----------------------------------------------------------------------
00045 |   AP4_EsdsAtom
00046 +---------------------------------------------------------------------*/
00047 class AP4_EsdsAtom : public AP4_Atom
00048 {
00049 public:
00050     AP4_IMPLEMENT_DYNAMIC_CAST_D(AP4_EsdsAtom, AP4_Atom)
00051
00052     // class methods
00053     static AP4_EsdsAtom* Create(AP4_Size size, AP4_ByteStream& stream);
00054
00055     // methods
00056     AP4_EsdsAtom(AP4_EsDescriptor* descriptor);
00057    ~AP4_EsdsAtom();
00058     virtual AP4_Result WriteFields(AP4_ByteStream& stream);
00059     virtual AP4_Result InspectFields(AP4_AtomInspector& inspector);
00060     const AP4_EsDescriptor* GetEsDescriptor() const { return m_EsDescriptor; }
00061
00062 private:
00063     // methods
00064     AP4_EsdsAtom(AP4_UI32        size,
00065                  AP4_UI32        version,
00066                  AP4_UI32        flags,
00067                  AP4_ByteStream& stream);
00068
00069     // members
00070     AP4_EsDescriptor* m_EsDescriptor;
00071 };
00072
00073 #endif // _AP4_ESDS_ATOM_H_
Generated on Thu May 13 16:36:32 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4Expandable.h File Reference

  • File List
  • File Members

Ap4Expandable.h File Reference

#include "Ap4Types.h"
#include "Ap4DataBuffer.h"

Go to the source code of this file.

Classes

class | AP4_Expandable
class | AP4_UnknownExpandable
Generated on Thu May 13 16:36:37 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4Expandable.h Source File

  • File List
  • File Members

Ap4Expandable.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - Expandable base class
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027  ****************************************************************/
00028
00029 #ifndef _AP4_EXPANDABLE_H_
00030 #define _AP4_EXPANDABLE_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Types.h"
00036 #include "Ap4DataBuffer.h"
00037
00038 /*----------------------------------------------------------------------
00039 |   class references
00040 +---------------------------------------------------------------------*/
00041 class AP4_ByteStream;
00042 class AP4_AtomInspector;
00043
00044 /*----------------------------------------------------------------------
00045 |   AP4_Expandable
00046 +---------------------------------------------------------------------*/
00047 class AP4_Expandable
00048 {
00049  public:
00050     // types
00051     enum ClassIdSize {
00052         CLASS_ID_SIZE_08
00053     };
00054
00055     // class methods
00056     static AP4_Size MinHeaderSize(AP4_Size payload_size);
00057
00058     // methods
00059     AP4_Expandable(AP4_UI32    class_id,
00060                    ClassIdSize class_id_size,
00061                    AP4_Size    header_size,
00062                    AP4_Size    payload_size);
00063     virtual ~AP4_Expandable() {}
00064     AP4_UI32           GetClassId()    { return m_ClassId;                  }
00065     AP4_Size           GetSize()       { return m_PayloadSize+m_HeaderSize; }
00066     AP4_Size           GetHeaderSize() { return m_HeaderSize;               }
00067     virtual AP4_Result Write(AP4_ByteStream& stream);
00068     virtual AP4_Result WriteFields(AP4_ByteStream& stream) = 0;
00069     virtual AP4_Result Inspect(AP4_AtomInspector& inspector);
00070
00071  protected:
00072     // members
00073     AP4_UI32    m_ClassId;
00074     ClassIdSize m_ClassIdSize;
00075     AP4_Size    m_HeaderSize;
00076     AP4_Size    m_PayloadSize;
00077 };
00078
00079 /*----------------------------------------------------------------------
00080 |   AP4_UnknownExpandable
00081 +---------------------------------------------------------------------*/
00082 class AP4_UnknownExpandable : public AP4_Expandable
00083 {
00084 public:
00085     // methods
00086     AP4_UnknownExpandable(AP4_ByteStream& stream,
00087                           AP4_UI32        class_id,
00088                           ClassIdSize     class_id_size,
00089                           AP4_Size        header_size,
00090                           AP4_Size        payload_size);
00091     virtual AP4_Result WriteFields(AP4_ByteStream& stream);
00092
00093 private:
00094     // members
00095     AP4_DataBuffer m_Data;
00096 };
00097
00098 #endif // _AP4_EXPANDABLE_H_
Generated on Thu May 13 16:36:32 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4File.h File Reference

  • File List
  • File Members

Ap4File.h File Reference

#include "Ap4Types.h"
#include "Ap4List.h"
#include "Ap4Atom.h"
#include "Ap4AtomFactory.h"

Go to the source code of this file.

Classes

class | AP4_File
The AP4_File object is the top level object for MP4 Files. More...

Variables

const AP4_UI32 | AP4_FILE_BRAND_QT__ = AP4_ATOM_TYPE('q','t',' ',' ')
const AP4_UI32 | AP4_FILE_BRAND_ISOM = AP4_ATOM_TYPE('i','s','o','m')
const AP4_UI32 | AP4_FILE_BRAND_MP41 = AP4_ATOM_TYPE('m','p','4','1')
const AP4_UI32 | AP4_FILE_BRAND_MP42 = AP4_ATOM_TYPE('m','p','4','2')
const AP4_UI32 | AP4_FILE_BRAND_3GP1 = AP4_ATOM_TYPE('3','g','p','1')
const AP4_UI32 | AP4_FILE_BRAND_3GP2 = AP4_ATOM_TYPE('3','g','p','2')
const AP4_UI32 | AP4_FILE_BRAND_3GP3 = AP4_ATOM_TYPE('3','g','p','3')
const AP4_UI32 | AP4_FILE_BRAND_3GP4 = AP4_ATOM_TYPE('3','g','p','4')
const AP4_UI32 | AP4_FILE_BRAND_3GP5 = AP4_ATOM_TYPE('3','g','p','5')
const AP4_UI32 | AP4_FILE_BRAND_3G2A = AP4_ATOM_TYPE('3','g','2','a')
const AP4_UI32 | AP4_FILE_BRAND_MMP4 = AP4_ATOM_TYPE('m','m','p','4')
const AP4_UI32 | AP4_FILE_BRAND_M4A_ = AP4_ATOM_TYPE('M','4','A',' ')
const AP4_UI32 | AP4_FILE_BRAND_M4P_ = AP4_ATOM_TYPE('M','4','P',' ')
const AP4_UI32 | AP4_FILE_BRAND_MJP2 = AP4_ATOM_TYPE('m','j','p','2')

Variable Documentation

const AP4_UI32 AP4_FILE_BRAND_3G2A = AP4_ATOM_TYPE('3','g','2','a')

Definition at line 60 of file Ap4File.h.

const AP4_UI32 AP4_FILE_BRAND_3GP1 = AP4_ATOM_TYPE('3','g','p','1')

Definition at line 55 of file Ap4File.h.

const AP4_UI32 AP4_FILE_BRAND_3GP2 = AP4_ATOM_TYPE('3','g','p','2')

Definition at line 56 of file Ap4File.h.

const AP4_UI32 AP4_FILE_BRAND_3GP3 = AP4_ATOM_TYPE('3','g','p','3')

Definition at line 57 of file Ap4File.h.

const AP4_UI32 AP4_FILE_BRAND_3GP4 = AP4_ATOM_TYPE('3','g','p','4')

Definition at line 58 of file Ap4File.h.

const AP4_UI32 AP4_FILE_BRAND_3GP5 = AP4_ATOM_TYPE('3','g','p','5')

Definition at line 59 of file Ap4File.h.

const AP4_UI32 AP4_FILE_BRAND_ISOM = AP4_ATOM_TYPE('i','s','o','m')

Definition at line 52 of file Ap4File.h.

const AP4_UI32 AP4_FILE_BRAND_M4A_ = AP4_ATOM_TYPE('M','4','A',' ')

Definition at line 62 of file Ap4File.h.

const AP4_UI32 AP4_FILE_BRAND_M4P_ = AP4_ATOM_TYPE('M','4','P',' ')

Definition at line 63 of file Ap4File.h.

const AP4_UI32 AP4_FILE_BRAND_MJP2 = AP4_ATOM_TYPE('m','j','p','2')

Definition at line 64 of file Ap4File.h.

const AP4_UI32 AP4_FILE_BRAND_MMP4 = AP4_ATOM_TYPE('m','m','p','4')

Definition at line 61 of file Ap4File.h.

const AP4_UI32 AP4_FILE_BRAND_MP41 = AP4_ATOM_TYPE('m','p','4','1')

Definition at line 53 of file Ap4File.h.

const AP4_UI32 AP4_FILE_BRAND_MP42 = AP4_ATOM_TYPE('m','p','4','2')

Definition at line 54 of file Ap4File.h.

const AP4_UI32 AP4_FILE_BRAND_QT__ = AP4_ATOM_TYPE('q','t',' ',' ')

Definition at line 51 of file Ap4File.h.

Generated on Thu May 13 16:36:37 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4File.h Source File

  • File List
  • File Members

Ap4File.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - File
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027  ****************************************************************/
00028
00029 #ifndef _AP4_FILE_H_
00030 #define _AP4_FILE_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Types.h"
00036 #include "Ap4List.h"
00037 #include "Ap4Atom.h"
00038 #include "Ap4AtomFactory.h"
00039
00040 /*----------------------------------------------------------------------
00041 |   class references
00042 +---------------------------------------------------------------------*/
00043 class AP4_ByteStream;
00044 class AP4_Movie;
00045 class AP4_FtypAtom;
00046 class AP4_MetaData;
00047
00048 /*----------------------------------------------------------------------
00049 |   file type/brands
00050 +---------------------------------------------------------------------*/
00051 const AP4_UI32 AP4_FILE_BRAND_QT__ = AP4_ATOM_TYPE('q','t',' ',' ');
00052 const AP4_UI32 AP4_FILE_BRAND_ISOM = AP4_ATOM_TYPE('i','s','o','m');
00053 const AP4_UI32 AP4_FILE_BRAND_MP41 = AP4_ATOM_TYPE('m','p','4','1');
00054 const AP4_UI32 AP4_FILE_BRAND_MP42 = AP4_ATOM_TYPE('m','p','4','2');
00055 const AP4_UI32 AP4_FILE_BRAND_3GP1 = AP4_ATOM_TYPE('3','g','p','1');
00056 const AP4_UI32 AP4_FILE_BRAND_3GP2 = AP4_ATOM_TYPE('3','g','p','2');
00057 const AP4_UI32 AP4_FILE_BRAND_3GP3 = AP4_ATOM_TYPE('3','g','p','3');
00058 const AP4_UI32 AP4_FILE_BRAND_3GP4 = AP4_ATOM_TYPE('3','g','p','4');
00059 const AP4_UI32 AP4_FILE_BRAND_3GP5 = AP4_ATOM_TYPE('3','g','p','5');
00060 const AP4_UI32 AP4_FILE_BRAND_3G2A = AP4_ATOM_TYPE('3','g','2','a');
00061 const AP4_UI32 AP4_FILE_BRAND_MMP4 = AP4_ATOM_TYPE('m','m','p','4');
00062 const AP4_UI32 AP4_FILE_BRAND_M4A_ = AP4_ATOM_TYPE('M','4','A',' ');
00063 const AP4_UI32 AP4_FILE_BRAND_M4P_ = AP4_ATOM_TYPE('M','4','P',' ');
00064 const AP4_UI32 AP4_FILE_BRAND_MJP2 = AP4_ATOM_TYPE('m','j','p','2');
00065
00066 /*----------------------------------------------------------------------
00067 |   AP4_File
00068 +---------------------------------------------------------------------*/
00069
00074 class AP4_File : public AP4_AtomParent {
00075 public:
00076     // constructors and destructor
00081     AP4_File(AP4_Movie* movie = NULL);
00082
00091     AP4_File(AP4_ByteStream&  stream,
00092              AP4_AtomFactory& atom_factory = AP4_DefaultAtomFactory::Instance,
00093              bool             moov_only = false);
00094
00098     virtual ~AP4_File();
00099
00103     AP4_List<AP4_Atom>& GetTopLevelAtoms() { return m_Children; }
00104
00108     AP4_Movie* GetMovie() { return m_Movie; }
00109
00110
00114     AP4_FtypAtom* GetFileType() { return m_FileType; }
00115
00120     AP4_Result SetFileType(AP4_UI32     major_brand,
00121                            AP4_UI32     minor_version,
00122                            AP4_UI32*    compatible_brands = NULL,
00123                            AP4_Cardinal compatible_brand_count = 0);
00124
00128     bool IsMoovBeforeMdat() const { return m_MoovIsBeforeMdat; }
00129
00133     const AP4_MetaData* GetMetaData();
00134
00138     virtual AP4_Result  Inspect(AP4_AtomInspector& inspector);
00139
00140 private:
00141     // members
00142     AP4_Movie*    m_Movie;
00143     AP4_FtypAtom* m_FileType;
00144     AP4_MetaData* m_MetaData;
00145     bool          m_MoovIsBeforeMdat;
00146 };
00147
00148 #endif // _AP4_FILE_H_
Generated on Thu May 13 16:36:32 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4FileByteStream.h File Reference

  • File List
  • File Members

Ap4FileByteStream.h File Reference

#include "Ap4Types.h"
#include "Ap4ByteStream.h"
#include "Ap4Config.h"

Go to the source code of this file.

Classes

class AP4_FileByteStream
Generated on Thu May 13 16:36:37 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4FileByteStream.h Source File

  • File List
  • File Members

Ap4FileByteStream.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - FileByteStream
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027  ****************************************************************/
00028
00029 /*----------------------------------------------------------------------
00030 |   includes
00031 +---------------------------------------------------------------------*/
00032 #include "Ap4Types.h"
00033 #include "Ap4ByteStream.h"
00034 #include "Ap4Config.h"
00035
00036 #ifndef _AP4_FILE_BYTE_STREAM_H_
00037 #define _AP4_FILE_BYTE_STREAM_H_
00038
00039 /*----------------------------------------------------------------------
00040 |   AP4_FileByteStream
00041 +---------------------------------------------------------------------*/
00042 class AP4_FileByteStream: public AP4_ByteStream
00043 {
00044 public:
00045     // types
00046     typedef enum {
00047         STREAM_MODE_READ        = 0,
00048         STREAM_MODE_WRITE       = 1,
00049         STREAM_MODE_READ_WRITE  = 2
00050     } Mode;
00051
00062     static AP4_Result Create(const char* name, Mode mode, AP4_ByteStream*& stream);
00063
00064     // constructors
00065     AP4_FileByteStream(AP4_ByteStream* delegate) : m_Delegate(delegate) {}
00066
00067 #if !defined(AP4_CONFIG_NO_EXCEPTIONS)
00068
00071     AP4_FileByteStream(const char* name, Mode mode);
00072 #endif
00073
00074     // AP4_ByteStream methods
00075     AP4_Result ReadPartial(void*    buffer,
00076                            AP4_Size  bytesToRead,
00077                            AP4_Size& bytesRead) {
00078         return m_Delegate->ReadPartial(buffer, bytesToRead, bytesRead);
00079     }
00080     AP4_Result WritePartial(const void* buffer,
00081                             AP4_Size    bytesToWrite,
00082                             AP4_Size&   bytesWritten) {
00083         return m_Delegate->WritePartial(buffer, bytesToWrite, bytesWritten);
00084     }
00085     AP4_Result Seek(AP4_Position position)  { return m_Delegate->Seek(position); }
00086     AP4_Result Tell(AP4_Position& position) { return m_Delegate->Tell(position); }
00087     AP4_Result GetSize(AP4_LargeSize& size) { return m_Delegate->GetSize(size);  }
00088     AP4_Result Flush()                      { return m_Delegate->Flush();        }
00089
00090     // AP4_Referenceable methods
00091     void AddReference() { m_Delegate->AddReference(); }
00092     void Release()      { m_Delegate->Release();      }
00093
00094 protected:
00095     // methods
00096     virtual ~AP4_FileByteStream() {
00097         delete m_Delegate;
00098     }
00099
00100     // members
00101     AP4_ByteStream* m_Delegate;
00102 };
00103
00104 #endif // _AP4_FILE_BYTE_STREAM_H_
00105
00106
00107
00108
00109
00110
00111
00112
Generated on Thu May 13 16:36:32 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4FileCopier.h File Reference

  • File List
  • File Members

Ap4FileCopier.h File Reference

#include "Ap4Types.h"

Go to the source code of this file.

Classes

class AP4_FileCopier
Generated on Thu May 13 16:36:37 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4FileCopier.h Source File

  • File List
  • File Members

Ap4FileCopier.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - File Writer
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027  ****************************************************************/
00028
00029 #ifndef _AP4_FILE_COPIER_H_
00030 #define _AP4_FILE_COPIER_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Types.h"
00036
00037 /*----------------------------------------------------------------------
00038 |   class references
00039 +---------------------------------------------------------------------*/
00040 class AP4_ByteStream;
00041 class AP4_File;
00042
00043 /*----------------------------------------------------------------------
00044 |   AP4_FileCopier
00045 +---------------------------------------------------------------------*/
00046 class AP4_FileCopier {
00047 public:
00048     // class methods
00049     static AP4_Result Write(AP4_File& file, AP4_ByteStream& stream);
00050
00051 private:
00052     // don't instantiate this class
00053     AP4_FileCopier() {};
00054 };
00055
00056 #endif // _AP4_FILE_COPIER_H_
Generated on Thu May 13 16:36:32 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4FileWriter.h File Reference

  • File List
  • File Members

Ap4FileWriter.h File Reference

#include "Ap4Types.h"

Go to the source code of this file.

Classes

class AP4_FileWriter
Generated on Thu May 13 16:36:37 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4FileWriter.h Source File

  • File List
  • File Members

Ap4FileWriter.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - File Writer
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027  ****************************************************************/
00028
00029 #ifndef _AP4_FILE_WRITER_H_
00030 #define _AP4_FILE_WRITER_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Types.h"
00036
00037 /*----------------------------------------------------------------------
00038 |   class references
00039 +---------------------------------------------------------------------*/
00040 class AP4_ByteStream;
00041 class AP4_File;
00042
00043 /*----------------------------------------------------------------------
00044 |   AP4_FileWriter
00045 +---------------------------------------------------------------------*/
00046 class AP4_FileWriter {
00047 public:
00048     // types
00049     typedef enum {
00050         INTERLEAVING_SEQUENTIAL
00051     } Interleaving;
00052
00053     // class methods
00054     static AP4_Result Write(AP4_File&       file,
00055                             AP4_ByteStream& stream,
00056                             Interleaving    interleaving = INTERLEAVING_SEQUENTIAL);
00057
00058 private:
00059     // don't instantiate this class
00060     AP4_FileWriter() {}
00061 };
00062
00063 #endif // _AP4_FILE_WRITER_H_
Generated on Thu May 13 16:36:32 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4FragmentSampleTable.h File Reference

  • File List
  • File Members

Ap4FragmentSampleTable.h File Reference

#include "Ap4Types.h"
#include "Ap4SampleTable.h"
#include "Ap4Array.h"

Go to the source code of this file.

Classes

class AP4_FragmentSampleTable
Generated on Thu May 13 16:36:37 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4FragmentSampleTable.h Source File

  • File List
  • File Members

Ap4FragmentSampleTable.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - Fragment Based Sample Table
00004 |
00005 |    Copyright 2002-2009 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This atom is part of AP4 (MP4 Audio Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the atom COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027  ****************************************************************/
00028
00029 #ifndef _AP4_FRAGMENT_SAMPLE_TABLE_H_
00030 #define _AP4_FRAGMENT_SAMPLE_TABLE_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Types.h"
00036 #include "Ap4SampleTable.h"
00037 #include "Ap4Array.h"
00038
00039 /*----------------------------------------------------------------------
00040 |   forward declarations
00041 +---------------------------------------------------------------------*/
00042 class AP4_Atom;
00043 class AP4_ByteStream;
00044 class AP4_TrunAtom;
00045 class AP4_TrexAtom;
00046 class AP4_TfhdAtom;
00047
00048 /*----------------------------------------------------------------------
00049 |   AP4_FragmentSampleTable
00050 +---------------------------------------------------------------------*/
00051 class AP4_FragmentSampleTable : public AP4_SampleTable
00052 {
00053  public:
00054     // methods
00055              AP4_FragmentSampleTable(AP4_ContainerAtom* traf,
00056                                      AP4_TrexAtom*      trex,
00057                                      AP4_ByteStream*    sample_stream,
00058                                      AP4_Position       moof_offset,
00059                                      AP4_Position       mdat_payload_offset, // hack because MS doesn't implement the spec correctly
00060                                      AP4_UI64           dts_origin=0);
00061     virtual ~AP4_FragmentSampleTable();
00062
00063     // AP4_SampleTable methods
00064     virtual AP4_Result   GetSample(AP4_Ordinal sample_index, AP4_Sample& sample);
00065     virtual AP4_Cardinal GetSampleCount();
00066     virtual AP4_SampleDescription* GetSampleDescription(AP4_Ordinal sd_index);
00067     virtual AP4_Cardinal GetSampleDescriptionCount();
00068     virtual AP4_Result   GetSampleChunkPosition(AP4_Ordinal  sample_index,
00069                                                 AP4_Ordinal& chunk_index,
00070                                                 AP4_Ordinal& position_in_chunk);
00071     virtual AP4_Result   GetSampleIndexForTimeStamp(AP4_UI64 ts, AP4_Ordinal& sample_index);
00072     virtual AP4_Ordinal  GetNearestSyncSampleIndex(AP4_Ordinal index, bool before=true);
00073
00074     // methods
00075     AP4_UI64 GetDuration() { return m_Duration; }
00076
00077 private:
00078     // members
00079     AP4_TrunAtom*         m_TrunAtom;
00080     AP4_Array<AP4_Sample> m_Samples;
00081     AP4_UI64              m_Duration;
00082
00083     // methods
00084     AP4_Result AddTrun(AP4_TrunAtom*   trun,
00085                        AP4_TfhdAtom*   tfhd,
00086                        AP4_TrexAtom*   trex,
00087                        AP4_ByteStream* sample_stream,
00088                        AP4_Position    moof_offset,
00089                        AP4_Position&   payload_offset,
00090                        AP4_UI64&       dts_origin);
00091
00092 };
00093
00094 #endif // _AP4_FRAGMENT_SAMPLE_TABLE_H_
Generated on Thu May 13 16:36:32 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4FrmaAtom.h File Reference

  • File List
  • File Members

Ap4FrmaAtom.h File Reference

#include "Ap4Types.h"
#include "Ap4Atom.h"

Go to the source code of this file.

Classes

class AP4_FrmaAtom
Generated on Thu May 13 16:36:38 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4FrmaAtom.h Source File

  • File List
  • File Members

Ap4FrmaAtom.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - frma Atoms
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027  ****************************************************************/
00028
00029 #ifndef _AP4_FRMA_ATOM_H_
00030 #define _AP4_FRMA_ATOM_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Types.h"
00036 #include "Ap4Atom.h"
00037
00038 /*----------------------------------------------------------------------
00039 |   class references
00040 +---------------------------------------------------------------------*/
00041 class AP4_ByteStream;
00042
00043 /*----------------------------------------------------------------------
00044 |   AP4_FrmaAtom
00045 +---------------------------------------------------------------------*/
00046 class AP4_FrmaAtom : public AP4_Atom
00047 {
00048 public:
00049     AP4_IMPLEMENT_DYNAMIC_CAST_D(AP4_FrmaAtom, AP4_Atom)
00050
00051     // class methods
00052     static AP4_FrmaAtom* Create(AP4_Size size, AP4_ByteStream& stream) {
00053         return new AP4_FrmaAtom(size, stream);
00054     }
00055
00056     // constructors
00057     AP4_FrmaAtom(AP4_UI32 original_format);
00058
00059     // methods
00060     virtual AP4_Result InspectFields(AP4_AtomInspector& inspector);
00061     virtual AP4_Result WriteFields(AP4_ByteStream& stream);
00062     AP4_UI32 GetOriginalFormat() { return m_OriginalFormat; }
00063
00064 private:
00065     // methods
00066     AP4_FrmaAtom(AP4_UI32 size, AP4_ByteStream& stream);
00067
00068     // members
00069     AP4_UI32 m_OriginalFormat;
00070 };
00071
00072 #endif // _AP4_FRMA_ATOM_H_
Generated on Thu May 13 16:36:32 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4FtypAtom.h File Reference

  • File List
  • File Members

Ap4FtypAtom.h File Reference

#include "Ap4Types.h"
#include "Ap4Atom.h"
#include "Ap4Array.h"

Go to the source code of this file.

Classes

class | AP4_FtypAtom

Variables

const AP4_UI32 | AP4_FTYP_BRAND_ISOM = AP4_ATOM_TYPE('i','s','o','m')

Variable Documentation

const AP4_UI32 AP4_FTYP_BRAND_ISOM = AP4_ATOM_TYPE('i','s','o','m')

Definition at line 47 of file Ap4FtypAtom.h.

Generated on Thu May 13 16:36:38 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4FtypAtom.h Source File

  • File List
  • File Members

Ap4FtypAtom.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - ftyp Atoms
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027  ****************************************************************/
00028
00029 #ifndef _AP4_FTYP_ATOM_H_
00030 #define _AP4_FTYP_ATOM_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Types.h"
00036 #include "Ap4Atom.h"
00037 #include "Ap4Array.h"
00038
00039 /*----------------------------------------------------------------------
00040 |   class references
00041 +---------------------------------------------------------------------*/
00042 class AP4_ByteStream;
00043
00044 /*----------------------------------------------------------------------
00045 |   constants
00046 +---------------------------------------------------------------------*/
00047 const AP4_UI32 AP4_FTYP_BRAND_ISOM = AP4_ATOM_TYPE('i','s','o','m');
00048
00049 /*----------------------------------------------------------------------
00050 |   AP4_FtypAtom
00051 +---------------------------------------------------------------------*/
00052 class AP4_FtypAtom : public AP4_Atom
00053 {
00054 public:
00055     AP4_IMPLEMENT_DYNAMIC_CAST_D(AP4_FtypAtom, AP4_Atom)
00056
00057     // class methods
00058     static AP4_FtypAtom* Create(AP4_Size size, AP4_ByteStream& stream) {
00059         return new AP4_FtypAtom(size, stream);
00060     }
00061
00062     // methods
00063     AP4_FtypAtom(AP4_UI32     major_brand,
00064                  AP4_UI32     minor_version,
00065                  AP4_UI32*    compatible_brands = NULL,
00066                  AP4_Cardinal compatible_brand_count = 0);
00067     virtual AP4_Result InspectFields(AP4_AtomInspector& inspector);
00068     virtual AP4_Result WriteFields(AP4_ByteStream& stream);
00069
00070     // accessors
00071     AP4_UI32 GetMajorBrand()         { return m_MajorBrand;       }
00072     AP4_UI32 GetMinorVersion()       { return m_MinorVersion;     }
00073     AP4_Array<AP4_UI32>& GetCompatibleBrands() {
00074         return m_CompatibleBrands;
00075     }
00076     bool HasCompatibleBrand(AP4_UI32 brand);
00077
00078 private:
00079     // methods
00080     AP4_FtypAtom(AP4_UI32 size, AP4_ByteStream& stream);
00081
00082     // members
00083     AP4_UI32            m_MajorBrand;
00084     AP4_UI32            m_MinorVersion;
00085     AP4_Array<AP4_UI32> m_CompatibleBrands;
00086 };
00087
00088 #endif // _AP4_FTYP_ATOM_H_
Generated on Thu May 13 16:36:32 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4GrpiAtom.h File Reference

  • File List
  • File Members

Ap4GrpiAtom.h File Reference

#include "Ap4Types.h"
#include "Ap4Atom.h"
#include "Ap4String.h"
#include "Ap4DataBuffer.h"

Go to the source code of this file.

Classes

class AP4_GrpiAtom
Generated on Thu May 13 16:36:38 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4GrpiAtom.h Source File

  • File List
  • File Members

Ap4GrpiAtom.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - grpi Atom
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027 ****************************************************************/
00028
00029 #ifndef _AP4_GRPI_ATOM_H_
00030 #define _AP4_GRPI_ATOM_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Types.h"
00036 #include "Ap4Atom.h"
00037 #include "Ap4String.h"
00038 #include "Ap4DataBuffer.h"
00039
00040 /*----------------------------------------------------------------------
00041 |   AP4_GrpiAtom
00042 +---------------------------------------------------------------------*/
00043 class AP4_GrpiAtom : public AP4_Atom
00044 {
00045 public:
00046     AP4_IMPLEMENT_DYNAMIC_CAST_D(AP4_GrpiAtom, AP4_Atom)
00047
00048     // class methods
00049     static AP4_GrpiAtom* Create(AP4_Size        size,
00050                                 AP4_ByteStream& stream);
00051
00052     // constructor
00053     AP4_GrpiAtom(AP4_UI08        key_encryption_method,
00054                  const char*     group_id,
00055                  const AP4_UI08* group_key,
00056                  AP4_Size        group_key_length);
00057
00058     // methods
00059     virtual AP4_Result InspectFields(AP4_AtomInspector& inspector);
00060     virtual AP4_Result WriteFields(AP4_ByteStream& stream);
00061     virtual AP4_Atom*  Clone();
00062
00063     // accessors
00064     AP4_UI08              GetKeyEncryptionMethod() const { return m_KeyEncryptionMethod; }
00065     void                  SetKeyEncryptionMethod(AP4_UI08 encryption_method) { m_KeyEncryptionMethod = encryption_method; }
00066     const AP4_String&     GetGroupId()  const { return m_GroupId; }
00067     const AP4_DataBuffer& GetGroupKey() const { return m_GroupKey;  }
00068
00069 private:
00070     // methods
00071     AP4_GrpiAtom(AP4_UI32         size,
00072                  AP4_UI32         version,
00073                  AP4_UI32         flags,
00074                  AP4_ByteStream&  stream);
00075
00076     // members
00077     AP4_UI08       m_KeyEncryptionMethod;
00078     AP4_String     m_GroupId;
00079     AP4_DataBuffer m_GroupKey;
00080 };
00081
00082 #endif // _AP4_GRPI_ATOM_H_
Generated on Thu May 13 16:36:32 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4HdlrAtom.h File Reference

  • File List
  • File Members

Ap4HdlrAtom.h File Reference

#include "Ap4Atom.h"
#include "Ap4String.h"

Go to the source code of this file.

Classes

class | AP4_HdlrAtom

Variables

const AP4_UI32 | AP4_HANDLER_TYPE_SOUN = AP4_ATOM_TYPE('s','o','u','n')
const AP4_UI32 | AP4_HANDLER_TYPE_VIDE = AP4_ATOM_TYPE('v','i','d','e')
const AP4_UI32 | AP4_HANDLER_TYPE_HINT = AP4_ATOM_TYPE('h','i','n','t')
const AP4_UI32 | AP4_HANDLER_TYPE_MDIR = AP4_ATOM_TYPE('m','d','i','r')
const AP4_UI32 | AP4_HANDLER_TYPE_TEXT = AP4_ATOM_TYPE('t','e','x','t')
const AP4_UI32 | AP4_HANDLER_TYPE_TX3G = AP4_ATOM_TYPE('t','x','3','g')
const AP4_UI32 | AP4_HANDLER_TYPE_JPEG = AP4_ATOM_TYPE('j','p','e','g')
const AP4_UI32 | AP4_HANDLER_TYPE_ODSM = AP4_ATOM_TYPE('o','d','s','m')
const AP4_UI32 | AP4_HANDLER_TYPE_SDSM = AP4_ATOM_TYPE('s','d','s','m')

Variable Documentation

const AP4_UI32 AP4_HANDLER_TYPE_HINT = AP4_ATOM_TYPE('h','i','n','t')

Definition at line 48 of file Ap4HdlrAtom.h.

const AP4_UI32 AP4_HANDLER_TYPE_JPEG = AP4_ATOM_TYPE('j','p','e','g')

Definition at line 52 of file Ap4HdlrAtom.h.

const AP4_UI32 AP4_HANDLER_TYPE_MDIR = AP4_ATOM_TYPE('m','d','i','r')

Definition at line 49 of file Ap4HdlrAtom.h.

const AP4_UI32 AP4_HANDLER_TYPE_ODSM = AP4_ATOM_TYPE('o','d','s','m')

Definition at line 53 of file Ap4HdlrAtom.h.

const AP4_UI32 AP4_HANDLER_TYPE_SDSM = AP4_ATOM_TYPE('s','d','s','m')

Definition at line 54 of file Ap4HdlrAtom.h.

const AP4_UI32 AP4_HANDLER_TYPE_SOUN = AP4_ATOM_TYPE('s','o','u','n')

Definition at line 46 of file Ap4HdlrAtom.h.

const AP4_UI32 AP4_HANDLER_TYPE_TEXT = AP4_ATOM_TYPE('t','e','x','t')

Definition at line 50 of file Ap4HdlrAtom.h.

const AP4_UI32 AP4_HANDLER_TYPE_TX3G = AP4_ATOM_TYPE('t','x','3','g')

Definition at line 51 of file Ap4HdlrAtom.h.

const AP4_UI32 AP4_HANDLER_TYPE_VIDE = AP4_ATOM_TYPE('v','i','d','e')

Definition at line 47 of file Ap4HdlrAtom.h.

Generated on Thu May 13 16:36:38 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4HdlrAtom.h Source File

  • File List
  • File Members

Ap4HdlrAtom.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - hdlr Atoms
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027  ****************************************************************/
00028
00029 #ifndef _AP4_HDLR_ATOM_H_
00030 #define _AP4_HDLR_ATOM_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Atom.h"
00036 #include "Ap4String.h"
00037
00038 /*----------------------------------------------------------------------
00039 |   class references
00040 +---------------------------------------------------------------------*/
00041 class AP4_ByteStream;
00042
00043 /*----------------------------------------------------------------------
00044 |   constants
00045 +---------------------------------------------------------------------*/
00046 const AP4_UI32 AP4_HANDLER_TYPE_SOUN = AP4_ATOM_TYPE('s','o','u','n');
00047 const AP4_UI32 AP4_HANDLER_TYPE_VIDE = AP4_ATOM_TYPE('v','i','d','e');
00048 const AP4_UI32 AP4_HANDLER_TYPE_HINT = AP4_ATOM_TYPE('h','i','n','t');
00049 const AP4_UI32 AP4_HANDLER_TYPE_MDIR = AP4_ATOM_TYPE('m','d','i','r');
00050 const AP4_UI32 AP4_HANDLER_TYPE_TEXT = AP4_ATOM_TYPE('t','e','x','t');
00051 const AP4_UI32 AP4_HANDLER_TYPE_TX3G = AP4_ATOM_TYPE('t','x','3','g');
00052 const AP4_UI32 AP4_HANDLER_TYPE_JPEG = AP4_ATOM_TYPE('j','p','e','g');
00053 const AP4_UI32 AP4_HANDLER_TYPE_ODSM = AP4_ATOM_TYPE('o','d','s','m');
00054 const AP4_UI32 AP4_HANDLER_TYPE_SDSM = AP4_ATOM_TYPE('s','d','s','m');
00055
00056 /*----------------------------------------------------------------------
00057 |   AP4_HdlrAtom
00058 +---------------------------------------------------------------------*/
00059 class AP4_HdlrAtom : public AP4_Atom
00060 {
00061 public:
00062     AP4_IMPLEMENT_DYNAMIC_CAST_D(AP4_HdlrAtom, AP4_Atom)
00063
00064     // class methods
00065     static AP4_HdlrAtom* Create(AP4_Size size, AP4_ByteStream& stream);
00066
00067     // methods
00068     AP4_HdlrAtom(AP4_UI32 hdlr_type, const char* hdlr_name);
00069     virtual AP4_Result InspectFields(AP4_AtomInspector& inspector);
00070     virtual AP4_Result WriteFields(AP4_ByteStream& stream);
00071
00072     AP4_UI32   GetHandlerType() { return m_HandlerType; }
00073     AP4_String GetHandlerName() { return m_HandlerName; }
00074
00075 private:
00076     // methods
00077     AP4_HdlrAtom(AP4_UI32        size,
00078                  AP4_UI32        version,
00079                  AP4_UI32        flags,
00080                  AP4_ByteStream& stream);
00081
00082     // members
00083     AP4_UI32   m_HandlerType;
00084     AP4_UI32   m_Reserved[3];
00085     AP4_String m_HandlerName;
00086 };
00087
00088 #endif // _AP4_HDLR_ATOM_H_
Generated on Thu May 13 16:36:32 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4HintTrackReader.h File Reference

  • File List
  • File Members

Ap4HintTrackReader.h File Reference

#include "Ap4Types.h"
#include "Ap4Sample.h"

Go to the source code of this file.

Classes

class AP4_HintTrackReader
Generated on Thu May 13 16:36:38 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4HintTrackReader.h Source File

  • File List
  • File Members

Ap4HintTrackReader.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - Hint Track Reader
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027 ****************************************************************/
00028
00029 #ifndef _AP4_HINT_TRACK_READER_H_
00030 #define _AP4_HINT_TRACK_READER_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Types.h"
00036 #include "Ap4Sample.h"
00037
00038 /*----------------------------------------------------------------------
00039 |   class declarations
00040 +---------------------------------------------------------------------*/
00041 class AP4_DataBuffer;
00042 class AP4_Movie;
00043 class AP4_Track;
00044 class AP4_RtpSampleData;
00045 class AP4_RtpPacket;
00046 class AP4_ImmediateRtpConstructor;
00047 class AP4_SampleRtpConstructor;
00048 class AP4_String;
00049
00050 /*----------------------------------------------------------------------
00051 |   AP4_HintTrackReader
00052 +---------------------------------------------------------------------*/
00053 class AP4_HintTrackReader
00054 {
00055 public:
00056     // constructor and destructor
00057     static AP4_Result Create(AP4_Track&            hint_track,
00058                              AP4_Movie&            movie,
00059                              AP4_UI32              ssrc, // if 0, a random value is chosen
00060                              AP4_HintTrackReader*& reader);
00061     ~AP4_HintTrackReader();
00062
00063     // methods
00064     AP4_Result      GetNextPacket(AP4_DataBuffer& packet,
00065                                   AP4_UI32&       ts_ms);
00066     AP4_Result      SeekToTimeStampMs(AP4_UI32  desired_ts_ms,
00067                                       AP4_UI32& actual_ts_ms);
00068     AP4_UI32        GetCurrentTimeStampMs();
00069     AP4_Result      Rewind();
00070     AP4_Result      GetSdpText(AP4_String& sdp);
00071     AP4_Track*      GetMediaTrack() { return m_MediaTrack; }
00072
00073 private:
00074     // use the factory instead of the constructor
00075     AP4_HintTrackReader(AP4_Track& hint_track,
00076                         AP4_Movie& movie,
00077                         AP4_UI32   ssrc);
00078
00079     // methods
00080     AP4_Result GetRtpSample(AP4_Ordinal index);
00081     AP4_Result BuildRtpPacket(AP4_RtpPacket*  packet,
00082                               AP4_DataBuffer& packet_data);
00083     AP4_Result WriteImmediateRtpData(AP4_ImmediateRtpConstructor* constructor,
00084                                      AP4_ByteStream*              data_stream);
00085     AP4_Result WriteSampleRtpData(AP4_SampleRtpConstructor* constructor,
00086                                   AP4_ByteStream*           data_stream);
00087
00088     // members
00089     AP4_Track&          m_HintTrack;
00090     AP4_Track*          m_MediaTrack;
00091     AP4_UI32            m_MediaTimeScale;
00092     AP4_Sample          m_CurrentHintSample;
00093     AP4_RtpSampleData*  m_RtpSampleData;
00094     AP4_UI32            m_Ssrc;
00095     AP4_Ordinal         m_SampleIndex;
00096     AP4_Ordinal         m_PacketIndex;
00097     AP4_UI16            m_RtpSequenceStart;
00098     AP4_UI32            m_RtpTimeStampStart;
00099     AP4_UI32            m_RtpTimeScale;
00100 };
00101
00102 #endif // _AP4_HINT_TRACK_READER_H_
Generated on Thu May 13 16:36:32 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4Hmac.h File Reference

  • File List
  • File Members

Ap4Hmac.h File Reference

#include "Ap4Results.h"
#include "Ap4Types.h"
#include "Ap4DataBuffer.h"

Go to the source code of this file.

Classes

class AP4_Hmac
Generated on Thu May 13 16:36:38 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4Hmac.h Source File

  • File List
  • File Members

Ap4Hmac.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - HMAC Algorithms
00004 |
00005 |    Copyright 2002-2009 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027 ****************************************************************/
00028
00029 #ifndef _AP4_HMAC_H_
00030 #define _AP4_HMAC_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Results.h"
00036 #include "Ap4Types.h"
00037 #include "Ap4DataBuffer.h"
00038
00039 /*----------------------------------------------------------------------
00040 |   AP4_Hmac
00041 +---------------------------------------------------------------------*/
00042 class AP4_Hmac
00043 {
00044 public:
00045     // types
00046     typedef enum {
00047         SHA256
00048     } Algorithm;
00049
00050     // class methods
00051     static AP4_Result Create(Algorithm       algorithm,
00052                              const AP4_UI08* key,
00053                              AP4_Size        key_size,
00054                              AP4_Hmac*&      hmac);
00055
00056     // methods
00057     virtual ~AP4_Hmac() {}
00058     virtual AP4_Result Update(const AP4_UI08* data, AP4_Size data_size) = 0;
00059     virtual AP4_Result Final(AP4_DataBuffer& mac) = 0;
00060 };
00061
00062 #endif // _AP4_HMAC_H_
Generated on Thu May 13 16:36:32 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4HmhdAtom.h File Reference

  • File List
  • File Members

Ap4HmhdAtom.h File Reference

#include "Ap4Types.h"
#include "Ap4Atom.h"

Go to the source code of this file.

Classes

class AP4_HmhdAtom
Generated on Thu May 13 16:36:38 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4HmhdAtom.h Source File

  • File List
  • File Members

Ap4HmhdAtom.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - hmhd Atoms
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027 ****************************************************************/
00028
00029 #ifndef _AP4_HMHD_ATOM_H_
00030 #define _AP4_HMHD_ATOM_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Types.h"
00036 #include "Ap4Atom.h"
00037
00038 /*----------------------------------------------------------------------
00039 |   class references
00040 +---------------------------------------------------------------------*/
00041 class AP4_ByteStream;
00042
00043 /*----------------------------------------------------------------------
00044 |   AP4_HmhdAtom
00045 +---------------------------------------------------------------------*/
00046 class AP4_HmhdAtom : public AP4_Atom
00047 {
00048 public:
00049     // class methods
00050     static AP4_HmhdAtom* Create(AP4_Size size, AP4_ByteStream& stream);
00051
00052     // methods
00053     virtual AP4_Result InspectFields(AP4_AtomInspector& inspector);
00054     virtual AP4_Result WriteFields(AP4_ByteStream& stream);
00055
00056 private:
00057     // methods
00058     AP4_HmhdAtom(AP4_UI32        size,
00059                  AP4_UI32        version,
00060                  AP4_UI32        flags,
00061                  AP4_ByteStream& stream);
00062
00063     // members
00064     AP4_UI16 m_MaxPduSize;
00065     AP4_UI16 m_AvgPduSize;
00066     AP4_UI32 m_MaxBitrate;
00067     AP4_UI32 m_AvgBitrate;
00068     AP4_UI32 m_Reserved;
00069 };
00070
00071 #endif // _AP4_HMHD_ATOM_H_
Generated on Thu May 13 16:36:32 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4IkmsAtom.h File Reference

  • File List
  • File Members

Ap4IkmsAtom.h File Reference

#include "Ap4Types.h"
#include "Ap4Atom.h"
#include "Ap4String.h"

Go to the source code of this file.

Classes

class AP4_IkmsAtom
Generated on Thu May 13 16:36:38 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4IkmsAtom.h Source File

  • File List
  • File Members

Ap4IkmsAtom.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - iKMS Atom
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027 ****************************************************************/
00028
00029 #ifndef _AP4_IKMS_ATOM_H_
00030 #define _AP4_IKMS_ATOM_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Types.h"
00036 #include "Ap4Atom.h"
00037 #include "Ap4String.h"
00038
00039 /*----------------------------------------------------------------------
00040 |   AP4_IkmsAtom
00041 +---------------------------------------------------------------------*/
00042 class AP4_IkmsAtom : public AP4_Atom
00043 {
00044 public:
00045     AP4_IMPLEMENT_DYNAMIC_CAST_D(AP4_IkmsAtom, AP4_Atom)
00046
00047     // class methods
00048     static AP4_IkmsAtom* Create(AP4_Size size, AP4_ByteStream& stream);
00049
00050     // methods
00051     AP4_IkmsAtom(const char* kms_uri,
00052                  AP4_UI32    kms_id = 0,
00053                  AP4_UI32    kms_version = 0);
00054     virtual AP4_Atom*  Clone();
00055     virtual AP4_Result InspectFields(AP4_AtomInspector& inspector);
00056     virtual AP4_Result WriteFields(AP4_ByteStream& stream);
00057
00058     // accessors
00059     const AP4_String& GetKmsUri()     { return m_KmsUri;     }
00060     AP4_UI32          GetKmsId()      { return m_KmsId;      }
00061     AP4_UI32          GetKmsVersion() { return m_KmsVersion; }
00062
00063 private:
00064     // methods
00065     AP4_IkmsAtom(AP4_UI32        size,
00066                  AP4_UI32        version,
00067                  AP4_UI32        flags,
00068                  AP4_ByteStream& stream);
00069
00070     // members
00071     AP4_String m_KmsUri;
00072     AP4_UI32   m_KmsId;
00073     AP4_UI32   m_KmsVersion;
00074 };
00075
00076 #endif // _AP4_IKMS_ATOM_H_
Generated on Thu May 13 16:36:32 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4Interfaces.h File Reference

  • File List
  • File Members

Ap4Interfaces.h File Reference

#include "Ap4Types.h"

Go to the source code of this file.

Classes

class | AP4_Exception
class | AP4_Referenceable

Defines

#define | AP4_RELEASE(o) do { if (o) (o)->Release(); (o) = NULL; } while (0)
#define | AP4_ADD_REFERENCE(o) do { if (o) (o)->AddReference(); } while (0)

Define Documentation

#define AP4_ADD_REFERENCE ( o ) do { if (o) (o)->AddReference(); } while (0)

Definition at line 41 of file Ap4Interfaces.h.

#define AP4_RELEASE ( o ) do { if (o) (o)->Release(); (o) = NULL; } while (0)

Definition at line 40 of file Ap4Interfaces.h.

Generated on Thu May 13 16:36:38 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4Interfaces.h Source File

  • File List
  • File Members

Ap4Interfaces.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - Common Interfaces
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027  ****************************************************************/
00028
00029 #ifndef _AP4_INTERFACES_H_
00030 #define _AP4_INTERFACES_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Types.h"
00036
00037 /*----------------------------------------------------------------------
00038 |   macros
00039 +---------------------------------------------------------------------*/
00040 #define AP4_RELEASE(o) do { if (o) (o)->Release(); (o) = NULL; } while (0)
00041 #define AP4_ADD_REFERENCE(o) do { if (o) (o)->AddReference(); } while (0)
00042
00043 #if !defined(AP4_CONFIG_NO_EXCEPTIONS)
00044 /*----------------------------------------------------------------------
00045 |   AP4_Exception
00046 +---------------------------------------------------------------------*/
00047 class AP4_Exception
00048 {
00049 public:
00050     // methods
00051     AP4_Exception(AP4_Result error) : m_Error(error) {}
00052
00053     // members
00054     AP4_Result m_Error;
00055 };
00056 #endif
00057
00058 /*----------------------------------------------------------------------
00059 |   AP4_Referenceable
00060 +---------------------------------------------------------------------*/
00061 class AP4_Referenceable
00062 {
00063  public:
00064     // methods
00065     virtual ~AP4_Referenceable() {}
00066     virtual void AddReference() = 0;
00067     virtual void Release() = 0;
00068 };
00069
00070 #endif // _AP4_INTERFACES_H_
Generated on Thu May 13 16:36:32 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4IodsAtom.h File Reference

  • File List
  • File Members

Ap4IodsAtom.h File Reference

#include "Ap4Types.h"
#include "Ap4Atom.h"
#include "Ap4ObjectDescriptor.h"

Go to the source code of this file.

Classes

class AP4_IodsAtom
Generated on Thu May 13 16:36:38 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4IodsAtom.h Source File

  • File List
  • File Members

Ap4IodsAtom.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - iods Atom
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027  ****************************************************************/
00028
00029 #ifndef _AP4_IODS_ATOM_H_
00030 #define _AP4_IODS_ATOM_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Types.h"
00036 #include "Ap4Atom.h"
00037 #include "Ap4ObjectDescriptor.h"
00038
00039 /*----------------------------------------------------------------------
00040 |   class references
00041 +---------------------------------------------------------------------*/
00042 class AP4_ByteStream;
00043
00044 /*----------------------------------------------------------------------
00045 |   AP4_IodsAtom
00046 +---------------------------------------------------------------------*/
00047 class AP4_IodsAtom : public AP4_Atom
00048 {
00049 public:
00050     AP4_IMPLEMENT_DYNAMIC_CAST_D(AP4_IodsAtom, AP4_Atom)
00051
00052     // class methods
00053     static AP4_IodsAtom* Create(AP4_Size size, AP4_ByteStream& stream);
00054
00055     // methods
00056     AP4_IodsAtom(AP4_ObjectDescriptor* descriptor); // ownership of 'descriptor' is transfered
00057    ~AP4_IodsAtom();
00058     virtual AP4_Result WriteFields(AP4_ByteStream& stream);
00059     virtual AP4_Result InspectFields(AP4_AtomInspector& inspector);
00060     const AP4_ObjectDescriptor* GetObjectDescriptor() const { return m_ObjectDescriptor; }
00061
00062 private:
00063     // methods
00064     AP4_IodsAtom(AP4_UI32        size,
00065                  AP4_UI32        version,
00066                  AP4_UI32        flags,
00067                  AP4_ByteStream& stream);
00068
00069     // members
00070     AP4_ObjectDescriptor* m_ObjectDescriptor;
00071 };
00072
00073 #endif // _AP4_IODS_ATOM_H_
Generated on Thu May 13 16:36:32 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4Ipmp.h File Reference

  • File List
  • File Members

Ap4Ipmp.h File Reference

#include "Ap4Types.h"
#include "Ap4String.h"
#include "Ap4Descriptor.h"

Go to the source code of this file.

Classes

class | AP4_IpmpDescriptorPointer
class | AP4_IpmpDescriptor

Variables

const AP4_UI08 | AP4_DESCRIPTOR_TAG_IPMP_DESCRIPTOR_POINTER = 0x0A
const AP4_UI08 | AP4_DESCRIPTOR_TAG_IPMP_DESCRIPTOR = 0x0B

Variable Documentation

const AP4_UI08 AP4_DESCRIPTOR_TAG_IPMP_DESCRIPTOR = 0x0B

Definition at line 43 of file Ap4Ipmp.h.

const AP4_UI08 AP4_DESCRIPTOR_TAG_IPMP_DESCRIPTOR_POINTER = 0x0A

Definition at line 42 of file Ap4Ipmp.h.

Generated on Thu May 13 16:36:38 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4Ipmp.h Source File

  • File List
  • File Members

Ap4Ipmp.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - IPMP
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027  ****************************************************************/
00028
00029 #ifndef _AP4_IPMP_H_
00030 #define _AP4_IPMP_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Types.h"
00036 #include "Ap4String.h"
00037 #include "Ap4Descriptor.h"
00038
00039 /*----------------------------------------------------------------------
00040 |   constants
00041 +---------------------------------------------------------------------*/
00042 const AP4_UI08 AP4_DESCRIPTOR_TAG_IPMP_DESCRIPTOR_POINTER = 0x0A;
00043 const AP4_UI08 AP4_DESCRIPTOR_TAG_IPMP_DESCRIPTOR         = 0x0B;
00044
00045 /*----------------------------------------------------------------------
00046 |   AP4_IpmpDescriptorPointer
00047 +---------------------------------------------------------------------*/
00048 class AP4_IpmpDescriptorPointer : public AP4_Descriptor
00049 {
00050 public:
00051     AP4_IMPLEMENT_DYNAMIC_CAST_D(AP4_IpmpDescriptorPointer, AP4_Descriptor)
00052
00053     // methods
00054     AP4_IpmpDescriptorPointer(AP4_UI08 descriptor_id);
00055     AP4_IpmpDescriptorPointer(AP4_ByteStream&     stream,
00056                               AP4_Size            header_size,
00057                               AP4_Size            payload_size);
00058     virtual AP4_Result WriteFields(AP4_ByteStream& stream);
00059     virtual AP4_Result Inspect(AP4_AtomInspector& inspector);
00060
00061     // accessors
00062     AP4_UI08 GetDescriptorId()   const { return m_DescriptorId;   }
00063     AP4_UI16 GetDescriptorIdEx() const { return m_DescriptorIdEx; }
00064     AP4_UI16 GetEsId()           const { return m_EsId;           }
00065
00066 private:
00067     // members
00068     AP4_UI08 m_DescriptorId;
00069     AP4_UI16 m_DescriptorIdEx;
00070     AP4_UI16 m_EsId;
00071 };
00072
00073 /*----------------------------------------------------------------------
00074 |   AP4_IpmpDescriptor
00075 +---------------------------------------------------------------------*/
00076 class AP4_IpmpDescriptor : public AP4_Descriptor
00077 {
00078 public:
00079     AP4_IMPLEMENT_DYNAMIC_CAST_D(AP4_IpmpDescriptor, AP4_Descriptor)
00080
00081     // methods
00082     AP4_IpmpDescriptor(AP4_UI08 descriptor_id, AP4_UI16 ipmps_type);
00083     AP4_IpmpDescriptor(AP4_ByteStream&     stream,
00084                        AP4_Size            header_size,
00085                        AP4_Size            payload_size);
00086     virtual AP4_Result WriteFields(AP4_ByteStream& stream);
00087     virtual AP4_Result Inspect(AP4_AtomInspector& inspector);
00088
00089     // accessors
00090     AP4_UI08              GetDescriptorId()     const { return m_DescriptorId;     }
00091     AP4_UI16              GetIpmpsType()        const { return m_IpmpsType;        }
00092     AP4_UI16              GetDescriptorIdEx()   const { return m_DescriptorIdEx;   }
00093     const AP4_UI08*       GetToolId()           const { return m_ToolId;           }
00094     AP4_UI08              GetControlPointCode() const { return m_ControlPointCode; }
00095     AP4_UI08              GetSequenceCode()     const { return m_SequenceCode;     }
00096     const AP4_String&     GetUrl()              const { return m_Url;              }
00097     const AP4_DataBuffer& GetData()             const { return m_Data;             }
00098     void                  SetData(const unsigned char* data, AP4_Size data_size);
00099
00100 private:
00101     // members
00102     AP4_UI08       m_DescriptorId;
00103     AP4_UI16       m_IpmpsType;
00104     AP4_UI16       m_DescriptorIdEx;
00105     AP4_UI08       m_ToolId[16];
00106     AP4_UI08       m_ControlPointCode;
00107     AP4_UI08       m_SequenceCode;
00108     AP4_String     m_Url;
00109     AP4_DataBuffer m_Data;
00110 };
00111
00112 #endif // _AP4_IPMP_H_
Generated on Thu May 13 16:36:32 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4IproAtom.h File Reference

  • File List
  • File Members

Ap4IproAtom.h File Reference

#include "Ap4Types.h"
#include "Ap4Array.h"
#include "Ap4ContainerAtom.h"

Go to the source code of this file.

Classes

class AP4_IproAtom
Generated on Thu May 13 16:36:38 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4IproAtom.h Source File

  • File List
  • File Members

Ap4IproAtom.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - ipro Atoms
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027  ****************************************************************/
00028
00029 #ifndef _AP4_IPRO_ATOM_H_
00030 #define _AP4_IPRO_ATOM_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Types.h"
00036 #include "Ap4Array.h"
00037 #include "Ap4ContainerAtom.h"
00038
00039 /*----------------------------------------------------------------------
00040 |   AP4_IproAtom
00041 +---------------------------------------------------------------------*/
00042 class AP4_IproAtom : public AP4_ContainerAtom
00043 {
00044 public:
00045     // class methods
00046     static AP4_IproAtom* Create(AP4_Size         size,
00047                                 AP4_ByteStream&  stream,
00048                                 AP4_AtomFactory& atom_factory);
00049
00050     // methods
00051     virtual AP4_Result InspectFields(AP4_AtomInspector& inspector);
00052     virtual AP4_Result WriteFields(AP4_ByteStream& stream);
00053
00054 private:
00055     // methods
00056     AP4_IproAtom(AP4_UI32         size,
00057                  AP4_UI32         version,
00058                  AP4_UI32         flags,
00059                  AP4_ByteStream&  stream,
00060                  AP4_AtomFactory& atom_factory);
00061 };
00062
00063 #endif // _AP4_IPRO_ATOM_H_
00064
Generated on Thu May 13 16:36:32 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4IsfmAtom.h File Reference

  • File List
  • File Members

Ap4IsfmAtom.h File Reference

#include "Ap4Types.h"
#include "Ap4Atom.h"

Go to the source code of this file.

Classes

class AP4_IsfmAtom
Generated on Thu May 13 16:36:38 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4IsfmAtom.h Source File

  • File List
  • File Members

Ap4IsfmAtom.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - iSFM Atom
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027 ****************************************************************/
00028
00029 #ifndef _AP4_ISFM_ATOM_H_
00030 #define _AP4_ISFM_ATOM_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Types.h"
00036 #include "Ap4Atom.h"
00037
00038 /*----------------------------------------------------------------------
00039 |   AP4_IsfmAtom
00040 +---------------------------------------------------------------------*/
00041 class AP4_IsfmAtom : public AP4_Atom
00042 {
00043 public:
00044     AP4_IMPLEMENT_DYNAMIC_CAST_D(AP4_IsfmAtom, AP4_Atom)
00045
00046     // class methods
00047     static AP4_IsfmAtom* Create(AP4_Size size, AP4_ByteStream& stream);
00048
00049     // methods
00050     AP4_IsfmAtom(bool     m_SelectiveEncryption,
00051                  AP4_UI08 m_KeyIndicatorLength,
00052                  AP4_UI08 m_IvLength);
00053     virtual AP4_Atom*  Clone();
00054     virtual AP4_Result InspectFields(AP4_AtomInspector& inspector);
00055     virtual AP4_Result WriteFields(AP4_ByteStream& stream);
00056
00057     // accessors
00058     bool GetSelectiveEncryption()    { return m_SelectiveEncryption; }
00059     AP4_UI08 GetKeyIndicatorLength() { return m_KeyIndicatorLength;  }
00060     AP4_UI08 GetIvLength()           { return m_IvLength;            }
00061
00062 private:
00063     // methods
00064     AP4_IsfmAtom(AP4_UI32        size,
00065                  AP4_UI32        version,
00066                  AP4_UI32        flags,
00067                  AP4_ByteStream& stream);
00068
00069     // members
00070     bool     m_SelectiveEncryption;
00071     AP4_UI08 m_KeyIndicatorLength;
00072     AP4_UI08 m_IvLength;
00073 };
00074
00075 #endif // _AP4_ISFM_ATOM_H_
Generated on Thu May 13 16:36:32 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4IsltAtom.h File Reference

  • File List
  • File Members

Ap4IsltAtom.h File Reference

#include "Ap4Types.h"
#include "Ap4Atom.h"

Go to the source code of this file.

Classes

class AP4_IsltAtom
Generated on Thu May 13 16:36:38 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4IsltAtom.h Source File

  • File List
  • File Members

Ap4IsltAtom.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - iSLT Atom
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027 ****************************************************************/
00028
00029 #ifndef _AP4_ISLT_ATOM_H_
00030 #define _AP4_ISLT_ATOM_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Types.h"
00036 #include "Ap4Atom.h"
00037
00038 /*----------------------------------------------------------------------
00039 |   AP4_IsltAtom
00040 +---------------------------------------------------------------------*/
00041 class AP4_IsltAtom : public AP4_Atom
00042 {
00043 public:
00044     AP4_IMPLEMENT_DYNAMIC_CAST_D(AP4_IsltAtom, AP4_Atom)
00045
00046     // class methods
00047     static AP4_IsltAtom* Create(AP4_Size size, AP4_ByteStream& stream) {
00048         if (size != AP4_ATOM_HEADER_SIZE+8) return NULL;
00049         return new AP4_IsltAtom(size, stream);
00050     }
00051
00052     // methods
00053     AP4_IsltAtom(const AP4_UI08* salt);
00054     virtual AP4_Result InspectFields(AP4_AtomInspector& inspector);
00055     virtual AP4_Result WriteFields(AP4_ByteStream& stream);
00056
00057     // accessors
00058     const AP4_UI08* GetSalt() { return m_Salt; }
00059
00060 private:
00061     // methods
00062     AP4_IsltAtom(AP4_UI32 size, AP4_ByteStream& stream);
00063
00064     // members
00065     AP4_UI08 m_Salt[8];
00066 };
00067
00068 #endif // _AP4_ISLT_ATOM_H_
Generated on Thu May 13 16:36:32 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4IsmaCryp.h File Reference

  • File List
  • File Members

Ap4IsmaCryp.h File Reference

#include "Ap4Types.h"
#include "Ap4SampleEntry.h"
#include "Ap4Atom.h"
#include "Ap4AtomFactory.h"
#include "Ap4SampleDescription.h"
#include "Ap4Processor.h"
#include "Ap4Protection.h"

Go to the source code of this file.

Classes

class | AP4_IsmaCipher
class | AP4_IsmaTrackDecrypter
class | AP4_IsmaEncryptingProcessor

Variables

const AP4_UI32 | AP4_PROTECTION_SCHEME_TYPE_IAEC = AP4_ATOM_TYPE('i','A','E','C')

Variable Documentation

const AP4_UI32 AP4_PROTECTION_SCHEME_TYPE_IAEC = AP4_ATOM_TYPE('i','A','E','C')

Definition at line 52 of file Ap4IsmaCryp.h.

Generated on Thu May 13 16:36:38 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4IsmaCryp.h Source File

  • File List
  • File Members

Ap4IsmaCryp.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - ISMA E&A support
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027 ****************************************************************/
00028
00029 #ifndef _AP4_ISMACRYP_H_
00030 #define _AP4_ISMACRYP_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Types.h"
00036 #include "Ap4SampleEntry.h"
00037 #include "Ap4Atom.h"
00038 #include "Ap4AtomFactory.h"
00039 #include "Ap4SampleDescription.h"
00040 #include "Ap4Processor.h"
00041 #include "Ap4Protection.h"
00042
00043 /*----------------------------------------------------------------------
00044 |   class references
00045 +---------------------------------------------------------------------*/
00046 class AP4_CtrStreamCipher;
00047 class AP4_IsfmAtom;
00048
00049 /*----------------------------------------------------------------------
00050 |   constants
00051 +---------------------------------------------------------------------*/
00052 const AP4_UI32 AP4_PROTECTION_SCHEME_TYPE_IAEC = AP4_ATOM_TYPE('i','A','E','C');
00053
00054 /*----------------------------------------------------------------------
00055 |   AP4_IsmaCipher
00056 +---------------------------------------------------------------------*/
00057 class AP4_IsmaCipher : public AP4_SampleDecrypter
00058 {
00059 public:
00060     // factory
00061     static AP4_Result CreateSampleDecrypter(AP4_ProtectedSampleDescription* sample_description,
00062                                             const AP4_UI08*                 key,
00063                                             AP4_Size                        key_size,
00064                                             AP4_BlockCipherFactory*         block_cipher_factory,
00065                                             AP4_IsmaCipher*&                decrypter);
00066
00067     // constructor and destructor
00068     AP4_IsmaCipher(AP4_BlockCipher* block_cipher,
00069                    const AP4_UI08*  salt,
00070                    AP4_UI08         iv_length,
00071                    AP4_UI08         key_indicator_length,
00072                    bool             selective_encryption);
00073    ~AP4_IsmaCipher();
00074     AP4_Result EncryptSampleData(AP4_DataBuffer& data_in,
00075                                  AP4_DataBuffer& data_out,
00076                                  AP4_UI32        offset);
00077     AP4_Result DecryptSampleData(AP4_DataBuffer& data_in,
00078                                  AP4_DataBuffer& data_out,
00079                                  const AP4_UI08* iv = NULL);
00080     AP4_Size   GetDecryptedSampleSize(AP4_Sample& sample);
00081     AP4_CtrStreamCipher* GetCipher()   { return m_Cipher;   }
00082     AP4_UI08             GetIvLength() { return m_IvLength; }
00083     AP4_UI08             GetKeyIndicatorLength() { return m_KeyIndicatorLength; }
00084     bool                 GetSelectiveEncryption(){ return m_SelectiveEncryption;}
00085
00086 private:
00087     // members
00088     AP4_CtrStreamCipher* m_Cipher;
00089     AP4_UI08             m_IvLength;
00090     AP4_UI08             m_KeyIndicatorLength;
00091     bool                 m_SelectiveEncryption;
00092 };
00093
00094 /*----------------------------------------------------------------------
00095 |   AP4_IsmaTrackDecrypter
00096 +---------------------------------------------------------------------*/
00097 class AP4_IsmaTrackDecrypter : public AP4_Processor::TrackHandler {
00098 public:
00099     // construction
00100     static AP4_Result Create(const AP4_UI08*                 key,
00101                              AP4_Size                        key_size,
00102                              AP4_ProtectedSampleDescription* sample_description,
00103                              AP4_SampleEntry*                sample_entry,
00104                              AP4_BlockCipherFactory*         block_cipher_factory,
00105                              AP4_IsmaTrackDecrypter*&        decrypter);
00106
00107     virtual ~AP4_IsmaTrackDecrypter();
00108
00109     // methods
00110     virtual AP4_Size   GetProcessedSampleSize(AP4_Sample& sample);
00111     virtual AP4_Result ProcessTrack();
00112     virtual AP4_Result ProcessSample(AP4_DataBuffer& data_in,
00113                                      AP4_DataBuffer& data_out);
00114
00115 private:
00116     // constructor
00117     AP4_IsmaTrackDecrypter(AP4_IsmaCipher*  cipher,
00118                            AP4_SampleEntry* sample_entry,
00119                            AP4_UI32         original_format);
00120
00121     // members
00122     AP4_IsmaCipher*  m_Cipher;
00123     AP4_SampleEntry* m_SampleEntry;
00124     AP4_UI32         m_OriginalFormat;
00125 };
00126
00127 /*----------------------------------------------------------------------
00128 |   AP4_IsmaEncryptingProcessor
00129 +---------------------------------------------------------------------*/
00130 class AP4_IsmaEncryptingProcessor : public AP4_Processor
00131 {
00132 public:
00133     // constructors and destructor
00134     AP4_IsmaEncryptingProcessor(const char*             kms_uri,
00135                                 AP4_BlockCipherFactory* block_cipher_factory = NULL);
00136
00137     // accessors
00138     AP4_ProtectionKeyMap& GetKeyMap() { return m_KeyMap; }
00139
00140     // methods
00141     virtual AP4_Processor::TrackHandler* CreateTrackHandler(AP4_TrakAtom* trak);
00142
00143 private:
00144     // members
00145     AP4_ProtectionKeyMap    m_KeyMap;
00146     AP4_String              m_KmsUri;
00147     AP4_BlockCipherFactory* m_BlockCipherFactory;
00148 };
00149
00150 #endif // _AP4_ISMACRYP_H_
Generated on Thu May 13 16:36:32 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4KeyWrap.h File Reference

  • File List
  • File Members

Ap4KeyWrap.h File Reference

#include "Ap4Results.h"
#include "Ap4Types.h"
#include "Ap4DataBuffer.h"

Go to the source code of this file.

Functions

AP4_Result | AP4_AesKeyWrap (const AP4_UI08 *kek, const AP4_UI08 *cleartext_key, AP4_Size cleartext_key_size, AP4_DataBuffer &wrapped_key)
AP4_Result | AP4_AesKeyUnwrap (const AP4_UI08 *kek, const AP4_UI08 *wrapped_key, AP4_Size wrapped_key_size, AP4_DataBuffer &cleartext_key)

Function Documentation

AP4_Result AP4_AesKeyUnwrap | ( | const AP4_UI08 * | kek,
 |  | const AP4_UI08 * | wrapped_key,
 |  | AP4_Size | wrapped_key_size,
 |  | AP4_DataBuffer & | cleartext_key
 | ) |  |
AP4_Result AP4_AesKeyWrap | ( | const AP4_UI08 * | kek,
 |  | const AP4_UI08 * | cleartext_key,
 |  | AP4_Size | cleartext_key_size,
 |  | AP4_DataBuffer & | wrapped_key
 | ) |  |
Generated on Thu May 13 16:36:38 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4KeyWrap.h Source File

  • File List
  • File Members

Ap4KeyWrap.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - Key Wrap Algorithms
00004 |
00005 |    Copyright 2002-2009 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027 ****************************************************************/
00028
00029 #ifndef _AP4_KEY_WRAP_H_
00030 #define _AP4_KEY_WRAP_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Results.h"
00036 #include "Ap4Types.h"
00037 #include "Ap4DataBuffer.h"
00038
00039 /*----------------------------------------------------------------------
00040 |   functions
00041 +---------------------------------------------------------------------*/
00042 AP4_Result AP4_AesKeyWrap(const AP4_UI08* kek,
00043                           const AP4_UI08* cleartext_key,
00044                           AP4_Size        cleartext_key_size,
00045                           AP4_DataBuffer& wrapped_key);
00046
00047 AP4_Result AP4_AesKeyUnwrap(const AP4_UI08* kek,
00048                             const AP4_UI08* wrapped_key,
00049                             AP4_Size        wrapped_key_size,
00050                             AP4_DataBuffer& cleartext_key);
00051
00052 #endif // _AP4_KEY_WRAP_H_
Generated on Thu May 13 16:36:32 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4LinearReader.h File Reference

  • File List
  • File Members

Ap4LinearReader.h File Reference

#include "Ap4Types.h"
#include "Ap4Array.h"
#include "Ap4Movie.h"
#include "Ap4Sample.h"

Go to the source code of this file.

Classes

class | AP4_LinearReader
class | AP4_LinearReader::SampleBuffer
class | AP4_LinearReader::Tracker

Variables

const unsigned int | AP4_LINEAR_READER_INITIALIZED = 1
const unsigned int | AP4_LINEAR_READER_FLAG_EOS = 2
const unsigned int | AP4_LINEAR_READER_DEFAULT_BUFFER_SIZE = 4096*1024

Variable Documentation

const unsigned int AP4_LINEAR_READER_DEFAULT_BUFFER_SIZE = 4096*1024

Definition at line 51 of file Ap4LinearReader.h.

const unsigned int AP4_LINEAR_READER_FLAG_EOS = 2

Definition at line 49 of file Ap4LinearReader.h.

const unsigned int AP4_LINEAR_READER_INITIALIZED = 1

Definition at line 48 of file Ap4LinearReader.h.

Generated on Thu May 13 16:36:38 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4LinearReader.h Source File

  • File List
  • File Members

Ap4LinearReader.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - File Writer
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027  ****************************************************************/
00028
00029 #ifndef _AP4_LINEAR_READER_H_
00030 #define _AP4_LINEAR_READER_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Types.h"
00036 #include "Ap4Array.h"
00037 #include "Ap4Movie.h"
00038 #include "Ap4Sample.h"
00039
00040 /*----------------------------------------------------------------------
00041 |   class references
00042 +---------------------------------------------------------------------*/
00043 class AP4_Track;
00044
00045 /*----------------------------------------------------------------------
00046 |   constants
00047 +---------------------------------------------------------------------*/
00048 const unsigned int AP4_LINEAR_READER_INITIALIZED = 1;
00049 const unsigned int AP4_LINEAR_READER_FLAG_EOS    = 2;
00050
00051 const unsigned int AP4_LINEAR_READER_DEFAULT_BUFFER_SIZE = 4096*1024;
00052
00053 /*----------------------------------------------------------------------
00054 |   AP4_LinearReader
00055 +---------------------------------------------------------------------*/
00056 class AP4_LinearReader {
00057 public:
00058     AP4_LinearReader(AP4_Movie& movie, AP4_Size max_buffer=AP4_LINEAR_READER_DEFAULT_BUFFER_SIZE);
00059    ~AP4_LinearReader();
00060
00061     AP4_Result EnableTrack(AP4_UI32 track_id);
00066     AP4_Result ReadNextSample(AP4_Sample&     sample,
00067                               AP4_DataBuffer& sample_data,
00068                               AP4_UI32&       track_id);
00072     AP4_Result ReadNextSample(AP4_UI32        track_id,
00073                               AP4_Sample&     sample,
00074                               AP4_DataBuffer& sample_data);
00075
00076     AP4_Result SetSampleIndex(AP4_UI32 track_id, AP4_UI32 sample_index);
00077
00078     // accessors
00079     AP4_Size GetBufferFullness() { return m_BufferFullness; }
00080
00081 private:
00082     class SampleBuffer {
00083     public:
00084         SampleBuffer(AP4_Sample* sample) : m_Sample(sample) {}
00085        ~SampleBuffer() { delete m_Sample; }
00086         AP4_Sample*    m_Sample;
00087         AP4_DataBuffer m_Data;
00088     };
00089     class Tracker {
00090     public:
00091         Tracker(AP4_Track* track) :
00092             m_Eos(false),
00093             m_Track(track),
00094             m_NextSample(NULL),
00095             m_NextSampleIndex(0) {}
00096         Tracker(const Tracker& other) :
00097             m_Eos(other.m_Eos),
00098             m_Track(other.m_Track),
00099             m_NextSample(NULL),
00100             m_NextSampleIndex(other.m_NextSampleIndex) {} // don't copy samples
00101        ~Tracker() { m_Samples.DeleteReferences(); }
00102         bool                   m_Eos;
00103         AP4_Track*             m_Track;
00104         AP4_Sample*            m_NextSample;
00105         AP4_Ordinal            m_NextSampleIndex;
00106         AP4_List<SampleBuffer> m_Samples;
00107     };
00108
00109     // methods
00110     Tracker*   FindTracker(AP4_UI32 track_id);
00111     AP4_Result Advance();
00112     bool       PopSample(Tracker* tracker, AP4_Sample& sample, AP4_DataBuffer& sample_data);
00113
00114     // members
00115     AP4_Movie&          m_Movie;
00116     AP4_Array<Tracker*> m_Trackers;
00117     AP4_Size            m_BufferFullness;
00118     AP4_Size            m_BufferFullnessPeak;
00119     AP4_Size            m_MaxBufferFullness;
00120 };
00121
00122 #endif // _AP4_LINEAR_READER_H_
Generated on Thu May 13 16:36:32 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4List.h File Reference

  • File List
  • File Members

Ap4List.h File Reference

#include "Ap4Types.h"
#include "Ap4Results.h"

Go to the source code of this file.

Classes

class | AP4_List< T >
class | AP4_List< T >::Item
class | AP4_List< T >::Item::Operator
class | AP4_List< T >::Item::Finder
Generated on Thu May 13 16:36:38 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4List.h Source File

  • File List
  • File Members

Ap4List.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - Lists
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027  ****************************************************************/
00028
00029 #ifndef _AP4_LIST_H_
00030 #define _AP4_LIST_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Types.h"
00036 #include "Ap4Results.h"
00037
00038 /*----------------------------------------------------------------------
00039 |   forward references
00040 +---------------------------------------------------------------------*/
00041 template <typename T> class AP4_List;
00042
00043 /*----------------------------------------------------------------------
00044 |   AP4_List
00045 +---------------------------------------------------------------------*/
00046 template <typename T>
00047 class AP4_List
00048 {
00049 public:
00050     // types
00051     class Item
00052     {
00053     public:
00054         // types
00055         class Operator
00056         {
00057         public:
00058             // methods
00059             virtual ~Operator() {}
00060             virtual AP4_Result Action(T* data) const = 0;
00061         };
00062
00063         class Finder
00064         {
00065         public:
00066             // methods
00067             virtual ~Finder() {}
00068             virtual AP4_Result Test(T* data) const = 0;
00069         };
00070
00071         // methods
00072         Item(T* data) : m_Data(data), m_Next(0), m_Prev(0) {}
00073        ~Item() {}
00074         Item* GetNext() { return m_Next; }
00075         Item* GetPrev() { return m_Prev; }
00076         T*    GetData() { return m_Data; }
00077
00078     private:
00079         // members
00080         T*    m_Data;
00081         Item* m_Next;
00082         Item* m_Prev;
00083
00084         // friends
00085         friend class AP4_List;
00086     };
00087
00088     // methods
00089                  AP4_List<T>(): m_ItemCount(0), m_Head(0), m_Tail(0) {}
00090     virtual     ~AP4_List<T>();
00091     AP4_Result   Clear();
00092     AP4_Result   Add(T* data);
00093     AP4_Result   Add(Item* item);
00094     AP4_Result   Remove(T* data);
00095     AP4_Result   Insert(Item* where, T* data);
00096     AP4_Result   Get(AP4_Ordinal idx, T*& data) const;
00097     AP4_Result   PopHead(T*& data);
00098     AP4_Result   Apply(const typename Item::Operator& op) const;
00099     AP4_Result   ApplyUntilFailure(const typename Item::Operator& op) const;
00100     AP4_Result   ApplyUntilSuccess(const typename Item::Operator& op) const ;
00101     AP4_Result   ReverseApply(const typename Item::Operator& op) const;
00102     AP4_Result   Find(const typename Item::Finder& finder, T*& data) const;
00103     AP4_Result   ReverseFind(const typename Item::Finder& finder, T*& data) const;
00104     AP4_Result   DeleteReferences();
00105     AP4_Cardinal ItemCount() const { return m_ItemCount; }
00106     Item*        FirstItem() const { return m_Head; }
00107     Item*        LastItem()  const { return m_Tail; }
00108
00109 protected:
00110     // members
00111     AP4_Cardinal m_ItemCount;
00112     Item*        m_Head;
00113     Item*        m_Tail;
00114
00115 private:
00116     // these cannot be used
00117     AP4_List<T>(const AP4_List<T>&);
00118     AP4_List<T>& operator=(const AP4_List<T>&);
00119 };
00120
00121 /*----------------------------------------------------------------------
00122 |   AP4_List<T>::~AP4_List<T>
00123 +---------------------------------------------------------------------*/
00124 template <typename T>
00125 AP4_List<T>::~AP4_List()
00126 {
00127     Clear();
00128 }
00129
00130 /*----------------------------------------------------------------------
00131 |   AP4_List<T>::Clear
00132 +---------------------------------------------------------------------*/
00133 template <typename T>
00134 inline
00135 AP4_Result
00136 AP4_List<T>::Clear()
00137 {
00138     Item* item = m_Head;
00139
00140     while (item) {
00141         Item* next = item->m_Next;
00142         delete item;
00143         item = next;
00144     }
00145     m_ItemCount = 0;
00146     m_Head = m_Tail = NULL;
00147
00148     return AP4_SUCCESS;
00149 }
00150
00151 /*----------------------------------------------------------------------
00152 |   AP4_List<T>::Add
00153 +---------------------------------------------------------------------*/
00154 template <typename T>
00155 inline
00156 AP4_Result
00157 AP4_List<T>::Add(T* data)
00158 {
00159     return Add(new Item(data));
00160 }
00161
00162 /*----------------------------------------------------------------------
00163 |   AP4_List<T>::Add
00164 +---------------------------------------------------------------------*/
00165 template <typename T>
00166 AP4_Result
00167 AP4_List<T>::Add(Item* item)
00168 {
00169     // add element at the tail
00170     if (m_Tail) {
00171         item->m_Prev = m_Tail;
00172         item->m_Next = NULL;
00173         m_Tail->m_Next = item;
00174         m_Tail = item;
00175     } else {
00176         m_Head = item;
00177         m_Tail = item;
00178         item->m_Next = NULL;
00179         item->m_Prev = NULL;
00180     }
00181
00182     // one more item in the list now
00183     m_ItemCount++;
00184
00185     return AP4_SUCCESS;
00186 }
00187
00188 /*----------------------------------------------------------------------
00189 |   AP4_List<T>::Remove
00190 +---------------------------------------------------------------------*/
00191 template <typename T>
00192 AP4_Result
00193 AP4_List<T>::Remove(T* data)
00194 {
00195     Item* item = m_Head;
00196
00197     while (item) {
00198         if (item->m_Data == data) {
00199             // delete item
00200             if (item->m_Prev) {
00201                 // item is not the head
00202                 if (item->m_Next) {
00203                     // item is not the tail
00204                     item->m_Next->m_Prev = item->m_Prev;
00205                     item->m_Prev->m_Next = item->m_Next;
00206                 } else {
00207                     // item is the tail
00208                     m_Tail = item->m_Prev;
00209                     m_Tail->m_Next = NULL;
00210                 }
00211             } else {
00212                 // item is the head
00213                 m_Head = item->m_Next;
00214                 if (m_Head) {
00215                     // item is not the tail
00216                     m_Head->m_Prev = NULL;
00217                 } else {
00218                     // item is also the tail
00219                     m_Tail = NULL;
00220                 }
00221             }
00222
00223             // delete the item
00224             delete item;
00225
00226             // one less item in the list now
00227             m_ItemCount--;
00228
00229             return AP4_SUCCESS;
00230         }
00231         item = item->m_Next;
00232     }
00233
00234     return AP4_ERROR_NO_SUCH_ITEM;
00235 }
00236
00237 /*----------------------------------------------------------------------
00238 |   AP4_List<T>::Insert
00239 +---------------------------------------------------------------------*/
00240 template <typename T>
00241 AP4_Result
00242 AP4_List<T>::Insert(Item* where, T* data)
00243 {
00244     Item* item = new Item(data);
00245
00246     if (where == NULL) {
00247         // insert as the head
00248         if (m_Head) {
00249             // replace the current head
00250             item->m_Prev = NULL;
00251             item->m_Next = m_Head;
00252             m_Head->m_Prev = item;
00253             m_Head = item;
00254         } else {
00255             // this item becomes the head and tail
00256             m_Head = item;
00257             m_Tail = item;
00258             item->m_Next = NULL;
00259             item->m_Prev = NULL;
00260         }
00261     } else {
00262         // insert after the 'where' item
00263         if (where == m_Tail) {
00264             // add the item at the end
00265             return Add(item);
00266         } else {
00267             // update the links
00268             item->m_Prev = where;
00269             item->m_Next = where->m_Next;
00270             where->m_Next->m_Prev = item;
00271             where->m_Next = item;
00272         }
00273     }
00274
00275     // one more item in the list now
00276     ++m_ItemCount;
00277
00278     return AP4_SUCCESS;
00279 }
00280
00281 /*----------------------------------------------------------------------
00282 |   AP4_List<T>::Get
00283 +---------------------------------------------------------------------*/
00284 template <typename T>
00285 AP4_Result
00286 AP4_List<T>::Get(AP4_Ordinal idx, T*& data) const
00287 {
00288     Item* item = m_Head;
00289
00290     if (idx < m_ItemCount) {
00291         while (idx--) item = item->m_Next;
00292         data = item->m_Data;
00293         return AP4_SUCCESS;
00294     } else {
00295         data = NULL;
00296         return AP4_ERROR_NO_SUCH_ITEM;
00297     }
00298 }
00299
00300 /*----------------------------------------------------------------------
00301 |   AP4_List<T>::PopHead
00302 +---------------------------------------------------------------------*/
00303 template <typename T>
00304 AP4_Result
00305 AP4_List<T>::PopHead(T*& data)
00306 {
00307     // check that we have at least one item
00308     if (m_Head == NULL) {
00309         return AP4_ERROR_LIST_EMPTY;
00310     }
00311
00312     // remove the item and return it
00313     data = m_Head->m_Data;
00314     Item* head = m_Head;
00315     m_Head = m_Head->m_Next;
00316     if (m_Head) {
00317         m_Head->m_Prev = NULL;
00318     } else {
00319         m_Tail = NULL;
00320     }
00321
00322     // delete item
00323     delete head;
00324
00325     // one less item in the list now
00326     m_ItemCount--;
00327
00328     return AP4_SUCCESS;
00329 }
00330
00331 /*----------------------------------------------------------------------
00332 |   AP4_List<T>::Apply
00333 +---------------------------------------------------------------------*/
00334 template <typename T>
00335 inline
00336 AP4_Result
00337 AP4_List<T>::Apply(const typename Item::Operator& op) const
00338 {
00339     Item* item = m_Head;
00340
00341     while (item) {
00342         op.Action(item->m_Data);
00343         item = item->m_Next;
00344     }
00345
00346     return AP4_SUCCESS;
00347 }
00348
00349 /*----------------------------------------------------------------------
00350 |   AP4_List<T>::ApplyUntilFailure
00351 +---------------------------------------------------------------------*/
00352 template <typename T>
00353 inline
00354 AP4_Result
00355 AP4_List<T>::ApplyUntilFailure(const typename Item::Operator& op) const
00356 {
00357     Item* item = m_Head;
00358
00359     while (item) {
00360         AP4_Result result;
00361         result = op.Action(item->m_Data);
00362         if (result != AP4_SUCCESS) return result;
00363         item = item->m_Next;
00364     }
00365
00366     return AP4_SUCCESS;
00367 }
00368
00369 /*----------------------------------------------------------------------
00370 |   AP4_List<T>::ApplyUntilSuccess
00371 +---------------------------------------------------------------------*/
00372 template <typename T>
00373 inline
00374 AP4_Result
00375 AP4_List<T>::ApplyUntilSuccess(const typename Item::Operator& op) const
00376 {
00377     Item* item = m_Head;
00378
00379     while (item) {
00380         AP4_Result result;
00381         result = op.Action(item->m_Data);
00382         if (result == AP4_SUCCESS) return AP4_SUCCESS;
00383         item = item->m_Next;
00384     }
00385
00386     return AP4_FAILURE;
00387 }
00388
00389 /*----------------------------------------------------------------------
00390 |   AP4_List<T>::ReverseApply
00391 +---------------------------------------------------------------------*/
00392 template <typename T>
00393 inline
00394 AP4_Result
00395 AP4_List<T>::ReverseApply(const typename Item::Operator& op) const
00396 {
00397     Item* item = m_Tail;
00398
00399     while (item) {
00400         if (op.Action(item->m_Data) != AP4_SUCCESS) {
00401             return AP4_ERROR_LIST_OPERATION_ABORTED;
00402         }
00403         item = item->m_Prev;
00404     }
00405
00406     return AP4_SUCCESS;
00407 }
00408
00409 /*----------------------------------------------------------------------
00410 |   AP4_List<T>::Find
00411 +---------------------------------------------------------------------*/
00412 template <typename T>
00413 inline
00414 AP4_Result
00415 AP4_List<T>::Find(const typename Item::Finder& finder, T*& data) const
00416 {
00417     Item* item = m_Head;
00418
00419     while (item) {
00420         if (finder.Test(item->m_Data) == AP4_SUCCESS) {
00421             data = item->m_Data;
00422             return AP4_SUCCESS;
00423         }
00424         item = item->m_Next;
00425     }
00426
00427     data = NULL;
00428     return AP4_ERROR_NO_SUCH_ITEM;
00429 }
00430
00431 /*----------------------------------------------------------------------
00432 |   AP4_List<T>::ReverseFind
00433 +---------------------------------------------------------------------*/
00434 template <typename T>
00435 inline
00436 AP4_Result
00437 AP4_List<T>::ReverseFind(const typename Item::Finder& finder, T*& data) const
00438 {
00439     Item* item = m_Tail;
00440
00441     while (item) {
00442         if (finder.Test(item->m_Data) == AP4_SUCCESS) {
00443             data = item->m_Data;
00444             return AP4_SUCCESS;
00445         }
00446         item = item->m_Prev;
00447     }
00448
00449     data = NULL;
00450     return AP4_ERROR_NO_SUCH_ITEM;
00451 }
00452
00453 /*----------------------------------------------------------------------
00454 |   AP4_List<T>::DeleteReferences
00455 +---------------------------------------------------------------------*/
00456 template <typename T>
00457 inline
00458 AP4_Result
00459 AP4_List<T>::DeleteReferences()
00460 {
00461     Item* item = m_Head;
00462
00463     while (item) {
00464         Item* next = item->m_Next;
00465         delete item->m_Data;
00466         delete item;
00467         item = next;
00468     }
00469
00470     // no more items
00471     m_Head = m_Tail = NULL;
00472     m_ItemCount = 0;
00473
00474     return AP4_SUCCESS;
00475 }
00476
00477 #endif // _AP4_LIST_H_
00478
00479
00480
00481
00482
00483
00484
00485
00486
00487
00488
00489
00490
Generated on Thu May 13 16:36:32 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4Marlin.h File Reference

  • File List
  • File Members

Ap4Marlin.h File Reference

#include "Ap4Types.h"
#include "Ap4SampleEntry.h"
#include "Ap4Atom.h"
#include "Ap4AtomFactory.h"
#include "Ap4SampleDescription.h"
#include "Ap4Processor.h"
#include "Ap4Protection.h"
#include "Ap4TrefTypeAtom.h"
#include "Ap4ObjectDescriptor.h"
#include "Ap4Command.h"
#include "Ap4UuidAtom.h"
#include "Ap4OmaDcf.h"

Go to the source code of this file.

Classes

class | AP4_MarlinIpmpParser
struct | AP4_MarlinIpmpParser::SinfEntry
class | AP4_MarlinIpmpDecryptingProcessor
class | AP4_MarlinIpmpTrackDecrypter
class | AP4_MarlinIpmpEncryptingProcessor
class | AP4_MarlinIpmpTrackEncrypter

Variables

const AP4_UI32 | AP4_MARLIN_BRAND_MGSV = AP4_ATOM_TYPE('M','G','S','V')
const AP4_UI16 | AP4_MARLIN_IPMPS_TYPE_MGSV = 0xA551
const AP4_UI32 | AP4_PROTECTION_SCHEME_TYPE_MARLIN_ACBC = AP4_ATOM_TYPE('A','C','B','C')
const AP4_UI32 | AP4_PROTECTION_SCHEME_TYPE_MARLIN_ACGK = AP4_ATOM_TYPE('A','C','G','K')
const AP4_Atom::Type | AP4_ATOM_TYPE_SATR = AP4_ATOM_TYPE('s','a','t','r')
const AP4_Atom::Type | AP4_ATOM_TYPE_STYP = AP4_ATOM_TYPE('s','t','y','p')
const AP4_Atom::Type | AP4_ATOM_TYPE_HMAC = AP4_ATOM_TYPE('h','m','a','c')
const AP4_Atom::Type | AP4_ATOM_TYPE_GKEY = AP4_ATOM_TYPE('g','k','e','y')
const char *const | AP4_MARLIN_IPMP_STYP_VIDEO = "urn:marlin:organization:sne:content-type:video"
const char *const | AP4_MARLIN_IPMP_STYP_AUDIO = "urn:marlin:organization:sne:content-type:audio"

Variable Documentation

const AP4_Atom::Type AP4_ATOM_TYPE_GKEY = AP4_ATOM_TYPE('g','k','e','y')

Definition at line 59 of file Ap4Marlin.h.

const AP4_Atom::Type AP4_ATOM_TYPE_HMAC = AP4_ATOM_TYPE('h','m','a','c')

Definition at line 58 of file Ap4Marlin.h.

const AP4_Atom::Type AP4_ATOM_TYPE_SATR = AP4_ATOM_TYPE('s','a','t','r')

Definition at line 56 of file Ap4Marlin.h.

const AP4_Atom::Type AP4_ATOM_TYPE_STYP = AP4_ATOM_TYPE('s','t','y','p')

Definition at line 57 of file Ap4Marlin.h.

const AP4_UI32 AP4_MARLIN_BRAND_MGSV = AP4_ATOM_TYPE('M','G','S','V')

Definition at line 51 of file Ap4Marlin.h.

const char* const AP4_MARLIN_IPMP_STYP_AUDIO = "urn:marlin:organization:sne:content-type:audio"

Definition at line 62 of file Ap4Marlin.h.

const char* const AP4_MARLIN_IPMP_STYP_VIDEO = "urn:marlin:organization:sne:content-type:video"

Definition at line 61 of file Ap4Marlin.h.

const AP4_UI16 AP4_MARLIN_IPMPS_TYPE_MGSV = 0xA551

Definition at line 52 of file Ap4Marlin.h.

const AP4_UI32 AP4_PROTECTION_SCHEME_TYPE_MARLIN_ACBC = AP4_ATOM_TYPE('A','C','B','C')

Definition at line 53 of file Ap4Marlin.h.

const AP4_UI32 AP4_PROTECTION_SCHEME_TYPE_MARLIN_ACGK = AP4_ATOM_TYPE('A','C','G','K')

Definition at line 54 of file Ap4Marlin.h.

Generated on Thu May 13 16:36:38 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4Marlin.h Source File

  • File List
  • File Members

Ap4Marlin.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - Marlin File Format support
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027 ****************************************************************/
00028
00029 #ifndef _AP4_MARLIN_H_
00030 #define _AP4_MARLIN_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Types.h"
00036 #include "Ap4SampleEntry.h"
00037 #include "Ap4Atom.h"
00038 #include "Ap4AtomFactory.h"
00039 #include "Ap4SampleDescription.h"
00040 #include "Ap4Processor.h"
00041 #include "Ap4Protection.h"
00042 #include "Ap4TrefTypeAtom.h"
00043 #include "Ap4ObjectDescriptor.h"
00044 #include "Ap4Command.h"
00045 #include "Ap4UuidAtom.h"
00046 #include "Ap4OmaDcf.h"
00047
00048 /*----------------------------------------------------------------------
00049 |   constants
00050 +---------------------------------------------------------------------*/
00051 const AP4_UI32 AP4_MARLIN_BRAND_MGSV       = AP4_ATOM_TYPE('M','G','S','V');
00052 const AP4_UI16 AP4_MARLIN_IPMPS_TYPE_MGSV  = 0xA551;
00053 const AP4_UI32 AP4_PROTECTION_SCHEME_TYPE_MARLIN_ACBC = AP4_ATOM_TYPE('A','C','B','C');
00054 const AP4_UI32 AP4_PROTECTION_SCHEME_TYPE_MARLIN_ACGK = AP4_ATOM_TYPE('A','C','G','K');
00055
00056 const AP4_Atom::Type AP4_ATOM_TYPE_SATR = AP4_ATOM_TYPE('s','a','t','r');
00057 const AP4_Atom::Type AP4_ATOM_TYPE_STYP = AP4_ATOM_TYPE('s','t','y','p');
00058 const AP4_Atom::Type AP4_ATOM_TYPE_HMAC = AP4_ATOM_TYPE('h','m','a','c');
00059 const AP4_Atom::Type AP4_ATOM_TYPE_GKEY = AP4_ATOM_TYPE('g','k','e','y');
00060
00061 const char* const AP4_MARLIN_IPMP_STYP_VIDEO = "urn:marlin:organization:sne:content-type:video";
00062 const char* const AP4_MARLIN_IPMP_STYP_AUDIO = "urn:marlin:organization:sne:content-type:audio";
00063
00064 /*----------------------------------------------------------------------
00065 |   AP4_MarlinIpmpParser
00066 +---------------------------------------------------------------------*/
00067 class AP4_MarlinIpmpParser
00068 {
00069 public:
00070     // types
00071     struct SinfEntry {
00072          SinfEntry(AP4_UI32 track_id, AP4_ContainerAtom* sinf) :
00073              m_TrackId(track_id), m_Sinf(sinf) {}
00074         ~SinfEntry() { delete m_Sinf; }
00075         AP4_UI32           m_TrackId;
00076         AP4_ContainerAtom* m_Sinf;
00077     };
00078
00079     // methods
00080     static AP4_Result Parse(AP4_AtomParent&      top_level,
00081                             AP4_ByteStream&      stream,
00082                             AP4_List<SinfEntry>& sinf_entries,
00083                             bool                 remove_od_data=false);
00084
00085 private:
00086     AP4_MarlinIpmpParser() {} // this class can't be instantiated
00087 };
00088
00089 /*----------------------------------------------------------------------
00090 |   AP4_MarlinIpmpDecryptingProcessor
00091 +---------------------------------------------------------------------*/
00092 class AP4_MarlinIpmpDecryptingProcessor : public AP4_Processor
00093 {
00094 public:
00095     // constructor and destructor
00096     AP4_MarlinIpmpDecryptingProcessor(const AP4_ProtectionKeyMap* key_map = NULL,
00097                                       AP4_BlockCipherFactory*     block_cipher_factory = NULL);
00098     ~AP4_MarlinIpmpDecryptingProcessor();
00099
00100     // accessors
00101     AP4_ProtectionKeyMap& GetKeyMap() { return m_KeyMap; }
00102
00103     // methods
00104     virtual AP4_Result Initialize(AP4_AtomParent&   top_level,
00105                                   AP4_ByteStream&   stream,
00106                                   ProgressListener* listener);
00107     virtual AP4_Processor::TrackHandler* CreateTrackHandler(AP4_TrakAtom* trak);
00108
00109 private:
00110
00111     // members
00112     AP4_BlockCipherFactory*                   m_BlockCipherFactory;
00113     AP4_ProtectionKeyMap                      m_KeyMap;
00114     AP4_List<AP4_MarlinIpmpParser::SinfEntry> m_SinfEntries;
00115 };
00116
00117 /*----------------------------------------------------------------------
00118 |   AP4_MarlinIpmpTrackDecrypter
00119 +---------------------------------------------------------------------*/
00120 class AP4_MarlinIpmpTrackDecrypter : public AP4_Processor::TrackHandler
00121 {
00122 public:
00123     // class methods
00124     static AP4_Result Create(AP4_BlockCipherFactory&        cipher_factory,
00125                              const AP4_UI08*                key,
00126                              AP4_MarlinIpmpTrackDecrypter*& decrypter);
00127
00128     // destructor
00129     ~AP4_MarlinIpmpTrackDecrypter();
00130
00131     // AP4_Processor::TrackHandler methods
00132     virtual AP4_Size GetProcessedSampleSize(AP4_Sample& sample);
00133     virtual AP4_Result ProcessSample(AP4_DataBuffer& data_in,
00134                                      AP4_DataBuffer& data_out);
00135
00136
00137 private:
00138     // constructor
00139     AP4_MarlinIpmpTrackDecrypter(AP4_StreamCipher* cipher) : m_Cipher(cipher) {}
00140
00141     // members
00142     AP4_StreamCipher* m_Cipher;
00143 };
00144
00145 /*----------------------------------------------------------------------
00146 |   AP4_MarlinIpmpEncryptingProcessor
00147 +---------------------------------------------------------------------*/
00148 class AP4_MarlinIpmpEncryptingProcessor : public AP4_Processor
00149 {
00150 public:
00151     // constructor
00152     AP4_MarlinIpmpEncryptingProcessor(bool                        use_group_key = false,
00153                                       const AP4_ProtectionKeyMap* key_map = NULL,
00154                                       AP4_BlockCipherFactory*     block_cipher_factory = NULL);
00155
00156     // accessors
00157     AP4_ProtectionKeyMap& GetKeyMap()      { return m_KeyMap;      }
00158     AP4_TrackPropertyMap& GetPropertyMap() { return m_PropertyMap; }
00159
00160     // AP4_Processor methods
00161     virtual AP4_Result Initialize(AP4_AtomParent&   top_level,
00162                                   AP4_ByteStream&   stream,
00163                                   AP4_Processor::ProgressListener* listener = NULL);
00164     virtual AP4_Processor::TrackHandler* CreateTrackHandler(AP4_TrakAtom* trak);
00165
00166 private:
00167     // members
00168     AP4_BlockCipherFactory* m_BlockCipherFactory;
00169     bool                    m_UseGroupKey;
00170     AP4_ProtectionKeyMap    m_KeyMap;
00171     AP4_TrackPropertyMap    m_PropertyMap;
00172 };
00173
00174 /*----------------------------------------------------------------------
00175 |   AP4_MarlinIpmpTrackEncrypter
00176 +---------------------------------------------------------------------*/
00177 class AP4_MarlinIpmpTrackEncrypter : public AP4_Processor::TrackHandler
00178 {
00179 public:
00180     // class methods
00181     static AP4_Result Create(AP4_BlockCipherFactory&        cipher_factory,
00182                              const AP4_UI08*                key,
00183                              const AP4_UI08*                iv,
00184                              AP4_MarlinIpmpTrackEncrypter*& encrypter);
00185
00186     // destructor
00187     ~AP4_MarlinIpmpTrackEncrypter();
00188
00189     // AP4_Processor::TrackHandler methods
00190     virtual AP4_Size GetProcessedSampleSize(AP4_Sample& sample);
00191     virtual AP4_Result ProcessSample(AP4_DataBuffer& data_in,
00192                                      AP4_DataBuffer& data_out);
00193
00194
00195 private:
00196     // constructor
00197     AP4_MarlinIpmpTrackEncrypter(AP4_StreamCipher* cipher, const AP4_UI08* iv);
00198
00199     // members
00200     AP4_UI08          m_IV[16];
00201     AP4_StreamCipher* m_Cipher;
00202 };
00203
00204 #endif // _AP4_MARLIN_H_
Generated on Thu May 13 16:36:32 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4MdhdAtom.h File Reference

  • File List
  • File Members

Ap4MdhdAtom.h File Reference

#include "Ap4Atom.h"
#include "Ap4String.h"

Go to the source code of this file.

Classes

class | AP4_MdhdAtom

Variables

const AP4_UI32 | AP4_MDHD_DEFAULT_GENERIC_TIMESCALE = 1000
const AP4_UI32 | AP4_MDHD_DEFAULT_VIDEO_TIMESCALE = 90000

Variable Documentation

const AP4_UI32 AP4_MDHD_DEFAULT_GENERIC_TIMESCALE = 1000

Definition at line 41 of file Ap4MdhdAtom.h.

const AP4_UI32 AP4_MDHD_DEFAULT_VIDEO_TIMESCALE = 90000

Definition at line 42 of file Ap4MdhdAtom.h.

Generated on Thu May 13 16:36:38 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4MdhdAtom.h Source File

  • File List
  • File Members

Ap4MdhdAtom.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - mdhd Atoms
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027  ****************************************************************/
00028
00029 #ifndef _AP4_MDHD_ATOM_H_
00030 #define _AP4_MDHD_ATOM_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Atom.h"
00036 #include "Ap4String.h"
00037
00038 /*----------------------------------------------------------------------
00039 |   constants
00040 +---------------------------------------------------------------------*/
00041 const AP4_UI32 AP4_MDHD_DEFAULT_GENERIC_TIMESCALE = 1000;
00042 const AP4_UI32 AP4_MDHD_DEFAULT_VIDEO_TIMESCALE   = 90000;
00043
00044 /*----------------------------------------------------------------------
00045 |   AP4_MdhdAtom
00046 +---------------------------------------------------------------------*/
00047 class AP4_MdhdAtom : public AP4_Atom
00048 {
00049 public:
00050     AP4_IMPLEMENT_DYNAMIC_CAST_D(AP4_MdhdAtom, AP4_Atom)
00051
00052     // class methods
00053     static AP4_MdhdAtom* Create(AP4_Size size, AP4_ByteStream& stream);
00054
00055     // methods
00056     AP4_MdhdAtom(AP4_UI32    creation_time,
00057                  AP4_UI32    modification_time,
00058                  AP4_UI32    time_scale,
00059                  AP4_UI64    duration,
00060                  const char* language);
00061     virtual AP4_Result InspectFields(AP4_AtomInspector& inspector);
00062     virtual AP4_Result WriteFields(AP4_ByteStream& stream);
00063
00064     AP4_UI32          GetDurationMs();
00065     AP4_UI64          GetDuration()  { return m_Duration;  }
00066     void              SetDuration(AP4_UI64 duration) { m_Duration = duration; }
00067     AP4_UI32          GetTimeScale() { return m_TimeScale; }
00068     void              SetTimeScale(AP4_UI32 timescale) { m_TimeScale = timescale; }
00069     const AP4_String& GetLanguage()  { return m_Language;  }
00070
00071 private:
00072     // methods
00073     AP4_MdhdAtom(AP4_UI32        size,
00074                  AP4_UI32        version,
00075                  AP4_UI32        flags,
00076                  AP4_ByteStream& stream);
00077
00078     // members
00079     AP4_UI64   m_CreationTime;
00080     AP4_UI64   m_ModificationTime;
00081     AP4_UI32   m_TimeScale;
00082     AP4_UI64   m_Duration;
00083     AP4_String m_Language;
00084 };
00085
00086 #endif // _AP4_MDHD_ATOM_H_
Generated on Thu May 13 16:36:32 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4MehdAtom.h File Reference

  • File List
  • File Members

Ap4MehdAtom.h File Reference

#include "Ap4List.h"
#include "Ap4Atom.h"

Go to the source code of this file.

Classes

class AP4_MehdAtom
Generated on Thu May 13 16:36:38 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4MehdAtom.h Source File

  • File List
  • File Members

Ap4MehdAtom.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - mehd Atoms
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027  ****************************************************************/
00028
00029 #ifndef _AP4_MEHD_ATOM_H_
00030 #define _AP4_MEHD_ATOM_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4List.h"
00036 #include "Ap4Atom.h"
00037
00038 /*----------------------------------------------------------------------
00039 |   AP4_MehdAtom
00040 +---------------------------------------------------------------------*/
00041 class AP4_MehdAtom : public AP4_Atom
00042 {
00043 public:
00044     AP4_IMPLEMENT_DYNAMIC_CAST_D(AP4_MehdAtom, AP4_Atom)
00045
00046     // class methods
00047     static AP4_MehdAtom* Create(AP4_Size size, AP4_ByteStream& stream);
00048
00049     // methods
00050     AP4_MehdAtom(AP4_UI64 duration);
00051     virtual AP4_Result InspectFields(AP4_AtomInspector& inspector);
00052     virtual AP4_Result WriteFields(AP4_ByteStream& stream);
00053     AP4_UI64           GetDuration() { return m_Duration; }
00054     void               SetDuration(AP4_UI64 duration) { m_Duration = duration;}
00055
00056 private:
00057     // methods
00058     AP4_MehdAtom(AP4_UI32        size,
00059                  AP4_UI32        version,
00060                  AP4_UI32        flags,
00061                  AP4_ByteStream& stream);
00062
00063     // members
00064     AP4_UI64 m_Duration;
00065 };
00066
00067 #endif // _AP4_MEHD_ATOM_H_
Generated on Thu May 13 16:36:32 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4MetaData.h File Reference

  • File List
  • File Members

Ap4MetaData.h File Reference

#include "Ap4Atom.h"
#include "Ap4AtomFactory.h"
#include "Ap4String.h"
#include "Ap4Array.h"
#include "Ap4List.h"

Go to the source code of this file.

Classes

class | AP4_MetaData
class | AP4_MetaData::Key
class | AP4_MetaData::Value
class | AP4_MetaData::KeyInfo
class | AP4_MetaData::Entry
class | AP4_MetaDataAtomTypeHandler
struct | AP4_MetaDataAtomTypeHandler::TypeList
class | AP4_MetaDataTag
class | AP4_3GppLocalizedStringAtom
class | AP4_DcfStringAtom
class | AP4_DcfdAtom
class | AP4_MetaDataStringAtom
class | AP4_DataAtom
class | AP4_StringMetaDataValue
class | AP4_IntegerMetaDataValue
class | AP4_BinaryMetaDataValue
class | AP4_AtomMetaDataValue

Variables

const AP4_Atom::Type | AP4_ATOM_TYPE_DATA = AP4_ATOM_TYPE('d','a','t','a')
const AP4_Atom::Type | AP4_ATOM_TYPE_MEAN = AP4_ATOM_TYPE('m','e','a','n')
const AP4_Atom::Type | AP4_ATOM_TYPE_NAME = AP4_ATOM_TYPE('n','a','m','e')
const AP4_Atom::Type | AP4_ATOM_TYPE_dddd = AP4_ATOM_TYPE('-','-','-','-')
const AP4_Atom::Type | AP4_ATOM_TYPE_cNAM = AP4_ATOM_TYPE(0xA9,'n','a','m')
const AP4_Atom::Type | AP4_ATOM_TYPE_cART = AP4_ATOM_TYPE(0xA9,'A','R','T')
const AP4_Atom::Type | AP4_ATOM_TYPE_cCOM = AP4_ATOM_TYPE(0xA9,'c','o','m')
const AP4_Atom::Type | AP4_ATOM_TYPE_cWRT = AP4_ATOM_TYPE(0xA9,'w','r','t')
const AP4_Atom::Type | AP4_ATOM_TYPE_cALB = AP4_ATOM_TYPE(0xA9,'a','l','b')
const AP4_Atom::Type | AP4_ATOM_TYPE_cGEN = AP4_ATOM_TYPE(0xA9,'g','e','n')
const AP4_Atom::Type | AP4_ATOM_TYPE_cGRP = AP4_ATOM_TYPE(0xA9,'g','r','p')
const AP4_Atom::Type | AP4_ATOM_TYPE_cDAY = AP4_ATOM_TYPE(0xA9,'d','a','y')
const AP4_Atom::Type | AP4_ATOM_TYPE_cTOO = AP4_ATOM_TYPE(0xA9,'t','o','o')
const AP4_Atom::Type | AP4_ATOM_TYPE_cCMT = AP4_ATOM_TYPE(0xA9,'c','m','t')
const AP4_Atom::Type | AP4_ATOM_TYPE_cLYR = AP4_ATOM_TYPE(0xA9,'l','y','r')
const AP4_Atom::Type | AP4_ATOM_TYPE_TRKN = AP4_ATOM_TYPE('t','r','k','n')
const AP4_Atom::Type | AP4_ATOM_TYPE_DISK = AP4_ATOM_TYPE('d','i','s','k')
const AP4_Atom::Type | AP4_ATOM_TYPE_COVR = AP4_ATOM_TYPE('c','o','v','r')
const AP4_Atom::Type | AP4_ATOM_TYPE_DESC = AP4_ATOM_TYPE('d','e','s','c')
const AP4_Atom::Type | AP4_ATOM_TYPE_CPIL = AP4_ATOM_TYPE('c','p','i','l')
const AP4_Atom::Type | AP4_ATOM_TYPE_TMPO = AP4_ATOM_TYPE('t','m','p','o')
const AP4_Atom::Type | AP4_ATOM_TYPE_apID = AP4_ATOM_TYPE('a','p','I','D')
const AP4_Atom::Type | AP4_ATOM_TYPE_cnID = AP4_ATOM_TYPE('c','n','I','D')
const AP4_Atom::Type | AP4_ATOM_TYPE_cmID = AP4_ATOM_TYPE('c','m','I','D')
const AP4_Atom::Type | AP4_ATOM_TYPE_atID = AP4_ATOM_TYPE('a','t','I','D')
const AP4_Atom::Type | AP4_ATOM_TYPE_plID = AP4_ATOM_TYPE('p','l','I','D')
const AP4_Atom::Type | AP4_ATOM_TYPE_geID = AP4_ATOM_TYPE('g','e','I','D')
const AP4_Atom::Type | AP4_ATOM_TYPE_sfID = AP4_ATOM_TYPE('s','f','I','D')
const AP4_Atom::Type | AP4_ATOM_TYPE_akID = AP4_ATOM_TYPE('a','k','I','D')
const AP4_Atom::Type | AP4_ATOM_TYPE_aART = AP4_ATOM_TYPE('a','A','R','T')
const AP4_Atom::Type | AP4_ATOM_TYPE_TVNN = AP4_ATOM_TYPE('t','v','n','n')
const AP4_Atom::Type | AP4_ATOM_TYPE_TVSH = AP4_ATOM_TYPE('t','v','s','h')
const AP4_Atom::Type | AP4_ATOM_TYPE_TVEN = AP4_ATOM_TYPE('t','v','e','n')
const AP4_Atom::Type | AP4_ATOM_TYPE_TVSN = AP4_ATOM_TYPE('t','v','s','n')
const AP4_Atom::Type | AP4_ATOM_TYPE_TVES = AP4_ATOM_TYPE('t','v','e','s')
const AP4_Atom::Type | AP4_ATOM_TYPE_STIK = AP4_ATOM_TYPE('s','t','i','k')
const AP4_Atom::Type | AP4_ATOM_TYPE_PCST = AP4_ATOM_TYPE('p','c','s','t')
const AP4_Atom::Type | AP4_ATOM_TYPE_PURD = AP4_ATOM_TYPE('p','u','r','d')
const AP4_Atom::Type | AP4_ATOM_TYPE_PURL = AP4_ATOM_TYPE('p','u','r','l')
const AP4_Atom::Type | AP4_ATOM_TYPE_EGID = AP4_ATOM_TYPE('e','g','i','d')
const AP4_Atom::Type | AP4_ATOM_TYPE_PGAP = AP4_ATOM_TYPE('p','g','a','p')
const AP4_Atom::Type | AP4_ATOM_TYPE_CATG = AP4_ATOM_TYPE('c','a','t','g')
const AP4_Atom::Type | AP4_ATOM_TYPE_KEYW = AP4_ATOM_TYPE('k','e','y','w')
const AP4_Atom::Type | AP4_ATOM_TYPE_SONM = AP4_ATOM_TYPE('s','o','n','m')
const AP4_Atom::Type | AP4_ATOM_TYPE_SOAL = AP4_ATOM_TYPE('s','o','a','l')
const AP4_Atom::Type | AP4_ATOM_TYPE_SOAR = AP4_ATOM_TYPE('s','o','a','r')
const AP4_Atom::Type | AP4_ATOM_TYPE_SOAA = AP4_ATOM_TYPE('s','o','a','a')
const AP4_Atom::Type | AP4_ATOM_TYPE_SOCO = AP4_ATOM_TYPE('s','o','c','o')
const AP4_Atom::Type | AP4_ATOM_TYPE_SOSN = AP4_ATOM_TYPE('s','o','s','n')
const AP4_Atom::Type | AP4_ATOM_TYPE_TITL = AP4_ATOM_TYPE('t','i','t','l')
const AP4_Atom::Type | AP4_ATOM_TYPE_DSCP = AP4_ATOM_TYPE('d','s','c','p')
const AP4_Atom::Type | AP4_ATOM_TYPE_CPRT = AP4_ATOM_TYPE('c','p','r','t')
const AP4_Atom::Type | AP4_ATOM_TYPE_PERF = AP4_ATOM_TYPE('p','e','r','f')
const AP4_Atom::Type | AP4_ATOM_TYPE_AUTH = AP4_ATOM_TYPE('a','u','t','h')
const AP4_Atom::Type | AP4_ATOM_TYPE_GNRE = AP4_ATOM_TYPE('g','n','r','e')
const AP4_Atom::Type | AP4_ATOM_TYPE_RTNG = AP4_ATOM_TYPE('r','t','n','g')
const AP4_Atom::Type | AP4_ATOM_TYPE_CLSF = AP4_ATOM_TYPE('c','l','s','f')
const AP4_Atom::Type | AP4_ATOM_TYPE_KYWD = AP4_ATOM_TYPE('k','y','w','d')
const AP4_Atom::Type | AP4_ATOM_TYPE_LOCI = AP4_ATOM_TYPE('l','o','c','i')
const AP4_Atom::Type | AP4_ATOM_TYPE_ALBM = AP4_ATOM_TYPE('a','l','b','m')
const AP4_Atom::Type | AP4_ATOM_TYPE_YRRC = AP4_ATOM_TYPE('y','r','r','c')
const AP4_Atom::Type | AP4_ATOM_TYPE_TSEL = AP4_ATOM_TYPE('t','s','e','l')
const AP4_Atom::Type | AP4_ATOM_TYPE_ICNU = AP4_ATOM_TYPE('i','c','n','u')
const AP4_Atom::Type | AP4_ATOM_TYPE_INFU = AP4_ATOM_TYPE('i','n','f','u')
const AP4_Atom::Type | AP4_ATOM_TYPE_CVRU = AP4_ATOM_TYPE('c','v','r','u')
const AP4_Atom::Type | AP4_ATOM_TYPE_LRCU = AP4_ATOM_TYPE('l','r','c','u')
const AP4_Atom::Type | AP4_ATOM_TYPE_DCFD = AP4_ATOM_TYPE('d','c','f','D')

Variable Documentation

const AP4_Atom::Type AP4_ATOM_TYPE_aART = AP4_ATOM_TYPE('a','A','R','T')

Definition at line 85 of file Ap4MetaData.h.

const AP4_Atom::Type AP4_ATOM_TYPE_akID = AP4_ATOM_TYPE('a','k','I','D')

Definition at line 84 of file Ap4MetaData.h.

const AP4_Atom::Type AP4_ATOM_TYPE_ALBM = AP4_ATOM_TYPE('a','l','b','m')

Definition at line 116 of file Ap4MetaData.h.

const AP4_Atom::Type AP4_ATOM_TYPE_apID = AP4_ATOM_TYPE('a','p','I','D')

Definition at line 77 of file Ap4MetaData.h.

const AP4_Atom::Type AP4_ATOM_TYPE_atID = AP4_ATOM_TYPE('a','t','I','D')

Definition at line 80 of file Ap4MetaData.h.

const AP4_Atom::Type AP4_ATOM_TYPE_AUTH = AP4_ATOM_TYPE('a','u','t','h')

Definition at line 110 of file Ap4MetaData.h.

const AP4_Atom::Type AP4_ATOM_TYPE_cALB = AP4_ATOM_TYPE(0xA9,'a','l','b')

Definition at line 64 of file Ap4MetaData.h.

const AP4_Atom::Type AP4_ATOM_TYPE_cART = AP4_ATOM_TYPE(0xA9,'A','R','T')

Definition at line 61 of file Ap4MetaData.h.

const AP4_Atom::Type AP4_ATOM_TYPE_CATG = AP4_ATOM_TYPE('c','a','t','g')

Definition at line 97 of file Ap4MetaData.h.

const AP4_Atom::Type AP4_ATOM_TYPE_cCMT = AP4_ATOM_TYPE(0xA9,'c','m','t')

Definition at line 69 of file Ap4MetaData.h.

const AP4_Atom::Type AP4_ATOM_TYPE_cCOM = AP4_ATOM_TYPE(0xA9,'c','o','m')

Definition at line 62 of file Ap4MetaData.h.

const AP4_Atom::Type AP4_ATOM_TYPE_cDAY = AP4_ATOM_TYPE(0xA9,'d','a','y')

Definition at line 67 of file Ap4MetaData.h.

const AP4_Atom::Type AP4_ATOM_TYPE_cGEN = AP4_ATOM_TYPE(0xA9,'g','e','n')

Definition at line 65 of file Ap4MetaData.h.

const AP4_Atom::Type AP4_ATOM_TYPE_cGRP = AP4_ATOM_TYPE(0xA9,'g','r','p')

Definition at line 66 of file Ap4MetaData.h.

const AP4_Atom::Type AP4_ATOM_TYPE_CLSF = AP4_ATOM_TYPE('c','l','s','f')

Definition at line 113 of file Ap4MetaData.h.

const AP4_Atom::Type AP4_ATOM_TYPE_cLYR = AP4_ATOM_TYPE(0xA9,'l','y','r')

Definition at line 70 of file Ap4MetaData.h.

const AP4_Atom::Type AP4_ATOM_TYPE_cmID = AP4_ATOM_TYPE('c','m','I','D')

Definition at line 79 of file Ap4MetaData.h.

const AP4_Atom::Type AP4_ATOM_TYPE_cNAM = AP4_ATOM_TYPE(0xA9,'n','a','m')

Definition at line 60 of file Ap4MetaData.h.

const AP4_Atom::Type AP4_ATOM_TYPE_cnID = AP4_ATOM_TYPE('c','n','I','D')

Definition at line 78 of file Ap4MetaData.h.

const AP4_Atom::Type AP4_ATOM_TYPE_COVR = AP4_ATOM_TYPE('c','o','v','r')

Definition at line 73 of file Ap4MetaData.h.

const AP4_Atom::Type AP4_ATOM_TYPE_CPIL = AP4_ATOM_TYPE('c','p','i','l')

Definition at line 75 of file Ap4MetaData.h.

const AP4_Atom::Type AP4_ATOM_TYPE_CPRT = AP4_ATOM_TYPE('c','p','r','t')

Definition at line 108 of file Ap4MetaData.h.

const AP4_Atom::Type AP4_ATOM_TYPE_cTOO = AP4_ATOM_TYPE(0xA9,'t','o','o')

Definition at line 68 of file Ap4MetaData.h.

const AP4_Atom::Type AP4_ATOM_TYPE_CVRU = AP4_ATOM_TYPE('c','v','r','u')

Definition at line 122 of file Ap4MetaData.h.

const AP4_Atom::Type AP4_ATOM_TYPE_cWRT = AP4_ATOM_TYPE(0xA9,'w','r','t')

Definition at line 63 of file Ap4MetaData.h.

const AP4_Atom::Type AP4_ATOM_TYPE_DATA = AP4_ATOM_TYPE('d','a','t','a')

Definition at line 56 of file Ap4MetaData.h.

const AP4_Atom::Type AP4_ATOM_TYPE_DCFD = AP4_ATOM_TYPE('d','c','f','D')

Definition at line 124 of file Ap4MetaData.h.

const AP4_Atom::Type AP4_ATOM_TYPE_dddd = AP4_ATOM_TYPE('-','-','-','-')

Definition at line 59 of file Ap4MetaData.h.

const AP4_Atom::Type AP4_ATOM_TYPE_DESC = AP4_ATOM_TYPE('d','e','s','c')

Definition at line 74 of file Ap4MetaData.h.

const AP4_Atom::Type AP4_ATOM_TYPE_DISK = AP4_ATOM_TYPE('d','i','s','k')

Definition at line 72 of file Ap4MetaData.h.

const AP4_Atom::Type AP4_ATOM_TYPE_DSCP = AP4_ATOM_TYPE('d','s','c','p')

Definition at line 107 of file Ap4MetaData.h.

const AP4_Atom::Type AP4_ATOM_TYPE_EGID = AP4_ATOM_TYPE('e','g','i','d')

Definition at line 95 of file Ap4MetaData.h.

const AP4_Atom::Type AP4_ATOM_TYPE_geID = AP4_ATOM_TYPE('g','e','I','D')

Definition at line 82 of file Ap4MetaData.h.

const AP4_Atom::Type AP4_ATOM_TYPE_GNRE = AP4_ATOM_TYPE('g','n','r','e')

Definition at line 111 of file Ap4MetaData.h.

const AP4_Atom::Type AP4_ATOM_TYPE_ICNU = AP4_ATOM_TYPE('i','c','n','u')

Definition at line 120 of file Ap4MetaData.h.

const AP4_Atom::Type AP4_ATOM_TYPE_INFU = AP4_ATOM_TYPE('i','n','f','u')

Definition at line 121 of file Ap4MetaData.h.

const AP4_Atom::Type AP4_ATOM_TYPE_KEYW = AP4_ATOM_TYPE('k','e','y','w')

Definition at line 98 of file Ap4MetaData.h.

const AP4_Atom::Type AP4_ATOM_TYPE_KYWD = AP4_ATOM_TYPE('k','y','w','d')

Definition at line 114 of file Ap4MetaData.h.

const AP4_Atom::Type AP4_ATOM_TYPE_LOCI = AP4_ATOM_TYPE('l','o','c','i')

Definition at line 115 of file Ap4MetaData.h.

const AP4_Atom::Type AP4_ATOM_TYPE_LRCU = AP4_ATOM_TYPE('l','r','c','u')

Definition at line 123 of file Ap4MetaData.h.

const AP4_Atom::Type AP4_ATOM_TYPE_MEAN = AP4_ATOM_TYPE('m','e','a','n')

Definition at line 57 of file Ap4MetaData.h.

const AP4_Atom::Type AP4_ATOM_TYPE_NAME = AP4_ATOM_TYPE('n','a','m','e')

Definition at line 58 of file Ap4MetaData.h.

const AP4_Atom::Type AP4_ATOM_TYPE_PCST = AP4_ATOM_TYPE('p','c','s','t')

Definition at line 92 of file Ap4MetaData.h.

const AP4_Atom::Type AP4_ATOM_TYPE_PERF = AP4_ATOM_TYPE('p','e','r','f')

Definition at line 109 of file Ap4MetaData.h.

const AP4_Atom::Type AP4_ATOM_TYPE_PGAP = AP4_ATOM_TYPE('p','g','a','p')

Definition at line 96 of file Ap4MetaData.h.

const AP4_Atom::Type AP4_ATOM_TYPE_plID = AP4_ATOM_TYPE('p','l','I','D')

Definition at line 81 of file Ap4MetaData.h.

const AP4_Atom::Type AP4_ATOM_TYPE_PURD = AP4_ATOM_TYPE('p','u','r','d')

Definition at line 93 of file Ap4MetaData.h.

const AP4_Atom::Type AP4_ATOM_TYPE_PURL = AP4_ATOM_TYPE('p','u','r','l')

Definition at line 94 of file Ap4MetaData.h.

const AP4_Atom::Type AP4_ATOM_TYPE_RTNG = AP4_ATOM_TYPE('r','t','n','g')

Definition at line 112 of file Ap4MetaData.h.

const AP4_Atom::Type AP4_ATOM_TYPE_sfID = AP4_ATOM_TYPE('s','f','I','D')

Definition at line 83 of file Ap4MetaData.h.

const AP4_Atom::Type AP4_ATOM_TYPE_SOAA = AP4_ATOM_TYPE('s','o','a','a')

Definition at line 102 of file Ap4MetaData.h.

const AP4_Atom::Type AP4_ATOM_TYPE_SOAL = AP4_ATOM_TYPE('s','o','a','l')

Definition at line 100 of file Ap4MetaData.h.

const AP4_Atom::Type AP4_ATOM_TYPE_SOAR = AP4_ATOM_TYPE('s','o','a','r')

Definition at line 101 of file Ap4MetaData.h.

const AP4_Atom::Type AP4_ATOM_TYPE_SOCO = AP4_ATOM_TYPE('s','o','c','o')

Definition at line 103 of file Ap4MetaData.h.

const AP4_Atom::Type AP4_ATOM_TYPE_SONM = AP4_ATOM_TYPE('s','o','n','m')

Definition at line 99 of file Ap4MetaData.h.

const AP4_Atom::Type AP4_ATOM_TYPE_SOSN = AP4_ATOM_TYPE('s','o','s','n')

Definition at line 104 of file Ap4MetaData.h.

const AP4_Atom::Type AP4_ATOM_TYPE_STIK = AP4_ATOM_TYPE('s','t','i','k')

Definition at line 91 of file Ap4MetaData.h.

const AP4_Atom::Type AP4_ATOM_TYPE_TITL = AP4_ATOM_TYPE('t','i','t','l')

Definition at line 106 of file Ap4MetaData.h.

const AP4_Atom::Type AP4_ATOM_TYPE_TMPO = AP4_ATOM_TYPE('t','m','p','o')

Definition at line 76 of file Ap4MetaData.h.

const AP4_Atom::Type AP4_ATOM_TYPE_TRKN = AP4_ATOM_TYPE('t','r','k','n')

Definition at line 71 of file Ap4MetaData.h.

const AP4_Atom::Type AP4_ATOM_TYPE_TSEL = AP4_ATOM_TYPE('t','s','e','l')

Definition at line 118 of file Ap4MetaData.h.

const AP4_Atom::Type AP4_ATOM_TYPE_TVEN = AP4_ATOM_TYPE('t','v','e','n')

Definition at line 88 of file Ap4MetaData.h.

const AP4_Atom::Type AP4_ATOM_TYPE_TVES = AP4_ATOM_TYPE('t','v','e','s')

Definition at line 90 of file Ap4MetaData.h.

const AP4_Atom::Type AP4_ATOM_TYPE_TVNN = AP4_ATOM_TYPE('t','v','n','n')

Definition at line 86 of file Ap4MetaData.h.

const AP4_Atom::Type AP4_ATOM_TYPE_TVSH = AP4_ATOM_TYPE('t','v','s','h')

Definition at line 87 of file Ap4MetaData.h.

const AP4_Atom::Type AP4_ATOM_TYPE_TVSN = AP4_ATOM_TYPE('t','v','s','n')

Definition at line 89 of file Ap4MetaData.h.

const AP4_Atom::Type AP4_ATOM_TYPE_YRRC = AP4_ATOM_TYPE('y','r','r','c')

Definition at line 117 of file Ap4MetaData.h.

Generated on Thu May 13 16:36:39 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4MetaData.h Source File

  • File List
  • File Members

Ap4MetaData.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - MetaData
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027 ****************************************************************/
00028
00029 #ifndef _AP4_META_DATA_H_
00030 #define _AP4_META_DATA_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Atom.h"
00036 #include "Ap4AtomFactory.h"
00037 #include "Ap4String.h"
00038 #include "Ap4Array.h"
00039 #include "Ap4List.h"
00040
00041 /*----------------------------------------------------------------------
00042 |   class references
00043 +---------------------------------------------------------------------*/
00044 class AP4_File;
00045 class AP4_MoovAtom;
00046 class AP4_DataBuffer;
00047 class AP4_ContainerAtom;
00048 class AP4_DataAtom;
00049 class AP4_3GppLocalizedStringAtom;
00050 class AP4_DcfStringAtom;
00051 class AP4_DcfdAtom;
00052
00053 /*----------------------------------------------------------------------
00054 |   metadata keys
00055 +---------------------------------------------------------------------*/
00056 const AP4_Atom::Type AP4_ATOM_TYPE_DATA = AP4_ATOM_TYPE('d','a','t','a'); // data
00057 const AP4_Atom::Type AP4_ATOM_TYPE_MEAN = AP4_ATOM_TYPE('m','e','a','n'); // namespace
00058 const AP4_Atom::Type AP4_ATOM_TYPE_NAME = AP4_ATOM_TYPE('n','a','m','e'); // name
00059 const AP4_Atom::Type AP4_ATOM_TYPE_dddd = AP4_ATOM_TYPE('-','-','-','-'); // free form
00060 const AP4_Atom::Type AP4_ATOM_TYPE_cNAM = AP4_ATOM_TYPE(0xA9,'n','a','m'); // name
00061 const AP4_Atom::Type AP4_ATOM_TYPE_cART = AP4_ATOM_TYPE(0xA9,'A','R','T'); // artist
00062 const AP4_Atom::Type AP4_ATOM_TYPE_cCOM = AP4_ATOM_TYPE(0xA9,'c','o','m'); // composer
00063 const AP4_Atom::Type AP4_ATOM_TYPE_cWRT = AP4_ATOM_TYPE(0xA9,'w','r','t'); // writer
00064 const AP4_Atom::Type AP4_ATOM_TYPE_cALB = AP4_ATOM_TYPE(0xA9,'a','l','b'); // album
00065 const AP4_Atom::Type AP4_ATOM_TYPE_cGEN = AP4_ATOM_TYPE(0xA9,'g','e','n'); // genre
00066 const AP4_Atom::Type AP4_ATOM_TYPE_cGRP = AP4_ATOM_TYPE(0xA9,'g','r','p'); // group
00067 const AP4_Atom::Type AP4_ATOM_TYPE_cDAY = AP4_ATOM_TYPE(0xA9,'d','a','y'); // date
00068 const AP4_Atom::Type AP4_ATOM_TYPE_cTOO = AP4_ATOM_TYPE(0xA9,'t','o','o'); // tool
00069 const AP4_Atom::Type AP4_ATOM_TYPE_cCMT = AP4_ATOM_TYPE(0xA9,'c','m','t'); // comment
00070 const AP4_Atom::Type AP4_ATOM_TYPE_cLYR = AP4_ATOM_TYPE(0xA9,'l','y','r'); // lyrics
00071 const AP4_Atom::Type AP4_ATOM_TYPE_TRKN = AP4_ATOM_TYPE('t','r','k','n'); // track#
00072 const AP4_Atom::Type AP4_ATOM_TYPE_DISK = AP4_ATOM_TYPE('d','i','s','k'); // disk#
00073 const AP4_Atom::Type AP4_ATOM_TYPE_COVR = AP4_ATOM_TYPE('c','o','v','r'); // cover art
00074 const AP4_Atom::Type AP4_ATOM_TYPE_DESC = AP4_ATOM_TYPE('d','e','s','c'); // description
00075 const AP4_Atom::Type AP4_ATOM_TYPE_CPIL = AP4_ATOM_TYPE('c','p','i','l'); // compilation?
00076 const AP4_Atom::Type AP4_ATOM_TYPE_TMPO = AP4_ATOM_TYPE('t','m','p','o'); // tempo
00077 const AP4_Atom::Type AP4_ATOM_TYPE_apID = AP4_ATOM_TYPE('a','p','I','D');
00078 const AP4_Atom::Type AP4_ATOM_TYPE_cnID = AP4_ATOM_TYPE('c','n','I','D');
00079 const AP4_Atom::Type AP4_ATOM_TYPE_cmID = AP4_ATOM_TYPE('c','m','I','D');
00080 const AP4_Atom::Type AP4_ATOM_TYPE_atID = AP4_ATOM_TYPE('a','t','I','D');
00081 const AP4_Atom::Type AP4_ATOM_TYPE_plID = AP4_ATOM_TYPE('p','l','I','D');
00082 const AP4_Atom::Type AP4_ATOM_TYPE_geID = AP4_ATOM_TYPE('g','e','I','D');
00083 const AP4_Atom::Type AP4_ATOM_TYPE_sfID = AP4_ATOM_TYPE('s','f','I','D');
00084 const AP4_Atom::Type AP4_ATOM_TYPE_akID = AP4_ATOM_TYPE('a','k','I','D');
00085 const AP4_Atom::Type AP4_ATOM_TYPE_aART = AP4_ATOM_TYPE('a','A','R','T');
00086 const AP4_Atom::Type AP4_ATOM_TYPE_TVNN = AP4_ATOM_TYPE('t','v','n','n'); // TV network
00087 const AP4_Atom::Type AP4_ATOM_TYPE_TVSH = AP4_ATOM_TYPE('t','v','s','h'); // TV show
00088 const AP4_Atom::Type AP4_ATOM_TYPE_TVEN = AP4_ATOM_TYPE('t','v','e','n'); // TV episode name
00089 const AP4_Atom::Type AP4_ATOM_TYPE_TVSN = AP4_ATOM_TYPE('t','v','s','n'); // TV show season #
00090 const AP4_Atom::Type AP4_ATOM_TYPE_TVES = AP4_ATOM_TYPE('t','v','e','s'); // TV show episode #
00091 const AP4_Atom::Type AP4_ATOM_TYPE_STIK = AP4_ATOM_TYPE('s','t','i','k');
00092 const AP4_Atom::Type AP4_ATOM_TYPE_PCST = AP4_ATOM_TYPE('p','c','s','t'); // Podcast?
00093 const AP4_Atom::Type AP4_ATOM_TYPE_PURD = AP4_ATOM_TYPE('p','u','r','d'); //
00094 const AP4_Atom::Type AP4_ATOM_TYPE_PURL = AP4_ATOM_TYPE('p','u','r','l'); // Podcast URL (binary)
00095 const AP4_Atom::Type AP4_ATOM_TYPE_EGID = AP4_ATOM_TYPE('e','g','i','d'); //
00096 const AP4_Atom::Type AP4_ATOM_TYPE_PGAP = AP4_ATOM_TYPE('p','g','a','p'); // Gapless Playback
00097 const AP4_Atom::Type AP4_ATOM_TYPE_CATG = AP4_ATOM_TYPE('c','a','t','g'); // Category
00098 const AP4_Atom::Type AP4_ATOM_TYPE_KEYW = AP4_ATOM_TYPE('k','e','y','w'); // Keywords
00099 const AP4_Atom::Type AP4_ATOM_TYPE_SONM = AP4_ATOM_TYPE('s','o','n','m'); // Sort-Order: Name
00100 const AP4_Atom::Type AP4_ATOM_TYPE_SOAL = AP4_ATOM_TYPE('s','o','a','l'); // Sort-Order: Album
00101 const AP4_Atom::Type AP4_ATOM_TYPE_SOAR = AP4_ATOM_TYPE('s','o','a','r'); // Sort-Order: Artist
00102 const AP4_Atom::Type AP4_ATOM_TYPE_SOAA = AP4_ATOM_TYPE('s','o','a','a'); // Sort-Order: Album Artist
00103 const AP4_Atom::Type AP4_ATOM_TYPE_SOCO = AP4_ATOM_TYPE('s','o','c','o'); // Sort-Order: Composer
00104 const AP4_Atom::Type AP4_ATOM_TYPE_SOSN = AP4_ATOM_TYPE('s','o','s','n'); // Sort-Order: Show
00105
00106 const AP4_Atom::Type AP4_ATOM_TYPE_TITL = AP4_ATOM_TYPE('t','i','t','l'); // 3GPP: title
00107 const AP4_Atom::Type AP4_ATOM_TYPE_DSCP = AP4_ATOM_TYPE('d','s','c','p'); // 3GPP: description
00108 const AP4_Atom::Type AP4_ATOM_TYPE_CPRT = AP4_ATOM_TYPE('c','p','r','t'); // 3GPP, ISO or ILST: copyright
00109 const AP4_Atom::Type AP4_ATOM_TYPE_PERF = AP4_ATOM_TYPE('p','e','r','f'); // 3GPP: performer
00110 const AP4_Atom::Type AP4_ATOM_TYPE_AUTH = AP4_ATOM_TYPE('a','u','t','h'); // 3GPP: author
00111 const AP4_Atom::Type AP4_ATOM_TYPE_GNRE = AP4_ATOM_TYPE('g','n','r','e'); // 3GPP or ILST: genre (in 3GPP -> string, in ILST -> ID3v1 index + 1)
00112 const AP4_Atom::Type AP4_ATOM_TYPE_RTNG = AP4_ATOM_TYPE('r','t','n','g'); // 3GPP or ILST: rating
00113 const AP4_Atom::Type AP4_ATOM_TYPE_CLSF = AP4_ATOM_TYPE('c','l','s','f'); // 3GPP: classification
00114 const AP4_Atom::Type AP4_ATOM_TYPE_KYWD = AP4_ATOM_TYPE('k','y','w','d'); // 3GPP: keywords
00115 const AP4_Atom::Type AP4_ATOM_TYPE_LOCI = AP4_ATOM_TYPE('l','o','c','i'); // 3GPP: location information
00116 const AP4_Atom::Type AP4_ATOM_TYPE_ALBM = AP4_ATOM_TYPE('a','l','b','m'); // 3GPP: album title and track number
00117 const AP4_Atom::Type AP4_ATOM_TYPE_YRRC = AP4_ATOM_TYPE('y','r','r','c'); // 3GPP: recording year
00118 const AP4_Atom::Type AP4_ATOM_TYPE_TSEL = AP4_ATOM_TYPE('t','s','e','l'); // 3GPP: track selection
00119
00120 const AP4_Atom::Type AP4_ATOM_TYPE_ICNU = AP4_ATOM_TYPE('i','c','n','u'); // DCF: icon URI      (OMA DCF 2.1)
00121 const AP4_Atom::Type AP4_ATOM_TYPE_INFU = AP4_ATOM_TYPE('i','n','f','u'); // DCF: info URI      (OMA DCF 2.1)
00122 const AP4_Atom::Type AP4_ATOM_TYPE_CVRU = AP4_ATOM_TYPE('c','v','r','u'); // DCF: cover art URI (OMA DCF 2.1)
00123 const AP4_Atom::Type AP4_ATOM_TYPE_LRCU = AP4_ATOM_TYPE('l','r','c','u'); // DCF: lyrics URI    (OMA DCF 2.1)
00124 const AP4_Atom::Type AP4_ATOM_TYPE_DCFD = AP4_ATOM_TYPE('d','c','f','D'); // DCF: duration      (OMarlin)
00125
00126 /*----------------------------------------------------------------------
00127 |   AP4_MetaData
00128 +---------------------------------------------------------------------*/
00129 class AP4_MetaData {
00130 public:
00131     class Key {
00132     public:
00133         // constructors
00134         Key(const char* name, const char* ns) :
00135           m_Name(name), m_Namespace(ns) {}
00136
00137         // methods
00138         const AP4_String& GetNamespace() const { return m_Namespace; }
00139         const AP4_String& GetName()      const { return m_Name;      }
00140
00141     private:
00142         // members
00143         const AP4_String m_Name;
00144         const AP4_String m_Namespace;
00145     };
00146
00147     class Value {
00148     public:
00149         // types
00150         typedef enum {
00151             TYPE_BINARY,
00152             TYPE_STRING_UTF_8,
00153             TYPE_STRING_UTF_16,
00154             TYPE_STRING_PASCAL,
00155             TYPE_GIF,
00156             TYPE_JPEG,
00157             TYPE_INT_08_BE,
00158             TYPE_INT_16_BE,
00159             TYPE_INT_32_BE,
00160             TYPE_FLOAT_32_BE,
00161             TYPE_FLOAT_64_BE
00162         } Type;
00163
00164         typedef enum {
00165             TYPE_CATEGORY_STRING,
00166             TYPE_CATEGORY_BINARY,
00167             TYPE_CATEGORY_INTEGER,
00168             TYPE_CATEGORY_FLOAT
00169         } TypeCategory;
00170
00171         typedef enum {
00172             MEANING_UNKNOWN,
00173             MEANING_ID3_GENRE,
00174             MEANING_BOOLEAN,
00175             MEANING_FILE_KIND,
00176             MEANING_BINARY_ENCODED_CHARS
00177         } Meaning;
00178
00179         // destructor
00180         virtual ~Value() {}
00181
00182         // methods
00183         Type               GetType() const                   { return m_Type;         }
00184         TypeCategory       GetTypeCategory() const;
00185         Meaning            GetMeaning() const                { return m_Meaning;      }
00186         const AP4_String&  GetLanguage() const               { return m_Language;     }
00187         void               SetLanguage(const char* language) { m_Language = language; }
00188         virtual AP4_String ToString() const = 0;
00189         virtual AP4_Result ToBytes(AP4_DataBuffer& bytes) const = 0;
00190         virtual long       ToInteger() const = 0;
00191
00192     protected:
00193         // class methods
00194         static TypeCategory MapTypeToCategory(Type type);
00195
00196         // constructor
00197         Value(Type        type,
00198               Meaning     meaning  = MEANING_UNKNOWN,
00199               const char* language = NULL) :
00200             m_Type(type), m_Meaning(meaning), m_Language(language) {}
00201
00202         // members
00203         Type       m_Type;
00204         Meaning    m_Meaning;
00205         AP4_String m_Language;
00206     };
00207
00208     class KeyInfo {
00209     public:
00210         // members
00211         const char* name;
00212         const char* description;
00213         AP4_UI32    four_cc;
00214         Value::Type value_type;
00215     };
00216
00217     class Entry {
00218     public:
00219         // constructor
00220         Entry(const char* name, const char* ns, Value* value) :
00221           m_Key(name, ns), m_Value(value) {}
00222
00223         // destructor
00224         ~Entry() { delete m_Value; }
00225
00226         // methods
00227         AP4_Result         AddToFile(AP4_File& file, AP4_Ordinal index = 0);
00228         AP4_Result         AddToFileIlst(AP4_File& file, AP4_Ordinal index = 0);
00229         AP4_Result         AddToFileDcf(AP4_File& file, AP4_Ordinal index = 0);
00230         AP4_Result         RemoveFromFile(AP4_File& file, AP4_Ordinal index);
00231         AP4_Result         RemoveFromFileIlst(AP4_File& file, AP4_Ordinal index);
00232         AP4_Result         RemoveFromFileDcf(AP4_File& file, AP4_Ordinal index);
00233         AP4_ContainerAtom* FindInIlst(AP4_ContainerAtom* ilst) const;
00234         AP4_Result         ToAtom(AP4_Atom*& atom) const;
00235
00236         // members
00237         Key    m_Key;
00238         Value* m_Value;
00239     };
00240
00241     // class members
00242     static AP4_Array<KeyInfo> KeyInfos;
00243
00244     // constructor
00245     AP4_MetaData(AP4_File* file);
00246
00247     // methods
00248     AP4_Result ParseMoov(AP4_MoovAtom* moov);
00249     AP4_Result ParseUdta(AP4_ContainerAtom* udta, const char* namespc);
00250
00251     // destructor
00252     ~AP4_MetaData();
00253
00254     // accessors
00255     const AP4_List<Entry>& GetEntries() const { return m_Entries; }
00256
00257     // methods
00258     AP4_Result ResolveKeyName(AP4_Atom::Type atom_type, AP4_String& value);
00259     AP4_Result AddIlstEntries(AP4_ContainerAtom* atom, const char* namespc);
00260     AP4_Result Add3GppEntry(AP4_3GppLocalizedStringAtom* atom, const char* namespc);
00261     AP4_Result AddDcfStringEntry(AP4_DcfStringAtom* atom, const char* namespc);
00262     AP4_Result AddDcfdEntry(AP4_DcfdAtom* atom, const char* namespc);
00263
00264 private:
00265     // members
00266     AP4_List<Entry> m_Entries;
00267 };
00268
00269 /*----------------------------------------------------------------------
00270 |   AP4_MetaDataAtomTypeHandler
00271 +---------------------------------------------------------------------*/
00272 class AP4_MetaDataAtomTypeHandler : public AP4_AtomFactory::TypeHandler
00273 {
00274 public:
00275     // constructor
00276     AP4_MetaDataAtomTypeHandler(AP4_AtomFactory* atom_factory) :
00277       m_AtomFactory(atom_factory) {}
00278     virtual AP4_Result CreateAtom(AP4_Atom::Type  type,
00279                                   AP4_UI32        size,
00280                                   AP4_ByteStream& stream,
00281                                   AP4_Atom::Type  context,
00282                                   AP4_Atom*&      atom);
00283
00284     // types
00285     struct TypeList {
00286         const AP4_Atom::Type* m_Types;
00287         AP4_Size              m_Size;
00288     };
00289
00290     // class constants
00291     static const AP4_Atom::Type IlstTypes[];
00292     static const TypeList       IlstTypeList;
00293     static const AP4_Atom::Type _3gppLocalizedStringTypes[];
00294     static const TypeList       _3gppLocalizedStringTypeList;
00295     static const AP4_Atom::Type _3gppOtherTypes[];
00296     static const TypeList       _3gppOtherTypeList;
00297     static const AP4_Atom::Type DcfStringTypes[];
00298     static const TypeList       DcfStringTypeList;
00299
00300     // class methods
00301     static bool IsTypeInList(AP4_Atom::Type type, const TypeList& list);
00302
00303 private:
00304     // members
00305     AP4_AtomFactory* m_AtomFactory;
00306 };
00307
00308 /*----------------------------------------------------------------------
00309 |   AP4_MetaDataTag
00310 +---------------------------------------------------------------------*/
00311 class AP4_MetaDataTag
00312 {
00313 public:
00314
00315     // destructor
00316     virtual ~AP4_MetaDataTag() {}
00317
00318     // methods
00319     virtual AP4_Result Write(AP4_ByteStream& stream);
00320     virtual AP4_Result Inspect(AP4_AtomInspector& inspector);
00321
00322 protected:
00323     // constructor
00324     AP4_MetaDataTag(AP4_UI32        data_type,
00325                     AP4_UI32        data_lang,
00326                     AP4_Size        size,
00327                     AP4_ByteStream& stream);
00328
00329 };
00330
00331 /*----------------------------------------------------------------------
00332 |   AP4_3GppLocalizedStringAtom
00333 +---------------------------------------------------------------------*/
00334 class AP4_3GppLocalizedStringAtom : public AP4_Atom
00335 {
00336 public:
00337     AP4_IMPLEMENT_DYNAMIC_CAST_D(AP4_3GppLocalizedStringAtom, AP4_Atom)
00338
00339     // factory method
00340     static AP4_3GppLocalizedStringAtom* Create(Type type, AP4_UI32 size, AP4_ByteStream& stream);
00341
00342     // constructor
00343     AP4_3GppLocalizedStringAtom(Type type, const char* language, const char* value);
00344     AP4_3GppLocalizedStringAtom(Type            type,
00345                                 AP4_UI32        size,
00346                                 AP4_UI32        version,
00347                                 AP4_UI32        flags,
00348                                 AP4_ByteStream& stream);
00349
00350     // AP4_Atom methods
00351     virtual AP4_Result InspectFields(AP4_AtomInspector& inspector);
00352     virtual AP4_Result WriteFields(AP4_ByteStream& stream);
00353
00354     // methods
00355     const char*       GetLanguage() const { return m_Language; }
00356     const AP4_String& GetValue()    const { return m_Value;    }
00357
00358 private:
00359     // members
00360     char       m_Language[4];
00361     AP4_String m_Value;
00362 };
00363
00364 /*----------------------------------------------------------------------
00365 |   AP4_DcfStringAtom
00366 +---------------------------------------------------------------------*/
00367 class AP4_DcfStringAtom : public AP4_Atom
00368 {
00369 public:
00370     AP4_IMPLEMENT_DYNAMIC_CAST_D(AP4_DcfStringAtom, AP4_Atom)
00371
00372     // factory method
00373     static AP4_DcfStringAtom* Create(Type type, AP4_UI32 size, AP4_ByteStream& stream);
00374
00375     // constructor
00376     AP4_DcfStringAtom(Type type, const char* value);
00377     AP4_DcfStringAtom(Type            type,
00378                       AP4_UI32        size,
00379                       AP4_UI32        version,
00380                       AP4_UI32        flags,
00381                       AP4_ByteStream& stream);
00382
00383     // AP4_Atom methods
00384     virtual AP4_Result InspectFields(AP4_AtomInspector& inspector);
00385     virtual AP4_Result WriteFields(AP4_ByteStream& stream);
00386
00387     // methods
00388     const AP4_String& GetValue() const { return m_Value;  }
00389
00390 private:
00391     // members
00392     AP4_String m_Value;
00393 };
00394
00395 /*----------------------------------------------------------------------
00396 |   AP4_DcfdAtom
00397 +---------------------------------------------------------------------*/
00398 class AP4_DcfdAtom : public AP4_Atom
00399 {
00400 public:
00401     AP4_IMPLEMENT_DYNAMIC_CAST_D(AP4_DcfdAtom, AP4_Atom)
00402
00403     // factory method
00404     static AP4_DcfdAtom* Create(AP4_UI32 size, AP4_ByteStream& stream);
00405
00406     // constructors
00407     AP4_DcfdAtom(AP4_UI32        version,
00408                  AP4_UI32        flags,
00409                  AP4_ByteStream& stream);
00410     AP4_DcfdAtom(AP4_UI32 duration);
00411
00412     // AP4_Atom methods
00413     virtual AP4_Result InspectFields(AP4_AtomInspector& inspector);
00414     virtual AP4_Result WriteFields(AP4_ByteStream& stream);
00415
00416     // methods
00417     AP4_UI32 GetDuration() const { return m_Duration;  }
00418
00419 private:
00420     // members
00421     AP4_UI32 m_Duration;
00422 };
00423
00424 /*----------------------------------------------------------------------
00425 |   AP4_MetaDataStringAtom
00426 +---------------------------------------------------------------------*/
00427 class AP4_MetaDataStringAtom : public AP4_Atom
00428 {
00429 public:
00430     // constructors
00431     AP4_MetaDataStringAtom(Type type, const char* value);
00432     AP4_MetaDataStringAtom(Type type, AP4_UI32 size, AP4_ByteStream& stream);
00433
00434     // AP4_Atom methods
00435     virtual AP4_Result InspectFields(AP4_AtomInspector& inspector);
00436     virtual AP4_Result WriteFields(AP4_ByteStream& stream);
00437
00438     // methods
00439     const AP4_String& GetValue() { return m_Value; }
00440
00441 private:
00442     // members
00443     AP4_UI32   m_Reserved;
00444     AP4_String m_Value;
00445 };
00446
00447 /*----------------------------------------------------------------------
00448 |   AP4_DataAtom
00449 +---------------------------------------------------------------------*/
00450 class AP4_DataAtom : public AP4_Atom
00451 {
00452 public:
00453     AP4_IMPLEMENT_DYNAMIC_CAST_D(AP4_DataAtom, AP4_Atom)
00454
00455     typedef enum {
00456         DATA_TYPE_BINARY        = 0,
00457         DATA_TYPE_STRING_UTF_8  = 1,
00458         DATA_TYPE_STRING_UTF_16 = 2,
00459         DATA_TYPE_STRING_PASCAL = 3,
00460         DATA_TYPE_GIF           = 13,
00461         DATA_TYPE_JPEG          = 14,
00462         DATA_TYPE_SIGNED_INT_BE = 21, /* the size of the integer is derived from the container size */
00463         DATA_TYPE_FLOAT_32_BE   = 22,
00464         DATA_TYPE_FLOAT_64_BE   = 23
00465     } DataType;
00466
00467     typedef enum {
00468         LANGUAGE_ENGLISH = 0
00469     } DataLang;
00470
00471     // constructors
00472     AP4_DataAtom(const AP4_MetaData::Value& value);
00473     AP4_DataAtom(AP4_UI32 size, AP4_ByteStream& stream);
00474
00475     // destructor
00476     ~AP4_DataAtom();
00477
00478     // AP4_Atom methods
00479     virtual AP4_Result InspectFields(AP4_AtomInspector& inspector);
00480     virtual AP4_Result WriteFields(AP4_ByteStream& stream);
00481
00482     // accessors
00483     DataType GetDataType() { return m_DataType; }
00484     DataLang GetDataLang() { return m_DataLang; }
00485     AP4_MetaData::Value::Type GetValueType();
00486
00487     // methods
00488     AP4_Result LoadString(AP4_String*& string);
00489     AP4_Result LoadBytes(AP4_DataBuffer& bytes);
00490     AP4_Result LoadInteger(long& value);
00491
00492 private:
00493     // members
00494     DataType        m_DataType;
00495     DataLang        m_DataLang;
00496     AP4_ByteStream* m_Source;
00497 };
00498
00499 /*----------------------------------------------------------------------
00500 |   AP4_StringMetaDataValue
00501 +---------------------------------------------------------------------*/
00502 class AP4_StringMetaDataValue : public AP4_MetaData::Value {
00503 public:
00504     // constructor
00505     AP4_StringMetaDataValue(const char* value, const char* language=NULL) :
00506         Value(TYPE_STRING_UTF_8, MEANING_UNKNOWN, language),
00507         m_Value(value) {}
00508
00509     // AP4_MetaData::Value methods
00510     virtual AP4_String ToString() const;
00511     virtual AP4_Result ToBytes(AP4_DataBuffer& bytes) const;
00512     virtual long       ToInteger() const;
00513
00514 private:
00515     // members
00516     AP4_String m_Value;
00517 };
00518
00519 /*----------------------------------------------------------------------
00520 |   AP4_IntegerMetaDataValue
00521 +---------------------------------------------------------------------*/
00522 class AP4_IntegerMetaDataValue : public AP4_MetaData::Value {
00523 public:
00524     // constructor
00525     AP4_IntegerMetaDataValue(Type type, long value) :
00526         Value(type), m_Value(value) {}
00527
00528     // AP4_MetaData::Value methods
00529     virtual AP4_String ToString() const;
00530     virtual AP4_Result ToBytes(AP4_DataBuffer& bytes) const;
00531     virtual long       ToInteger() const;
00532
00533 private:
00534     // members
00535     long m_Value;
00536 };
00537
00538 /*----------------------------------------------------------------------
00539 |   AP4_BinaryMetaDataValue
00540 +---------------------------------------------------------------------*/
00541 class AP4_BinaryMetaDataValue : public AP4_MetaData::Value {
00542 public:
00543     // constructor
00544     AP4_BinaryMetaDataValue(Type type, const AP4_UI08* data, AP4_Size size) :
00545         Value(type), m_Value(data, size) {}
00546
00547     // AP4_MetaData::Value methods
00548     virtual AP4_String ToString() const;
00549     virtual AP4_Result ToBytes(AP4_DataBuffer& bytes) const;
00550     virtual long       ToInteger() const;
00551
00552 private:
00553     // members
00554     AP4_DataBuffer m_Value;
00555 };
00556
00557 /*----------------------------------------------------------------------
00558 |   AP4_AtomMetaDataValue
00559 +---------------------------------------------------------------------*/
00560 class AP4_AtomMetaDataValue : public AP4_MetaData::Value
00561 {
00562 public:
00563     // constructor
00564     AP4_AtomMetaDataValue(AP4_DataAtom* data_atom, AP4_UI32 parent_type);
00565
00566     // AP4_MetaData::Value methods
00567     virtual AP4_String ToString() const;
00568     virtual AP4_Result ToBytes(AP4_DataBuffer& bytes) const;
00569     virtual long       ToInteger() const;
00570
00571 private:
00572     // members
00573     AP4_DataAtom* m_DataAtom;
00574 };
00575
00576 #endif // _AP4_META_DATA_H_
Generated on Thu May 13 16:36:32 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4MfhdAtom.h File Reference

  • File List
  • File Members

Ap4MfhdAtom.h File Reference

#include "Ap4Atom.h"

Go to the source code of this file.

Classes

class AP4_MfhdAtom
Generated on Thu May 13 16:36:39 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4MfhdAtom.h Source File

  • File List
  • File Members

Ap4MfhdAtom.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - mfhd Atoms
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027  ****************************************************************/
00028
00029 #ifndef _AP4_MFHD_ATOM_H_
00030 #define _AP4_MFHD_ATOM_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Atom.h"
00036
00037 /*----------------------------------------------------------------------
00038 |   AP4_MfhdAtom
00039 +---------------------------------------------------------------------*/
00040 class AP4_MfhdAtom : public AP4_Atom
00041 {
00042 public:
00043     AP4_IMPLEMENT_DYNAMIC_CAST(AP4_MfhdAtom)
00044
00045     // class methods
00046     static AP4_MfhdAtom* Create(AP4_Size size, AP4_ByteStream& stream);
00047
00048     // methods
00049     AP4_MfhdAtom(AP4_UI32 sequence_number);
00050     virtual AP4_Result InspectFields(AP4_AtomInspector& inspector);
00051     virtual AP4_Result WriteFields(AP4_ByteStream& stream);
00052
00053     AP4_UI32 GetSequenceNumber()                         { return m_SequenceNumber;            }
00054     void     SetSequenceNumber(AP4_UI32 sequence_number) { m_SequenceNumber = sequence_number; }
00055
00056 private:
00057     // methods
00058     AP4_MfhdAtom(AP4_UI32        size,
00059                  AP4_UI32        version,
00060                  AP4_UI32        flags,
00061                  AP4_ByteStream& stream);
00062
00063     // members
00064     AP4_UI32 m_SequenceNumber;
00065 };
00066
00067 #endif // _AP4_MFHD_ATOM_H_
Generated on Thu May 13 16:36:32 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4MfroAtom.h File Reference

  • File List
  • File Members

Ap4MfroAtom.h File Reference

#include "Ap4Types.h"
#include "Ap4Atom.h"
#include "Ap4Array.h"

Go to the source code of this file.

Classes

class AP4_MfroAtom
Generated on Thu May 13 16:36:39 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4MfroAtom.h Source File

  • File List
  • File Members

Ap4MfroAtom.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - mfro Atoms
00004 |
00005 |    Copyright 2002-2009 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027  ****************************************************************/
00028
00029 #ifndef _AP4_MFRO_ATOM_H_
00030 #define _AP4_MFRO_ATOM_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Types.h"
00036 #include "Ap4Atom.h"
00037 #include "Ap4Array.h"
00038
00039 /*----------------------------------------------------------------------
00040 |   class references
00041 +---------------------------------------------------------------------*/
00042 class AP4_ByteStream;
00043
00044 /*----------------------------------------------------------------------
00045 |   AP4_MfroAtom
00046 +---------------------------------------------------------------------*/
00047 class AP4_MfroAtom : public AP4_Atom
00048 {
00049 public:
00050     // class methods
00051     static AP4_MfroAtom* Create(AP4_Size size, AP4_ByteStream& stream);
00052
00053     // constructors
00054     AP4_MfroAtom(AP4_UI32 mfra_size);
00055
00056     // methods
00057     virtual AP4_Result InspectFields(AP4_AtomInspector& inspector);
00058     virtual AP4_Result WriteFields(AP4_ByteStream& stream);
00059
00060     // accessors
00061     AP4_UI32 GetMfraSize() { return m_MfraSize; }
00062
00063 private:
00064     // methods
00065     AP4_MfroAtom(AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags, AP4_ByteStream& stream);
00066
00067     // members
00068     AP4_UI32 m_MfraSize;
00069 };
00070
00071 #endif // _AP4_MFRO_ATOM_H_
Generated on Thu May 13 16:36:32 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4MoovAtom.h File Reference

  • File List
  • File Members

Ap4MoovAtom.h File Reference

#include "Ap4List.h"
#include "Ap4ContainerAtom.h"

Go to the source code of this file.

Classes

class AP4_MoovAtom
Generated on Thu May 13 16:36:39 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4MoovAtom.h Source File

  • File List
  • File Members

Ap4MoovAtom.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - moov Atoms
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027  ****************************************************************/
00028
00029 #ifndef _AP4_MOOV_ATOM_H_
00030 #define _AP4_MOOV_ATOM_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4List.h"
00036 #include "Ap4ContainerAtom.h"
00037
00038 /*----------------------------------------------------------------------
00039 |   class references
00040 +---------------------------------------------------------------------*/
00041 class AP4_AtomFactory;
00042 class AP4_TrakAtom;
00043
00044 /*----------------------------------------------------------------------
00045 |   AP4_MoovAtom
00046 +---------------------------------------------------------------------*/
00047 class AP4_MoovAtom : public AP4_ContainerAtom
00048 {
00049 public:
00050     AP4_IMPLEMENT_DYNAMIC_CAST_D(AP4_MoovAtom, AP4_ContainerAtom)
00051
00052     // class methods
00053     static AP4_MoovAtom* Create(AP4_Size         size,
00054                                 AP4_ByteStream&  stream,
00055                                 AP4_AtomFactory& atom_factory) {
00056         return new AP4_MoovAtom(size, stream, atom_factory);
00057     }
00058
00059     // methods
00060     AP4_MoovAtom();
00061     AP4_List<AP4_TrakAtom>& GetTrakAtoms() {
00062         return m_TrakAtoms;
00063     }
00064     AP4_UI32 GetTimeScale() {
00065         return m_TimeScale;
00066     }
00067     AP4_Result AdjustChunkOffsets(AP4_SI64 offset);
00068
00069     // AP4_AtomParent methods
00070     void OnChildAdded(AP4_Atom* atom);
00071     void OnChildRemoved(AP4_Atom* atom);
00072
00073 private:
00074     // methods
00075     AP4_MoovAtom(AP4_UI32         size,
00076                  AP4_ByteStream&  stream,
00077                  AP4_AtomFactory& atom_factory);
00078
00079     // members
00080     AP4_List<AP4_TrakAtom> m_TrakAtoms;
00081     AP4_UI32               m_TimeScale;
00082 };
00083
00084 #endif // _AP4_MOOV_ATOM_H_
Generated on Thu May 13 16:36:32 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4Movie.h File Reference

  • File List
  • File Members

Ap4Movie.h File Reference

#include "Ap4Types.h"
#include "Ap4MoovAtom.h"
#include "Ap4MvhdAtom.h"
#include "Ap4Track.h"
#include "Ap4List.h"

Go to the source code of this file.

Classes

class AP4_Movie
Generated on Thu May 13 16:36:39 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4Movie.h Source File

  • File List
  • File Members

Ap4Movie.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - Movie
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027  ****************************************************************/
00028
00029 #ifndef _AP4_MOVIE_H_
00030 #define _AP4_MOVIE_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Types.h"
00036 #include "Ap4MoovAtom.h"
00037 #include "Ap4MvhdAtom.h"
00038 #include "Ap4Track.h"
00039 #include "Ap4List.h"
00040
00041 /*----------------------------------------------------------------------
00042 |   class references
00043 +---------------------------------------------------------------------*/
00044 class AP4_ByteStream;
00045 class AP4_AtomInspector;
00046 class AP4_MetaData;
00047
00048 /*----------------------------------------------------------------------
00049 |   AP4_Movie
00050 +---------------------------------------------------------------------*/
00051 class AP4_Movie {
00052 public:
00053     // methods
00054     AP4_Movie(AP4_UI32 time_scale = 0);
00055     AP4_Movie(AP4_MoovAtom* moov, AP4_ByteStream& sample_stream, bool transfer_moov_ownership = true);
00056     virtual ~AP4_Movie();
00057     AP4_Result Inspect(AP4_AtomInspector& inspector);
00058
00059     AP4_MoovAtom* GetMoovAtom() { return m_MoovAtom;}
00060     AP4_MvhdAtom* GetMvhdAtom() { return m_MvhdAtom;}
00061     AP4_List<AP4_Track>& GetTracks() { return m_Tracks; }
00062     AP4_Track*   GetTrack(AP4_UI32 track_id);
00063     AP4_Track*   GetTrack(AP4_Track::Type type, AP4_Ordinal index = 0);
00064     AP4_Result   AddTrack(AP4_Track* track);
00065     AP4_UI32     GetTimeScale();
00066     AP4_UI64     GetDuration();
00067     AP4_UI32     GetDurationMs();
00068
00069 private:
00070     // members
00071     AP4_MoovAtom*       m_MoovAtom;
00072     bool                m_MoovAtomIsOwned;
00073     AP4_MvhdAtom*       m_MvhdAtom;
00074     AP4_List<AP4_Track> m_Tracks;
00075 };
00076
00077 #endif // _AP4_MOVIE_H_
Generated on Thu May 13 16:36:32 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4MovieFragment.h File Reference

  • File List
  • File Members

Ap4MovieFragment.h File Reference

#include "Ap4Types.h"
#include "Ap4MfhdAtom.h"
#include "Ap4List.h"

Go to the source code of this file.

Classes

class | AP4_MovieFragment

Variables

const AP4_UI32 | AP4_FRAG_FLAG_SAMPLE_IS_DIFFERENCE = 0x00010000

Variable Documentation

const AP4_UI32 AP4_FRAG_FLAG_SAMPLE_IS_DIFFERENCE = 0x00010000

Definition at line 51 of file Ap4MovieFragment.h.

Generated on Thu May 13 16:36:39 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4MovieFragment.h Source File

  • File List
  • File Members

Ap4MovieFragment.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - Movie Fragments
00004 |
00005 |    Copyright 2002-2009 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027  ****************************************************************/
00028
00029 #ifndef _AP4_MOVIE_FRAGMENT_H_
00030 #define _AP4_MOVIE_FRAGMENT_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Types.h"
00036 #include "Ap4MfhdAtom.h"
00037 #include "Ap4List.h"
00038
00039 /*----------------------------------------------------------------------
00040 |   class references
00041 +---------------------------------------------------------------------*/
00042 class AP4_ByteStream;
00043 class AP4_ContainerAtom;
00044 class AP4_FragmentSampleTable;
00045 class AP4_Movie;
00046 class AP4_MoovAtom;
00047
00048 /*----------------------------------------------------------------------
00049 |   constants
00050 +---------------------------------------------------------------------*/
00051 const AP4_UI32 AP4_FRAG_FLAG_SAMPLE_IS_DIFFERENCE = 0x00010000;
00052
00053 /*----------------------------------------------------------------------
00054 |   AP4_MovieFragment
00055 +---------------------------------------------------------------------*/
00056 class AP4_MovieFragment {
00057 public:
00058     // this constructor transfers the ownership of the moof atom to the
00059     // newly constructed object
00060     AP4_MovieFragment(AP4_ContainerAtom* moof);
00061     virtual ~AP4_MovieFragment();
00062
00063     AP4_ContainerAtom* GetMoofAtom() { return m_MoofAtom;}
00064     AP4_MfhdAtom*      GetMfhdAtom() { return m_MfhdAtom;}
00065     AP4_UI32           GetSequenceNumber();
00066     AP4_Result         GetTrackIds(AP4_Array<AP4_UI32>& ids);
00067     AP4_Result         GetTrafAtom(AP4_UI32 track_id, AP4_ContainerAtom*& traf);
00068     AP4_Result         CreateSampleTable(AP4_MoovAtom*             moov,
00069                                          AP4_UI32                  track_id,
00070                                          AP4_ByteStream*           sample_stream,
00071                                          AP4_Position              moof_offset,
00072                                          AP4_Position              mdat_payload_offset, // hack because MS doesn't implement the spec properly
00073                                          AP4_FragmentSampleTable*& sample_table);
00074     AP4_Result         CreateSampleTable(AP4_Movie*                movie,
00075                                          AP4_UI32                  track_id,
00076                                          AP4_ByteStream*           sample_stream,
00077                                          AP4_Position              moof_offset,
00078                                          AP4_Position              mdat_payload_offset, // hack because MS doesn't implement the spec properly
00079                                          AP4_FragmentSampleTable*& sample_table);
00080
00081 private:
00082     // members
00083     AP4_ContainerAtom*  m_MoofAtom;
00084     AP4_MfhdAtom*       m_MfhdAtom;
00085 };
00086
00087 #endif // _AP4_MOVIE_FRAGMENT_H_
Generated on Thu May 13 16:36:33 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4Mpeg2Ts.h File Reference

  • File List
  • File Members

Ap4Mpeg2Ts.h File Reference

#include "Ap4Types.h"

Go to the source code of this file.

Classes

class | AP4_Mpeg2TsWriter
This class is a simple implementation of a converter that can convert MP4 audio and video access units into an MPEG2 transport stream. More...
class | AP4_Mpeg2TsWriter::Stream
class | AP4_Mpeg2TsWriter::SampleStream

Variables

const AP4_UI16 | AP4_MPEG2_TS_DEFAULT_PID_PMT = 0x100
const AP4_UI16 | AP4_MPEG2_TS_DEFAULT_PID_AUDIO = 0x101
const AP4_UI16 | AP4_MPEG2_TS_DEFAULT_PID_VIDEO = 0x102
const AP4_UI16 | AP4_MPEG2_TS_DEFAULT_STREAM_ID_AUDIO = 0xc0
const AP4_UI16 | AP4_MPEG2_TS_DEFAULT_STREAM_ID_VIDEO = 0xe0
const AP4_UI08 | AP4_MPEG2_STREAM_TYPE_ISO_IEC_13818_7 = 0x0F
const AP4_UI08 | AP4_MPEG2_STREAM_TYPE_AVC = 0x1B

Variable Documentation

const AP4_UI08 AP4_MPEG2_STREAM_TYPE_AVC = 0x1B

Definition at line 54 of file Ap4Mpeg2Ts.h.

const AP4_UI08 AP4_MPEG2_STREAM_TYPE_ISO_IEC_13818_7 = 0x0F

Definition at line 53 of file Ap4Mpeg2Ts.h.

const AP4_UI16 AP4_MPEG2_TS_DEFAULT_PID_AUDIO = 0x101

Definition at line 48 of file Ap4Mpeg2Ts.h.

const AP4_UI16 AP4_MPEG2_TS_DEFAULT_PID_PMT = 0x100

Definition at line 47 of file Ap4Mpeg2Ts.h.

const AP4_UI16 AP4_MPEG2_TS_DEFAULT_PID_VIDEO = 0x102

Definition at line 49 of file Ap4Mpeg2Ts.h.

const AP4_UI16 AP4_MPEG2_TS_DEFAULT_STREAM_ID_AUDIO = 0xc0

Definition at line 50 of file Ap4Mpeg2Ts.h.

const AP4_UI16 AP4_MPEG2_TS_DEFAULT_STREAM_ID_VIDEO = 0xe0

Definition at line 51 of file Ap4Mpeg2Ts.h.

Generated on Thu May 13 16:36:39 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4Mpeg2Ts.h Source File

  • File List
  • File Members

Ap4Mpeg2Ts.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - MPEG2 Transport Streams
00004 |
00005 |    Copyright 2002-2009 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027 ****************************************************************/
00028
00029 #ifndef _AP4_MPEG2_TS_H_
00030 #define _AP4_MPEG2_TS_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Types.h"
00036
00037 /*----------------------------------------------------------------------
00038 |   classes
00039 +---------------------------------------------------------------------*/
00040 class AP4_ByteStream;
00041 class AP4_Sample;
00042 class AP4_SampleDescription;
00043
00044 /*----------------------------------------------------------------------
00045 |   constants
00046 +---------------------------------------------------------------------*/
00047 const AP4_UI16 AP4_MPEG2_TS_DEFAULT_PID_PMT         = 0x100;
00048 const AP4_UI16 AP4_MPEG2_TS_DEFAULT_PID_AUDIO       = 0x101;
00049 const AP4_UI16 AP4_MPEG2_TS_DEFAULT_PID_VIDEO       = 0x102;
00050 const AP4_UI16 AP4_MPEG2_TS_DEFAULT_STREAM_ID_AUDIO = 0xc0;
00051 const AP4_UI16 AP4_MPEG2_TS_DEFAULT_STREAM_ID_VIDEO = 0xe0;
00052
00053 const AP4_UI08 AP4_MPEG2_STREAM_TYPE_ISO_IEC_13818_7 = 0x0F;
00054 const AP4_UI08 AP4_MPEG2_STREAM_TYPE_AVC             = 0x1B;
00055
00056 /*----------------------------------------------------------------------
00057 |   AP4_Mpeg2TsWriter
00058 +---------------------------------------------------------------------*/
00066 class AP4_Mpeg2TsWriter
00067 {
00068 public:
00069     // classes
00070     class Stream {
00071     public:
00072         Stream(AP4_UI16 pid) : m_PID(pid), m_ContinuityCounter(0) {}
00073         virtual ~Stream() {}
00074
00075         AP4_UI16 GetPID() { return m_PID; }
00076         void WritePacketHeader(bool            payload_start,
00077                                unsigned int&   payload_size,
00078                                bool            with_pcr,
00079                                AP4_UI64        pcr,
00080                                AP4_ByteStream& output);
00081
00082     private:
00083         unsigned int m_PID;
00084         unsigned int m_ContinuityCounter;
00085     };
00086
00087     class SampleStream : public Stream {
00088     public:
00089         SampleStream(AP4_UI16 pid, AP4_UI16 stream_id, AP4_UI08 stream_type, AP4_UI32 timescale) :
00090             Stream(pid),
00091             m_StreamId(stream_id),
00092             m_StreamType(stream_type),
00093             m_TimeScale(timescale) {}
00094
00095         virtual AP4_Result WritePES(const unsigned char* data,
00096                                     unsigned int         data_size,
00097                                     AP4_UI64             dts,
00098                                     bool                 with_dts,
00099                                     AP4_UI64             pts,
00100                                     bool                 with_pcr,
00101                                     AP4_ByteStream&      output);
00102         virtual AP4_Result WriteSample(AP4_Sample&            sample,
00103                                        AP4_SampleDescription* sample_description,
00104                                        bool                   with_pcr,
00105                                        AP4_ByteStream&        output) = 0;
00106
00107         unsigned int m_StreamId;
00108         AP4_UI08     m_StreamType;
00109         AP4_UI32     m_TimeScale;
00110     };
00111
00112     // constructor
00113     AP4_Mpeg2TsWriter();
00114     ~AP4_Mpeg2TsWriter();
00115
00116     Stream* GetPAT() { return m_PAT; }
00117     Stream* GetPMT() { return m_PMT; }
00118     AP4_Result WritePAT(AP4_ByteStream& output);
00119     AP4_Result WritePMT(AP4_ByteStream& output);
00120     AP4_Result SetAudioStream(AP4_UI32 timescale, SampleStream*& stream);
00121     AP4_Result SetVideoStream(AP4_UI32 timescale, SampleStream*& stream);
00122
00123 private:
00124     Stream*       m_PAT;
00125     Stream*       m_PMT;
00126     SampleStream* m_Audio;
00127     SampleStream* m_Video;
00128 };
00129
00130 #endif // _AP4_MPEG2_TS_H_
Generated on Thu May 13 16:36:33 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4MvhdAtom.h File Reference

  • File List
  • File Members

Ap4MvhdAtom.h File Reference

#include "Ap4List.h"
#include "Ap4Atom.h"

Go to the source code of this file.

Classes

class AP4_MvhdAtom
Generated on Thu May 13 16:36:39 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4MvhdAtom.h Source File

  • File List
  • File Members

Ap4MvhdAtom.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - mvhd Atoms
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027  ****************************************************************/
00028
00029 #ifndef _AP4_MVHD_ATOM_H_
00030 #define _AP4_MVHD_ATOM_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4List.h"
00036 #include "Ap4Atom.h"
00037
00038 /*----------------------------------------------------------------------
00039 |   AP4_MvhdAtom
00040 +---------------------------------------------------------------------*/
00041 class AP4_MvhdAtom : public AP4_Atom
00042 {
00043 public:
00044     AP4_IMPLEMENT_DYNAMIC_CAST_D(AP4_MvhdAtom, AP4_Atom)
00045
00046     // class methods
00047     static AP4_MvhdAtom* Create(AP4_Size size, AP4_ByteStream& stream);
00048
00049     // methods
00050     AP4_MvhdAtom(AP4_UI32 creation_time,
00051                  AP4_UI32 modification_time,
00052                  AP4_UI32 time_scale,
00053                  AP4_UI32 duration,
00054                  AP4_UI32 rate,
00055                  AP4_UI16 volume);
00056     virtual AP4_Result InspectFields(AP4_AtomInspector& inspector);
00057     virtual AP4_Result WriteFields(AP4_ByteStream& stream);
00058     AP4_UI64           GetDuration() { return m_Duration; }
00059     void               SetDuration(AP4_UI64 duration) { m_Duration = duration;}
00060     AP4_UI32           GetDurationMs();
00061     AP4_UI32           GetTimeScale() { return m_TimeScale; }
00062     AP4_Result         SetTimeScale(AP4_UI32 time_scale) {
00063         m_TimeScale = time_scale;
00064         return AP4_SUCCESS;
00065     }
00066
00067 private:
00068     // methods
00069     AP4_MvhdAtom(AP4_UI32        size,
00070                  AP4_UI32        version,
00071                  AP4_UI32        flags,
00072                  AP4_ByteStream& stream);
00073
00074     // members
00075     AP4_UI64 m_CreationTime;
00076     AP4_UI64 m_ModificationTime;
00077     AP4_UI32 m_TimeScale;
00078     AP4_UI64 m_Duration;
00079     AP4_UI32 m_Rate;
00080     AP4_UI16 m_Volume;
00081     AP4_UI08 m_Reserved1[2];
00082     AP4_UI08 m_Reserved2[8];
00083     AP4_UI32 m_Matrix[9];
00084     AP4_UI08 m_Predefined[24];
00085     AP4_UI32 m_NextTrackId;
00086 };
00087
00088 #endif // _AP4_MVHD_ATOM_H_
Generated on Thu May 13 16:36:33 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4NmhdAtom.h File Reference

  • File List
  • File Members

Ap4NmhdAtom.h File Reference

#include "Ap4Atom.h"

Go to the source code of this file.

Classes

class AP4_NmhdAtom
Generated on Thu May 13 16:36:39 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4NmhdAtom.h Source File

  • File List
  • File Members

Ap4NmhdAtom.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - nmhd Atoms
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027 ****************************************************************/
00028
00029 #ifndef _AP4_NMHD_ATOM_H_
00030 #define _AP4_NMHD_ATOM_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Atom.h"
00036
00037 /*----------------------------------------------------------------------
00038 |   AP4_NmhdAtom
00039 +---------------------------------------------------------------------*/
00040 class AP4_NmhdAtom : public AP4_Atom
00041 {
00042 public:
00043     // class methods
00044     static AP4_NmhdAtom* Create(AP4_Size size, AP4_ByteStream& stream);
00045
00046     // methods
00047     AP4_NmhdAtom();
00048     virtual AP4_Result WriteFields(AP4_ByteStream& stream);
00049
00050 private:
00051     // methods
00052     AP4_NmhdAtom(AP4_UI32        size,
00053                  AP4_UI32        version,
00054                  AP4_UI32        flags,
00055                  AP4_ByteStream& stream);
00056 };
00057
00058 #endif // _AP4_NMHD_ATOM_H_
Generated on Thu May 13 16:36:33 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4ObjectDescriptor.h File Reference

  • File List
  • File Members

Ap4ObjectDescriptor.h File Reference

#include "Ap4List.h"
#include "Ap4String.h"
#include "Ap4Descriptor.h"
#include "Ap4Command.h"

Go to the source code of this file.

Classes

class | AP4_ObjectDescriptor
class | AP4_InitialObjectDescriptor
class | AP4_DescriptorUpdateCommand
This class is used for ObjectDescriptorUpdateCommand and IPMP_DescriptorUpdateCommand. More...

Variables

const AP4_UI08 | AP4_DESCRIPTOR_TAG_OD = 0x01
const AP4_UI08 | AP4_DESCRIPTOR_TAG_IOD = 0x02
const AP4_UI08 | AP4_DESCRIPTOR_TAG_MP4_OD = 0x11
const AP4_UI08 | AP4_DESCRIPTOR_TAG_MP4_IOD = 0x10

Variable Documentation

const AP4_UI08 AP4_DESCRIPTOR_TAG_IOD = 0x02

Definition at line 49 of file Ap4ObjectDescriptor.h.

const AP4_UI08 AP4_DESCRIPTOR_TAG_MP4_IOD = 0x10

Definition at line 51 of file Ap4ObjectDescriptor.h.

const AP4_UI08 AP4_DESCRIPTOR_TAG_MP4_OD = 0x11

Definition at line 50 of file Ap4ObjectDescriptor.h.

const AP4_UI08 AP4_DESCRIPTOR_TAG_OD = 0x01

Definition at line 48 of file Ap4ObjectDescriptor.h.

Generated on Thu May 13 16:36:39 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4ObjectDescriptor.h Source File

  • File List
  • File Members

Ap4ObjectDescriptor.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - Object Descriptor
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027  ****************************************************************/
00028
00029 #ifndef _AP4_OBJECT_DESCRIPTOR_H_
00030 #define _AP4_OBJECT_DESCRIPTOR_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4List.h"
00036 #include "Ap4String.h"
00037 #include "Ap4Descriptor.h"
00038 #include "Ap4Command.h"
00039
00040 /*----------------------------------------------------------------------
00041 |   class references
00042 +---------------------------------------------------------------------*/
00043 class AP4_ByteStream;
00044
00045 /*----------------------------------------------------------------------
00046 |   constants
00047 +---------------------------------------------------------------------*/
00048 const AP4_UI08 AP4_DESCRIPTOR_TAG_OD      = 0x01;
00049 const AP4_UI08 AP4_DESCRIPTOR_TAG_IOD     = 0x02;
00050 const AP4_UI08 AP4_DESCRIPTOR_TAG_MP4_OD  = 0x11;
00051 const AP4_UI08 AP4_DESCRIPTOR_TAG_MP4_IOD = 0x10;
00052
00053 /*----------------------------------------------------------------------
00054 |   AP4_ObjectDescriptor
00055 +---------------------------------------------------------------------*/
00056 class AP4_ObjectDescriptor : public AP4_Descriptor
00057 {
00058  public:
00059     AP4_IMPLEMENT_DYNAMIC_CAST_D(AP4_ObjectDescriptor, AP4_Descriptor)
00060
00061     // methods
00062     AP4_ObjectDescriptor(AP4_ByteStream& stream,
00063                          AP4_UI08        tag,
00064                          AP4_Size        header_size,
00065                          AP4_Size        payload_size);
00066     AP4_ObjectDescriptor(AP4_UI08 tag, AP4_UI16 id);
00067     virtual ~AP4_ObjectDescriptor();
00068
00073     virtual AP4_Result AddSubDescriptor(AP4_Descriptor* descriptor);
00074
00075     virtual AP4_Descriptor* FindSubDescriptor(AP4_UI08 tag) const;
00076     virtual AP4_Result WriteFields(AP4_ByteStream& stream);
00077     virtual AP4_Result Inspect(AP4_AtomInspector& inspector);
00078
00079     // accessors
00080     AP4_UI16 GetObjectDescriptorId() const { return m_ObjectDescriptorId; }
00081     bool     GetUrlFlag()            const { return m_UrlFlag; }
00082     const AP4_String& GetUrl()       const { return m_Url;}
00083
00084  protected:
00085     // constructor
00086     AP4_ObjectDescriptor(AP4_UI08 tag, AP4_Size header_size, AP4_Size payload_size);
00087
00088     // members
00089     AP4_UI16                         m_ObjectDescriptorId;
00090     bool                             m_UrlFlag;
00091     AP4_String                       m_Url;
00092     mutable AP4_List<AP4_Descriptor> m_SubDescriptors;
00093 };
00094
00095 /*----------------------------------------------------------------------
00096 |   AP4_InitialObjectDescriptor
00097 +---------------------------------------------------------------------*/
00098 class AP4_InitialObjectDescriptor : public AP4_ObjectDescriptor
00099 {
00100  public:
00101     // methods
00102     AP4_InitialObjectDescriptor(AP4_ByteStream& stream,
00103                                 AP4_UI08        tag,
00104                                 AP4_Size        header_size,
00105                                 AP4_Size        payload_size);
00106     AP4_InitialObjectDescriptor(AP4_UI08    tag, // should be AP4_DESCRIPTOR_TAG_IOD or AP4_DESCRIPTOR_TAG_MP4_IOD
00107                                 AP4_UI16    object_descriptor_id,
00108                                 bool        include_inline_profile_level,
00109                                 AP4_UI08    od_profile_level_indication,
00110                                 AP4_UI08    scene_profile_level_indication,
00111                                 AP4_UI08    audio_profile_level_indication,
00112                                 AP4_UI08    visual_profile_level_indication,
00113                                 AP4_UI08    graphics_profile_level_indication);
00114
00115     virtual AP4_Result WriteFields(AP4_ByteStream& stream);
00116     virtual AP4_Result Inspect(AP4_AtomInspector& inspector);
00117
00118     // accessors
00119     bool     GetIncludeProfileLevelFlag()        const { return m_IncludeInlineProfileLevelFlag; }
00120     AP4_UI08 GetOdProfileLevelIndication()       const { return m_OdProfileLevelIndication; }
00121     AP4_UI08 GetSceneProfileLevelIndication()    const { return m_SceneProfileLevelIndication; }
00122     AP4_UI08 GetAudioProfileLevelIndication()    const { return m_AudioProfileLevelIndication; }
00123     AP4_UI08 GetVisualProfileLevelIndication()   const { return m_VisualProfileLevelIndication; }
00124     AP4_UI08 GetGraphicsProfileLevelIndication() const { return m_GraphicsProfileLevelIndication; }
00125
00126  private:
00127     // members
00128     bool     m_IncludeInlineProfileLevelFlag;
00129     AP4_UI08 m_OdProfileLevelIndication;
00130     AP4_UI08 m_SceneProfileLevelIndication;
00131     AP4_UI08 m_AudioProfileLevelIndication;
00132     AP4_UI08 m_VisualProfileLevelIndication;
00133     AP4_UI08 m_GraphicsProfileLevelIndication;
00134 };
00135
00136 /*----------------------------------------------------------------------
00137 |   AP4_DescriptorUpdateCommand
00138 +---------------------------------------------------------------------*/
00143 class AP4_DescriptorUpdateCommand : public AP4_Command
00144 {
00145  public:
00146     AP4_IMPLEMENT_DYNAMIC_CAST_D(AP4_DescriptorUpdateCommand, AP4_Command)
00147
00148     // methods
00149     AP4_DescriptorUpdateCommand(AP4_UI08 tag);
00150     AP4_DescriptorUpdateCommand(AP4_ByteStream& stream,
00151                                 AP4_UI08        tag,
00152                                 AP4_Size        header_size,
00153                                 AP4_Size        payload_size);
00154     virtual ~AP4_DescriptorUpdateCommand();
00155     virtual AP4_Result AddDescriptor(AP4_Descriptor* descriptor);
00156     virtual AP4_Result WriteFields(AP4_ByteStream& stream);
00157     virtual AP4_Result Inspect(AP4_AtomInspector& inspector);
00158
00159     // accessors
00160     const AP4_List<AP4_Descriptor>& GetDescriptors() { return m_Descriptors; }
00161
00162  protected:
00163     // members
00164     mutable AP4_List<AP4_Descriptor> m_Descriptors;
00165 };
00166
00167 #endif // _AP4_OBJECT_DESCRIPTOR_H_
Generated on Thu May 13 16:36:33 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4OdafAtom.h File Reference

  • File List
  • File Members

Ap4OdafAtom.h File Reference

#include "Ap4Types.h"
#include "Ap4Atom.h"

Go to the source code of this file.

Classes

class AP4_OdafAtom
Generated on Thu May 13 16:36:39 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4OdafAtom.h Source File

  • File List
  • File Members

Ap4OdafAtom.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - odaf Atom
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027 ****************************************************************/
00028
00029 #ifndef _AP4_ODAF_ATOM_H_
00030 #define _AP4_ODAF_ATOM_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Types.h"
00036 #include "Ap4Atom.h"
00037
00038 /*----------------------------------------------------------------------
00039 |   AP4_OdafAtom
00040 +---------------------------------------------------------------------*/
00041 class AP4_OdafAtom : public AP4_Atom
00042 {
00043 public:
00044     AP4_IMPLEMENT_DYNAMIC_CAST_D(AP4_OdafAtom, AP4_Atom)
00045
00046     // class methods
00047     static AP4_OdafAtom* Create(AP4_Size size, AP4_ByteStream& stream);
00048
00049     // methods
00050     AP4_OdafAtom(bool     m_SelectiveEncryption,
00051                  AP4_UI08 m_KeyIndicatorLength,
00052                  AP4_UI08 m_IvLength);
00053     virtual AP4_Result InspectFields(AP4_AtomInspector& inspector);
00054     virtual AP4_Result WriteFields(AP4_ByteStream& stream);
00055
00056     // accessors
00057     bool GetSelectiveEncryption()    { return m_SelectiveEncryption; }
00058     AP4_UI08 GetKeyIndicatorLength() { return m_KeyIndicatorLength;  }
00059     AP4_UI08 GetIvLength()           { return m_IvLength;            }
00060
00061 private:
00062     // methods
00063     AP4_OdafAtom(AP4_UI32        size,
00064                  AP4_UI32        version,
00065                  AP4_UI32        flags,
00066                  AP4_ByteStream& stream);
00067
00068     // members
00069     bool     m_SelectiveEncryption;
00070     AP4_UI08 m_KeyIndicatorLength;
00071     AP4_UI08 m_IvLength;
00072 };
00073
00074 #endif // _AP4_ODAF_ATOM_H_
Generated on Thu May 13 16:36:33 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4OddaAtom.h File Reference

  • File List
  • File Members

Ap4OddaAtom.h File Reference

#include "Ap4Types.h"
#include "Ap4Atom.h"
#include "Ap4String.h"

Go to the source code of this file.

Classes

class AP4_OddaAtom
Generated on Thu May 13 16:36:39 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4OddaAtom.h Source File

  • File List
  • File Members

Ap4OddaAtom.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - odda Atom
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027 ****************************************************************/
00028
00029 #ifndef _AP4_ODDA_ATOM_H_
00030 #define _AP4_ODDA_ATOM_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Types.h"
00036 #include "Ap4Atom.h"
00037 #include "Ap4String.h"
00038
00039 /*----------------------------------------------------------------------
00040 |   AP4_OddaAtom
00041 +---------------------------------------------------------------------*/
00042 class AP4_OddaAtom : public AP4_Atom
00043 {
00044 public:
00045     AP4_IMPLEMENT_DYNAMIC_CAST_D(AP4_OddaAtom, AP4_Atom)
00046
00047     // class methods
00048     static AP4_OddaAtom* Create(AP4_UI64        size,
00049                                 AP4_ByteStream& stream);
00050
00051     // constructor
00052     AP4_OddaAtom(AP4_ByteStream& encrypted_payload);
00053
00054     // destructor
00055     ~AP4_OddaAtom();
00056
00057     // methods
00058     virtual AP4_Result InspectFields(AP4_AtomInspector& inspector);
00059     virtual AP4_Result WriteFields(AP4_ByteStream& stream);
00060
00061     // accessors
00062     AP4_UI64 GetEncryptedDataLength() { return m_EncryptedDataLength; }
00063
00067     AP4_Result SetEncryptedPayload(AP4_ByteStream& stream);
00068     AP4_Result SetEncryptedPayload(AP4_ByteStream& stream, AP4_LargeSize length);
00069
00073     AP4_ByteStream& GetEncryptedPayload() { return *m_EncryptedPayload; }
00074
00075 private:
00076     // methods
00077     AP4_OddaAtom(AP4_UI64         size,
00078                  AP4_UI32         version,
00079                  AP4_UI32         flags,
00080                  AP4_ByteStream&  stream);
00081
00082     // members
00083     AP4_UI64        m_EncryptedDataLength;
00084     AP4_ByteStream* m_EncryptedPayload;
00085 };
00086
00087 #endif // _AP4_ODDA_ATOM_H_
Generated on Thu May 13 16:36:33 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4OdheAtom.h File Reference

  • File List
  • File Members

Ap4OdheAtom.h File Reference

#include "Ap4Types.h"
#include "Ap4Atom.h"
#include "Ap4ContainerAtom.h"
#include "Ap4String.h"

Go to the source code of this file.

Classes

class AP4_OdheAtom
Generated on Thu May 13 16:36:39 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4OdheAtom.h Source File

  • File List
  • File Members

Ap4OdheAtom.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - odhe Atom
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027 ****************************************************************/
00028
00029 #ifndef _AP4_ODHE_ATOM_H_
00030 #define _AP4_ODHE_ATOM_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Types.h"
00036 #include "Ap4Atom.h"
00037 #include "Ap4ContainerAtom.h"
00038 #include "Ap4String.h"
00039
00040 /*----------------------------------------------------------------------
00041 |   class references
00042 +---------------------------------------------------------------------*/
00043 class AP4_OhdrAtom;
00044
00045 /*----------------------------------------------------------------------
00046 |   AP4_OdheAtom
00047 +---------------------------------------------------------------------*/
00048 class AP4_OdheAtom : public AP4_ContainerAtom
00049 {
00050 public:
00051     AP4_IMPLEMENT_DYNAMIC_CAST_D(AP4_OdheAtom, AP4_ContainerAtom)
00052
00053     // class methods
00054     static AP4_OdheAtom* Create(AP4_Size         size,
00055                                 AP4_ByteStream&  stream,
00056                                 AP4_AtomFactory& atom_factory);
00057
00058     // constructor
00062     AP4_OdheAtom(const char* content_type, AP4_OhdrAtom* ohdr);
00063
00064     // AP4_Atom methods
00065     virtual AP4_Result InspectFields(AP4_AtomInspector& inspector);
00066     virtual AP4_Result WriteFields(AP4_ByteStream& stream);
00067
00068     // AP4_AtomParent methods
00069     virtual void OnChildChanged(AP4_Atom* child);
00070
00071     // methods
00072     const AP4_String& GetContentType() { return m_ContentType; }
00073
00074 private:
00075     // methods
00076     AP4_OdheAtom(AP4_UI32         size,
00077                  AP4_UI32         version,
00078                  AP4_UI32         flags,
00079                  AP4_ByteStream&  stream,
00080                  AP4_AtomFactory& atom_factory);
00081
00082     // members
00083     AP4_String m_ContentType;
00084
00085 };
00086
00087 #endif // _AP4_ODHE_ATOM_H_
Generated on Thu May 13 16:36:33 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4OhdrAtom.h File Reference

  • File List
  • File Members

Ap4OhdrAtom.h File Reference

#include "Ap4Types.h"
#include "Ap4Atom.h"
#include "Ap4ContainerAtom.h"
#include "Ap4String.h"
#include "Ap4OmaDcf.h"

Go to the source code of this file.

Classes

class | AP4_OhdrAtom

Variables

const AP4_UI08 | AP4_OMA_DCF_ENCRYPTION_METHOD_NULL = 0
const AP4_UI08 | AP4_OMA_DCF_ENCRYPTION_METHOD_AES_CBC = 1
const AP4_UI08 | AP4_OMA_DCF_ENCRYPTION_METHOD_AES_CTR = 2
const AP4_UI08 | AP4_OMA_DCF_PADDING_SCHEME_NONE = 0
const AP4_UI08 | AP4_OMA_DCF_PADDING_SCHEME_RFC_2630 = 1

Variable Documentation

const AP4_UI08 AP4_OMA_DCF_ENCRYPTION_METHOD_AES_CBC = 1

Definition at line 45 of file Ap4OhdrAtom.h.

const AP4_UI08 AP4_OMA_DCF_ENCRYPTION_METHOD_AES_CTR = 2

Definition at line 46 of file Ap4OhdrAtom.h.

const AP4_UI08 AP4_OMA_DCF_ENCRYPTION_METHOD_NULL = 0

Definition at line 44 of file Ap4OhdrAtom.h.

const AP4_UI08 AP4_OMA_DCF_PADDING_SCHEME_NONE = 0

Definition at line 48 of file Ap4OhdrAtom.h.

const AP4_UI08 AP4_OMA_DCF_PADDING_SCHEME_RFC_2630 = 1

Definition at line 49 of file Ap4OhdrAtom.h.

Generated on Thu May 13 16:36:39 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4OhdrAtom.h Source File

  • File List
  • File Members

Ap4OhdrAtom.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - ohdr Atom
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027 ****************************************************************/
00028
00029 #ifndef _AP4_OHDR_ATOM_H_
00030 #define _AP4_OHDR_ATOM_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Types.h"
00036 #include "Ap4Atom.h"
00037 #include "Ap4ContainerAtom.h"
00038 #include "Ap4String.h"
00039 #include "Ap4OmaDcf.h"
00040
00041 /*----------------------------------------------------------------------
00042 |   constants
00043 +---------------------------------------------------------------------*/
00044 const AP4_UI08 AP4_OMA_DCF_ENCRYPTION_METHOD_NULL    = 0;
00045 const AP4_UI08 AP4_OMA_DCF_ENCRYPTION_METHOD_AES_CBC = 1;
00046 const AP4_UI08 AP4_OMA_DCF_ENCRYPTION_METHOD_AES_CTR = 2;
00047
00048 const AP4_UI08 AP4_OMA_DCF_PADDING_SCHEME_NONE     = 0;
00049 const AP4_UI08 AP4_OMA_DCF_PADDING_SCHEME_RFC_2630 = 1;
00050
00051 /*----------------------------------------------------------------------
00052 |   AP4_OhdrAtom
00053 +---------------------------------------------------------------------*/
00054 class AP4_OhdrAtom : public AP4_ContainerAtom, public AP4_OmaDrmInfo
00055 {
00056 public:
00057     AP4_IMPLEMENT_DYNAMIC_CAST_D2(AP4_OhdrAtom, AP4_ContainerAtom, AP4_OmaDrmInfo)
00058
00059     // class methods
00060     static AP4_OhdrAtom* Create(AP4_Size         size,
00061                                 AP4_ByteStream&  stream,
00062                                 AP4_AtomFactory& atom_factory);
00063
00064     // constructor
00065     AP4_OhdrAtom(AP4_UI08        encryption_method,
00066                  AP4_UI08        padding_scheme,
00067                  AP4_UI64        plaintext_length,
00068                  const char*     content_id,
00069                  const char*     rights_issuer_url,
00070                  const AP4_Byte* textual_headers,
00071                  AP4_Size        textual_headers_size);
00072
00073     // methods
00074     virtual AP4_Result InspectFields(AP4_AtomInspector& inspector);
00075     virtual AP4_Result WriteFields(AP4_ByteStream& stream);
00076     virtual AP4_Atom*  Clone();
00077
00078     // accessors
00079     AP4_UI08          GetEncryptionMethod()   const { return m_EncryptionMethod; }
00080     void              SetEncryptionMethod(AP4_UI08 encryption_method) { m_EncryptionMethod = encryption_method; }
00081     AP4_UI08          GetPaddingScheme()      const { return m_PaddingScheme;    }
00082     void              SetPaddingScheme(AP4_UI08 padding_scheme) { m_PaddingScheme = padding_scheme; }
00083     AP4_UI64          GetPlaintextLength()    const { return m_PlaintextLength;  }
00084
00085     // AP4_OmaDrmInfo implementation
00086     const AP4_String& GetContentId()          const { return m_ContentId;        }
00087     const AP4_String& GetRightsIssuerUrl()    const { return m_RightsIssuerUrl;  }
00088     const AP4_DataBuffer& GetTextualHeaders() const { return m_TextualHeaders;   }
00089
00090 private:
00091     // methods
00092     AP4_OhdrAtom(AP4_UI32         size,
00093                  AP4_UI32         version,
00094                  AP4_UI32         flags,
00095                  AP4_ByteStream&  stream,
00096                  AP4_AtomFactory& atom_factory);
00097
00098     // members
00099     AP4_UI08       m_EncryptionMethod;
00100     AP4_UI08       m_PaddingScheme;
00101     AP4_UI64       m_PlaintextLength;
00102     AP4_String     m_ContentId;
00103     AP4_String     m_RightsIssuerUrl;
00104     AP4_DataBuffer m_TextualHeaders;
00105 };
00106
00107 #endif // _AP4_OHDR_ATOM_H_
Generated on Thu May 13 16:36:33 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4OmaDcf.h File Reference

  • File List
  • File Members

Ap4OmaDcf.h File Reference

#include "Ap4Types.h"
#include "Ap4SampleEntry.h"
#include "Ap4Atom.h"
#include "Ap4AtomFactory.h"
#include "Ap4SampleDescription.h"
#include "Ap4Processor.h"
#include "Ap4Protection.h"
#include "Ap4DynamicCast.h"

Go to the source code of this file.

Classes

class | AP4_OmaDcfAtomDecrypter
class | AP4_OmaDcfSampleDecrypter
class | AP4_OmaDcfCtrSampleDecrypter
class | AP4_OmaDcfCbcSampleDecrypter
class | AP4_OmaDcfTrackDecrypter
class | AP4_OmaDcfSampleEncrypter
class | AP4_OmaDcfCtrSampleEncrypter
class | AP4_OmaDcfCbcSampleEncrypter
class | AP4_OmaDcfDecryptingProcessor
Use for DCF only, not PDCF. More...
class | AP4_OmaDcfEncryptingProcessor
class | AP4_OmaDrmInfo

Enumerations

enum AP4_OmaDcfCipherMode {
AP4_OMA_DCF_CIPHER_MODE_CTR,
AP4_OMA_DCF_CIPHER_MODE_CBC
}

Variables

const AP4_UI32 | AP4_PROTECTION_SCHEME_TYPE_OMA = AP4_ATOM_TYPE('o','d','k','m')
const AP4_UI32 | AP4_PROTECTION_SCHEME_VERSION_OMA_20 = 0x00000200
const AP4_UI32 | AP4_OMA_DCF_BRAND_ODCF = AP4_ATOM_TYPE('o','d','c','f')
const AP4_UI32 | AP4_OMA_DCF_BRAND_OPF2 = AP4_ATOM_TYPE('o','p','f','2')

Enumeration Type Documentation

enum AP4_OmaDcfCipherMode
Enumerator:
AP4_OMA_DCF_CIPHER_MODE_CTR
AP4_OMA_DCF_CIPHER_MODE_CBC

Definition at line 60 of file Ap4OmaDcf.h.

Variable Documentation

const AP4_UI32 AP4_OMA_DCF_BRAND_ODCF = AP4_ATOM_TYPE('o','d','c','f')

Definition at line 57 of file Ap4OmaDcf.h.

const AP4_UI32 AP4_OMA_DCF_BRAND_OPF2 = AP4_ATOM_TYPE('o','p','f','2')

Definition at line 58 of file Ap4OmaDcf.h.

const AP4_UI32 AP4_PROTECTION_SCHEME_TYPE_OMA = AP4_ATOM_TYPE('o','d','k','m')

Definition at line 55 of file Ap4OmaDcf.h.

const AP4_UI32 AP4_PROTECTION_SCHEME_VERSION_OMA_20 = 0x00000200

Definition at line 56 of file Ap4OmaDcf.h.

Generated on Thu May 13 16:36:39 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4OmaDcf.h Source File

  • File List
  • File Members

Ap4OmaDcf.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - OMA DCF support
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027 ****************************************************************/
00028
00029 #ifndef _AP4_OMA_DCF_H_
00030 #define _AP4_OMA_DCF_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Types.h"
00036 #include "Ap4SampleEntry.h"
00037 #include "Ap4Atom.h"
00038 #include "Ap4AtomFactory.h"
00039 #include "Ap4SampleDescription.h"
00040 #include "Ap4Processor.h"
00041 #include "Ap4Protection.h"
00042 #include "Ap4DynamicCast.h"
00043
00044 /*----------------------------------------------------------------------
00045 |   class references
00046 +---------------------------------------------------------------------*/
00047 class AP4_OdafAtom;
00048 class AP4_StreamCipher;
00049 class AP4_CbcStreamCipher;
00050 class AP4_CtrStreamCipher;
00051
00052 /*----------------------------------------------------------------------
00053 |   constants
00054 +---------------------------------------------------------------------*/
00055 const AP4_UI32 AP4_PROTECTION_SCHEME_TYPE_OMA = AP4_ATOM_TYPE('o','d','k','m');
00056 const AP4_UI32 AP4_PROTECTION_SCHEME_VERSION_OMA_20 = 0x00000200;
00057 const AP4_UI32 AP4_OMA_DCF_BRAND_ODCF = AP4_ATOM_TYPE('o','d','c','f');
00058 const AP4_UI32 AP4_OMA_DCF_BRAND_OPF2 = AP4_ATOM_TYPE('o','p','f','2');
00059
00060 typedef enum {
00061     AP4_OMA_DCF_CIPHER_MODE_CTR,
00062     AP4_OMA_DCF_CIPHER_MODE_CBC
00063 } AP4_OmaDcfCipherMode;
00064
00065 /*----------------------------------------------------------------------
00066 |   AP4_OmaDcfAtomDecrypter
00067 +---------------------------------------------------------------------*/
00068 class AP4_OmaDcfAtomDecrypter {
00069 public:
00070     // class methods
00071     static AP4_Result DecryptAtoms(AP4_AtomParent&                  atoms,
00072                                    AP4_Processor::ProgressListener* listener,
00073                                    AP4_BlockCipherFactory*          block_cipher_factory,
00074                                    AP4_ProtectionKeyMap&            key_map);
00075
00076     // Returns a byte stream that will produce the decrypted data found
00077     // in the 'odda' child atom of an 'odrm' atom
00078     static AP4_Result CreateDecryptingStream(AP4_ContainerAtom&      odrm_atom,
00079                                              const AP4_UI08*         key,
00080                                              AP4_Size                key_size,
00081                                              AP4_BlockCipherFactory* block_cipher_factory,
00082                                              AP4_ByteStream*&        stream);
00083
00084     // Returns a byte stream that will produce the decrypted data from
00085     // an encrypted stream where the IV follows the encrypted bytes.
00086     // This method is normally not called directly: most callers will call
00087     // the stream factory that takes an 'odrm' atom as an input parameter
00088     static AP4_Result CreateDecryptingStream(AP4_OmaDcfCipherMode    mode,
00089                                              AP4_ByteStream&         encrypted_stream,
00090                                              AP4_LargeSize           cleartext_size,
00091                                              const AP4_UI08*         key,
00092                                              AP4_Size                key_size,
00093                                              AP4_BlockCipherFactory* block_cipher_factory,
00094                                              AP4_ByteStream*&        stream);
00095 };
00096
00097 /*----------------------------------------------------------------------
00098 |   AP4_OmaDcfSampleDecrypter
00099 +---------------------------------------------------------------------*/
00100 class AP4_OmaDcfSampleDecrypter : public AP4_SampleDecrypter
00101 {
00102 public:
00103     // factory
00104     static AP4_Result Create(AP4_ProtectedSampleDescription* sample_description,
00105                              const AP4_UI08*                 key,
00106                              AP4_Size                        key_size,
00107                              AP4_BlockCipherFactory*         block_cipher_factory,
00108                              AP4_OmaDcfSampleDecrypter*&     cipher);
00109
00110     // constructor and destructor
00111     AP4_OmaDcfSampleDecrypter(AP4_Size iv_length,
00112                               bool     selective_encryption) :
00113         m_IvLength(iv_length),
00114         m_SelectiveEncryption(selective_encryption) {}
00115
00116 protected:
00117     AP4_Size m_IvLength;
00118     AP4_Size m_KeyIndicatorLength;
00119     bool     m_SelectiveEncryption;
00120 };
00121
00122 /*----------------------------------------------------------------------
00123 |   AP4_OmaDcfCtrSampleDecrypter
00124 +---------------------------------------------------------------------*/
00125 class AP4_OmaDcfCtrSampleDecrypter : public AP4_OmaDcfSampleDecrypter
00126 {
00127 public:
00128     // constructor and destructor
00129     AP4_OmaDcfCtrSampleDecrypter(AP4_BlockCipher* block_cipher,
00130                                  AP4_Size         iv_length,
00131                                  bool             selective_encryption);
00132     ~AP4_OmaDcfCtrSampleDecrypter();
00133
00134     // methods
00135     virtual AP4_Result DecryptSampleData(AP4_DataBuffer& data_in,
00136                                          AP4_DataBuffer& data_out,
00137                                          const AP4_UI08* iv = NULL);
00138     virtual AP4_Size   GetDecryptedSampleSize(AP4_Sample& sample);
00139
00140 private:
00141     // members
00142     AP4_CtrStreamCipher* m_Cipher;
00143 };
00144
00145 /*----------------------------------------------------------------------
00146 |   AP4_OmaDcfCbcSampleDecrypter
00147 +---------------------------------------------------------------------*/
00148 class AP4_OmaDcfCbcSampleDecrypter : public AP4_OmaDcfSampleDecrypter
00149 {
00150 public:
00151     // constructor and destructor
00152     AP4_OmaDcfCbcSampleDecrypter(AP4_BlockCipher* block_cipher,
00153                                  bool             selective_encryption);
00154     ~AP4_OmaDcfCbcSampleDecrypter();
00155
00156     // methods
00157     virtual AP4_Result DecryptSampleData(AP4_DataBuffer& data_in,
00158                                          AP4_DataBuffer& data_out,
00159                                          const AP4_UI08* iv = NULL);
00160     virtual AP4_Size   GetDecryptedSampleSize(AP4_Sample& sample);
00161
00162 private:
00163     // members
00164     AP4_CbcStreamCipher* m_Cipher;
00165 };
00166
00167 /*----------------------------------------------------------------------
00168 |   AP4_OmaDcfTrackDecrypter
00169 +---------------------------------------------------------------------*/
00170 class AP4_OmaDcfTrackDecrypter : public AP4_Processor::TrackHandler {
00171 public:
00172     // constructor
00173     static AP4_Result Create(const AP4_UI08*                 key,
00174                              AP4_Size                        key_size,
00175                              AP4_ProtectedSampleDescription* sample_description,
00176                              AP4_SampleEntry*                sample_entry,
00177                              AP4_BlockCipherFactory*         block_cipher_factory,
00178                              AP4_OmaDcfTrackDecrypter*&      decrypter);
00179     virtual ~AP4_OmaDcfTrackDecrypter();
00180
00181     // methods
00182     virtual AP4_Size   GetProcessedSampleSize(AP4_Sample& sample);
00183     virtual AP4_Result ProcessTrack();
00184     virtual AP4_Result ProcessSample(AP4_DataBuffer& data_in,
00185                                      AP4_DataBuffer& data_out);
00186
00187 private:
00188     // constructor
00189     AP4_OmaDcfTrackDecrypter(AP4_OmaDcfSampleDecrypter* cipher,
00190                              AP4_SampleEntry*           sample_entry,
00191                              AP4_UI32                   original_format);
00192
00193     // members
00194     AP4_OmaDcfSampleDecrypter* m_Cipher;
00195     AP4_SampleEntry*           m_SampleEntry;
00196     AP4_UI32                   m_OriginalFormat;
00197 };
00198
00199 /*----------------------------------------------------------------------
00200 |   AP4_OmaDcfSampleEncrypter
00201 +---------------------------------------------------------------------*/
00202 class AP4_OmaDcfSampleEncrypter
00203 {
00204 public:
00205     // constructor and destructor
00206     AP4_OmaDcfSampleEncrypter(const AP4_UI08* salt); // salt is only 8 bytes
00207     virtual ~AP4_OmaDcfSampleEncrypter() {}
00208
00209     // methods
00210     virtual AP4_Result EncryptSampleData(AP4_DataBuffer& data_in,
00211                                          AP4_DataBuffer& data_out,
00212                                          AP4_UI64        bso,
00213                                          bool            skip_encryption) = 0;
00214     virtual AP4_Size   GetEncryptedSampleSize(AP4_Sample& sample) = 0;
00215
00216 protected:
00217     // members
00218     AP4_UI08 m_Salt[16];
00219 };
00220
00221 /*----------------------------------------------------------------------
00222 |   AP4_OmaDcfCtrSampleEncrypter
00223 +---------------------------------------------------------------------*/
00224 class AP4_OmaDcfCtrSampleEncrypter : public AP4_OmaDcfSampleEncrypter
00225 {
00226 public:
00227     // constructor and destructor
00228     AP4_OmaDcfCtrSampleEncrypter(AP4_BlockCipher* block_cipher,
00229                                  const AP4_UI08*  salt); // salt is only 8 bytes
00230     ~AP4_OmaDcfCtrSampleEncrypter();
00231
00232     // methods
00233     virtual AP4_Result EncryptSampleData(AP4_DataBuffer& data_in,
00234                                          AP4_DataBuffer& data_out,
00235                                          AP4_UI64        bso,
00236                                          bool            skip_encryption);
00237     virtual AP4_Size   GetEncryptedSampleSize(AP4_Sample& sample);
00238
00239 private:
00240     // members
00241     AP4_CtrStreamCipher* m_Cipher;
00242 };
00243
00244 /*----------------------------------------------------------------------
00245 |   AP4_OmaDcfCbcSampleEncrypter
00246 +---------------------------------------------------------------------*/
00247 class AP4_OmaDcfCbcSampleEncrypter : public AP4_OmaDcfSampleEncrypter
00248 {
00249 public:
00250     // constructor and destructor
00251     AP4_OmaDcfCbcSampleEncrypter(AP4_BlockCipher* block_cipher,
00252                                  const AP4_UI08*  salt); // salt is only 8 bytes
00253     ~AP4_OmaDcfCbcSampleEncrypter();
00254
00255     // methods
00256     virtual AP4_Result EncryptSampleData(AP4_DataBuffer& data_in,
00257                                          AP4_DataBuffer& data_out,
00258                                          AP4_UI64        bso,
00259                                          bool            skip_encryption);
00260     virtual AP4_Size   GetEncryptedSampleSize(AP4_Sample& sample);
00261
00262 private:
00263     // members
00264     AP4_CbcStreamCipher* m_Cipher;
00265 };
00266
00267 /*----------------------------------------------------------------------
00268 |   AP4_OmaDcfDecryptingProcessor
00269 +---------------------------------------------------------------------*/
00274 class AP4_OmaDcfDecryptingProcessor : public AP4_Processor
00275 {
00276 public:
00277     // constructor
00278     AP4_OmaDcfDecryptingProcessor(const AP4_ProtectionKeyMap* key_map = NULL,
00279                                   AP4_BlockCipherFactory*     block_cipher_factory = NULL);
00280
00281     // accessors
00282     AP4_ProtectionKeyMap& GetKeyMap() { return m_KeyMap; }
00283
00284     // methods
00285     virtual AP4_Result Initialize(AP4_AtomParent&   top_level,
00286                                   AP4_ByteStream&   stream,
00287                                   ProgressListener* listener);
00288
00289 private:
00290     // members
00291     AP4_BlockCipherFactory* m_BlockCipherFactory;
00292     AP4_ProtectionKeyMap    m_KeyMap;
00293 };
00294
00295 /*----------------------------------------------------------------------
00296 |   AP4_OmaDcfEncryptingProcessor
00297 +---------------------------------------------------------------------*/
00298 class AP4_OmaDcfEncryptingProcessor : public AP4_Processor
00299 {
00300 public:
00301     // constructor
00302     AP4_OmaDcfEncryptingProcessor(AP4_OmaDcfCipherMode    cipher_mode,
00303                                   AP4_BlockCipherFactory* block_cipher_factory = NULL);
00304
00305     // accessors
00306     AP4_ProtectionKeyMap& GetKeyMap()      { return m_KeyMap;      }
00307     AP4_TrackPropertyMap& GetPropertyMap() { return m_PropertyMap; }
00308
00309     // AP4_Processor methods
00310     virtual AP4_Result Initialize(AP4_AtomParent&   top_level,
00311                                   AP4_ByteStream&   stream,
00312                                   AP4_Processor::ProgressListener* listener = NULL);
00313     virtual AP4_Processor::TrackHandler* CreateTrackHandler(AP4_TrakAtom* trak);
00314
00315 private:
00316     // members
00317     AP4_OmaDcfCipherMode    m_CipherMode;
00318     AP4_BlockCipherFactory* m_BlockCipherFactory;
00319     AP4_ProtectionKeyMap    m_KeyMap;
00320     AP4_TrackPropertyMap    m_PropertyMap;
00321 };
00322
00323 /*----------------------------------------------------------------------
00324 |   AP4_OmaDrmInfo
00325 +---------------------------------------------------------------------*/
00326 class AP4_OmaDrmInfo
00327 {
00328 public:
00329     AP4_IMPLEMENT_DYNAMIC_CAST(AP4_OmaDrmInfo)
00330     virtual ~AP4_OmaDrmInfo() {}
00331     virtual const AP4_String& GetContentId()          const = 0;
00332     virtual const AP4_String& GetRightsIssuerUrl()    const = 0;
00333     virtual const AP4_DataBuffer& GetTextualHeaders() const = 0;
00334 };
00335
00336
00337 #endif // _AP4_OMA_DCF_H_
Generated on Thu May 13 16:36:33 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4Piff.h File Reference

  • File List
  • File Members

Ap4Piff.h File Reference

#include "Ap4Types.h"
#include "Ap4SampleEntry.h"
#include "Ap4Atom.h"
#include "Ap4AtomFactory.h"
#include "Ap4SampleDescription.h"
#include "Ap4Processor.h"
#include "Ap4Protection.h"
#include "Ap4UuidAtom.h"

Go to the source code of this file.

Classes

class | AP4_PiffSampleEncrypter
class | AP4_PiffCtrSampleEncrypter
class | AP4_PiffAvcCtrSampleEncrypter
class | AP4_PiffCbcSampleEncrypter
class | AP4_PiffAvcCbcSampleEncrypter
class | AP4_PiffEncryptingProcessor
struct | AP4_PiffEncryptingProcessor::Encrypter
class | AP4_PiffSampleDecrypter
class | AP4_PiffNullSampleDecrypter
class | AP4_PiffCtrSampleDecrypter
class | AP4_PiffAvcCtrSampleDecrypter
class | AP4_PiffCbcSampleDecrypter
class | AP4_PiffAvcCbcSampleDecrypter
class | AP4_PiffTrackEncryptionAtom
class | AP4_PiffSampleEncryptionAtom

Enumerations

enum AP4_PiffCipherMode {
AP4_PIFF_CIPHER_MODE_CTR,
AP4_PIFF_CIPHER_MODE_CBC
}

Variables

const AP4_UI32 | AP4_PROTECTION_SCHEME_TYPE_PIFF = AP4_ATOM_TYPE('p','i','f','f')
const AP4_UI32 | AP4_PROTECTION_SCHEME_VERSION_PIFF_10 = 0x00010000
const AP4_UI32 | AP4_PIFF_BRAND = AP4_ATOM_TYPE('p','i','f','f')
const AP4_UI32 | AP4_PIFF_ALGORITHM_ID_NONE = 0
const AP4_UI32 | AP4_PIFF_ALGORITHM_ID_CTR = 1
const AP4_UI32 | AP4_PIFF_ALGORITHM_ID_CBC = 2
AP4_UI08 const | AP4_UUID_PIFF_TRACK_ENCRYPTION_ATOM [16]
AP4_UI08 const | AP4_UUID_PIFF_SAMPLE_ENCRYPTION_ATOM [16]
const unsigned int | AP4_PIFF_SAMPLE_ENCRYPTION_FLAG_OVERRIDE_TRACK_ENCRYPTION_DEFAULTS = 1

Enumeration Type Documentation

enum AP4_PiffCipherMode
Enumerator:
AP4_PIFF_CIPHER_MODE_CTR
AP4_PIFF_CIPHER_MODE_CBC

Definition at line 67 of file Ap4Piff.h.

Variable Documentation

const AP4_UI32 AP4_PIFF_ALGORITHM_ID_CBC = 2

Definition at line 60 of file Ap4Piff.h.

const AP4_UI32 AP4_PIFF_ALGORITHM_ID_CTR = 1

Definition at line 59 of file Ap4Piff.h.

const AP4_UI32 AP4_PIFF_ALGORITHM_ID_NONE = 0

Definition at line 58 of file Ap4Piff.h.

const AP4_UI32 AP4_PIFF_BRAND = AP4_ATOM_TYPE('p','i','f','f')

Definition at line 57 of file Ap4Piff.h.

const unsigned int AP4_PIFF_SAMPLE_ENCRYPTION_FLAG_OVERRIDE_TRACK_ENCRYPTION_DEFAULTS = 1

Definition at line 65 of file Ap4Piff.h.

const AP4_UI32 AP4_PROTECTION_SCHEME_TYPE_PIFF = AP4_ATOM_TYPE('p','i','f','f')

Definition at line 55 of file Ap4Piff.h.

const AP4_UI32 AP4_PROTECTION_SCHEME_VERSION_PIFF_10 = 0x00010000

Definition at line 56 of file Ap4Piff.h.

AP4_UI08 const AP4_UUID_PIFF_SAMPLE_ENCRYPTION_ATOM[16]
AP4_UI08 const AP4_UUID_PIFF_TRACK_ENCRYPTION_ATOM[16]
Generated on Thu May 13 16:36:39 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4Piff.h Source File

  • File List
  • File Members

Ap4Piff.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - PIFF support
00004 |
00005 |    Copyright 2002-2009 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027 ****************************************************************/
00028
00029 #ifndef _AP4_PIFF_H_
00030 #define _AP4_PIFF_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Types.h"
00036 #include "Ap4SampleEntry.h"
00037 #include "Ap4Atom.h"
00038 #include "Ap4AtomFactory.h"
00039 #include "Ap4SampleDescription.h"
00040 #include "Ap4Processor.h"
00041 #include "Ap4Protection.h"
00042 #include "Ap4UuidAtom.h"
00043
00044 /*----------------------------------------------------------------------
00045 |   class references
00046 +---------------------------------------------------------------------*/
00047 class AP4_StreamCipher;
00048 class AP4_CbcStreamCipher;
00049 class AP4_CtrStreamCipher;
00050 class AP4_PiffSampleEncryptionAtom;
00051
00052 /*----------------------------------------------------------------------
00053 |   constants
00054 +---------------------------------------------------------------------*/
00055 const AP4_UI32 AP4_PROTECTION_SCHEME_TYPE_PIFF = AP4_ATOM_TYPE('p','i','f','f');
00056 const AP4_UI32 AP4_PROTECTION_SCHEME_VERSION_PIFF_10 =  0x00010000;
00057 const AP4_UI32 AP4_PIFF_BRAND = AP4_ATOM_TYPE('p','i','f','f');
00058 const AP4_UI32 AP4_PIFF_ALGORITHM_ID_NONE = 0;
00059 const AP4_UI32 AP4_PIFF_ALGORITHM_ID_CTR  = 1;
00060 const AP4_UI32 AP4_PIFF_ALGORITHM_ID_CBC  = 2;
00061
00062 extern AP4_UI08 const AP4_UUID_PIFF_TRACK_ENCRYPTION_ATOM[16];
00063 extern AP4_UI08 const AP4_UUID_PIFF_SAMPLE_ENCRYPTION_ATOM[16];
00064
00065 const unsigned int AP4_PIFF_SAMPLE_ENCRYPTION_FLAG_OVERRIDE_TRACK_ENCRYPTION_DEFAULTS = 1;
00066
00067 typedef enum {
00068     AP4_PIFF_CIPHER_MODE_CTR,
00069     AP4_PIFF_CIPHER_MODE_CBC
00070 } AP4_PiffCipherMode;
00071
00072 /*----------------------------------------------------------------------
00073 |   AP4_PiffSampleEncrypter
00074 +---------------------------------------------------------------------*/
00075 class AP4_PiffSampleEncrypter
00076 {
00077 public:
00078     // constructor and destructor
00079     AP4_PiffSampleEncrypter() { AP4_SetMemory(m_Iv, 0, 16); };
00080     virtual ~AP4_PiffSampleEncrypter() {}
00081
00082     // methods
00083     virtual AP4_Result EncryptSampleData(AP4_DataBuffer& data_in,
00084                                          AP4_DataBuffer& data_out) = 0;
00085
00086     void            SetIv(const AP4_UI08* iv) { AP4_CopyMemory(m_Iv, iv, 16); }
00087     const AP4_UI08* GetIv()                   { return m_Iv;                  }
00088
00089 protected:
00090     AP4_UI08 m_Iv[16];
00091 };
00092
00093 /*----------------------------------------------------------------------
00094 |   AP4_PiffCtrSampleEncrypter
00095 +---------------------------------------------------------------------*/
00096 class AP4_PiffCtrSampleEncrypter : public AP4_PiffSampleEncrypter
00097 {
00098 public:
00099     // constructor and destructor
00100     AP4_PiffCtrSampleEncrypter(AP4_BlockCipher* block_cipher);
00101     ~AP4_PiffCtrSampleEncrypter();
00102
00103     // methods
00104     virtual AP4_Result EncryptSampleData(AP4_DataBuffer& data_in,
00105                                          AP4_DataBuffer& data_out);
00106
00107 protected:
00108     // members
00109     AP4_CtrStreamCipher* m_Cipher;
00110 };
00111
00112 /*----------------------------------------------------------------------
00113 |   AP4_PiffAvcCtrSampleEncrypter
00114 +---------------------------------------------------------------------*/
00115 class AP4_PiffAvcCtrSampleEncrypter : public AP4_PiffCtrSampleEncrypter
00116 {
00117 public:
00118     // constructor and destructor
00119     AP4_PiffAvcCtrSampleEncrypter(AP4_BlockCipher* block_cipher,
00120                                   AP4_Size         nalu_length_size) :
00121         AP4_PiffCtrSampleEncrypter(block_cipher),
00122         m_NaluLengthSize(nalu_length_size) {}
00123
00124     // methods
00125     virtual AP4_Result EncryptSampleData(AP4_DataBuffer& data_in,
00126                                          AP4_DataBuffer& data_out);
00127
00128 private:
00129     // members
00130     AP4_Size m_NaluLengthSize;
00131 };
00132
00133 /*----------------------------------------------------------------------
00134 |   AP4_PiffCbcSampleEncrypter
00135 +---------------------------------------------------------------------*/
00136 class AP4_PiffCbcSampleEncrypter : public AP4_PiffSampleEncrypter
00137 {
00138 public:
00139     // constructor and destructor
00140     AP4_PiffCbcSampleEncrypter(AP4_BlockCipher* block_cipher);
00141     ~AP4_PiffCbcSampleEncrypter();
00142
00143     // methods
00144     virtual AP4_Result EncryptSampleData(AP4_DataBuffer& data_in,
00145                                          AP4_DataBuffer& data_out);
00146
00147 protected:
00148     // members
00149     AP4_CbcStreamCipher* m_Cipher;
00150 };
00151
00152 /*----------------------------------------------------------------------
00153 |   AP4_PiffAvcCbcSampleEncrypter
00154 +---------------------------------------------------------------------*/
00155 class AP4_PiffAvcCbcSampleEncrypter : public AP4_PiffCbcSampleEncrypter
00156 {
00157 public:
00158     // constructor and destructor
00159     AP4_PiffAvcCbcSampleEncrypter(AP4_BlockCipher* block_cipher,
00160                                   AP4_Size         nalu_length_size) :
00161         AP4_PiffCbcSampleEncrypter(block_cipher),
00162         m_NaluLengthSize(nalu_length_size) {}
00163
00164     // methods
00165     virtual AP4_Result EncryptSampleData(AP4_DataBuffer& data_in,
00166                                          AP4_DataBuffer& data_out);
00167
00168 private:
00169     // members
00170     AP4_Size m_NaluLengthSize;
00171 };
00172
00173 /*----------------------------------------------------------------------
00174 |   AP4_PiffEncryptingProcessor
00175 +---------------------------------------------------------------------*/
00176 class AP4_PiffEncryptingProcessor : public AP4_Processor
00177 {
00178 public:
00179     // types
00180     struct Encrypter {
00181         Encrypter(AP4_UI32 track_id, AP4_PiffSampleEncrypter* sample_encrypter) :
00182             m_TrackId(track_id),
00183             m_SampleEncrypter(sample_encrypter) {}
00184         Encrypter() { delete m_SampleEncrypter; }
00185         AP4_UI32                 m_TrackId;
00186         AP4_PiffSampleEncrypter* m_SampleEncrypter;
00187     };
00188
00189     // constructor
00190     AP4_PiffEncryptingProcessor(AP4_PiffCipherMode      cipher_mode,
00191                                 AP4_BlockCipherFactory* block_cipher_factory = NULL);
00192     ~AP4_PiffEncryptingProcessor();
00193
00194     // accessors
00195     AP4_ProtectionKeyMap& GetKeyMap()      { return m_KeyMap;      }
00196     AP4_TrackPropertyMap& GetPropertyMap() { return m_PropertyMap; }
00197
00198     // AP4_Processor methods
00199     virtual AP4_Result Initialize(AP4_AtomParent&   top_level,
00200                                   AP4_ByteStream&   stream,
00201                                   AP4_Processor::ProgressListener* listener = NULL);
00202     virtual AP4_Processor::TrackHandler*    CreateTrackHandler(AP4_TrakAtom* trak);
00203     virtual AP4_Processor::FragmentHandler* CreateFragmentHandler(AP4_ContainerAtom* traf);
00204
00205 protected:
00206     // members
00207     AP4_PiffCipherMode      m_CipherMode;
00208     AP4_BlockCipherFactory* m_BlockCipherFactory;
00209     AP4_ProtectionKeyMap    m_KeyMap;
00210     AP4_TrackPropertyMap    m_PropertyMap;
00211     AP4_List<Encrypter>     m_Encrypters;
00212 };
00213
00214 /*----------------------------------------------------------------------
00215 |   AP4_PiffSampleDecrypter
00216 +---------------------------------------------------------------------*/
00217 class AP4_PiffSampleDecrypter : public AP4_SampleDecrypter
00218 {
00219 public:
00220     // factory
00221     static AP4_Result Create(AP4_ProtectedSampleDescription* sample_description,
00222                              AP4_ContainerAtom*              traf,
00223                              const AP4_UI08*                 key,
00224                              AP4_Size                        key_size,
00225                              AP4_BlockCipherFactory*         block_cipher_factory,
00226                              AP4_PiffSampleDecrypter*&       decrypter);
00227
00228     // methods
00229     virtual AP4_Result SetSampleIndex(AP4_Ordinal sample_index);
00230
00231 protected:
00232     AP4_PiffSampleDecrypter(AP4_PiffSampleEncryptionAtom* sample_encryption_atom) :
00233         m_SampleEncryptionAtom(sample_encryption_atom),
00234         m_SampleIndex(0) {}
00235     AP4_PiffSampleEncryptionAtom* m_SampleEncryptionAtom;
00236     AP4_Ordinal                   m_SampleIndex;
00237 };
00238
00239 /*----------------------------------------------------------------------
00240 |   AP4_PiffNullSampleDecrypter
00241 +---------------------------------------------------------------------*/
00242 class AP4_PiffNullSampleDecrypter : public AP4_PiffSampleDecrypter
00243 {
00244 public:
00245     // constructor
00246     AP4_PiffNullSampleDecrypter() : AP4_PiffSampleDecrypter(NULL) {}
00247
00248     // methods
00249     virtual AP4_Result DecryptSampleData(AP4_DataBuffer& data_in,
00250                                          AP4_DataBuffer& data_out,
00251                                          const AP4_UI08* /*iv = NULL*/) {
00252         data_out.SetData(data_in.GetData(), data_in.GetDataSize());
00253         return AP4_SUCCESS;
00254     }
00255 };
00256
00257 /*----------------------------------------------------------------------
00258 |   AP4_PiffCtrSampleDecrypter
00259 +---------------------------------------------------------------------*/
00260 class AP4_PiffCtrSampleDecrypter : public AP4_PiffSampleDecrypter
00261 {
00262 public:
00263     // constructor and destructor
00264     AP4_PiffCtrSampleDecrypter(AP4_BlockCipher*              block_cipher,
00265                                AP4_Size                      iv_size,
00266                                AP4_PiffSampleEncryptionAtom* sample_encryption_atom);
00267     ~AP4_PiffCtrSampleDecrypter();
00268
00269     // methods
00270     virtual AP4_Result DecryptSampleData(AP4_DataBuffer& data_in,
00271                                          AP4_DataBuffer& data_out,
00272                                          const AP4_UI08* iv = NULL);
00273
00274 private:
00275     // members
00276     AP4_CtrStreamCipher* m_Cipher;
00277     AP4_Size             m_IvSize;
00278 };
00279
00280 /*----------------------------------------------------------------------
00281 |   AP4_PiffAvcCtrSampleDecrypter
00282 +---------------------------------------------------------------------*/
00283 class AP4_PiffAvcCtrSampleDecrypter : public AP4_PiffCtrSampleDecrypter
00284 {
00285 public:
00286     // constructor and destructor
00287     AP4_PiffAvcCtrSampleDecrypter(AP4_BlockCipher*              block_cipher,
00288                                   AP4_Size                      iv_size,
00289                                   AP4_PiffSampleEncryptionAtom* sample_encryption_atom,
00290                                   AP4_Size                      nalu_length_size) :
00291         AP4_PiffCtrSampleDecrypter(block_cipher, iv_size, sample_encryption_atom),
00292         m_NaluLengthSize(nalu_length_size) {}
00293
00294     // methods
00295     virtual AP4_Result DecryptSampleData(AP4_DataBuffer& data_in,
00296                                          AP4_DataBuffer& data_out,
00297                                          const AP4_UI08* iv = NULL);
00298
00299 private:
00300     // members
00301     AP4_Size m_NaluLengthSize;
00302 };
00303
00304 /*----------------------------------------------------------------------
00305 |   AP4_PiffCbcSampleDecrypter
00306 +---------------------------------------------------------------------*/
00307 class AP4_PiffCbcSampleDecrypter : public AP4_PiffSampleDecrypter
00308 {
00309 public:
00310     // constructor and destructor
00311     AP4_PiffCbcSampleDecrypter(AP4_BlockCipher*              block_cipher,
00312                                AP4_PiffSampleEncryptionAtom* sample_encryption_atom);
00313     ~AP4_PiffCbcSampleDecrypter();
00314
00315     // methods
00316     virtual AP4_Result DecryptSampleData(AP4_DataBuffer& data_in,
00317                                          AP4_DataBuffer& data_out,
00318                                          const AP4_UI08* iv = NULL);
00319
00320 protected:
00321     // members
00322     AP4_CbcStreamCipher* m_Cipher;
00323 };
00324
00325 /*----------------------------------------------------------------------
00326 |   AP4_PiffAvcCbcSampleDecrypter
00327 +---------------------------------------------------------------------*/
00328 class AP4_PiffAvcCbcSampleDecrypter : public AP4_PiffCbcSampleDecrypter
00329 {
00330 public:
00331     // constructor and destructor
00332     AP4_PiffAvcCbcSampleDecrypter(AP4_BlockCipher*              block_cipher,
00333                                   AP4_PiffSampleEncryptionAtom* sample_encryption_atom,
00334                                   AP4_Size                      nalu_length_size) :
00335         AP4_PiffCbcSampleDecrypter(block_cipher, sample_encryption_atom),
00336         m_NaluLengthSize(nalu_length_size) {}
00337
00338     // methods
00339     virtual AP4_Result DecryptSampleData(AP4_DataBuffer& data_in,
00340                                          AP4_DataBuffer& data_out,
00341                                          const AP4_UI08* iv = NULL);
00342
00343 private:
00344     // members
00345     AP4_Size m_NaluLengthSize;
00346 };
00347
00348 /*----------------------------------------------------------------------
00349 |   AP4_PiffTrackEncryptionAtom
00350 +---------------------------------------------------------------------*/
00351 class AP4_PiffTrackEncryptionAtom : public AP4_UuidAtom
00352 {
00353 public:
00354     AP4_IMPLEMENT_DYNAMIC_CAST_D(AP4_PiffTrackEncryptionAtom, AP4_UuidAtom)
00355
00356     // class methods
00357     static AP4_PiffTrackEncryptionAtom* Create(AP4_Size        size,
00358                                                AP4_ByteStream& stream);
00359
00360     // constructors
00361     AP4_PiffTrackEncryptionAtom(AP4_UI32        default_algorithm_id,
00362                                 AP4_UI08        default_iv_size,
00363                                 const AP4_UI08* default_kid);
00364
00365     // methods
00366     virtual AP4_Result InspectFields(AP4_AtomInspector& inspector);
00367     virtual AP4_Result WriteFields(AP4_ByteStream& stream);
00368
00369     // accessors
00370     AP4_UI32        GetDefaultAlgorithmId() { return m_DefaultAlgorithmId; }
00371     AP4_UI08        GetDefaultIvSize()      { return m_DefaultIvSize;      }
00372     const AP4_UI08* GetDefaultKid()         { return m_DefaultKid;         }
00373
00374 private:
00375     // methods
00376     AP4_PiffTrackEncryptionAtom(AP4_UI32        size,
00377                                 AP4_UI32        version,
00378                                 AP4_UI32        flags,
00379                                 AP4_ByteStream& stream);
00380
00381     // members
00382     AP4_UI32 m_DefaultAlgorithmId;
00383     AP4_UI08 m_DefaultIvSize;
00384     AP4_UI08 m_DefaultKid[16];
00385 };
00386
00387 /*----------------------------------------------------------------------
00388 |   AP4_PiffSampleEncryptionAtom
00389 +---------------------------------------------------------------------*/
00390 class AP4_PiffSampleEncryptionAtom : public AP4_UuidAtom
00391 {
00392 public:
00393     AP4_IMPLEMENT_DYNAMIC_CAST_D(AP4_PiffSampleEncryptionAtom, AP4_UuidAtom)
00394
00395     // class methods
00396     static AP4_PiffSampleEncryptionAtom* Create(AP4_Size        size,
00397                                                 AP4_ByteStream& stream);
00398
00399     // constructors
00400     AP4_PiffSampleEncryptionAtom(AP4_Cardinal sample_count);
00401     AP4_PiffSampleEncryptionAtom(AP4_UI32        algorithm_id,
00402                                  AP4_UI08        iv_size,
00403                                  const AP4_UI08* kid,
00404                                  AP4_Cardinal    sample_count);
00405
00406     // methods
00407     virtual AP4_Result InspectFields(AP4_AtomInspector& inspector);
00408     virtual AP4_Result WriteFields(AP4_ByteStream& stream);
00409
00410     // accessors
00411     AP4_UI32        GetAlgorithmId()        { return m_AlgorithmId; }
00412     AP4_UI08        GetIvSize()             { return m_IvSize;      }
00413     AP4_Result      SetIvSize(AP4_UI08 iv_size);
00414     const AP4_UI08* GetKid()                { return m_Kid;         }
00415     AP4_Cardinal    GetIvCount()            { return m_IvCount;     }
00416     const AP4_UI08* GetIv(AP4_Ordinal indx);
00417     AP4_Result      SetIv(AP4_Ordinal indx, const AP4_UI08* iv);
00418
00419 private:
00420     // methods
00421     AP4_PiffSampleEncryptionAtom(AP4_UI32        size,
00422                                  AP4_UI32        version,
00423                                  AP4_UI32        flags,
00424                                  AP4_ByteStream& stream);
00425
00426     // members
00427     AP4_UI32       m_AlgorithmId;
00428     AP4_UI08       m_IvSize;
00429     AP4_UI08       m_Kid[16];
00430     AP4_Cardinal   m_IvCount;
00431     AP4_DataBuffer m_Ivs;
00432 };
00433
00434 #endif // _AP4_PIFF_H_
Generated on Thu May 13 16:36:33 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4Processor.h File Reference

  • File List
  • File Members

Ap4Processor.h File Reference

#include "Ap4Types.h"
#include "Ap4AtomFactory.h"
#include "Ap4File.h"
#include "Ap4Track.h"
#include "Ap4Sample.h"

Go to the source code of this file.

Classes

class | AP4_Processor
class | AP4_Processor::ProgressListener
Abstract class that defines the interface implemented by progress listeners. More...
class | AP4_Processor::TrackHandler
Abstract class that defines the interface implemented by concrete track handlers. More...
class | AP4_Processor::FragmentHandler
Abstract class that defines the interface implemented by concrete fragment handlers. More...
class | AP4_Processor::ExternalTrackData
Generated on Thu May 13 16:36:40 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4Processor.h Source File

  • File List
  • File Members

Ap4Processor.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - File Processor
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027 ****************************************************************/
00028
00029 #ifndef _AP4_PROCESSOR_H_
00030 #define _AP4_PROCESSOR_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Types.h"
00036 #include "Ap4AtomFactory.h"
00037 #include "Ap4File.h"
00038 #include "Ap4Track.h"
00039 #include "Ap4Sample.h"
00040
00041 /*----------------------------------------------------------------------
00042 |   class references
00043 +---------------------------------------------------------------------*/
00044 class AP4_ContainerAtom;
00045 class AP4_ByteStream;
00046 class AP4_DataBuffer;
00047 class AP4_TrakAtom;
00048 struct AP4_MoofLocator;
00049
00050 /*----------------------------------------------------------------------
00051 |   AP4_Processor
00052 +---------------------------------------------------------------------*/
00053 class AP4_Processor {
00054 public:
00060     class ProgressListener {
00061     public:
00062         virtual ~ProgressListener() {}
00063
00074         virtual AP4_Result OnProgress(unsigned int step,
00075                                       unsigned int total) = 0;
00076     };
00077
00083     class TrackHandler {
00084     public:
00088         virtual ~TrackHandler() {}
00089
00094         virtual AP4_Result ProcessTrack() { return AP4_SUCCESS; }
00095
00101         virtual AP4_Size GetProcessedSampleSize(AP4_Sample& sample) { return sample.GetSize(); }
00102
00109         virtual AP4_Result ProcessSample(AP4_DataBuffer& data_in,
00110                                          AP4_DataBuffer& data_out) = 0;
00111     };
00112
00118     class FragmentHandler {
00119     public:
00123         virtual ~FragmentHandler() {}
00124
00129         virtual AP4_Result ProcessFragment() { return AP4_SUCCESS; }
00130
00136         virtual AP4_Result FinishFragment() { return AP4_ERROR_NOT_SUPPORTED; }
00137
00143         virtual AP4_Size   GetProcessedSampleSize(AP4_Sample& sample) { return sample.GetSize(); }
00144
00151         virtual AP4_Result ProcessSample(AP4_DataBuffer& data_in,
00152                                          AP4_DataBuffer& data_out) = 0;
00153     };
00154
00158     virtual ~AP4_Processor() { m_ExternalTrackData.DeleteReferences(); }
00159
00169     AP4_Result Process(AP4_ByteStream&   input,
00170                        AP4_ByteStream&   output,
00171                        ProgressListener* listener = NULL,
00172                        AP4_AtomFactory&  atom_factory =
00173                            AP4_DefaultAtomFactory::Instance);
00174
00184     virtual AP4_Result Initialize(AP4_AtomParent&   top_level,
00185                                   AP4_ByteStream&   stream,
00186                                   ProgressListener* listener = NULL);
00187
00192     virtual AP4_Result Finalize(AP4_AtomParent&   top_level,
00193                                 ProgressListener* listener = NULL);
00194
00203     virtual TrackHandler* CreateTrackHandler(AP4_TrakAtom* /*trak*/) { return NULL; }
00204
00213     virtual FragmentHandler* CreateFragmentHandler(AP4_ContainerAtom* /*traf*/) { return NULL; }
00214
00215 protected:
00216     class ExternalTrackData {
00217     public:
00218         ExternalTrackData(unsigned int track_id, AP4_ByteStream* media_data) :
00219             m_TrackId(track_id), m_MediaData(media_data) {
00220             media_data->AddReference();
00221         }
00222         ~ExternalTrackData() { m_MediaData->Release(); }
00223         unsigned int    m_TrackId;
00224         AP4_ByteStream* m_MediaData;
00225     };
00226
00227     AP4_Result ProcessFragments(AP4_MoovAtom*              moov,
00228                                 AP4_List<AP4_MoofLocator>& moofs,
00229                                 AP4_ContainerAtom*         mfra,
00230                                 AP4_ByteStream&            input,
00231                                 AP4_ByteStream&            output);
00232
00233
00234     AP4_List<ExternalTrackData> m_ExternalTrackData;
00235 };
00236
00237 #endif // _AP4_PROCESSOR_H_
Generated on Thu May 13 16:36:33 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4Protection.h File Reference

  • File List
  • File Members

Ap4Protection.h File Reference

#include "Ap4Types.h"
#include "Ap4SampleEntry.h"
#include "Ap4Atom.h"
#include "Ap4AtomFactory.h"
#include "Ap4SampleDescription.h"
#include "Ap4Processor.h"

Go to the source code of this file.

Classes

class | AP4_EncaSampleEntry
class | AP4_EncvSampleEntry
class | AP4_DrmsSampleEntry
class | AP4_DrmiSampleEntry
class | AP4_ProtectionKeyMap
class | AP4_ProtectionKeyMap::KeyEntry
class | AP4_TrackPropertyMap
class | AP4_TrackPropertyMap::Entry
class | AP4_ProtectionSchemeInfo
class | AP4_ProtectedSampleDescription
class | AP4_BlockCipher
class | AP4_BlockCipherFactory
class | AP4_DefaultBlockCipherFactory
class | AP4_SampleDecrypter
class | AP4_StandardDecryptingProcessor
class | AP4_DecryptingStream
class | AP4_EncryptingStream

Variables

const unsigned int | AP4_PROTECTION_KEY_LENGTH = 16
const AP4_UI32 | AP4_PROTECTION_SCHEME_TYPE_ITUNES = AP4_ATOM_TYPE('i','t','u','n')

Variable Documentation

const unsigned int AP4_PROTECTION_KEY_LENGTH = 16

Definition at line 51 of file Ap4Protection.h.

const AP4_UI32 AP4_PROTECTION_SCHEME_TYPE_ITUNES = AP4_ATOM_TYPE('i','t','u','n')

Definition at line 53 of file Ap4Protection.h.

Generated on Thu May 13 16:36:40 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4Protection.h Source File

  • File List
  • File Members

Ap4Protection.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - Protected Streams support
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027 ****************************************************************/
00028
00029 #ifndef _AP4_PROTECTION_H_
00030 #define _AP4_PROTECTION_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Types.h"
00036 #include "Ap4SampleEntry.h"
00037 #include "Ap4Atom.h"
00038 #include "Ap4AtomFactory.h"
00039 #include "Ap4SampleDescription.h"
00040 #include "Ap4Processor.h"
00041
00042 /*----------------------------------------------------------------------
00043 |   classes
00044 +---------------------------------------------------------------------*/
00045 class AP4_StreamCipher;
00046
00047 /*----------------------------------------------------------------------
00048 |   constants
00049 +---------------------------------------------------------------------*/
00050 // this is fixed for now
00051 const unsigned int AP4_PROTECTION_KEY_LENGTH = 16;
00052
00053 const AP4_UI32 AP4_PROTECTION_SCHEME_TYPE_ITUNES = AP4_ATOM_TYPE('i','t','u','n');
00054
00055 /*----------------------------------------------------------------------
00056 |   AP4_EncaSampleEntry
00057 +---------------------------------------------------------------------*/
00058 class AP4_EncaSampleEntry : public AP4_AudioSampleEntry
00059 {
00060 public:
00061     // methods
00062     AP4_EncaSampleEntry(AP4_Size         size,
00063                         AP4_ByteStream&  stream,
00064                         AP4_AtomFactory& atom_factory);
00065     AP4_EncaSampleEntry(AP4_UI32         type,
00066                         AP4_Size         size,
00067                         AP4_ByteStream&  stream,
00068                         AP4_AtomFactory& atom_factory);
00069
00070     // methods
00071     AP4_SampleDescription* ToSampleDescription();
00072
00073     // this method is used as a factory by the ISMACryp classes
00074     // NOTE: this should be named ToSampleDescription, but C++ has a
00075     // problem with that because the base class does not have this
00076     // overloaded method, but has another other one by that name
00077     virtual AP4_SampleDescription* ToTargetSampleDescription(AP4_UI32 format);
00078 };
00079
00080 /*----------------------------------------------------------------------
00081 |   AP4_EncvSampleEntry
00082 +---------------------------------------------------------------------*/
00083 class AP4_EncvSampleEntry : public AP4_VisualSampleEntry
00084 {
00085 public:
00086     // constructors
00087     AP4_EncvSampleEntry(AP4_Size         size,
00088                         AP4_ByteStream&  stream,
00089                         AP4_AtomFactory& atom_factory);
00090     AP4_EncvSampleEntry(AP4_UI32         type,
00091                         AP4_Size         size,
00092                         AP4_ByteStream&  stream,
00093                         AP4_AtomFactory& atom_factory);
00094
00095     // methods
00096     AP4_SampleDescription* ToSampleDescription();
00097
00098     // this method is used as a factory by the ISMACryp classes
00099     // NOTE: this should be named ToSampleDescription, but C++ has a
00100     // problem with that because the base class does not have this
00101     // overloaded method, but has another other one by that name
00102     virtual AP4_SampleDescription* ToTargetSampleDescription(AP4_UI32 format);
00103 };
00104
00105 /*----------------------------------------------------------------------
00106 |   AP4_DrmsSampleEntry
00107 +---------------------------------------------------------------------*/
00108 class AP4_DrmsSampleEntry : public AP4_EncaSampleEntry
00109 {
00110 public:
00111     // methods
00112     AP4_DrmsSampleEntry(AP4_Size         size,
00113                         AP4_ByteStream&  stream,
00114                         AP4_AtomFactory& atom_factory);
00115 };
00116
00117 /*----------------------------------------------------------------------
00118 |   AP4_DrmiSampleEntry
00119 +---------------------------------------------------------------------*/
00120 class AP4_DrmiSampleEntry : public AP4_EncvSampleEntry
00121 {
00122 public:
00123     // methods
00124     AP4_DrmiSampleEntry(AP4_Size         size,
00125                         AP4_ByteStream&  stream,
00126                         AP4_AtomFactory& atom_factory);
00127 };
00128
00129 /*----------------------------------------------------------------------
00130 |   AP4_ProtectionKeyMap
00131 +---------------------------------------------------------------------*/
00132 class AP4_ProtectionKeyMap
00133 {
00134 public:
00135     // constructors and destructor
00136     AP4_ProtectionKeyMap();
00137     ~AP4_ProtectionKeyMap();
00138
00139     // methods
00140     AP4_Result      SetKey(AP4_UI32 track_id, const AP4_UI08* key, const AP4_UI08* iv = NULL);
00141     AP4_Result      SetKeys(const AP4_ProtectionKeyMap& key_map);
00142     AP4_Result      GetKeyAndIv(AP4_UI32 track_id, const AP4_UI08*& key, const AP4_UI08*& iv);
00143     const AP4_UI08* GetKey(AP4_UI32 track_id) const;
00144
00145 private:
00146     // types
00147     class KeyEntry {
00148     public:
00149         KeyEntry(AP4_UI32 track_id, const AP4_UI08* key, const AP4_UI08* iv = NULL);
00150         void SetKey(const AP4_UI08* key, const AP4_UI08* iv);
00151         AP4_Ordinal m_TrackId;
00152         AP4_UI08    m_Key[AP4_PROTECTION_KEY_LENGTH];
00153         AP4_UI08    m_IV[AP4_PROTECTION_KEY_LENGTH];
00154     };
00155
00156     // methods
00157     KeyEntry* GetEntry(AP4_UI32 track_id) const;
00158
00159     // members
00160     AP4_List<KeyEntry> m_KeyEntries;
00161 };
00162
00163 /*----------------------------------------------------------------------
00164 |   AP4_TrackPropertyMap
00165 +---------------------------------------------------------------------*/
00166 class AP4_TrackPropertyMap
00167 {
00168 public:
00169     // methods
00170     AP4_Result  SetProperty(AP4_UI32 track_id, const char* name, const char* value);
00171     AP4_Result  SetProperties(const AP4_TrackPropertyMap& properties);
00172     const char* GetProperty(AP4_UI32 track_id, const char* name);
00173     AP4_Result  GetTextualHeaders(AP4_UI32 track_id, AP4_DataBuffer& buffer);
00174
00175
00176     // destructor
00177     virtual ~AP4_TrackPropertyMap();
00178
00179 private:
00180     // types
00181     class Entry {
00182     public:
00183         Entry(AP4_UI32 track_id, const char* name, const char* value) :
00184           m_TrackId(track_id), m_Name(name), m_Value(value) {}
00185         AP4_UI32   m_TrackId;
00186         AP4_String m_Name;
00187         AP4_String m_Value;
00188     };
00189
00190     // members
00191     AP4_List<Entry> m_Entries;
00192 };
00193
00194 /*----------------------------------------------------------------------
00195 |   AP4_ProtectionSchemeInfo
00196 +---------------------------------------------------------------------*/
00197 class AP4_ProtectionSchemeInfo
00198 {
00199 public:
00200     // constructors and destructor
00201     AP4_ProtectionSchemeInfo(AP4_ContainerAtom* schi);
00202     virtual ~AP4_ProtectionSchemeInfo();
00203
00204     // accessors
00205     AP4_ContainerAtom* GetSchiAtom() { return m_SchiAtom; }
00206
00207 protected:
00208     AP4_ContainerAtom* m_SchiAtom;
00209 };
00210
00211 /*----------------------------------------------------------------------
00212 |   AP4_ProtectedSampleDescription
00213 +---------------------------------------------------------------------*/
00214 class AP4_ProtectedSampleDescription : public AP4_SampleDescription
00215 {
00216 public:
00217     AP4_IMPLEMENT_DYNAMIC_CAST_D(AP4_ProtectedSampleDescription, AP4_SampleDescription)
00218
00219     // constructor and destructor
00220     AP4_ProtectedSampleDescription(AP4_UI32               format,
00221                                    AP4_SampleDescription* original_sample_description,
00222                                    AP4_UI32               original_format,
00223                                    AP4_UI32               scheme_type,
00224                                    AP4_UI32               scheme_version,
00225                                    const char*            scheme_uri,
00226                                    AP4_ContainerAtom*     schi_atom, // will be cloned
00227                                    bool                   transfer_ownership_of_original=true);
00228     ~AP4_ProtectedSampleDescription();
00229
00230     // accessors
00231     AP4_SampleDescription* GetOriginalSampleDescription() {
00232         return m_OriginalSampleDescription;
00233     }
00234     AP4_UI32          GetOriginalFormat() const { return m_OriginalFormat; }
00235     AP4_UI32          GetSchemeType()     const { return m_SchemeType;     }
00236     AP4_UI32          GetSchemeVersion()  const { return m_SchemeVersion;  }
00237     const AP4_String& GetSchemeUri()      const { return m_SchemeUri;      }
00238     AP4_ProtectionSchemeInfo* GetSchemeInfo() const {
00239         return m_SchemeInfo;
00240     }
00241
00242     // implementation of abstract base class methods
00243     virtual AP4_Atom* ToAtom() const;
00244
00245 private:
00246     // members
00247     AP4_SampleDescription*    m_OriginalSampleDescription;
00248     bool                      m_OriginalSampleDescriptionIsOwned;
00249     AP4_UI32                  m_OriginalFormat;
00250     AP4_UI32                  m_SchemeType;
00251     AP4_UI32                  m_SchemeVersion;
00252     AP4_String                m_SchemeUri;
00253     AP4_ProtectionSchemeInfo* m_SchemeInfo;
00254 };
00255
00256 /*----------------------------------------------------------------------
00257 |   AP4_BlockCipher
00258 +---------------------------------------------------------------------*/
00259 class AP4_BlockCipher
00260 {
00261 public:
00262     // types
00263     typedef enum {
00264         ENCRYPT,
00265         DECRYPT
00266     } CipherDirection;
00267
00268     typedef enum {
00269         AES_128
00270     } CipherType;
00271
00272     // constructor and destructor
00273     virtual ~AP4_BlockCipher() {}
00274
00275     // methods
00276     virtual AP4_Result ProcessBlock(const AP4_UI08* block_in, AP4_UI08* block_out) = 0;
00277 };
00278
00279 /*----------------------------------------------------------------------
00280 |   AP4_BlockCipherFactory
00281 +---------------------------------------------------------------------*/
00282 class AP4_BlockCipherFactory
00283 {
00284 public:
00285     // methods
00286     virtual ~AP4_BlockCipherFactory() {}
00287     virtual AP4_Result Create(AP4_BlockCipher::CipherType      type,
00288                               AP4_BlockCipher::CipherDirection direction,
00289                               const AP4_UI08*                  key,
00290                               AP4_Size                         key_size,
00291                               AP4_BlockCipher*&                cipher) = 0;
00292 };
00293
00294 /*----------------------------------------------------------------------
00295 |   AP4_DefaultBlockCipherFactory
00296 +---------------------------------------------------------------------*/
00297 class AP4_DefaultBlockCipherFactory : public AP4_BlockCipherFactory
00298 {
00299 public:
00300     // class variables
00301     static AP4_DefaultBlockCipherFactory Instance;
00302
00303     // methods
00304     virtual AP4_Result Create(AP4_BlockCipher::CipherType      type,
00305                               AP4_BlockCipher::CipherDirection direction,
00306                               const AP4_UI08*                  key,
00307                               AP4_Size                         key_size,
00308                               AP4_BlockCipher*&                cipher);
00309 };
00310
00311 /*----------------------------------------------------------------------
00312 |   AP4_SampleDecrypter
00313 +---------------------------------------------------------------------*/
00314 class AP4_SampleDecrypter
00315 {
00316 public:
00320     static AP4_SampleDecrypter* Create(AP4_ProtectedSampleDescription* sample_description,
00321                                        const AP4_UI08*                 key,
00322                                        AP4_Size                        key_size,
00323                                        AP4_BlockCipherFactory*         block_cipher_factory = NULL);
00324
00328     static AP4_SampleDecrypter* Create(AP4_ProtectedSampleDescription* sample_description,
00329                                        AP4_ContainerAtom*              traf,
00330                                        const AP4_UI08*                 key,
00331                                        AP4_Size                        key_size,
00332                                        AP4_BlockCipherFactory*         block_cipher_factory = NULL);
00333
00334     // destructor
00335     virtual ~AP4_SampleDecrypter() {}
00336
00337     // methods
00338     virtual AP4_Size   GetDecryptedSampleSize(AP4_Sample& sample) { return sample.GetSize(); }
00339     virtual AP4_Result SetSampleIndex(AP4_Ordinal /*index*/)      { return AP4_SUCCESS;      }
00340     virtual AP4_Result DecryptSampleData(AP4_DataBuffer&    data_in,
00341                                          AP4_DataBuffer&    data_out,
00342                                          const AP4_UI08*    iv = NULL) = 0;
00343 };
00344
00345 /*----------------------------------------------------------------------
00346 |   AP4_StandardDecryptingProcessor
00347 +---------------------------------------------------------------------*/
00348 class AP4_StandardDecryptingProcessor : public AP4_Processor
00349 {
00350 public:
00351     // constructor
00352     AP4_StandardDecryptingProcessor(const AP4_ProtectionKeyMap* key_map = NULL,
00353                                     AP4_BlockCipherFactory*     block_cipher_factory = NULL);
00354
00355     // accessors
00356     AP4_ProtectionKeyMap& GetKeyMap() { return m_KeyMap; }
00357
00358     // methods
00359     virtual AP4_Result Initialize(AP4_AtomParent&   top_level,
00360                                   AP4_ByteStream&   stream,
00361                                   ProgressListener* listener);
00362     virtual AP4_Processor::TrackHandler* CreateTrackHandler(AP4_TrakAtom* trak);
00363
00364 private:
00365     // members
00366     AP4_BlockCipherFactory* m_BlockCipherFactory;
00367     AP4_ProtectionKeyMap    m_KeyMap;
00368 };
00369
00370 /*----------------------------------------------------------------------
00371 |   AP4_DecryptingStream
00372 +---------------------------------------------------------------------*/
00373 class AP4_DecryptingStream : public AP4_ByteStream
00374 {
00375 public:
00376     typedef enum {
00377         CIPHER_MODE_CTR,
00378         CIPHER_MODE_CBC
00379     } CipherMode;
00380
00381     static AP4_Result Create(CipherMode              mode,
00382                              AP4_ByteStream&         encrypted_stream,
00383                              AP4_LargeSize           cleartext_size,
00384                              const AP4_UI08*         iv,
00385                              AP4_Size                iv_size,
00386                              const AP4_UI08*         key,
00387                              AP4_Size                key_size,
00388                              AP4_BlockCipherFactory* block_cipher_factory,
00389                              AP4_ByteStream*&        stream);
00390
00391     // AP4_ByteStream methods
00392     virtual AP4_Result ReadPartial(void*     buffer,
00393                                    AP4_Size  bytes_to_read,
00394                                    AP4_Size& bytes_read);
00395     virtual AP4_Result WritePartial(const void* buffer,
00396                                     AP4_Size    bytes_to_write,
00397                                     AP4_Size&   bytes_written);
00398     virtual AP4_Result Seek(AP4_Position position);
00399     virtual AP4_Result Tell(AP4_Position& position);
00400     virtual AP4_Result GetSize(AP4_LargeSize& size);
00401
00402     // AP4_Referenceable methods
00403     virtual void AddReference();
00404     virtual void Release();
00405
00406 private:
00407     // methods
00408     AP4_DecryptingStream() {} // private constructor, use the factory instead
00409     ~AP4_DecryptingStream();
00410
00411     // members
00412     CipherMode        m_Mode;
00413     AP4_LargeSize     m_CleartextSize;
00414     AP4_Position      m_CleartextPosition;
00415     AP4_ByteStream*   m_EncryptedStream;
00416     AP4_LargeSize     m_EncryptedSize;
00417     AP4_Position      m_EncryptedPosition;
00418     AP4_StreamCipher* m_StreamCipher;
00419     AP4_UI08          m_Buffer[16];
00420     AP4_Size          m_BufferFullness;
00421     AP4_Size          m_BufferOffset;
00422     AP4_Cardinal      m_ReferenceCount;
00423 };
00424
00425 /*----------------------------------------------------------------------
00426 |   AP4_EncryptingStream
00427 +---------------------------------------------------------------------*/
00428 class AP4_EncryptingStream : public AP4_ByteStream
00429 {
00430 public:
00431     typedef enum {
00432         CIPHER_MODE_CTR,
00433         CIPHER_MODE_CBC
00434     } CipherMode;
00435
00436     static AP4_Result Create(CipherMode              mode,
00437                              AP4_ByteStream&         cleartext_stream,
00438                              const AP4_UI08*         iv,
00439                              AP4_Size                iv_size,
00440                              const AP4_UI08*         key,
00441                              AP4_Size                key_size,
00442                              bool                    prepend_iv,
00443                              AP4_BlockCipherFactory* block_cipher_factory,
00444                              AP4_ByteStream*&        stream);
00445
00446     // AP4_ByteStream methods
00447     virtual AP4_Result ReadPartial(void*     buffer,
00448                                    AP4_Size  bytes_to_read,
00449                                    AP4_Size& bytes_read);
00450     virtual AP4_Result WritePartial(const void* buffer,
00451                                     AP4_Size    bytes_to_write,
00452                                     AP4_Size&   bytes_written);
00453     virtual AP4_Result Seek(AP4_Position position);
00454     virtual AP4_Result Tell(AP4_Position& position);
00455     virtual AP4_Result GetSize(AP4_LargeSize& size);
00456
00457     // AP4_Referenceable methods
00458     virtual void AddReference();
00459     virtual void Release();
00460
00461 private:
00462     // methods
00463     AP4_EncryptingStream() {} // private constructor, use the factory instead
00464     ~AP4_EncryptingStream();
00465
00466     // members
00467     CipherMode        m_Mode;
00468     AP4_LargeSize     m_CleartextSize;
00469     AP4_Position      m_CleartextPosition;
00470     AP4_ByteStream*   m_CleartextStream;
00471     AP4_LargeSize     m_EncryptedSize;
00472     AP4_Position      m_EncryptedPosition;
00473     AP4_StreamCipher* m_StreamCipher;
00474     AP4_UI08          m_Buffer[32]; // one cipher block plus one block padding
00475     AP4_Size          m_BufferFullness;
00476     AP4_Size          m_BufferOffset;
00477     AP4_Cardinal      m_ReferenceCount;
00478 };
00479
00480 #endif // _AP4_PROTECTION_H_
Generated on Thu May 13 16:36:33 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4Results.h File Reference

  • File List
  • File Members

Ap4Results.h File Reference

Go to the source code of this file.

Defines

#define | AP4_FAILED(result) ((result) != AP4_SUCCESS)
#define | AP4_SUCCEEDED(result) ((result) == AP4_SUCCESS)
#define | AP4_CHECK(_x)

Functions

const char * | AP4_ResultText (int result)

Variables

const int | AP4_SUCCESS = 0
const int | AP4_FAILURE = -1
const int | AP4_ERROR_OUT_OF_MEMORY = -2
const int | AP4_ERROR_INVALID_PARAMETERS = -3
const int | AP4_ERROR_NO_SUCH_FILE = -4
const int | AP4_ERROR_PERMISSION_DENIED = -5
const int | AP4_ERROR_CANNOT_OPEN_FILE = -6
const int | AP4_ERROR_EOS = -7
const int | AP4_ERROR_WRITE_FAILED = -8
const int | AP4_ERROR_READ_FAILED = -9
const int | AP4_ERROR_INVALID_FORMAT = -10
const int | AP4_ERROR_NO_SUCH_ITEM = -11
const int | AP4_ERROR_OUT_OF_RANGE = -12
const int | AP4_ERROR_INTERNAL = -13
const int | AP4_ERROR_INVALID_STATE = -14
const int | AP4_ERROR_LIST_EMPTY = -15
const int | AP4_ERROR_LIST_OPERATION_ABORTED = -16
const int | AP4_ERROR_INVALID_RTP_CONSTRUCTOR_TYPE = -17
const int | AP4_ERROR_NOT_SUPPORTED = -18
const int | AP4_ERROR_INVALID_TRACK_TYPE = -19
const int | AP4_ERROR_INVALID_RTP_PACKET_EXTRA_DATA = -20
const int | AP4_ERROR_BUFFER_TOO_SMALL = -21
const int | AP4_ERROR_NOT_ENOUGH_DATA = -22
const int | AP4_ERROR_NOT_ENOUGH_SPACE = -23

Define Documentation

#define AP4_CHECK ( _x )
Value:
do {                      \
    AP4_Result _result = (_x);                  \
    if (AP4_FAILED(_result)) return _result;    \
} while(0)

Definition at line 71 of file Ap4Results.h.

#define AP4_FAILED ( result ) ((result) != AP4_SUCCESS)

Definition at line 68 of file Ap4Results.h.

Referenced by AP4_Array< T >::SetItemCount().

#define AP4_SUCCEEDED ( result ) ((result) == AP4_SUCCESS)

Definition at line 69 of file Ap4Results.h.

Function Documentation

const char* AP4_ResultText ( int result )

Variable Documentation

const int AP4_ERROR_BUFFER_TOO_SMALL = -21

Definition at line 56 of file Ap4Results.h.

const int AP4_ERROR_CANNOT_OPEN_FILE = -6

Definition at line 41 of file Ap4Results.h.

const int AP4_ERROR_EOS = -7

Definition at line 42 of file Ap4Results.h.

const int AP4_ERROR_INTERNAL = -13

Definition at line 48 of file Ap4Results.h.

const int AP4_ERROR_INVALID_FORMAT = -10

Definition at line 45 of file Ap4Results.h.

const int AP4_ERROR_INVALID_PARAMETERS = -3

Definition at line 38 of file Ap4Results.h.

const int AP4_ERROR_INVALID_RTP_CONSTRUCTOR_TYPE = -17

Definition at line 52 of file Ap4Results.h.

const int AP4_ERROR_INVALID_RTP_PACKET_EXTRA_DATA = -20

Definition at line 55 of file Ap4Results.h.

const int AP4_ERROR_INVALID_STATE = -14

Definition at line 49 of file Ap4Results.h.

const int AP4_ERROR_INVALID_TRACK_TYPE = -19

Definition at line 54 of file Ap4Results.h.

const int AP4_ERROR_LIST_EMPTY = -15

Definition at line 50 of file Ap4Results.h.

Referenced by AP4_List< T >::PopHead().

const int AP4_ERROR_LIST_OPERATION_ABORTED = -16

Definition at line 51 of file Ap4Results.h.

Referenced by AP4_List< T >::ReverseApply().

const int AP4_ERROR_NO_SUCH_FILE = -4

Definition at line 39 of file Ap4Results.h.

const int AP4_ERROR_NO_SUCH_ITEM = -11

Definition at line 46 of file Ap4Results.h.

Referenced by AP4_List< T >::Find(), AP4_List< T >::Get(), AP4_List< T >::Remove(), and AP4_List< T >::ReverseFind().

const int AP4_ERROR_NOT_ENOUGH_DATA = -22

Definition at line 57 of file Ap4Results.h.

const int AP4_ERROR_NOT_ENOUGH_SPACE = -23

Definition at line 58 of file Ap4Results.h.

const int AP4_ERROR_NOT_SUPPORTED = -18

Definition at line 53 of file Ap4Results.h.

Referenced by AP4_Processor::FragmentHandler::FinishFragment().

const int AP4_ERROR_OUT_OF_MEMORY = -2

Definition at line 37 of file Ap4Results.h.

Referenced by AP4_Array< T >::EnsureCapacity().

const int AP4_ERROR_OUT_OF_RANGE = -12

Definition at line 47 of file Ap4Results.h.

Referenced by AP4_Array< T >::RemoveLast().

const int AP4_ERROR_PERMISSION_DENIED = -5

Definition at line 40 of file Ap4Results.h.

const int AP4_ERROR_READ_FAILED = -9

Definition at line 44 of file Ap4Results.h.

const int AP4_ERROR_WRITE_FAILED = -8

Definition at line 43 of file Ap4Results.h.

const int AP4_FAILURE = -1

Definition at line 36 of file Ap4Results.h.

Referenced by AP4_List< T >::ApplyUntilSuccess(), AP4_DescriptorFinder::Test(), and AP4_AtomFinder::Test().

const int AP4_SUCCESS = 0

Definition at line 35 of file Ap4Results.h.

Referenced by AP4_DescriptorListInspector::Action(), AP4_AtomListInspector::Action(), AP4_List< T >::Add(), AP4_Array< T >::Append(), AP4_List< T >::Apply(), AP4_List< T >::ApplyUntilFailure(), AP4_List< T >::ApplyUntilSuccess(), AP4_List< T >::Clear(), AP4_Array< T >::Clear(), AP4_PiffNullSampleDecrypter::DecryptSampleData(), AP4_List< T >::DeleteReferences(), AP4_Array< T >::EnsureCapacity(), AP4_List< T >::Find(), AP4_ByteStream::Flush(), AP4_List< T >::Get(), AP4_MemoryByteStream::GetSize(), AP4_SubStream::GetSize(), AP4_List< T >::Insert(), AP4_Atom::InspectFields(), AP4_List< T >::PopHead(), AP4_Processor::FragmentHandler::ProcessFragment(), AP4_Processor::TrackHandler::ProcessTrack(), AP4_List< T >::Remove(), AP4_Array< T >::RemoveLast(), AP4_List< T >::ReverseApply(), AP4_List< T >::ReverseFind(), AP4_Array< T >::SetItemCount(), AP4_Atom::SetParent(), AP4_SampleDecrypter::SetSampleIndex(), AP4_MvhdAtom::SetTimeScale(), AP4_MemoryByteStream::Tell(), AP4_SubStream::Tell(), AP4_DescriptorFinder::Test(), and AP4_AtomFinder::Test().

Generated on Thu May 13 16:36:40 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4Results.h Source File

  • File List
  • File Members

Ap4Results.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - Result Codes
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027  ****************************************************************/
00028
00029 #ifndef _AP4_RESULTS_H_
00030 #define _AP4_RESULTS_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   constants
00034 +---------------------------------------------------------------------*/
00035 const int AP4_SUCCESS                               =  0;
00036 const int AP4_FAILURE                               = -1;
00037 const int AP4_ERROR_OUT_OF_MEMORY                   = -2;
00038 const int AP4_ERROR_INVALID_PARAMETERS              = -3;
00039 const int AP4_ERROR_NO_SUCH_FILE                    = -4;
00040 const int AP4_ERROR_PERMISSION_DENIED               = -5;
00041 const int AP4_ERROR_CANNOT_OPEN_FILE                = -6;
00042 const int AP4_ERROR_EOS                             = -7;
00043 const int AP4_ERROR_WRITE_FAILED                    = -8;
00044 const int AP4_ERROR_READ_FAILED                     = -9;
00045 const int AP4_ERROR_INVALID_FORMAT                  = -10;
00046 const int AP4_ERROR_NO_SUCH_ITEM                    = -11;
00047 const int AP4_ERROR_OUT_OF_RANGE                    = -12;
00048 const int AP4_ERROR_INTERNAL                        = -13;
00049 const int AP4_ERROR_INVALID_STATE                   = -14;
00050 const int AP4_ERROR_LIST_EMPTY                      = -15;
00051 const int AP4_ERROR_LIST_OPERATION_ABORTED          = -16;
00052 const int AP4_ERROR_INVALID_RTP_CONSTRUCTOR_TYPE    = -17;
00053 const int AP4_ERROR_NOT_SUPPORTED                   = -18;
00054 const int AP4_ERROR_INVALID_TRACK_TYPE              = -19;
00055 const int AP4_ERROR_INVALID_RTP_PACKET_EXTRA_DATA   = -20;
00056 const int AP4_ERROR_BUFFER_TOO_SMALL                = -21;
00057 const int AP4_ERROR_NOT_ENOUGH_DATA                 = -22;
00058 const int AP4_ERROR_NOT_ENOUGH_SPACE                = -23;
00059
00060 /*----------------------------------------------------------------------
00061 |   utility functions
00062 +---------------------------------------------------------------------*/
00063 const char* AP4_ResultText(int result);
00064
00065 /*----------------------------------------------------------------------
00066 |   macros
00067 +---------------------------------------------------------------------*/
00068 #define AP4_FAILED(result) ((result) != AP4_SUCCESS)
00069 #define AP4_SUCCEEDED(result) ((result) == AP4_SUCCESS)
00070
00071 #define AP4_CHECK(_x) do {                      \
00072     AP4_Result _result = (_x);                  \
00073     if (AP4_FAILED(_result)) return _result;    \
00074 } while(0)
00075
00076 #endif // _AP4_RESULTS_H_
Generated on Thu May 13 16:36:33 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4RtpAtom.h File Reference

  • File List
  • File Members

Ap4RtpAtom.h File Reference

#include "Ap4Types.h"
#include "Ap4List.h"
#include "Ap4String.h"
#include "Ap4Atom.h"

Go to the source code of this file.

Classes

class AP4_RtpAtom
Generated on Thu May 13 16:36:40 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4RtpAtom.h Source File

  • File List
  • File Members

Ap4RtpAtom.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - rtp Atoms
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027 ****************************************************************/
00028
00029 #ifndef _AP4_RTP_ATOM_H_
00030 #define _AP4_RTP_ATOM_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Types.h"
00036 #include "Ap4List.h"
00037 #include "Ap4String.h"
00038 #include "Ap4Atom.h"
00039
00040 /*----------------------------------------------------------------------
00041 |   class references
00042 +---------------------------------------------------------------------*/
00043 class AP4_ByteStream;
00044
00045 /*----------------------------------------------------------------------
00046 |   AP4_RtpAtom
00047 +---------------------------------------------------------------------*/
00048 class AP4_RtpAtom : public AP4_Atom
00049 {
00050 public:
00051     // class methods
00052     static AP4_RtpAtom* Create(AP4_Size size, AP4_ByteStream& stream) {
00053         return new AP4_RtpAtom(size, stream);
00054     }
00055
00056     // methods
00057     const AP4_String& GetSdpText() { return m_SdpText; }
00058     virtual AP4_Result InspectFields(AP4_AtomInspector& inspector);
00059     virtual AP4_Result WriteFields(AP4_ByteStream& stream);
00060
00061 private:
00062     // methods
00063     AP4_RtpAtom(AP4_UI32 size, AP4_ByteStream& stream);
00064
00065     // members
00066     AP4_UI32   m_DescriptionFormat;
00067     AP4_String m_SdpText;
00068 };
00069
00070 #endif // _AP4_RTP_ATOM_H_
Generated on Thu May 13 16:36:33 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4RtpHint.h File Reference

  • File List
  • File Members

Ap4RtpHint.h File Reference

#include "Ap4Types.h"
#include "Ap4List.h"
#include "Ap4DataBuffer.h"
#include "Ap4Interfaces.h"

Go to the source code of this file.

Classes

class | AP4_RtpSampleData
class | AP4_RtpPacket
class | AP4_RtpConstructor
class | AP4_NoopRtpConstructor
class | AP4_ImmediateRtpConstructor
class | AP4_SampleRtpConstructor
class | AP4_SampleDescRtpConstructor
class | AP4_RtpConstructorFactory

Variables

const AP4_Size | AP4_RTP_CONSTRUCTOR_SIZE = 16
const AP4_RtpConstructor::Type | AP4_RTP_CONSTRUCTOR_TYPE_NOOP = 0
const AP4_RtpConstructor::Type | AP4_RTP_CONSTRUCTOR_TYPE_IMMEDIATE = 1
const AP4_RtpConstructor::Type | AP4_RTP_CONSTRUCTOR_TYPE_SAMPLE = 2
const AP4_RtpConstructor::Type | AP4_RTP_CONSTRUCTOR_TYPE_SAMPLE_DESC = 3

Variable Documentation

const AP4_Size AP4_RTP_CONSTRUCTOR_SIZE = 16

Definition at line 169 of file Ap4RtpHint.h.

const AP4_RtpConstructor::Type AP4_RTP_CONSTRUCTOR_TYPE_IMMEDIATE = 1

Definition at line 175 of file Ap4RtpHint.h.

const AP4_RtpConstructor::Type AP4_RTP_CONSTRUCTOR_TYPE_NOOP = 0

Definition at line 174 of file Ap4RtpHint.h.

const AP4_RtpConstructor::Type AP4_RTP_CONSTRUCTOR_TYPE_SAMPLE = 2

Definition at line 176 of file Ap4RtpHint.h.

const AP4_RtpConstructor::Type AP4_RTP_CONSTRUCTOR_TYPE_SAMPLE_DESC = 3

Definition at line 177 of file Ap4RtpHint.h.

Generated on Thu May 13 16:36:40 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4RtpHint.h Source File

  • File List
  • File Members

Ap4RtpHint.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - RTP Hint Objects
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027  ****************************************************************/
00028
00029 #ifndef _AP4_RTP_HINT_H_
00030 #define _AP4_RTP_HINT_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Types.h"
00036 #include "Ap4List.h"
00037 #include "Ap4DataBuffer.h"
00038 #include "Ap4Interfaces.h"
00039
00040 /*----------------------------------------------------------------------
00041 |   forward declarations
00042 +---------------------------------------------------------------------*/
00043 class AP4_ByteStream;
00044 class AP4_RtpConstructor;
00045 class AP4_RtpPacket;
00046
00047 /*----------------------------------------------------------------------
00048 |   AP4_RtpSampleData
00049 +---------------------------------------------------------------------*/
00050 class AP4_RtpSampleData
00051 {
00052 public:
00053     // constructors and destructor
00054     AP4_RtpSampleData(AP4_ByteStream& stream, AP4_UI32 size);
00055     AP4_RtpSampleData() {}
00056     virtual ~AP4_RtpSampleData();
00057
00058     // methods
00059     virtual AP4_Result          AddPacket(AP4_RtpPacket* packet);
00060     virtual AP4_Size            GetSize();
00061     virtual AP4_ByteStream*     ToByteStream();
00062
00063     // accessors
00064     AP4_List<AP4_RtpPacket>& GetPackets() {
00065         return m_Packets;
00066     }
00067     const AP4_DataBuffer& GetExtraData() const {
00068         return m_ExtraData;
00069     }
00070
00071 protected:
00072     // members
00073     AP4_List<AP4_RtpPacket>     m_Packets;
00074     AP4_DataBuffer              m_ExtraData;
00075 };
00076
00077 /*----------------------------------------------------------------------
00078 |   AP4_RtpPacket
00079 +---------------------------------------------------------------------*/
00080 class AP4_RtpPacket : public AP4_Referenceable
00081 {
00082 public:
00083     // constructor and destructor
00084     AP4_RtpPacket(AP4_ByteStream& stream);
00085     AP4_RtpPacket(int      relative_time,
00086                   bool     p_bit,
00087                   bool     x_bit,
00088                   bool     m_bit,
00089                   AP4_UI08 payload_type,
00090                   AP4_UI16 sequence_seed,
00091                   int      time_stamp_offset = 0,
00092                   bool     bframe_flag = false,
00093                   bool     repeat_flag = false);
00094     ~AP4_RtpPacket();
00095
00096     // methods
00097     AP4_Result Write(AP4_ByteStream& stream);
00098     AP4_Result AddConstructor(AP4_RtpConstructor* constructor);
00099     AP4_Size GetSize();
00100     AP4_Size GetConstructedDataSize();
00101
00102     // Referenceable methods
00103     void AddReference();
00104     void Release();
00105
00106     // Accessors
00107     int GetRelativeTime() const { return m_RelativeTime; }
00108     bool GetPBit() const { return m_PBit; }
00109     bool GetXBit() const { return m_XBit; }
00110     bool GetMBit() const { return m_MBit; }
00111     AP4_UI08 GetPayloadType() const { return m_PayloadType; }
00112     AP4_UI16 GetSequenceSeed() const { return m_SequenceSeed; }
00113     int  GetTimeStampOffset() const { return m_TimeStampOffset; }
00114     bool GetBFrameFlag() const { return m_BFrameFlag; }
00115     bool GetRepeatFlag() const { return m_RepeatFlag; }
00116     AP4_List<AP4_RtpConstructor>& GetConstructors() {
00117         return m_Constructors;
00118     }
00119
00120 private:
00121     // members
00122     AP4_Cardinal                    m_ReferenceCount;
00123     int                             m_RelativeTime;
00124     bool                            m_PBit;
00125     bool                            m_XBit;
00126     bool                            m_MBit;
00127     AP4_UI08                        m_PayloadType;
00128     AP4_UI16                        m_SequenceSeed;
00129     int                             m_TimeStampOffset;
00130     bool                            m_BFrameFlag;
00131     bool                            m_RepeatFlag;
00132     AP4_List<AP4_RtpConstructor>    m_Constructors;
00133 };
00134
00135 /*----------------------------------------------------------------------
00136 |   AP4_RtpContructor
00137 +---------------------------------------------------------------------*/
00138 class AP4_RtpConstructor : public AP4_Referenceable
00139 {
00140 public:
00141     // types
00142     typedef AP4_UI08 Type;
00143
00144     // constructor & destructor
00145     AP4_RtpConstructor(Type type) : m_ReferenceCount(1), m_Type(type) {}
00146
00147     // methods
00148     Type GetType() const { return m_Type; }
00149     AP4_Result Write(AP4_ByteStream& stream);
00150     virtual AP4_Size GetConstructedDataSize() = 0;
00151
00152     // Referenceable methods
00153     void AddReference();
00154     void Release();
00155
00156 protected:
00157     // methods
00158     virtual ~AP4_RtpConstructor() {}
00159     virtual AP4_Result DoWrite(AP4_ByteStream& stream) = 0;
00160
00161     // members
00162     AP4_Cardinal m_ReferenceCount;
00163     Type         m_Type;
00164 };
00165
00166 /*----------------------------------------------------------------------
00167 |   constructor size
00168 +---------------------------------------------------------------------*/
00169 const AP4_Size AP4_RTP_CONSTRUCTOR_SIZE = 16;
00170
00171 /*----------------------------------------------------------------------
00172 |   constructor types
00173 +---------------------------------------------------------------------*/
00174 const AP4_RtpConstructor::Type AP4_RTP_CONSTRUCTOR_TYPE_NOOP        = 0;
00175 const AP4_RtpConstructor::Type AP4_RTP_CONSTRUCTOR_TYPE_IMMEDIATE   = 1;
00176 const AP4_RtpConstructor::Type AP4_RTP_CONSTRUCTOR_TYPE_SAMPLE      = 2;
00177 const AP4_RtpConstructor::Type AP4_RTP_CONSTRUCTOR_TYPE_SAMPLE_DESC = 3;
00178
00179 /*----------------------------------------------------------------------
00180 |   AP4_NoopRtpConstructor
00181 +---------------------------------------------------------------------*/
00182 class AP4_NoopRtpConstructor : public AP4_RtpConstructor
00183 {
00184 public:
00185     // constructor
00186     AP4_NoopRtpConstructor(AP4_ByteStream& stream);
00187     AP4_NoopRtpConstructor() : AP4_RtpConstructor(AP4_RTP_CONSTRUCTOR_TYPE_NOOP) {}
00188
00189     // methods
00190     virtual AP4_Size GetConstructedDataSize() { return 0; }
00191
00192 protected:
00193     // methods
00194     virtual AP4_Result DoWrite(AP4_ByteStream& stream);
00195 };
00196
00197 /*----------------------------------------------------------------------
00198 |   AP4_ImmediateRtpConstructor
00199 +---------------------------------------------------------------------*/
00200 class AP4_ImmediateRtpConstructor : public AP4_RtpConstructor
00201 {
00202 public:
00203     // constructor
00204     AP4_ImmediateRtpConstructor(AP4_ByteStream& stream);
00205     AP4_ImmediateRtpConstructor(const AP4_DataBuffer& data);
00206
00207     // accessors
00208     const AP4_DataBuffer& GetData() const { return m_Data; }
00209
00210     // methods
00211     virtual AP4_Size GetConstructedDataSize() { return m_Data.GetDataSize(); }
00212
00213 protected:
00214     // methods
00215     virtual AP4_Result DoWrite(AP4_ByteStream& stream);
00216
00217     // members
00218     AP4_DataBuffer m_Data;
00219 };
00220
00221 /*----------------------------------------------------------------------
00222 |   AP4_SampleRtpConstructor
00223 +---------------------------------------------------------------------*/
00224 class AP4_SampleRtpConstructor : public AP4_RtpConstructor
00225 {
00226 public:
00227     // constructor
00228     AP4_SampleRtpConstructor(AP4_ByteStream& stream);
00229     AP4_SampleRtpConstructor(AP4_UI08 track_ref_index,
00230                              AP4_UI16 length,
00231                              AP4_UI32 sample_num,
00232                              AP4_UI32 sample_offset);
00233
00234     // accessors
00235     AP4_UI08 GetTrackRefIndex() const { return m_TrackRefIndex; }
00236     AP4_UI16 GetLength() const { return m_Length; }
00237     AP4_UI32 GetSampleNum() const { return m_SampleNum; }
00238     AP4_UI32 GetSampleOffset() const { return m_SampleOffset; }
00239
00240     // methods
00241     virtual AP4_Size GetConstructedDataSize() { return m_Length; }
00242
00243 protected:
00244     // methods
00245     virtual AP4_Result DoWrite(AP4_ByteStream& stream);
00246
00247     // members
00248     AP4_UI08    m_TrackRefIndex;
00249     AP4_UI16    m_Length;
00250     AP4_UI32    m_SampleNum;
00251     AP4_UI32    m_SampleOffset;
00252 };
00253
00254 /*----------------------------------------------------------------------
00255 |   AP4_SampleDescRtpConstructor
00256 +---------------------------------------------------------------------*/
00257 class AP4_SampleDescRtpConstructor : public AP4_RtpConstructor
00258 {
00259 public:
00260     // constructor
00261     AP4_SampleDescRtpConstructor(AP4_ByteStream& stream);
00262     AP4_SampleDescRtpConstructor(AP4_UI08 track_ref_index,
00263                                  AP4_UI16 length,
00264                                  AP4_UI32 sample_desc_index,
00265                                  AP4_UI32 sample_desc_offset);
00266
00267     // accessors
00268     AP4_UI08 GetTrackRefIndex() const { return m_TrackRefIndex; }
00269     AP4_UI16 GetLength() const { return m_Length; }
00270     AP4_UI32 GetSampleDescIndex() const { return m_SampleDescIndex; }
00271     AP4_UI32 GetSampleDescOffset() const { return m_SampleDescOffset; }
00272
00273     // methods
00274     virtual AP4_Size GetConstructedDataSize() { return m_Length; }
00275
00276 protected:
00277     // methods
00278     virtual AP4_Result DoWrite(AP4_ByteStream& stream);
00279
00280     // members
00281     AP4_UI08    m_TrackRefIndex;
00282     AP4_UI16    m_Length;
00283     AP4_UI32    m_SampleDescIndex;
00284     AP4_UI32    m_SampleDescOffset;
00285 };
00286
00287 /*----------------------------------------------------------------------
00288 |   AP4_RtpConstructorFactory
00289 +---------------------------------------------------------------------*/
00290 class AP4_RtpConstructorFactory
00291 {
00292 public:
00293     static AP4_Result CreateConstructorFromStream(AP4_ByteStream&      stream,
00294                                                   AP4_RtpConstructor*& constructor);
00295 };
00296
00297 #endif // _AP4_RTP_HINT_H_
Generated on Thu May 13 16:36:33 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4Sample.h File Reference

  • File List
  • File Members

Ap4Sample.h File Reference

#include "Ap4Types.h"

Go to the source code of this file.

Classes

class AP4_Sample
Generated on Thu May 13 16:36:40 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4Sample.h Source File

  • File List
  • File Members

Ap4Sample.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - Sample Objects
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027  ****************************************************************/
00028
00029 #ifndef _AP4_SAMPLE_H_
00030 #define _AP4_SAMPLE_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Types.h"
00036
00037 /*----------------------------------------------------------------------
00038 |   class references
00039 +---------------------------------------------------------------------*/
00040 class AP4_ByteStream;
00041 class AP4_DataBuffer;
00042
00043 /*----------------------------------------------------------------------
00044 |   AP4_Sample DO NOT DERIVE FROM THIS CLASS
00045 +---------------------------------------------------------------------*/
00046 class AP4_Sample
00047 {
00048 public:
00052     AP4_Sample();
00053
00057     AP4_Sample(const AP4_Sample& other);
00058
00075     AP4_Sample(AP4_ByteStream& data_stream,
00076                AP4_Position    offset,
00077                AP4_Size        size,
00078                AP4_UI32        duration,
00079                AP4_Ordinal     description_index,
00080                AP4_UI64        dts,
00081                AP4_UI32        cts_delta,
00082                bool            sync_flag);
00083
00084     ~AP4_Sample(); // not virtual on purpose: do not derive from it
00085
00086     // operators
00087     AP4_Sample&     operator=(const AP4_Sample& other);
00088
00089     // methods
00090     AP4_Result      ReadData(AP4_DataBuffer& data);
00091     AP4_Result      ReadData(AP4_DataBuffer& data,
00092                              AP4_Size        size,
00093                              AP4_Size        offset = 0);
00094
00095     // sample properties accessors
00096     AP4_ByteStream* GetDataStream();
00097     void            SetDataStream(AP4_ByteStream& stream);
00098     AP4_Position    GetOffset() const { return m_Offset; }
00099     void            SetOffset(AP4_Position offset) { m_Offset = offset; }
00100     AP4_Size        GetSize() { return m_Size; }
00101     void            SetSize(AP4_Size size) { m_Size = size; }
00102     AP4_Ordinal     GetDescriptionIndex() const { return m_DescriptionIndex; }
00103     void            SetDescriptionIndex(AP4_Ordinal index) { m_DescriptionIndex = index; }
00104
00108     AP4_UI64        GetDts() const { return m_Dts; }
00109
00113     void            SetDts(AP4_UI64 dts) { m_Dts = dts; }
00114
00118     AP4_UI64        GetCts() const { return m_Dts+m_CtsDelta; }
00119
00123     void            SetCts(AP4_UI64 cts) { m_CtsDelta = (cts > m_Dts) ? (AP4_UI32)(cts-m_Dts) : 0;  }
00124
00129     AP4_UI32        GetCtsDelta() const { return m_CtsDelta; }
00130
00135     void            SetCtsDelta(AP4_UI32 delta) { m_CtsDelta = (AP4_SI32)delta;  }
00136
00140     AP4_UI32        GetDuration() const { return m_Duration; }
00141
00145     void            SetDuration(AP4_UI32 duration) { m_Duration = duration; }
00146
00150     bool            IsSync() const { return m_IsSync; }
00151
00155     void            SetSync(bool is_sync) { m_IsSync = is_sync; }
00156
00160     void            Reset();
00161
00162 protected:
00163     AP4_ByteStream* m_DataStream;
00164     AP4_Position    m_Offset;
00165     AP4_Size        m_Size;
00166     AP4_UI32        m_Duration;
00167     AP4_Ordinal     m_DescriptionIndex;
00168     AP4_UI64        m_Dts;
00169     AP4_SI32        m_CtsDelta; // make this a signed value, because quicktime can use negative offsets
00170     bool            m_IsSync;
00171 };
00172
00173 #endif // _AP4_SAMPLE_H_
Generated on Thu May 13 16:36:33 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4SampleDescription.h File Reference

  • File List
  • File Members

Ap4SampleDescription.h File Reference

#include "Ap4Types.h"
#include "Ap4Atom.h"
#include "Ap4EsDescriptor.h"
#include "Ap4EsdsAtom.h"
#include "Ap4Array.h"
#include "Ap4AvccAtom.h"
#include "Ap4DynamicCast.h"

Go to the source code of this file.

Classes

class | AP4_SampleDescription
class | AP4_UnknownSampleDescription
class | AP4_AudioSampleDescription
class | AP4_VideoSampleDescription
class | AP4_GenericAudioSampleDescription
class | AP4_GenericVideoSampleDescription
class | AP4_AvcSampleDescription
class | AP4_MpegSampleDescription
class | AP4_MpegSystemSampleDescription
class | AP4_MpegAudioSampleDescription
class | AP4_MpegVideoSampleDescription

Defines

#define | AP4_SAMPLE_FORMAT_MP4A AP4_ATOM_TYPE('m','p','4','a')
#define | AP4_SAMPLE_FORMAT_MP4V AP4_ATOM_TYPE('m','p','4','v')
#define | AP4_SAMPLE_FORMAT_MP4S AP4_ATOM_TYPE('m','p','4','s')
#define | AP4_SAMPLE_FORMAT_AVC1 AP4_ATOM_TYPE('a','v','c','1')
#define | AP4_SAMPLE_FORMAT_ALAC AP4_ATOM_TYPE('a','l','a','c')
#define | AP4_SAMPLE_FORMAT_OWMA AP4_ATOM_TYPE('o','w','m','a')
#define | AP4_SAMPLE_FORMAT_OVC1 AP4_ATOM_TYPE('o','v','c','1')
#define | AP4_SAMPLE_FORMAT_AVCP AP4_ATOM_TYPE('a','v','c','p')
#define | AP4_SAMPLE_FORMAT_DRAC AP4_ATOM_TYPE('d','r','a','c')
#define | AP4_SAMPLE_FORMAT_DRA1 AP4_ATOM_TYPE('d','r','a','1')
#define | AP4_SAMPLE_FORMAT_AC_3 AP4_ATOM_TYPE('a','c','-','3')
#define | AP4_SAMPLE_FORMAT_EC_3 AP4_ATOM_TYPE('e','c','-','3')
#define | AP4_SAMPLE_FORMAT_G726 AP4_ATOM_TYPE('g','7','2','6')
#define | AP4_SAMPLE_FORMAT_MJP2 AP4_ATOM_TYPE('m','j','p','2')
#define | AP4_SAMPLE_FORMAT_OKSD AP4_ATOM_TYPE('o','k','s','d')
#define | AP4_SAMPLE_FORMAT_RAW_ AP4_ATOM_TYPE('r','a','w',' ')
#define | AP4_SAMPLE_FORMAT_RTP_ AP4_ATOM_TYPE('r','t','p',' ')
#define | AP4_SAMPLE_FORMAT_S263 AP4_ATOM_TYPE('s','2','6','3')
#define | AP4_SAMPLE_FORMAT_SAMR AP4_ATOM_TYPE('s','a','m','r')
#define | AP4_SAMPLE_FORMAT_SAWB AP4_ATOM_TYPE('s','a','w','b')
#define | AP4_SAMPLE_FORMAT_SAWP AP4_ATOM_TYPE('s','a','w','p')
#define | AP4_SAMPLE_FORMAT_SEVC AP4_ATOM_TYPE('s','e','v','c')
#define | AP4_SAMPLE_FORMAT_SQCP AP4_ATOM_TYPE('s','q','c','p')
#define | AP4_SAMPLE_FORMAT_SRTP AP4_ATOM_TYPE('s','r','t','p')
#define | AP4_SAMPLE_FORMAT_SSMV AP4_ATOM_TYPE('s','s','m','v')
#define | AP4_SAMPLE_FORMAT_TEXT AP4_ATOM_TYPE('t','e','t','x')
#define | AP4_SAMPLE_FORMAT_TWOS AP4_ATOM_TYPE('t','w','o','s')
#define | AP4_SAMPLE_FORMAT_TX3G AP4_ATOM_TYPE('t','x','3','g')
#define | AP4_SAMPLE_FORMAT_VC_1 AP4_ATOM_TYPE('v','c','-','1')
#define | AP4_SAMPLE_FORMAT_XML_ AP4_ATOM_TYPE('x','m','l',' ')

Functions

const char * | AP4_GetFormatName (AP4_UI32 format)

Variables

const
AP4_MpegSampleDescription::StreamType 		AP4_STREAM_TYPE_FORBIDDEN = 0x00
const
AP4_MpegSampleDescription::StreamType 		AP4_STREAM_TYPE_OD = 0x01
const
AP4_MpegSampleDescription::StreamType 		AP4_STREAM_TYPE_CR = 0x02
const
AP4_MpegSampleDescription::StreamType 		AP4_STREAM_TYPE_BIFS = 0x03
const
AP4_MpegSampleDescription::StreamType 		AP4_STREAM_TYPE_VISUAL = 0x04
const
AP4_MpegSampleDescription::StreamType 		AP4_STREAM_TYPE_AUDIO = 0x05
const
AP4_MpegSampleDescription::StreamType 		AP4_STREAM_TYPE_MPEG7 = 0x06
const
AP4_MpegSampleDescription::StreamType 		AP4_STREAM_TYPE_IPMP = 0x07
const
AP4_MpegSampleDescription::StreamType 		AP4_STREAM_TYPE_OCI = 0x08
const
AP4_MpegSampleDescription::StreamType 		AP4_STREAM_TYPE_MPEGJ = 0x09
const
AP4_MpegSampleDescription::StreamType 		AP4_STREAM_TYPE_TEXT = 0x0D
const
AP4_MpegSampleDescription::OTI 		AP4_OTI_MPEG4_SYSTEM = 0x01
const
AP4_MpegSampleDescription::OTI 		AP4_OTI_MPEG4_SYSTEM_COR = 0x02
const
AP4_MpegSampleDescription::OTI 		AP4_OTI_MPEG4_TEXT = 0x08
const
AP4_MpegSampleDescription::OTI 		AP4_OTI_MPEG4_VISUAL = 0x20
const
AP4_MpegSampleDescription::OTI 		AP4_OTI_MPEG4_AUDIO = 0x40
const
AP4_MpegSampleDescription::OTI 		AP4_OTI_MPEG2_VISUAL_SIMPLE = 0x60
const
AP4_MpegSampleDescription::OTI 		AP4_OTI_MPEG2_VISUAL_MAIN = 0x61
const
AP4_MpegSampleDescription::OTI 		AP4_OTI_MPEG2_VISUAL_SNR = 0x62
const
AP4_MpegSampleDescription::OTI 		AP4_OTI_MPEG2_VISUAL_SPATIAL = 0x63
const
AP4_MpegSampleDescription::OTI 		AP4_OTI_MPEG2_VISUAL_HIGH = 0x64
const
AP4_MpegSampleDescription::OTI 		AP4_OTI_MPEG2_VISUAL_422 = 0x65
const
AP4_MpegSampleDescription::OTI 		AP4_OTI_MPEG2_AAC_AUDIO_MAIN = 0x66
const
AP4_MpegSampleDescription::OTI 		AP4_OTI_MPEG2_AAC_AUDIO_LC = 0x67
const
AP4_MpegSampleDescription::OTI 		AP4_OTI_MPEG2_AAC_AUDIO_SSRP = 0x68
const
AP4_MpegSampleDescription::OTI 		AP4_OTI_MPEG2_PART3_AUDIO = 0x69
const
AP4_MpegSampleDescription::OTI 		AP4_OTI_MPEG1_VISUAL = 0x6A
const
AP4_MpegSampleDescription::OTI 		AP4_OTI_MPEG1_AUDIO = 0x6B
const
AP4_MpegSampleDescription::OTI 		AP4_OTI_JPEG = 0x6C
const AP4_UI08 | AP4_MPEG4_AUDIO_OBJECT_TYPE_AAC_MAIN = 1
AAC Main Profile.
const AP4_UI08 | AP4_MPEG4_AUDIO_OBJECT_TYPE_AAC_LC = 2
AAC Low Complexity.
const AP4_UI08 | AP4_MPEG4_AUDIO_OBJECT_TYPE_AAC_SSR = 3
AAC Scalable Sample Rate.
const AP4_UI08 | AP4_MPEG4_AUDIO_OBJECT_TYPE_AAC_LTP = 4
AAC Long Term Predictor.
const AP4_UI08 | AP4_MPEG4_AUDIO_OBJECT_TYPE_SBR = 5
Spectral Band Replication.
const AP4_UI08 | AP4_MPEG4_AUDIO_OBJECT_TYPE_AAC_SCALABLE = 6
AAC Scalable.
const AP4_UI08 | AP4_MPEG4_AUDIO_OBJECT_TYPE_TWINVQ = 7
Twin VQ.
const AP4_UI08 | AP4_MPEG4_AUDIO_OBJECT_TYPE_CELP = 8
CELP.
const AP4_UI08 | AP4_MPEG4_AUDIO_OBJECT_TYPE_HVXC = 9
HVXC.
const AP4_UI08 | AP4_MPEG4_AUDIO_OBJECT_TYPE_TTSI = 12
TTSI.
const AP4_UI08 | AP4_MPEG4_AUDIO_OBJECT_TYPE_MAIN_SYNTHETIC = 13
Main Synthetic.
const AP4_UI08 | AP4_MPEG4_AUDIO_OBJECT_TYPE_WAVETABLE_SYNTHESIS = 14
WavetableSynthesis.
const AP4_UI08 | AP4_MPEG4_AUDIO_OBJECT_TYPE_GENERAL_MIDI = 15
General MIDI.
const AP4_UI08 | AP4_MPEG4_AUDIO_OBJECT_TYPE_ALGORITHMIC_SYNTHESIS = 16
Algorithmic Synthesis.
const AP4_UI08 | AP4_MPEG4_AUDIO_OBJECT_TYPE_ER_AAC_LC = 17
Error Resilient AAC Low Complexity.
const AP4_UI08 | AP4_MPEG4_AUDIO_OBJECT_TYPE_ER_AAC_LTP = 19
Error Resilient AAC Long Term Prediction.
const AP4_UI08 | AP4_MPEG4_AUDIO_OBJECT_TYPE_ER_AAC_SCALABLE = 20
Error Resilient AAC Scalable.
const AP4_UI08 | AP4_MPEG4_AUDIO_OBJECT_TYPE_ER_TWINVQ = 21
Error Resilient Twin VQ.
const AP4_UI08 | AP4_MPEG4_AUDIO_OBJECT_TYPE_ER_BSAC = 22
Error Resilient Bit Sliced Arithmetic Coding.
const AP4_UI08 | AP4_MPEG4_AUDIO_OBJECT_TYPE_ER_AAC_LD = 23
Error Resilient AAC Low Delay.
const AP4_UI08 | AP4_MPEG4_AUDIO_OBJECT_TYPE_ER_CELP = 24
Error Resilient CELP.
const AP4_UI08 | AP4_MPEG4_AUDIO_OBJECT_TYPE_ER_HVXC = 25
Error Resilient HVXC.
const AP4_UI08 | AP4_MPEG4_AUDIO_OBJECT_TYPE_ER_HILN = 26
Error Resilient HILN.
const AP4_UI08 | AP4_MPEG4_AUDIO_OBJECT_TYPE_ER_PARAMETRIC = 27
Error Resilient Parametric.
const AP4_UI08 | AP4_MPEG4_AUDIO_OBJECT_TYPE_SSC = 28
SSC.
const AP4_UI08 | AP4_MPEG4_AUDIO_OBJECT_TYPE_PS = 29
Parametric Stereo.
const AP4_UI08 | AP4_MPEG4_AUDIO_OBJECT_TYPE_MPEG_SURROUND = 30
MPEG Surround.
const AP4_UI08 | AP4_MPEG4_AUDIO_OBJECT_TYPE_LAYER_1 = 32
MPEG Layer 1.
const AP4_UI08 | AP4_MPEG4_AUDIO_OBJECT_TYPE_LAYER_2 = 33
MPEG Layer 2.
const AP4_UI08 | AP4_MPEG4_AUDIO_OBJECT_TYPE_LAYER_3 = 34
MPEG Layer 3.
const AP4_UI08 | AP4_MPEG4_AUDIO_OBJECT_TYPE_DST = 35
DST Direct Stream Transfer.
const AP4_UI08 | AP4_MPEG4_AUDIO_OBJECT_TYPE_ALS = 36
ALS Lossless Coding.
const AP4_UI08 | AP4_MPEG4_AUDIO_OBJECT_TYPE_SLS = 37
SLS Scalable Lossless Coding.
const AP4_UI08 | AP4_MPEG4_AUDIO_OBJECT_TYPE_SLS_NON_CORE = 38
SLS Sclable Lossless Coding Non-Core.
const AP4_UI08 | AP4_MPEG4_AUDIO_OBJECT_TYPE_ER_AAC_ELD = 39
Error Resilient AAC ELD.
const AP4_UI08 | AP4_MPEG4_AUDIO_OBJECT_TYPE_SMR_SIMPLE = 40
SMR Simple.
const AP4_UI08 | AP4_MPEG4_AUDIO_OBJECT_TYPE_SMR_MAIN = 41
SMR Main.

Define Documentation

#define AP4_SAMPLE_FORMAT_AC_3 AP4_ATOM_TYPE('a','c','-','3')

Definition at line 62 of file Ap4SampleDescription.h.

#define AP4_SAMPLE_FORMAT_ALAC AP4_ATOM_TYPE('a','l','a','c')

Definition at line 56 of file Ap4SampleDescription.h.

#define AP4_SAMPLE_FORMAT_AVC1 AP4_ATOM_TYPE('a','v','c','1')

Definition at line 55 of file Ap4SampleDescription.h.

#define AP4_SAMPLE_FORMAT_AVCP AP4_ATOM_TYPE('a','v','c','p')

Definition at line 59 of file Ap4SampleDescription.h.

#define AP4_SAMPLE_FORMAT_DRA1 AP4_ATOM_TYPE('d','r','a','1')

Definition at line 61 of file Ap4SampleDescription.h.

#define AP4_SAMPLE_FORMAT_DRAC AP4_ATOM_TYPE('d','r','a','c')

Definition at line 60 of file Ap4SampleDescription.h.

#define AP4_SAMPLE_FORMAT_EC_3 AP4_ATOM_TYPE('e','c','-','3')

Definition at line 63 of file Ap4SampleDescription.h.

#define AP4_SAMPLE_FORMAT_G726 AP4_ATOM_TYPE('g','7','2','6')

Definition at line 64 of file Ap4SampleDescription.h.

#define AP4_SAMPLE_FORMAT_MJP2 AP4_ATOM_TYPE('m','j','p','2')

Definition at line 65 of file Ap4SampleDescription.h.

#define AP4_SAMPLE_FORMAT_MP4A AP4_ATOM_TYPE('m','p','4','a')

Definition at line 52 of file Ap4SampleDescription.h.

#define AP4_SAMPLE_FORMAT_MP4S AP4_ATOM_TYPE('m','p','4','s')

Definition at line 54 of file Ap4SampleDescription.h.

#define AP4_SAMPLE_FORMAT_MP4V AP4_ATOM_TYPE('m','p','4','v')

Definition at line 53 of file Ap4SampleDescription.h.

#define AP4_SAMPLE_FORMAT_OKSD AP4_ATOM_TYPE('o','k','s','d')

Definition at line 66 of file Ap4SampleDescription.h.

#define AP4_SAMPLE_FORMAT_OVC1 AP4_ATOM_TYPE('o','v','c','1')

Definition at line 58 of file Ap4SampleDescription.h.

#define AP4_SAMPLE_FORMAT_OWMA AP4_ATOM_TYPE('o','w','m','a')

Definition at line 57 of file Ap4SampleDescription.h.

#define AP4_SAMPLE_FORMAT_RAW_ AP4_ATOM_TYPE('r','a','w',' ')

Definition at line 67 of file Ap4SampleDescription.h.

#define AP4_SAMPLE_FORMAT_RTP_ AP4_ATOM_TYPE('r','t','p',' ')

Definition at line 68 of file Ap4SampleDescription.h.

#define AP4_SAMPLE_FORMAT_S263 AP4_ATOM_TYPE('s','2','6','3')

Definition at line 69 of file Ap4SampleDescription.h.

#define AP4_SAMPLE_FORMAT_SAMR AP4_ATOM_TYPE('s','a','m','r')

Definition at line 70 of file Ap4SampleDescription.h.

#define AP4_SAMPLE_FORMAT_SAWB AP4_ATOM_TYPE('s','a','w','b')

Definition at line 71 of file Ap4SampleDescription.h.

#define AP4_SAMPLE_FORMAT_SAWP AP4_ATOM_TYPE('s','a','w','p')

Definition at line 72 of file Ap4SampleDescription.h.

#define AP4_SAMPLE_FORMAT_SEVC AP4_ATOM_TYPE('s','e','v','c')

Definition at line 73 of file Ap4SampleDescription.h.

#define AP4_SAMPLE_FORMAT_SQCP AP4_ATOM_TYPE('s','q','c','p')

Definition at line 74 of file Ap4SampleDescription.h.

#define AP4_SAMPLE_FORMAT_SRTP AP4_ATOM_TYPE('s','r','t','p')

Definition at line 75 of file Ap4SampleDescription.h.

#define AP4_SAMPLE_FORMAT_SSMV AP4_ATOM_TYPE('s','s','m','v')

Definition at line 76 of file Ap4SampleDescription.h.

#define AP4_SAMPLE_FORMAT_TEXT AP4_ATOM_TYPE('t','e','t','x')

Definition at line 77 of file Ap4SampleDescription.h.

#define AP4_SAMPLE_FORMAT_TWOS AP4_ATOM_TYPE('t','w','o','s')

Definition at line 78 of file Ap4SampleDescription.h.

#define AP4_SAMPLE_FORMAT_TX3G AP4_ATOM_TYPE('t','x','3','g')

Definition at line 79 of file Ap4SampleDescription.h.

#define AP4_SAMPLE_FORMAT_VC_1 AP4_ATOM_TYPE('v','c','-','1')

Definition at line 80 of file Ap4SampleDescription.h.

#define AP4_SAMPLE_FORMAT_XML_ AP4_ATOM_TYPE('x','m','l',' ')

Definition at line 81 of file Ap4SampleDescription.h.

Function Documentation

const char* AP4_GetFormatName ( AP4_UI32 format )

Variable Documentation

const AP4_UI08 AP4_MPEG4_AUDIO_OBJECT_TYPE_AAC_LC = 2

AAC Low Complexity.

Definition at line 475 of file Ap4SampleDescription.h.

const AP4_UI08 AP4_MPEG4_AUDIO_OBJECT_TYPE_AAC_LTP = 4

AAC Long Term Predictor.

Definition at line 477 of file Ap4SampleDescription.h.

const AP4_UI08 AP4_MPEG4_AUDIO_OBJECT_TYPE_AAC_MAIN = 1

AAC Main Profile.

Definition at line 474 of file Ap4SampleDescription.h.

const AP4_UI08 AP4_MPEG4_AUDIO_OBJECT_TYPE_AAC_SCALABLE = 6

AAC Scalable.

Definition at line 479 of file Ap4SampleDescription.h.

const AP4_UI08 AP4_MPEG4_AUDIO_OBJECT_TYPE_AAC_SSR = 3

AAC Scalable Sample Rate.

Definition at line 476 of file Ap4SampleDescription.h.

const AP4_UI08 AP4_MPEG4_AUDIO_OBJECT_TYPE_ALGORITHMIC_SYNTHESIS = 16

Algorithmic Synthesis.

Definition at line 487 of file Ap4SampleDescription.h.

const AP4_UI08 AP4_MPEG4_AUDIO_OBJECT_TYPE_ALS = 36

ALS Lossless Coding.

Definition at line 505 of file Ap4SampleDescription.h.

const AP4_UI08 AP4_MPEG4_AUDIO_OBJECT_TYPE_CELP = 8

CELP.

Definition at line 481 of file Ap4SampleDescription.h.

const AP4_UI08 AP4_MPEG4_AUDIO_OBJECT_TYPE_DST = 35

DST Direct Stream Transfer.

Definition at line 504 of file Ap4SampleDescription.h.

const AP4_UI08 AP4_MPEG4_AUDIO_OBJECT_TYPE_ER_AAC_ELD = 39

Error Resilient AAC ELD.

Definition at line 508 of file Ap4SampleDescription.h.

const AP4_UI08 AP4_MPEG4_AUDIO_OBJECT_TYPE_ER_AAC_LC = 17

Error Resilient AAC Low Complexity.

Definition at line 488 of file Ap4SampleDescription.h.

const AP4_UI08 AP4_MPEG4_AUDIO_OBJECT_TYPE_ER_AAC_LD = 23

Error Resilient AAC Low Delay.

Definition at line 493 of file Ap4SampleDescription.h.

const AP4_UI08 AP4_MPEG4_AUDIO_OBJECT_TYPE_ER_AAC_LTP = 19

Error Resilient AAC Long Term Prediction.

Definition at line 489 of file Ap4SampleDescription.h.

const AP4_UI08 AP4_MPEG4_AUDIO_OBJECT_TYPE_ER_AAC_SCALABLE = 20

Error Resilient AAC Scalable.

Definition at line 490 of file Ap4SampleDescription.h.

const AP4_UI08 AP4_MPEG4_AUDIO_OBJECT_TYPE_ER_BSAC = 22

Error Resilient Bit Sliced Arithmetic Coding.

Definition at line 492 of file Ap4SampleDescription.h.

const AP4_UI08 AP4_MPEG4_AUDIO_OBJECT_TYPE_ER_CELP = 24

Error Resilient CELP.

Definition at line 494 of file Ap4SampleDescription.h.

const AP4_UI08 AP4_MPEG4_AUDIO_OBJECT_TYPE_ER_HILN = 26

Error Resilient HILN.

Definition at line 496 of file Ap4SampleDescription.h.

const AP4_UI08 AP4_MPEG4_AUDIO_OBJECT_TYPE_ER_HVXC = 25

Error Resilient HVXC.

Definition at line 495 of file Ap4SampleDescription.h.

const AP4_UI08 AP4_MPEG4_AUDIO_OBJECT_TYPE_ER_PARAMETRIC = 27

Error Resilient Parametric.

Definition at line 497 of file Ap4SampleDescription.h.

const AP4_UI08 AP4_MPEG4_AUDIO_OBJECT_TYPE_ER_TWINVQ = 21

Error Resilient Twin VQ.

Definition at line 491 of file Ap4SampleDescription.h.

const AP4_UI08 AP4_MPEG4_AUDIO_OBJECT_TYPE_GENERAL_MIDI = 15

General MIDI.

Definition at line 486 of file Ap4SampleDescription.h.

const AP4_UI08 AP4_MPEG4_AUDIO_OBJECT_TYPE_HVXC = 9

HVXC.

Definition at line 482 of file Ap4SampleDescription.h.

const AP4_UI08 AP4_MPEG4_AUDIO_OBJECT_TYPE_LAYER_1 = 32

MPEG Layer 1.

Definition at line 501 of file Ap4SampleDescription.h.

const AP4_UI08 AP4_MPEG4_AUDIO_OBJECT_TYPE_LAYER_2 = 33

MPEG Layer 2.

Definition at line 502 of file Ap4SampleDescription.h.

const AP4_UI08 AP4_MPEG4_AUDIO_OBJECT_TYPE_LAYER_3 = 34

MPEG Layer 3.

Definition at line 503 of file Ap4SampleDescription.h.

const AP4_UI08 AP4_MPEG4_AUDIO_OBJECT_TYPE_MAIN_SYNTHETIC = 13

Main Synthetic.

Definition at line 484 of file Ap4SampleDescription.h.

const AP4_UI08 AP4_MPEG4_AUDIO_OBJECT_TYPE_MPEG_SURROUND = 30

MPEG Surround.

Definition at line 500 of file Ap4SampleDescription.h.

const AP4_UI08 AP4_MPEG4_AUDIO_OBJECT_TYPE_PS = 29

Parametric Stereo.

Definition at line 499 of file Ap4SampleDescription.h.

const AP4_UI08 AP4_MPEG4_AUDIO_OBJECT_TYPE_SBR = 5

Spectral Band Replication.

Definition at line 478 of file Ap4SampleDescription.h.

const AP4_UI08 AP4_MPEG4_AUDIO_OBJECT_TYPE_SLS = 37

SLS Scalable Lossless Coding.

Definition at line 506 of file Ap4SampleDescription.h.

const AP4_UI08 AP4_MPEG4_AUDIO_OBJECT_TYPE_SLS_NON_CORE = 38

SLS Sclable Lossless Coding Non-Core.

Definition at line 507 of file Ap4SampleDescription.h.

const AP4_UI08 AP4_MPEG4_AUDIO_OBJECT_TYPE_SMR_MAIN = 41

SMR Main.

Definition at line 510 of file Ap4SampleDescription.h.

const AP4_UI08 AP4_MPEG4_AUDIO_OBJECT_TYPE_SMR_SIMPLE = 40

SMR Simple.

Definition at line 509 of file Ap4SampleDescription.h.

const AP4_UI08 AP4_MPEG4_AUDIO_OBJECT_TYPE_SSC = 28

SSC.

Definition at line 498 of file Ap4SampleDescription.h.

const AP4_UI08 AP4_MPEG4_AUDIO_OBJECT_TYPE_TTSI = 12

TTSI.

Definition at line 483 of file Ap4SampleDescription.h.

const AP4_UI08 AP4_MPEG4_AUDIO_OBJECT_TYPE_TWINVQ = 7

Twin VQ.

Definition at line 480 of file Ap4SampleDescription.h.

const AP4_UI08 AP4_MPEG4_AUDIO_OBJECT_TYPE_WAVETABLE_SYNTHESIS = 14

WavetableSynthesis.

Definition at line 485 of file Ap4SampleDescription.h.

const AP4_MpegSampleDescription::OTI AP4_OTI_JPEG = 0x6C

Definition at line 472 of file Ap4SampleDescription.h.

const AP4_MpegSampleDescription::OTI AP4_OTI_MPEG1_AUDIO = 0x6B

Definition at line 471 of file Ap4SampleDescription.h.

const AP4_MpegSampleDescription::OTI AP4_OTI_MPEG1_VISUAL = 0x6A

Definition at line 470 of file Ap4SampleDescription.h.

const AP4_MpegSampleDescription::OTI AP4_OTI_MPEG2_AAC_AUDIO_LC = 0x67

Definition at line 467 of file Ap4SampleDescription.h.

const AP4_MpegSampleDescription::OTI AP4_OTI_MPEG2_AAC_AUDIO_MAIN = 0x66

Definition at line 466 of file Ap4SampleDescription.h.

const AP4_MpegSampleDescription::OTI AP4_OTI_MPEG2_AAC_AUDIO_SSRP = 0x68

Definition at line 468 of file Ap4SampleDescription.h.

const AP4_MpegSampleDescription::OTI AP4_OTI_MPEG2_PART3_AUDIO = 0x69

Definition at line 469 of file Ap4SampleDescription.h.

const AP4_MpegSampleDescription::OTI AP4_OTI_MPEG2_VISUAL_422 = 0x65

Definition at line 465 of file Ap4SampleDescription.h.

const AP4_MpegSampleDescription::OTI AP4_OTI_MPEG2_VISUAL_HIGH = 0x64

Definition at line 464 of file Ap4SampleDescription.h.

const AP4_MpegSampleDescription::OTI AP4_OTI_MPEG2_VISUAL_MAIN = 0x61

Definition at line 461 of file Ap4SampleDescription.h.

const AP4_MpegSampleDescription::OTI AP4_OTI_MPEG2_VISUAL_SIMPLE = 0x60

Definition at line 460 of file Ap4SampleDescription.h.

const AP4_MpegSampleDescription::OTI AP4_OTI_MPEG2_VISUAL_SNR = 0x62

Definition at line 462 of file Ap4SampleDescription.h.

const AP4_MpegSampleDescription::OTI AP4_OTI_MPEG2_VISUAL_SPATIAL = 0x63

Definition at line 463 of file Ap4SampleDescription.h.

const AP4_MpegSampleDescription::OTI AP4_OTI_MPEG4_AUDIO = 0x40

Definition at line 459 of file Ap4SampleDescription.h.

const AP4_MpegSampleDescription::OTI AP4_OTI_MPEG4_SYSTEM = 0x01

Definition at line 455 of file Ap4SampleDescription.h.

const AP4_MpegSampleDescription::OTI AP4_OTI_MPEG4_SYSTEM_COR = 0x02

Definition at line 456 of file Ap4SampleDescription.h.

const AP4_MpegSampleDescription::OTI AP4_OTI_MPEG4_TEXT = 0x08

Definition at line 457 of file Ap4SampleDescription.h.

const AP4_MpegSampleDescription::OTI AP4_OTI_MPEG4_VISUAL = 0x20

Definition at line 458 of file Ap4SampleDescription.h.

const AP4_MpegSampleDescription::StreamType AP4_STREAM_TYPE_AUDIO = 0x05

Definition at line 448 of file Ap4SampleDescription.h.

const AP4_MpegSampleDescription::StreamType AP4_STREAM_TYPE_BIFS = 0x03

Definition at line 446 of file Ap4SampleDescription.h.

const AP4_MpegSampleDescription::StreamType AP4_STREAM_TYPE_CR = 0x02

Definition at line 445 of file Ap4SampleDescription.h.

const AP4_MpegSampleDescription::StreamType AP4_STREAM_TYPE_FORBIDDEN = 0x00

Definition at line 443 of file Ap4SampleDescription.h.

const AP4_MpegSampleDescription::StreamType AP4_STREAM_TYPE_IPMP = 0x07

Definition at line 450 of file Ap4SampleDescription.h.

const AP4_MpegSampleDescription::StreamType AP4_STREAM_TYPE_MPEG7 = 0x06

Definition at line 449 of file Ap4SampleDescription.h.

const AP4_MpegSampleDescription::StreamType AP4_STREAM_TYPE_MPEGJ = 0x09

Definition at line 452 of file Ap4SampleDescription.h.

const AP4_MpegSampleDescription::StreamType AP4_STREAM_TYPE_OCI = 0x08

Definition at line 451 of file Ap4SampleDescription.h.

const AP4_MpegSampleDescription::StreamType AP4_STREAM_TYPE_OD = 0x01

Definition at line 444 of file Ap4SampleDescription.h.

const AP4_MpegSampleDescription::StreamType AP4_STREAM_TYPE_TEXT = 0x0D

Definition at line 453 of file Ap4SampleDescription.h.

const AP4_MpegSampleDescription::StreamType AP4_STREAM_TYPE_VISUAL = 0x04

Definition at line 447 of file Ap4SampleDescription.h.

Generated on Thu May 13 16:36:40 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4SampleDescription.h Source File

  • File List
  • File Members

Ap4SampleDescription.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - Sample Descriptions
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027  ****************************************************************/
00028
00029 #ifndef _AP4_SAMPLE_DESCRIPTION_H_
00030 #define _AP4_SAMPLE_DESCRIPTION_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Types.h"
00036 #include "Ap4Atom.h"
00037 #include "Ap4EsDescriptor.h"
00038 #include "Ap4EsdsAtom.h"
00039 #include "Ap4Array.h"
00040 #include "Ap4AvccAtom.h"
00041 #include "Ap4DynamicCast.h"
00042
00043 /*----------------------------------------------------------------------
00044 |   class references
00045 +---------------------------------------------------------------------*/
00046 class AP4_SampleEntry;
00047 class AP4_DataBuffer;
00048
00049 /*----------------------------------------------------------------------
00050 |   constants
00051 +---------------------------------------------------------------------*/
00052 #define AP4_SAMPLE_FORMAT_MP4A AP4_ATOM_TYPE('m','p','4','a')
00053 #define AP4_SAMPLE_FORMAT_MP4V AP4_ATOM_TYPE('m','p','4','v')
00054 #define AP4_SAMPLE_FORMAT_MP4S AP4_ATOM_TYPE('m','p','4','s')
00055 #define AP4_SAMPLE_FORMAT_AVC1 AP4_ATOM_TYPE('a','v','c','1')
00056 #define AP4_SAMPLE_FORMAT_ALAC AP4_ATOM_TYPE('a','l','a','c')
00057 #define AP4_SAMPLE_FORMAT_OWMA AP4_ATOM_TYPE('o','w','m','a')
00058 #define AP4_SAMPLE_FORMAT_OVC1 AP4_ATOM_TYPE('o','v','c','1')
00059 #define AP4_SAMPLE_FORMAT_AVCP AP4_ATOM_TYPE('a','v','c','p')
00060 #define AP4_SAMPLE_FORMAT_DRAC AP4_ATOM_TYPE('d','r','a','c')
00061 #define AP4_SAMPLE_FORMAT_DRA1 AP4_ATOM_TYPE('d','r','a','1')
00062 #define AP4_SAMPLE_FORMAT_AC_3 AP4_ATOM_TYPE('a','c','-','3')
00063 #define AP4_SAMPLE_FORMAT_EC_3 AP4_ATOM_TYPE('e','c','-','3')
00064 #define AP4_SAMPLE_FORMAT_G726 AP4_ATOM_TYPE('g','7','2','6')
00065 #define AP4_SAMPLE_FORMAT_MJP2 AP4_ATOM_TYPE('m','j','p','2')
00066 #define AP4_SAMPLE_FORMAT_OKSD AP4_ATOM_TYPE('o','k','s','d')
00067 #define AP4_SAMPLE_FORMAT_RAW_ AP4_ATOM_TYPE('r','a','w',' ')
00068 #define AP4_SAMPLE_FORMAT_RTP_ AP4_ATOM_TYPE('r','t','p',' ')
00069 #define AP4_SAMPLE_FORMAT_S263 AP4_ATOM_TYPE('s','2','6','3')
00070 #define AP4_SAMPLE_FORMAT_SAMR AP4_ATOM_TYPE('s','a','m','r')
00071 #define AP4_SAMPLE_FORMAT_SAWB AP4_ATOM_TYPE('s','a','w','b')
00072 #define AP4_SAMPLE_FORMAT_SAWP AP4_ATOM_TYPE('s','a','w','p')
00073 #define AP4_SAMPLE_FORMAT_SEVC AP4_ATOM_TYPE('s','e','v','c')
00074 #define AP4_SAMPLE_FORMAT_SQCP AP4_ATOM_TYPE('s','q','c','p')
00075 #define AP4_SAMPLE_FORMAT_SRTP AP4_ATOM_TYPE('s','r','t','p')
00076 #define AP4_SAMPLE_FORMAT_SSMV AP4_ATOM_TYPE('s','s','m','v')
00077 #define AP4_SAMPLE_FORMAT_TEXT AP4_ATOM_TYPE('t','e','t','x')
00078 #define AP4_SAMPLE_FORMAT_TWOS AP4_ATOM_TYPE('t','w','o','s')
00079 #define AP4_SAMPLE_FORMAT_TX3G AP4_ATOM_TYPE('t','x','3','g')
00080 #define AP4_SAMPLE_FORMAT_VC_1 AP4_ATOM_TYPE('v','c','-','1')
00081 #define AP4_SAMPLE_FORMAT_XML_ AP4_ATOM_TYPE('x','m','l',' ')
00082
00083 const char*
00084 AP4_GetFormatName(AP4_UI32 format);
00085
00086 /*----------------------------------------------------------------------
00087 |   AP4_SampleDescription
00088 +---------------------------------------------------------------------*/
00089 class AP4_SampleDescription
00090 {
00091  public:
00092     AP4_IMPLEMENT_DYNAMIC_CAST(AP4_SampleDescription)
00093
00094     // type constants of the sample description
00095     enum Type {
00096         TYPE_UNKNOWN   = 0x00,
00097         TYPE_MPEG      = 0x01,
00098         TYPE_PROTECTED = 0x02,
00099         TYPE_AVC       = 0x03
00100     };
00101
00102     // constructors & destructor
00103     AP4_SampleDescription(Type            type,
00104                           AP4_UI32        format,
00105                           AP4_AtomParent* details);
00106     virtual ~AP4_SampleDescription() {}
00107     virtual AP4_SampleDescription* Clone(AP4_Result* result = NULL);
00108
00109     // accessors
00110     Type            GetType()   const { return m_Type;    }
00111     AP4_UI32        GetFormat() const { return m_Format;  }
00112     AP4_AtomParent& GetDetails()      { return m_Details; }
00113
00114     // factories
00115     virtual AP4_Atom* ToAtom() const;
00116
00117  protected:
00118     Type           m_Type;
00119     AP4_UI32       m_Format;
00120     AP4_AtomParent m_Details;
00121 };
00122
00123 /*----------------------------------------------------------------------
00124 |   AP4_UnknownSampleDescription
00125 +---------------------------------------------------------------------*/
00126 class AP4_UnknownSampleDescription : public AP4_SampleDescription
00127 {
00128 public:
00129     AP4_IMPLEMENT_DYNAMIC_CAST_D(AP4_UnknownSampleDescription, AP4_SampleDescription)
00130
00131     // this constructor takes makes a copy of the atom passed as an argument
00132     AP4_UnknownSampleDescription(AP4_Atom* atom);
00133     ~AP4_UnknownSampleDescription();
00134
00135     virtual AP4_SampleDescription* Clone(AP4_Result* result);
00136     virtual AP4_Atom* ToAtom() const;
00137
00138     // accessor
00139     const AP4_Atom* GetAtom() { return m_Atom; }
00140
00141 private:
00142     AP4_Atom* m_Atom;
00143 };
00144
00145 /*----------------------------------------------------------------------
00146 |   AP4_AudioSampleDescription  // MIXIN class
00147 +---------------------------------------------------------------------*/
00148 class AP4_AudioSampleDescription
00149 {
00150 public:
00151     AP4_IMPLEMENT_DYNAMIC_CAST(AP4_AudioSampleDescription)
00152
00153     // constructor
00154     AP4_AudioSampleDescription(unsigned int sample_rate,
00155                                unsigned int sample_size,
00156                                unsigned int channel_count) :
00157     m_SampleRate(sample_rate),
00158     m_SampleSize(sample_size),
00159     m_ChannelCount(channel_count) {}
00160
00161     // accessors
00162     AP4_UI32 GetSampleRate()   { return m_SampleRate;   }
00163     AP4_UI16 GetSampleSize()   { return m_SampleSize;   }
00164     AP4_UI16 GetChannelCount() { return m_ChannelCount; }
00165
00166 protected:
00167     // members
00168     AP4_UI32 m_SampleRate;
00169     AP4_UI16 m_SampleSize;
00170     AP4_UI16 m_ChannelCount;
00171 };
00172
00173 /*----------------------------------------------------------------------
00174 |   AP4_VideoSampleDescription  // MIXIN class
00175 +---------------------------------------------------------------------*/
00176 class AP4_VideoSampleDescription
00177 {
00178 public:
00179     AP4_IMPLEMENT_DYNAMIC_CAST(AP4_VideoSampleDescription)
00180
00181     // constructor
00182     AP4_VideoSampleDescription(AP4_UI16    width,
00183                                AP4_UI16    height,
00184                                AP4_UI16    depth,
00185                                const char* compressor_name) :
00186     m_Width(width),
00187     m_Height(height),
00188     m_Depth(depth),
00189     m_CompressorName(compressor_name) {}
00190
00191     // accessors
00192     AP4_UI16    GetWidth()          { return m_Width;  }
00193     AP4_UI16    GetHeight()         { return m_Height; }
00194     AP4_UI16    GetDepth()          { return m_Depth;  }
00195     const char* GetCompressorName() { return m_CompressorName.GetChars(); }
00196
00197 protected:
00198     // members
00199     AP4_UI16   m_Width;
00200     AP4_UI16   m_Height;
00201     AP4_UI16   m_Depth;
00202     AP4_String m_CompressorName;
00203 };
00204
00205 /*----------------------------------------------------------------------
00206 |   AP4_GenericAudioSampleDescription
00207 +---------------------------------------------------------------------*/
00208 class AP4_GenericAudioSampleDescription : public AP4_SampleDescription,
00209                                           public AP4_AudioSampleDescription
00210 {
00211 public:
00212     AP4_IMPLEMENT_DYNAMIC_CAST_D2(AP4_GenericAudioSampleDescription, AP4_SampleDescription, AP4_AudioSampleDescription)
00213
00214     // constructors
00215     AP4_GenericAudioSampleDescription(AP4_UI32        format,
00216                                       unsigned int    sample_rate,
00217                                       unsigned int    sample_size,
00218                                       unsigned int    channel_count,
00219                                       AP4_AtomParent* details) :
00220         AP4_SampleDescription(TYPE_UNKNOWN, format, details),
00221         AP4_AudioSampleDescription(sample_rate, sample_size, channel_count) {}
00222 };
00223
00224 /*----------------------------------------------------------------------
00225 |   AP4_GenericVideoSampleDescription
00226 +---------------------------------------------------------------------*/
00227 class AP4_GenericVideoSampleDescription : public AP4_SampleDescription,
00228                                           public AP4_VideoSampleDescription
00229 {
00230 public:
00231     AP4_IMPLEMENT_DYNAMIC_CAST_D2(AP4_GenericVideoSampleDescription, AP4_SampleDescription, AP4_VideoSampleDescription)
00232
00233     // constructor
00234     AP4_GenericVideoSampleDescription(AP4_UI32        format,
00235                                       AP4_UI16        width,
00236                                       AP4_UI16        height,
00237                                       AP4_UI16        depth,
00238                                       const char*     compressor_name,
00239                                       AP4_AtomParent* details) :
00240     AP4_SampleDescription(TYPE_UNKNOWN, format, details),
00241     AP4_VideoSampleDescription(width, height, depth, compressor_name) {}
00242 };
00243
00244 /*----------------------------------------------------------------------
00245 |   AP4_AvcSampleDescription
00246 +---------------------------------------------------------------------*/
00247 class AP4_AvcSampleDescription : public AP4_SampleDescription,
00248                                  public AP4_VideoSampleDescription
00249 {
00250 public:
00251     AP4_IMPLEMENT_DYNAMIC_CAST_D2(AP4_AvcSampleDescription, AP4_SampleDescription, AP4_VideoSampleDescription)
00252
00253     // constructors
00254     AP4_AvcSampleDescription(AP4_UI16            width,
00255                              AP4_UI16            height,
00256                              AP4_UI16            depth,
00257                              const char*         compressor_name,
00258                              const AP4_AvccAtom* avcc);
00259
00260     AP4_AvcSampleDescription(AP4_UI16        width,
00261                              AP4_UI16        height,
00262                              AP4_UI16        depth,
00263                              const char*     compressor_name,
00264                              AP4_AtomParent* details);
00265
00266     AP4_AvcSampleDescription(AP4_UI16                         width,
00267                              AP4_UI16                         height,
00268                              AP4_UI16                         depth,
00269                              const char*                      compressor_name,
00270                              AP4_UI08                         profile,
00271                              AP4_UI08                         level,
00272                              AP4_UI08                         profile_compatibility,
00273                              AP4_UI08                         nalu_length_size,
00274                              const AP4_Array<AP4_DataBuffer>& sequence_parameters,
00275                              const AP4_Array<AP4_DataBuffer>& picture_parameters);
00276
00277     // accessors
00278     AP4_UI08 GetConfigurationVersion() const { return m_AvccAtom->GetConfigurationVersion(); }
00279     AP4_UI08 GetProfile() const { return m_AvccAtom->GetProfile(); }
00280     AP4_UI08 GetLevel() const { return m_AvccAtom->GetLevel(); }
00281     AP4_UI08 GetProfileCompatibility() const { return m_AvccAtom->GetProfileCompatibility(); }
00282     AP4_UI08 GetNaluLengthSize() const { return m_AvccAtom->GetNaluLengthSize(); }
00283     AP4_Array<AP4_DataBuffer>& GetSequenceParameters() {return m_AvccAtom->GetSequenceParameters(); }
00284     AP4_Array<AP4_DataBuffer>& GetPictureParameters() { return m_AvccAtom->GetPictureParameters(); }
00285     const AP4_DataBuffer& GetRawBytes() const { return m_AvccAtom->GetRawBytes(); }
00286
00287     // inherited from AP4_SampleDescription
00288     virtual AP4_Atom* ToAtom() const;
00289
00290     // static methods
00291     static const char* GetProfileName(AP4_UI08 profile) {
00292         return AP4_AvccAtom::GetProfileName(profile);
00293     }
00294
00295 private:
00296     AP4_AvccAtom* m_AvccAtom;
00297 };
00298
00299 /*----------------------------------------------------------------------
00300 |   AP4_MpegSampleDescription
00301 +---------------------------------------------------------------------*/
00302 class AP4_MpegSampleDescription : public AP4_SampleDescription
00303 {
00304  public:
00305     AP4_IMPLEMENT_DYNAMIC_CAST_D(AP4_MpegSampleDescription, AP4_SampleDescription)
00306
00307     // types
00308     typedef AP4_UI08 StreamType;
00309     typedef AP4_UI08 OTI;
00310
00311     // class methods
00312     static const char* GetStreamTypeString(StreamType type);
00313     static const char* GetObjectTypeString(OTI oti);
00314
00315     // constructors & destructor
00316     AP4_MpegSampleDescription(AP4_UI32      format,
00317                               AP4_EsdsAtom* esds);
00318     AP4_MpegSampleDescription(AP4_UI32              format,
00319                               StreamType            stream_type,
00320                               OTI                   oti,
00321                               const AP4_DataBuffer* decoder_info,
00322                               AP4_UI32              buffer_size,
00323                               AP4_UI32              max_bitrate,
00324                               AP4_UI32              avg_bitrate);
00325
00326     // accessors
00327     AP4_Byte GetStreamType()   const { return m_StreamType; }
00328     AP4_Byte GetObjectTypeId() const { return m_ObjectTypeId; }
00329     AP4_UI32 GetBufferSize()   const { return m_BufferSize; }
00330     AP4_UI32 GetMaxBitrate()   const { return m_MaxBitrate; }
00331     AP4_UI32 GetAvgBitrate()   const { return m_AvgBitrate; }
00332     const AP4_DataBuffer& GetDecoderInfo() const { return m_DecoderInfo; }
00333
00334     // methods
00335     AP4_EsDescriptor* CreateEsDescriptor() const;
00336
00337  protected:
00338     // members
00339     AP4_UI32       m_Format;
00340     StreamType     m_StreamType;
00341     OTI            m_ObjectTypeId;
00342     AP4_UI32       m_BufferSize;
00343     AP4_UI32       m_MaxBitrate;
00344     AP4_UI32       m_AvgBitrate;
00345     AP4_DataBuffer m_DecoderInfo;
00346 };
00347
00348 /*----------------------------------------------------------------------
00349 |   AP4_MpegSystemSampleDescription
00350 +---------------------------------------------------------------------*/
00351 class AP4_MpegSystemSampleDescription : public AP4_MpegSampleDescription
00352 {
00353 public:
00354     AP4_IMPLEMENT_DYNAMIC_CAST_D(AP4_MpegSystemSampleDescription, AP4_MpegSampleDescription)
00355
00356     // constructor
00357     AP4_MpegSystemSampleDescription(AP4_EsdsAtom* esds);
00358     AP4_MpegSystemSampleDescription(StreamType            stream_type,
00359                                     OTI                   oti,
00360                                     const AP4_DataBuffer* decoder_info,
00361                                     AP4_UI32              buffer_size,
00362                                     AP4_UI32              max_bitrate,
00363                                     AP4_UI32              avg_bitrate);
00364
00365     // methods
00366     AP4_Atom* ToAtom() const;
00367 };
00368
00369 /*----------------------------------------------------------------------
00370 |   AP4_MpegAudioSampleDescription
00371 +---------------------------------------------------------------------*/
00372 class AP4_MpegAudioSampleDescription : public AP4_MpegSampleDescription,
00373                                        public AP4_AudioSampleDescription
00374 {
00375 public:
00376     AP4_IMPLEMENT_DYNAMIC_CAST_D2(AP4_MpegAudioSampleDescription, AP4_MpegSampleDescription, AP4_AudioSampleDescription)
00377
00378     // types
00379     typedef AP4_UI08 Mpeg4AudioObjectType;
00380
00381     // class methods
00382     static const char* GetMpeg4AudioObjectTypeString(Mpeg4AudioObjectType type);
00383
00384     // constructor
00385     AP4_MpegAudioSampleDescription(unsigned int  sample_rate,
00386                                    unsigned int  sample_size,
00387                                    unsigned int  channel_count,
00388                                    AP4_EsdsAtom* esds);
00389
00390     AP4_MpegAudioSampleDescription(OTI                   oti,
00391                                    unsigned int          sample_rate,
00392                                    unsigned int          sample_size,
00393                                    unsigned int          channel_count,
00394                                    const AP4_DataBuffer* decoder_info,
00395                                    AP4_UI32              buffer_size,
00396                                    AP4_UI32              max_bitrate,
00397                                    AP4_UI32              avg_bitrate);
00398
00399     // methods
00400     AP4_Atom* ToAtom() const;
00401
00407     Mpeg4AudioObjectType GetMpeg4AudioObjectType() const;
00408 };
00409
00410 /*----------------------------------------------------------------------
00411 |   AP4_MpegVideoSampleDescription
00412 +---------------------------------------------------------------------*/
00413 class AP4_MpegVideoSampleDescription : public AP4_MpegSampleDescription,
00414                                        public AP4_VideoSampleDescription
00415 {
00416 public:
00417     AP4_IMPLEMENT_DYNAMIC_CAST_D2(AP4_MpegVideoSampleDescription, AP4_MpegSampleDescription, AP4_VideoSampleDescription)
00418
00419     // constructor
00420     AP4_MpegVideoSampleDescription(AP4_UI16      width,
00421                                    AP4_UI16      height,
00422                                    AP4_UI16      depth,
00423                                    const char*   compressor_name,
00424                                    AP4_EsdsAtom* esds);
00425
00426     AP4_MpegVideoSampleDescription(OTI                   oti,
00427                                    AP4_UI16              width,
00428                                    AP4_UI16              height,
00429                                    AP4_UI16              depth,
00430                                    const char*           compressor_name,
00431                                    const AP4_DataBuffer* decoder_info,
00432                                    AP4_UI32              buffer_size,
00433                                    AP4_UI32              max_bitrate,
00434                                    AP4_UI32              avg_bitrate);
00435
00436     // methods
00437     AP4_Atom* ToAtom() const;
00438 };
00439
00440 /*----------------------------------------------------------------------
00441 |   constants
00442 +---------------------------------------------------------------------*/
00443 const AP4_MpegSampleDescription::StreamType AP4_STREAM_TYPE_FORBIDDEN = 0x00;
00444 const AP4_MpegSampleDescription::StreamType AP4_STREAM_TYPE_OD        = 0x01;
00445 const AP4_MpegSampleDescription::StreamType AP4_STREAM_TYPE_CR        = 0x02;
00446 const AP4_MpegSampleDescription::StreamType AP4_STREAM_TYPE_BIFS      = 0x03;
00447 const AP4_MpegSampleDescription::StreamType AP4_STREAM_TYPE_VISUAL    = 0x04;
00448 const AP4_MpegSampleDescription::StreamType AP4_STREAM_TYPE_AUDIO     = 0x05;
00449 const AP4_MpegSampleDescription::StreamType AP4_STREAM_TYPE_MPEG7     = 0x06;
00450 const AP4_MpegSampleDescription::StreamType AP4_STREAM_TYPE_IPMP      = 0x07;
00451 const AP4_MpegSampleDescription::StreamType AP4_STREAM_TYPE_OCI       = 0x08;
00452 const AP4_MpegSampleDescription::StreamType AP4_STREAM_TYPE_MPEGJ     = 0x09;
00453 const AP4_MpegSampleDescription::StreamType AP4_STREAM_TYPE_TEXT      = 0x0D;
00454
00455 const AP4_MpegSampleDescription::OTI AP4_OTI_MPEG4_SYSTEM         = 0x01;
00456 const AP4_MpegSampleDescription::OTI AP4_OTI_MPEG4_SYSTEM_COR     = 0x02;
00457 const AP4_MpegSampleDescription::OTI AP4_OTI_MPEG4_TEXT           = 0x08;
00458 const AP4_MpegSampleDescription::OTI AP4_OTI_MPEG4_VISUAL         = 0x20;
00459 const AP4_MpegSampleDescription::OTI AP4_OTI_MPEG4_AUDIO          = 0x40;
00460 const AP4_MpegSampleDescription::OTI AP4_OTI_MPEG2_VISUAL_SIMPLE  = 0x60;
00461 const AP4_MpegSampleDescription::OTI AP4_OTI_MPEG2_VISUAL_MAIN    = 0x61;
00462 const AP4_MpegSampleDescription::OTI AP4_OTI_MPEG2_VISUAL_SNR     = 0x62;
00463 const AP4_MpegSampleDescription::OTI AP4_OTI_MPEG2_VISUAL_SPATIAL = 0x63;
00464 const AP4_MpegSampleDescription::OTI AP4_OTI_MPEG2_VISUAL_HIGH    = 0x64;
00465 const AP4_MpegSampleDescription::OTI AP4_OTI_MPEG2_VISUAL_422     = 0x65;
00466 const AP4_MpegSampleDescription::OTI AP4_OTI_MPEG2_AAC_AUDIO_MAIN = 0x66;
00467 const AP4_MpegSampleDescription::OTI AP4_OTI_MPEG2_AAC_AUDIO_LC   = 0x67;
00468 const AP4_MpegSampleDescription::OTI AP4_OTI_MPEG2_AAC_AUDIO_SSRP = 0x68;
00469 const AP4_MpegSampleDescription::OTI AP4_OTI_MPEG2_PART3_AUDIO    = 0x69;
00470 const AP4_MpegSampleDescription::OTI AP4_OTI_MPEG1_VISUAL         = 0x6A;
00471 const AP4_MpegSampleDescription::OTI AP4_OTI_MPEG1_AUDIO          = 0x6B;
00472 const AP4_MpegSampleDescription::OTI AP4_OTI_JPEG                 = 0x6C;
00473
00474 const AP4_UI08 AP4_MPEG4_AUDIO_OBJECT_TYPE_AAC_MAIN              = 1;
00475 const AP4_UI08 AP4_MPEG4_AUDIO_OBJECT_TYPE_AAC_LC                = 2;
00476 const AP4_UI08 AP4_MPEG4_AUDIO_OBJECT_TYPE_AAC_SSR               = 3;
00477 const AP4_UI08 AP4_MPEG4_AUDIO_OBJECT_TYPE_AAC_LTP               = 4;
00478 const AP4_UI08 AP4_MPEG4_AUDIO_OBJECT_TYPE_SBR                   = 5;
00479 const AP4_UI08 AP4_MPEG4_AUDIO_OBJECT_TYPE_AAC_SCALABLE          = 6;
00480 const AP4_UI08 AP4_MPEG4_AUDIO_OBJECT_TYPE_TWINVQ                = 7;
00481 const AP4_UI08 AP4_MPEG4_AUDIO_OBJECT_TYPE_CELP                  = 8;
00482 const AP4_UI08 AP4_MPEG4_AUDIO_OBJECT_TYPE_HVXC                  = 9;
00483 const AP4_UI08 AP4_MPEG4_AUDIO_OBJECT_TYPE_TTSI                  = 12;
00484 const AP4_UI08 AP4_MPEG4_AUDIO_OBJECT_TYPE_MAIN_SYNTHETIC        = 13;
00485 const AP4_UI08 AP4_MPEG4_AUDIO_OBJECT_TYPE_WAVETABLE_SYNTHESIS   = 14;
00486 const AP4_UI08 AP4_MPEG4_AUDIO_OBJECT_TYPE_GENERAL_MIDI          = 15;
00487 const AP4_UI08 AP4_MPEG4_AUDIO_OBJECT_TYPE_ALGORITHMIC_SYNTHESIS = 16;
00488 const AP4_UI08 AP4_MPEG4_AUDIO_OBJECT_TYPE_ER_AAC_LC             = 17;
00489 const AP4_UI08 AP4_MPEG4_AUDIO_OBJECT_TYPE_ER_AAC_LTP            = 19;
00490 const AP4_UI08 AP4_MPEG4_AUDIO_OBJECT_TYPE_ER_AAC_SCALABLE       = 20;
00491 const AP4_UI08 AP4_MPEG4_AUDIO_OBJECT_TYPE_ER_TWINVQ             = 21;
00492 const AP4_UI08 AP4_MPEG4_AUDIO_OBJECT_TYPE_ER_BSAC               = 22;
00493 const AP4_UI08 AP4_MPEG4_AUDIO_OBJECT_TYPE_ER_AAC_LD             = 23;
00494 const AP4_UI08 AP4_MPEG4_AUDIO_OBJECT_TYPE_ER_CELP               = 24;
00495 const AP4_UI08 AP4_MPEG4_AUDIO_OBJECT_TYPE_ER_HVXC               = 25;
00496 const AP4_UI08 AP4_MPEG4_AUDIO_OBJECT_TYPE_ER_HILN               = 26;
00497 const AP4_UI08 AP4_MPEG4_AUDIO_OBJECT_TYPE_ER_PARAMETRIC         = 27;
00498 const AP4_UI08 AP4_MPEG4_AUDIO_OBJECT_TYPE_SSC                   = 28;
00499 const AP4_UI08 AP4_MPEG4_AUDIO_OBJECT_TYPE_PS                    = 29;
00500 const AP4_UI08 AP4_MPEG4_AUDIO_OBJECT_TYPE_MPEG_SURROUND         = 30;
00501 const AP4_UI08 AP4_MPEG4_AUDIO_OBJECT_TYPE_LAYER_1               = 32;
00502 const AP4_UI08 AP4_MPEG4_AUDIO_OBJECT_TYPE_LAYER_2               = 33;
00503 const AP4_UI08 AP4_MPEG4_AUDIO_OBJECT_TYPE_LAYER_3               = 34;
00504 const AP4_UI08 AP4_MPEG4_AUDIO_OBJECT_TYPE_DST                   = 35;
00505 const AP4_UI08 AP4_MPEG4_AUDIO_OBJECT_TYPE_ALS                   = 36;
00506 const AP4_UI08 AP4_MPEG4_AUDIO_OBJECT_TYPE_SLS                   = 37;
00507 const AP4_UI08 AP4_MPEG4_AUDIO_OBJECT_TYPE_SLS_NON_CORE          = 38;
00508 const AP4_UI08 AP4_MPEG4_AUDIO_OBJECT_TYPE_ER_AAC_ELD            = 39;
00509 const AP4_UI08 AP4_MPEG4_AUDIO_OBJECT_TYPE_SMR_SIMPLE            = 40;
00510 const AP4_UI08 AP4_MPEG4_AUDIO_OBJECT_TYPE_SMR_MAIN              = 41;
00512 #endif // _AP4_SAMPLE_DESCRIPTION_H_
00513
Generated on Thu May 13 16:36:33 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4SampleEntry.h File Reference

  • File List
  • File Members

Ap4SampleEntry.h File Reference

#include "Ap4Types.h"
#include "Ap4List.h"
#include "Ap4Atom.h"
#include "Ap4EsdsAtom.h"
#include "Ap4AtomFactory.h"
#include "Ap4ContainerAtom.h"

Go to the source code of this file.

Classes

class | AP4_SampleEntry
class | AP4_UnknownSampleEntry
class | AP4_AudioSampleEntry
class | AP4_VisualSampleEntry
class | AP4_MpegSystemSampleEntry
class | AP4_MpegAudioSampleEntry
class | AP4_MpegVideoSampleEntry
class | AP4_Mp4sSampleEntry
class | AP4_Mp4aSampleEntry
class | AP4_Mp4vSampleEntry
class | AP4_Avc1SampleEntry
class | AP4_RtpHintSampleEntry
Generated on Thu May 13 16:36:40 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4SampleEntry.h Source File

  • File List
  • File Members

Ap4SampleEntry.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - sample entries
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027  ****************************************************************/
00028
00029 #ifndef _AP4_SAMPLE_ENTRY_H_
00030 #define _AP4_SAMPLE_ENTRY_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Types.h"
00036 #include "Ap4List.h"
00037 #include "Ap4Atom.h"
00038 #include "Ap4EsdsAtom.h"
00039 #include "Ap4AtomFactory.h"
00040 #include "Ap4ContainerAtom.h"
00041
00042 /*----------------------------------------------------------------------
00043 |   class references
00044 +---------------------------------------------------------------------*/
00045 class AP4_SampleDescription;
00046 class AP4_AvccAtom;
00047
00048 /*----------------------------------------------------------------------
00049 |   AP4_SampleEntry
00050 +---------------------------------------------------------------------*/
00051 class AP4_SampleEntry : public AP4_ContainerAtom
00052 {
00053  public:
00054     AP4_IMPLEMENT_DYNAMIC_CAST_D(AP4_SampleEntry, AP4_ContainerAtom)
00055
00056     // methods
00057     AP4_SampleEntry(AP4_Atom::Type format, AP4_UI16 data_ref_index = 1);
00058     AP4_SampleEntry(AP4_Atom::Type   format,
00059                     AP4_Size         size,
00060                     AP4_ByteStream&  stream,
00061                     AP4_AtomFactory& atom_factory);
00062     virtual ~AP4_SampleEntry() {}
00063
00064     AP4_UI16           GetDataReferenceIndex() { return m_DataReferenceIndex; }
00065     virtual AP4_Result Write(AP4_ByteStream& stream);
00066     virtual AP4_Result Inspect(AP4_AtomInspector& inspector);
00067     virtual AP4_SampleDescription* ToSampleDescription();
00068
00069     // AP4_AtomParent methods
00070     virtual void OnChildChanged(AP4_Atom* child);
00071
00072  protected:
00073     // constructor
00074     AP4_SampleEntry(AP4_Atom::Type format, AP4_Size size);
00075
00076     // methods
00077     virtual void       Read(AP4_ByteStream& stream, AP4_AtomFactory& atom_factory);
00078     virtual AP4_Size   GetFieldsSize();
00079     virtual AP4_Result ReadFields(AP4_ByteStream& stream);
00080     virtual AP4_Result WriteFields(AP4_ByteStream& stream);
00081     virtual AP4_Result InspectFields(AP4_AtomInspector& inspector);
00082
00083     // members
00084     AP4_UI08 m_Reserved1[6];         // = 0
00085     AP4_UI16 m_DataReferenceIndex;
00086 };
00087
00088 /*----------------------------------------------------------------------
00089 |   AP4_UnknownSampleEntry
00090 +---------------------------------------------------------------------*/
00091 class AP4_UnknownSampleEntry : public AP4_SampleEntry
00092 {
00093  public:
00094     // this constructor takes ownership of the atom passed to it
00095     AP4_UnknownSampleEntry(AP4_Atom::Type type, AP4_Size size, AP4_ByteStream& stream);
00096
00097     // AP4_SampleEntry methods
00098     virtual AP4_SampleDescription* ToSampleDescription();
00099
00100     // accessors
00101     const AP4_DataBuffer& GetPayload() { return m_Payload; }
00102
00103  protected:
00104     // methods
00105     virtual AP4_Size   GetFieldsSize();
00106     virtual AP4_Result ReadFields(AP4_ByteStream& stream);
00107     virtual AP4_Result WriteFields(AP4_ByteStream& stream);
00108
00109     // members
00110     AP4_DataBuffer m_Payload;
00111 };
00112
00113 /*----------------------------------------------------------------------
00114 |   AP4_AudioSampleEntry
00115 +---------------------------------------------------------------------*/
00116 class AP4_AudioSampleEntry : public AP4_SampleEntry
00117 {
00118 public:
00119     // methods
00120     AP4_AudioSampleEntry(AP4_Atom::Type   format,
00121                          AP4_UI32         sample_rate,
00122                          AP4_UI16         sample_size,
00123                          AP4_UI16         channel_count);
00124     AP4_AudioSampleEntry(AP4_Atom::Type   format,
00125                          AP4_Size         size,
00126                          AP4_ByteStream&  stream,
00127                          AP4_AtomFactory& atom_factory);
00128
00129     // accessors
00130     AP4_UI32 GetSampleRate();
00131     AP4_UI16 GetSampleSize() { return m_SampleSize; }
00132     AP4_UI16 GetChannelCount();
00133
00134     // methods
00135     AP4_SampleDescription* ToSampleDescription();
00136
00137 protected:
00138     // methods
00139     virtual AP4_Size   GetFieldsSize();
00140     virtual AP4_Result ReadFields(AP4_ByteStream& stream);
00141     virtual AP4_Result WriteFields(AP4_ByteStream& stream);
00142     virtual AP4_Result InspectFields(AP4_AtomInspector& inspector);
00143
00144     // members
00145     AP4_UI16 m_QtVersion;       // 0, 1 or 2
00146     AP4_UI16 m_QtRevision;      // 0
00147     AP4_UI32 m_QtVendor;        // 0
00148     AP4_UI16 m_ChannelCount;
00149     AP4_UI16 m_SampleSize;
00150     AP4_UI16 m_QtCompressionId; // 0 or -2
00151     AP4_UI16 m_QtPacketSize;    // always 0
00152     AP4_UI32 m_SampleRate;      // 16.16 fixed point
00153
00154     AP4_UI32 m_QtV1SamplesPerPacket;
00155     AP4_UI32 m_QtV1BytesPerPacket;
00156     AP4_UI32 m_QtV1BytesPerFrame;
00157     AP4_UI32 m_QtV1BytesPerSample;
00158
00159     AP4_UI32 m_QtV2StructSize;
00160     double   m_QtV2SampleRate64;
00161     AP4_UI32 m_QtV2ChannelCount;
00162     AP4_UI32 m_QtV2Reserved;
00163     AP4_UI32 m_QtV2BitsPerChannel;
00164     AP4_UI32 m_QtV2FormatSpecificFlags;
00165     AP4_UI32 m_QtV2BytesPerAudioPacket;
00166     AP4_UI32 m_QtV2LPCMFramesPerAudioPacket;
00167     AP4_DataBuffer m_QtV2Extension;
00168 };
00169
00170 /*----------------------------------------------------------------------
00171 |   AP4_VisualSampleEntry
00172 +---------------------------------------------------------------------*/
00173 class AP4_VisualSampleEntry : public AP4_SampleEntry
00174 {
00175 public:
00176     // methods
00177     AP4_VisualSampleEntry(AP4_Atom::Type    format,
00178                           AP4_UI16          width,
00179                           AP4_UI16          height,
00180                           AP4_UI16          depth,
00181                           const char*       compressor_name);
00182     AP4_VisualSampleEntry(AP4_Atom::Type   format,
00183                           AP4_Size         size,
00184                           AP4_ByteStream&  stream,
00185                           AP4_AtomFactory& atom_factory);
00186
00187     // accessors
00188     AP4_UI16    GetWidth()          { return m_Width;  }
00189     AP4_UI16    GetHeight()         { return m_Height; }
00190     AP4_UI16    GetHorizResolution(){ return m_HorizResolution;  }
00191     AP4_UI16    GetVertResolution() { return m_VertResolution; }
00192     AP4_UI16    GetDepth()          { return m_Depth;  }
00193     const char* GetCompressorName() { return m_CompressorName.GetChars(); }
00194
00195     // methods
00196     AP4_SampleDescription* ToSampleDescription();
00197
00198 protected:
00199     // methods
00200     virtual AP4_Size   GetFieldsSize();
00201     virtual AP4_Result ReadFields(AP4_ByteStream& stream);
00202     virtual AP4_Result WriteFields(AP4_ByteStream& stream);
00203     virtual AP4_Result InspectFields(AP4_AtomInspector& inspector);
00204
00205     //members
00206     AP4_UI16   m_Predefined1;     // = 0
00207     AP4_UI16   m_Reserved2;       // = 0
00208     AP4_UI08   m_Predefined2[12]; // = 0
00209     AP4_UI16   m_Width;
00210     AP4_UI16   m_Height;
00211     AP4_UI32   m_HorizResolution; // = 0x00480000 (72 dpi)
00212     AP4_UI32   m_VertResolution;  // = 0x00480000 (72 dpi)
00213     AP4_UI32   m_Reserved3;       // = 0
00214     AP4_UI16   m_FrameCount;      // = 1
00215     AP4_String m_CompressorName;
00216     AP4_UI16   m_Depth;           // = 0x0018
00217     AP4_UI16   m_Predefined3;     // = 0xFFFF
00218 };
00219
00220 /*----------------------------------------------------------------------
00221 |   AP4_MpegSystemSampleEntry
00222 +---------------------------------------------------------------------*/
00223 class AP4_MpegSystemSampleEntry : public AP4_SampleEntry
00224 {
00225 public:
00226     // constructors
00227     AP4_MpegSystemSampleEntry(AP4_UI32          type,
00228                               AP4_EsDescriptor* descriptor);
00229     AP4_MpegSystemSampleEntry(AP4_UI32         type,
00230                               AP4_Size         size,
00231                               AP4_ByteStream&  stream,
00232                               AP4_AtomFactory& atom_factory);
00233
00234     // methods
00235     AP4_SampleDescription* ToSampleDescription();
00236 };
00237
00238 /*----------------------------------------------------------------------
00239 |   AP4_MpegAudioSampleEntry
00240 +---------------------------------------------------------------------*/
00241 class AP4_MpegAudioSampleEntry : public AP4_AudioSampleEntry
00242 {
00243 public:
00244     // constructors
00245     AP4_MpegAudioSampleEntry(AP4_UI32          type,
00246                              AP4_UI32          sample_rate,
00247                              AP4_UI16          sample_size,
00248                              AP4_UI16          channel_count,
00249                              AP4_EsDescriptor* descriptor);
00250     AP4_MpegAudioSampleEntry(AP4_UI32         type,
00251                              AP4_Size         size,
00252                              AP4_ByteStream&  stream,
00253                              AP4_AtomFactory& atom_factory);
00254
00255     // methods
00256     AP4_SampleDescription* ToSampleDescription();
00257 };
00258
00259 /*----------------------------------------------------------------------
00260 |   AP4_MpegVideoSampleEntry
00261 +---------------------------------------------------------------------*/
00262 class AP4_MpegVideoSampleEntry : public AP4_VisualSampleEntry
00263 {
00264 public:
00265     // constructors
00266     AP4_MpegVideoSampleEntry(AP4_UI32          type,
00267                              AP4_UI16          width,
00268                              AP4_UI16          height,
00269                              AP4_UI16          depth,
00270                              const char*       compressor_name,
00271                              AP4_EsDescriptor* descriptor);
00272     AP4_MpegVideoSampleEntry(AP4_UI32         type,
00273                              AP4_Size         size,
00274                              AP4_ByteStream&  stream,
00275                              AP4_AtomFactory& atom_factory);
00276
00277     // methods
00278     AP4_SampleDescription* ToSampleDescription();
00279 };
00280
00281 /*----------------------------------------------------------------------
00282 |   AP4_Mp4sSampleEntry
00283 +---------------------------------------------------------------------*/
00284 class AP4_Mp4sSampleEntry : public AP4_MpegSystemSampleEntry
00285 {
00286  public:
00287     // constructors
00288     AP4_Mp4sSampleEntry(AP4_Size         size,
00289                         AP4_ByteStream&  stream,
00290                         AP4_AtomFactory& atom_factory);
00291     AP4_Mp4sSampleEntry(AP4_EsDescriptor* descriptor);
00292
00293     // methods
00294     AP4_SampleDescription* ToSampleDescription();
00295 };
00296
00297 /*----------------------------------------------------------------------
00298 |   AP4_Mp4aSampleEntry
00299 +---------------------------------------------------------------------*/
00300 class AP4_Mp4aSampleEntry : public AP4_MpegAudioSampleEntry
00301 {
00302  public:
00303     // constructors
00304     AP4_Mp4aSampleEntry(AP4_Size         size,
00305                         AP4_ByteStream&  stream,
00306                         AP4_AtomFactory& atom_factory);
00307     AP4_Mp4aSampleEntry(AP4_UI32          sample_rate,
00308                         AP4_UI16          sample_size,
00309                         AP4_UI16          channel_count,
00310                         AP4_EsDescriptor* descriptor);
00311 };
00312
00313 /*----------------------------------------------------------------------
00314 |   AP4_Mp4vSampleEntry
00315 +---------------------------------------------------------------------*/
00316 class AP4_Mp4vSampleEntry : public AP4_MpegVideoSampleEntry
00317 {
00318  public:
00319     // constructors
00320     AP4_Mp4vSampleEntry(AP4_Size         size,
00321                         AP4_ByteStream&  stream,
00322                         AP4_AtomFactory& atom_factory);
00323     AP4_Mp4vSampleEntry(AP4_UI16          width,
00324                         AP4_UI16          height,
00325                         AP4_UI16          depth,
00326                         const char*       compressor_name,
00327                         AP4_EsDescriptor* descriptor);
00328 };
00329
00330 /*----------------------------------------------------------------------
00331 |   AP4_Avc1SampleEntry
00332 +---------------------------------------------------------------------*/
00333 class AP4_Avc1SampleEntry : public AP4_VisualSampleEntry
00334 {
00335 public:
00336     // constructors
00337     AP4_Avc1SampleEntry(AP4_Size         size,
00338                         AP4_ByteStream&  stream,
00339                         AP4_AtomFactory& atom_factory);
00340     AP4_Avc1SampleEntry(AP4_UI16            width,
00341                         AP4_UI16            height,
00342                         AP4_UI16            depth,
00343                         const char*         compressor_name,
00344                         const AP4_AvccAtom& avcc);
00345
00346     // inherited from AP4_SampleEntry
00347     virtual AP4_SampleDescription* ToSampleDescription();
00348 };
00349
00350 /*----------------------------------------------------------------------
00351 |   AP4_RtpHintSampleEntry
00352 +---------------------------------------------------------------------*/
00353 class AP4_RtpHintSampleEntry : public AP4_SampleEntry
00354 {
00355 public:
00356     // methods
00357     AP4_RtpHintSampleEntry(AP4_UI16 hint_track_version,
00358                            AP4_UI16 highest_compatible_version,
00359                            AP4_UI32 max_packet_size,
00360                            AP4_UI32 timescale);
00361     AP4_RtpHintSampleEntry(AP4_Size         size,
00362                            AP4_ByteStream&  stream,
00363                            AP4_AtomFactory& atom_factory);
00364
00365 protected:
00366     // methods
00367     virtual AP4_Size   GetFieldsSize();
00368     virtual AP4_Result ReadFields(AP4_ByteStream& stream);
00369     virtual AP4_Result WriteFields(AP4_ByteStream& stream);
00370     virtual AP4_Result InspectFields(AP4_AtomInspector& inspector);
00371
00372     // members
00373     AP4_UI16 m_HintTrackVersion;
00374     AP4_UI16 m_HighestCompatibleVersion;
00375     AP4_UI32 m_MaxPacketSize;
00376 };
00377
00378 #endif // _AP4_SAMPLE_ENTRY_H_
Generated on Thu May 13 16:36:33 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4SampleSource.h File Reference

  • File List
  • File Members

Ap4SampleSource.h File Reference

#include "Ap4Types.h"

Go to the source code of this file.

Classes

class | AP4_SampleSource
class | AP4_TrackSampleSource
Generated on Thu May 13 16:36:40 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4SampleSource.h Source File

  • File List
  • File Members

Ap4SampleSource.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - Sample Source Interface
00004 |
00005 |    Copyright 2002-2009 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027  ****************************************************************/
00028
00029 #ifndef _AP4_SAMPLE_SOURCE_H_
00030 #define _AP4_SAMPLE_SOURCE_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Types.h"
00036
00037 /*----------------------------------------------------------------------
00038 |   class references
00039 +---------------------------------------------------------------------*/
00040 class AP4_Sample;
00041 class AP4_SampleDescription;
00042 class AP4_Track;
00043 class AP4_DataBuffer;
00044
00045 /*----------------------------------------------------------------------
00046 |   AP4_SampleSource
00047 +---------------------------------------------------------------------*/
00048 class AP4_SampleSource
00049 {
00050 public:
00051     virtual ~AP4_SampleSource() {}
00052
00056     virtual AP4_UI32 GetTimeScale() = 0;
00057
00061     virtual AP4_UI32 GetDurationMs() = 0;
00062
00067     virtual AP4_UI32 GetTrackId() = 0;
00068
00072     virtual AP4_Result ReadNextSample(AP4_Sample& sample, AP4_DataBuffer& buffer) = 0;
00073
00077     virtual AP4_Ordinal GetNearestSyncSampleIndex(AP4_Ordinal indx, bool before=true) = 0;
00078
00082     virtual AP4_Result GetSampleIndexForTimeStampMs(AP4_UI32 timestamp, AP4_Ordinal& indx) = 0;
00083
00087     virtual AP4_Result SetSampleIndex(AP4_Ordinal indx) = 0;
00088
00093     virtual AP4_SampleDescription* GetSampleDescription(AP4_Ordinal indx) = 0;
00094 };
00095
00096 /*----------------------------------------------------------------------
00097 |   AP4_TrackSampleSource
00098 +---------------------------------------------------------------------*/
00099 class AP4_TrackSampleSource : public AP4_SampleSource
00100 {
00101 public:
00102     AP4_TrackSampleSource(AP4_Track* track);
00103
00104     virtual AP4_UI32    GetTimeScale();
00105     virtual AP4_UI32    GetDurationMs();
00106     virtual AP4_UI32    GetTrackId();
00107     virtual AP4_Result  ReadNextSample(AP4_Sample& sample, AP4_DataBuffer& buffer);
00108     virtual AP4_Ordinal GetNearestSyncSampleIndex(AP4_Ordinal indx, bool before=true);
00109     virtual AP4_Result  GetSampleIndexForTimeStampMs(AP4_UI32 timestamp, AP4_Ordinal& indx);
00110     virtual AP4_Result  SetSampleIndex(AP4_Ordinal indx);
00111     virtual AP4_SampleDescription* GetSampleDescription(AP4_Ordinal indx);
00112
00113 private:
00114     AP4_Track*  m_Track;
00115     AP4_Ordinal m_SampleIndex;
00116 };
00117
00118 #endif // _AP4_SAMPLE_SOURCE_H_
Generated on Thu May 13 16:36:33 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4SampleTable.h File Reference

  • File List
  • File Members

Ap4SampleTable.h File Reference

#include "Ap4Types.h"
#include "Ap4DynamicCast.h"

Go to the source code of this file.

Classes

class AP4_SampleTable
Generated on Thu May 13 16:36:40 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4SampleTable.h Source File

  • File List
  • File Members

Ap4SampleTable.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - Sample Table Interface
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027  ****************************************************************/
00028
00029 #ifndef _AP4_SAMPLE_TABLE_H_
00030 #define _AP4_SAMPLE_TABLE_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Types.h"
00036 #include "Ap4DynamicCast.h"
00037
00038 /*----------------------------------------------------------------------
00039 |   class references
00040 +---------------------------------------------------------------------*/
00041 class AP4_Sample;
00042 class AP4_ContainerAtom;
00043 class AP4_SampleDescription;
00044
00045 /*----------------------------------------------------------------------
00046 |   AP4_SampleTable
00047 +---------------------------------------------------------------------*/
00048 class AP4_SampleTable {
00049 public:
00050     AP4_IMPLEMENT_DYNAMIC_CAST(AP4_SampleTable)
00051
00052     // constructors and destructor
00053     virtual ~AP4_SampleTable() {};
00054
00055     // methods
00056     virtual AP4_Result   GenerateStblAtom(AP4_ContainerAtom*& stbl);
00057     virtual AP4_Result   GetSample(AP4_Ordinal sample_index, AP4_Sample& sample) = 0;
00058     virtual AP4_Cardinal GetSampleCount() = 0;
00059     virtual AP4_Result   GetSampleChunkPosition(AP4_Ordinal  sample_index,
00060                                                 AP4_Ordinal& chunk_index,
00061                                                 AP4_Ordinal& position_in_chunk) = 0;
00062     virtual AP4_Cardinal GetSampleDescriptionCount() = 0;
00063     virtual AP4_SampleDescription* GetSampleDescription(AP4_Ordinal index) = 0;
00064     virtual AP4_Result   GetSampleIndexForTimeStamp(AP4_UI64     ts,
00065                                                     AP4_Ordinal& index) = 0;
00066     virtual AP4_Ordinal  GetNearestSyncSampleIndex(AP4_Ordinal index, bool before=true) = 0;
00067 };
00068
00069 #endif // _AP4_SAMPLE_TABLE_H_
Generated on Thu May 13 16:36:33 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4SchmAtom.h File Reference

  • File List
  • File Members

Ap4SchmAtom.h File Reference

#include "Ap4Types.h"
#include "Ap4String.h"
#include "Ap4Atom.h"
#include "Ap4Array.h"

Go to the source code of this file.

Classes

class AP4_SchmAtom
Generated on Thu May 13 16:36:40 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4SchmAtom.h Source File

  • File List
  • File Members

Ap4SchmAtom.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - schm Atoms
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027  ****************************************************************/
00028
00029 #ifndef _AP4_SCHM_ATOM_H_
00030 #define _AP4_SCHM_ATOM_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Types.h"
00036 #include "Ap4String.h"
00037 #include "Ap4Atom.h"
00038 #include "Ap4Array.h"
00039
00040 /*----------------------------------------------------------------------
00041 |   class references
00042 +---------------------------------------------------------------------*/
00043 class AP4_ByteStream;
00044
00045 /*----------------------------------------------------------------------
00046 |   AP4_SchmAtom
00047 +---------------------------------------------------------------------*/
00048 class AP4_SchmAtom : public AP4_Atom
00049 {
00050 public:
00051     AP4_IMPLEMENT_DYNAMIC_CAST_D(AP4_SchmAtom, AP4_Atom)
00052
00053     // class methods
00054     static AP4_SchmAtom* Create(AP4_Size                   size,
00055                                 AP4_Array<AP4_Atom::Type>* context,
00056                                 AP4_ByteStream&            stream);
00057
00058     // constructors
00059     AP4_SchmAtom(AP4_UI32    scheme_type,
00060                  AP4_UI32    scheme_version,
00061                  const char* scheme_uri = NULL,
00062                  bool        short_form = false);
00063
00064     // methods
00065     virtual AP4_Result InspectFields(AP4_AtomInspector& inspector);
00066     virtual AP4_Result WriteFields(AP4_ByteStream& stream);
00067
00068     // accessors
00069     AP4_UI32    GetSchemeType()    { return m_SchemeType;    }
00070     AP4_UI32    GetSchemeVersion() { return m_SchemeVersion; }
00071     AP4_String& GetSchemeUri()     { return m_SchemeUri;     }
00072
00073 private:
00074     // methods
00075     AP4_SchmAtom(AP4_UI32        size,
00076                  AP4_UI32        version,
00077                  AP4_UI32        flags,
00078                  bool            short_form,
00079                  AP4_ByteStream& stream);
00080
00081     // members
00082     bool       m_AtomHasShortForm; // for versions of this where the version
00083                                    // field is only 16 bits
00084     AP4_UI32   m_SchemeType;
00085     AP4_UI32   m_SchemeVersion;
00086     AP4_String m_SchemeUri;
00087 };
00088
00089 #endif // _AP4_SCHM_ATOM_H_
Generated on Thu May 13 16:36:33 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4SdpAtom.h File Reference

  • File List
  • File Members

Ap4SdpAtom.h File Reference

#include "Ap4List.h"
#include "Ap4Atom.h"
#include "Ap4String.h"

Go to the source code of this file.

Classes

class AP4_SdpAtom
Generated on Thu May 13 16:36:40 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4SdpAtom.h Source File

  • File List
  • File Members

Ap4SdpAtom.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - sdp Atoms
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027 ****************************************************************/
00028
00029 #ifndef _AP4_SDP_ATOM_H_
00030 #define _AP4_SDP_ATOM_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4List.h"
00036 #include "Ap4Atom.h"
00037 #include "Ap4String.h"
00038
00039 /*----------------------------------------------------------------------
00040 |   class references
00041 +---------------------------------------------------------------------*/
00042 class AP4_ByteStream;
00043
00044 /*----------------------------------------------------------------------
00045 |   AP4_SdpAtom
00046 +---------------------------------------------------------------------*/
00047 class AP4_SdpAtom : public AP4_Atom
00048 {
00049 public:
00050     // class methods
00051     static AP4_SdpAtom* Create(AP4_Size size, AP4_ByteStream& stream) {
00052         return new AP4_SdpAtom(size, stream);
00053     }
00054
00055     // methods
00056     AP4_SdpAtom(const char* sdp_text);
00057     virtual AP4_Result InspectFields(AP4_AtomInspector& inspector);
00058     virtual AP4_Result WriteFields(AP4_ByteStream& stream);
00059
00060     // accessors
00061     const AP4_String& GetSdpText() const;
00062
00063 private:
00064     // methods
00065     AP4_SdpAtom(AP4_UI32 size, AP4_ByteStream& stream);
00066
00067     // members
00068     AP4_String m_SdpText;
00069 };
00070
00071 #endif // _AP4_SDP_ATOM_H_
Generated on Thu May 13 16:36:33 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4SLConfigDescriptor.h File Reference

  • File List
  • File Members

Ap4SLConfigDescriptor.h File Reference

#include "Ap4Types.h"
#include "Ap4Descriptor.h"

Go to the source code of this file.

Classes

class | AP4_SLConfigDescriptor

Variables

const AP4_UI08 | AP4_DESCRIPTOR_TAG_SL_CONFIG = 0x06

Variable Documentation

const AP4_UI08 AP4_DESCRIPTOR_TAG_SL_CONFIG = 0x06

Definition at line 41 of file Ap4SLConfigDescriptor.h.

Generated on Thu May 13 16:36:40 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4SLConfigDescriptor.h Source File

  • File List
  • File Members

Ap4SLConfigDescriptor.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - SLConfig Descriptor
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027 ****************************************************************/
00028
00029 #ifndef _AP4_SLCONFIG_DESCRIPTOR_H_
00030 #define _AP4_SLCONFIG_DESCRIPTOR_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Types.h"
00036 #include "Ap4Descriptor.h"
00037
00038 /*----------------------------------------------------------------------
00039 |   constants
00040 +---------------------------------------------------------------------*/
00041 const AP4_UI08 AP4_DESCRIPTOR_TAG_SL_CONFIG = 0x06;
00042
00043 /*----------------------------------------------------------------------
00044 |   AP4_SLConfigDescriptor
00045 +---------------------------------------------------------------------*/
00046 class AP4_SLConfigDescriptor : public AP4_Descriptor
00047 {
00048 public:
00049     // methods
00050     AP4_SLConfigDescriptor(AP4_Size header_size = 2);
00051     virtual AP4_Result WriteFields(AP4_ByteStream& stream);
00052
00053 private:
00054     // members
00055     AP4_UI08 m_Predefined; // = 2 (fixed for MP4 files)
00056 };
00057
00058
00059 #endif // _AP4_SLCONFIG_DESCRIPTOR_H_
Generated on Thu May 13 16:36:33 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4SmhdAtom.h File Reference

  • File List
  • File Members

Ap4SmhdAtom.h File Reference

#include "Ap4Types.h"
#include "Ap4Atom.h"

Go to the source code of this file.

Classes

class AP4_SmhdAtom
Generated on Thu May 13 16:36:40 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4SmhdAtom.h Source File

  • File List
  • File Members

Ap4SmhdAtom.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - smhd Atoms
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027 ****************************************************************/
00028
00029 #ifndef _AP4_SMHD_ATOM_H_
00030 #define _AP4_SMHD_ATOM_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Types.h"
00036 #include "Ap4Atom.h"
00037
00038 /*----------------------------------------------------------------------
00039 |   AP4_SmhdAtom
00040 +---------------------------------------------------------------------*/
00041 class AP4_SmhdAtom : public AP4_Atom
00042 {
00043 public:
00044     // class methods
00045     static AP4_SmhdAtom* Create(AP4_Size size, AP4_ByteStream& stream);
00046
00047     // methods
00048     AP4_SmhdAtom(AP4_UI16 balance);
00049     virtual AP4_Result InspectFields(AP4_AtomInspector& inspector);
00050     virtual AP4_Result WriteFields(AP4_ByteStream& stream);
00051
00052 private:
00053     // methods
00054     AP4_SmhdAtom(AP4_UI32        size,
00055                  AP4_UI32        version,
00056                  AP4_UI32        flags,
00057                  AP4_ByteStream& stream);
00058
00059     // members
00060     AP4_UI16 m_Balance;
00061     AP4_UI16 m_Reserved;
00062 };
00063
00064 #endif // _AP4_SMHD_ATOM_H_
Generated on Thu May 13 16:36:33 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4StcoAtom.h File Reference

  • File List
  • File Members

Ap4StcoAtom.h File Reference

#include "Ap4Types.h"
#include "Ap4Atom.h"

Go to the source code of this file.

Classes

class AP4_StcoAtom
Generated on Thu May 13 16:36:40 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4StcoAtom.h Source File

  • File List
  • File Members

Ap4StcoAtom.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - stco Atoms
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027  ****************************************************************/
00028
00029 #ifndef _AP4_STCO_ATOM_H_
00030 #define _AP4_STCO_ATOM_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Types.h"
00036 #include "Ap4Atom.h"
00037
00038 /*----------------------------------------------------------------------
00039 |   AP4_StcoAtom
00040 +---------------------------------------------------------------------*/
00041 class AP4_StcoAtom : public AP4_Atom
00042 {
00043 public:
00044     AP4_IMPLEMENT_DYNAMIC_CAST_D(AP4_StcoAtom, AP4_Atom)
00045
00046     // class methods
00047     static AP4_StcoAtom* Create(AP4_Size size, AP4_ByteStream& stream);
00048
00049     // methods
00050     AP4_StcoAtom(AP4_UI32* offsets, AP4_UI32 offset_count);
00051     ~AP4_StcoAtom();
00052     virtual AP4_Result InspectFields(AP4_AtomInspector& inspector);
00053     virtual AP4_Result WriteFields(AP4_ByteStream& stream);
00054     AP4_Cardinal GetChunkCount()   { return m_EntryCount;  }
00055     AP4_UI32*    GetChunkOffsets() { return m_Entries;     }
00056     AP4_Result   GetChunkOffset(AP4_Ordinal chunk, AP4_UI32& chunk_offset);
00057     AP4_Result   SetChunkOffset(AP4_Ordinal chunk, AP4_UI32  chunk_offset);
00058     AP4_Result   AdjustChunkOffsets(int delta);
00059
00060 private:
00061     // methods
00062     AP4_StcoAtom(AP4_UI32        size,
00063                  AP4_UI32        version,
00064                  AP4_UI32        flags,
00065                  AP4_ByteStream& stream);
00066
00067     // members
00068     AP4_UI32* m_Entries;
00069     AP4_UI32  m_EntryCount;
00070 };
00071
00072 #endif // _AP4_STCO_ATOM_H_
Generated on Thu May 13 16:36:33 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4StreamCipher.h File Reference

  • File List
  • File Members

Ap4StreamCipher.h File Reference

#include "Ap4Protection.h"
#include "Ap4Results.h"
#include "Ap4Types.h"

Go to the source code of this file.

Classes

class | AP4_StreamCipher
class | AP4_CtrStreamCipher
class | AP4_CbcStreamCipher

Variables

const unsigned int | AP4_CIPHER_BLOCK_SIZE = 16

Variable Documentation

const unsigned int AP4_CIPHER_BLOCK_SIZE = 16

Definition at line 43 of file Ap4StreamCipher.h.

Generated on Thu May 13 16:36:40 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4StreamCipher.h Source File

  • File List
  • File Members

Ap4StreamCipher.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - Stream Cipher
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027 ****************************************************************/
00028
00029 #ifndef _AP4_STREAM_CIPHER_H_
00030 #define _AP4_STREAM_CIPHER_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Protection.h"
00036 #include "Ap4Results.h"
00037 #include "Ap4Types.h"
00038
00039 /*----------------------------------------------------------------------
00040 |   constants
00041 +---------------------------------------------------------------------*/
00042 // we only support this for now
00043 const unsigned int AP4_CIPHER_BLOCK_SIZE = 16;
00044
00045 /*----------------------------------------------------------------------
00046 |   AP4_StreamCipher interface
00047 +---------------------------------------------------------------------*/
00048 class AP4_StreamCipher
00049 {
00050 public:
00051     // types
00052     typedef enum {
00053         ENCRYPT,
00054         DECRYPT
00055     } CipherDirection;
00056
00057     // methods
00058     virtual            ~AP4_StreamCipher() {}
00059
00060     virtual AP4_UI64    GetStreamOffset() = 0;
00061
00062     virtual AP4_Result  ProcessBuffer(const AP4_UI08* in,
00063                                       AP4_Size        in_size,
00064                                       AP4_UI08*       out,
00065                                       AP4_Size*       out_size,
00066                                       bool            is_last_buffer = false) = 0;
00067
00068     // preroll gives the number of bytes you have to preroll your input and feed
00069     // it through ProcessBuffer (in one shot) in order to be able to spit out
00070     // the output at the given offset
00071     virtual AP4_Result  SetStreamOffset(AP4_UI64      offset,
00072                                         AP4_Cardinal* preroll) = 0;
00073
00074     virtual AP4_Result SetIV(const AP4_UI08* iv) = 0;
00075     virtual const AP4_UI08* GetIV() = 0;
00076 };
00077
00078
00079 /*----------------------------------------------------------------------
00080 |   AP4_CtrStreamCipher
00081 +---------------------------------------------------------------------*/
00082 class AP4_CtrStreamCipher : public AP4_StreamCipher
00083 {
00084 public:
00085    // methods
00086
00091     AP4_CtrStreamCipher(AP4_BlockCipher* block_cipher,
00092                         const AP4_UI08*  salt,
00093                         AP4_Size         counter_size);
00094     ~AP4_CtrStreamCipher();
00095
00096     // AP4_StreamCipher implementation
00097     virtual AP4_Result      SetStreamOffset(AP4_UI64      offset,
00098                                        AP4_Cardinal* preroll = NULL);
00099     virtual AP4_UI64        GetStreamOffset() { return m_StreamOffset; }
00100     virtual AP4_Result      ProcessBuffer(const AP4_UI08* in,
00101                                           AP4_Size        in_size,
00102                                           AP4_UI08*       out,
00103                                           AP4_Size*       out_size       = NULL,
00104                                           bool            is_last_buffer = false);
00105
00106     virtual AP4_Result      SetIV(const AP4_UI08* iv);
00107     virtual const AP4_UI08* GetIV()  { return m_BaseCounter;  }
00108
00109 private:
00110     // methods
00111     void SetCounterOffset(AP4_UI32 offset);
00112     void UpdateKeyStream();
00113
00114     // members
00115     AP4_UI64         m_StreamOffset;
00116     AP4_Size         m_CounterSize;
00117     AP4_UI08         m_BaseCounter[AP4_CIPHER_BLOCK_SIZE];
00118     AP4_UI08         m_XBlock[AP4_CIPHER_BLOCK_SIZE];
00119     AP4_BlockCipher* m_BlockCipher;
00120 };
00121
00122 /*----------------------------------------------------------------------
00123 |   AP4_CbcStreamCipher
00124 +---------------------------------------------------------------------*/
00125 class AP4_CbcStreamCipher : public AP4_StreamCipher
00126 {
00127 public:
00128     // methods
00129
00134     AP4_CbcStreamCipher(AP4_BlockCipher* block_cipher, CipherDirection direction);
00135     ~AP4_CbcStreamCipher();
00136
00137     // AP4_StreamCipher implementation
00138     virtual AP4_Result      SetStreamOffset(AP4_UI64      offset,
00139                                             AP4_Cardinal* preroll);
00140     virtual AP4_UI64        GetStreamOffset() { return m_StreamOffset; }
00141     virtual AP4_Result      ProcessBuffer(const AP4_UI08* in,
00142                                           AP4_Size        in_size,
00143                                           AP4_UI08*       out,
00144                                           AP4_Size*       out_size,
00145                                           bool            is_last_buffer = false);
00146     virtual AP4_Result      SetIV(const AP4_UI08* iv);
00147     virtual const AP4_UI08* GetIV() { return m_Iv; };
00148
00149 private:
00150     // members
00151     CipherDirection  m_Direction;
00152     AP4_UI64         m_StreamOffset;
00153     AP4_Size         m_OutputSkip;
00154     AP4_UI08         m_InBlockCache[AP4_CIPHER_BLOCK_SIZE];
00155     AP4_UI08         m_OutBlockCache[AP4_CIPHER_BLOCK_SIZE];
00156     AP4_UI08         m_Iv[AP4_CIPHER_BLOCK_SIZE];
00157     AP4_BlockCipher* m_BlockCipher;
00158     bool             m_Eos;
00159     AP4_Cardinal     m_PrerollByteCount;
00160 };
00161
00162 #endif // _AP4_STREAM_CIPHER_H_
Generated on Thu May 13 16:36:33 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4String.h File Reference

  • File List
  • File Members

Ap4String.h File Reference

#include "Ap4Config.h"
#include "Ap4Types.h"

Go to the source code of this file.

Classes

class AP4_String
Generated on Thu May 13 16:36:40 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4String.h Source File

  • File List
  • File Members

Ap4String.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - Strings
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027 ****************************************************************/
00028
00029 #ifndef _AP4_STRING_H_
00030 #define _AP4_STRING_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Config.h"
00036 #include "Ap4Types.h"
00037
00038 /*----------------------------------------------------------------------
00039 |   AP4_String
00040 +---------------------------------------------------------------------*/
00041 class AP4_String
00042 {
00043 public:
00044     // constructors
00045     AP4_String();
00046     AP4_String(const char* s);
00047     AP4_String(const char* s, AP4_Size size);
00048     AP4_String(const AP4_String& s);
00049     explicit AP4_String(AP4_Size size);
00050
00051     // destructor
00052     ~AP4_String();
00053
00054     // operators
00055     const AP4_String& operator=(const AP4_String& s);
00056     const AP4_String& operator=(const char* s);
00057     char operator[](unsigned int index) const {
00058         return m_Chars[index];
00059     }
00060     bool operator==(const AP4_String& s) const;
00061     bool operator!=(const AP4_String& s) const { return !(*this == s); }
00062     bool operator==(const char* s) const;
00063     bool operator!=(const char* s) const { return !(*this == s); }
00064
00065     // methods
00066     AP4_Size    GetLength() const { return m_Length; }
00067     const char* GetChars() const  { return m_Chars;  }
00068     char*       UseChars()        { return m_Chars;  }
00069     void        Assign(const char* chars, AP4_Size size);
00070     int         Find(char c, unsigned int start = 0) const;
00071
00072 private:
00073     // class members
00074     static char EmptyString;
00075
00076     // members
00077     char*    m_Chars;
00078     AP4_Size m_Length;
00079 };
00080
00081 #endif // _AP4_STRING_H_
Generated on Thu May 13 16:36:33 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4StscAtom.h File Reference

  • File List
  • File Members

Ap4StscAtom.h File Reference

#include "Ap4Types.h"
#include "Ap4Atom.h"
#include "Ap4Array.h"

Go to the source code of this file.

Classes

class | AP4_StscTableEntry
class | AP4_StscAtom
Generated on Thu May 13 16:36:40 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4StscAtom.h Source File

  • File List
  • File Members

Ap4StscAtom.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - stsc Atoms
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027  ****************************************************************/
00028
00029 #ifndef _AP4_STSC_ATOM_H_
00030 #define _AP4_STSC_ATOM_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Types.h"
00036 #include "Ap4Atom.h"
00037 #include "Ap4Array.h"
00038
00039 /*----------------------------------------------------------------------
00040 |   AP4_StscTableEntry
00041 +---------------------------------------------------------------------*/
00042 class AP4_StscTableEntry {
00043  public:
00044     AP4_StscTableEntry() :
00045         m_FirstChunk(0),
00046         m_FirstSample(0),
00047         m_ChunkCount(0),
00048         m_SamplesPerChunk(0),
00049         m_SampleDescriptionIndex(0) {}
00050     AP4_StscTableEntry(AP4_Ordinal  first_chunk,
00051                        AP4_Ordinal  first_sample,
00052                        AP4_Cardinal samples_per_chunk,
00053                        AP4_Ordinal  sample_description_index) :
00054         m_FirstChunk(first_chunk),
00055         m_FirstSample(first_sample),
00056         m_ChunkCount(0),
00057         m_SamplesPerChunk(samples_per_chunk),
00058         m_SampleDescriptionIndex(sample_description_index) {}
00059     AP4_StscTableEntry(AP4_Ordinal  first_chunk,
00060                        AP4_Ordinal  first_sample,
00061                        AP4_Cardinal chunk_count,
00062                        AP4_Cardinal samples_per_chunk,
00063                        AP4_Ordinal  sample_description_index) :
00064         m_FirstChunk(first_chunk),
00065         m_FirstSample(first_sample),
00066         m_ChunkCount(chunk_count),
00067         m_SamplesPerChunk(samples_per_chunk),
00068         m_SampleDescriptionIndex(sample_description_index) {}
00069     AP4_Ordinal  m_FirstChunk;
00070     AP4_Ordinal  m_FirstSample;  // computed (not in file)
00071     AP4_Cardinal m_ChunkCount;   // computed (not in file)
00072     AP4_Cardinal m_SamplesPerChunk;
00073     AP4_Ordinal  m_SampleDescriptionIndex;
00074 };
00075
00076 /*----------------------------------------------------------------------
00077 |   AP4_StscAtom
00078 +---------------------------------------------------------------------*/
00079 class AP4_StscAtom : public AP4_Atom
00080 {
00081 public:
00082     AP4_IMPLEMENT_DYNAMIC_CAST_D(AP4_StscAtom, AP4_Atom)
00083
00084     // class methods
00085     static AP4_StscAtom* Create(AP4_Size size, AP4_ByteStream& stream);
00086
00087     // methods
00088     AP4_StscAtom();
00089     virtual AP4_Result InspectFields(AP4_AtomInspector& inspector);
00090     virtual AP4_Result GetChunkForSample(AP4_Ordinal   sample,
00091                                          AP4_Ordinal&  chunk,
00092                                          AP4_Ordinal&  skip,
00093                                          AP4_Ordinal&  sample_description_index);
00094     virtual AP4_Result AddEntry(AP4_Cardinal chunk_count,
00095                                 AP4_Cardinal samples_per_chunk,
00096                                 AP4_Ordinal  sample_description_index);
00097     virtual AP4_Result WriteFields(AP4_ByteStream& stream);
00098
00099 private:
00100     // methods
00101     AP4_StscAtom(AP4_UI32        size,
00102                  AP4_UI32        version,
00103                  AP4_UI32        flags,
00104                  AP4_ByteStream& stream);
00105
00106     // members
00107     AP4_Array<AP4_StscTableEntry> m_Entries;
00108     AP4_Ordinal                   m_CachedChunkGroup;
00109 };
00110
00111 #endif // _AP4_STSC_ATOM_H_
Generated on Thu May 13 16:36:33 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4StsdAtom.h File Reference

  • File List
  • File Members

Ap4StsdAtom.h File Reference

#include "Ap4Types.h"
#include "Ap4Array.h"
#include "Ap4ContainerAtom.h"

Go to the source code of this file.

Classes

class AP4_StsdAtom
Generated on Thu May 13 16:36:40 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4StsdAtom.h Source File

  • File List
  • File Members

Ap4StsdAtom.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - stsd Atoms
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027  ****************************************************************/
00028
00029 #ifndef _AP4_STSD_ATOM_H_
00030 #define _AP4_STSD_ATOM_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Types.h"
00036 #include "Ap4Array.h"
00037 #include "Ap4ContainerAtom.h"
00038
00039 /*----------------------------------------------------------------------
00040 |   class references
00041 +---------------------------------------------------------------------*/
00042 class AP4_SampleTable;
00043 class AP4_SampleDescription;
00044 class AP4_SampleEntry;
00045
00046 /*----------------------------------------------------------------------
00047 |   AP4_StsdAtom
00048 +---------------------------------------------------------------------*/
00049 class AP4_StsdAtom : public AP4_ContainerAtom
00050 {
00051 public:
00052     AP4_IMPLEMENT_DYNAMIC_CAST_D(AP4_StsdAtom, AP4_ContainerAtom)
00053
00054     // class methods
00055     static AP4_StsdAtom* Create(AP4_Size         size,
00056                                 AP4_ByteStream&  stream,
00057                                 AP4_AtomFactory& atom_factory);
00058
00059     // methods
00060     AP4_StsdAtom(AP4_SampleTable* sample_table);
00061     ~AP4_StsdAtom();
00062     virtual AP4_Result InspectFields(AP4_AtomInspector& inspector);
00063     virtual AP4_Result WriteFields(AP4_ByteStream& stream);
00064     virtual AP4_Cardinal           GetSampleDescriptionCount();
00065     virtual AP4_SampleDescription* GetSampleDescription(AP4_Ordinal index);
00066     virtual AP4_SampleEntry*       GetSampleEntry(AP4_Ordinal index);
00067
00068     // AP4_AtomParent methods
00069     void OnChildChanged(AP4_Atom* child);
00070
00071 private:
00072     // methods
00073     AP4_StsdAtom(AP4_UI32         size,
00074                  AP4_UI32         version,
00075                  AP4_UI32         flags,
00076                  AP4_ByteStream&  stream,
00077                  AP4_AtomFactory& atom_factory);
00078
00079     // members
00080     AP4_Array<AP4_SampleDescription*> m_SampleDescriptions;
00081 };
00082
00083 #endif // _AP4_STSD_ATOM_H_
00084
Generated on Thu May 13 16:36:33 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4StssAtom.h File Reference

  • File List
  • File Members

Ap4StssAtom.h File Reference

#include "Ap4Array.h"
#include "Ap4Atom.h"

Go to the source code of this file.

Classes

class AP4_StssAtom
Generated on Thu May 13 16:36:40 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4StssAtom.h Source File

  • File List
  • File Members

Ap4StssAtom.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - stss Atoms
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027  ****************************************************************/
00028
00029 #ifndef _AP4_STSS_ATOM_H_
00030 #define _AP4_STSS_ATOM_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Array.h"
00036 #include "Ap4Atom.h"
00037
00038 /*----------------------------------------------------------------------
00039 |   AP4_StssAtom
00040 +---------------------------------------------------------------------*/
00041 class AP4_StssAtom : public AP4_Atom
00042 {
00043 public:
00044     AP4_IMPLEMENT_DYNAMIC_CAST_D(AP4_StssAtom, AP4_Atom)
00045
00046     // class methods
00047     static AP4_StssAtom* Create(AP4_Size size, AP4_ByteStream& stream);
00048
00049     // constructor
00050     AP4_StssAtom();
00051
00052     // methods
00053     // methods
00054     const AP4_Array<AP4_UI32>& GetEntries() { return m_Entries; }
00055     AP4_Result                 AddEntry(AP4_UI32 sample);
00056     virtual AP4_Result         InspectFields(AP4_AtomInspector& inspector);
00057     virtual bool               IsSampleSync(AP4_Ordinal sample);
00058     virtual AP4_Result         WriteFields(AP4_ByteStream& stream);
00059
00060 private:
00061     // methods
00062     AP4_StssAtom(AP4_UI32        size,
00063                  AP4_UI32        version,
00064                  AP4_UI32        flags,
00065                  AP4_ByteStream& stream);
00066
00067     // members
00068     AP4_Array<AP4_UI32> m_Entries;
00069     AP4_Ordinal         m_LookupCache;
00070 };
00071
00072 #endif // _AP4_STSS_ATOM_H_
Generated on Thu May 13 16:36:33 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4StszAtom.h File Reference

  • File List
  • File Members

Ap4StszAtom.h File Reference

#include "Ap4Array.h"
#include "Ap4Atom.h"

Go to the source code of this file.

Classes

class AP4_StszAtom
Generated on Thu May 13 16:36:40 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4StszAtom.h Source File

  • File List
  • File Members

Ap4StszAtom.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - stsz Atoms
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027  ****************************************************************/
00028
00029 #ifndef _AP4_STSZ_ATOM_H_
00030 #define _AP4_STSZ_ATOM_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Array.h"
00036 #include "Ap4Atom.h"
00037
00038 /*----------------------------------------------------------------------
00039 |   AP4_StszAtom
00040 +---------------------------------------------------------------------*/
00041 class AP4_StszAtom : public AP4_Atom
00042 {
00043 public:
00044     AP4_IMPLEMENT_DYNAMIC_CAST_D(AP4_StszAtom, AP4_Atom)
00045
00046     // class methods
00047     static AP4_StszAtom* Create(AP4_Size size, AP4_ByteStream& stream);
00048
00049     // methods
00050     AP4_StszAtom();
00051     virtual AP4_Result InspectFields(AP4_AtomInspector& inspector);
00052     virtual AP4_Result WriteFields(AP4_ByteStream& stream);
00053     virtual AP4_UI32   GetSampleCount();
00054     virtual AP4_Result GetSampleSize(AP4_Ordinal sample,
00055                                      AP4_Size&   sample_size);
00066     virtual AP4_Result SetSampleSize(AP4_Ordinal sample,
00067                                      AP4_Size    sample_size);
00068     virtual AP4_Result AddEntry(AP4_UI32 size);
00069
00070 private:
00071     // methods
00072     AP4_StszAtom(AP4_UI32        size,
00073                  AP4_UI32        version,
00074                  AP4_UI32        flags,
00075                  AP4_ByteStream& stream);
00076
00077     // members
00078     AP4_UI32            m_SampleSize;
00079     AP4_UI32            m_SampleCount;
00080     AP4_Array<AP4_UI32> m_Entries;
00081 };
00082
00083 #endif // _AP4_STSZ_ATOM_H_
Generated on Thu May 13 16:36:33 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4SttsAtom.h File Reference

  • File List
  • File Members

Ap4SttsAtom.h File Reference

#include "Ap4Array.h"
#include "Ap4Atom.h"

Go to the source code of this file.

Classes

class | AP4_SttsTableEntry
class | AP4_SttsAtom
Generated on Thu May 13 16:36:40 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4SttsAtom.h Source File

  • File List
  • File Members

Ap4SttsAtom.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - stts Atoms
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027  ****************************************************************/
00028
00029 #ifndef _AP4_STTS_ATOM_H_
00030 #define _AP4_STTS_ATOM_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Array.h"
00036 #include "Ap4Atom.h"
00037
00038 /*----------------------------------------------------------------------
00039 |   AP4_SttsTableEntry
00040 +---------------------------------------------------------------------*/
00041 class AP4_SttsTableEntry {
00042  public:
00043     AP4_SttsTableEntry() :
00044         m_SampleCount(0),
00045         m_SampleDuration(0) {}
00046     AP4_SttsTableEntry(AP4_UI32 sample_count,
00047                        AP4_UI32 sample_duration) :
00048         m_SampleCount(sample_count),
00049         m_SampleDuration(sample_duration) {}
00050
00051     AP4_UI32 m_SampleCount;
00052     AP4_UI32 m_SampleDuration;
00053 };
00054
00055 /*----------------------------------------------------------------------
00056 |   AP4_SttsAtom
00057 +---------------------------------------------------------------------*/
00058 class AP4_SttsAtom : public AP4_Atom
00059 {
00060 public:
00061     AP4_IMPLEMENT_DYNAMIC_CAST_D(AP4_SttsAtom, AP4_Atom)
00062
00063     // class methods
00064     static AP4_SttsAtom* Create(AP4_Size size, AP4_ByteStream& stream);
00065
00066     // methods
00067     AP4_SttsAtom();
00068     virtual AP4_Result InspectFields(AP4_AtomInspector& inspector);
00069     virtual AP4_Result GetDts(AP4_Ordinal sample, AP4_UI64& dts, AP4_UI32* duration = NULL);
00070     virtual AP4_Result AddEntry(AP4_UI32 sample_count, AP4_UI32 sample_duration);
00071     virtual AP4_Result GetSampleIndexForTimeStamp(AP4_UI64      ts,
00072                                                   AP4_Ordinal&  sample_index);
00073     virtual AP4_Result WriteFields(AP4_ByteStream& stream);
00074
00075 private:
00076     // methods
00077     AP4_SttsAtom(AP4_UI32        size,
00078                  AP4_UI32        version,
00079                  AP4_UI32        flags,
00080                  AP4_ByteStream& stream);
00081
00082     // members
00083     AP4_Array<AP4_SttsTableEntry> m_Entries;
00084     struct {
00085         AP4_Ordinal entry_index;
00086         AP4_Ordinal sample;
00087         AP4_UI64    dts;
00088     } m_LookupCache;
00089 };
00090
00091 #endif // _AP4_STTS_ATOM_H_
Generated on Thu May 13 16:36:33 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4SyntheticSampleTable.h File Reference

  • File List
  • File Members

Ap4SyntheticSampleTable.h File Reference

#include "Ap4Array.h"
#include "Ap4List.h"
#include "Ap4Sample.h"
#include "Ap4SampleTable.h"
#include "Ap4SampleDescription.h"

Go to the source code of this file.

Classes

class | AP4_SyntheticSampleTable
class | AP4_SyntheticSampleTable::SampleDescriptionHolder

Variables

const AP4_Cardinal | AP4_SYNTHETIC_SAMPLE_TABLE_DEFAULT_CHUNK_SIZE = 10

Variable Documentation

const AP4_Cardinal AP4_SYNTHETIC_SAMPLE_TABLE_DEFAULT_CHUNK_SIZE = 10

Definition at line 49 of file Ap4SyntheticSampleTable.h.

Generated on Thu May 13 16:36:40 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4SyntheticSampleTable.h Source File

  • File List
  • File Members

Ap4SyntheticSampleTable.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - Synthetic Sample Table
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027  ****************************************************************/
00028
00029 #ifndef _AP4_SYNTHETIC_SAMPLE_TABLE_H_
00030 #define _AP4_SYNTHETIC_SAMPLE_TABLE_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Array.h"
00036 #include "Ap4List.h"
00037 #include "Ap4Sample.h"
00038 #include "Ap4SampleTable.h"
00039 #include "Ap4SampleDescription.h"
00040
00041 /*----------------------------------------------------------------------
00042 |   forward declarations
00043 +---------------------------------------------------------------------*/
00044 class AP4_ByteStream;
00045
00046 /*----------------------------------------------------------------------
00047 |   constants
00048 +---------------------------------------------------------------------*/
00049 const AP4_Cardinal AP4_SYNTHETIC_SAMPLE_TABLE_DEFAULT_CHUNK_SIZE = 10;
00050
00051 /*----------------------------------------------------------------------
00052 |   AP4_SyntheticSampleTable
00053 +---------------------------------------------------------------------*/
00054 class AP4_SyntheticSampleTable : public AP4_SampleTable
00055 {
00056  public:
00057     // methods
00058              AP4_SyntheticSampleTable(AP4_Cardinal chunk_size
00059                                       = AP4_SYNTHETIC_SAMPLE_TABLE_DEFAULT_CHUNK_SIZE);
00060     virtual ~AP4_SyntheticSampleTable();
00061
00062     // AP4_SampleTable methods
00063     virtual AP4_Result GetSample(AP4_Ordinal index, AP4_Sample& sample);
00064     virtual AP4_Cardinal GetSampleCount();
00065     virtual AP4_Result   GetSampleChunkPosition(AP4_Ordinal  sample_index,
00066                                                 AP4_Ordinal& chunk_index,
00067                                                 AP4_Ordinal& position_in_chunk);
00068     virtual AP4_Cardinal GetSampleDescriptionCount();
00069     virtual AP4_SampleDescription* GetSampleDescription(AP4_Ordinal index);
00070     virtual AP4_Result GetSampleIndexForTimeStamp(AP4_UI64 ts, AP4_Ordinal& index);
00071     virtual AP4_Ordinal  GetNearestSyncSampleIndex(AP4_Ordinal index, bool before);
00072
00073     // methods
00086     virtual AP4_Result AddSampleDescription(AP4_SampleDescription* description,
00087                                             bool                   transfer_ownership=true);
00088
00113     virtual AP4_Result AddSample(AP4_ByteStream& data_stream,
00114                                  AP4_Position    offset,
00115                                  AP4_Size        size,
00116                                  AP4_UI32        duration,
00117                                  AP4_Ordinal     description_index,
00118                                  AP4_UI64        dts,
00119                                  AP4_UI32        cts_delta,
00120                                  bool            sync);
00121
00122 private:
00123     // classes
00124     class SampleDescriptionHolder {
00125     public:
00126         SampleDescriptionHolder(AP4_SampleDescription* description, bool is_owned) :
00127             m_SampleDescription(description), m_IsOwned(is_owned) {}
00128         ~SampleDescriptionHolder() { if (m_IsOwned) delete m_SampleDescription; }
00129         AP4_SampleDescription* m_SampleDescription;
00130         bool                   m_IsOwned;
00131     };
00132
00133     // members
00134     AP4_Array<AP4_Sample>             m_Samples;
00135     AP4_List<SampleDescriptionHolder> m_SampleDescriptions;
00136     AP4_Cardinal                      m_ChunkSize;
00137     AP4_Array<AP4_UI32>               m_SamplesInChunk;
00138     struct {
00139         AP4_Ordinal m_Sample;
00140         AP4_Ordinal m_Chunk;
00141     } m_LookupCache;
00142 };
00143
00144 #endif // _AP4_SYNTHETIC_SAMPLE_TABLE_H_
Generated on Thu May 13 16:36:33 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4TfhdAtom.h File Reference

  • File List
  • File Members

Ap4TfhdAtom.h File Reference

#include "Ap4Atom.h"

Go to the source code of this file.

Classes

class | AP4_TfhdAtom

Variables

const AP4_UI32 | AP4_TFHD_FLAG_BASE_DATA_OFFSET_PRESENT = 0x00001
const AP4_UI32 | AP4_TFHD_FLAG_SAMPLE_DESCRIPTION_INDEX_PRESENT = 0x00002
const AP4_UI32 | AP4_TFHD_FLAG_DEFAULT_SAMPLE_DURATION_PRESENT = 0x00008
const AP4_UI32 | AP4_TFHD_FLAG_DEFAULT_SAMPLE_SIZE_PRESENT = 0x00010
const AP4_UI32 | AP4_TFHD_FLAG_DEFAULT_SAMPLE_FLAGS_PRESENT = 0x00020
const AP4_UI32 | AP4_TFHD_FLAG_DURATION_IS_EMPTY = 0x10000

Variable Documentation

const AP4_UI32 AP4_TFHD_FLAG_BASE_DATA_OFFSET_PRESENT = 0x00001

Definition at line 40 of file Ap4TfhdAtom.h.

const AP4_UI32 AP4_TFHD_FLAG_DEFAULT_SAMPLE_DURATION_PRESENT = 0x00008

Definition at line 42 of file Ap4TfhdAtom.h.

const AP4_UI32 AP4_TFHD_FLAG_DEFAULT_SAMPLE_FLAGS_PRESENT = 0x00020

Definition at line 44 of file Ap4TfhdAtom.h.

const AP4_UI32 AP4_TFHD_FLAG_DEFAULT_SAMPLE_SIZE_PRESENT = 0x00010

Definition at line 43 of file Ap4TfhdAtom.h.

const AP4_UI32 AP4_TFHD_FLAG_DURATION_IS_EMPTY = 0x10000

Definition at line 45 of file Ap4TfhdAtom.h.

const AP4_UI32 AP4_TFHD_FLAG_SAMPLE_DESCRIPTION_INDEX_PRESENT = 0x00002

Definition at line 41 of file Ap4TfhdAtom.h.

Generated on Thu May 13 16:36:40 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4TfhdAtom.h Source File

  • File List
  • File Members

Ap4TfhdAtom.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - tfhd Atoms
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027  ****************************************************************/
00028
00029 #ifndef _AP4_TFHD_ATOM_H_
00030 #define _AP4_TFHD_ATOM_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Atom.h"
00036
00037 /*----------------------------------------------------------------------
00038 |   constants
00039 +---------------------------------------------------------------------*/
00040 const AP4_UI32 AP4_TFHD_FLAG_BASE_DATA_OFFSET_PRESENT         = 0x00001;
00041 const AP4_UI32 AP4_TFHD_FLAG_SAMPLE_DESCRIPTION_INDEX_PRESENT = 0x00002;
00042 const AP4_UI32 AP4_TFHD_FLAG_DEFAULT_SAMPLE_DURATION_PRESENT  = 0x00008;
00043 const AP4_UI32 AP4_TFHD_FLAG_DEFAULT_SAMPLE_SIZE_PRESENT      = 0x00010;
00044 const AP4_UI32 AP4_TFHD_FLAG_DEFAULT_SAMPLE_FLAGS_PRESENT     = 0x00020;
00045 const AP4_UI32 AP4_TFHD_FLAG_DURATION_IS_EMPTY                = 0x10000;
00046
00047 /*----------------------------------------------------------------------
00048 |   AP4_TfhdAtom
00049 +---------------------------------------------------------------------*/
00050 class AP4_TfhdAtom : public AP4_Atom
00051 {
00052 public:
00053     AP4_IMPLEMENT_DYNAMIC_CAST(AP4_TfhdAtom)
00054
00055     // class methods
00056     static AP4_TfhdAtom* Create(AP4_Size size, AP4_ByteStream& stream);
00057     static AP4_UI32      ComputeSize(AP4_UI32 flags);
00058
00059     // methods
00060     AP4_TfhdAtom(AP4_UI32 flags,
00061                  AP4_UI32 track_id,
00062                  AP4_UI64 base_data_offset,
00063                  AP4_UI32 sample_description_index,
00064                  AP4_UI32 default_sample_duration,
00065                  AP4_UI32 default_sample_size,
00066                  AP4_UI32 default_sample_flags);
00067     virtual AP4_Result InspectFields(AP4_AtomInspector& inspector);
00068     virtual AP4_Result WriteFields(AP4_ByteStream& stream);
00069
00070     AP4_UI32 GetTrackId()                                { return m_TrackId;                   }
00071     void     SetTrackId(AP4_UI32 track_id)               { m_TrackId = track_id;               }
00072     AP4_UI64 GetBaseDataOffset()                         { return m_BaseDataOffset;            }
00073     void     SetBaseDataOffset(AP4_UI64 offset)          { m_BaseDataOffset = offset;          }
00074     AP4_UI32 GetSampleDescriptionIndex()                 { return m_SampleDescriptionIndex;    }
00075     void     SetSampleDescriptionIndex(AP4_UI32 indx)    { m_SampleDescriptionIndex = indx;    }
00076     AP4_UI32 GetDefaultSampleDuration()                  { return m_DefaultSampleDuration;     }
00077     void     SetDefaultSampleDuration(AP4_UI32 duration) { m_DefaultSampleDuration = duration; }
00078     AP4_UI32 GetDefaultSampleSize()                      { return m_DefaultSampleSize;         }
00079     void     SetDefaultSampleSize(AP4_UI32 size)         { m_DefaultSampleSize = size;         }
00080     AP4_UI32 GetDefaultSampleFlags()                     { return m_DefaultSampleFlags;        }
00081     void     SetDefaultSampleFlags(AP4_UI32 flags)       { m_DefaultSampleFlags = flags;       }
00082
00083 private:
00084     // methods
00085     AP4_TfhdAtom(AP4_UI32        size,
00086                  AP4_UI32        version,
00087                  AP4_UI32        flags,
00088                  AP4_ByteStream& stream);
00089
00090     // members
00091     AP4_UI32 m_TrackId;
00092     AP4_UI64 m_BaseDataOffset;
00093     AP4_UI32 m_SampleDescriptionIndex;
00094     AP4_UI32 m_DefaultSampleDuration;
00095     AP4_UI32 m_DefaultSampleSize;
00096     AP4_UI32 m_DefaultSampleFlags;
00097 };
00098
00099 #endif // _AP4_TFHD_ATOM_H_
Generated on Thu May 13 16:36:33 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4TfraAtom.h File Reference

  • File List
  • File Members

Ap4TfraAtom.h File Reference

#include "Ap4Types.h"
#include "Ap4Atom.h"
#include "Ap4Array.h"

Go to the source code of this file.

Classes

class | AP4_TfraAtom
struct | AP4_TfraAtom::Entry
Generated on Thu May 13 16:36:40 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4TfraAtom.h Source File

  • File List
  • File Members

Ap4TfraAtom.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - tfra Atoms
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027  ****************************************************************/
00028
00029 #ifndef _AP4_TFRA_ATOM_H_
00030 #define _AP4_TFRA_ATOM_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Types.h"
00036 #include "Ap4Atom.h"
00037 #include "Ap4Array.h"
00038
00039 /*----------------------------------------------------------------------
00040 |   class references
00041 +---------------------------------------------------------------------*/
00042 class AP4_ByteStream;
00043
00044 /*----------------------------------------------------------------------
00045 |   AP4_TfraAtom
00046 +---------------------------------------------------------------------*/
00047 class AP4_TfraAtom : public AP4_Atom
00048 {
00049 public:
00050     AP4_IMPLEMENT_DYNAMIC_CAST_D(AP4_TfraAtom, AP4_Atom)
00051
00052     // types
00053     struct Entry {
00054         Entry() : m_Time(0), m_MoofOffset(0), m_TrafNumber(0), m_TrunNumber(0), m_SampleNumber(0) {}
00055         AP4_UI64 m_Time;
00056         AP4_UI64 m_MoofOffset;
00057         AP4_UI32 m_TrafNumber;
00058         AP4_UI32 m_TrunNumber;
00059         AP4_UI32 m_SampleNumber;
00060     };
00061
00062     // class methods
00063     static AP4_TfraAtom* Create(AP4_Size size, AP4_ByteStream& stream);
00064
00065     // constructors
00066     AP4_TfraAtom();
00067
00068     // methods
00069     virtual AP4_Result InspectFields(AP4_AtomInspector& inspector);
00070     virtual AP4_Result WriteFields(AP4_ByteStream& stream);
00071
00072     // accessors
00073     AP4_Array<Entry>& GetEntries() { return m_Entries; }
00074
00075 private:
00076     // methods
00077     AP4_TfraAtom(AP4_UI32 size, AP4_UI32 version, AP4_UI32 flags, AP4_ByteStream& stream);
00078
00079     // members
00080     AP4_UI32         m_TrackId;
00081     AP4_UI08         m_LengthSizeOfTrafNumber;
00082     AP4_UI08         m_LengthSizeOfTrunNumber;
00083     AP4_UI08         m_LengthSizeOfSampleNumber;
00084     AP4_Array<Entry> m_Entries;
00085 };
00086
00087 #endif // _AP4_TFRA_ATOM_H_
Generated on Thu May 13 16:36:33 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4TimsAtom.h File Reference

  • File List
  • File Members

Ap4TimsAtom.h File Reference

#include "Ap4Atom.h"

Go to the source code of this file.

Classes

class AP4_TimsAtom
Generated on Thu May 13 16:36:40 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4TimsAtom.h Source File

  • File List
  • File Members

Ap4TimsAtom.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - tims Atoms
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027 ****************************************************************/
00028
00029 #ifndef _AP4_TIMS_ATOM_H_
00030 #define _AP4_TIMS_ATOM_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Atom.h"
00036
00037 /*----------------------------------------------------------------------
00038 |   AP4_TimsAtom
00039 +---------------------------------------------------------------------*/
00040 class AP4_TimsAtom : public AP4_Atom
00041 {
00042 public:
00043     // class methods
00044     static AP4_TimsAtom* Create(AP4_Size size, AP4_ByteStream& stream) {
00045         return new AP4_TimsAtom(size, stream);
00046     }
00047
00048     // methods
00049     AP4_TimsAtom(AP4_UI32 timescale);
00050     virtual AP4_Result InspectFields(AP4_AtomInspector& inspector);
00051     virtual AP4_Result WriteFields(AP4_ByteStream& stream);
00052
00053     // accessors
00054     virtual AP4_UI32 GetTimeScale() { return m_TimeScale; }
00055
00056 private:
00057     // methods
00058     AP4_TimsAtom(AP4_UI32 size, AP4_ByteStream& stream);
00059
00060     // members
00061     AP4_UI32 m_TimeScale;
00062 };
00063
00064 #endif // _AP4_TIMS_ATOM_H_
Generated on Thu May 13 16:36:33 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4TkhdAtom.h File Reference

  • File List
  • File Members

Ap4TkhdAtom.h File Reference

#include "Ap4Atom.h"

Go to the source code of this file.

Classes

class | AP4_TkhdAtom

Variables

const int | AP4_TKHD_FLAG_TRACK_ENABLED = 1
const int | AP4_TKHD_FLAG_TRACK_IN_MOVIE = 2
const int | AP4_TKHD_FLAG_TRACK_IN_PREVIEW = 4
const int | AP4_TKHD_FLAG_DEFAULTS = 7

Variable Documentation

const int AP4_TKHD_FLAG_DEFAULTS = 7

Definition at line 44 of file Ap4TkhdAtom.h.

const int AP4_TKHD_FLAG_TRACK_ENABLED = 1

Definition at line 40 of file Ap4TkhdAtom.h.

const int AP4_TKHD_FLAG_TRACK_IN_MOVIE = 2

Definition at line 41 of file Ap4TkhdAtom.h.

const int AP4_TKHD_FLAG_TRACK_IN_PREVIEW = 4

Definition at line 42 of file Ap4TkhdAtom.h.

Generated on Thu May 13 16:36:40 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4TkhdAtom.h Source File

  • File List
  • File Members

Ap4TkhdAtom.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - tkhd Atoms
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027  ****************************************************************/
00028
00029 #ifndef _AP4_TKHD_ATOM_H_
00030 #define _AP4_TKHD_ATOM_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Atom.h"
00036
00037 /*----------------------------------------------------------------------
00038 |   constants
00039 +---------------------------------------------------------------------*/
00040 const int AP4_TKHD_FLAG_TRACK_ENABLED    = 1;
00041 const int AP4_TKHD_FLAG_TRACK_IN_MOVIE   = 2;
00042 const int AP4_TKHD_FLAG_TRACK_IN_PREVIEW = 4;
00043
00044 const int AP4_TKHD_FLAG_DEFAULTS         = 7;
00045
00046 /*----------------------------------------------------------------------
00047 |   AP4_TkhdAtom
00048 +---------------------------------------------------------------------*/
00049 class AP4_TkhdAtom : public AP4_Atom
00050 {
00051 public:
00052     AP4_IMPLEMENT_DYNAMIC_CAST_D(AP4_TkhdAtom, AP4_Atom)
00053
00054     // class methods
00055     static AP4_TkhdAtom* Create(AP4_Size size, AP4_ByteStream& stream);
00056
00057     // methods
00058     AP4_TkhdAtom(AP4_UI32 creation_time,
00059                  AP4_UI32 modification_time,
00060                  AP4_UI32 track_id,
00061                  AP4_UI64 duration,
00062                  AP4_UI16 volume,
00063                  AP4_UI32 width,
00064                  AP4_UI32 height);
00065     virtual AP4_Result InspectFields(AP4_AtomInspector& inspector);
00066     virtual AP4_Result WriteFields(AP4_ByteStream& stream);
00067
00068     AP4_UI64   GetDuration()                  { return m_Duration;     }
00069     void       SetDuration(AP4_UI64 duration) { m_Duration = duration; }
00070     AP4_UI32   GetTrackId()                   { return m_TrackId;      }
00071     void       SetTrackId(AP4_UI32 track_id)  { m_TrackId = track_id;  }
00072
00073     void GetTranslation(float& x, float& y) {
00074         x = (float)(*(int*)&m_Matrix[6]) / 65536;
00075         y = (float)(*(int*)&m_Matrix[7]) / 65536;
00076     }
00077
00078     AP4_UI32 GetWidth()                 { return m_Width;    }
00079     void     SetWidth(AP4_UI32 width)   { m_Width = width;   }
00080     AP4_UI32 GetHeight()                { return m_Height;   }
00081     void     SetHeight(AP4_UI32 height) { m_Height = height; }
00082
00083  private:
00084     // methods
00085     AP4_TkhdAtom(AP4_UI32        size,
00086                  AP4_UI32        version,
00087                  AP4_UI32        flags,
00088                  AP4_ByteStream& stream);
00089
00090     // members
00091     AP4_UI64 m_CreationTime;
00092     AP4_UI64 m_ModificationTime;
00093     AP4_UI32 m_TrackId;
00094     AP4_UI32 m_Reserved1;
00095     AP4_UI64 m_Duration;
00096     AP4_UI32 m_Reserved2[2];
00097     AP4_UI16 m_Layer;
00098     AP4_UI16 m_AlternateGroup;
00099     AP4_UI16 m_Volume;
00100     AP4_UI16 m_Reserved3;
00101     AP4_UI32 m_Matrix[9];
00102     AP4_UI32 m_Width;
00103     AP4_UI32 m_Height;
00104 };
00105
00106 #endif // _AP4_TKHD_ATOM_H_
Generated on Thu May 13 16:36:34 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4Track.h File Reference

  • File List
  • File Members

Ap4Track.h File Reference

#include "Ap4Types.h"
#include "Ap4Array.h"

Go to the source code of this file.

Classes

class | AP4_Track

Variables

const AP4_UI32 | AP4_TRACK_DEFAULT_MOVIE_TIMESCALE = 1000
const AP4_UI32 | AP4_TRACK_FLAG_ENABLED = 0x0001
const AP4_UI32 | AP4_TRACK_FLAG_IN_MOVIE = 0x0002
const AP4_UI32 | AP4_TRACK_FLAG_IN_PREVIEW = 0x0004

Variable Documentation

const AP4_UI32 AP4_TRACK_DEFAULT_MOVIE_TIMESCALE = 1000

Definition at line 53 of file Ap4Track.h.

const AP4_UI32 AP4_TRACK_FLAG_ENABLED = 0x0001

Definition at line 55 of file Ap4Track.h.

const AP4_UI32 AP4_TRACK_FLAG_IN_MOVIE = 0x0002

Definition at line 56 of file Ap4Track.h.

const AP4_UI32 AP4_TRACK_FLAG_IN_PREVIEW = 0x0004

Definition at line 57 of file Ap4Track.h.

Generated on Thu May 13 16:36:40 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4Track.h Source File

  • File List
  • File Members

Ap4Track.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - Track Objects
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027  ****************************************************************/
00028
00029 #ifndef _AP4_TRAK_H_
00030 #define _AP4_TRAK_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Types.h"
00036 #include "Ap4Array.h"
00037
00038 /*----------------------------------------------------------------------
00039 |   forward declarations
00040 +---------------------------------------------------------------------*/
00041 class AP4_StblAtom;
00042 class AP4_ByteStream;
00043 class AP4_Sample;
00044 class AP4_DataBuffer;
00045 class AP4_TrakAtom;
00046 class AP4_MoovAtom;
00047 class AP4_SampleDescription;
00048 class AP4_SampleTable;
00049
00050 /*----------------------------------------------------------------------
00051 |   constants
00052 +---------------------------------------------------------------------*/
00053 const AP4_UI32 AP4_TRACK_DEFAULT_MOVIE_TIMESCALE = 1000;
00054
00055 const AP4_UI32 AP4_TRACK_FLAG_ENABLED    = 0x0001;
00056 const AP4_UI32 AP4_TRACK_FLAG_IN_MOVIE   = 0x0002;
00057 const AP4_UI32 AP4_TRACK_FLAG_IN_PREVIEW = 0x0004;
00058
00059 /*----------------------------------------------------------------------
00060 |   AP4_Track
00061 +---------------------------------------------------------------------*/
00062 class AP4_Track {
00063  public:
00064     // types
00065     typedef enum {
00066         TYPE_UNKNOWN = 0,
00067         TYPE_AUDIO   = 1,
00068         TYPE_VIDEO   = 2,
00069         TYPE_SYSTEM  = 3,
00070         TYPE_HINT    = 4,
00071         TYPE_TEXT    = 5,
00072         TYPE_JPEG    = 6,
00073         TYPE_RTP     = 7
00074     } Type;
00075
00076     // methods
00077     AP4_Track(Type             type,
00078               AP4_SampleTable* sample_table,     // ownership is transfered to the AP4_Track object
00079               AP4_UI32         track_id,
00080               AP4_UI32         movie_time_scale, // 0 = use default
00081               AP4_UI64         track_duration,   // in the movie timescale
00082               AP4_UI32         media_time_scale,
00083               AP4_UI64         media_duration,   // in the media timescale
00084               const char*      language,
00085               AP4_UI32         width,            // in 16.16 fixed point
00086               AP4_UI32         height);          // in 16.16 fixed point
00087     AP4_Track(AP4_TrakAtom&   atom,
00088               AP4_ByteStream& sample_stream,
00089               AP4_UI32        movie_time_scale);
00090     virtual ~AP4_Track();
00091
00097     AP4_Track* Clone(AP4_Result* result = NULL);
00098
00099     AP4_UI32     GetFlags();
00100     AP4_Result   SetFlags(AP4_UI32 flags);
00101     AP4_Track::Type GetType() { return m_Type; }
00102     AP4_UI32     GetHandlerType();
00103     AP4_UI64     GetDuration();   // in the timescale of the movie
00104     AP4_UI32     GetDurationMs(); // in milliseconds
00105     AP4_UI32     GetWidth();      // in 16.16 fixed point
00106     AP4_UI32     GetHeight();     // in 16.16 fixed point
00107     AP4_Cardinal GetSampleCount();
00108     AP4_Result   GetSample(AP4_Ordinal index, AP4_Sample& sample);
00109     AP4_Result   ReadSample(AP4_Ordinal     index,
00110                             AP4_Sample&     sample,
00111                             AP4_DataBuffer& data);
00112     AP4_Result   GetSampleIndexForTimeStampMs(AP4_UI32     ts_ms,
00113                                               AP4_Ordinal& index);
00114     AP4_Ordinal  GetNearestSyncSampleIndex(AP4_Ordinal index, bool before=true);
00115     AP4_SampleDescription* GetSampleDescription(AP4_Ordinal index);
00116     AP4_SampleTable*       GetSampleTable() { return m_SampleTable; }
00117     AP4_UI32      GetId();
00118     AP4_Result    SetId(AP4_UI32 track_id);
00119     AP4_TrakAtom* GetTrakAtom() { return m_TrakAtom; }
00120     AP4_Result    SetMovieTimeScale(AP4_UI32 time_scale);
00121     AP4_UI32      GetMovieTimeScale() { return m_MovieTimeScale; }
00122     AP4_UI32      GetMediaTimeScale();
00123     AP4_UI64      GetMediaDuration(); // in the timescale of the media
00124     const char*   GetTrackName();
00125     const char*   GetTrackLanguage();
00126     AP4_Result    Attach(AP4_MoovAtom* moov);
00127
00128  protected:
00129     // members
00130     AP4_TrakAtom*    m_TrakAtom;
00131     bool             m_TrakAtomIsOwned;
00132     Type             m_Type;
00133     AP4_SampleTable* m_SampleTable;
00134     bool             m_SampleTableIsOwned;
00135     AP4_UI32         m_MovieTimeScale;
00136 };
00137
00138 #endif // _AP4_TRAK_H_
Generated on Thu May 13 16:36:34 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4TrakAtom.h File Reference

  • File List
  • File Members

Ap4TrakAtom.h File Reference

#include "Ap4ContainerAtom.h"
#include "Ap4Array.h"

Go to the source code of this file.

Classes

class AP4_TrakAtom
Generated on Thu May 13 16:36:40 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4TrakAtom.h Source File

  • File List
  • File Members

Ap4TrakAtom.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - trak Atoms
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027  ****************************************************************/
00028
00029 #ifndef _AP4_TRAK_ATOM_H_
00030 #define _AP4_TRAK_ATOM_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4ContainerAtom.h"
00036 #include "Ap4Array.h"
00037
00038 /*----------------------------------------------------------------------
00039 |   class references
00040 +---------------------------------------------------------------------*/
00041 class AP4_HdlrAtom;
00042 class AP4_TkhdAtom;
00043 class AP4_MdhdAtom;
00044 class AP4_SampleTable;
00045
00046 /*----------------------------------------------------------------------
00047 |   AP4_TrakAtom
00048 +---------------------------------------------------------------------*/
00049 class AP4_TrakAtom : public AP4_ContainerAtom
00050 {
00051  public:
00052     AP4_IMPLEMENT_DYNAMIC_CAST_D(AP4_TrakAtom, AP4_ContainerAtom)
00053
00054     // class methods
00055      static AP4_TrakAtom* Create(AP4_Size         size,
00056                                  AP4_ByteStream&  stream,
00057                                  AP4_AtomFactory& atom_factory) {
00058         return new AP4_TrakAtom(size, stream, atom_factory);
00059     }
00060
00061     // methods
00062     AP4_TrakAtom(AP4_SampleTable* sample_table,
00063                  AP4_Atom::Type   hdlr_type,
00064                  const char*      hdlr_name,
00065                  AP4_UI32         track_id,
00066                  AP4_UI32         creation_time,
00067                  AP4_UI32         modification_time,
00068                  AP4_UI64         track_duration,
00069                  AP4_UI32         media_time_scale,
00070                  AP4_UI64         media_duration,
00071                  AP4_UI16         volume,
00072                  const char*      language,
00073                  AP4_UI32         width,
00074                  AP4_UI32         heigh);
00075     AP4_TkhdAtom* GetTkhdAtom() { return m_TkhdAtom; }
00076     AP4_Result AdjustChunkOffsets(AP4_SI64 delta);
00077     AP4_Result GetChunkOffsets(AP4_Array<AP4_UI64>& chunk_offsets);
00078     AP4_Result SetChunkOffsets(const AP4_Array<AP4_UI64>& chunk_offsets);
00079     AP4_UI32   GetId();
00080     AP4_Result SetId(AP4_UI32 track_id);
00081     AP4_UI64   GetDuration();
00082     AP4_Result SetDuration(AP4_UI64 duration);
00083     AP4_UI64   GetMediaDuration();
00084     AP4_Result SetMediaDuration(AP4_UI32 duration);
00085     AP4_UI32   GetMediaTimeScale();
00086     AP4_Result SetMediaTimeScale(AP4_UI32 timescale);
00087     AP4_UI32   GetWidth();
00088     AP4_Result SetWidth(AP4_UI32 width);
00089     AP4_UI32   GetHeight();
00090     AP4_Result SetHeight(AP4_UI32 height);
00091
00092  private:
00093     // methods
00094     AP4_TrakAtom(AP4_UI32         size,
00095                  AP4_ByteStream&  stream,
00096                  AP4_AtomFactory& atom_factory);
00097
00098     // members
00099     AP4_TkhdAtom* m_TkhdAtom;
00100     AP4_MdhdAtom* m_MdhdAtom;
00101 };
00102
00103 #endif // _AP4_TRAK_ATOM_H_
Generated on Thu May 13 16:36:34 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4TrefTypeAtom.h File Reference

  • File List
  • File Members

Ap4TrefTypeAtom.h File Reference

#include "Ap4Atom.h"
#include "Ap4Array.h"

Go to the source code of this file.

Classes

class AP4_TrefTypeAtom
Generated on Thu May 13 16:36:40 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4TrefTypeAtom.h Source File

  • File List
  • File Members

Ap4TrefTypeAtom.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - tref type Atoms
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027 ****************************************************************/
00028
00029 #ifndef _AP4_TREF_TYPE_ATOM_H_
00030 #define _AP4_TREF_TYPE_ATOM_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Atom.h"
00036 #include "Ap4Array.h"
00037
00038 /*----------------------------------------------------------------------
00039 |   AP4_TrefTypeAtom
00040 +---------------------------------------------------------------------*/
00041 class AP4_TrefTypeAtom : public AP4_Atom
00042 {
00043 public:
00044     AP4_IMPLEMENT_DYNAMIC_CAST_D(AP4_TrefTypeAtom, AP4_Atom)
00045
00046     // class methods
00047     static AP4_TrefTypeAtom* Create(AP4_Atom::Type  type,
00048                                     AP4_UI32        size,
00049                                     AP4_ByteStream& stream) {
00050         return new AP4_TrefTypeAtom(type, size, stream);
00051     }
00052
00053     // contructor
00054     AP4_TrefTypeAtom(AP4_Atom::Type type);
00055
00056     // methods
00057     virtual AP4_Result InspectFields(AP4_AtomInspector& inspector);
00058     virtual AP4_Result WriteFields(AP4_ByteStream& stream);
00059     AP4_Result AddTrackId(AP4_UI32 track_id);
00060
00061     // accessors
00062     const AP4_Array<AP4_UI32>& GetTrackIds() { return m_TrackIds; }
00063
00064 private:
00065     // methods
00066     AP4_TrefTypeAtom(AP4_Atom::Type type, AP4_UI32 size, AP4_ByteStream& stream);
00067
00068     // members
00069     AP4_Array<AP4_UI32> m_TrackIds;
00070 };
00071
00072 #endif
00073
Generated on Thu May 13 16:36:34 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4TrexAtom.h File Reference

  • File List
  • File Members

Ap4TrexAtom.h File Reference

#include "Ap4List.h"
#include "Ap4Atom.h"

Go to the source code of this file.

Classes

class | AP4_TrexAtom

Defines

#define | AP4_TREX_SAMPLE_IS_DIFFERENCE_SAMPLE(_flags) ( (_flags)&

Define Documentation

#define AP4_TREX_SAMPLE_IS_DIFFERENCE_SAMPLE ( _flags ) ( (_flags)&

Definition at line 41 of file Ap4TrexAtom.h.

Generated on Thu May 13 16:36:40 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4TrexAtom.h Source File

  • File List
  • File Members

Ap4TrexAtom.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - trex Atoms
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027  ****************************************************************/
00028
00029 #ifndef _AP4_TREX_ATOM_H_
00030 #define _AP4_TREX_ATOM_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4List.h"
00036 #include "Ap4Atom.h"
00037
00038 /*----------------------------------------------------------------------
00039 |   macros
00040 +---------------------------------------------------------------------*/
00041 #define AP4_TREX_SAMPLE_IS_DIFFERENCE_SAMPLE(_flags) ( (_flags)&
00042
00043 /*----------------------------------------------------------------------
00044 |   AP4_TrexAtom
00045 +---------------------------------------------------------------------*/
00046 class AP4_TrexAtom : public AP4_Atom
00047 {
00048 public:
00049     AP4_IMPLEMENT_DYNAMIC_CAST_D(AP4_TrexAtom, AP4_Atom)
00050
00051     // class methods
00052     static AP4_TrexAtom* Create(AP4_Size size, AP4_ByteStream& stream);
00053
00054     // methods
00055     AP4_TrexAtom(AP4_UI32 track_id,
00056                  AP4_UI32 default_sample_description_index,
00057                  AP4_UI32 default_sample_duration,
00058                  AP4_UI32 default_sample_size,
00059                  AP4_UI32 default_sample_flags);
00060     virtual AP4_Result InspectFields(AP4_AtomInspector& inspector);
00061     virtual AP4_Result WriteFields(AP4_ByteStream& stream);
00062
00063     // accessors
00064     AP4_UI32 GetTrackId()                       { return m_TrackId;                       }
00065     AP4_UI32 GetDefaultSampleDescriptionIndex() { return m_DefaultSampleDescriptionIndex; }
00066     AP4_UI32 GetDefaultSampleDuration()         { return m_DefaultSampleDuration;         }
00067     AP4_UI32 GetDefaultSampleSize()             { return m_DefaultSampleSize;             }
00068     AP4_UI32 GetDefaultSampleFlags()            { return m_DefaultSampleFlags;            }
00069
00070 private:
00071     // methods
00072     AP4_TrexAtom(AP4_UI32        size,
00073                  AP4_UI32        version,
00074                  AP4_UI32        flags,
00075                  AP4_ByteStream& stream);
00076
00077     // members
00078     AP4_UI32 m_TrackId;
00079     AP4_UI32 m_DefaultSampleDescriptionIndex;
00080     AP4_UI32 m_DefaultSampleDuration;
00081     AP4_UI32 m_DefaultSampleSize;
00082     AP4_UI32 m_DefaultSampleFlags;
00083 };
00084
00085 #endif // _AP4_TREX_ATOM_H_
Generated on Thu May 13 16:36:34 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4TrunAtom.h File Reference

  • File List
  • File Members

Ap4TrunAtom.h File Reference

#include "Ap4Atom.h"
#include "Ap4Array.h"

Go to the source code of this file.

Classes

class | AP4_TrunAtom
struct | AP4_TrunAtom::Entry

Variables

const AP4_UI32 | AP4_TRUN_FLAG_DATA_OFFSET_PRESENT = 0x0001
const AP4_UI32 | AP4_TRUN_FLAG_FIRST_SAMPLE_FLAGS_PRESENT = 0x0004
const AP4_UI32 | AP4_TRUN_FLAG_SAMPLE_DURATION_PRESENT = 0x0100
const AP4_UI32 | AP4_TRUN_FLAG_SAMPLE_SIZE_PRESENT = 0x0200
const AP4_UI32 | AP4_TRUN_FLAG_SAMPLE_FLAGS_PRESENT = 0x0400
const AP4_UI32 | AP4_TRUN_FLAG_SAMPLE_COMPOSITION_TIME_OFFSET_PRESENT = 0x0800

Variable Documentation

const AP4_UI32 AP4_TRUN_FLAG_DATA_OFFSET_PRESENT = 0x0001

Definition at line 41 of file Ap4TrunAtom.h.

const AP4_UI32 AP4_TRUN_FLAG_FIRST_SAMPLE_FLAGS_PRESENT = 0x0004

Definition at line 42 of file Ap4TrunAtom.h.

const AP4_UI32 AP4_TRUN_FLAG_SAMPLE_COMPOSITION_TIME_OFFSET_PRESENT = 0x0800

Definition at line 46 of file Ap4TrunAtom.h.

const AP4_UI32 AP4_TRUN_FLAG_SAMPLE_DURATION_PRESENT = 0x0100

Definition at line 43 of file Ap4TrunAtom.h.

const AP4_UI32 AP4_TRUN_FLAG_SAMPLE_FLAGS_PRESENT = 0x0400

Definition at line 45 of file Ap4TrunAtom.h.

const AP4_UI32 AP4_TRUN_FLAG_SAMPLE_SIZE_PRESENT = 0x0200

Definition at line 44 of file Ap4TrunAtom.h.

Generated on Thu May 13 16:36:40 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4TrunAtom.h Source File

  • File List
  • File Members

Ap4TrunAtom.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - trun Atoms
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027  ****************************************************************/
00028
00029 #ifndef _AP4_TRUN_ATOM_H_
00030 #define _AP4_TRUN_ATOM_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Atom.h"
00036 #include "Ap4Array.h"
00037
00038 /*----------------------------------------------------------------------
00039 |   constants
00040 +---------------------------------------------------------------------*/
00041 const AP4_UI32 AP4_TRUN_FLAG_DATA_OFFSET_PRESENT                    = 0x0001;
00042 const AP4_UI32 AP4_TRUN_FLAG_FIRST_SAMPLE_FLAGS_PRESENT             = 0x0004;
00043 const AP4_UI32 AP4_TRUN_FLAG_SAMPLE_DURATION_PRESENT                = 0x0100;
00044 const AP4_UI32 AP4_TRUN_FLAG_SAMPLE_SIZE_PRESENT                    = 0x0200;
00045 const AP4_UI32 AP4_TRUN_FLAG_SAMPLE_FLAGS_PRESENT                   = 0x0400;
00046 const AP4_UI32 AP4_TRUN_FLAG_SAMPLE_COMPOSITION_TIME_OFFSET_PRESENT = 0x0800;
00047
00048 /*----------------------------------------------------------------------
00049 |   AP4_TrunAtom
00050 +---------------------------------------------------------------------*/
00051 class AP4_TrunAtom : public AP4_Atom
00052 {
00053 public:
00054     AP4_IMPLEMENT_DYNAMIC_CAST(AP4_TrunAtom)
00055
00056     // types
00057     struct Entry {
00058         Entry() : sample_duration(0), sample_size(0), sample_flags(0), sample_composition_time_offset(0) {}
00059         AP4_UI32 sample_duration;
00060         AP4_UI32 sample_size;
00061         AP4_UI32 sample_flags;
00062         AP4_UI32 sample_composition_time_offset;
00063     };
00064
00065     // class methods
00066     static AP4_TrunAtom* Create(AP4_Size size, AP4_ByteStream& stream);
00067     static unsigned int  ComputeOptionalFieldsCount(AP4_UI32 flags);
00068     static unsigned int  ComputeRecordFieldsCount(AP4_UI32 flags);
00069
00070     // methods
00071     AP4_TrunAtom(AP4_UI32 flags,
00072                  AP4_SI32 data_offset,
00073                  AP4_UI32 first_sample_flags);
00074     virtual AP4_Result InspectFields(AP4_AtomInspector& inspector);
00075     virtual AP4_Result WriteFields(AP4_ByteStream& stream);
00076
00077     // accessors
00078     AP4_SI32                GetDataOffset()       { return m_DataOffset;       }
00079     AP4_UI32                GetFirstSampleFlags() { return m_FirstSampleFlags; }
00080     const AP4_Array<Entry>& GetEntries()          { return m_Entries;          }
00081
00082 private:
00083     // methods
00084     AP4_TrunAtom(AP4_UI32        size,
00085                  AP4_UI32        version,
00086                  AP4_UI32        flags,
00087                  AP4_ByteStream& stream);
00088
00089     // members
00090     AP4_SI32         m_DataOffset;
00091     AP4_UI32         m_FirstSampleFlags;
00092     AP4_Array<Entry> m_Entries;
00093 };
00094
00095 #endif // _AP4_TRUN_ATOM_H_
Generated on Thu May 13 16:36:34 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4Types.h File Reference

  • File List
  • File Members

Ap4Types.h File Reference

#include "Ap4Config.h"

Go to the source code of this file.

Classes

struct | AP4_UI64

Typedefs

typedef int | AP4_Result
typedef unsigned int | AP4_Flags
typedef unsigned int | AP4_Mask
typedef unsigned int | AP4_Cardinal
typedef unsigned int | AP4_Ordinal
typedef unsigned int | AP4_UI32
typedef signed int | AP4_SI32
typedef unsigned short | AP4_UI16
typedef signed short | AP4_SI16
typedef unsigned char | AP4_UI08
typedef AP4_UI08 | AP4_Byte
typedef AP4_UI32 | AP4_Size
typedef struct AP4_UI64 | AP4_SI64
typedef unsigned long | AP4_LargeSize
typedef long | AP4_Offset
typedef unsigned long | AP4_Position

Typedef Documentation

typedef AP4_UI08 AP4_Byte

Definition at line 50 of file Ap4Types.h.

typedef unsigned int AP4_Cardinal

Definition at line 43 of file Ap4Types.h.

typedef unsigned int AP4_Flags

Definition at line 41 of file Ap4Types.h.

typedef unsigned long AP4_LargeSize

Definition at line 67 of file Ap4Types.h.

typedef unsigned int AP4_Mask

Definition at line 42 of file Ap4Types.h.

typedef long AP4_Offset

Definition at line 68 of file Ap4Types.h.

typedef unsigned int AP4_Ordinal

Definition at line 44 of file Ap4Types.h.

typedef unsigned long AP4_Position

Definition at line 69 of file Ap4Types.h.

typedef int AP4_Result

Definition at line 40 of file Ap4Types.h.

typedef signed short AP4_SI16

Definition at line 48 of file Ap4Types.h.

typedef signed int AP4_SI32

Definition at line 46 of file Ap4Types.h.

typedef struct AP4_UI64 AP4_SI64
typedef AP4_UI32 AP4_Size

Definition at line 51 of file Ap4Types.h.

typedef unsigned char AP4_UI08

Definition at line 49 of file Ap4Types.h.

typedef unsigned short AP4_UI16

Definition at line 47 of file Ap4Types.h.

typedef unsigned int AP4_UI32

Definition at line 45 of file Ap4Types.h.

Generated on Thu May 13 16:36:40 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4Types.h Source File

  • File List
  • File Members

Ap4Types.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - Shared Types
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027  ****************************************************************/
00028
00029 #ifndef _AP4_TYPES_H_
00030 #define _AP4_TYPES_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Config.h"
00036
00037 /*----------------------------------------------------------------------
00038 |   types
00039 +---------------------------------------------------------------------*/
00040 typedef int            AP4_Result;
00041 typedef unsigned int   AP4_Flags;
00042 typedef unsigned int   AP4_Mask;
00043 typedef unsigned int   AP4_Cardinal;
00044 typedef unsigned int   AP4_Ordinal;
00045 typedef unsigned int   AP4_UI32;
00046 typedef signed   int   AP4_SI32;
00047 typedef unsigned short AP4_UI16;
00048 typedef signed   short AP4_SI16;
00049 typedef unsigned char  AP4_UI08;
00050 typedef AP4_UI08       AP4_Byte;
00051 typedef AP4_UI32       AP4_Size;
00052
00053 // the rest depends on whether the platform supports 64-bit integers
00054 #if defined(AP4_CONFIG_HAVE_INT64)
00055     // we have 64-bit integers
00056     typedef AP4_CONFIG_INT64_TYPE          AP4_SI64;
00057     typedef unsigned AP4_CONFIG_INT64_TYPE AP4_UI64;
00058     typedef unsigned AP4_CONFIG_INT64_TYPE AP4_LargeSize;
00059     typedef AP4_CONFIG_INT64_TYPE          AP4_Offset;
00060     typedef unsigned AP4_CONFIG_INT64_TYPE AP4_Position;
00061 #else
00062     // use only 32-bit integers
00063     typedef struct {
00064         AP4_UI32 hi;
00065         AP4_UI32 lo;
00066     } AP4_UI64, AP4_SI64;
00067     typedef unsigned long  AP4_LargeSize;
00068     typedef long           AP4_Offset;
00069     typedef unsigned long  AP4_Position;
00070 #endif
00071
00072 #ifndef NULL
00073 #define NULL 0
00074 #endif
00075
00076 #endif // _AP4_TYPES_H_
Generated on Thu May 13 16:36:34 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4UrlAtom.h File Reference

  • File List
  • File Members

Ap4UrlAtom.h File Reference

#include "Ap4Atom.h"
#include "Ap4String.h"

Go to the source code of this file.

Classes

class AP4_UrlAtom
Generated on Thu May 13 16:36:41 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4UrlAtom.h Source File

  • File List
  • File Members

Ap4UrlAtom.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - url Atoms
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027  ****************************************************************/
00028
00029 #ifndef _AP4_URL_ATOM_H_
00030 #define _AP4_URL_ATOM_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Atom.h"
00036 #include "Ap4String.h"
00037
00038 /*----------------------------------------------------------------------
00039 |   AP4_UrlAtom
00040 +---------------------------------------------------------------------*/
00041 class AP4_UrlAtom : public AP4_Atom
00042 {
00043 public:
00044     // class methods
00045     static AP4_UrlAtom* Create(AP4_Size size, AP4_ByteStream& stream);
00046
00047     // methods
00048     AP4_UrlAtom(); // local ref only (no URL string)
00049     virtual AP4_Result InspectFields(AP4_AtomInspector& inspector);
00050     virtual AP4_Result WriteFields(AP4_ByteStream& stream);
00051
00052 private:
00053     // methods
00054     AP4_UrlAtom(AP4_UI32        size,
00055                 AP4_UI32        version,
00056                 AP4_UI32        flags,
00057                 AP4_ByteStream& stream);
00058
00059     // members
00060     AP4_String m_Url;
00061 };
00062
00063 #endif // _AP4_URL_ATOM_H_
Generated on Thu May 13 16:36:34 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4Utils.h File Reference

  • File List
  • File Members

Ap4Utils.h File Reference

#include "Ap4Config.h"
#include "Ap4Types.h"
#include "Ap4Results.h"

Go to the source code of this file.

Classes

class | AP4_BitWriter

Functions

double | AP4_BytesToDoubleBE (const unsigned char *bytes)
AP4_UI64 | AP4_BytesToUInt64BE (const unsigned char *bytes)
void | AP4_BytesFromDoubleBE (unsigned char *bytes, double value)
void | AP4_BytesFromUInt64BE (unsigned char *bytes, AP4_UI64 value)
AP4_UI32 | AP4_BytesToUInt32BE (const unsigned char *bytes)
AP4_SI32 | AP4_BytesToInt32BE (const unsigned char *bytes)
AP4_UI32 | AP4_BytesToUInt24BE (const unsigned char *bytes)
AP4_UI16 | AP4_BytesToUInt16BE (const unsigned char *bytes)
AP4_SI16 | AP4_BytesToInt16BE (const unsigned char *bytes)
void | AP4_BytesFromUInt32BE (unsigned char *bytes, AP4_UI32 value)
void | AP4_BytesFromUInt24BE (unsigned char *bytes, AP4_UI32 value)
void | AP4_BytesFromUInt16BE (unsigned char *bytes, AP4_UI16 value)
AP4_UI32 | AP4_DurationMsFromUnits (AP4_UI64 units, AP4_UI32 units_per_second)
AP4_UI64 | AP4_ConvertTime (AP4_UI64 time_value, AP4_UI32 from_time_scale, AP4_UI32 to_time_scale)
int | AP4_FormatString (char *str, AP4_Size size, const char *format,...)
int | AP4_FormatStringVN (char *buffer, size_t count, const char *format, va_list argptr)
unsigned char | AP4_HexNibble (char c)
char | AP4_NibbleHex (unsigned int nibble)
void | AP4_FormatFourChars (char *str, AP4_UI32 value)
void | AP4_FormatFourCharsPrintable (char *str, AP4_UI32 value)
AP4_Result | AP4_ParseHex (const char *hex, unsigned char *bytes, unsigned int count)
AP4_Result | AP4_FormatHex (const AP4_UI08 *data, unsigned int data_size, char *hex)
AP4_Result | AP4_SplitArgs (char *arg, char *&arg0, char *&arg1, char *&arg2)
AP4_Result | AP4_SplitArgs (char *arg, char *&arg0, char *&arg1)

Function Documentation

void AP4_BytesFromDoubleBE | ( | unsigned char * | bytes,
 |  | double | value
 | ) |  |
void AP4_BytesFromUInt16BE | ( | unsigned char * | bytes,
 |  | AP4_UI16 | value |
 | ) |  |  | [inline]

Definition at line 129 of file Ap4Utils.h.

void AP4_BytesFromUInt24BE | ( | unsigned char * | bytes,
 |  | AP4_UI32 | value |
 | ) |  |  | [inline]

Definition at line 118 of file Ap4Utils.h.

void AP4_BytesFromUInt32BE | ( | unsigned char * | bytes,
 |  | AP4_UI32 | value |
 | ) |  |  | [inline]

Definition at line 106 of file Ap4Utils.h.

void AP4_BytesFromUInt64BE | ( | unsigned char * | bytes,
 |  | AP4_UI64 | value
 | ) |  |
double AP4_BytesToDoubleBE ( const unsigned char * bytes )
AP4_SI16 AP4_BytesToInt16BE ( const unsigned char * bytes ) [inline]

Definition at line 97 of file Ap4Utils.h.

References AP4_BytesToUInt16BE().

AP4_SI32 AP4_BytesToInt32BE ( const unsigned char * bytes ) [inline]

Definition at line 65 of file Ap4Utils.h.

References AP4_BytesToUInt32BE().

AP4_UI16 AP4_BytesToUInt16BE ( const unsigned char * bytes ) [inline]

Definition at line 86 of file Ap4Utils.h.

Referenced by AP4_BytesToInt16BE().

AP4_UI32 AP4_BytesToUInt24BE ( const unsigned char * bytes ) [inline]

Definition at line 74 of file Ap4Utils.h.

AP4_UI32 AP4_BytesToUInt32BE ( const unsigned char * bytes ) [inline]

Definition at line 52 of file Ap4Utils.h.

Referenced by AP4_BytesToInt32BE().

AP4_UI64 AP4_BytesToUInt64BE ( const unsigned char * bytes )
AP4_UI64 AP4_ConvertTime | ( | AP4_UI64 | time_value,
 |  | AP4_UI32 | from_time_scale,
 |  | AP4_UI32 | to_time_scale
 | ) |  |
AP4_UI32 AP4_DurationMsFromUnits | ( | AP4_UI64 | units,
 |  | AP4_UI32 | units_per_second
 | ) |  |
void AP4_FormatFourChars | ( | char * | str,
 |  | AP4_UI32 | value
 | ) |  |
void AP4_FormatFourCharsPrintable | ( | char * | str,
 |  | AP4_UI32 | value
 | ) |  |
AP4_Result AP4_FormatHex | ( | const AP4_UI08 * | data,
 |  | unsigned int | data_size,
 |  | char * | hex
 | ) |  |
int AP4_FormatString | ( | char * | str,
 |  | AP4_Size | size,
 |  | const char * | format,
 |  |  | ...
 | ) |  |
int AP4_FormatStringVN | ( | char * | buffer,
 |  | size_t | count,
 |  | const char * | format,
 |  | va_list | argptr
 | ) |  |
unsigned char AP4_HexNibble ( char c )
char AP4_NibbleHex ( unsigned int nibble )
AP4_Result AP4_ParseHex | ( | const char * | hex,
 |  | unsigned char * | bytes,
 |  | unsigned int | count
 | ) |  |
AP4_Result AP4_SplitArgs | ( | char * | arg,
 |  | char *& | arg0,
 |  | char *& | arg1
 | ) |  |
AP4_Result AP4_SplitArgs | ( | char * | arg,
 |  | char *& | arg0,
 |  | char *& | arg1,
 |  | char *& | arg2
 | ) |  |
Generated on Thu May 13 16:36:41 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4Utils.h Source File

  • File List
  • File Members

Ap4Utils.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - Utilities
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027  ****************************************************************/
00028
00029 #ifndef _AP4_UTILS_H_
00030 #define _AP4_UTILS_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Config.h"
00036 #include "Ap4Types.h"
00037 #include "Ap4Results.h"
00038 #include "Ap4Config.h"
00039
00040 /*----------------------------------------------------------------------
00041 |   non-inline functions
00042 +---------------------------------------------------------------------*/
00043 double   AP4_BytesToDoubleBE(const unsigned char* bytes);
00044 AP4_UI64 AP4_BytesToUInt64BE(const unsigned char* bytes);
00045 void AP4_BytesFromDoubleBE(unsigned char* bytes, double value);
00046 void AP4_BytesFromUInt64BE(unsigned char* bytes, AP4_UI64 value);
00047
00048 /*----------------------------------------------------------------------
00049 |   AP4_BytesToUInt32BE
00050 +---------------------------------------------------------------------*/
00051 inline AP4_UI32
00052 AP4_BytesToUInt32BE(const unsigned char* bytes)
00053 {
00054     return
00055         ( ((AP4_UI32)bytes[0])<<24 ) |
00056         ( ((AP4_UI32)bytes[1])<<16 ) |
00057         ( ((AP4_UI32)bytes[2])<<8  ) |
00058         ( ((AP4_UI32)bytes[3])     );
00059 }
00060
00061 /*----------------------------------------------------------------------
00062 |   AP4_BytesToInt32BE
00063 +---------------------------------------------------------------------*/
00064 inline AP4_SI32
00065 AP4_BytesToInt32BE(const unsigned char* bytes)
00066 {
00067     return AP4_BytesToUInt32BE(bytes);
00068 }
00069
00070 /*----------------------------------------------------------------------
00071 |   AP4_BytesToUInt24BE
00072 +---------------------------------------------------------------------*/
00073 inline AP4_UI32
00074 AP4_BytesToUInt24BE(const unsigned char* bytes)
00075 {
00076     return
00077         ( ((AP4_UI32)bytes[0])<<16 ) |
00078         ( ((AP4_UI32)bytes[1])<<8  ) |
00079         ( ((AP4_UI32)bytes[2])     );
00080 }
00081
00082 /*----------------------------------------------------------------------
00083 |   AP4_BytesToInt16BE
00084 +---------------------------------------------------------------------*/
00085 inline AP4_UI16
00086 AP4_BytesToUInt16BE(const unsigned char* bytes)
00087 {
00088     return
00089         ( ((AP4_UI16)bytes[0])<<8  ) |
00090         ( ((AP4_UI16)bytes[1])     );
00091 }
00092
00093 /*----------------------------------------------------------------------
00094 |   AP4_BytesToInt16BE
00095 +---------------------------------------------------------------------*/
00096 inline AP4_SI16
00097 AP4_BytesToInt16BE(const unsigned char* bytes)
00098 {
00099     return (AP4_SI16)AP4_BytesToUInt16BE(bytes);
00100 }
00101
00102 /*----------------------------------------------------------------------
00103 |   AP4_BytesFromUInt32BE
00104 +---------------------------------------------------------------------*/
00105 inline void
00106 AP4_BytesFromUInt32BE(unsigned char* bytes, AP4_UI32 value)
00107 {
00108     bytes[0] = (unsigned char)(value >> 24);
00109     bytes[1] = (unsigned char)(value >> 16);
00110     bytes[2] = (unsigned char)(value >>  8);
00111     bytes[3] = (unsigned char)(value      );
00112 }
00113
00114 /*----------------------------------------------------------------------
00115 |   AP4_BytesFromUInt24BE
00116 +---------------------------------------------------------------------*/
00117 inline void
00118 AP4_BytesFromUInt24BE(unsigned char* bytes, AP4_UI32 value)
00119 {
00120     bytes[0] = (unsigned char)(value >> 16);
00121     bytes[1] = (unsigned char)(value >>  8);
00122     bytes[2] = (unsigned char)(value      );
00123 }
00124
00125 /*----------------------------------------------------------------------
00126 |   AP4_BytesFromUInt16BE
00127 +---------------------------------------------------------------------*/
00128 inline void
00129 AP4_BytesFromUInt16BE(unsigned char* bytes, AP4_UI16 value)
00130 {
00131     bytes[0] = (unsigned char)(value >> 8);
00132     bytes[1] = (unsigned char)(value     );
00133 }
00134
00135 /*----------------------------------------------------------------------
00136 |   time functions
00137 +---------------------------------------------------------------------*/
00138 AP4_UI32 AP4_DurationMsFromUnits(AP4_UI64 units,
00139                                  AP4_UI32 units_per_second);
00140 AP4_UI64 AP4_ConvertTime(AP4_UI64 time_value,
00141                          AP4_UI32 from_time_scale,
00142                          AP4_UI32 to_time_scale);
00143
00144 /*----------------------------------------------------------------------
00145 |   string utils
00146 +---------------------------------------------------------------------*/
00147 #if defined (AP4_CONFIG_HAVE_STDIO_H)
00148 #include <stdio.h>
00149 #endif
00150
00151 #if defined (AP4_CONFIG_HAVE_SNPRINTF)
00152 #define AP4_FormatString AP4_snprintf
00153 #else
00154 int AP4_FormatString(char* str, AP4_Size size, const char* format, ...);
00155 #endif
00156 #if defined(AP4_CONFIG_HAVE_VSNPRINTF)
00157 #define AP4_FormatStringVN(s,c,f,a) AP4_vsnprintf(s,c,f,a)
00158 #else
00159 extern int AP4_FormatStringVN(char *buffer, size_t count, const char *format, va_list argptr);
00160 #endif
00161
00162 #if defined (AP4_CONFIG_HAVE_STRING_H)
00163 #include <string.h>
00164 #define AP4_StringLength(x) strlen(x)
00165 #define AP4_CopyMemory(x,y,z) memcpy(x,y,z)
00166 #define AP4_CompareMemory(x, y, z) memcmp(x, y, z)
00167 #define AP4_SetMemory(x,y,z) memset(x,y,z)
00168 #define AP4_CompareStrings(x,y) strcmp(x,y)
00169 #endif
00170
00171 unsigned char AP4_HexNibble(char c);
00172 char AP4_NibbleHex(unsigned int nibble);
00173 void AP4_FormatFourChars(char* str, AP4_UI32 value);
00174 void AP4_FormatFourCharsPrintable(char* str, AP4_UI32 value);
00175 AP4_Result
00176 AP4_ParseHex(const char* hex, unsigned char* bytes, unsigned int count);
00177 AP4_Result
00178 AP4_FormatHex(const AP4_UI08* data, unsigned int data_size, char* hex);
00179 AP4_Result
00180 AP4_SplitArgs(char* arg, char*& arg0, char*& arg1, char*& arg2);
00181 AP4_Result
00182 AP4_SplitArgs(char* arg, char*& arg0, char*& arg1);
00183
00184 /*----------------------------------------------------------------------
00185 |   AP4_BitWriter
00186 +---------------------------------------------------------------------*/
00187 class AP4_BitWriter
00188 {
00189 public:
00190     AP4_BitWriter(AP4_Size size) : m_DataSize(size), m_BitCount(0) {
00191         if (size) {
00192             m_Data = new unsigned char[size];
00193             AP4_SetMemory(m_Data, 0, size);
00194         } else {
00195             m_Data = NULL;
00196         }
00197     }
00198     ~AP4_BitWriter() { delete m_Data; }
00199
00200     void Write(AP4_UI32 bits, unsigned int bit_count);
00201
00202     unsigned int GetBitCount()     { return m_BitCount; }
00203     const unsigned char* GetData() { return m_Data;     }
00204
00205 private:
00206     unsigned char* m_Data;
00207     unsigned int   m_DataSize;
00208     unsigned int   m_BitCount;
00209 };
00210
00211
00212 #endif // _AP4_UTILS_H_
Generated on Thu May 13 16:36:34 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4UuidAtom.h File Reference

  • File List
  • File Members

Ap4UuidAtom.h File Reference

UUID Atoms. More...

#include "Ap4Atom.h"
#include "Ap4ByteStream.h"

Go to the source code of this file.

Classes

class | AP4_UuidAtom
Base class for uuid atoms. More...
class | AP4_UnknownUuidAtom
Unknown uuid atoms. More...

Variables

const AP4_UI32 | AP4_UUID_ATOM_HEADER_SIZE = AP4_ATOM_HEADER_SIZE+16
const AP4_UI32 | AP4_FULL_UUID_ATOM_HEADER_SIZE = AP4_FULL_ATOM_HEADER_SIZE+16

Detailed Description

UUID Atoms.

Definition in file Ap4UuidAtom.h.

Variable Documentation

const AP4_UI32 AP4_FULL_UUID_ATOM_HEADER_SIZE = AP4_FULL_ATOM_HEADER_SIZE+16

Definition at line 46 of file Ap4UuidAtom.h.

const AP4_UI32 AP4_UUID_ATOM_HEADER_SIZE = AP4_ATOM_HEADER_SIZE+16

Definition at line 45 of file Ap4UuidAtom.h.

Generated on Thu May 13 16:36:41 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4UuidAtom.h Source File

  • File List
  • File Members

Ap4UuidAtom.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - UUID Atoms
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027  ****************************************************************/
00033 #ifndef _AP4_UUID_ATOM_H_
00034 #define _AP4_UUID_ATOM_H_
00035
00036 /*----------------------------------------------------------------------
00037 |   includes
00038 +---------------------------------------------------------------------*/
00039 #include "Ap4Atom.h"
00040 #include "Ap4ByteStream.h"
00041
00042 /*----------------------------------------------------------------------
00043 |   constants
00044 +---------------------------------------------------------------------*/
00045 const AP4_UI32 AP4_UUID_ATOM_HEADER_SIZE      = AP4_ATOM_HEADER_SIZE+16;
00046 const AP4_UI32 AP4_FULL_UUID_ATOM_HEADER_SIZE = AP4_FULL_ATOM_HEADER_SIZE+16;
00047
00048 /*----------------------------------------------------------------------
00049 |   AP4_UuidAtom
00050 +---------------------------------------------------------------------*/
00054 class AP4_UuidAtom : public AP4_Atom {
00055 public:
00056     AP4_IMPLEMENT_DYNAMIC_CAST_D(AP4_UuidAtom, AP4_Atom)
00057
00058     // constructor and destructor
00059     virtual ~AP4_UuidAtom() {};
00060
00061     // methods
00062     virtual AP4_Size   GetHeaderSize() const;
00063     virtual AP4_Result WriteHeader(AP4_ByteStream& stream);
00064     virtual AP4_Result InspectHeader(AP4_AtomInspector& inspector);
00065
00066     // accessors
00067     const AP4_UI08* GetUuid() { return m_Uuid; }
00068
00069 protected:
00070     // members
00071     AP4_UuidAtom(AP4_UI64 size, const AP4_UI08* uuid);
00072     AP4_UuidAtom(AP4_UI64 size, const AP4_UI08* uuid, AP4_UI32 version, AP4_UI32 flags);
00073     AP4_UuidAtom(AP4_UI64 size, bool is_full, AP4_ByteStream& stream);
00074     AP4_UI08 m_Uuid[16];
00075 };
00076
00077 /*----------------------------------------------------------------------
00078 |   AP4_UnknownUuidAtom
00079 +---------------------------------------------------------------------*/
00083 class AP4_UnknownUuidAtom : public AP4_UuidAtom {
00084 public:
00085     AP4_IMPLEMENT_DYNAMIC_CAST_D(AP4_UnknownUuidAtom, AP4_UuidAtom)
00086
00087     // constructors
00088     AP4_UnknownUuidAtom(AP4_UI64 size, AP4_ByteStream& stream);
00089     AP4_UnknownUuidAtom(AP4_UI64 size, const AP4_UI08* uuid, AP4_ByteStream& stream);
00090
00091     // methods
00092     virtual AP4_Result WriteFields(AP4_ByteStream& stream);
00093
00094 protected:
00095     // members
00096     AP4_DataBuffer m_Data;
00097 };
00098
00099 #endif // _AP4_UUID_ATOM_H_
Generated on Thu May 13 16:36:34 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4Version.h File Reference

  • File List
  • File Members

Ap4Version.h File Reference

Go to the source code of this file.

Defines

#define | AP4_VERSION 0x01020300
Version number of the SDK.
#define | AP4_VERSION_STRING "1.2.3.0"

Define Documentation

#define AP4_VERSION 0x01020300

Version number of the SDK.

Definition at line 40 of file Ap4Version.h.

#define AP4_VERSION_STRING "1.2.3.0"

Definition at line 41 of file Ap4Version.h.

Generated on Thu May 13 16:36:41 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4Version.h Source File

  • File List
  • File Members

Ap4Version.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - Version Numbers
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Unless you have obtained Bento4 under a difference license,
00013 |    this version of Bento4 is Bento4|GPL.
00014 |    Bento4|GPL is free software; you can redistribute it and/or modify
00015 |    it under the terms of the GNU General Public License as published by
00016 |    the Free Software Foundation; either version 2, or (at your option)
00017 |    any later version.
00018 |
00019 |    Bento4|GPL is distributed in the hope that it will be useful,
00020 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00021 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00022 |    GNU General Public License for more details.
00023 |
00024 |    You should have received a copy of the GNU General Public License
00025 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00026 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00027 |    02111-1307, USA.
00028 |
00029 ****************************************************************/
00030
00031 #ifndef _AP4_VERSION_H_
00032 #define _AP4_VERSION_H_
00033
00034 /*----------------------------------------------------------------------
00035 |   version constants
00036 +---------------------------------------------------------------------*/
00040 #define AP4_VERSION        0x01020300
00041 #define AP4_VERSION_STRING "1.2.3.0"
00042
00043 #endif // _AP4_VERSION_H_
Generated on Thu May 13 16:36:34 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4VmhdAtom.h File Reference

  • File List
  • File Members

Ap4VmhdAtom.h File Reference

#include "Ap4Atom.h"

Go to the source code of this file.

Classes

class AP4_VmhdAtom
Generated on Thu May 13 16:36:41 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Ap4VmhdAtom.h Source File

  • File List
  • File Members

Ap4VmhdAtom.h

Go to the documentation of this file.
00001 /*****************************************************************
00002 |
00003 |    AP4 - vmhd Atoms
00004 |
00005 |    Copyright 2002-2008 Axiomatic Systems, LLC
00006 |
00007 |
00008 |    This file is part of Bento4/AP4 (MP4 Atom Processing Library).
00009 |
00010 |    Unless you have obtained Bento4 under a difference license,
00011 |    this version of Bento4 is Bento4|GPL.
00012 |    Bento4|GPL is free software; you can redistribute it and/or modify
00013 |    it under the terms of the GNU General Public License as published by
00014 |    the Free Software Foundation; either version 2, or (at your option)
00015 |    any later version.
00016 |
00017 |    Bento4|GPL is distributed in the hope that it will be useful,
00018 |    but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 |    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00020 |    GNU General Public License for more details.
00021 |
00022 |    You should have received a copy of the GNU General Public License
00023 |    along with Bento4|GPL; see the file COPYING.  If not, write to the
00024 |    Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
00025 |    02111-1307, USA.
00026 |
00027 ****************************************************************/
00028
00029 #ifndef _AP4_VMHD_ATOM_H_
00030 #define _AP4_VMHD_ATOM_H_
00031
00032 /*----------------------------------------------------------------------
00033 |   includes
00034 +---------------------------------------------------------------------*/
00035 #include "Ap4Atom.h"
00036
00037 /*----------------------------------------------------------------------
00038 |   AP4_VmhdAtom
00039 +---------------------------------------------------------------------*/
00040 class AP4_VmhdAtom : public AP4_Atom
00041 {
00042 public:
00043     // class methods
00044     static AP4_VmhdAtom* Create(AP4_Size size, AP4_ByteStream& stream);
00045
00046     // methods
00047     AP4_VmhdAtom(AP4_UI16 graphics_mode, AP4_UI16 r, AP4_UI16 g, AP4_UI16 b);
00048     virtual AP4_Result InspectFields(AP4_AtomInspector& inspector);
00049     virtual AP4_Result WriteFields(AP4_ByteStream& stream);
00050
00051 private:
00052     // methods
00053     AP4_VmhdAtom(AP4_UI32        size,
00054                  AP4_UI32        version,
00055                  AP4_UI32        flags,
00056                  AP4_ByteStream& stream);
00057
00058     // members
00059     AP4_UI16 m_GraphicsMode;
00060     AP4_UI16 m_OpColor[3];
00061 };
00062
00063 #endif // _AP4_VMHD_ATOM_H_
Generated on Thu May 13 16:36:34 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
Here is a list of all file members with links to the files they belong to:

- a -

  • AP4_8BDL_XML_DATA_ENCODING : Ap48bdlAtom.h
  • AP4_ADD_REFERENCE : Ap4Interfaces.h
  • AP4_AES_BLOCK_SIZE : Ap4AesBlockCipher.h
  • AP4_AES_KEY_LENGTH : Ap4AesBlockCipher.h
  • AP4_AesKeyUnwrap() : Ap4KeyWrap.h
  • AP4_AesKeyWrap() : Ap4KeyWrap.h
  • AP4_ARRAY_INITIAL_COUNT : Ap4Array.h
  • AP4_ATOM_HEADER_SIZE : Ap4Atom.h
  • AP4_ATOM_HEADER_SIZE_64 : Ap4Atom.h
  • AP4_ATOM_MAX_NAME_SIZE : Ap4Atom.h
  • AP4_ATOM_MAX_URI_SIZE : Ap4Atom.h
  • AP4_ATOM_TYPE : Ap4Atom.h
  • AP4_ATOM_TYPE_8BDL : Ap4Atom.h
  • AP4_ATOM_TYPE_8ID_ : Ap4Atom.h
  • AP4_ATOM_TYPE_aART : Ap4MetaData.h
  • AP4_ATOM_TYPE_AC_3 : Ap4Atom.h
  • AP4_ATOM_TYPE_akID : Ap4MetaData.h
  • AP4_ATOM_TYPE_ALAC : Ap4Atom.h
  • AP4_ATOM_TYPE_ALBM : Ap4MetaData.h
  • AP4_ATOM_TYPE_ALIS : Ap4Atom.h
  • AP4_ATOM_TYPE_apID : Ap4MetaData.h
  • AP4_ATOM_TYPE_atID : Ap4MetaData.h
  • AP4_ATOM_TYPE_AUTH : Ap4MetaData.h
  • AP4_ATOM_TYPE_AVC1 : Ap4Atom.h
  • AP4_ATOM_TYPE_AVCC : Ap4Atom.h
  • AP4_ATOM_TYPE_cALB : Ap4MetaData.h
  • AP4_ATOM_TYPE_cART : Ap4MetaData.h
  • AP4_ATOM_TYPE_CATG : Ap4MetaData.h
  • AP4_ATOM_TYPE_cCMT : Ap4MetaData.h
  • AP4_ATOM_TYPE_cCOM : Ap4MetaData.h
  • AP4_ATOM_TYPE_cDAY : Ap4MetaData.h
  • AP4_ATOM_TYPE_CDSC : Ap4Atom.h
  • AP4_ATOM_TYPE_cGEN : Ap4MetaData.h
  • AP4_ATOM_TYPE_cGRP : Ap4MetaData.h
  • AP4_ATOM_TYPE_CHAP : Ap4Atom.h
  • AP4_ATOM_TYPE_CLSF : Ap4MetaData.h
  • AP4_ATOM_TYPE_cLYR : Ap4MetaData.h
  • AP4_ATOM_TYPE_cmID : Ap4MetaData.h
  • AP4_ATOM_TYPE_cNAM : Ap4MetaData.h
  • AP4_ATOM_TYPE_cnID : Ap4MetaData.h
  • AP4_ATOM_TYPE_CO64 : Ap4Atom.h
  • AP4_ATOM_TYPE_COVR : Ap4MetaData.h
  • AP4_ATOM_TYPE_CPIL : Ap4MetaData.h
  • AP4_ATOM_TYPE_CPRT : Ap4MetaData.h
  • AP4_ATOM_TYPE_cTOO : Ap4MetaData.h
  • AP4_ATOM_TYPE_CTTS : Ap4Atom.h
  • AP4_ATOM_TYPE_CVRU : Ap4MetaData.h
  • AP4_ATOM_TYPE_cWRT : Ap4MetaData.h
  • AP4_ATOM_TYPE_DATA : Ap4MetaData.h
  • AP4_ATOM_TYPE_DCFD : Ap4MetaData.h
  • AP4_ATOM_TYPE_dddd : Ap4MetaData.h
  • AP4_ATOM_TYPE_DESC : Ap4MetaData.h
  • AP4_ATOM_TYPE_DINF : Ap4Atom.h
  • AP4_ATOM_TYPE_DISK : Ap4MetaData.h
  • AP4_ATOM_TYPE_DPND : Ap4Atom.h
  • AP4_ATOM_TYPE_DREF : Ap4Atom.h
  • AP4_ATOM_TYPE_DRMI : Ap4Atom.h
  • AP4_ATOM_TYPE_DRMS : Ap4Atom.h
  • AP4_ATOM_TYPE_DSCP : Ap4MetaData.h
  • AP4_ATOM_TYPE_EC_3 : Ap4Atom.h
  • AP4_ATOM_TYPE_EDTS : Ap4Atom.h
  • AP4_ATOM_TYPE_EGID : Ap4MetaData.h
  • AP4_ATOM_TYPE_ELST : Ap4Atom.h
  • AP4_ATOM_TYPE_ENCA : Ap4Atom.h
  • AP4_ATOM_TYPE_ENCV : Ap4Atom.h
  • AP4_ATOM_TYPE_ESDS : Ap4Atom.h
  • AP4_ATOM_TYPE_FREE : Ap4Atom.h
  • AP4_ATOM_TYPE_FRMA : Ap4Atom.h
  • AP4_ATOM_TYPE_FTYP : Ap4Atom.h
  • AP4_ATOM_TYPE_geID : Ap4MetaData.h
  • AP4_ATOM_TYPE_GKEY : Ap4Marlin.h
  • AP4_ATOM_TYPE_GNRE : Ap4MetaData.h
  • AP4_ATOM_TYPE_GRPI : Ap4Atom.h
  • AP4_ATOM_TYPE_HDLR : Ap4Atom.h
  • AP4_ATOM_TYPE_HINT : Ap4Atom.h
  • AP4_ATOM_TYPE_HMAC : Ap4Marlin.h
  • AP4_ATOM_TYPE_HMHD : Ap4Atom.h
  • AP4_ATOM_TYPE_HNTI : Ap4Atom.h
  • AP4_ATOM_TYPE_ICNU : Ap4MetaData.h
  • AP4_ATOM_TYPE_IKMS : Ap4Atom.h
  • AP4_ATOM_TYPE_ILST : Ap4Atom.h
  • AP4_ATOM_TYPE_INFU : Ap4MetaData.h
  • AP4_ATOM_TYPE_IODS : Ap4Atom.h
  • AP4_ATOM_TYPE_IPIR : Ap4Atom.h
  • AP4_ATOM_TYPE_IPRO : Ap4Atom.h
  • AP4_ATOM_TYPE_ISFM : Ap4Atom.h
  • AP4_ATOM_TYPE_ISLT : Ap4Atom.h
  • AP4_ATOM_TYPE_KEYW : Ap4MetaData.h
  • AP4_ATOM_TYPE_KYWD : Ap4MetaData.h
  • AP4_ATOM_TYPE_LOCI : Ap4MetaData.h
  • AP4_ATOM_TYPE_LRCU : Ap4MetaData.h
  • AP4_ATOM_TYPE_MDAT : Ap4Atom.h
  • AP4_ATOM_TYPE_MDHD : Ap4Atom.h
  • AP4_ATOM_TYPE_MDIA : Ap4Atom.h
  • AP4_ATOM_TYPE_MDRI : Ap4Atom.h
  • AP4_ATOM_TYPE_MEAN : Ap4MetaData.h
  • AP4_ATOM_TYPE_MEHD : Ap4Atom.h
  • AP4_ATOM_TYPE_META : Ap4Atom.h
  • AP4_ATOM_TYPE_MFHD : Ap4Atom.h
  • AP4_ATOM_TYPE_MFRA : Ap4Atom.h
  • AP4_ATOM_TYPE_MFRO : Ap4Atom.h
  • AP4_ATOM_TYPE_MINF : Ap4Atom.h
  • AP4_ATOM_TYPE_MOOF : Ap4Atom.h
  • AP4_ATOM_TYPE_MOOV : Ap4Atom.h
  • AP4_ATOM_TYPE_MP4A : Ap4Atom.h
  • AP4_ATOM_TYPE_MP4S : Ap4Atom.h
  • AP4_ATOM_TYPE_MP4V : Ap4Atom.h
  • AP4_ATOM_TYPE_MPOD : Ap4Atom.h
  • AP4_ATOM_TYPE_MVEX : Ap4Atom.h
  • AP4_ATOM_TYPE_MVHD : Ap4Atom.h
  • AP4_ATOM_TYPE_NAME : Ap4MetaData.h
  • AP4_ATOM_TYPE_NMHD : Ap4Atom.h
  • AP4_ATOM_TYPE_ODAF : Ap4Atom.h
  • AP4_ATOM_TYPE_ODDA : Ap4Atom.h
  • AP4_ATOM_TYPE_ODHE : Ap4Atom.h
  • AP4_ATOM_TYPE_ODKM : Ap4Atom.h
  • AP4_ATOM_TYPE_ODRM : Ap4Atom.h
  • AP4_ATOM_TYPE_OHDR : Ap4Atom.h
  • AP4_ATOM_TYPE_PCST : Ap4MetaData.h
  • AP4_ATOM_TYPE_PERF : Ap4MetaData.h
  • AP4_ATOM_TYPE_PGAP : Ap4MetaData.h
  • AP4_ATOM_TYPE_plID : Ap4MetaData.h
  • AP4_ATOM_TYPE_PURD : Ap4MetaData.h
  • AP4_ATOM_TYPE_PURL : Ap4MetaData.h
  • AP4_ATOM_TYPE_RTNG : Ap4MetaData.h
  • AP4_ATOM_TYPE_RTP_ : Ap4Atom.h
  • AP4_ATOM_TYPE_SATR : Ap4Marlin.h
  • AP4_ATOM_TYPE_SCHI : Ap4Atom.h
  • AP4_ATOM_TYPE_SCHM : Ap4Atom.h
  • AP4_ATOM_TYPE_SDP_ : Ap4Atom.h
  • AP4_ATOM_TYPE_sfID : Ap4MetaData.h
  • AP4_ATOM_TYPE_SINF : Ap4Atom.h
  • AP4_ATOM_TYPE_SMHD : Ap4Atom.h
  • AP4_ATOM_TYPE_SOAA : Ap4MetaData.h
  • AP4_ATOM_TYPE_SOAL : Ap4MetaData.h
  • AP4_ATOM_TYPE_SOAR : Ap4MetaData.h
  • AP4_ATOM_TYPE_SOCO : Ap4MetaData.h
  • AP4_ATOM_TYPE_SONM : Ap4MetaData.h
  • AP4_ATOM_TYPE_SOSN : Ap4MetaData.h
  • AP4_ATOM_TYPE_STBL : Ap4Atom.h
  • AP4_ATOM_TYPE_STCO : Ap4Atom.h
  • AP4_ATOM_TYPE_STIK : Ap4MetaData.h
  • AP4_ATOM_TYPE_STSC : Ap4Atom.h
  • AP4_ATOM_TYPE_STSD : Ap4Atom.h
  • AP4_ATOM_TYPE_STSS : Ap4Atom.h
  • AP4_ATOM_TYPE_STSZ : Ap4Atom.h
  • AP4_ATOM_TYPE_STTS : Ap4Atom.h
  • AP4_ATOM_TYPE_STYP : Ap4Marlin.h
  • AP4_ATOM_TYPE_SYNC : Ap4Atom.h
  • AP4_ATOM_TYPE_TFHD : Ap4Atom.h
  • AP4_ATOM_TYPE_TFRA : Ap4Atom.h
  • AP4_ATOM_TYPE_TIMS : Ap4Atom.h
  • AP4_ATOM_TYPE_TITL : Ap4MetaData.h
  • AP4_ATOM_TYPE_TKHD : Ap4Atom.h
  • AP4_ATOM_TYPE_TMPO : Ap4MetaData.h
  • AP4_ATOM_TYPE_TRAF : Ap4Atom.h
  • AP4_ATOM_TYPE_TRAK : Ap4Atom.h
  • AP4_ATOM_TYPE_TREF : Ap4Atom.h
  • AP4_ATOM_TYPE_TREX : Ap4Atom.h
  • AP4_ATOM_TYPE_TRKN : Ap4MetaData.h
  • AP4_ATOM_TYPE_TRUN : Ap4Atom.h
  • AP4_ATOM_TYPE_TSEL : Ap4MetaData.h
  • AP4_ATOM_TYPE_TVEN : Ap4MetaData.h
  • AP4_ATOM_TYPE_TVES : Ap4MetaData.h
  • AP4_ATOM_TYPE_TVNN : Ap4MetaData.h
  • AP4_ATOM_TYPE_TVSH : Ap4MetaData.h
  • AP4_ATOM_TYPE_TVSN : Ap4MetaData.h
  • AP4_ATOM_TYPE_UDTA : Ap4Atom.h
  • AP4_ATOM_TYPE_URL : Ap4Atom.h
  • AP4_ATOM_TYPE_UUID : Ap4Atom.h
  • AP4_ATOM_TYPE_VMHD : Ap4Atom.h
  • AP4_ATOM_TYPE_WAVE : Ap4Atom.h
  • AP4_ATOM_TYPE_WIDE : Ap4Atom.h
  • AP4_ATOM_TYPE_YRRC : Ap4MetaData.h
  • AP4_AVC_PROFILE_BASELINE : Ap4AvccAtom.h
  • AP4_AVC_PROFILE_EXTENDED : Ap4AvccAtom.h
  • AP4_AVC_PROFILE_HIGH : Ap4AvccAtom.h
  • AP4_AVC_PROFILE_HIGH_10 : Ap4AvccAtom.h
  • AP4_AVC_PROFILE_HIGH_422 : Ap4AvccAtom.h
  • AP4_AVC_PROFILE_HIGH_444 : Ap4AvccAtom.h
  • AP4_AVC_PROFILE_MAIN : Ap4AvccAtom.h
  • AP4_Byte : Ap4Types.h
  • AP4_BytesFromDoubleBE() : Ap4Utils.h
  • AP4_BytesFromUInt16BE() : Ap4Utils.h
  • AP4_BytesFromUInt24BE() : Ap4Utils.h
  • AP4_BytesFromUInt32BE() : Ap4Utils.h
  • AP4_BytesFromUInt64BE() : Ap4Utils.h
  • AP4_BytesToDoubleBE() : Ap4Utils.h
  • AP4_BytesToInt16BE() : Ap4Utils.h
  • AP4_BytesToInt32BE() : Ap4Utils.h
  • AP4_BytesToUInt16BE() : Ap4Utils.h
  • AP4_BytesToUInt24BE() : Ap4Utils.h
  • AP4_BytesToUInt32BE() : Ap4Utils.h
  • AP4_BytesToUInt64BE() : Ap4Utils.h
  • AP4_Cardinal : Ap4Types.h
  • AP4_CHECK : Ap4Results.h
  • AP4_CIPHER_BLOCK_SIZE : Ap4StreamCipher.h
  • AP4_COMMAND_TAG_ES_DESCRIPTOR_REMOVE : Ap4Command.h
  • AP4_COMMAND_TAG_ES_DESCRIPTOR_REMOVE_REF : Ap4Command.h
  • AP4_COMMAND_TAG_ES_DESCRIPTOR_UPDATE : Ap4Command.h
  • AP4_COMMAND_TAG_IPMP_DESCRIPTOR_REMOVE : Ap4Command.h
  • AP4_COMMAND_TAG_IPMP_DESCRIPTOR_UPDATE : Ap4Command.h
  • AP4_COMMAND_TAG_OBJECT_DESCRIPTOR_EXECUTE : Ap4Command.h
  • AP4_COMMAND_TAG_OBJECT_DESCRIPTOR_REMOVE : Ap4Command.h
  • AP4_COMMAND_TAG_OBJECT_DESCRIPTOR_UPDATE : Ap4Command.h
  • AP4_CONFIG_HAVE_ASSERT_H : Ap4Config.h
  • AP4_CONFIG_HAVE_INT64 : Ap4Config.h
  • AP4_CONFIG_HAVE_SNPRINTF : Ap4Config.h
  • AP4_CONFIG_HAVE_STDIO_H : Ap4Config.h
  • AP4_CONFIG_HAVE_STRING_H : Ap4Config.h
  • AP4_CONFIG_HAVE_VSNPRINTF : Ap4Config.h
  • AP4_ConvertTime() : Ap4Utils.h
  • AP4_Debug() : Ap4Debug.h
  • AP4_DEFINE_DYNAMIC_CAST_ANCHOR : Ap4DynamicCast.h
  • AP4_DESCRIPTOR_TAG_DECODER_CONFIG : Ap4DecoderConfigDescriptor.h
  • AP4_DESCRIPTOR_TAG_DECODER_SPECIFIC_INFO : Ap4DecoderSpecificInfoDescriptor.h
  • AP4_DESCRIPTOR_TAG_ES : Ap4EsDescriptor.h
  • AP4_DESCRIPTOR_TAG_ES_ID_INC : Ap4EsDescriptor.h
  • AP4_DESCRIPTOR_TAG_ES_ID_REF : Ap4EsDescriptor.h
  • AP4_DESCRIPTOR_TAG_IOD : Ap4ObjectDescriptor.h
  • AP4_DESCRIPTOR_TAG_IPMP_DESCRIPTOR : Ap4Ipmp.h
  • AP4_DESCRIPTOR_TAG_IPMP_DESCRIPTOR_POINTER : Ap4Ipmp.h
  • AP4_DESCRIPTOR_TAG_MP4_IOD : Ap4ObjectDescriptor.h
  • AP4_DESCRIPTOR_TAG_MP4_OD : Ap4ObjectDescriptor.h
  • AP4_DESCRIPTOR_TAG_OD : Ap4ObjectDescriptor.h
  • AP4_DESCRIPTOR_TAG_SL_CONFIG : Ap4SLConfigDescriptor.h
  • AP4_DurationMsFromUnits() : Ap4Utils.h
  • AP4_DYNAMIC_CAST : Ap4DynamicCast.h
  • AP4_ERROR_BUFFER_TOO_SMALL : Ap4Results.h
  • AP4_ERROR_CANNOT_OPEN_FILE : Ap4Results.h
  • AP4_ERROR_EOS : Ap4Results.h
  • AP4_ERROR_INTERNAL : Ap4Results.h
  • AP4_ERROR_INVALID_FORMAT : Ap4Results.h
  • AP4_ERROR_INVALID_PARAMETERS : Ap4Results.h
  • AP4_ERROR_INVALID_RTP_CONSTRUCTOR_TYPE : Ap4Results.h
  • AP4_ERROR_INVALID_RTP_PACKET_EXTRA_DATA : Ap4Results.h
  • AP4_ERROR_INVALID_STATE : Ap4Results.h
  • AP4_ERROR_INVALID_TRACK_TYPE : Ap4Results.h
  • AP4_ERROR_LIST_EMPTY : Ap4Results.h
  • AP4_ERROR_LIST_OPERATION_ABORTED : Ap4Results.h
  • AP4_ERROR_NO_SUCH_FILE : Ap4Results.h
  • AP4_ERROR_NO_SUCH_ITEM : Ap4Results.h
  • AP4_ERROR_NOT_ENOUGH_DATA : Ap4Results.h
  • AP4_ERROR_NOT_ENOUGH_SPACE : Ap4Results.h
  • AP4_ERROR_NOT_SUPPORTED : Ap4Results.h
  • AP4_ERROR_OUT_OF_MEMORY : Ap4Results.h
  • AP4_ERROR_OUT_OF_RANGE : Ap4Results.h
  • AP4_ERROR_PERMISSION_DENIED : Ap4Results.h
  • AP4_ERROR_READ_FAILED : Ap4Results.h
  • AP4_ERROR_WRITE_FAILED : Ap4Results.h
  • AP4_ES_DESCRIPTOR_FLAG_OCR_STREAM : Ap4EsDescriptor.h
  • AP4_ES_DESCRIPTOR_FLAG_STREAM_DEPENDENCY : Ap4EsDescriptor.h
  • AP4_ES_DESCRIPTOR_FLAG_URL : Ap4EsDescriptor.h
  • AP4_FAILED : Ap4Results.h
  • AP4_FAILURE : Ap4Results.h
  • AP4_FILE_BRAND_3G2A : Ap4File.h
  • AP4_FILE_BRAND_3GP1 : Ap4File.h
  • AP4_FILE_BRAND_3GP2 : Ap4File.h
  • AP4_FILE_BRAND_3GP3 : Ap4File.h
  • AP4_FILE_BRAND_3GP4 : Ap4File.h
  • AP4_FILE_BRAND_3GP5 : Ap4File.h
  • AP4_FILE_BRAND_ISOM : Ap4File.h
  • AP4_FILE_BRAND_M4A_ : Ap4File.h
  • AP4_FILE_BRAND_M4P_ : Ap4File.h
  • AP4_FILE_BRAND_MJP2 : Ap4File.h
  • AP4_FILE_BRAND_MMP4 : Ap4File.h
  • AP4_FILE_BRAND_MP41 : Ap4File.h
  • AP4_FILE_BRAND_MP42 : Ap4File.h
  • AP4_FILE_BRAND_QT__ : Ap4File.h
  • AP4_Flags : Ap4Types.h
  • AP4_FormatFourChars() : Ap4Utils.h
  • AP4_FormatFourCharsPrintable() : Ap4Utils.h
  • AP4_FormatHex() : Ap4Utils.h
  • AP4_FormatString() : Ap4Utils.h
  • AP4_FormatStringVN() : Ap4Utils.h
  • AP4_FRAG_FLAG_SAMPLE_IS_DIFFERENCE : Ap4MovieFragment.h
  • AP4_fseek : Ap4Config.h
  • AP4_ftell : Ap4Config.h
  • AP4_FTYP_BRAND_ISOM : Ap4FtypAtom.h
  • AP4_FULL_ATOM_HEADER_SIZE : Ap4Atom.h
  • AP4_FULL_ATOM_HEADER_SIZE_64 : Ap4Atom.h
  • AP4_FULL_UUID_ATOM_HEADER_SIZE : Ap4UuidAtom.h
  • AP4_GetFormatName() : Ap4SampleDescription.h
  • AP4_HANDLER_TYPE_HINT : Ap4HdlrAtom.h
  • AP4_HANDLER_TYPE_JPEG : Ap4HdlrAtom.h
  • AP4_HANDLER_TYPE_MDIR : Ap4HdlrAtom.h
  • AP4_HANDLER_TYPE_ODSM : Ap4HdlrAtom.h
  • AP4_HANDLER_TYPE_SDSM : Ap4HdlrAtom.h
  • AP4_HANDLER_TYPE_SOUN : Ap4HdlrAtom.h
  • AP4_HANDLER_TYPE_TEXT : Ap4HdlrAtom.h
  • AP4_HANDLER_TYPE_TX3G : Ap4HdlrAtom.h
  • AP4_HANDLER_TYPE_VIDE : Ap4HdlrAtom.h
  • AP4_HexNibble() : Ap4Utils.h
  • AP4_IMPLEMENT_DYNAMIC_CAST : Ap4DynamicCast.h
  • AP4_IMPLEMENT_DYNAMIC_CAST_D : Ap4DynamicCast.h
  • AP4_IMPLEMENT_DYNAMIC_CAST_D2 : Ap4DynamicCast.h
  • AP4_LargeSize : Ap4Types.h
  • AP4_LINEAR_READER_DEFAULT_BUFFER_SIZE : Ap4LinearReader.h
  • AP4_LINEAR_READER_FLAG_EOS : Ap4LinearReader.h
  • AP4_LINEAR_READER_INITIALIZED : Ap4LinearReader.h
  • AP4_MARLIN_BRAND_MGSV : Ap4Marlin.h
  • AP4_MARLIN_IPMP_STYP_AUDIO : Ap4Marlin.h
  • AP4_MARLIN_IPMP_STYP_VIDEO : Ap4Marlin.h
  • AP4_MARLIN_IPMPS_TYPE_MGSV : Ap4Marlin.h
  • AP4_Mask : Ap4Types.h
  • AP4_MDHD_DEFAULT_GENERIC_TIMESCALE : Ap4MdhdAtom.h
  • AP4_MDHD_DEFAULT_VIDEO_TIMESCALE : Ap4MdhdAtom.h
  • AP4_MPEG2_STREAM_TYPE_AVC : Ap4Mpeg2Ts.h
  • AP4_MPEG2_STREAM_TYPE_ISO_IEC_13818_7 : Ap4Mpeg2Ts.h
  • AP4_MPEG2_TS_DEFAULT_PID_AUDIO : Ap4Mpeg2Ts.h
  • AP4_MPEG2_TS_DEFAULT_PID_PMT : Ap4Mpeg2Ts.h
  • AP4_MPEG2_TS_DEFAULT_PID_VIDEO : Ap4Mpeg2Ts.h
  • AP4_MPEG2_TS_DEFAULT_STREAM_ID_AUDIO : Ap4Mpeg2Ts.h
  • AP4_MPEG2_TS_DEFAULT_STREAM_ID_VIDEO : Ap4Mpeg2Ts.h
  • AP4_MPEG4_AUDIO_OBJECT_TYPE_AAC_LC : Ap4SampleDescription.h
  • AP4_MPEG4_AUDIO_OBJECT_TYPE_AAC_LTP : Ap4SampleDescription.h
  • AP4_MPEG4_AUDIO_OBJECT_TYPE_AAC_MAIN : Ap4SampleDescription.h
  • AP4_MPEG4_AUDIO_OBJECT_TYPE_AAC_SCALABLE : Ap4SampleDescription.h
  • AP4_MPEG4_AUDIO_OBJECT_TYPE_AAC_SSR : Ap4SampleDescription.h
  • AP4_MPEG4_AUDIO_OBJECT_TYPE_ALGORITHMIC_SYNTHESIS : Ap4SampleDescription.h
  • AP4_MPEG4_AUDIO_OBJECT_TYPE_ALS : Ap4SampleDescription.h
  • AP4_MPEG4_AUDIO_OBJECT_TYPE_CELP : Ap4SampleDescription.h
  • AP4_MPEG4_AUDIO_OBJECT_TYPE_DST : Ap4SampleDescription.h
  • AP4_MPEG4_AUDIO_OBJECT_TYPE_ER_AAC_ELD : Ap4SampleDescription.h
  • AP4_MPEG4_AUDIO_OBJECT_TYPE_ER_AAC_LC : Ap4SampleDescription.h
  • AP4_MPEG4_AUDIO_OBJECT_TYPE_ER_AAC_LD : Ap4SampleDescription.h
  • AP4_MPEG4_AUDIO_OBJECT_TYPE_ER_AAC_LTP : Ap4SampleDescription.h
  • AP4_MPEG4_AUDIO_OBJECT_TYPE_ER_AAC_SCALABLE : Ap4SampleDescription.h
  • AP4_MPEG4_AUDIO_OBJECT_TYPE_ER_BSAC : Ap4SampleDescription.h
  • AP4_MPEG4_AUDIO_OBJECT_TYPE_ER_CELP : Ap4SampleDescription.h
  • AP4_MPEG4_AUDIO_OBJECT_TYPE_ER_HILN : Ap4SampleDescription.h
  • AP4_MPEG4_AUDIO_OBJECT_TYPE_ER_HVXC : Ap4SampleDescription.h
  • AP4_MPEG4_AUDIO_OBJECT_TYPE_ER_PARAMETRIC : Ap4SampleDescription.h
  • AP4_MPEG4_AUDIO_OBJECT_TYPE_ER_TWINVQ : Ap4SampleDescription.h
  • AP4_MPEG4_AUDIO_OBJECT_TYPE_GENERAL_MIDI : Ap4SampleDescription.h
  • AP4_MPEG4_AUDIO_OBJECT_TYPE_HVXC : Ap4SampleDescription.h
  • AP4_MPEG4_AUDIO_OBJECT_TYPE_LAYER_1 : Ap4SampleDescription.h
  • AP4_MPEG4_AUDIO_OBJECT_TYPE_LAYER_2 : Ap4SampleDescription.h
  • AP4_MPEG4_AUDIO_OBJECT_TYPE_LAYER_3 : Ap4SampleDescription.h
  • AP4_MPEG4_AUDIO_OBJECT_TYPE_MAIN_SYNTHETIC : Ap4SampleDescription.h
  • AP4_MPEG4_AUDIO_OBJECT_TYPE_MPEG_SURROUND : Ap4SampleDescription.h
  • AP4_MPEG4_AUDIO_OBJECT_TYPE_PS : Ap4SampleDescription.h
  • AP4_MPEG4_AUDIO_OBJECT_TYPE_SBR : Ap4SampleDescription.h
  • AP4_MPEG4_AUDIO_OBJECT_TYPE_SLS : Ap4SampleDescription.h
  • AP4_MPEG4_AUDIO_OBJECT_TYPE_SLS_NON_CORE : Ap4SampleDescription.h
  • AP4_MPEG4_AUDIO_OBJECT_TYPE_SMR_MAIN : Ap4SampleDescription.h
  • AP4_MPEG4_AUDIO_OBJECT_TYPE_SMR_SIMPLE : Ap4SampleDescription.h
  • AP4_MPEG4_AUDIO_OBJECT_TYPE_SSC : Ap4SampleDescription.h
  • AP4_MPEG4_AUDIO_OBJECT_TYPE_TTSI : Ap4SampleDescription.h
  • AP4_MPEG4_AUDIO_OBJECT_TYPE_TWINVQ : Ap4SampleDescription.h
  • AP4_MPEG4_AUDIO_OBJECT_TYPE_WAVETABLE_SYNTHESIS : Ap4SampleDescription.h
  • AP4_NibbleHex() : Ap4Utils.h
  • AP4_Offset : Ap4Types.h
  • AP4_OMA_DCF_BRAND_ODCF : Ap4OmaDcf.h
  • AP4_OMA_DCF_BRAND_OPF2 : Ap4OmaDcf.h
  • AP4_OMA_DCF_CIPHER_MODE_CBC : Ap4OmaDcf.h
  • AP4_OMA_DCF_CIPHER_MODE_CTR : Ap4OmaDcf.h
  • AP4_OMA_DCF_ENCRYPTION_METHOD_AES_CBC : Ap4OhdrAtom.h
  • AP4_OMA_DCF_ENCRYPTION_METHOD_AES_CTR : Ap4OhdrAtom.h
  • AP4_OMA_DCF_ENCRYPTION_METHOD_NULL : Ap4OhdrAtom.h
  • AP4_OMA_DCF_PADDING_SCHEME_NONE : Ap4OhdrAtom.h
  • AP4_OMA_DCF_PADDING_SCHEME_RFC_2630 : Ap4OhdrAtom.h
  • AP4_OmaDcfCipherMode : Ap4OmaDcf.h
  • AP4_Ordinal : Ap4Types.h
  • AP4_OTI_JPEG : Ap4SampleDescription.h
  • AP4_OTI_MPEG1_AUDIO : Ap4SampleDescription.h
  • AP4_OTI_MPEG1_VISUAL : Ap4SampleDescription.h
  • AP4_OTI_MPEG2_AAC_AUDIO_LC : Ap4SampleDescription.h
  • AP4_OTI_MPEG2_AAC_AUDIO_MAIN : Ap4SampleDescription.h
  • AP4_OTI_MPEG2_AAC_AUDIO_SSRP : Ap4SampleDescription.h
  • AP4_OTI_MPEG2_PART3_AUDIO : Ap4SampleDescription.h
  • AP4_OTI_MPEG2_VISUAL_422 : Ap4SampleDescription.h
  • AP4_OTI_MPEG2_VISUAL_HIGH : Ap4SampleDescription.h
  • AP4_OTI_MPEG2_VISUAL_MAIN : Ap4SampleDescription.h
  • AP4_OTI_MPEG2_VISUAL_SIMPLE : Ap4SampleDescription.h
  • AP4_OTI_MPEG2_VISUAL_SNR : Ap4SampleDescription.h
  • AP4_OTI_MPEG2_VISUAL_SPATIAL : Ap4SampleDescription.h
  • AP4_OTI_MPEG4_AUDIO : Ap4SampleDescription.h
  • AP4_OTI_MPEG4_SYSTEM : Ap4SampleDescription.h
  • AP4_OTI_MPEG4_SYSTEM_COR : Ap4SampleDescription.h
  • AP4_OTI_MPEG4_TEXT : Ap4SampleDescription.h
  • AP4_OTI_MPEG4_VISUAL : Ap4SampleDescription.h
  • AP4_ParseHex() : Ap4Utils.h
  • AP4_PIFF_ALGORITHM_ID_CBC : Ap4Piff.h
  • AP4_PIFF_ALGORITHM_ID_CTR : Ap4Piff.h
  • AP4_PIFF_ALGORITHM_ID_NONE : Ap4Piff.h
  • AP4_PIFF_BRAND : Ap4Piff.h
  • AP4_PIFF_CIPHER_MODE_CBC : Ap4Piff.h
  • AP4_PIFF_CIPHER_MODE_CTR : Ap4Piff.h
  • AP4_PIFF_SAMPLE_ENCRYPTION_FLAG_OVERRIDE_TRACK_ENCRYPTION_DEFAULTS : Ap4Piff.h
  • AP4_PiffCipherMode : Ap4Piff.h
  • AP4_PLATFORM_BYTE_ORDER_BIG_ENDIAN : Ap4Config.h
  • AP4_PLATFORM_BYTE_ORDER_LITTLE_ENDIAN : Ap4Config.h
  • AP4_Position : Ap4Types.h
  • AP4_PROTECTION_KEY_LENGTH : Ap4Protection.h
  • AP4_PROTECTION_SCHEME_TYPE_IAEC : Ap4IsmaCryp.h
  • AP4_PROTECTION_SCHEME_TYPE_ITUNES : Ap4Protection.h
  • AP4_PROTECTION_SCHEME_TYPE_MARLIN_ACBC : Ap4Marlin.h
  • AP4_PROTECTION_SCHEME_TYPE_MARLIN_ACGK : Ap4Marlin.h
  • AP4_PROTECTION_SCHEME_TYPE_OMA : Ap4OmaDcf.h
  • AP4_PROTECTION_SCHEME_TYPE_PIFF : Ap4Piff.h
  • AP4_PROTECTION_SCHEME_VERSION_OMA_20 : Ap4OmaDcf.h
  • AP4_PROTECTION_SCHEME_VERSION_PIFF_10 : Ap4Piff.h
  • AP4_RELEASE : Ap4Interfaces.h
  • AP4_Result : Ap4Types.h
  • AP4_ResultText() : Ap4Results.h
  • AP4_RTP_CONSTRUCTOR_SIZE : Ap4RtpHint.h
  • AP4_RTP_CONSTRUCTOR_TYPE_IMMEDIATE : Ap4RtpHint.h
  • AP4_RTP_CONSTRUCTOR_TYPE_NOOP : Ap4RtpHint.h
  • AP4_RTP_CONSTRUCTOR_TYPE_SAMPLE : Ap4RtpHint.h
  • AP4_RTP_CONSTRUCTOR_TYPE_SAMPLE_DESC : Ap4RtpHint.h
  • AP4_SAMPLE_FORMAT_AC_3 : Ap4SampleDescription.h
  • AP4_SAMPLE_FORMAT_ALAC : Ap4SampleDescription.h
  • AP4_SAMPLE_FORMAT_AVC1 : Ap4SampleDescription.h
  • AP4_SAMPLE_FORMAT_AVCP : Ap4SampleDescription.h
  • AP4_SAMPLE_FORMAT_DRA1 : Ap4SampleDescription.h
  • AP4_SAMPLE_FORMAT_DRAC : Ap4SampleDescription.h
  • AP4_SAMPLE_FORMAT_EC_3 : Ap4SampleDescription.h
  • AP4_SAMPLE_FORMAT_G726 : Ap4SampleDescription.h
  • AP4_SAMPLE_FORMAT_MJP2 : Ap4SampleDescription.h
  • AP4_SAMPLE_FORMAT_MP4A : Ap4SampleDescription.h
  • AP4_SAMPLE_FORMAT_MP4S : Ap4SampleDescription.h
  • AP4_SAMPLE_FORMAT_MP4V : Ap4SampleDescription.h
  • AP4_SAMPLE_FORMAT_OKSD : Ap4SampleDescription.h
  • AP4_SAMPLE_FORMAT_OVC1 : Ap4SampleDescription.h
  • AP4_SAMPLE_FORMAT_OWMA : Ap4SampleDescription.h
  • AP4_SAMPLE_FORMAT_RAW_ : Ap4SampleDescription.h
  • AP4_SAMPLE_FORMAT_RTP_ : Ap4SampleDescription.h
  • AP4_SAMPLE_FORMAT_S263 : Ap4SampleDescription.h
  • AP4_SAMPLE_FORMAT_SAMR : Ap4SampleDescription.h
  • AP4_SAMPLE_FORMAT_SAWB : Ap4SampleDescription.h
  • AP4_SAMPLE_FORMAT_SAWP : Ap4SampleDescription.h
  • AP4_SAMPLE_FORMAT_SEVC : Ap4SampleDescription.h
  • AP4_SAMPLE_FORMAT_SQCP : Ap4SampleDescription.h
  • AP4_SAMPLE_FORMAT_SRTP : Ap4SampleDescription.h
  • AP4_SAMPLE_FORMAT_SSMV : Ap4SampleDescription.h
  • AP4_SAMPLE_FORMAT_TEXT : Ap4SampleDescription.h
  • AP4_SAMPLE_FORMAT_TWOS : Ap4SampleDescription.h
  • AP4_SAMPLE_FORMAT_TX3G : Ap4SampleDescription.h
  • AP4_SAMPLE_FORMAT_VC_1 : Ap4SampleDescription.h
  • AP4_SAMPLE_FORMAT_XML_ : Ap4SampleDescription.h
  • AP4_SI16 : Ap4Types.h
  • AP4_SI32 : Ap4Types.h
  • AP4_SI64 : Ap4Types.h
  • AP4_Size : Ap4Types.h
  • AP4_snprintf : Ap4Config.h
  • AP4_SplitArgs() : Ap4Utils.h
  • AP4_STREAM_TYPE_AUDIO : Ap4SampleDescription.h
  • AP4_STREAM_TYPE_BIFS : Ap4SampleDescription.h
  • AP4_STREAM_TYPE_CR : Ap4SampleDescription.h
  • AP4_STREAM_TYPE_FORBIDDEN : Ap4SampleDescription.h
  • AP4_STREAM_TYPE_IPMP : Ap4SampleDescription.h
  • AP4_STREAM_TYPE_MPEG7 : Ap4SampleDescription.h
  • AP4_STREAM_TYPE_MPEGJ : Ap4SampleDescription.h
  • AP4_STREAM_TYPE_OCI : Ap4SampleDescription.h
  • AP4_STREAM_TYPE_OD : Ap4SampleDescription.h
  • AP4_STREAM_TYPE_TEXT : Ap4SampleDescription.h
  • AP4_STREAM_TYPE_VISUAL : Ap4SampleDescription.h
  • AP4_SUCCEEDED : Ap4Results.h
  • AP4_SUCCESS : Ap4Results.h
  • AP4_SYNTHETIC_SAMPLE_TABLE_DEFAULT_CHUNK_SIZE : Ap4SyntheticSampleTable.h
  • AP4_TFHD_FLAG_BASE_DATA_OFFSET_PRESENT : Ap4TfhdAtom.h
  • AP4_TFHD_FLAG_DEFAULT_SAMPLE_DURATION_PRESENT : Ap4TfhdAtom.h
  • AP4_TFHD_FLAG_DEFAULT_SAMPLE_FLAGS_PRESENT : Ap4TfhdAtom.h
  • AP4_TFHD_FLAG_DEFAULT_SAMPLE_SIZE_PRESENT : Ap4TfhdAtom.h
  • AP4_TFHD_FLAG_DURATION_IS_EMPTY : Ap4TfhdAtom.h
  • AP4_TFHD_FLAG_SAMPLE_DESCRIPTION_INDEX_PRESENT : Ap4TfhdAtom.h
  • AP4_TKHD_FLAG_DEFAULTS : Ap4TkhdAtom.h
  • AP4_TKHD_FLAG_TRACK_ENABLED : Ap4TkhdAtom.h
  • AP4_TKHD_FLAG_TRACK_IN_MOVIE : Ap4TkhdAtom.h
  • AP4_TKHD_FLAG_TRACK_IN_PREVIEW : Ap4TkhdAtom.h
  • AP4_TRACK_DEFAULT_MOVIE_TIMESCALE : Ap4Track.h
  • AP4_TRACK_FLAG_ENABLED : Ap4Track.h
  • AP4_TRACK_FLAG_IN_MOVIE : Ap4Track.h
  • AP4_TRACK_FLAG_IN_PREVIEW : Ap4Track.h
  • AP4_TREX_SAMPLE_IS_DIFFERENCE_SAMPLE : Ap4TrexAtom.h
  • AP4_TRUN_FLAG_DATA_OFFSET_PRESENT : Ap4TrunAtom.h
  • AP4_TRUN_FLAG_FIRST_SAMPLE_FLAGS_PRESENT : Ap4TrunAtom.h
  • AP4_TRUN_FLAG_SAMPLE_COMPOSITION_TIME_OFFSET_PRESENT : Ap4TrunAtom.h
  • AP4_TRUN_FLAG_SAMPLE_DURATION_PRESENT : Ap4TrunAtom.h
  • AP4_TRUN_FLAG_SAMPLE_FLAGS_PRESENT : Ap4TrunAtom.h
  • AP4_TRUN_FLAG_SAMPLE_SIZE_PRESENT : Ap4TrunAtom.h
  • AP4_UI08 : Ap4Types.h
  • AP4_UI16 : Ap4Types.h
  • AP4_UI32 : Ap4Types.h
  • AP4_UUID_ATOM_HEADER_SIZE : Ap4UuidAtom.h
  • AP4_UUID_PIFF_SAMPLE_ENCRYPTION_ATOM : Ap4Piff.h
  • AP4_UUID_PIFF_TRACK_ENCRYPTION_ATOM : Ap4Piff.h
  • AP4_VERSION : Ap4Version.h
  • AP4_VERSION_STRING : Ap4Version.h
  • AP4_vsnprintf : Ap4Config.h
  • APT_CONFIG_HAVE_NEW_H : Ap4Config.h
Generated on Thu May 13 16:38:12 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a

- a -

  • AP4_ADD_REFERENCE : Ap4Interfaces.h
  • AP4_AES_BLOCK_SIZE : Ap4AesBlockCipher.h
  • AP4_AES_KEY_LENGTH : Ap4AesBlockCipher.h
  • AP4_ATOM_TYPE : Ap4Atom.h
  • AP4_CHECK : Ap4Results.h
  • AP4_CONFIG_HAVE_ASSERT_H : Ap4Config.h
  • AP4_CONFIG_HAVE_INT64 : Ap4Config.h
  • AP4_CONFIG_HAVE_SNPRINTF : Ap4Config.h
  • AP4_CONFIG_HAVE_STDIO_H : Ap4Config.h
  • AP4_CONFIG_HAVE_STRING_H : Ap4Config.h
  • AP4_CONFIG_HAVE_VSNPRINTF : Ap4Config.h
  • AP4_DEFINE_DYNAMIC_CAST_ANCHOR : Ap4DynamicCast.h
  • AP4_DYNAMIC_CAST : Ap4DynamicCast.h
  • AP4_FAILED : Ap4Results.h
  • AP4_fseek : Ap4Config.h
  • AP4_ftell : Ap4Config.h
  • AP4_IMPLEMENT_DYNAMIC_CAST : Ap4DynamicCast.h
  • AP4_IMPLEMENT_DYNAMIC_CAST_D : Ap4DynamicCast.h
  • AP4_IMPLEMENT_DYNAMIC_CAST_D2 : Ap4DynamicCast.h
  • AP4_PLATFORM_BYTE_ORDER_BIG_ENDIAN : Ap4Config.h
  • AP4_PLATFORM_BYTE_ORDER_LITTLE_ENDIAN : Ap4Config.h
  • AP4_RELEASE : Ap4Interfaces.h
  • AP4_SAMPLE_FORMAT_AC_3 : Ap4SampleDescription.h
  • AP4_SAMPLE_FORMAT_ALAC : Ap4SampleDescription.h
  • AP4_SAMPLE_FORMAT_AVC1 : Ap4SampleDescription.h
  • AP4_SAMPLE_FORMAT_AVCP : Ap4SampleDescription.h
  • AP4_SAMPLE_FORMAT_DRA1 : Ap4SampleDescription.h
  • AP4_SAMPLE_FORMAT_DRAC : Ap4SampleDescription.h
  • AP4_SAMPLE_FORMAT_EC_3 : Ap4SampleDescription.h
  • AP4_SAMPLE_FORMAT_G726 : Ap4SampleDescription.h
  • AP4_SAMPLE_FORMAT_MJP2 : Ap4SampleDescription.h
  • AP4_SAMPLE_FORMAT_MP4A : Ap4SampleDescription.h
  • AP4_SAMPLE_FORMAT_MP4S : Ap4SampleDescription.h
  • AP4_SAMPLE_FORMAT_MP4V : Ap4SampleDescription.h
  • AP4_SAMPLE_FORMAT_OKSD : Ap4SampleDescription.h
  • AP4_SAMPLE_FORMAT_OVC1 : Ap4SampleDescription.h
  • AP4_SAMPLE_FORMAT_OWMA : Ap4SampleDescription.h
  • AP4_SAMPLE_FORMAT_RAW_ : Ap4SampleDescription.h
  • AP4_SAMPLE_FORMAT_RTP_ : Ap4SampleDescription.h
  • AP4_SAMPLE_FORMAT_S263 : Ap4SampleDescription.h
  • AP4_SAMPLE_FORMAT_SAMR : Ap4SampleDescription.h
  • AP4_SAMPLE_FORMAT_SAWB : Ap4SampleDescription.h
  • AP4_SAMPLE_FORMAT_SAWP : Ap4SampleDescription.h
  • AP4_SAMPLE_FORMAT_SEVC : Ap4SampleDescription.h
  • AP4_SAMPLE_FORMAT_SQCP : Ap4SampleDescription.h
  • AP4_SAMPLE_FORMAT_SRTP : Ap4SampleDescription.h
  • AP4_SAMPLE_FORMAT_SSMV : Ap4SampleDescription.h
  • AP4_SAMPLE_FORMAT_TEXT : Ap4SampleDescription.h
  • AP4_SAMPLE_FORMAT_TWOS : Ap4SampleDescription.h
  • AP4_SAMPLE_FORMAT_TX3G : Ap4SampleDescription.h
  • AP4_SAMPLE_FORMAT_VC_1 : Ap4SampleDescription.h
  • AP4_SAMPLE_FORMAT_XML_ : Ap4SampleDescription.h
  • AP4_snprintf : Ap4Config.h
  • AP4_SUCCEEDED : Ap4Results.h
  • AP4_TREX_SAMPLE_IS_DIFFERENCE_SAMPLE : Ap4TrexAtom.h
  • AP4_VERSION : Ap4Version.h
  • AP4_VERSION_STRING : Ap4Version.h
  • AP4_vsnprintf : Ap4Config.h
  • APT_CONFIG_HAVE_NEW_H : Ap4Config.h
Generated on Thu May 13 16:38:12 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • AP4_OmaDcfCipherMode : Ap4OmaDcf.h
  • AP4_PiffCipherMode : Ap4Piff.h
Generated on Thu May 13 16:38:12 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • AP4_OMA_DCF_CIPHER_MODE_CBC : Ap4OmaDcf.h
  • AP4_OMA_DCF_CIPHER_MODE_CTR : Ap4OmaDcf.h
  • AP4_PIFF_CIPHER_MODE_CBC : Ap4Piff.h
  • AP4_PIFF_CIPHER_MODE_CTR : Ap4Piff.h
Generated on Thu May 13 16:38:12 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • AP4_AesKeyUnwrap() : Ap4KeyWrap.h
  • AP4_AesKeyWrap() : Ap4KeyWrap.h
  • AP4_BytesFromDoubleBE() : Ap4Utils.h
  • AP4_BytesFromUInt16BE() : Ap4Utils.h
  • AP4_BytesFromUInt24BE() : Ap4Utils.h
  • AP4_BytesFromUInt32BE() : Ap4Utils.h
  • AP4_BytesFromUInt64BE() : Ap4Utils.h
  • AP4_BytesToDoubleBE() : Ap4Utils.h
  • AP4_BytesToInt16BE() : Ap4Utils.h
  • AP4_BytesToInt32BE() : Ap4Utils.h
  • AP4_BytesToUInt16BE() : Ap4Utils.h
  • AP4_BytesToUInt24BE() : Ap4Utils.h
  • AP4_BytesToUInt32BE() : Ap4Utils.h
  • AP4_BytesToUInt64BE() : Ap4Utils.h
  • AP4_ConvertTime() : Ap4Utils.h
  • AP4_Debug() : Ap4Debug.h
  • AP4_DurationMsFromUnits() : Ap4Utils.h
  • AP4_FormatFourChars() : Ap4Utils.h
  • AP4_FormatFourCharsPrintable() : Ap4Utils.h
  • AP4_FormatHex() : Ap4Utils.h
  • AP4_FormatString() : Ap4Utils.h
  • AP4_FormatStringVN() : Ap4Utils.h
  • AP4_GetFormatName() : Ap4SampleDescription.h
  • AP4_HexNibble() : Ap4Utils.h
  • AP4_NibbleHex() : Ap4Utils.h
  • AP4_ParseHex() : Ap4Utils.h
  • AP4_ResultText() : Ap4Results.h
  • AP4_SplitArgs() : Ap4Utils.h
Generated on Thu May 13 16:38:12 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • AP4_Byte : Ap4Types.h
  • AP4_Cardinal : Ap4Types.h
  • AP4_Flags : Ap4Types.h
  • AP4_LargeSize : Ap4Types.h
  • AP4_Mask : Ap4Types.h
  • AP4_Offset : Ap4Types.h
  • AP4_Ordinal : Ap4Types.h
  • AP4_Position : Ap4Types.h
  • AP4_Result : Ap4Types.h
  • AP4_SI16 : Ap4Types.h
  • AP4_SI32 : Ap4Types.h
  • AP4_SI64 : Ap4Types.h
  • AP4_Size : Ap4Types.h
  • AP4_UI08 : Ap4Types.h
  • AP4_UI16 : Ap4Types.h
  • AP4_UI32 : Ap4Types.h
Generated on Thu May 13 16:38:12 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a

- a -

  • AP4_8BDL_XML_DATA_ENCODING : Ap48bdlAtom.h
  • AP4_ARRAY_INITIAL_COUNT : Ap4Array.h
  • AP4_ATOM_HEADER_SIZE : Ap4Atom.h
  • AP4_ATOM_HEADER_SIZE_64 : Ap4Atom.h
  • AP4_ATOM_MAX_NAME_SIZE : Ap4Atom.h
  • AP4_ATOM_MAX_URI_SIZE : Ap4Atom.h
  • AP4_ATOM_TYPE_8BDL : Ap4Atom.h
  • AP4_ATOM_TYPE_8ID_ : Ap4Atom.h
  • AP4_ATOM_TYPE_aART : Ap4MetaData.h
  • AP4_ATOM_TYPE_AC_3 : Ap4Atom.h
  • AP4_ATOM_TYPE_akID : Ap4MetaData.h
  • AP4_ATOM_TYPE_ALAC : Ap4Atom.h
  • AP4_ATOM_TYPE_ALBM : Ap4MetaData.h
  • AP4_ATOM_TYPE_ALIS : Ap4Atom.h
  • AP4_ATOM_TYPE_apID : Ap4MetaData.h
  • AP4_ATOM_TYPE_atID : Ap4MetaData.h
  • AP4_ATOM_TYPE_AUTH : Ap4MetaData.h
  • AP4_ATOM_TYPE_AVC1 : Ap4Atom.h
  • AP4_ATOM_TYPE_AVCC : Ap4Atom.h
  • AP4_ATOM_TYPE_cALB : Ap4MetaData.h
  • AP4_ATOM_TYPE_cART : Ap4MetaData.h
  • AP4_ATOM_TYPE_CATG : Ap4MetaData.h
  • AP4_ATOM_TYPE_cCMT : Ap4MetaData.h
  • AP4_ATOM_TYPE_cCOM : Ap4MetaData.h
  • AP4_ATOM_TYPE_cDAY : Ap4MetaData.h
  • AP4_ATOM_TYPE_CDSC : Ap4Atom.h
  • AP4_ATOM_TYPE_cGEN : Ap4MetaData.h
  • AP4_ATOM_TYPE_cGRP : Ap4MetaData.h
  • AP4_ATOM_TYPE_CHAP : Ap4Atom.h
  • AP4_ATOM_TYPE_CLSF : Ap4MetaData.h
  • AP4_ATOM_TYPE_cLYR : Ap4MetaData.h
  • AP4_ATOM_TYPE_cmID : Ap4MetaData.h
  • AP4_ATOM_TYPE_cNAM : Ap4MetaData.h
  • AP4_ATOM_TYPE_cnID : Ap4MetaData.h
  • AP4_ATOM_TYPE_CO64 : Ap4Atom.h
  • AP4_ATOM_TYPE_COVR : Ap4MetaData.h
  • AP4_ATOM_TYPE_CPIL : Ap4MetaData.h
  • AP4_ATOM_TYPE_CPRT : Ap4MetaData.h
  • AP4_ATOM_TYPE_cTOO : Ap4MetaData.h
  • AP4_ATOM_TYPE_CTTS : Ap4Atom.h
  • AP4_ATOM_TYPE_CVRU : Ap4MetaData.h
  • AP4_ATOM_TYPE_cWRT : Ap4MetaData.h
  • AP4_ATOM_TYPE_DATA : Ap4MetaData.h
  • AP4_ATOM_TYPE_DCFD : Ap4MetaData.h
  • AP4_ATOM_TYPE_dddd : Ap4MetaData.h
  • AP4_ATOM_TYPE_DESC : Ap4MetaData.h
  • AP4_ATOM_TYPE_DINF : Ap4Atom.h
  • AP4_ATOM_TYPE_DISK : Ap4MetaData.h
  • AP4_ATOM_TYPE_DPND : Ap4Atom.h
  • AP4_ATOM_TYPE_DREF : Ap4Atom.h
  • AP4_ATOM_TYPE_DRMI : Ap4Atom.h
  • AP4_ATOM_TYPE_DRMS : Ap4Atom.h
  • AP4_ATOM_TYPE_DSCP : Ap4MetaData.h
  • AP4_ATOM_TYPE_EC_3 : Ap4Atom.h
  • AP4_ATOM_TYPE_EDTS : Ap4Atom.h
  • AP4_ATOM_TYPE_EGID : Ap4MetaData.h
  • AP4_ATOM_TYPE_ELST : Ap4Atom.h
  • AP4_ATOM_TYPE_ENCA : Ap4Atom.h
  • AP4_ATOM_TYPE_ENCV : Ap4Atom.h
  • AP4_ATOM_TYPE_ESDS : Ap4Atom.h
  • AP4_ATOM_TYPE_FREE : Ap4Atom.h
  • AP4_ATOM_TYPE_FRMA : Ap4Atom.h
  • AP4_ATOM_TYPE_FTYP : Ap4Atom.h
  • AP4_ATOM_TYPE_geID : Ap4MetaData.h
  • AP4_ATOM_TYPE_GKEY : Ap4Marlin.h
  • AP4_ATOM_TYPE_GNRE : Ap4MetaData.h
  • AP4_ATOM_TYPE_GRPI : Ap4Atom.h
  • AP4_ATOM_TYPE_HDLR : Ap4Atom.h
  • AP4_ATOM_TYPE_HINT : Ap4Atom.h
  • AP4_ATOM_TYPE_HMAC : Ap4Marlin.h
  • AP4_ATOM_TYPE_HMHD : Ap4Atom.h
  • AP4_ATOM_TYPE_HNTI : Ap4Atom.h
  • AP4_ATOM_TYPE_ICNU : Ap4MetaData.h
  • AP4_ATOM_TYPE_IKMS : Ap4Atom.h
  • AP4_ATOM_TYPE_ILST : Ap4Atom.h
  • AP4_ATOM_TYPE_INFU : Ap4MetaData.h
  • AP4_ATOM_TYPE_IODS : Ap4Atom.h
  • AP4_ATOM_TYPE_IPIR : Ap4Atom.h
  • AP4_ATOM_TYPE_IPRO : Ap4Atom.h
  • AP4_ATOM_TYPE_ISFM : Ap4Atom.h
  • AP4_ATOM_TYPE_ISLT : Ap4Atom.h
  • AP4_ATOM_TYPE_KEYW : Ap4MetaData.h
  • AP4_ATOM_TYPE_KYWD : Ap4MetaData.h
  • AP4_ATOM_TYPE_LOCI : Ap4MetaData.h
  • AP4_ATOM_TYPE_LRCU : Ap4MetaData.h
  • AP4_ATOM_TYPE_MDAT : Ap4Atom.h
  • AP4_ATOM_TYPE_MDHD : Ap4Atom.h
  • AP4_ATOM_TYPE_MDIA : Ap4Atom.h
  • AP4_ATOM_TYPE_MDRI : Ap4Atom.h
  • AP4_ATOM_TYPE_MEAN : Ap4MetaData.h
  • AP4_ATOM_TYPE_MEHD : Ap4Atom.h
  • AP4_ATOM_TYPE_META : Ap4Atom.h
  • AP4_ATOM_TYPE_MFHD : Ap4Atom.h
  • AP4_ATOM_TYPE_MFRA : Ap4Atom.h
  • AP4_ATOM_TYPE_MFRO : Ap4Atom.h
  • AP4_ATOM_TYPE_MINF : Ap4Atom.h
  • AP4_ATOM_TYPE_MOOF : Ap4Atom.h
  • AP4_ATOM_TYPE_MOOV : Ap4Atom.h
  • AP4_ATOM_TYPE_MP4A : Ap4Atom.h
  • AP4_ATOM_TYPE_MP4S : Ap4Atom.h
  • AP4_ATOM_TYPE_MP4V : Ap4Atom.h
  • AP4_ATOM_TYPE_MPOD : Ap4Atom.h
  • AP4_ATOM_TYPE_MVEX : Ap4Atom.h
  • AP4_ATOM_TYPE_MVHD : Ap4Atom.h
  • AP4_ATOM_TYPE_NAME : Ap4MetaData.h
  • AP4_ATOM_TYPE_NMHD : Ap4Atom.h
  • AP4_ATOM_TYPE_ODAF : Ap4Atom.h
  • AP4_ATOM_TYPE_ODDA : Ap4Atom.h
  • AP4_ATOM_TYPE_ODHE : Ap4Atom.h
  • AP4_ATOM_TYPE_ODKM : Ap4Atom.h
  • AP4_ATOM_TYPE_ODRM : Ap4Atom.h
  • AP4_ATOM_TYPE_OHDR : Ap4Atom.h
  • AP4_ATOM_TYPE_PCST : Ap4MetaData.h
  • AP4_ATOM_TYPE_PERF : Ap4MetaData.h
  • AP4_ATOM_TYPE_PGAP : Ap4MetaData.h
  • AP4_ATOM_TYPE_plID : Ap4MetaData.h
  • AP4_ATOM_TYPE_PURD : Ap4MetaData.h
  • AP4_ATOM_TYPE_PURL : Ap4MetaData.h
  • AP4_ATOM_TYPE_RTNG : Ap4MetaData.h
  • AP4_ATOM_TYPE_RTP_ : Ap4Atom.h
  • AP4_ATOM_TYPE_SATR : Ap4Marlin.h
  • AP4_ATOM_TYPE_SCHI : Ap4Atom.h
  • AP4_ATOM_TYPE_SCHM : Ap4Atom.h
  • AP4_ATOM_TYPE_SDP_ : Ap4Atom.h
  • AP4_ATOM_TYPE_sfID : Ap4MetaData.h
  • AP4_ATOM_TYPE_SINF : Ap4Atom.h
  • AP4_ATOM_TYPE_SMHD : Ap4Atom.h
  • AP4_ATOM_TYPE_SOAA : Ap4MetaData.h
  • AP4_ATOM_TYPE_SOAL : Ap4MetaData.h
  • AP4_ATOM_TYPE_SOAR : Ap4MetaData.h
  • AP4_ATOM_TYPE_SOCO : Ap4MetaData.h
  • AP4_ATOM_TYPE_SONM : Ap4MetaData.h
  • AP4_ATOM_TYPE_SOSN : Ap4MetaData.h
  • AP4_ATOM_TYPE_STBL : Ap4Atom.h
  • AP4_ATOM_TYPE_STCO : Ap4Atom.h
  • AP4_ATOM_TYPE_STIK : Ap4MetaData.h
  • AP4_ATOM_TYPE_STSC : Ap4Atom.h
  • AP4_ATOM_TYPE_STSD : Ap4Atom.h
  • AP4_ATOM_TYPE_STSS : Ap4Atom.h
  • AP4_ATOM_TYPE_STSZ : Ap4Atom.h
  • AP4_ATOM_TYPE_STTS : Ap4Atom.h
  • AP4_ATOM_TYPE_STYP : Ap4Marlin.h
  • AP4_ATOM_TYPE_SYNC : Ap4Atom.h
  • AP4_ATOM_TYPE_TFHD : Ap4Atom.h
  • AP4_ATOM_TYPE_TFRA : Ap4Atom.h
  • AP4_ATOM_TYPE_TIMS : Ap4Atom.h
  • AP4_ATOM_TYPE_TITL : Ap4MetaData.h
  • AP4_ATOM_TYPE_TKHD : Ap4Atom.h
  • AP4_ATOM_TYPE_TMPO : Ap4MetaData.h
  • AP4_ATOM_TYPE_TRAF : Ap4Atom.h
  • AP4_ATOM_TYPE_TRAK : Ap4Atom.h
  • AP4_ATOM_TYPE_TREF : Ap4Atom.h
  • AP4_ATOM_TYPE_TREX : Ap4Atom.h
  • AP4_ATOM_TYPE_TRKN : Ap4MetaData.h
  • AP4_ATOM_TYPE_TRUN : Ap4Atom.h
  • AP4_ATOM_TYPE_TSEL : Ap4MetaData.h
  • AP4_ATOM_TYPE_TVEN : Ap4MetaData.h
  • AP4_ATOM_TYPE_TVES : Ap4MetaData.h
  • AP4_ATOM_TYPE_TVNN : Ap4MetaData.h
  • AP4_ATOM_TYPE_TVSH : Ap4MetaData.h
  • AP4_ATOM_TYPE_TVSN : Ap4MetaData.h
  • AP4_ATOM_TYPE_UDTA : Ap4Atom.h
  • AP4_ATOM_TYPE_URL : Ap4Atom.h
  • AP4_ATOM_TYPE_UUID : Ap4Atom.h
  • AP4_ATOM_TYPE_VMHD : Ap4Atom.h
  • AP4_ATOM_TYPE_WAVE : Ap4Atom.h
  • AP4_ATOM_TYPE_WIDE : Ap4Atom.h
  • AP4_ATOM_TYPE_YRRC : Ap4MetaData.h
  • AP4_AVC_PROFILE_BASELINE : Ap4AvccAtom.h
  • AP4_AVC_PROFILE_EXTENDED : Ap4AvccAtom.h
  • AP4_AVC_PROFILE_HIGH : Ap4AvccAtom.h
  • AP4_AVC_PROFILE_HIGH_10 : Ap4AvccAtom.h
  • AP4_AVC_PROFILE_HIGH_422 : Ap4AvccAtom.h
  • AP4_AVC_PROFILE_HIGH_444 : Ap4AvccAtom.h
  • AP4_AVC_PROFILE_MAIN : Ap4AvccAtom.h
  • AP4_CIPHER_BLOCK_SIZE : Ap4StreamCipher.h
  • AP4_COMMAND_TAG_ES_DESCRIPTOR_REMOVE : Ap4Command.h
  • AP4_COMMAND_TAG_ES_DESCRIPTOR_REMOVE_REF : Ap4Command.h
  • AP4_COMMAND_TAG_ES_DESCRIPTOR_UPDATE : Ap4Command.h
  • AP4_COMMAND_TAG_IPMP_DESCRIPTOR_REMOVE : Ap4Command.h
  • AP4_COMMAND_TAG_IPMP_DESCRIPTOR_UPDATE : Ap4Command.h
  • AP4_COMMAND_TAG_OBJECT_DESCRIPTOR_EXECUTE : Ap4Command.h
  • AP4_COMMAND_TAG_OBJECT_DESCRIPTOR_REMOVE : Ap4Command.h
  • AP4_COMMAND_TAG_OBJECT_DESCRIPTOR_UPDATE : Ap4Command.h
  • AP4_DESCRIPTOR_TAG_DECODER_CONFIG : Ap4DecoderConfigDescriptor.h
  • AP4_DESCRIPTOR_TAG_DECODER_SPECIFIC_INFO : Ap4DecoderSpecificInfoDescriptor.h
  • AP4_DESCRIPTOR_TAG_ES : Ap4EsDescriptor.h
  • AP4_DESCRIPTOR_TAG_ES_ID_INC : Ap4EsDescriptor.h
  • AP4_DESCRIPTOR_TAG_ES_ID_REF : Ap4EsDescriptor.h
  • AP4_DESCRIPTOR_TAG_IOD : Ap4ObjectDescriptor.h
  • AP4_DESCRIPTOR_TAG_IPMP_DESCRIPTOR : Ap4Ipmp.h
  • AP4_DESCRIPTOR_TAG_IPMP_DESCRIPTOR_POINTER : Ap4Ipmp.h
  • AP4_DESCRIPTOR_TAG_MP4_IOD : Ap4ObjectDescriptor.h
  • AP4_DESCRIPTOR_TAG_MP4_OD : Ap4ObjectDescriptor.h
  • AP4_DESCRIPTOR_TAG_OD : Ap4ObjectDescriptor.h
  • AP4_DESCRIPTOR_TAG_SL_CONFIG : Ap4SLConfigDescriptor.h
  • AP4_ERROR_BUFFER_TOO_SMALL : Ap4Results.h
  • AP4_ERROR_CANNOT_OPEN_FILE : Ap4Results.h
  • AP4_ERROR_EOS : Ap4Results.h
  • AP4_ERROR_INTERNAL : Ap4Results.h
  • AP4_ERROR_INVALID_FORMAT : Ap4Results.h
  • AP4_ERROR_INVALID_PARAMETERS : Ap4Results.h
  • AP4_ERROR_INVALID_RTP_CONSTRUCTOR_TYPE : Ap4Results.h
  • AP4_ERROR_INVALID_RTP_PACKET_EXTRA_DATA : Ap4Results.h
  • AP4_ERROR_INVALID_STATE : Ap4Results.h
  • AP4_ERROR_INVALID_TRACK_TYPE : Ap4Results.h
  • AP4_ERROR_LIST_EMPTY : Ap4Results.h
  • AP4_ERROR_LIST_OPERATION_ABORTED : Ap4Results.h
  • AP4_ERROR_NO_SUCH_FILE : Ap4Results.h
  • AP4_ERROR_NO_SUCH_ITEM : Ap4Results.h
  • AP4_ERROR_NOT_ENOUGH_DATA : Ap4Results.h
  • AP4_ERROR_NOT_ENOUGH_SPACE : Ap4Results.h
  • AP4_ERROR_NOT_SUPPORTED : Ap4Results.h
  • AP4_ERROR_OUT_OF_MEMORY : Ap4Results.h
  • AP4_ERROR_OUT_OF_RANGE : Ap4Results.h
  • AP4_ERROR_PERMISSION_DENIED : Ap4Results.h
  • AP4_ERROR_READ_FAILED : Ap4Results.h
  • AP4_ERROR_WRITE_FAILED : Ap4Results.h
  • AP4_ES_DESCRIPTOR_FLAG_OCR_STREAM : Ap4EsDescriptor.h
  • AP4_ES_DESCRIPTOR_FLAG_STREAM_DEPENDENCY : Ap4EsDescriptor.h
  • AP4_ES_DESCRIPTOR_FLAG_URL : Ap4EsDescriptor.h
  • AP4_FAILURE : Ap4Results.h
  • AP4_FILE_BRAND_3G2A : Ap4File.h
  • AP4_FILE_BRAND_3GP1 : Ap4File.h
  • AP4_FILE_BRAND_3GP2 : Ap4File.h
  • AP4_FILE_BRAND_3GP3 : Ap4File.h
  • AP4_FILE_BRAND_3GP4 : Ap4File.h
  • AP4_FILE_BRAND_3GP5 : Ap4File.h
  • AP4_FILE_BRAND_ISOM : Ap4File.h
  • AP4_FILE_BRAND_M4A_ : Ap4File.h
  • AP4_FILE_BRAND_M4P_ : Ap4File.h
  • AP4_FILE_BRAND_MJP2 : Ap4File.h
  • AP4_FILE_BRAND_MMP4 : Ap4File.h
  • AP4_FILE_BRAND_MP41 : Ap4File.h
  • AP4_FILE_BRAND_MP42 : Ap4File.h
  • AP4_FILE_BRAND_QT__ : Ap4File.h
  • AP4_FRAG_FLAG_SAMPLE_IS_DIFFERENCE : Ap4MovieFragment.h
  • AP4_FTYP_BRAND_ISOM : Ap4FtypAtom.h
  • AP4_FULL_ATOM_HEADER_SIZE : Ap4Atom.h
  • AP4_FULL_ATOM_HEADER_SIZE_64 : Ap4Atom.h
  • AP4_FULL_UUID_ATOM_HEADER_SIZE : Ap4UuidAtom.h
  • AP4_HANDLER_TYPE_HINT : Ap4HdlrAtom.h
  • AP4_HANDLER_TYPE_JPEG : Ap4HdlrAtom.h
  • AP4_HANDLER_TYPE_MDIR : Ap4HdlrAtom.h
  • AP4_HANDLER_TYPE_ODSM : Ap4HdlrAtom.h
  • AP4_HANDLER_TYPE_SDSM : Ap4HdlrAtom.h
  • AP4_HANDLER_TYPE_SOUN : Ap4HdlrAtom.h
  • AP4_HANDLER_TYPE_TEXT : Ap4HdlrAtom.h
  • AP4_HANDLER_TYPE_TX3G : Ap4HdlrAtom.h
  • AP4_HANDLER_TYPE_VIDE : Ap4HdlrAtom.h
  • AP4_LINEAR_READER_DEFAULT_BUFFER_SIZE : Ap4LinearReader.h
  • AP4_LINEAR_READER_FLAG_EOS : Ap4LinearReader.h
  • AP4_LINEAR_READER_INITIALIZED : Ap4LinearReader.h
  • AP4_MARLIN_BRAND_MGSV : Ap4Marlin.h
  • AP4_MARLIN_IPMP_STYP_AUDIO : Ap4Marlin.h
  • AP4_MARLIN_IPMP_STYP_VIDEO : Ap4Marlin.h
  • AP4_MARLIN_IPMPS_TYPE_MGSV : Ap4Marlin.h
  • AP4_MDHD_DEFAULT_GENERIC_TIMESCALE : Ap4MdhdAtom.h
  • AP4_MDHD_DEFAULT_VIDEO_TIMESCALE : Ap4MdhdAtom.h
  • AP4_MPEG2_STREAM_TYPE_AVC : Ap4Mpeg2Ts.h
  • AP4_MPEG2_STREAM_TYPE_ISO_IEC_13818_7 : Ap4Mpeg2Ts.h
  • AP4_MPEG2_TS_DEFAULT_PID_AUDIO : Ap4Mpeg2Ts.h
  • AP4_MPEG2_TS_DEFAULT_PID_PMT : Ap4Mpeg2Ts.h
  • AP4_MPEG2_TS_DEFAULT_PID_VIDEO : Ap4Mpeg2Ts.h
  • AP4_MPEG2_TS_DEFAULT_STREAM_ID_AUDIO : Ap4Mpeg2Ts.h
  • AP4_MPEG2_TS_DEFAULT_STREAM_ID_VIDEO : Ap4Mpeg2Ts.h
  • AP4_MPEG4_AUDIO_OBJECT_TYPE_AAC_LC : Ap4SampleDescription.h
  • AP4_MPEG4_AUDIO_OBJECT_TYPE_AAC_LTP : Ap4SampleDescription.h
  • AP4_MPEG4_AUDIO_OBJECT_TYPE_AAC_MAIN : Ap4SampleDescription.h
  • AP4_MPEG4_AUDIO_OBJECT_TYPE_AAC_SCALABLE : Ap4SampleDescription.h
  • AP4_MPEG4_AUDIO_OBJECT_TYPE_AAC_SSR : Ap4SampleDescription.h
  • AP4_MPEG4_AUDIO_OBJECT_TYPE_ALGORITHMIC_SYNTHESIS : Ap4SampleDescription.h
  • AP4_MPEG4_AUDIO_OBJECT_TYPE_ALS : Ap4SampleDescription.h
  • AP4_MPEG4_AUDIO_OBJECT_TYPE_CELP : Ap4SampleDescription.h
  • AP4_MPEG4_AUDIO_OBJECT_TYPE_DST : Ap4SampleDescription.h
  • AP4_MPEG4_AUDIO_OBJECT_TYPE_ER_AAC_ELD : Ap4SampleDescription.h
  • AP4_MPEG4_AUDIO_OBJECT_TYPE_ER_AAC_LC : Ap4SampleDescription.h
  • AP4_MPEG4_AUDIO_OBJECT_TYPE_ER_AAC_LD : Ap4SampleDescription.h
  • AP4_MPEG4_AUDIO_OBJECT_TYPE_ER_AAC_LTP : Ap4SampleDescription.h
  • AP4_MPEG4_AUDIO_OBJECT_TYPE_ER_AAC_SCALABLE : Ap4SampleDescription.h
  • AP4_MPEG4_AUDIO_OBJECT_TYPE_ER_BSAC : Ap4SampleDescription.h
  • AP4_MPEG4_AUDIO_OBJECT_TYPE_ER_CELP : Ap4SampleDescription.h
  • AP4_MPEG4_AUDIO_OBJECT_TYPE_ER_HILN : Ap4SampleDescription.h
  • AP4_MPEG4_AUDIO_OBJECT_TYPE_ER_HVXC : Ap4SampleDescription.h
  • AP4_MPEG4_AUDIO_OBJECT_TYPE_ER_PARAMETRIC : Ap4SampleDescription.h
  • AP4_MPEG4_AUDIO_OBJECT_TYPE_ER_TWINVQ : Ap4SampleDescription.h
  • AP4_MPEG4_AUDIO_OBJECT_TYPE_GENERAL_MIDI : Ap4SampleDescription.h
  • AP4_MPEG4_AUDIO_OBJECT_TYPE_HVXC : Ap4SampleDescription.h
  • AP4_MPEG4_AUDIO_OBJECT_TYPE_LAYER_1 : Ap4SampleDescription.h
  • AP4_MPEG4_AUDIO_OBJECT_TYPE_LAYER_2 : Ap4SampleDescription.h
  • AP4_MPEG4_AUDIO_OBJECT_TYPE_LAYER_3 : Ap4SampleDescription.h
  • AP4_MPEG4_AUDIO_OBJECT_TYPE_MAIN_SYNTHETIC : Ap4SampleDescription.h
  • AP4_MPEG4_AUDIO_OBJECT_TYPE_MPEG_SURROUND : Ap4SampleDescription.h
  • AP4_MPEG4_AUDIO_OBJECT_TYPE_PS : Ap4SampleDescription.h
  • AP4_MPEG4_AUDIO_OBJECT_TYPE_SBR : Ap4SampleDescription.h
  • AP4_MPEG4_AUDIO_OBJECT_TYPE_SLS : Ap4SampleDescription.h
  • AP4_MPEG4_AUDIO_OBJECT_TYPE_SLS_NON_CORE : Ap4SampleDescription.h
  • AP4_MPEG4_AUDIO_OBJECT_TYPE_SMR_MAIN : Ap4SampleDescription.h
  • AP4_MPEG4_AUDIO_OBJECT_TYPE_SMR_SIMPLE : Ap4SampleDescription.h
  • AP4_MPEG4_AUDIO_OBJECT_TYPE_SSC : Ap4SampleDescription.h
  • AP4_MPEG4_AUDIO_OBJECT_TYPE_TTSI : Ap4SampleDescription.h
  • AP4_MPEG4_AUDIO_OBJECT_TYPE_TWINVQ : Ap4SampleDescription.h
  • AP4_MPEG4_AUDIO_OBJECT_TYPE_WAVETABLE_SYNTHESIS : Ap4SampleDescription.h
  • AP4_OMA_DCF_BRAND_ODCF : Ap4OmaDcf.h
  • AP4_OMA_DCF_BRAND_OPF2 : Ap4OmaDcf.h
  • AP4_OMA_DCF_ENCRYPTION_METHOD_AES_CBC : Ap4OhdrAtom.h
  • AP4_OMA_DCF_ENCRYPTION_METHOD_AES_CTR : Ap4OhdrAtom.h
  • AP4_OMA_DCF_ENCRYPTION_METHOD_NULL : Ap4OhdrAtom.h
  • AP4_OMA_DCF_PADDING_SCHEME_NONE : Ap4OhdrAtom.h
  • AP4_OMA_DCF_PADDING_SCHEME_RFC_2630 : Ap4OhdrAtom.h
  • AP4_OTI_JPEG : Ap4SampleDescription.h
  • AP4_OTI_MPEG1_AUDIO : Ap4SampleDescription.h
  • AP4_OTI_MPEG1_VISUAL : Ap4SampleDescription.h
  • AP4_OTI_MPEG2_AAC_AUDIO_LC : Ap4SampleDescription.h
  • AP4_OTI_MPEG2_AAC_AUDIO_MAIN : Ap4SampleDescription.h
  • AP4_OTI_MPEG2_AAC_AUDIO_SSRP : Ap4SampleDescription.h
  • AP4_OTI_MPEG2_PART3_AUDIO : Ap4SampleDescription.h
  • AP4_OTI_MPEG2_VISUAL_422 : Ap4SampleDescription.h
  • AP4_OTI_MPEG2_VISUAL_HIGH : Ap4SampleDescription.h
  • AP4_OTI_MPEG2_VISUAL_MAIN : Ap4SampleDescription.h
  • AP4_OTI_MPEG2_VISUAL_SIMPLE : Ap4SampleDescription.h
  • AP4_OTI_MPEG2_VISUAL_SNR : Ap4SampleDescription.h
  • AP4_OTI_MPEG2_VISUAL_SPATIAL : Ap4SampleDescription.h
  • AP4_OTI_MPEG4_AUDIO : Ap4SampleDescription.h
  • AP4_OTI_MPEG4_SYSTEM : Ap4SampleDescription.h
  • AP4_OTI_MPEG4_SYSTEM_COR : Ap4SampleDescription.h
  • AP4_OTI_MPEG4_TEXT : Ap4SampleDescription.h
  • AP4_OTI_MPEG4_VISUAL : Ap4SampleDescription.h
  • AP4_PIFF_ALGORITHM_ID_CBC : Ap4Piff.h
  • AP4_PIFF_ALGORITHM_ID_CTR : Ap4Piff.h
  • AP4_PIFF_ALGORITHM_ID_NONE : Ap4Piff.h
  • AP4_PIFF_BRAND : Ap4Piff.h
  • AP4_PIFF_SAMPLE_ENCRYPTION_FLAG_OVERRIDE_TRACK_ENCRYPTION_DEFAULTS : Ap4Piff.h
  • AP4_PROTECTION_KEY_LENGTH : Ap4Protection.h
  • AP4_PROTECTION_SCHEME_TYPE_IAEC : Ap4IsmaCryp.h
  • AP4_PROTECTION_SCHEME_TYPE_ITUNES : Ap4Protection.h
  • AP4_PROTECTION_SCHEME_TYPE_MARLIN_ACBC : Ap4Marlin.h
  • AP4_PROTECTION_SCHEME_TYPE_MARLIN_ACGK : Ap4Marlin.h
  • AP4_PROTECTION_SCHEME_TYPE_OMA : Ap4OmaDcf.h
  • AP4_PROTECTION_SCHEME_TYPE_PIFF : Ap4Piff.h
  • AP4_PROTECTION_SCHEME_VERSION_OMA_20 : Ap4OmaDcf.h
  • AP4_PROTECTION_SCHEME_VERSION_PIFF_10 : Ap4Piff.h
  • AP4_RTP_CONSTRUCTOR_SIZE : Ap4RtpHint.h
  • AP4_RTP_CONSTRUCTOR_TYPE_IMMEDIATE : Ap4RtpHint.h
  • AP4_RTP_CONSTRUCTOR_TYPE_NOOP : Ap4RtpHint.h
  • AP4_RTP_CONSTRUCTOR_TYPE_SAMPLE : Ap4RtpHint.h
  • AP4_RTP_CONSTRUCTOR_TYPE_SAMPLE_DESC : Ap4RtpHint.h
  • AP4_STREAM_TYPE_AUDIO : Ap4SampleDescription.h
  • AP4_STREAM_TYPE_BIFS : Ap4SampleDescription.h
  • AP4_STREAM_TYPE_CR : Ap4SampleDescription.h
  • AP4_STREAM_TYPE_FORBIDDEN : Ap4SampleDescription.h
  • AP4_STREAM_TYPE_IPMP : Ap4SampleDescription.h
  • AP4_STREAM_TYPE_MPEG7 : Ap4SampleDescription.h
  • AP4_STREAM_TYPE_MPEGJ : Ap4SampleDescription.h
  • AP4_STREAM_TYPE_OCI : Ap4SampleDescription.h
  • AP4_STREAM_TYPE_OD : Ap4SampleDescription.h
  • AP4_STREAM_TYPE_TEXT : Ap4SampleDescription.h
  • AP4_STREAM_TYPE_VISUAL : Ap4SampleDescription.h
  • AP4_SUCCESS : Ap4Results.h
  • AP4_SYNTHETIC_SAMPLE_TABLE_DEFAULT_CHUNK_SIZE : Ap4SyntheticSampleTable.h
  • AP4_TFHD_FLAG_BASE_DATA_OFFSET_PRESENT : Ap4TfhdAtom.h
  • AP4_TFHD_FLAG_DEFAULT_SAMPLE_DURATION_PRESENT : Ap4TfhdAtom.h
  • AP4_TFHD_FLAG_DEFAULT_SAMPLE_FLAGS_PRESENT : Ap4TfhdAtom.h
  • AP4_TFHD_FLAG_DEFAULT_SAMPLE_SIZE_PRESENT : Ap4TfhdAtom.h
  • AP4_TFHD_FLAG_DURATION_IS_EMPTY : Ap4TfhdAtom.h
  • AP4_TFHD_FLAG_SAMPLE_DESCRIPTION_INDEX_PRESENT : Ap4TfhdAtom.h
  • AP4_TKHD_FLAG_DEFAULTS : Ap4TkhdAtom.h
  • AP4_TKHD_FLAG_TRACK_ENABLED : Ap4TkhdAtom.h
  • AP4_TKHD_FLAG_TRACK_IN_MOVIE : Ap4TkhdAtom.h
  • AP4_TKHD_FLAG_TRACK_IN_PREVIEW : Ap4TkhdAtom.h
  • AP4_TRACK_DEFAULT_MOVIE_TIMESCALE : Ap4Track.h
  • AP4_TRACK_FLAG_ENABLED : Ap4Track.h
  • AP4_TRACK_FLAG_IN_MOVIE : Ap4Track.h
  • AP4_TRACK_FLAG_IN_PREVIEW : Ap4Track.h
  • AP4_TRUN_FLAG_DATA_OFFSET_PRESENT : Ap4TrunAtom.h
  • AP4_TRUN_FLAG_FIRST_SAMPLE_FLAGS_PRESENT : Ap4TrunAtom.h
  • AP4_TRUN_FLAG_SAMPLE_COMPOSITION_TIME_OFFSET_PRESENT : Ap4TrunAtom.h
  • AP4_TRUN_FLAG_SAMPLE_DURATION_PRESENT : Ap4TrunAtom.h
  • AP4_TRUN_FLAG_SAMPLE_FLAGS_PRESENT : Ap4TrunAtom.h
  • AP4_TRUN_FLAG_SAMPLE_SIZE_PRESENT : Ap4TrunAtom.h
  • AP4_UUID_ATOM_HEADER_SIZE : Ap4UuidAtom.h
  • AP4_UUID_PIFF_SAMPLE_ENCRYPTION_ATOM : Ap4Piff.h
  • AP4_UUID_PIFF_TRACK_ENCRYPTION_ATOM : Ap4Piff.h
Generated on Thu May 13 16:38:12 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Alphabetical List

Class Index

A | E | F | I | K | O | P | S | T | V
A
AP4_DrefAtom AP4_MehdAtom AP4_PiffCtrSampleEncrypter AP4_Track
AP4_3GppLocalizedStringAtom AP4_DrmiSampleEntry AP4_MemoryByteStream AP4_PiffEncryptingProcessor AP4_TrackPropertyMap
AP4_8bdlAtom AP4_DrmsSampleEntry AP4_MetaData AP4_PiffNullSampleDecrypter AP4_TrackSampleSource
AP4_AesBlockCipher AP4_ElstAtom AP4_MetaDataAtomTypeHandler AP4_PiffSampleDecrypter AP4_TrakAtom
AP4_Array AP4_ElstEntry AP4_MetaDataStringAtom AP4_PiffSampleEncrypter AP4_TrefTypeAtom
AP4_Atom AP4_EncaSampleEntry AP4_MetaDataTag AP4_PiffSampleEncryptionAtom AP4_TrexAtom
AP4_AtomFactory AP4_EncryptingStream AP4_MfhdAtom AP4_PiffTrackEncryptionAtom AP4_TrunAtom
AP4_AtomFinder AP4_EncvSampleEntry AP4_MfroAtom AP4_PrintInspector AP4_UI64
AP4_AtomInspector AP4_EsDescriptor AP4_MoovAtom AP4_Processor AP4_UnknownAtom
AP4_AtomListInspector AP4_EsdsAtom AP4_Movie AP4_ProtectedSampleDescription AP4_UnknownCommand
AP4_AtomListWriter AP4_EsIdIncDescriptor AP4_MovieFragment AP4_ProtectionKeyMap AP4_UnknownDescriptor
AP4_AtomMetaDataValue AP4_EsIdRefDescriptor AP4_Mp4aSampleEntry AP4_ProtectionSchemeInfo AP4_UnknownExpandable
AP4_AtomParent AP4_Exception AP4_Mp4sSampleEntry AP4_Referenceable AP4_UnknownSampleDescription
AP4_AtomSampleTable AP4_Expandable AP4_Mp4vSampleEntry AP4_RtpAtom AP4_UnknownSampleEntry
AP4_AtomSizeAdder AP4_File AP4_Mpeg2TsWriter AP4_RtpConstructor AP4_UnknownUuidAtom
AP4_AudioSampleDescription AP4_FileByteStream AP4_MpegAudioSampleDescription AP4_RtpConstructorFactory AP4_UrlAtom
AP4_AudioSampleEntry AP4_FileCopier AP4_MpegAudioSampleEntry AP4_RtpHintSampleEntry AP4_UuidAtom
AP4_Avc1SampleEntry AP4_FileWriter AP4_MpegSampleDescription AP4_RtpPacket AP4_VideoSampleDescription
AP4_AvccAtom AP4_FragmentSampleTable AP4_MpegSystemSampleDescription AP4_RtpSampleData AP4_VisualSampleEntry
AP4_AvcSampleDescription AP4_FrmaAtom AP4_MpegSystemSampleEntry AP4_Sample AP4_VmhdAtom
AP4_BinaryMetaDataValue AP4_FtypAtom AP4_MpegVideoSampleDescription AP4_SampleDecrypter
E
AP4_BitWriter AP4_GenericAudioSampleDescription AP4_MpegVideoSampleEntry AP4_SampleDescription AP4_PiffEncryptingProcessor::Encrypter
AP4_BlockCipher AP4_GenericVideoSampleDescription AP4_MvhdAtom AP4_SampleDescRtpConstructor AP4_TfraAtom::Entry
AP4_BlockCipherFactory AP4_GrpiAtom AP4_NmhdAtom AP4_SampleEntry AP4_MetaData::Entry
AP4_BufferedInputStream AP4_HdlrAtom AP4_NoopRtpConstructor AP4_SampleRtpConstructor AP4_TrunAtom::Entry
AP4_ByteStream AP4_HintTrackReader AP4_NullTerminatedStringAtom AP4_SampleSource AP4_Processor::ExternalTrackData
AP4_CbcStreamCipher AP4_Hmac AP4_ObjectDescriptor AP4_SampleTable
F
AP4_Co64Atom AP4_HmhdAtom AP4_OdafAtom AP4_SchmAtom AP4_List::Item::Finder
AP4_Command AP4_IkmsAtom AP4_OddaAtom AP4_SdpAtom AP4_Processor::FragmentHandler
AP4_CommandFactory AP4_ImmediateRtpConstructor AP4_OdheAtom AP4_SLConfigDescriptor
I
AP4_ContainerAtom AP4_InitialObjectDescriptor AP4_OhdrAtom AP4_SmhdAtom AP4_List::Item
AP4_CtrStreamCipher AP4_IntegerMetaDataValue AP4_OmaDcfAtomDecrypter AP4_StandardDecryptingProcessor
K
AP4_CttsAtom AP4_IodsAtom AP4_OmaDcfCbcSampleDecrypter AP4_StcoAtom AP4_MetaData::Key
AP4_CttsTableEntry AP4_IpmpDescriptor AP4_OmaDcfCbcSampleEncrypter AP4_StreamCipher AP4_MetaData::KeyInfo
AP4_DataAtom AP4_IpmpDescriptorPointer AP4_OmaDcfCtrSampleDecrypter AP4_String
O
AP4_DataBuffer AP4_IproAtom AP4_OmaDcfCtrSampleEncrypter AP4_StringMetaDataValue AP4_List::Item::Operator
AP4_DcfdAtom AP4_IsfmAtom AP4_OmaDcfDecryptingProcessor AP4_StscAtom
P
AP4_DcfStringAtom AP4_IsltAtom AP4_OmaDcfEncryptingProcessor AP4_StscTableEntry AP4_Processor::ProgressListener
AP4_DecoderConfigDescriptor AP4_IsmaCipher AP4_OmaDcfSampleDecrypter AP4_StsdAtom
S
AP4_DecoderSpecificInfoDescriptor AP4_IsmaEncryptingProcessor AP4_OmaDcfSampleEncrypter AP4_StssAtom AP4_Mpeg2TsWriter::SampleStream
AP4_DecryptingStream AP4_IsmaTrackDecrypter AP4_OmaDcfTrackDecrypter AP4_StszAtom AP4_MarlinIpmpParser::SinfEntry
AP4_DefaultAtomFactory AP4_LinearReader AP4_OmaDrmInfo AP4_SttsAtom AP4_Mpeg2TsWriter::Stream
AP4_DefaultBlockCipherFactory AP4_List AP4_PiffAvcCbcSampleDecrypter AP4_SttsTableEntry
T
AP4_Descriptor AP4_MarlinIpmpDecryptingProcessor AP4_PiffAvcCbcSampleEncrypter AP4_SubStream AP4_Processor::TrackHandler
AP4_DescriptorFactory AP4_MarlinIpmpEncryptingProcessor AP4_PiffAvcCtrSampleDecrypter AP4_SyntheticSampleTable AP4_AtomFactory::TypeHandler
AP4_DescriptorFinder AP4_MarlinIpmpParser AP4_PiffAvcCtrSampleEncrypter AP4_TfhdAtom AP4_MetaDataAtomTypeHandler::TypeList
AP4_DescriptorListInspector AP4_MarlinIpmpTrackDecrypter AP4_PiffCbcSampleDecrypter AP4_TfraAtom
V
AP4_DescriptorListWriter AP4_MarlinIpmpTrackEncrypter AP4_PiffCbcSampleEncrypter AP4_TimsAtom AP4_MetaData::Value
AP4_DescriptorUpdateCommand AP4_MdhdAtom AP4_PiffCtrSampleDecrypter AP4_TkhdAtom
A | E | F | I | K | O | P | S | T | V
Generated on Thu May 13 16:36:41 2010 for Bento4 MP4 SDK by doxygen 1.6.3


Bento4 MP4 SDK: Page Index

Related Pages

Here is a list of all related documentation pages:
  • Deprecated List
Generated on Thu May 13 16:36:31 2010 for Bento4 MP4 SDK by doxygen 1.6.3